View:


Namespace:


xCBL 4.0 Structure Reference

To begin please select a namespace from the drop down list above.


Return to xCBL Homepage


complexType definition: AccountCheckReferencesType

AccountCheckReferencesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( AccountCode[core:ReferenceType]? , RequisitionReference[core:ReferenceType] , ContractReferences[core:ListOfContractType]? , QuoteReference[core:ReferenceType]? , ListOfCostCenter[core:ListOfCostCenterType]? , OtherAccountCheckReferences[core:ListOfReferenceCodedType]? )

    Description: AccountCheckReferencesType defines the references for the AccountCheck.

    Elements:

    • AccountCode - is the unique identification assigned to the buyer by the seller. This is used for reference purposes in the transaction. For example, Buyer Company A has a standing account with Seller Company B, which is assigned the identification of A-127654, therefore A-127654 would be the AccountCode.
    • RequisitionReference - contains a reference to the requisition.
    • ContractReferences - is an element that holds the contract number and contract type for referencing a contract. This element can also be used to hold a reference to a standing order. In this case do not use the ContractType field.
    • QuoteReference - refers to a Quote ID or Shopping Cart ID.
    • ListOfCostCenter - identifies all cost center information, and if applicable, the split to each different cost center for the entire order. If a quantity is used to show the split, it is assumed to be the default quantity for each item on the order, and can be overwritten. If a a percent or monetary amount is used, it is assumed to be in relation to the entire amount of the order, included any taxes, allowances, or charges.
    • OtherAccountCheckReferences - is all other references to the AccountCheck not explicitly stated as the content of other elements.

[^]Code Fragment

    <xsd:complexType name="AccountCheckReferencesType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="AccountCode" type="core:ReferenceType">
        <xsd:element name="RequisitionReference" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="ContractReferences" type="core:ListOfContractType">
        <xsd:element minOccurs="0" name="QuoteReference" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="ListOfCostCenter" type="core:ListOfCostCenterType">
        <xsd:element minOccurs="0" name="OtherAccountCheckReferences" type="core:ListOfReferenceCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: AccountCheckRequestDetailType

AccountCheckRequestDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( AccountCheckRequestBaseItemDetail[BaseItemDetailType] , AccountCheckRequestDetailParty[RequisitionDetailPartyType]? , AccountCheckRequestPricingDetail[core:PricingDetailType]? , PaymentInstructions[core:PaymentInstructionsType]? , AccountCheckRequestLineItemNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? )

    Description: AccountCheckRequestDetailType contains the line item details for the AccountCheckRequest.

    Elements:

    • AccountCheckRequestBaseItemDetail - identifies the line item for the document. This contains the description, specific identifiers, and other information associated with the product.
    • AccountCheckRequestDetailParty - holds line level information on the parties for the AccountCheckRequest, including unique ID's and address information. Party information specified at the detail level overrides the default party information given at the header level.
    • AccountCheckRequestPricingDetail - contains all pricing information, including taxes, allowances and charges, and total price for an item.
    • PaymentInstructions - holds the detail level payment instructions for the AccountCheckRequest.
    • AccountCheckRequestLineItemNote - describes any free form text pertinent to the line item. This element may contain notes or any other similar information that is not contained explicitly in another structure. Users should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. Such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfNameValueSet - is used to hold sets of name value pairs. The use of this element should be limited to the support of previous versions of xCBL.

[^]Code Fragment

    <xsd:complexType name="AccountCheckRequestDetailType">
    <xsd:sequence>
        <xsd:element name="AccountCheckRequestBaseItemDetail" type="BaseItemDetailType">
        <xsd:element minOccurs="0" name="AccountCheckRequestDetailParty" type="RequisitionDetailPartyType">
        <xsd:element minOccurs="0" name="AccountCheckRequestPricingDetail" type="core:PricingDetailType">
        <xsd:element minOccurs="0" name="PaymentInstructions" type="core:PaymentInstructionsType">
        <xsd:element minOccurs="0" name="AccountCheckRequestLineItemNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: AccountCheckRequestHeaderType

AccountCheckRequestHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( AccountCheckRequestID[xsd:string] , AccountCheckRequestIssueDate[xsd:dateTime] , AccountCheckReferences[AccountCheckReferencesType]? , Purpose[core:PurposeType]? , AccountCheckRequestCurrency[core:CurrencyType] , AccountCheckRequestLanguage[core:LanguageType] , AccountCheckRequestDates[RequisitionDatesType]? , AccountCheckRequestParty[RequisitionPartyType]? , AccountCheckRequestTaxReference[core:TaxReferenceType]* , JustificationNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? , AccountCheckRequestHeaderAttachments[core:ListOfAttachmentType]? )

    Description: AccountCheckRequestHeaderType contains the header information of the AccountCheckRequest.

    Elements:

    • AccountCheckRequestID - is the unique number assigned to the AccountCheckRequest, typically according to the system that generated the AccountCheckRequest.
    • AccountCheckRequestIssueDate - holds a time stamp provided by the application that created the AccountCheckRequest document.
    • AccountCheckReferences - contains external references to the AccountCheckRequest that are important to the processing and use of the AccountCheckRequest.
    • Purpose - is used to communicate the purpose of the AccountCheckRequest.
    • AccountCheckRequestCurrency - identifies the default currency of the AccountCheckRequest, which when used at the header level may be overwritten at the lower level within the structure.
    • AccountCheckRequestLanguage - identifies the language of the AccountCheckRequest.
    • AccountCheckRequestDates - is used to hold a list of the pertinent dates for the AccountCheckRequest - dates include validity dates, RequestedShipDate, CancelByDates, among others. These dates apply to the entire AccountCheckRequest, acting as defaults and that may be overwritten at the item level or package level in the body of the message.
    • AccountCheckRequestParty - holds information on the parties for the AccountCheckRequest, including unique ID's and address information.
    • AccountCheckRequestTaxReference - identifies the default tax information for the AccountCheckRequest
    • JustificationNote - contains free form text that is used to give justification or reason for the request for goods or services.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfNameValueSet - is used to hold sets of name value pairs. The use of this element should be limited to the support of previous versions of xCBL.
    • AccountCheckRequestHeaderAttachments - holds a list of attachments applicable to the entire AccountCheckRequest, or a large part of the consignment it describes. This information is not specific to a particular line item or package unless specifically noted.

[^]Code Fragment

    <xsd:complexType name="AccountCheckRequestHeaderType">
    <xsd:sequence>
        <xsd:element name="AccountCheckRequestID" type="xsd:string">
        <xsd:element name="AccountCheckRequestIssueDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="AccountCheckReferences" type="AccountCheckReferencesType">
        <xsd:element minOccurs="0" name="Purpose" type="core:PurposeType">
        <xsd:element name="AccountCheckRequestCurrency" type="core:CurrencyType">
        <xsd:element name="AccountCheckRequestLanguage" type="core:LanguageType">
        <xsd:element minOccurs="0" name="AccountCheckRequestDates" type="RequisitionDatesType">
        <xsd:element minOccurs="0" name="AccountCheckRequestParty" type="RequisitionPartyType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="AccountCheckRequestTaxReference" type="core:TaxReferenceType">
        <xsd:element minOccurs="0" name="JustificationNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
        <xsd:element minOccurs="0" name="AccountCheckRequestHeaderAttachments" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: AccountCheckRequestType

AccountCheckRequestType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( AccountCheckRequestHeader[AccountCheckRequestHeaderType] , ListOfAccountCheckRequestDetail[ListOfAccountCheckRequestDetailType] , AccountCheckRequestSummary[RequisitionSummaryType]? )

    Description: AccountCheckRequestType is used to verify the information submitted for the acquisition of goods or services is valid.

    Elements:

    • AccountCheckRequestHeader - contains the header information of the AccountCheckRequest.
    • ListOfAccountCheckRequestDetail - contains the line item details of the AccountCheckRequest.
    • AccountCheckRequestSummary - contains the summary information of the AccountCheckRequest.

[^]Code Fragment

    <xsd:complexType name="AccountCheckRequestType">
    <xsd:sequence>
        <xsd:element name="AccountCheckRequestHeader" type="AccountCheckRequestHeaderType">
        <xsd:element name="ListOfAccountCheckRequestDetail" type="ListOfAccountCheckRequestDetailType">
        <xsd:element minOccurs="0" name="AccountCheckRequestSummary" type="RequisitionSummaryType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ApprovalInformationType

ApprovalInformationType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( Sequence[xsd:int]? , ApproverNameAddress[core:NameAddressType] , ListOfApproverContactNumber[core:ListOfContactNumberType]? , ApproverAuthorization[core:ReferenceType]? , ApprovalNotes[xsd:string]? )

    Description: ApprovalInformationType holds the details associated with the approvers for the Requisition.

    Elements:

    • Sequence - is a counter to be used in the case where there are more than one valid approver for the Requisition. This field can also be used to assign rank or levels to the approvers (i.e., first, second, third).
    • ApproverNameAddress - contains the name and address details for the approver of the Requisition.
    • ListOfApproverContactNumber - contains a list of contact numbers for the approver of the Requisition.
    • ApproverAuthorization - is used to specify the signature or authorization code of the approver along with a date and time that the authorization was issued for the Requisition.
    • ApprovalNotes - contains notes associated with the approval of the Requisition.

[^]Code Fragment

    <xsd:complexType name="ApprovalInformationType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="Sequence" type="xsd:int">
        <xsd:element name="ApproverNameAddress" type="core:NameAddressType">
        <xsd:element minOccurs="0" name="ListOfApproverContactNumber" type="core:ListOfContactNumberType">
        <xsd:element minOccurs="0" name="ApproverAuthorization" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="ApprovalNotes" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: BaseItemDetailType

BaseItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( LineItemNum[core:LineItemNumType] , LineItemType[core:LineItemTypeType]? , ParentItemNumber[core:LineItemNumberReferenceType]? , ItemIdentifiers[core:ItemIdentifiersType]? , ListOfDimension[core:ListOfDimensionType]? , TotalQuantity[core:QuantityType] , MaxBackOrderQuantity[core:QuantityType]? , ListOfQuantityCoded[core:ListOfQuantityCodedType]? , BaseItemReferences[core:BaseItemReferencesType]? , CountryOfOrigin[core:CountryType]? , CountryOfDestination[core:CountryType]? , FinalRecipient[core:PartyType]? , ListOfPartyCoded[core:ListOfPartyCodedType]? , ConditionsOfSale[core:ConditionsOfSaleType]? , HazardousMaterials[core:HazardousType]? )

    Description: BaseItemDetailType identifies the line item for the document. This contains the description, specific identifiers, weights, measures and other information associated with the product.

    Elements:

    • LineItemNum - is a set of numbers uniquely identifying the line item for the number. In the case where the seller's system splits a line item number into 2 line items, the buyer item number will remain the same for both line items, but the seller item number will be different.
    • LineItemType - identifies whether the line item is a component group (consists of other line items), a typical line item, or a textual line item.
    • ParentItemNumber - identifies the line item that groups this and other line items. This is done using LineItemNumberReference, which specifies the number of the parent line item and whether this reference is the Buyer or Seller's number. LineItemNumberReference is a string content model of datatype integer that contains an attribute to specify whether the ParentItemNumber is a Seller or Buyer number, with the default being Buyer. This value references the parent item represented a group.
    • ItemIdentifiers - details all of the part numbers assigned to the item.
    • ListOfDimension - lists one or more quantitative measurements of the item.
    • TotalQuantity - contains the total amount of the line item pertaining to the document.
    • MaxBackOrderQuantity - specifies the maximum quantity of an item that a customer will allow to be back ordered.
    • ListOfQuantityCoded - specifies any other quantities not explicitly stated.
    • BaseItemReferences - contains all reference information for the item.
    • CountryOfOrigin - specifies the country code for the country in which the line item was manufactured.
    • CountryOfDestination - specifies the country code for the country in which the delivery is finally received.
    • FinalRecipient - identifies the person or organization who will ultimately receive the item or items.
    • ListOfPartyCoded - specifies any other parties associated with the line item that are not already explicitly stated.
    • ConditionsOfSale - details the conditions of sale for the item.
    • HazardousMaterials - contains the hazardous information for the line item.

[^]Code Fragment

    <xsd:complexType name="BaseItemDetailType">
    <xsd:sequence>
        <xsd:element name="LineItemNum" type="core:LineItemNumType">
        <xsd:element minOccurs="0" name="LineItemType" type="core:LineItemTypeType">
        <xsd:element minOccurs="0" name="ParentItemNumber" type="core:LineItemNumberReferenceType">
        <xsd:element minOccurs="0" name="ItemIdentifiers" type="core:ItemIdentifiersType">
        <xsd:element minOccurs="0" name="ListOfDimension" type="core:ListOfDimensionType">
        <xsd:element name="TotalQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="MaxBackOrderQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="ListOfQuantityCoded" type="core:ListOfQuantityCodedType">
        <xsd:element minOccurs="0" name="BaseItemReferences" type="core:BaseItemReferencesType">
        <xsd:element minOccurs="0" name="CountryOfOrigin" type="core:CountryType">
        <xsd:element minOccurs="0" name="CountryOfDestination" type="core:CountryType">
        <xsd:element minOccurs="0" name="FinalRecipient" type="core:PartyType">
        <xsd:element minOccurs="0" name="ListOfPartyCoded" type="core:ListOfPartyCodedType">
        <xsd:element minOccurs="0" name="ConditionsOfSale" type="core:ConditionsOfSaleType">
        <xsd:element minOccurs="0" name="HazardousMaterials" type="core:HazardousType">
    </xsd:sequence>
</xsd:complexType>


Complex Types:

AccountCheckRequestDetailType
ListOfAccountCheckRequestDetailType
AccountCheckRequestHeaderType
AccountCheckReferencesType
AccountCheckRequestType
ApprovalInformationType
ListOfApprovalInformationType
GetOrderType
POReferencesType
ListOfPOReferencesType
RequisitionDatesType
RequisitionDeliveryDetailType
RequisitionItemDetailType
ListOfRequisitionItemDetailType
RequisitionDetailPartyType
RequisitionHeaderType
RequisitionDetailType
RequisitionNumberType
RequisitionPartyType
RequisitionReferencesType
RequisitionSummaryType
RequisitionType
BaseItemDetailType
GetERPDataType
KeyFieldType
ListOfKeyFieldType
FieldType
ListOfFieldType
GetERPDataResponseType
RecordDataType
RecordFieldType
RecordFieldAttributeType
RequisitionTypeType
RoundTripShoppingCartType
ListOfRoundTripShoppingCartType


complexType definition: FieldType

FieldType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( FieldName[xsd:string] , FieldDescription[xsd:string]? , FieldDataType[xsd:string]? )

    Description: FieldType contains the data for the non-key fields of a table.

    Elements:

    • FieldName - specifies the name of the field.
    • FieldDescription - contains a text description of the field.
    • FieldDataType - specifies the data type of the field value.

[^]Code Fragment

    <xsd:complexType name="FieldType">
    <xsd:sequence>
        <xsd:element name="FieldName" type="xsd:string">
        <xsd:element minOccurs="0" name="FieldDescription" type="xsd:string">
        <xsd:element minOccurs="0" name="FieldDataType" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: GetERPDataResponseType

GetERPDataResponseType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( GetERPDataResponseID[xsd:string] , GetERPDataResponseIssueDate[xsd:dateTime] , SenderParty[core:PartyType] , ReceiverParty[core:PartyType] , Purpose[core:PurposeType]? , ( ErrorInfo[core:ErrorInfoType]+ | ( RecordData[RecordDataType] , ErrorInfo[core:ErrorInfoType]* ) ) , GetERPDataResponseLanguage[core:LanguageType] , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? , GetERPDataResponseAttachments[core:ListOfAttachmentType]? )

    Description: GetERPDataResponseType contains a response document to the request for synchronization of ERP data.

    Elements:

    • GetERPDataResponseID - is the unique number assigned to the GetERPDataResponse, typically according to the system that generated the GetERPData.
    • GetERPDataResponseIssueDate - holds a time stamp provided by the application that created the GetERPDataResponse document.
    • SenderParty - contains information for the party sending the transaction.
    • ReceiverParty - contains information for the party receiving the transaction.
    • Purpose - is used to communicate the purpose of the GetERPDataResponse.
    • ErrorInfo - is used to specify system generated error messages for the GetERPDataResponse.
    • RecordData - contains the requested data from the ERP table requested from the GetERPData transaction.
    • ErrorInfo - is used to specify system generated warning and informational messages for the GetERPDataResponse.
    • GetERPDataResponseLanguage - identifies the language of the GetERPDataResponse.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfNameValueSet - is used to hold sets of name value pairs. The use of this element should be limited to the support of previous versions of xCBL.
    • GetERPDataResponseAttachments - holds a list of attachments applicable to the entire GetERPDataResponse. This information is not specific to a particular line item or package unless specifically noted.

[^]Code Fragment

    <xsd:complexType name="GetERPDataResponseType">
    <xsd:sequence>
        <xsd:element name="GetERPDataResponseID" type="xsd:string">
        <xsd:element name="GetERPDataResponseIssueDate" type="xsd:dateTime">
        <xsd:element name="SenderParty" type="core:PartyType">
        <xsd:element name="ReceiverParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="Purpose" type="core:PurposeType">
        <xsd:choice>
            <xsd:element maxOccurs="unbounded" name="ErrorInfo" type="core:ErrorInfoType">
            <xsd:sequence>
                <xsd:element name="RecordData" type="RecordDataType">
                <xsd:element minOccurs="0" maxOccurs="unbounded" name="ErrorInfo" type="core:ErrorInfoType">
            </xsd:sequence>
        </xsd:choice>
        <xsd:element name="GetERPDataResponseLanguage" type="core:LanguageType">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
        <xsd:element minOccurs="0" name="GetERPDataResponseAttachments" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: GetERPDataType

GetERPDataType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( GetERPDataID[xsd:string] , GetERPDataIssueDate[xsd:dateTime] , SenderParty[core:PartyType] , ReceiverParty[core:PartyType] , Purpose[core:PurposeType]? , TableName[xsd:string] , ListOfKeyField[ListOfKeyFieldType] , ListOfField[ListOfFieldType]? , GetERPDataLanguage[core:LanguageType] , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? , GetERPDataAttachments[core:ListOfAttachmentType]? )

    Description: GetERPDataType contains a request for synchronization of ERP data.

    Elements:

    • GetERPDataID - is the unique number assigned to the GetERPData, typically according to the system that generated the GetERPData.
    • GetERPDataIssueDate - holds a time stamp provided by the application that created the GetERPData document.
    • SenderParty - contains information for the party sending the transaction.
    • ReceiverParty - contains information for the party receiving the transaction.
    • Purpose - is used to communicate the purpose of the GetERPData.
    • TableName - contains the name of the ERP table from which data is to be retrieved.
    • ListOfKeyField - specifies the key fields for the table from which data is to be retrieved.
    • ListOfField - identifies additional non-key fields form which data is to be retrieved.
    • GetERPDataLanguage - identifies the language of the GetERPData.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfNameValueSet - is used to hold sets of name value pairs. The use of this element should be limited to the support of previous versions of xCBL.
    • GetERPDataAttachments - holds a list of attachments applicable to the entire GetERPData. This information is not specific to a particular line item or package unless specifically noted.

[^]Code Fragment

    <xsd:complexType name="GetERPDataType">
    <xsd:sequence>
        <xsd:element name="GetERPDataID" type="xsd:string">
        <xsd:element name="GetERPDataIssueDate" type="xsd:dateTime">
        <xsd:element name="SenderParty" type="core:PartyType">
        <xsd:element name="ReceiverParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="Purpose" type="core:PurposeType">
        <xsd:element name="TableName" type="xsd:string">
        <xsd:element name="ListOfKeyField" type="ListOfKeyFieldType">
        <xsd:element minOccurs="0" name="ListOfField" type="ListOfFieldType">
        <xsd:element name="GetERPDataLanguage" type="core:LanguageType">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
        <xsd:element minOccurs="0" name="GetERPDataAttachments" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: GetOrderType

GetOrderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( GetOrderID[xsd:string] , GetOrderIssueDate[xsd:dateTime] , SenderParty[core:PartyType] , ReceiverParty[core:PartyType] , Purpose[core:PurposeType]? , ListOfPOReferences[ListOfPOReferencesType] , GetOrderLanguage[core:LanguageType] , SpecialHandling[core:SpecialHandlingType]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? , GetOrderAttachments[core:ListOfAttachmentType]? )

    Description: GetOrderType contains a request for new purchase orders.

    Elements:

    • GetOrderID - is the unique number assigned to the GetOrder, typically according to the system that generated the GetOrder.
    • GetOrderIssueDate - holds a time stamp provided by the application that created the GetOrder document.
    • SenderParty - contains information for the party sending the transaction.
    • ReceiverParty - contains information for the party receiving the transaction.
    • Purpose - is used to communicate the purpose of the GetOrder.
    • ListOfPOReferences - contains references that are used to identify the purchase order.
    • GetOrderLanguage - identifies the language of the GetOrder.
    • SpecialHandling - descibes any special handling conditions that apply to the enitre GetOrder.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfNameValueSet - is used to hold sets of name value pairs. The use of this element should be limited to the support of previous versions of xCBL.
    • GetOrderAttachments - holds a list of attachments applicable to the entire GetOrder. This information is not specific to a particular line item or package unless specifically noted.

[^]Code Fragment

    <xsd:complexType name="GetOrderType">
    <xsd:sequence>
        <xsd:element name="GetOrderID" type="xsd:string">
        <xsd:element name="GetOrderIssueDate" type="xsd:dateTime">
        <xsd:element name="SenderParty" type="core:PartyType">
        <xsd:element name="ReceiverParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="Purpose" type="core:PurposeType">
        <xsd:element name="ListOfPOReferences" type="ListOfPOReferencesType">
        <xsd:element name="GetOrderLanguage" type="core:LanguageType">
        <xsd:element minOccurs="0" name="SpecialHandling" type="core:SpecialHandlingType">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
        <xsd:element minOccurs="0" name="GetOrderAttachments" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


Global Elements (Document Roots):

AccountCheckRequest
GetERPData
GetERPDataResponse
GetOrder
Requisition


complexType definition: KeyFieldType

KeyFieldType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( KeyFieldName[xsd:string] , KeyFieldDescription[xsd:string]? , KeyFieldDataType[xsd:string]? , Filter[xsd:string]? )

    Description: KeyFieldType contains the data for the key fields of a table.

    Elements:

    • KeyFieldName - specifies the name of the key field.
    • KeyFieldDescription - contains a text description of the key field.
    • KeyFieldDataType - specifies the data type of the key field value.
    • Filter - contains a free-form text field to be used asfilter for the key field.

[^]Code Fragment

    <xsd:complexType name="KeyFieldType">
    <xsd:sequence>
        <xsd:element name="KeyFieldName" type="xsd:string">
        <xsd:element minOccurs="0" name="KeyFieldDescription" type="xsd:string">
        <xsd:element minOccurs="0" name="KeyFieldDataType" type="xsd:string">
        <xsd:element minOccurs="0" name="Filter" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfAccountCheckRequestDetailType

ListOfAccountCheckRequestDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( AccountCheckRequestDetail[AccountCheckRequestDetailType]+ )

    Description: ListOfAccountCheckRequestDetailType contains one or more line items for the AccountCheckRequest.

    Elements:

    • AccountCheckRequestDetail - contains the line level information for the AccountCheckRequest.

[^]Code Fragment

    <xsd:complexType name="ListOfAccountCheckRequestDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="AccountCheckRequestDetail" type="AccountCheckRequestDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfApprovalInformationType

ListOfApprovalInformationType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( ApprovalInformation[ApprovalInformationType]+ )

    Description: ListOfApprovalInformationType contains a list of valid approvers for the Requisition.

    Elements:

    • ApprovalInformation - holds the details associated with the approvers for the Requisition.

[^]Code Fragment

    <xsd:complexType name="ListOfApprovalInformationType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="ApprovalInformation" type="ApprovalInformationType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfFieldType

ListOfFieldType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( Field[FieldType]+ )

    Description: ListOfFieldType contains a set of non-key fields.

    Elements:

    • Field - contains the data for the non-key fields of a table.

[^]Code Fragment

    <xsd:complexType name="ListOfFieldType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="Field" type="FieldType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfKeyFieldType

ListOfKeyFieldType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( KeyField[KeyFieldType]+ )

    Description: ListOfKeyFieldType contains a set of key fields to be used to access a table.

    Elements:

    • KeyField - contains the data for the key fields of a table.

[^]Code Fragment

    <xsd:complexType name="ListOfKeyFieldType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="KeyField" type="KeyFieldType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfPOReferencesType

ListOfPOReferencesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( POReferences[POReferencesType]+ )

    Description: ListOfPOReferencesType contains a set of references for a Purchase Order.

    Elements:

    • POReferences - contains the references for a Purchase Order

[^]Code Fragment

    <xsd:complexType name="ListOfPOReferencesType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="POReferences" type="POReferencesType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfRequisitionItemDetailType

ListOfRequisitionItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( RequisitionItemDetail[RequisitionItemDetailType]+ )

    Description: ListOfRequisitionItemDetailType contains one or more line items for the Requisition.

    Elements:

    • RequisitionItemDetail - contains the line level information for the Requisition.

[^]Code Fragment

    <xsd:complexType name="ListOfRequisitionItemDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="RequisitionItemDetail" type="RequisitionItemDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfRoundTripShoppingCartType

ListOfRoundTripShoppingCartType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( RoundTripShoppingCart[RoundTripShoppingCartType]+ )

    Description: ListOfRoundTripShoppingCartType contains information to describe one or more round trip shopping carts.

    Elements:

    • RoundTripShoppingCart - contains the round trip shopping cart information.

[^]Code Fragment

    <xsd:complexType name="ListOfRoundTripShoppingCartType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="RoundTripShoppingCart" type="RoundTripShoppingCartType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: POReferencesType

POReferencesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( PurchaseOrderReference[core:ReferenceType]? , AccountCode[core:ReferenceType]? , RequisitionReference[core:ReferenceType]? , ContractReferences[core:ListOfContractType]? , QuoteReference[core:ReferenceType]? , ListOfCostCenter[core:ListOfCostCenterType]? , OtherPOReferences[core:ListOfReferenceCodedType]? )

    Description: POReferencesType defines the references for the Purchase Order.

    Elements:

    • PurchaseOrderReference - contains a reference to the purchase order document.
    • AccountCode - is the unique identification assigned to the buyer by the seller. This is used for reference purposes in the transaction. For example, Buyer Company A has a standing account with Seller Company B, which is assigned the identification of A-127654, therefore A-127654 would be the AccountCode.
    • RequisitionReference - contains a reference to the requisition.
    • ContractReferences - is an element that holds the contract number and contract type for referencing a contract. This element can also be used to hold a reference to a standing order. In this case do not use the ContractType field.
    • QuoteReference - refers to a Quote ID or Shopping Cart ID.
    • ListOfCostCenter - identifies all cost center information, and if applicable, the split to each different cost center for the entire order. If a quantity is used to show the split, it is assumed to be the default quantity for each item on the order, and can be overwritten. If a a percent or monetary amount is used, it is assumed to be in relation to the entire amount of the order, included any taxes, allowances, or charges.
    • OtherPOReferences - is all other references to the purchase order not explicitly stated as the content of other elements.

[^]Code Fragment

    <xsd:complexType name="POReferencesType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="PurchaseOrderReference" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="AccountCode" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="RequisitionReference" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="ContractReferences" type="core:ListOfContractType">
        <xsd:element minOccurs="0" name="QuoteReference" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="ListOfCostCenter" type="core:ListOfCostCenterType">
        <xsd:element minOccurs="0" name="OtherPOReferences" type="core:ListOfReferenceCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: RecordDataType

RecordDataType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( RecordName[xsd:string] , RecordField[RecordFieldType]* )

    Description: RecordDataType contains the data record from a given ERP table.

    Elements:

    • RecordName - specifies the name of the record.
    • RecordField - contains the field data for the given record.

[^]Code Fragment

    <xsd:complexType name="RecordDataType">
    <xsd:sequence>
        <xsd:element name="RecordName" type="xsd:string">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="RecordField" type="RecordFieldType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: RecordFieldAttributeType

RecordFieldAttributeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( AttributeName[xsd:string] , AttributeCategory[xsd:string]? )

    Description: RecordFieldAttributeType specifies the attribute details for the record field.

    Elements:

    • AttributeName - contains name of the field record attribute.
    • AttributeCategory - contains category value of the field record attribute.

[^]Code Fragment

    <xsd:complexType name="RecordFieldAttributeType">
    <xsd:sequence>
        <xsd:element name="AttributeName" type="xsd:string">
        <xsd:element minOccurs="0" name="AttributeCategory" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: RecordFieldType

RecordFieldType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( RecordFieldCounter[xsd:int] , RecordFieldName[xsd:string] , RecordFieldValue[xsd:string] , IsNull[xsd:boolean]? , RecordFieldAttribute[RecordFieldAttributeType]* )

    Description: RecordFieldType specifies the field information for the record.

    Elements:

    • RecordFieldCounter - is a sequence counter to identify the field record.
    • RecordFieldName - contains name of the field record.
    • RecordFieldValue - contains value of the field record.
    • IsNull - is a boolean flag to indicate whether the record field value is null.
    • RecordFieldAttribute - specifies attributes to describe the record field.

[^]Code Fragment

    <xsd:complexType name="RecordFieldType">
    <xsd:sequence>
        <xsd:element name="RecordFieldCounter" type="xsd:int">
        <xsd:element name="RecordFieldName" type="xsd:string">
        <xsd:element name="RecordFieldValue" type="xsd:string">
        <xsd:element minOccurs="0" name="IsNull" type="xsd:boolean">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="RecordFieldAttribute" type="RecordFieldAttributeType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: RequisitionDatesType

RequisitionDatesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( RequestedShipByDate[xsd:dateTime]? , RequestedDeliverByDate[xsd:dateTime]? , ValidityDates[core:ValidityDatesType]? , CancelByDate[xsd:dateTime]? , ListOfDateCoded[core:ListOfDateCodedType]? )

    Description: RequisitionDatesType is used to hold a list of the pertinent dates for the requisition. which includes validity dates, RequestedShipDate, CancelByDates, among others. These dates act as defaults that may be overwritten at the item level in the body of the message.

    Elements:

    • RequestedShipByDate - is the date items in the requisition must be shipped from the seller.
    • RequestedDeliverByDate - is the date items in the requisition must be received by the buyer.
    • ValidityDates - contains the dates between which the Requisition is effective.
    • CancelByDate - is the date after which the Requisition should be cancelled.
    • ListOfDateCoded - contains all other dates for the Requisition that are not explicitly stated.

[^]Code Fragment

    <xsd:complexType name="RequisitionDatesType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="RequestedShipByDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="RequestedDeliverByDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ValidityDates" type="core:ValidityDatesType">
        <xsd:element minOccurs="0" name="CancelByDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ListOfDateCoded" type="core:ListOfDateCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: RequisitionDeliveryDetailType

RequisitionDeliveryDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( ShipToLocation[core:LocationType]? , ShipFromLocation[core:LocationType]? , ListOfScheduleLine[core:ListOfScheduleLineType]? , TermsOfDelivery[core:TermsOfDeliveryType]* , SpecialHandling[core:SpecialHandlingType]? , ShipInstructions[xsd:string]? )

    Description: RequisitionDeliveryDetailType is used to specify the scheduling information for a distinct set of ship from party, ship to party, and transport information for the line item

    Elements:

    • ShipToLocation - is the location to which the shipments are to be delivered.
    • ShipFromLocation - identifies the party from which the item is to be shipped from. This is only used if the ShipFromParty differs from that identified in the header.
    • ListOfScheduleLine - is all of the schedule information relevant to the line item for the shipping parties. This may indicate several shipments to the same location over a period of time.
    • TermsOfDelivery - includes the information related to delivery including shipment method payment and transport.
    • SpecialHandling - is used to describe any special handling relating to the item.
    • ShipInstructions - contains free form text to describe special instructions related to the shipment of the item.

[^]Code Fragment

    <xsd:complexType name="RequisitionDeliveryDetailType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ShipToLocation" type="core:LocationType">
        <xsd:element minOccurs="0" name="ShipFromLocation" type="core:LocationType">
        <xsd:element minOccurs="0" name="ListOfScheduleLine" type="core:ListOfScheduleLineType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="TermsOfDelivery" type="core:TermsOfDeliveryType">
        <xsd:element minOccurs="0" name="SpecialHandling" type="core:SpecialHandlingType">
        <xsd:element minOccurs="0" name="ShipInstructions" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: RequisitionDetailPartyType

RequisitionDetailPartyType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( RequisitionerParty[core:PartyType]? , BuyerParty[core:PartyType]? , SellerParty[core:PartyType] , ShipToParty[core:PartyType]? , BillToParty[core:PartyType]? , RemitToParty[core:PartyType]? , ShipFromParty[core:PartyType]? , SoldToParty[core:PartyType]? )

    Description: RequisitionDetailPartyType holds all party information related to the requisition transaction.

    Elements:

    • RequisitionerParty - contains the information for the party creating the requisition.
    • BuyerParty - contains the information for the party purchasing the goods.
    • SellerParty - identifies the party selling the goods.
    • ShipToParty - contains the information for the party which the items are to be shipped.
    • BillToParty - contains the information for the party that will receive the bill for the goods..
    • RemitToParty - contains the information for the party to be paid.
    • ShipFromParty - contains party information identifying the location from which the items are to be shipped.
    • SoldToParty - contains party information identifying the location where the items were sold.

[^]Code Fragment

    <xsd:complexType name="RequisitionDetailPartyType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="RequisitionerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="BuyerParty" type="core:PartyType">
        <xsd:element name="SellerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ShipToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="BillToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="RemitToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ShipFromParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="SoldToParty" type="core:PartyType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: RequisitionDetailType

RequisitionDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( ListOfRequisitionItemDetail[ListOfRequisitionItemDetailType] , ListOfRoundTripShoppingCart[ListOfRoundTripShoppingCartType]? )

    Description: RequisitionDetailType contains the detail level information for the Requisition.

    Elements:

    • ListOfRequisitionItemDetail - contains the line level information for the Requisition.
    • ListOfRoundTripShoppingCart - contains the shopping cart information.

[^]Code Fragment

    <xsd:complexType name="RequisitionDetailType">
    <xsd:sequence>
        <xsd:element name="ListOfRequisitionItemDetail" type="ListOfRequisitionItemDetailType">
        <xsd:element minOccurs="0" name="ListOfRoundTripShoppingCart" type="ListOfRoundTripShoppingCartType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: RequisitionHeaderType

RequisitionHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( RequisitionNumber[RequisitionNumberType] , RequisitionIssueDate[xsd:dateTime] , RequisitionCreateDate[xsd:dateTime]? , RequisitionType[RequisitionTypeType] , RequisitionReferences[RequisitionReferencesType]? , Purpose[core:PurposeType]? , RequisitionCurrency[core:CurrencyType] , RequisitionLanguage[core:LanguageType] , RequisitionDates[RequisitionDatesType]? , RequisitionParty[RequisitionPartyType] , ListOfApprovalInformation[ListOfApprovalInformationType]? , RequisitionTaxReference[core:TaxReferenceType]* , ListOfTransportRouting[core:ListOfTransportRoutingType]? , RequisitionTermsOfDelivery[core:TermsOfDeliveryType]* , RequisitionPaymentInstructions[core:PaymentInstructionsType]? , RequisitionAllowancesOrCharges[core:ListOfAllowOrChargeType]? , JustificationNote[xsd:string]? , SpecialHandling[core:SpecialHandlingType]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? , RequisitionHeaderAttachments[core:ListOfAttachmentType]? )

    Description: RequisitionHeaderType contains the header information of the requisition.

    Elements:

    • RequisitionNumber - is the unique number assigned to the Requisition, typically according to the system that generated the Requisition.
    • RequisitionIssueDate - holds a time stamp provided by the application that created the Requisition document. This is the date and time the document is transmitted.
    • RequisitionCreateDate - holds a time stamp provided by the application that created the Requisition document. This is the date and time the requisition document is created.
    • RequisitionType - is used to identify whether the requisition is a blanket order release, order request, or some other user defined requisition type.
    • RequisitionReferences - contains external references to the Requisition that are important to the processing and use of the Requisition.
    • Purpose - is used to communicate the purpose of the Requisition.
    • RequisitionCurrency - identifies the default currency of the Requisition, which when used at the header level may be overwritten at the lower level within the structure.
    • RequisitionLanguage - identifies the language of the Requisition.
    • RequisitionDates - is used to hold a list of the pertinent dates for the Requisition - dates include validity dates, RequestedShipDate, CancelByDates, among others. These dates apply to the entire Requisition, acting as defaults and that may be overwritten at the item level or package level in the body of the message.
    • RequisitionParty - holds information on the parties for the Requisition, including unique ID's and address information.
    • ListOfApprovalInformation - contains the name, address, and contact information for the designated approvers of the requisition.
    • RequisitionTaxReference - identifies the default tax information for the Requisition
    • ListOfTransportRouting - provides information on the movement of the goods including carrier, equipment and service level instructions.
    • RequisitionTermsOfDelivery - defines the terms of delivery for the Requisition.
    • RequisitionPaymentInstructions - holds the payment instructions for the Requisition.
    • RequisitionAllowancesOrCharges - contains the allowances and/or charges for the whole Requisition. These may include goods and shipping charges. Additional allowance or charges may be present at lower levels of the Requisition.
    • JustificationNote - contains free form text that is used to give justification or reason for the request for goods or services.
    • SpecialHandling - descibes any special handling conditions that apply to the enitre Requisition.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfNameValueSet - is used to hold sets of name value pairs. The use of this element should be limited to the support of previous versions of xCBL.
    • RequisitionHeaderAttachments - holds a list of attachments applicable to the entire Requisition, or a large part of the consignment it describes. This information is not specific to a particular line item or package unless specifically noted.

[^]Code Fragment

    <xsd:complexType name="RequisitionHeaderType">
    <xsd:sequence>
        <xsd:element name="RequisitionNumber" type="RequisitionNumberType">
        <xsd:element name="RequisitionIssueDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="RequisitionCreateDate" type="xsd:dateTime">
        <xsd:element name="RequisitionType" type="RequisitionTypeType">
        <xsd:element minOccurs="0" name="RequisitionReferences" type="RequisitionReferencesType">
        <xsd:element minOccurs="0" name="Purpose" type="core:PurposeType">
        <xsd:element name="RequisitionCurrency" type="core:CurrencyType">
        <xsd:element name="RequisitionLanguage" type="core:LanguageType">
        <xsd:element minOccurs="0" name="RequisitionDates" type="RequisitionDatesType">
        <xsd:element name="RequisitionParty" type="RequisitionPartyType">
        <xsd:element minOccurs="0" name="ListOfApprovalInformation" type="ListOfApprovalInformationType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="RequisitionTaxReference" type="core:TaxReferenceType">
        <xsd:element minOccurs="0" name="ListOfTransportRouting" type="core:ListOfTransportRoutingType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="RequisitionTermsOfDelivery" type="core:TermsOfDeliveryType">
        <xsd:element minOccurs="0" name="RequisitionPaymentInstructions" type="core:PaymentInstructionsType">
        <xsd:element minOccurs="0" name="RequisitionAllowancesOrCharges" type="core:ListOfAllowOrChargeType">
        <xsd:element minOccurs="0" name="JustificationNote" type="xsd:string">
        <xsd:element minOccurs="0" name="SpecialHandling" type="core:SpecialHandlingType">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
        <xsd:element minOccurs="0" name="RequisitionHeaderAttachments" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: RequisitionItemDetailType

RequisitionItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( RequisitionBaseItemDetail[BaseItemDetailType] , RequisitionPricingDetail[core:PricingDetailType]? , RequisitionDeliveryDetail[core:DeliveryDetailType]? , RoundTripShoppingCartID[xsd:int]? , RequisitionPaymentInstructions[core:PaymentInstructionsType]? , RequisitionDetailParty[RequisitionDetailPartyType]? , RequisitionLineItemNote[xsd:string]? , SpecialHandling[core:SpecialHandlingType]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? , LineItemAttachments[core:ListOfAttachmentType]? )

    Description: RequisitionItemDetailType contains the line item details for the Requisition.

    Elements:

    • RequisitionBaseItemDetail - identifies the line item for the document. This contains the description, specific identifiers, and other information associated with the product.
    • RequisitionPricingDetail - contains all pricing information, including taxes, allowances and charges, and total price for an item.
    • RequisitionDeliveryDetail - is used to specify the scheduling, delivery, and transport information for the line item.
    • RoundTripShoppingCartID - is a reference to the round trip shopping cart ID.
    • RequisitionPaymentInstructions - holds the payment instructions for the Requisition.
    • RequisitionDetailParty - holds information on the parties for requisition at the item level, including unique ID's and address information.
    • RequisitionLineItemNote - describes any free form text pertinent to the line item. This element may contain notes or any other similar information that is not contained explicitly in another structure. Users should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • SpecialHandling - descibes any special handling conditions that apply to the enitre Requisition.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. Such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfNameValueSet - is used to hold sets of name value pairs. The use of this element should be limited to the support of previous versions of xCBL.
    • LineItemAttachments - contains attachments for the line item.

[^]Code Fragment

    <xsd:complexType name="RequisitionItemDetailType">
    <xsd:sequence>
        <xsd:element name="RequisitionBaseItemDetail" type="BaseItemDetailType">
        <xsd:element minOccurs="0" name="RequisitionPricingDetail" type="core:PricingDetailType">
        <xsd:element minOccurs="0" name="RequisitionDeliveryDetail" type="core:DeliveryDetailType">
        <xsd:element minOccurs="0" name="RoundTripShoppingCartID" type="xsd:int">
        <xsd:element minOccurs="0" name="RequisitionPaymentInstructions" type="core:PaymentInstructionsType">
        <xsd:element minOccurs="0" name="RequisitionDetailParty" type="RequisitionDetailPartyType">
        <xsd:element minOccurs="0" name="RequisitionLineItemNote" type="xsd:string">
        <xsd:element minOccurs="0" name="SpecialHandling" type="core:SpecialHandlingType">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
        <xsd:element minOccurs="0" name="LineItemAttachments" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: RequisitionNumberType

RequisitionNumberType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( ReqNumber[xsd:string] , ReqName[xsd:string]? , RevisionNumber[core:ReferenceType]? )

    Description: RequisitionNumberType contains the unique number and name assigned to identify a requistion.

    Elements:

    • ReqNumber - is a unique number assigned to the Requisition by the system generating the requisition transaction.
    • ReqName - is a descriptive name assigned to the Requisition by the user generating the requisition transaction.
    • RevisionNumber - contains the requisition revision number along with an optional revision date element.

[^]Code Fragment

    <xsd:complexType name="RequisitionNumberType">
    <xsd:sequence>
        <xsd:element name="ReqNumber" type="xsd:string">
        <xsd:element minOccurs="0" name="ReqName" type="xsd:string">
        <xsd:element minOccurs="0" name="RevisionNumber" type="core:ReferenceType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: RequisitionPartyType

RequisitionPartyType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( RequisitionerParty[core:PartyType] , BuyerParty[core:PartyType] , SellerParty[core:PartyType]? , ShipToParty[core:PartyType]? , BillToParty[core:PartyType]? , RemitToParty[core:PartyType]? , ShipFromParty[core:PartyType]? , SoldToParty[core:PartyType]? , ListOfPartyCoded[core:ListOfPartyCodedType]? )

    Description: RequisitionPartyType holds all party information related to the requisition transaction.

    Elements:

    • RequisitionerParty - contains the information for the party creating the requisition.
    • BuyerParty - contains the information for the party purchasing the goods.
    • SellerParty - identifies the party selling the goods.
    • ShipToParty - contains the information for the party which the items are to be shipped.
    • BillToParty - contains the information for the party that will receive the bill for the goods..
    • RemitToParty - contains the information for the party to be paid.
    • ShipFromParty - contains party information identifying the location from which the items are to be shipped.
    • SoldToParty - contains party information identifying the location where the items were sold.
    • ListOfPartyCoded - is a collection of all other party information not explicitly stated as the content of another element.

[^]Code Fragment

    <xsd:complexType name="RequisitionPartyType">
    <xsd:sequence>
        <xsd:element name="RequisitionerParty" type="core:PartyType">
        <xsd:element name="BuyerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="SellerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ShipToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="BillToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="RemitToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ShipFromParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="SoldToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ListOfPartyCoded" type="core:ListOfPartyCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: RequisitionReferencesType

RequisitionReferencesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( AccountCode[core:ReferenceType]? , ContractReferences[core:ListOfContractType]? , QuoteReference[core:ReferenceType]? , BlanketOrderReference[core:ReferenceType]? , ListOfCostCenter[core:ListOfCostCenterType]? , OtherRequisitionReferences[core:ListOfReferenceCodedType]? )

    Description: RequisitionReferencesType defines the references for the Requisition.

    Elements:

    • AccountCode - is the unique identification assigned to the buyer by the seller. This is used for reference purposes in the transaction. For example, Buyer Company A has a standing account with Seller Company B, which is assigned the identification of A-127654, therefore A-127654 would be the AccountCode.
    • ContractReferences - is an element that holds the contract number and contract type for referencing a contract. This element can also be used to hold a reference to a standing order. In this case do not use the ContractType field.
    • QuoteReference - refers to a Quote ID or Shopping Cart ID.
    • BlanketOrderReference - references a blanket purchase order.
    • ListOfCostCenter - identifies all cost center information, and if applicable, the split to each different cost center for the entire order. If a quantity is used to show the split, it is assumed to be the default quantity for each item on the order, and can be overwritten. If a a percent or monetary amount is used, it is assumed to be in relation to the entire amount of the order, included any taxes, allowances, or charges.
    • OtherRequisitionReferences - is all other references to the Requisition not explicitly stated as the content of other elements.

[^]Code Fragment

    <xsd:complexType name="RequisitionReferencesType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="AccountCode" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="ContractReferences" type="core:ListOfContractType">
        <xsd:element minOccurs="0" name="QuoteReference" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="BlanketOrderReference" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="ListOfCostCenter" type="core:ListOfCostCenterType">
        <xsd:element minOccurs="0" name="OtherRequisitionReferences" type="core:ListOfReferenceCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: RequisitionSummaryType

RequisitionSummaryType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( NumberOfLines[xsd:int]? , ListOfTaxSummary[core:ListOfTaxSummaryType]? , AllowOrChargeSummary[core:AllowOrChargeSummaryType]? , RequisitionSubTotal[core:MonetaryValueType]? , RequisitionTotal[core:MonetaryValueType]? , SummaryNote[xsd:string]? )

    Description: RequisitionSummaryType contains the summary information, typically totals of numerical fields.

    Elements:

    • NumberOfLines - identifies the number of line items.
    • ListOfTaxSummary - contains the summary of the tax information specified within the Invoice. This element is mandatory if tax elements occur in either the invoice header or any invoice detail item line.
    • AllowOrChargeSummary - contains the summary amounts, for each category of the allowance or charge.
    • RequisitionSubTotal - contains the sub total for all items on the requisition. This should be the sum of the sub totals of all items, not including taxes, allowances, or charges.
    • RequisitionTotal - contains the total price for the entire requisition, including all taxes, allowances, and charges.
    • SummaryNote - contains any free form text for the OrderSummary. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.

[^]Code Fragment

    <xsd:complexType name="RequisitionSummaryType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="NumberOfLines" type="xsd:int">
        <xsd:element minOccurs="0" name="ListOfTaxSummary" type="core:ListOfTaxSummaryType">
        <xsd:element minOccurs="0" name="AllowOrChargeSummary" type="core:AllowOrChargeSummaryType">
        <xsd:element minOccurs="0" name="RequisitionSubTotal" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="RequisitionTotal" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="SummaryNote" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: RequisitionType

RequisitionType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( RequisitionHeader[RequisitionHeaderType] , RequisitionDetail[RequisitionDetailType]? , RequisitionSummary[RequisitionSummaryType]? )

    Description: RequisitionType is used to request the acquisition of goods or services.

    Elements:

    • RequisitionHeader - contains the header information of the Requisition.
    • RequisitionDetail - contains the line item details of the Requisition.
    • RequisitionSummary - contains the summary information of the Requisition.

[^]Code Fragment

    <xsd:complexType name="RequisitionType">
    <xsd:sequence>
        <xsd:element name="RequisitionHeader" type="RequisitionHeaderType">
        <xsd:element minOccurs="0" name="RequisitionDetail" type="RequisitionDetailType">
        <xsd:element minOccurs="0" name="RequisitionSummary" type="RequisitionSummaryType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: RequisitionTypeCodeType

RequisitionTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • OrderRequest - Document functions as a request to procure goods or services.
    • BlanketOrderRelease - Document functions as a release to a blanket order.

[^]Code Fragment

    <xsd:simpleType name="RequisitionTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="OrderRequest">
        <xsd:enumeration value="BlanketOrderRelease">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: RequisitionTypeType

RequisitionTypeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( RequisitionTypeCoded[RequisitionTypeCodeType] , RequisitionTypeCodedOther[xsd:string]? )

    Description: RequisitionTypeType identifies the type of requisition.

    Elements:

    • RequisitionTypeCoded - defines the type of requisition.
    • RequisitionTypeCodedOther - is used to provide a non-standard RequisitionTypeCode. This element is mandatory if the value of RequisitionTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="RequisitionTypeType">
    <xsd:sequence>
        <xsd:element name="RequisitionTypeCoded" type="RequisitionTypeCodeType">
        <xsd:element minOccurs="0" name="RequisitionTypeCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: RoundTripShoppingCartType

RoundTripShoppingCartType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/applicationintegration/v1_0/applicationintegration.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( ShoppingCartID[xsd:int] , SellerParty[core:PartyType] , RoundTripInformation[core:RoundTripInformationType]? )

    Description: RoundTripShoppingCartType contains information pertinent to the round trip shopping cart.

    Elements:

    • ShoppingCartID - is a unique number assigned to the shopping cart.
    • SellerParty - contains details to describe the seller party.
    • RoundTripInformation - contains the details to describe the round trip.

[^]Code Fragment

    <xsd:complexType name="RoundTripShoppingCartType">
    <xsd:sequence>
        <xsd:element name="ShoppingCartID" type="xsd:int">
        <xsd:element name="SellerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="RoundTripInformation" type="core:RoundTripInformationType">
    </xsd:sequence>
</xsd:complexType>


Simple Types:

RequisitionTypeCodeType


complexType definition: ActionType

ActionType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content:

    Attribute:Name: Value, Type: core:ActionValueCodeType, Default: 'Add'

    Description: ActionType specifies the action to be taken by the application processing the product description.

    Attributes:

    • Value - indicates the action to be taken:

[^]Code Fragment

    <xsd:complexType name="ActionType">
    <xsd:attribute name="Value" type="core:ActionValueCodeType" use="optional" default="Add">
</xsd:complexType>


complexType definition: AttributeNameType

AttributeNameType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: Extension of type: xsd:string

    Attribute:Ref: xml:lang, Default: 'en'

    Description: AttributeNameType contains the name of the attribute. Multilanguage support is provided by potentially having multiple AttributeName elements, each of which has an xml:lang attribute. xml:lang must contain a value that is a valid RFC 1766 language code. If not specified in DefaultLanguage or in a specific element, the value is assumed to be en for "English."

    Attributes:

    • xml:lang

[^]Code Fragment

    <xsd:complexType name="AttributeNameType">
    <xsd:simpleContent>
        <xsd:extension base="xsd:string">
            <xsd:attribute ref="xml:lang" use="optional" default="en">
        </xsd:extension>
    </xsd:simpleContent>
</xsd:complexType>


complexType definition: AttributeTypeType

AttributeTypeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( EnumeratedValue[xsd:string]* )

    Attribute:Name: ScalarType, Type: ScalarTypeCodeType, Default: 'String'
    Attribute:Name: MaxSize, Type: xsd:string, Use: 'optional'

    Description: AttributeTypeType provides the data type of the category's attribute. Has ScalarType enumerated attribute that indicates whether this data value is a String, an Integer, a Numeric value (such as a floating point number), a Currency (an ISO Currency Code), a Date, or an Enumeration. If an Enumeration, AttributeType has a set of subelements called EnumeratedValue which list the values of the enumeration. Also optionally has MaxSize attribute which indicates the maximum length of the string in characters.

    Elements:

    • EnumeratedValue - provides a single, allowable value in an enumeration of such values.
    Attributes:
    • ScalarType
    • MaxSize

[^]Code Fragment

    <xsd:complexType name="AttributeTypeType">
    <xsd:sequence>
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="EnumeratedValue" type="xsd:string">
    </xsd:sequence>
    <xsd:attribute name="ScalarType" type="ScalarTypeCodeType" use="optional" default="String">
    <xsd:attribute name="MaxSize" type="xsd:string" use="optional">
</xsd:complexType>


complexType definition: AttributeValueType

AttributeValueType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: Extension of type: xsd:string

    Attribute:Ref: xml:lang, Default: 'en'

    Description: AttributeValueType gives the value of the attribute being described. For example, if the attribute is "Color", the value is "Red". Multiple values may be specified, each with its own xml:lang value.

    Attributes:

    • xml:lang

[^]Code Fragment

    <xsd:complexType name="AttributeValueType">
    <xsd:simpleContent>
        <xsd:extension base="xsd:string">
            <xsd:attribute ref="xml:lang" use="optional" default="en">
        </xsd:extension>
    </xsd:simpleContent>
</xsd:complexType>


simpleType definition: BuyerSupplierCodeType

BuyerSupplierCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Description:
    This code identifies the role of a trading partner, or otherwise qualifies a piece of data that could come from more than one source within the trading relationship.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • Buyer
    • Supplier

[^]Code Fragment

    <xsd:simpleType name="BuyerSupplierCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Buyer">
        <xsd:enumeration value="Supplier">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: BuyerType

BuyerType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Imported Namespaces:
    • rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: Extension of type: xsd:string

    Attribute: Name: PartnerRef, Type: xsd:IDREF, Use: 'optional'

    Description: BuyerType provides the name of a buyer, or a reference to a buyer described in ListOfTradingPartner. If the name is supplied, as well as a reference to the buyer, the reference should be treated as the primary identifier.

    Attributes:

    • PartnerRef

[^]Code Fragment

    <xsd:complexType name="BuyerType">
    <xsd:simpleContent>
        <xsd:extension base="xsd:string">
            <xsd:attribute name="PartnerRef" type="xsd:IDREF" use="optional">
        </xsd:extension>
    </xsd:simpleContent>
</xsd:complexType>


simpleType definition: CatalogAudienceCodeType

CatalogAudienceCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Description:
    This code identifies the intended audience of a catalog.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • EnumeratedBuyersOnly - Only those partners declared to be of type Buyer in the ListOfParnter element are allowed to view the catalog
    • Public - The catalog is intended for public viewing.

[^]Code Fragment

    <xsd:simpleType name="CatalogAudienceCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="EnumeratedBuyersOnly">
        <xsd:enumeration value="Public">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: CatalogAudienceType

CatalogAudienceType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content:

    Attribute:Name: CatalogAudienceCoded, Type: CatalogAudienceCodeType, Default: 'Public'

    Description: CatalogAudienceType Has an attribute CatalogAudienceCoded which is essentially a binary flag, values restricted to either "Public" or "EnumeratedBuyersOnly": is access to information defined as public (i.e., price catalogs associated with an IsPublicAccount) restricted to only the Partner's of type Buyer listed in the ListOfPartners (EnumeratedBuyersOnly); or is access unrestricted (Public). Default is Public.

    Attributes:

    • CatalogAudienceCoded -

[^]Code Fragment

    <xsd:complexType name="CatalogAudienceType">
    <xsd:attribute name="CatalogAudienceCoded" type="CatalogAudienceCodeType" use="optional" default="Public">
</xsd:complexType>


complexType definition: CatalogContractType

CatalogContractType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( CatalogContractID[xsd:string] , CatalogContractItemID[xsd:string] )

    Attribute:Name: Type, Type: BuyerSupplierCodeType, Default: 'Buyer'

    Description: CatalogContractType contains information to identify the buyer's or supplier's contract, and the item identification in terms of that contract.

    Elements:

    • CatalogContractID - holds the reference to the contract, typically as a contract number.
    • CatalogContractItemID - holds the contract's reference to the item, also typically a number.
    Attributes:
    • Type - identifies whether the contract information refers to a buyer's contract, a supplier's contract, or some other contract. "Other" is not used here to refer to a custom value (that is, there is no string field to contain a custom value.) If needed, this additional information should form part of the contract number information supplied in

[^]Code Fragment

    <xsd:complexType name="CatalogContractType">
    <xsd:sequence>
        <xsd:element name="CatalogContractID" type="xsd:string">
        <xsd:element name="CatalogContractItemID" type="xsd:string">
    </xsd:sequence>
    <xsd:attribute name="Type" type="BuyerSupplierCodeType" use="optional" default="Buyer">
</xsd:complexType>


complexType definition: CatalogDataType

CatalogDataType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( ( Product[ProductType] | Pricing[PricingType] )* )

    Description: CatalogDataType is a container for instances of products and pricings described in the ProductCatalog.

    Elements:

    • Product - contains all attributes associated with a product.
    • Pricing - contains all prices associated with a particular product from a particular price catalog.

[^]Code Fragment

    <xsd:complexType name="CatalogDataType">
    <xsd:sequence>
        <xsd:choice minOccurs="0" maxOccurs="unbounded">
            <xsd:element name="Product" type="ProductType">
            <xsd:element name="Pricing" type="PricingType">
        </xsd:choice>
    </xsd:sequence>
</xsd:complexType>


complexType definition: CatalogHeaderType

CatalogHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( CatalogID[xsd:string] , CatalogDate[xsd:dateTime]? , CatalogProvider[CatalogProviderType] , CatalogPrettyName[xsd:string]? , CatalogLogoURL[xsd:string]? , PricingInformation[PricingInformationType]? , SupplierAccountInformation[SupplierAccountInformationType]? , ValidFrom[xsd:dateTime]? , ValidUntil[xsd:dateTime]? , CatalogVersion[xsd:decimal]? , DefaultLanguage[DefaultLanguageType]? , DefaultCurrency[core:CurrencyType]? , IsReplacement[IsReplacementType]? , ShortDescription[ShortDescriptionType]* , LongDescription[LongDescriptionType]* , ObjectAttribute[ObjectAttributeType]* )

    Description: CatalogHeaderType provides administrative information about the catalog including its provider, and suppliers and other trading partners present in the catalog.

    Elements:

    • CatalogID - holds a required unique identifier for catalog. Must be unique within the set of catalogs provided by a particular catalog provider.
    • CatalogDate - is the date that this catalog information was created.
    • CatalogProvider - specifies the providing party of this catalog. Contains an optional Party subelement. Has optional attribute of ProviderID whose ID overrides the ID present on a Party element. Either a ProviderID attribute or a Party subelement must be present.
    • CatalogPrettyName - is used to hold the name of the catalog to be used for display purposes.
    • CatalogLogoURL - holds the location of a logo for the catalog to be used for display purposes.
    • PricingInformation - A list of PriceCatalog definitions (see sub-element tables for definition) NOTE: without mention in a SupplierAccount, the audience for prices in a PriceCatalog is undefined.
    • SupplierAccountInformation - is used by the supplier to provide a within-catalog unique name for an account associated with a particular buyer that has a specific pricing rule associated with it.
    • ValidFrom - gives the date that products and price in this catalog begin to be available.
    • ValidUntil - gives the date on which the information in this catalog is no longer applicable.
    • CatalogVersion - holds the version number of catalog specified as a single integer. Should be specified as a higher number than any previous catalog updates that have been sent.
    • DefaultLanguage - contains the attribute xml:lang indicating the language that should be assumed for the catalogdocument (and subsequent documents targeting this catalog, if it is not respecified) when it is not specified explicitly on a particular element. The value of xml:lang must be a valid RFC 1766 language code.
    • DefaultCurrency - ISO currency code indicating the currency that should be assumed in this catalog document (and subsequent documents targeting this catalog, if it is not respecified). Contains a Currency element from the rest of xCBL, which itself contains a CurrencyCoded and a CurrencyCodedOther element. Only CurrencyCoded is required to appear in the Currency element.
    • IsReplacement - indicates that this is a complete replacement for an existing catalog's Schema and Products-Pricing's are unaffected by this flag (see the PriceCatalog Action sub-element for how to effect bulk deletions of Pricings).The independence between Product and Pricing replacement is a feature enabling a new set of Product information to be added without needing to restate all the pricing information.
    • ShortDescription - gives a short description of the catalog. Has xml:lang attribute so there can be more than one ShortDescription in multiple languages. xml:lang must contain valid RFC 1766 language code.
    • LongDescription - gives a long description of the catalog. Has xml:lang attribute for multilanguage support. xml:lang must contain valid RFC 1766 language code. If not specified in DefaultLanguage or in a specific element, the value is assumed to be en for "English." DescriptionPurpose is an attribute that attempts to describe what the description is for. Examples of valid values are "sales" and "internal use only".
    • ObjectAttribute - provides other data items for the overall catalog or catalog administration that are not in elements that already exist in the CatalogHeader.

[^]Code Fragment

    <xsd:complexType name="CatalogHeaderType">
    <xsd:sequence>
        <xsd:element name="CatalogID" type="xsd:string">
        <xsd:element minOccurs="0" name="CatalogDate" type="xsd:dateTime">
        <xsd:element name="CatalogProvider" type="CatalogProviderType">
        <xsd:element minOccurs="0" name="CatalogPrettyName" type="xsd:string">
        <xsd:element minOccurs="0" name="CatalogLogoURL" type="xsd:string">
        <xsd:element minOccurs="0" name="PricingInformation" type="PricingInformationType">
        <xsd:element minOccurs="0" name="SupplierAccountInformation" type="SupplierAccountInformationType">
        <xsd:element minOccurs="0" name="ValidFrom" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ValidUntil" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="CatalogVersion" type="xsd:decimal">
        <xsd:element minOccurs="0" name="DefaultLanguage" type="DefaultLanguageType">
        <xsd:element minOccurs="0" name="DefaultCurrency" type="core:CurrencyType">
        <xsd:element minOccurs="0" name="IsReplacement" type="IsReplacementType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="ShortDescription" type="ShortDescriptionType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="LongDescription" type="LongDescriptionType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="ObjectAttribute" type="ObjectAttributeType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: CatalogProviderType

CatalogProviderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( Party[core:PartyType]? , CatalogSystem[CatalogSystemType]? )

    Attribute:Name: ProviderID, Type: xsd:string, Use: 'optional'

    Description: CatalogProviderType specifies the providing party of this catalog. Contains an optional Party subelement.

    Elements:

    • Party - identifies an entity doing business and the relevant information pertaining to it.
    • CatalogSystem - allows the provider to identify the location and type of the system that created the catalog.
    Attributes:
    • ProviderID - specifies an identifier for the provider of the catalog. Must be specified if there is no

[^]Code Fragment

    <xsd:complexType name="CatalogProviderType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="Party" type="core:PartyType">
        <xsd:element minOccurs="0" name="CatalogSystem" type="CatalogSystemType">
    </xsd:sequence>
    <xsd:attribute name="ProviderID" type="xsd:string" use="optional">
</xsd:complexType>


complexType definition: CatalogSchemaType

CatalogSchemaType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( SchemaName[xsd:string] , SchemaVersion[xsd:decimal]? , SchemaStandard[xsd:string]? , ValidateAttributes[ValidateAttributesType]? , ShortDescription[ShortDescriptionType]* , LongDescription[LongDescriptionType]* , SchemaSource[xsd:anyURI]? , SchemaURN[xsd:anyURI]? , ExtensionToSchemasURN[xsd:anyURI]? , SchemaCategory[SchemaCategoryType]* )

    Attribute:Name: Type, Type: BuyerSupplierCodeType, Default: 'Supplier'

    Description: CatalogSchemaType holds optional, creator-configured information about the structure of products in the catalog.

    Elements:

    • SchemaName - The SchemaName is a set of categories used for products in this catalog. The schema was created by a buyer, a supplier or "other" (such as a marketplace or manufacturer): this is the name assigned to that schema by its creator.
    • SchemaVersion - is the version number for the catalog schema used for products in this catalog
    • SchemaStandard - is the taxonomy standard that this catalog may be based upon or is a subset of, e.g. UNSPSC or eClass.
    • ValidateAttributes - is an element whose presence indicates that the category attributes should be validated.
    • ShortDescription - is a short description of the schema. There may be more than one ShortDescription element to allow for internationalized content, which is effected by use of the xml:lang attribute. xml:lang must contain a value that is a valid RFC 1766 language code. If not specified in DefaultLanguage or in a specific element, the value is assumed to be en for "English".
    • LongDescription - is a long description of the schema. There may be more than one LongDescription element to allow for internationalized content, which is effected by use of the xml:lang attribute. xml:lang must contain a value that is a valid RFC 1766 language code.If not specified in DefaultLanguage or in a specific element, the value is assumed to be en for "English"
    • SchemaSource - is a URL to an external schema. This external schema should either be a ProductCatalog document containing a schema or a CatalogSchema document. Use of an external SchemaSource is necessary to validate Product instances when ExternalCategory is used on a Product in lieu of a SchemaCategoryRef on Product. Note that if this element is present in the CatalogSchema, no SchemaCategory element(s) should be present in the CatalogSchema, and SchemaCategoryRef should not be used on any of the Products in the document. This element is useful when a supplier or other catalog provider is providing data that needs to be validated against someone else's (such as the net market maker's) schema.
    • SchemaURN - is a URN identifying the schema defined in this element.
    • ExtensionToSchemasURN -
    • SchemaCategory - is a list of categories. Should not be present if there is a SchemaSource element supplied to identify an external schema.
    Attributes:
    • Type - contains a code to identify the type of the schema:Supplier,Buyer, or Other. (Supplier is the default)

[^]Code Fragment

    <xsd:complexType name="CatalogSchemaType">
    <xsd:sequence>
        <xsd:element name="SchemaName" type="xsd:string">
        <xsd:element minOccurs="0" name="SchemaVersion" type="xsd:decimal">
        <xsd:element minOccurs="0" name="SchemaStandard" type="xsd:string">
        <xsd:element minOccurs="0" name="ValidateAttributes" type="ValidateAttributesType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="ShortDescription" type="ShortDescriptionType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="LongDescription" type="LongDescriptionType">
        <xsd:element minOccurs="0" name="SchemaSource" type="xsd:anyURI">
        <xsd:element minOccurs="0" name="SchemaURN" type="xsd:anyURI">
        <xsd:element minOccurs="0" name="ExtensionToSchemasURN" type="xsd:anyURI">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="SchemaCategory" type="SchemaCategoryType">
    </xsd:sequence>
    <xsd:attribute name="Type" type="BuyerSupplierCodeType" use="optional" default="Supplier">
</xsd:complexType>


complexType definition: CatalogSystemType

CatalogSystemType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( SystemAddress[xsd:string] , SystemType[xsd:string] )

    Description: CatalogSystemType specifies the system address and type of system of this catalog. Contains 2 mandatory subelements.

    Elements:

    • SystemAddress - supplies a system address supplied by the provider's catalog system.
    • SystemType - gives a description of the type of system used by the provider to create the catalog.

[^]Code Fragment

    <xsd:complexType name="CatalogSystemType">
    <xsd:sequence>
        <xsd:element name="SystemAddress" type="xsd:string">
        <xsd:element name="SystemType" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: CategoryAttributeType

CategoryAttributeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( AttributeID[xsd:string] , AttributeName[AttributeNameType]* , AttributeType[AttributeTypeType] , DefaultUOM[core:UOMType]? , IsRequired[IsRequiredType]? )

    Description: CategoryAttributeType holds definitions of additional attributes (if any) applicable to members of this category.

    Elements:

    • AttributeID - identifies the category's attribute. It must be unique among attributes present in this particular SchemaCategory. If a child SchemaCategory has the same AttributeID as a parent SchemaCategory, the suggested behavior of an xCBL catalog processor is to report this as an error.
    • AttributeName - contains the name of the attribute. Multilanguage support is provided by potentially having multiple AttributeName elements, each of which has an xml:lang attribute. xml:lang must contain a value that is a valid RFC 1766 language code. If not specified in DefaultLanguage or in a specific element, the value is assumed to be en for "English."
    • AttributeType - provides the data type of the category's attribute. Has ScalarType enumerated attribute that indicates whether this data value is a String, an Integer, a Numeric value (such as a floating point number), a Currency (an ISO Currency Code), a Date, or an Enumeration. If an Enumeration, AttributeType has a set of subelements called EnumeratedValue which list the values of the enumeration. Also optionally has MaxSize attribute which indicates the maximum length of the string in characters.
    • DefaultUOM - is the default unit of measure for this attribute. This defaults to EA (each) and implies the dimensionality of the attribute (e.g. length, mass, time, etc.)
    • IsRequired - indicates, by its presence in the message, that the attribute is required. This should be reflected by the validation behavior of the processing application.

[^]Code Fragment

    <xsd:complexType name="CategoryAttributeType">
    <xsd:sequence>
        <xsd:element name="AttributeID" type="xsd:string">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="AttributeName" type="AttributeNameType">
        <xsd:element name="AttributeType" type="AttributeTypeType">
        <xsd:element minOccurs="0" name="DefaultUOM" type="core:UOMType">
        <xsd:element minOccurs="0" name="IsRequired" type="IsRequiredType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: CategoryNameType

CategoryNameType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: Extension of type: xsd:string

    Attribute:Ref: xml:lang, Default: 'en'

    Description: CategoryNameType contains the name of the category as given by its creator.

    Attributes:

    • xml:lang

[^]Code Fragment

    <xsd:complexType name="CategoryNameType">
    <xsd:simpleContent>
        <xsd:extension base="xsd:string">
            <xsd:attribute ref="xml:lang" use="optional" default="en">
        </xsd:extension>
    </xsd:simpleContent>
</xsd:complexType>


Complex Types:

ActionType
AttributeNameType
AttributeValueType
AttributeTypeType
CatalogAudienceType
CatalogContractType
CatalogDataType
CatalogHeaderType
CatalogProviderType
CatalogSchemaType
CatalogSystemType
CategoryAttributeType
CategoryNameType
DefaultLanguageType
ExternalItemRefType
IsPublicAccountType
IsReplacementType
IsRequiredType
LongDescriptionType
ManufacturerType
ObjectAttributeType
ParentCategoryRefListType
PartnerRelationshipType
PartnerType
ListOfPartnersType
PriceCatalogType
PricingInformationType
PricingType
ProductAttachmentType
ProductCatalogType
ProductIDStandardType
ProductIDType
ProductNameType
ProductPriceType
ProductType
RelatedProductType
SchemaCategoryRefListType
SchemaCategoryType
ShortDescriptionType
SupplierAccountInformationType
SupplierAccountType
ValidateAttributesType
VisibilityRulesType


complexType definition: DefaultLanguageType

DefaultLanguageType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content:

    Attribute:Ref: xml:lang, Default: 'en'

    Description: DefaultLanguageType contains the attribute xml:lang indicating the language that should be assumed for the catalogdocument (and subsequent documents targeting this catalog, if it is not respecified) when it is not specified explicitly on a particular element. The value of xml:lang must be a valid RFC 1766 language code.

    Attributes:

    • xml:lang

[^]Code Fragment

    <xsd:complexType name="DefaultLanguageType">
    <xsd:attribute ref="xml:lang" use="optional" default="en">
</xsd:complexType>


complexType definition: ExternalItemRefType

ExternalItemRefType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( ( CatalogProviderIDRef[xsd:string] , CatalogIDRef[xsd:string] , ProductIDRef[xsd:string] ) | ItemGUID[xsd:string] )

    Description: ExternalItemRefType is a reference to a piece of CatalogData in another catalog. Can be either a ItemGUID (see below) or a triple of Catalog ID, Catalog Provider, and Product ID. Note: Unresolved references do not constitute an error. Note: Circular references and recursive references are undefined, and should be considered an error.

    Elements:

    • CatalogProviderIDRef - is the identification of the provider of the catalog that contains the item being referenced and should be a GUID.
    • CatalogIDRef - is the identification of the catalog that contains the item being referenced and should be an ID unique to a particular provider.
    • ProductIDRef - is the identification of the item being referenced and must be unique within the catalog.
    • ItemGUID - is a registered globally unique identifier for an item in a catalog.

[^]Code Fragment

    <xsd:complexType name="ExternalItemRefType">
    <xsd:choice>
        <xsd:sequence>
            <xsd:element name="CatalogProviderIDRef" type="xsd:string">
            <xsd:element name="CatalogIDRef" type="xsd:string">
            <xsd:element name="ProductIDRef" type="xsd:string">
        </xsd:sequence>
        <xsd:element name="ItemGUID" type="xsd:string">
    </xsd:choice>
</xsd:complexType>


Global Elements (Document Roots):

ProductCatalog


complexType definition: IsMultiVendorType

IsMultiVendorType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Imported Namespaces:
    • rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content:

    Description: IsMultiVendorType is an element whose presence indicates that the catalog is a multivendor catalog. If a product is multivendor, price should only appear under ProductVendorData.

[^]Code Fragment

    <xsd:complexType name="IsMultiVendorType">


complexType definition: IsPriceUpdateType

IsPriceUpdateType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Imported Namespaces:
    • rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content:

    Description: IsPriceUpdateType is an element whose presence indicates that the catalog is only being used to update prices.

[^]Code Fragment

    <xsd:complexType name="IsPriceUpdateType">


complexType definition: IsPublicAccountType

IsPublicAccountType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content:

    Description: IsPublicAccountType is a empty element meaning that all prices in the PriceCatalog(s) with PriceCatalogIDRef(s) are available to the public.

[^]Code Fragment

    <xsd:complexType name="IsPublicAccountType">


complexType definition: IsReplacementType

IsReplacementType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content:

    Description: IsReplacementType Indicates that this is a complete replacement for an existing catalog's Schema and Products-Pricing's are unaffected by this flag (see the PriceCatalog Action sub-element for how to effect bulk deletions of Pricings).The independence between Product and Pricing replacement is a feature enabling a new set of Product information to be added without needing to restate all the pricing information.

[^]Code Fragment

    <xsd:complexType name="IsReplacementType">


complexType definition: IsRequiredType

IsRequiredType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content:

    Description: IsRequiredType indicates, by its presence in the message, that the attribute is required. This should be reflected by the validation behavior of the processing application.

[^]Code Fragment

    <xsd:complexType name="IsRequiredType">


complexType definition: ListOfPartnersType

ListOfPartnersType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( Partner[PartnerType]+ )

    Description: ListOfPartnersType

    Elements:

    • Partner

[^]Code Fragment

    <xsd:complexType name="ListOfPartnersType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="Partner" type="PartnerType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: LongDescriptionType

LongDescriptionType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: Extension of type: xsd:string

    Attribute:Ref: xml:lang, Default: 'en'
    Attribute:Name: DescriptionPurpose, Type: xsd:string, Use: 'optional'

    Description: LongDescriptionType provides a long textual description of the catalog. Has xml:lang attribute for multilanguage support. xml:lang must contain valid RFC 1766 language code. If not specified in DefaultLanguage or in a specific element, the value is assumed to be en for "English."

    Attributes:

    • xml:lang
    • DescriptionPurpose - is an attribute that attempts to describe what the description is for. Examples of valid values are "sales" and "internal use only".

[^]Code Fragment

    <xsd:complexType name="LongDescriptionType">
    <xsd:simpleContent>
        <xsd:extension base="xsd:string">
            <xsd:attribute ref="xml:lang" use="optional" default="en">
            <xsd:attribute name="DescriptionPurpose" type="xsd:string" use="optional">
        </xsd:extension>
    </xsd:simpleContent>
</xsd:complexType>


complexType definition: ManufacturerType

ManufacturerType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: Extension of type: xsd:string

    Description: ManufacturerType supplies the name of the manufacturer or a reference to a manufacturer partner in the ListOfPartners. If a value is supplied in the PartnerRef attribute, the string content of the element will typically be ignored by the application or treated as secondary. Deprecate use of PartnerRef .

[^]Code Fragment

    <xsd:complexType name="ManufacturerType">
    <xsd:simpleContent>
        <xsd:extension base="xsd:string">
    </xsd:simpleContent>
</xsd:complexType>


complexType definition: ObjectAttributeType

ObjectAttributeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( AttributeID[xsd:string] , AttributeUnit[core:UOMType]? , AttributeValue[AttributeValueType]* )

    Description: ObjectAttributeType provides customizable data regarding the overall catalog, catalog administration, configured schema category, or product description that are not in elements that already exist in the CatalogHeader, SchemaCategory, or Product.

    Elements:

    • AttributeID - identifies the custom attribute. It must be unique among attributes present in a particular SchemaCategory when used in that context.
    • AttributeUnit - holds an ISO unit of measure for the ObjectAttribute. Must be commensurable (of the same dimension, so it can be converted and compared with other values) with CategoryAttribute DefaultUOM (if supplied) or with all previous UOM's supplied for ObjectAttributes with this AttributeID. Defaults to EA.
    • AttributeValue - gives the value of the ObjectAttribute. If a schema is present more than one AttributeValue can be listed, each with its own xml:lang attribute.

[^]Code Fragment

    <xsd:complexType name="ObjectAttributeType">
    <xsd:sequence>
        <xsd:element name="AttributeID" type="xsd:string">
        <xsd:element minOccurs="0" name="AttributeUnit" type="core:UOMType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="AttributeValue" type="AttributeValueType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ParentCategoryRefListType

ParentCategoryRefListType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( CategoryIDRef[xsd:string]+ )

    Description: ParentCategoryRefListType is a list of CatalogIDRefs for schema categories which are proper superclasses of this category, and from which this category inherits attributes.

    Elements:

    • CategoryIDRef - references a SchemaCategory by the CategoryID.

[^]Code Fragment

    <xsd:complexType name="ParentCategoryRefListType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="CategoryIDRef" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: PartnerRelationshipCodeType

PartnerRelationshipCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Description:
    describes the relationship/role of the partner who the catalog is targeted at.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Supplier
    • SupplierAgent
    • Buyer
    • InfoProvider
    • Manufacturer

[^]Code Fragment

    <xsd:simpleType name="PartnerRelationshipCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Supplier">
        <xsd:enumeration value="SupplierAgent">
        <xsd:enumeration value="Buyer">
        <xsd:enumeration value="InfoProvider">
        <xsd:enumeration value="Manufacturer">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: PartnerRelationshipType

PartnerRelationshipType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( PartnerRelationshipCoded[PartnerRelationshipCodeType] , PartnerRelationshipCodedOther[xsd:string]? )

    Description: PartnerRelationshipType identifies the role of the partners.

    Elements:

    • PartnerRelationshipCoded - describes the relationship/role of the partner who the catalog is targeted at.
    • PartnerRelationshipCodedOther - is used to provide a non-standard PartnerRelationshipCode. This element is mandatory if the value of PartnerRelationshipCode is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="PartnerRelationshipType">
    <xsd:sequence>
        <xsd:element name="PartnerRelationshipCoded" type="PartnerRelationshipCodeType">
        <xsd:element minOccurs="0" name="PartnerRelationshipCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PartnerType

PartnerType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( Action[ActionType]? , Party[core:PartyType]? , PartnerRelationship[PartnerRelationshipType]* )

    Description: PartnerType Partner has an optional PartnerID attribute that is an XML ID. Use of any XML ID or IDREF(S) is deprectated, including PartnerID. Although the PartnerID attribute is optional, an ID must be present as either the PartnerID or in the Party subelement. The ID in the Party subelement takes precedence over the PartnerID. The Partner subelement definition is shown in the table below.

    Elements:

    • Action - defines the action to be taken on the partner identified.
    • Party - identifies an entity doing business and the relevant information pertaining to it.
    • PartnerRelationship - identifies the role or roles of the partners.

[^]Code Fragment

    <xsd:complexType name="PartnerType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="Action" type="ActionType">
        <xsd:element minOccurs="0" name="Party" type="core:PartyType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="PartnerRelationship" type="PartnerRelationshipType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PriceCatalogType

PriceCatalogType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( Action[ActionType]? , PriceCatalogID[xsd:string] , ValidFrom[xsd:dateTime]? , ValidUntil[xsd:dateTime]? )

    Description: PriceCatalogType provides a means of naming a set of ProductPrices when used in conjunction with the Pricing element.

    Elements:

    • Action - identifies the action to be taken on the price catalog. Add, Replace, Update and Delete are acceptable values and additionally apply to all the Pricing elements whose PriceCatalogIDRef matches this PriceCatalogID.
    • PriceCatalogID - is a catalog-unique identification to refer to a set of ProductPrices denoted by grouping them in a Pricing element with a PriceCatalogIDRef matching this. NOTE: PriceCatalog's have no established audience unless SupplierAccount is defined which references it.
    • ValidFrom - is the date from which the Pricings in the catalog are effective. This overrides individual ProductPrice ValidFrom dates if and only if they are earlier than this date.
    • ValidUntil - is the date until which the Pricings in the catalog are effective. This overrides individual ProductPrice ValidUntil dates if and only if they are later than this date

[^]Code Fragment

    <xsd:complexType name="PriceCatalogType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="Action" type="ActionType">
        <xsd:element name="PriceCatalogID" type="xsd:string">
        <xsd:element minOccurs="0" name="ValidFrom" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ValidUntil" type="xsd:dateTime">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PricingInformationType

PricingInformationType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( PriceCatalog[PriceCatalogType]+ )

    Description: PricingInformationType is a list of PriceCatalog elements. NOTE - without mention in a SupplierAccount, the audience for prices in a PriceCatalog is undefined.

    Elements:

    • PriceCatalog - element provides a means of naming a set of ProductPrices when used in conjunction with the Pricing element.

[^]Code Fragment

    <xsd:complexType name="PricingInformationType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="PriceCatalog" type="PriceCatalogType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PricingType

PricingType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( ProductIDRef[xsd:string] , PriceCatalogIDRef[xsd:string] , ProductPrice[ProductPriceType]* )

    Description: PricingType contains all prices associated with a particular product from a particular price catalog.

    Elements:

    • ProductIDRef - is the identification of the product to which the prices are for.
    • PriceCatalogIDRef - is a reference to the price catalog that the product prices are members of.
    • ProductPrice - is a list of the product pricing schemes

[^]Code Fragment

    <xsd:complexType name="PricingType">
    <xsd:sequence>
        <xsd:element name="ProductIDRef" type="xsd:string">
        <xsd:element name="PriceCatalogIDRef" type="xsd:string">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="ProductPrice" type="ProductPriceType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ProductAttachmentType

ProductAttachmentType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( AttachmentURL[xsd:anyURI] , AttachmentPurpose[xsd:string]? , AttachmentMIMEType[xsd:string]? , ShortDescription[ShortDescriptionType]* , LongDescription[LongDescriptionType]* )

    Description: ProductAttachmentType allows the catalog creator to attach files of any type to the product description, and contains relevant information.

    Elements:

    • AttachmentURL - gives the URL of the attached file, used by the processing application to retrieve the attachment.
    • AttachmentPurpose - indicates the purpose of the attached file. This is not a coded value, and so will generally be displayed by the processing application for the edification of the user.
    • AttachmentMIMEType - supplies the MIME type of the attached file, to enable the processing application to display the correct behavior based on the type of the file.
    • ShortDescription - gives a single short description of the attachment. This takes an xml:lang attribute, which must contain a valid code according to RFC 1766. If not specified in DefaultLanguage or in a specific element, the value is assumed to be en for "English."
    • LongDescription - is a long description of the attachment. There may be more than one LongDescription element to allow for internationalized content, which is effected by use of the xml:lang attribute. xml:lang must contain a value that is a valid RFC 1766 language code. If not specified in DefaultLanguage or in a specific element, the value is assumed to be en for "English."

[^]Code Fragment

    <xsd:complexType name="ProductAttachmentType">
    <xsd:sequence>
        <xsd:element name="AttachmentURL" type="xsd:anyURI">
        <xsd:element minOccurs="0" name="AttachmentPurpose" type="xsd:string">
        <xsd:element minOccurs="0" name="AttachmentMIMEType" type="xsd:string">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="ShortDescription" type="ShortDescriptionType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="LongDescription" type="LongDescriptionType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ProductCatalogType

ProductCatalogType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( CatalogHeader[CatalogHeaderType] , CatalogSchema[CatalogSchemaType]? , CatalogData[CatalogDataType]? )

    Description: ProductCatalogType is a document that is used to supply pricing and product description data to trading partners. It is also used to configure non-standard product attributes that are useful for a particular type of product, service, catalog, etc., and is sometimes used as a vehicle for exchanging non-standard attributes and categorizations.

    Elements:

    • CatalogHeader - contains administrative information about the catalog including its provider, and suppliers and other trading partners present in the catalog.
    • CatalogSchema - provides optional information about the structure of products in the catalog.
    • CatalogData - is a container for instances of products and pricings described in the ProductCatalog.

[^]Code Fragment

    <xsd:complexType name="ProductCatalogType">
    <xsd:sequence>
        <xsd:element name="CatalogHeader" type="CatalogHeaderType">
        <xsd:element minOccurs="0" name="CatalogSchema" type="CatalogSchemaType">
        <xsd:element minOccurs="0" name="CatalogData" type="CatalogDataType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: ProductIDStandardCodeType

ProductIDStandardCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Description:
    This code identifies the standard that the product ID is produced to.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • GTIN - Global Trade Item Number
    • EAN - International Article Numbering Association
    • UCC - Uniform Code Council

[^]Code Fragment

    <xsd:simpleType name="ProductIDStandardCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="GTIN">
        <xsd:enumeration value="EAN">
        <xsd:enumeration value="UCC">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: ProductIDStandardType

ProductIDStandardType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: Extension of type: xsd:string

    Attribute:Name: Agency, Type: ProductIDStandardCodeType, Default: 'Other'

    Description: ProductIDStandardType indicates the agency whose product identification scheme is being used in ProductID.

    Attributes:

    • Agency - identifies the organization and if necessary the codelist from which the identifier is assigned.

[^]Code Fragment

    <xsd:complexType name="ProductIDStandardType">
    <xsd:simpleContent>
        <xsd:extension base="xsd:string">
            <xsd:attribute name="Agency" type="ProductIDStandardCodeType" use="optional" default="Other">
        </xsd:extension>
    </xsd:simpleContent>
</xsd:complexType>


complexType definition: ProductIDType

ProductIDType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: Extension of type: xsd:string

    Attribute:Name: Type, Type: BuyerSupplierCodeType, Default: 'Supplier'

    Description: ProductIDType is an unique identifier of the product. The optional Type attribute indicates whether the ProductID was created by a buyer, a supplier or "other" (such as a marketplace).

    Attributes:

    • Type - indicates whether the product ID was created by a buyer, a supplier or "other" (such as a marketplace).

[^]Code Fragment

    <xsd:complexType name="ProductIDType">
    <xsd:simpleContent>
        <xsd:extension base="xsd:string">
            <xsd:attribute name="Type" type="BuyerSupplierCodeType" use="optional" default="Supplier">
        </xsd:extension>
    </xsd:simpleContent>
</xsd:complexType>


complexType definition: ProductNameType

ProductNameType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: Extension of type: xsd:string

    Attribute:Ref: xml:lang, Default: 'en'

    Description: ProductNameType contains the name of the product. Multilanguage support is provided by potentially having multiple ProductName elements, each of which has an xml:lang attribute. xml:lang must contain a value that is a valid RFC 1766 language code. If not specified in DefaultLanguage or in a specific element, the value is assumed to be en for "English."

    Attributes:

    • xml:lang

[^]Code Fragment

    <xsd:complexType name="ProductNameType">
    <xsd:simpleContent>
        <xsd:extension base="xsd:string">
            <xsd:attribute ref="xml:lang" use="optional" default="en">
        </xsd:extension>
    </xsd:simpleContent>
</xsd:complexType>


complexType definition: ProductPriceType

ProductPriceType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( Amount[core:Decimal18_3Type] , PriceType[xsd:string]? , Currency[core:CurrencyType]? , UOM[core:UOMType]? , MinimumQuantity[xsd:decimal]? , ShortDescription[ShortDescriptionType]? , ValidFrom[xsd:dateTime]? , ValidUntil[xsd:dateTime]? , PriceBasisQuant[xsd:decimal]? )

    Description: ProductPriceType gives a set of price information for the item. If there is more than one relevant price, repeat the element.

    Elements:

    • Amount - supplies the price of the item as a decimal currency amount.
    • PriceType - gives the type of price being supplied, based on the catalog creator's or agreed-upon distinctions.
    • Currency - supplies an ISO Currency Code that overrides the default currency for the catalog if supplied.
    • UOM - gives an ISO unit of measure code. Defines the unit of measure for the value in PriceBasisQuant sub-element of ProductPrice. Must be exactly the same as the UOM sub-element of Product.
    • MinimumQuantity - supplies the The minimum number of LotSize x UOM's that must be purchased for this pricing to be effective (where UOM is the Product sub-element. If UOM is Liter, and LotSize is 0.5, that would be 1/2 liters). A value of 0 (zero) is the default and means there is no minimum order. If given, this value takes precedence over the Product MinOrder value.
    • ShortDescription - gives a single short description of the price. This takes an xml:lang attribute, which must contain a valid code according to RFC 1766. If not specified in DefaultLanguage or in a specific element, the value is assumed to be en for "English."
    • ValidFrom - gives an inclusive date on which the price becomes applicable.
    • ValidUntil - gives the date on which the price ceases to be applicable.
    • PriceBasisQuant - holds the quantity that is the basis of the price. This enables one to control the level of precision with which the price is expressed. Must be a number. Amount / PriceBasisQuant = price per 1 UOM. That is, the number of UOM's of the Product the Amount will purchase. It has no direct relationship to LotSize: this doesn't specify the "quanta" in which product can be ordered, just the "quanta" by which it's priced. It defaults to 1 (one). For example, if the price is 5 for $10, this value would be 5, the Amount is 10, and the UOM is EA.

[^]Code Fragment

    <xsd:complexType name="ProductPriceType">
    <xsd:sequence>
        <xsd:element name="Amount" type="core:Decimal18_3Type">
        <xsd:element minOccurs="0" name="PriceType" type="xsd:string">
        <xsd:element minOccurs="0" name="Currency" type="core:CurrencyType">
        <xsd:element minOccurs="0" name="UOM" type="core:UOMType">
        <xsd:element minOccurs="0" name="MinimumQuantity" type="xsd:decimal">
        <xsd:element minOccurs="0" name="ShortDescription" type="ShortDescriptionType">
        <xsd:element minOccurs="0" name="ValidFrom" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ValidUntil" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="PriceBasisQuant" type="xsd:decimal">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ProductType

ProductType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( Action[ActionType]? , ProductID[ProductIDType] , BaseProductNumber[xsd:string]? , SchemaCategoryRefList[SchemaCategoryRefListType]? , ProductIDExtension[xsd:string]? , ExternalItemRef[ExternalItemRefType]* , ProductIDStandard[ProductIDStandardType]? , ProductName[ProductNameType]* , UOM[core:UOMType]? , ComparableUOM[core:UOMType]? , ComparableUOMConversionFactor[xsd:decimal]? , Manufacturer[ManufacturerType]? , ManuPartNumber[xsd:string]? , LeadTime[xsd:decimal]? , LeadTimeUOM[core:UOMType]? , ValidFrom[xsd:dateTime]? , ValidUntil[xsd:dateTime]? , CountryOfOrigin[core:CountryType]? , MinOrder[xsd:decimal]? , LotSize[xsd:decimal]? , ShortDescription[ShortDescriptionType]* , LongDescription[LongDescriptionType]* , CatalogContract[CatalogContractType]* , ProductAttachment[ProductAttachmentType]* , RelatedProduct[RelatedProductType]* , ObjectAttribute[ObjectAttributeType]* )

    Attribute:Name: Type, Type: ProductTypeCodedType, Default: 'Good'

    Description: ProductType contains all attributes associated with a product.

    Elements:

    • Action - describes the action to be taken by an application processing the catalog, for the specific product.
    • ProductID - is a unique identifier of the product.The optional Type attribute indicates whether the ProductID was created by a buyer, a supplier or "other" (such as a marketplace).
    • BaseProductNumber - is the value to return as the product identifier. If not supplied, this defaults to the value of the ProductID element. This is only useful to suppliers which use a double or triple of values to uniquely identify a product - the ID, an ID extension, and a unit of measurement. Suppliers which have a single unique ID for each and every product they offer can ignore this element.
    • SchemaCategoryRefList - is a list of references to the schema categories of which this product is an instance of. The use of this element is encouraged over the use of the SchemaCategoryRef attribute. NOTE: this is a multiple inheritance model. The order of the categories establishes precedence, the list being ordered in descending precedence. This is most important in determining which class an undeclared ObjectAttribute used in the CatalogData section is added to.
    • ProductIDExtension - acts as an auxiliary of ProductID, providing further distinctions between items that have the same value for ProductID.
    • ExternalItemRef - is a reference to a piece of CatalogData in another catalog. Can be either a ItemGUID (see below) or a triple of CatalogID, CatalogProvider, ProductID
    • ProductIDStandard - indicates the agency whose product identification scheme is being used in ProductID.
    • ProductName - contains the name of the product. Multilanguage support is provided by potentially having multiple AttributeName elements, each of which has an xml:lang attribute. xml:lang must contain a value that is a valid RFC 1766 language code. If not specified in DefaultLanguage or in a specific element, the value is assumed to be en for "English."
    • UOM - represents orderable unit of measure of the product. Contains xCBL element UOM to represent ISO unit of measure code. Describes what unit of measure the LotSize sub-element is expressed in. Defaults to EA (each).
    • ComparableUOM - is analogous to the notion of a base UOM and is included to enable comparisions of this product's pricings with other, similar, products.
    • ComparableUOMConversionFactor - is the number of ComparableUOM per UOM.
    • Manufacturer - supplies the name of the manufacturer or a reference to a manufacturer partner in the ListOfPartners. If a value is supplied in the PartnerRef attribute, the string content of the element will typically be ignored by the application or treated as secondary. Deprecate use of PartnerRef .
    • ManuPartNumber - holds the manufacturer's part number.
    • LeadTime - provides the lead time required when ordering the product described. Time is expressed in number of days unless otherwise specified in LeadTimeUOM.
    • LeadTimeUOM - supplies the time unit of measure for the product's lead time.
    • ValidFrom - gives an inclusive date that the product and its price begin to be available/applicable.
    • ValidUntil - gives the date on which the product and its price are no longer applicable.
    • CountryOfOrigin - holds an ISO Country Code indicating the country in which the goods described originated. This is typically important in a consideration of purchasing goods from overseas, because of import/export laws, etc.
    • MinOrder - indicates the minimum order. That is, the Minimum number of LotSize x UOM's of ProductID purchasable (e.g., LotSize = 6, UOM = EA, MinOrder = 1, have to buy at least 6 of item). A value of 1 (one) is the default. The ProductPrice MinimumQuantity takes precedence over this value.
    • LotSize - indicates the granularity possible with orders with respect to Product UOM. If Product UOM has a value of EA, and LotSize has a value of 5, then ordering 1 of this Product, is effectively order 5 EA of whatever's offered-essentially, the offering is a 5-pack, ordering one is ordering one 5-pack. Defaults to 1.
    • ShortDescription - is a short description of the product. There may be more than one ShortDescription(s) of the product.
    • LongDescription - is a long description of the product. There may be more than one Long description(s) of the product.
    • CatalogContract - is the contract information. The Type attribute indicates whether the Contract is buyer contract, supplier contract or "other".
    • ProductAttachment - allows the catalog creator to include references to files of any type to the product description, and contains relevant information.
    • RelatedProduct - holds a reference to another product, using its product identifier, to establish a relationship between them, and to indicate the type of relationship.
    • ObjectAttribute - are additional attributes of products not built into the elements described above. NOTE: this is a multiple inheritance model. The order of the categories establishes precedence, the list being ordered in descending precedence. This is most important in determining which class an undeclared ObjectAttribute used here (in the CatalogData section) is added to.
    Attributes:
    • Type - provides a distinction between goods and services as these are described in the

[^]Code Fragment

    <xsd:complexType name="ProductType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="Action" type="ActionType">
        <xsd:element name="ProductID" type="ProductIDType">
        <xsd:element minOccurs="0" name="BaseProductNumber" type="xsd:string">
        <xsd:element minOccurs="0" name="SchemaCategoryRefList" type="SchemaCategoryRefListType">
        <xsd:element minOccurs="0" name="ProductIDExtension" type="xsd:string">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="ExternalItemRef" type="ExternalItemRefType">
        <xsd:element minOccurs="0" name="ProductIDStandard" type="ProductIDStandardType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="ProductName" type="ProductNameType">
        <xsd:element minOccurs="0" name="UOM" type="core:UOMType">
        <xsd:element minOccurs="0" name="ComparableUOM" type="core:UOMType">
        <xsd:element minOccurs="0" name="ComparableUOMConversionFactor" type="xsd:decimal">
        <xsd:element minOccurs="0" name="Manufacturer" type="ManufacturerType">
        <xsd:element minOccurs="0" name="ManuPartNumber" type="xsd:string">
        <xsd:element minOccurs="0" name="LeadTime" type="xsd:decimal">
        <xsd:element minOccurs="0" name="LeadTimeUOM" type="core:UOMType">
        <xsd:element minOccurs="0" name="ValidFrom" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ValidUntil" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="CountryOfOrigin" type="core:CountryType">
        <xsd:element minOccurs="0" name="MinOrder" type="xsd:decimal">
        <xsd:element minOccurs="0" name="LotSize" type="xsd:decimal">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="ShortDescription" type="ShortDescriptionType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="LongDescription" type="LongDescriptionType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="CatalogContract" type="CatalogContractType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="ProductAttachment" type="ProductAttachmentType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="RelatedProduct" type="RelatedProductType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="ObjectAttribute" type="ObjectAttributeType">
    </xsd:sequence>
    <xsd:attribute name="Type" type="ProductTypeCodedType" use="optional" default="Good">
</xsd:complexType>


simpleType definition: ProductTypeCodedType

ProductTypeCodedType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other
    • Good
    • Service

[^]Code Fragment

    <xsd:simpleType name="ProductTypeCodedType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Good">
        <xsd:enumeration value="Service">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: ProductVendorDataType

ProductVendorDataType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Imported Namespaces:
    • rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( VendorIDRef[xsd:string]? , VendorPartNumber[xsd:string]? , LeadTime[xsd:string]? , LeadTimeUOM[core:UOMType]? , CatalogContract[CatalogContractType]? , MinOrder[xsd:int]? , ProductPrice[ProductPriceType]* )

    Attribute: Name: PartnerRef, Type: xsd:IDREF, Use: 'required'

    Description: ProductVendorDataType holds the data specific to a particular product vendor. The product vendor is identified using the PartRef attribute.

    Elements:

    • VendorIDRef - is the vendor's identification. This is a value that can be returned to uniquely identify who the vendor (or supplier) of this product with this set of prices is. The use of this element is encouraged over the use of the codetagstartPartnerRefcodetagend attribute.
    • VendorPartNumber - contains the vendor's part number.
    • LeadTime - provides the lead time required when ordering the product described, from the particular vendor. Time is expressed in number of days unless otherwise specified in codetagstartLeadTimeUOMcodetagend.
    • LeadTimeUOM - supplies the time unit of measure for the product's lead time.
    • CatalogContract - holds the contract information specific to the vendor identified in codetagstartPartnerRefcodetagend.
    • MinOrder - gives the minimum order for the specified vendor, expressed in terms of the product's codetagstartUOMcodetagend.
    • ProductPrice - supplies the price for the specified vendor.
    Attributes:
    • PartnerRef

[^]Code Fragment

    <xsd:complexType name="ProductVendorDataType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="VendorIDRef" type="xsd:string">
        <xsd:element minOccurs="0" name="VendorPartNumber" type="xsd:string">
        <xsd:element minOccurs="0" name="LeadTime" type="xsd:string">
        <xsd:element minOccurs="0" name="LeadTimeUOM" type="core:UOMType">
        <xsd:element minOccurs="0" name="CatalogContract" type="CatalogContractType">
        <xsd:element minOccurs="0" name="MinOrder" type="xsd:int">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="ProductPrice" type="ProductPriceType">
    </xsd:sequence>
    <xsd:attribute name="PartnerRef" type="xsd:IDREF" use="required">
</xsd:complexType>


complexType definition: RelatedProductType

RelatedProductType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: Extension of type: xsd:string

    Attribute:Name: TargetType, Type: TargetTypeCodeType, Default: 'Component'

    Description: RelatedProductType allows the catalog to describe relationships between products, both by identifying the related product, and by explaining what type of relationship is being indicated. The content of this element should be the product ID of the related product.

    Attributes:

    • TargetType -

[^]Code Fragment

    <xsd:complexType name="RelatedProductType">
    <xsd:simpleContent>
        <xsd:extension base="xsd:string">
            <xsd:attribute name="TargetType" type="TargetTypeCodeType" use="optional" default="Component">
        </xsd:extension>
    </xsd:simpleContent>
</xsd:complexType>


simpleType definition: ScalarTypeCodeType

ScalarTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • String - String
    • Integer - Integer
    • Numeric - Numeric
    • Currency - Currency
    • Date - Date
    • Enumeration - Enumeration

[^]Code Fragment

    <xsd:simpleType name="ScalarTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="String">
        <xsd:enumeration value="Integer">
        <xsd:enumeration value="Numeric">
        <xsd:enumeration value="Currency">
        <xsd:enumeration value="Date">
        <xsd:enumeration value="Enumeration">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: SchemaCategoryRefListType

SchemaCategoryRefListType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( CategoryIDRef[xsd:string]+ )

    Description: SchemaCategoryRefListType is a list of references to the schema categories of which this product is an instance of. The use of this element is encouraged over the use of the SchemaCategoryRef attribute. NOTE: this is a multiple inheritance model. The order of the categories establishes precedence, the list being ordered in descending precedence. This is most important in determining which class an undeclared ObjectAttribute used in the CatalogData section is added to.

    Elements:

    • CategoryIDRef - if this has the same value as the CategoryID of a SchemaCategory, it implies that Product is an instance of that SchemaCategory.

[^]Code Fragment

    <xsd:complexType name="SchemaCategoryRefListType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="CategoryIDRef" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: SchemaCategoryType

SchemaCategoryType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( CategoryID[xsd:string] , ParentCategoryRefList[ParentCategoryRefListType]? , CategoryName[CategoryNameType]* , ShortDescription[ShortDescriptionType]* , LongDescription[LongDescriptionType]* , CategoryAttribute[CategoryAttributeType]* )

    Description: SchemaCategoryType contains a list of categories. One or more SchemaCategory elements are used to describe the contents of the Schema taxonomy. Should not be present if there is a SchemaSource element supplied to identify an external schema.

    Elements:

    • CategoryID - is a schema-unique identification for the category. The use of this element is encouraged over the use of the CategoryID attribute.
    • ParentCategoryRefList - is a list of CatalogIDRefs for schema categories which are proper superclasses of this category, and from which this category inherits attributes. The use of this element is encouraged over the use of the ParentCategoryRef XML IDREFS attribute. No value for this implies that this category is a sub-category of Product. Hence, ultimately, every category is a sub-category of Product. NOTE: this is a multiple inheritance model. The order of the categories establishes precedence, the list being ordered in descending precedence. This is most important in determing which class an undeclared ObjectAttribute used in the CatalogData section is added to.
    • CategoryName - contains the name of the category as given by its creator.
    • ShortDescription - is a short description of the category. There may be more than one ShortDescription element to allow for internationalized content, which is effected by use of the xml:lang attribute. xml:lang must contain a value that is a valid RFC 1766 language code, and defaults to en (for "English") if not present.
    • LongDescription - is a long description of the category. There may be more than one LongDescription element to allow for internationalized content, which is effected by use of the xml:lang attribute. xml:lang must contain a value that is a valid RFC 1766 language code. If not specified in DefaultLanguage or in a specific element, the value is assumed to be en for "English."
    • CategoryAttribute - is an attribute list definition.

[^]Code Fragment

    <xsd:complexType name="SchemaCategoryType">
    <xsd:sequence>
        <xsd:element name="CategoryID" type="xsd:string">
        <xsd:element minOccurs="0" name="ParentCategoryRefList" type="ParentCategoryRefListType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="CategoryName" type="CategoryNameType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="ShortDescription" type="ShortDescriptionType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="LongDescription" type="LongDescriptionType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="CategoryAttribute" type="CategoryAttributeType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ShortDescriptionType

ShortDescriptionType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: Extension of type: xsd:string

    Attribute:Ref: xml:lang, Default: 'en'

    Description: ShortDescriptionType holds a short textual description. Has xml:lang attribute so there can be more than one ShortDescription in multiple languages. xml:lang must contain valid RFC 1766 language code.

    Attributes:

    • xml:lang

[^]Code Fragment

    <xsd:complexType name="ShortDescriptionType">
    <xsd:simpleContent>
        <xsd:extension base="xsd:string">
            <xsd:attribute ref="xml:lang" use="optional" default="en">
        </xsd:extension>
    </xsd:simpleContent>
</xsd:complexType>


Simple Types:

BuyerSupplierCodeType
CatalogAudienceCodeType
PartnerRelationshipCodeType
ProductIDStandardCodeType
ProductTypeCodedType
ScalarTypeCodeType
TargetTypeCodeType


complexType definition: SupplierAccountInformationType

SupplierAccountInformationType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( SupplierAccount[SupplierAccountType]+ )

    Description: SupplierAccountInformationType can provide a within-catalog unique name for an account associated with a particular Buyer, that has a specific pricing rule associated with it. This supports supplier/buyer relationships that may have more than one pricing agreement as well as those suppliers which only have a single pricing agreement with each buyer.

    Elements:

    • SupplierAccount - links a supplier's id for an account that a buyer may purchase against, and the buyer's TPID.

[^]Code Fragment

    <xsd:complexType name="SupplierAccountInformationType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="SupplierAccount" type="SupplierAccountType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: SupplierAccountType

SupplierAccountType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( Action[ActionType]? , SupplierAccountID[xsd:string]? , ( BuyerIdentifier[core:IdentifierType] | IsPublicAccount[IsPublicAccountType] ) , PriceCatalogIDRef[xsd:string]* )

    Description: SupplierAccountType links a supplier's ID for an account that a buyer may purchase against, and the buyer's TPID.

    Elements:

    • Action - indicates the the type of action to be performed on the supplier account. Add, Replace, Update and Delete are acceptable values and no value implies the action is Add. The extent of the update semantics is restricted to membership in this list.
    • SupplierAccountID - is an identifier for referencing the prices defined under a particular purchasing agreement or contract. NOTE: the ID is the key so there is only one association between a particular Buyer and a particular SupplierAccountID. NOTE: if the ID is not specified, it defaults to the "NULL" id, which is also considered a unique ID (subsequent SupplierAccount entries with no ID are assumed to reference the same SupplierAccount, even though it is nameless). The "null" id was allowed primarily to accommodate the declaration of a PriceCatalog set as being the one available to anyone, as opposed to those available via a negotiated agreement between the supplier and a particular buyer, in which case a supplier account id would be established.
    • BuyerIdentifier - identifies the buyer.
    • IsPublicAccount - is a empty element meaning that all prices in the PriceCatalog(s) with PriceCatalogIDRef(s) are available to the public
    • PriceCatalogIDRef - references a PriceCatalog defined in the PricingInformation

[^]Code Fragment

    <xsd:complexType name="SupplierAccountType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="Action" type="ActionType">
        <xsd:element minOccurs="0" name="SupplierAccountID" type="xsd:string">
        <xsd:choice>
            <xsd:element name="BuyerIdentifier" type="core:IdentifierType">
            <xsd:element name="IsPublicAccount" type="IsPublicAccountType">
        </xsd:choice>
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="PriceCatalogIDRef" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: TargetTypeCodeType

TargetTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Component - Component
    • Substitute - Substitute
    • Alternative - Alternate
    • Accessory - Accessory

[^]Code Fragment

    <xsd:simpleType name="TargetTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Component">
        <xsd:enumeration value="Substitute">
        <xsd:enumeration value="Alternative">
        <xsd:enumeration value="Accessory">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: ValidateAttributesType

ValidateAttributesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content:

    Description: ValidateAttributesType is an element whose presence indicates that the category attributes should be validated.

[^]Code Fragment

    <xsd:complexType name="ValidateAttributesType">


complexType definition: VisibilityOfBuyerType

VisibilityOfBuyerType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Imported Namespaces:
    • rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( BuyerContactName[xsd:boolean]? , ContactPhoneNumber[xsd:boolean]? , ContactMobile[xsd:boolean]? , ContactFaxNumber[xsd:boolean]? , ContactEmail[xsd:boolean]? , AlternativeBuyerContactName[xsd:boolean]? , AlternativeContactPhoneNumber[xsd:boolean]? , AlternativeContactMobile[xsd:boolean]? , AlternativeContactFaxNumber[xsd:boolean]? , AlternativeContactEmail[xsd:boolean]? )

    Description: VisibilityOfBuyerType indicates if the buyer should be visible to the suppliers. If this element is not present then the buyer details are not visible to the suppliers.

    Elements:

    • BuyerContactName - indicates if the buyers contact name can be accessed by the suppliers. True - visible. False - not visible.
    • ContactPhoneNumber - indicates if the buyers contact phone number can be accessed by the suppliers. True - visible. False - not visible.
    • ContactMobile - indicates if the buyers mobile number can be accessed by the suppliers. True - visible. False - not visible.
    • ContactFaxNumber - indicates if the buyers fax number can be accessed by the suppliers. True - visible. False - not visible.
    • ContactEmail - indicates if the buyers contact email can be accessed by the suppliers. True - visible. False - not visible.
    • AlternativeBuyerContactName - indicates if the buyers alternative contact name can be accessed by the suppliers. True - visible. False - not visible.
    • AlternativeContactPhoneNumber - indicates if the buyers alternative contact phone number can be accessed by the suppliers. True - visible. False - not visible.
    • AlternativeContactMobile - indicates if the buyers alternative mobile number can be accessed by the suppliers. True - visible. False - not visible.
    • AlternativeContactFaxNumber - indicates if the buyers alternative fax number can be accessed by the suppliers. True - visible. False - not visible.
    • AlternativeContactEmail - indicates if the buyers alternative contact email can be accessed by the suppliers. True - visible. False - not visible.

[^]Code Fragment

    <xsd:complexType name="VisibilityOfBuyerType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="BuyerContactName" type="xsd:boolean">
        <xsd:element minOccurs="0" name="ContactPhoneNumber" type="xsd:boolean">
        <xsd:element minOccurs="0" name="ContactMobile" type="xsd:boolean">
        <xsd:element minOccurs="0" name="ContactFaxNumber" type="xsd:boolean">
        <xsd:element minOccurs="0" name="ContactEmail" type="xsd:boolean">
        <xsd:element minOccurs="0" name="AlternativeBuyerContactName" type="xsd:boolean">
        <xsd:element minOccurs="0" name="AlternativeContactPhoneNumber" type="xsd:boolean">
        <xsd:element minOccurs="0" name="AlternativeContactMobile" type="xsd:boolean">
        <xsd:element minOccurs="0" name="AlternativeContactFaxNumber" type="xsd:boolean">
        <xsd:element minOccurs="0" name="AlternativeContactEmail" type="xsd:boolean">
    </xsd:sequence>
</xsd:complexType>


complexType definition: VisibilityRulesType

VisibilityRulesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/catalog/v1_0/catalog.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( VisibilityIndicator[xsd:boolean]? , VisibilityOfComments[xsd:boolean]? , VisibilityOfAmounts[xsd:boolean]? , VisibilityOfQuantities[xsd:boolean]? , VisibilityOfParticipants[xsd:boolean]? )

    Description: VisibilityRulesType indicates the visibility level of the auction. If the information is not provided, then the assumption is made that the auction is public and that all values are visible.

    Elements:

    • VisibilityIndicator - is a general indicator to specify whether or not the auction is public or private.
    • VisibilityOfComments - indicates if an auction participant can access the comments of other participants.
    • VisibilityOfAmounts - indicates if an auction participant can access the bid amounts of other participants.
    • VisibilityOfQuantities - indicates if an auction participant can access the bid quantities of other participants.
    • VisibilityOfParticipants - indicates if an auction participant can access the identities of other participants.

[^]Code Fragment

    <xsd:complexType name="VisibilityRulesType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="VisibilityIndicator" type="xsd:boolean">
        <xsd:element minOccurs="0" name="VisibilityOfComments" type="xsd:boolean">
        <xsd:element minOccurs="0" name="VisibilityOfAmounts" type="xsd:boolean">
        <xsd:element minOccurs="0" name="VisibilityOfQuantities" type="xsd:boolean">
        <xsd:element minOccurs="0" name="VisibilityOfParticipants" type="xsd:boolean">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: AcademicTitleCodeType

AcademicTitleCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the academic title of the user.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • Prof - Professor
    • Dr - Doctor
    • Magister - Master
    • Phd - Doctorate
    • MBA - Master of Business Administration
    • BA - Bachellor of Arts

[^]Code Fragment

    <xsd:simpleType name="AcademicTitleCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Prof">
        <xsd:enumeration value="Dr">
        <xsd:enumeration value="Magister">
        <xsd:enumeration value="Phd">
        <xsd:enumeration value="MBA">
        <xsd:enumeration value="BA">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: AcademicTitleType

AcademicTitleType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( AcademicTitleCoded[AcademicTitleCodeType] , AcademicTitleCodedOther[xsd:string]? )

    Description: AcademicTitleType contains the academic title of the user, e.g. Dr.

    Elements:

    • AcademicTitleCoded - provides the tile of an individual relating to their academic qualifications.
    • AcademicTitleCodedOther - is used to provide a non-standard AcademicTitleCode. This element is mandatory if the value of AcademicTitleCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="AcademicTitleType">
    <xsd:sequence>
        <xsd:element name="AcademicTitleCoded" type="AcademicTitleCodeType">
        <xsd:element minOccurs="0" name="AcademicTitleCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: AccountAssignmentType

AccountAssignmentType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( AccountAssignmentID[xsd:string]? , AccountAssignmentName[xsd:string]? , AccountAssignmentValue[xsd:string]? )

    Description: AccountAssignmentType provides detailed account assignment information referring to items of internal documents.

    Elements:

    • AccountAssignmentID - is the item number of account assignment information.
    • AccountAssignmentName - is the name of the account assignment.
    • AccountAssignmentValue - is the value of the account assignment identified by the account assignment name.

[^]Code Fragment

    <xsd:complexType name="AccountAssignmentType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="AccountAssignmentID" type="xsd:string">
        <xsd:element minOccurs="0" name="AccountAssignmentName" type="xsd:string">
        <xsd:element minOccurs="0" name="AccountAssignmentValue" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: AccountDetailType

AccountDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( AccountID[xsd:string] , SecondaryAccountID[xsd:string]? , IBAN[IBANType]? , AccountControlKey[xsd:string]? , AccountTypeCoded[AccountTypeCodeType] , AccountTypeCodedOther[xsd:string]? , AccountName1[xsd:string] , AccountName2[xsd:string]? , Currency[CurrencyType]? , AccountReferences[ListOfReferenceCodedType]? )

    Description: AccountDetailType contains information pertinent to identifying an account within a financial institution.

    Elements:

    • AccountID - specifies the account number or identifier for the account.
    • SecondaryAccountID - specifies a secondary account number to identify the account.
    • IBAN - specifies an IBAN number (International Bank Account Number).
    • AccountControlKey - specifies the control number to uniquely identify the account at the financial institution.
    • AccountTypeCoded - contains a code qualifying the type of account.
    • AccountTypeCodedOther - is used to provide a non-standard AccountTypeCode. This element is mandatory if the value of AccountTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • AccountName1 - specifies the main account holder of the account.
    • AccountName2 - specifies a secondary name/holder on the account.
    • Currency - specifies the currency that applies to the account.
    • AccountReferences - contains a list of coded references to specify an identifier or name associated with the account.

[^]Code Fragment

    <xsd:complexType name="AccountDetailType">
    <xsd:sequence>
        <xsd:element name="AccountID" type="xsd:string">
        <xsd:element minOccurs="0" name="SecondaryAccountID" type="xsd:string">
        <xsd:element minOccurs="0" name="IBAN" type="IBANType">
        <xsd:element minOccurs="0" name="AccountControlKey" type="xsd:string">
        <xsd:element name="AccountTypeCoded" type="AccountTypeCodeType">
        <xsd:element minOccurs="0" name="AccountTypeCodedOther" type="xsd:string">
        <xsd:element name="AccountName1" type="xsd:string">
        <xsd:element minOccurs="0" name="AccountName2" type="xsd:string">
        <xsd:element minOccurs="0" name="Currency" type="CurrencyType">
        <xsd:element minOccurs="0" name="AccountReferences" type="ListOfReferenceCodedType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: AccountTypeCodeType

AccountTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other
    • NewBusinessAccount
    • GroupNumber
    • PolicyNumber
    • MoneyMarketFund
    • RetirementAccountVestedInterestatMarketValue
    • RetirementAccountVestedInterestNetCashValue
    • IndividualRetirementAccount-IRA-VestedInterestatMarketValue
    • IndividualRetirementAccount-IRA-VestedInterestNetCashValue
    • CorporateControlledRetirementAccountVestedInterest
    • TimeDeposit
    • CheckingAccount
    • Stock
    • Bond
    • LifeInsuranceFaceValue
    • RetirementAccount-VestedInterest
    • BusinessAccount
    • TrustFundAccount
    • StocksandBondsAccount
    • LifeInsuranceAccount-NetCashValue
    • EmployeeRetirementAccount-401K
    • Agency
    • Application
    • BrokerageAccount
    • ChargeBackAccountforReturns
    • CreditCard
    • CashManagement
    • DemandDeposit
    • DebitCard
    • ExistingCarrier
    • ReturnItemsonDemandDepositAccount
    • ReturnItemsonSavingsAccount
    • Savings
    • AgencyLocationCode
    • Annuity
    • ControlledDisbursementMasterAccount
    • ControlledDisbursementSubAccount
    • CreditUnion
    • EnrichedPlanContractNumber
    • Long-termDisabilityPolicyNumber
    • MutualFund
    • PrimaryBank
    • RelationshipSummaryAccount
    • Safekeeping-CustodyAccount
    • ZeroBalanceMasterAccount
    • ZeroBalanceAffiliateAccount

[^]Code Fragment

    <xsd:simpleType name="AccountTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="NewBusinessAccount">
        <xsd:enumeration value="GroupNumber">
        <xsd:enumeration value="PolicyNumber">
        <xsd:enumeration value="MoneyMarketFund">
        <xsd:enumeration value="RetirementAccountVestedInterestatMarketValue">
        <xsd:enumeration value="RetirementAccountVestedInterestNetCashValue">
        <xsd:enumeration value="IndividualRetirementAccount-IRA-VestedInterestatMarketValue">
        <xsd:enumeration value="IndividualRetirementAccount-IRA-VestedInterestNetCashValue">
        <xsd:enumeration value="CorporateControlledRetirementAccountVestedInterest">
        <xsd:enumeration value="TimeDeposit">
        <xsd:enumeration value="CheckingAccount">
        <xsd:enumeration value="Stock">
        <xsd:enumeration value="Bond">
        <xsd:enumeration value="LifeInsuranceFaceValue">
        <xsd:enumeration value="RetirementAccount-VestedInterest">
        <xsd:enumeration value="BusinessAccount">
        <xsd:enumeration value="TrustFundAccount">
        <xsd:enumeration value="StocksandBondsAccount">
        <xsd:enumeration value="LifeInsuranceAccount-NetCashValue">
        <xsd:enumeration value="EmployeeRetirementAccount-401K">
        <xsd:enumeration value="Agency">
        <xsd:enumeration value="Application">
        <xsd:enumeration value="BrokerageAccount">
        <xsd:enumeration value="ChargeBackAccountforReturns">
        <xsd:enumeration value="CreditCard">
        <xsd:enumeration value="CashManagement">
        <xsd:enumeration value="DemandDeposit">
        <xsd:enumeration value="DebitCard">
        <xsd:enumeration value="ExistingCarrier">
        <xsd:enumeration value="ReturnItemsonDemandDepositAccount">
        <xsd:enumeration value="ReturnItemsonSavingsAccount">
        <xsd:enumeration value="Savings">
        <xsd:enumeration value="AgencyLocationCode">
        <xsd:enumeration value="Annuity">
        <xsd:enumeration value="ControlledDisbursementMasterAccount">
        <xsd:enumeration value="ControlledDisbursementSubAccount">
        <xsd:enumeration value="CreditUnion">
        <xsd:enumeration value="EnrichedPlanContractNumber">
        <xsd:enumeration value="Long-termDisabilityPolicyNumber">
        <xsd:enumeration value="MutualFund">
        <xsd:enumeration value="PrimaryBank">
        <xsd:enumeration value="RelationshipSummaryAccount">
        <xsd:enumeration value="Safekeeping-CustodyAccount">
        <xsd:enumeration value="ZeroBalanceMasterAccount">
        <xsd:enumeration value="ZeroBalanceAffiliateAccount">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: ActionValueCodeType

ActionValueCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the action taken by the application processing the data.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Add - Add the element given, and specified sub-elements, if there's no existing element that matches on it's key. If there is a matching, existing element, the sub-element values given replace the current sub-element if that sub-element is single-valued. If it's multi-valued, then add another value to the existing set of values for that sub-element. If no value is given for the sub-element of an existing element, the previous value (if any) is left intact.
    • Update - Similar to an Add, but with two key differences: there must be an existing element that matches on it's key (otherwise it's an error); and existing values are replaced, regardless of whether they're defined as single-valued or multi-valued sub-elements. Again, if no value is given for the sub-element of an existing element, the previous value (if any) is left intact.
    • Delete - If there's an existing element that matches on it's key values, delete the existing element and all of it's sub-elements from the catalog. References to the deleted item are not removed. The latter is an important distinction - if a Product is removed, it's pricing persists, and if re-introduced it will suddenly have pricing, though none's apparently been specified.
    • Replace - If there's an existing element that matches on it's key values, delete it and add the values for the current definition as the new value for the element. If there's no existing definition, just add this new value.

[^]Code Fragment

    <xsd:simpleType name="ActionValueCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Add">
        <xsd:enumeration value="Update">
        <xsd:enumeration value="Delete">
        <xsd:enumeration value="Replace">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: ActualPaymentStatusCodeType

ActualPaymentStatusCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the actual status of a payment.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • PaidInFull - The invoice is completely paid
    • PartPaid - The invoice has been partly, but not completely, paid
    • NotPaid - The invoice has not been paid
    • OverPaid - More than the full value of the invoice has been paid
    • FreeOfCharge - The invoice must not be paid although tax payments may be due

[^]Code Fragment

    <xsd:simpleType name="ActualPaymentStatusCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="PaidInFull">
        <xsd:enumeration value="PartPaid">
        <xsd:enumeration value="NotPaid">
        <xsd:enumeration value="OverPaid">
        <xsd:enumeration value="FreeOfCharge">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: ActualPaymentStatusType

ActualPaymentStatusType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ActualPaymentStatusCoded[ActualPaymentStatusCodeType]? , ActualPaymentStatusCodedOther[xsd:string]? )

    Description: ActualPaymentStatusType contains information relating to the payment status of the line item.

    Elements:

    • ActualPaymentStatusCoded - is a code specifying the actual status of a payment.
    • ActualPaymentStatusCodedOther - is used to provide a non-standard ActualPaymentStatusCode. This element is mandatory if the value of ActualPaymentStatusCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="ActualPaymentStatusType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ActualPaymentStatusCoded" type="ActualPaymentStatusCodeType">
        <xsd:element minOccurs="0" name="ActualPaymentStatusCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ActualPaymentType

ActualPaymentType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PaymentAmount[PaymentAmountType] , PaymentDate[xsd:dateTime] , PaymentMean[PaymentMeanType] , PaymentRecord[PaymentRecordType]? , OtherPaymentInfo[xsd:string]? )

    Description: ActualPaymentType contains detailed information on amounts, date, mean, method, card information and references relating to the ActualPayment.

    Elements:

    • PaymentAmount - contains information relating to a payment.
    • PaymentDate - holds the date the payment was made.
    • PaymentMean - contains information about a particular payment method that is used.
    • PaymentRecord - contains a record of the type of payment instrument or other method used to make the payment.
    • OtherPaymentInfo - contains any free form text pertinent to the payment information. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information, holds additional information or reference information about the actual payment made.

[^]Code Fragment

    <xsd:complexType name="ActualPaymentType">
    <xsd:sequence>
        <xsd:element name="PaymentAmount" type="PaymentAmountType">
        <xsd:element name="PaymentDate" type="xsd:dateTime">
        <xsd:element name="PaymentMean" type="PaymentMeanType">
        <xsd:element minOccurs="0" name="PaymentRecord" type="PaymentRecordType">
        <xsd:element minOccurs="0" name="OtherPaymentInfo" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: AgencyCodeType

AgencyCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the agency responsible for a codelist. This codelist is derived from EDIFACT 3055 (Code list responsible agency code) and X12 559 (Agency Qualifier Code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • AAMVA - American Association of Motor Vehicle Administrators
    • ABCD-TheMicrocomputerIndustryAssociation - ABCD-TheMicrocomputerIndustryAssociation
    • ACGIH - American Conference of Government Industrial Hygienists
    • ACORD - Agency Company Organization for Research and Development
    • AdvertisingIndustry - Advertising Industry
    • AECMA - A code to identify the Association Europeen des Constructeurs de Materiel Aeropsatial (European Association of Aerospace Products Manufacturers) as an authorizing agency for code lists.
    • AIHA - American Industrial Hygiene Association
    • AirTransportAssociationOfAmerica - Air Transport Association of America
    • Alabama
    • Alaska
    • AluminumAssociation - Aluminum Association
    • AmericanApparelManufacturersAssociation - American Apparel Manufacturers Association
    • AmericanFurnitureManufacturersAssociation - American Furniture Manufacturers Association
    • AmericanIronAndSteelInstitute - American Iron and Steel Institute
    • AmericanLandTitleAssociation - American Land Title Association
    • AmericanMedicalAssociation - American Medical Association
    • AmericanPaperInstitute - American Paper Institute
    • AmericanPetroleumInstitute - American Petroleum Institute
    • APWAAndOCSI - American Public Works Association (APWA) One Call Systems International (OCSI)
    • AmericanSocietyForAutomationInPharmacy - American Society for Automation in Pharmacy
    • AmericanTextileManufacturersInstitute - American Textile Manufacturers Institute
    • AmericanTruckingAssociations - American Trucking Associations
    • ANSIAccreditedStandardsCommittee - ANSI Accredited Standards Committee, X12
    • Arizona
    • Arkansas
    • ASME - American Society of Mechanical Engineers
    • AssignedByBuyerOrBuyersAgent - Assigned by buyer or buyer's agent
    • AssignedByCarrier - Codes assigned by the carrier.
    • AssignedByDistributor - Assigned by distributor
    • AssignedByManufacturer - Assigned by manufacturer
    • AssignedByMarketPlace - Assigned by Market Place
    • AssignedByNationalTradeAgency - The code list is from a national agency.
    • AssignedByOwnerOfOperation - Assigned by owner of operation (e.g. used in construction).
    • AssignedByPartyOriginatingTheMessage - Codes assigned by the party originating the message.
    • AssignedBySellerOrSellersAgent - Assigned by seller or seller's agent
    • AssignedByTransportCompany - Codes assigned by a transport company.
    • ASTM - American Society for Testing and Materials
    • AT - Austrian Federal Railways
    • AT-GeldausgabeautomatenServiceGesellschaftMBH - Description to be provided.
    • AT-AustrianCustoms - Austrian Customs
    • AT-AustrianPTT - Austrian PTT
    • AT-VerbandOesterreichischerBankenUndBankiers - Austrian bankers association.
    • AU-ACOS - Australian Chamber of Shipping: National organization for the maritime industry in Australia
    • AU-ADA - Australian Dental Association
    • AU-AIHW - Australian Institute of Health and Welfare
    • AU-APCA - Australian Payments Clearing Association
    • AU-AQIS - Australian Quarantine and Inspection Service
    • AU-AustrianCustomsService - Australian Customs Service.
    • AU-DOH - Australian Department of Health
    • AU-HIC - Health Insurance Commission
    • AU-LIFA - Life Insurance Federation of Australia.
    • AU-NCCH - AustralianNational Centre for Classification in Health
    • AU-ROA - Railways of Australia - Maintains code lists which are accepted by Australian government railways.
    • AU-SAA - Standards Association of Australia.
    • AU-Tradegate - Electronic Commerce Australia
    • AWS - American Welding Society
    • AYSA - AmericanYarn Spinners Association
    • BE - Belgian National Railway Company
    • BE-BelgianBankersAssociation - Belgian Bankers Association
    • BE-BelgianCustoms - Belgian Customs
    • BE-BelgianMinistryOfFinance - VAT numbers.
    • Bellcore - Bell Communications Research
    • BG - Bulgaria State Railway
    • BIC - Bureau International des Containeurs - The container industry's international organization responsible for the issuance of container-related codes.
    • BookIndustrySystemsAdvisoryCommittee - Book Industry Systems Advisory Committee
    • BR-BancoCentralDoBrazil - Self-explanatory.
    • BR-MAAndRAAAndLIMNETAndRINET - Joint venture between BRMA (Brokers and Reinsurance Markets Association) / RAA (Reinsurance Association of America) - LIMNET (London Insurance Market Network) - RINET (Reinsurance and Insurance Network)
    • CA-CPA - CA-Canadian Payment Association
    • CA-CSIO - Centre for Study of Insurance Operations in Canada
    • California
    • CaliforniaLandTitleAssociation - California Land Title Association
    • CanadianFreightClassification - Canadian Freight Classification
    • CarbideManufacturers - Carbide Manufacturers
    • CA-RevenueCanadaCustomsAndExcise - Revenue Canada, Customs and Excise
    • CAS - Chemical Abstract Services
    • CA-SCC - CA-Standards Council of Canada
    • CCC - Customs Co-operation Council
    • CEC - Commission of the European Communities
    • CECDGXIIID5 - (Commission of the European Communities), DG/XIII-D-5
    • CECDGXXI01 - (Computerization within Customs area).
    • CECDGXXIB1 - Description to be provided.
    • CECDGXXXIV - Statistical Office of the European Communities: e.g.Geomenclature
    • CEFIC - Conseil Europeen des Federations de l'Industrie Chimique - EDI project for chemical industry
    • CH - Swiss Federal Railways
    • CH-AdministrationFederaleDesContributions - Indirect taxation (e.g. turn-over/sales taxes)
    • CH-AssociationSuisseCodeDesArticles - Association suisse code des articles, Swiss article numbering association
    • CH-Carbura - Centrale suisse pour l'importation de carburants et combustibles liquides (Oil products)
    • CH-CentraleSuissePourLImportationDuCharbon - Coal
    • CH-DirectionGeneraleDesDouanes - Customs (incl. ISO alpha 2 country code)
    • CH-DivisionDesImportationsEtExportations - Import and export licences, OFAEE
    • CH-EntrepriseDesPTT - Entreprise des PTT
    • CH-MinistryOfTaxationCentralCustomsAndTaxAdministration - Danish Customs administration
    • CH-OfficeFiduciaireDesImportateursDeDenreesAlimentaires - Foodstuff
    • CH-SwissSecuritiesClearingCorporation - Swiss Securities Clearing Corporation
    • CH-TelekursAG - Telekur AG
    • CIDX - Chemical Industry Data Exchange
    • CIECA - Collision Industry ElectronicCommerce Association
    • CodeAssignedByTheOrganizationThatIsTheUltimateDestinationOfTheTransactionSet
    • CO-DIAN - The Colombian customs organization (Direccion de Impuestos y Aduanas Nacionales)
    • Colorado
    • CommanderRomeAirDevelopmentCenter - Commander-Rome Air Development Center
    • ConcordEDIGroup - An organisation of international transport equipment leasing companies and transport equipment repair providers responsible for promoting the use of EDI standards and standard business terms
    • Connecticut
    • ConventionsOnSADAndTransit - SAD = Single Administrative Document.
    • CopperAndBrassFabricatorsCouncil - Organization that assigns identification numbers for the copper and brass fabricators industry
    • CO-SBDC - Superintendencia Bancaria De Colombia-The organization which assigns identification numbers to financial institutions conducting business in Colombia
    • CountyDesignatorCode - County Designator Code
    • CSI - Construction Specification Institute
    • CSIExtended - Construction Specification Institute (CSI) Extended
    • CUSIP - Committee on Uniform Security Identification Procedures
    • CZ - Tchechian State Railway
    • DE - German Railway
    • DE-ARE - A German code for subsidiary unit number.
    • DE-BDI - Bundesverband der Deutschen Industrie e.V.: German industry association
    • DE-BIA - Berufsgenossenschaftliches Institut fuer Arbeitssicherheit: German institute of the workmen's compensation board
    • DE-BRD - Gesetzgeber der Bundesrepublik Deutschland - German legislature
    • DE-DIN - Deutsches Institut fuer Normung: German standardization institute
    • DE-DTAG - Deutsch Telekom AG- German telecommunication services agency.
    • DE-EDIBAU - National body responsible for the German codification in the construction area.
    • DefenseLogisticsAgency - Defense Logistics Agency
    • DE-GDV - Gesamtverband der Deutschen Versicherungswirtschaft e.V. (German Insurance Association)
    • DE-GermanBankersAssociation - German banker's association
    • DE-GermanCustoms - German Customs
    • DE-GMBH - Centrale fuer Coorganisation - German representation of European Article Numbering (EAN) International
    • Delaware
    • DepartmentOfAirForce - Department Of Air Force
    • DepartmentOfArmy - Department Of Army
    • DepartmentOfDefense - Department of Defense
    • DepartmentOfHealthAndHumanServices - Department of Health and Human Services
    • DepartmentOfHousingAndUrbanDevelopment - Department of Housing and Urban Development
    • DepartmentOfLabor - Department of Labor
    • DepartmentOfTheNavy - Department of the Navy
    • DE-SiemensAG - Siemens AG, Germany.
    • DE-VDA - Verband der Automobilindustrie E.V. - The national organisation representing Germany in ODETTE
    • DFAS - Defense Finance and Accounting Service
    • DIN - Deutsches Institutfur Normung
    • DirectionGeneraleDesDouanesEtDroitsIndirects - French Customs
    • DistrictOfColumbia
    • DK - Danish State Railways
    • DK-EAN - Denmark based European Article Numbering (EAN) Association
    • DK-MHA - Danish Ministry of Home Affairs
    • DK-NBH - Danish National Board of Health
    • DK-PBS - Pengainstitutternes Betalings Service
    • DunAndBradstreet - Dun and Bradstreet Corporation
    • EAN - International Article Numbering Association
    • Edibuild - EDI organization for companies in the construction industry
    • EdielNordicForum - A code to identify Ediel Nordic forum, which is an organization standardizing the use of EDI between the participants in the Nordic power market
    • EDIFICE - Standardized electronic commerce forum for companies with interests in computing, electronics, and telecommunications.
    • EDITEUR - European book sector electronic data interchange group - Code identifying the pan European user group for the book industry as an organization responsible for code values in the book industry.
    • EDITEX - Europe - EDI group for the textile and clothing industry.
    • EEG7 - European Expert Group 7 for Insurance.
    • EIDX - Electronics Industry Data Exchange
    • ElectricUtilities - Electric Utilities
    • ElectronicIndustriesAssociation - Electronic Industries Association
    • EPA - United States Environmental Protection Agency
    • ES - Spanish National Railway
    • ESDX - Environment and Safety Data Exchange
    • ES-ODETT - The national organisation representing Spain in ODETTE
    • ES-SpanishCustoms - Spanish Customs
    • EU-EDIFICAS - EDI for financial, informational, cost, accounting, auditing and social areas - Europe
    • EU-ETIS - European Telecommunications Informatics Services
    • EU-ROFER - European steel organisation - EDI project for the European steel industry
    • FASLINC - Fabric and Supplier Linkage Council
    • FCC - Federal Communications Commission
    • FCI - Factors Chain International
    • FDA - Food and Drug Administration
    • FederalGovernment - Federal Government
    • FederalHighwayAdministration - Federal Highway Administration
    • FI - Finish State Railway
    • FI-ATA - International Federation of Freight Forwarders Association
    • FI-FinnishCustoms - Finnish Customs
    • FI-TB - Finnish tax board
    • FI-TheFinnishBankersAssociation - Finnish Bankers Association
    • Florida
    • FR - French National Railway Company
    • FR-AGF - Assurances Generales de France
    • FR-ArvA - Value added network administering insurance code lists on behalf of the French insurance community
    • FR-BanqueDeFrance - Bank of France
    • FR-CFONB - National body responsible for the French codification in banking activity
    • FR-CNAMTS - Caisse Nationale de l'Assurance Maladie des Travailleurs Salaries
    • FR-DCP - Direction de la Comptabilite Publique-The French public accounting office
    • FR-DGI - Direction Generale des Impots
    • FR-EDIFCAS - EDI for financial, informational, cost, accounting, auditing and social areas - France
    • FR-EDIFRANCE - French association responsible for coordination and promotion of EDI application in France.
    • FR-EDITRANSPORT - French association developing EDI in transport logistics.
    • FR-GALIA - Groupement pour l'Amelioration des Liaisons dans l'Industrie Automobile - The national organisation representing France in ODETTE
    • FR-GENCOD - French organization responsible for EDI and Barcoding application in the retail sector.
    • FR-INSEE - Institut National de la Statistique et des Etudes Economiques
    • FR-RC - Federal Reserve Routing Code
    • GB - British Railways
    • GB-ABI - The Association of British Insurers
    • GB-ABTA - Association of British Travel Agencies
    • GB-ArticleNumberAssociationLimited - EAN bar-coding.
    • GB-AssociationForPaymentClearingServices - Association for payment clearing services
    • GB-BACSLimited
    • GB-CHAPSAndTownClearingCompanyLimited - Chaps and Town Clearing Company Limited
    • GB-FLEETNET - Association of fleet vehicle hiring and leasing companies in the UK.
    • GB-HMCustomsAndExcise
    • GB-ODETTE - The national organisation representing UK in ODETTE
    • GB-TheClearingHouse - The Clearing House
    • Georgia
    • GraphicsCommunicationsAssociation - Graphics Communications Association
    • GRE - Reference Group of Experts
    • GR-GreekCustoms - Greek Customs
    • GSA - General Services Administration
    • GTIN - Global Trade Identifier Number
    • Hawaii
    • HealthCareFinancingAdministration - Health Care Financing Administration
    • HealthInsuranceAssociationOfAmerica - Health Insurance Association of America
    • HK-HongKongCustoms - Hong Kong Customs
    • HU - Hungarian State Railway
    • IAPSO - United Nations Inter-Agency Procurement Services Office
    • IARC - International Agency for Research on Cancer
    • IATA - International Air Transport Association
    • ICAO - International Civil Aviation Organization
    • ICC - International Chamber of Commerce
    • ICS - International Chamber of Shipping
    • Idaho
    • IE - Irish Transport Company
    • IE-RevenueCommissionersCustomsAEProject
    • IL-IsraelCustoms - Israel Customs
    • Illinois
    • IMO - International Maritime Organization.
    • Indiana
    • InterContainerInterFrigo - European railway associated organisation involved in the transport of containers by rail
    • InternationalAssociationOfCorporationAdministrators - International Association of Corporation Administrators
    • InternationalAssociationOfIndustrialAccidentBoardsAndCommissions - International Association of Industrial Accident Boards and Commissions
    • InternationalStandardsOrganization - International Standards Organization
    • Iowa
    • IP - Institute of Petroleum
    • IronAndSteelStandardsCommitteeISM - Iron and Steel Standards CommitteeI SM
    • IS-IcelandCustoms - Iceland Customs
    • ISO - International Organization for Standardization
    • InsuranceServicesOffice - Insurance Services Office
    • IT - Italian State Railways
    • IT-AssociazioneBancariaItaliana - Italian bank association
    • IT-ItalianCustoms - Italian Customs
    • IT-ODETTE - The national organisation representing Italy in ODETTE
    • IT-SocieataInterbancariaPerLAutomazione
    • JapaneseStandardsAssociation - Japanese Standards Association
    • JP-JapanCustoms - Japan Customs
    • JP-MOT - Japanese Ministry of Transport.
    • JP-MSA - Japanese Maritime Safety Agency.
    • JP-NACCS - NACCS (Nippon Automated Cargo Clearance System Operation Organization Center - Operations organization of the automated cargo clearance system in Japan
    • Kansas
    • Kentucky
    • LeasingIndustry - Leasing Industry
    • LifeAndAnnuityIndustryCommittee - Life and Annuity Industry Committee
    • LI-LiechtensteinAuthority - Identification of relevant responsible agency for e.g. banking financial matters still pending
    • LloydsRegisterOfShipping - A register of ocean going vessels maintained by Lloyd's of London.
    • Louisiana
    • LU - Luxembourg National Railway Company
    • LU-LuxembourgCustoms - Luxembourg Customs
    • Maine
    • ManufacturingCompany - Manufacturing Company
    • Maryland
    • Massachusetts
    • MaterialSafetyDataSheetProvider - MaterialSafetyDataSheet(MSDS)Provider
    • Michigan
    • MilitaryStandard - Military Standard
    • Minnesota
    • Mississippi
    • Missouri
    • Montana
    • MortgageBankersAssociationOfAmerica - Mortgage Bankers Association of America
    • MY-DagangNet - Malaysia, Dagang.Net is a national clearing house which provide EDI/VAN service for customs, transport, retail and financial and other industries in the national and international trade.
    • MY-MalaysiaCentralBank - Malaysia Central Bank is a regulatory body set up by the government to charge with promoting economic monetary and credit condition favourable to commercial and industrial activity.
    • MY-MalaysiaCustomsAndExcise - Malaysia Royal Customs and Excise.
    • NACE - National Association Of Corrosion Engineers
    • NAGS - National Auto Glass Specification
    • NationalAlcoholBeverageControlAssociation - National Alcohol Beverage Control Association
    • NationalAssociationOfBusinessAndEducationalRadio - National Association of Business and Educational Radio
    • NationalBusinessFormsAssociation - National Business Forms Association
    • NationalCenterforStateCourts - National Center for State Courts
    • NationalCottonCouncilOfAmerica - National Cotton Council Of America
    • NationalCouncilOnCompensationInsurance - National Council on Compensation Insurance
    • NationalRetailMerchantsAssociation - National Retail Merchants Association
    • NationalWholesaleDruggistsAssociation - National Wholesale Druggists Association
    • NATO - A code to identify the North Atlantic Treaty Organization (NATO) as an authorizing agency for code lists.
    • NaturalGasUtilities - Natural Gas Utilities
    • NCIC - National Crime Information Center
    • Nebraska
    • NEMA - National Electric Manufacturers Association
    • Nevada
    • NewHampshire
    • NewJersey
    • NewMexico
    • NewspaperAssociationOfAmerica - Newspaper Association of America
    • NewYork
    • NFPA - National Fire Protection Agency
    • NICB - National Insurance Crime Bureau
    • NIOSH - National Institute of Occupational Safety and Health
    • NL - Foundation Uniform Transport Code is the EDI organization for shippers, carriers, and other logistics service providers in the Netherlands.
    • NetherlandsRailways - Netherlands Railways
    • NL-BankGirocentraleBV
    • NL-BEANETBV
    • NL-EAN - Netherlands based European Article Numbering Association (EAN)
    • NL-InterpayCards - Interpay Cards
    • NL-InterpayGiraal - Interpay Giraal
    • NL-NetherlandsCustoms - NetherlandsCustoms
    • NL-ODETTE - The national organisation representing Netherlands in ODETTE
    • NorweigianStateRailway - Norwegian State Railway
    • NO - Enhetsregisteret ved Bronnoysundregisterne - The co-ordinating register for companies and business units of companies at the Bronnoysund register centre.
    • NO-NORPRO
    • NO-NorwegianBankersAssociation - Norweigian Bankers Association
    • NO-NorwegianCustoms - Norwegian Customs
    • NO-NorwegianInterbankResearchOrganization - Norweigian Interbank Research Organization
    • NorthAmerica-TelecommunicationsIndustryForum - Trade association representing telecommunications service providers, equipment manufacturers, suppliers to the industry and customers.
    • NorthCarolina
    • NorthDakota
    • NTP - National Toxicology Program
    • NZ-NewZealandCustoms - New Zealand Customs
    • ODETTE - Organization for Data Exchange through Tele-Transmission in Europe (European automotive industry project).
    • OfficeOfManagementAndBudget - Office of Management and Budget
    • OfficeOfWorkersCompensationPrograms - Office of Workers Compensation Programs
    • OfficeProducts - Office Products
    • Ohio
    • Oklahoma
    • OpticalIndustry - Optical Industry
    • Oregon
    • OSHA - United States Occupational Safety and Health Administration
    • Pennsylvania
    • PennsylvaniaCourts - Pennsylvania Courts
    • PL - Polish State Railway
    • PT - Portuguese Railways
    • PT-CB - Banco de Portugal - Portuguese Central Bank
    • PT-PortugueseCustoms - Portuguese Customs
    • PT-SIBS - Poruguese Sociedade Interbancaria de Servicos - Portuguese automated clearing house
    • RealEstateInformationIndustry - Real Estate Information Industry
    • RhodeIsland
    • RINET - Reinsurance and Insurance Network
    • RO - Rumanian State Railway
    • RU-BIC - Russian Bank Identification Code
    • RU-SFT - Society for Financial Telecommunications - Russian company representing the users of the Global Financial Telecommunication Network (GFTN)
    • SAE - Society of Automotive Engineers, Inc.
    • SA-SaudiArabiaCustoms - Saudi Arabia Customs
    • SE - Swedish State Railway
    • SE-CentralBank - Swedish central bank.
    • SE-ODETTE - The national organisation representing Scandinavian countries in ODETTE
    • SE-SvenskaBankfoereningen - Swedish bankers association.
    • SE-SwedishCustoms - Swedish Customs
    • ShippersAssociation - Code assigned by a shipper's association
    • SISAC - Serials Industry Systems Advisory Committee
    • SK - Slovakian State Railways
    • SouthCarolina
    • SouthDakota
    • StateAgencyAssigned - State Agency Assigned
    • StudentLoanGuarantor - Student Loan Guarantor
    • SWIFT - Society for Worldwide Interbank Financial Telecommunications s.c.
    • TALC - Textile Apparel Linkage Council
    • TelecommunicationsIndustry - Telecommunications Industry
    • TemporaryHelpIndustry - Temporary Help Industry
    • Tennessee
    • Texas
    • TexasLandTitleAssociation - Texas Land Title Association
    • TextileDistributorsAssociationInc - Textile Distributors Association, Inc.
    • TDCC-EDIA - Transportation Data Coordinating Committee:Electronic Data Interchange Association
    • TW-ChineseTaipeiCustoms - Chinese Taipei Customs - Customs authorities of Chinese Taipei responsible for collecting import duties and preventing smuggling.
    • TW-Trade-van - Trade-van is an EDI/VAN service centre for customs, transport, and insurance in national and international trade.
    • UCS - Uniform Code Council
    • UIC - International Union of Railways
    • UN - United Nations
    • UNECE - United Nations - Economic Commission for Europe
    • UNCTAD - UNCTAD (United Nations - Conference on Trade And Development)
    • UnitedStatesCourts - United States Courts
    • UnitedStatesMarineCorps - United States Marine Corps
    • UnitedStatesNuclearRegulatoryCommission - United States Nuclear Regulatory Commission
    • UPU - Universal Postal Union
    • US-AA - Aluminum Association
    • US-AAR - Association of American Railroads
    • US-ABA - American Bankers Association
    • US-AIAG - US-Automotive Industry Action Group
    • US-AirTransportAssociationOfAmerica - U.S.-based trade association representing the major North American scheduled airlines
    • US-AISI - American Iron and Steel Institute
    • US-AmericanPetroleumInstitute - US-based trade association representing oil and natural gas producers, shippers, refineries, marketers, etc
    • US-ANSIASCX12 - American National Standards Institute ASC X12.
    • US-API - American Paper Institute
    • US-ASTM - American Society of Testing and Materials
    • US-ATF - A code representing the United States Bureau of Alcohol, Tobacco, and Firearms, Department of Treasury (ATF)
    • US-BATF - United States Bureau of Alcohol, Tobacco and Firearms (BATF) Note: This code value will be removed effective with directory D.01A
    • US-BXA - A code representing the United States Bureau of Export Administration (BXA) under the Department of Commerce (DOC)
    • US-CHIPS - United States Clearing House Interbank Payment Systems
    • US-CIDX - Chemical Industry Data Exchange
    • US-CM - Carbide Manufacturers
    • US-COPAS - Council of Petroleum Accounting Society
    • US-DAndB - Dun and Bradstreet Corporation
    • US-DCI - US-Distribution Codes, INC.
    • US-DEA - US-Drug Enforcement Agency
    • US-DHHS - United States Department of Health and Human Services
    • US-DISA - Data Interchange Standards Association
    • US-DISCUS - United States Distilled Spirits Council of the United States (DISCUS)
    • US-DLMSO - The Defense Logistics Management Standards Office.
    • US-DOA - Department of Agriculture, United States federal agency.
    • US-DOD - The US Department of Defense.
    • US-DODAAC - Department Of Defense Active Agency Code
    • US-DOL - To identify the United States department of labour.
    • US-DOT - United States Department of Transportation.
    • US-DSAA - A code representing the United States Defense Security Assistance Agency (DSAA) under the Department of Defense (DOD)
    • US-EIA - Electronic Industry Association
    • US-FCC - Federal Communications Commission
    • US-FDA - Food and Drug Administration
    • US-FIPS - US-Federal Information Publishing Standard
    • US-FMC - US-Federal Maritime Commission
    • US-FWS - Fish and Wildlife Service
    • US-GSA - The US General Services Administration.
    • US-HBICC - Code identifying the United States Health Industry Business Communication Council
    • US-HI - United States health industry
    • US-HL7 - United States, electronic data interchange standards-making organization, Health Level 7
    • US-ISA - Codes assigned by the Information Systems Agreement (ISA) for use by its members.
    • US-MARAD - A code representing the United States Maritime Administration (MARAD) under the Department of Tranportation (DOT)
    • US-NABCA - United States National Alcohol Beverage Control Assocation (NABCA)
    • US-NAIC - National Association of Insurance Commissioners
    • USNationalCenterForHealthStatisticsCommissionOfProfessionalAndHospitalActivities - U.S. National Center for Health Statistics Commission of Professional and Hospital Activities
    • US-NationalMotorFreightClassificationAssociation - The organisation in the USA which is responsible for code maintenance in the trucking industry
    • US-NationalRetailFederation - The National Retail Federation is the trade association for the general merchandise retailing industry. In addition to providing support and education services, they also maintain and publish standard colour and size codes for the retail industry.
    • US-NCCMA - Account Analysis Codes
    • US-NIST - The US National Institute of Standards and Technology.
    • US-NRC - A code representing the United States Nuclear Regulatory Commission (NRC)
    • US-NWDA - National Wholesale Druggist Association
    • US-ODTC - A code representing the United States Office of Defense Trade Controls (ODTC) under the Department of State
    • US-OFAC - Office of Foreign Assets Control
    • US-OMB - Office of Management and Budget
    • US-StandardCarrierAlphaCode - Organisation maintaining the SCAC lists and transportation operating in North America
    • US-TDCC - United States Transportation Data Coordinating Committee
    • US-UCC - Uniform Code Council
    • US-UN-SPSC - United Nations Standard Products and Services Classification Association
    • US-UOP - United States Universal Oil Products
    • US-USCensusBureau - The Bureau of the Census of the U.S. Dept. of Commerce.
    • US-USCustomsService - U.S. Customs Service
    • US-USPS - United States Postal Service (USPS)
    • US-VA - The Department of Veterans Affairs.
    • US-VICS - Voluntary Inter-Industry Commerce Standards
    • US-WSSA - United States based Wine and Spirits Shippers Association
    • Utah
    • UtilityIndustryGroup - Utility Industry Group
    • Vermont
    • VICS - Voluntary Inter-Industry Commerce Standard (VICS) EDI
    • Virginia
    • Washington
    • WestVirginia
    • WHMIS - Canadian Workplace Hazardous Materials Information System
    • Wisconsin
    • Wyoming
    • DirectorGeneralOfCanada

[^]Code Fragment

    <xsd:simpleType name="AgencyCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="AAMVA">
        <xsd:enumeration value="ABCD-TheMicrocomputerIndustryAssociation">
        <xsd:enumeration value="ACGIH">
        <xsd:enumeration value="ACORD">
        <xsd:enumeration value="AdvertisingIndustry">
        <xsd:enumeration value="AECMA">
        <xsd:enumeration value="AIHA">
        <xsd:enumeration value="AirTransportAssociationOfAmerica">
        <xsd:enumeration value="Alabama">
        <xsd:enumeration value="Alaska">
        <xsd:enumeration value="AluminumAssociation">
        <xsd:enumeration value="AmericanApparelManufacturersAssociation">
        <xsd:enumeration value="AmericanFurnitureManufacturersAssociation">
        <xsd:enumeration value="AmericanIronAndSteelInstitute">
        <xsd:enumeration value="AmericanLandTitleAssociation">
        <xsd:enumeration value="AmericanMedicalAssociation">
        <xsd:enumeration value="AmericanPaperInstitute">
        <xsd:enumeration value="AmericanPetroleumInstitute">
        <xsd:enumeration value="APWAAndOCSI">
        <xsd:enumeration value="AmericanSocietyForAutomationInPharmacy">
        <xsd:enumeration value="AmericanTextileManufacturersInstitute">
        <xsd:enumeration value="AmericanTruckingAssociations">
        <xsd:enumeration value="ANSIAccreditedStandardsCommittee">
        <xsd:enumeration value="Arizona">
        <xsd:enumeration value="Arkansas">
        <xsd:enumeration value="ASME">
        <xsd:enumeration value="AssignedByBuyerOrBuyersAgent">
        <xsd:enumeration value="AssignedByCarrier">
        <xsd:enumeration value="AssignedByDistributor">
        <xsd:enumeration value="AssignedByManufacturer">
        <xsd:enumeration value="AssignedByMarketPlace">
        <xsd:enumeration value="AssignedByNationalTradeAgency">
        <xsd:enumeration value="AssignedByOwnerOfOperation">
        <xsd:enumeration value="AssignedByPartyOriginatingTheMessage">
        <xsd:enumeration value="AssignedBySellerOrSellersAgent">
        <xsd:enumeration value="AssignedByTransportCompany">
        <xsd:enumeration value="ASTM">
        <xsd:enumeration value="AT">
        <xsd:enumeration value="AT-GeldausgabeautomatenServiceGesellschaftMBH">
        <xsd:enumeration value="AT-AustrianCustoms">
        <xsd:enumeration value="AT-AustrianPTT">
        <xsd:enumeration value="AT-VerbandOesterreichischerBankenUndBankiers">
        <xsd:enumeration value="AU-ACOS">
        <xsd:enumeration value="AU-ADA">
        <xsd:enumeration value="AU-AIHW">
        <xsd:enumeration value="AU-APCA">
        <xsd:enumeration value="AU-AQIS">
        <xsd:enumeration value="AU-AustrianCustomsService">
        <xsd:enumeration value="AU-DOH">
        <xsd:enumeration value="AU-HIC">
        <xsd:enumeration value="AU-LIFA">
        <xsd:enumeration value="AU-NCCH">
        <xsd:enumeration value="AU-ROA">
        <xsd:enumeration value="AU-SAA">
        <xsd:enumeration value="AU-Tradegate">
        <xsd:enumeration value="AWS">
        <xsd:enumeration value="AYSA">
        <xsd:enumeration value="BE">
        <xsd:enumeration value="BE-BelgianBankersAssociation">
        <xsd:enumeration value="BE-BelgianCustoms">
        <xsd:enumeration value="BE-BelgianMinistryOfFinance">
        <xsd:enumeration value="Bellcore">
        <xsd:enumeration value="BG">
        <xsd:enumeration value="BIC">
        <xsd:enumeration value="BookIndustrySystemsAdvisoryCommittee">
        <xsd:enumeration value="BR-BancoCentralDoBrazil">
        <xsd:enumeration value="BR-MAAndRAAAndLIMNETAndRINET">
        <xsd:enumeration value="CA-CPA">
        <xsd:enumeration value="CA-CSIO">
        <xsd:enumeration value="California">
        <xsd:enumeration value="CaliforniaLandTitleAssociation">
        <xsd:enumeration value="CanadianFreightClassification">
        <xsd:enumeration value="CarbideManufacturers">
        <xsd:enumeration value="CA-RevenueCanadaCustomsAndExcise">
        <xsd:enumeration value="CAS">
        <xsd:enumeration value="CA-SCC">
        <xsd:enumeration value="CCC">
        <xsd:enumeration value="CEC">
        <xsd:enumeration value="CECDGXIIID5">
        <xsd:enumeration value="CECDGXXI01">
        <xsd:enumeration value="CECDGXXIB1">
        <xsd:enumeration value="CECDGXXXIV">
        <xsd:enumeration value="CEFIC">
        <xsd:enumeration value="CH">
        <xsd:enumeration value="CH-AdministrationFederaleDesContributions">
        <xsd:enumeration value="CH-AssociationSuisseCodeDesArticles">
        <xsd:enumeration value="CH-Carbura">
        <xsd:enumeration value="CH-CentraleSuissePourLImportationDuCharbon">
        <xsd:enumeration value="CH-DirectionGeneraleDesDouanes">
        <xsd:enumeration value="CH-DivisionDesImportationsEtExportations">
        <xsd:enumeration value="CH-EntrepriseDesPTT">
        <xsd:enumeration value="CH-MinistryOfTaxationCentralCustomsAndTaxAdministration">
        <xsd:enumeration value="CH-OfficeFiduciaireDesImportateursDeDenreesAlimentaires">
        <xsd:enumeration value="CH-SwissSecuritiesClearingCorporation">
        <xsd:enumeration value="CH-TelekursAG">
        <xsd:enumeration value="CIDX">
        <xsd:enumeration value="CIECA">
        <xsd:enumeration value="CodeAssignedByTheOrganizationThatIsTheUltimateDestinationOfTheTransactionSet">
        <xsd:enumeration value="CO-DIAN">
        <xsd:enumeration value="Colorado">
        <xsd:enumeration value="CommanderRomeAirDevelopmentCenter">
        <xsd:enumeration value="ConcordEDIGroup">
        <xsd:enumeration value="Connecticut">
        <xsd:enumeration value="ConventionsOnSADAndTransit">
        <xsd:enumeration value="CopperAndBrassFabricatorsCouncil">
        <xsd:enumeration value="CO-SBDC">
        <xsd:enumeration value="CountyDesignatorCode">
        <xsd:enumeration value="CSI">
        <xsd:enumeration value="CSIExtended">
        <xsd:enumeration value="CUSIP">
        <xsd:enumeration value="CZ">
        <xsd:enumeration value="DE">
        <xsd:enumeration value="DE-ARE">
        <xsd:enumeration value="DE-BDI">
        <xsd:enumeration value="DE-BIA">
        <xsd:enumeration value="DE-BRD">
        <xsd:enumeration value="DE-DIN">
        <xsd:enumeration value="DE-DTAG">
        <xsd:enumeration value="DE-EDIBAU">
        <xsd:enumeration value="DefenseLogisticsAgency">
        <xsd:enumeration value="DE-GDV">
        <xsd:enumeration value="DE-GermanBankersAssociation">
        <xsd:enumeration value="DE-GermanCustoms">
        <xsd:enumeration value="DE-GMBH">
        <xsd:enumeration value="Delaware">
        <xsd:enumeration value="DepartmentOfAirForce">
        <xsd:enumeration value="DepartmentOfArmy">
        <xsd:enumeration value="DepartmentOfDefense">
        <xsd:enumeration value="DepartmentOfHealthAndHumanServices">
        <xsd:enumeration value="DepartmentOfHousingAndUrbanDevelopment">
        <xsd:enumeration value="DepartmentOfLabor">
        <xsd:enumeration value="DepartmentOfTheNavy">
        <xsd:enumeration value="DE-SiemensAG">
        <xsd:enumeration value="DE-VDA">
        <xsd:enumeration value="DFAS">
        <xsd:enumeration value="DIN">
        <xsd:enumeration value="DirectionGeneraleDesDouanesEtDroitsIndirects">
        <xsd:enumeration value="DistrictOfColumbia">
        <xsd:enumeration value="DK">
        <xsd:enumeration value="DK-EAN">
        <xsd:enumeration value="DK-MHA">
        <xsd:enumeration value="DK-NBH">
        <xsd:enumeration value="DK-PBS">
        <xsd:enumeration value="DunAndBradstreet">
        <xsd:enumeration value="EAN">
        <xsd:enumeration value="Edibuild">
        <xsd:enumeration value="EdielNordicForum">
        <xsd:enumeration value="EDIFICE">
        <xsd:enumeration value="EDITEUR">
        <xsd:enumeration value="EDITEX">
        <xsd:enumeration value="EEG7">
        <xsd:enumeration value="EIDX">
        <xsd:enumeration value="ElectricUtilities">
        <xsd:enumeration value="ElectronicIndustriesAssociation">
        <xsd:enumeration value="EPA">
        <xsd:enumeration value="ES">
        <xsd:enumeration value="ESDX">
        <xsd:enumeration value="ES-ODETT">
        <xsd:enumeration value="ES-SpanishCustoms">
        <xsd:enumeration value="EU-EDIFICAS">
        <xsd:enumeration value="EU-ETIS">
        <xsd:enumeration value="EU-ROFER">
        <xsd:enumeration value="FASLINC">
        <xsd:enumeration value="FCC">
        <xsd:enumeration value="FCI">
        <xsd:enumeration value="FDA">
        <xsd:enumeration value="FederalGovernment">
        <xsd:enumeration value="FederalHighwayAdministration">
        <xsd:enumeration value="FI">
        <xsd:enumeration value="FI-ATA">
        <xsd:enumeration value="FI-FinnishCustoms">
        <xsd:enumeration value="FI-TB">
        <xsd:enumeration value="FI-TheFinnishBankersAssociation">
        <xsd:enumeration value="Florida">
        <xsd:enumeration value="FR">
        <xsd:enumeration value="FR-AGF">
        <xsd:enumeration value="FR-ArvA">
        <xsd:enumeration value="FR-BanqueDeFrance">
        <xsd:enumeration value="FR-CFONB">
        <xsd:enumeration value="FR-CNAMTS">
        <xsd:enumeration value="FR-DCP">
        <xsd:enumeration value="FR-DGI">
        <xsd:enumeration value="FR-EDIFCAS">
        <xsd:enumeration value="FR-EDIFRANCE">
        <xsd:enumeration value="FR-EDITRANSPORT">
        <xsd:enumeration value="FR-GALIA">
        <xsd:enumeration value="FR-GENCOD">
        <xsd:enumeration value="FR-INSEE">
        <xsd:enumeration value="FR-RC">
        <xsd:enumeration value="GB">
        <xsd:enumeration value="GB-ABI">
        <xsd:enumeration value="GB-ABTA">
        <xsd:enumeration value="GB-ArticleNumberAssociationLimited">
        <xsd:enumeration value="GB-AssociationForPaymentClearingServices">
        <xsd:enumeration value="GB-BACSLimited">
        <xsd:enumeration value="GB-CHAPSAndTownClearingCompanyLimited">
        <xsd:enumeration value="GB-FLEETNET">
        <xsd:enumeration value="GB-HMCustomsAndExcise">
        <xsd:enumeration value="GB-ODETTE">
        <xsd:enumeration value="GB-TheClearingHouse">
        <xsd:enumeration value="Georgia">
        <xsd:enumeration value="GraphicsCommunicationsAssociation">
        <xsd:enumeration value="GRE">
        <xsd:enumeration value="GR-GreekCustoms">
        <xsd:enumeration value="GSA">
        <xsd:enumeration value="GTIN">
        <xsd:enumeration value="Hawaii">
        <xsd:enumeration value="HealthCareFinancingAdministration">
        <xsd:enumeration value="HealthInsuranceAssociationOfAmerica">
        <xsd:enumeration value="HK-HongKongCustoms">
        <xsd:enumeration value="HU">
        <xsd:enumeration value="IAPSO">
        <xsd:enumeration value="IARC">
        <xsd:enumeration value="IATA">
        <xsd:enumeration value="ICAO">
        <xsd:enumeration value="ICC">
        <xsd:enumeration value="ICS">
        <xsd:enumeration value="Idaho">
        <xsd:enumeration value="IE">
        <xsd:enumeration value="IE-RevenueCommissionersCustomsAEProject">
        <xsd:enumeration value="IL-IsraelCustoms">
        <xsd:enumeration value="Illinois">
        <xsd:enumeration value="IMO">
        <xsd:enumeration value="Indiana">
        <xsd:enumeration value="InterContainerInterFrigo">
        <xsd:enumeration value="InternationalAssociationOfCorporationAdministrators">
        <xsd:enumeration value="InternationalAssociationOfIndustrialAccidentBoardsAndCommissions">
        <xsd:enumeration value="InternationalStandardsOrganization">
        <xsd:enumeration value="Iowa">
        <xsd:enumeration value="IP">
        <xsd:enumeration value="IronAndSteelStandardsCommitteeISM">
        <xsd:enumeration value="IS-IcelandCustoms">
        <xsd:enumeration value="ISO">
        <xsd:enumeration value="InsuranceServicesOffice">
        <xsd:enumeration value="IT">
        <xsd:enumeration value="IT-AssociazioneBancariaItaliana">
        <xsd:enumeration value="IT-ItalianCustoms">
        <xsd:enumeration value="IT-ODETTE">
        <xsd:enumeration value="IT-SocieataInterbancariaPerLAutomazione">
        <xsd:enumeration value="JapaneseStandardsAssociation">
        <xsd:enumeration value="JP-JapanCustoms">
        <xsd:enumeration value="JP-MOT">
        <xsd:enumeration value="JP-MSA">
        <xsd:enumeration value="JP-NACCS">
        <xsd:enumeration value="Kansas">
        <xsd:enumeration value="Kentucky">
        <xsd:enumeration value="LeasingIndustry">
        <xsd:enumeration value="LifeAndAnnuityIndustryCommittee">
        <xsd:enumeration value="LI-LiechtensteinAuthority">
        <xsd:enumeration value="LloydsRegisterOfShipping">
        <xsd:enumeration value="Louisiana">
        <xsd:enumeration value="LU">
        <xsd:enumeration value="LU-LuxembourgCustoms">
        <xsd:enumeration value="Maine">
        <xsd:enumeration value="ManufacturingCompany">
        <xsd:enumeration value="Maryland">
        <xsd:enumeration value="Massachusetts">
        <xsd:enumeration value="MaterialSafetyDataSheetProvider">
        <xsd:enumeration value="Michigan">
        <xsd:enumeration value="MilitaryStandard">
        <xsd:enumeration value="Minnesota">
        <xsd:enumeration value="Mississippi">
        <xsd:enumeration value="Missouri">
        <xsd:enumeration value="Montana">
        <xsd:enumeration value="MortgageBankersAssociationOfAmerica">
        <xsd:enumeration value="MY-DagangNet">
        <xsd:enumeration value="MY-MalaysiaCentralBank">
        <xsd:enumeration value="MY-MalaysiaCustomsAndExcise">
        <xsd:enumeration value="NACE">
        <xsd:enumeration value="NAGS">
        <xsd:enumeration value="NationalAlcoholBeverageControlAssociation">
        <xsd:enumeration value="NationalAssociationOfBusinessAndEducationalRadio">
        <xsd:enumeration value="NationalBusinessFormsAssociation">
        <xsd:enumeration value="NationalCenterforStateCourts">
        <xsd:enumeration value="NationalCottonCouncilOfAmerica">
        <xsd:enumeration value="NationalCouncilOnCompensationInsurance">
        <xsd:enumeration value="NationalRetailMerchantsAssociation">
        <xsd:enumeration value="NationalWholesaleDruggistsAssociation">
        <xsd:enumeration value="NATO">
        <xsd:enumeration value="NaturalGasUtilities">
        <xsd:enumeration value="NCIC">
        <xsd:enumeration value="Nebraska">
        <xsd:enumeration value="NEMA">
        <xsd:enumeration value="Nevada">
        <xsd:enumeration value="NewHampshire">
        <xsd:enumeration value="NewJersey">
        <xsd:enumeration value="NewMexico">
        <xsd:enumeration value="NewspaperAssociationOfAmerica">
        <xsd:enumeration value="NewYork">
        <xsd:enumeration value="NFPA">
        <xsd:enumeration value="NICB">
        <xsd:enumeration value="NIOSH">
        <xsd:enumeration value="NL">
        <xsd:enumeration value="NetherlandsRailways">
        <xsd:enumeration value="NL-BankGirocentraleBV">
        <xsd:enumeration value="NL-BEANETBV">
        <xsd:enumeration value="NL-EAN">
        <xsd:enumeration value="NL-InterpayCards">
        <xsd:enumeration value="NL-InterpayGiraal">
        <xsd:enumeration value="NL-NetherlandsCustoms">
        <xsd:enumeration value="NL-ODETTE">
        <xsd:enumeration value="NorweigianStateRailway">
        <xsd:enumeration value="NO">
        <xsd:enumeration value="NO-NORPRO">
        <xsd:enumeration value="NO-NorwegianBankersAssociation">
        <xsd:enumeration value="NO-NorwegianCustoms">
        <xsd:enumeration value="NO-NorwegianInterbankResearchOrganization">
        <xsd:enumeration value="NorthAmerica-TelecommunicationsIndustryForum">
        <xsd:enumeration value="NorthCarolina">
        <xsd:enumeration value="NorthDakota">
        <xsd:enumeration value="NTP">
        <xsd:enumeration value="NZ-NewZealandCustoms">
        <xsd:enumeration value="ODETTE">
        <xsd:enumeration value="OfficeOfManagementAndBudget">
        <xsd:enumeration value="OfficeOfWorkersCompensationPrograms">
        <xsd:enumeration value="OfficeProducts">
        <xsd:enumeration value="Ohio">
        <xsd:enumeration value="Oklahoma">
        <xsd:enumeration value="OpticalIndustry">
        <xsd:enumeration value="Oregon">
        <xsd:enumeration value="OSHA">
        <xsd:enumeration value="Pennsylvania">
        <xsd:enumeration value="PennsylvaniaCourts">
        <xsd:enumeration value="PL">
        <xsd:enumeration value="PT">
        <xsd:enumeration value="PT-CB">
        <xsd:enumeration value="PT-PortugueseCustoms">
        <xsd:enumeration value="PT-SIBS">
        <xsd:enumeration value="RealEstateInformationIndustry">
        <xsd:enumeration value="RhodeIsland">
        <xsd:enumeration value="RINET">
        <xsd:enumeration value="RO">
        <xsd:enumeration value="RU-BIC">
        <xsd:enumeration value="RU-SFT">
        <xsd:enumeration value="SAE">
        <xsd:enumeration value="SA-SaudiArabiaCustoms">
        <xsd:enumeration value="SE">
        <xsd:enumeration value="SE-CentralBank">
        <xsd:enumeration value="SE-ODETTE">
        <xsd:enumeration value="SE-SvenskaBankfoereningen">
        <xsd:enumeration value="SE-SwedishCustoms">
        <xsd:enumeration value="ShippersAssociation">
        <xsd:enumeration value="SISAC">
        <xsd:enumeration value="SK">
        <xsd:enumeration value="SouthCarolina">
        <xsd:enumeration value="SouthDakota">
        <xsd:enumeration value="StateAgencyAssigned">
        <xsd:enumeration value="StudentLoanGuarantor">
        <xsd:enumeration value="SWIFT">
        <xsd:enumeration value="TALC">
        <xsd:enumeration value="TelecommunicationsIndustry">
        <xsd:enumeration value="TemporaryHelpIndustry">
        <xsd:enumeration value="Tennessee">
        <xsd:enumeration value="Texas">
        <xsd:enumeration value="TexasLandTitleAssociation">
        <xsd:enumeration value="TextileDistributorsAssociationInc">
        <xsd:enumeration value="TDCC-EDIA">
        <xsd:enumeration value="TW-ChineseTaipeiCustoms">
        <xsd:enumeration value="TW-Trade-van">
        <xsd:enumeration value="UCS">
        <xsd:enumeration value="UIC">
        <xsd:enumeration value="UN">
        <xsd:enumeration value="UNECE">
        <xsd:enumeration value="UNCTAD">
        <xsd:enumeration value="UnitedStatesCourts">
        <xsd:enumeration value="UnitedStatesMarineCorps">
        <xsd:enumeration value="UnitedStatesNuclearRegulatoryCommission">
        <xsd:enumeration value="UPU">
        <xsd:enumeration value="US-AA">
        <xsd:enumeration value="US-AAR">
        <xsd:enumeration value="US-ABA">
        <xsd:enumeration value="US-AIAG">
        <xsd:enumeration value="US-AirTransportAssociationOfAmerica">
        <xsd:enumeration value="US-AISI">
        <xsd:enumeration value="US-AmericanPetroleumInstitute">
        <xsd:enumeration value="US-ANSIASCX12">
        <xsd:enumeration value="US-API">
        <xsd:enumeration value="US-ASTM">
        <xsd:enumeration value="US-ATF">
        <xsd:enumeration value="US-BATF">
        <xsd:enumeration value="US-BXA">
        <xsd:enumeration value="US-CHIPS">
        <xsd:enumeration value="US-CIDX">
        <xsd:enumeration value="US-CM">
        <xsd:enumeration value="US-COPAS">
        <xsd:enumeration value="US-DAndB">
        <xsd:enumeration value="US-DCI">
        <xsd:enumeration value="US-DEA">
        <xsd:enumeration value="US-DHHS">
        <xsd:enumeration value="US-DISA">
        <xsd:enumeration value="US-DISCUS">
        <xsd:enumeration value="US-DLMSO">
        <xsd:enumeration value="US-DOA">
        <xsd:enumeration value="US-DOD">
        <xsd:enumeration value="US-DODAAC">
        <xsd:enumeration value="US-DOL">
        <xsd:enumeration value="US-DOT">
        <xsd:enumeration value="US-DSAA">
        <xsd:enumeration value="US-EIA">
        <xsd:enumeration value="US-FCC">
        <xsd:enumeration value="US-FDA">
        <xsd:enumeration value="US-FIPS">
        <xsd:enumeration value="US-FMC">
        <xsd:enumeration value="US-FWS">
        <xsd:enumeration value="US-GSA">
        <xsd:enumeration value="US-HBICC">
        <xsd:enumeration value="US-HI">
        <xsd:enumeration value="US-HL7">
        <xsd:enumeration value="US-ISA">
        <xsd:enumeration value="US-MARAD">
        <xsd:enumeration value="US-NABCA">
        <xsd:enumeration value="US-NAIC">
        <xsd:enumeration value="USNationalCenterForHealthStatisticsCommissionOfProfessionalAndHospitalActivities">
        <xsd:enumeration value="US-NationalMotorFreightClassificationAssociation">
        <xsd:enumeration value="US-NationalRetailFederation">
        <xsd:enumeration value="US-NCCMA">
        <xsd:enumeration value="US-NIST">
        <xsd:enumeration value="US-NRC">
        <xsd:enumeration value="US-NWDA">
        <xsd:enumeration value="US-ODTC">
        <xsd:enumeration value="US-OFAC">
        <xsd:enumeration value="US-OMB">
        <xsd:enumeration value="US-StandardCarrierAlphaCode">
        <xsd:enumeration value="US-TDCC">
        <xsd:enumeration value="US-UCC">
        <xsd:enumeration value="US-UN-SPSC">
        <xsd:enumeration value="US-UOP">
        <xsd:enumeration value="US-USCensusBureau">
        <xsd:enumeration value="US-USCustomsService">
        <xsd:enumeration value="US-USPS">
        <xsd:enumeration value="US-VA">
        <xsd:enumeration value="US-VICS">
        <xsd:enumeration value="US-WSSA">
        <xsd:enumeration value="Utah">
        <xsd:enumeration value="UtilityIndustryGroup">
        <xsd:enumeration value="Vermont">
        <xsd:enumeration value="VICS">
        <xsd:enumeration value="Virginia">
        <xsd:enumeration value="Washington">
        <xsd:enumeration value="WestVirginia">
        <xsd:enumeration value="WHMIS">
        <xsd:enumeration value="Wisconsin">
        <xsd:enumeration value="Wyoming">
        <xsd:enumeration value="DirectorGeneralOfCanada">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: AgencyType

AgencyType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( AgencyCoded[AgencyCodeType] , AgencyCodedOther[xsd:string]? , AgencyDescription[xsd:string]? , CodeListIdentifierCoded[CodeListIdentifierCodeType]? , CodeListIdentifierCodedOther[xsd:string]? )

    Description: AgencyType identifies the organization and if necessary the codelist from which the identifier is assigned.

    Elements:

    • AgencyCoded - specifies the agency, company or organization responsible for issuing the codelist or identifiers.
    • AgencyCodedOther - is used to provide a non-standard AgencyCode. This element is mandatory if the value of AgencyCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • AgencyDescription - describes additional information needed to clarify the identification of the agency.
    • CodeListIdentifierCoded - contains a code qualifying the type of code list used.
    • CodeListIdentifierCodedOther - is used to provide a non-standard CodeListIdentifierCode. This element is mandatory if the value of CodeListIdentifierCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="AgencyType">
    <xsd:sequence>
        <xsd:element name="AgencyCoded" type="AgencyCodeType">
        <xsd:element minOccurs="0" name="AgencyCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="AgencyDescription" type="xsd:string">
        <xsd:element minOccurs="0" name="CodeListIdentifierCoded" type="CodeListIdentifierCodeType">
        <xsd:element minOccurs="0" name="CodeListIdentifierCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: AllowOrChargeIndicatorCodeType

AllowOrChargeIndicatorCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code indicates an allowance or charge for the specified service. This codelist is derived from EDIFACT 5463 (Allowance) and X12 248 (Allowance Or Charge Indicator)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • Allowance
    • Charge
    • AllowanceRequest
    • NoAllowanceOrCharge

[^]Code Fragment

    <xsd:simpleType name="AllowOrChargeIndicatorCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Allowance">
        <xsd:enumeration value="Charge">
        <xsd:enumeration value="AllowanceRequest">
        <xsd:enumeration value="NoAllowanceOrCharge">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: AllowOrChargeSummaryType

AllowOrChargeSummaryType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( TotalAllowOrCharge[TotalAllowOrChargeType]+ )

    Description: AllowOrChargeSummaryType contains the summary amounts, for each category of the allowance or charge.

    Elements:

    • TotalAllowOrCharge - contain the details of the summerized totals of the allowance or charge categorized by the AllowOrChargeDesc.

[^]Code Fragment

    <xsd:complexType name="AllowOrChargeSummaryType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="TotalAllowOrCharge" type="TotalAllowOrChargeType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: AllowOrChargeTreatmentCodeType

AllowOrChargeTreatmentCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the basis for the calculation of the allowance or charge at line item level.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • UnitPriceNet - AllowOrCharge based on UnitPrice, TotalValue is net of AllowOrCharge
    • UnitPriceGross - AllowOrCharge based on UnitPrice, TotalValue is gross of AllowOrCharge
    • SubTotalNet - AllowOrCharge based on TotalValue, TotalValue is net of AllowOrCharge

[^]Code Fragment

    <xsd:simpleType name="AllowOrChargeTreatmentCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="UnitPriceNet">
        <xsd:enumeration value="UnitPriceGross">
        <xsd:enumeration value="SubTotalNet">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: AllowOrChargeTreatmentType

AllowOrChargeTreatmentType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( AllowOrChargeTreatmentCoded[AllowOrChargeTreatmentCodeType] , AllowOrChargeTreatmentCodedOther[xsd:string]? )

    Description: AllowOrChargeTreatmentType contains information relating to the treatment of the allowance or charge.

    Elements:

    • AllowOrChargeTreatmentCoded - is a code specifying the basis of the line item-level AllowOrCharge, and whether the amounts are net or gross of AllowOrCharge.
    • AllowOrChargeTreatmentCodedOther - is used to provide a non-standard AllowOrChargeTreatmentCode. This element is mandatory if the value of AllowOrChargeTreatmentCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="AllowOrChargeTreatmentType">
    <xsd:sequence>
        <xsd:element name="AllowOrChargeTreatmentCoded" type="AllowOrChargeTreatmentCodeType">
        <xsd:element minOccurs="0" name="AllowOrChargeTreatmentCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: AllowOrChargeType

AllowOrChargeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( IndicatorCoded[IndicatorCodeType] , IndicatorCodedOther[xsd:string]? , BasisCoded[BasisCodeType]? , BasisCodedOther[xsd:string]? , MethodOfHandlingCoded[MethodOfHandlingCodeType] , MethodOfHandlingCodedOther[xsd:string]? , AllowOrChargeTreatment[AllowOrChargeTreatmentType]? , AllowanceOrChargeDescription[AllowOrChgDescType] , ValidityDates[ValidityDatesType]? , ( BasisQuantityRange[QuantityType] | BasisMonetaryRange[BasisMonetaryRangeType] )? , TypeOfAllowanceOrCharge[TypeOfAllowanceOrChargeType] , Tax[TaxType]* )

    Attribute:Name: SeqNo, Type: xsd:int, Default: '1'

    Description: AllowOrChargeType requests or identifies a service, promotion, allowance, or charge and specifies the amount or percentage for the service, promotion, allowance, or charge.

    Elements:

    • IndicatorCoded - identifies whether an allowance or a charge applies using a standard codelist. Allowances are considered to be discounts.
    • IndicatorCodedOther - is used to provide a non-standard IndicatorCode. This element is mandatory if the value of IndicatorCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • BasisCoded - defines on what basis the allowance or charge is calculated using a standard codelist.
    • BasisCodedOther - is used to specify a non-standard BasisCode. This element is mandatory when the value of BasisCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • MethodOfHandlingCoded - identifies how the allowance or charge will be settled using a standard codelist.
    • MethodOfHandlingCodedOther - is used to specify a non-standard MethodOfHandlingCode. This element is mandatory if the value of MethodOfHandlingCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • AllowOrChargeTreatment - contains information relating to the calculation of the allowance or charges and the calculation of the price.
    • AllowanceOrChargeDescription - describes the allowance or charge using references or free text.
    • ValidityDates - contains the dates between which the allowance or charge takes effect.
    • BasisQuantityRange - is the quantity range over which the allowance or charge applies.
    • BasisMonetaryRange - is the monetary range over which the allowance or charge applies.
    • TypeOfAllowanceOrCharge - is a container for the information on the type of allowance or charge. Only one method of calculating the allowance or charge can be specified.
    • Tax - is a container for tax levies on the allowance or charge if applicable.
    Attributes:
    • SeqNo - is the calculations sequence indicator and is used when multiple allowances and/or charges are applicable. If various allowances and/or charges percentages, quantities, monetary amounts or rates are applicable to the same base price, then the calculation sequence indicator will always equal one. If the various allowances and/or charges are applied against a fluctuating price (constantly changing because of the application of other allowances and/or charges) then the sequence of calculation is indicated using this data element. Note that several allowances or charges may have the same sequence number, indicating they are applied to the same quantity.

[^]Code Fragment

    <xsd:complexType name="AllowOrChargeType">
    <xsd:sequence>
        <xsd:element name="IndicatorCoded" type="IndicatorCodeType">
        <xsd:element minOccurs="0" name="IndicatorCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="BasisCoded" type="BasisCodeType">
        <xsd:element minOccurs="0" name="BasisCodedOther" type="xsd:string">
        <xsd:element name="MethodOfHandlingCoded" type="MethodOfHandlingCodeType">
        <xsd:element minOccurs="0" name="MethodOfHandlingCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="AllowOrChargeTreatment" type="AllowOrChargeTreatmentType">
        <xsd:element name="AllowanceOrChargeDescription" type="AllowOrChgDescType">
        <xsd:element minOccurs="0" name="ValidityDates" type="ValidityDatesType">
        <xsd:choice minOccurs="0">
            <xsd:element name="BasisQuantityRange" type="QuantityType">
            <xsd:element name="BasisMonetaryRange" type="BasisMonetaryRangeType">
        </xsd:choice>
        <xsd:element name="TypeOfAllowanceOrCharge" type="TypeOfAllowanceOrChargeType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="Tax" type="TaxType">
    </xsd:sequence>
    <xsd:attribute name="SeqNo" type="xsd:int" use="optional" default="1">
</xsd:complexType>


complexType definition: AllowOrChgDescType

AllowOrChgDescType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( RefID[xsd:string]? , ListOfDescription[xsd:string]? , ServiceCoded[ServiceCodeType] , ServiceCodedOther[xsd:string]? )

    Description: AllowOrChgDescType describes the allowance or charge using references or free text.

    Elements:

    • RefID - is a code number known to the supplier that identifies the charge or allowance.
    • ListOfDescription - is Description of the reference or charge.
    • ServiceCoded - identifies a type of service using a standard codelist.
    • ServiceCodedOther - is used to provide a non-standard ServiceCode This element is mandatory when the value of ServiceCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="AllowOrChgDescType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="RefID" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfDescription" type="xsd:string">
        <xsd:element name="ServiceCoded" type="ServiceCodeType">
        <xsd:element minOccurs="0" name="ServiceCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: AlphaNum3Type

AlphaNum3Type (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    is a string with a maximum length of 3

    Content: Restriction of base type xsd:string

      xsd:maxLength: 3

[^]Code Fragment

    <xsd:simpleType name="AlphaNum3Type">
    <xsd:restriction base="xsd:string">
        <xsd:maxLength value="3">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: AlphaNum6Type

AlphaNum6Type (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    is a string with a maximum length of 6

    Content: Restriction of base type xsd:string

      xsd:maxLength: 6

[^]Code Fragment

    <xsd:simpleType name="AlphaNum6Type">
    <xsd:restriction base="xsd:string">
        <xsd:maxLength value="6">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: AlphaNum9Type

AlphaNum9Type (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    is a string with a maximum length of 9

    Content: Restriction of base type xsd:string

      xsd:maxLength: 9

[^]Code Fragment

    <xsd:simpleType name="AlphaNum9Type">
    <xsd:restriction base="xsd:string">
        <xsd:maxLength value="9">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: AlphaNum10Type

AlphaNum10Type (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    is a string with a maximum length of 10

    Content: Restriction of base type xsd:string

      xsd:maxLength: 10

[^]Code Fragment

    <xsd:simpleType name="AlphaNum10Type">
    <xsd:restriction base="xsd:string">
        <xsd:maxLength value="10">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: AlphaNum14Type

AlphaNum14Type (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    is a string with a maximum length of 14

    Content: Restriction of base type xsd:string

      xsd:maxLength: 14

[^]Code Fragment

    <xsd:simpleType name="AlphaNum14Type">
    <xsd:restriction base="xsd:string">
        <xsd:maxLength value="14">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: AlphaNum17Type

AlphaNum17Type (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    is a string with a maximum length of 17

    Content: Restriction of base type xsd:string

      xsd:maxLength: 17

[^]Code Fragment

    <xsd:simpleType name="AlphaNum17Type">
    <xsd:restriction base="xsd:string">
        <xsd:maxLength value="17">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: AlphaNum20Type

AlphaNum20Type (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    is a string with a maximum length of 20

    Content: Restriction of base type xsd:string

      xsd:maxLength: 20

[^]Code Fragment

    <xsd:simpleType name="AlphaNum20Type">
    <xsd:restriction base="xsd:string">
        <xsd:maxLength value="20">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: AlphaNum30Type

AlphaNum30Type (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    is a string with a maximum length of 30

    Content: Restriction of base type xsd:string

      xsd:maxLength: 30

[^]Code Fragment

    <xsd:simpleType name="AlphaNum30Type">
    <xsd:restriction base="xsd:string">
        <xsd:maxLength value="30">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: AlphaNum35Type

AlphaNum35Type (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    is a string with a maximum length of 35

    Content: Restriction of base type xsd:string

      xsd:maxLength: 35

[^]Code Fragment

    <xsd:simpleType name="AlphaNum35Type">
    <xsd:restriction base="xsd:string">
        <xsd:maxLength value="35">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: AlphaNum40Type

AlphaNum40Type (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    is a string with a maximum length of 40

    Content: Restriction of base type xsd:string

      xsd:maxLength: 40

[^]Code Fragment

    <xsd:simpleType name="AlphaNum40Type">
    <xsd:restriction base="xsd:string">
        <xsd:maxLength value="40">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: AlphaNum50Type

AlphaNum50Type (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    is a string with a maximum length of 50

    Content: Restriction of base type xsd:string

      xsd:maxLength: 50

[^]Code Fragment

    <xsd:simpleType name="AlphaNum50Type">
    <xsd:restriction base="xsd:string">
        <xsd:maxLength value="50">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: AlphaNum60Type

AlphaNum60Type (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    is a string with a maximum length of 60

    Content: Restriction of base type xsd:string

      xsd:maxLength: 60

[^]Code Fragment

    <xsd:simpleType name="AlphaNum60Type">
    <xsd:restriction base="xsd:string">
        <xsd:maxLength value="60">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: AlphaNum70Type

AlphaNum70Type (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    is a string with a maximum length of 70

    Content: Restriction of base type xsd:string

      xsd:maxLength: 70

[^]Code Fragment

    <xsd:simpleType name="AlphaNum70Type">
    <xsd:restriction base="xsd:string">
        <xsd:maxLength value="70">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: AlphaNum80Type

AlphaNum80Type (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    is a string with a maximum length of 80

    Content: Restriction of base type xsd:string

      xsd:maxLength: 80

[^]Code Fragment

    <xsd:simpleType name="AlphaNum80Type">
    <xsd:restriction base="xsd:string">
        <xsd:maxLength value="80">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: AlphaNum256Type

AlphaNum256Type (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    Used for free-form notes

    Content: Restriction of base type xsd:string

      xsd:maxLength: 256

[^]Code Fragment

    <xsd:simpleType name="AlphaNum256Type">
    <xsd:restriction base="xsd:string">
        <xsd:maxLength value="256">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: AlphaNum512Type

AlphaNum512Type (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    is a string with a maximum length of 512

    Content: Restriction of base type xsd:string

      xsd:maxLength: 512

[^]Code Fragment

    <xsd:simpleType name="AlphaNum512Type">
    <xsd:restriction base="xsd:string">
        <xsd:maxLength value="512">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: AssociatedDocumentsType

AssociatedDocumentsType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ListOfDocumentLoose[ListOfPackageDocType]? , ListOfDocumentAttached[ListOfPackageDocType]? )

    Description: AssociatedDocumentsType identifies documents with information related to the hazardous packaging of this order.

    Elements:

    • ListOfDocumentLoose - identifies documents significant to the packaging that are not attached to the package.
    • ListOfDocumentAttached - identifies documents significant to the packaging that are attached to the package.

[^]Code Fragment

    <xsd:complexType name="AssociatedDocumentsType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ListOfDocumentLoose" type="ListOfPackageDocType">
        <xsd:element minOccurs="0" name="ListOfDocumentAttached" type="ListOfPackageDocType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: AttachmentActionCodeType

AttachmentActionCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    Identifies the action to be taken on the attachment for a response or change document.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom code
    • Add - The attachment is to be added.
    • Update - The attachment is to be updated.
    • Delete - The attachment is to be deleted.
    • NoChange - No action needed.

[^]Code Fragment

    <xsd:simpleType name="AttachmentActionCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Add">
        <xsd:enumeration value="Update">
        <xsd:enumeration value="Delete">
        <xsd:enumeration value="NoChange">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: AttachmentType

AttachmentType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( AttachmentActionCoded[AttachmentActionCodeType]? , AttachmentActionCodedOther[xsd:string]? , AttachmentPurpose[xsd:string]? , FileName[xsd:string]? , AttachmentTitle[xsd:string]? , AttachmentDescription[xsd:string]? , Language[LanguageType]? , MIMEType[xsd:string]? , AttachmentLocation[xsd:anyURI] )

    Description: AttachmentType is a container for specifying the attachments to a document.

    Elements:

    • AttachmentActionCoded - identifies the action to be taken on this attachment. This should only be used in response and change documents.
    • AttachmentActionCodedOther - is used to provide a non-standard AttachmentActionCoded. This element is mandatory if the value of AttachmentActionCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • AttachmentPurpose - explains the reason or purpose for attaching the message to the document or its intended use.
    • FileName - provides name of the attached file.
    • AttachmentTitle - displays the title of the attached document.
    • AttachmentDescription - describes the attachment.
    • Language - denotes the language the attachment is written in.
    • MIMEType - describes the format of the attachment.
    • AttachmentLocation - identifies the location of the attachment to the document.

[^]Code Fragment

    <xsd:complexType name="AttachmentType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="AttachmentActionCoded" type="AttachmentActionCodeType">
        <xsd:element minOccurs="0" name="AttachmentActionCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="AttachmentPurpose" type="xsd:string">
        <xsd:element minOccurs="0" name="FileName" type="xsd:string">
        <xsd:element minOccurs="0" name="AttachmentTitle" type="xsd:string">
        <xsd:element minOccurs="0" name="AttachmentDescription" type="xsd:string">
        <xsd:element minOccurs="0" name="Language" type="LanguageType">
        <xsd:element minOccurs="0" name="MIMEType" type="xsd:string">
        <xsd:element name="AttachmentLocation" type="xsd:anyURI">
    </xsd:sequence>
</xsd:complexType>


complexType definition: BaseItemReferencesType

BaseItemReferencesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( OffCatalogFlag[xsd:boolean]? , CatalogReference[CatalogReferenceType]? , ItemContractReferences[ListOfContractType]? , LineItemRequisitionReference[LineItemRequisitionReferenceType]? , BlanketOrderReference[ReferenceType]? , IsItemImmutable[xsd:boolean]? , ListOfCostCenter[ListOfCostCenterType]? , ListOfItemReferences[ListOfReferenceCodedType]? )

    Description: BaseItemReferencesType contains a collection of references which pertain to line items.

    Elements:

    • OffCatalogFlag - is a flag to denote whether the item was ordered from a catalog.
    • CatalogReference - references a catalog.
    • ItemContractReferences - list information about any contracts that apply to the line item.
    • LineItemRequisitionReference - identifies all cost center information, and if applicable, the split to each different cost center for the item.
    • BlanketOrderReference - references a blanket purchase order.
    • IsItemImmutable - flag to identify whether the item is immutable.
    • ListOfCostCenter - identifies all cost center information, and if applicable, the split to each different cost center for the item.
    • ListOfItemReferences - lists one or more references relating to the line item.

[^]Code Fragment

    <xsd:complexType name="BaseItemReferencesType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="OffCatalogFlag" type="xsd:boolean">
        <xsd:element minOccurs="0" name="CatalogReference" type="CatalogReferenceType">
        <xsd:element minOccurs="0" name="ItemContractReferences" type="ListOfContractType">
        <xsd:element minOccurs="0" name="LineItemRequisitionReference" type="LineItemRequisitionReferenceType">
        <xsd:element minOccurs="0" name="BlanketOrderReference" type="ReferenceType">
        <xsd:element minOccurs="0" name="IsItemImmutable" type="xsd:boolean">
        <xsd:element minOccurs="0" name="ListOfCostCenter" type="ListOfCostCenterType">
        <xsd:element minOccurs="0" name="ListOfItemReferences" type="ListOfReferenceCodedType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: BasicResponseCodeType

BasicResponseCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    The code contains a simple acknowledgment and is used convey whether a document, transaction, or action is Accepted or Rejected.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Accepted
    • Rejected
    • Other

[^]Code Fragment

    <xsd:simpleType name="BasicResponseCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Accepted">
        <xsd:enumeration value="Rejected">
        <xsd:enumeration value="Other">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: BasisCodeType

BasisCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code specifies the basis on which the allowance or charge is calculated.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom code
    • None - The figure provided for the allowance or charge is as stated and is not derived from calculation.
    • Quantity - The allowance or charge is based on a quantity.
    • Percent - The allowance or charge is based on a percentage.
    • MonetaryAmount - The allowance or charge is based on a monetary amount.

[^]Code Fragment

    <xsd:simpleType name="BasisCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="None">
        <xsd:enumeration value="Quantity">
        <xsd:enumeration value="Percent">
        <xsd:enumeration value="MonetaryAmount">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: BasisMonetaryRangeType

BasisMonetaryRangeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( MonetaryRange[MonetaryRangeType] | MonetaryLimit[MonetaryLimitType] )

    Description: BasisMonetaryRangeType is the monetary range over which the allowance or charge applies.

    Elements:

    • MonetaryRange - identifies a monetary range from which the allowance or charge will apply.
    • MonetaryLimit - is used to specify either a lower or upper bound, beyond which an allowance or charge will apply.

[^]Code Fragment

    <xsd:complexType name="BasisMonetaryRangeType">
    <xsd:choice>
        <xsd:element name="MonetaryRange" type="MonetaryRangeType">
        <xsd:element name="MonetaryLimit" type="MonetaryLimitType">
    </xsd:choice>
</xsd:complexType>


complexType definition: CardInfoType

CardInfoType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( CardNum[xsd:string] , CardAuthCode[xsd:string]? , CardRefNum[xsd:string]? , CardExpirationDate[xsd:dateTime]? , CardType[CardTypeCodeType]? , CardTypeOther[xsd:string]? , CardHolderName[xsd:string]? )

    Description: CardInfoType contains details of the credit or debit card that is being used for the payment.

    Elements:

    • CardNum - contains the identifying number of the credit or debit card.
    • CardAuthCode - contains the authorization number of the card.
    • CardRefNum - contains the customer reference number. This is used to enable transmission of customer specific information with the card.
    • CardExpirationDate - contains the date up to which the card is valid .
    • CardType - holds information on the issuer of the credit or debit card.
    • CardTypeOther - is used to provide a non-standard CardTypeCode. This element is mandatory if the value of CardType is 'Other'. These codes should not contain white space unless absolutely necessary.
    • CardHolderName - contains the name of the holder of the card.

[^]Code Fragment

    <xsd:complexType name="CardInfoType">
    <xsd:sequence>
        <xsd:element name="CardNum" type="xsd:string">
        <xsd:element minOccurs="0" name="CardAuthCode" type="xsd:string">
        <xsd:element minOccurs="0" name="CardRefNum" type="xsd:string">
        <xsd:element minOccurs="0" name="CardExpirationDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="CardType" type="CardTypeCodeType">
        <xsd:element minOccurs="0" name="CardTypeOther" type="xsd:string">
        <xsd:element minOccurs="0" name="CardHolderName" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: CardTypeCodeType

CardTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other
    • AMEX
    • VISA
    • MC
    • Discover
    • JCB
    • Diners

[^]Code Fragment

    <xsd:simpleType name="CardTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="AMEX">
        <xsd:enumeration value="VISA">
        <xsd:enumeration value="MC">
        <xsd:enumeration value="Discover">
        <xsd:enumeration value="JCB">
        <xsd:enumeration value="Diners">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: CargoClassificationType

CargoClassificationType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( NatureOfGoods[IdentifierType]? , OperationalTypeCoded[OperationalTypeCodeType]? , OperationalTypeCodedOther[xsd:string]? , TypeOfCargo[xsd:string]? )

    Description: CargoClassificationType contains different conventions for the classification and description of the goods being transported.

    Elements:

    • NatureOfGoods - is the high level nature of goods code issued by a specific maintenance agency. It is generally the first two digits of the HS code. This also defines the maintenance agency for the codelist (usually WCO World Customs Organization).
    • OperationalTypeCoded - identifies the classification of the cargo using a standard codelist.
    • OperationalTypeCodedOther - is used to provide a non-standard OperationalTypeCode. This element is mandatory if the value of OperationalTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • TypeOfCargo - is the commodity code that identifies at a high level what the items are. Set of understood description of goods. UN/ECE Rec 21 single digit type of cargo coded. Note; UN/ECE rec 21 is under revision and will need to update to recommendation 29

[^]Code Fragment

    <xsd:complexType name="CargoClassificationType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="NatureOfGoods" type="IdentifierType">
        <xsd:element minOccurs="0" name="OperationalTypeCoded" type="OperationalTypeCodeType">
        <xsd:element minOccurs="0" name="OperationalTypeCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="TypeOfCargo" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: CatalogReferenceType

CatalogReferenceType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( CatalogURL[xsd:anyURI] , CatalogID[xsd:string]? , CatalogItemID[xsd:string]? )

    Description: CatalogReferenceType is the the reference to the catalog.

    Elements:

    • CatalogURL - is the URL of the catalog.
    • CatalogID - is the ID of the catalog.
    • CatalogItemID - is the ID of the selected catalog item.

[^]Code Fragment

    <xsd:complexType name="CatalogReferenceType">
    <xsd:sequence>
        <xsd:element name="CatalogURL" type="xsd:anyURI">
        <xsd:element minOccurs="0" name="CatalogID" type="xsd:string">
        <xsd:element minOccurs="0" name="CatalogItemID" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: CategoryType

CategoryType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( CategoryID[xsd:string]? , StandardCategoryID[StandardCategoryIDType]? )

    Description: CategoryType contains the product category.

    Elements:

    • CategoryID - is the material group number.
    • StandardCategoryID - is the standard material group number in accordance with UNSPSC or eClass.

[^]Code Fragment

    <xsd:complexType name="CategoryType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="CategoryID" type="xsd:string">
        <xsd:element minOccurs="0" name="StandardCategoryID" type="StandardCategoryIDType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: ChangeTypeCodeType

ChangeTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other
    • AddAdditionalItems
    • Cancel
    • ChangeInDetailSection
    • ChangeInHeadingSection
    • ChangeOfDates
    • ChangeOfDateTerms
    • ChangesToItemLevelAllowanceAndCharges
    • ChangesToLineItems
    • ChangesToTotalLevelAllowanceAndCharges
    • CorrectionOfError
    • LineItemsNumbersChanged
    • PreviousPaymentDecisionReversed
    • PriceChange
    • QuantityDecrease
    • QuantityIncrease
    • ReplaceAllDates
    • ReplaceAllValues
    • ReplaceHeadingSectionOnly
    • ReplaceItemDetailAndSummaryOnly
    • ReplaceModeOfShipment
    • Reschedule
    • ReversalForCancellation
    • ReversalOfACredit
    • ReversalOfADebit
    • SellerInitiatedChange
    • TermsChangedForNewTerms

[^]Code Fragment

    <xsd:simpleType name="ChangeTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="AddAdditionalItems">
        <xsd:enumeration value="Cancel">
        <xsd:enumeration value="ChangeInDetailSection">
        <xsd:enumeration value="ChangeInHeadingSection">
        <xsd:enumeration value="ChangeOfDates">
        <xsd:enumeration value="ChangeOfDateTerms">
        <xsd:enumeration value="ChangesToItemLevelAllowanceAndCharges">
        <xsd:enumeration value="ChangesToLineItems">
        <xsd:enumeration value="ChangesToTotalLevelAllowanceAndCharges">
        <xsd:enumeration value="CorrectionOfError">
        <xsd:enumeration value="LineItemsNumbersChanged">
        <xsd:enumeration value="PreviousPaymentDecisionReversed">
        <xsd:enumeration value="PriceChange">
        <xsd:enumeration value="QuantityDecrease">
        <xsd:enumeration value="QuantityIncrease">
        <xsd:enumeration value="ReplaceAllDates">
        <xsd:enumeration value="ReplaceAllValues">
        <xsd:enumeration value="ReplaceHeadingSectionOnly">
        <xsd:enumeration value="ReplaceItemDetailAndSummaryOnly">
        <xsd:enumeration value="ReplaceModeOfShipment">
        <xsd:enumeration value="Reschedule">
        <xsd:enumeration value="ReversalForCancellation">
        <xsd:enumeration value="ReversalOfACredit">
        <xsd:enumeration value="ReversalOfADebit">
        <xsd:enumeration value="SellerInitiatedChange">
        <xsd:enumeration value="TermsChangedForNewTerms">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: ChangeTypeType

ChangeTypeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ChangeTypeCoded[ChangeTypeCodeType] , ChangeTypeCodedOther[xsd:string]? )

    Description: ChangeTypeType identifies the type of change in the ChangeOrder.

    Elements:

    • ChangeTypeCoded - signifies the type of change initiated by this ChangeOrder.
    • ChangeTypeCodedOther - is used to provide a non-standard ChangeTypeCode. This element is mandatory if the value of ChangeTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="ChangeTypeType">
    <xsd:sequence>
        <xsd:element name="ChangeTypeCoded" type="ChangeTypeCodeType">
        <xsd:element minOccurs="0" name="ChangeTypeCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: CodeListIdentifierCodeType

CodeListIdentifierCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the code list used. This code list is derived from EDIFACT 1131 (Code list identification code) and X12 1270 (Code list identifier code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • AcceptanceSiteCode
    • AccidentParameters
    • AccordEuropeenRelatifAuTransportInternationalDesMarchandises - A code list identifying dangerous goods for transport purposes.
    • AccountAnalysisCodes - Account service charges list.
    • AccountCharacteristicsCode
    • AccountingInformationIdentifier - Identification of a specific kind of accounting information.
    • AccountRating - Identifies the code list containing account rating types.
    • AccountRelationshipType - Identifies a code list containing types of account relationships.
    • AcquisitionAdviceCode
    • AcquisitionMethodCode
    • AcquisitionMethodSuffixCode
    • ActionCode
    • ActivitePrincipaleExerceeCode
    • Activity - Code identifying activities.
    • AdmittingDiagnosis
    • AdverseEventCode
    • AdverseEventOutcomeCode
    • AdviceCode
    • AgentStatusCode
    • AidTypeCode
    • AirCarrier
    • AirCommodityAndSpecialHandlingCode
    • AircraftMissionDesignSeriesCode
    • AirDimensionCode
    • AirportOrCity - As described and published by IATA.
    • AirportTerminal - Code identifying terminals or other sub-locations at airports.
    • AirTerminalIdentifierCode
    • AllegationTypeCode
    • AllPatientDiagnosisRelatedGroups
    • AllPatientRefinedDiagnosisRelatedGroups
    • AlterationLookup
    • AmbulatoryPatientGroups
    • AmendmentCode-Customs - Customs code indicating the reason for transmitting an amendment to Customs.
    • AmericanPsychiatricAssociationDiagnosticStatisticalManualOfMentalDisorders
    • AmericanSocietyForTestingAndMaterials
    • AntennaPolarization
    • AntennaStructureType
    • ApplicantClassificationType
    • ApplicantType
    • ApplicationAcknowledgementAndErrorCodes - A code list to identify acknowledgement and error codes applicable at the application level.
    • ApplicationErrorCode - A code list specifying application errors.
    • ApplicationQuestionIdentifier
    • ApplicationType
    • Area - Codes for specific geographic areas e.g. seas, straits, basins etc.
    • AreaOfOperation
    • ArrestReason
    • ArticleStatus - A code list defining the status of an article from the procurement point of view, e.g. new article, critical article, etc.
    • AssetDetails - Identifies a code list containing details of the asset types.
    • AssetRecurrence - Identifies the code list containing the types of recurrences of assets.
    • AssetStatusOrTransactionReportingCode
    • AssetTransferStatusCode
    • AssetType
    • AssignedByReceiver
    • AssignedBySender
    • AssociationOfAmericanRailroadsDeprescriptionDistributionList
    • AssociationOfAmericanRailroadsDeprescriptionExceptionList
    • AssociationOfAmericanRailroadsRateEdiNetworkErrorCode
    • AssociationOfAmericanRailroadsStandardTransportationCommodityCodeDescriptionQualifier
    • AssociationOfAmericanRailroadsStandardTransportationCommodityCodeMasterDescriptionInformation
    • AssociationOfAmericanRailroadsSwitchReleaseCodes
    • AssuredDeliveryIndicator
    • AuthorizationType
    • AutomatedClearingHouse - Identification of automated clearing houses.
    • AutomatedDataProcessingEquipmentIdentificationCode
    • AwardSource
    • BalanceTypeCode
    • BankAdministrationInstitute
    • BankBranchSortingIdentification - Identification of a specific branch of a bank.
    • BankIdentification - Code for identification of banks.
    • BankSecuritiesCode
    • BasisOfJurisdictionCode
    • BeneficiaryType
    • BidRejectionReason
    • BilledOfficeIndicatorCode
    • BillingAdviceCode
    • BillingStatusCode
    • BillOfLadingClauses - Code list identifying official clauses associated with bills of lading.
    • BoardOfInspectionAndSurveyPartLookup
    • BoardOfInspectionAndSurveyResponsibilityLookup
    • BoardOfInspectionAndSurveyShipLookup
    • BusinessAccountNumber - An identifying number or code assigned by issuing authorities to manage business activities.
    • BusinessChangeCode
    • BusinessClassification - Code list of business classifications.
    • BusinessCreditRating - Identifies a code list containing business credit rating types.
    • BusinessEntityFilingDetailCode
    • BusinessEntityFilingLocationCode
    • BusinessEntityFilingReportTypeCode
    • BusinessEntityFilingSecuritiesInformationCode
    • BusinessEntityFilingStatusCode
    • BusinessEntityFinancialInformationCode
    • BusinessEntityStatusCode
    • BusinessFunction
    • BusinessLegalStructureType - Identifies a code list containing business legal structure details.
    • BusinessSizeCode
    • BusinessType
    • CallSignDirectory - A directory of call signs assigned to transport vehicles.
    • CanadianInterEdi
    • CancellationReason
    • Carriers - Code list identifying carriers.
    • CaseDesignatorNumber
    • CaseOriginCode
    • CashDiscountStipulationCode
    • CauseLookup
    • CauseOfInjuryCode
    • CauseOfLossCode
    • CeilingTypeCode
    • CertificationRequirementsCode
    • Charge - Identification of a type of charge.
    • CitizenIdentification
    • City - Identifies a code list containing cities.
    • CitySubdivision - Identifies a code list containing subdivisions of a city.
    • ClaimPaymentRemarkCodes
    • ClaimType - Identifies the code list containing the claim types.
    • ClassOfOperation
    • ClassOfPitch
    • ClauseStatusType
    • ClearingCode - Identification of the responsible bank/clearing house which has cleared or is ordered to do the clearing.
    • ClearingHouseAutomatedPayment
    • ClearingHouseInterbankPaymentSystemParticipantsId - Participants identification of the automated clearing house of the New York Clearing House Association (CHIPS).
    • ClearingHouseInterbankPaymentSystemUniversalId - Universal identification of the automated clearing house of the New York Clearing House Association (CHIPS).
    • CoastDesignationCode
    • CognizanceSymbol
    • CollisionIndustryElectronicCommerceAssociation-Inspection
    • CollisionIndustryElectronicCommerceAssociation-LossCategory
    • CollisionIndustryElectronicCommerceAssociation-PointsOfImpact
    • CollisionIndustryElectronicCommerceAssociation-Profile
    • Combiterms1990 - Code to indicate the applicable Combiterm (1990 edition), used for the purpose of cost distribution between seller according to Incoterms 1990.
    • CommercialAndGovernmentEntity - List of codes identifying a commercial and government entity.
    • CommercialDriversLicense
    • CommercialVehicleOperationsCommodityCode
    • CommercialVehicleOperationsHazardousMaterialCode
    • CommercialVehicleOperationsInsurance
    • CommercialVehicleOperationsSafetyCode
    • CommercialVehicleOperationsStatusCode
    • CommercialVehicleRegistration
    • CommercialVehicleTax
    • CommercialVehicleTitle
    • CommercialVehicleType
    • Commodity - (7357) Code identifying types of goods for Customs, transport or statistical purposes (generic term).
    • CommunicationsRoutingIdentifierCode
    • CompanyUnitID
    • CompensationTypeCodes
    • CompetitiveCharacteristicsCode
    • ComplaintRequestCode
    • ComplianceReviewCode
    • ConclusionEvaluationCode
    • Condition
    • ConditionDetail - Identifies a code list containing condition details.
    • ConsigneesPremises - Facility controlled by the consignee of cargo.
    • ConsignorsPremises - Facility controlled by the consignor of cargo.
    • ConsolidationAndContainerizationPointCode
    • ConsolidationDetail - Identifies a code list containing consolidation details.
    • ConstructionMaterial - Identifies the code list containing types of materials used for construction.
    • ContactorAlertListReason
    • ContactStatusCode
    • ContainerAndRoll-OnOrRoll-OffNumberCode
    • ContainerTerminal - Codes for container terminal.
    • ContentIndicatorCode
    • Continent - Identifies a code list containing continents, that are any of the main continuous expanses of land.
    • Contract
    • ContractClose-OutGroupCode
    • ContractDeliveryDateRevisionAgentCode
    • ContractFundReportingTransactionCode
    • ContractorAlertListStatus
    • ContractorReviewListStatus
    • ContractPaymentDeductionOrCollectionCode
    • ContractPaymentLineItemStatusCode
    • ContractShipmentAdviceCode
    • ControlledInventoryItemCode
    • ControlUnitDesignCode
    • ControvertCode
    • ConvictionOffenseType
    • CooperativeLogisticsProgramSupportCode
    • CorporateFinancialFilingCriteria - Identifies a code list containing criteria for corporate financial filings.
    • CorporateStatementFilingCode
    • CorrectionOrChangeForStorageItemRecordsCode
    • Country - Identification of a country.
    • CountryAndActivityCode
    • CountryCode-FinanceAndAcquisition
    • CountrySub-Entity - (3228) Identification of country sub-entity (region, department, state, province) defined by appropriate authority.
    • County - Identifies a code list containing counties. A county is any of the territorial divisions of some countries, forming the chief unit of local administration.
    • CountyDesignatorCode
    • CouponAdjustmentReasonCode
    • CourtAppearanceTypeCode
    • CourtCaseStatusCode
    • CourtDispositionCode
    • CourtDocumentTypeCode
    • CourtIssuedWarrantTypeCode
    • CourtOfLawEventType - Identifies the code list containing the type of law events.
    • CourtOfLawType - Identifies a code list containing court of law types.
    • CourtPartyStatus
    • CourtPleadingTypeCode
    • CoverageCodeList
    • CoverageModifier
    • Cpa-CanadianPaymentsAssociation
    • CriminalCharge
    • CriminalChargeGrade
    • CriticalityDesignatorCode
    • CuisineTypeCode
    • CurrentAssetDetails - Identifies a code list containing details of the current asset types.
    • CurrentDentalTerminologyCode
    • CurrentLiabilityDetails - Identifies a code list containing the current liability types.
    • CurrentProceduralTerminologyCodes
    • CustomerMaintenanceLevelLookup
    • CustomerWithinCountryCode
    • CustomizedNoticeTypeCode
    • CustomsAreaOfTransaction - Customs code to indicate the different types of declarations according to the countries involved in the transaction (e.g. box 1/1 of SAD: inter EC Member States, EC-EFTA, EC-third countries, etc.).
    • CustomsDeclarationType - Customs code to indicate the type of declaration according to the different Customs procedures requested (e.g.: import, export, transit).
    • CustomsDomesticPortLocationCodes-USScheduleD - Code list containing Customs domestic port locations (United States Schedule D).
    • CustomsForeignPortLocationCodes-USScheduleK - Code list containing Customs foreign port locations (United States Schedule K).
    • CustomsIndicator - Customs code for circumstances where only an indication is needed.
    • CustomsInspectionType - A code to indicate the type of inspection performed by customs.
    • CustomsOffice - Customs administrative unit competent for the performance of Customs formalities, and the premises or other areas approved for the purpose by the competent authorities (CCC).
    • CustomsPreference - Customs code to identify a specific tariff preference.
    • CustomsProcedure - (9380) Customs code to identify goods which are subject to Customs control (e.g. home use, Customs warehousing, temporary admission, Customs transit).
    • CustomsReleaseNotification - Authorisation given by Customs to move the goods or not move the goods from the place of registration.
    • CustomsSimplifiedProcedure - Customs code to indicate the type of simplified Customs procedure requested by a declarant (CCC).
    • CustomsSpecialCodes - Customs code to indicate an exemption to a regulation or a special Customs treatment.
    • CustomsStatusOfGoods - Customs code to specify the status accorded by Customs to a consignment e.g. release without further formality, present supporting documents for inspection, etc (CCC).
    • CustomsTransitGuarantee - Customs code to identify the type of guarantee used in a transit movement.
    • CustomsTransitType - Customs code to indicate the different kinds of transit movement of the goods (e.g. Box 1/3 of the SAD).
    • CustomsValuationMethod - Customs code to identify the valuation method used to determine the dutiable value of the declared goods.
    • CustomsWarehouse - Identification and/or location of the Customs warehouse in which goods will be or have been deposited (CCC).
    • DangerousGoodsPackingType - Identification of package types for the description related to dangerous goods.
    • DataCategory - Identifies a code list containing data categories.
    • DateShippedOrReceivedCode
    • DebtorBusinessTypeCode
    • DebtorTypeCode
    • DefendantPleaTypeCode
    • DefensePrioritiesAndAllocationsSystemCode
    • DeferralLookup
    • DeficiencyCause
    • DeficiencyIndicator
    • DelinquencyIndicator
    • DeliverySourceCode
    • DeliveryTermCode
    • DemandCode
    • DemilitarizationCode
    • DepartmentOfDefenseIdentificationCode
    • DeviceAvailabilityCode
    • DeviceEvaluationCode
    • DeviceEventProblemCode
    • DeviceOperatorTypeCode
    • DeviceStatusCode
    • DeviceUsageCode
    • Diagnosis
    • DiagnosisEncounteredDuringExaminationAndInvestigationOfIndividualsAndPopulationsCode
    • DiagnosisRelatedGroup - Code list containing diagnosis related group classifications.
    • DiagnosticAndStatisticalManualOfMentalDisorders
    • DirectNumericalControlSystemCode
    • DisbursementStatusCode
    • Discrepancy
    • DiscrepancyAdviceCode
    • DiscrepancyCode
    • DiscrepancyIndicatorCode
    • DiscrepancyStatusOrDispositionCode
    • DisposalAuthorityCode
    • DisposalConditionCode
    • DistributionCode
    • DocumentIdentificationCode
    • DocumentRequestedByCustoms - Customs code to identify documents requested by Customs in an information interchange.
    • Dodaac-DepartmentOfDefenseActivityAddressCode - A code list containing codes assigned to operating military units to identify the name and address of the unit.
    • DomesticLineOfBusinessCode
    • DoseFormCode
    • DriverParameters
    • DriversLicenseWithdrawalBasis
    • DriversLicenseWithdrawalDueProcessStatus
    • DriversLicenseWithdrawalExtent
    • DriversLicenseWithdrawalReason
    • DriversLicenseWithdrawalType
    • DrugDetailCode
    • DrugStatusAdverseEventCode
    • DrugStatusCode
    • DumpingOrCountervailingAssessmentMethod - A code to identify the method used to determine the dumping or countervailing duty.
    • DumpingSpecification - Code list to identify types of goods for dumping purposes.
    • DunAndBradstreetCanadas8DigitStandardIndustrialClassificationCode
    • Duns-DunAndBradstreetPlus4 - An organization identified by the DUNS number and a 4- character extension.
    • DunsStandardIndustrialClassification2Plus2DunAndBradstreet
    • DutyTaxOrFeePaymentMethod - [4390] Method by which a duty or tax is paid to the relevant administration.
    • DynamicGeneratorSetCode
    • DynamicLocomotiveTagCode
    • Edira-Id-EdiRegistrationAuthorityIdentification - A code list specifying codes assigned by the EDI Registration Authority to register organizations (legal persons, partnerships, sole proprietorships and their branch offices) and private persons.
    • EditErrorCode
    • EducationalInstitutionType - Identifies a code list containing educational institution types.
    • EducationalStudyArea - Identifies a code list containing educational study areas.
    • ElectromagneticTransmitterIdentification - A code list containing electromagnetic transmitter identifications.
    • EmployeeIdentification - A list of codes identifying employees of an organization.
    • EnhancedPartyIdentification
    • Entitlement - Code to indicate the recipient of a charge amount (IATA).
    • EntityRelationship - Identifies a code list of entity relationships.
    • EquipmentStatusLookup
    • ErrorClassificationCode
    • EssentialityCode
    • EstimatedTimeOfArrivalCode
    • EstimateTypeLookup
    • EstimatingMethodStatusCode
    • Ethnicity - Identifies the code list containing ethnic types.
    • EvaluateWorkCandidateLookup
    • EvaluateWorkCandidateReasonLookup
    • EventAbatementCode
    • EventCodes
    • EventOrExposureCode
    • EventReappearanceCode
    • ExaminationFacility - Building or location where merchandise is examined by Customs.
    • ExcavationInformationCodeList
    • ExcessMaterialDispositionCode
    • ExciseDuty - Customs or fiscal authorities code to identify a specific or ad valorem levy on a specific commodity, applied either domestically or at time of importation.
    • ExportCommodityClassification-USScheduleB - Code list containing the commodity classifications applying to goods being exported (United States Schedule B).
    • ExportRequirements - Identification of requirements and regulations established by relevant authorities concerning exportation.
    • ExtensionReason
    • EyeColorCode
    • FacilityIdentification - A code list identifying a facility(ies).
    • FacilitySecurityClearance - Code list specifying the security clearance assigned to a facility.
    • FailureToAwardReason
    • FannieMaeAdjustableRateMortgagePlanCodes
    • FannieMae-FederalNationalMortgageAssociation-MortgageInsuranceCode
    • FannieMae-FederalNationalMortgageAssociation-PoolFeatureCode
    • FannieMae-FederalNationalMortgageAssociation-RemittancePrograms
    • FannieMae-FederalNationalMortgageAssociation-SpecialFeatureCode
    • FannieMaeRefinancePlanCode
    • FederalFinanceCodeList1
    • FederalHealthCareCodeList1
    • FederalLogisticsCodeList1
    • FederalProcurementCodeList1
    • FederalTransportationCodeList1
    • FinancialAnalysisCategories - Identifies a code list containing financial analysis categories.
    • FinancialInformationType - Identifies a code list containing financial information types.
    • FinancialItemAllocation - Identifies a code list containing financial item allocations.
    • FinancialItemAttributedCode
    • FinancialItemReclassification - Identifies a code list containing financial item reclassifications.
    • FinancialManagementServiceCash-LinkCode
    • FinancialRating
    • FinancialRegime - Nature and methods of a transaction from financial viewpoint.
    • FinancialRouting
    • FinancialStatementFormat - Identifies a code list containing financial statement formats.
    • FleetParameters
    • FlowOfTheGoods - List of statistical codes covering the movement of the goods to be declared (e.g. despatch, arrival).
    • Follow-UpCode
    • ForecastType - Identifies a code list containing forecast types.
    • ForeignLineOfBusinessCode
    • ForeignMilitarySalesCountryCode
    • FormTypeCode
    • ForwardingRestrictions - A code list containing restrictions regarding the forwarding of goods or equipment.
    • FreddieMac-FederalHomeLoanMortgageCorporation-MortgageInsuranceCode
    • FreddieMac-FederalHomeLoanMortgageCorporation-RemittancePrograms
    • FreddieMac-FederalHomeLoanMortgageCorporation-SpecialCharacterCode
    • FreddieMacRefinancePlanCode
    • FreeOnBoardSiteCode
    • FreeZone - Code identifying the zone within a state where any goods introduced are generally regarded, insofar as import duties and taxes are concerned, as being outside the Customs territory and are not subject to the usual Customs control.
    • FreightForwarder - Codes for freight forwarders.
    • Frequency
    • FrequencyBand
    • FunctionalArea
    • FunctionalGroup - Identifies a group of application related messages.
    • FundCode
    • FundPurpose
    • GainOrLossIndicatorCode
    • Gate - The location at which access to or from a facility is controlled.
    • GeneralServicesAdministrationCustomerSupplyCenterNumberCode
    • GeneralTerritoryType - Identifies a code list containing general territory types.
    • GeneratorSetMountingCode
    • GeographicLocation - Identifies a code list containing geographic locations.
    • GlassActionCode
    • GoodsDescription - Identification of a type of goods description.
    • GovernmentAgencyProcedure - Treatment applied by a government agency other than Customs to merchandise under their control.
    • GradeOfDifficulty
    • GroupQualifierCode
    • HairColorCode
    • HandlingAction - Codes for handling action.
    • HarmonizedSystem - Identification of commodities according to the Harmonized System.
    • HazardousMaterialCode
    • HazardousMaterialsCredential
    • HazardousResponseCodes
    • HealthCareClaimStatusCode
    • HealthCareFinancingAdministrationCommonProceduralCodingSystem
    • HealthCareFinancingAdministrationCommonProceduralCodingSystemPrincipalProcedure
    • HealthCareFinancingAdministrationDurableMedicalEquipmentRegionalCarrierCertificateOfMedicalNecessityForms
    • HealthcareProviderCharacteristicsAndResources
    • HealthcareProviderTaxonomy
    • HealthIndustryNumber
    • HealthIndustryOrganizationIdentification - List of codes identifying organizations in the health care industry.
    • Hobby - Identifies a code list containing hobby types.
    • Icd10 - Code list containing the International Classification of Diseases, version 10 (ICD 10).
    • IdentificationCode
    • IdentifyingCharacteristics
    • IdentityDisclosureCode
    • ImmunizationInjectionCode
    • ImpactAxisOrAnalogPortCode
    • ImpactRecorderCode
    • IncidentConditionCode
    • IncidentConsequenceCode
    • IncidentLocationCode
    • IncidentRelatedActionCode
    • Incoterms1980 - (4110) Code to indicate applicable Incoterms (1980 edition) under which seller undertakes to deliver merchandise to buyer (ICC). Incoterms 1990: use 4053 only.
    • IndicatorCode
    • IndividualInsuranceFinancialDetail
    • IndividualParticipationInCompany - Identifies the code list containing the types of participation of an individual within a company.
    • IndividualSecurityClearance - Code list specifying the security clearance assigned to an individual.
    • IndustryRating - Identifies a code list containing industry ratings.
    • InformationIndicatorCode
    • InformationRequestResult - Identifies a code list containing information request results.
    • InformationRequestType - Identifies a code list containing types of information requests.
    • InformationType - Identifies a code list containing types of information.
    • InitialTreatmentCode
    • InquirySelection - Identifies a code list containing inquiry selections.
    • InspectionParameters
    • InsuranceCoverageDetail - Identifies a code list containing insurance coverage details.
    • InsuranceInformationIndicator - Identifies the type of insurance information provided.
    • InsurancePlanDescriptionCharacteristics
    • IntermediateContainerCode
    • IntermediateContainerQuantityCode
    • InternationalClassificationOfDiseasesClinicalModificationProcedure
    • InternationalClassificationOfDiseasesClinicalModificationPrincipalProcedure
    • InternationalClassificationOfDiseasesClinicalModification-Icd-9-CmCode
    • InternationalStandardDesignationSystemForTeethAndAreasOfTheOralCavity
    • InventoryCategoryCode
    • InventoryTypeCode
    • InvestigationStatusCode
    • InvestmentFundType
    • InvestmentType
    • IrsQualificationCode
    • ItemManagementCode
    • ItemSourcingCategory - A code list to specify details related to the sourcing of the corresponding item such as provided by the buyer, from a mandatory source, etc.
    • ItemType - A code list defining the level of elaboration of a item such as raw material, component, tooling, etc.
    • JobCharacteristicsLookup
    • JobOriginatorLookup
    • JointLifeInsuranceIndicator - Indicates joint life insurance coverage.
    • JudicialHearingTypeCode
    • JudicialOrderTypeCode
    • JudicialSentenceTypeCode
    • JurisdictionType
    • KeyEventLookup
    • KindOfContractCode
    • KindOfModificationCode
    • LaboratoryResultsIdentificationCode
    • LaboratoryTestConditionCode
    • LegalCaseType - Identifies the code list containing the type of legal cases.
    • LegalEvent - Identifies a code list of legal events.
    • LegalStructureCode
    • LetterOfRecommendationRatingCategory
    • LiabilityDetails - Identifies a code list containing details of liability types.
    • LiabilityType
    • LifeOrAnnuityProductCode
    • LifeOrAnnuityServiceFeatures
    • LifeOrAnnuityStatusCodes
    • LifeReinsuranceMessageType - To indicate the type of life reinsurance activity transmitted in the message.
    • LineItemConditionCode
    • LineOfAuthority
    • LineOfBusinessCode
    • LoanType - Identifies the code list of loan types.
    • LocaleOfActivity
    • LocalSourceCode
    • LocationCode
    • LocationOfGoods - (3384) Indication of the place where goods are located and where they are available for examination.
    • LocationsForTariffCalculations - A list of locations related to tariff calculations.
    • LogicalObservationIdentifierNamesAndCodesCodes
    • LogisticsCodeList - Code list containing logistics and program management activities.
    • LossDescriptionCode
    • LossSeverityCode
    • LotTypeCode
    • MajorForceProgramCode
    • ManagementCode
    • ManagementIndicatorCode-Petroleum
    • ManualClassCode
    • MarineBerth - The location within a port where a ship anchors or ties up.
    • MarineWharf - Landing platform where a ship can load and unload.
    • MarketPlaceOrganizationID - Identifies an Organization within a Market Place
    • MarketPlaceTradingPartnerID - Identifies a Trading Partner within a Market Place
    • MaterialControlCode
    • Materials
    • MeansOfCommunicationsIdentifier - Code list of communication means used to transmit data.
    • MeansOfTransportIdentification - Code identifying the name or number of a means of transport (vessel, vehicle).
    • MechanizationOfContractAdministrationServicesSystemErrorCode
    • MediaAndStatusCode
    • MedicaidProvider - A list of codes identifying health care providers under a Medicaid program.
    • MedicalBenefitsSchedule - Code list containing classifications of medical services for use in determining the medical benefits payable.
    • MedicareProvider - A list of codes identifying health care providers under the Medicare program.
    • MediumOfTransmissionCode
    • MemberOrganizations - Identification of member organizations.
    • MethodEvaluationCode
    • MethodsOfPayment - Identification of methods of payment.
    • MilitaryAndCivilianGradeCode
    • MilitaryAssistanceProgramAddressCode - Lists of codes identifying name and address information for organizations participating in a military assistance program.
    • MinorityIndicator
    • MissionImpactStatementCode
    • MonetaryFunctionDetail - Identifies a code list containing monetary function details.
    • MortgageIndexSourceCode
    • Multi-MediaObject
    • Nacha-NationalAutomatedClearingHouseAssociation
    • NationalCouncilForPrescriptionDrugProgramsRejectOrPaymentCodes
    • NationalCouncilOnCompensationInsuranceNatureOfInjuryCode
    • NationalCouncilOnCompensationInsurancePartOfBodyCode
    • NationalCouncilOnCompensationInsuranceSourceOfInjuryCode
    • NationalDrugCode
    • NationalMotorFreightClassificationCode
    • NationalStandardToothNumberingSystem
    • NatureOfBuy
    • NatureOfDebtCode
    • NatureOfEventCode
    • NatureOfInjuryCode
    • NatureOfSuit
    • NatureOfSuitCode
    • NatureOfTransaction - Identification of the nature of the transaction.
    • NoLongerConsideredForAwardReason
    • NomenclatureActivityClassificationEconomyCode
    • Non-PostalTown - Identifies a code list containing towns not recognised as a postal entity.
    • NormeActiviteFrancaiseCode
    • NoticeType - Identifies the code list containing the type of notice.
    • NotificationIndicatorCode
    • ObligationVarianceCode
    • OccupationalSafetyAndHealthAdministrationNatureOfInjuryCode
    • OccupationalSafetyAndHealthAdministrationPartOfBodyCode
    • OccupationalSafetyAndHealthAdministrationSourceOfInjuryCode
    • OccupationClassification - Identifies the class of occupation.
    • OccupationCode
    • Occurrence
    • OccurrenceSpan
    • OceanCarrierCode
    • OfferAndReleaseOptionCode
    • OfficeOfWorkersCompensationProgramsNatureOfInjuryCode
    • OfficeOfWorkersCompensationProgramsOccupationCode
    • OfficeOfWorkersCompensationProgramsPartOfBodyCode
    • OfficeOfWorkersCompensationProgramsSourceOfInjuryCode
    • OperatingStatus - Code list identifying operating status of an entity.
    • OperationType
    • OversizeOrOverweightCredential
    • OwnershipCode
    • OwnershipRights - Identifies a code list containing types of ownership rights.
    • PackageFailureCode
    • PackingAndOrUnpackingFacility - Facility dedicated to the packing and/or unpacking of cargo.
    • PackingRequirementLevelACode
    • PackingRequirementLevelBCode
    • PackingRequirementLevelCCode
    • PartOfBodyAffected
    • PartOfBodyCode
    • PartyIdentification - Identification of parties, corporates, etc.
    • PassportNumber - Number assigned to a passport.
    • PatientEventProblemCode
    • PaymentBehaviourRating - Identifies a code list containing payment behaviour ratings.
    • PaymentTypeCode
    • PedestrianCode
    • PersonalPropertyAndContentsCode
    • PetroleumBillType
    • PetroleumLandCategory
    • PetroleumLeaseStatus
    • PetroleumProductDisposition
    • PetroleumProductPoint-Of-Sale
    • PetroleumProductSellingArrangement
    • PetroleumProductValueAdjustment
    • PetroleumRegulatoryReport
    • PetroleumRoyaltyAdjustment
    • PetroleumRoyaltyCalculationMethod
    • PetroleumRoyaltyTransaction
    • PetroleumUnitedStatesGeologicalSurveyFormationCode
    • PetroleumWellAction
    • PetroleumWellClassificationStatus
    • PetroleumWellInformation
    • PetroleumWellShut-InReason
    • PetroleumWellTestInformation
    • PhysicalCharacteristicsCode
    • PlantClearanceOfficeCode
    • PlusOrMinusIndicatorCode
    • PolicyOnClaimIndicator - Identifies a code list containing indicators referring to policy on claims.
    • PolicyReserveValuationType - Identification of the policy reserve valuation type.
    • PolicyType - To identify the code list for the type of policy.
    • Port - A location having facilities for means of transport to load or discharge cargo.
    • PortalID - Portal Identification
    • PostalDistrict - Identifies a code list containing territories for the routing of mail.
    • PostalServiceCarrierRoute - Identifies a code list containing routes covered by a postal service carrier.
    • PostcodeDirectory - [3251] Code defining postal zones or addresses.
    • PostMarketStudyStatusCode
    • PreciousMetalsIndicatorCode
    • PreservationDataCode
    • PreservationMaterialCode
    • PreventiveMeasure
    • PrimaryDiagnosis
    • PrincipalDiagnosis
    • PrincipalPartyCitizenshipCode
    • PriorityDesignatorCode
    • PriorityLookup
    • ProducerFinancialHistoryCodes
    • ProductCode - Code assigned to a specific product by a controlling agency.
    • ProductQualityDeficiencyReportSummaryCode
    • ProductSupplyCondition - A code list specifying the rules according to which a product is supplied, e.g. from stock, available on demand, make on order, etc.
    • ProfessionalDesignation
    • ProfessionalStatusCode
    • ProfessionTypeCode
    • ProgramOriginatorCode
    • ProgramYearCode
    • ProjectCode
    • ProjectionType
    • PropertyOwnershipExtent - Identifies a code list containing the extent of legal rights of possession to property.
    • PropertyOwnershipTypeCode
    • PropertyRecordStatusCode
    • PropertySourceCode
    • PropertyType - Identifies a code list containing property types.
    • PropertyUnderwritingConditionCode
    • Proprietary
    • PurchasingContractOfficerInstructionsCode
    • PurposeCode
    • QualityAlertListReason
    • QualityAssuranceSiteCode
    • QualityConformance - A code list specifying the quality standard a product complies with, e.g. ISO9000, BS5750, etc.
    • QualityControlCode - A code list specifying how the article is classified according to the quality control point of view, e.g. safety item, subject to regulation, etc.
    • QuantityPerUnitPackCode
    • QueryOptions
    • QueryStatus
    • RadioFrequencyType
    • RadioServiceType
    • RadioSystemType
    • RailAdditionalCharges - A code list identifying specific rail charges included in the payment conditions in addition to the freight cost.
    • RailcarLetterMarking - Codes for all marking codes (in letters) for railcars specifying the type, series, order number, check digit and some technical characteristics.
    • RailDocumentNames - Rail specific identifications of documents.
    • RailHandlingRestrictionsAndInstructions - A code list specifying rail codes for handling restrictions or instructions.
    • RailHarmonizedCodificationOfTariffs - A list of rail tariffs, the coding of which has been harmonized.
    • RailHarmonizedEquipmentType - A code list specifying codes for harmonized equipment type in the railway industry.
    • RailRoutes - A code list identifying routes used in rail transport.
    • RailUnifiedNomenclatureOfGoods
    • RailwayCompanyNetwork - A code list identifying the different railway companies as member of the International Union of Railways.
    • RailwayCustomer - A code list identifying rail customers.
    • RailwayFrontierAndTransitPoint - A code list specifying frontier or transit points in the railway industry.
    • RailwayLocations - Code identifying a location in railway environment.
    • RailwayServicesHarmonizedCode - Services provided by the different railway organizations.
    • RateClass - Code to identify a specific rate category.
    • RatingSummaryValue - Identifies a code list containing rating summary values.
    • RealEstateAssetType - Identifies the code list containing the types of real estate assets.
    • ReasonForContractDeliveryDateRevisionCode
    • ReasonForDelayedClosingOfContractFileCode
    • ReasonForDisposalCode
    • ReasonForFinancialItemDetailChange - Identifies a code list containing reasons for the change in financial item details.
    • ReasonForPublicRecordFiling - Identifies a code list containing reasons for public record filings.
    • ReasonForRequisitioningCode
    • RecipientOfBillingStatusCode
    • RecommendationsRegardingDelayedDeliveriesCode
    • RecordControlNumber
    • RecordPrecedenceBasedOnItsCurrencyInTime - Identifies the priority of a record based on its currency in time.
    • ReferenceAndStationCode
    • RefrigerationUnitOperatingModeCode
    • Region - Identifies a code list containing regions that identify an area of the earth's surface, having definable boundaries or characteristics.
    • RegisteredContractorActivityCode
    • RegistrationType - Identifies a code list containing registration types.
    • ReinsuranceMonetaryType - Identifies the type of reinsurance amounts.
    • ReinsurancePolicyAttributes - A list of attributes regarding policies reinsured with a professional reinsurer.
    • RejectAdviceCode
    • RejectIndicatorCode
    • RelatedDeviceApplicabilityCode
    • ReligiousAffiliationCode
    • RemedialActionCode
    • RemovableAccessoriesAndSpecialEquipmentOnRailcars - A list of removable accessories and special equipment associated with railcars.
    • RentalCharge
    • RepairFacility - Facility at which repairs are carried out.
    • ReportableEventCode
    • ReportableEventStatusCode
    • ReportCode
    • ReportDistributionCode
    • ReportSourceCode
    • RepresentativeBuyIndicator
    • RequestCode
    • RequestType
    • RequirementCode
    • RequirementsIndicator - A code list which specifies various requirements that a customer may have when fulfilling a purchase order.
    • ResidencyIndicator
    • ResidentialAndCommercialRoomCode
    • ResponseStatusCode
    • RestrictionsAndProhibitionsPlacedOnTheRe-UseOf - designated rail wagons A code list identifying restrictions and prohibitions placed on the re-use of designated rail wagons.
    • ResultEvaluationCode
    • ReviewPeriodIndicatorCode
    • RiskClass
    • RoadCharacteristicCode
    • RoadwayDetail - Identifies a code list containing roadway details.
    • RoadwayType - Identifies a code list containing roadway types.
    • RouteCode
    • RunType
    • SafetyAndFitnessElectronicRecordSystemsErrorCode
    • SafetyAndFitnessElectronicRecordSystemsSubscriptionOption
    • SafetyHazardLookup
    • SafetyRegulation - A code list specifying the safety regulations which apply to a product, such as UK COSHH (control of substances hazardous to health) regulations.
    • SalesPriceConditionCode
    • SalvageDispositionCode
    • SampleExtractionLocation - Code list identifying the location from which a sample is taken.
    • SeavanOwnershipCode
    • SecondaryDiagnosis
    • SecondarySourceOfInjury
    • SecurityShareType - Identifies a code list containing security share types.
    • Service - Identification of services.
    • ServiceAndAgencyCode
    • ServiceContractActOccupationCategoryCode
    • ServiceContractActOccupationClassificationCode
    • ServiceContractActOperationCode
    • SettlementOrPayoutOptions
    • ShareTypeCode
    • ShelfLifeCode
    • ShipmentAcceptanceDiscrepancyExplanationCode
    • ShipmentDescription - Code to indicate whether a shipment is a total, part or split consignment.
    • ShipmentHoldCode
    • ShipmentReleaseCode
    • ShippingAgent - Codes for shipping agents.
    • SignalCode
    • SingleStateRegistrationSystemAndOperatingAuthorityCredential
    • SingleUseLabelCode
    • SizeAndType
    • SkinToneCode
    • SmallArmsErrorTransactionRejectCode
    • SmallArmsTransactionCode
    • SocialSecurityIdentification - Code assigned by the authority competent to issue social security identification to identify a person.
    • SolicitationCancellationReason
    • SolicitationMethod
    • SoundCode
    • Source
    • SourceMaintenanceAndRecoverabilityCode
    • SourceOfDepositCode
    • SourceOfDisclosure - Identifies a code list containing disclosure sources.
    • SourceOfInjuryCode
    • SourceOfLeadCode
    • SourceOfLossCode
    • SpecialCategoryCode
    • SpecialContractProvisionCode
    • SpecialDating
    • SpecialHandling - Code to indicate that the nature of the consignment may necessitate use of special handling procedures (IATA).
    • SpecialMarketingTypeCode
    • SpecialMarkingCode
    • SpecialMaterialIdentificationCode
    • SpecialProgramRequirementStatusCode
    • SpecialReimbursableProvisionsCode
    • SpecialRequirementLookup
    • SpecialRequirementsCode
    • StandardIndustrialClassification
    • StandardOccupationClassificationCode
    • StandardTextAccordingUSEmbargoRegulations - US government regulations prescribe specific standard text usage. Using codes from this code list prevents full text transmission.
    • StandardTextClauses - A list of codes representing standardized text clauses.
    • StandardTextForExportAccordingNationalPrescriptions - National export regulations prescribe specific standard text usage. Using codes from this code list prevents full text transmission.
    • StateCode - A code list of states within a country.
    • StationClassification
    • StationClassificationType
    • StatisticalAdministrativeInformationCode
    • StatisticalNatureOfTransaction - Indication of the type of contract under which goods are supplied.
    • StatisticalObject - A statistical object such as a statistical concept, array structure component or statistical nomenclature.
    • StatisticalProcedures - Indication of the statistical procedure to which the goods are subject.
    • StatisticBundesAmtCode
    • StatusCode
    • StockExchangeCode
    • StockExchangeDetail - Identifies a code list containing stock exchange details.
    • StockFundOrNon-StockFundCode
    • StorageFacility - Facility at which goods are stored.
    • StudentActivityTypeCode
    • StudentAwardCode
    • SubcaseNumber
    • SubrogationActionCode
    • SubrogationPaymentOptions
    • SubrogationRequestCodes
    • SubrogationResponseCodes
    • SubsistenceTypeOfPackCode
    • SuffixCode
    • SuffixOrLimitCode
    • SummonsTypeCode
    • SupplementalData
    • SupplementaryAccountingClassificationCode
    • SuppliersStockTurnover - A code list giving an indication about the level of the supplier's stock turnover.
    • SupplyConditionCode
    • SurfaceDescriptorCode
    • SWIFT
    • SyntaxNotes - A code list of syntax (dependency) note identifiers.
    • SystematizedNomenclatureOfHumanAndVeterinaryMedicine
    • SystemStatus
    • TariffSchedule
    • TaxAssessmentMethod - A code to identify the tax assessment method.
    • TaxOrFeeExemptionReasonCode
    • TaxPartyIdentification - Code assigned by a tax authority to identify a party.
    • TechnicalAssessmentChecklist - A code list of technical assessment checklist numbers.
    • TelephoneDirectory
    • TemplateCharacteristicLookup
    • TemplateOwnerLookup
    • TemplateTypeLookup
    • Termination
    • TermsOfDelivery - Code to identify terms of delivery.
    • TertiaryDiagnosis
    • TestingDemographicCategoryCodeList
    • TestingServiceQuestionCodeList
    • TestingStatisticalCategoryCodeList
    • TestResultsCode
    • TitleDocumentCodeList
    • TitleExceptionAndRequirementCodeList
    • TradeCode
    • TrainIdentification - A code list specifying international train identifications maintained by the UIC (International Union of Railways).
    • TransactionStatusIndicatorCode
    • TransportationBillCode
    • TransportationHoldingDelayCode
    • TransportationModeOrMethodCode
    • TransportationModeReasonCode
    • TransportationPriorityCode
    • TreasuryManagementAssociationServiceCode
    • TreasuryManagementAssociationServiceCodeAndBankServiceCode
    • TreasurySymbolCode
    • TreatmentCodes
    • TrendReason
    • TrialTypeCode
    • TypeAdjustmentCode
    • TypeAndCauseCode
    • TypeDue-InIndicator
    • TypeIdentityChangeCode
    • TypeInspectionCode
    • TypeNumericalControlSystemCode
    • TypeOfAssetsAndLiabilities - Identification of the type of assets and liabilities.
    • TypeOfAssistanceCode
    • TypeOfBillCode
    • TypeOfBusinessCode
    • TypeOfCargoCode
    • TypeOfContractCode
    • TypeOfContractorCode
    • TypeOfDelayCode
    • TypeOfFinancialAccount - Identification of the type of financial account.
    • TypeOfFirmCode
    • TypeOfIndustrialActivity - Identification of the type of industrial activity.
    • TypeOfInquiryCode
    • TypeOfInsured - To specify the insured type.
    • TypeOfIssueCode
    • TypeOfLocationReconciliationRequest
    • TypeOfMediaCode
    • TypeOfPackage - Indication of the type of package codes.
    • TypeOfProcurement
    • TypeOfStorageCode
    • TypeOfSurveyQuestion - Identification of the type of survey question.
    • TypePackCode
    • TypePhysicalInventoryOrTransactionHistoryCode
    • UltimateRecipientCode
    • UnclaimedPropertyAdditionsDeletionsAndDeductionsCodes
    • UnclaimedPropertyTypeCode
    • UniformFreightClassificationCode
    • UniformResidentialAppraisalAttributesCode
    • UnitCode
    • UnitedNationsCommonCodingSystem - A code list adopted by the United Nations organisations for the procurement of goods and services.
    • UnitedNationsStandardProductsAndServices - Classification (UN/SPSC) code A code list that provides a hierarchical classification of goods and services for the purposes of resource discovery and spend analysis.
    • UnitedStatesDepartmentOfHealthAndHumanServicesOfficeOfVitalStatisticsE-Code
    • UnsolicitedProposalRejectionReason
    • UtilizationCode
    • VaccinationInnoculationOrIsolationCode
    • ValuationTypeCode
    • Value
    • ValueAddedTaxIdentification - Value added tax identification code.
    • VehicleClass
    • VehicleOccupantCode
    • VehicleParameters
    • VesselStatusAndTermsOfCarriageCode
    • VesselStowageLocationCode
    • VesselSustainingCode
    • ViewParameters
    • ViolationTypeCodeList
    • VoyageDocumentNumberCode
    • VoyageManifestReferenceCode
    • Warehouse - A covered facility for the storage and distribution of goods.
    • WarReserveMaterialRequirementCode
    • WaterCommodityAndSpecialHandlingCode
    • WaterTerminalIdentifierCode
    • WeightOrFragilityCode
    • WhenDiscoveredLookup

[^]Code Fragment

    <xsd:simpleType name="CodeListIdentifierCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="AcceptanceSiteCode">
        <xsd:enumeration value="AccidentParameters">
        <xsd:enumeration value="AccordEuropeenRelatifAuTransportInternationalDesMarchandises">
        <xsd:enumeration value="AccountAnalysisCodes">
        <xsd:enumeration value="AccountCharacteristicsCode">
        <xsd:enumeration value="AccountingInformationIdentifier">
        <xsd:enumeration value="AccountRating">
        <xsd:enumeration value="AccountRelationshipType">
        <xsd:enumeration value="AcquisitionAdviceCode">
        <xsd:enumeration value="AcquisitionMethodCode">
        <xsd:enumeration value="AcquisitionMethodSuffixCode">
        <xsd:enumeration value="ActionCode">
        <xsd:enumeration value="ActivitePrincipaleExerceeCode">
        <xsd:enumeration value="Activity">
        <xsd:enumeration value="AdmittingDiagnosis">
        <xsd:enumeration value="AdverseEventCode">
        <xsd:enumeration value="AdverseEventOutcomeCode">
        <xsd:enumeration value="AdviceCode">
        <xsd:enumeration value="AgentStatusCode">
        <xsd:enumeration value="AidTypeCode">
        <xsd:enumeration value="AirCarrier">
        <xsd:enumeration value="AirCommodityAndSpecialHandlingCode">
        <xsd:enumeration value="AircraftMissionDesignSeriesCode">
        <xsd:enumeration value="AirDimensionCode">
        <xsd:enumeration value="AirportOrCity">
        <xsd:enumeration value="AirportTerminal">
        <xsd:enumeration value="AirTerminalIdentifierCode">
        <xsd:enumeration value="AllegationTypeCode">
        <xsd:enumeration value="AllPatientDiagnosisRelatedGroups">
        <xsd:enumeration value="AllPatientRefinedDiagnosisRelatedGroups">
        <xsd:enumeration value="AlterationLookup">
        <xsd:enumeration value="AmbulatoryPatientGroups">
        <xsd:enumeration value="AmendmentCode-Customs">
        <xsd:enumeration value="AmericanPsychiatricAssociationDiagnosticStatisticalManualOfMentalDisorders">
        <xsd:enumeration value="AmericanSocietyForTestingAndMaterials">
        <xsd:enumeration value="AntennaPolarization">
        <xsd:enumeration value="AntennaStructureType">
        <xsd:enumeration value="ApplicantClassificationType">
        <xsd:enumeration value="ApplicantType">
        <xsd:enumeration value="ApplicationAcknowledgementAndErrorCodes">
        <xsd:enumeration value="ApplicationErrorCode">
        <xsd:enumeration value="ApplicationQuestionIdentifier">
        <xsd:enumeration value="ApplicationType">
        <xsd:enumeration value="Area">
        <xsd:enumeration value="AreaOfOperation">
        <xsd:enumeration value="ArrestReason">
        <xsd:enumeration value="ArticleStatus">
        <xsd:enumeration value="AssetDetails">
        <xsd:enumeration value="AssetRecurrence">
        <xsd:enumeration value="AssetStatusOrTransactionReportingCode">
        <xsd:enumeration value="AssetTransferStatusCode">
        <xsd:enumeration value="AssetType">
        <xsd:enumeration value="AssignedByReceiver">
        <xsd:enumeration value="AssignedBySender">
        <xsd:enumeration value="AssociationOfAmericanRailroadsDeprescriptionDistributionList">
        <xsd:enumeration value="AssociationOfAmericanRailroadsDeprescriptionExceptionList">
        <xsd:enumeration value="AssociationOfAmericanRailroadsRateEdiNetworkErrorCode">
        <xsd:enumeration value="AssociationOfAmericanRailroadsStandardTransportationCommodityCodeDescriptionQualifier">
        <xsd:enumeration value="AssociationOfAmericanRailroadsStandardTransportationCommodityCodeMasterDescriptionInformation">
        <xsd:enumeration value="AssociationOfAmericanRailroadsSwitchReleaseCodes">
        <xsd:enumeration value="AssuredDeliveryIndicator">
        <xsd:enumeration value="AuthorizationType">
        <xsd:enumeration value="AutomatedClearingHouse">
        <xsd:enumeration value="AutomatedDataProcessingEquipmentIdentificationCode">
        <xsd:enumeration value="AwardSource">
        <xsd:enumeration value="BalanceTypeCode">
        <xsd:enumeration value="BankAdministrationInstitute">
        <xsd:enumeration value="BankBranchSortingIdentification">
        <xsd:enumeration value="BankIdentification">
        <xsd:enumeration value="BankSecuritiesCode">
        <xsd:enumeration value="BasisOfJurisdictionCode">
        <xsd:enumeration value="BeneficiaryType">
        <xsd:enumeration value="BidRejectionReason">
        <xsd:enumeration value="BilledOfficeIndicatorCode">
        <xsd:enumeration value="BillingAdviceCode">
        <xsd:enumeration value="BillingStatusCode">
        <xsd:enumeration value="BillOfLadingClauses">
        <xsd:enumeration value="BoardOfInspectionAndSurveyPartLookup">
        <xsd:enumeration value="BoardOfInspectionAndSurveyResponsibilityLookup">
        <xsd:enumeration value="BoardOfInspectionAndSurveyShipLookup">
        <xsd:enumeration value="BusinessAccountNumber">
        <xsd:enumeration value="BusinessChangeCode">
        <xsd:enumeration value="BusinessClassification">
        <xsd:enumeration value="BusinessCreditRating">
        <xsd:enumeration value="BusinessEntityFilingDetailCode">
        <xsd:enumeration value="BusinessEntityFilingLocationCode">
        <xsd:enumeration value="BusinessEntityFilingReportTypeCode">
        <xsd:enumeration value="BusinessEntityFilingSecuritiesInformationCode">
        <xsd:enumeration value="BusinessEntityFilingStatusCode">
        <xsd:enumeration value="BusinessEntityFinancialInformationCode">
        <xsd:enumeration value="BusinessEntityStatusCode">
        <xsd:enumeration value="BusinessFunction">
        <xsd:enumeration value="BusinessLegalStructureType">
        <xsd:enumeration value="BusinessSizeCode">
        <xsd:enumeration value="BusinessType">
        <xsd:enumeration value="CallSignDirectory">
        <xsd:enumeration value="CanadianInterEdi">
        <xsd:enumeration value="CancellationReason">
        <xsd:enumeration value="Carriers">
        <xsd:enumeration value="CaseDesignatorNumber">
        <xsd:enumeration value="CaseOriginCode">
        <xsd:enumeration value="CashDiscountStipulationCode">
        <xsd:enumeration value="CauseLookup">
        <xsd:enumeration value="CauseOfInjuryCode">
        <xsd:enumeration value="CauseOfLossCode">
        <xsd:enumeration value="CeilingTypeCode">
        <xsd:enumeration value="CertificationRequirementsCode">
        <xsd:enumeration value="Charge">
        <xsd:enumeration value="CitizenIdentification">
        <xsd:enumeration value="City">
        <xsd:enumeration value="CitySubdivision">
        <xsd:enumeration value="ClaimPaymentRemarkCodes">
        <xsd:enumeration value="ClaimType">
        <xsd:enumeration value="ClassOfOperation">
        <xsd:enumeration value="ClassOfPitch">
        <xsd:enumeration value="ClauseStatusType">
        <xsd:enumeration value="ClearingCode">
        <xsd:enumeration value="ClearingHouseAutomatedPayment">
        <xsd:enumeration value="ClearingHouseInterbankPaymentSystemParticipantsId">
        <xsd:enumeration value="ClearingHouseInterbankPaymentSystemUniversalId">
        <xsd:enumeration value="CoastDesignationCode">
        <xsd:enumeration value="CognizanceSymbol">
        <xsd:enumeration value="CollisionIndustryElectronicCommerceAssociation-Inspection">
        <xsd:enumeration value="CollisionIndustryElectronicCommerceAssociation-LossCategory">
        <xsd:enumeration value="CollisionIndustryElectronicCommerceAssociation-PointsOfImpact">
        <xsd:enumeration value="CollisionIndustryElectronicCommerceAssociation-Profile">
        <xsd:enumeration value="Combiterms1990">
        <xsd:enumeration value="CommercialAndGovernmentEntity">
        <xsd:enumeration value="CommercialDriversLicense">
        <xsd:enumeration value="CommercialVehicleOperationsCommodityCode">
        <xsd:enumeration value="CommercialVehicleOperationsHazardousMaterialCode">
        <xsd:enumeration value="CommercialVehicleOperationsInsurance">
        <xsd:enumeration value="CommercialVehicleOperationsSafetyCode">
        <xsd:enumeration value="CommercialVehicleOperationsStatusCode">
        <xsd:enumeration value="CommercialVehicleRegistration">
        <xsd:enumeration value="CommercialVehicleTax">
        <xsd:enumeration value="CommercialVehicleTitle">
        <xsd:enumeration value="CommercialVehicleType">
        <xsd:enumeration value="Commodity">
        <xsd:enumeration value="CommunicationsRoutingIdentifierCode">
        <xsd:enumeration value="CompanyUnitID">
        <xsd:enumeration value="CompensationTypeCodes">
        <xsd:enumeration value="CompetitiveCharacteristicsCode">
        <xsd:enumeration value="ComplaintRequestCode">
        <xsd:enumeration value="ComplianceReviewCode">
        <xsd:enumeration value="ConclusionEvaluationCode">
        <xsd:enumeration value="Condition">
        <xsd:enumeration value="ConditionDetail">
        <xsd:enumeration value="ConsigneesPremises">
        <xsd:enumeration value="ConsignorsPremises">
        <xsd:enumeration value="ConsolidationAndContainerizationPointCode">
        <xsd:enumeration value="ConsolidationDetail">
        <xsd:enumeration value="ConstructionMaterial">
        <xsd:enumeration value="ContactorAlertListReason">
        <xsd:enumeration value="ContactStatusCode">
        <xsd:enumeration value="ContainerAndRoll-OnOrRoll-OffNumberCode">
        <xsd:enumeration value="ContainerTerminal">
        <xsd:enumeration value="ContentIndicatorCode">
        <xsd:enumeration value="Continent">
        <xsd:enumeration value="Contract">
        <xsd:enumeration value="ContractClose-OutGroupCode">
        <xsd:enumeration value="ContractDeliveryDateRevisionAgentCode">
        <xsd:enumeration value="ContractFundReportingTransactionCode">
        <xsd:enumeration value="ContractorAlertListStatus">
        <xsd:enumeration value="ContractorReviewListStatus">
        <xsd:enumeration value="ContractPaymentDeductionOrCollectionCode">
        <xsd:enumeration value="ContractPaymentLineItemStatusCode">
        <xsd:enumeration value="ContractShipmentAdviceCode">
        <xsd:enumeration value="ControlledInventoryItemCode">
        <xsd:enumeration value="ControlUnitDesignCode">
        <xsd:enumeration value="ControvertCode">
        <xsd:enumeration value="ConvictionOffenseType">
        <xsd:enumeration value="CooperativeLogisticsProgramSupportCode">
        <xsd:enumeration value="CorporateFinancialFilingCriteria">
        <xsd:enumeration value="CorporateStatementFilingCode">
        <xsd:enumeration value="CorrectionOrChangeForStorageItemRecordsCode">
        <xsd:enumeration value="Country">
        <xsd:enumeration value="CountryAndActivityCode">
        <xsd:enumeration value="CountryCode-FinanceAndAcquisition">
        <xsd:enumeration value="CountrySub-Entity">
        <xsd:enumeration value="County">
        <xsd:enumeration value="CountyDesignatorCode">
        <xsd:enumeration value="CouponAdjustmentReasonCode">
        <xsd:enumeration value="CourtAppearanceTypeCode">
        <xsd:enumeration value="CourtCaseStatusCode">
        <xsd:enumeration value="CourtDispositionCode">
        <xsd:enumeration value="CourtDocumentTypeCode">
        <xsd:enumeration value="CourtIssuedWarrantTypeCode">
        <xsd:enumeration value="CourtOfLawEventType">
        <xsd:enumeration value="CourtOfLawType">
        <xsd:enumeration value="CourtPartyStatus">
        <xsd:enumeration value="CourtPleadingTypeCode">
        <xsd:enumeration value="CoverageCodeList">
        <xsd:enumeration value="CoverageModifier">
        <xsd:enumeration value="Cpa-CanadianPaymentsAssociation">
        <xsd:enumeration value="CriminalCharge">
        <xsd:enumeration value="CriminalChargeGrade">
        <xsd:enumeration value="CriticalityDesignatorCode">
        <xsd:enumeration value="CuisineTypeCode">
        <xsd:enumeration value="CurrentAssetDetails">
        <xsd:enumeration value="CurrentDentalTerminologyCode">
        <xsd:enumeration value="CurrentLiabilityDetails">
        <xsd:enumeration value="CurrentProceduralTerminologyCodes">
        <xsd:enumeration value="CustomerMaintenanceLevelLookup">
        <xsd:enumeration value="CustomerWithinCountryCode">
        <xsd:enumeration value="CustomizedNoticeTypeCode">
        <xsd:enumeration value="CustomsAreaOfTransaction">
        <xsd:enumeration value="CustomsDeclarationType">
        <xsd:enumeration value="CustomsDomesticPortLocationCodes-USScheduleD">
        <xsd:enumeration value="CustomsForeignPortLocationCodes-USScheduleK">
        <xsd:enumeration value="CustomsIndicator">
        <xsd:enumeration value="CustomsInspectionType">
        <xsd:enumeration value="CustomsOffice">
        <xsd:enumeration value="CustomsPreference">
        <xsd:enumeration value="CustomsProcedure">
        <xsd:enumeration value="CustomsReleaseNotification">
        <xsd:enumeration value="CustomsSimplifiedProcedure">
        <xsd:enumeration value="CustomsSpecialCodes">
        <xsd:enumeration value="CustomsStatusOfGoods">
        <xsd:enumeration value="CustomsTransitGuarantee">
        <xsd:enumeration value="CustomsTransitType">
        <xsd:enumeration value="CustomsValuationMethod">
        <xsd:enumeration value="CustomsWarehouse">
        <xsd:enumeration value="DangerousGoodsPackingType">
        <xsd:enumeration value="DataCategory">
        <xsd:enumeration value="DateShippedOrReceivedCode">
        <xsd:enumeration value="DebtorBusinessTypeCode">
        <xsd:enumeration value="DebtorTypeCode">
        <xsd:enumeration value="DefendantPleaTypeCode">
        <xsd:enumeration value="DefensePrioritiesAndAllocationsSystemCode">
        <xsd:enumeration value="DeferralLookup">
        <xsd:enumeration value="DeficiencyCause">
        <xsd:enumeration value="DeficiencyIndicator">
        <xsd:enumeration value="DelinquencyIndicator">
        <xsd:enumeration value="DeliverySourceCode">
        <xsd:enumeration value="DeliveryTermCode">
        <xsd:enumeration value="DemandCode">
        <xsd:enumeration value="DemilitarizationCode">
        <xsd:enumeration value="DepartmentOfDefenseIdentificationCode">
        <xsd:enumeration value="DeviceAvailabilityCode">
        <xsd:enumeration value="DeviceEvaluationCode">
        <xsd:enumeration value="DeviceEventProblemCode">
        <xsd:enumeration value="DeviceOperatorTypeCode">
        <xsd:enumeration value="DeviceStatusCode">
        <xsd:enumeration value="DeviceUsageCode">
        <xsd:enumeration value="Diagnosis">
        <xsd:enumeration value="DiagnosisEncounteredDuringExaminationAndInvestigationOfIndividualsAndPopulationsCode">
        <xsd:enumeration value="DiagnosisRelatedGroup">
        <xsd:enumeration value="DiagnosticAndStatisticalManualOfMentalDisorders">
        <xsd:enumeration value="DirectNumericalControlSystemCode">
        <xsd:enumeration value="DisbursementStatusCode">
        <xsd:enumeration value="Discrepancy">
        <xsd:enumeration value="DiscrepancyAdviceCode">
        <xsd:enumeration value="DiscrepancyCode">
        <xsd:enumeration value="DiscrepancyIndicatorCode">
        <xsd:enumeration value="DiscrepancyStatusOrDispositionCode">
        <xsd:enumeration value="DisposalAuthorityCode">
        <xsd:enumeration value="DisposalConditionCode">
        <xsd:enumeration value="DistributionCode">
        <xsd:enumeration value="DocumentIdentificationCode">
        <xsd:enumeration value="DocumentRequestedByCustoms">
        <xsd:enumeration value="Dodaac-DepartmentOfDefenseActivityAddressCode">
        <xsd:enumeration value="DomesticLineOfBusinessCode">
        <xsd:enumeration value="DoseFormCode">
        <xsd:enumeration value="DriverParameters">
        <xsd:enumeration value="DriversLicenseWithdrawalBasis">
        <xsd:enumeration value="DriversLicenseWithdrawalDueProcessStatus">
        <xsd:enumeration value="DriversLicenseWithdrawalExtent">
        <xsd:enumeration value="DriversLicenseWithdrawalReason">
        <xsd:enumeration value="DriversLicenseWithdrawalType">
        <xsd:enumeration value="DrugDetailCode">
        <xsd:enumeration value="DrugStatusAdverseEventCode">
        <xsd:enumeration value="DrugStatusCode">
        <xsd:enumeration value="DumpingOrCountervailingAssessmentMethod">
        <xsd:enumeration value="DumpingSpecification">
        <xsd:enumeration value="DunAndBradstreetCanadas8DigitStandardIndustrialClassificationCode">
        <xsd:enumeration value="Duns-DunAndBradstreetPlus4">
        <xsd:enumeration value="DunsStandardIndustrialClassification2Plus2DunAndBradstreet">
        <xsd:enumeration value="DutyTaxOrFeePaymentMethod">
        <xsd:enumeration value="DynamicGeneratorSetCode">
        <xsd:enumeration value="DynamicLocomotiveTagCode">
        <xsd:enumeration value="Edira-Id-EdiRegistrationAuthorityIdentification">
        <xsd:enumeration value="EditErrorCode">
        <xsd:enumeration value="EducationalInstitutionType">
        <xsd:enumeration value="EducationalStudyArea">
        <xsd:enumeration value="ElectromagneticTransmitterIdentification">
        <xsd:enumeration value="EmployeeIdentification">
        <xsd:enumeration value="EnhancedPartyIdentification">
        <xsd:enumeration value="Entitlement">
        <xsd:enumeration value="EntityRelationship">
        <xsd:enumeration value="EquipmentStatusLookup">
        <xsd:enumeration value="ErrorClassificationCode">
        <xsd:enumeration value="EssentialityCode">
        <xsd:enumeration value="EstimatedTimeOfArrivalCode">
        <xsd:enumeration value="EstimateTypeLookup">
        <xsd:enumeration value="EstimatingMethodStatusCode">
        <xsd:enumeration value="Ethnicity">
        <xsd:enumeration value="EvaluateWorkCandidateLookup">
        <xsd:enumeration value="EvaluateWorkCandidateReasonLookup">
        <xsd:enumeration value="EventAbatementCode">
        <xsd:enumeration value="EventCodes">
        <xsd:enumeration value="EventOrExposureCode">
        <xsd:enumeration value="EventReappearanceCode">
        <xsd:enumeration value="ExaminationFacility">
        <xsd:enumeration value="ExcavationInformationCodeList">
        <xsd:enumeration value="ExcessMaterialDispositionCode">
        <xsd:enumeration value="ExciseDuty">
        <xsd:enumeration value="ExportCommodityClassification-USScheduleB">
        <xsd:enumeration value="ExportRequirements">
        <xsd:enumeration value="ExtensionReason">
        <xsd:enumeration value="EyeColorCode">
        <xsd:enumeration value="FacilityIdentification">
        <xsd:enumeration value="FacilitySecurityClearance">
        <xsd:enumeration value="FailureToAwardReason">
        <xsd:enumeration value="FannieMaeAdjustableRateMortgagePlanCodes">
        <xsd:enumeration value="FannieMae-FederalNationalMortgageAssociation-MortgageInsuranceCode">
        <xsd:enumeration value="FannieMae-FederalNationalMortgageAssociation-PoolFeatureCode">
        <xsd:enumeration value="FannieMae-FederalNationalMortgageAssociation-RemittancePrograms">
        <xsd:enumeration value="FannieMae-FederalNationalMortgageAssociation-SpecialFeatureCode">
        <xsd:enumeration value="FannieMaeRefinancePlanCode">
        <xsd:enumeration value="FederalFinanceCodeList1">
        <xsd:enumeration value="FederalHealthCareCodeList1">
        <xsd:enumeration value="FederalLogisticsCodeList1">
        <xsd:enumeration value="FederalProcurementCodeList1">
        <xsd:enumeration value="FederalTransportationCodeList1">
        <xsd:enumeration value="FinancialAnalysisCategories">
        <xsd:enumeration value="FinancialInformationType">
        <xsd:enumeration value="FinancialItemAllocation">
        <xsd:enumeration value="FinancialItemAttributedCode">
        <xsd:enumeration value="FinancialItemReclassification">
        <xsd:enumeration value="FinancialManagementServiceCash-LinkCode">
        <xsd:enumeration value="FinancialRating">
        <xsd:enumeration value="FinancialRegime">
        <xsd:enumeration value="FinancialRouting">
        <xsd:enumeration value="FinancialStatementFormat">
        <xsd:enumeration value="FleetParameters">
        <xsd:enumeration value="FlowOfTheGoods">
        <xsd:enumeration value="Follow-UpCode">
        <xsd:enumeration value="ForecastType">
        <xsd:enumeration value="ForeignLineOfBusinessCode">
        <xsd:enumeration value="ForeignMilitarySalesCountryCode">
        <xsd:enumeration value="FormTypeCode">
        <xsd:enumeration value="ForwardingRestrictions">
        <xsd:enumeration value="FreddieMac-FederalHomeLoanMortgageCorporation-MortgageInsuranceCode">
        <xsd:enumeration value="FreddieMac-FederalHomeLoanMortgageCorporation-RemittancePrograms">
        <xsd:enumeration value="FreddieMac-FederalHomeLoanMortgageCorporation-SpecialCharacterCode">
        <xsd:enumeration value="FreddieMacRefinancePlanCode">
        <xsd:enumeration value="FreeOnBoardSiteCode">
        <xsd:enumeration value="FreeZone">
        <xsd:enumeration value="FreightForwarder">
        <xsd:enumeration value="Frequency">
        <xsd:enumeration value="FrequencyBand">
        <xsd:enumeration value="FunctionalArea">
        <xsd:enumeration value="FunctionalGroup">
        <xsd:enumeration value="FundCode">
        <xsd:enumeration value="FundPurpose">
        <xsd:enumeration value="GainOrLossIndicatorCode">
        <xsd:enumeration value="Gate">
        <xsd:enumeration value="GeneralServicesAdministrationCustomerSupplyCenterNumberCode">
        <xsd:enumeration value="GeneralTerritoryType">
        <xsd:enumeration value="GeneratorSetMountingCode">
        <xsd:enumeration value="GeographicLocation">
        <xsd:enumeration value="GlassActionCode">
        <xsd:enumeration value="GoodsDescription">
        <xsd:enumeration value="GovernmentAgencyProcedure">
        <xsd:enumeration value="GradeOfDifficulty">
        <xsd:enumeration value="GroupQualifierCode">
        <xsd:enumeration value="HairColorCode">
        <xsd:enumeration value="HandlingAction">
        <xsd:enumeration value="HarmonizedSystem">
        <xsd:enumeration value="HazardousMaterialCode">
        <xsd:enumeration value="HazardousMaterialsCredential">
        <xsd:enumeration value="HazardousResponseCodes">
        <xsd:enumeration value="HealthCareClaimStatusCode">
        <xsd:enumeration value="HealthCareFinancingAdministrationCommonProceduralCodingSystem">
        <xsd:enumeration value="HealthCareFinancingAdministrationCommonProceduralCodingSystemPrincipalProcedure">
        <xsd:enumeration value="HealthCareFinancingAdministrationDurableMedicalEquipmentRegionalCarrierCertificateOfMedicalNecessityForms">
        <xsd:enumeration value="HealthcareProviderCharacteristicsAndResources">
        <xsd:enumeration value="HealthcareProviderTaxonomy">
        <xsd:enumeration value="HealthIndustryNumber">
        <xsd:enumeration value="HealthIndustryOrganizationIdentification">
        <xsd:enumeration value="Hobby">
        <xsd:enumeration value="Icd10">
        <xsd:enumeration value="IdentificationCode">
        <xsd:enumeration value="IdentifyingCharacteristics">
        <xsd:enumeration value="IdentityDisclosureCode">
        <xsd:enumeration value="ImmunizationInjectionCode">
        <xsd:enumeration value="ImpactAxisOrAnalogPortCode">
        <xsd:enumeration value="ImpactRecorderCode">
        <xsd:enumeration value="IncidentConditionCode">
        <xsd:enumeration value="IncidentConsequenceCode">
        <xsd:enumeration value="IncidentLocationCode">
        <xsd:enumeration value="IncidentRelatedActionCode">
        <xsd:enumeration value="Incoterms1980">
        <xsd:enumeration value="IndicatorCode">
        <xsd:enumeration value="IndividualInsuranceFinancialDetail">
        <xsd:enumeration value="IndividualParticipationInCompany">
        <xsd:enumeration value="IndividualSecurityClearance">
        <xsd:enumeration value="IndustryRating">
        <xsd:enumeration value="InformationIndicatorCode">
        <xsd:enumeration value="InformationRequestResult">
        <xsd:enumeration value="InformationRequestType">
        <xsd:enumeration value="InformationType">
        <xsd:enumeration value="InitialTreatmentCode">
        <xsd:enumeration value="InquirySelection">
        <xsd:enumeration value="InspectionParameters">
        <xsd:enumeration value="InsuranceCoverageDetail">
        <xsd:enumeration value="InsuranceInformationIndicator">
        <xsd:enumeration value="InsurancePlanDescriptionCharacteristics">
        <xsd:enumeration value="IntermediateContainerCode">
        <xsd:enumeration value="IntermediateContainerQuantityCode">
        <xsd:enumeration value="InternationalClassificationOfDiseasesClinicalModificationProcedure">
        <xsd:enumeration value="InternationalClassificationOfDiseasesClinicalModificationPrincipalProcedure">
        <xsd:enumeration value="InternationalClassificationOfDiseasesClinicalModification-Icd-9-CmCode">
        <xsd:enumeration value="InternationalStandardDesignationSystemForTeethAndAreasOfTheOralCavity">
        <xsd:enumeration value="InventoryCategoryCode">
        <xsd:enumeration value="InventoryTypeCode">
        <xsd:enumeration value="InvestigationStatusCode">
        <xsd:enumeration value="InvestmentFundType">
        <xsd:enumeration value="InvestmentType">
        <xsd:enumeration value="IrsQualificationCode">
        <xsd:enumeration value="ItemManagementCode">
        <xsd:enumeration value="ItemSourcingCategory">
        <xsd:enumeration value="ItemType">
        <xsd:enumeration value="JobCharacteristicsLookup">
        <xsd:enumeration value="JobOriginatorLookup">
        <xsd:enumeration value="JointLifeInsuranceIndicator">
        <xsd:enumeration value="JudicialHearingTypeCode">
        <xsd:enumeration value="JudicialOrderTypeCode">
        <xsd:enumeration value="JudicialSentenceTypeCode">
        <xsd:enumeration value="JurisdictionType">
        <xsd:enumeration value="KeyEventLookup">
        <xsd:enumeration value="KindOfContractCode">
        <xsd:enumeration value="KindOfModificationCode">
        <xsd:enumeration value="LaboratoryResultsIdentificationCode">
        <xsd:enumeration value="LaboratoryTestConditionCode">
        <xsd:enumeration value="LegalCaseType">
        <xsd:enumeration value="LegalEvent">
        <xsd:enumeration value="LegalStructureCode">
        <xsd:enumeration value="LetterOfRecommendationRatingCategory">
        <xsd:enumeration value="LiabilityDetails">
        <xsd:enumeration value="LiabilityType">
        <xsd:enumeration value="LifeOrAnnuityProductCode">
        <xsd:enumeration value="LifeOrAnnuityServiceFeatures">
        <xsd:enumeration value="LifeOrAnnuityStatusCodes">
        <xsd:enumeration value="LifeReinsuranceMessageType">
        <xsd:enumeration value="LineItemConditionCode">
        <xsd:enumeration value="LineOfAuthority">
        <xsd:enumeration value="LineOfBusinessCode">
        <xsd:enumeration value="LoanType">
        <xsd:enumeration value="LocaleOfActivity">
        <xsd:enumeration value="LocalSourceCode">
        <xsd:enumeration value="LocationCode">
        <xsd:enumeration value="LocationOfGoods">
        <xsd:enumeration value="LocationsForTariffCalculations">
        <xsd:enumeration value="LogicalObservationIdentifierNamesAndCodesCodes">
        <xsd:enumeration value="LogisticsCodeList">
        <xsd:enumeration value="LossDescriptionCode">
        <xsd:enumeration value="LossSeverityCode">
        <xsd:enumeration value="LotTypeCode">
        <xsd:enumeration value="MajorForceProgramCode">
        <xsd:enumeration value="ManagementCode">
        <xsd:enumeration value="ManagementIndicatorCode-Petroleum">
        <xsd:enumeration value="ManualClassCode">
        <xsd:enumeration value="MarineBerth">
        <xsd:enumeration value="MarineWharf">
        <xsd:enumeration value="MarketPlaceOrganizationID">
        <xsd:enumeration value="MarketPlaceTradingPartnerID">
        <xsd:enumeration value="MaterialControlCode">
        <xsd:enumeration value="Materials">
        <xsd:enumeration value="MeansOfCommunicationsIdentifier">
        <xsd:enumeration value="MeansOfTransportIdentification">
        <xsd:enumeration value="MechanizationOfContractAdministrationServicesSystemErrorCode">
        <xsd:enumeration value="MediaAndStatusCode">
        <xsd:enumeration value="MedicaidProvider">
        <xsd:enumeration value="MedicalBenefitsSchedule">
        <xsd:enumeration value="MedicareProvider">
        <xsd:enumeration value="MediumOfTransmissionCode">
        <xsd:enumeration value="MemberOrganizations">
        <xsd:enumeration value="MethodEvaluationCode">
        <xsd:enumeration value="MethodsOfPayment">
        <xsd:enumeration value="MilitaryAndCivilianGradeCode">
        <xsd:enumeration value="MilitaryAssistanceProgramAddressCode">
        <xsd:enumeration value="MinorityIndicator">
        <xsd:enumeration value="MissionImpactStatementCode">
        <xsd:enumeration value="MonetaryFunctionDetail">
        <xsd:enumeration value="MortgageIndexSourceCode">
        <xsd:enumeration value="Multi-MediaObject">
        <xsd:enumeration value="Nacha-NationalAutomatedClearingHouseAssociation">
        <xsd:enumeration value="NationalCouncilForPrescriptionDrugProgramsRejectOrPaymentCodes">
        <xsd:enumeration value="NationalCouncilOnCompensationInsuranceNatureOfInjuryCode">
        <xsd:enumeration value="NationalCouncilOnCompensationInsurancePartOfBodyCode">
        <xsd:enumeration value="NationalCouncilOnCompensationInsuranceSourceOfInjuryCode">
        <xsd:enumeration value="NationalDrugCode">
        <xsd:enumeration value="NationalMotorFreightClassificationCode">
        <xsd:enumeration value="NationalStandardToothNumberingSystem">
        <xsd:enumeration value="NatureOfBuy">
        <xsd:enumeration value="NatureOfDebtCode">
        <xsd:enumeration value="NatureOfEventCode">
        <xsd:enumeration value="NatureOfInjuryCode">
        <xsd:enumeration value="NatureOfSuit">
        <xsd:enumeration value="NatureOfSuitCode">
        <xsd:enumeration value="NatureOfTransaction">
        <xsd:enumeration value="NoLongerConsideredForAwardReason">
        <xsd:enumeration value="NomenclatureActivityClassificationEconomyCode">
        <xsd:enumeration value="Non-PostalTown">
        <xsd:enumeration value="NormeActiviteFrancaiseCode">
        <xsd:enumeration value="NoticeType">
        <xsd:enumeration value="NotificationIndicatorCode">
        <xsd:enumeration value="ObligationVarianceCode">
        <xsd:enumeration value="OccupationalSafetyAndHealthAdministrationNatureOfInjuryCode">
        <xsd:enumeration value="OccupationalSafetyAndHealthAdministrationPartOfBodyCode">
        <xsd:enumeration value="OccupationalSafetyAndHealthAdministrationSourceOfInjuryCode">
        <xsd:enumeration value="OccupationClassification">
        <xsd:enumeration value="OccupationCode">
        <xsd:enumeration value="Occurrence">
        <xsd:enumeration value="OccurrenceSpan">
        <xsd:enumeration value="OceanCarrierCode">
        <xsd:enumeration value="OfferAndReleaseOptionCode">
        <xsd:enumeration value="OfficeOfWorkersCompensationProgramsNatureOfInjuryCode">
        <xsd:enumeration value="OfficeOfWorkersCompensationProgramsOccupationCode">
        <xsd:enumeration value="OfficeOfWorkersCompensationProgramsPartOfBodyCode">
        <xsd:enumeration value="OfficeOfWorkersCompensationProgramsSourceOfInjuryCode">
        <xsd:enumeration value="OperatingStatus">
        <xsd:enumeration value="OperationType">
        <xsd:enumeration value="OversizeOrOverweightCredential">
        <xsd:enumeration value="OwnershipCode">
        <xsd:enumeration value="OwnershipRights">
        <xsd:enumeration value="PackageFailureCode">
        <xsd:enumeration value="PackingAndOrUnpackingFacility">
        <xsd:enumeration value="PackingRequirementLevelACode">
        <xsd:enumeration value="PackingRequirementLevelBCode">
        <xsd:enumeration value="PackingRequirementLevelCCode">
        <xsd:enumeration value="PartOfBodyAffected">
        <xsd:enumeration value="PartOfBodyCode">
        <xsd:enumeration value="PartyIdentification">
        <xsd:enumeration value="PassportNumber">
        <xsd:enumeration value="PatientEventProblemCode">
        <xsd:enumeration value="PaymentBehaviourRating">
        <xsd:enumeration value="PaymentTypeCode">
        <xsd:enumeration value="PedestrianCode">
        <xsd:enumeration value="PersonalPropertyAndContentsCode">
        <xsd:enumeration value="PetroleumBillType">
        <xsd:enumeration value="PetroleumLandCategory">
        <xsd:enumeration value="PetroleumLeaseStatus">
        <xsd:enumeration value="PetroleumProductDisposition">
        <xsd:enumeration value="PetroleumProductPoint-Of-Sale">
        <xsd:enumeration value="PetroleumProductSellingArrangement">
        <xsd:enumeration value="PetroleumProductValueAdjustment">
        <xsd:enumeration value="PetroleumRegulatoryReport">
        <xsd:enumeration value="PetroleumRoyaltyAdjustment">
        <xsd:enumeration value="PetroleumRoyaltyCalculationMethod">
        <xsd:enumeration value="PetroleumRoyaltyTransaction">
        <xsd:enumeration value="PetroleumUnitedStatesGeologicalSurveyFormationCode">
        <xsd:enumeration value="PetroleumWellAction">
        <xsd:enumeration value="PetroleumWellClassificationStatus">
        <xsd:enumeration value="PetroleumWellInformation">
        <xsd:enumeration value="PetroleumWellShut-InReason">
        <xsd:enumeration value="PetroleumWellTestInformation">
        <xsd:enumeration value="PhysicalCharacteristicsCode">
        <xsd:enumeration value="PlantClearanceOfficeCode">
        <xsd:enumeration value="PlusOrMinusIndicatorCode">
        <xsd:enumeration value="PolicyOnClaimIndicator">
        <xsd:enumeration value="PolicyReserveValuationType">
        <xsd:enumeration value="PolicyType">
        <xsd:enumeration value="Port">
        <xsd:enumeration value="PortalID">
        <xsd:enumeration value="PostalDistrict">
        <xsd:enumeration value="PostalServiceCarrierRoute">
        <xsd:enumeration value="PostcodeDirectory">
        <xsd:enumeration value="PostMarketStudyStatusCode">
        <xsd:enumeration value="PreciousMetalsIndicatorCode">
        <xsd:enumeration value="PreservationDataCode">
        <xsd:enumeration value="PreservationMaterialCode">
        <xsd:enumeration value="PreventiveMeasure">
        <xsd:enumeration value="PrimaryDiagnosis">
        <xsd:enumeration value="PrincipalDiagnosis">
        <xsd:enumeration value="PrincipalPartyCitizenshipCode">
        <xsd:enumeration value="PriorityDesignatorCode">
        <xsd:enumeration value="PriorityLookup">
        <xsd:enumeration value="ProducerFinancialHistoryCodes">
        <xsd:enumeration value="ProductCode">
        <xsd:enumeration value="ProductQualityDeficiencyReportSummaryCode">
        <xsd:enumeration value="ProductSupplyCondition">
        <xsd:enumeration value="ProfessionalDesignation">
        <xsd:enumeration value="ProfessionalStatusCode">
        <xsd:enumeration value="ProfessionTypeCode">
        <xsd:enumeration value="ProgramOriginatorCode">
        <xsd:enumeration value="ProgramYearCode">
        <xsd:enumeration value="ProjectCode">
        <xsd:enumeration value="ProjectionType">
        <xsd:enumeration value="PropertyOwnershipExtent">
        <xsd:enumeration value="PropertyOwnershipTypeCode">
        <xsd:enumeration value="PropertyRecordStatusCode">
        <xsd:enumeration value="PropertySourceCode">
        <xsd:enumeration value="PropertyType">
        <xsd:enumeration value="PropertyUnderwritingConditionCode">
        <xsd:enumeration value="Proprietary">
        <xsd:enumeration value="PurchasingContractOfficerInstructionsCode">
        <xsd:enumeration value="PurposeCode">
        <xsd:enumeration value="QualityAlertListReason">
        <xsd:enumeration value="QualityAssuranceSiteCode">
        <xsd:enumeration value="QualityConformance">
        <xsd:enumeration value="QualityControlCode">
        <xsd:enumeration value="QuantityPerUnitPackCode">
        <xsd:enumeration value="QueryOptions">
        <xsd:enumeration value="QueryStatus">
        <xsd:enumeration value="RadioFrequencyType">
        <xsd:enumeration value="RadioServiceType">
        <xsd:enumeration value="RadioSystemType">
        <xsd:enumeration value="RailAdditionalCharges">
        <xsd:enumeration value="RailcarLetterMarking">
        <xsd:enumeration value="RailDocumentNames">
        <xsd:enumeration value="RailHandlingRestrictionsAndInstructions">
        <xsd:enumeration value="RailHarmonizedCodificationOfTariffs">
        <xsd:enumeration value="RailHarmonizedEquipmentType">
        <xsd:enumeration value="RailRoutes">
        <xsd:enumeration value="RailUnifiedNomenclatureOfGoods">
        <xsd:enumeration value="RailwayCompanyNetwork">
        <xsd:enumeration value="RailwayCustomer">
        <xsd:enumeration value="RailwayFrontierAndTransitPoint">
        <xsd:enumeration value="RailwayLocations">
        <xsd:enumeration value="RailwayServicesHarmonizedCode">
        <xsd:enumeration value="RateClass">
        <xsd:enumeration value="RatingSummaryValue">
        <xsd:enumeration value="RealEstateAssetType">
        <xsd:enumeration value="ReasonForContractDeliveryDateRevisionCode">
        <xsd:enumeration value="ReasonForDelayedClosingOfContractFileCode">
        <xsd:enumeration value="ReasonForDisposalCode">
        <xsd:enumeration value="ReasonForFinancialItemDetailChange">
        <xsd:enumeration value="ReasonForPublicRecordFiling">
        <xsd:enumeration value="ReasonForRequisitioningCode">
        <xsd:enumeration value="RecipientOfBillingStatusCode">
        <xsd:enumeration value="RecommendationsRegardingDelayedDeliveriesCode">
        <xsd:enumeration value="RecordControlNumber">
        <xsd:enumeration value="RecordPrecedenceBasedOnItsCurrencyInTime">
        <xsd:enumeration value="ReferenceAndStationCode">
        <xsd:enumeration value="RefrigerationUnitOperatingModeCode">
        <xsd:enumeration value="Region">
        <xsd:enumeration value="RegisteredContractorActivityCode">
        <xsd:enumeration value="RegistrationType">
        <xsd:enumeration value="ReinsuranceMonetaryType">
        <xsd:enumeration value="ReinsurancePolicyAttributes">
        <xsd:enumeration value="RejectAdviceCode">
        <xsd:enumeration value="RejectIndicatorCode">
        <xsd:enumeration value="RelatedDeviceApplicabilityCode">
        <xsd:enumeration value="ReligiousAffiliationCode">
        <xsd:enumeration value="RemedialActionCode">
        <xsd:enumeration value="RemovableAccessoriesAndSpecialEquipmentOnRailcars">
        <xsd:enumeration value="RentalCharge">
        <xsd:enumeration value="RepairFacility">
        <xsd:enumeration value="ReportableEventCode">
        <xsd:enumeration value="ReportableEventStatusCode">
        <xsd:enumeration value="ReportCode">
        <xsd:enumeration value="ReportDistributionCode">
        <xsd:enumeration value="ReportSourceCode">
        <xsd:enumeration value="RepresentativeBuyIndicator">
        <xsd:enumeration value="RequestCode">
        <xsd:enumeration value="RequestType">
        <xsd:enumeration value="RequirementCode">
        <xsd:enumeration value="RequirementsIndicator">
        <xsd:enumeration value="ResidencyIndicator">
        <xsd:enumeration value="ResidentialAndCommercialRoomCode">
        <xsd:enumeration value="ResponseStatusCode">
        <xsd:enumeration value="RestrictionsAndProhibitionsPlacedOnTheRe-UseOf">
        <xsd:enumeration value="ResultEvaluationCode">
        <xsd:enumeration value="ReviewPeriodIndicatorCode">
        <xsd:enumeration value="RiskClass">
        <xsd:enumeration value="RoadCharacteristicCode">
        <xsd:enumeration value="RoadwayDetail">
        <xsd:enumeration value="RoadwayType">
        <xsd:enumeration value="RouteCode">
        <xsd:enumeration value="RunType">
        <xsd:enumeration value="SafetyAndFitnessElectronicRecordSystemsErrorCode">
        <xsd:enumeration value="SafetyAndFitnessElectronicRecordSystemsSubscriptionOption">
        <xsd:enumeration value="SafetyHazardLookup">
        <xsd:enumeration value="SafetyRegulation">
        <xsd:enumeration value="SalesPriceConditionCode">
        <xsd:enumeration value="SalvageDispositionCode">
        <xsd:enumeration value="SampleExtractionLocation">
        <xsd:enumeration value="SeavanOwnershipCode">
        <xsd:enumeration value="SecondaryDiagnosis">
        <xsd:enumeration value="SecondarySourceOfInjury">
        <xsd:enumeration value="SecurityShareType">
        <xsd:enumeration value="Service">
        <xsd:enumeration value="ServiceAndAgencyCode">
        <xsd:enumeration value="ServiceContractActOccupationCategoryCode">
        <xsd:enumeration value="ServiceContractActOccupationClassificationCode">
        <xsd:enumeration value="ServiceContractActOperationCode">
        <xsd:enumeration value="SettlementOrPayoutOptions">
        <xsd:enumeration value="ShareTypeCode">
        <xsd:enumeration value="ShelfLifeCode">
        <xsd:enumeration value="ShipmentAcceptanceDiscrepancyExplanationCode">
        <xsd:enumeration value="ShipmentDescription">
        <xsd:enumeration value="ShipmentHoldCode">
        <xsd:enumeration value="ShipmentReleaseCode">
        <xsd:enumeration value="ShippingAgent">
        <xsd:enumeration value="SignalCode">
        <xsd:enumeration value="SingleStateRegistrationSystemAndOperatingAuthorityCredential">
        <xsd:enumeration value="SingleUseLabelCode">
        <xsd:enumeration value="SizeAndType">
        <xsd:enumeration value="SkinToneCode">
        <xsd:enumeration value="SmallArmsErrorTransactionRejectCode">
        <xsd:enumeration value="SmallArmsTransactionCode">
        <xsd:enumeration value="SocialSecurityIdentification">
        <xsd:enumeration value="SolicitationCancellationReason">
        <xsd:enumeration value="SolicitationMethod">
        <xsd:enumeration value="SoundCode">
        <xsd:enumeration value="Source">
        <xsd:enumeration value="SourceMaintenanceAndRecoverabilityCode">
        <xsd:enumeration value="SourceOfDepositCode">
        <xsd:enumeration value="SourceOfDisclosure">
        <xsd:enumeration value="SourceOfInjuryCode">
        <xsd:enumeration value="SourceOfLeadCode">
        <xsd:enumeration value="SourceOfLossCode">
        <xsd:enumeration value="SpecialCategoryCode">
        <xsd:enumeration value="SpecialContractProvisionCode">
        <xsd:enumeration value="SpecialDating">
        <xsd:enumeration value="SpecialHandling">
        <xsd:enumeration value="SpecialMarketingTypeCode">
        <xsd:enumeration value="SpecialMarkingCode">
        <xsd:enumeration value="SpecialMaterialIdentificationCode">
        <xsd:enumeration value="SpecialProgramRequirementStatusCode">
        <xsd:enumeration value="SpecialReimbursableProvisionsCode">
        <xsd:enumeration value="SpecialRequirementLookup">
        <xsd:enumeration value="SpecialRequirementsCode">
        <xsd:enumeration value="StandardIndustrialClassification">
        <xsd:enumeration value="StandardOccupationClassificationCode">
        <xsd:enumeration value="StandardTextAccordingUSEmbargoRegulations">
        <xsd:enumeration value="StandardTextClauses">
        <xsd:enumeration value="StandardTextForExportAccordingNationalPrescriptions">
        <xsd:enumeration value="StateCode">
        <xsd:enumeration value="StationClassification">
        <xsd:enumeration value="StationClassificationType">
        <xsd:enumeration value="StatisticalAdministrativeInformationCode">
        <xsd:enumeration value="StatisticalNatureOfTransaction">
        <xsd:enumeration value="StatisticalObject">
        <xsd:enumeration value="StatisticalProcedures">
        <xsd:enumeration value="StatisticBundesAmtCode">
        <xsd:enumeration value="StatusCode">
        <xsd:enumeration value="StockExchangeCode">
        <xsd:enumeration value="StockExchangeDetail">
        <xsd:enumeration value="StockFundOrNon-StockFundCode">
        <xsd:enumeration value="StorageFacility">
        <xsd:enumeration value="StudentActivityTypeCode">
        <xsd:enumeration value="StudentAwardCode">
        <xsd:enumeration value="SubcaseNumber">
        <xsd:enumeration value="SubrogationActionCode">
        <xsd:enumeration value="SubrogationPaymentOptions">
        <xsd:enumeration value="SubrogationRequestCodes">
        <xsd:enumeration value="SubrogationResponseCodes">
        <xsd:enumeration value="SubsistenceTypeOfPackCode">
        <xsd:enumeration value="SuffixCode">
        <xsd:enumeration value="SuffixOrLimitCode">
        <xsd:enumeration value="SummonsTypeCode">
        <xsd:enumeration value="SupplementalData">
        <xsd:enumeration value="SupplementaryAccountingClassificationCode">
        <xsd:enumeration value="SuppliersStockTurnover">
        <xsd:enumeration value="SupplyConditionCode">
        <xsd:enumeration value="SurfaceDescriptorCode">
        <xsd:enumeration value="SWIFT">
        <xsd:enumeration value="SyntaxNotes">
        <xsd:enumeration value="SystematizedNomenclatureOfHumanAndVeterinaryMedicine">
        <xsd:enumeration value="SystemStatus">
        <xsd:enumeration value="TariffSchedule">
        <xsd:enumeration value="TaxAssessmentMethod">
        <xsd:enumeration value="TaxOrFeeExemptionReasonCode">
        <xsd:enumeration value="TaxPartyIdentification">
        <xsd:enumeration value="TechnicalAssessmentChecklist">
        <xsd:enumeration value="TelephoneDirectory">
        <xsd:enumeration value="TemplateCharacteristicLookup">
        <xsd:enumeration value="TemplateOwnerLookup">
        <xsd:enumeration value="TemplateTypeLookup">
        <xsd:enumeration value="Termination">
        <xsd:enumeration value="TermsOfDelivery">
        <xsd:enumeration value="TertiaryDiagnosis">
        <xsd:enumeration value="TestingDemographicCategoryCodeList">
        <xsd:enumeration value="TestingServiceQuestionCodeList">
        <xsd:enumeration value="TestingStatisticalCategoryCodeList">
        <xsd:enumeration value="TestResultsCode">
        <xsd:enumeration value="TitleDocumentCodeList">
        <xsd:enumeration value="TitleExceptionAndRequirementCodeList">
        <xsd:enumeration value="TradeCode">
        <xsd:enumeration value="TrainIdentification">
        <xsd:enumeration value="TransactionStatusIndicatorCode">
        <xsd:enumeration value="TransportationBillCode">
        <xsd:enumeration value="TransportationHoldingDelayCode">
        <xsd:enumeration value="TransportationModeOrMethodCode">
        <xsd:enumeration value="TransportationModeReasonCode">
        <xsd:enumeration value="TransportationPriorityCode">
        <xsd:enumeration value="TreasuryManagementAssociationServiceCode">
        <xsd:enumeration value="TreasuryManagementAssociationServiceCodeAndBankServiceCode">
        <xsd:enumeration value="TreasurySymbolCode">
        <xsd:enumeration value="TreatmentCodes">
        <xsd:enumeration value="TrendReason">
        <xsd:enumeration value="TrialTypeCode">
        <xsd:enumeration value="TypeAdjustmentCode">
        <xsd:enumeration value="TypeAndCauseCode">
        <xsd:enumeration value="TypeDue-InIndicator">
        <xsd:enumeration value="TypeIdentityChangeCode">
        <xsd:enumeration value="TypeInspectionCode">
        <xsd:enumeration value="TypeNumericalControlSystemCode">
        <xsd:enumeration value="TypeOfAssetsAndLiabilities">
        <xsd:enumeration value="TypeOfAssistanceCode">
        <xsd:enumeration value="TypeOfBillCode">
        <xsd:enumeration value="TypeOfBusinessCode">
        <xsd:enumeration value="TypeOfCargoCode">
        <xsd:enumeration value="TypeOfContractCode">
        <xsd:enumeration value="TypeOfContractorCode">
        <xsd:enumeration value="TypeOfDelayCode">
        <xsd:enumeration value="TypeOfFinancialAccount">
        <xsd:enumeration value="TypeOfFirmCode">
        <xsd:enumeration value="TypeOfIndustrialActivity">
        <xsd:enumeration value="TypeOfInquiryCode">
        <xsd:enumeration value="TypeOfInsured">
        <xsd:enumeration value="TypeOfIssueCode">
        <xsd:enumeration value="TypeOfLocationReconciliationRequest">
        <xsd:enumeration value="TypeOfMediaCode">
        <xsd:enumeration value="TypeOfPackage">
        <xsd:enumeration value="TypeOfProcurement">
        <xsd:enumeration value="TypeOfStorageCode">
        <xsd:enumeration value="TypeOfSurveyQuestion">
        <xsd:enumeration value="TypePackCode">
        <xsd:enumeration value="TypePhysicalInventoryOrTransactionHistoryCode">
        <xsd:enumeration value="UltimateRecipientCode">
        <xsd:enumeration value="UnclaimedPropertyAdditionsDeletionsAndDeductionsCodes">
        <xsd:enumeration value="UnclaimedPropertyTypeCode">
        <xsd:enumeration value="UniformFreightClassificationCode">
        <xsd:enumeration value="UniformResidentialAppraisalAttributesCode">
        <xsd:enumeration value="UnitCode">
        <xsd:enumeration value="UnitedNationsCommonCodingSystem">
        <xsd:enumeration value="UnitedNationsStandardProductsAndServices">
        <xsd:enumeration value="UnitedStatesDepartmentOfHealthAndHumanServicesOfficeOfVitalStatisticsE-Code">
        <xsd:enumeration value="UnsolicitedProposalRejectionReason">
        <xsd:enumeration value="UtilizationCode">
        <xsd:enumeration value="VaccinationInnoculationOrIsolationCode">
        <xsd:enumeration value="ValuationTypeCode">
        <xsd:enumeration value="Value">
        <xsd:enumeration value="ValueAddedTaxIdentification">
        <xsd:enumeration value="VehicleClass">
        <xsd:enumeration value="VehicleOccupantCode">
        <xsd:enumeration value="VehicleParameters">
        <xsd:enumeration value="VesselStatusAndTermsOfCarriageCode">
        <xsd:enumeration value="VesselStowageLocationCode">
        <xsd:enumeration value="VesselSustainingCode">
        <xsd:enumeration value="ViewParameters">
        <xsd:enumeration value="ViolationTypeCodeList">
        <xsd:enumeration value="VoyageDocumentNumberCode">
        <xsd:enumeration value="VoyageManifestReferenceCode">
        <xsd:enumeration value="Warehouse">
        <xsd:enumeration value="WarReserveMaterialRequirementCode">
        <xsd:enumeration value="WaterCommodityAndSpecialHandlingCode">
        <xsd:enumeration value="WaterTerminalIdentifierCode">
        <xsd:enumeration value="WeightOrFragilityCode">
        <xsd:enumeration value="WhenDiscoveredLookup">
    </xsd:restriction>
</xsd:simpleType>


Complex Types:

AcademicTitleType
AccountAssignmentType
ListOfAccountAssignmentType
AccountDetailType
ActualPaymentStatusType
ActualPaymentType
ListOfActualPaymentType
AgencyType
AllowOrChargeSummaryType
AllowOrChargeTreatmentType
AllowOrChargeType
ListOfAllowOrChargeType
AllowOrChgDescType
AssociatedDocumentsType
AttachmentType
ListOfAttachmentType
BaseItemReferencesType
BasisMonetaryRangeType
CardInfoType
CargoClassificationType
CatalogReferenceType
CategoryType
ChangeTypeType
ConditionsOfSaleType
ConditionsType
ContactFunctionType
ContactNumberType
ListOfContactNumberType
ContactType
ListOfContactType
ContractType
ListOfContractType
ContractTypeType
CostCenterType
ListOfCostCenterType
CountryType
CurrencyType
ListOfCurrencyType
DateCodedType
ListOfDateCodedType
DateQualifierType
DeliveryDetailType
DestinationRefType
ListOfDestinationRefType
DimensionType
ListOfDimensionType
DiscountsType
ErrorInfoType
ListOfErrorInfoType
FIAccountDetailType
FIAccountType
FinancialInstitutionDetailType
FinancialInstitutionType
FITransferType
GPSCoordinatesType
HazardousIdentifiersType
ListOfHazardousIdentifiersType
HazardousPlacardInformationType
HazardousShipmentInformationType
HazardousTemperaturesType
HazardousType
ListOfHazardousType
IDAssignedByType
IdentifierType
ListOfIdentifierType
ItemCharacteristicType
ListOfItemCharacteristicType
ItemIdentifiersType
ItemPackagingReferenceType
LanguageStringType
ListOfLanguageStringType
LanguageType
ListOfLanguageType
LineItemNumberReferenceType
LineItemNumType
LineItemRequisitionReferenceType
LineItemTypeType
LocationIdentifierType
LocationType
ListOfLocationType
ManufacturerPartNumberType
MaximumValueType
MeasurementRangeType
MeasurementType
ListOfMeasurementType
MeasurementValueType
MinimumValueType
MonetaryLimitType
MonetaryRangeType
MonetaryValueType
NameAddressType
ListOfNameAddressType
NameValuePairType
ListOfNameValuePairType
NameValueSetType
ListOfNameValueSetType
OrderTypeType
PackageCharacteristicType
ListOfPackageCharacteristicType
PackageDescriptionType
ListOfPackageDescriptionType
PackageDetailType
ListOfPackageDetailType
PackageDocType
ListOfPackageDocType
PackageIdentifierType
ListOfPackageIdentifierType
PackageItemReferenceType
ListOfPackageItemReferenceType
PackageMarkType
ListOfPackageMarkType
PackageReferenceType
PackageType
ListOfPackageType
PackageTypeType
ListOfPackageTypeType
ListOfParameterType
PartialOrderType
PartNumbersType
PartNumType
ListOfPartNumType
PartyCodedType
ListOfPartyCodedType
PartyTaxInformationType
PartyType
ListOfPartyType
PaymentAmountType
PaymentInstructionsType
ListOfPaymentInstructionsType
PaymentMeanType
PaymentMethodType
PaymentRecordType
PaymentTermsType
PaymentTermType
PercentageAllowanceOrChargeType
PercentQualifierType
PercentType
POBoxType
PriceMultiplierType
PriceType
ListOfPriceType
PricingDetailType
PricingTypeType
ProductIdentifierCodedType
ListOfProductIdentifierCodedType
PurchaseOrderReferenceType
ListOfPurchaseOrderReferenceType
PurposeType
QuantityAllowanceOrChargeType
QuantityCodedType
ListOfQuantityCodedType
QuantityRangeType
QuantityType
ListOfQuantityType
QuantityValueType
RangeType
RateOfExchangeDetailType
ListOfRateOfExchangeDetailType
RateType
ReferenceCodedType
ListOfReferenceCodedType
ReferenceType
ListOfReferenceType
RegionType
ListOfRegionType
RequestedResponseType
ResponseTypeType
ReturnableContainerInfoType
RoundTripInformationType
SalesRequirementType
ScheduleLineType
ListOfScheduleLineType
SealInfoType
ListOfSealInfoType
SealIssuerType
SealStatusDescriptionType
ServiceLevelType
SeverityType
ShipmentStatusEventType
ShipToSubInformationType
ListOfShipToSubInformationType
SpecialHandlingType
StandardCategoryIDType
StatusEventType
StatusReasonType
ListOfStatusReasonType
StatusType
StructuredNoteType
ListOfStructuredNoteType
TaxReferenceType
TaxSummaryType
ListOfTaxSummaryType
TaxType
TermsOfDeliveryType
TimeDueType
TimezoneType
ListOfTimezoneType
TitleType
TotalAllowOrChargeType
TransitDirectionType
TransportEquipmentType
ListOfTransportEquipmentType
TransportLocationListType
TransportLocationType
TransportMeansType
TransportModeType
TransportPackagingTotalsType
TransportQuantitiesType
TransportRoutingType
ListOfTransportRoutingType
TypeOfAllowanceOrChargeType
UnitOfMeasurementType
UnitPriceType
UOMType
ValidityDatesType
ListOfValuesType


simpleType definition: ConditionsCodeType

ConditionsCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the conditions that apply to a measurement value. This code list is derived from X12 935 (Measurement significance code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • WhereAirEquals1
    • WhereButylAcetateEquals1
    • WhereH2OEquals1OrWaterEquals1
    • CorrectedTo60DegreesFahrenheit
    • WhereTolueneEquals1
    • VaporInAir
    • VaporInOtherThanAir
    • StandardTemperatureAndPressure
    • ConditionsOtherThanStandardTemperatureAndPressure
    • InEthylAlcohol
    • InEthylEther
    • InWater
    • At1AtmospherePressure
    • WhereEtherEquals1
    • Actual
    • Predicted
    • Air-DriedBasis
    • As-ReceivedBasis
    • DryBasis
    • EquilibriumBasis
    • MoistureAndAsh-FreeBasis
    • OxidizingAtmosphere
    • ReducingAtmosphere
    • Calculated
    • ScaledWeight
    • Ratchet
    • SaturatedVapor
    • Unconditional
    • Short-Term
    • Time-Weighted
    • Corrected
    • Uncorrected
    • OffPeak
    • OnPeak
    • Intermediate
    • Average
    • PerGallon
    • Estimated
    • Minimum
    • Mist
    • Predominant
    • Total
    • Cost
    • Tenant
    • Owner
    • ForSale
    • RealEstateOwnedOrCorporateOwned
    • BoardedOrBlockedUp
    • Planned
    • Completed
    • Sold
    • Rented
    • Current
    • CurrentList
    • Effective
    • ListWhenSold
    • Sales
    • FinalList
    • AsIs
    • AsRepairedOrImproved
    • Instantaneous
    • Low
    • LowToGood
    • LowToHigh
    • LowToMedium
    • LowToModerate
    • Medium
    • MediumToGood
    • MediumToHigh
    • Moderate
    • ModerateToGood
    • ModerateToHigh
    • ModerateToMedium
    • Good
    • GoodToHigh
    • High
    • Budgeted
    • Forecast
    • Adjusted
    • Allocated
    • Increasing
    • Stable
    • Declining
    • Previous
    • Potential
    • Modeled
    • Measured
    • Maximum
    • SummerOn-Peak
    • SummerMid-Peak
    • SummerOff-Peak
    • SummerSuperOn-Peak
    • SummerSuperOff-Peak
    • WinterOn-Peak
    • WinterMid-Peak
    • WinterOff-Peak
    • WinterSuperOn-Peak
    • WinterSuperOff-Peak
    • SummerDay
    • SummerNight
    • WinterDay
    • WinterNight
    • Summer
    • Winter
    • Day
    • Night
    • Peak-2
    • Peak-3
    • Peak-4
    • Shoulder
    • NonTimeRelatedDemand

[^]Code Fragment

    <xsd:simpleType name="ConditionsCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="WhereAirEquals1">
        <xsd:enumeration value="WhereButylAcetateEquals1">
        <xsd:enumeration value="WhereH2OEquals1OrWaterEquals1">
        <xsd:enumeration value="CorrectedTo60DegreesFahrenheit">
        <xsd:enumeration value="WhereTolueneEquals1">
        <xsd:enumeration value="VaporInAir">
        <xsd:enumeration value="VaporInOtherThanAir">
        <xsd:enumeration value="StandardTemperatureAndPressure">
        <xsd:enumeration value="ConditionsOtherThanStandardTemperatureAndPressure">
        <xsd:enumeration value="InEthylAlcohol">
        <xsd:enumeration value="InEthylEther">
        <xsd:enumeration value="InWater">
        <xsd:enumeration value="At1AtmospherePressure">
        <xsd:enumeration value="WhereEtherEquals1">
        <xsd:enumeration value="Actual">
        <xsd:enumeration value="Predicted">
        <xsd:enumeration value="Air-DriedBasis">
        <xsd:enumeration value="As-ReceivedBasis">
        <xsd:enumeration value="DryBasis">
        <xsd:enumeration value="EquilibriumBasis">
        <xsd:enumeration value="MoistureAndAsh-FreeBasis">
        <xsd:enumeration value="OxidizingAtmosphere">
        <xsd:enumeration value="ReducingAtmosphere">
        <xsd:enumeration value="Calculated">
        <xsd:enumeration value="ScaledWeight">
        <xsd:enumeration value="Ratchet">
        <xsd:enumeration value="SaturatedVapor">
        <xsd:enumeration value="Unconditional">
        <xsd:enumeration value="Short-Term">
        <xsd:enumeration value="Time-Weighted">
        <xsd:enumeration value="Corrected">
        <xsd:enumeration value="Uncorrected">
        <xsd:enumeration value="OffPeak">
        <xsd:enumeration value="OnPeak">
        <xsd:enumeration value="Intermediate">
        <xsd:enumeration value="Average">
        <xsd:enumeration value="PerGallon">
        <xsd:enumeration value="Estimated">
        <xsd:enumeration value="Minimum">
        <xsd:enumeration value="Mist">
        <xsd:enumeration value="Predominant">
        <xsd:enumeration value="Total">
        <xsd:enumeration value="Cost">
        <xsd:enumeration value="Tenant">
        <xsd:enumeration value="Owner">
        <xsd:enumeration value="ForSale">
        <xsd:enumeration value="RealEstateOwnedOrCorporateOwned">
        <xsd:enumeration value="BoardedOrBlockedUp">
        <xsd:enumeration value="Planned">
        <xsd:enumeration value="Completed">
        <xsd:enumeration value="Sold">
        <xsd:enumeration value="Rented">
        <xsd:enumeration value="Current">
        <xsd:enumeration value="CurrentList">
        <xsd:enumeration value="Effective">
        <xsd:enumeration value="ListWhenSold">
        <xsd:enumeration value="Sales">
        <xsd:enumeration value="FinalList">
        <xsd:enumeration value="AsIs">
        <xsd:enumeration value="AsRepairedOrImproved">
        <xsd:enumeration value="Instantaneous">
        <xsd:enumeration value="Low">
        <xsd:enumeration value="LowToGood">
        <xsd:enumeration value="LowToHigh">
        <xsd:enumeration value="LowToMedium">
        <xsd:enumeration value="LowToModerate">
        <xsd:enumeration value="Medium">
        <xsd:enumeration value="MediumToGood">
        <xsd:enumeration value="MediumToHigh">
        <xsd:enumeration value="Moderate">
        <xsd:enumeration value="ModerateToGood">
        <xsd:enumeration value="ModerateToHigh">
        <xsd:enumeration value="ModerateToMedium">
        <xsd:enumeration value="Good">
        <xsd:enumeration value="GoodToHigh">
        <xsd:enumeration value="High">
        <xsd:enumeration value="Budgeted">
        <xsd:enumeration value="Forecast">
        <xsd:enumeration value="Adjusted">
        <xsd:enumeration value="Allocated">
        <xsd:enumeration value="Increasing">
        <xsd:enumeration value="Stable">
        <xsd:enumeration value="Declining">
        <xsd:enumeration value="Previous">
        <xsd:enumeration value="Potential">
        <xsd:enumeration value="Modeled">
        <xsd:enumeration value="Measured">
        <xsd:enumeration value="Maximum">
        <xsd:enumeration value="SummerOn-Peak">
        <xsd:enumeration value="SummerMid-Peak">
        <xsd:enumeration value="SummerOff-Peak">
        <xsd:enumeration value="SummerSuperOn-Peak">
        <xsd:enumeration value="SummerSuperOff-Peak">
        <xsd:enumeration value="WinterOn-Peak">
        <xsd:enumeration value="WinterMid-Peak">
        <xsd:enumeration value="WinterOff-Peak">
        <xsd:enumeration value="WinterSuperOn-Peak">
        <xsd:enumeration value="WinterSuperOff-Peak">
        <xsd:enumeration value="SummerDay">
        <xsd:enumeration value="SummerNight">
        <xsd:enumeration value="WinterDay">
        <xsd:enumeration value="WinterNight">
        <xsd:enumeration value="Summer">
        <xsd:enumeration value="Winter">
        <xsd:enumeration value="Day">
        <xsd:enumeration value="Night">
        <xsd:enumeration value="Peak-2">
        <xsd:enumeration value="Peak-3">
        <xsd:enumeration value="Peak-4">
        <xsd:enumeration value="Shoulder">
        <xsd:enumeration value="NonTimeRelatedDemand">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: ConditionsOfSaleType

ConditionsOfSaleType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( SalesRequirement[SalesRequirementType]+ , SalesActionCoded[SalesActionCodeType]? , SalesActionCodedOther[xsd:string]? , SalesActionValue[xsd:string]? )

    Description: ConditionsOfSaleType details the conditions of sale for the item.

    Elements:

    • SalesRequirement - outlines any specific sales information relating to the item.
    • SalesActionCoded - code indicating what action should be undertaken in specific circumstances.
    • SalesActionCodedOther - is used to provide a non-standard SalesActionCode. This element is mandatory if the value of SalesActionCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • SalesActionValue - is the value associated with the action code.

[^]Code Fragment

    <xsd:complexType name="ConditionsOfSaleType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="SalesRequirement" type="SalesRequirementType">
        <xsd:element minOccurs="0" name="SalesActionCoded" type="SalesActionCodeType">
        <xsd:element minOccurs="0" name="SalesActionCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="SalesActionValue" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ConditionsType

ConditionsType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( RefrigerationOn[xsd:boolean]? , Residue[xsd:boolean]? , ListOfConditions[ListOfDimensionType]? )

    Description: ConditionsType describes the special conditions regarding the equipment.

    Elements:

    • RefrigerationOn - defines whether the refrigeration is on or off.
    • Residue - indicates that the shipment is not a loaded movement but contains a residue from a prior movement.
    • ListOfConditions - lists the conditions of the equipment.

[^]Code Fragment

    <xsd:complexType name="ConditionsType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="RefrigerationOn" type="xsd:boolean">
        <xsd:element minOccurs="0" name="Residue" type="xsd:boolean">
        <xsd:element minOccurs="0" name="ListOfConditions" type="ListOfDimensionType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: ContactFunctionCodeType

ContactFunctionCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the major duty or responsibility of the person or department for contact purposes. This code list is derived from EDIFACT 3139 (Contact function code) and X12 366 (Contact function code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • AcceptingContact - Department/person in charge of accepting incoming goods.
    • AcceptingOfficial
    • Accountingcontact - The contact responsible for accounting matters.
    • AccountsPayableContact - Department/person responsible for the accounts payable function within a corporation.
    • AccountsReceivableContact - Department/person responsible for the accounts receivable within a corporation.
    • AdditionalInsuranceInformationContact
    • AdministrativeContractingOfficer
    • Administrator
    • Advisor
    • After-HoursContact
    • Agent - Department/person of the agent which acts on behalf of another party.
    • AlternateContact - Alternate department or person to contact.
    • Applicant
    • AppointmentScheduler
    • Appraiser
    • Attention-ToParty
    • Attorney
    • AuditingContact - Department or person to contact with regard to auditing.
    • AuthorizedFinancialContact
    • AuthorizedNegotiator
    • AuthorizedRepresentative
    • AuthorizedSignature
    • AutomatedClearinghouseContact - Code specifying a person to be contacted at an automated clearing house.
    • BankingContact - Contact person for bank.
    • BillInquiryContact
    • BoardStaff
    • Broker
    • BrokerContact
    • BusinessUnitManager
    • BuyerNameorDepartment
    • CADAndCAMSpecialist
    • Carrier - (3126) Party undertaking or arranging transport of goods between named points.
    • CaseManager
    • CertificationContact - Code specifying a contact with knowledge of a certification action.
    • Certifier
    • ChairmanOfTheBoard
    • ChangedBy - Person who made the change.
    • ChangeOrderApprover
    • ChiefExecutiveOfficer
    • ChiefFinancialOfficer
    • ChiefInformationOfficer
    • ChiefOperatingOfficer
    • CityWorksAuthorityContact - Department/person to contact for matters regarding city works.
    • Claimant
    • ClaimApprover
    • ClaimRecipient
    • ClaimsContact - Department/person to contact for matters regarding claims.
    • ClearinghouseContact
    • ClerkOfCourt
    • Co-Borrower
    • Co-Investigator
    • Collector
    • CollegeofEducationAdmissionsOffice
    • ComplianceOfficer
    • ComponentEngineer
    • ComputerSystemsContact
    • ConcurrentEmployerContact
    • ConfirmedWith - Person with whom the contents of the purchase order has been discussed and agreed (e.g. by telephone) prior to the sending of this message.
    • Consignee - (3132) Party to which goods are consigned.
    • Consignor - (3336) Party which, by contract with a carrier, consigns or sends goods with the carrier, or has them conveyed by him. Synonym: shipper/sender.
    • ContainerManager
    • ContractContact - Department/person to contact for matters regarding contracts.
    • CoordinationContact - Department/person to contact for matters regarding technical coordination of works.
    • Coordinator
    • CorporatePurchasingAgent
    • CostAndScheduleCoordinator
    • CustomerContactGrantingAppointment
    • CustomerEngineer
    • CustomerMaintenanceManager
    • CustomerRelations - Individual responsible for customer relations.
    • DangerousGoodsContact - Department/person to be contacted for details about the transportation of dangerous goods/hazardous material.
    • DeliveryContact - Department/person responsible for delivery.
    • DeliveryInstructionsContact
    • DentalSchoolAdmissionsOffice
    • DepartmentOrEmployeeToExecuteExportProcedures
    • DepartmentOrEmployeeToExecuteImportProcedures
    • DepartmentOrPersonResponsibleForProcessingPurchaseOrder - Identification of the department or person responsible for the processing of purchase orders.
    • DesignEngineer
    • Development
    • Director
    • DirectoryAdvertisingContact
    • DivisionDirector
    • DivisionManager
    • EDICoordinator
    • EducationCoordinator - Person in charge of coordination of education.
    • ElectricitySupplyContact - Department/person to contact for matters regarding electricity supply.
    • ElectronicDataInterchangeCoordinator - Code specifying a person responsible for the coordination of matters related to the exchange of information in electronic data interchange format.
    • ElectronicSubmissionRecipient
    • EmergencyContact
    • EmergencyContact-Consignee
    • EmergencyContact-MilitaryTrafficManagementCommand
    • EmergencyContact-Shipper
    • EmergencyDangerousGoodsContact - Party who is to be contacted to intervene in case of emergency.
    • EmployerContact
    • Engineer
    • EngineeringContact - Department/person to contact for matters regarding engineering.
    • EnteredBy - Name of an individual who made the entry.
    • Estimator
    • EveningProgramsOffice
    • ExecutiveOfficer
    • ExecutiveVice-President
    • Expeditor - The contact for expediting.
    • FinancialAidOffice
    • ForeclosingLenderAdministrativeContact
    • ForwarderContact
    • FunctionalManager
    • GasSupplyContact - Department/person to contact for matters regarding gas supply.
    • GeneralContact
    • GoodsReceivingContact - Department/person responsible for receiving the goods at the place of delivery.
    • GraduateAdmissionsOffice
    • GraduateBusinessOffice
    • GraduateEngineeringOffice
    • GraduateFineArtsOffice
    • GuidanceCounselor
    • HazardousMaterialContact - Department/person responsible for hazardous material control.
    • HeadOfUnitForInformationDissemination - Head of unit to contact for matters regarding dissemination of information.
    • HeadOfUnitForInformationProduction - Head of unit to contact for matters regarding the production information.
    • HeadOfUnitOrComputerDataProcessing - Head of unit to contact for matters regarding computer data processing.
    • HealthMaintenanceOrganizationContact
    • HumanResources
    • InformationContact - Department/person to contact for questions regarding transactions.
    • InsuranceContact - Department/person to contact for matters regarding insurance.
    • InsuredParty
    • InsurerContact
    • Interviewer
    • Investigator
    • InvestmentContact - Department/person to contact for matters regarding investments.
    • IssuingOfficer
    • JointWorkAgent
    • LaboratoryContact - Department/person to contact for laboratory matters.
    • LandregistryContact - Department/person to contact for matters regarding land registry.
    • LawFirm
    • LawSchoolAdmissionsOffice
    • LegalAuditingContact - Department or person to contact with regard to legal auditing.
    • Licensee
    • LocalPurchasingAgent
    • MaintenanceContact - Department/person to contact for matters regarding maintenance
    • Manager
    • Manufacturing
    • ManufacturingPlantContact
    • MarketingDepartment
    • MarketingDirector
    • MaterialControlContact - Department/person responsible for the controlling/inspection of goods.
    • MaterialDispositionContact - Department/person responsible for the disposition/scheduling of goods.
    • MaterialHandlingContact
    • MaterialSafetyDataSheetContact
    • Mayor
    • MedicalAdmissionsOffice
    • MedicalContact
    • MessageRecipientContact
    • MessageSenderContact
    • MultipleListingServiceStaff
    • MultipleListingServiceVendor
    • NationalAgent
    • NewBusinessProcessing
    • NewDevelopmentsContact - Department/person to contact for matters regarding new developments (e.g. construction).
    • NotaryPublic
    • NotificationContact
    • NumericalControlEngineer
    • OfficeManager - An individual responsible for managing the day to day activities of an office.
    • OfficeStaff
    • Operations
    • OrderContact - An individual to contact for questions regarding this order.
    • OrderDepartment
    • OrderingOfficer
    • OtherAdult
    • Owner
    • OwnerRepresentative
    • Packager
    • ParentorGuardian
    • ParticipatingLaboratoryContact
    • Partner
    • Patient
    • PayeeContact
    • PayersClaimOffice
    • PerformanceEvaluationCommittee
    • PersonnelContact - Department/person to contact for matters regarding personnel (human resources).
    • Physician
    • PlaceOfCollectionContact
    • PlaceOfDeliveryContact
    • PlantManager
    • PlantOrEquipmentContact - Department/person to contact for matters regarding plant/equipment contact.
    • PlatformMaintenanceManager
    • PortEngineer
    • PreawardSurveyManager
    • PreferredProviderOrganizationContact
    • Preparer
    • President
    • PriceAdministration
    • PrimaryContact
    • PrimaryControlPoint
    • PrimaryTaxpayer
    • PrincipalStudyContactorAuthor
    • ProbationorLegalOfficer
    • ProcessEngineer
    • Processor
    • ProductionRepresentative
    • ProductManagementContact - Department/person to contact for questions regarding this order.
    • ProgramDirector
    • ProgramManager
    • ProjectDirector
    • ProjectManagementContact - Department/person to contact for matters regarding project management on behalf of the contractor.
    • ProjectManager
    • PrototypeCoordinator - Description to be provided.
    • Provider
    • PublicRelationsContact - Department/person to contact for matters regarding public relations.
    • PurchaseServiceProvider
    • PurchasingContact - Department/person responsible for issuing this purchase order.
    • PurchasingContractingOfficer
    • QualityAssuranceContact - Quality assurance contact within an organization.
    • QualityCoordinatorContact - Quality coordinator contact within an organization.
    • QualityInspector
    • QualityManager
    • QuantitySurveyorContact - Department/person to contact for matters regarding quantity surveying.
    • QuotingParty
    • RateSupervisorOrClerk
    • RealEstatePropertyKeyHolder
    • RealEstatePropertyOccupant
    • RebateOrChargebackContact
    • ReceivingContact
    • ReceivingDockContact - The receiving dock contact within an organization.
    • Registrar
    • RentalCompanyAdministrativeContact
    • ReportAuthorizer
    • ReportPreparer
    • Requestor
    • Respondant
    • ResponsiblePerson
    • ResponsiblePersonForComputerDataProcessing - Responsible person to contact for matters regarding computer data processing.
    • ResponsiblePersonforInformationDissemination - Responsible person to contact for matters regarding information dissemination
    • ResponsiblePersonForInformationProduction - Responsible person to contact for matters regarding the production of information.
    • ReviewAndRepricingContact
    • SalesAdministration - Name of the sales administration contact within a corporation.
    • SalesRepresentativeOrDepartment - The sales representative or department contact within an organization.
    • ScheduleContact - Name of the scheduling contact within a corporation.
    • SchoolClerk
    • SchoolofTheologyAdmissionsOffice
    • SchoolofVeterinaryMedicineAdmissionsOffice
    • SchoolPrincipal
    • SecondaryTaxpayer
    • Secretary
    • ServiceContact - Department/person to be contacted in service matters.
    • ServiceManager
    • ServiceOrderWriter
    • ServiceOrganization
    • ServiceTeam
    • ServiceTechnician
    • ShipperContact
    • ShippingContact - The shipping department contact within an organization.
    • SocialServicesWorker
    • SoftwareHouseContact - Department or person to contact with regard to software house.
    • SpecialProgramContact
    • Spouse
    • Staff
    • Student
    • StudentinAbsentia
    • StudySubmitterContact
    • SubmittingContact
    • Supervisor
    • SupplierContact - Department/person to be contacted at the supplier.
    • SystemsAdministrator
    • TechnicalContact - Department/person to contact for matters regarding technical issues.
    • TechnicalDepartment
    • TechnicalDocumentationRecipient - Department/person to receive technical documentation.
    • TechnicalMarketingRepresentative
    • TechnicalWriter
    • TelecommunicationsNetworkContact - Department/person to contact for matters regarding telecommunications network.
    • TelephoneAnsweringServiceContact
    • Tenant
    • TenderDeveloper
    • TestContact - Department/person responsible for testing contact.
    • Third-PartyAdministratorContact - Third Party Administrator Contact
    • TownPlanningContact - Department/person to contact for matters regarding town planning.
    • TrafficAdministrator - The traffic administrator contact within an organization.
    • TrafficAuthorityContact - Department/person to contact for matters regarding traffic.
    • Transmitter
    • TransportContact - Department/person in charge of transportation.
    • TransportInfrastructureAuthority - Department/person to contact for matters regarding transport infrastructure.
    • Treasurer
    • UltimateConsignee - Final recipient of the consignment.
    • UltimateReceiver
    • UndergraduateAdmissionsOffice
    • Underwriter
    • UnionPresident
    • VicePresident
    • WaiverContact - Code specifying a party knowledgeable about a waiver.
    • Warehouse - The warehouse contact within an organization.
    • WaterSupplyContact - Department/person to contact for matters regarding water supply.
    • Witness
    • WorkBrokerMaintenanceManager
    • WorkshopContact - Department/person to contact for matters regarding the workshop.
    • WorksManagementContact - Department/person to contact for matters regarding management of works on behalf of the owner.

[^]Code Fragment

    <xsd:simpleType name="ContactFunctionCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="AcceptingContact">
        <xsd:enumeration value="AcceptingOfficial">
        <xsd:enumeration value="Accountingcontact">
        <xsd:enumeration value="AccountsPayableContact">
        <xsd:enumeration value="AccountsReceivableContact">
        <xsd:enumeration value="AdditionalInsuranceInformationContact">
        <xsd:enumeration value="AdministrativeContractingOfficer">
        <xsd:enumeration value="Administrator">
        <xsd:enumeration value="Advisor">
        <xsd:enumeration value="After-HoursContact">
        <xsd:enumeration value="Agent">
        <xsd:enumeration value="AlternateContact">
        <xsd:enumeration value="Applicant">
        <xsd:enumeration value="AppointmentScheduler">
        <xsd:enumeration value="Appraiser">
        <xsd:enumeration value="Attention-ToParty">
        <xsd:enumeration value="Attorney">
        <xsd:enumeration value="AuditingContact">
        <xsd:enumeration value="AuthorizedFinancialContact">
        <xsd:enumeration value="AuthorizedNegotiator">
        <xsd:enumeration value="AuthorizedRepresentative">
        <xsd:enumeration value="AuthorizedSignature">
        <xsd:enumeration value="AutomatedClearinghouseContact">
        <xsd:enumeration value="BankingContact">
        <xsd:enumeration value="BillInquiryContact">
        <xsd:enumeration value="BoardStaff">
        <xsd:enumeration value="Broker">
        <xsd:enumeration value="BrokerContact">
        <xsd:enumeration value="BusinessUnitManager">
        <xsd:enumeration value="BuyerNameorDepartment">
        <xsd:enumeration value="CADAndCAMSpecialist">
        <xsd:enumeration value="Carrier">
        <xsd:enumeration value="CaseManager">
        <xsd:enumeration value="CertificationContact">
        <xsd:enumeration value="Certifier">
        <xsd:enumeration value="ChairmanOfTheBoard">
        <xsd:enumeration value="ChangedBy">
        <xsd:enumeration value="ChangeOrderApprover">
        <xsd:enumeration value="ChiefExecutiveOfficer">
        <xsd:enumeration value="ChiefFinancialOfficer">
        <xsd:enumeration value="ChiefInformationOfficer">
        <xsd:enumeration value="ChiefOperatingOfficer">
        <xsd:enumeration value="CityWorksAuthorityContact">
        <xsd:enumeration value="Claimant">
        <xsd:enumeration value="ClaimApprover">
        <xsd:enumeration value="ClaimRecipient">
        <xsd:enumeration value="ClaimsContact">
        <xsd:enumeration value="ClearinghouseContact">
        <xsd:enumeration value="ClerkOfCourt">
        <xsd:enumeration value="Co-Borrower">
        <xsd:enumeration value="Co-Investigator">
        <xsd:enumeration value="Collector">
        <xsd:enumeration value="CollegeofEducationAdmissionsOffice">
        <xsd:enumeration value="ComplianceOfficer">
        <xsd:enumeration value="ComponentEngineer">
        <xsd:enumeration value="ComputerSystemsContact">
        <xsd:enumeration value="ConcurrentEmployerContact">
        <xsd:enumeration value="ConfirmedWith">
        <xsd:enumeration value="Consignee">
        <xsd:enumeration value="Consignor">
        <xsd:enumeration value="ContainerManager">
        <xsd:enumeration value="ContractContact">
        <xsd:enumeration value="CoordinationContact">
        <xsd:enumeration value="Coordinator">
        <xsd:enumeration value="CorporatePurchasingAgent">
        <xsd:enumeration value="CostAndScheduleCoordinator">
        <xsd:enumeration value="CustomerContactGrantingAppointment">
        <xsd:enumeration value="CustomerEngineer">
        <xsd:enumeration value="CustomerMaintenanceManager">
        <xsd:enumeration value="CustomerRelations">
        <xsd:enumeration value="DangerousGoodsContact">
        <xsd:enumeration value="DeliveryContact">
        <xsd:enumeration value="DeliveryInstructionsContact">
        <xsd:enumeration value="DentalSchoolAdmissionsOffice">
        <xsd:enumeration value="DepartmentOrEmployeeToExecuteExportProcedures">
        <xsd:enumeration value="DepartmentOrEmployeeToExecuteImportProcedures">
        <xsd:enumeration value="DepartmentOrPersonResponsibleForProcessingPurchaseOrder">
        <xsd:enumeration value="DesignEngineer">
        <xsd:enumeration value="Development">
        <xsd:enumeration value="Director">
        <xsd:enumeration value="DirectoryAdvertisingContact">
        <xsd:enumeration value="DivisionDirector">
        <xsd:enumeration value="DivisionManager">
        <xsd:enumeration value="EDICoordinator">
        <xsd:enumeration value="EducationCoordinator">
        <xsd:enumeration value="ElectricitySupplyContact">
        <xsd:enumeration value="ElectronicDataInterchangeCoordinator">
        <xsd:enumeration value="ElectronicSubmissionRecipient">
        <xsd:enumeration value="EmergencyContact">
        <xsd:enumeration value="EmergencyContact-Consignee">
        <xsd:enumeration value="EmergencyContact-MilitaryTrafficManagementCommand">
        <xsd:enumeration value="EmergencyContact-Shipper">
        <xsd:enumeration value="EmergencyDangerousGoodsContact">
        <xsd:enumeration value="EmployerContact">
        <xsd:enumeration value="Engineer">
        <xsd:enumeration value="EngineeringContact">
        <xsd:enumeration value="EnteredBy">
        <xsd:enumeration value="Estimator">
        <xsd:enumeration value="EveningProgramsOffice">
        <xsd:enumeration value="ExecutiveOfficer">
        <xsd:enumeration value="ExecutiveVice-President">
        <xsd:enumeration value="Expeditor">
        <xsd:enumeration value="FinancialAidOffice">
        <xsd:enumeration value="ForeclosingLenderAdministrativeContact">
        <xsd:enumeration value="ForwarderContact">
        <xsd:enumeration value="FunctionalManager">
        <xsd:enumeration value="GasSupplyContact">
        <xsd:enumeration value="GeneralContact">
        <xsd:enumeration value="GoodsReceivingContact">
        <xsd:enumeration value="GraduateAdmissionsOffice">
        <xsd:enumeration value="GraduateBusinessOffice">
        <xsd:enumeration value="GraduateEngineeringOffice">
        <xsd:enumeration value="GraduateFineArtsOffice">
        <xsd:enumeration value="GuidanceCounselor">
        <xsd:enumeration value="HazardousMaterialContact">
        <xsd:enumeration value="HeadOfUnitForInformationDissemination">
        <xsd:enumeration value="HeadOfUnitForInformationProduction">
        <xsd:enumeration value="HeadOfUnitOrComputerDataProcessing">
        <xsd:enumeration value="HealthMaintenanceOrganizationContact">
        <xsd:enumeration value="HumanResources">
        <xsd:enumeration value="InformationContact">
        <xsd:enumeration value="InsuranceContact">
        <xsd:enumeration value="InsuredParty">
        <xsd:enumeration value="InsurerContact">
        <xsd:enumeration value="Interviewer">
        <xsd:enumeration value="Investigator">
        <xsd:enumeration value="InvestmentContact">
        <xsd:enumeration value="IssuingOfficer">
        <xsd:enumeration value="JointWorkAgent">
        <xsd:enumeration value="LaboratoryContact">
        <xsd:enumeration value="LandregistryContact">
        <xsd:enumeration value="LawFirm">
        <xsd:enumeration value="LawSchoolAdmissionsOffice">
        <xsd:enumeration value="LegalAuditingContact">
        <xsd:enumeration value="Licensee">
        <xsd:enumeration value="LocalPurchasingAgent">
        <xsd:enumeration value="MaintenanceContact">
        <xsd:enumeration value="Manager">
        <xsd:enumeration value="Manufacturing">
        <xsd:enumeration value="ManufacturingPlantContact">
        <xsd:enumeration value="MarketingDepartment">
        <xsd:enumeration value="MarketingDirector">
        <xsd:enumeration value="MaterialControlContact">
        <xsd:enumeration value="MaterialDispositionContact">
        <xsd:enumeration value="MaterialHandlingContact">
        <xsd:enumeration value="MaterialSafetyDataSheetContact">
        <xsd:enumeration value="Mayor">
        <xsd:enumeration value="MedicalAdmissionsOffice">
        <xsd:enumeration value="MedicalContact">
        <xsd:enumeration value="MessageRecipientContact">
        <xsd:enumeration value="MessageSenderContact">
        <xsd:enumeration value="MultipleListingServiceStaff">
        <xsd:enumeration value="MultipleListingServiceVendor">
        <xsd:enumeration value="NationalAgent">
        <xsd:enumeration value="NewBusinessProcessing">
        <xsd:enumeration value="NewDevelopmentsContact">
        <xsd:enumeration value="NotaryPublic">
        <xsd:enumeration value="NotificationContact">
        <xsd:enumeration value="NumericalControlEngineer">
        <xsd:enumeration value="OfficeManager">
        <xsd:enumeration value="OfficeStaff">
        <xsd:enumeration value="Operations">
        <xsd:enumeration value="OrderContact">
        <xsd:enumeration value="OrderDepartment">
        <xsd:enumeration value="OrderingOfficer">
        <xsd:enumeration value="OtherAdult">
        <xsd:enumeration value="Owner">
        <xsd:enumeration value="OwnerRepresentative">
        <xsd:enumeration value="Packager">
        <xsd:enumeration value="ParentorGuardian">
        <xsd:enumeration value="ParticipatingLaboratoryContact">
        <xsd:enumeration value="Partner">
        <xsd:enumeration value="Patient">
        <xsd:enumeration value="PayeeContact">
        <xsd:enumeration value="PayersClaimOffice">
        <xsd:enumeration value="PerformanceEvaluationCommittee">
        <xsd:enumeration value="PersonnelContact">
        <xsd:enumeration value="Physician">
        <xsd:enumeration value="PlaceOfCollectionContact">
        <xsd:enumeration value="PlaceOfDeliveryContact">
        <xsd:enumeration value="PlantManager">
        <xsd:enumeration value="PlantOrEquipmentContact">
        <xsd:enumeration value="PlatformMaintenanceManager">
        <xsd:enumeration value="PortEngineer">
        <xsd:enumeration value="PreawardSurveyManager">
        <xsd:enumeration value="PreferredProviderOrganizationContact">
        <xsd:enumeration value="Preparer">
        <xsd:enumeration value="President">
        <xsd:enumeration value="PriceAdministration">
        <xsd:enumeration value="PrimaryContact">
        <xsd:enumeration value="PrimaryControlPoint">
        <xsd:enumeration value="PrimaryTaxpayer">
        <xsd:enumeration value="PrincipalStudyContactorAuthor">
        <xsd:enumeration value="ProbationorLegalOfficer">
        <xsd:enumeration value="ProcessEngineer">
        <xsd:enumeration value="Processor">
        <xsd:enumeration value="ProductionRepresentative">
        <xsd:enumeration value="ProductManagementContact">
        <xsd:enumeration value="ProgramDirector">
        <xsd:enumeration value="ProgramManager">
        <xsd:enumeration value="ProjectDirector">
        <xsd:enumeration value="ProjectManagementContact">
        <xsd:enumeration value="ProjectManager">
        <xsd:enumeration value="PrototypeCoordinator">
        <xsd:enumeration value="Provider">
        <xsd:enumeration value="PublicRelationsContact">
        <xsd:enumeration value="PurchaseServiceProvider">
        <xsd:enumeration value="PurchasingContact">
        <xsd:enumeration value="PurchasingContractingOfficer">
        <xsd:enumeration value="QualityAssuranceContact">
        <xsd:enumeration value="QualityCoordinatorContact">
        <xsd:enumeration value="QualityInspector">
        <xsd:enumeration value="QualityManager">
        <xsd:enumeration value="QuantitySurveyorContact">
        <xsd:enumeration value="QuotingParty">
        <xsd:enumeration value="RateSupervisorOrClerk">
        <xsd:enumeration value="RealEstatePropertyKeyHolder">
        <xsd:enumeration value="RealEstatePropertyOccupant">
        <xsd:enumeration value="RebateOrChargebackContact">
        <xsd:enumeration value="ReceivingContact">
        <xsd:enumeration value="ReceivingDockContact">
        <xsd:enumeration value="Registrar">
        <xsd:enumeration value="RentalCompanyAdministrativeContact">
        <xsd:enumeration value="ReportAuthorizer">
        <xsd:enumeration value="ReportPreparer">
        <xsd:enumeration value="Requestor">
        <xsd:enumeration value="Respondant">
        <xsd:enumeration value="ResponsiblePerson">
        <xsd:enumeration value="ResponsiblePersonForComputerDataProcessing">
        <xsd:enumeration value="ResponsiblePersonforInformationDissemination">
        <xsd:enumeration value="ResponsiblePersonForInformationProduction">
        <xsd:enumeration value="ReviewAndRepricingContact">
        <xsd:enumeration value="SalesAdministration">
        <xsd:enumeration value="SalesRepresentativeOrDepartment">
        <xsd:enumeration value="ScheduleContact">
        <xsd:enumeration value="SchoolClerk">
        <xsd:enumeration value="SchoolofTheologyAdmissionsOffice">
        <xsd:enumeration value="SchoolofVeterinaryMedicineAdmissionsOffice">
        <xsd:enumeration value="SchoolPrincipal">
        <xsd:enumeration value="SecondaryTaxpayer">
        <xsd:enumeration value="Secretary">
        <xsd:enumeration value="ServiceContact">
        <xsd:enumeration value="ServiceManager">
        <xsd:enumeration value="ServiceOrderWriter">
        <xsd:enumeration value="ServiceOrganization">
        <xsd:enumeration value="ServiceTeam">
        <xsd:enumeration value="ServiceTechnician">
        <xsd:enumeration value="ShipperContact">
        <xsd:enumeration value="ShippingContact">
        <xsd:enumeration value="SocialServicesWorker">
        <xsd:enumeration value="SoftwareHouseContact">
        <xsd:enumeration value="SpecialProgramContact">
        <xsd:enumeration value="Spouse">
        <xsd:enumeration value="Staff">
        <xsd:enumeration value="Student">
        <xsd:enumeration value="StudentinAbsentia">
        <xsd:enumeration value="StudySubmitterContact">
        <xsd:enumeration value="SubmittingContact">
        <xsd:enumeration value="Supervisor">
        <xsd:enumeration value="SupplierContact">
        <xsd:enumeration value="SystemsAdministrator">
        <xsd:enumeration value="TechnicalContact">
        <xsd:enumeration value="TechnicalDepartment">
        <xsd:enumeration value="TechnicalDocumentationRecipient">
        <xsd:enumeration value="TechnicalMarketingRepresentative">
        <xsd:enumeration value="TechnicalWriter">
        <xsd:enumeration value="TelecommunicationsNetworkContact">
        <xsd:enumeration value="TelephoneAnsweringServiceContact">
        <xsd:enumeration value="Tenant">
        <xsd:enumeration value="TenderDeveloper">
        <xsd:enumeration value="TestContact">
        <xsd:enumeration value="Third-PartyAdministratorContact">
        <xsd:enumeration value="TownPlanningContact">
        <xsd:enumeration value="TrafficAdministrator">
        <xsd:enumeration value="TrafficAuthorityContact">
        <xsd:enumeration value="Transmitter">
        <xsd:enumeration value="TransportContact">
        <xsd:enumeration value="TransportInfrastructureAuthority">
        <xsd:enumeration value="Treasurer">
        <xsd:enumeration value="UltimateConsignee">
        <xsd:enumeration value="UltimateReceiver">
        <xsd:enumeration value="UndergraduateAdmissionsOffice">
        <xsd:enumeration value="Underwriter">
        <xsd:enumeration value="UnionPresident">
        <xsd:enumeration value="VicePresident">
        <xsd:enumeration value="WaiverContact">
        <xsd:enumeration value="Warehouse">
        <xsd:enumeration value="WaterSupplyContact">
        <xsd:enumeration value="Witness">
        <xsd:enumeration value="WorkBrokerMaintenanceManager">
        <xsd:enumeration value="WorkshopContact">
        <xsd:enumeration value="WorksManagementContact">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: ContactFunctionType

ContactFunctionType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ContactFunctionCoded[ContactFunctionCodeType] , ContactFunctionCodedOther[xsd:string]? )

    Description: ContactFunctionType describes the purpose of the contact.

    Elements:

    • ContactFunctionCoded - identifies the purpose of a contact using a standard codelist.
    • ContactFunctionCodedOther - is used to provide a non-standard ContactFuctionCode This element is mandatory if the value of ContactFunctionCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="ContactFunctionType">
    <xsd:sequence>
        <xsd:element name="ContactFunctionCoded" type="ContactFunctionCodeType">
        <xsd:element minOccurs="0" name="ContactFunctionCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ContactNumberType

ContactNumberType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ContactNumberValue[xsd:string] , ContactNumberTypeCoded[ContactNumberTypeCodeType] , ContactNumberTypeCodedOther[xsd:string]? )

    Description: ContactNumberType contains the channel and value of a communication point.

    Elements:

    • ContactNumberValue - displays the value of the communication point.
    • ContactNumberTypeCoded - identifies the channel of communication using a standard codelist.
    • ContactNumberTypeCodedOther - is used to provide a non-standard ContactNumberTypeCode This element is mandatory if the value of ContactNumberTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="ContactNumberType">
    <xsd:sequence>
        <xsd:element name="ContactNumberValue" type="xsd:string">
        <xsd:element name="ContactNumberTypeCoded" type="ContactNumberTypeCodeType">
        <xsd:element minOccurs="0" name="ContactNumberTypeCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: ContactNumberTypeCodeType

ContactNumberTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other
    • TelephoneNumber
    • FaxNumber
    • EmailAddress
    • MobileNumber
    • TelexNumber
    • PagerNumber
    • HomePage
    • WWW
    • FTP
    • URLOther

[^]Code Fragment

    <xsd:simpleType name="ContactNumberTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="TelephoneNumber">
        <xsd:enumeration value="FaxNumber">
        <xsd:enumeration value="EmailAddress">
        <xsd:enumeration value="MobileNumber">
        <xsd:enumeration value="TelexNumber">
        <xsd:enumeration value="PagerNumber">
        <xsd:enumeration value="HomePage">
        <xsd:enumeration value="WWW">
        <xsd:enumeration value="FTP">
        <xsd:enumeration value="URLOther">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: ContactType

ContactType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ContactID[IdentifierType]? , ContactName[xsd:string] , ContactFunction[ContactFunctionType]? , ContactDescription[xsd:string]? , ListOfContactNumber[ListOfContactNumberType]? , CorrespondenceLanguage[LanguageType]? )

    Description: ContactType contains the means for contacting a person or department.

    Elements:

    • ContactID - holds the identifier of the department or employee.
    • ContactName - identifies the department or employee name.
    • ContactFunction - describes the purpose of the contact.
    • ContactDescription - is a free form description field to further explain the purpose of the contact.
    • ListOfContactNumber - lists one or more communication points.
    • CorrespondenceLanguage - identifies the language in which all correspondences with the contact should be.

[^]Code Fragment

    <xsd:complexType name="ContactType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ContactID" type="IdentifierType">
        <xsd:element name="ContactName" type="xsd:string">
        <xsd:element minOccurs="0" name="ContactFunction" type="ContactFunctionType">
        <xsd:element minOccurs="0" name="ContactDescription" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfContactNumber" type="ListOfContactNumberType">
        <xsd:element minOccurs="0" name="CorrespondenceLanguage" type="LanguageType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ContractType

ContractType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ContractID[IdentifierType] , TypeOfContract[ContractTypeType]? , ValidityDates[ValidityDatesType]? , SystemID[xsd:string]? , ContractItemNumber[xsd:string]? )

    Description: ContractType provides the details of an agreement between trading partners.

    Elements:

    • ContractID - is a unique identifier assigned to the contract.
    • TypeOfContract - identifies the type of contract.
    • ValidityDates - specifies the dates for which the contract is effective.
    • SystemID - is the ID of the system in which the contract resides
    • ContractItemNumber - references a specific item within the contract being referenced.

[^]Code Fragment

    <xsd:complexType name="ContractType">
    <xsd:sequence>
        <xsd:element name="ContractID" type="IdentifierType">
        <xsd:element minOccurs="0" name="TypeOfContract" type="ContractTypeType">
        <xsd:element minOccurs="0" name="ValidityDates" type="ValidityDatesType">
        <xsd:element minOccurs="0" name="SystemID" type="xsd:string">
        <xsd:element minOccurs="0" name="ContractItemNumber" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: ContractTypeCodeType

ContractTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other
    • DiagnosisRelatedGroup
    • PerDiem
    • VariablePerDiem
    • Flat
    • Capitated
    • Percent
    • NegotiatedGrowingEquityMortgage
    • AnticipatedContract
    • FederalHousingAuthorityAdjustableRateMortgage
    • FederalHousingAuthorityVeteransAffairsFixedRateMortgage
    • ConventionalSecondMortgages
    • ConventionalFixedRateMortgages
    • FederalHousingAuthorityVeteransAffairsGraduatedPaymentMortgage
    • NegotiatedConventionalGraduatedPaymentOrStepRateMortgage
    • ConventionalAdjustableRateMortgage
    • CostPlusIncentiveFee
    • CostSharing
    • CostPlus
    • Cost
    • CostPlusAwardFee
    • CostPlusFixedFee
    • Distributor
    • ExclusiveAgency
    • ExclusiveRight
    • FirmorActualContract
    • FixedPriceIncentiveFirmTargetWithPerformanceIncentive
    • FixedPriceIncentiveFirmTargetWithoutPerformanceIncentive
    • FixedPriceRedetermination
    • FixedPricewithEscalation
    • FixedPriceIncentiveSuccessiveTargetWithPerformanceIncentive
    • FixedPriceIncentiveSuccessiveTargetWithoutPerformanceIncentive
    • FixedPriceAwardFee
    • FixedPriceIncentive
    • FixedPriceLevelofEffort
    • NoCost
    • FlatAmount
    • RetroactiveFixedPriceRedetermination
    • FirmFixedPrice
    • FixedPricewithEconomicPriceAdjustment
    • Labor
    • LevelofEffort
    • LaborHours
    • OtherContractType
    • ProspectReservation
    • SamePercentageasFilmRentalEarned
    • TimeandMaterials

[^]Code Fragment

    <xsd:simpleType name="ContractTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="DiagnosisRelatedGroup">
        <xsd:enumeration value="PerDiem">
        <xsd:enumeration value="VariablePerDiem">
        <xsd:enumeration value="Flat">
        <xsd:enumeration value="Capitated">
        <xsd:enumeration value="Percent">
        <xsd:enumeration value="NegotiatedGrowingEquityMortgage">
        <xsd:enumeration value="AnticipatedContract">
        <xsd:enumeration value="FederalHousingAuthorityAdjustableRateMortgage">
        <xsd:enumeration value="FederalHousingAuthorityVeteransAffairsFixedRateMortgage">
        <xsd:enumeration value="ConventionalSecondMortgages">
        <xsd:enumeration value="ConventionalFixedRateMortgages">
        <xsd:enumeration value="FederalHousingAuthorityVeteransAffairsGraduatedPaymentMortgage">
        <xsd:enumeration value="NegotiatedConventionalGraduatedPaymentOrStepRateMortgage">
        <xsd:enumeration value="ConventionalAdjustableRateMortgage">
        <xsd:enumeration value="CostPlusIncentiveFee">
        <xsd:enumeration value="CostSharing">
        <xsd:enumeration value="CostPlus">
        <xsd:enumeration value="Cost">
        <xsd:enumeration value="CostPlusAwardFee">
        <xsd:enumeration value="CostPlusFixedFee">
        <xsd:enumeration value="Distributor">
        <xsd:enumeration value="ExclusiveAgency">
        <xsd:enumeration value="ExclusiveRight">
        <xsd:enumeration value="FirmorActualContract">
        <xsd:enumeration value="FixedPriceIncentiveFirmTargetWithPerformanceIncentive">
        <xsd:enumeration value="FixedPriceIncentiveFirmTargetWithoutPerformanceIncentive">
        <xsd:enumeration value="FixedPriceRedetermination">
        <xsd:enumeration value="FixedPricewithEscalation">
        <xsd:enumeration value="FixedPriceIncentiveSuccessiveTargetWithPerformanceIncentive">
        <xsd:enumeration value="FixedPriceIncentiveSuccessiveTargetWithoutPerformanceIncentive">
        <xsd:enumeration value="FixedPriceAwardFee">
        <xsd:enumeration value="FixedPriceIncentive">
        <xsd:enumeration value="FixedPriceLevelofEffort">
        <xsd:enumeration value="NoCost">
        <xsd:enumeration value="FlatAmount">
        <xsd:enumeration value="RetroactiveFixedPriceRedetermination">
        <xsd:enumeration value="FirmFixedPrice">
        <xsd:enumeration value="FixedPricewithEconomicPriceAdjustment">
        <xsd:enumeration value="Labor">
        <xsd:enumeration value="LevelofEffort">
        <xsd:enumeration value="LaborHours">
        <xsd:enumeration value="OtherContractType">
        <xsd:enumeration value="ProspectReservation">
        <xsd:enumeration value="SamePercentageasFilmRentalEarned">
        <xsd:enumeration value="TimeandMaterials">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: ContractTypeType

ContractTypeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ContractTypeCoded[ContractTypeCodeType] , ContractTypeCodedOther[xsd:string]? )

    Description: ContractTypeType provides the details of an agreement between trading partners.

    Elements:

    • ContractTypeCoded - identifies the type of contract through a standard codelist.
    • ContractTypeCodedOther - is used to provide a non-standard ContractTypeCode. This element is mandatory if the value of ContractTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="ContractTypeType">
    <xsd:sequence>
        <xsd:element name="ContractTypeCoded" type="ContractTypeCodeType">
        <xsd:element minOccurs="0" name="ContractTypeCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: CostCenterType

CostCenterType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( CostCenterNumber[xsd:string] , ListOfAccountAssignment[ListOfAccountAssignmentType]? , MonetaryValue[MonetaryValueType]? , Quantity[QuantityType]? , Percent[PercentType]? )

    Description: CostCenterType identifies a cost center, and any or all of the amount, quantity, or percentage allocated to it.

    Elements:

    • CostCenterNumber - identifies the cost center.
    • ListOfAccountAssignment - is identification of the cost center.
    • MonetaryValue - is the amount of money allocated to the cost center identified.
    • Quantity - is the amount of an item that is allocated to the cost center identified. This will typically only be used at the item level.
    • Percent - is a percentage allocation of the total amount to the cost center identified.

[^]Code Fragment

    <xsd:complexType name="CostCenterType">
    <xsd:sequence>
        <xsd:element name="CostCenterNumber" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfAccountAssignment" type="ListOfAccountAssignmentType">
        <xsd:element minOccurs="0" name="MonetaryValue" type="MonetaryValueType">
        <xsd:element minOccurs="0" name="Quantity" type="QuantityType">
        <xsd:element minOccurs="0" name="Percent" type="PercentType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: CountryCodeType

CountryCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies a country. This code list is derived from ISO 3166-1997

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom code
    • AE - United Arab Emirates
    • AF - Afghanistan
    • AG - Antigua And Barbuda
    • AI - Anguilla
    • AL - Albania
    • AM - Armenia
    • AN - Netherlands Antilles
    • AO - Angola
    • AQ - Antarctica
    • AR - Argentina
    • AS - American Samoa
    • AT - Austria
    • AU - Australia
    • AW - Aruba
    • AZ - Azerbaijan
    • BA - Bosnia-Hercegovina
    • BB - Barbados
    • BD - Bangladesh
    • BE - Belgium
    • BF - Burkina Faso
    • BG - Bulgaria
    • BH - Bahrain
    • BI - Burundi
    • BJ - Benin
    • BM - Bermuda
    • BN - Brunei Darussalam
    • BO - Bolivia
    • BR - Brazil
    • BS - Bahamas
    • BT - Bhutan
    • BU - Burma (See MM Myanmar)
    • BW - Botswana
    • BY - Belarus
    • BZ - Belize
    • CA - Canada
    • CC - Cocos (Keeling) Islands
    • CD - Congo, Democratic Republic Of
    • CF - Central African Republic
    • CG - Congo
    • CH - Switzerland
    • CI - Cote D'Ivoire
    • CK - Cook Islands
    • CL - Chile
    • CM - Cameroon
    • CN - China
    • CO - Colombia
    • CR - Costa Rica
    • CS - Former Czechoslovakia
    • CU - Cuba
    • CV - Cape Verde
    • CX - Christmas Islands
    • CY - Cyprus
    • CZ - Czech Republic
    • DE - Germany, Federal Republic Of
    • DJ - Djibouti
    • DK - Denmark
    • DM - Dominica
    • DO - Dominican Republic
    • DZ - Algeria
    • EC - Ecuador
    • EE - Estonia
    • EG - Egypt
    • EH - Western Sahara
    • ER - Eritrea
    • ES - Spain
    • ET - Ethiopia
    • FI - Finland
    • FJ - Fiji
    • FK - Falkland Islands (Malvinas)
    • FM - Fed States Of Micronesia
    • FO - Faeroe Islands
    • FR - France
    • GA - Gabon
    • GB - United Kingdom
    • GD - Grenada
    • GE - Georgia
    • GF - French Guiana
    • GH - Ghana
    • GI - Gibraltar
    • GL - Greenland
    • GM - Gambia
    • GN - Guinea
    • GP - Guadeloupe
    • GQ - Equatorial Guinea
    • GR - Greece
    • GS - S. Georgia and S. Sandwich Islands
    • GT - Guatemala
    • GU - Guam
    • GW - Guinea-Bissau
    • GY - Guyana
    • HK - Hong Kong
    • HN - Honduras
    • HR - Croatia
    • HT - Haiti
    • HU - Hungary
    • ID - Indonesia
    • IE - Ireland
    • IL - Israel
    • IN - India
    • IO - Indian Ocean Territory
    • IQ - Iraq
    • IR - Iran, Islamic Republic Of
    • IS - Iceland
    • IT - Italy
    • JM - Jamaica
    • JO - Jordan
    • JP - Japan
    • KE - Kenya
    • KG - Kyrgyzstan
    • KH - Cambodia
    • KI - Kiribati
    • KM - Comoros
    • KN - St Kitts-Nevis
    • KP - Korea, Democratic People's Rep
    • KR - Korea, Republic Of
    • KW - Kuwait
    • KY - Cayman Islands
    • KZ - Kazakhstan
    • LA - Lao, People's Democratic Rep
    • LB - Lebanon
    • LC - Saint Lucia
    • LI - Liechtenstein
    • LK - Sri Lanka
    • LR - Liberia
    • LS - Lesotho
    • LT - Lithuania
    • LU - Luxembourg
    • LV - Latvia
    • LY - Lybian Arab Jamahiriya
    • MA - Morocco
    • MC - Monaco
    • MD - Moldova
    • MG - Madagascar
    • MH - Marshall Islands
    • MK - Frmr Yugoslav Rep Of Macedonia
    • ML - Mali
    • MM - Myanmar (Former Burma)
    • MN - Mongolia
    • MO - Macau
    • MP - Northern Marianas
    • MQ - Martinique
    • MR - Mauritania
    • MS - Montserrat
    • MT - Malta
    • MU - Mauritius
    • MV - Maldives
    • MW - Malawi
    • MX - Mexico
    • MY - Malaysia
    • MZ - Mozambique
    • NA - Namibia
    • NC - New Caledonia
    • NE - Niger
    • NF - Norfolk Island
    • NG - Nigeria
    • NI - Nicaragua
    • NL - Netherlands
    • NO - Norway
    • NP - Nepal
    • NR - Nauru
    • NU - Niue
    • NZ - New Zealand
    • OM - Oman
    • PA - Panama
    • PE - Peru
    • PF - French Polynesia
    • PG - Papua New Guinea
    • PH - Philippines
    • PK - Pakistan
    • PL - Poland
    • PM - St Pierre and Miquelon
    • PN - Pitcairn
    • PR - Puerto Rico
    • PT - Portugal
    • PW - Palau
    • PY - Paraguay
    • QA - Qatar
    • RE - Reunion
    • RO - Romania
    • RU - Russian Federation
    • RW - Rwanda
    • SA - Saudi Arabia
    • SB - Solomon Islands
    • SC - Seychelles
    • SD - Sudan
    • SE - Sweden
    • SG - Singapore
    • SH - St Helena
    • SI - Slovenia
    • SJ - Svalbard and Jan Mayen
    • SK - Slovakia
    • SL - Sierra Leone
    • SM - San Marino
    • SN - Senegal
    • SO - Somalia
    • SR - Suriname
    • ST - Sao Tome and Principe
    • SV - El Salvador
    • SY - Syrian Arab Republic
    • SZ - Swaziland
    • TC - Turks and Caicos Islands
    • TD - Chad
    • TF - French Southern Territories
    • TG - Togo
    • TH - Thailand
    • TJ - Tajikistan
    • TM - Turkmenistan
    • TN - Tunisia
    • TO - Tonga
    • TP - East Timor
    • TR - Turkey
    • TT - Trinidad and Tobago
    • TV - Tuvalu
    • TW - Taiwan, Province Of China
    • TZ - Tanzania, United Republic Of
    • UA - Ukraine
    • UG - Uganda
    • UM - US Minor Outlying Islands
    • US - United States
    • UY - Uruguay
    • UZ - Uzbekistan
    • VA - Vatican City State (Holy See)
    • VC - St Vincent and Grenadines
    • VE - Venezuela
    • VG - Virgin Islands, British
    • VI - United States Virgin Islands
    • VN - Viet Nam
    • VU - Vanuatu
    • WF - Wallis and Futuna Islands
    • WS - Samoa
    • YE - Yemen
    • YT - Mayotte
    • YU - Yugoslavia (Fed Rep Of)
    • ZA - South Africa
    • ZM - Zambia
    • ZW - Zimbabwe

[^]Code Fragment

    <xsd:simpleType name="CountryCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="AE">
        <xsd:enumeration value="AF">
        <xsd:enumeration value="AG">
        <xsd:enumeration value="AI">
        <xsd:enumeration value="AL">
        <xsd:enumeration value="AM">
        <xsd:enumeration value="AN">
        <xsd:enumeration value="AO">
        <xsd:enumeration value="AQ">
        <xsd:enumeration value="AR">
        <xsd:enumeration value="AS">
        <xsd:enumeration value="AT">
        <xsd:enumeration value="AU">
        <xsd:enumeration value="AW">
        <xsd:enumeration value="AZ">
        <xsd:enumeration value="BA">
        <xsd:enumeration value="BB">
        <xsd:enumeration value="BD">
        <xsd:enumeration value="BE">
        <xsd:enumeration value="BF">
        <xsd:enumeration value="BG">
        <xsd:enumeration value="BH">
        <xsd:enumeration value="BI">
        <xsd:enumeration value="BJ">
        <xsd:enumeration value="BM">
        <xsd:enumeration value="BN">
        <xsd:enumeration value="BO">
        <xsd:enumeration value="BR">
        <xsd:enumeration value="BS">
        <xsd:enumeration value="BT">
        <xsd:enumeration value="BU">
        <xsd:enumeration value="BW">
        <xsd:enumeration value="BY">
        <xsd:enumeration value="BZ">
        <xsd:enumeration value="CA">
        <xsd:enumeration value="CC">
        <xsd:enumeration value="CD">
        <xsd:enumeration value="CF">
        <xsd:enumeration value="CG">
        <xsd:enumeration value="CH">
        <xsd:enumeration value="CI">
        <xsd:enumeration value="CK">
        <xsd:enumeration value="CL">
        <xsd:enumeration value="CM">
        <xsd:enumeration value="CN">
        <xsd:enumeration value="CO">
        <xsd:enumeration value="CR">
        <xsd:enumeration value="CS">
        <xsd:enumeration value="CU">
        <xsd:enumeration value="CV">
        <xsd:enumeration value="CX">
        <xsd:enumeration value="CY">
        <xsd:enumeration value="CZ">
        <xsd:enumeration value="DE">
        <xsd:enumeration value="DJ">
        <xsd:enumeration value="DK">
        <xsd:enumeration value="DM">
        <xsd:enumeration value="DO">
        <xsd:enumeration value="DZ">
        <xsd:enumeration value="EC">
        <xsd:enumeration value="EE">
        <xsd:enumeration value="EG">
        <xsd:enumeration value="EH">
        <xsd:enumeration value="ER">
        <xsd:enumeration value="ES">
        <xsd:enumeration value="ET">
        <xsd:enumeration value="FI">
        <xsd:enumeration value="FJ">
        <xsd:enumeration value="FK">
        <xsd:enumeration value="FM">
        <xsd:enumeration value="FO">
        <xsd:enumeration value="FR">
        <xsd:enumeration value="GA">
        <xsd:enumeration value="GB">
        <xsd:enumeration value="GD">
        <xsd:enumeration value="GE">
        <xsd:enumeration value="GF">
        <xsd:enumeration value="GH">
        <xsd:enumeration value="GI">
        <xsd:enumeration value="GL">
        <xsd:enumeration value="GM">
        <xsd:enumeration value="GN">
        <xsd:enumeration value="GP">
        <xsd:enumeration value="GQ">
        <xsd:enumeration value="GR">
        <xsd:enumeration value="GS">
        <xsd:enumeration value="GT">
        <xsd:enumeration value="GU">
        <xsd:enumeration value="GW">
        <xsd:enumeration value="GY">
        <xsd:enumeration value="HK">
        <xsd:enumeration value="HN">
        <xsd:enumeration value="HR">
        <xsd:enumeration value="HT">
        <xsd:enumeration value="HU">
        <xsd:enumeration value="ID">
        <xsd:enumeration value="IE">
        <xsd:enumeration value="IL">
        <xsd:enumeration value="IN">
        <xsd:enumeration value="IO">
        <xsd:enumeration value="IQ">
        <xsd:enumeration value="IR">
        <xsd:enumeration value="IS">
        <xsd:enumeration value="IT">
        <xsd:enumeration value="JM">
        <xsd:enumeration value="JO">
        <xsd:enumeration value="JP">
        <xsd:enumeration value="KE">
        <xsd:enumeration value="KG">
        <xsd:enumeration value="KH">
        <xsd:enumeration value="KI">
        <xsd:enumeration value="KM">
        <xsd:enumeration value="KN">
        <xsd:enumeration value="KP">
        <xsd:enumeration value="KR">
        <xsd:enumeration value="KW">
        <xsd:enumeration value="KY">
        <xsd:enumeration value="KZ">
        <xsd:enumeration value="LA">
        <xsd:enumeration value="LB">
        <xsd:enumeration value="LC">
        <xsd:enumeration value="LI">
        <xsd:enumeration value="LK">
        <xsd:enumeration value="LR">
        <xsd:enumeration value="LS">
        <xsd:enumeration value="LT">
        <xsd:enumeration value="LU">
        <xsd:enumeration value="LV">
        <xsd:enumeration value="LY">
        <xsd:enumeration value="MA">
        <xsd:enumeration value="MC">
        <xsd:enumeration value="MD">
        <xsd:enumeration value="MG">
        <xsd:enumeration value="MH">
        <xsd:enumeration value="MK">
        <xsd:enumeration value="ML">
        <xsd:enumeration value="MM">
        <xsd:enumeration value="MN">
        <xsd:enumeration value="MO">
        <xsd:enumeration value="MP">
        <xsd:enumeration value="MQ">
        <xsd:enumeration value="MR">
        <xsd:enumeration value="MS">
        <xsd:enumeration value="MT">
        <xsd:enumeration value="MU">
        <xsd:enumeration value="MV">
        <xsd:enumeration value="MW">
        <xsd:enumeration value="MX">
        <xsd:enumeration value="MY">
        <xsd:enumeration value="MZ">
        <xsd:enumeration value="NA">
        <xsd:enumeration value="NC">
        <xsd:enumeration value="NE">
        <xsd:enumeration value="NF">
        <xsd:enumeration value="NG">
        <xsd:enumeration value="NI">
        <xsd:enumeration value="NL">
        <xsd:enumeration value="NO">
        <xsd:enumeration value="NP">
        <xsd:enumeration value="NR">
        <xsd:enumeration value="NU">
        <xsd:enumeration value="NZ">
        <xsd:enumeration value="OM">
        <xsd:enumeration value="PA">
        <xsd:enumeration value="PE">
        <xsd:enumeration value="PF">
        <xsd:enumeration value="PG">
        <xsd:enumeration value="PH">
        <xsd:enumeration value="PK">
        <xsd:enumeration value="PL">
        <xsd:enumeration value="PM">
        <xsd:enumeration value="PN">
        <xsd:enumeration value="PR">
        <xsd:enumeration value="PT">
        <xsd:enumeration value="PW">
        <xsd:enumeration value="PY">
        <xsd:enumeration value="QA">
        <xsd:enumeration value="RE">
        <xsd:enumeration value="RO">
        <xsd:enumeration value="RU">
        <xsd:enumeration value="RW">
        <xsd:enumeration value="SA">
        <xsd:enumeration value="SB">
        <xsd:enumeration value="SC">
        <xsd:enumeration value="SD">
        <xsd:enumeration value="SE">
        <xsd:enumeration value="SG">
        <xsd:enumeration value="SH">
        <xsd:enumeration value="SI">
        <xsd:enumeration value="SJ">
        <xsd:enumeration value="SK">
        <xsd:enumeration value="SL">
        <xsd:enumeration value="SM">
        <xsd:enumeration value="SN">
        <xsd:enumeration value="SO">
        <xsd:enumeration value="SR">
        <xsd:enumeration value="ST">
        <xsd:enumeration value="SV">
        <xsd:enumeration value="SY">
        <xsd:enumeration value="SZ">
        <xsd:enumeration value="TC">
        <xsd:enumeration value="TD">
        <xsd:enumeration value="TF">
        <xsd:enumeration value="TG">
        <xsd:enumeration value="TH">
        <xsd:enumeration value="TJ">
        <xsd:enumeration value="TM">
        <xsd:enumeration value="TN">
        <xsd:enumeration value="TO">
        <xsd:enumeration value="TP">
        <xsd:enumeration value="TR">
        <xsd:enumeration value="TT">
        <xsd:enumeration value="TV">
        <xsd:enumeration value="TW">
        <xsd:enumeration value="TZ">
        <xsd:enumeration value="UA">
        <xsd:enumeration value="UG">
        <xsd:enumeration value="UM">
        <xsd:enumeration value="US">
        <xsd:enumeration value="UY">
        <xsd:enumeration value="UZ">
        <xsd:enumeration value="VA">
        <xsd:enumeration value="VC">
        <xsd:enumeration value="VE">
        <xsd:enumeration value="VG">
        <xsd:enumeration value="VI">
        <xsd:enumeration value="VN">
        <xsd:enumeration value="VU">
        <xsd:enumeration value="WF">
        <xsd:enumeration value="WS">
        <xsd:enumeration value="YE">
        <xsd:enumeration value="YT">
        <xsd:enumeration value="YU">
        <xsd:enumeration value="ZA">
        <xsd:enumeration value="ZM">
        <xsd:enumeration value="ZW">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: CountryType

CountryType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( CountryCoded[CountryCodeType] , CountryCodedOther[xsd:string]? )

    Description: CountryType identifies a country.

    Elements:

    • CountryCoded - identifies a country according to ISO standards.
    • CountryCodedOther - is used to provide a non-standard CountryCode. This element is mandatory if the value of CountryCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="CountryType">
    <xsd:sequence>
        <xsd:element name="CountryCoded" type="CountryCodeType">
        <xsd:element minOccurs="0" name="CountryCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: CurrencyCodeType

CurrencyCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the type of currency being used. This codelist is derived from UN/ECE Recommendation no.9

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • AFA - Afghani
    • DZD - Algerian Dinar
    • ADF - Andorran Franc
    • ADP - Andorran Peseta
    • ARP - Argentine Peso
    • ARS - Argentine Peso
    • ARA - Argentinian Austral
    • AMD - Armenian Dram
    • AWF - Aruban Florin
    • AUD - Australian Dollar
    • ATS - Austrian Schilling
    • AZM - Azerbaijanian Manat
    • BSD - Bahamian Dollar
    • BHD - Bahraini Dinar
    • BDT - Bangladeshi Taka
    • BBD - Barbados Dollar
    • BYB - Belarussian Ruble
    • BEF - Belgian Franc
    • BZD - Belize Dollar
    • BMD - Bermudian Dollar
    • BTN - Bhutanese Ngultrum
    • BOB - Boliviano
    • BAK - Bosnia and Herzegovena Convertible Mark
    • BWP - Botswana Pula
    • BRL - Brazilian Real
    • BND - Brunei Dollar
    • BGL - Bulgarian Lev
    • BIF - Burundi Franc
    • KHR - Cambodian Riel
    • CAD - Canadian Dollar
    • CVE - Cape Verde Escudo
    • KYD - Cayman Is. Dollar
    • XOF - CFA Franc BCEAO
    • XAF - CFA Franc BEAC
    • XPF - CFP Franc
    • CLP - Chilean Peso
    • CLF - Chilean Unidades de Formento
    • CNY - Chinese Yuan Renminbi
    • COP - Colombian Peso
    • KMF - Comoran Franc
    • CRC - Costa Rican Colon
    • HRK - Croatian Kuna
    • CUP - Cuban Peso
    • CYP - Cyprus Pound
    • CZK - Czech Koruna
    • DKK - Danish Krone
    • DEM - Deutsche Mark
    • BAD - Dinar
    • DJF - Djibouti Franc
    • DOP - Dominican Peso
    • XCD - East Caribbean Dollar
    • ECS - Ecuador Sucre
    • EGP - Egyptian Pound
    • SVC - El Salvador Colon
    • ERN - Eritrea Nakfa
    • EEK - Estonia Kroon
    • ETB - Ethiopian Birr
    • EUR - Euro
    • XEU - European Currency Unit (E.C.U.)
    • FKP - Falkland Islands Pound
    • FJD - Fiji Dollar
    • ZAL - Financial Rand
    • FIM - Finnish Markka
    • FRF - French Franc
    • GMD - Gambian Dalasi
    • GEL - Georgian Lari
    • GHC - Ghanaian Cedi
    • GIP - Gibraltar Pound
    • XAU - Gold
    • GRD - Greek Drachma
    • GTQ - Guatemalan Quetzal
    • GNF - Guinea Franc
    • GWP - Guinea-Bissau Peso
    • GYD - Guyanan Dollar
    • HTG - Haitian Gourde
    • HNL - Honduran Lempira
    • HKD - Hong Kong Dollar
    • HUF - Hungarian Forint
    • ISK - Iceland Krona
    • INR - Indian Rupee
    • IDR - Indonesian Rupiah
    • IRA - Iranian Airline Rate
    • IRR - Iranian Rial
    • IQD - Iraqi Dinar
    • IEP - Irish Punt
    • ILS - Israeli New Shekel
    • ITL - Italian Lira
    • JMD - Jamaican Dollar
    • JPY - Japanese Yen
    • JOD - Jordanian Dinar
    • KZT - Kazakhstan Tenge
    • KES - Kenyan Schilling
    • KWD - Kuwaiti Dinar
    • AOR - Kwanza Reajustado
    • KGS - Kyrgyzstani Som
    • LAK - Lao Kip
    • LVL - Latvian Lats
    • LBP - Lebanese Pound
    • ALL - Lek
    • LSL - Lesotho Loti
    • LRD - Liberian Dollar
    • LYD - Libyan Dinar
    • LTL - Lithuanian Litas
    • LUF - Luxembourg Franc
    • MOP - Macau Pataca
    • MKD - Macedonian Denar
    • MGF - Malagasy Franc
    • MWK - Malawi Kwacha
    • MYR - Malaysian Ringgit
    • MVR - Maldive Rufiyaa
    • MTL - Maltese Lira
    • MRO - Mauritanian Ouguiya
    • MUR - Mauritius Rupee
    • MXN - Mexican Nuevo Peso
    • MDL - Moldovan Leu
    • MNT - Mongolian Tugrik
    • MAD - Moroccan Dirham
    • MZM - Mozambique Metical
    • BOV - MVDol
    • MMK - Myanmar Kyat
    • NAD - Namibian Dollar
    • NPR - Nepalese Rupee
    • ANG - Netherlands Antillean Guilder
    • AWG - Netherlands Antillean Guilder
    • NLG - Netherlands Guilder
    • AON - New Kwanza
    • TWD - New Taiwan Dollar
    • ZRN - New Zaire
    • NZD - New Zealand Dollar
    • NIO - Nicaraguan Cordoba Oro
    • NGN - Nigerian Naira
    • KPW - North Korean Won
    • NOK - Norwegian Krone
    • PKR - Pakistan Rupee
    • PAB - Panamanian Balboa
    • PGK - Papua New Guinea Kina
    • PYG - Paraguay Guarani
    • PEN - Peruvian Nuevo Sol
    • PHP - Philippine Peso
    • PLN - Polish New Zloty
    • PLZ - Polish Zloty
    • PTE - Portuguese Escudo
    • GBP - Pound Sterling
    • QAR - Qatari Rial
    • OMR - Rial Omani
    • ROL - Romanian Leu
    • RUR - Russian Ruble
    • RWF - Rwanda Franc
    • WST - Samoan Tala
    • STD - Sao Tome and Principe Dobra
    • SAR - Saudi Riyal
    • SBL - Seborga Luigino
    • SCR - Seychelles Rupee
    • SLL - Sierra Leone Leone
    • SGD - Singapore Dollar
    • SKK - Slovak Koruna
    • SIT - Slovenian Tolar
    • SBD - Solomon Islands Dollar
    • SOS - Somali Shilling
    • ZAR - South African Rand
    • KRW - South Korean Won
    • ESP - Spanish Peseta
    • LKR - Sri Lanka Rupee
    • SHP - St. Helena Pound
    • SDA - Sudan Airline Rate
    • SDD - Sudanese Dinar
    • SDP - Sudanese Pound
    • SRG - Surinam Guilder
    • SZL - Swaziland Lilangeni
    • SEK - Swedish Krona
    • CHF - Swiss Franc
    • SYP - Syrian Pound
    • TJR - Tajik Ruble
    • TZS - Tanzanian Shilling
    • THB - Thai Baht
    • TPE - Timor Escudo
    • TOP - Tongan Pa'anga
    • TTD - Trinidad and Tobago Dollar
    • TND - Tunisian Dinar
    • TRL - Turkish Lira
    • TMM - Turkmen Manat
    • USD - U.S. Dollar
    • AED - UAE Dirham
    • UGX - Uganda Shilling
    • UAH - Ukrainian Hryvnia
    • ECV - Unidad de Valor Constante
    • UYU - Uruguayan Peso
    • USN - US Dollar (Next day)
    • UZS - Uzbekistan Sum
    • VUV - Vanuatu Vatu
    • VEB - Venezuelan Bolivar
    • VND - Vietnamese Dong
    • YER - Yemeni Rial
    • YUN - Yugoslavian New Dinar
    • ZMK - Zambian Kwacha
    • ZWD - Zimbabwe Dollar

[^]Code Fragment

    <xsd:simpleType name="CurrencyCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="AFA">
        <xsd:enumeration value="DZD">
        <xsd:enumeration value="ADF">
        <xsd:enumeration value="ADP">
        <xsd:enumeration value="ARP">
        <xsd:enumeration value="ARS">
        <xsd:enumeration value="ARA">
        <xsd:enumeration value="AMD">
        <xsd:enumeration value="AWF">
        <xsd:enumeration value="AUD">
        <xsd:enumeration value="ATS">
        <xsd:enumeration value="AZM">
        <xsd:enumeration value="BSD">
        <xsd:enumeration value="BHD">
        <xsd:enumeration value="BDT">
        <xsd:enumeration value="BBD">
        <xsd:enumeration value="BYB">
        <xsd:enumeration value="BEF">
        <xsd:enumeration value="BZD">
        <xsd:enumeration value="BMD">
        <xsd:enumeration value="BTN">
        <xsd:enumeration value="BOB">
        <xsd:enumeration value="BAK">
        <xsd:enumeration value="BWP">
        <xsd:enumeration value="BRL">
        <xsd:enumeration value="BND">
        <xsd:enumeration value="BGL">
        <xsd:enumeration value="BIF">
        <xsd:enumeration value="KHR">
        <xsd:enumeration value="CAD">
        <xsd:enumeration value="CVE">
        <xsd:enumeration value="KYD">
        <xsd:enumeration value="XOF">
        <xsd:enumeration value="XAF">
        <xsd:enumeration value="XPF">
        <xsd:enumeration value="CLP">
        <xsd:enumeration value="CLF">
        <xsd:enumeration value="CNY">
        <xsd:enumeration value="COP">
        <xsd:enumeration value="KMF">
        <xsd:enumeration value="CRC">
        <xsd:enumeration value="HRK">
        <xsd:enumeration value="CUP">
        <xsd:enumeration value="CYP">
        <xsd:enumeration value="CZK">
        <xsd:enumeration value="DKK">
        <xsd:enumeration value="DEM">
        <xsd:enumeration value="BAD">
        <xsd:enumeration value="DJF">
        <xsd:enumeration value="DOP">
        <xsd:enumeration value="XCD">
        <xsd:enumeration value="ECS">
        <xsd:enumeration value="EGP">
        <xsd:enumeration value="SVC">
        <xsd:enumeration value="ERN">
        <xsd:enumeration value="EEK">
        <xsd:enumeration value="ETB">
        <xsd:enumeration value="EUR">
        <xsd:enumeration value="XEU">
        <xsd:enumeration value="FKP">
        <xsd:enumeration value="FJD">
        <xsd:enumeration value="ZAL">
        <xsd:enumeration value="FIM">
        <xsd:enumeration value="FRF">
        <xsd:enumeration value="GMD">
        <xsd:enumeration value="GEL">
        <xsd:enumeration value="GHC">
        <xsd:enumeration value="GIP">
        <xsd:enumeration value="XAU">
        <xsd:enumeration value="GRD">
        <xsd:enumeration value="GTQ">
        <xsd:enumeration value="GNF">
        <xsd:enumeration value="GWP">
        <xsd:enumeration value="GYD">
        <xsd:enumeration value="HTG">
        <xsd:enumeration value="HNL">
        <xsd:enumeration value="HKD">
        <xsd:enumeration value="HUF">
        <xsd:enumeration value="ISK">
        <xsd:enumeration value="INR">
        <xsd:enumeration value="IDR">
        <xsd:enumeration value="IRA">
        <xsd:enumeration value="IRR">
        <xsd:enumeration value="IQD">
        <xsd:enumeration value="IEP">
        <xsd:enumeration value="ILS">
        <xsd:enumeration value="ITL">
        <xsd:enumeration value="JMD">
        <xsd:enumeration value="JPY">
        <xsd:enumeration value="JOD">
        <xsd:enumeration value="KZT">
        <xsd:enumeration value="KES">
        <xsd:enumeration value="KWD">
        <xsd:enumeration value="AOR">
        <xsd:enumeration value="KGS">
        <xsd:enumeration value="LAK">
        <xsd:enumeration value="LVL">
        <xsd:enumeration value="LBP">
        <xsd:enumeration value="ALL">
        <xsd:enumeration value="LSL">
        <xsd:enumeration value="LRD">
        <xsd:enumeration value="LYD">
        <xsd:enumeration value="LTL">
        <xsd:enumeration value="LUF">
        <xsd:enumeration value="MOP">
        <xsd:enumeration value="MKD">
        <xsd:enumeration value="MGF">
        <xsd:enumeration value="MWK">
        <xsd:enumeration value="MYR">
        <xsd:enumeration value="MVR">
        <xsd:enumeration value="MTL">
        <xsd:enumeration value="MRO">
        <xsd:enumeration value="MUR">
        <xsd:enumeration value="MXN">
        <xsd:enumeration value="MDL">
        <xsd:enumeration value="MNT">
        <xsd:enumeration value="MAD">
        <xsd:enumeration value="MZM">
        <xsd:enumeration value="BOV">
        <xsd:enumeration value="MMK">
        <xsd:enumeration value="NAD">
        <xsd:enumeration value="NPR">
        <xsd:enumeration value="ANG">
        <xsd:enumeration value="AWG">
        <xsd:enumeration value="NLG">
        <xsd:enumeration value="AON">
        <xsd:enumeration value="TWD">
        <xsd:enumeration value="ZRN">
        <xsd:enumeration value="NZD">
        <xsd:enumeration value="NIO">
        <xsd:enumeration value="NGN">
        <xsd:enumeration value="KPW">
        <xsd:enumeration value="NOK">
        <xsd:enumeration value="PKR">
        <xsd:enumeration value="PAB">
        <xsd:enumeration value="PGK">
        <xsd:enumeration value="PYG">
        <xsd:enumeration value="PEN">
        <xsd:enumeration value="PHP">
        <xsd:enumeration value="PLN">
        <xsd:enumeration value="PLZ">
        <xsd:enumeration value="PTE">
        <xsd:enumeration value="GBP">
        <xsd:enumeration value="QAR">
        <xsd:enumeration value="OMR">
        <xsd:enumeration value="ROL">
        <xsd:enumeration value="RUR">
        <xsd:enumeration value="RWF">
        <xsd:enumeration value="WST">
        <xsd:enumeration value="STD">
        <xsd:enumeration value="SAR">
        <xsd:enumeration value="SBL">
        <xsd:enumeration value="SCR">
        <xsd:enumeration value="SLL">
        <xsd:enumeration value="SGD">
        <xsd:enumeration value="SKK">
        <xsd:enumeration value="SIT">
        <xsd:enumeration value="SBD">
        <xsd:enumeration value="SOS">
        <xsd:enumeration value="ZAR">
        <xsd:enumeration value="KRW">
        <xsd:enumeration value="ESP">
        <xsd:enumeration value="LKR">
        <xsd:enumeration value="SHP">
        <xsd:enumeration value="SDA">
        <xsd:enumeration value="SDD">
        <xsd:enumeration value="SDP">
        <xsd:enumeration value="SRG">
        <xsd:enumeration value="SZL">
        <xsd:enumeration value="SEK">
        <xsd:enumeration value="CHF">
        <xsd:enumeration value="SYP">
        <xsd:enumeration value="TJR">
        <xsd:enumeration value="TZS">
        <xsd:enumeration value="THB">
        <xsd:enumeration value="TPE">
        <xsd:enumeration value="TOP">
        <xsd:enumeration value="TTD">
        <xsd:enumeration value="TND">
        <xsd:enumeration value="TRL">
        <xsd:enumeration value="TMM">
        <xsd:enumeration value="USD">
        <xsd:enumeration value="AED">
        <xsd:enumeration value="UGX">
        <xsd:enumeration value="UAH">
        <xsd:enumeration value="ECV">
        <xsd:enumeration value="UYU">
        <xsd:enumeration value="USN">
        <xsd:enumeration value="UZS">
        <xsd:enumeration value="VUV">
        <xsd:enumeration value="VEB">
        <xsd:enumeration value="VND">
        <xsd:enumeration value="YER">
        <xsd:enumeration value="YUN">
        <xsd:enumeration value="ZMK">
        <xsd:enumeration value="ZWD">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: CurrencyType

CurrencyType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( CurrencyCoded[CurrencyCodeType] , CurrencyCodedOther[xsd:string]? )

    Description: CurrencyType identifies a currency.

    Elements:

    • CurrencyCoded - identifies a currency using the standard set by UN/ECE Recommendation no.9
    • CurrencyCodedOther - is used to provide a non-standard CurrencyCode. This element is mandatory if the value of CurrencyCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="CurrencyType">
    <xsd:sequence>
        <xsd:element name="CurrencyCoded" type="CurrencyCodeType">
        <xsd:element minOccurs="0" name="CurrencyCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: DateCodedType

DateCodedType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( Date[xsd:dateTime] , DateQualifier[DateQualifierType] )

    Description: DateCodedType is a container for a date that has its function indicated with a qualifier.

    Elements:

    • Date - contains the actual date.
    • DateQualifier - is a container for the code qualifying a date.

[^]Code Fragment

    <xsd:complexType name="DateCodedType">
    <xsd:sequence>
        <xsd:element name="Date" type="xsd:dateTime">
        <xsd:element name="DateQualifier" type="DateQualifierType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: DateQualifierCodeType

DateQualifierCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the function of a date, time or period. This code list is derived from EDIFACT 2005 (Date or time or period function code qualifier) and X12 374 (Date/Time qualifier)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • 36030 - Calculation is based on year of 360 days, month of 30 days.
    • 36530 - Calculation is based on year of 365 days, month of 30 days.
    • 365630 - Calculation is based on year of 365-6 days, month of 30 days.
    • 3602831 - Calculation is based on year of 360 days, month of 28-31 days.
    • 3652831 - Calculation is based on year of 365 days, month of 28-31 days.
    • 36562831 - Calculation is based on year of 365-6 days, month of 28- 31 days.
    • 1stScheduleDelivery
    • 1stScheduleShip
    • Acceleration
    • AcceptanceDateOfDocument - The date on which a document was accepted.
    • AcceptanceDateOfGoodsDeclarationCustoms - Date on which a Goods declaration is accepted by Customs in accordance with Customs legislation.
    • AcceptanceDateTimeOfGoods - Date on which the goods are taken over by the carrier at the place of acceptance (CMR 4).
    • AccidentBenefitAgeLimit - To identify the age to which benefits are provided to the insured in the event of an accident.
    • AccidentBenefitPeriod - To identify the period of time for which benefits are provided in the event of an accident.
    • AccidentDateAndOrTime - Date and or time when an accident occurred.
    • AccidentInsuranceEliminationPeriod - To identify the period of time the insured must be disabled in the event of an accident for benefits to be payable by the ceding company.
    • AccidentLifetimeBenefitQualificationAge - To identify the qualification age for lifetime benefits provided to the insured in the event of an accident.
    • AccountantsOpinionDate - Date of an accountant's opinion.
    • AccountClosedDate - Date when account was closed.
    • AccountingMethodologyChangeDate - Date when accounting methodology was changed.
    • AccountingPeriod - Self-explanatory.
    • AccountingPeriodEndDate
    • AccountingPeriodStartDate
    • AccountingTransactionDate - Date to which an accounting transaction refers.
    • AccountingValueDate - Date against which the entry has to be legally allocated.
    • AccountingYear - Year considered for accounting of the treaty or portion of the treaty.
    • AccountOpened
    • AccountsReceivable-StatementDate
    • Acknowledgment
    • AcquisitionDate
    • ActionDate - Date of action.
    • ActionEndDate
    • ActivityReportingDate - The date applicable to the activity being reported.
    • ActivityPeriodDateRange - A specific date range associated with an activity.
    • Actual
    • ActualArchive
    • ArrivalDateTimeActual - [2106] Date (and time) of arrival of means of transport.
    • ActualComplete
    • DepartureDateTimeActual - (2280) Date (and time) of departure of means of transport.
    • DischargeDateTimeActual - Date/time when the specified goods or transport equipment has or have been discharged from the means of transport.
    • ActualPortOfEntry
    • ActualRelease
    • ActualReturnToWork
    • StartDateActual - Actual date of start.
    • AcuteManifestationDate - The date the symptoms manifested themselves in an acute form.
    • AcuteManifestationOfAChronicCondition
    • Added
    • AddressPeriod
    • Adjournment - The period of time over which an adjournment is in effect.
    • AdjustedAge - The adjusted age used for purposes of calculation.
    • AdjustedContestability
    • AdjustedDeathBenefit
    • AdjustedEnd
    • AdjustedHire
    • AdjustedStart
    • AdjustmentEffectiveDate
    • AdjustmentPeriod
    • AdjustmentPeriodEnd
    • AdjustmentPeriodStart
    • AdjustmentProcessed
    • AdjustmentPromised
    • AdjustmentToBillDated
    • AdministratorOrderedDate - Date when an administrator is ordered for a company.
    • AdmissionDateAndOrTimeExpected - Expected date and/or time of admission.
    • AdoptionDateActual - Actual date when adoption occurs.
    • AdviseAfterDateTime - The information must be advised after the date/time indicated.
    • AdviseBeforeDateTime - The information must be advised before the date/time indicated.
    • AdviseCompletedDateTime - The advise has been completed at the date indicated.
    • AdviseOnDateTime - The information must be advised on the date/time indicated.
    • AdvisingDate - Date of advice.
    • Age - The length of time that a person or thing has existed.
    • AgreementToPayDate - Date on which the debtor agreed to pay.
    • AiredDate
    • AllotmentPeriodStart
    • AllowableEffective
    • AllowedRenewalDurationPeriod - The period of time a company can renew its duration period.
    • AlternateBasePeriod
    • AlternateProblemResolution
    • AlternativeDueDate
    • AnalysisMonthEnding
    • AnesthesiaAdministration
    • Anniversary
    • AnnualReportDelinquentOnDate - Date when annual report was considered delinquent.
    • AnnualReportDueDate - Date when annual report is due.
    • AnnualReportFilingDate - Date when the annual report was filed.
    • AnnualReportMailingDate - Date when the annual report was mailed.
    • Annuitization
    • AnnuityCommencementDate
    • AnticipatedClosing
    • AppliancePlacement
    • ApplicantSigned
    • Application
    • ApplicationEntry
    • ApplicationLoggedDate
    • ApplicationStatus
    • AppointmentEffective
    • AppointmentExpiryDate - Date when an appointment will expire.
    • AppraisalOrdered
    • ApprovalOffer
    • ApprovalDate - Date of approval.
    • Arrested
    • ArrivalDateTimeAtInitialPort - Date/time that the conveyance arrives at the initial port in the country of destination.
    • ArrivalDateTimeEarliest - Date/time of earliest arrival of means of transport.
    • ArrivalDateTimeOfTransportLeadTime - Lead time is referenced to the date a transport will arrive or has arrived.
    • ArrivalDateTimeScheduled - Date (and time) of scheduled arrival of means of transport.
    • ArrivalDateTimeUltimate - Date (and time) of ultimate arrival of means of transport.
    • ArrivalInCountry
    • ArterialBloodGasTest
    • AsOf
    • AssemblyStart
    • Asset
    • AssetAndLiabilityScheduleDate - Date of the asset and liability schedule.
    • AssetDocumentationExpiration
    • AssignedDate - Date when assigned.
    • AssignmentRecorded
    • AttendanceDateAndOrTimeAndOrPeriod - Date and or time and or period of attendance.
    • AudienceDeficiencyPeriod
    • AuditPeriodAfterSplitDate
    • AuditPeriodPriorToSplitDate
    • AuthenticationDateTimeOfDocument - Date/time when the document is signed or otherwise authenticated.
    • AuthenticationValidationDateTime
    • AuthorizationDate - Date when an authorization was given.
    • AutomaticPremiumLoan
    • AvailabilityDueDate - Date when ordered items should be available at a specified location.
    • Availability - Date/time when received item is available.
    • AverageDeliveryDelay - The average delay between deliveries.
    • AveragePaymentPeriod - The average period of time over which money has been paid.
    • Award
    • BackOnMarket
    • BackOrderDeliveryDateTimePeriod - The date/time/period during which the delivery of a back order will take, or has taken, place.
    • BalanceDateTimePeriod - The date/time/period of a balance.
    • BalanceSheetDateLatest - Date of the latest balance sheet.
    • Base
    • Baseline
    • BaselineComplete
    • BaselineStart
    • BeforeInventoryIsReplenishedBasedOnStockCheckLeadTime - Lead time is the defined timespan.
    • BeginningLayDate
    • BeginTherapy
    • BeneficiarysBanksDueDate - Date on which funds should be made available to the beneficiary's bank.
    • Benefit
    • BenefitAdjustmentEnd
    • BenefitAdjustmentPeriod
    • BenefitAdjustmentStart
    • BenefitApplicationDate
    • BenefitBegin
    • BenefitChangeDateTime - Date/time when a benefit provided by a service provider is changed.
    • BenefitCreditEnd
    • BenefitCreditPeriod
    • BenefitCreditStart
    • BenefitDebitEnd
    • BenefitDebitStart
    • BenefitEnd
    • BenefitPaymentsTerminationDate - To identify the date on which benefit payments have ceased.
    • BenefitPeriod - The period of time for which benefits are provided.
    • BenefitReleaseAuthorizationDate - Date when a benefit is authorized for release.
    • BenefitsPaid
    • BenefitTransferEnd
    • BenefitTransferPeriod
    • BenefitTransferStart
    • BenefitTypeGrossWeeklyAmountEffective
    • BenefitTypeNetWeeklyAmountEffective
    • BenefitPeriodEndDate - Date when a period of benefit ends.
    • BenefitPeriodStartDate - Date when a period of benefit begins.
    • BestBeforeDate - The best before date.
    • BestTimeToCall
    • BiannualTerminalInspectionDate - The date on which a biannual inspection of a terminal has taken or will take place.
    • BidEffective
    • BidOpenDateBidsWillBeOpened
    • BidPriceException
    • Bill
    • BilledThrough
    • BillOfLadingDate - Date as specified on the bill of lading.
    • BirthCertificate
    • BirthDateTime - Date/time when a person was born.
    • BlanksValueDate - The date on which the funds are at the disposal of the receiving bank.
    • Blueprint
    • BoardOfDirectorsIncompleteAsOf
    • BoardOfDirectorsNotAuthorizedAsOfGivenDate - As of this date the board of directors is not authorized.
    • BoardOfDirectorsNotCompleteAsOfGivenDate - As of this date the board of directors is not fully filled.
    • BoardOfDirectorsRegistrationDate - Date when the board of directors was registered.
    • BookEntryDelivery
    • BookingDateTime - Date at which the booking was made.
    • BritishThermalUnitTestPerformed
    • BudgetLineApplicationDate - The date on which something has been applied to a budget line.
    • BusinessControlChangeDate - Date when a new authority took control.
    • BusinessOpenedDate - Date opened for business.
    • BusinessTerminationDate - Date the business terminates.
    • BuyersDock
    • BuyersLocalTime - Time at the buyer's location.
    • CalculationDate
    • CalendarAnniversary
    • CalendarYear
    • CancelAfter
    • CancelAfterExCountry
    • CancelAfterExFactory
    • CancelIfNotDeliveredByThisDate
    • CancelIfNotPublishedByThisDate - Cancel if not published by this date.
    • CancelIfNotShippedByThisDate - Cancel the order if goods not shipped by this date.
    • CancellationDate - Date on which a document or message has been cancelled.
    • CancellationDateTimeLatest - The latest date/time on which cancellation of the payment order may be requested.
    • CapitalizationDate - Date of capitalization.
    • CapitationPeriodEnd
    • CapitationPeriodStart
    • CargoBookingConfirmedDateTime - Date/time at which the cargo booking has been accepted by the carrier.
    • CargoReleaseDateTimeUltimate - Ultimate date/time at which goods or equipment should be released.
    • CaseConverted
    • CaseReopened
    • CashCallDate - Date on which a cash call was made for a loss suffered and covered.
    • CategoryChangeDateTime - Date/time when a change of category is made.
    • CeasedOperations
    • CertificateEffective
    • Certification
    • CertificationOfWeightDateTime - Date/time at which the carrier proceeds to the weighting of the goods.
    • CertificationPeriodStart
    • CertificationRevision
    • ChangedAccountingDate
    • ChangedDate - Date change takes place.
    • ChargeBackDateTime - Description to be provided.
    • ChargePeriod - Period a specified charge is valid for.
    • ChargePeriodEndDate - The charge period's last date.
    • ChargePeriodStartDate - The charge period's first date.
    • ChartOfAccountPeriod - Period covered by the chart of account.
    • Check
    • CheckedDate - Date when checked.
    • ChildbirthDateAndOrTimeActual - Actual date and or time of childbirth.
    • ChildbirthDateEstimated - Estimated date of childbirth.
    • Christening
    • Citation
    • CitizenshipChangeDate - Date of citizenship change.
    • ClaimAdministratorKnowledgeOfTheInjury
    • ClaimAdministratorNotifiedOfEmployeeLegalRepresentation
    • ClaimIncurredDate - The date that the claim was incurred.
    • ClaimMadeDate - The date on which a claim was made.
    • ClaimNotificationReceived
    • ClaimsMade
    • ClaimStatementPeriodEnd
    • ClaimStatementPeriodStart
    • Clause
    • ClearanceDateCustoms - (3080) Date on which Customs formalities necessary to allow goods to be exported, to enter home use, or to be placed under another Customs procedure has been accomplished (CCC).
    • ClinicalExaminationDateAndOrTime - Date and or time of clinical examination.
    • Closed
    • ClosedUntilDate - Date when again open.
    • ClosingDateOfFirstBalanceSheet
    • ClosingDateTime - Final date for delivering cargo to a liner ship.
    • ClosureDateTimePeriod - Date/time/period when an enterprise is closed.
    • CollateralDependent
    • CollateralDependentBegin
    • CollateralDependentEnd
    • Collection
    • CollectionDateTimeEarliest - The transport order may be issued before the goods are ready for picking up. This date/time indicates from when on the carrier can have access to the consignment.
    • CollectionDateTimeLatest - In relation with the arrangements agreed between buyer and seller or between sender and main transport it may be necessary to specify the latest collection date/time.
    • CommencedPumpingBallastDateTime - Date/time on which the intake of materials to be carried to improve the trim and the stability of the means of transport, was commenced.
    • CommencedTankCleaningDateTime - The date/and or time tank cleaning was started.
    • CommercialRating
    • CompanyTermination
    • ComparisonPeriod - The time period covered in a comparison.
    • CompilationDateAndTime - Date and time of the compilation.
    • Complaint
    • CompletedPumpingBallastDateTime - Date/time at which the intake of materials, to be carried to improve the trim and the stability of the means of transport, was completed.
    • CompletedTankCleaningDateTime - The date and/or time tank cleaning was completed.
    • CompletionDate - Date of completion.
    • CompletionDateOrTimeNotAfter - The not after date or time for completion.
    • CompletionDateOrTimeNotBefore - The not before date or time for completion.
    • CompletionDateOrTimeScheduled - The scheduled date or time for completion.
    • Compliance
    • ConditionInitialTreatmentDate - Date when initially treated for this condition.
    • Confinement
    • ConfinementEnd
    • ConfinementStart
    • ConfirmationDateLeadTime - Lead time is referenced to the date of confirmation.
    • ConfirmedDateTime - Date/time which has been confirmed.
    • Connection
    • Consolidated
    • ConsolidatedOmnibusBudgetReconciliationActCOBRA
    • ConsolidatedOmnibusBudgetReconciliationActCOBRABegin
    • ConsolidatedOmnibusBudgetReconciliationActCOBRAEnd
    • ConsolidatedOmnibusBudgetReconciliationActCOBRAQualifyingEvent
    • ConsolidationDate - Date when consolidation occurred.
    • ConstructionDateActual - Date of actual construction.
    • ConstructionStart
    • ContainerSafetyConventionCscInspectionDate - The date on which container equipment is to be or has been inspected as per the Container Safety Convention (CSC).
    • ContainerSafetyConventionCscPlateExpirationDate - Date on which the validity of a Container Safety Convention (CSC) plate expires.
    • ContainerStrippingDateTimeUltimate - Date/time on which the container stripping should be completed at the latest.
    • ContainerStuffingDateTimeUltimate - Date/time on which the container stuffing should be completed at the latest.
    • Contestability
    • Contingency
    • ContingencyEnd
    • Continuance
    • ContinuationOfPayStartDate
    • ContinuingEducationRequirement
    • ContinuousCoverageDates
    • ContinuousPassiveMotionCPM
    • ContractAuditDate
    • ContractAwardDateTime - Date/time on which the contract is awarded to a tenderer.
    • ContractBindingDate - The date from which a contract becomes binding on the contracting parties.
    • ContractCompletionDate - The date a contract is completed.
    • ContractCostsThrough
    • ContractDate - [2326] Date when a Contract is agreed.
    • ContractDefinition
    • ContractEffectiveDate - Date when a contract becomes valid.
    • ContractExpiryDate - Date when a contract expires.
    • ContractMailed
    • ContractPerformanceDelivery
    • ContractPerformanceStart
    • ContractPeriod
    • ContractRe-Open
    • ContractStart
    • ContractualDeliveryDate - The date of delivery contractually agreed between parties.
    • ContractualStartDateTime - Date/time on which activities stated in the contract must start.
    • ContributionPeriodEndDateTime - Date/time when a contribution period ends.
    • ContributionPeriodStartDateTime - Date/time when a contribution period commences.
    • ContributionsCeasingDateTime - Date/time when contributions cease.
    • ControlPlan
    • ControvertDate
    • ConversionPrivilegeEnd
    • ConversionToRepayment
    • ConversionIntoHoldingCompanyDate - Date business was converted into a holding company.
    • ConvertedToElectronicDate
    • ConveyanceRegistrationDate - Date when a vessel, vehicle or other means of transport was registered by a competent authority.
    • ConvictedDate - Date when convicted.
    • CoordinationOfBenefits
    • CoordinationOfBenefitsBegin
    • CoordinationOfBenefitsEnd
    • CorrectedDateOfBirth
    • Correction
    • CosignerSigned
    • CourtDismissalDate - The date on which a court refused further hearing of a case.
    • CourtEvent
    • CourtNotice
    • CourtRegistrationDate - Date of registration in the court.
    • CoverageDuration - The period coverage has been in force.
    • CoverageIssueDate - Date from which the anniversary coverage is measured.
    • CoveredIncomePeriod - To identify the period over which covered income is measured.
    • CreditAdvice
    • CreditDocumentationExpiration
    • CreditedService
    • CreditedServiceBegin
    • CreditedServiceEnd
    • CreditorsRequestedValueDate - Date on which the creditor requests to be credited.
    • Crime
    • CriminalSentenceDuration - The period of time over which a criminal sentence applies.
    • CrossborderDateTime - Date/time at which goods are transferred across a country border.
    • CumulativeQuantityEndDate - Last Date for accumulation of delivery quantities.
    • CumulativeQuantityStartDate - First Date for accumulation of delivery quantities.
    • CureTime - Specifies the length of time that an article was or should be cured.
    • Current
    • CurrentAuthorityControlStartDate - Date when current authority took control.
    • CurrentDisabilityPeriodEnd
    • CurrentDisabilityPeriodLastDayWorked
    • CurrentDisabilityPeriodStart
    • CurrentIncomePeriod - To identify the period over which current income is measured.
    • CurrentLegalStructureEffectiveDate - Date when current legal structure became effective.
    • CurrentList
    • CurrentMonthEnding
    • CurrentNameEffectiveDate - Date when current name became effective.
    • CurrentReportDate - Date of the current report.
    • CurrentScheduleDelivery
    • CurrentScheduleShip
    • CurtailmentDate
    • CurtailmentDatefromAdviceOfPayment
    • CustomerContractEffective
    • CustomerContractExpiration
    • CustomerOrder
    • CustomerValueDate - Date at which funds are taken into account for interest calculation (in debit or credit).
    • CustomsCargoRelease
    • CustomsClearance
    • CustomsEntryDate
    • Cycle
    • CycleBegin
    • CycleEnd
    • CycleToDate
    • DateAccountMatures
    • DateAcquired
    • DateAndOrTimeOfHandlingEstimated - The date and or time when the handling action is estimated to take place.
    • DateAsAt - Date related to a given context.
    • DateAssignmentFiledForRecord
    • BankruptcyFiledDate - Date when bankruptcy was filed.
    • DateBecameAware
    • DateClaimPaid
    • DateCourseOfOrthodonticsTreatmentBeganOrIsExpectedToBegin
    • DateDeedFiledForRecord
    • DateDefaultWasCured
    • DateDocumentationOrPaperworkOrBothWasSent
    • FiledDate - Date when filed.
    • DateForeclosureHeld
    • DateForeclosureProceedingsInstituted
    • DateForeclosureSaleScheduled
    • DateForTheLastUpdate - Date for the last update.
    • DateHazardInsurancePolicyCancelled
    • DateHazardInsurancePolicyRefused
    • DateMaterialUsageSuspended
    • DateOfAbandonment
    • DateOfAcquisitionOfTitle
    • DateOfAction
    • DateOfAdvance
    • DateOfAppraisal
    • DateOfAssignmentApproval
    • DateOfAssignmentRejection
    • DateOfClaim
    • DateOfClosing
    • DateOfDamage
    • DeceaseDate - Date when a person died.
    • DateOfDeedInLieu
    • DateOfDivorce - Date when two married persons are officially divorced.
    • DateOfExtensionToConvey
    • DateOfFirmCommitment
    • DateOfFirstMortgagePayment
    • DateOfFirstRegistration - Date of first registration.
    • DateOfFirstUncuredDefault
    • DateOfForeclosureNotice
    • DateOfLastContact
    • DateOfLastDraw
    • DateOfLastInstallmentReceived
    • DateOfLastPaymentReceived
    • DateOfLastUpdate
    • DateOfLoan
    • DateOfLocalOfficeApprovalOfConveyanceOfDamagedRealEstateProperty
    • DateOfLocalOfficeApprovalOfConveyanceOfOccupied
    • DateOfLocalOfficeCertificationOfConveyanceOfDamagedRealEstate
    • DateOfMaximumMedicalImprovement
    • DateOfNoticeOfProbableIneligibilityForAssignment
    • DateOfNoticeOfReferralForAssignment
    • DateOfNoticeToConvey
    • DateOfOperation
    • DateOfOrderLeadTime - Lead time is referenced to the date of order.
    • DateOfPossession
    • DateOfProductFailure - The date the product failed.
    • DateOfPropertyInspection
    • ReleaseFromBankruptcyDate - Date when an entity is released from bankruptcy status.
    • DateOfRepairOrService - The date of a repair or service.
    • DateOfSeizure
    • DateOfSeparation - Date of marital separation.
    • DateOfSourceDocument - The date of the source document.
    • DateOfSpecification
    • DateOfStandard
    • DateOnWhichAssetsJudgedInsufficientToPayCreditors
    • DateOutstandingLoanBalanceReported
    • PackagingDate - The date on which the packaging of a product took place.
    • DatePaid
    • DatePlacedInDisfavour - Date when placed in a disfavoured category or status.
    • DatePossessoryActionInitiated
    • DatePracticeCeased
    • DatePracticeEstablished
    • DatePropertySold
    • DateReadyForCollection - A date on which an object is ready for collection.
    • DateRedemptionPeriodEnds
    • DateReferredToAttorneyForForeclosure
    • RequestDate - The date on which something was asked for.
    • DateThroughWhichPropertyTaxesHaveBeenPaid
    • DateTimeOfDiscountTermination - Date/time when the deduction from an amount comes to an end.
    • DateTimeOfInterestDue - Date/time when the interest has to be paid.
    • DateTimeOfLatestAccountsFilingAtPublicRegistry - The latest date/time when financial accounts were filed at public registry.
    • DateTotalAmountOfDelinquencyReported
    • DateVoluntaryConveyanceAccepted
    • DateWhenContainerEquipmentBecomesDomestic - The date on which foreign-built container equipment has entered into the commerce of another country and has become domestic equipment.
    • DaylightOverdraftTime
    • DaysOfOperation - Week days of operation.
    • DeathDateAndOrTime - Date and or time of death.
    • DebitAdvice
    • DebitValueDateRequested - Date on which the account owner wants the debit value to his account.
    • DebtIncurred
    • DecisionDate
    • Declaration
    • DeclarationPresentationDate - Date when item has been or has to be declared/presented.
    • DeclarationReferencePeriod - Reference period of a set of items reported on the same declaration.
    • Deductible
    • DeedNotAvailableAsOfGivenDate - Date when deed was not available.
    • Deferral
    • DeferredDistribution
    • DeferredPayment
    • DeferredPeriod - The period of time for which an activity has been postponed.
    • DefinitionOfDisabilityDuration - To identify the period for which the definition of disability applies.
    • DelayedBillingNotDelayedPayment
    • DeletionDate - The date on which deletion occurs.
    • Delivered
    • DeliverNotBeforeAndNotAfterDates - Deliver not before and not after a specific date range.
    • DeliveryAppointmentDateAndTime
    • DeliveryDateTime1StSchedule
    • DeliveryDateTimeActual - Date/time on which goods or consignment are delivered at their destination.
    • DeliveryDateTimeCurrentSchedule - Delivery Date deriving from actual schedule.
    • DeliveryDateTimeDeferred - New date and time of delivery calculated on basis of a consignee's requirement (chargeable).
    • DeliveryDateTimeEarliest - Date identifying a point in time before which the goods shall not be delivered.
    • DeliveryDateTimeExpected - Date/time on which goods are expected to be delivered.
    • DeliveryDateTimeFirst - First possible date/time for delivery.
    • DeliveryDateTimeLast - Date when the last delivery should be or has been accomplished.
    • DeliveryDateTimeLatest - Date identifying a point of time after which goods shall not or will not be delivered.
    • DeliveryDateTimePromisedFor - [2138] Date by which, or period within which, the merchandise should be delivered to the buyer, as agreed between the seller and the buyer (generic term).
    • DeliveryDateTimePromisedForAfterAndIncluding - Delivery might take place earliest at given date.
    • DeliveryDateTimePromisedForPriorToAndIncluding - Delivery might take place latest at given date.
    • DeliveryDateTimeRequested - Date on which buyer requests goods to be delivered.
    • DeliveryDateTimeScheduledFor
    • DeliveryEnd
    • DeliveryOrderIssued
    • DeliveryRating
    • DeliveryRequested
    • DeliveryStart
    • DeliveryTicket
    • DenialEffective
    • DenialRescission
    • DepartmentAdmissionDateAndOrTime - Date and or time of admission to a department.
    • DepartmentDischargeDateAndOrTime - Date and or time of discharge from a department.
    • DepartmentOfLaborWageDeterminationDate
    • DepartureDateTime - [2280] Date (and time) of departure of means of transport.
    • DepartureDateTimeEarliest - Date/time of earliest departure of means of transport.
    • DepartureDateTimeFromLastPortOfCall - Date/time that conveyance departed from the last foreign port of call.
    • DepartureDateTimeScheduled - Date (and time) of scheduled departure of means of transport.
    • DepartureDateTimeUltimate - Date/time at which a means of transport has to depart ultimately.
    • DepartureFromSpecification
    • DepositDateTime
    • DespatchDateAndOrTime - (2170) Date/time on which the goods are or are expected to be despatched or shipped.
    • DespatchNoteDate - [2218] Date when a Despatch Note is issued.
    • DetrimentalInformationReceiptDate - Date when detrimental information was received.
    • DirectInterchangeDate - Date the item was directly interchanged.
    • Disability
    • DisabilityWaitPeriod - The period of time the insured must be disabled before reinsurance coverage becomes effective.
    • DisbursementDate
    • DischargeDateTime - Date/time when goods should, might or have been discharged from the means of transport.
    • DischargeAndLoadingCompletedDateTime - Date/time when all discharge and loading operations on the transport means have been completed.
    • Discharge-Planned
    • Discovered
    • DiscrepancyDateTime - Date/time at which a discrepancy has been found.
    • DisembarkationDateAndTime - Date and time at which crew and/or passengers disembark.
    • DismissalDate
    • Disposal
    • Disposition
    • DistributorEffective
    • DistributorTermination
    • DividendApplied
    • DocumentaryCreditAmendmentDate - Date of amendment of a documentary credit.
    • DocumentaryCreditExpiryDateTime - The latest date/time for presentation of the documents to the bank where the credit expires.
    • DocumentaryCreditIssueDate - The date the documentary credit has been issued.
    • DocumentaryCreditPresentationPeriod - The specification of the period of time, expressed in number of days, after the date of issuance of the transport document(s) within which the documents must be presented.
    • DocumentDate
    • DocumentDue
    • DocumentMessageDateTime - (2006) Date/time when a document/message is issued. This may include authentication.
    • DocumentReceivedDateTime - Date/time on which the document was actually received.
    • DocumentRequestedDateTime - Date/time on which the document is requested by a party.
    • DoNotDeliverAfter
    • DoNotDeliverBefore
    • DoNotShipBeforeExCountry
    • DoNotShipBeforeExFactory
    • Draft
    • DrawingRevisionDate - Date the drawing revision has been allocated to a design.
    • DropActionDate
    • DroppedToLessThanHalfTime
    • DueDate
    • DueDateLastCompleteInstallmentPaid
    • DueDateOfFirstPaymentToPrincipalAndInterest
    • DueToCustomer
    • DuplicateBill
    • Duration - Duration.
    • EarliestFilingPeriod - Earliest period for which a filing is made.
    • EarliestSaleDate - The earliest date on which the product may be made available for sale.
    • EarlyFinish
    • EarlyStart
    • EarlyWithdrawal
    • EarningsEffectiveDate
    • Education
    • EducationBegin
    • EducationEndDate - Date education is completed at an educational institution.
    • EducationStartDate - Date education begins at an educational institution.
    • EffectiveDateTime - Date and/or time at which specified event or document becomes effective.
    • EffectiveDateOfChange
    • Election
    • Eligibility
    • EligibilityBegin
    • EligibilityEnd
    • EmbarkationDateAndTime - Date and time at which crew and/or passengers board.
    • EmployedInThisPosition
    • EmployedInThisProfession
    • EmployeeEffectiveDateOfCoverage
    • EmployeeLaidOff
    • EmployeeTemporaryLaidOffPeriodStartDate - The start date of a period in which employees were temporarily placed out of work.
    • EmployeeTemporaryLaidOffPeriodEndDate - The ending date of a period in which employees were temporarily placed out of work.
    • EmployeeWagesCeased
    • EmployerKnowledgeOfTheInjury
    • EmployerReportedInjuryToClaimAdministrator
    • EmploymentPositionStartDate - The start date of employment in a particular position.
    • EmploymentEnd
    • EmploymentOrHire
    • EmploymentPositionStartDateEstimated - Estimated start date of employment in a particular position.
    • EmploymentProfessionStartDate - Start date of employment in a particular profession.
    • EndDateTime - Date/time on which a period (from - to) ends.
    • EndAvailabilityDate - The end date of availability.
    • EndDateOfSupport
    • EndDateScheduled - Date when activity is scheduled to end.
    • EndingLayDate
    • EndOfGrace
    • EndOfLastFiscalYear
    • EndorsedCertificateIssueDate - Date on which a certificate, endorsed by signature or other agreed means, is issued.
    • EndorsementDate
    • EngineeringChangeLevelDate - Date the engineering level of goods is changed.
    • EngineeringDataList
    • Enrollment
    • EnrollmentSignatureDate
    • EntryDate - Date of entry.
    • EntryDateEstimatedCustoms - Date on which the official date of Customs entry is anticipated.
    • EquipmentCollectionOrPickUpDateTimeActual - Date/time on which the equipment was actually collected.
    • EquipmentCollectionOrPickUpDateTimeEarliest - Date/time on which equipment can be picked up at the earliest.
    • EquipmentCollectionOrPickUpDateTimePlanned - Date/time on which equipment can be picked up, either full or empty, according to a planning.
    • EquipmentLogEntry
    • EquipmentPositioningDateTimeActual - Date/time on which equipment was actually positioned (delivered).
    • EquipmentPositioningDateTimeEstimated - Date/time on which equipment is estimated to be positioned (delivered).
    • EquipmentPositioningDateTimeRequested - Date/time on which equipment is requested to be positioned (delivered).
    • EquipmentPositioningDateTimeUltimate - Date/time on which equipment should be positioned (delivered) at the latest.
    • EquipmentPreTripDate - The date on which equipment is pre-tripped.
    • EquipmentReconditioningDateTimeActual - Actual date/time of the reconditioning of a piece of equipment.
    • EquipmentRepairReadyDateTimeUltimate - Ultimate date/time on which a piece of equipment must be
    • EquipmentReturnPeriodExpected - Period until which equipment is expected to be hired.
    • EquipmentStockCheckDateTime - Date/time on which equipment has been ascertained as being in stock.
    • EscalationDate - Value date of indexes appearing as numerators in an escalation formula.
    • EscalationStartDate - Value date of the indexes appearing as denominators in an escalation formula.
    • EstablishedDate - Date when an entity was established or created.
    • EstimateComment
    • Estimated
    • EstimatedAcceptanceDate - To estimate the date of acceptance.
    • ArrivalDateTimeEstimated - (2348) Date/time when carrier estimates that a means of transport should arrive at the port of discharge or place of destination.
    • CompletionDateOrTimeEstimated - The estimated date or time for completion.
    • EstimatedCompletion-FirstPriorMonth
    • EstimatedCompletion-SecondPriorMonth
    • EstimatedCompletion-ThirdPriorMonth
    • ConstructionDateEstimated - Estimated date of construction.
    • DateOfBirthEstimated - The estimated date of birth.
    • DeliveryDateTimeEstimated - Date and/or time when the shipper of the goods expects delivery will take place.
    • DepartureDateTimeEstimated - Date/time when carrier estimates that a means of transport should depart at the place of departure.
    • EstimatedEscrowClosing
    • EstimatedImmigrationDate
    • EstimatedPointOfArrival
    • EstimatedPointOfDischarge
    • EstimatedPortOfEntry
    • StartDateEstimated - Date of estimated start.
    • EstimatedStart-FirstPriorMonth
    • EstimatedStart-SecondPriorMonth
    • EstimatedStart-ThirdPriorMonth
    • EstimatePreparation
    • EvaluationDate - Date evaluation takes place.
    • EventDate - A date specifying an event.
    • Examination
    • ExecutionDate - The date when ordered bank initiated the transaction.
    • ExecutionDateTimeRequested - The date/time on which the ordered bank is requested to initiate the payment order, as specified by the originator (e.g. the date of the debit).
    • ExitPlantDate
    • ExpectedContainerHireFromDateTime - Estimated date and time when the containers are expected to go on-hire.
    • ExpectedFundingDate
    • ExpectedProblemResolutionDate - Date when problem is expected to be resolved.
    • ExpectedReply
    • ExpectedValueDate - Date on which the funds are expected to be at the disposal of the beneficiary.
    • ExpeditedOn
    • Expiration
    • ExpirationDateOfExtensionToAssign
    • ExpirationDateOfExtensiontoForeclose
    • ExpirationDateTimeOfCustomsDocument - Date on which validity of a customs document expires.
    • ExpirationDateToSubmitTitleEvidence
    • ExpirationOfExtensionToConvey
    • ExpirationOfExtensionToSubmitFiscalData
    • ExpirationOfForeclosureTimeframe
    • ExpiryDate - Date of expiry of the validity of a referenced document, price information or any other referenced data element with a limited validity period.
    • ExpiryDateOfExportLicence - [2078] Date of expiry of the validity of an Export Licence.
    • ExpiryDateOfImportLicence - [2272] Date of expiry of the validity of an Import Licence.
    • Explantation
    • ExportationDate - Date when imported vessel/merchandise last left the country of export for the country of import.
    • ExportationDateForTextiles - Date when imported textiles last left the country of origin for the country of importation.
    • Exposure
    • ExposureSourcePeriod
    • Extended
    • Extract
    • FacsimileDueBy
    • Failed
    • FailureModeEffective
    • FeasibilitySignOff
    • FederalHighwayAdministrationFhwaInspectionDate - The date on which container equipment is to be or has been inspected in accordance with the requirements of the U.S. Federal Highway Administration.
    • FeeCapitalization
    • FieldFailure
    • FieldTest
    • FileGenerationDateAndOrTime - Date and, or time of file generation.
    • FilingPeriod
    • FinalIssue
    • FinalReconciliationValueEstimateAsOf
    • FinalScheduledPayment
    • FinancialCoveragePeriod - The period of time for which financial coverage applies.
    • FinancialInformationDate - Date of the financial information.
    • FinancialInformationSubmissionDateTime - Date/time when financial information is submitted.
    • FinishDateOrTimeMandatory - The mandatory date or time for finishing.
    • FinishDateOrTimeEarliest - The earliest date or time for finishing.
    • FinishDateOrTimeLatest - The latest date or time for finishing.
    • FirstContact
    • FirstDateOfOrdering - The first date on which ordering may take place.
    • FirstInterestBearingDate - The first date from which interest is borne.
    • FirstInterestPaymentDue
    • FirstInvolvement
    • FirstIssue
    • FirstMarketed
    • FirstPaymentChange
    • FirstPaymentDue
    • FirstProduced
    • FirstPublishedDate - Date when material was first published.
    • FirstRateAdjustment
    • FirstSaleDateAndOrTimeAndOrPeriod - The first date, and/or time, and/or period a product was sold.
    • FirstSubmission
    • FirstVisitorConsultation
    • FiscalAnniversary
    • FlatExtraEnd
    • FlatExtraPeriod - Period for charging the additional extra.
    • ForecastPeriod - A period for which a forecast applies.
    • ForecastPeriodEndDate - The ending date of a forecast period.
    • ForecastPeriodStart - The beginning of a forecast period.
    • Formation
    • FreightBillDateTime - Date/time when freight bill is issued.
    • FromDateOfAwardToCompletion - Lead time to determine the completion date of an effort based on the date an award is made.
    • FromDateOfAwardToDelivery - Lead time to determine the delivery date based on the date an award is made.
    • FromDateOfAwardToEarliestDelivery - Lead time to determine the earliest date a delivery can be made based on the date an award is made.
    • FromDateOfAwardToLatestDelivery - Lead time to determine the latest date a delivery can be made based on the date an award is made.
    • FromDateOfNoticeToProceedToCommencementOf - performance Period of time from notice to proceed until performance commencement.
    • FromDateOfNoticeToProceedToCompletion - Period of time from date of notice to proceed until completion.
    • FromDateOfOrderReceiptToDelivery - Lead time is the defined timespan.
    • FromDateOfOrderReceiptToSampleReady - Lead time is the defined timespan.
    • FromDateOfOrderReceiptToShipment - Lead time is the defined timespan.
    • FromDateOfReceiptOfItemToApproval - Lead time to determine the date an item will be approved based on the date the item was received.
    • FromDateOfReceiptOfToolingAidsToSampleReady - Lead time is the defined timespan.
    • FromDateOfSampleApprovalToFirstProductShipment - Lead time is the defined timespan.
    • FromDateOfToolingAuthorizationToSampleReady - Lead time is the defined timespan.
    • FromLastBookedOrderToDelivery - Lead time is the defined timespan.
    • FumigationDateAndOrTime - The date/or time on which fumigation is to occur or has taken place.
    • FunctionalTest
    • FundsAppropriation-End
    • FundsAppropriation-Start
    • FuturePeriod - Period in the future.
    • GallonsPerMinuteTestPerformed
    • GoodsCollectionOrPickUpDateTimePlanned - Date/time at which goods can be picked up, according to a planning.
    • GoodsPositioningDateTimeExpected - Date/time on which goods are expected to be positioned.
    • GoodsPositioningDateTimePlanned - The date/time on which the goods will be positioned according to a planning.
    • GoodsReceiptDateTime - Date/time upon which the goods were received by a given party.
    • GraduationDate - Date when graduation occurs.
    • GroupContractEffective
    • GroupContractExpiration
    • GuaranteeDate - Date when a guarantee is placed.
    • GuaranteePeriod
    • GuarantorReceived
    • HandOverDateTimeActual - Date/time on which hand over (i.e. the transfer of responsibility for an object or activity such as documentation, system etc. from one party to another) actually takes place.
    • HandOverDateTimePlanned - Date/time on which hand over (i.e. the transfer of responsibility for an object or activity such as documentation, system etc. from one party to another) is planned to take place.
    • HighCapitalYear
    • HighFabricationReleaseAuthorization
    • HighRawMaterialAuthorization
    • HiredFromDate - Date from which an item has been or will be hired.
    • HiredUntilDate - Date until which an item has been or will be hired.
    • HoldAsOf
    • HoldAsStockAsOf
    • Holiday - A date or period that is a break from work.
    • HolidayFinish
    • HolidayStart
    • Homestead
    • HorizonEndDate - The last date of a period forming a horizon.
    • HorizonPeriod - Period forming a (planning) horizon.
    • HorizonStartDate - The first date of a period forming a horizon.
    • HosesConnectedDateTime - The date and/or time hoses were connected.
    • HosesDisconnectedDateTime - The date and/or time hoses were disconnected.
    • HospitalAdmissionDateAndOrTime - Date and or time of admission to a hospital.
    • HospitalDischargeDateAndOrTime - Date and or time of discharge from a hospital.
    • HydrotestDate - The date equipment has been hydrotested.
    • Illness
    • IllnessBegin
    • IllnessRecoveryDateExpected - Date when a person is expected to recover from illness.
    • ImmigrationDate
    • Implantation
    • ImplementationDateTimePeriod - A date/time/period within which an implementation is to take place.
    • Import
    • ImportationDate - Date on which goods are imported, as determined by the governing Customs administration.
    • ImportLicenceDate - [2292] Date when Import Licence is issued.
    • InactivityEndDate - Date when inactivity ends.
    • Inactivity
    • InboundMovementAuthorizationDate - Inland movement authorization date.
    • Incident
    • Income
    • IncomeDocumentationExpiration
    • IncomeIncreasePeriod
    • IncomePeriod - The period of time in which income is earned.
    • IncorporationDate - Date of incorporation.
    • IncorporationDissolution
    • IncumbencyPeriod
    • IndividualEducationPlanIEP
    • In-force
    • InformationReleaseAuthorizationDate - Date when the information was authorized to be released.
    • InitialClaim
    • InitialCompletion
    • InitialContactDate
    • InitialDisabilityPeriodEnd
    • InitialDisabilityPeriodLastDayWorked
    • InitialDisabilityPeriodReturnToWork
    • InitialDisabilityPeriodStart
    • InitialFeeDue
    • InitialFinancialAccountsFiledDate - Date when the initial financial accounts were filed.
    • PlacementDateInitial - Date of initial placement.
    • InitialPremium
    • InitialPremiumEffective
    • InitialRequestDate - Date of an initial request.
    • InitialTreatment
    • InjuryBegin
    • InjuryEnd
    • InjuryOrIllness
    • InlandShip
    • InquiryDate
    • InServiceSurveyDate - Date of survey of equipment while in use.
    • InsolvencyDischargeGrantedDate - Date when insolvency discharge was granted.
    • InspectionDate - Date of inspection.
    • InstallationDateTimePeriod
    • InstallmentDate
    • InstalmentPaymentDueDate - Self-explanatory.
    • InstructionsOriginalExecutionDate - Original execution date for the instruction.
    • InsufficientAssetsJudgementDate - The date on which assets were judged to be insufficient.
    • InsuranceCard
    • InterestCapitalization
    • InterestPaidThrough
    • InterestPaidTo
    • InterestPeriod - Number of days used for the calculation of interests.
    • InterestRateValidityPeriod - Validity period of the interest rate.
    • InternationalAssessmentApprovalForPublicationDate - Date the Data Maintenance Request (DMR) was approved for publication after completing international review.
    • InternationalReviewCycleStartDate - Date the international review cycle starts.
    • InterruptionEnd
    • InterruptionStart
    • InterviewedDate - Date of an interview.
    • InterviewerSigned
    • Inventory
    • InventoryReportDate - Date on which a inventory report is made.
    • InvestigationEndDate - The date when an investigation ended.
    • InvestigationStartDate - The date when an investigation began.
    • InvestmentNumberAllocationDate - The date that an investment number was allocated.
    • InvitationToTenderDateTime - Date/time on which the invitation to tender has been made available to relevant parties.
    • InvoiceDateTime - [2376] Date when a Commercial Invoice is issued.
    • InvoiceDateRequired - Date required for invoice issue.
    • InvoicePeriodEnd
    • InvoicePeriodStart
    • InvoicingPeriod - Period for which an invoice is issued.
    • IrregularInterestPaymentDue
    • IssueDate - Date when a document/message has been or will be issued.
    • ItemContractEffective
    • ItemContractExpiration
    • JoinedEmployerDate - Date when a person joins an employer.
    • JoinedFundDateTime - Date/time when a person joins a fund.
    • JudgementDate - The date on which a decision from a court of law was rendered.
    • Judgment
    • KeyEventCalendarYear
    • KeyEventFiscalYear
    • LabourWageDeterminationDate - The date a labour wage is determined.
    • LastActivityDate - Date of last activity.
    • LastAnnualReportDate - Date of the last annual report.
    • LastCapitalChangeDate - Date of last capital change.
    • LastCertification
    • LastChange
    • LastCheckForBalanceSheetUpdateDate - Date balance sheet was last checked to determine if update had taken place.
    • LastCivilianFlight
    • LastDateForAGovernmentAgencyToFileAClaim
    • LastDateOfAccountsFiledAtPublicRegister - Date on which accounts were last filed at the public register.
    • LastDateOfOrdering - The last date on which ordering may take place.
    • LastDateToFileAClaim - Date after which no claim can be filed.
    • LastDateToObject
    • LastEpisode
    • LastFlight
    • LastFollow-up
    • LastInsuranceMedical
    • LastInterestBearingDate - The last date from which interest is borne.
    • LastItemDelivery
    • LastLogged
    • LastMarketed
    • LastMeal
    • LastMenstrualCycleStartDate - Date when the last menstrual cycle started.
    • LastMenstrualPeriod
    • LastMilitaryFlight
    • LastNotification
    • LastOffHireDate - Date the item was last returned from hire.
    • LastOnHireDate - Date the item was last placed on hire.
    • LastPaidInstallmentDate
    • LastPaymentMade
    • LastPhysical
    • LastPremiumEffective
    • LastPremiumPaidDate
    • LastProduction
    • LastPublication
    • LastPublishedDate - Date when material was last published.
    • LastSalaryIncrease
    • LastSaleDateAndOrTimeAndOrPeriod - The last date, and/or time, and/or period a product was sold.
    • LastScreening
    • LastSeenDate - The date when last seen.
    • LastVisitDate - Date of last visit.
    • LastXRayDate - The date the last X-ray was taken.
    • LateFinish
    • LatestAbsence
    • LateStart
    • LatestBalanceSheet
    • LatestCheckInTime - Latest time of check-in.
    • LatestDeliveryDateatPier
    • LatestDeliveryDateAtRailRamp
    • LatestFilingPeriod - Latest period for which a filing may be made.
    • LatestMaterialSafetyDataSheetDate
    • LatestMeterReadingDate - Date on which the latest reading of a meter took place.
    • LatestOnBoardCarrierDate
    • LatestPriceAdjustmentDate - Date on which the latest price adjustment took place.
    • LatestReceivingDateCutoffDate
    • LatestVisitorConsultation
    • LayTimeFirstDay - First of a number of days allowed in a charter party of the loading and discharging of cargo.
    • LayTimeLastDay - Last of a number of days allowed in a charter party for the loading and discharging of cargo.
    • LeadTime - Time required between order entry till earliest goods delivery.
    • LeaseCommencement
    • LeasePeriod - The period associated with a lease.
    • LeaseTermEndDate - End date of the lease term.
    • LeaseTermStartDate - Start date of the lease term.
    • LeftEmployerDate - Date when a person leaves an employer.
    • LegalActionClosedDate - Date when the legal action was closed.
    • LegalActionStarted
    • LegalSettlementTermsMetDate - Date when terms specified in the legal settlement were met.
    • LegalStructureChangeDate - Date when legal structure was changed.
    • LenderCreditCheck
    • LetterOfAgreementDate - Date of a letter of agreement.
    • LetterOfLiabilityDate - Date of a letter of liability.
    • License
    • LicenseEffective
    • LicenseExpiration
    • LicenseRenewal
    • LicenseRequested
    • Lien
    • LiquidationDate - Date of liquidation.
    • ListingReceived
    • ListPriceChange
    • LoadedonVessel
    • LoadingDateTimeActual - Date/time when the specified goods or transport equipment has or have been loaded in or on the means of transport.
    • Loan
    • LoanPurchase
    • LoanServicingTransfer
    • LocationExceptionOrderNumberAssigned
    • Loss - Date, time, period on which a referenced loss occurred.
    • LotNumberExpiration
    • LowestActivityPeriod - Period of lowest activity.
    • LowPeriod
    • MailBy
    • MailingDate - Date when an item may be mailed.
    • MailReceiptDate - Date mail was received.
    • Maintenance
    • MaintenanceComment
    • MaintenanceEffective
    • MakegoodCommercialDate
    • ManagementAvailableDate - Date when management is available.
    • ManagerNotRegisteredAsOfGivenDate - As of this date the manager is not registered.
    • MandatoryOrTargetFinish
    • MandatoryOrTargetStart
    • ManifestShipNoticeDate - The date of issuance of a manifest or ship notice.
    • Manufacture
    • Map
    • DateOfMarriage - Date when two persons are married.
    • MasterLeaseAgreement
    • MaterialChangeNotice
    • MaterialClassification
    • MaterialSpecification
    • Maturity
    • MaturityDate - Date at which maturity occurs.
    • MaximumCreditGrantedDate - Date on which the highest credit was granted.
    • MeatAgeingPeriod - Period of time between slaughter and delivery during which meat is ageing.
    • Medicaid
    • MedicaidBegin
    • MedicaidEnd
    • MedicalCertificate
    • MedicalInformationSignature
    • MedicalInformationSystem
    • Medicare
    • MedicareBegin
    • MedicareEnd
    • MedicarePartACoverageEffectiveDate
    • MedicarePartAEligibilityBeginDate
    • MedicarePartAEligibilityEndDate
    • MedicarePartATerminationDate
    • MedicarePartBCoverageEffectiveDate
    • MedicarePartBEligibilityBeginDate
    • MedicarePartBEligibilityEndDate
    • MedicarePartBTerminationDate
    • Medication
    • MeetingDate - Date of the meeting.
    • Merger
    • Message
    • MeterReading
    • MidpointOfPerformance
    • MinimumRequiredDistribution
    • MinimumShelfLifeRemainingAtTimeOfDespatchPeriod - Period indicating the minimum shelf life remaining for a product at the time of leaving the supplier.
    • MinimumShelfLifeRemainingAtTimeOfReceipt - The minimum shelf life remaining at the time of receipt.
    • MonthEnding
    • MonthToDate
    • MooringDateAndTime - Date and time of mooring.
    • MortgageeOfficialSignatureDate
    • MortgageeReportedCurtailmentDate
    • MortgageNoteDate
    • MostLikelyEarlyFinish
    • MostLikelyEarlyStart
    • MostLikelyLateFinish
    • MostLikelyLateStart
    • MostRecentHemoglobinOrHematocritOrBoth
    • MostRecentRenewal
    • MostRecentRevisionorInitialVersion
    • MostRecentSerumCreatine
    • MovedFromLocationDate - The date an entity moved from a location.
    • NegotiatedExtensionDate
    • NegotiatedFinish
    • NegotiatedStart
    • NegotiationsStartDate - The date on which negotiations started.
    • NetCreditServiceDate
    • NetWorthDate - Date of net worth.
    • NextActivity
    • NextAnniversary
    • NextAnnualMeeting
    • NextInstallmentDueDate
    • NextInterestChangeDate
    • NextPayIncrease
    • NextPaymentDue
    • NextReviewDate - Date of next review.
    • NonWorking - To specify a non working date or period.
    • NoProductionScheduleEstablishedAsOf
    • NoPromiseAsOf
    • NoShippingScheduleEstablishedAsOf
    • NotAfter
    • NotBefore
    • Note
    • Notice
    • NotificationDateTime - Date/time of notification.
    • NotificationOfDeath
    • NotificationTimeLimit - The time limit which has been set for a notification to take place.
    • Notified
    • NotRegistered
    • NotRegisteredAsOfGivenDate - Date when not yet registered.
    • NursingHome
    • NursingHomeFrom
    • NursingHomeTo
    • Occupancy
    • Occurrence
    • OccurrenceSpan
    • OccurrenceSpanFrom
    • OccurrenceSpanTo
    • OfferExpiration
    • OffHireSurveyDate - Date on which the equipment was surveyed at the end of the current leasing period.
    • OffHold
    • OfficialRailCarInterchangeEitherActualorAgreedUpon
    • Off-Market
    • Offset
    • OffsetBegin
    • OffsetEnd
    • OffsetFromCoordinatedUniversalTimeUtc - Number of hour's offset from Coordinated Universal Time (UTC).
    • OldestUnpaidInstallment
    • On - Fixed maturity day for deferred payment or time draft(s).
    • OnBoardDate - The date goods have been loaded on board of a conveyance.
    • OnHireSurveyDate - Date on which the equipment was surveyed at the beginning of the current leasing period.
    • OnHold
    • OnsetOfCurrentSymptomsOrIllness
    • OnsetOfSimilarSymptomsOrIllness
    • OpenHouse
    • OpeningDate - Date of opening.
    • OperationsCeasedDate - Date when operations ceased.
    • Opinion
    • OptimisticEarlyFinish
    • OptimisticEarlyStart
    • OptimisticLateFinish
    • OptimisticLateStart
    • Option
    • Order
    • OrderAmendmentBindingDate - The date when an order amendment becomes binding for both parties.
    • OrderCompletionDateTimeUltimate - Date/time on which the order should be completed at the latest.
    • OrderDateTime - [2010] Date when an order is issued.
    • OrderEnd
    • OrderReceivedDateTime - Date/time when the purchase order is received by the seller.
    • OrderStart
    • OrderToProceedDate - Issue date of an instruction to start work.
    • Original
    • OriginalDueDate
    • OriginalDuration - Original length of time.
    • OriginalEarlyFinish
    • OriginalEarlyStart
    • OriginalEstimateDate - The date of the original estimate.
    • OriginalIssueAge - The original issue age.
    • OriginalList
    • OriginallyScheduledShip
    • OriginalMaturityDate
    • OriginalNameChangeDate - Date when the original name was changed.
    • OriginalPostingDate - Date when the entry was originally posted.
    • OriginalReceipt
    • OrthodonticTreatmentPeriodRemaining - The period of time that the orthodontic treatment has remaining.
    • OrthodonticTreatmentPeriodTotal - The period of orthodontic treatment from beginning to end.
    • Out-Of-Pocket
    • OutsideAuditorsReport
    • Overhauled
    • OverrideDateForSettlement
    • OverTargetBaselineMonth
    • OvertimeEndDate - Date when a period of overtime ends.
    • OvertimeStartDate - Date when a period of overtime begins.
    • OwnershipChangeDate - Date when ownership changes.
    • OwnershipPeriod
    • OxygenSaturationTest
    • OxygenTherapy
    • OxygenTherapyEvaluation
    • OxygenTherapyFrom
    • OxygenTherapyTo
    • PackingEndDate - Date on which packing completed.
    • PackingStartDate - Date on which packing commenced.
    • PaidInFull
    • PaidThroughDate
    • Paid-ThroughDateForAccruedSickPay
    • PaidThroughDateForMinimumPayment
    • Paid-ThroughDateForSalaryContinuation
    • PaidThroughDateForTotalPayment
    • Paid-ThroughDateForVacationPay
    • PaidToDate - Date to which payments have been paid.
    • Paid-up
    • PaperworkMailed
    • PartialAnnuitization
    • ParticipationDate - Date of participation.
    • PartTimeWorkingChangeDateTime - Date/time when the proportion of part-time work changes.
    • PastDue
    • PatientFirstVisitForCondition - The date of the first visit by a patient to a healthcare provider for this condition.
    • PaymentCommencement
    • PaymentDate - [2034] Date on which an amount due is made available to the creditor, in accordance with the terms of payment.
    • PaymentDateTimeDeferred - Date/time when instalments are due.
    • PaymentDueDate - Date/time at which funds should be made available.
    • PaymentEffective
    • PaymentInitiated
    • PaymentInstructionDateTime - Date/time on which a payment instruction was given.
    • PaymentIssue
    • PaymentPeriod - A period of time in which a payment has been or will be made.
    • PaymentPeriodEnd
    • PaymentPeriodStart
    • PaymentValuationPresentationDateTime - Date/time on which the payment valuation is presented.
    • PayrollDeductionDateTime - Date/time of a monetary deduction made from the salary of a person on a payroll.
    • PayrollPeriod
    • PayrollPeriodBegin
    • PayrollPeriodEnd
    • PeakActivityPeriod - Period of peak activity.
    • PeerReviewOrganizationPROApprovedStay
    • PeerReviewOrganizationPROApprovedStayFrom
    • PeerReviewOrganizationPROApprovedStayTo
    • Penalty
    • PenaltyBegin
    • PenaltyEnd
    • PendingArchive
    • PercolationTest
    • PeriodAnEventIsLateDueToCustomer - The period of time an event is late due to the actions of a customer.
    • PeriodAssigned - The period assigned.
    • PeriodBetweenChanges - The period of time between changes.
    • PeriodCoveredBySourceDocuments
    • PeriodEnd
    • PeriodExtended - Number of time units added to the original end date/time/period.
    • PeriodicInspectionDate - The date on which a periodic inspection has to take place.
    • PeriodOfCareEndDateAndOrTime - Date and or time when a period of care ends.
    • PeriodOfCareStartDateAndOrTime - Date and or time when a period of care starts.
    • PeriodOfIllnessEndDate - Date when a period of illness ends.
    • PeriodOfIllnessStartDate - Date when a period of illness began.
    • PeriodOverdue - The period by which an event is overdue.
    • PeriodStart
    • PeriodWorkedForTheCompany - Period of time that was worked for the company.
    • PermitToAdmitDate - Date on which permission was granted to move merchandise into a bonded warehouse or free trade zone.
    • PermitYear
    • PessimisticEarlyFinish
    • PessimisticEarlyStart
    • PessimisticLateFinish
    • PessimisticLateStart
    • PickUpCollectionDateTimeOfCargo - Date/time at which the cargo is picked up.
    • PickUpDateTimeOfEquipment - Date/time at which the equipment is picked up.
    • Placement
    • PlacementDate - The date something is placed.
    • PlacementDatePrevious - The date something was previously placed.
    • PlacementPeriodExpiration
    • Plan
    • PlanAnniversary
    • PlanBegin
    • PlanEnd
    • PlanEntry
    • PlannedDurationOfWorks
    • PlannedRelease
    • PlanOfTreatmentPeriod
    • PlanParticipationSuspension
    • PlanPeriodElection
    • PlanPeriodElectionBegin
    • PlanPeriodElectionEnd
    • PlanTermination
    • PluggedAndAbandoned
    • PolicyEffective
    • PolicyEffectiveOnOrAfter
    • PolicyEffectiveOnOrBefore
    • PolicyExpiration
    • PolicySurrender
    • PoolSettlement
    • PositioningDateTimeOfEquipment - Date/time when equipment is positioned.
    • PositioningDateTimeOfGoods - The date and/or time the goods have to be or have been positioned.
    • PostingDate - The date when an entry is posted to an account.
    • PostmarkDateTime
    • Post-Reclassification
    • Post-ReclassificationEndOfSecondYear
    • Post-ReclassificationFirstReportCard
    • Post-ReclassificationFirstSemi-annual
    • Post-ReclassificationSecondSemi-annual
    • PrearrangedDealMatch
    • Pre-AwardSurvey
    • PrecedingPeriod - Period preceding current period.
    • Pre-certificationDate
    • PreforeclosureAcceptanceDate
    • PreforeclosureSaleClosingDate
    • PregnancyBegin
    • PregnancyDurationActual - Actual duration of pregnancy.
    • PregnancyEnd
    • PremiumChangePeriod - To identify the period of the premium change.
    • PremiumPaidToDate
    • PremiumPaidToDateBegin
    • PremiumPaidToDateEnd
    • PreparationDateTimeOfDocument - Date and/or time that the document was prepared.
    • Prescription
    • PrescriptionDispensingDateAndOrTime - Date and or time when a prescription was dispensed.
    • PrescriptionFill
    • PrescriptionFrom
    • PrescriptionIssueDateAndOrTime - Date and or time when a prescription was issued.
    • PrescriptionTo
    • PresentationDateLatest - Latest date for presentation of a document.
    • PresentationDateOfGoodsDeclarationCustoms - [2032] Date on which a Goods declaration is presented or lodged with Customs.
    • PresentationToBankruptcyReceiversDate - Date when presented to the bankruptcy receivers.
    • PresentControl
    • PresentedToReceivers
    • PresentLegalStructure
    • PresentlyResiding
    • PresentmentDate
    • PresentName
    • PresentResidenceStartDate - The beginning date of residence at present location.
    • PreviousBookingDateTime - Date/time at which the previous booking was made.
    • PreviousCourtEvent
    • PreviousCurrentAccountDate - Date of the previous current account.
    • PreviousEmployment
    • PreviousEmploymentEnd
    • PreviousEmploymentStart
    • PreviousInvoiceDate - Indicates the date which was allocated to a previous invoice.
    • PreviouslyReportedDateOfBirth
    • PreviouslyResided
    • PreviousMeterReadingDate - Date on which the previous reading of a meter took place.
    • PreviousMonthEnding
    • PreviousPeriod
    • PreviousReportDate - Date of the previous report.
    • PreviousResidence
    • PreviousResidenceEnd
    • PreviousResidenceStart
    • PreviousTerminationDate - Identifies the date of the previous termination.
    • PriceAdjustmentDate - Value date of indexes appearing as numerators in a price adjustment formula.
    • PriceAdjustmentLimitDate - Limit value date of indexes used as numerators in a price adjustment formula.
    • PriceAdjustmentStartDate - Value date of the indexes appearing as denominators in a price adjustment formula.
    • PriceBaseDateTime - Base date/time of prices.
    • PriceProtection
    • PrimaryCareProvider
    • PrimaryCareProviderBegin
    • PrimaryCareProviderEnd
    • Printed
    • PriorContractAnniversary
    • PriorContractIssue
    • PriorHospitalizationDatesRelatedToCurrentServices
    • PriorIncorrectDateOfBirth
    • PriorNotice
    • PriorPlacement
    • PrivilegeDetailsVerificationDate - Date when privilege details were verified.
    • ProcessingDateTime - Date/time of processing.
    • ProcessingDatePeriod - Date/period a specific process happened/will happen.
    • ProcessingEndDateTime - Date/Time when a specific process ends.
    • ProcessingStartDateTime - Date/Time when a specific process starts.
    • ProductAvailabilityDate
    • ProductHeldUntil
    • Production
    • ProductionDateNoScheduleEstablishedAsOf - Date as of there is no valid production schedule.
    • ProductionInspectionDate - Date of production inspection.
    • ProductionManufactureDate - Date on which goods are produced.
    • ProductLifespanAtTimeOfProduction - The total lifespan of a product at the time of its production.
    • ProfitPeriod - Period over which profit was earned.
    • ProgrammedCalendarYear
    • ProgrammedFiscalYear
    • ProgressPayment
    • ProjectedActionEndDate
    • ProjectedForeclosureSaleDate
    • ProjectOverTargetBaselineDate - The date an over target baseline was implemented for a project.
    • PromisedForDelivery
    • PromisedForDeliveryAfterAndIncluding
    • PromisedForDeliveryPriorToAndIncluding
    • PromisedForDeliveryWeekOf
    • PromisedForShipment
    • PromisedForShipmentAfterAndIncluding
    • PromisedForShipmentPriortoAndIncluding
    • PromisedForShipmentWeekOf
    • PromotionDatePeriod - Date/period relevant for specific promotion activities.
    • PromotionEndDateTime - Date/time when promotion activities end.
    • PromotionFloorStockProtect-End
    • PromotionFloorStockProtect-Start
    • PromotionInvoicePerformance-End
    • PromotionInvoicePerformance-Start
    • PromotionOrder-End
    • PromotionOrder-Start
    • PromotionPerformance-End
    • PromotionPerformance-Start
    • PromotionRequestedDelivery-End
    • PromotionRequestedDelivery-Start
    • PromotionShip-End
    • PromotionShip-Start
    • PromotionStartDateTime - Date/time when promotion activities begin.
    • Property
    • PropertyAcquired
    • PropertyBuilt
    • PrototypeTest
    • ProviderSignatureDate - Date when the provider signed.
    • PublicationDate
    • PurchasedDate - Date of purchase.
    • PurchaseOrder
    • PurchaseOrderLatestPossibleChangeDate - Date identifying a point of time after which a purchase order cannot be changed.
    • PurchaseOrderReceived
    • PutIntoService
    • QualityRating
    • QuarterEnding
    • QuotaDate - Date that the quota applies to.
    • Quote
    • QuoteToBeReceivedBy
    • RateAdjustment
    • RateDate
    • RateOfExchangeDateTime - Date/time on which the exchange rate was fixed.
    • RatePriceDateTime - Date/time on which a rate/price is determined.
    • ReachedTotalDepth
    • ReadyForInspection
    • RealEstateProperty
    • RealEstateTaxYear
    • Rebuilt
    • Recapture
    • ReceivablesCollectionPeriod - The period of time over which receivable accounts are collected.
    • Received
    • ReceiveAtLockboxDate - The date on which a financial institution, serving as collection agency for a company located in another part of the country, collects an amount of money on behalf of that company.
    • ReceivedDateTime - Date/time of receipt.
    • ReceivedInTheMail
    • ReceiverAppointed
    • ReceivershipPeriod - Period of time a receivership lasts.
    • ReceivershipResultDate - Date when the result of the receivership occurs.
    • Reclassification
    • ReclassificationExitDate
    • Recompletion
    • RecordedDate - Date when recorded.
    • Recovery
    • RecoveryFinish
    • RecoveryStart
    • Re-entry
    • Re-evaluationDate
    • ReExportationDate - Date of re-exportation.
    • ReferenceDateTime - Date/time on which the reference was issued.
    • ReferencedItemCreationDate - Creation date of referenced item.
    • ReferralDate
    • ReferredFrom
    • ReferredTo
    • Refinance
    • RefusalPeriod - The period within which a refusal can be made.
    • Registered
    • RegisteredContractorNumberAssignmentDateOriginal - Date when a registered contractor number was originally assigned.
    • RegistrationDate - Date when registered.
    • RegistrationDateOfPreviousCustomsDeclaration - Registration date of the Customs declaration for the previous Customs procedure either in the same or another country.
    • RegistrationOfBoardOfDirectors
    • Rehire
    • ReimbursementClaimIssueDateAndOrTime - Date and or time when a reimbursement claim is issued.
    • ReImportationDate - Date of re-importation.
    • ReinstatementDate - Identifies the date of reinstatement.
    • ReinsuranceAccountingPeriod - To identify a reinsurance account period via start and end dates.
    • ReinsuranceCoverageDuration - The period for which reinsurance coverage has been in force.
    • ReinsuranceCurrentAccountPeriod - Description to be provided.
    • ReinsuranceEffective
    • ReinsuranceIssueAge - The actual or equivalent age at time of issue.
    • ReinsurancePaidUpDate - The date up to which the reinsurance has been paid.
    • ReinsurancePaymentFrequency - The frequency of payments of reinsurance premiums.
    • Reissue
    • Rejected
    • ReleaseDateTime - Date/time assigned to identify the release of a set of rules, conditions, conventions, productions, etc.
    • ReleaseDateCustoms - Date on which Customs releases merchandise to the carrier or importer.
    • ReleaseDateOfCustomer - Date the customer authorised the goods' release.
    • ReleaseDateOfSupplier - Date when the supplier released goods.
    • ReleasedReturnToWork
    • ReleasedToVessel
    • ReleaseFrequency - Frequency of a release.
    • ReleaseOfInformation
    • Remittance
    • RemodelingCompleted
    • Removed
    • RenewalDate - Date of renewal.
    • RentalPeriod
    • RentStart
    • RentSurvey
    • RepairTurnaroundTime - Provides the period of time necessary to turnaround a given repair.
    • RepaymentBegin
    • RepaymentScheduleSent
    • Replaced
    • Replacement
    • ReplacementEffective
    • ReplyDate
    • Report
    • ReportedDate - Date when reported.
    • ReportEndDate
    • ReportingCycleDate
    • ReportPeriod - Period covered by the report.
    • ReportStartDate
    • Requalification
    • Request
    • RequestedContract
    • RequestedDepartureDate
    • RequestedFinish
    • DeliveryDateTimeRequestedForAfterAndIncluding - Delivery is requested to happen after or on given date.
    • DeliveryDateTimeRequestedForPriorToAndIncluding - Delivery is requested to happen prior to or including the given date.
    • RequestedForDeliveryWeekOf
    • ShipmentDateTimeRequestedForAfterAndIncluding - Shipment should happen earliest at given date.
    • ShipmentDateTimeRequestedForPriorToAndIncluding - Shipment should take place latest at given date.
    • RequestedForShipmentWeekOf
    • RequestedOffer
    • RequestedPick-up
    • RequestedSettlement
    • RequestedShip
    • RequestedStart
    • RequestForQuotation
    • RequiredBy
    • RequiredDelivery
    • ReservationOfFacility
    • ResidentLicenseEffective
    • ResidentLicenseExpiration
    • ResignationDate - Date of resignation.
    • Resigned
    • ResolvedDate - Date when resolved.
    • RestDay
    • RestFinish
    • RestStart
    • Resubmission
    • RetentionReleaseDateTime - Date/time on which the retention is released.
    • RetentionReleaseDateTimePartial - Date/time on which the retention is partially released.
    • Retermination
    • Retirement
    • RetransmissionTimeStamp
    • ReturnedDate - Date return takes place.
    • ReturnedToCustomer
    • ReturnToWorkDate - Date of return to work.
    • ReturnToWorkPartTime
    • ReviewDate - Date the item was or will be reviewed.
    • ReviewPeriodEnd
    • RevisedAdjustedEnd
    • RevisedAdjustedStart
    • RevisedEstimateDate - The date the estimate was revised.
    • Revision
    • Revocation
    • Revoked
    • RigArrival
    • RoadFundTaxExpiryDate - The date of expiry of the road fund tax.
    • Sailing
    • SalaryChangeEffectiveDate - Date when a change in salary becomes effective.
    • SalaryDeferral
    • SaleableStockDemandCoverPeriodExpected - A period of time when saleable stocks are expected to cover demand for a product.
    • SalesDateAndOrTimeAndOrPeriod - The date, and or time, and or period on which a sale took place.
    • SalesPeriod
    • SampleAvailableDate - Date as of a sample will be available seller defined.
    • SampleCollected
    • SampleRequiredDate - Date as of a sample has to be available customer defined.
    • SamplesToBeReturnedBy
    • Sanction
    • SatisfactionDate - Date when satisfaction was obtained.
    • Satisfied
    • Schedule
    • ScheduledFinish
    • ScheduledForDeliveryOnOrAfter - Scheduled for delivery on or after the specified date, and or time.
    • ScheduledForDeliveryOnOrBefore - Scheduled for delivery on or before specified date and or time.
    • ScheduledForDeliveryWeekOf
    • ScheduledForShipmentAfterAndIncluding
    • ScheduledForShipmentPriorToAndIncluding
    • ScheduledForShipmentWeekOf
    • ScheduledInterchangeDelivery
    • ScheduledStart
    • ScheduleRelease
    • SchoolRefund
    • Seal
    • SecondAdmissionDate
    • SecondDischargeDate
    • SecurityRateAdjustment
    • SecuritySharePriceAsOfGivenDate - Date of the security share price.
    • Selected
    • SelectionPeriodEndDate - Date when a period of selection ends.
    • SelectionPeriodStartDate - Date when a period of selection begins.
    • SellByDate - The date by which a product should be sold.
    • SellersLocalTime - Time at the seller's location.
    • SemiannualEnding
    • SendingRoadTimeStamp
    • SepticApproval
    • Service
    • ServiceCompletionDateTimeActual - Actual date/time on which the service was completed.
    • ServiceInterruption
    • ServicePeriodEnd
    • ServicePeriodStart
    • ServiceRequested
    • ServicerSignatureDate
    • Setoff
    • Settled
    • SettlementDate - Date for settlement of financial transaction e.g. foreign exchange securities.
    • SettlementDateAsSpecifiedByTheOriginator
    • SettlementDateFromInterlineSettlementSystemOnly
    • SettlementDatePlanned
    • SettlementDueDate - More generic than 'payment due date' and therefore more apt for reinsurance/insurance business.
    • SettlementStatus
    • SharePrice
    • ShelfLifeExpiration
    • ShipDateOriginallyScheduled - The date on which the shipment of goods was originally scheduled.
    • ShipDuringDate - The date identifying the period during or in which the goods should be shipped.
    • ShipmentDateTimePromisedFor - Shipment might happen at given date/time.
    • ShipmentDateTimePromisedForPriorToAndIncluding - Shipment might take place latest at given date.
    • ShipmentDateTimeRequested - Date on which goods should be shipped or despatched by the supplier.
    • ShipNotLaterThanDateTime - Date/time by which the goods should have been shipped.
    • ShipNotBeforeDateTime - Goods should not be shipped before given date/time.
    • ShipNotBeforeAndNotAfterDateTime - Shipment(s) of goods is/are to be made not before the first specified date/time and not after the second specified date/time.
    • ShipOnOrAboutDate - Date on or about which goods should be shipped.
    • Shipped
    • ShippingDateAndOrTimeCurrentSchedule - Shipping date and/or time as currently scheduled.
    • ShippingDateNoScheduleEstablishedAsOf - As at this date no valid shipping schedule has been established.
    • ShipWeekOfDate - Date identifying the week during which goods should be shipped.
    • ShutIn
    • SicknessBenefitAgeLimit - To identify the age to which benefits are provided to the insured in the event of sickness.
    • SicknessBenefitPeriod - To identify the period of time for which benefits are provided in the event of sickness.
    • SicknessInsuranceEliminationPeriod - The period of time the insured must be disabled in the event of sickness for benefits to be payable by the ceding company.
    • SicknessLifetimeBenefitQualificationAge - To identify the qualification age for lifetime benefits provided to the insured in the event of sickness.
    • SidetrackedWellbore
    • SignatureDate - Date of signature.
    • SignatureReceived
    • SimilarIllnessOnsetDate - The date of the onset of an illness similar to the illness currently being treated.
    • SimpleInterestDue
    • SlaughteringEndDate - Date on which slaughtering completed.
    • SlaughteringStartDate - Date on which slaughtering commenced.
    • SocialSecurityClaimsVerificationDate - Date when social security claims were verified.
    • Sold
    • SoldBookPublication
    • SoleDirectorshipRegistrationDate - Date when sole directorship was registered.
    • Solicitation
    • SourceDocumentCaptureDate - Date source document data is entered into a business application.
    • SpacingOrderUnitAssigned
    • SponsoredDependent
    • SponsoredDependentBegin
    • SponsoredDependentEnd
    • SpouseRetirement
    • Spud
    • StartDateTime - Date/time on which a period starts.
    • StartDateOrTimeActual - The actual date or time for starting.
    • StartDateOrTimeEarliest - The earliest date or time for starting.
    • StartDateOrTimeEstimated - The estimated date or time for starting.
    • StartDateOrTimeLatest - The latest date or time for starting.
    • StartDateOrTimeMandatory - The mandatory date or time for starting.
    • StartDateOrTimeNotAfter - The not after date or time for starting.
    • StartDateOrTimeNotBefore - The not before date or time for starting.
    • StartDateOrTimeScheduled - The scheduled date or time for starting.
    • StartDateTimePlanned
    • StartedDoingBusiness
    • StartNoEarlierThan
    • StartNoLaterThan
    • Statement
    • StateResidencyDate
    • StateTermination
    • StatisticalTimeSeriesDate - Date for statistical time series purposes.
    • Status
    • StatusAfterAndIncluding
    • StatusAssignmentDate - Date a status was assigned.
    • StatusChangeDateTime - Date/time when a status changes.
    • StatusCommercial
    • StatusOutsideProcessor
    • StatusPriorAndIncluding
    • StopDistributionDate - The date on which distribution is to stop.
    • StopWorkAsOfGivenDate - Date work stopped or will stop.
    • Stored
    • StudentSigned
    • SubcontractorPeriodOfHire
    • SubmissionDate - The date of a submission.
    • Submittal
    • SubsequentInterestPaymentDue
    • SubsequentSubmission
    • SupersededDateTime - Date/time being overlaid by a date given elsewhere.
    • SupplementalIssue
    • SuppliersAverageCreditPeriod - The average period of time that credit is extended by suppliers.
    • SurfaceCasingAuthorityApproval
    • Surgery
    • Surrender
    • SurveyYear
    • SuspendedDate - Date of suspension.
    • SuspensionEffective
    • SuspensionPeriod - The period for which something is suspended.
    • SwornAndSubscribed
    • SymptomsOnsetPatientAlleged - Date and/or time of onset of symptoms according to the patient.
    • SystemSurvey
    • SystemTest
    • TableRatingEnd
    • TailCoverageBegin
    • TailCoverageEnd
    • TanksAcceptedDateTime - The date and/or time the tanks are to be or have been accepted.
    • TanksInspectedDateTime - The date and/or time the tanks are to be or have been inspected. Note: 1. This period is not the same as "reinsurance current account period".
    • Tax
    • TaxPeriod - Period a tax rate/tax amount etc. is applicable.
    • TaxPeriodEndDate - Date when a tax period ends.
    • TaxPeriodStartDate - Date when a tax period begins.
    • TaxPointDate - Date on which tax is due or calculated.
    • TaxYear
    • TechnicalRating
    • TelexDate - Date identifying when a telex message was sent.
    • TemporaryProsthesisDate - The date a temporary prosthetic device was provided.
    • TenderSubmissionDateTime - Date/time on which the tender was submitted.
    • TerminatedDate - Date termination takes place.
    • Termination
    • TerminationOfFacility
    • TermsDiscountDueDateTime - Date by which payment should be made if discount terms are to apply.
    • TermsMet
    • TermsNetDueDate - Date by which payment must be made.
    • TestCompletionDate - Date when a test has been completed.
    • TestPerformed
    • TestPeriodEnding
    • TestStartDate - Date when a test has been started.
    • TexasLineTermination
    • Therapy
    • TimeEmployeeBeganWork
    • TimeInUS
    • TimeLimit - The time limit in which an event must take place.
    • TimeNowDate - A time now date used for planning and scheduling purposes.
    • TimePeriod
    • TitleTransfer
    • ToolingRequiredDate - Date as of a tool has to be available customer defined.
    • TotalShelfLifePeriod - A period indicating the total shelf life of a product.
    • Tour
    • TradeDate
    • TradeStyleRegistrationDate - Date when trade style was registered.
    • TrainingBegin
    • TrainingEnd
    • TransactionCreationDate
    • TransferNoteAcceptanceDateAndTime - Date and time when a transfer note (transfer document for transport exclusively using containers as equipment) is recognised as being valid by the carrier.
    • Transferred
    • TranshipmentDateTime - Date and time of the transfer of the goods from one means of transport to another.
    • Transition
    • TransitTimeLimits - Description to be provided.
    • TransmissionDateTimeOfDocument
    • Transmitted
    • TransportEquipmentStrippingDateAndOrTime - The date and/or time on which the stripping of a transport equipment is to or has taken place.
    • TransportEquipmentStuffingDateAndOrTime - The date and/or time on which the stuffing of transport equipment is to or has taken place.
    • Travel
    • Treatment
    • TreatmentEnd
    • TreatmentStart
    • TrialBalancePeriod - Period covered by the trial balance.
    • TrialSet
    • TrialStartDateActual - Date when the trial actually started.
    • TrialStartDateScheduled - Date when a trial is scheduled to begin.
    • Trust
    • UnderwritingYear - Year in which the treaty was commenced.
    • UnloadedDateAndTime - To report the date and time that an unloading action occurred.
    • ValidationDate
    • ValidityPeriod - Dates (from/to)/period referenced documents are valid.
    • ValidityStartDate
    • ValidUntil
    • ValuationDateTime - Date/time of valuation.
    • ValuationDateCustoms - Date when Customs valuation was made.
    • ValueAddedTaxClaimsVerificationDate - Date when the Value Added Tax (VAT) claims were verified.
    • ValueDate - Date on which the funds are at the disposal of the beneficiary or cease to be at the disposal of the ordering customer.
    • ValueDateOfIndex - Date of validity of index values.
    • VerbalReportNeeded
    • VerificationReceived
    • VerificationSent
    • Verified
    • Version
    • VesselRegistry
    • VestingService
    • VestingServiceBegin
    • VestingServiceEnd
    • VoluntaryTermination
    • VoucherDateOf
    • WageEffective
    • WagesEarned
    • WagePeriodEndDate - Date when a period of wage ends.
    • WagePeriodStartDate - Date when a period of wage begins.
    • WaitingTime - The period of time between the moment at which one wants an activity to begin and the moment at which this activity can actually begin.
    • WarrantyExpiration
    • Waybill
    • WeekEnding
    • Weighed
    • WellLogRun
    • WholesaleContractEffective
    • WholesaleContractExpiration
    • WillAdviseAsOf
    • WithdrawnDate - The date when something was retracted.
    • WithheldDate
    • WorkEffectiveStartDate - The date on which work will effectively start.
    • WorkingPeriodEndDate - Date when a period of work ends.
    • WorkingPeriodStartDate - Date when a period of work begins.
    • WorkPeriod - Period of execution of works.
    • WorksCompletionDateTimeActual
    • WorksCompletionDateTimePlanned
    • WorstTimeToCall
    • YearBeginning
    • YearDue
    • YearEnding
    • YearOfOccurrence - Year in which a specific event (e.g. a loss) took place.
    • YearToDate

[^]Code Fragment

    <xsd:simpleType name="DateQualifierCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="36030">
        <xsd:enumeration value="36530">
        <xsd:enumeration value="365630">
        <xsd:enumeration value="3602831">
        <xsd:enumeration value="3652831">
        <xsd:enumeration value="36562831">
        <xsd:enumeration value="1stScheduleDelivery">
        <xsd:enumeration value="1stScheduleShip">
        <xsd:enumeration value="Acceleration">
        <xsd:enumeration value="AcceptanceDateOfDocument">
        <xsd:enumeration value="AcceptanceDateOfGoodsDeclarationCustoms">
        <xsd:enumeration value="AcceptanceDateTimeOfGoods">
        <xsd:enumeration value="AccidentBenefitAgeLimit">
        <xsd:enumeration value="AccidentBenefitPeriod">
        <xsd:enumeration value="AccidentDateAndOrTime">
        <xsd:enumeration value="AccidentInsuranceEliminationPeriod">
        <xsd:enumeration value="AccidentLifetimeBenefitQualificationAge">
        <xsd:enumeration value="AccountantsOpinionDate">
        <xsd:enumeration value="AccountClosedDate">
        <xsd:enumeration value="AccountingMethodologyChangeDate">
        <xsd:enumeration value="AccountingPeriod">
        <xsd:enumeration value="AccountingPeriodEndDate">
        <xsd:enumeration value="AccountingPeriodStartDate">
        <xsd:enumeration value="AccountingTransactionDate">
        <xsd:enumeration value="AccountingValueDate">
        <xsd:enumeration value="AccountingYear">
        <xsd:enumeration value="AccountOpened">
        <xsd:enumeration value="AccountsReceivable-StatementDate">
        <xsd:enumeration value="Acknowledgment">
        <xsd:enumeration value="AcquisitionDate">
        <xsd:enumeration value="ActionDate">
        <xsd:enumeration value="ActionEndDate">
        <xsd:enumeration value="ActivityReportingDate">
        <xsd:enumeration value="ActivityPeriodDateRange">
        <xsd:enumeration value="Actual">
        <xsd:enumeration value="ActualArchive">
        <xsd:enumeration value="ArrivalDateTimeActual">
        <xsd:enumeration value="ActualComplete">
        <xsd:enumeration value="DepartureDateTimeActual">
        <xsd:enumeration value="DischargeDateTimeActual">
        <xsd:enumeration value="ActualPortOfEntry">
        <xsd:enumeration value="ActualRelease">
        <xsd:enumeration value="ActualReturnToWork">
        <xsd:enumeration value="StartDateActual">
        <xsd:enumeration value="AcuteManifestationDate">
        <xsd:enumeration value="AcuteManifestationOfAChronicCondition">
        <xsd:enumeration value="Added">
        <xsd:enumeration value="AddressPeriod">
        <xsd:enumeration value="Adjournment">
        <xsd:enumeration value="AdjustedAge">
        <xsd:enumeration value="AdjustedContestability">
        <xsd:enumeration value="AdjustedDeathBenefit">
        <xsd:enumeration value="AdjustedEnd">
        <xsd:enumeration value="AdjustedHire">
        <xsd:enumeration value="AdjustedStart">
        <xsd:enumeration value="AdjustmentEffectiveDate">
        <xsd:enumeration value="AdjustmentPeriod">
        <xsd:enumeration value="AdjustmentPeriodEnd">
        <xsd:enumeration value="AdjustmentPeriodStart">
        <xsd:enumeration value="AdjustmentProcessed">
        <xsd:enumeration value="AdjustmentPromised">
        <xsd:enumeration value="AdjustmentToBillDated">
        <xsd:enumeration value="AdministratorOrderedDate">
        <xsd:enumeration value="AdmissionDateAndOrTimeExpected">
        <xsd:enumeration value="AdoptionDateActual">
        <xsd:enumeration value="AdviseAfterDateTime">
        <xsd:enumeration value="AdviseBeforeDateTime">
        <xsd:enumeration value="AdviseCompletedDateTime">
        <xsd:enumeration value="AdviseOnDateTime">
        <xsd:enumeration value="AdvisingDate">
        <xsd:enumeration value="Age">
        <xsd:enumeration value="AgreementToPayDate">
        <xsd:enumeration value="AiredDate">
        <xsd:enumeration value="AllotmentPeriodStart">
        <xsd:enumeration value="AllowableEffective">
        <xsd:enumeration value="AllowedRenewalDurationPeriod">
        <xsd:enumeration value="AlternateBasePeriod">
        <xsd:enumeration value="AlternateProblemResolution">
        <xsd:enumeration value="AlternativeDueDate">
        <xsd:enumeration value="AnalysisMonthEnding">
        <xsd:enumeration value="AnesthesiaAdministration">
        <xsd:enumeration value="Anniversary">
        <xsd:enumeration value="AnnualReportDelinquentOnDate">
        <xsd:enumeration value="AnnualReportDueDate">
        <xsd:enumeration value="AnnualReportFilingDate">
        <xsd:enumeration value="AnnualReportMailingDate">
        <xsd:enumeration value="Annuitization">
        <xsd:enumeration value="AnnuityCommencementDate">
        <xsd:enumeration value="AnticipatedClosing">
        <xsd:enumeration value="AppliancePlacement">
        <xsd:enumeration value="ApplicantSigned">
        <xsd:enumeration value="Application">
        <xsd:enumeration value="ApplicationEntry">
        <xsd:enumeration value="ApplicationLoggedDate">
        <xsd:enumeration value="ApplicationStatus">
        <xsd:enumeration value="AppointmentEffective">
        <xsd:enumeration value="AppointmentExpiryDate">
        <xsd:enumeration value="AppraisalOrdered">
        <xsd:enumeration value="ApprovalOffer">
        <xsd:enumeration value="ApprovalDate">
        <xsd:enumeration value="Arrested">
        <xsd:enumeration value="ArrivalDateTimeAtInitialPort">
        <xsd:enumeration value="ArrivalDateTimeEarliest">
        <xsd:enumeration value="ArrivalDateTimeOfTransportLeadTime">
        <xsd:enumeration value="ArrivalDateTimeScheduled">
        <xsd:enumeration value="ArrivalDateTimeUltimate">
        <xsd:enumeration value="ArrivalInCountry">
        <xsd:enumeration value="ArterialBloodGasTest">
        <xsd:enumeration value="AsOf">
        <xsd:enumeration value="AssemblyStart">
        <xsd:enumeration value="Asset">
        <xsd:enumeration value="AssetAndLiabilityScheduleDate">
        <xsd:enumeration value="AssetDocumentationExpiration">
        <xsd:enumeration value="AssignedDate">
        <xsd:enumeration value="AssignmentRecorded">
        <xsd:enumeration value="AttendanceDateAndOrTimeAndOrPeriod">
        <xsd:enumeration value="AudienceDeficiencyPeriod">
        <xsd:enumeration value="AuditPeriodAfterSplitDate">
        <xsd:enumeration value="AuditPeriodPriorToSplitDate">
        <xsd:enumeration value="AuthenticationDateTimeOfDocument">
        <xsd:enumeration value="AuthenticationValidationDateTime">
        <xsd:enumeration value="AuthorizationDate">
        <xsd:enumeration value="AutomaticPremiumLoan">
        <xsd:enumeration value="AvailabilityDueDate">
        <xsd:enumeration value="Availability">
        <xsd:enumeration value="AverageDeliveryDelay">
        <xsd:enumeration value="AveragePaymentPeriod">
        <xsd:enumeration value="Award">
        <xsd:enumeration value="BackOnMarket">
        <xsd:enumeration value="BackOrderDeliveryDateTimePeriod">
        <xsd:enumeration value="BalanceDateTimePeriod">
        <xsd:enumeration value="BalanceSheetDateLatest">
        <xsd:enumeration value="Base">
        <xsd:enumeration value="Baseline">
        <xsd:enumeration value="BaselineComplete">
        <xsd:enumeration value="BaselineStart">
        <xsd:enumeration value="BeforeInventoryIsReplenishedBasedOnStockCheckLeadTime">
        <xsd:enumeration value="BeginningLayDate">
        <xsd:enumeration value="BeginTherapy">
        <xsd:enumeration value="BeneficiarysBanksDueDate">
        <xsd:enumeration value="Benefit">
        <xsd:enumeration value="BenefitAdjustmentEnd">
        <xsd:enumeration value="BenefitAdjustmentPeriod">
        <xsd:enumeration value="BenefitAdjustmentStart">
        <xsd:enumeration value="BenefitApplicationDate">
        <xsd:enumeration value="BenefitBegin">
        <xsd:enumeration value="BenefitChangeDateTime">
        <xsd:enumeration value="BenefitCreditEnd">
        <xsd:enumeration value="BenefitCreditPeriod">
        <xsd:enumeration value="BenefitCreditStart">
        <xsd:enumeration value="BenefitDebitEnd">
        <xsd:enumeration value="BenefitDebitStart">
        <xsd:enumeration value="BenefitEnd">
        <xsd:enumeration value="BenefitPaymentsTerminationDate">
        <xsd:enumeration value="BenefitPeriod">
        <xsd:enumeration value="BenefitReleaseAuthorizationDate">
        <xsd:enumeration value="BenefitsPaid">
        <xsd:enumeration value="BenefitTransferEnd">
        <xsd:enumeration value="BenefitTransferPeriod">
        <xsd:enumeration value="BenefitTransferStart">
        <xsd:enumeration value="BenefitTypeGrossWeeklyAmountEffective">
        <xsd:enumeration value="BenefitTypeNetWeeklyAmountEffective">
        <xsd:enumeration value="BenefitPeriodEndDate">
        <xsd:enumeration value="BenefitPeriodStartDate">
        <xsd:enumeration value="BestBeforeDate">
        <xsd:enumeration value="BestTimeToCall">
        <xsd:enumeration value="BiannualTerminalInspectionDate">
        <xsd:enumeration value="BidEffective">
        <xsd:enumeration value="BidOpenDateBidsWillBeOpened">
        <xsd:enumeration value="BidPriceException">
        <xsd:enumeration value="Bill">
        <xsd:enumeration value="BilledThrough">
        <xsd:enumeration value="BillOfLadingDate">
        <xsd:enumeration value="BirthCertificate">
        <xsd:enumeration value="BirthDateTime">
        <xsd:enumeration value="BlanksValueDate">
        <xsd:enumeration value="Blueprint">
        <xsd:enumeration value="BoardOfDirectorsIncompleteAsOf">
        <xsd:enumeration value="BoardOfDirectorsNotAuthorizedAsOfGivenDate">
        <xsd:enumeration value="BoardOfDirectorsNotCompleteAsOfGivenDate">
        <xsd:enumeration value="BoardOfDirectorsRegistrationDate">
        <xsd:enumeration value="BookEntryDelivery">
        <xsd:enumeration value="BookingDateTime">
        <xsd:enumeration value="BritishThermalUnitTestPerformed">
        <xsd:enumeration value="BudgetLineApplicationDate">
        <xsd:enumeration value="BusinessControlChangeDate">
        <xsd:enumeration value="BusinessOpenedDate">
        <xsd:enumeration value="BusinessTerminationDate">
        <xsd:enumeration value="BuyersDock">
        <xsd:enumeration value="BuyersLocalTime">
        <xsd:enumeration value="CalculationDate">
        <xsd:enumeration value="CalendarAnniversary">
        <xsd:enumeration value="CalendarYear">
        <xsd:enumeration value="CancelAfter">
        <xsd:enumeration value="CancelAfterExCountry">
        <xsd:enumeration value="CancelAfterExFactory">
        <xsd:enumeration value="CancelIfNotDeliveredByThisDate">
        <xsd:enumeration value="CancelIfNotPublishedByThisDate">
        <xsd:enumeration value="CancelIfNotShippedByThisDate">
        <xsd:enumeration value="CancellationDate">
        <xsd:enumeration value="CancellationDateTimeLatest">
        <xsd:enumeration value="CapitalizationDate">
        <xsd:enumeration value="CapitationPeriodEnd">
        <xsd:enumeration value="CapitationPeriodStart">
        <xsd:enumeration value="CargoBookingConfirmedDateTime">
        <xsd:enumeration value="CargoReleaseDateTimeUltimate">
        <xsd:enumeration value="CaseConverted">
        <xsd:enumeration value="CaseReopened">
        <xsd:enumeration value="CashCallDate">
        <xsd:enumeration value="CategoryChangeDateTime">
        <xsd:enumeration value="CeasedOperations">
        <xsd:enumeration value="CertificateEffective">
        <xsd:enumeration value="Certification">
        <xsd:enumeration value="CertificationOfWeightDateTime">
        <xsd:enumeration value="CertificationPeriodStart">
        <xsd:enumeration value="CertificationRevision">
        <xsd:enumeration value="ChangedAccountingDate">
        <xsd:enumeration value="ChangedDate">
        <xsd:enumeration value="ChargeBackDateTime">
        <xsd:enumeration value="ChargePeriod">
        <xsd:enumeration value="ChargePeriodEndDate">
        <xsd:enumeration value="ChargePeriodStartDate">
        <xsd:enumeration value="ChartOfAccountPeriod">
        <xsd:enumeration value="Check">
        <xsd:enumeration value="CheckedDate">
        <xsd:enumeration value="ChildbirthDateAndOrTimeActual">
        <xsd:enumeration value="ChildbirthDateEstimated">
        <xsd:enumeration value="Christening">
        <xsd:enumeration value="Citation">
        <xsd:enumeration value="CitizenshipChangeDate">
        <xsd:enumeration value="ClaimAdministratorKnowledgeOfTheInjury">
        <xsd:enumeration value="ClaimAdministratorNotifiedOfEmployeeLegalRepresentation">
        <xsd:enumeration value="ClaimIncurredDate">
        <xsd:enumeration value="ClaimMadeDate">
        <xsd:enumeration value="ClaimNotificationReceived">
        <xsd:enumeration value="ClaimsMade">
        <xsd:enumeration value="ClaimStatementPeriodEnd">
        <xsd:enumeration value="ClaimStatementPeriodStart">
        <xsd:enumeration value="Clause">
        <xsd:enumeration value="ClearanceDateCustoms">
        <xsd:enumeration value="ClinicalExaminationDateAndOrTime">
        <xsd:enumeration value="Closed">
        <xsd:enumeration value="ClosedUntilDate">
        <xsd:enumeration value="ClosingDateOfFirstBalanceSheet">
        <xsd:enumeration value="ClosingDateTime">
        <xsd:enumeration value="ClosureDateTimePeriod">
        <xsd:enumeration value="CollateralDependent">
        <xsd:enumeration value="CollateralDependentBegin">
        <xsd:enumeration value="CollateralDependentEnd">
        <xsd:enumeration value="Collection">
        <xsd:enumeration value="CollectionDateTimeEarliest">
        <xsd:enumeration value="CollectionDateTimeLatest">
        <xsd:enumeration value="CommencedPumpingBallastDateTime">
        <xsd:enumeration value="CommencedTankCleaningDateTime">
        <xsd:enumeration value="CommercialRating">
        <xsd:enumeration value="CompanyTermination">
        <xsd:enumeration value="ComparisonPeriod">
        <xsd:enumeration value="CompilationDateAndTime">
        <xsd:enumeration value="Complaint">
        <xsd:enumeration value="CompletedPumpingBallastDateTime">
        <xsd:enumeration value="CompletedTankCleaningDateTime">
        <xsd:enumeration value="CompletionDate">
        <xsd:enumeration value="CompletionDateOrTimeNotAfter">
        <xsd:enumeration value="CompletionDateOrTimeNotBefore">
        <xsd:enumeration value="CompletionDateOrTimeScheduled">
        <xsd:enumeration value="Compliance">
        <xsd:enumeration value="ConditionInitialTreatmentDate">
        <xsd:enumeration value="Confinement">
        <xsd:enumeration value="ConfinementEnd">
        <xsd:enumeration value="ConfinementStart">
        <xsd:enumeration value="ConfirmationDateLeadTime">
        <xsd:enumeration value="ConfirmedDateTime">
        <xsd:enumeration value="Connection">
        <xsd:enumeration value="Consolidated">
        <xsd:enumeration value="ConsolidatedOmnibusBudgetReconciliationActCOBRA">
        <xsd:enumeration value="ConsolidatedOmnibusBudgetReconciliationActCOBRABegin">
        <xsd:enumeration value="ConsolidatedOmnibusBudgetReconciliationActCOBRAEnd">
        <xsd:enumeration value="ConsolidatedOmnibusBudgetReconciliationActCOBRAQualifyingEvent">
        <xsd:enumeration value="ConsolidationDate">
        <xsd:enumeration value="ConstructionDateActual">
        <xsd:enumeration value="ConstructionStart">
        <xsd:enumeration value="ContainerSafetyConventionCscInspectionDate">
        <xsd:enumeration value="ContainerSafetyConventionCscPlateExpirationDate">
        <xsd:enumeration value="ContainerStrippingDateTimeUltimate">
        <xsd:enumeration value="ContainerStuffingDateTimeUltimate">
        <xsd:enumeration value="Contestability">
        <xsd:enumeration value="Contingency">
        <xsd:enumeration value="ContingencyEnd">
        <xsd:enumeration value="Continuance">
        <xsd:enumeration value="ContinuationOfPayStartDate">
        <xsd:enumeration value="ContinuingEducationRequirement">
        <xsd:enumeration value="ContinuousCoverageDates">
        <xsd:enumeration value="ContinuousPassiveMotionCPM">
        <xsd:enumeration value="ContractAuditDate">
        <xsd:enumeration value="ContractAwardDateTime">
        <xsd:enumeration value="ContractBindingDate">
        <xsd:enumeration value="ContractCompletionDate">
        <xsd:enumeration value="ContractCostsThrough">
        <xsd:enumeration value="ContractDate">
        <xsd:enumeration value="ContractDefinition">
        <xsd:enumeration value="ContractEffectiveDate">
        <xsd:enumeration value="ContractExpiryDate">
        <xsd:enumeration value="ContractMailed">
        <xsd:enumeration value="ContractPerformanceDelivery">
        <xsd:enumeration value="ContractPerformanceStart">
        <xsd:enumeration value="ContractPeriod">
        <xsd:enumeration value="ContractRe-Open">
        <xsd:enumeration value="ContractStart">
        <xsd:enumeration value="ContractualDeliveryDate">
        <xsd:enumeration value="ContractualStartDateTime">
        <xsd:enumeration value="ContributionPeriodEndDateTime">
        <xsd:enumeration value="ContributionPeriodStartDateTime">
        <xsd:enumeration value="ContributionsCeasingDateTime">
        <xsd:enumeration value="ControlPlan">
        <xsd:enumeration value="ControvertDate">
        <xsd:enumeration value="ConversionPrivilegeEnd">
        <xsd:enumeration value="ConversionToRepayment">
        <xsd:enumeration value="ConversionIntoHoldingCompanyDate">
        <xsd:enumeration value="ConvertedToElectronicDate">
        <xsd:enumeration value="ConveyanceRegistrationDate">
        <xsd:enumeration value="ConvictedDate">
        <xsd:enumeration value="CoordinationOfBenefits">
        <xsd:enumeration value="CoordinationOfBenefitsBegin">
        <xsd:enumeration value="CoordinationOfBenefitsEnd">
        <xsd:enumeration value="CorrectedDateOfBirth">
        <xsd:enumeration value="Correction">
        <xsd:enumeration value="CosignerSigned">
        <xsd:enumeration value="CourtDismissalDate">
        <xsd:enumeration value="CourtEvent">
        <xsd:enumeration value="CourtNotice">
        <xsd:enumeration value="CourtRegistrationDate">
        <xsd:enumeration value="CoverageDuration">
        <xsd:enumeration value="CoverageIssueDate">
        <xsd:enumeration value="CoveredIncomePeriod">
        <xsd:enumeration value="CreditAdvice">
        <xsd:enumeration value="CreditDocumentationExpiration">
        <xsd:enumeration value="CreditedService">
        <xsd:enumeration value="CreditedServiceBegin">
        <xsd:enumeration value="CreditedServiceEnd">
        <xsd:enumeration value="CreditorsRequestedValueDate">
        <xsd:enumeration value="Crime">
        <xsd:enumeration value="CriminalSentenceDuration">
        <xsd:enumeration value="CrossborderDateTime">
        <xsd:enumeration value="CumulativeQuantityEndDate">
        <xsd:enumeration value="CumulativeQuantityStartDate">
        <xsd:enumeration value="CureTime">
        <xsd:enumeration value="Current">
        <xsd:enumeration value="CurrentAuthorityControlStartDate">
        <xsd:enumeration value="CurrentDisabilityPeriodEnd">
        <xsd:enumeration value="CurrentDisabilityPeriodLastDayWorked">
        <xsd:enumeration value="CurrentDisabilityPeriodStart">
        <xsd:enumeration value="CurrentIncomePeriod">
        <xsd:enumeration value="CurrentLegalStructureEffectiveDate">
        <xsd:enumeration value="CurrentList">
        <xsd:enumeration value="CurrentMonthEnding">
        <xsd:enumeration value="CurrentNameEffectiveDate">
        <xsd:enumeration value="CurrentReportDate">
        <xsd:enumeration value="CurrentScheduleDelivery">
        <xsd:enumeration value="CurrentScheduleShip">
        <xsd:enumeration value="CurtailmentDate">
        <xsd:enumeration value="CurtailmentDatefromAdviceOfPayment">
        <xsd:enumeration value="CustomerContractEffective">
        <xsd:enumeration value="CustomerContractExpiration">
        <xsd:enumeration value="CustomerOrder">
        <xsd:enumeration value="CustomerValueDate">
        <xsd:enumeration value="CustomsCargoRelease">
        <xsd:enumeration value="CustomsClearance">
        <xsd:enumeration value="CustomsEntryDate">
        <xsd:enumeration value="Cycle">
        <xsd:enumeration value="CycleBegin">
        <xsd:enumeration value="CycleEnd">
        <xsd:enumeration value="CycleToDate">
        <xsd:enumeration value="DateAccountMatures">
        <xsd:enumeration value="DateAcquired">
        <xsd:enumeration value="DateAndOrTimeOfHandlingEstimated">
        <xsd:enumeration value="DateAsAt">
        <xsd:enumeration value="DateAssignmentFiledForRecord">
        <xsd:enumeration value="BankruptcyFiledDate">
        <xsd:enumeration value="DateBecameAware">
        <xsd:enumeration value="DateClaimPaid">
        <xsd:enumeration value="DateCourseOfOrthodonticsTreatmentBeganOrIsExpectedToBegin">
        <xsd:enumeration value="DateDeedFiledForRecord">
        <xsd:enumeration value="DateDefaultWasCured">
        <xsd:enumeration value="DateDocumentationOrPaperworkOrBothWasSent">
        <xsd:enumeration value="FiledDate">
        <xsd:enumeration value="DateForeclosureHeld">
        <xsd:enumeration value="DateForeclosureProceedingsInstituted">
        <xsd:enumeration value="DateForeclosureSaleScheduled">
        <xsd:enumeration value="DateForTheLastUpdate">
        <xsd:enumeration value="DateHazardInsurancePolicyCancelled">
        <xsd:enumeration value="DateHazardInsurancePolicyRefused">
        <xsd:enumeration value="DateMaterialUsageSuspended">
        <xsd:enumeration value="DateOfAbandonment">
        <xsd:enumeration value="DateOfAcquisitionOfTitle">
        <xsd:enumeration value="DateOfAction">
        <xsd:enumeration value="DateOfAdvance">
        <xsd:enumeration value="DateOfAppraisal">
        <xsd:enumeration value="DateOfAssignmentApproval">
        <xsd:enumeration value="DateOfAssignmentRejection">
        <xsd:enumeration value="DateOfClaim">
        <xsd:enumeration value="DateOfClosing">
        <xsd:enumeration value="DateOfDamage">
        <xsd:enumeration value="DeceaseDate">
        <xsd:enumeration value="DateOfDeedInLieu">
        <xsd:enumeration value="DateOfDivorce">
        <xsd:enumeration value="DateOfExtensionToConvey">
        <xsd:enumeration value="DateOfFirmCommitment">
        <xsd:enumeration value="DateOfFirstMortgagePayment">
        <xsd:enumeration value="DateOfFirstRegistration">
        <xsd:enumeration value="DateOfFirstUncuredDefault">
        <xsd:enumeration value="DateOfForeclosureNotice">
        <xsd:enumeration value="DateOfLastContact">
        <xsd:enumeration value="DateOfLastDraw">
        <xsd:enumeration value="DateOfLastInstallmentReceived">
        <xsd:enumeration value="DateOfLastPaymentReceived">
        <xsd:enumeration value="DateOfLastUpdate">
        <xsd:enumeration value="DateOfLoan">
        <xsd:enumeration value="DateOfLocalOfficeApprovalOfConveyanceOfDamagedRealEstateProperty">
        <xsd:enumeration value="DateOfLocalOfficeApprovalOfConveyanceOfOccupied">
        <xsd:enumeration value="DateOfLocalOfficeCertificationOfConveyanceOfDamagedRealEstate">
        <xsd:enumeration value="DateOfMaximumMedicalImprovement">
        <xsd:enumeration value="DateOfNoticeOfProbableIneligibilityForAssignment">
        <xsd:enumeration value="DateOfNoticeOfReferralForAssignment">
        <xsd:enumeration value="DateOfNoticeToConvey">
        <xsd:enumeration value="DateOfOperation">
        <xsd:enumeration value="DateOfOrderLeadTime">
        <xsd:enumeration value="DateOfPossession">
        <xsd:enumeration value="DateOfProductFailure">
        <xsd:enumeration value="DateOfPropertyInspection">
        <xsd:enumeration value="ReleaseFromBankruptcyDate">
        <xsd:enumeration value="DateOfRepairOrService">
        <xsd:enumeration value="DateOfSeizure">
        <xsd:enumeration value="DateOfSeparation">
        <xsd:enumeration value="DateOfSourceDocument">
        <xsd:enumeration value="DateOfSpecification">
        <xsd:enumeration value="DateOfStandard">
        <xsd:enumeration value="DateOnWhichAssetsJudgedInsufficientToPayCreditors">
        <xsd:enumeration value="DateOutstandingLoanBalanceReported">
        <xsd:enumeration value="PackagingDate">
        <xsd:enumeration value="DatePaid">
        <xsd:enumeration value="DatePlacedInDisfavour">
        <xsd:enumeration value="DatePossessoryActionInitiated">
        <xsd:enumeration value="DatePracticeCeased">
        <xsd:enumeration value="DatePracticeEstablished">
        <xsd:enumeration value="DatePropertySold">
        <xsd:enumeration value="DateReadyForCollection">
        <xsd:enumeration value="DateRedemptionPeriodEnds">
        <xsd:enumeration value="DateReferredToAttorneyForForeclosure">
        <xsd:enumeration value="RequestDate">
        <xsd:enumeration value="DateThroughWhichPropertyTaxesHaveBeenPaid">
        <xsd:enumeration value="DateTimeOfDiscountTermination">
        <xsd:enumeration value="DateTimeOfInterestDue">
        <xsd:enumeration value="DateTimeOfLatestAccountsFilingAtPublicRegistry">
        <xsd:enumeration value="DateTotalAmountOfDelinquencyReported">
        <xsd:enumeration value="DateVoluntaryConveyanceAccepted">
        <xsd:enumeration value="DateWhenContainerEquipmentBecomesDomestic">
        <xsd:enumeration value="DaylightOverdraftTime">
        <xsd:enumeration value="DaysOfOperation">
        <xsd:enumeration value="DeathDateAndOrTime">
        <xsd:enumeration value="DebitAdvice">
        <xsd:enumeration value="DebitValueDateRequested">
        <xsd:enumeration value="DebtIncurred">
        <xsd:enumeration value="DecisionDate">
        <xsd:enumeration value="Declaration">
        <xsd:enumeration value="DeclarationPresentationDate">
        <xsd:enumeration value="DeclarationReferencePeriod">
        <xsd:enumeration value="Deductible">
        <xsd:enumeration value="DeedNotAvailableAsOfGivenDate">
        <xsd:enumeration value="Deferral">
        <xsd:enumeration value="DeferredDistribution">
        <xsd:enumeration value="DeferredPayment">
        <xsd:enumeration value="DeferredPeriod">
        <xsd:enumeration value="DefinitionOfDisabilityDuration">
        <xsd:enumeration value="DelayedBillingNotDelayedPayment">
        <xsd:enumeration value="DeletionDate">
        <xsd:enumeration value="Delivered">
        <xsd:enumeration value="DeliverNotBeforeAndNotAfterDates">
        <xsd:enumeration value="DeliveryAppointmentDateAndTime">
        <xsd:enumeration value="DeliveryDateTime1StSchedule">
        <xsd:enumeration value="DeliveryDateTimeActual">
        <xsd:enumeration value="DeliveryDateTimeCurrentSchedule">
        <xsd:enumeration value="DeliveryDateTimeDeferred">
        <xsd:enumeration value="DeliveryDateTimeEarliest">
        <xsd:enumeration value="DeliveryDateTimeExpected">
        <xsd:enumeration value="DeliveryDateTimeFirst">
        <xsd:enumeration value="DeliveryDateTimeLast">
        <xsd:enumeration value="DeliveryDateTimeLatest">
        <xsd:enumeration value="DeliveryDateTimePromisedFor">
        <xsd:enumeration value="DeliveryDateTimePromisedForAfterAndIncluding">
        <xsd:enumeration value="DeliveryDateTimePromisedForPriorToAndIncluding">
        <xsd:enumeration value="DeliveryDateTimeRequested">
        <xsd:enumeration value="DeliveryDateTimeScheduledFor">
        <xsd:enumeration value="DeliveryEnd">
        <xsd:enumeration value="DeliveryOrderIssued">
        <xsd:enumeration value="DeliveryRating">
        <xsd:enumeration value="DeliveryRequested">
        <xsd:enumeration value="DeliveryStart">
        <xsd:enumeration value="DeliveryTicket">
        <xsd:enumeration value="DenialEffective">
        <xsd:enumeration value="DenialRescission">
        <xsd:enumeration value="DepartmentAdmissionDateAndOrTime">
        <xsd:enumeration value="DepartmentDischargeDateAndOrTime">
        <xsd:enumeration value="DepartmentOfLaborWageDeterminationDate">
        <xsd:enumeration value="DepartureDateTime">
        <xsd:enumeration value="DepartureDateTimeEarliest">
        <xsd:enumeration value="DepartureDateTimeFromLastPortOfCall">
        <xsd:enumeration value="DepartureDateTimeScheduled">
        <xsd:enumeration value="DepartureDateTimeUltimate">
        <xsd:enumeration value="DepartureFromSpecification">
        <xsd:enumeration value="DepositDateTime">
        <xsd:enumeration value="DespatchDateAndOrTime">
        <xsd:enumeration value="DespatchNoteDate">
        <xsd:enumeration value="DetrimentalInformationReceiptDate">
        <xsd:enumeration value="DirectInterchangeDate">
        <xsd:enumeration value="Disability">
        <xsd:enumeration value="DisabilityWaitPeriod">
        <xsd:enumeration value="DisbursementDate">
        <xsd:enumeration value="DischargeDateTime">
        <xsd:enumeration value="DischargeAndLoadingCompletedDateTime">
        <xsd:enumeration value="Discharge-Planned">
        <xsd:enumeration value="Discovered">
        <xsd:enumeration value="DiscrepancyDateTime">
        <xsd:enumeration value="DisembarkationDateAndTime">
        <xsd:enumeration value="DismissalDate">
        <xsd:enumeration value="Disposal">
        <xsd:enumeration value="Disposition">
        <xsd:enumeration value="DistributorEffective">
        <xsd:enumeration value="DistributorTermination">
        <xsd:enumeration value="DividendApplied">
        <xsd:enumeration value="DocumentaryCreditAmendmentDate">
        <xsd:enumeration value="DocumentaryCreditExpiryDateTime">
        <xsd:enumeration value="DocumentaryCreditIssueDate">
        <xsd:enumeration value="DocumentaryCreditPresentationPeriod">
        <xsd:enumeration value="DocumentDate">
        <xsd:enumeration value="DocumentDue">
        <xsd:enumeration value="DocumentMessageDateTime">
        <xsd:enumeration value="DocumentReceivedDateTime">
        <xsd:enumeration value="DocumentRequestedDateTime">
        <xsd:enumeration value="DoNotDeliverAfter">
        <xsd:enumeration value="DoNotDeliverBefore">
        <xsd:enumeration value="DoNotShipBeforeExCountry">
        <xsd:enumeration value="DoNotShipBeforeExFactory">
        <xsd:enumeration value="Draft">
        <xsd:enumeration value="DrawingRevisionDate">
        <xsd:enumeration value="DropActionDate">
        <xsd:enumeration value="DroppedToLessThanHalfTime">
        <xsd:enumeration value="DueDate">
        <xsd:enumeration value="DueDateLastCompleteInstallmentPaid">
        <xsd:enumeration value="DueDateOfFirstPaymentToPrincipalAndInterest">
        <xsd:enumeration value="DueToCustomer">
        <xsd:enumeration value="DuplicateBill">
        <xsd:enumeration value="Duration">
        <xsd:enumeration value="EarliestFilingPeriod">
        <xsd:enumeration value="EarliestSaleDate">
        <xsd:enumeration value="EarlyFinish">
        <xsd:enumeration value="EarlyStart">
        <xsd:enumeration value="EarlyWithdrawal">
        <xsd:enumeration value="EarningsEffectiveDate">
        <xsd:enumeration value="Education">
        <xsd:enumeration value="EducationBegin">
        <xsd:enumeration value="EducationEndDate">
        <xsd:enumeration value="EducationStartDate">
        <xsd:enumeration value="EffectiveDateTime">
        <xsd:enumeration value="EffectiveDateOfChange">
        <xsd:enumeration value="Election">
        <xsd:enumeration value="Eligibility">
        <xsd:enumeration value="EligibilityBegin">
        <xsd:enumeration value="EligibilityEnd">
        <xsd:enumeration value="EmbarkationDateAndTime">
        <xsd:enumeration value="EmployedInThisPosition">
        <xsd:enumeration value="EmployedInThisProfession">
        <xsd:enumeration value="EmployeeEffectiveDateOfCoverage">
        <xsd:enumeration value="EmployeeLaidOff">
        <xsd:enumeration value="EmployeeTemporaryLaidOffPeriodStartDate">
        <xsd:enumeration value="EmployeeTemporaryLaidOffPeriodEndDate">
        <xsd:enumeration value="EmployeeWagesCeased">
        <xsd:enumeration value="EmployerKnowledgeOfTheInjury">
        <xsd:enumeration value="EmployerReportedInjuryToClaimAdministrator">
        <xsd:enumeration value="EmploymentPositionStartDate">
        <xsd:enumeration value="EmploymentEnd">
        <xsd:enumeration value="EmploymentOrHire">
        <xsd:enumeration value="EmploymentPositionStartDateEstimated">
        <xsd:enumeration value="EmploymentProfessionStartDate">
        <xsd:enumeration value="EndDateTime">
        <xsd:enumeration value="EndAvailabilityDate">
        <xsd:enumeration value="EndDateOfSupport">
        <xsd:enumeration value="EndDateScheduled">
        <xsd:enumeration value="EndingLayDate">
        <xsd:enumeration value="EndOfGrace">
        <xsd:enumeration value="EndOfLastFiscalYear">
        <xsd:enumeration value="EndorsedCertificateIssueDate">
        <xsd:enumeration value="EndorsementDate">
        <xsd:enumeration value="EngineeringChangeLevelDate">
        <xsd:enumeration value="EngineeringDataList">
        <xsd:enumeration value="Enrollment">
        <xsd:enumeration value="EnrollmentSignatureDate">
        <xsd:enumeration value="EntryDate">
        <xsd:enumeration value="EntryDateEstimatedCustoms">
        <xsd:enumeration value="EquipmentCollectionOrPickUpDateTimeActual">
        <xsd:enumeration value="EquipmentCollectionOrPickUpDateTimeEarliest">
        <xsd:enumeration value="EquipmentCollectionOrPickUpDateTimePlanned">
        <xsd:enumeration value="EquipmentLogEntry">
        <xsd:enumeration value="EquipmentPositioningDateTimeActual">
        <xsd:enumeration value="EquipmentPositioningDateTimeEstimated">
        <xsd:enumeration value="EquipmentPositioningDateTimeRequested">
        <xsd:enumeration value="EquipmentPositioningDateTimeUltimate">
        <xsd:enumeration value="EquipmentPreTripDate">
        <xsd:enumeration value="EquipmentReconditioningDateTimeActual">
        <xsd:enumeration value="EquipmentRepairReadyDateTimeUltimate">
        <xsd:enumeration value="EquipmentReturnPeriodExpected">
        <xsd:enumeration value="EquipmentStockCheckDateTime">
        <xsd:enumeration value="EscalationDate">
        <xsd:enumeration value="EscalationStartDate">
        <xsd:enumeration value="EstablishedDate">
        <xsd:enumeration value="EstimateComment">
        <xsd:enumeration value="Estimated">
        <xsd:enumeration value="EstimatedAcceptanceDate">
        <xsd:enumeration value="ArrivalDateTimeEstimated">
        <xsd:enumeration value="CompletionDateOrTimeEstimated">
        <xsd:enumeration value="EstimatedCompletion-FirstPriorMonth">
        <xsd:enumeration value="EstimatedCompletion-SecondPriorMonth">
        <xsd:enumeration value="EstimatedCompletion-ThirdPriorMonth">
        <xsd:enumeration value="ConstructionDateEstimated">
        <xsd:enumeration value="DateOfBirthEstimated">
        <xsd:enumeration value="DeliveryDateTimeEstimated">
        <xsd:enumeration value="DepartureDateTimeEstimated">
        <xsd:enumeration value="EstimatedEscrowClosing">
        <xsd:enumeration value="EstimatedImmigrationDate">
        <xsd:enumeration value="EstimatedPointOfArrival">
        <xsd:enumeration value="EstimatedPointOfDischarge">
        <xsd:enumeration value="EstimatedPortOfEntry">
        <xsd:enumeration value="StartDateEstimated">
        <xsd:enumeration value="EstimatedStart-FirstPriorMonth">
        <xsd:enumeration value="EstimatedStart-SecondPriorMonth">
        <xsd:enumeration value="EstimatedStart-ThirdPriorMonth">
        <xsd:enumeration value="EstimatePreparation">
        <xsd:enumeration value="EvaluationDate">
        <xsd:enumeration value="EventDate">
        <xsd:enumeration value="Examination">
        <xsd:enumeration value="ExecutionDate">
        <xsd:enumeration value="ExecutionDateTimeRequested">
        <xsd:enumeration value="ExitPlantDate">
        <xsd:enumeration value="ExpectedContainerHireFromDateTime">
        <xsd:enumeration value="ExpectedFundingDate">
        <xsd:enumeration value="ExpectedProblemResolutionDate">
        <xsd:enumeration value="ExpectedReply">
        <xsd:enumeration value="ExpectedValueDate">
        <xsd:enumeration value="ExpeditedOn">
        <xsd:enumeration value="Expiration">
        <xsd:enumeration value="ExpirationDateOfExtensionToAssign">
        <xsd:enumeration value="ExpirationDateOfExtensiontoForeclose">
        <xsd:enumeration value="ExpirationDateTimeOfCustomsDocument">
        <xsd:enumeration value="ExpirationDateToSubmitTitleEvidence">
        <xsd:enumeration value="ExpirationOfExtensionToConvey">
        <xsd:enumeration value="ExpirationOfExtensionToSubmitFiscalData">
        <xsd:enumeration value="ExpirationOfForeclosureTimeframe">
        <xsd:enumeration value="ExpiryDate">
        <xsd:enumeration value="ExpiryDateOfExportLicence">
        <xsd:enumeration value="ExpiryDateOfImportLicence">
        <xsd:enumeration value="Explantation">
        <xsd:enumeration value="ExportationDate">
        <xsd:enumeration value="ExportationDateForTextiles">
        <xsd:enumeration value="Exposure">
        <xsd:enumeration value="ExposureSourcePeriod">
        <xsd:enumeration value="Extended">
        <xsd:enumeration value="Extract">
        <xsd:enumeration value="FacsimileDueBy">
        <xsd:enumeration value="Failed">
        <xsd:enumeration value="FailureModeEffective">
        <xsd:enumeration value="FeasibilitySignOff">
        <xsd:enumeration value="FederalHighwayAdministrationFhwaInspectionDate">
        <xsd:enumeration value="FeeCapitalization">
        <xsd:enumeration value="FieldFailure">
        <xsd:enumeration value="FieldTest">
        <xsd:enumeration value="FileGenerationDateAndOrTime">
        <xsd:enumeration value="FilingPeriod">
        <xsd:enumeration value="FinalIssue">
        <xsd:enumeration value="FinalReconciliationValueEstimateAsOf">
        <xsd:enumeration value="FinalScheduledPayment">
        <xsd:enumeration value="FinancialCoveragePeriod">
        <xsd:enumeration value="FinancialInformationDate">
        <xsd:enumeration value="FinancialInformationSubmissionDateTime">
        <xsd:enumeration value="FinishDateOrTimeMandatory">
        <xsd:enumeration value="FinishDateOrTimeEarliest">
        <xsd:enumeration value="FinishDateOrTimeLatest">
        <xsd:enumeration value="FirstContact">
        <xsd:enumeration value="FirstDateOfOrdering">
        <xsd:enumeration value="FirstInterestBearingDate">
        <xsd:enumeration value="FirstInterestPaymentDue">
        <xsd:enumeration value="FirstInvolvement">
        <xsd:enumeration value="FirstIssue">
        <xsd:enumeration value="FirstMarketed">
        <xsd:enumeration value="FirstPaymentChange">
        <xsd:enumeration value="FirstPaymentDue">
        <xsd:enumeration value="FirstProduced">
        <xsd:enumeration value="FirstPublishedDate">
        <xsd:enumeration value="FirstRateAdjustment">
        <xsd:enumeration value="FirstSaleDateAndOrTimeAndOrPeriod">
        <xsd:enumeration value="FirstSubmission">
        <xsd:enumeration value="FirstVisitorConsultation">
        <xsd:enumeration value="FiscalAnniversary">
        <xsd:enumeration value="FlatExtraEnd">
        <xsd:enumeration value="FlatExtraPeriod">
        <xsd:enumeration value="ForecastPeriod">
        <xsd:enumeration value="ForecastPeriodEndDate">
        <xsd:enumeration value="ForecastPeriodStart">
        <xsd:enumeration value="Formation">
        <xsd:enumeration value="FreightBillDateTime">
        <xsd:enumeration value="FromDateOfAwardToCompletion">
        <xsd:enumeration value="FromDateOfAwardToDelivery">
        <xsd:enumeration value="FromDateOfAwardToEarliestDelivery">
        <xsd:enumeration value="FromDateOfAwardToLatestDelivery">
        <xsd:enumeration value="FromDateOfNoticeToProceedToCommencementOf">
        <xsd:enumeration value="FromDateOfNoticeToProceedToCompletion">
        <xsd:enumeration value="FromDateOfOrderReceiptToDelivery">
        <xsd:enumeration value="FromDateOfOrderReceiptToSampleReady">
        <xsd:enumeration value="FromDateOfOrderReceiptToShipment">
        <xsd:enumeration value="FromDateOfReceiptOfItemToApproval">
        <xsd:enumeration value="FromDateOfReceiptOfToolingAidsToSampleReady">
        <xsd:enumeration value="FromDateOfSampleApprovalToFirstProductShipment">
        <xsd:enumeration value="FromDateOfToolingAuthorizationToSampleReady">
        <xsd:enumeration value="FromLastBookedOrderToDelivery">
        <xsd:enumeration value="FumigationDateAndOrTime">
        <xsd:enumeration value="FunctionalTest">
        <xsd:enumeration value="FundsAppropriation-End">
        <xsd:enumeration value="FundsAppropriation-Start">
        <xsd:enumeration value="FuturePeriod">
        <xsd:enumeration value="GallonsPerMinuteTestPerformed">
        <xsd:enumeration value="GoodsCollectionOrPickUpDateTimePlanned">
        <xsd:enumeration value="GoodsPositioningDateTimeExpected">
        <xsd:enumeration value="GoodsPositioningDateTimePlanned">
        <xsd:enumeration value="GoodsReceiptDateTime">
        <xsd:enumeration value="GraduationDate">
        <xsd:enumeration value="GroupContractEffective">
        <xsd:enumeration value="GroupContractExpiration">
        <xsd:enumeration value="GuaranteeDate">
        <xsd:enumeration value="GuaranteePeriod">
        <xsd:enumeration value="GuarantorReceived">
        <xsd:enumeration value="HandOverDateTimeActual">
        <xsd:enumeration value="HandOverDateTimePlanned">
        <xsd:enumeration value="HighCapitalYear">
        <xsd:enumeration value="HighFabricationReleaseAuthorization">
        <xsd:enumeration value="HighRawMaterialAuthorization">
        <xsd:enumeration value="HiredFromDate">
        <xsd:enumeration value="HiredUntilDate">
        <xsd:enumeration value="HoldAsOf">
        <xsd:enumeration value="HoldAsStockAsOf">
        <xsd:enumeration value="Holiday">
        <xsd:enumeration value="HolidayFinish">
        <xsd:enumeration value="HolidayStart">
        <xsd:enumeration value="Homestead">
        <xsd:enumeration value="HorizonEndDate">
        <xsd:enumeration value="HorizonPeriod">
        <xsd:enumeration value="HorizonStartDate">
        <xsd:enumeration value="HosesConnectedDateTime">
        <xsd:enumeration value="HosesDisconnectedDateTime">
        <xsd:enumeration value="HospitalAdmissionDateAndOrTime">
        <xsd:enumeration value="HospitalDischargeDateAndOrTime">
        <xsd:enumeration value="HydrotestDate">
        <xsd:enumeration value="Illness">
        <xsd:enumeration value="IllnessBegin">
        <xsd:enumeration value="IllnessRecoveryDateExpected">
        <xsd:enumeration value="ImmigrationDate">
        <xsd:enumeration value="Implantation">
        <xsd:enumeration value="ImplementationDateTimePeriod">
        <xsd:enumeration value="Import">
        <xsd:enumeration value="ImportationDate">
        <xsd:enumeration value="ImportLicenceDate">
        <xsd:enumeration value="InactivityEndDate">
        <xsd:enumeration value="Inactivity">
        <xsd:enumeration value="InboundMovementAuthorizationDate">
        <xsd:enumeration value="Incident">
        <xsd:enumeration value="Income">
        <xsd:enumeration value="IncomeDocumentationExpiration">
        <xsd:enumeration value="IncomeIncreasePeriod">
        <xsd:enumeration value="IncomePeriod">
        <xsd:enumeration value="IncorporationDate">
        <xsd:enumeration value="IncorporationDissolution">
        <xsd:enumeration value="IncumbencyPeriod">
        <xsd:enumeration value="IndividualEducationPlanIEP">
        <xsd:enumeration value="In-force">
        <xsd:enumeration value="InformationReleaseAuthorizationDate">
        <xsd:enumeration value="InitialClaim">
        <xsd:enumeration value="InitialCompletion">
        <xsd:enumeration value="InitialContactDate">
        <xsd:enumeration value="InitialDisabilityPeriodEnd">
        <xsd:enumeration value="InitialDisabilityPeriodLastDayWorked">
        <xsd:enumeration value="InitialDisabilityPeriodReturnToWork">
        <xsd:enumeration value="InitialDisabilityPeriodStart">
        <xsd:enumeration value="InitialFeeDue">
        <xsd:enumeration value="InitialFinancialAccountsFiledDate">
        <xsd:enumeration value="PlacementDateInitial">
        <xsd:enumeration value="InitialPremium">
        <xsd:enumeration value="InitialPremiumEffective">
        <xsd:enumeration value="InitialRequestDate">
        <xsd:enumeration value="InitialTreatment">
        <xsd:enumeration value="InjuryBegin">
        <xsd:enumeration value="InjuryEnd">
        <xsd:enumeration value="InjuryOrIllness">
        <xsd:enumeration value="InlandShip">
        <xsd:enumeration value="InquiryDate">
        <xsd:enumeration value="InServiceSurveyDate">
        <xsd:enumeration value="InsolvencyDischargeGrantedDate">
        <xsd:enumeration value="InspectionDate">
        <xsd:enumeration value="InstallationDateTimePeriod">
        <xsd:enumeration value="InstallmentDate">
        <xsd:enumeration value="InstalmentPaymentDueDate">
        <xsd:enumeration value="InstructionsOriginalExecutionDate">
        <xsd:enumeration value="InsufficientAssetsJudgementDate">
        <xsd:enumeration value="InsuranceCard">
        <xsd:enumeration value="InterestCapitalization">
        <xsd:enumeration value="InterestPaidThrough">
        <xsd:enumeration value="InterestPaidTo">
        <xsd:enumeration value="InterestPeriod">
        <xsd:enumeration value="InterestRateValidityPeriod">
        <xsd:enumeration value="InternationalAssessmentApprovalForPublicationDate">
        <xsd:enumeration value="InternationalReviewCycleStartDate">
        <xsd:enumeration value="InterruptionEnd">
        <xsd:enumeration value="InterruptionStart">
        <xsd:enumeration value="InterviewedDate">
        <xsd:enumeration value="InterviewerSigned">
        <xsd:enumeration value="Inventory">
        <xsd:enumeration value="InventoryReportDate">
        <xsd:enumeration value="InvestigationEndDate">
        <xsd:enumeration value="InvestigationStartDate">
        <xsd:enumeration value="InvestmentNumberAllocationDate">
        <xsd:enumeration value="InvitationToTenderDateTime">
        <xsd:enumeration value="InvoiceDateTime">
        <xsd:enumeration value="InvoiceDateRequired">
        <xsd:enumeration value="InvoicePeriodEnd">
        <xsd:enumeration value="InvoicePeriodStart">
        <xsd:enumeration value="InvoicingPeriod">
        <xsd:enumeration value="IrregularInterestPaymentDue">
        <xsd:enumeration value="IssueDate">
        <xsd:enumeration value="ItemContractEffective">
        <xsd:enumeration value="ItemContractExpiration">
        <xsd:enumeration value="JoinedEmployerDate">
        <xsd:enumeration value="JoinedFundDateTime">
        <xsd:enumeration value="JudgementDate">
        <xsd:enumeration value="Judgment">
        <xsd:enumeration value="KeyEventCalendarYear">
        <xsd:enumeration value="KeyEventFiscalYear">
        <xsd:enumeration value="LabourWageDeterminationDate">
        <xsd:enumeration value="LastActivityDate">
        <xsd:enumeration value="LastAnnualReportDate">
        <xsd:enumeration value="LastCapitalChangeDate">
        <xsd:enumeration value="LastCertification">
        <xsd:enumeration value="LastChange">
        <xsd:enumeration value="LastCheckForBalanceSheetUpdateDate">
        <xsd:enumeration value="LastCivilianFlight">
        <xsd:enumeration value="LastDateForAGovernmentAgencyToFileAClaim">
        <xsd:enumeration value="LastDateOfAccountsFiledAtPublicRegister">
        <xsd:enumeration value="LastDateOfOrdering">
        <xsd:enumeration value="LastDateToFileAClaim">
        <xsd:enumeration value="LastDateToObject">
        <xsd:enumeration value="LastEpisode">
        <xsd:enumeration value="LastFlight">
        <xsd:enumeration value="LastFollow-up">
        <xsd:enumeration value="LastInsuranceMedical">
        <xsd:enumeration value="LastInterestBearingDate">
        <xsd:enumeration value="LastItemDelivery">
        <xsd:enumeration value="LastLogged">
        <xsd:enumeration value="LastMarketed">
        <xsd:enumeration value="LastMeal">
        <xsd:enumeration value="LastMenstrualCycleStartDate">
        <xsd:enumeration value="LastMenstrualPeriod">
        <xsd:enumeration value="LastMilitaryFlight">
        <xsd:enumeration value="LastNotification">
        <xsd:enumeration value="LastOffHireDate">
        <xsd:enumeration value="LastOnHireDate">
        <xsd:enumeration value="LastPaidInstallmentDate">
        <xsd:enumeration value="LastPaymentMade">
        <xsd:enumeration value="LastPhysical">
        <xsd:enumeration value="LastPremiumEffective">
        <xsd:enumeration value="LastPremiumPaidDate">
        <xsd:enumeration value="LastProduction">
        <xsd:enumeration value="LastPublication">
        <xsd:enumeration value="LastPublishedDate">
        <xsd:enumeration value="LastSalaryIncrease">
        <xsd:enumeration value="LastSaleDateAndOrTimeAndOrPeriod">
        <xsd:enumeration value="LastScreening">
        <xsd:enumeration value="LastSeenDate">
        <xsd:enumeration value="LastVisitDate">
        <xsd:enumeration value="LastXRayDate">
        <xsd:enumeration value="LateFinish">
        <xsd:enumeration value="LatestAbsence">
        <xsd:enumeration value="LateStart">
        <xsd:enumeration value="LatestBalanceSheet">
        <xsd:enumeration value="LatestCheckInTime">
        <xsd:enumeration value="LatestDeliveryDateatPier">
        <xsd:enumeration value="LatestDeliveryDateAtRailRamp">
        <xsd:enumeration value="LatestFilingPeriod">
        <xsd:enumeration value="LatestMaterialSafetyDataSheetDate">
        <xsd:enumeration value="LatestMeterReadingDate">
        <xsd:enumeration value="LatestOnBoardCarrierDate">
        <xsd:enumeration value="LatestPriceAdjustmentDate">
        <xsd:enumeration value="LatestReceivingDateCutoffDate">
        <xsd:enumeration value="LatestVisitorConsultation">
        <xsd:enumeration value="LayTimeFirstDay">
        <xsd:enumeration value="LayTimeLastDay">
        <xsd:enumeration value="LeadTime">
        <xsd:enumeration value="LeaseCommencement">
        <xsd:enumeration value="LeasePeriod">
        <xsd:enumeration value="LeaseTermEndDate">
        <xsd:enumeration value="LeaseTermStartDate">
        <xsd:enumeration value="LeftEmployerDate">
        <xsd:enumeration value="LegalActionClosedDate">
        <xsd:enumeration value="LegalActionStarted">
        <xsd:enumeration value="LegalSettlementTermsMetDate">
        <xsd:enumeration value="LegalStructureChangeDate">
        <xsd:enumeration value="LenderCreditCheck">
        <xsd:enumeration value="LetterOfAgreementDate">
        <xsd:enumeration value="LetterOfLiabilityDate">
        <xsd:enumeration value="License">
        <xsd:enumeration value="LicenseEffective">
        <xsd:enumeration value="LicenseExpiration">
        <xsd:enumeration value="LicenseRenewal">
        <xsd:enumeration value="LicenseRequested">
        <xsd:enumeration value="Lien">
        <xsd:enumeration value="LiquidationDate">
        <xsd:enumeration value="ListingReceived">
        <xsd:enumeration value="ListPriceChange">
        <xsd:enumeration value="LoadedonVessel">
        <xsd:enumeration value="LoadingDateTimeActual">
        <xsd:enumeration value="Loan">
        <xsd:enumeration value="LoanPurchase">
        <xsd:enumeration value="LoanServicingTransfer">
        <xsd:enumeration value="LocationExceptionOrderNumberAssigned">
        <xsd:enumeration value="Loss">
        <xsd:enumeration value="LotNumberExpiration">
        <xsd:enumeration value="LowestActivityPeriod">
        <xsd:enumeration value="LowPeriod">
        <xsd:enumeration value="MailBy">
        <xsd:enumeration value="MailingDate">
        <xsd:enumeration value="MailReceiptDate">
        <xsd:enumeration value="Maintenance">
        <xsd:enumeration value="MaintenanceComment">
        <xsd:enumeration value="MaintenanceEffective">
        <xsd:enumeration value="MakegoodCommercialDate">
        <xsd:enumeration value="ManagementAvailableDate">
        <xsd:enumeration value="ManagerNotRegisteredAsOfGivenDate">
        <xsd:enumeration value="MandatoryOrTargetFinish">
        <xsd:enumeration value="MandatoryOrTargetStart">
        <xsd:enumeration value="ManifestShipNoticeDate">
        <xsd:enumeration value="Manufacture">
        <xsd:enumeration value="Map">
        <xsd:enumeration value="DateOfMarriage">
        <xsd:enumeration value="MasterLeaseAgreement">
        <xsd:enumeration value="MaterialChangeNotice">
        <xsd:enumeration value="MaterialClassification">
        <xsd:enumeration value="MaterialSpecification">
        <xsd:enumeration value="Maturity">
        <xsd:enumeration value="MaturityDate">
        <xsd:enumeration value="MaximumCreditGrantedDate">
        <xsd:enumeration value="MeatAgeingPeriod">
        <xsd:enumeration value="Medicaid">
        <xsd:enumeration value="MedicaidBegin">
        <xsd:enumeration value="MedicaidEnd">
        <xsd:enumeration value="MedicalCertificate">
        <xsd:enumeration value="MedicalInformationSignature">
        <xsd:enumeration value="MedicalInformationSystem">
        <xsd:enumeration value="Medicare">
        <xsd:enumeration value="MedicareBegin">
        <xsd:enumeration value="MedicareEnd">
        <xsd:enumeration value="MedicarePartACoverageEffectiveDate">
        <xsd:enumeration value="MedicarePartAEligibilityBeginDate">
        <xsd:enumeration value="MedicarePartAEligibilityEndDate">
        <xsd:enumeration value="MedicarePartATerminationDate">
        <xsd:enumeration value="MedicarePartBCoverageEffectiveDate">
        <xsd:enumeration value="MedicarePartBEligibilityBeginDate">
        <xsd:enumeration value="MedicarePartBEligibilityEndDate">
        <xsd:enumeration value="MedicarePartBTerminationDate">
        <xsd:enumeration value="Medication">
        <xsd:enumeration value="MeetingDate">
        <xsd:enumeration value="Merger">
        <xsd:enumeration value="Message">
        <xsd:enumeration value="MeterReading">
        <xsd:enumeration value="MidpointOfPerformance">
        <xsd:enumeration value="MinimumRequiredDistribution">
        <xsd:enumeration value="MinimumShelfLifeRemainingAtTimeOfDespatchPeriod">
        <xsd:enumeration value="MinimumShelfLifeRemainingAtTimeOfReceipt">
        <xsd:enumeration value="MonthEnding">
        <xsd:enumeration value="MonthToDate">
        <xsd:enumeration value="MooringDateAndTime">
        <xsd:enumeration value="MortgageeOfficialSignatureDate">
        <xsd:enumeration value="MortgageeReportedCurtailmentDate">
        <xsd:enumeration value="MortgageNoteDate">
        <xsd:enumeration value="MostLikelyEarlyFinish">
        <xsd:enumeration value="MostLikelyEarlyStart">
        <xsd:enumeration value="MostLikelyLateFinish">
        <xsd:enumeration value="MostLikelyLateStart">
        <xsd:enumeration value="MostRecentHemoglobinOrHematocritOrBoth">
        <xsd:enumeration value="MostRecentRenewal">
        <xsd:enumeration value="MostRecentRevisionorInitialVersion">
        <xsd:enumeration value="MostRecentSerumCreatine">
        <xsd:enumeration value="MovedFromLocationDate">
        <xsd:enumeration value="NegotiatedExtensionDate">
        <xsd:enumeration value="NegotiatedFinish">
        <xsd:enumeration value="NegotiatedStart">
        <xsd:enumeration value="NegotiationsStartDate">
        <xsd:enumeration value="NetCreditServiceDate">
        <xsd:enumeration value="NetWorthDate">
        <xsd:enumeration value="NextActivity">
        <xsd:enumeration value="NextAnniversary">
        <xsd:enumeration value="NextAnnualMeeting">
        <xsd:enumeration value="NextInstallmentDueDate">
        <xsd:enumeration value="NextInterestChangeDate">
        <xsd:enumeration value="NextPayIncrease">
        <xsd:enumeration value="NextPaymentDue">
        <xsd:enumeration value="NextReviewDate">
        <xsd:enumeration value="NonWorking">
        <xsd:enumeration value="NoProductionScheduleEstablishedAsOf">
        <xsd:enumeration value="NoPromiseAsOf">
        <xsd:enumeration value="NoShippingScheduleEstablishedAsOf">
        <xsd:enumeration value="NotAfter">
        <xsd:enumeration value="NotBefore">
        <xsd:enumeration value="Note">
        <xsd:enumeration value="Notice">
        <xsd:enumeration value="NotificationDateTime">
        <xsd:enumeration value="NotificationOfDeath">
        <xsd:enumeration value="NotificationTimeLimit">
        <xsd:enumeration value="Notified">
        <xsd:enumeration value="NotRegistered">
        <xsd:enumeration value="NotRegisteredAsOfGivenDate">
        <xsd:enumeration value="NursingHome">
        <xsd:enumeration value="NursingHomeFrom">
        <xsd:enumeration value="NursingHomeTo">
        <xsd:enumeration value="Occupancy">
        <xsd:enumeration value="Occurrence">
        <xsd:enumeration value="OccurrenceSpan">
        <xsd:enumeration value="OccurrenceSpanFrom">
        <xsd:enumeration value="OccurrenceSpanTo">
        <xsd:enumeration value="OfferExpiration">
        <xsd:enumeration value="OffHireSurveyDate">
        <xsd:enumeration value="OffHold">
        <xsd:enumeration value="OfficialRailCarInterchangeEitherActualorAgreedUpon">
        <xsd:enumeration value="Off-Market">
        <xsd:enumeration value="Offset">
        <xsd:enumeration value="OffsetBegin">
        <xsd:enumeration value="OffsetEnd">
        <xsd:enumeration value="OffsetFromCoordinatedUniversalTimeUtc">
        <xsd:enumeration value="OldestUnpaidInstallment">
        <xsd:enumeration value="On">
        <xsd:enumeration value="OnBoardDate">
        <xsd:enumeration value="OnHireSurveyDate">
        <xsd:enumeration value="OnHold">
        <xsd:enumeration value="OnsetOfCurrentSymptomsOrIllness">
        <xsd:enumeration value="OnsetOfSimilarSymptomsOrIllness">
        <xsd:enumeration value="OpenHouse">
        <xsd:enumeration value="OpeningDate">
        <xsd:enumeration value="OperationsCeasedDate">
        <xsd:enumeration value="Opinion">
        <xsd:enumeration value="OptimisticEarlyFinish">
        <xsd:enumeration value="OptimisticEarlyStart">
        <xsd:enumeration value="OptimisticLateFinish">
        <xsd:enumeration value="OptimisticLateStart">
        <xsd:enumeration value="Option">
        <xsd:enumeration value="Order">
        <xsd:enumeration value="OrderAmendmentBindingDate">
        <xsd:enumeration value="OrderCompletionDateTimeUltimate">
        <xsd:enumeration value="OrderDateTime">
        <xsd:enumeration value="OrderEnd">
        <xsd:enumeration value="OrderReceivedDateTime">
        <xsd:enumeration value="OrderStart">
        <xsd:enumeration value="OrderToProceedDate">
        <xsd:enumeration value="Original">
        <xsd:enumeration value="OriginalDueDate">
        <xsd:enumeration value="OriginalDuration">
        <xsd:enumeration value="OriginalEarlyFinish">
        <xsd:enumeration value="OriginalEarlyStart">
        <xsd:enumeration value="OriginalEstimateDate">
        <xsd:enumeration value="OriginalIssueAge">
        <xsd:enumeration value="OriginalList">
        <xsd:enumeration value="OriginallyScheduledShip">
        <xsd:enumeration value="OriginalMaturityDate">
        <xsd:enumeration value="OriginalNameChangeDate">
        <xsd:enumeration value="OriginalPostingDate">
        <xsd:enumeration value="OriginalReceipt">
        <xsd:enumeration value="OrthodonticTreatmentPeriodRemaining">
        <xsd:enumeration value="OrthodonticTreatmentPeriodTotal">
        <xsd:enumeration value="Out-Of-Pocket">
        <xsd:enumeration value="OutsideAuditorsReport">
        <xsd:enumeration value="Overhauled">
        <xsd:enumeration value="OverrideDateForSettlement">
        <xsd:enumeration value="OverTargetBaselineMonth">
        <xsd:enumeration value="OvertimeEndDate">
        <xsd:enumeration value="OvertimeStartDate">
        <xsd:enumeration value="OwnershipChangeDate">
        <xsd:enumeration value="OwnershipPeriod">
        <xsd:enumeration value="OxygenSaturationTest">
        <xsd:enumeration value="OxygenTherapy">
        <xsd:enumeration value="OxygenTherapyEvaluation">
        <xsd:enumeration value="OxygenTherapyFrom">
        <xsd:enumeration value="OxygenTherapyTo">
        <xsd:enumeration value="PackingEndDate">
        <xsd:enumeration value="PackingStartDate">
        <xsd:enumeration value="PaidInFull">
        <xsd:enumeration value="PaidThroughDate">
        <xsd:enumeration value="Paid-ThroughDateForAccruedSickPay">
        <xsd:enumeration value="PaidThroughDateForMinimumPayment">
        <xsd:enumeration value="Paid-ThroughDateForSalaryContinuation">
        <xsd:enumeration value="PaidThroughDateForTotalPayment">
        <xsd:enumeration value="Paid-ThroughDateForVacationPay">
        <xsd:enumeration value="PaidToDate">
        <xsd:enumeration value="Paid-up">
        <xsd:enumeration value="PaperworkMailed">
        <xsd:enumeration value="PartialAnnuitization">
        <xsd:enumeration value="ParticipationDate">
        <xsd:enumeration value="PartTimeWorkingChangeDateTime">
        <xsd:enumeration value="PastDue">
        <xsd:enumeration value="PatientFirstVisitForCondition">
        <xsd:enumeration value="PaymentCommencement">
        <xsd:enumeration value="PaymentDate">
        <xsd:enumeration value="PaymentDateTimeDeferred">
        <xsd:enumeration value="PaymentDueDate">
        <xsd:enumeration value="PaymentEffective">
        <xsd:enumeration value="PaymentInitiated">
        <xsd:enumeration value="PaymentInstructionDateTime">
        <xsd:enumeration value="PaymentIssue">
        <xsd:enumeration value="PaymentPeriod">
        <xsd:enumeration value="PaymentPeriodEnd">
        <xsd:enumeration value="PaymentPeriodStart">
        <xsd:enumeration value="PaymentValuationPresentationDateTime">
        <xsd:enumeration value="PayrollDeductionDateTime">
        <xsd:enumeration value="PayrollPeriod">
        <xsd:enumeration value="PayrollPeriodBegin">
        <xsd:enumeration value="PayrollPeriodEnd">
        <xsd:enumeration value="PeakActivityPeriod">
        <xsd:enumeration value="PeerReviewOrganizationPROApprovedStay">
        <xsd:enumeration value="PeerReviewOrganizationPROApprovedStayFrom">
        <xsd:enumeration value="PeerReviewOrganizationPROApprovedStayTo">
        <xsd:enumeration value="Penalty">
        <xsd:enumeration value="PenaltyBegin">
        <xsd:enumeration value="PenaltyEnd">
        <xsd:enumeration value="PendingArchive">
        <xsd:enumeration value="PercolationTest">
        <xsd:enumeration value="PeriodAnEventIsLateDueToCustomer">
        <xsd:enumeration value="PeriodAssigned">
        <xsd:enumeration value="PeriodBetweenChanges">
        <xsd:enumeration value="PeriodCoveredBySourceDocuments">
        <xsd:enumeration value="PeriodEnd">
        <xsd:enumeration value="PeriodExtended">
        <xsd:enumeration value="PeriodicInspectionDate">
        <xsd:enumeration value="PeriodOfCareEndDateAndOrTime">
        <xsd:enumeration value="PeriodOfCareStartDateAndOrTime">
        <xsd:enumeration value="PeriodOfIllnessEndDate">
        <xsd:enumeration value="PeriodOfIllnessStartDate">
        <xsd:enumeration value="PeriodOverdue">
        <xsd:enumeration value="PeriodStart">
        <xsd:enumeration value="PeriodWorkedForTheCompany">
        <xsd:enumeration value="PermitToAdmitDate">
        <xsd:enumeration value="PermitYear">
        <xsd:enumeration value="PessimisticEarlyFinish">
        <xsd:enumeration value="PessimisticEarlyStart">
        <xsd:enumeration value="PessimisticLateFinish">
        <xsd:enumeration value="PessimisticLateStart">
        <xsd:enumeration value="PickUpCollectionDateTimeOfCargo">
        <xsd:enumeration value="PickUpDateTimeOfEquipment">
        <xsd:enumeration value="Placement">
        <xsd:enumeration value="PlacementDate">
        <xsd:enumeration value="PlacementDatePrevious">
        <xsd:enumeration value="PlacementPeriodExpiration">
        <xsd:enumeration value="Plan">
        <xsd:enumeration value="PlanAnniversary">
        <xsd:enumeration value="PlanBegin">
        <xsd:enumeration value="PlanEnd">
        <xsd:enumeration value="PlanEntry">
        <xsd:enumeration value="PlannedDurationOfWorks">
        <xsd:enumeration value="PlannedRelease">
        <xsd:enumeration value="PlanOfTreatmentPeriod">
        <xsd:enumeration value="PlanParticipationSuspension">
        <xsd:enumeration value="PlanPeriodElection">
        <xsd:enumeration value="PlanPeriodElectionBegin">
        <xsd:enumeration value="PlanPeriodElectionEnd">
        <xsd:enumeration value="PlanTermination">
        <xsd:enumeration value="PluggedAndAbandoned">
        <xsd:enumeration value="PolicyEffective">
        <xsd:enumeration value="PolicyEffectiveOnOrAfter">
        <xsd:enumeration value="PolicyEffectiveOnOrBefore">
        <xsd:enumeration value="PolicyExpiration">
        <xsd:enumeration value="PolicySurrender">
        <xsd:enumeration value="PoolSettlement">
        <xsd:enumeration value="PositioningDateTimeOfEquipment">
        <xsd:enumeration value="PositioningDateTimeOfGoods">
        <xsd:enumeration value="PostingDate">
        <xsd:enumeration value="PostmarkDateTime">
        <xsd:enumeration value="Post-Reclassification">
        <xsd:enumeration value="Post-ReclassificationEndOfSecondYear">
        <xsd:enumeration value="Post-ReclassificationFirstReportCard">
        <xsd:enumeration value="Post-ReclassificationFirstSemi-annual">
        <xsd:enumeration value="Post-ReclassificationSecondSemi-annual">
        <xsd:enumeration value="PrearrangedDealMatch">
        <xsd:enumeration value="Pre-AwardSurvey">
        <xsd:enumeration value="PrecedingPeriod">
        <xsd:enumeration value="Pre-certificationDate">
        <xsd:enumeration value="PreforeclosureAcceptanceDate">
        <xsd:enumeration value="PreforeclosureSaleClosingDate">
        <xsd:enumeration value="PregnancyBegin">
        <xsd:enumeration value="PregnancyDurationActual">
        <xsd:enumeration value="PregnancyEnd">
        <xsd:enumeration value="PremiumChangePeriod">
        <xsd:enumeration value="PremiumPaidToDate">
        <xsd:enumeration value="PremiumPaidToDateBegin">
        <xsd:enumeration value="PremiumPaidToDateEnd">
        <xsd:enumeration value="PreparationDateTimeOfDocument">
        <xsd:enumeration value="Prescription">
        <xsd:enumeration value="PrescriptionDispensingDateAndOrTime">
        <xsd:enumeration value="PrescriptionFill">
        <xsd:enumeration value="PrescriptionFrom">
        <xsd:enumeration value="PrescriptionIssueDateAndOrTime">
        <xsd:enumeration value="PrescriptionTo">
        <xsd:enumeration value="PresentationDateLatest">
        <xsd:enumeration value="PresentationDateOfGoodsDeclarationCustoms">
        <xsd:enumeration value="PresentationToBankruptcyReceiversDate">
        <xsd:enumeration value="PresentControl">
        <xsd:enumeration value="PresentedToReceivers">
        <xsd:enumeration value="PresentLegalStructure">
        <xsd:enumeration value="PresentlyResiding">
        <xsd:enumeration value="PresentmentDate">
        <xsd:enumeration value="PresentName">
        <xsd:enumeration value="PresentResidenceStartDate">
        <xsd:enumeration value="PreviousBookingDateTime">
        <xsd:enumeration value="PreviousCourtEvent">
        <xsd:enumeration value="PreviousCurrentAccountDate">
        <xsd:enumeration value="PreviousEmployment">
        <xsd:enumeration value="PreviousEmploymentEnd">
        <xsd:enumeration value="PreviousEmploymentStart">
        <xsd:enumeration value="PreviousInvoiceDate">
        <xsd:enumeration value="PreviouslyReportedDateOfBirth">
        <xsd:enumeration value="PreviouslyResided">
        <xsd:enumeration value="PreviousMeterReadingDate">
        <xsd:enumeration value="PreviousMonthEnding">
        <xsd:enumeration value="PreviousPeriod">
        <xsd:enumeration value="PreviousReportDate">
        <xsd:enumeration value="PreviousResidence">
        <xsd:enumeration value="PreviousResidenceEnd">
        <xsd:enumeration value="PreviousResidenceStart">
        <xsd:enumeration value="PreviousTerminationDate">
        <xsd:enumeration value="PriceAdjustmentDate">
        <xsd:enumeration value="PriceAdjustmentLimitDate">
        <xsd:enumeration value="PriceAdjustmentStartDate">
        <xsd:enumeration value="PriceBaseDateTime">
        <xsd:enumeration value="PriceProtection">
        <xsd:enumeration value="PrimaryCareProvider">
        <xsd:enumeration value="PrimaryCareProviderBegin">
        <xsd:enumeration value="PrimaryCareProviderEnd">
        <xsd:enumeration value="Printed">
        <xsd:enumeration value="PriorContractAnniversary">
        <xsd:enumeration value="PriorContractIssue">
        <xsd:enumeration value="PriorHospitalizationDatesRelatedToCurrentServices">
        <xsd:enumeration value="PriorIncorrectDateOfBirth">
        <xsd:enumeration value="PriorNotice">
        <xsd:enumeration value="PriorPlacement">
        <xsd:enumeration value="PrivilegeDetailsVerificationDate">
        <xsd:enumeration value="ProcessingDateTime">
        <xsd:enumeration value="ProcessingDatePeriod">
        <xsd:enumeration value="ProcessingEndDateTime">
        <xsd:enumeration value="ProcessingStartDateTime">
        <xsd:enumeration value="ProductAvailabilityDate">
        <xsd:enumeration value="ProductHeldUntil">
        <xsd:enumeration value="Production">
        <xsd:enumeration value="ProductionDateNoScheduleEstablishedAsOf">
        <xsd:enumeration value="ProductionInspectionDate">
        <xsd:enumeration value="ProductionManufactureDate">
        <xsd:enumeration value="ProductLifespanAtTimeOfProduction">
        <xsd:enumeration value="ProfitPeriod">
        <xsd:enumeration value="ProgrammedCalendarYear">
        <xsd:enumeration value="ProgrammedFiscalYear">
        <xsd:enumeration value="ProgressPayment">
        <xsd:enumeration value="ProjectedActionEndDate">
        <xsd:enumeration value="ProjectedForeclosureSaleDate">
        <xsd:enumeration value="ProjectOverTargetBaselineDate">
        <xsd:enumeration value="PromisedForDelivery">
        <xsd:enumeration value="PromisedForDeliveryAfterAndIncluding">
        <xsd:enumeration value="PromisedForDeliveryPriorToAndIncluding">
        <xsd:enumeration value="PromisedForDeliveryWeekOf">
        <xsd:enumeration value="PromisedForShipment">
        <xsd:enumeration value="PromisedForShipmentAfterAndIncluding">
        <xsd:enumeration value="PromisedForShipmentPriortoAndIncluding">
        <xsd:enumeration value="PromisedForShipmentWeekOf">
        <xsd:enumeration value="PromotionDatePeriod">
        <xsd:enumeration value="PromotionEndDateTime">
        <xsd:enumeration value="PromotionFloorStockProtect-End">
        <xsd:enumeration value="PromotionFloorStockProtect-Start">
        <xsd:enumeration value="PromotionInvoicePerformance-End">
        <xsd:enumeration value="PromotionInvoicePerformance-Start">
        <xsd:enumeration value="PromotionOrder-End">
        <xsd:enumeration value="PromotionOrder-Start">
        <xsd:enumeration value="PromotionPerformance-End">
        <xsd:enumeration value="PromotionPerformance-Start">
        <xsd:enumeration value="PromotionRequestedDelivery-End">
        <xsd:enumeration value="PromotionRequestedDelivery-Start">
        <xsd:enumeration value="PromotionShip-End">
        <xsd:enumeration value="PromotionShip-Start">
        <xsd:enumeration value="PromotionStartDateTime">
        <xsd:enumeration value="Property">
        <xsd:enumeration value="PropertyAcquired">
        <xsd:enumeration value="PropertyBuilt">
        <xsd:enumeration value="PrototypeTest">
        <xsd:enumeration value="ProviderSignatureDate">
        <xsd:enumeration value="PublicationDate">
        <xsd:enumeration value="PurchasedDate">
        <xsd:enumeration value="PurchaseOrder">
        <xsd:enumeration value="PurchaseOrderLatestPossibleChangeDate">
        <xsd:enumeration value="PurchaseOrderReceived">
        <xsd:enumeration value="PutIntoService">
        <xsd:enumeration value="QualityRating">
        <xsd:enumeration value="QuarterEnding">
        <xsd:enumeration value="QuotaDate">
        <xsd:enumeration value="Quote">
        <xsd:enumeration value="QuoteToBeReceivedBy">
        <xsd:enumeration value="RateAdjustment">
        <xsd:enumeration value="RateDate">
        <xsd:enumeration value="RateOfExchangeDateTime">
        <xsd:enumeration value="RatePriceDateTime">
        <xsd:enumeration value="ReachedTotalDepth">
        <xsd:enumeration value="ReadyForInspection">
        <xsd:enumeration value="RealEstateProperty">
        <xsd:enumeration value="RealEstateTaxYear">
        <xsd:enumeration value="Rebuilt">
        <xsd:enumeration value="Recapture">
        <xsd:enumeration value="ReceivablesCollectionPeriod">
        <xsd:enumeration value="Received">
        <xsd:enumeration value="ReceiveAtLockboxDate">
        <xsd:enumeration value="ReceivedDateTime">
        <xsd:enumeration value="ReceivedInTheMail">
        <xsd:enumeration value="ReceiverAppointed">
        <xsd:enumeration value="ReceivershipPeriod">
        <xsd:enumeration value="ReceivershipResultDate">
        <xsd:enumeration value="Reclassification">
        <xsd:enumeration value="ReclassificationExitDate">
        <xsd:enumeration value="Recompletion">
        <xsd:enumeration value="RecordedDate">
        <xsd:enumeration value="Recovery">
        <xsd:enumeration value="RecoveryFinish">
        <xsd:enumeration value="RecoveryStart">
        <xsd:enumeration value="Re-entry">
        <xsd:enumeration value="Re-evaluationDate">
        <xsd:enumeration value="ReExportationDate">
        <xsd:enumeration value="ReferenceDateTime">
        <xsd:enumeration value="ReferencedItemCreationDate">
        <xsd:enumeration value="ReferralDate">
        <xsd:enumeration value="ReferredFrom">
        <xsd:enumeration value="ReferredTo">
        <xsd:enumeration value="Refinance">
        <xsd:enumeration value="RefusalPeriod">
        <xsd:enumeration value="Registered">
        <xsd:enumeration value="RegisteredContractorNumberAssignmentDateOriginal">
        <xsd:enumeration value="RegistrationDate">
        <xsd:enumeration value="RegistrationDateOfPreviousCustomsDeclaration">
        <xsd:enumeration value="RegistrationOfBoardOfDirectors">
        <xsd:enumeration value="Rehire">
        <xsd:enumeration value="ReimbursementClaimIssueDateAndOrTime">
        <xsd:enumeration value="ReImportationDate">
        <xsd:enumeration value="ReinstatementDate">
        <xsd:enumeration value="ReinsuranceAccountingPeriod">
        <xsd:enumeration value="ReinsuranceCoverageDuration">
        <xsd:enumeration value="ReinsuranceCurrentAccountPeriod">
        <xsd:enumeration value="ReinsuranceEffective">
        <xsd:enumeration value="ReinsuranceIssueAge">
        <xsd:enumeration value="ReinsurancePaidUpDate">
        <xsd:enumeration value="ReinsurancePaymentFrequency">
        <xsd:enumeration value="Reissue">
        <xsd:enumeration value="Rejected">
        <xsd:enumeration value="ReleaseDateTime">
        <xsd:enumeration value="ReleaseDateCustoms">
        <xsd:enumeration value="ReleaseDateOfCustomer">
        <xsd:enumeration value="ReleaseDateOfSupplier">
        <xsd:enumeration value="ReleasedReturnToWork">
        <xsd:enumeration value="ReleasedToVessel">
        <xsd:enumeration value="ReleaseFrequency">
        <xsd:enumeration value="ReleaseOfInformation">
        <xsd:enumeration value="Remittance">
        <xsd:enumeration value="RemodelingCompleted">
        <xsd:enumeration value="Removed">
        <xsd:enumeration value="RenewalDate">
        <xsd:enumeration value="RentalPeriod">
        <xsd:enumeration value="RentStart">
        <xsd:enumeration value="RentSurvey">
        <xsd:enumeration value="RepairTurnaroundTime">
        <xsd:enumeration value="RepaymentBegin">
        <xsd:enumeration value="RepaymentScheduleSent">
        <xsd:enumeration value="Replaced">
        <xsd:enumeration value="Replacement">
        <xsd:enumeration value="ReplacementEffective">
        <xsd:enumeration value="ReplyDate">
        <xsd:enumeration value="Report">
        <xsd:enumeration value="ReportedDate">
        <xsd:enumeration value="ReportEndDate">
        <xsd:enumeration value="ReportingCycleDate">
        <xsd:enumeration value="ReportPeriod">
        <xsd:enumeration value="ReportStartDate">
        <xsd:enumeration value="Requalification">
        <xsd:enumeration value="Request">
        <xsd:enumeration value="RequestedContract">
        <xsd:enumeration value="RequestedDepartureDate">
        <xsd:enumeration value="RequestedFinish">
        <xsd:enumeration value="DeliveryDateTimeRequestedForAfterAndIncluding">
        <xsd:enumeration value="DeliveryDateTimeRequestedForPriorToAndIncluding">
        <xsd:enumeration value="RequestedForDeliveryWeekOf">
        <xsd:enumeration value="ShipmentDateTimeRequestedForAfterAndIncluding">
        <xsd:enumeration value="ShipmentDateTimeRequestedForPriorToAndIncluding">
        <xsd:enumeration value="RequestedForShipmentWeekOf">
        <xsd:enumeration value="RequestedOffer">
        <xsd:enumeration value="RequestedPick-up">
        <xsd:enumeration value="RequestedSettlement">
        <xsd:enumeration value="RequestedShip">
        <xsd:enumeration value="RequestedStart">
        <xsd:enumeration value="RequestForQuotation">
        <xsd:enumeration value="RequiredBy">
        <xsd:enumeration value="RequiredDelivery">
        <xsd:enumeration value="ReservationOfFacility">
        <xsd:enumeration value="ResidentLicenseEffective">
        <xsd:enumeration value="ResidentLicenseExpiration">
        <xsd:enumeration value="ResignationDate">
        <xsd:enumeration value="Resigned">
        <xsd:enumeration value="ResolvedDate">
        <xsd:enumeration value="RestDay">
        <xsd:enumeration value="RestFinish">
        <xsd:enumeration value="RestStart">
        <xsd:enumeration value="Resubmission">
        <xsd:enumeration value="RetentionReleaseDateTime">
        <xsd:enumeration value="RetentionReleaseDateTimePartial">
        <xsd:enumeration value="Retermination">
        <xsd:enumeration value="Retirement">
        <xsd:enumeration value="RetransmissionTimeStamp">
        <xsd:enumeration value="ReturnedDate">
        <xsd:enumeration value="ReturnedToCustomer">
        <xsd:enumeration value="ReturnToWorkDate">
        <xsd:enumeration value="ReturnToWorkPartTime">
        <xsd:enumeration value="ReviewDate">
        <xsd:enumeration value="ReviewPeriodEnd">
        <xsd:enumeration value="RevisedAdjustedEnd">
        <xsd:enumeration value="RevisedAdjustedStart">
        <xsd:enumeration value="RevisedEstimateDate">
        <xsd:enumeration value="Revision">
        <xsd:enumeration value="Revocation">
        <xsd:enumeration value="Revoked">
        <xsd:enumeration value="RigArrival">
        <xsd:enumeration value="RoadFundTaxExpiryDate">
        <xsd:enumeration value="Sailing">
        <xsd:enumeration value="SalaryChangeEffectiveDate">
        <xsd:enumeration value="SalaryDeferral">
        <xsd:enumeration value="SaleableStockDemandCoverPeriodExpected">
        <xsd:enumeration value="SalesDateAndOrTimeAndOrPeriod">
        <xsd:enumeration value="SalesPeriod">
        <xsd:enumeration value="SampleAvailableDate">
        <xsd:enumeration value="SampleCollected">
        <xsd:enumeration value="SampleRequiredDate">
        <xsd:enumeration value="SamplesToBeReturnedBy">
        <xsd:enumeration value="Sanction">
        <xsd:enumeration value="SatisfactionDate">
        <xsd:enumeration value="Satisfied">
        <xsd:enumeration value="Schedule">
        <xsd:enumeration value="ScheduledFinish">
        <xsd:enumeration value="ScheduledForDeliveryOnOrAfter">
        <xsd:enumeration value="ScheduledForDeliveryOnOrBefore">
        <xsd:enumeration value="ScheduledForDeliveryWeekOf">
        <xsd:enumeration value="ScheduledForShipmentAfterAndIncluding">
        <xsd:enumeration value="ScheduledForShipmentPriorToAndIncluding">
        <xsd:enumeration value="ScheduledForShipmentWeekOf">
        <xsd:enumeration value="ScheduledInterchangeDelivery">
        <xsd:enumeration value="ScheduledStart">
        <xsd:enumeration value="ScheduleRelease">
        <xsd:enumeration value="SchoolRefund">
        <xsd:enumeration value="Seal">
        <xsd:enumeration value="SecondAdmissionDate">
        <xsd:enumeration value="SecondDischargeDate">
        <xsd:enumeration value="SecurityRateAdjustment">
        <xsd:enumeration value="SecuritySharePriceAsOfGivenDate">
        <xsd:enumeration value="Selected">
        <xsd:enumeration value="SelectionPeriodEndDate">
        <xsd:enumeration value="SelectionPeriodStartDate">
        <xsd:enumeration value="SellByDate">
        <xsd:enumeration value="SellersLocalTime">
        <xsd:enumeration value="SemiannualEnding">
        <xsd:enumeration value="SendingRoadTimeStamp">
        <xsd:enumeration value="SepticApproval">
        <xsd:enumeration value="Service">
        <xsd:enumeration value="ServiceCompletionDateTimeActual">
        <xsd:enumeration value="ServiceInterruption">
        <xsd:enumeration value="ServicePeriodEnd">
        <xsd:enumeration value="ServicePeriodStart">
        <xsd:enumeration value="ServiceRequested">
        <xsd:enumeration value="ServicerSignatureDate">
        <xsd:enumeration value="Setoff">
        <xsd:enumeration value="Settled">
        <xsd:enumeration value="SettlementDate">
        <xsd:enumeration value="SettlementDateAsSpecifiedByTheOriginator">
        <xsd:enumeration value="SettlementDateFromInterlineSettlementSystemOnly">
        <xsd:enumeration value="SettlementDatePlanned">
        <xsd:enumeration value="SettlementDueDate">
        <xsd:enumeration value="SettlementStatus">
        <xsd:enumeration value="SharePrice">
        <xsd:enumeration value="ShelfLifeExpiration">
        <xsd:enumeration value="ShipDateOriginallyScheduled">
        <xsd:enumeration value="ShipDuringDate">
        <xsd:enumeration value="ShipmentDateTimePromisedFor">
        <xsd:enumeration value="ShipmentDateTimePromisedForPriorToAndIncluding">
        <xsd:enumeration value="ShipmentDateTimeRequested">
        <xsd:enumeration value="ShipNotLaterThanDateTime">
        <xsd:enumeration value="ShipNotBeforeDateTime">
        <xsd:enumeration value="ShipNotBeforeAndNotAfterDateTime">
        <xsd:enumeration value="ShipOnOrAboutDate">
        <xsd:enumeration value="Shipped">
        <xsd:enumeration value="ShippingDateAndOrTimeCurrentSchedule">
        <xsd:enumeration value="ShippingDateNoScheduleEstablishedAsOf">
        <xsd:enumeration value="ShipWeekOfDate">
        <xsd:enumeration value="ShutIn">
        <xsd:enumeration value="SicknessBenefitAgeLimit">
        <xsd:enumeration value="SicknessBenefitPeriod">
        <xsd:enumeration value="SicknessInsuranceEliminationPeriod">
        <xsd:enumeration value="SicknessLifetimeBenefitQualificationAge">
        <xsd:enumeration value="SidetrackedWellbore">
        <xsd:enumeration value="SignatureDate">
        <xsd:enumeration value="SignatureReceived">
        <xsd:enumeration value="SimilarIllnessOnsetDate">
        <xsd:enumeration value="SimpleInterestDue">
        <xsd:enumeration value="SlaughteringEndDate">
        <xsd:enumeration value="SlaughteringStartDate">
        <xsd:enumeration value="SocialSecurityClaimsVerificationDate">
        <xsd:enumeration value="Sold">
        <xsd:enumeration value="SoldBookPublication">
        <xsd:enumeration value="SoleDirectorshipRegistrationDate">
        <xsd:enumeration value="Solicitation">
        <xsd:enumeration value="SourceDocumentCaptureDate">
        <xsd:enumeration value="SpacingOrderUnitAssigned">
        <xsd:enumeration value="SponsoredDependent">
        <xsd:enumeration value="SponsoredDependentBegin">
        <xsd:enumeration value="SponsoredDependentEnd">
        <xsd:enumeration value="SpouseRetirement">
        <xsd:enumeration value="Spud">
        <xsd:enumeration value="StartDateTime">
        <xsd:enumeration value="StartDateOrTimeActual">
        <xsd:enumeration value="StartDateOrTimeEarliest">
        <xsd:enumeration value="StartDateOrTimeEstimated">
        <xsd:enumeration value="StartDateOrTimeLatest">
        <xsd:enumeration value="StartDateOrTimeMandatory">
        <xsd:enumeration value="StartDateOrTimeNotAfter">
        <xsd:enumeration value="StartDateOrTimeNotBefore">
        <xsd:enumeration value="StartDateOrTimeScheduled">
        <xsd:enumeration value="StartDateTimePlanned">
        <xsd:enumeration value="StartedDoingBusiness">
        <xsd:enumeration value="StartNoEarlierThan">
        <xsd:enumeration value="StartNoLaterThan">
        <xsd:enumeration value="Statement">
        <xsd:enumeration value="StateResidencyDate">
        <xsd:enumeration value="StateTermination">
        <xsd:enumeration value="StatisticalTimeSeriesDate">
        <xsd:enumeration value="Status">
        <xsd:enumeration value="StatusAfterAndIncluding">
        <xsd:enumeration value="StatusAssignmentDate">
        <xsd:enumeration value="StatusChangeDateTime">
        <xsd:enumeration value="StatusCommercial">
        <xsd:enumeration value="StatusOutsideProcessor">
        <xsd:enumeration value="StatusPriorAndIncluding">
        <xsd:enumeration value="StopDistributionDate">
        <xsd:enumeration value="StopWorkAsOfGivenDate">
        <xsd:enumeration value="Stored">
        <xsd:enumeration value="StudentSigned">
        <xsd:enumeration value="SubcontractorPeriodOfHire">
        <xsd:enumeration value="SubmissionDate">
        <xsd:enumeration value="Submittal">
        <xsd:enumeration value="SubsequentInterestPaymentDue">
        <xsd:enumeration value="SubsequentSubmission">
        <xsd:enumeration value="SupersededDateTime">
        <xsd:enumeration value="SupplementalIssue">
        <xsd:enumeration value="SuppliersAverageCreditPeriod">
        <xsd:enumeration value="SurfaceCasingAuthorityApproval">
        <xsd:enumeration value="Surgery">
        <xsd:enumeration value="Surrender">
        <xsd:enumeration value="SurveyYear">
        <xsd:enumeration value="SuspendedDate">
        <xsd:enumeration value="SuspensionEffective">
        <xsd:enumeration value="SuspensionPeriod">
        <xsd:enumeration value="SwornAndSubscribed">
        <xsd:enumeration value="SymptomsOnsetPatientAlleged">
        <xsd:enumeration value="SystemSurvey">
        <xsd:enumeration value="SystemTest">
        <xsd:enumeration value="TableRatingEnd">
        <xsd:enumeration value="TailCoverageBegin">
        <xsd:enumeration value="TailCoverageEnd">
        <xsd:enumeration value="TanksAcceptedDateTime">
        <xsd:enumeration value="TanksInspectedDateTime">
        <xsd:enumeration value="Tax">
        <xsd:enumeration value="TaxPeriod">
        <xsd:enumeration value="TaxPeriodEndDate">
        <xsd:enumeration value="TaxPeriodStartDate">
        <xsd:enumeration value="TaxPointDate">
        <xsd:enumeration value="TaxYear">
        <xsd:enumeration value="TechnicalRating">
        <xsd:enumeration value="TelexDate">
        <xsd:enumeration value="TemporaryProsthesisDate">
        <xsd:enumeration value="TenderSubmissionDateTime">
        <xsd:enumeration value="TerminatedDate">
        <xsd:enumeration value="Termination">
        <xsd:enumeration value="TerminationOfFacility">
        <xsd:enumeration value="TermsDiscountDueDateTime">
        <xsd:enumeration value="TermsMet">
        <xsd:enumeration value="TermsNetDueDate">
        <xsd:enumeration value="TestCompletionDate">
        <xsd:enumeration value="TestPerformed">
        <xsd:enumeration value="TestPeriodEnding">
        <xsd:enumeration value="TestStartDate">
        <xsd:enumeration value="TexasLineTermination">
        <xsd:enumeration value="Therapy">
        <xsd:enumeration value="TimeEmployeeBeganWork">
        <xsd:enumeration value="TimeInUS">
        <xsd:enumeration value="TimeLimit">
        <xsd:enumeration value="TimeNowDate">
        <xsd:enumeration value="TimePeriod">
        <xsd:enumeration value="TitleTransfer">
        <xsd:enumeration value="ToolingRequiredDate">
        <xsd:enumeration value="TotalShelfLifePeriod">
        <xsd:enumeration value="Tour">
        <xsd:enumeration value="TradeDate">
        <xsd:enumeration value="TradeStyleRegistrationDate">
        <xsd:enumeration value="TrainingBegin">
        <xsd:enumeration value="TrainingEnd">
        <xsd:enumeration value="TransactionCreationDate">
        <xsd:enumeration value="TransferNoteAcceptanceDateAndTime">
        <xsd:enumeration value="Transferred">
        <xsd:enumeration value="TranshipmentDateTime">
        <xsd:enumeration value="Transition">
        <xsd:enumeration value="TransitTimeLimits">
        <xsd:enumeration value="TransmissionDateTimeOfDocument">
        <xsd:enumeration value="Transmitted">
        <xsd:enumeration value="TransportEquipmentStrippingDateAndOrTime">
        <xsd:enumeration value="TransportEquipmentStuffingDateAndOrTime">
        <xsd:enumeration value="Travel">
        <xsd:enumeration value="Treatment">
        <xsd:enumeration value="TreatmentEnd">
        <xsd:enumeration value="TreatmentStart">
        <xsd:enumeration value="TrialBalancePeriod">
        <xsd:enumeration value="TrialSet">
        <xsd:enumeration value="TrialStartDateActual">
        <xsd:enumeration value="TrialStartDateScheduled">
        <xsd:enumeration value="Trust">
        <xsd:enumeration value="UnderwritingYear">
        <xsd:enumeration value="UnloadedDateAndTime">
        <xsd:enumeration value="ValidationDate">
        <xsd:enumeration value="ValidityPeriod">
        <xsd:enumeration value="ValidityStartDate">
        <xsd:enumeration value="ValidUntil">
        <xsd:enumeration value="ValuationDateTime">
        <xsd:enumeration value="ValuationDateCustoms">
        <xsd:enumeration value="ValueAddedTaxClaimsVerificationDate">
        <xsd:enumeration value="ValueDate">
        <xsd:enumeration value="ValueDateOfIndex">
        <xsd:enumeration value="VerbalReportNeeded">
        <xsd:enumeration value="VerificationReceived">
        <xsd:enumeration value="VerificationSent">
        <xsd:enumeration value="Verified">
        <xsd:enumeration value="Version">
        <xsd:enumeration value="VesselRegistry">
        <xsd:enumeration value="VestingService">
        <xsd:enumeration value="VestingServiceBegin">
        <xsd:enumeration value="VestingServiceEnd">
        <xsd:enumeration value="VoluntaryTermination">
        <xsd:enumeration value="VoucherDateOf">
        <xsd:enumeration value="WageEffective">
        <xsd:enumeration value="WagesEarned">
        <xsd:enumeration value="WagePeriodEndDate">
        <xsd:enumeration value="WagePeriodStartDate">
        <xsd:enumeration value="WaitingTime">
        <xsd:enumeration value="WarrantyExpiration">
        <xsd:enumeration value="Waybill">
        <xsd:enumeration value="WeekEnding">
        <xsd:enumeration value="Weighed">
        <xsd:enumeration value="WellLogRun">
        <xsd:enumeration value="WholesaleContractEffective">
        <xsd:enumeration value="WholesaleContractExpiration">
        <xsd:enumeration value="WillAdviseAsOf">
        <xsd:enumeration value="WithdrawnDate">
        <xsd:enumeration value="WithheldDate">
        <xsd:enumeration value="WorkEffectiveStartDate">
        <xsd:enumeration value="WorkingPeriodEndDate">
        <xsd:enumeration value="WorkingPeriodStartDate">
        <xsd:enumeration value="WorkPeriod">
        <xsd:enumeration value="WorksCompletionDateTimeActual">
        <xsd:enumeration value="WorksCompletionDateTimePlanned">
        <xsd:enumeration value="WorstTimeToCall">
        <xsd:enumeration value="YearBeginning">
        <xsd:enumeration value="YearDue">
        <xsd:enumeration value="YearEnding">
        <xsd:enumeration value="YearOfOccurrence">
        <xsd:enumeration value="YearToDate">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: DateQualifierType

DateQualifierType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( DateQualifierCoded[DateQualifierCodeType] , DateQualifierCodedOther[xsd:string]? )

    Description: DateQualifierType is a container for the code qualifying a date.

    Elements:

    • DateQualifierCoded - identifies the function of a date using a standard codelist.
    • DateQualifierCodedOther - is used to provide a non-standard DateQualifierCode. This element is mandatory if the value of DateQualifierCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="DateQualifierType">
    <xsd:sequence>
        <xsd:element name="DateQualifierCoded" type="DateQualifierCodeType">
        <xsd:element minOccurs="0" name="DateQualifierCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: DateTimeRefCodeType

DateTimeRefCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code references to a point in time. This code list is derived from EDIFACT 2475 (Payment time reference code) and X12 333 (Term basis date code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • AnticipatedDeliveryDate - The date on which delivery is anticipated to take place.
    • ApprovalOfGageDate
    • ApprovalOfSampleDate
    • CompletionAndAcceptanceDate
    • CustomsClearanceDateExport - Date when goods clear Customs in the exporting country.
    • CustomsClearanceDateImport - Date when goods clear Customs in the importing country.
    • DateCreditNoteReceived - Payment time reference is date of credit note received.
    • DateExWorks - Payment time reference is date when goods are leaving the sellers factory.
    • DateGoodsHandedOverForShipmentBySellerOrAgent
    • DateGoodsReceivedByBuyer - Payment time reference is date when goods are received by buyer.
    • DateGoodsReceivedByBuyersAgent - Payment time reference is date when goods are received by buyer's agent.
    • DateGoodsReceivedByCarrier - Payment time reference is date when goods are received by carrier.
    • DateInvoiceReceived - Payment time reference is date of invoice received.
    • DateOfAcceptanceOfFirstSamplesProducedUnderProductionConditions - Payment time reference is date of acceptance of first samples produced under production conditions.
    • DateOfAcceptanceOfNegotiableInstrument - Date when the negotiable instrument is accepted or will be accepted by drawee.
    • DateOfAcceptanceOfTooling - Payment time reference is date of acceptance of tooling or set of tooling.
    • DateOfArrivalOfTransport - Date the transport arrived at the agreed destination.
    • DateOfBillOfLadingConsignmentNoteOrOtherTransportDocument - The date of issuance of a bill of lading, consignment note or similar transport document.
    • DateOfCertificateOfFinalAcceptance
    • DateOfCertificateOfPreliminaryAcceptance - Date of certificate of temporary acceptance of work until final reception will take place.
    • DateOfConfirmation - Payment time reference is date of confirmation.
    • DateOfConfirmationOfOrderReceived - Payment time reference is date of confirmation received.
    • DateOfContract - Payment time reference is date of contract.
    • DateOfCreditNote - Payment time reference is date of credit note.
    • DeliveryDate
    • DateOfDeliveryOfGoodsToEstablishmentsDomicileSite - Date the goods are delivered at agreed place of destination.
    • DateOfDeliveryToBuyerOfDocumentsRepresentingGoods - Date when documents representing goods are received by buyer .
    • DateOfDeliveryToBuyersAgentOfDocumentsRepresentingGoods - Date when documents representing goods are received by buyer's agent.
    • DateOfDeliveryToCarrierOfDocumentsRepresentingGoods - Date when documents representing goods are received by carrier.
    • DateOfDeliveryToIntermediaryBankOfDocumentsRepresentingGood - Date when documents representing goods are received by intermediary bank.
    • DateOfEndOfWork
    • DateOfFinalAcceptanceOfWork
    • DateOfInvoice - Payment time reference is date of invoice.
    • DateOfInwardFrontierCrossing - Date the goods are crossing the border of the importers country.
    • DateOfIssueOfTransportDocument - The date on which a transport document(s) is issued.
    • DateOfNegotiableInstrumentDraftPromissoryNoteBank
    • DateOfOrder - Payment time reference is date of order.
    • DateOfOutwardFrontierCrossing - Date the goods are crossing the border of the exporters country.
    • DateOfPresentationOfDocuments
    • DateOfPresentationOfNegotiableInstrument - Date when the negotiable instrument is presented or will be presented to will be presented to drawee.
    • DateOfPresentDocument - Payment time reference is date of present document.
    • DateOfProvisionalReceptionOfWork - Date of temporary acceptance of work until final reception will take place.
    • DateOfReceiptForLoadingMatesReceipt - Date when goods are expedited to a ship confirmed by mate's received.
    • DateOfReceiptOfToolDependentInitialSamplesPlusUnlimitedAbsoluteBankGuaranteePlusValueAddedTax - Payment time reference is date of receipt of tool dependent initial samples and unlimited absolute bank guarantee of a third party, who is liable to the full amount of the tooling (which is owned by the customer).
    • DateOfReceiptOfTooling - Payment time reference is date of receipt of tooling or set of tooling.
    • DateOfResaleByBuyer - Payment time reference is date of resale by the buyer.
    • DateOfSalaryPayment - Date when a salary payment was made.
    • ShipDate
    • DateOfShipmentAsEvidencedByTheTransportDocument - Date of shipment as evidenced by the transport document(s).
    • DateOfSignatureOfContract - Payment time reference is date of signature of contract.
    • DateOfStartOfWork
    • DatePresentDocumentReceived - Payment time reference is date of present document received.
    • DateProceedsOfResaleCollectedByBuyer - Payment time reference is date of resale proceeds are collected by buyer. "buyer" is a retailer. Retailer will pay his supplier when having sold goods and money received.
    • DraftAtDaysAfterDateOfIssuanceOfTransportDocument - Draft(s) is/are due after a specific number of days after date of issuance of transport document(s).
    • DraftAtDaysAfterDateOfPresentationOfDocuments - Draft(s) is/are due after a specific number of days after date of presentation of documents.
    • DraftAtDaysDate - Draft(s) is/are due after a specific number of days after date.
    • DraftAtDaysSight - Draft(s) is/are due after a specific number of days after sight.
    • DueDateOfNegotiableInstrument - Date when the negotiable instrument is due for payment.
    • EffectiveDate - The date on which an action or event becomes effective.
    • InvoiceDate
    • InvoiceReceiptDate
    • InvoiceTransmissionDate
    • InvoiceVerificationDate
    • OtherReferenceDateAgreedUponBetweenTheParties
    • PaymentDate - Date when a payment was made.
    • PaymentDueDate - Date on which a payment is due.
    • PurchaseOrderDate
    • QualityApprovalDate
    • QuarterStartDate
    • ReceiptOfGoods
    • RequestedDateOfDelivery - Payment terms apply from the requested date of delivery.
    • SpecifiedDate - Date specified elsewhere.
    • SpecifiedDraftDate - Draft at specified date.
    • StipulatedDateForAcceptanceOfDocumentaryCredit - Date as per agreement when documentary credit is accepted.
    • StipulatedDateForNegotiationOfDocumentaryCredit - Date as per agreement when documentary credit is negotiated.
    • StipulatedDateForPaymentOfDocumentaryCredit - Date as per agreement when documentary credit is due for payment.

[^]Code Fragment

    <xsd:simpleType name="DateTimeRefCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="AnticipatedDeliveryDate">
        <xsd:enumeration value="ApprovalOfGageDate">
        <xsd:enumeration value="ApprovalOfSampleDate">
        <xsd:enumeration value="CompletionAndAcceptanceDate">
        <xsd:enumeration value="CustomsClearanceDateExport">
        <xsd:enumeration value="CustomsClearanceDateImport">
        <xsd:enumeration value="DateCreditNoteReceived">
        <xsd:enumeration value="DateExWorks">
        <xsd:enumeration value="DateGoodsHandedOverForShipmentBySellerOrAgent">
        <xsd:enumeration value="DateGoodsReceivedByBuyer">
        <xsd:enumeration value="DateGoodsReceivedByBuyersAgent">
        <xsd:enumeration value="DateGoodsReceivedByCarrier">
        <xsd:enumeration value="DateInvoiceReceived">
        <xsd:enumeration value="DateOfAcceptanceOfFirstSamplesProducedUnderProductionConditions">
        <xsd:enumeration value="DateOfAcceptanceOfNegotiableInstrument">
        <xsd:enumeration value="DateOfAcceptanceOfTooling">
        <xsd:enumeration value="DateOfArrivalOfTransport">
        <xsd:enumeration value="DateOfBillOfLadingConsignmentNoteOrOtherTransportDocument">
        <xsd:enumeration value="DateOfCertificateOfFinalAcceptance">
        <xsd:enumeration value="DateOfCertificateOfPreliminaryAcceptance">
        <xsd:enumeration value="DateOfConfirmation">
        <xsd:enumeration value="DateOfConfirmationOfOrderReceived">
        <xsd:enumeration value="DateOfContract">
        <xsd:enumeration value="DateOfCreditNote">
        <xsd:enumeration value="DeliveryDate">
        <xsd:enumeration value="DateOfDeliveryOfGoodsToEstablishmentsDomicileSite">
        <xsd:enumeration value="DateOfDeliveryToBuyerOfDocumentsRepresentingGoods">
        <xsd:enumeration value="DateOfDeliveryToBuyersAgentOfDocumentsRepresentingGoods">
        <xsd:enumeration value="DateOfDeliveryToCarrierOfDocumentsRepresentingGoods">
        <xsd:enumeration value="DateOfDeliveryToIntermediaryBankOfDocumentsRepresentingGood">
        <xsd:enumeration value="DateOfEndOfWork">
        <xsd:enumeration value="DateOfFinalAcceptanceOfWork">
        <xsd:enumeration value="DateOfInvoice">
        <xsd:enumeration value="DateOfInwardFrontierCrossing">
        <xsd:enumeration value="DateOfIssueOfTransportDocument">
        <xsd:enumeration value="DateOfNegotiableInstrumentDraftPromissoryNoteBank">
        <xsd:enumeration value="DateOfOrder">
        <xsd:enumeration value="DateOfOutwardFrontierCrossing">
        <xsd:enumeration value="DateOfPresentationOfDocuments">
        <xsd:enumeration value="DateOfPresentationOfNegotiableInstrument">
        <xsd:enumeration value="DateOfPresentDocument">
        <xsd:enumeration value="DateOfProvisionalReceptionOfWork">
        <xsd:enumeration value="DateOfReceiptForLoadingMatesReceipt">
        <xsd:enumeration value="DateOfReceiptOfToolDependentInitialSamplesPlusUnlimitedAbsoluteBankGuaranteePlusValueAddedTax">
        <xsd:enumeration value="DateOfReceiptOfTooling">
        <xsd:enumeration value="DateOfResaleByBuyer">
        <xsd:enumeration value="DateOfSalaryPayment">
        <xsd:enumeration value="ShipDate">
        <xsd:enumeration value="DateOfShipmentAsEvidencedByTheTransportDocument">
        <xsd:enumeration value="DateOfSignatureOfContract">
        <xsd:enumeration value="DateOfStartOfWork">
        <xsd:enumeration value="DatePresentDocumentReceived">
        <xsd:enumeration value="DateProceedsOfResaleCollectedByBuyer">
        <xsd:enumeration value="DraftAtDaysAfterDateOfIssuanceOfTransportDocument">
        <xsd:enumeration value="DraftAtDaysAfterDateOfPresentationOfDocuments">
        <xsd:enumeration value="DraftAtDaysDate">
        <xsd:enumeration value="DraftAtDaysSight">
        <xsd:enumeration value="DueDateOfNegotiableInstrument">
        <xsd:enumeration value="EffectiveDate">
        <xsd:enumeration value="InvoiceDate">
        <xsd:enumeration value="InvoiceReceiptDate">
        <xsd:enumeration value="InvoiceTransmissionDate">
        <xsd:enumeration value="InvoiceVerificationDate">
        <xsd:enumeration value="OtherReferenceDateAgreedUponBetweenTheParties">
        <xsd:enumeration value="PaymentDate">
        <xsd:enumeration value="PaymentDueDate">
        <xsd:enumeration value="PurchaseOrderDate">
        <xsd:enumeration value="QualityApprovalDate">
        <xsd:enumeration value="QuarterStartDate">
        <xsd:enumeration value="ReceiptOfGoods">
        <xsd:enumeration value="RequestedDateOfDelivery">
        <xsd:enumeration value="SpecifiedDate">
        <xsd:enumeration value="SpecifiedDraftDate">
        <xsd:enumeration value="StipulatedDateForAcceptanceOfDocumentaryCredit">
        <xsd:enumeration value="StipulatedDateForNegotiationOfDocumentaryCredit">
        <xsd:enumeration value="StipulatedDateForPaymentOfDocumentaryCredit">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: Decimal2_0Type

Decimal2_0Type (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    is intended to hold a decimal double with up to 2 digits of precision, including up to 2 digits to the left of the decimal sign and 0 digits to the right.

    Content: Restriction of base type xsd:decimal

      xsd:totalDigits: 2
      xsd:fractionDigits: 0

[^]Code Fragment

    <xsd:simpleType name="Decimal2_0Type">
    <xsd:restriction base="xsd:decimal">
        <xsd:totalDigits value="2">
        <xsd:fractionDigits value="0">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: Decimal6_0Type

Decimal6_0Type (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    is intended to hold a decimal double with up to 6 digits of precision, including up to 6 digits to the left of the decimal sign and 0 digits to the right.

    Content: Restriction of base type xsd:decimal

      xsd:totalDigits: 6
      xsd:fractionDigits: 0

[^]Code Fragment

    <xsd:simpleType name="Decimal6_0Type">
    <xsd:restriction base="xsd:decimal">
        <xsd:totalDigits value="6">
        <xsd:fractionDigits value="0">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: Decimal8_2Type

Decimal8_2Type (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    is intended to hold a decimal double with up to 8 digits of precision, including up to 6 digits to the left of the decimal sign and 2 digits to the right.

    Content: Restriction of base type xsd:decimal

      xsd:totalDigits: 8
      xsd:fractionDigits: 2

[^]Code Fragment

    <xsd:simpleType name="Decimal8_2Type">
    <xsd:restriction base="xsd:decimal">
        <xsd:totalDigits value="8">
        <xsd:fractionDigits value="2">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: Decimal10_4Type

Decimal10_4Type (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    is intended to hold a decimal double with up to 10 digits of precision, including up to 6 digits to the left of the decimal sign and 4 digits to the right.

    Content: Restriction of base type xsd:decimal

      xsd:totalDigits: 10
      xsd:fractionDigits: 4

[^]Code Fragment

    <xsd:simpleType name="Decimal10_4Type">
    <xsd:restriction base="xsd:decimal">
        <xsd:totalDigits value="10">
        <xsd:fractionDigits value="4">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: Decimal15_3Type

Decimal15_3Type (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    is intended to hold a decimal double with up to 15 digits of precision, including up to 12 digits to the left of the decimal sign and 3 digits to the right.

    Content: Restriction of base type xsd:decimal

      xsd:totalDigits: 15
      xsd:fractionDigits: 3

[^]Code Fragment

    <xsd:simpleType name="Decimal15_3Type">
    <xsd:restriction base="xsd:decimal">
        <xsd:totalDigits value="15">
        <xsd:fractionDigits value="3">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: Decimal15_4Type

Decimal15_4Type (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    is intended to hold a decimal double with up to 15 digits of precision, including up to 11 digits to the left of the decimal sign and 4 digits to the right.

    Content: Restriction of base type xsd:decimal

      xsd:totalDigits: 15
      xsd:fractionDigits: 4

[^]Code Fragment

    <xsd:simpleType name="Decimal15_4Type">
    <xsd:restriction base="xsd:decimal">
        <xsd:totalDigits value="15">
        <xsd:fractionDigits value="4">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: Decimal18_3Type

Decimal18_3Type (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    is intended to hold a decimal double with up to 18 digits of precision, including up to 15 digits to the left of the decimal sign and 3 digits to the right.

    Content: Restriction of base type xsd:decimal

      xsd:totalDigits: 18
      xsd:fractionDigits: 3

[^]Code Fragment

    <xsd:simpleType name="Decimal18_3Type">
    <xsd:restriction base="xsd:decimal">
        <xsd:totalDigits value="18">
        <xsd:fractionDigits value="3">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: Decimal19_9Type

Decimal19_9Type (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    is intended to hold a decimal double with up to 19 digits of precision, including up to 10 digits to the left of the decimal sign and 9 digits to the right.

    Content: Restriction of base type xsd:decimal

      xsd:totalDigits: 19
      xsd:fractionDigits: 9

[^]Code Fragment

    <xsd:simpleType name="Decimal19_9Type">
    <xsd:restriction base="xsd:decimal">
        <xsd:totalDigits value="19">
        <xsd:fractionDigits value="9">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: Decimal21_6Type

Decimal21_6Type (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    is intended to hold a decimal double with up to 21 digits of precision, including up to 15 digits to the left of the decimal sign and 6 digits to the right.

    Content: Restriction of base type xsd:decimal

      xsd:totalDigits: 21
      xsd:fractionDigits: 6

[^]Code Fragment

    <xsd:simpleType name="Decimal21_6Type">
    <xsd:restriction base="xsd:decimal">
        <xsd:totalDigits value="21">
        <xsd:fractionDigits value="6">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: DeliveryDetailType

DeliveryDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ShipToLocation[LocationType]? , ShipFromLocation[LocationType]? , ListOfScheduleLine[ListOfScheduleLineType]? , ItemPackagingReference[ItemPackagingReferenceType]? , SimplePackageNote[xsd:string]? , TermsOfDelivery[TermsOfDeliveryType]* , CargoClassification[CargoClassificationType]? )

    Description: DeliveryDetailType is used to specify the scheduling information for a distinct set of ship from party, ship to party, and transport information for the line item

    Elements:

    • ShipToLocation - is the location to which the shipments are to be delivered.
    • ShipFromLocation - identifies the party from which the item is to be shipped from. This is only used if the ShipFromParty differs from that identified in the header.
    • ListOfScheduleLine - is all of the schedule information relevant to the line item for the shipping parties. This may indicate several shipments to the same location over a period of time.
    • ItemPackagingReference - contains reference information when detailed packaging information contained in list of package detail is to be associated with the line item.
    • SimplePackageNote - is free form text relating to the packaging.
    • TermsOfDelivery - includes the information related to delivery including shipment method payment and transport.
    • CargoClassification - contains different conventions for the classification and description of the goods being transported.

[^]Code Fragment

    <xsd:complexType name="DeliveryDetailType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ShipToLocation" type="LocationType">
        <xsd:element minOccurs="0" name="ShipFromLocation" type="LocationType">
        <xsd:element minOccurs="0" name="ListOfScheduleLine" type="ListOfScheduleLineType">
        <xsd:element minOccurs="0" name="ItemPackagingReference" type="ItemPackagingReferenceType">
        <xsd:element minOccurs="0" name="SimplePackageNote" type="xsd:string">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="TermsOfDelivery" type="TermsOfDeliveryType">
        <xsd:element minOccurs="0" name="CargoClassification" type="CargoClassificationType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: DestinationRefType

DestinationRefType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( RouteID[xsd:int] , LocationID[xsd:int] )

    Description: DestinationRefType holds the references for the destinations to the line item.

    Elements:

    • RouteID - references the route ID in TransportRouting.
    • LocationID - holds the unique number referenced internally from line item package and detail.

[^]Code Fragment

    <xsd:complexType name="DestinationRefType">
    <xsd:sequence>
        <xsd:element name="RouteID" type="xsd:int">
        <xsd:element name="LocationID" type="xsd:int">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: DetailChangeCodeType

DetailChangeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the type of change to the line item. This code list is derived from EDIFACT 1229 and X12 668 and 670

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • AbideOutcomeOfNegotiations
    • AddAdditionalItems
    • AdditionalSubOrdinateStructureWillFollow
    • AdditionalSubOrdinateStructureWillNotFollow
    • Audited
    • BuyerClaimsAgainstInvoice
    • BuyerHasDeductedAmount
    • CallOffDelivery
    • Cancelled
    • ChangeOfDates
    • ChangeOfDateTerms
    • ChangesToItemLevelAllowanceOrCharges
    • ChangesToLineItems
    • ChangesToTerms
    • ChargeBackToSeller
    • Closed
    • ClosedAfterReopening
    • ConditionallyPaid
    • CorrectionOfError
    • EquipmentProvisionallyRepaired
    • ForUnitPriceQuantityRescheduleChangeMultiple
    • ItemDeleted
    • ItemNumberChanged
    • New
    • NoAction
    • NoDelivery
    • NotPaidPredeterminationPricingOnly
    • OnAppeal
    • PreviousPaymentDecisionReversed
    • PriceChanged
    • Proposed
    • ProposedAmendment
    • QuantityDecrease
    • QuantityIncrease
    • Reaudited
    • Redetermined
    • ReferredIemRejected
    • ReferredItemAccepted
    • Reopened
    • ReplaceAllDates
    • ReplaceAllValues
    • Replaced
    • ReplacementItem
    • ReplacementItemWithModifications
    • ReplaceModeOfShipment
    • Reschedule
    • Reschedule-QuantityChange
    • Reviewed
    • Schedule
    • SellerWillIssueACreditNote
    • TermsChangedForNewTerms
    • TransferItem
    • UnitPrice-QuantityChange
    • UnitPrice-RescheduleChange
    • CancelPreviouslyTransmittedPurchaseOrder
    • ChangeToTotalLevelAllowanceOrCharge
    • ChangeToOriginalConfirmationOfOriginalAnnouncement
    • ChangeToConfirmationOfRevisedAnnouncment
    • ConcurrentItemNoChange
    • OriginalConfirmationOfRevisedAnnouncment
    • OriginalConfirmationOfOriginalAnnouncement

[^]Code Fragment

    <xsd:simpleType name="DetailChangeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="AbideOutcomeOfNegotiations">
        <xsd:enumeration value="AddAdditionalItems">
        <xsd:enumeration value="AdditionalSubOrdinateStructureWillFollow">
        <xsd:enumeration value="AdditionalSubOrdinateStructureWillNotFollow">
        <xsd:enumeration value="Audited">
        <xsd:enumeration value="BuyerClaimsAgainstInvoice">
        <xsd:enumeration value="BuyerHasDeductedAmount">
        <xsd:enumeration value="CallOffDelivery">
        <xsd:enumeration value="Cancelled">
        <xsd:enumeration value="ChangeOfDates">
        <xsd:enumeration value="ChangeOfDateTerms">
        <xsd:enumeration value="ChangesToItemLevelAllowanceOrCharges">
        <xsd:enumeration value="ChangesToLineItems">
        <xsd:enumeration value="ChangesToTerms">
        <xsd:enumeration value="ChargeBackToSeller">
        <xsd:enumeration value="Closed">
        <xsd:enumeration value="ClosedAfterReopening">
        <xsd:enumeration value="ConditionallyPaid">
        <xsd:enumeration value="CorrectionOfError">
        <xsd:enumeration value="EquipmentProvisionallyRepaired">
        <xsd:enumeration value="ForUnitPriceQuantityRescheduleChangeMultiple">
        <xsd:enumeration value="ItemDeleted">
        <xsd:enumeration value="ItemNumberChanged">
        <xsd:enumeration value="New">
        <xsd:enumeration value="NoAction">
        <xsd:enumeration value="NoDelivery">
        <xsd:enumeration value="NotPaidPredeterminationPricingOnly">
        <xsd:enumeration value="OnAppeal">
        <xsd:enumeration value="PreviousPaymentDecisionReversed">
        <xsd:enumeration value="PriceChanged">
        <xsd:enumeration value="Proposed">
        <xsd:enumeration value="ProposedAmendment">
        <xsd:enumeration value="QuantityDecrease">
        <xsd:enumeration value="QuantityIncrease">
        <xsd:enumeration value="Reaudited">
        <xsd:enumeration value="Redetermined">
        <xsd:enumeration value="ReferredIemRejected">
        <xsd:enumeration value="ReferredItemAccepted">
        <xsd:enumeration value="Reopened">
        <xsd:enumeration value="ReplaceAllDates">
        <xsd:enumeration value="ReplaceAllValues">
        <xsd:enumeration value="Replaced">
        <xsd:enumeration value="ReplacementItem">
        <xsd:enumeration value="ReplacementItemWithModifications">
        <xsd:enumeration value="ReplaceModeOfShipment">
        <xsd:enumeration value="Reschedule">
        <xsd:enumeration value="Reschedule-QuantityChange">
        <xsd:enumeration value="Reviewed">
        <xsd:enumeration value="Schedule">
        <xsd:enumeration value="SellerWillIssueACreditNote">
        <xsd:enumeration value="TermsChangedForNewTerms">
        <xsd:enumeration value="TransferItem">
        <xsd:enumeration value="UnitPrice-QuantityChange">
        <xsd:enumeration value="UnitPrice-RescheduleChange">
        <xsd:enumeration value="CancelPreviouslyTransmittedPurchaseOrder">
        <xsd:enumeration value="ChangeToTotalLevelAllowanceOrCharge">
        <xsd:enumeration value="ChangeToOriginalConfirmationOfOriginalAnnouncement">
        <xsd:enumeration value="ChangeToConfirmationOfRevisedAnnouncment">
        <xsd:enumeration value="ConcurrentItemNoChange">
        <xsd:enumeration value="OriginalConfirmationOfRevisedAnnouncment">
        <xsd:enumeration value="OriginalConfirmationOfOriginalAnnouncement">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: DetailResponseCodeType

DetailResponseCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the response for the line item detail. This code list is derived from EDIFACT 1225 (Message function code), 1229 (Action request/notification description code), and 4343 (Response type code) and X12 353 (Transaction set purpose code), 587 (Acknowledgment type), and 670 (Change or response type code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • AcceptedWithAmendment
    • AcceptedWithAmendmentNoConfirmationRequired
    • AcknowledgeWithDetailAndChange
    • Agreed
    • AlreadyDelivered
    • ApprovedAsAmended
    • ApprovedAsSubmitted
    • Cancelled
    • ChangeOfDates
    • ChangeOfDateTerms
    • ChangesToItemLevelAllowanceAndCharges
    • ChangesToLineItems
    • ChangeToConfirmationOfRevisedAnnouncement
    • ChangeToOriginalConfirmationOfOriginaAnnouncement
    • ItemAccepted
    • ItemAcceptedAndReleasedForShipment
    • ItemAcceptedAndShipped
    • ItemAcceptedChangesMade
    • ItemAcceptedDateRescheduled
    • ItemAccepted-OrderForwardedToAlternateSupplierLocation
    • ItemAcceptedPartialShipmentBalanceBackordered
    • ItemAcceptedPriceChanged
    • ItemAcceptedPricePending
    • ItemAcceptedQuantityChanged
    • ItemAcceptedScheduleDatePending
    • ItemAcceptedSubstitutionMade
    • ItemBackordered
    • ItemChangeRejected
    • ItemDeleted
    • ItemNotAcceptedByTheSeller
    • ItemOnHold
    • ItemOnHoldIncompleteDescription
    • ItemOnHoldWaiverRequired
    • ItemRejected
    • ItemRejectedContractItemNotAvailable
    • ItemRejectedInvalidItemProductNumber
    • ItemRejectedInvalidUnitOfIssue
    • ItemRejectedNotAContractItem
    • ItemRejectedReorderItemAsADropShipment
    • ItemRejectedReorderItemAsAJustInTimeOrder
    • ItemRejectedReorderItemAsASurgeOrder
    • ItemRjectedReorderItemAsAnExtendedDeliveryOrder
    • LineItemNumberChanged
    • New
    • NotChecked
    • NotProcessed
    • Pending
    • PendingIncomplete
    • PendingWaitingAdditionalMaterial
    • PendingWaitingReview
    • PriceChange
    • QuantityDecrease
    • QuantityIncrease
    • ReferredItemAccepted
    • ReferredItemRejected
    • RejectedDuplicate
    • RejectedNoDetail
    • RejectedNotAsAgreed
    • RejectedSubmittedWithCorrections
    • RejectedViolatesIndustryPractices
    • RejectedWithCounterOffer
    • RejectWithDetail
    • RejectWithExceptionDetailOnly
    • ReplaceAllDates
    • ReplaceAllValues
    • Replaced
    • ReplacementItem
    • ReplacementItemWithModifications
    • ReplaceModeOfShipment
    • Repriced
    • Reschedule
    • Reschedule-QuantityChange
    • SellerRejectsDispute
    • TermsChangedForNewTerms
    • UnitPrice-QuantityChange
    • UnitPrice-RescheduleChange

[^]Code Fragment

    <xsd:simpleType name="DetailResponseCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="AcceptedWithAmendment">
        <xsd:enumeration value="AcceptedWithAmendmentNoConfirmationRequired">
        <xsd:enumeration value="AcknowledgeWithDetailAndChange">
        <xsd:enumeration value="Agreed">
        <xsd:enumeration value="AlreadyDelivered">
        <xsd:enumeration value="ApprovedAsAmended">
        <xsd:enumeration value="ApprovedAsSubmitted">
        <xsd:enumeration value="Cancelled">
        <xsd:enumeration value="ChangeOfDates">
        <xsd:enumeration value="ChangeOfDateTerms">
        <xsd:enumeration value="ChangesToItemLevelAllowanceAndCharges">
        <xsd:enumeration value="ChangesToLineItems">
        <xsd:enumeration value="ChangeToConfirmationOfRevisedAnnouncement">
        <xsd:enumeration value="ChangeToOriginalConfirmationOfOriginaAnnouncement">
        <xsd:enumeration value="ItemAccepted">
        <xsd:enumeration value="ItemAcceptedAndReleasedForShipment">
        <xsd:enumeration value="ItemAcceptedAndShipped">
        <xsd:enumeration value="ItemAcceptedChangesMade">
        <xsd:enumeration value="ItemAcceptedDateRescheduled">
        <xsd:enumeration value="ItemAccepted-OrderForwardedToAlternateSupplierLocation">
        <xsd:enumeration value="ItemAcceptedPartialShipmentBalanceBackordered">
        <xsd:enumeration value="ItemAcceptedPriceChanged">
        <xsd:enumeration value="ItemAcceptedPricePending">
        <xsd:enumeration value="ItemAcceptedQuantityChanged">
        <xsd:enumeration value="ItemAcceptedScheduleDatePending">
        <xsd:enumeration value="ItemAcceptedSubstitutionMade">
        <xsd:enumeration value="ItemBackordered">
        <xsd:enumeration value="ItemChangeRejected">
        <xsd:enumeration value="ItemDeleted">
        <xsd:enumeration value="ItemNotAcceptedByTheSeller">
        <xsd:enumeration value="ItemOnHold">
        <xsd:enumeration value="ItemOnHoldIncompleteDescription">
        <xsd:enumeration value="ItemOnHoldWaiverRequired">
        <xsd:enumeration value="ItemRejected">
        <xsd:enumeration value="ItemRejectedContractItemNotAvailable">
        <xsd:enumeration value="ItemRejectedInvalidItemProductNumber">
        <xsd:enumeration value="ItemRejectedInvalidUnitOfIssue">
        <xsd:enumeration value="ItemRejectedNotAContractItem">
        <xsd:enumeration value="ItemRejectedReorderItemAsADropShipment">
        <xsd:enumeration value="ItemRejectedReorderItemAsAJustInTimeOrder">
        <xsd:enumeration value="ItemRejectedReorderItemAsASurgeOrder">
        <xsd:enumeration value="ItemRjectedReorderItemAsAnExtendedDeliveryOrder">
        <xsd:enumeration value="LineItemNumberChanged">
        <xsd:enumeration value="New">
        <xsd:enumeration value="NotChecked">
        <xsd:enumeration value="NotProcessed">
        <xsd:enumeration value="Pending">
        <xsd:enumeration value="PendingIncomplete">
        <xsd:enumeration value="PendingWaitingAdditionalMaterial">
        <xsd:enumeration value="PendingWaitingReview">
        <xsd:enumeration value="PriceChange">
        <xsd:enumeration value="QuantityDecrease">
        <xsd:enumeration value="QuantityIncrease">
        <xsd:enumeration value="ReferredItemAccepted">
        <xsd:enumeration value="ReferredItemRejected">
        <xsd:enumeration value="RejectedDuplicate">
        <xsd:enumeration value="RejectedNoDetail">
        <xsd:enumeration value="RejectedNotAsAgreed">
        <xsd:enumeration value="RejectedSubmittedWithCorrections">
        <xsd:enumeration value="RejectedViolatesIndustryPractices">
        <xsd:enumeration value="RejectedWithCounterOffer">
        <xsd:enumeration value="RejectWithDetail">
        <xsd:enumeration value="RejectWithExceptionDetailOnly">
        <xsd:enumeration value="ReplaceAllDates">
        <xsd:enumeration value="ReplaceAllValues">
        <xsd:enumeration value="Replaced">
        <xsd:enumeration value="ReplacementItem">
        <xsd:enumeration value="ReplacementItemWithModifications">
        <xsd:enumeration value="ReplaceModeOfShipment">
        <xsd:enumeration value="Repriced">
        <xsd:enumeration value="Reschedule">
        <xsd:enumeration value="Reschedule-QuantityChange">
        <xsd:enumeration value="SellerRejectsDispute">
        <xsd:enumeration value="TermsChangedForNewTerms">
        <xsd:enumeration value="UnitPrice-QuantityChange">
        <xsd:enumeration value="UnitPrice-RescheduleChange">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: DimensionCodeType

DimensionCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the attribute measured. This code list is derived from EDIFACT 6313 (Measured attribute code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • ConsolidatedWeight
    • UnitNetWeight - [6160] Weight (Mass) Of Goods Including Any Packing Normally Going With Them To A Buyer In A Retail Sale.
    • UnitGrossWeight - [6292] Weight (Mass) Of Goods Including Packing But Excluding The Carrier'S Equipment.
    • TotalNetWeight - Total Weight Of Goods Excluding Packaging.
    • TotalGrossWeight - [6292] Weight (Mass) Of Goods Including Packing But Excluding The Carrier'S Equipment.
    • ItemGrossWeight - Gross weight at line item level.
    • NetNetWeight - [6048] Weight (mass) of the goods themselves without any packing.
    • NumberOfUnitsPerPallet - The number of units contained on a pallet.
    • FatContent - An indication of the fat content of a product.
    • NetWeight - [6160] Weight (mass) of goods including any packing normally going with them to a buyer in a retail sale.
    • GrossTonnageOfTheVessel - [6300] The measure of the overall size of a ship determined in accordance with the provisions of the International Convention on Tonnage Measurement of Ships, 1969.
    • NetTonnageOfTheVessel - [6302] The measure of the useful capacity of a ship determined in accordance with the provisions of the International Convention on Tonnage Measurement of Ships, 1969.
    • Humidity
    • Voltage
    • PowerConsumption - Value of energy consumption.
    • HeatDissipation
    • AirFlow
    • ShockImpact
    • OperativeTemperature - Temperature identified system or process works according to specifications.
    • NonOperativeTemperature - Temperature identified system or process does not work according to specifications.
    • GrossVolume - The observed volume unadjusted for factors such as temperature or gravity.
    • NetVolume - The observed volume after adjustment for factors such as temperature or gravity.
    • WaterContent - Water content in product.
    • TensileStress
    • Fibrosity
    • GaugeLength
    • Radius
    • Straightness - Straightness of the item.
    • Strain
    • Volume - The amount of air space taken up by the entity identified in the 6311 qualifier.
    • ItemWeight - Weight at line item level.
    • WeightOfConveyance - Tonnage of conveyance.
    • ConveyanceSummerDeadWeight - Registered summer dead weight total tonnage of the vessel.
    • ContainerizedCargoOnVesselsWeight - Total weight of containerized cargo on vessel.
    • Non-ContainerizedCargoOnVesselsWeight - Total weight of non-containerized cargo on vessel.
    • WeightAscertained - [4240] Endorsement of the true weight (mass) as ascertained or verified by the railway (CIM 81).
    • ChargeableWeight - The weight on which charges are based.
    • EstimatedGrossWeight - Estimated weight (mass) of goods, including packing and excluding carrier's.
    • EstimatedVolume - Estimated size or measure of anything in three dimensions.
    • VesselOverallLength - Total overall length of the vessel.
    • LoadingMeters - The length in a vehicle, whereby the complete width and height over that length is needed for the goods.
    • NumberOfAxles - Number of axles of movable equipment or means of transport on wheels.
    • Payload - The revenue-producing load carried by a means of transport.
    • StartPositionInTheLength - The starting position from the beginning of an item located in the length direction.
    • EndPositionInTheLength - The end position from the beginning of an item located in the length direction.
    • StartPositionInTheWidth - The start position from the beginning of an item located in the width direction.
    • EndPositionInTheWidth - The end position from the beginning of an item located in the width direction.
    • StartPositionInTheThickness - The start position from the beginning of an item located in the thickness direction.
    • EndPositionInTheThickness - The end position from the beginning of an item located in the thickness direction.
    • TransportContainerActualFillingWeight - Actual filling weight of a transport container.
    • TransportContainerMaximumCapacity - Maximum capacity of a transport container.
    • DeclaredNetWeight - The declared net weight of a product or products used for invoicing, customs or transport purposes.
    • LoadingHeight - Maximum height of products or packages loaded onto a given transportation device or equipment such as a pallet.
    • StackingHeight - Maximum height up to which the same product or package may be placed one upon the other for storage purposes.
    • CalculatedWeight - The calculated weight of the item based on the ordered dimensions.
    • Ferrite - The chemical composition ferrite.
    • Impurity - The impurity of the product i.e. the measurement of other chemical elements not normally appearing in a product.
    • GrainSize - The grain size.
    • Lanthanides - The chemical element Lanthanides.
    • Elasticity - The value of the elasticity.
    • DrainedWeight - The weight of a product when all liquids used in the packaging of the product have been removed.
    • Gallium - Measurement of the gallium component.
    • Strontium - Measurement of the strontium component.
    • EquipmentStorageLimitation - Maximum storage limit of the equipment.
    • RadioactiveIndexOfTransport - The index of transport determines the maximum radiation level at a distance of 1m from the external surface.
    • Radioactivity - Activity of radioactive material.
    • AverageGrossWeight - Weight which is the outcome of the division of the total gross weight by the number of units.
    • ForwardDraft - Depth of water from the surface of water to the bottom of the vessel measured at the draft mark of the bow.
    • AfterDraft - Depth of water from the surface of water to the bottom of the vessel measured at the draft mark of the stern.
    • TransportEquipmentGrossWeight - Weight of a transport equipment including the cargo and carrier's equipment.
    • TotalTransportEquipmentGrossWeight - Total weight of all transport equipment including the cargo and carrier's equipment.
    • AcidityOfJuice - Acid measurement of juice.
    • Penetrometry - Measurement of force required to drive a standard penetrating stamp.
    • Durofel - Measurement of the elastic force using a standard penetrating stamp.
    • JuiceWeightPer100Grams - Measurement of weight of juice, based on 100 grams of the entire weight.
    • FruitSkinColour - Measurement of the colouring of the epidermis of a fruit.
    • AngleOfBend
    • FixedIncrementalMeasurement - The measurement of the fixed increment.
    • DurofelD10 - Measure of the elastic force of the pulp of a fruit. It is measured with a penetrating stamp with diameter 10.
    • DurofelD25 - Measure of the elastic force of the pulp of a fruit. It is measured with a penetrating stamp with diameter 25.
    • DurofelD50 - Measure of the elastic force of the pulp of a fruit. It is measured with a penetrating stamp with diameter 50.
    • MaximumStackingWeight - The maximum weight which may be stacked upon a product or package without the product or packaging being crushed.
    • GrossMeasureCube - The total cubic space occupied by an item, taking into account any protruding components, arrived at by multiplying the maximum length, width and height.
    • PercentageFatContentInDryMatter - The percentage of fat content in dry matter.
    • SaccharometricContent - Measurement of the sugar content of a solution.
    • HydrateContentOfAnAlcoholicProductAfterBottling - The hydrate content which occurs in an alcoholic product after bottling.
    • AnhydrousContent - The non-water content.
    • CertifiedWeight - Weight which has been certified.
    • BilledWeight
    • BreakingLoad
    • Platinum - The measurement of the platinum component.
    • Silver - The measurement of the silver component.
    • List - The leaning or inclination of a vessel expressed in degrees port or starboard.
    • Trim - The condition of a vessel with reference to its longitudinal axis.
    • FreeWater - The volume of water present in a container that is not in suspension in the contained liquid.
    • Bands
    • AmericanPetroleumInstituteGravity - The relative density of petroleum liquids as specified by a standard developed by the API.
    • PetroleumGrossObservedVolume - The total volume of all petroleum liquids and sediment and water, excluding free water, at observed temperature and pressure.
    • PetroleumGrossStandardVolume - The total volume of all petroleum liquids, sediment, and water excluding free water, corrected by the appropriate volume correction factor for the observed temperature and American Petroleum Institute relative density, or density to a standard temperature.
    • VolumeVariance - The change in the volume measurement.
    • PetroleumNetStandardVolume - The total volume of all petroleum liquids, excluding sediment and water and free water, corrected by the appropriate volume correction factor for the observed temperature and American Petroleum Institute gravity relative to density or to a standard temperature.
    • MaterialOn-BoardQuantity-AfterDischarge - The material in vessel tanks, void spaces, and pipelines after discharge.
    • PetroleumTotalCalculatedVolume - The total volume of all petroleum liquids, sediment and water corrected by the appropriate volume correction factor for the observed temperature and American Petroleum Institute (API) gravity, relative density, or density to a standard temperature.
    • PetroleumTotalObservedVolume - The total volume of all petroleum liquids, sediment and water and free water at observed temperature and pressure.
    • InnageGaugeDistance - The measured distance from the surface of the liquid to a fixed datum plate or to the tank bottom.
    • PetroleumNetStandardWeight - The total weight of all petroleum liquids excluding sediments, water and free water.
    • SedimentAndWaterInPetroleum - The measurement of non-hydrocarbon solid material and water in suspension in petroleum liquid.
    • ObservedReferenceHeight-Tank - The observed distance from the tank bottom or datum plate to the established reference point.
    • ReferenceHeight-Tank - The measured distance from the tank bottom or datum plate to the established reference point.
    • UllageGaugeDistance - The measured distance from the cargo liquid surface to the reference point.
    • TrimCorrection - The correction applied to the observed gauge or observed volume when a vessel is not on an even keel.
    • BowToBridgeDistance - The distance between the bow and the bridge of a vessel.
    • Brightness
    • Brakes
    • Break
    • BreakingStrength
    • BreakingStrengthWet
    • BasisWeight
    • Change
    • Colour
    • ContentsOfPackage - In combination with the other data elements of the actual segment this code indicates the measured content of a package.
    • CommercialWeight - Item weight considering its maximum possible humidity.
    • CoreLength - To specify length of core on which product is to be placed.
    • DestinationWeightAgreement - The agreed weight of despatched goods whose weight may change during transport.
    • Diameter - Diameter of an article.
    • DeltaValueL
    • Density
    • Depth
    • Denier
    • DistanceBetweenPoints
    • Width-BoxcarDoor
    • EstimatedNewWeight
    • Elongation
    • DeficitWeight
    • FilamentCount - Used e.g. in textile, print industries.
    • LongitudinalFlatness
    • Flatness
    • TransverseFlatness
    • GrossWeight - [6292] Weight (mass) of goods including packing but excluding the carrier's equipment.
    • Gauge
    • GrossWeight-Maximum
    • Hardness
    • Height-Maximum
    • HeightDimension - Numeric value of height.
    • ImpactEnergy
    • InsideDiameter
    • LegalWeight
    • Length-Maximum
    • LengthDimension - (6168) Length of pieces or packages stated for transport purposes.
    • LostEnd
    • MinimumWeight
    • Moisture - Measurement application is the moisture content of the item.
    • MaximumWeight
    • ActualNetWeight - The actual weight of the goods excluding packaging.
    • OutsideDiameter
    • PreStretch - Measurement identifying the amount an item has been stretched prior to use.
    • PerTonne
    • RelativeHumidity
    • Resistivity
    • RockwellC - Hardness in the Rockwell C scale.
    • ReamWeight - Measurement indication for paper.
    • ReductionOfArea
    • Run-Process
    • Ratio
    • ShippedQuantity
    • TareWeight - Weight excluding goods and loose accessories.
    • Temperature - A measurement in relation to temperature.
    • Thickness
    • TimePeriod - Measurement of a specific length of time.
    • Time
    • WeightPerUnit - [6150] Numeric value of weight.
    • Height-VanDoor - The height of the door of a van or container.
    • Width-VanDoor - The width of the door of a van or container.
    • WeightPerUnitOfArea - The weight per unit of an area.
    • WidthDimension - Numeric value of width.
    • Width-Maximum - The maximum distance from side to side.
    • Weight - [6150] Numeric value of weight.
    • WeightPerUnitOfLength - The weight per unit of length.
    • SideHeight-FlatBedWithRemovableSides - The height of the removable sides of a flat bed truck.
    • Teir - Number of layers per pallet (unit of measurement = LR (Layer))
    • Block - Number of packages per layer on a pallet (unit of measurement = PK (Package)
    • Squareness
    • SpoolSize
    • YieldStress
    • Aluminium
    • Arsenic
    • Boron
    • Bismuth
    • Carbon
    • Calcium
    • Columbium
    • Cerium
    • Chlorine
    • Cobalt
    • Chromium
    • Copper
    • Iron
    • IronPlusSilicon
    • Germanium
    • Hydrogen
    • Potassium
    • Magnesium
    • Manganese
    • Molybdenum
    • Nitrogen
    • Sodium
    • Niobium
    • Nickel
    • Oxygen
    • Phosphorus
    • Lead
    • Sulphur
    • Antimony
    • Selenium
    • Silicon
    • SiliciumOxyd
    • Tin
    • Tantalium
    • Tellurium
    • Titanium
    • Vanadium
    • Tungsten
    • WasteContent
    • Zinc
    • Zirconium
    • StorageTemperature - The temperature at which the cargo is to be kept while it is in storage.
    • TransportTemperature - The temperature at which cargo is to be kept while it is under transport.
    • CargoOperatingTemperature - The temperature at which cargo is to be kept during cargo handling.
    • TransportEmergencyTemperature - The temperature at which emergency procedures apply for the disposal of temperature-controlled goods.
    • TransportControlTemperature - The maximum temperature at which certain products can be safely transported.

[^]Code Fragment

    <xsd:simpleType name="DimensionCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="ConsolidatedWeight">
        <xsd:enumeration value="UnitNetWeight">
        <xsd:enumeration value="UnitGrossWeight">
        <xsd:enumeration value="TotalNetWeight">
        <xsd:enumeration value="TotalGrossWeight">
        <xsd:enumeration value="ItemGrossWeight">
        <xsd:enumeration value="NetNetWeight">
        <xsd:enumeration value="NumberOfUnitsPerPallet">
        <xsd:enumeration value="FatContent">
        <xsd:enumeration value="NetWeight">
        <xsd:enumeration value="GrossTonnageOfTheVessel">
        <xsd:enumeration value="NetTonnageOfTheVessel">
        <xsd:enumeration value="Humidity">
        <xsd:enumeration value="Voltage">
        <xsd:enumeration value="PowerConsumption">
        <xsd:enumeration value="HeatDissipation">
        <xsd:enumeration value="AirFlow">
        <xsd:enumeration value="ShockImpact">
        <xsd:enumeration value="OperativeTemperature">
        <xsd:enumeration value="NonOperativeTemperature">
        <xsd:enumeration value="GrossVolume">
        <xsd:enumeration value="NetVolume">
        <xsd:enumeration value="WaterContent">
        <xsd:enumeration value="TensileStress">
        <xsd:enumeration value="Fibrosity">
        <xsd:enumeration value="GaugeLength">
        <xsd:enumeration value="Radius">
        <xsd:enumeration value="Straightness">
        <xsd:enumeration value="Strain">
        <xsd:enumeration value="Volume">
        <xsd:enumeration value="ItemWeight">
        <xsd:enumeration value="WeightOfConveyance">
        <xsd:enumeration value="ConveyanceSummerDeadWeight">
        <xsd:enumeration value="ContainerizedCargoOnVesselsWeight">
        <xsd:enumeration value="Non-ContainerizedCargoOnVesselsWeight">
        <xsd:enumeration value="WeightAscertained">
        <xsd:enumeration value="ChargeableWeight">
        <xsd:enumeration value="EstimatedGrossWeight">
        <xsd:enumeration value="EstimatedVolume">
        <xsd:enumeration value="VesselOverallLength">
        <xsd:enumeration value="LoadingMeters">
        <xsd:enumeration value="NumberOfAxles">
        <xsd:enumeration value="Payload">
        <xsd:enumeration value="StartPositionInTheLength">
        <xsd:enumeration value="EndPositionInTheLength">
        <xsd:enumeration value="StartPositionInTheWidth">
        <xsd:enumeration value="EndPositionInTheWidth">
        <xsd:enumeration value="StartPositionInTheThickness">
        <xsd:enumeration value="EndPositionInTheThickness">
        <xsd:enumeration value="TransportContainerActualFillingWeight">
        <xsd:enumeration value="TransportContainerMaximumCapacity">
        <xsd:enumeration value="DeclaredNetWeight">
        <xsd:enumeration value="LoadingHeight">
        <xsd:enumeration value="StackingHeight">
        <xsd:enumeration value="CalculatedWeight">
        <xsd:enumeration value="Ferrite">
        <xsd:enumeration value="Impurity">
        <xsd:enumeration value="GrainSize">
        <xsd:enumeration value="Lanthanides">
        <xsd:enumeration value="Elasticity">
        <xsd:enumeration value="DrainedWeight">
        <xsd:enumeration value="Gallium">
        <xsd:enumeration value="Strontium">
        <xsd:enumeration value="EquipmentStorageLimitation">
        <xsd:enumeration value="RadioactiveIndexOfTransport">
        <xsd:enumeration value="Radioactivity">
        <xsd:enumeration value="AverageGrossWeight">
        <xsd:enumeration value="ForwardDraft">
        <xsd:enumeration value="AfterDraft">
        <xsd:enumeration value="TransportEquipmentGrossWeight">
        <xsd:enumeration value="TotalTransportEquipmentGrossWeight">
        <xsd:enumeration value="AcidityOfJuice">
        <xsd:enumeration value="Penetrometry">
        <xsd:enumeration value="Durofel">
        <xsd:enumeration value="JuiceWeightPer100Grams">
        <xsd:enumeration value="FruitSkinColour">
        <xsd:enumeration value="AngleOfBend">
        <xsd:enumeration value="FixedIncrementalMeasurement">
        <xsd:enumeration value="DurofelD10">
        <xsd:enumeration value="DurofelD25">
        <xsd:enumeration value="DurofelD50">
        <xsd:enumeration value="MaximumStackingWeight">
        <xsd:enumeration value="GrossMeasureCube">
        <xsd:enumeration value="PercentageFatContentInDryMatter">
        <xsd:enumeration value="SaccharometricContent">
        <xsd:enumeration value="HydrateContentOfAnAlcoholicProductAfterBottling">
        <xsd:enumeration value="AnhydrousContent">
        <xsd:enumeration value="CertifiedWeight">
        <xsd:enumeration value="BilledWeight">
        <xsd:enumeration value="BreakingLoad">
        <xsd:enumeration value="Platinum">
        <xsd:enumeration value="Silver">
        <xsd:enumeration value="List">
        <xsd:enumeration value="Trim">
        <xsd:enumeration value="FreeWater">
        <xsd:enumeration value="Bands">
        <xsd:enumeration value="AmericanPetroleumInstituteGravity">
        <xsd:enumeration value="PetroleumGrossObservedVolume">
        <xsd:enumeration value="PetroleumGrossStandardVolume">
        <xsd:enumeration value="VolumeVariance">
        <xsd:enumeration value="PetroleumNetStandardVolume">
        <xsd:enumeration value="MaterialOn-BoardQuantity-AfterDischarge">
        <xsd:enumeration value="PetroleumTotalCalculatedVolume">
        <xsd:enumeration value="PetroleumTotalObservedVolume">
        <xsd:enumeration value="InnageGaugeDistance">
        <xsd:enumeration value="PetroleumNetStandardWeight">
        <xsd:enumeration value="SedimentAndWaterInPetroleum">
        <xsd:enumeration value="ObservedReferenceHeight-Tank">
        <xsd:enumeration value="ReferenceHeight-Tank">
        <xsd:enumeration value="UllageGaugeDistance">
        <xsd:enumeration value="TrimCorrection">
        <xsd:enumeration value="BowToBridgeDistance">
        <xsd:enumeration value="Brightness">
        <xsd:enumeration value="Brakes">
        <xsd:enumeration value="Break">
        <xsd:enumeration value="BreakingStrength">
        <xsd:enumeration value="BreakingStrengthWet">
        <xsd:enumeration value="BasisWeight">
        <xsd:enumeration value="Change">
        <xsd:enumeration value="Colour">
        <xsd:enumeration value="ContentsOfPackage">
        <xsd:enumeration value="CommercialWeight">
        <xsd:enumeration value="CoreLength">
        <xsd:enumeration value="DestinationWeightAgreement">
        <xsd:enumeration value="Diameter">
        <xsd:enumeration value="DeltaValueL">
        <xsd:enumeration value="Density">
        <xsd:enumeration value="Depth">
        <xsd:enumeration value="Denier">
        <xsd:enumeration value="DistanceBetweenPoints">
        <xsd:enumeration value="Width-BoxcarDoor">
        <xsd:enumeration value="EstimatedNewWeight">
        <xsd:enumeration value="Elongation">
        <xsd:enumeration value="DeficitWeight">
        <xsd:enumeration value="FilamentCount">
        <xsd:enumeration value="LongitudinalFlatness">
        <xsd:enumeration value="Flatness">
        <xsd:enumeration value="TransverseFlatness">
        <xsd:enumeration value="GrossWeight">
        <xsd:enumeration value="Gauge">
        <xsd:enumeration value="GrossWeight-Maximum">
        <xsd:enumeration value="Hardness">
        <xsd:enumeration value="Height-Maximum">
        <xsd:enumeration value="HeightDimension">
        <xsd:enumeration value="ImpactEnergy">
        <xsd:enumeration value="InsideDiameter">
        <xsd:enumeration value="LegalWeight">
        <xsd:enumeration value="Length-Maximum">
        <xsd:enumeration value="LengthDimension">
        <xsd:enumeration value="LostEnd">
        <xsd:enumeration value="MinimumWeight">
        <xsd:enumeration value="Moisture">
        <xsd:enumeration value="MaximumWeight">
        <xsd:enumeration value="ActualNetWeight">
        <xsd:enumeration value="OutsideDiameter">
        <xsd:enumeration value="PreStretch">
        <xsd:enumeration value="PerTonne">
        <xsd:enumeration value="RelativeHumidity">
        <xsd:enumeration value="Resistivity">
        <xsd:enumeration value="RockwellC">
        <xsd:enumeration value="ReamWeight">
        <xsd:enumeration value="ReductionOfArea">
        <xsd:enumeration value="Run-Process">
        <xsd:enumeration value="Ratio">
        <xsd:enumeration value="ShippedQuantity">
        <xsd:enumeration value="TareWeight">
        <xsd:enumeration value="Temperature">
        <xsd:enumeration value="Thickness">
        <xsd:enumeration value="TimePeriod">
        <xsd:enumeration value="Time">
        <xsd:enumeration value="WeightPerUnit">
        <xsd:enumeration value="Height-VanDoor">
        <xsd:enumeration value="Width-VanDoor">
        <xsd:enumeration value="WeightPerUnitOfArea">
        <xsd:enumeration value="WidthDimension">
        <xsd:enumeration value="Width-Maximum">
        <xsd:enumeration value="Weight">
        <xsd:enumeration value="WeightPerUnitOfLength">
        <xsd:enumeration value="SideHeight-FlatBedWithRemovableSides">
        <xsd:enumeration value="Teir">
        <xsd:enumeration value="Block">
        <xsd:enumeration value="Squareness">
        <xsd:enumeration value="SpoolSize">
        <xsd:enumeration value="YieldStress">
        <xsd:enumeration value="Aluminium">
        <xsd:enumeration value="Arsenic">
        <xsd:enumeration value="Boron">
        <xsd:enumeration value="Bismuth">
        <xsd:enumeration value="Carbon">
        <xsd:enumeration value="Calcium">
        <xsd:enumeration value="Columbium">
        <xsd:enumeration value="Cerium">
        <xsd:enumeration value="Chlorine">
        <xsd:enumeration value="Cobalt">
        <xsd:enumeration value="Chromium">
        <xsd:enumeration value="Copper">
        <xsd:enumeration value="Iron">
        <xsd:enumeration value="IronPlusSilicon">
        <xsd:enumeration value="Germanium">
        <xsd:enumeration value="Hydrogen">
        <xsd:enumeration value="Potassium">
        <xsd:enumeration value="Magnesium">
        <xsd:enumeration value="Manganese">
        <xsd:enumeration value="Molybdenum">
        <xsd:enumeration value="Nitrogen">
        <xsd:enumeration value="Sodium">
        <xsd:enumeration value="Niobium">
        <xsd:enumeration value="Nickel">
        <xsd:enumeration value="Oxygen">
        <xsd:enumeration value="Phosphorus">
        <xsd:enumeration value="Lead">
        <xsd:enumeration value="Sulphur">
        <xsd:enumeration value="Antimony">
        <xsd:enumeration value="Selenium">
        <xsd:enumeration value="Silicon">
        <xsd:enumeration value="SiliciumOxyd">
        <xsd:enumeration value="Tin">
        <xsd:enumeration value="Tantalium">
        <xsd:enumeration value="Tellurium">
        <xsd:enumeration value="Titanium">
        <xsd:enumeration value="Vanadium">
        <xsd:enumeration value="Tungsten">
        <xsd:enumeration value="WasteContent">
        <xsd:enumeration value="Zinc">
        <xsd:enumeration value="Zirconium">
        <xsd:enumeration value="StorageTemperature">
        <xsd:enumeration value="TransportTemperature">
        <xsd:enumeration value="CargoOperatingTemperature">
        <xsd:enumeration value="TransportEmergencyTemperature">
        <xsd:enumeration value="TransportControlTemperature">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: DimensionType

DimensionType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( Measurement[MeasurementType] , DimensionCoded[DimensionCodeType] , DimensionCodedOther[xsd:string]? )

    Description: DimensionType is quantitative physical characteristic.

    Elements:

    • Measurement - is the quantitative value and unit of measure for the dimension.
    • DimensionCoded - contains a code qualifying the quantitative physical characteristic as being described by the dimension.
    • DimensionCodedOther - is used to specify a non-standard DimensionCode. This element is mandatory if the value of DimensionCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="DimensionType">
    <xsd:sequence>
        <xsd:element name="Measurement" type="MeasurementType">
        <xsd:element name="DimensionCoded" type="DimensionCodeType">
        <xsd:element minOccurs="0" name="DimensionCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: DiscountsType

DiscountsType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( DiscountPercent[PercentType]? , DiscountAmount[MonetaryValueType]? , DiscountDueDate[xsd:dateTime]? , DiscountDayOfMonth[xsd:int]? , DiscountTimeDue[TimeDueType]? )

    Description: DiscountsType is a container element that holds discount information as it pertains to the payment term

    Elements:

    • DiscountPercent - contains the percent discounted in the terms of the payment. If a discount percent is specified then DiscountAmount should not be used.
    • DiscountAmount - contains the amount to be discounted from the payment value. If a discount amount is specified then DiscountPercent should not be used.
    • DiscountDueDate - contains the date the amount has to paid by in order to receive the discount. This is only used in the case where the discount applies to a payment term.
    • DiscountDayOfMonth - contains the generic day of the month, for example, the 15th, which the amount has to be paid by in order to receive the discount.
    • DiscountTimeDue - provides a structured element that allows the discount due date to expressed in a period time from a specific occurence, such as reciept of the goods ordered.

[^]Code Fragment

    <xsd:complexType name="DiscountsType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="DiscountPercent" type="PercentType">
        <xsd:element minOccurs="0" name="DiscountAmount" type="MonetaryValueType">
        <xsd:element minOccurs="0" name="DiscountDueDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="DiscountDayOfMonth" type="xsd:int">
        <xsd:element minOccurs="0" name="DiscountTimeDue" type="TimeDueType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: DocumentTypeCodeType

DocumentTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • CertificateOfAnalysis - Certificate providing the values of an analysis.
    • CertificateOfConformity - Certificate certifying the conformity to predefined definitions.
    • CertificateOfQuality - Certificate certifying the quality of goods, services etc.
    • TestReport - Report providing the results of a test session.
    • ProductPerformanceReport - Report specifying the performance values of products.
    • ProductSpecificationReport - Report providing specification values of products.
    • ProcessDataReport - Reports on events during production process.
    • FirstSampleTestReport
    • PriceSalesCatalogue
    • PartyInformation - Document/message providing basic data concerning a party.
    • FederalLabelApproval - A pre-approved document relating to federal label approval requirements.
    • MillCertificate - Certificate certifying a specific quality of agricultural products.
    • PostReceipt - Document/message which evidences the transport of goods by post (e.g. mail, parcel, etc.).
    • WeightCertificate - Certificate certifying the weight of goods.
    • WeightList - Document/message specifying the weight of goods.
    • Certificate - Document by means of which the documentary credit applicant specifies the conditions for the certificate and by whom the certificate is to be issued.
    • CombinedCertificateOfValueAndOrigin - Document identifying goods in which the issuing authority expressly certifies that the goods originate in a specific country or part of, or group of countries. It also states the price and/or cost of the goods with the purpose of determining the customs origin.
    • MovementCertificateATr1 - Specific form of transit declaration issued by the exporter (movement certificate).
    • CertificateOfQuantity - Certificate certifying the quantity of goods, services etc.
    • QualityDataMessage - Usage of QALITY-message.
    • Query - Request information based on defined criteria.
    • ResponseToQuery - Self-explanatory.
    • StatusInformation - Information regarding the status of a related message.
    • Restow - Message/document identifying containers that have been unloaded and then reloaded onto the same means of transport.
    • ContainerDischargeList - Message/document itemising containers to be discharged from vessel.
    • CorporateSuperannuationContributionsAdvice - Document/message providing contributions advice used for corporate superannuation schemes.
    • IndustrySuperannuationContributionsAdvice - Document/message providing contributions advice used for superannuation schemes which are industry wide.
    • CorporateSuperannuationMemberMaintenanceMessage - Member maintenance message used for corporate superannuation schemes.
    • IndustrySuperannuationMemberMaintenanceMessage - Member maintenance message used for industry wide superannuation schemes.
    • LifeInsurancePayrollDeductionsAdvice - Payroll deductions advice used in the life insurance industry.
    • UnderbondRequest - A Message/document requesting to move cargo from one Customs control point to another.
    • UnderbondApproval - A message/document issuing Customs approval to move cargo from one Customs control point to another.
    • CertificateOfSealingOfExportMeatLockers - Document / message issued by the authority in the exporting country evidencing the sealing of export meat lockers.
    • CargoStatus - Message identifying the status of cargo.
    • InventoryReport - A message specifying information relating to held inventories.
    • IdentityCard - Official document to identify a person.
    • ResponseToATradeStatisticsMessage - Document/message in which the competent national authorities provide a declarant with an acceptance or a rejection about a received declaration for European statistical purposes.
    • VaccinationCertificate - Official document proving immunisation against certain diseases.
    • Passport - An official document giving permission to travel in foreign countries.
    • DrivingLicenceNational - An official document giving permission to drive a car in a given country.
    • DrivingLicenceInternational - An official document giving a native of one country permission to drive a vehicle in certain other countries.
    • FreePass - A document giving free access to a service.
    • SeasonTicket - A document giving access to a service for a determined period of time.
    • TransportStatusReport - A message to report the transport status and/or change in the transport status (i.e. event) between agreed parties.
    • TransportStatusRequest - A message to request a transport status report (e.g. through the International multimodal status report message IFSTA).
    • BankingStatus - A banking status document and/or message.
    • Extra-CommunityTradeStatisticalDeclaration - Document/message in which a declarant provides information about extra-Community trade of goods required by the body responsible for the collection of trade statistics. Trade by a country in the European Union with a country outside the European Union.
    • WrittenInstructionsInConformanceWithAdrArticleNumber - Written instructions relating to dangerous goods and defined in the European Agreement of Dangerous Transport by Road known as ADR (Accord europeen relatif au transport international des marchandises Dangereuses par Route).
    • DamageCertification - Official certification that damages to the goods to be transported have been discovered.
    • ValidatedPricedTender - A validated priced tender.
    • PriceSalesCatalogueResponse - A document providing a response to a previously sent price/sales catalogue.
    • PriceNegotiationResult - A document providing the result of price negotiations.
    • SafetyAndHazardDataSheet - Document or message to supply advice on a dangerous or hazardous material to industrial customers so as to enable them to take measures to protect their employees and the environment from any potential harmful effects from these material.
    • LegalStatementOfAnAccount - A statement of an account containing the booked items as in the ledger of the account servicing financial institution.
    • ListingStatementOfAnAccount - A statement from the account servicing financial institution containing items pending to be booked.
    • ClosingStatementOfAnAccount - Last statement of a period containing the interest calculation and the final balance of the last entry date.
    • TransportEquipmentOn-HireReport - Report on the movement of containers or other items of transport equipment to record physical movement activity and establish the beginning of a rental period.
    • TransportEquipmentOff-HireReport - Report on the movement of containers or other items of transport equipment to record physical movement activity and establish the end of a rental period.
    • Treatment-NilOutturn - No shortage, surplus or damaged outturn resulting from container vessel unpacking.
    • Treatment-Time-UpUnderbond - Movement type indicator: goods are moved under customs control for warehousing due to being time-up.
    • Treatment-UnderbondBySea - Movement type indicator: goods are to move by sea under customs control to a customs office where formalities will be completed.
    • Treatment-PersonalEffect - Cargo consists of personal effects.
    • Treatment-Timber - Cargo consists of timber.
    • PreliminaryCreditAssessment - Document/message issued either by a factor to indicate his preliminary credit assessment on a buyer, or by a seller to request a factor's preliminary credit assessment on a buyer.
    • CreditCover - Document/message issued either by a factor to give a credit cover on a buyer, or by a seller to request a factor's credit cover.
    • CurrentAccount - Document/message issued by a factor to indicate the money movements of a seller's or another factor's account with him.
    • CommercialDispute - Document/message issued by a party (usually the buyer) to indicate that one or more invoices or one or more credit notes are disputed for payment.
    • Chargeback - Document/message issued by a factor to a seller or to another factor to indicate that the rest of the amounts of one or more invoices uncollectable from buyers are charged back to clear the invoice(s) off the ledger.
    • Reassignment - Document/message issued by a factor to a seller or to another factor to reassign an invoice or credit note previously assigned to him.
    • CollateralAccount - Document message issued by a factor to indicate the movements of invoices, credit notes and payments of a seller's account.
    • RequestForPayment - Document/message issued by a creditor to a debtor to request payment of one or more invoices past due.
    • UnshipPermit - A message or document issuing permission to unship cargo.
    • StatisticalDefinitions - Transmission of one or more statistical definitions.
    • StatisticalData - Transmission of one or more items of data or data sets.
    • RequestForStatisticalData - Request for one or more items or data sets of statistical data.
    • Call-OffDelivery - Document/message to provide split quantities and delivery dates referring to a previous delivery instruction.
    • ConsignmentStatusReport - Message covers information about the consignment status.
    • InventoryMovementAdvice - Advice of inventory movements.
    • InventoryStatusAdvice - Advice of stock on hand.
    • DebitNoteRelatedToGoodsOrServices - Debit information related to a transaction for goods or services to the relevant party.
    • CreditNoteRelatedToGoodsOrServices - Document message used to provide credit information related to a transaction for goods or services to the relevant party.
    • MeteredServicesInvoice - Document/message claiming payment for the supply of metered services (e.g., gas, electricity, etc.) supplied to a fixed meter whose consumption is measured over a period of time.
    • CreditNoteRelatedToFinancialAdjustments - Document message for providing credit information related to financial adjustments to the relevant party, e.g., bonuses.
    • DebitNoteRelatedToFinancialAdjustments - Document/message for providing debit information related to financial adjustments to the relevant party.
    • CustomsManifest - Message/document identifying a customs manifest. The document itemises a list of cargo prepared by shipping companies from bills of landing and presented to customs for formal report of cargo.
    • VesselUnpackReport - A document code to indicate that the message being transmitted identifies all short and surplus cargoes off-loaded from a vessel at a specified discharging port.
    • GeneralCargoSummaryManifestReport - A document code to indicate that the message being transmitted is summary manifest information for general cargo.
    • ConsignmentUnpackReport - A document code to indicate that the message being transmitted is a consignment unpack report only.
    • MeatAndMeatBy-ProductsSanitaryCertificate - Document or message issued by the competent authority in the exporting country evidencing that meat or meat by- products comply with the requirements set by the importing country.
    • MeatFoodProductsSanitaryCertificate - Document or message issued by the competent authority in the exporting country evidencing that meat food products comply with the requirements set by the importing country.
    • PoultrySanitaryCertificate - Document or message issued by the competent authority in the exporting country evidencing that poultry products comply with the requirements set by the importing country.
    • HorsemeatSanitaryCertificate - Document or message issued by the competent authority in the exporting country evidencing that horsemeat products comply with the requirements set by the importing country.
    • CasingSanitaryCertificate - Document or message issued by the competent authority in the exporting country evidencing that casing products comply with the requirements set by the importing country.
    • PharmaceuticalSanitaryCertificate - Document or message issued by the competent authority in the exporting country evidencing that pharmaceutical products comply with the requirements set by the importing country.
    • InedibleSanitaryCertificate - Document or message issued by the competent authority in the exporting country evidencing that inedible products comply with the requirements set by the importing country.
    • ImpendingArrival - Notification of impending arrival details for vessel.
    • MeansOfTransportAdvice - Message reporting the means of transport used to carry goods or cargo.
    • ArrivalInformation - Message reporting the arrival details of goods or cargo.
    • CargoReleaseNotification - Message/document sent by the cargo handler indicating that the cargo has moved from a Customs controlled premise.
    • ExciseCertificate - Certificate asserting that the goods have been submitted to the excise authorities before departure from the exporting country or before delivery in case of import traffic.
    • RegistrationDocument - An official document providing registration details.
    • TaxNotification - Used to specify that the message is a tax notification.
    • TransportEquipmentDirectInterchangeReport - Report on the movement of containers or other items of transport equipment being exchanged, establishing relevant rental periods.
    • TransportEquipmentImpendingArrivalAdvice - Advice that containers or other items of transport equipment may be expected to be delivered to a certain location.
    • PurchaseOrder - Document/message issued within an enterprise to initiate the purchase of articles, materials or services required for the production or manufacture of goods to be offered for sale or otherwise supplied to customers.
    • TransportEquipmentDamageReport - Report of damaged items of transport equipment that have been returned.
    • TransportEquipmentMaintenanceAndRepairWorkEstimateAdvice - Advice providing estimates of transport equipment maintenance and repair costs.
    • TransportEquipmentEmptyReleaseInstruction - Instruction to release an item of empty transport equipment to a specified party or parties.
    • TransportMovementGateInReport - Report on the inward movement of cargo, containers or other items of transport equipment which have been delivered to a facility by an inland carrier.
    • ManufacturingInstructions - Document/message issued within an enterprise to initiate the manufacture of goods to be offered for sale.
    • TransportMovementGateOutReport - Report on the outward movement of cargo, containers or other items of transport equipment (either full or empty) which have been picked up by an inland carrier.
    • TransportEquipmentUnpackingInstruction - Instruction to unpack specified cargo from specified containers or other items of transport equipment.
    • TransportEquipmentUnpackingReport - Report on the completion of unpacking specified containers or other items of transport equipment.
    • TransportEquipmentPick-UpAvailabilityRequest - Request for confirmation that an item of transport equipment will be available for collection.
    • TransportEquipmentPick-UpAvailabilityConfirmation - Confirmation that an item of transport equipment is available for collection.
    • TransportEquipmentPick-UpReport - Report that an item of transport equipment has been collected.
    • TransportEquipmentShiftReport - Report on the movement of containers or other items of transport within a facility.
    • TransportDischargeInstruction - Instruction to unload specified cargo, containers or transport equipment from a means of transport.
    • TransportDischargeReport - Report on cargo, containers or transport equipment unloaded from a particular means of transport.
    • StoresRequisition - Document/message issued within an enterprise ordering the taking out of stock of goods.
    • TransportLoadingInstruction - Instruction to load cargo, containers or transport equipment onto a means of transport.
    • TransportLoadingReport - Report on completion of loading cargo, containers or other transport equipment onto a means of transport.
    • TransportEquipmentMaintenanceAndRepairWork - authorisation Authorisation to have transport equipment repaired or to have maintenance performed.
    • TransportDepartureReport - Report of the departure of a means of transport from a particular facility.
    • TransportEmptyEquipmentAdvice - Advice that an item or items of empty transport equipment are available for return.
    • TransportEquipmentAcceptanceOrder - Order to accept items of transport equipment which are to be delivered by an inland carrier (rail, road or barge) to a specified facility.
    • TransportEquipmentSpecialServiceInstruction - Instruction to perform a specified service or services on an item or items of transport equipment.
    • TransportEquipmentStockReport - Report on the number of items of transport equipment stored at one or more locations.
    • TransportCargoReleaseOrder - Order to release cargo or items of transport equipment to a specified party.
    • InvoicingDataSheet - Document/message issued within an enterprise containing data about goods sold, to be used as the basis for the preparation of an invoice.
    • TransportEquipmentPackingInstruction - Instruction to pack cargo into a container or other item of transport equipment.
    • CustomsClearanceNotice - Notification of customs clearance of cargo or items of transport equipment.
    • CustomsDocumentsExpirationNotice - Notice specifying expiration of Customs documents relating to cargo or items of transport equipment.
    • TransportEquipmentOn-HireRequest - Request for transport equipment to be made available for hire.
    • TransportEquipmentOn-HireOrder - Order to release empty items of transport equipment for on-hire to a lessee, and authorising collection by or on behalf of a specified party.
    • TransportEquipmentOff-HireRequest - Request to terminate the lease on an item of transport equipment at a specified time.
    • TransportEquipmentSurveyOrder - Order to perform a survey on specified items of transport equipment.
    • TransportEquipmentSurveyOrderResponse - Response to an order to conduct a survey of transport equipment.
    • TransportEquipmentSurveyReport - Survey report of specified items of transport equipment.
    • PackingInstructions - Document/message within an enterprise giving instructions on how goods are to be packed.
    • AdvisingItemsToBeBookedToAFinancialAccount - A document and/or message advising of items which have to be booked to a financial account.
    • TransportEquipmentMaintenanceAndRepairWorkEstimateOrder - Order to draw up an estimate of the costs of maintenance or repair of transport equipment.
    • TransportEquipmentMaintenanceAndRepairNotice - Report of transport equipment which has been repaired or has had maintenance performed.
    • EmptyContainerDispositionOrder - Order to make available empty containers.
    • CargoVesselDischargeOrder - Order that the containers or cargo specified are to be discharged from a vessel.
    • CargoVesselLoadingOrder - Order that specified cargo, containers or groups of containers are to be loaded in or on a vessel.
    • MultidropOrder - One purchase order that contains the orders of two or more vendors and the associated delivery points for each.
    • BailmentContract - A document authorizing the bailing of goods.
    • BasicAgreement - A document indicating an agreement containing basic terms and conditions applicable to future contracts between two parties.
    • InternalTransportOrder - Document/message giving instructions about the transport of goods within an enterprise.
    • Grant - A document indicating the granting of funds.
    • IndefiniteDeliveryIndefiniteQuantityContract - A document indicating a contract calling for the indefinite deliveries of indefinite quantities of goods.
    • IndefiniteDeliveryDefiniteQuantityContract - A document indicating a contract calling for indefinite deliveries of definite quantities.
    • RequirementsContract - A document indicating a requirements contract that authorizes the filling of all purchase requirements during a specified contract period.
    • TaskOrder - A document indicating an order that tasks a contractor to perform a specified function.
    • MakeOrBuyPlan - A document indicating a plan that identifies which items will be made and which items will be bought.
    • SubcontractorPlan - A document indicating a plan that identifies the manufacturer's subcontracting strategy for a specific contract.
    • CostDataSummary - A document indicating a summary of cost data.
    • CertifiedCostAndPriceData - A document indicating cost and price data whose accuracy has been certified.
    • WageDetermination - A document indicating a determination of the wages to be paid.
    • ContractFundsStatusReportCfsr - A report to provide the status of funds applicable to the contract.
    • CertifiedInspectionAndTestResults - A certification as to the accuracy of inspection and test results.
    • MaterialInspectionAndReceivingReport - A report that is both an inspection report for materials and a receiving document.
    • PurchasingSpecification - A document indicating a specification used to purchase an item.
    • PaymentOrPerformanceBond - A document indicating a bond that guarantees the payment of monies or a performance.
    • ContractSecurityClassificationSpecification - A document that indicates the specification contains the security and classification requirements for a contract.
    • ManufacturingSpecification - A document indicating the specification of how an item is to be manufactured.
    • BuyAmericaCertificateOfCompliance - A document certifying that more than 50 percent of the cost of an item is attributed to US origin.
    • ContainerOff-HireNotice - Notice to return leased containers.
    • CargoAcceptanceOrder - Order to accept cargo to be delivered by a carrier.
    • Pick-UpNotice - Notice specifying the pick-up of released cargo or containers from a certain address.
    • AuthorisationToPlanAndSuggestOrders - Document or message that authorises receiver to plan orders, based on information in this message, and send these orders as suggestions to the sender.
    • AuthorisationToPlanAndShipOrders - Document or message that authorises receiver to plan and ship orders based on information in this message.
    • Drawing - The document or message is a drawing.
    • CostPerformanceReportCprFormat2 - A report identifying the cost performance on a contract at specified levels of the work breakdown structure (format 2 - organizational categories).
    • CostScheduleStatusReportCssr - A report providing the status of the cost and schedule applicable to a contract.
    • CostPerformanceReportCprFormat1 - A report identifying the cost performance on a contract including the current month's values at specified levels of the work breakdown structure (format 1 - work breakdown structure).
    • CostPerformanceReportCprFormat3 - A report identifying the cost performance on a contract that summarizes changes to a contract over a given reporting period with beginning and ending values (format 3 - baseline).
    • CostPerformanceReportCprFormat4 - A report identifying the cost performance on a contract including forecasts of labour requirements for the remaining portion of the contract (format 4 - staffing).
    • CostPerformanceReportCprFormat5 - A report identifying the cost performance on a contract that summarizes cost or schedule variances (format 5 - explanations and problem analysis).
    • ProgressiveDischargeReport - Document or message progressively issued by the container terminal operator in charge of discharging a vessel identifying containers that have been discharged from a specific vessel at that point in time.
    • BalanceConfirmation - Confirmation of a balance at an entry date.
    • ContainerStrippingOrder - Order to unload goods from a container.
    • ContainerStuffingOrder - Order to stuff specified goods or consignments in a container.
    • ConveyanceDeclarationArrival - Declaration to the public authority upon arrival of the conveyance.
    • ConveyanceDeclarationDeparture - Declaration to the public authority upon departure of the conveyance.
    • ConveyanceDeclarationCombined - Combined declaration of arrival and departure to the public authority.
    • ProjectRecoveryPlan - A project plan for recovery after a delay or problem resolution.
    • ProjectProductionPlan - A project plan for the production of goods.
    • StatisticalAndOtherAdministrativeInternalDocuments - Documents/messages issued within an enterprise for the for the purpose of collection of production and other internal statistics, and for other administration purposes.
    • ProjectMasterSchedule - A high level, all encompassing master schedule of activities to complete a project.
    • PricedAlternateTenderBillOfQuantity - A priced tender based upon an alternate specification.
    • EstimatedPricedBillOfQuantity - An estimate based upon a detailed, quantity based specification (bill of quantity).
    • DraftBillOfQuantity - Document/message providing a draft bill of quantity, issued in an unpriced form.
    • DocumentaryCreditCollectionInstruction - Instruction for the collection of the documentary credit.
    • RequestForAnAmendmentOfADocumentaryCredit - Request for an amendment of a documentary credit.
    • DocumentaryCreditAmendmentInformation - Documentary credit amendment information.
    • AdviceOfAnAmendmentOfADocumentaryCredit - Advice of an amendment of a documentary credit.
    • ResponseToAnAmendmentOfADocumentaryCredit - Response to an amendment of a documentary credit.
    • DocumentaryCreditIssuanceInformation - Provides information on documentary credit issuance.
    • DirectPaymentValuationRequest - Request to establish a direct payment valuation.
    • DirectPaymentValuation - Document/message addressed, for instance, by a general contractor to the owner, in order that a direct payment be made to a subcontractor.
    • ProvisionalPaymentValuation - Document/message establishing a provisional payment valuation.
    • PaymentValuation - Document/message establishing the financial elements of a situation of works.
    • QuantityValuation - Document/message providing a confirmed assessment, by quantity, of the completed work for a construction contract.
    • QuantityValuationRequest - Document/message providing an initial assessment, by quantity, of the completed work for a construction contract.
    • ContractBillOfQuantities-Boq - Document/message providing a formal specification identifying quantities and prices that are the basis of a contract for a construction project. BOQ means: Bill of quantity.
    • UnpricedBillOfQuantity - Document/message providing a detailed, quantity based specification, issued in an unpriced form to invite tender prices.
    • PricedTenderBoq - Document/message providing a detailed, quantity based specification, updated with prices to form a tender submission for a construction contract. BOQ means: Bill of quantity.
    • Enquiry - Document/message issued by a party interested in the purchase of goods specified therein and indicating particular, desirable conditions regarding delivery terms, etc., addressed to a prospective supplier with a view to obtaining an offer.
    • InterimApplicationForPayment - Document/message containing a provisional assessment in support of a request for payment for completed work for a construction contract.
    • AgreementToPay - Document/message in which the debtor expresses the intention to pay.
    • RequestForFinancialCancellation - The message is a request for financial cancellation.
    • Pre-AuthorisedDirectDebits - The message contains pre-authorised direct debit(s).
    • LetterOfIntent - Document/message by means of which a buyer informs a seller that the buyer intends to enter into contractual negotiations.
    • ApprovedUnpricedBillOfQuantity - Document/message providing an approved detailed, quantity based specification (bill of quantity), in an
    • PaymentValuationForUnscheduledItems - A payment valuation for unscheduled items.
    • FinalPaymentRequestBasedOnCompletionOfWork - The final payment request of a series of payment requests submitted upon completion of all the work.
    • PaymentRequestForCompletedUnits - A request for payment for completed units.
    • Order - Document/message by means of which a buyer initiates a transaction with a seller involving the supply of goods or services as specified, according to conditions set out in an offer, or otherwise known to the buyer.
    • BlanketOrder - Usage of document/message for general order purposes with later split into quantities and delivery dates and maybe delivery locations.
    • SpotOrder - Document/message ordering the remainder of a production's batch.
    • LeaseOrder - Document/message for goods in leasing contracts.
    • RushOrder - Document/message for urgent ordering.
    • RepairOrder - Document/message to order repair of goods.
    • CallOffOrder - Document/message to provide split quantities and delivery dates referring to a previous blanket order.
    • ConsignmentOrder - Order to deliver goods into stock with agreement on payment when goods are sold out of this stock.
    • SampleOrder - Document/message to order samples.
    • SwapOrder - Document/message informing buyer or seller of the replacement of goods previously ordered.
    • PurchaseOrderChangeRequest - Change to an purchase order already sent.
    • PurchaseOrderResponse - Response to an purchase order already received.
    • HireOrder - Document/message for hiring human resources or renting goods or equipment.
    • SparePartsOrder - Document/message to order spare parts.
    • CampaignPriceSalesCatalogue - A price/sales catalogue containing special prices which are valid only for a specified period or under specified conditions.
    • ContainerList - Document or message issued by party identifying the containers for which they are responsible.
    • DeliveryForecast - A message which enables the transmission of delivery or product forecasting requirements.
    • CrossDockingServicesOrder - A document or message to order cross docking services.
    • Non-Pre-AuthorisedDirectDebits - The message contains non-pre-authorised direct debit(s).
    • RejectedDirectDebits - The message contains rejected direct debit(s).
    • DeliveryInstructions - Document/message issued by a buyer giving instructions regarding the details of the delivery of goods ordered.
    • DeliverySchedule - Usage of DELFOR-message.
    • DeliveryJust-In-Time - Usage of DELJIT-message.
    • Pre-AuthorisedDirectDebitRequests - The message contains pre-authorised direct debit request(s).
    • Non-Pre-AuthorisedDirectDebitRequests - The message contains non-pre-authorised direct debit request(s).
    • DeliveryRelease - Document/message issued by a buyer releasing the despatch of goods after receipt of the Ready for despatch advice from the seller.
    • SettlementOfALetterOfCredit - Settlement of a letter of credit.
    • BankToBankFundsTransfer - The message is a bank to bank funds transfer.
    • CustomerPaymentOrders - The message contains customer payment order(s).
    • LowValuePaymentOrders - The message contains low value payment order(s) only.
    • CrewListDeclaration - Declaration regarding crew members aboard the conveyance.
    • Inquiry - This is a request for information.
    • ResponseToPreviousBankingStatusMessage - A response to a previously sent banking status message.
    • ProjectMasterPlan - A high level, all encompassing master plan to complete a project.
    • ProjectPlan - A plan for project work to be completed.
    • ProjectSchedule - A schedule of project activities to be completed.
    • ProjectPlanningAvailableResources - Available resources for project planning purposes.
    • ProjectPlanningCalendar - Work calendar information for project planning purposes.
    • StandingOrder - An order to supply fixed quantities of products at fixed regular intervals.
    • CargoMovementEventLog - A document detailing times and dates of events pertaining to a cargo movement.
    • CargoAnalysisVoyageReport - An analysis of the cargo for a voyage.
    • SelfBilledCreditNote - A document which indicates that the customer is claiming credit in a self billing environment.
    • ConsolidatedCreditNote-GoodsAndServices - Credit note for goods and services that covers multiple transactions involving more than one invoice.
    • InventoryAdjustmentStatusReport - A message detailing statuses related to the adjustment of inventory.
    • TransportEquipmentMovementInstruction - Instruction to perform one or more different movements of transport equipment.
    • TransportEquipmentMovementReport - Report on one or more different movements of transport equipment.
    • TransportEquipmentStatusChangeReport - Report on one or more changes of status associated with an item or items of transport equipment.
    • FumigationCertificate - Certificate attesting that fumigation has been performed.
    • WineCertificate - Certificate attesting to the quality, origin or appellation of wine.
    • WoolHealthCertificate - Certificate attesting that wool is free from specified risks to human or animal health.
    • DeliveryNote - Paper document attached to a consignment informing the receiving party about contents of this consignment.
    • PackingList - Document/message specifying the distribution of goods in individual packages (in trade environment the despatch advice message is used for the packing list).
    • NewCodeRequest - Requesting a new code.
    • CodeChangeRequest - Request a change to an existing code.
    • SimpleDataElementRequest - Requesting a new simple data element.
    • SimpleDataElementChangeRequest - Request a change to an existing simple data element.
    • CompositeDataElementRequest - Requesting a new composite data element.
    • CompositeDataElementChangeRequest - Request a change to an existing composite data element.
    • SegmentRequest - Request a new segment.
    • SegmentChangeRequest - Requesting a change to an existing segment.
    • NewMessageRequest - Request for a new message (NMR).
    • MessageInDevelopmentRequest - Requesting a Message in Development (MiD).
    • ModificationOfExistingMessage - Requesting a change to an existing message.
    • TrackingNumberAssignmentReport - Report of assigned tracking numbers.
    • UserDirectoryDefinition - Document/message defining the contents of a user directory set or parts thereof.
    • UnitedNationsStandardMessageRequest - Requesting a United Nations Standard Message (UNSM).
    • ServiceDirectoryDefinition - Document/message defining the contents of a service directory set or parts thereof.
    • StatusReport - Message covers information about the status.
    • KanbanSchedule - Message to describe a Kanban schedule.
    • ProductDataMessage - A message to submit master data, a set of data that is rarely changed, to identify and describe products a supplier offers to their (potential) customer or buyer.
    • AClaimForPartsAndOrLabourCharges - A claim for parts and/or labour charges incurred .
    • DeliveryScheduleResponse - A message providing a response to a previously transmitted delivery schedule.
    • InspectionRequest - A message requesting a party to inspect items.
    • InspectionReport - A message informing a party of the results of an inspection.
    • ApplicationAcknowledgementAndErrorReport - A message used by an application to acknowledge reception of a message and/or to report any errors.
    • PriceVariationInvoice - An invoice which requests payment for the difference in price between an original invoice and the result of the application of a price variation formula.
    • CreditNoteForPriceVariation - A credit note which is issued against a price variation invoice.
    • InstructionToCollect - A message instructing a party to collect goods.
    • DangerousGoodsList - Listing of all details of dangerous goods carried.
    • RegistrationRenewal - Code specifying the continued validity of previously submitted registration information.
    • RegistrationChange - Code specifying the modification of previously submitted registration information.
    • ResponseToRegistration - Code specifying a response to an occurrence of a registration message.
    • ImplementationGuideline - A document specifying the criterion and format for exchanging information in an electronic data interchange syntax.
    • RequestForTransfer - Document/message is a request for transfer.
    • CostPerformanceReport - A report to convey cost performance data for a project or contract.
    • ApplicationErrorAndAcknowledgement - A message to inform a message issuer that a previously sent message has been received by the addressee's application, or that a previously sent message has been rejected by the addressee's application.
    • CashPoolFinancialStatement - A financial statement for a cash pool.
    • SequencedDeliverySchedule - Message to describe a sequence of product delivery.
    • DelcredereCreditNote - A credit note sent to the party paying on behalf of a number of buyers.
    • OfferQuotation - Document/message which, with a view to concluding a contract, sets out the conditions under which the goods are offered.
    • RequestForQuote - Document/message requesting a quote on specified goods or services.
    • AcknowledgementMessage - Message providing acknowledgement information at the business application level concerning the processing of a message.
    • ApplicationErrorMessage - Message indicating that a message was rejected due to errors encountered at the application level.
    • CargoMovementVoyageSummary - A consolidated voyage summary which contains the information in a certificate of analysis, a voyage analysis and a cargo movement time log for a voyage.
    • Contract - Document/message evidencing an agreement between the seller and the buyer for the supply of goods or services; its effects are equivalent to those of an order followed by an acknowledgement of order.
    • ApplicationForUsageOfBerthOrMooringFacilities - Document to apply for usage of berth or mooring facilities.
    • ApplicationForDesignationOfBerthingPlaces - Document to apply for designation of berthing places.
    • ApplicationForShiftingFromTheDesignatedPlaceInPort - Document to apply for shifting from the designated place in port.
    • SupplementaryDocumentForApplicationForCargoOperationOfDangerousGoods - Supplementary document to apply for cargo operation of dangerous goods.
    • AcknowledgementOfOrder - Document/message acknowledging an undertaking to fulfil an order and confirming conditions or acceptance of conditions.
    • SupplementaryDocumentForApplicationForTransportOfDangerousGoods - Supplementary document to apply for transport of dangerous goods.
    • OpticalCharacterReadingOcrPayment - Payment effected by an Optical Character Reading (OCR) document.
    • PreliminarySalesReport - Preliminary sales report sent before all the information is available.
    • TransportEmergencyCard - Official document specifying, for a given dangerous goods item, information such as nature of hazard, protective devices, actions to be taken in case of accident, spillage or fire and first aid to be given.
    • ProformaInvoice - Document/message serving as a preliminary invoice, containing - on the whole - the same information as the final invoice, but not actually claiming payment.
    • PartialInvoice
    • OperatingInstructions
    • NameProductPlate - Plates on goods identifying and describing an article.
    • Co-InsuranceCedingBordereau - The document or message contains a bordereau describing co-insurance ceding information.
    • RequestForDeliveryInstructions - Document/message issued by a supplier requesting instructions from the buyer regarding the details of the delivery of goods ordered.
    • CommercialInvoiceWhichIncludesAPackingList - Commercial transaction (invoice) will include a packing list.
    • TradeData - Document/message is for trade data.
    • CustomsDeclarationForCargoExamination - Declaration provided to customs for cargo examination.
    • CustomsDeclarationForCargoExaminationAlternate - Alternate declaration provided to customs for cargo examination.
    • BookingRequest - Document/message issued by a supplier to a carrier requesting space to be reserved for a specified consignment, indicating desirable conveyance, despatch time, etc.
    • CustomsCrewAndConveyance - Document/message contains information regarding the crew list and conveyance.
    • CustomsSummaryDeclarationWithCommercialDetailAlternate - Alternate Customs declaration summary with commercial transaction details.
    • ItemsBookedToAFinancialAccountReport - A message reporting items which have been booked to a financial account.
    • ReportOfTransactionsWhichNeedFurtherInformationFromTheReceiver - A message reporting transactions which need further information from the receiver.
    • ShippingInstructions - Document/message advising details of cargo and exporter's requirements for its physical movement.
    • ShippersLetterOfInstructionsAir - Document/message issued by a consignor in which he gives details of a consignment of goods that enables an airline or its agent to prepare an air waybill.
    • ReportOfTransactionsForInformationOnly - A message reporting transactions for information only.
    • CartageOrderLocalTransport - Document/message giving instructions regarding local transport of goods, e.g. from the premises of an enterprise to those of a carrier undertaking further transport.
    • EdiAssociatedObjectAdministrationMessage - A message giving additional information about the exchange of an EDI associated object.
    • ReadyForDespatchAdvice - Document/message issued by a supplier informing a buyer that goods ordered are ready for despatch.
    • SummarySalesReport - Sales report containing summaries for several earlier sent sales reports.
    • OrderStatusEnquiry - A message enquiring the status of previously sent orders.
    • OrderStatusReport - A message reporting the status of previously sent orders.
    • DeclarationRegardingTheInwardAndOutwardMovementOfVessel - Document to declare inward and outward movement of a vessel.
    • DespatchOrder - Document/message issued by a supplier initiating the despatch of goods to a buyer (consignee).
    • DespatchAdvice - Document/message by means of which the seller or consignor informs the consignee about the despatch of goods.
    • NotificationOfUsageOfBerthOrMooringFacilities - Document to notify usage of berth or mooring facilities.
    • ApplicationForVesselsEnteringIntoPortAreaInNight-Time - Document to apply for vessel's entering into port area in night-time.
    • NotificationOfEmergencyShiftingFromTheDesignatedPlaceInPort - Document to notify shifting from designated place in port once secured at the designated place.
    • CustomsSummaryDeclarationWithoutCommercialDetailAlternate - Alternate Customs declaration summary without any commercial transaction details.
    • PerformanceBond - A document that guarantees performance.
    • PaymentBond - A document that guarantees the payment of monies.
    • AdviceOfDistributionOfDocuments - Document/message in which the party responsible for the issue of a set of trade documents specifies the various recipients of originals and copies of these documents, with an indication of the number of copies distributed to each of them.
    • CommercialInvoice - Document/message claiming payment for goods or services supplied under conditions agreed between seller and buyer.
    • CreditNote - Document/message for providing credit information to the relevant party.
    • CommissionNote - Document/message in which a seller specifies the amount of commission, the percentage of the invoice amount, or some other basis for the calculation of the commission to which a sales agent is entitled.
    • DebitNote - Document/message for providing debit information to the relevant party.
    • CorrectedInvoice - Commercial invoice that includes revised information differing from an earlier submission of the same invoice.
    • ConsolidatedInvoice - Commercial invoice that covers multiple transactions involving more than one vendor.
    • PrepaymentInvoice - An invoice to pay amounts for goods and services in advance; these amounts will be subtracted from the final invoice.
    • HireInvoice - Document/message for invoicing the hiring of human resources or renting goods or equipment.
    • TaxInvoice - An invoice for tax purposes.
    • Self-BilledInvoice - An invoice the invoicee is producing instead of the seller.
    • DelcredereInvoice - An invoice sent to the party paying for a number of buyers.
    • FactoredInvoice - Invoice assigned to a third party for collection.
    • LeaseInvoice - Usage of INVOIC-message for goods in leasing contracts.
    • ConsignmentInvoice - Commercial invoice that covers a transaction other than one involving a sale.
    • FactoredCreditNote - Credit note related to assigned invoice(s).
    • CommercialAccountSummaryResponse - A document providing a response to a previously sent commercial account summary message.
    • CrossDockingDespatchAdvice - Document by means of which the supplier or consignor informs the buyer, consignee or the distribution centre about the despatch of goods for cross docking.
    • TransshipmentDespatchAdvice - Document by means of which the supplier or consignor informs the buyer, consignee or the distribution centre about the despatch of goods for transshipment.
    • ExceptionalOrder - An order which falls outside the framework of an agreement.
    • TransshipmentOrder - An order requesting the supply of products packed according to the final delivery point which will be moved across a dock in a distribution centre without further handling.
    • CrossDockingOrder - An order requesting the supply of products which will be de-consolidated in the distribution centre and re- consolidated according to final delivery location.
    • MeansOfTransportationAvailabilityInformation - Information giving the various availabilities of a means of transportation.
    • MeansOfTransportationScheduleInformation - Information giving the various schedules of a means of transportation.
    • TransportEquipmentDeliveryNotice - Notification regarding the delivery of transport equipment.
    • InstructionsForBankTransfer - Document/message containing instructions from a customer to his bank to pay an amount in a specified currency to a nominated party in another country by a method either specified (e.g. teletransmission, air mail) or left to the discretion of the bank.
    • ApplicationForBankersDraft - Application by a customer to his bank to issue a banker's draft stating the amount and currency of the draft, the name of the payee and the place and country of payment.
    • CollectionPaymentAdvice - Document/message whereby a bank advises that a collection has been paid, giving details and methods of funds disposal.
    • DocumentaryCreditPaymentAdvice - Document/message whereby a bank advises payment under a documentary credit.
    • DocumentaryCreditAcceptanceAdvice - Document/message whereby a bank advises acceptance under a documentary credit.
    • DocumentaryCreditNegotiationAdvice - Document/message whereby a bank advises negotiation under a documentary credit.
    • ApplicationForBankersGuarantee - Document/message whereby a customer requests his bank to issue a guarantee in favour of a nominated party in another country, stating the amount and currency and the specific conditions of the guarantee.
    • BankersGuarantee - Document/message in which a bank undertakes to pay out a limited amount of money to a designated party, on conditions stated therein (other than those laid down in the Uniform Customs Practice).
    • DocumentaryCreditLetterOfIndemnity - Document/message in which a beneficiary of a documentary credit accepts responsibility for non-compliance with the terms and conditions of the credit, and undertakes to refund the money received under the credit, with interest and charges accrued.
    • PreadviceOfACredit - Preadvice indicating a credit to happen in the future.
    • CollectionOrder - Document/message whereby a bank is instructed (or requested) to handle financial and/or commercial documents in order to obtain acceptance and/or payment, or to deliver documents on such other terms and conditions as may be specified.
    • DocumentsPresentationForm - Document/message whereby a draft or similar instrument and/or commercial documents are presented to a bank for acceptance, discounting, negotiation, payment or collection, whether or not against a documentary credit.
    • PaymentOrder - Document/message containing information needed to initiate the payment. It may cover the financial settlement for one or more commercial trade transactions. A payment order is an instruction to the ordered bank to arrange for the payment of one specified amount to the beneficiary.
    • ExtendedPaymentOrder - Document/message containing information needed to initiate the payment. It may cover the financial settlement for several commercial trade transactions, which it is possible to specify in a special payments detail part. It is an instruction to the ordered bank to arrange for the payment of one specified amount to the beneficiary.
    • MultiplePaymentOrder - Document/message containing a payment order to debit one or more accounts and to credit one or more beneficiaries.
    • CreditAdvice - Document/message sent by an account servicing institution to one of its account owners, to inform the account owner of an entry which has been or will be credited to its account for a specified amount on the date indicated.
    • ExtendedCreditAdvice - Document/message sent by an account servicing institution to one of its account owners, to inform the account owner of an entry that has been or will be credited to its account for a specified amount on the date indicated. It provides extended commercial information concerning the relevant remittance advice.
    • DebitAdvice - Advice on a debit.
    • ReversalOfDebit - Reversal of debit accounting entry by bank.
    • ReversalOfCredit - Reversal of credit accounting entry by bank.
    • DocumentaryCreditApplication - Document/message whereby a bank is requested to issue a documentary credit on the conditions specified therein.
    • DocumentaryCredit - Document/message in which a bank states that it has issued a documentary credit under which the beneficiary is to obtain payment, acceptance or negotiation on compliance with certain terms and conditions and against presentation of stipulated documents and such drafts as may be specified. The credit may or may not be confirmed by another bank.
    • DocumentaryCreditNotification - Document/message issued by an advising bank in order to transmit a documentary credit to a beneficiary, or to another advising bank.
    • DocumentaryCreditTransferAdvice - Document/message whereby a bank advises that (part of) a documentary credit is being or has been transferred in favour of a second beneficiary.
    • DocumentaryCreditAmendmentNotification - Document/message whereby a bank advises that the terms and conditions of a documentary credit have been amended.
    • DocumentaryCreditAmendment - Document/message whereby a bank notifies a beneficiary of the details of an amendment to the terms and conditions of a documentary credit.
    • RemittanceAdvice - Document/message advising of the remittance of payment.
    • BankersDraft - Draft drawn in favour of a third party either by one bank on another bank, or by a branch of a bank on its head office (or vice versa) or upon another branch of the same bank. In either case, the draft should comply with the specifications laid down for cheques in the country in which it is to be payable.
    • BillOfExchange - Document/message, issued and signed in conformity with the applicable legislation, which contains an unconditional order whereby the drawer directs the drawee to pay a definite sum of money to the payee or to his order, on demand or at a definite time, against the surrender of the document itself.
    • PromissoryNote - Document/message, issued and signed in conformity with the applicable legislation, which contains an unconditional promise whereby the maker undertakes to pay a definite sum of money to the payee or to his order, on demand or at a definite time, against the surrender of the document itself.
    • FinancialStatementOfAccount - Statement giving the status of a financial account. Note: 1. This code value will be removed effective with directory D.00B.
    • StatementOfAccountMessage - Usage of STATAC-message.
    • InsuranceCertificate - Document/message issued to the insured certifying that insurance has been effected and that a policy has been issued. Such a certificate for a particular cargo is primarily used when good are insured under the terms of a floating or an open policy; at the request of the insured it can be exchanged for a policy.
    • InsurancePolicy - Document/message issued by the insurer evidencing an agreement to insure and containing the conditions of the agreement concluded whereby the insurer undertakes for a specific fee to indemnify the insured for the losses arising out of the perils and accidents specified in the contract.
    • InsuranceDeclarationSheetBordereau - A document/message used when an insured reports to his insurer details of individual shipments which are covered by an insurance contract - an open cover or a floating policy - between the parties.
    • InsurersInvoice - Document/message issued by an insurer specifying the cost of an insurance which has been effected and claiming payment therefore.
    • CoverNote - Document/message issued by an insurer (insurance broker, agent, etc.) to notify the insured that his insurance have been carried out.
    • ForwardingInstructions - Document/message issued to a freight forwarder, giving instructions regarding the action to be taken by the forwarder for the forwarding of goods described therein.
    • ForwardersAdviceToImportAgent - Document/message issued by a freight forwarder in an exporting country advising his counterpart in an importing country about the forwarding of goods described therein.
    • ForwardersAdviceToExporter - Document/message issued by a freight forwarder informing an exporter of the action taken in fulfillment of instructions received.
    • ForwardersInvoice - Invoice issued by a freight forwarder specifying services rendered and costs incurred and claiming payment therefore.
    • ForwardersCertificateOfReceipt - Non-negotiable document issued by a forwarder to certify that he has assumed control of a specified consignment, with irrevocable instructions to send it to the consignee indicated in the document or to hold it at his disposal. E.g. FIATA-FCR.
    • ShippingNote - Document/message provided by the shipper or his agent to the carrier, multimodal transport operator, terminal or other receiving authority, giving information about export consignments offered for transport, and providing for the necessary receipts and declarations of liability. (Sometimes a multipurpose cargo handling document also fulfilling the functions of document 632, 633, 650 and 655).
    • ForwardersWarehouseReceipt - Document/message issued by a forwarder acting as Warehouse Keeper acknowledging receipt of goods placed in a warehouse, and stating or referring to the conditions which govern the warehousing and the release of goods. The document contains detailed provisions regarding the rights of holders-by-endorsement, transfer of ownership, etc. E.g. FIATA-FWR.
    • GoodsReceipt - Document/message issued by a port, warehouse/shed, or terminal operator acknowledging receipt of goods specified therein on conditions stated or referred to in the document.
    • PortChargesDocuments - Documents/messages specifying services rendered, storage and handling costs, demurrage and other charges due to the owner of goods described therein.
    • WarehouseWarrant - Negotiable receipt document, issued by a Warehouse Keeper to a person placing goods in a warehouse and conferring title to the goods stored.
    • DeliveryOrder - Document/message issued by a party entitled to authorize the release of goods specified therein to a named consignee, to be retained by the custodian of the goods.
    • HandlingOrder - Document/message issued by a cargo handling organization (port administration, terminal operator, etc.) for the removal or other handling of goods under their care.
    • GatePass - Document/message authorizing goods specified therein to be brought out of a fenced-in port or terminal area.
    • Waybill - Non-negotiable document evidencing the contract for the transport of cargo.
    • UniversalMultipurposeTransportDocument - Document/message evidencing a contract of carriage covering the movement of goods by any mode of transport, or combination of modes, for national as well as international transport, under any applicable international convention or national law and under the conditions of carriage of any carrier or transport operator undertaking or arranging the transport referred to in the document.
    • GoodsReceiptCarriage - Document/message issued by a carrier or a carrier's agent, acknowledging receipt for carriage of goods specified therein on conditions stated or referred to in the document, enabling the carrier to issue a transport document.
    • HouseWaybill - The document made out by an agent/consolidator which evidences the contract between the shipper and the agent/consolidator for the arrangement of carriage of goods.
    • MasterBillOfLading - A bill of lading issued by the master of a vessel (in actuality the owner or charterer of the vessel). It could cover a number of house bills.
    • BillOfLading - Negotiable document/message which evidences a contract of carriage by sea and the taking over or loading of goods by carrier, and by which carrier undertakes to deliver goods against surrender of the document. A provision in the document that goods are to be delivered to the order of a named person, or to order, or to bearer, constitutes such an undertaking.
    • BillOfLadingOriginal - The original of the bill of lading issued by a transport company. When issued by the maritime industry it could signify ownership of the cargo.
    • BillOfLadingCopy - A copy of the bill of lading issued by a transport company.
    • EmptyContainerBill - Bill of lading indicating an empty container.
    • TankerBillOfLading - Document which evidences a transport of liquid bulk cargo.
    • SeaWaybill - Non-negotiable document which evidences a contract for the carriage of goods by sea and the taking over of the goods by the carrier, and by which the carrier undertakes to deliver the goods to the consignee named in the document.
    • InlandWaterwayBillOfLading - Negotiable transport document made out to a named person, to order or to bearer, signed by the carrier and handed to the sender after receipt of the goods.
    • Non-NegotiableMaritimeTransportDocumentGeneric - Non-negotiable document which evidences a contract for the carriage of goods by sea and the taking over or loading of the goods by the carrier, and by which the carrier undertakes to deliver the goods to the consignee named in the document. E.g. Sea waybill. Remark: Synonymous with "straight" or "non-negotiable Bill of lading" used in certain countries, e.g. Canada.
    • MatesReceipt - Document/message issued by a ship's officer to acknowledge that a specified consignment has been received on board a vessel, and the apparent condition of the goods; enabling the carrier to issue a Bill of lading.
    • HouseBillOfLading - The bill of lading issued not by the carrier but by the freight forwarder/consolidator known by the carrier.
    • LetterOfIndemnityForNon-SurrenderOfBillOfLading - Document/message issued by a commercial party or a bank of an insurance company accepting responsibility to the beneficiary of the indemnity in accordance with the terms thereof.
    • ForwardersBillOfLading - Non-negotiable document issued by a freight forwarder evidencing a contract for the carriage of goods by sea and the taking over or loading of the goods by the freight forwarder, and by which the freight forwarder undertakes to deliver the goods to the consignee named in the document.
    • RailConsignmentNoteGenericTerm - Transport document constituting a contract for the carriage of goods between the sender and the carrier (the railway). For international rail traffic, this document must conform to the model prescribed by the international conventions concerning carriage of goods by rail, e.g. CIM Convention, SMGS Convention.
    • RoadList-Smgs - Accounting document, one copy of which is drawn up for each consignment note; it accompanies the consignment over the whole route and is a rail transport document.
    • EscortOfficialRecognition - Document/message which gives right to the owner to exert all functions normally transferred to a guard in a train by which an escorted consignment is transported.
    • RechargingDocument - Fictitious transport document regarding a previous transport, enabling a carrier's agent to give to another carrier's agent (in a different country) the possibility to collect charges relating to the original transport (rail environment).
    • RoadConsignmentNote - Transport document/message which evidences a contract between a carrier and a sender for the carriage of goods by road (generic term). Remark: For international road traffic, this document must contain at least the particulars prescribed by the convention on the contract for the international carriage of goods by road (CMR).
    • AirWaybill - Document/message made out by or on behalf of the shipper which evidences the contract between the shipper and carrier(s) for carriage of goods over routes of the carrier(s) and which is identified by the airline prefix issuing the document plus a serial (IATA).
    • MasterAirWaybill - Document/message made out by or on behalf of the agent/consolidator which evidences the contract between the agent/consolidator and carrier(s) for carriage of goods over routes of the carrier(s) for a consignment consisting of goods originated by more than one shipper (IATA).
    • SubstituteAirWaybill - A temporary air waybill which contains only limited information because of the absence of the original.
    • CrewsEffectsDeclaration - Declaration to Customs regarding the personal effects of crew members aboard the conveyance; equivalent to IMO FAL 4.
    • PassengerList - Declaration to Customs regarding passengers aboard the conveyance; equivalent to IMO FAL 6.
    • DeliveryNoticeRailTransport - Document/message created by the consignor or by the departure station, joined to the transport or sent to the consignee, giving the possibility to the consignee or the arrival station to attest the delivery of the goods. The document must be returned to the consignor or to the departure station.
    • DespatchNotePostParcels - Document/message which, according to Article 106 of the "Agreement concerning Postal Parcels" under the UPU convention, is to accompany post parcels.
    • MultimodalCombinedTransportDocumentGeneric - A transport document used when more than one mode of transportation is involved in the movement of cargo. It is a contract of carriage and receipt of the cargo for a multimodal transport. It indicates the place where the responsible transport company in the move takes responsibility for the cargo, the place where the responsibility of this transport company in the move ends and the conveyances involved.
    • ThroughBillOfLading - Bill of lading which evidences a contract of carriage from one place to another in separate stages of which at least one stage is a sea transit, and by which the issuing carrier accepts responsibility for the carriage as set forth in the through bill of lading.
    • ForwardersCertificateOfTransport - Negotiable document/message issued by a forwarder to certify that he has taken charge of a specified consignment for despatch and delivery in accordance with the consignor's instructions, as indicated in the document, and that he accepts responsibility for delivery of the goods to the holder of the document through the intermediary of a delivery agent of his choice. E.g. FIATA-FCT.
    • CombinedTransportDocumentGeneric - Negotiable or non-negotiable document evidencing a contract for the performance and/or procurement of performance of combined transport of goods and bearing on its face either the heading "Negotiable combined transport document issued subject to Uniform Rules for a Combined Transport Document (ICC Brochure No. 298)" or the heading "Non-negotiable Combined Transport Document issued subject to Uniform Rules for a Combined Transport Document (ICC Brochure No. 298)".
    • MultimodalTransportDocumentGeneric - Document/message which evidences a multimodal transport contract, the taking in charge of the goods by the multimodal transport operator, and an undertaking by him to deliver the goods in accordance with the terms of the contract. (International Convention on Multimodal Transport of Goods).
    • CombinedTransportBillOfLadingMultimodalBillOfLading - Document which evidences a multimodal transport contract, the taking in charge of the goods by the multimodal transport operator, and an undertaking by him to deliver the goods in accordance with the terms of the contract.
    • BookingConfirmation - Document/message issued by a carrier to confirm that space has been reserved for a consignment in means of transport.
    • CallingForwardNotice - Instructions for release or delivery of goods.
    • FreightInvoice - Document/message issued by a transport operation specifying freight costs and charges incurred for a transport operation and stating conditions of payment.
    • ArrivalNoticeGoods - Notification from the carrier to the consignee in writing, by telephone or by any other means (express letter, message, telegram, etc.) informing him that a consignment addressed to him is being or will shortly be held at his disposal at a specified point in the place of destination.
    • NoticeOfCircumstancesPreventingDeliveryGoods - Request made by the carrier to the sender, or, as the case may be, the consignee, for instructions as to the disposal of the consignment when circumstances prevent delivery and the return of the goods has not been requested by the consignor in the transport document.
    • NoticeOfCircumstancesPreventingTransportGoods - Request made by the carrier to the sender, or, the consignee as the case may be, for instructions as to the disposal of the goods when circumstances prevent transport before departure or en route, after acceptance of the consignment concerned.
    • DeliveryNoticeGoods - Notification in writing, sent by the carrier to the sender, to inform him at his request of the actual date of delivery of the goods.
    • CargoManifest - Listing of goods comprising the cargo carried in a means of transport or in a transport-unit. The cargo manifest gives the commercial particulars of the goods, such as transport document numbers, consignors, consignees, shipping marks, number and kind of packages and descriptions and quantities of the goods.
    • FreightManifest - Document/message containing the same information as a cargo manifest, and additional details on freight amounts, charges, etc.
    • Bordereau - Document/message used in road transport, listing the cargo carried on a road vehicle, often referring to appended copies of Road consignment note.
    • ContainerManifestUnitPackingList - Document/message specifying the contents of particular freight containers or other transport units, prepared by the party responsible for their loading into the container or unit.
    • ChargesNote - Document used by the rail organization to indicate freight charges or additional charges in each case where the departure station is not able to calculate the charges for the total voyage (e.g. tariff not yet updated, part of voyage not covered by the tariff). This document must be considered as joined to the transport.
    • AdviceOfCollection - Document that is joined to the transport or sent by separate means, giving to the departure rail organization the proof that the cash-on delivery amount has been encashed by the arrival rail organization before reimbursement of the consignor.
    • SafetyOfShipCertificate - Document certifying a ship's safety to a specified date.
    • SafetyOfRadioCertificate - Document certifying the safety of a ship's radio facilities to a specified date.
    • SafetyOfEquipmentCertificate - Document certifying the safety of a ship's equipment to a specified date.
    • CivilLiabilityForOilCertificate - Document declaring a ship owner's liability for oil propelling or carried on a vessel.
    • LoadlineDocument - Document specifying the limit of a ship's legal submersion under various conditions.
    • DeratDocument - Document certifying that a ship is free of rats, valid to a specified date.
    • MaritimeDeclarationOfHealth - Document certifying the health condition on board a vessel, valid to a specified date.
    • CertificateOfRegistry - Official certificate stating the vessel's registry.
    • ShipsStoresDeclaration - Declaration to Customs regarding the contents of the ship's stores (equivalent to IMO FAL 3) i.e. goods intended for consumption by passengers/crew on board vessels, aircraft or trains, whether or not sold or landed; goods necessary for operation/maintenance of conveyance, including fuel/lubricants, excluding spare parts/equipment (IMO).
    • ExportLicenceApplicationFor - Application for a permit issued by a government authority permitting exportation of a specified commodity subject to specified conditions as quantity, country of destination, etc.
    • ExportLicence - Permit issued by a government authority permitting exportation of a specified commodity subject to specified conditions as quantity, country of destination, etc. Synonym: Embargo permit.
    • ExchangeControlDeclarationExport - Document/message completed by an exporter/seller as a means whereby the competent body may control that the amount of foreign exchange accrued from a trade transaction is repatriated in accordance with the conditions of payment and exchange control regulations in force.
    • DespatchNoteModelT - European community transit declaration.
    • DespatchNoteModelT1 - Transit declaration for goods circulating under internal community transit procedures (between European Union (EU) countries).
    • DespatchNoteModelT2 - Ascertainment that the declared goods were originally produced in an European Union (EU) country.
    • ControlDocumentT5 - Control document (export declaration) used particularly in case of re-sending without use with only VAT collection, refusal, unconformity with contract etc.
    • Re-SendingConsignmentNote - Rail consignment note prepared by the consignor for the facilitation of an eventual return to the origin of the goods.
    • DespatchNoteModelT2L - Ascertainment that the declared goods were originally produced in an European Union (EU) country. May only be used for goods that are loaded on one single means of transport in one single departure point for one single delivery point.
    • GoodsDeclarationForExportation - Document/message by which goods are declared for export Customs clearance, conforming to the layout key set out at Appendix I to Annex C.1 concerning outright exportation to the Kyoto convention (CCC). Within a Customs union, "for despatch" may have the same meaning as "for exportation".
    • CargoDeclarationDeparture - Generic term, sometimes referred to as Freight declaration, applied to the documents providing the particulars required by the Customs concerning the cargo (freight) carried by commercial means of transport (CCC).
    • ApplicationForGoodsControlCertificate - Document/message submitted to a competent body by party requesting a Goods control certificate to be issued in accordance with national or international standards, or conforming to legislation in the importing country, or as specified in the contract.
    • GoodsControlCertificate - Document/message issued by a competent body evidencing the quality of the goods described therein, in accordance with national or international standards, or conforming to legislation in the importing country, or as specified in the contract.
    • ApplicationForPhytosanitaryCertificate - Document/message submitted to a competent body by party requesting a Phytosanitary certificate to be issued.
    • PhytosanitaryCertificate - Document/message issued by the competent body in the exporting country evidencing that plants, fruit, or vegetables are free from disease and fit for consumption and giving details on fumigation or other treatment to which they may have been subjected.
    • SanitaryCertificate - Document/message issued by the competent authority in the exporting country evidencing that alimentary and animal products, including dead animals, are fit for human consumption, and giving details, when relevant, of controls undertaken.
    • VeterinaryCertificate - Document/message issued by the competent authority in the exporting country evidencing that live animals or birds are not infested or infected with disease, and giving details regarding their provenance, and of vaccinations and other treatment to which they have been subjected.
    • ApplicationForInspectionCertificate - Document/message submitted to a competent body by a party requesting an Inspection certificate to be issued in accordance with national or international standards, or conforming to legislation in the country in which it is required, or as specified in the contract.
    • InspectionCertificate - Document/message issued by a competent body evidencing that the goods described therein have been inspected in accordance with national or international standards, in conformity with legislation in the country in which the inspection is required, or as specified in the contract.
    • CertificateOfOriginApplicationFor - Document/message submitted to a competent body by an interested party requesting a Certificate of origin to be issued in accordance with relevant criteria, and on the basis of evidence of the origin of the goods.
    • CertificateOfOrigin - Document/message identifying goods, in which the authority or body authorized to issue it certifies expressly that the goods to which the certificate relates originate in a specific country. The word "country" may include a group of countries, a region or a part of a country. This certificate may also include a declaration by the manufacturer, producer, supplier, exporter or other competent person.
    • DeclarationOfOrigin - Appropriate statement as to the origin of the goods, made in connection with their exportation by the manufacturer, producer, supplier, exporter or other competent person on the Commercial invoice or any other document relating to the goods (CCC).
    • RegionalAppellationCertificate - Certificate drawn up in accordance with the rules laid down by an authority or approved body, certifying that the goods described therein qualify for a designation specific to the given region (e.g. champagne, port wine, Parmesan cheese).
    • PreferenceCertificateOfOrigin - Description to be provided.
    • CertificateOfOriginFormGsp - Specific form of certificate of origin for goods qualifying for preferential treatment under the generalized system of preferences (includes a combined declaration of origin and certificate, form A).
    • ConsularInvoice - Document/message to be prepared by an exporter in his country and presented to a diplomatic representation of the importing country for endorsement and subsequently to be presented by the importer in connection with the import of the goods described therein.
    • DangerousGoodsDeclaration - Document/message issued by a consignor in accordance with applicable conventions or regulations, describing hazardous goods or materials for transport purposes, and stating that the latter have been packed and labelled in accordance with the provisions of the relevant conventions or regulations.
    • StatisticalDocumentExport - Document/message in which an exporter provides information about exported goods required by the body responsible for the collection of international trade statistics.
    • IntrastatDeclaration - Document/message in which a declarant provides information about goods required by the body responsible for the collection of trade statistics.
    • DeliveryVerificationCertificate - Document/message whereby an official authority (Customs or governmental) certifies that goods have been delivered.
    • ImportLicenceApplicationFor - Document/message in which an interested party applies to the competent body for authorization to import either a limited quantity of articles subject to import restrictions, or an unlimited quantity of such articles during a limited period, and specifies the kind of articles, their origin and value, etc.
    • ImportLicence - Document/message issued by the competent body in accordance with import regulations in force, by which authorization is granted to a named party to import either a limited quantity of designated articles or an unlimited quantity of such articles during a limited period, under conditions specified in the document.
    • CustomsDeclarationWithoutCommercialDetail - CUSDEC transmission that does not include data from the commercial detail section of the message.
    • CustomsDeclarationWithCommercialAndItemDetail - CUSDEC transmission that includes data from both the commercial detail and item detail sections of the message.
    • CustomsDeclarationWithoutItemDetail - CUSDEC transmission that does not include data from the item detail section of the message.
    • RelatedDocument - Description to be provided.
    • ReceiptCustoms - Receipt for Customs duty/tax/fee paid.
    • ApplicationForExchangeAllocation - Document/message whereby an importer/buyer requests the competent body to allocate an amount of foreign exchange to be transferred to an exporter/seller in payment for goods.
    • ForeignExchangePermit - Document/message issued by the competent body authorizing an importer/buyer to transfer an amount of foreign exchange to an exporter/seller in payment for goods.
    • ExchangeControlDeclarationImport - Document/message completed by an importer/buyer as a means for the competent body to control that a trade transaction for which foreign exchange has been allocated has been executed and that money has been transferred in accordance with the conditions of payment and the exchange control regulations in force.
    • GoodsDeclarationForImportation - Document/message by which goods are declared for import Customs clearance [sister entry of 830].
    • GoodsDeclarationForHomeUse - Document/message by which goods are declared for import Customs clearance according to Annex B.1 (concerning clearance for home use) to the Kyoto convention (CCC).
    • CustomsImmediateReleaseDeclaration - Document/message issued by an importer notifying Customs that goods have been removed from an importing means of transport to the importer's premises under a Customs- approved arrangement for immediate release, or requesting authorization to do so.
    • CustomsDeliveryNote - Document/message whereby a Customs authority releases goods under its control to be placed at the disposal of the party concerned. Synonym: Customs release note.
    • CargoDeclarationArrival - Generic term, sometimes referred to as Freight declaration, applied to the documents providing the particulars required by the Customs concerning the cargo (freight) carried by commercial means of transport (CCC).
    • ValueDeclaration - Document/message in which a declarant (importer) states the invoice or other price (e.g. selling price, price of identical goods), and specifies costs for freight, insurance and packing, etc., terms of delivery and payment, any relationship with the trading partner, etc., for the purpose of determining the Customs value of goods imported.
    • CustomsInvoice - Document/message required by the Customs in an importing country in which an exporter states the invoice or other price (e.g. selling price, price of identical goods), and specifies costs for freight, insurance and packing, etc., terms of delivery and payment, for the purpose of determining the Customs value in the importing country of goods consigned to that country.
    • CustomsDeclarationPostParcels - Document/message which, according to Article 106 of the "Agreement concerning Postal Parcels" under the UPU Convention, must accompany post parcels and in which the contents of such parcels are specified.
    • TaxDeclarationValueAddedTax - Document/message in which an importer states the pertinent information required by the competent body for assessment of value-added tax.
    • TaxDeclarationGeneral - Document/message containing a general tax declaration.
    • TaxDemand - Document/message containing the demand of tax.
    • EmbargoPermit - Document/message giving the permission to export specified goods.
    • GoodsDeclarationForCustomsTransit - Document/message by which the sender declares goods for Customs transit according to Annex E.1 (concerning Customs transit) to the Kyoto convention (CCC).
    • TifForm - International Customs transit document by which the sender declares goods for carriage by rail in accordance with the provisions of the 1952 International Convention to facilitate the crossing of frontiers for goods carried by rail (TIF Convention of UIC).
    • TirCarnet - International Customs document (International Transit by Road), issued by a guaranteeing association approved by the Customs authorities, under the cover of which goods are carried, in most cases under Customs seal, in road vehicles and/or containers in compliance with the requirements of the Customs TIR Convention of the International Transport of Goods under cover of TIR Carnets (UN/ECE).
    • EcCarnet - EC customs transit document issued by EC customs authorities for transit and/or temporary user of goods within the EC.
    • Eur1CertificateOfOrigin - Customs certificate used in preferential goods interchanges between EC countries and EC external countries.
    • AtaCarnet - International Customs document (Admission Temporaire / Temporary Admission) which, issued under the terms of the ATA Convention (1961), incorporates an internationally valid guarantee and may be used, in lieu of national Customs documents and as security for import duties and taxes, to cover the temporary admission of goods and, where appropriate, the transit of goods. If accepted for controlling the temporary export and reimport of goods, international guarantee does not apply (CCC).
    • SingleAdministrativeDocument - A set of documents, replacing the various (national) forms for Customs declaration within the EC, implemented on 01-01-1988.
    • GeneralResponseCustoms - General response message to permit the transfer of data from Customs to the transmitter of the previous message.
    • DocumentResponseCustoms - Document response message to permit the transfer of data from Customs to the transmitter of the previous message.
    • ErrorResponseCustoms - Error response message to permit the transfer of data from Customs to the transmitter of the previous message.
    • PackageResponseCustoms - Package response message to permit the transfer of data from Customs to the transmitter of the previous message.
    • TaxCalculationConfirmationResponseCustoms - Tax calculation/confirmation response message to permit the transfer of data from Customs to the transmitter of the previous message.
    • QuotaPriorAllocationCertificate - Document/message issued by the competent body for prior allocation of a quota.
    • EndUseAuthorization - Description to be provided.
    • GovernmentContract - Description to be provided.
    • StatisticalDocumentImport - Description to be provided.
    • ApplicationForDocumentaryCredit - Message with application for opening of a documentary credit.
    • PreviousCustomsDocumentMessage - Indication of the previous Customs document/message concerning the same transaction.

[^]Code Fragment

    <xsd:simpleType name="DocumentTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="CertificateOfAnalysis">
        <xsd:enumeration value="CertificateOfConformity">
        <xsd:enumeration value="CertificateOfQuality">
        <xsd:enumeration value="TestReport">
        <xsd:enumeration value="ProductPerformanceReport">
        <xsd:enumeration value="ProductSpecificationReport">
        <xsd:enumeration value="ProcessDataReport">
        <xsd:enumeration value="FirstSampleTestReport">
        <xsd:enumeration value="PriceSalesCatalogue">
        <xsd:enumeration value="PartyInformation">
        <xsd:enumeration value="FederalLabelApproval">
        <xsd:enumeration value="MillCertificate">
        <xsd:enumeration value="PostReceipt">
        <xsd:enumeration value="WeightCertificate">
        <xsd:enumeration value="WeightList">
        <xsd:enumeration value="Certificate">
        <xsd:enumeration value="CombinedCertificateOfValueAndOrigin">
        <xsd:enumeration value="MovementCertificateATr1">
        <xsd:enumeration value="CertificateOfQuantity">
        <xsd:enumeration value="QualityDataMessage">
        <xsd:enumeration value="Query">
        <xsd:enumeration value="ResponseToQuery">
        <xsd:enumeration value="StatusInformation">
        <xsd:enumeration value="Restow">
        <xsd:enumeration value="ContainerDischargeList">
        <xsd:enumeration value="CorporateSuperannuationContributionsAdvice">
        <xsd:enumeration value="IndustrySuperannuationContributionsAdvice">
        <xsd:enumeration value="CorporateSuperannuationMemberMaintenanceMessage">
        <xsd:enumeration value="IndustrySuperannuationMemberMaintenanceMessage">
        <xsd:enumeration value="LifeInsurancePayrollDeductionsAdvice">
        <xsd:enumeration value="UnderbondRequest">
        <xsd:enumeration value="UnderbondApproval">
        <xsd:enumeration value="CertificateOfSealingOfExportMeatLockers">
        <xsd:enumeration value="CargoStatus">
        <xsd:enumeration value="InventoryReport">
        <xsd:enumeration value="IdentityCard">
        <xsd:enumeration value="ResponseToATradeStatisticsMessage">
        <xsd:enumeration value="VaccinationCertificate">
        <xsd:enumeration value="Passport">
        <xsd:enumeration value="DrivingLicenceNational">
        <xsd:enumeration value="DrivingLicenceInternational">
        <xsd:enumeration value="FreePass">
        <xsd:enumeration value="SeasonTicket">
        <xsd:enumeration value="TransportStatusReport">
        <xsd:enumeration value="TransportStatusRequest">
        <xsd:enumeration value="BankingStatus">
        <xsd:enumeration value="Extra-CommunityTradeStatisticalDeclaration">
        <xsd:enumeration value="WrittenInstructionsInConformanceWithAdrArticleNumber">
        <xsd:enumeration value="DamageCertification">
        <xsd:enumeration value="ValidatedPricedTender">
        <xsd:enumeration value="PriceSalesCatalogueResponse">
        <xsd:enumeration value="PriceNegotiationResult">
        <xsd:enumeration value="SafetyAndHazardDataSheet">
        <xsd:enumeration value="LegalStatementOfAnAccount">
        <xsd:enumeration value="ListingStatementOfAnAccount">
        <xsd:enumeration value="ClosingStatementOfAnAccount">
        <xsd:enumeration value="TransportEquipmentOn-HireReport">
        <xsd:enumeration value="TransportEquipmentOff-HireReport">
        <xsd:enumeration value="Treatment-NilOutturn">
        <xsd:enumeration value="Treatment-Time-UpUnderbond">
        <xsd:enumeration value="Treatment-UnderbondBySea">
        <xsd:enumeration value="Treatment-PersonalEffect">
        <xsd:enumeration value="Treatment-Timber">
        <xsd:enumeration value="PreliminaryCreditAssessment">
        <xsd:enumeration value="CreditCover">
        <xsd:enumeration value="CurrentAccount">
        <xsd:enumeration value="CommercialDispute">
        <xsd:enumeration value="Chargeback">
        <xsd:enumeration value="Reassignment">
        <xsd:enumeration value="CollateralAccount">
        <xsd:enumeration value="RequestForPayment">
        <xsd:enumeration value="UnshipPermit">
        <xsd:enumeration value="StatisticalDefinitions">
        <xsd:enumeration value="StatisticalData">
        <xsd:enumeration value="RequestForStatisticalData">
        <xsd:enumeration value="Call-OffDelivery">
        <xsd:enumeration value="ConsignmentStatusReport">
        <xsd:enumeration value="InventoryMovementAdvice">
        <xsd:enumeration value="InventoryStatusAdvice">
        <xsd:enumeration value="DebitNoteRelatedToGoodsOrServices">
        <xsd:enumeration value="CreditNoteRelatedToGoodsOrServices">
        <xsd:enumeration value="MeteredServicesInvoice">
        <xsd:enumeration value="CreditNoteRelatedToFinancialAdjustments">
        <xsd:enumeration value="DebitNoteRelatedToFinancialAdjustments">
        <xsd:enumeration value="CustomsManifest">
        <xsd:enumeration value="VesselUnpackReport">
        <xsd:enumeration value="GeneralCargoSummaryManifestReport">
        <xsd:enumeration value="ConsignmentUnpackReport">
        <xsd:enumeration value="MeatAndMeatBy-ProductsSanitaryCertificate">
        <xsd:enumeration value="MeatFoodProductsSanitaryCertificate">
        <xsd:enumeration value="PoultrySanitaryCertificate">
        <xsd:enumeration value="HorsemeatSanitaryCertificate">
        <xsd:enumeration value="CasingSanitaryCertificate">
        <xsd:enumeration value="PharmaceuticalSanitaryCertificate">
        <xsd:enumeration value="InedibleSanitaryCertificate">
        <xsd:enumeration value="ImpendingArrival">
        <xsd:enumeration value="MeansOfTransportAdvice">
        <xsd:enumeration value="ArrivalInformation">
        <xsd:enumeration value="CargoReleaseNotification">
        <xsd:enumeration value="ExciseCertificate">
        <xsd:enumeration value="RegistrationDocument">
        <xsd:enumeration value="TaxNotification">
        <xsd:enumeration value="TransportEquipmentDirectInterchangeReport">
        <xsd:enumeration value="TransportEquipmentImpendingArrivalAdvice">
        <xsd:enumeration value="PurchaseOrder">
        <xsd:enumeration value="TransportEquipmentDamageReport">
        <xsd:enumeration value="TransportEquipmentMaintenanceAndRepairWorkEstimateAdvice">
        <xsd:enumeration value="TransportEquipmentEmptyReleaseInstruction">
        <xsd:enumeration value="TransportMovementGateInReport">
        <xsd:enumeration value="ManufacturingInstructions">
        <xsd:enumeration value="TransportMovementGateOutReport">
        <xsd:enumeration value="TransportEquipmentUnpackingInstruction">
        <xsd:enumeration value="TransportEquipmentUnpackingReport">
        <xsd:enumeration value="TransportEquipmentPick-UpAvailabilityRequest">
        <xsd:enumeration value="TransportEquipmentPick-UpAvailabilityConfirmation">
        <xsd:enumeration value="TransportEquipmentPick-UpReport">
        <xsd:enumeration value="TransportEquipmentShiftReport">
        <xsd:enumeration value="TransportDischargeInstruction">
        <xsd:enumeration value="TransportDischargeReport">
        <xsd:enumeration value="StoresRequisition">
        <xsd:enumeration value="TransportLoadingInstruction">
        <xsd:enumeration value="TransportLoadingReport">
        <xsd:enumeration value="TransportEquipmentMaintenanceAndRepairWork">
        <xsd:enumeration value="TransportDepartureReport">
        <xsd:enumeration value="TransportEmptyEquipmentAdvice">
        <xsd:enumeration value="TransportEquipmentAcceptanceOrder">
        <xsd:enumeration value="TransportEquipmentSpecialServiceInstruction">
        <xsd:enumeration value="TransportEquipmentStockReport">
        <xsd:enumeration value="TransportCargoReleaseOrder">
        <xsd:enumeration value="InvoicingDataSheet">
        <xsd:enumeration value="TransportEquipmentPackingInstruction">
        <xsd:enumeration value="CustomsClearanceNotice">
        <xsd:enumeration value="CustomsDocumentsExpirationNotice">
        <xsd:enumeration value="TransportEquipmentOn-HireRequest">
        <xsd:enumeration value="TransportEquipmentOn-HireOrder">
        <xsd:enumeration value="TransportEquipmentOff-HireRequest">
        <xsd:enumeration value="TransportEquipmentSurveyOrder">
        <xsd:enumeration value="TransportEquipmentSurveyOrderResponse">
        <xsd:enumeration value="TransportEquipmentSurveyReport">
        <xsd:enumeration value="PackingInstructions">
        <xsd:enumeration value="AdvisingItemsToBeBookedToAFinancialAccount">
        <xsd:enumeration value="TransportEquipmentMaintenanceAndRepairWorkEstimateOrder">
        <xsd:enumeration value="TransportEquipmentMaintenanceAndRepairNotice">
        <xsd:enumeration value="EmptyContainerDispositionOrder">
        <xsd:enumeration value="CargoVesselDischargeOrder">
        <xsd:enumeration value="CargoVesselLoadingOrder">
        <xsd:enumeration value="MultidropOrder">
        <xsd:enumeration value="BailmentContract">
        <xsd:enumeration value="BasicAgreement">
        <xsd:enumeration value="InternalTransportOrder">
        <xsd:enumeration value="Grant">
        <xsd:enumeration value="IndefiniteDeliveryIndefiniteQuantityContract">
        <xsd:enumeration value="IndefiniteDeliveryDefiniteQuantityContract">
        <xsd:enumeration value="RequirementsContract">
        <xsd:enumeration value="TaskOrder">
        <xsd:enumeration value="MakeOrBuyPlan">
        <xsd:enumeration value="SubcontractorPlan">
        <xsd:enumeration value="CostDataSummary">
        <xsd:enumeration value="CertifiedCostAndPriceData">
        <xsd:enumeration value="WageDetermination">
        <xsd:enumeration value="ContractFundsStatusReportCfsr">
        <xsd:enumeration value="CertifiedInspectionAndTestResults">
        <xsd:enumeration value="MaterialInspectionAndReceivingReport">
        <xsd:enumeration value="PurchasingSpecification">
        <xsd:enumeration value="PaymentOrPerformanceBond">
        <xsd:enumeration value="ContractSecurityClassificationSpecification">
        <xsd:enumeration value="ManufacturingSpecification">
        <xsd:enumeration value="BuyAmericaCertificateOfCompliance">
        <xsd:enumeration value="ContainerOff-HireNotice">
        <xsd:enumeration value="CargoAcceptanceOrder">
        <xsd:enumeration value="Pick-UpNotice">
        <xsd:enumeration value="AuthorisationToPlanAndSuggestOrders">
        <xsd:enumeration value="AuthorisationToPlanAndShipOrders">
        <xsd:enumeration value="Drawing">
        <xsd:enumeration value="CostPerformanceReportCprFormat2">
        <xsd:enumeration value="CostScheduleStatusReportCssr">
        <xsd:enumeration value="CostPerformanceReportCprFormat1">
        <xsd:enumeration value="CostPerformanceReportCprFormat3">
        <xsd:enumeration value="CostPerformanceReportCprFormat4">
        <xsd:enumeration value="CostPerformanceReportCprFormat5">
        <xsd:enumeration value="ProgressiveDischargeReport">
        <xsd:enumeration value="BalanceConfirmation">
        <xsd:enumeration value="ContainerStrippingOrder">
        <xsd:enumeration value="ContainerStuffingOrder">
        <xsd:enumeration value="ConveyanceDeclarationArrival">
        <xsd:enumeration value="ConveyanceDeclarationDeparture">
        <xsd:enumeration value="ConveyanceDeclarationCombined">
        <xsd:enumeration value="ProjectRecoveryPlan">
        <xsd:enumeration value="ProjectProductionPlan">
        <xsd:enumeration value="StatisticalAndOtherAdministrativeInternalDocuments">
        <xsd:enumeration value="ProjectMasterSchedule">
        <xsd:enumeration value="PricedAlternateTenderBillOfQuantity">
        <xsd:enumeration value="EstimatedPricedBillOfQuantity">
        <xsd:enumeration value="DraftBillOfQuantity">
        <xsd:enumeration value="DocumentaryCreditCollectionInstruction">
        <xsd:enumeration value="RequestForAnAmendmentOfADocumentaryCredit">
        <xsd:enumeration value="DocumentaryCreditAmendmentInformation">
        <xsd:enumeration value="AdviceOfAnAmendmentOfADocumentaryCredit">
        <xsd:enumeration value="ResponseToAnAmendmentOfADocumentaryCredit">
        <xsd:enumeration value="DocumentaryCreditIssuanceInformation">
        <xsd:enumeration value="DirectPaymentValuationRequest">
        <xsd:enumeration value="DirectPaymentValuation">
        <xsd:enumeration value="ProvisionalPaymentValuation">
        <xsd:enumeration value="PaymentValuation">
        <xsd:enumeration value="QuantityValuation">
        <xsd:enumeration value="QuantityValuationRequest">
        <xsd:enumeration value="ContractBillOfQuantities-Boq">
        <xsd:enumeration value="UnpricedBillOfQuantity">
        <xsd:enumeration value="PricedTenderBoq">
        <xsd:enumeration value="Enquiry">
        <xsd:enumeration value="InterimApplicationForPayment">
        <xsd:enumeration value="AgreementToPay">
        <xsd:enumeration value="RequestForFinancialCancellation">
        <xsd:enumeration value="Pre-AuthorisedDirectDebits">
        <xsd:enumeration value="LetterOfIntent">
        <xsd:enumeration value="ApprovedUnpricedBillOfQuantity">
        <xsd:enumeration value="PaymentValuationForUnscheduledItems">
        <xsd:enumeration value="FinalPaymentRequestBasedOnCompletionOfWork">
        <xsd:enumeration value="PaymentRequestForCompletedUnits">
        <xsd:enumeration value="Order">
        <xsd:enumeration value="BlanketOrder">
        <xsd:enumeration value="SpotOrder">
        <xsd:enumeration value="LeaseOrder">
        <xsd:enumeration value="RushOrder">
        <xsd:enumeration value="RepairOrder">
        <xsd:enumeration value="CallOffOrder">
        <xsd:enumeration value="ConsignmentOrder">
        <xsd:enumeration value="SampleOrder">
        <xsd:enumeration value="SwapOrder">
        <xsd:enumeration value="PurchaseOrderChangeRequest">
        <xsd:enumeration value="PurchaseOrderResponse">
        <xsd:enumeration value="HireOrder">
        <xsd:enumeration value="SparePartsOrder">
        <xsd:enumeration value="CampaignPriceSalesCatalogue">
        <xsd:enumeration value="ContainerList">
        <xsd:enumeration value="DeliveryForecast">
        <xsd:enumeration value="CrossDockingServicesOrder">
        <xsd:enumeration value="Non-Pre-AuthorisedDirectDebits">
        <xsd:enumeration value="RejectedDirectDebits">
        <xsd:enumeration value="DeliveryInstructions">
        <xsd:enumeration value="DeliverySchedule">
        <xsd:enumeration value="DeliveryJust-In-Time">
        <xsd:enumeration value="Pre-AuthorisedDirectDebitRequests">
        <xsd:enumeration value="Non-Pre-AuthorisedDirectDebitRequests">
        <xsd:enumeration value="DeliveryRelease">
        <xsd:enumeration value="SettlementOfALetterOfCredit">
        <xsd:enumeration value="BankToBankFundsTransfer">
        <xsd:enumeration value="CustomerPaymentOrders">
        <xsd:enumeration value="LowValuePaymentOrders">
        <xsd:enumeration value="CrewListDeclaration">
        <xsd:enumeration value="Inquiry">
        <xsd:enumeration value="ResponseToPreviousBankingStatusMessage">
        <xsd:enumeration value="ProjectMasterPlan">
        <xsd:enumeration value="ProjectPlan">
        <xsd:enumeration value="ProjectSchedule">
        <xsd:enumeration value="ProjectPlanningAvailableResources">
        <xsd:enumeration value="ProjectPlanningCalendar">
        <xsd:enumeration value="StandingOrder">
        <xsd:enumeration value="CargoMovementEventLog">
        <xsd:enumeration value="CargoAnalysisVoyageReport">
        <xsd:enumeration value="SelfBilledCreditNote">
        <xsd:enumeration value="ConsolidatedCreditNote-GoodsAndServices">
        <xsd:enumeration value="InventoryAdjustmentStatusReport">
        <xsd:enumeration value="TransportEquipmentMovementInstruction">
        <xsd:enumeration value="TransportEquipmentMovementReport">
        <xsd:enumeration value="TransportEquipmentStatusChangeReport">
        <xsd:enumeration value="FumigationCertificate">
        <xsd:enumeration value="WineCertificate">
        <xsd:enumeration value="WoolHealthCertificate">
        <xsd:enumeration value="DeliveryNote">
        <xsd:enumeration value="PackingList">
        <xsd:enumeration value="NewCodeRequest">
        <xsd:enumeration value="CodeChangeRequest">
        <xsd:enumeration value="SimpleDataElementRequest">
        <xsd:enumeration value="SimpleDataElementChangeRequest">
        <xsd:enumeration value="CompositeDataElementRequest">
        <xsd:enumeration value="CompositeDataElementChangeRequest">
        <xsd:enumeration value="SegmentRequest">
        <xsd:enumeration value="SegmentChangeRequest">
        <xsd:enumeration value="NewMessageRequest">
        <xsd:enumeration value="MessageInDevelopmentRequest">
        <xsd:enumeration value="ModificationOfExistingMessage">
        <xsd:enumeration value="TrackingNumberAssignmentReport">
        <xsd:enumeration value="UserDirectoryDefinition">
        <xsd:enumeration value="UnitedNationsStandardMessageRequest">
        <xsd:enumeration value="ServiceDirectoryDefinition">
        <xsd:enumeration value="StatusReport">
        <xsd:enumeration value="KanbanSchedule">
        <xsd:enumeration value="ProductDataMessage">
        <xsd:enumeration value="AClaimForPartsAndOrLabourCharges">
        <xsd:enumeration value="DeliveryScheduleResponse">
        <xsd:enumeration value="InspectionRequest">
        <xsd:enumeration value="InspectionReport">
        <xsd:enumeration value="ApplicationAcknowledgementAndErrorReport">
        <xsd:enumeration value="PriceVariationInvoice">
        <xsd:enumeration value="CreditNoteForPriceVariation">
        <xsd:enumeration value="InstructionToCollect">
        <xsd:enumeration value="DangerousGoodsList">
        <xsd:enumeration value="RegistrationRenewal">
        <xsd:enumeration value="RegistrationChange">
        <xsd:enumeration value="ResponseToRegistration">
        <xsd:enumeration value="ImplementationGuideline">
        <xsd:enumeration value="RequestForTransfer">
        <xsd:enumeration value="CostPerformanceReport">
        <xsd:enumeration value="ApplicationErrorAndAcknowledgement">
        <xsd:enumeration value="CashPoolFinancialStatement">
        <xsd:enumeration value="SequencedDeliverySchedule">
        <xsd:enumeration value="DelcredereCreditNote">
        <xsd:enumeration value="OfferQuotation">
        <xsd:enumeration value="RequestForQuote">
        <xsd:enumeration value="AcknowledgementMessage">
        <xsd:enumeration value="ApplicationErrorMessage">
        <xsd:enumeration value="CargoMovementVoyageSummary">
        <xsd:enumeration value="Contract">
        <xsd:enumeration value="ApplicationForUsageOfBerthOrMooringFacilities">
        <xsd:enumeration value="ApplicationForDesignationOfBerthingPlaces">
        <xsd:enumeration value="ApplicationForShiftingFromTheDesignatedPlaceInPort">
        <xsd:enumeration value="SupplementaryDocumentForApplicationForCargoOperationOfDangerousGoods">
        <xsd:enumeration value="AcknowledgementOfOrder">
        <xsd:enumeration value="SupplementaryDocumentForApplicationForTransportOfDangerousGoods">
        <xsd:enumeration value="OpticalCharacterReadingOcrPayment">
        <xsd:enumeration value="PreliminarySalesReport">
        <xsd:enumeration value="TransportEmergencyCard">
        <xsd:enumeration value="ProformaInvoice">
        <xsd:enumeration value="PartialInvoice">
        <xsd:enumeration value="OperatingInstructions">
        <xsd:enumeration value="NameProductPlate">
        <xsd:enumeration value="Co-InsuranceCedingBordereau">
        <xsd:enumeration value="RequestForDeliveryInstructions">
        <xsd:enumeration value="CommercialInvoiceWhichIncludesAPackingList">
        <xsd:enumeration value="TradeData">
        <xsd:enumeration value="CustomsDeclarationForCargoExamination">
        <xsd:enumeration value="CustomsDeclarationForCargoExaminationAlternate">
        <xsd:enumeration value="BookingRequest">
        <xsd:enumeration value="CustomsCrewAndConveyance">
        <xsd:enumeration value="CustomsSummaryDeclarationWithCommercialDetailAlternate">
        <xsd:enumeration value="ItemsBookedToAFinancialAccountReport">
        <xsd:enumeration value="ReportOfTransactionsWhichNeedFurtherInformationFromTheReceiver">
        <xsd:enumeration value="ShippingInstructions">
        <xsd:enumeration value="ShippersLetterOfInstructionsAir">
        <xsd:enumeration value="ReportOfTransactionsForInformationOnly">
        <xsd:enumeration value="CartageOrderLocalTransport">
        <xsd:enumeration value="EdiAssociatedObjectAdministrationMessage">
        <xsd:enumeration value="ReadyForDespatchAdvice">
        <xsd:enumeration value="SummarySalesReport">
        <xsd:enumeration value="OrderStatusEnquiry">
        <xsd:enumeration value="OrderStatusReport">
        <xsd:enumeration value="DeclarationRegardingTheInwardAndOutwardMovementOfVessel">
        <xsd:enumeration value="DespatchOrder">
        <xsd:enumeration value="DespatchAdvice">
        <xsd:enumeration value="NotificationOfUsageOfBerthOrMooringFacilities">
        <xsd:enumeration value="ApplicationForVesselsEnteringIntoPortAreaInNight-Time">
        <xsd:enumeration value="NotificationOfEmergencyShiftingFromTheDesignatedPlaceInPort">
        <xsd:enumeration value="CustomsSummaryDeclarationWithoutCommercialDetailAlternate">
        <xsd:enumeration value="PerformanceBond">
        <xsd:enumeration value="PaymentBond">
        <xsd:enumeration value="AdviceOfDistributionOfDocuments">
        <xsd:enumeration value="CommercialInvoice">
        <xsd:enumeration value="CreditNote">
        <xsd:enumeration value="CommissionNote">
        <xsd:enumeration value="DebitNote">
        <xsd:enumeration value="CorrectedInvoice">
        <xsd:enumeration value="ConsolidatedInvoice">
        <xsd:enumeration value="PrepaymentInvoice">
        <xsd:enumeration value="HireInvoice">
        <xsd:enumeration value="TaxInvoice">
        <xsd:enumeration value="Self-BilledInvoice">
        <xsd:enumeration value="DelcredereInvoice">
        <xsd:enumeration value="FactoredInvoice">
        <xsd:enumeration value="LeaseInvoice">
        <xsd:enumeration value="ConsignmentInvoice">
        <xsd:enumeration value="FactoredCreditNote">
        <xsd:enumeration value="CommercialAccountSummaryResponse">
        <xsd:enumeration value="CrossDockingDespatchAdvice">
        <xsd:enumeration value="TransshipmentDespatchAdvice">
        <xsd:enumeration value="ExceptionalOrder">
        <xsd:enumeration value="TransshipmentOrder">
        <xsd:enumeration value="CrossDockingOrder">
        <xsd:enumeration value="MeansOfTransportationAvailabilityInformation">
        <xsd:enumeration value="MeansOfTransportationScheduleInformation">
        <xsd:enumeration value="TransportEquipmentDeliveryNotice">
        <xsd:enumeration value="InstructionsForBankTransfer">
        <xsd:enumeration value="ApplicationForBankersDraft">
        <xsd:enumeration value="CollectionPaymentAdvice">
        <xsd:enumeration value="DocumentaryCreditPaymentAdvice">
        <xsd:enumeration value="DocumentaryCreditAcceptanceAdvice">
        <xsd:enumeration value="DocumentaryCreditNegotiationAdvice">
        <xsd:enumeration value="ApplicationForBankersGuarantee">
        <xsd:enumeration value="BankersGuarantee">
        <xsd:enumeration value="DocumentaryCreditLetterOfIndemnity">
        <xsd:enumeration value="PreadviceOfACredit">
        <xsd:enumeration value="CollectionOrder">
        <xsd:enumeration value="DocumentsPresentationForm">
        <xsd:enumeration value="PaymentOrder">
        <xsd:enumeration value="ExtendedPaymentOrder">
        <xsd:enumeration value="MultiplePaymentOrder">
        <xsd:enumeration value="CreditAdvice">
        <xsd:enumeration value="ExtendedCreditAdvice">
        <xsd:enumeration value="DebitAdvice">
        <xsd:enumeration value="ReversalOfDebit">
        <xsd:enumeration value="ReversalOfCredit">
        <xsd:enumeration value="DocumentaryCreditApplication">
        <xsd:enumeration value="DocumentaryCredit">
        <xsd:enumeration value="DocumentaryCreditNotification">
        <xsd:enumeration value="DocumentaryCreditTransferAdvice">
        <xsd:enumeration value="DocumentaryCreditAmendmentNotification">
        <xsd:enumeration value="DocumentaryCreditAmendment">
        <xsd:enumeration value="RemittanceAdvice">
        <xsd:enumeration value="BankersDraft">
        <xsd:enumeration value="BillOfExchange">
        <xsd:enumeration value="PromissoryNote">
        <xsd:enumeration value="FinancialStatementOfAccount">
        <xsd:enumeration value="StatementOfAccountMessage">
        <xsd:enumeration value="InsuranceCertificate">
        <xsd:enumeration value="InsurancePolicy">
        <xsd:enumeration value="InsuranceDeclarationSheetBordereau">
        <xsd:enumeration value="InsurersInvoice">
        <xsd:enumeration value="CoverNote">
        <xsd:enumeration value="ForwardingInstructions">
        <xsd:enumeration value="ForwardersAdviceToImportAgent">
        <xsd:enumeration value="ForwardersAdviceToExporter">
        <xsd:enumeration value="ForwardersInvoice">
        <xsd:enumeration value="ForwardersCertificateOfReceipt">
        <xsd:enumeration value="ShippingNote">
        <xsd:enumeration value="ForwardersWarehouseReceipt">
        <xsd:enumeration value="GoodsReceipt">
        <xsd:enumeration value="PortChargesDocuments">
        <xsd:enumeration value="WarehouseWarrant">
        <xsd:enumeration value="DeliveryOrder">
        <xsd:enumeration value="HandlingOrder">
        <xsd:enumeration value="GatePass">
        <xsd:enumeration value="Waybill">
        <xsd:enumeration value="UniversalMultipurposeTransportDocument">
        <xsd:enumeration value="GoodsReceiptCarriage">
        <xsd:enumeration value="HouseWaybill">
        <xsd:enumeration value="MasterBillOfLading">
        <xsd:enumeration value="BillOfLading">
        <xsd:enumeration value="BillOfLadingOriginal">
        <xsd:enumeration value="BillOfLadingCopy">
        <xsd:enumeration value="EmptyContainerBill">
        <xsd:enumeration value="TankerBillOfLading">
        <xsd:enumeration value="SeaWaybill">
        <xsd:enumeration value="InlandWaterwayBillOfLading">
        <xsd:enumeration value="Non-NegotiableMaritimeTransportDocumentGeneric">
        <xsd:enumeration value="MatesReceipt">
        <xsd:enumeration value="HouseBillOfLading">
        <xsd:enumeration value="LetterOfIndemnityForNon-SurrenderOfBillOfLading">
        <xsd:enumeration value="ForwardersBillOfLading">
        <xsd:enumeration value="RailConsignmentNoteGenericTerm">
        <xsd:enumeration value="RoadList-Smgs">
        <xsd:enumeration value="EscortOfficialRecognition">
        <xsd:enumeration value="RechargingDocument">
        <xsd:enumeration value="RoadConsignmentNote">
        <xsd:enumeration value="AirWaybill">
        <xsd:enumeration value="MasterAirWaybill">
        <xsd:enumeration value="SubstituteAirWaybill">
        <xsd:enumeration value="CrewsEffectsDeclaration">
        <xsd:enumeration value="PassengerList">
        <xsd:enumeration value="DeliveryNoticeRailTransport">
        <xsd:enumeration value="DespatchNotePostParcels">
        <xsd:enumeration value="MultimodalCombinedTransportDocumentGeneric">
        <xsd:enumeration value="ThroughBillOfLading">
        <xsd:enumeration value="ForwardersCertificateOfTransport">
        <xsd:enumeration value="CombinedTransportDocumentGeneric">
        <xsd:enumeration value="MultimodalTransportDocumentGeneric">
        <xsd:enumeration value="CombinedTransportBillOfLadingMultimodalBillOfLading">
        <xsd:enumeration value="BookingConfirmation">
        <xsd:enumeration value="CallingForwardNotice">
        <xsd:enumeration value="FreightInvoice">
        <xsd:enumeration value="ArrivalNoticeGoods">
        <xsd:enumeration value="NoticeOfCircumstancesPreventingDeliveryGoods">
        <xsd:enumeration value="NoticeOfCircumstancesPreventingTransportGoods">
        <xsd:enumeration value="DeliveryNoticeGoods">
        <xsd:enumeration value="CargoManifest">
        <xsd:enumeration value="FreightManifest">
        <xsd:enumeration value="Bordereau">
        <xsd:enumeration value="ContainerManifestUnitPackingList">
        <xsd:enumeration value="ChargesNote">
        <xsd:enumeration value="AdviceOfCollection">
        <xsd:enumeration value="SafetyOfShipCertificate">
        <xsd:enumeration value="SafetyOfRadioCertificate">
        <xsd:enumeration value="SafetyOfEquipmentCertificate">
        <xsd:enumeration value="CivilLiabilityForOilCertificate">
        <xsd:enumeration value="LoadlineDocument">
        <xsd:enumeration value="DeratDocument">
        <xsd:enumeration value="MaritimeDeclarationOfHealth">
        <xsd:enumeration value="CertificateOfRegistry">
        <xsd:enumeration value="ShipsStoresDeclaration">
        <xsd:enumeration value="ExportLicenceApplicationFor">
        <xsd:enumeration value="ExportLicence">
        <xsd:enumeration value="ExchangeControlDeclarationExport">
        <xsd:enumeration value="DespatchNoteModelT">
        <xsd:enumeration value="DespatchNoteModelT1">
        <xsd:enumeration value="DespatchNoteModelT2">
        <xsd:enumeration value="ControlDocumentT5">
        <xsd:enumeration value="Re-SendingConsignmentNote">
        <xsd:enumeration value="DespatchNoteModelT2L">
        <xsd:enumeration value="GoodsDeclarationForExportation">
        <xsd:enumeration value="CargoDeclarationDeparture">
        <xsd:enumeration value="ApplicationForGoodsControlCertificate">
        <xsd:enumeration value="GoodsControlCertificate">
        <xsd:enumeration value="ApplicationForPhytosanitaryCertificate">
        <xsd:enumeration value="PhytosanitaryCertificate">
        <xsd:enumeration value="SanitaryCertificate">
        <xsd:enumeration value="VeterinaryCertificate">
        <xsd:enumeration value="ApplicationForInspectionCertificate">
        <xsd:enumeration value="InspectionCertificate">
        <xsd:enumeration value="CertificateOfOriginApplicationFor">
        <xsd:enumeration value="CertificateOfOrigin">
        <xsd:enumeration value="DeclarationOfOrigin">
        <xsd:enumeration value="RegionalAppellationCertificate">
        <xsd:enumeration value="PreferenceCertificateOfOrigin">
        <xsd:enumeration value="CertificateOfOriginFormGsp">
        <xsd:enumeration value="ConsularInvoice">
        <xsd:enumeration value="DangerousGoodsDeclaration">
        <xsd:enumeration value="StatisticalDocumentExport">
        <xsd:enumeration value="IntrastatDeclaration">
        <xsd:enumeration value="DeliveryVerificationCertificate">
        <xsd:enumeration value="ImportLicenceApplicationFor">
        <xsd:enumeration value="ImportLicence">
        <xsd:enumeration value="CustomsDeclarationWithoutCommercialDetail">
        <xsd:enumeration value="CustomsDeclarationWithCommercialAndItemDetail">
        <xsd:enumeration value="CustomsDeclarationWithoutItemDetail">
        <xsd:enumeration value="RelatedDocument">
        <xsd:enumeration value="ReceiptCustoms">
        <xsd:enumeration value="ApplicationForExchangeAllocation">
        <xsd:enumeration value="ForeignExchangePermit">
        <xsd:enumeration value="ExchangeControlDeclarationImport">
        <xsd:enumeration value="GoodsDeclarationForImportation">
        <xsd:enumeration value="GoodsDeclarationForHomeUse">
        <xsd:enumeration value="CustomsImmediateReleaseDeclaration">
        <xsd:enumeration value="CustomsDeliveryNote">
        <xsd:enumeration value="CargoDeclarationArrival">
        <xsd:enumeration value="ValueDeclaration">
        <xsd:enumeration value="CustomsInvoice">
        <xsd:enumeration value="CustomsDeclarationPostParcels">
        <xsd:enumeration value="TaxDeclarationValueAddedTax">
        <xsd:enumeration value="TaxDeclarationGeneral">
        <xsd:enumeration value="TaxDemand">
        <xsd:enumeration value="EmbargoPermit">
        <xsd:enumeration value="GoodsDeclarationForCustomsTransit">
        <xsd:enumeration value="TifForm">
        <xsd:enumeration value="TirCarnet">
        <xsd:enumeration value="EcCarnet">
        <xsd:enumeration value="Eur1CertificateOfOrigin">
        <xsd:enumeration value="AtaCarnet">
        <xsd:enumeration value="SingleAdministrativeDocument">
        <xsd:enumeration value="GeneralResponseCustoms">
        <xsd:enumeration value="DocumentResponseCustoms">
        <xsd:enumeration value="ErrorResponseCustoms">
        <xsd:enumeration value="PackageResponseCustoms">
        <xsd:enumeration value="TaxCalculationConfirmationResponseCustoms">
        <xsd:enumeration value="QuotaPriorAllocationCertificate">
        <xsd:enumeration value="EndUseAuthorization">
        <xsd:enumeration value="GovernmentContract">
        <xsd:enumeration value="StatisticalDocumentImport">
        <xsd:enumeration value="ApplicationForDocumentaryCredit">
        <xsd:enumeration value="PreviousCustomsDocumentMessage">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: EquipmentOwnerCodeType

EquipmentOwnerCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the relationship of equipment to carrier or ownership of equipment. This code list is derived from X12 102 (Ownership code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • NotCustomerOwnedOrLeased
    • SellerOwned
    • CustomerOwnedOrLeased
    • TripLeased

[^]Code Fragment

    <xsd:simpleType name="EquipmentOwnerCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="NotCustomerOwnedOrLeased">
        <xsd:enumeration value="SellerOwned">
        <xsd:enumeration value="CustomerOwnedOrLeased">
        <xsd:enumeration value="TripLeased">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: EquipmentProviderCodeType

EquipmentProviderCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the party that is the provider of the equipment. This code list is derived from EDIFACT 8077 (Equipment supplier code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • ShipperSupplied - The transport equipment is supplied by the shipper.
    • CarrierSupplied - The transport equipment is supplied by the carrier.
    • ConsolidatorSupplied - The equipment is supplied by the consolidator.
    • DeconsolidatorSupplied - The equipment is supplied by the deconsolidator.
    • ThirdPartySupplied - The equipment is supplied by a third party.
    • ForwarderSuppliedFromALeasingCompany - The equipment is supplied by the forwarder and is taken from a leasing company.
    • ForwarderSuppliedFromTheRailwaysPool - The equipment is supplied by the forwarder and is taken from a pool established by railway companies.

[^]Code Fragment

    <xsd:simpleType name="EquipmentProviderCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="ShipperSupplied">
        <xsd:enumeration value="CarrierSupplied">
        <xsd:enumeration value="ConsolidatorSupplied">
        <xsd:enumeration value="DeconsolidatorSupplied">
        <xsd:enumeration value="ThirdPartySupplied">
        <xsd:enumeration value="ForwarderSuppliedFromALeasingCompany">
        <xsd:enumeration value="ForwarderSuppliedFromTheRailwaysPool">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: EquipmentSizeTypeCodeType

EquipmentSizeTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • 20FtIlContainer-ClosedTop - A closed top container that is 20 feet in internal length.
    • 20FtIlContainer-OpenTop - An open top container that is 20 feet in internal length.
    • 40FtIlContainer-ClosedTop - A closed top container that is 40 feet in internal length.
    • 40FtIlContainer-OpenTop
    • Aircraft
    • AirFreight-BreakBulk
    • AirRideVan
    • Barge
    • BargeOpen
    • BilevelRailcarFullyEnclosed
    • BilevelRailcarFullyOpen
    • BilevelRailcarScreened-NoRoof
    • BilevelRailcarScreenedWithRoof
    • Bogie
    • Boxcar
    • BoxcarCushionUnderFrameOf
    • Boxcar-DamageFreeEquipped
    • Boxcar-Insulated
    • Boxcar-InteriorBulkheads
    • BoxPallet
    • Caboose
    • Chassis
    • Chassis-Gooseneck
    • ClosedContainer
    • ClosedContainer-ControlledTemperature
    • ClosedVan
    • Coil-CarCovered
    • CoilCarOpen
    • Container
    • Container-Aluminum
    • Container-Bulk
    • Container-ClosedTop-LengthUnspecified
    • Container-HeatedOrInsulatedOrVentilated
    • Container-HighSideOpenTop
    • ContainerIc20Feet - A container owned by InterContainer, a European railway subsidiary, with a length of 20 feet.
    • ContainerIc30Feet - A container owned by InterContainer, a European railway subsidiary, with a length of 30 feet.
    • ContainerIc40Feet - A container owned by InterContainer, a European railway subsidiary, with a length of 40 feet.
    • Container-Insulated
    • Container-InsulatedOrVentilated
    • Container-LowSideOpenTop
    • Container-Open-Sided
    • Container-OpenTop-LengthUnspecified
    • Container-Platform
    • ContainerRestingOnAChassis
    • Container-Steel
    • Container-Tank
    • Container-Tank-Chemicals
    • Container-Tank-FoodGrade-Liquid
    • Container-Tank-Gas
    • Container-Upgraded
    • Container-Vented
    • ContainerWithBagHangers
    • ContainerWithFloorSecuringRings
    • ContainerWithFlushDoors
    • ContainerWithHangarBars
    • ContainerWithSmoothSides
    • ContainerWithWavyOrRippleSides
    • ControlledTemperatureTrailer-Reefer
    • ControlUnit
    • CoveredBarge
    • Cut-InHelper
    • DimeCoatedTank
    • Double-DropTrailer
    • DropBackTrailer
    • DualTrailers - Two trailers linked together one behind another and pulled by one tractor.
    • EndOfTrainDevice
    • EpoxyCoatedTank
    • EuroPallet - 80 x 120 cm.
    • ExchangeablePallet - Standard pallet exchangeable following international convention.
    • Fixed-Rack-DoubleDropTrailer
    • Fixed-Rack-Flat-BedTrailer
    • Fixed-Rack-Single-DropTrailer
    • FlatbedSlidingTandem
    • FlatBedTrailer
    • FlatBedTrailer-RemovableSides
    • FlatBedTrailerWithHeadboards
    • FlatBedTrailerWithNoHeadboards
    • FlatCar
    • FlatCar-EndBulkheads
    • FlatcarWithPedestal
    • FrozenFoodTrailer
    • GeneratorSet
    • GondolaCar-Covered-InteriorBulkheads
    • GondolaCar-Open
    • GondolaCovered
    • HalfHeightFlatRack
    • Head-EndHelperUnit
    • HeadOfTrainDevice
    • HighCubeVan
    • HopperCar-Covered
    • HopperCar-Covered-PneumaticDischarge
    • HopperCar-Open
    • Hydrant-Cart
    • IdlerCar
    • IMO1 - Description to be provided.
    • IMO2 - Description to be provided.
    • IMO3 - Description to be provided.
    • LoadOrUnloadDeviceOnEquipment
    • Locomotive
    • MovableCase-Between10.90MAnd13.75M - A movable case with a length between 10,90 metres and 13,75 metres.
    • MovableCase-Between6.15MAnd7.82M - A movable case with a length between 6,15 metres and 7,82 metres.
    • MovableCase-Between7.82MAnd9.15M - A movable case with a length between 7,82 metres and 9,15 metres.
    • MovableCase-Between9.15MAnd10.90M - A movable case with a length between 9,15 metres and 10,90 metres.
    • MovableCase-LessThan6.15M - A movable case with a length less than 6,15 metres.
    • NonworkingReeferContainer20Ft - A 20 foot refrigerated container that is not actively controlling temperature of the product.
    • NonworkingReeferContainer40Ft - A 40 foot refrigerated container that is not actively controlling temperature of the product.
    • NonWorkingRefrigeratedOrReeferContainer30Ft - A 30 foot refrigerated (reefer) container that is not actively cooling the product.
    • OceanVessel-BreakBulk
    • Open-TopOrFlatbedTrailer
    • OpenTopVan
    • Pick-UpTruck
    • PowerPack
    • PressurizedTank
    • ProtectedTrailer
    • RailCar
    • RailroadMaintenanceOfWayCar
    • Rear-EndHelperUnit
    • RefrigeratedContainer
    • RefrigeratedOrReeferCar
    • RefrigeratedTank
    • RefrigeratedTank20Feet - A refrigerated tank with a length of 20 feet.
    • RefrigeratedTank30Feet - A refrigerated tank with a length of 30 feet.
    • RefrigeratedTank40Feet - A refrigerated tank with a length of 40 feet.
    • RefrigeratedTankIc20Feet - A refrigerated tank owned by InterContainer, a European railway subsidiary, with a length of 20 feet.
    • RefrigeratedTankIc40Feet - A refrigerated tank owned by InterContainer, a European railway subsidiary, with a length of 40 feet.
    • RemovableSideTrailer
    • Roadrailer
    • Saddle
    • ScandinavianPallet - 100 x 120 cm.
    • Semi-Refrigerated
    • Semi-Trailer - Non self propelled vehicle without front wheels designed for the carriage of cargo and provided with a kingpin.
    • ServiceCar
    • Single-DropTrailer
    • StackCar
    • StainlessSteelTank
    • Stak-Rak
    • TankCar
    • TankContainer20Feet - A tank container with a length of 20 feet.
    • TankContainer30Feet - A tank container with a length of 30 feet.
    • TankContainer40Feet - A tank container with a length of 40 feet.
    • TankContainerIc20Feet - A tank container owned by InterContainer, a European railway subsidiary, with a length of 20 feet.
    • TankContainerIc30Feet - A tank container owned by InterContainer, a European railway subsidiary, with a length of 30 feet.
    • TankContainerIc40Feet - A tank container, owned by InterContainer, a European railway subsidiary, with a length of 40 feet.
    • TelescopingTrailer
    • TemperatureControlledContainer20Ft - Temperature controlled container measuring 20 feet.
    • TemperatureControlledContainer30Ft - Temperature controlled container measuring 30 feet.
    • TemperatureControlledContainer40Ft - A temperature controlled container measuring 40 feet.
    • Totebin - A steel open top unit of about 1,5 * 1,5 * 2,5 meters for road transport of bulk cargo.
    • Tractor
    • Trailer - Non self-propelled vehicle designed for the carriage of cargo so that it can be towed by a motor vehicle.
    • Trailer-Boat
    • Trailer-Car
    • Trailer-DryFreight
    • Trailer-ElectricHeat
    • Trailer-HeatedOrInsulatedOrVentilated
    • Trailer-Insulated
    • Trailer-InsulatedOrVentilated
    • Trailer-NotOtherwiseSpecified
    • Trailer-Pneumatic
    • Trailer-Refrigerated
    • Trailer-Tank-Chemicals
    • Trailer-Tank-FoodGrade-Liquid
    • Trailer-Tank-Gas
    • TrilevelRailcar20Feet
    • TrilevelRailcarScreened-FullyEnclosed
    • TrilevelRailcarScreened-NoRoof
    • TrilevelRailcarScreened-WithDoors-NoRoof
    • TrilevelRailcarScreened-WithRoof
    • Truck-OpenTop
    • Truck-OpenTopHighSide
    • Truck-OpenTopLowSide
    • Truck-Van
    • UnitLoadDevice
    • Van-SpecialInsideLength-WidthOrHeightRequirements
    • Vessel-Lake
    • Vessel-Ocean
    • Vessel-Ocean-Containership
    • Vessel-Ocean-Lash
    • Vessel-Ocean-Rollon-Rolloff

[^]Code Fragment

    <xsd:simpleType name="EquipmentSizeTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="20FtIlContainer-ClosedTop">
        <xsd:enumeration value="20FtIlContainer-OpenTop">
        <xsd:enumeration value="40FtIlContainer-ClosedTop">
        <xsd:enumeration value="40FtIlContainer-OpenTop">
        <xsd:enumeration value="Aircraft">
        <xsd:enumeration value="AirFreight-BreakBulk">
        <xsd:enumeration value="AirRideVan">
        <xsd:enumeration value="Barge">
        <xsd:enumeration value="BargeOpen">
        <xsd:enumeration value="BilevelRailcarFullyEnclosed">
        <xsd:enumeration value="BilevelRailcarFullyOpen">
        <xsd:enumeration value="BilevelRailcarScreened-NoRoof">
        <xsd:enumeration value="BilevelRailcarScreenedWithRoof">
        <xsd:enumeration value="Bogie">
        <xsd:enumeration value="Boxcar">
        <xsd:enumeration value="BoxcarCushionUnderFrameOf">
        <xsd:enumeration value="Boxcar-DamageFreeEquipped">
        <xsd:enumeration value="Boxcar-Insulated">
        <xsd:enumeration value="Boxcar-InteriorBulkheads">
        <xsd:enumeration value="BoxPallet">
        <xsd:enumeration value="Caboose">
        <xsd:enumeration value="Chassis">
        <xsd:enumeration value="Chassis-Gooseneck">
        <xsd:enumeration value="ClosedContainer">
        <xsd:enumeration value="ClosedContainer-ControlledTemperature">
        <xsd:enumeration value="ClosedVan">
        <xsd:enumeration value="Coil-CarCovered">
        <xsd:enumeration value="CoilCarOpen">
        <xsd:enumeration value="Container">
        <xsd:enumeration value="Container-Aluminum">
        <xsd:enumeration value="Container-Bulk">
        <xsd:enumeration value="Container-ClosedTop-LengthUnspecified">
        <xsd:enumeration value="Container-HeatedOrInsulatedOrVentilated">
        <xsd:enumeration value="Container-HighSideOpenTop">
        <xsd:enumeration value="ContainerIc20Feet">
        <xsd:enumeration value="ContainerIc30Feet">
        <xsd:enumeration value="ContainerIc40Feet">
        <xsd:enumeration value="Container-Insulated">
        <xsd:enumeration value="Container-InsulatedOrVentilated">
        <xsd:enumeration value="Container-LowSideOpenTop">
        <xsd:enumeration value="Container-Open-Sided">
        <xsd:enumeration value="Container-OpenTop-LengthUnspecified">
        <xsd:enumeration value="Container-Platform">
        <xsd:enumeration value="ContainerRestingOnAChassis">
        <xsd:enumeration value="Container-Steel">
        <xsd:enumeration value="Container-Tank">
        <xsd:enumeration value="Container-Tank-Chemicals">
        <xsd:enumeration value="Container-Tank-FoodGrade-Liquid">
        <xsd:enumeration value="Container-Tank-Gas">
        <xsd:enumeration value="Container-Upgraded">
        <xsd:enumeration value="Container-Vented">
        <xsd:enumeration value="ContainerWithBagHangers">
        <xsd:enumeration value="ContainerWithFloorSecuringRings">
        <xsd:enumeration value="ContainerWithFlushDoors">
        <xsd:enumeration value="ContainerWithHangarBars">
        <xsd:enumeration value="ContainerWithSmoothSides">
        <xsd:enumeration value="ContainerWithWavyOrRippleSides">
        <xsd:enumeration value="ControlledTemperatureTrailer-Reefer">
        <xsd:enumeration value="ControlUnit">
        <xsd:enumeration value="CoveredBarge">
        <xsd:enumeration value="Cut-InHelper">
        <xsd:enumeration value="DimeCoatedTank">
        <xsd:enumeration value="Double-DropTrailer">
        <xsd:enumeration value="DropBackTrailer">
        <xsd:enumeration value="DualTrailers">
        <xsd:enumeration value="EndOfTrainDevice">
        <xsd:enumeration value="EpoxyCoatedTank">
        <xsd:enumeration value="EuroPallet">
        <xsd:enumeration value="ExchangeablePallet">
        <xsd:enumeration value="Fixed-Rack-DoubleDropTrailer">
        <xsd:enumeration value="Fixed-Rack-Flat-BedTrailer">
        <xsd:enumeration value="Fixed-Rack-Single-DropTrailer">
        <xsd:enumeration value="FlatbedSlidingTandem">
        <xsd:enumeration value="FlatBedTrailer">
        <xsd:enumeration value="FlatBedTrailer-RemovableSides">
        <xsd:enumeration value="FlatBedTrailerWithHeadboards">
        <xsd:enumeration value="FlatBedTrailerWithNoHeadboards">
        <xsd:enumeration value="FlatCar">
        <xsd:enumeration value="FlatCar-EndBulkheads">
        <xsd:enumeration value="FlatcarWithPedestal">
        <xsd:enumeration value="FrozenFoodTrailer">
        <xsd:enumeration value="GeneratorSet">
        <xsd:enumeration value="GondolaCar-Covered-InteriorBulkheads">
        <xsd:enumeration value="GondolaCar-Open">
        <xsd:enumeration value="GondolaCovered">
        <xsd:enumeration value="HalfHeightFlatRack">
        <xsd:enumeration value="Head-EndHelperUnit">
        <xsd:enumeration value="HeadOfTrainDevice">
        <xsd:enumeration value="HighCubeVan">
        <xsd:enumeration value="HopperCar-Covered">
        <xsd:enumeration value="HopperCar-Covered-PneumaticDischarge">
        <xsd:enumeration value="HopperCar-Open">
        <xsd:enumeration value="Hydrant-Cart">
        <xsd:enumeration value="IdlerCar">
        <xsd:enumeration value="IMO1">
        <xsd:enumeration value="IMO2">
        <xsd:enumeration value="IMO3">
        <xsd:enumeration value="LoadOrUnloadDeviceOnEquipment">
        <xsd:enumeration value="Locomotive">
        <xsd:enumeration value="MovableCase-Between10.90MAnd13.75M">
        <xsd:enumeration value="MovableCase-Between6.15MAnd7.82M">
        <xsd:enumeration value="MovableCase-Between7.82MAnd9.15M">
        <xsd:enumeration value="MovableCase-Between9.15MAnd10.90M">
        <xsd:enumeration value="MovableCase-LessThan6.15M">
        <xsd:enumeration value="NonworkingReeferContainer20Ft">
        <xsd:enumeration value="NonworkingReeferContainer40Ft">
        <xsd:enumeration value="NonWorkingRefrigeratedOrReeferContainer30Ft">
        <xsd:enumeration value="OceanVessel-BreakBulk">
        <xsd:enumeration value="Open-TopOrFlatbedTrailer">
        <xsd:enumeration value="OpenTopVan">
        <xsd:enumeration value="Pick-UpTruck">
        <xsd:enumeration value="PowerPack">
        <xsd:enumeration value="PressurizedTank">
        <xsd:enumeration value="ProtectedTrailer">
        <xsd:enumeration value="RailCar">
        <xsd:enumeration value="RailroadMaintenanceOfWayCar">
        <xsd:enumeration value="Rear-EndHelperUnit">
        <xsd:enumeration value="RefrigeratedContainer">
        <xsd:enumeration value="RefrigeratedOrReeferCar">
        <xsd:enumeration value="RefrigeratedTank">
        <xsd:enumeration value="RefrigeratedTank20Feet">
        <xsd:enumeration value="RefrigeratedTank30Feet">
        <xsd:enumeration value="RefrigeratedTank40Feet">
        <xsd:enumeration value="RefrigeratedTankIc20Feet">
        <xsd:enumeration value="RefrigeratedTankIc40Feet">
        <xsd:enumeration value="RemovableSideTrailer">
        <xsd:enumeration value="Roadrailer">
        <xsd:enumeration value="Saddle">
        <xsd:enumeration value="ScandinavianPallet">
        <xsd:enumeration value="Semi-Refrigerated">
        <xsd:enumeration value="Semi-Trailer">
        <xsd:enumeration value="ServiceCar">
        <xsd:enumeration value="Single-DropTrailer">
        <xsd:enumeration value="StackCar">
        <xsd:enumeration value="StainlessSteelTank">
        <xsd:enumeration value="Stak-Rak">
        <xsd:enumeration value="TankCar">
        <xsd:enumeration value="TankContainer20Feet">
        <xsd:enumeration value="TankContainer30Feet">
        <xsd:enumeration value="TankContainer40Feet">
        <xsd:enumeration value="TankContainerIc20Feet">
        <xsd:enumeration value="TankContainerIc30Feet">
        <xsd:enumeration value="TankContainerIc40Feet">
        <xsd:enumeration value="TelescopingTrailer">
        <xsd:enumeration value="TemperatureControlledContainer20Ft">
        <xsd:enumeration value="TemperatureControlledContainer30Ft">
        <xsd:enumeration value="TemperatureControlledContainer40Ft">
        <xsd:enumeration value="Totebin">
        <xsd:enumeration value="Tractor">
        <xsd:enumeration value="Trailer">
        <xsd:enumeration value="Trailer-Boat">
        <xsd:enumeration value="Trailer-Car">
        <xsd:enumeration value="Trailer-DryFreight">
        <xsd:enumeration value="Trailer-ElectricHeat">
        <xsd:enumeration value="Trailer-HeatedOrInsulatedOrVentilated">
        <xsd:enumeration value="Trailer-Insulated">
        <xsd:enumeration value="Trailer-InsulatedOrVentilated">
        <xsd:enumeration value="Trailer-NotOtherwiseSpecified">
        <xsd:enumeration value="Trailer-Pneumatic">
        <xsd:enumeration value="Trailer-Refrigerated">
        <xsd:enumeration value="Trailer-Tank-Chemicals">
        <xsd:enumeration value="Trailer-Tank-FoodGrade-Liquid">
        <xsd:enumeration value="Trailer-Tank-Gas">
        <xsd:enumeration value="TrilevelRailcar20Feet">
        <xsd:enumeration value="TrilevelRailcarScreened-FullyEnclosed">
        <xsd:enumeration value="TrilevelRailcarScreened-NoRoof">
        <xsd:enumeration value="TrilevelRailcarScreened-WithDoors-NoRoof">
        <xsd:enumeration value="TrilevelRailcarScreened-WithRoof">
        <xsd:enumeration value="Truck-OpenTop">
        <xsd:enumeration value="Truck-OpenTopHighSide">
        <xsd:enumeration value="Truck-OpenTopLowSide">
        <xsd:enumeration value="Truck-Van">
        <xsd:enumeration value="UnitLoadDevice">
        <xsd:enumeration value="Van-SpecialInsideLength-WidthOrHeightRequirements">
        <xsd:enumeration value="Vessel-Lake">
        <xsd:enumeration value="Vessel-Ocean">
        <xsd:enumeration value="Vessel-Ocean-Containership">
        <xsd:enumeration value="Vessel-Ocean-Lash">
        <xsd:enumeration value="Vessel-Ocean-Rollon-Rolloff">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: EquipmentStatusCodeType

EquipmentStatusCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the status of the equipment. This code list is derived from EDIFACT 8249

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • Continental - The equipment is or will be moving across a continent on an intermodal or multimodal basis.
    • Export - Transport equipment to be exported on a marine vessel.
    • Import - Transport equipment to be imported on a marine vessel.
    • RemainOnBoard - Transport equipment arriving on a marine vessel is to remain on board.
    • Shifter - Transport equipment is to be shifted from one stowage location on a marine vessel to another on the same vessel.
    • Transhipment - Transport equipment is to be transferred from one marine vessel to another.
    • Shortlanded - Transport equipment notified to arrive which did not arrive on the means of transport.
    • Overlanded - Transport equipment not notified to arrive but which did arrive on the means of transport.
    • Domestic - Transport equipment is used in domestic service.
    • Positioning - Equipment is being transported for positioning purposes.
    • Delivery - Equipment is being delivered.
    • Redelivery - Equipment is being redelivered.
    • Repair - The equipment is for repair.
    • Reloader - Transport equipment to be discharged and subsequently reloaded on the same means of transport but in a different stowage location.

[^]Code Fragment

    <xsd:simpleType name="EquipmentStatusCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Continental">
        <xsd:enumeration value="Export">
        <xsd:enumeration value="Import">
        <xsd:enumeration value="RemainOnBoard">
        <xsd:enumeration value="Shifter">
        <xsd:enumeration value="Transhipment">
        <xsd:enumeration value="Shortlanded">
        <xsd:enumeration value="Overlanded">
        <xsd:enumeration value="Domestic">
        <xsd:enumeration value="Positioning">
        <xsd:enumeration value="Delivery">
        <xsd:enumeration value="Redelivery">
        <xsd:enumeration value="Repair">
        <xsd:enumeration value="Reloader">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: ErrorInfoType

ErrorInfoType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( CompletionText[xsd:string] , CompletionMsg[LanguageStringType] , Severity[SeverityType] , ListOfParameter[ListOfParameterType]? , MinRetrySecs[xsd:int]? , SwVendorErrorRef[xsd:string]? )

    Description: ErrorInfoType is used by the receiving application to return complete information about errors encountered during processing of a message.

    Elements:

    • CompletionText - is the error code produced. A complete list of error codes is available elsewhere, specific to the message that uses this module.
    • CompletionMsg - is the error message
    • Severity - states the severity of the error encountered.
    • ListOfParameter - is an optional field that can be used to pass extra information to the caller about an error. In a way, the motivation of this field is similar to the IOTP's PackagedContent concept. For example, a buyer and a supplier can agree that under the situation where the supplier does not have enough stock, it will pass these three parameters: Param1 SKU#, Param2 Buyer Requested Delivery Date, Param3 The date when supplier will be able to fulfil the order
    • MinRetrySecs - is an optional field used to specify the number of seconds that a caller has to wait before sending the retry request. This field is usually used by an error that has severity=Transient
    • SwVendorErrorRef - is the optional software vendor error reference and is used to specify the exact location where the error occurs. It should contain information that enable software vendor to trace back the exact location of the code that generate this code.

[^]Code Fragment

    <xsd:complexType name="ErrorInfoType">
    <xsd:sequence>
        <xsd:element name="CompletionText" type="xsd:string">
        <xsd:element name="CompletionMsg" type="LanguageStringType">
        <xsd:element name="Severity" type="SeverityType">
        <xsd:element minOccurs="0" name="ListOfParameter" type="ListOfParameterType">
        <xsd:element minOccurs="0" name="MinRetrySecs" type="xsd:int">
        <xsd:element minOccurs="0" name="SwVendorErrorRef" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: FIAccountDetailType

FIAccountDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( AccountDetail[AccountDetailType] , FinancialInstitution[FinancialInstitutionType] )

    Description: FIAccountDetailType is a container for the financial institution and account details.

    Elements:

    • AccountDetail - contains information pertinent to identifying a financial institution and an account within the financial institution.
    • FinancialInstitution - identifies the financial institution and branch that holds the account.

[^]Code Fragment

    <xsd:complexType name="FIAccountDetailType">
    <xsd:sequence>
        <xsd:element name="AccountDetail" type="AccountDetailType">
        <xsd:element name="FinancialInstitution" type="FinancialInstitutionType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: FIAccountType

FIAccountType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( AccountDetail[AccountDetailType]? , FinancialInstitution[FinancialInstitutionType] )

    Description: FIAccountType describes account information including account numbers, institution and branch.

    Elements:

    • AccountDetail - contains information pertinent to identifying an account within a financial institution.
    • FinancialInstitution - identifies the financial institution and branch that holds the account.

[^]Code Fragment

    <xsd:complexType name="FIAccountType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="AccountDetail" type="AccountDetailType">
        <xsd:element name="FinancialInstitution" type="FinancialInstitutionType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: FinancialInstitutionDetailType

FinancialInstitutionDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( OriginatingFinancialInstitution[FIAccountDetailType] , ReceivingFinancialInstitution[FIAccountDetailType] , ListOfFinancialInstitution[FinancialInstitutionType]? )

    Description: FinancialInstitutionDetailType contains specifications for the financial institution information which includes both account specific detail (i.e., account ID, account type, account holder) and financial institution specific detail (i.e., bank ID, branch ID). Financial institution information must be provided for the originating bank and associated account detail and the receiving bank and associated account detail.

    Elements:

    • OriginatingFinancialInstitution - contains the financial institution account information of the originating bank. The account detail and financial institution detail are required.
    • ReceivingFinancialInstitution - contains the financial institution account information for the receiving bank. The account detail and financial institution detail are required.
    • ListOfFinancialInstitution - contains a list of other financial institutions or intermediary banks associated with the payment request. The financial institution detail is required; the account detail is optional.

[^]Code Fragment

    <xsd:complexType name="FinancialInstitutionDetailType">
    <xsd:sequence>
        <xsd:element name="OriginatingFinancialInstitution" type="FIAccountDetailType">
        <xsd:element name="ReceivingFinancialInstitution" type="FIAccountDetailType">
        <xsd:element minOccurs="0" name="ListOfFinancialInstitution" type="FinancialInstitutionType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: FinancialInstitutionType

FinancialInstitutionType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( FinancialInstitutionID[xsd:string] , FinancialInstitutionName[xsd:string] , FIBranchID[xsd:string]? , FIBranchAddress[NameAddressType]? )

    Description: FinancialInstitutionType identifies a financial institution and branch.

    Elements:

    • FinancialInstitutionID - identifies the financial institution by code.
    • FinancialInstitutionName - identifies the financial institution by name.
    • FIBranchID - identifies the branch of the financial institution by the branch code.
    • FIBranchAddress - holds the name and address information for the financial institution branch.

[^]Code Fragment

    <xsd:complexType name="FinancialInstitutionType">
    <xsd:sequence>
        <xsd:element name="FinancialInstitutionID" type="xsd:string">
        <xsd:element name="FinancialInstitutionName" type="xsd:string">
        <xsd:element minOccurs="0" name="FIBranchID" type="xsd:string">
        <xsd:element minOccurs="0" name="FIBranchAddress" type="NameAddressType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: FITransferType

FITransferType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( FromFITransfer[FIAccountType]? , ToFITransfer[FIAccountType] , PaymentRecordOther[xsd:string]? )

    Description: FITransferType contains details about the transfer from one financial institution to another.

    Elements:

    • FromFITransfer - identifies the account and financial institution from which the transfer is to originate.
    • ToFITransfer - identifies the account and financial institution to which the transfer it to be made.
    • PaymentRecordOther - contains any free form text description or record of the payment. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information, holds additional information or reference information about the actual payment made.

[^]Code Fragment

    <xsd:complexType name="FITransferType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="FromFITransfer" type="FIAccountType">
        <xsd:element name="ToFITransfer" type="FIAccountType">
        <xsd:element minOccurs="0" name="PaymentRecordOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: Float_16Type

Float_16Type (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    a floating point value with a maximum number of 16 digits.

    Content: Restriction of base type xsd:decimal

      xsd:totalDigits: 16

[^]Code Fragment

    <xsd:simpleType name="Float_16Type">
    <xsd:restriction base="xsd:decimal">
        <xsd:totalDigits value="16">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: FullIndicatorCodeType

FullIndicatorCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the fill status of the equipment. This code list is derived from EDIFACT 8169 (Full/empty indicator, coded)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • Full
    • Empty
    • Partial

[^]Code Fragment

    <xsd:simpleType name="FullIndicatorCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Full">
        <xsd:enumeration value="Empty">
        <xsd:enumeration value="Partial">
    </xsd:restriction>
</xsd:simpleType>


Global Elements (Document Roots):


complexType definition: GPSCoordinatesType

GPSCoordinatesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( GPSSystem[xsd:string] , Latitude[xsd:string] , Longitude[xsd:string] )

    Description: GPSCoordinatesType identifies the location by specific co-ordinates.

    Elements:

    • GPSSystem - identifies the GPS system.
    • Latitude - specifies the latitude of the location.
    • Longitude - specifies the longitude of the location.

[^]Code Fragment

    <xsd:complexType name="GPSCoordinatesType">
    <xsd:sequence>
        <xsd:element name="GPSSystem" type="xsd:string">
        <xsd:element name="Latitude" type="xsd:string">
        <xsd:element name="Longitude" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: HazardClassCodeType

HazardClassCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the hazardous class.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • Primary
    • Secondary

[^]Code Fragment

    <xsd:simpleType name="HazardClassCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Primary">
        <xsd:enumeration value="Secondary">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: HazardousIdentifiersType

HazardousIdentifiersType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( HazardousRegulationsCoded[AgencyCodeType] , HazardousRegulationsCodedOther[xsd:string]? , HazardCode[xsd:string]? , CodeExtension[xsd:string]? , CodeVersion[xsd:string]? , HazardOfficialText[xsd:string]? , TremCardNum[xsd:string]? )

    Description: HazardousIdentifiersType are identifiers that describe specifics of the hazardous codes associated with an item or packaging.

    Elements:

    • HazardousRegulationsCoded - is the agency that assigns the hazard code.
    • HazardousRegulationsCodedOther - is used to provide a non-standard HazardousRegulationsCode. This element is mandatory if the value of HazardousRegulationsCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • HazardCode - is the value of the hazard code.
    • CodeExtension - is an extension to the hazardous packaging code above. Can also be used to hold additional code values such as a Waste Characteristics Code in conjunction with an EPA Waste Stream code.
    • CodeVersion - is the version of the hazardous code.
    • HazardOfficialText - is the official name of the hazardous substance.
    • TremCardNum - is the identification of a transport emergency card, giving advice for emergency actions. Can be used for the identity number of a specific hazardous emergency response plan that is assigned by the Director General of Canada.

[^]Code Fragment

    <xsd:complexType name="HazardousIdentifiersType">
    <xsd:sequence>
        <xsd:element name="HazardousRegulationsCoded" type="AgencyCodeType">
        <xsd:element minOccurs="0" name="HazardousRegulationsCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="HazardCode" type="xsd:string">
        <xsd:element minOccurs="0" name="CodeExtension" type="xsd:string">
        <xsd:element minOccurs="0" name="CodeVersion" type="xsd:string">
        <xsd:element minOccurs="0" name="HazardOfficialText" type="xsd:string">
        <xsd:element minOccurs="0" name="TremCardNum" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: HazardousPlacardInformationType

HazardousPlacardInformationType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( HazardousPlacardIdentification[xsd:string]? , HazardousPlacardText[xsd:string]? )

    Description: HazardousPlacardInformationType is used to specify the placard information required on the means of transport or shipping information.

    Elements:

    • HazardousPlacardIdentification - is the placard notation corresponding to the hazard class of the hazardous commodity. Can also be the hazard identification number of the orange placard (upper part) required on the means of transport.
    • HazardousPlacardText - is used for the placard endorsement that is to be shown on the shipping papers for the hazardous commodity. Can also be used for the number of the orange placard (lower part) required on the means of transport.

[^]Code Fragment

    <xsd:complexType name="HazardousPlacardInformationType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="HazardousPlacardIdentification" type="xsd:string">
        <xsd:element minOccurs="0" name="HazardousPlacardText" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: HazardousShipmentCodeType

HazardousShipmentCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the type of information being passed so that a receiver may format a description of hazardous commodity movements that meet regulatory requirements. This code list is derived from X12 808 (Hazardous material shipment information qualifier)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • AdditionalDescriptiveInformationNotRequiredByRegulationButDesiredToAccompanyTheMovementByTheShipper - Additional Descriptive Information Not Required by Regulation but Desired to Accompany the Movement by the Shipper
    • CargoAirliftOnly - Cargo Airlift Only
    • DOT-113DoNotBumpOrCutOffCarWhileInMotionDeclaration - "DOT - 113, Do Not Bump or Cut Off Car While in Motion" Declaration
    • DamagedCarNumber - Damaged Car Number
    • DangerousWhenWetDeclaration - "Dangerous When Wet" Declaration
    • EMSPageNumber - Emergency Schedule (EMS) Page Number
    • IdentifiesProductsInAHeatedMoltenState - Identifies Products in a Heated Molten State
    • HazardousSubstanceConstituents - Hazardous Substance Constituents
    • InhalationHazard - Inhalation Hazard
    • LimitedQuantityDeclaration - "Limited Quantity" Declaration
    • MFAGPageNumber - Medical First Aid Guide (MFAG) Page Number
    • MaximumOperatingSpeed - Maximum Operating Speed
    • MarinePollutant - Marine Pollutant
    • Poison-InhalationHazardDeclaration - "Poison - Inhalation Hazard" Declaration
    • PoisonDeclaration - "Poison" Declaration
    • RadioactiveMaterialData - Radioactive Material Data
    • TechnicalOrChemicalGroupName - Technical or Chemical Group Name
    • TradeName - Trade Name
    • WasteDeclaration - Waste Declaration

[^]Code Fragment

    <xsd:simpleType name="HazardousShipmentCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="AdditionalDescriptiveInformationNotRequiredByRegulationButDesiredToAccompanyTheMovementByTheShipper">
        <xsd:enumeration value="CargoAirliftOnly">
        <xsd:enumeration value="DOT-113DoNotBumpOrCutOffCarWhileInMotionDeclaration">
        <xsd:enumeration value="DamagedCarNumber">
        <xsd:enumeration value="DangerousWhenWetDeclaration">
        <xsd:enumeration value="EMSPageNumber">
        <xsd:enumeration value="IdentifiesProductsInAHeatedMoltenState">
        <xsd:enumeration value="HazardousSubstanceConstituents">
        <xsd:enumeration value="InhalationHazard">
        <xsd:enumeration value="LimitedQuantityDeclaration">
        <xsd:enumeration value="MFAGPageNumber">
        <xsd:enumeration value="MaximumOperatingSpeed">
        <xsd:enumeration value="MarinePollutant">
        <xsd:enumeration value="Poison-InhalationHazardDeclaration">
        <xsd:enumeration value="PoisonDeclaration">
        <xsd:enumeration value="RadioactiveMaterialData">
        <xsd:enumeration value="TechnicalOrChemicalGroupName">
        <xsd:enumeration value="TradeName">
        <xsd:enumeration value="WasteDeclaration">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: HazardousShipmentInformationType

HazardousShipmentInformationType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( HazardPackingCoded[HazardPackingCodeType]? , HazardPackingCodedOther[xsd:string]? , HazardousShipmentCoded[HazardousShipmentCodeType]? , HazardousShipmentCodedOther[xsd:string]? , HazardousShipmentNote[xsd:string]? , HazardousZoneCoded[HazardousZoneCodeType]? , HazardousZoneCodedOther[xsd:string]? )

    Description: HazardousShipmentInformationType holds information related to the shipping and packaging of hazardous goods.

    Elements:

    • HazardPackingCoded - identifies the hazardous packaging information.
    • HazardPackingCodedOther - is used to provide a non-standard HazardPackingCode. This element is mandatory if the value of HazardPackingCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • HazardousShipmentCoded - indicates the type of information being passed so that a receiver may format a description of hazardous commodity movements that meets regulatory requirements
    • HazardousShipmentCodedOther - is used to provide a non-standard HazardousShipmentCode. This element is mandatory if the value of HazardousShipmentCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • HazardousShipmentNote - is used to provide specific information required by law for hazardous material shipments or any free form text relating to hazardous shipments.
    • HazardousZoneCoded - is used to specify the Department of Transportation assigned zone designating the Inhalation Toxicity Hazard Zone
    • HazardousZoneCodedOther - is used to provide a non-standard HazardousZoneCode. This element is mandatory if the value of HazardousZoneCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="HazardousShipmentInformationType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="HazardPackingCoded" type="HazardPackingCodeType">
        <xsd:element minOccurs="0" name="HazardPackingCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="HazardousShipmentCoded" type="HazardousShipmentCodeType">
        <xsd:element minOccurs="0" name="HazardousShipmentCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="HazardousShipmentNote" type="xsd:string">
        <xsd:element minOccurs="0" name="HazardousZoneCoded" type="HazardousZoneCodeType">
        <xsd:element minOccurs="0" name="HazardousZoneCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: HazardousTemperaturesType

HazardousTemperaturesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( Flashpoint[MeasurementType]? , Emergency[MeasurementType]? , Control[MeasurementType]? , ListOfTemperatureCoded[ListOfDimensionType]? )

    Description: HazardousTemperaturesType contains the various temperatures that relate to the item or package, such as flashpoint, control, and emergency.

    Elements:

    • Flashpoint - is the lowest temperature at which the vapor of a combustible liquid can be made to ignite momentarily in air.
    • Emergency - is the temperature at which emergency procedures apply for the disposal of temperature-controlled goods.
    • Control - is the maximum temperature at which certain products can be safely transported.
    • ListOfTemperatureCoded - holds a list of one or more temperatures.

[^]Code Fragment

    <xsd:complexType name="HazardousTemperaturesType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="Flashpoint" type="MeasurementType">
        <xsd:element minOccurs="0" name="Emergency" type="MeasurementType">
        <xsd:element minOccurs="0" name="Control" type="MeasurementType">
        <xsd:element minOccurs="0" name="ListOfTemperatureCoded" type="ListOfDimensionType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: HazardousType

HazardousType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ListOfHazardousIdentifiers[ListOfHazardousIdentifiersType]? , HazardClassCoded[HazardClassCodeType]? , HazardClassCodedOther[xsd:string]? , HazardousPlacardInformation[HazardousPlacardInformationType]? , HazardousReferences[ListOfReferenceCodedType]? , HazardousContact[ContactType]? , HazardNote[xsd:string]? , UNDGNum[xsd:int]? , HazardousTemperatures[HazardousTemperaturesType]? , HazardousShipmentInformation[HazardousShipmentInformationType]? , EMSNum[xsd:string]? , Mfag[xsd:string]? )

    Description: HazardousType specifies the hazardous information required for safe handling of an item or package.

    Elements:

    • ListOfHazardousIdentifiers - is a list of identifiers that are in reference to the hazardous material being described.
    • HazardClassCoded - is a code qualifying hazardous class. Values are primary or secondary.
    • HazardClassCodedOther - is used to specify a non-standard HazardClassCode. This element is mandatory if the value of HazardClassCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • HazardousPlacardInformation - is used to specify the placard information required on the means of transport or shipping information.
    • HazardousReferences - is used to transmit specific hazardous material reference numbers.
    • HazardousContact - is the seller's contact for more information on the hazardous information
    • HazardNote - provides additional information regarding the hazardous substance. (Can be used to hold information such as the type of regulatory requirements that apply to a description, e.g. N.O.S.)
    • UNDGNum - contains a unique serial number assigned within the United Nations to substances and articles contained in a list of the dangerous goods most commonly carried.
    • HazardousTemperatures - contains the various temperatures that relate to the item or package, such as flashpoint, control, and emergency.
    • HazardousShipmentInformation - holds information related to the shipping and packaging of hazardous goods.
    • EMSNum - is the emergency procedures for ships carrying dangerous goods.
    • Mfag - is the medical first aid guide.

[^]Code Fragment

    <xsd:complexType name="HazardousType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ListOfHazardousIdentifiers" type="ListOfHazardousIdentifiersType">
        <xsd:element minOccurs="0" name="HazardClassCoded" type="HazardClassCodeType">
        <xsd:element minOccurs="0" name="HazardClassCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="HazardousPlacardInformation" type="HazardousPlacardInformationType">
        <xsd:element minOccurs="0" name="HazardousReferences" type="ListOfReferenceCodedType">
        <xsd:element minOccurs="0" name="HazardousContact" type="ContactType">
        <xsd:element minOccurs="0" name="HazardNote" type="xsd:string">
        <xsd:element minOccurs="0" name="UNDGNum" type="xsd:int">
        <xsd:element minOccurs="0" name="HazardousTemperatures" type="HazardousTemperaturesType">
        <xsd:element minOccurs="0" name="HazardousShipmentInformation" type="HazardousShipmentInformationType">
        <xsd:element minOccurs="0" name="EMSNum" type="xsd:string">
        <xsd:element minOccurs="0" name="Mfag" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: HazardousZoneCodeType

HazardousZoneCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the Department of Transportation assigned zone designating the inhalation toxicity hazard zone. This is code list is derived from X12 1023 (Hazard zone code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • HazardZoneA
    • HazardZoneB
    • HazardZoneC
    • HazardZoneD

[^]Code Fragment

    <xsd:simpleType name="HazardousZoneCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="HazardZoneA">
        <xsd:enumeration value="HazardZoneB">
        <xsd:enumeration value="HazardZoneC">
        <xsd:enumeration value="HazardZoneD">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: HazardPackingCodeType

HazardPackingCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the packing criteria for hazardous materials as assigned by IATA/IMDB/ADR/RID. Minor Damage is equal to III. Meduim Danger is equal to II. Great Damage is equal to I. This code list is derived from EDIFACT 8339 (Packing group code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom code
    • NotSpecified - No criteria specified
    • GreatDanger - Must meet criteria to pack hazardous materials with great danger (Group I)
    • MediumDanger - Must meet criteria to pack hazardous materials with medium danger (Group II)
    • MinorDanger - Must meet criteria to pack hazardous materials with minor danger (Group III)

[^]Code Fragment

    <xsd:simpleType name="HazardPackingCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="NotSpecified">
        <xsd:enumeration value="GreatDanger">
        <xsd:enumeration value="MediumDanger">
        <xsd:enumeration value="MinorDanger">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: IBANType

IBANType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:

    Content: Restriction of base type xsd:normalizedString

      xsd:maxLength: 34
      xsd:pattern: [A-Z]{2}.*

[^]Code Fragment

    <xsd:simpleType name="IBANType">
    <xsd:restriction base="xsd:normalizedString">
        <xsd:maxLength value="34">
        <xsd:pattern value="[A-Z]{2}.*">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: IDAssignedByType

IDAssignedByType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( IDAssignedByCoded[PartyRoleCodeType] , IDAssignedByCodedOther[xsd:string]? )

    Description: IDAssignedByType identifies who assigns the MessageID to the message.

    Elements:

    • IDAssignedByCoded - identifies the role of the party that assigned the ID.
    • IDAssignedByCodedOther - is used to provide a non-standard PartyRoleCode. This element is mandatory if the value of PartyRoleCode is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="IDAssignedByType">
    <xsd:sequence>
        <xsd:element name="IDAssignedByCoded" type="PartyRoleCodeType">
        <xsd:element minOccurs="0" name="IDAssignedByCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: IdentifierType

IdentifierType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( Agency[AgencyType]? , Ident[xsd:string] )

    Description: IdentifierType is used to provide an identification number that is assigned by a standards agency.

    Elements:

    • Agency - identifies the standards agency, and if necessary, the codelist which the identification belongs to.
    • Ident - holds the identification number assigned by the agency.

[^]Code Fragment

    <xsd:complexType name="IdentifierType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="Agency" type="AgencyType">
        <xsd:element name="Ident" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: IndicatorCodeType

IndicatorCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies whether an allowance or charge applies. This code list is derived from EDIFACT 5463 (Allowance) and X12 248 (Allowance Or Charge Indicator)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • About - To be construed as allowing a difference not exceeding 10 % more or 10 % less than the amount which it refers.
    • Adjustment
    • Allowance
    • AllowanceLineItems - Allowance is related to all line items in a message as a default allowance. It may be overridden per line item.
    • AllowanceMessage - Allowance is related to the entire message.
    • AllowancePerCallOf
    • AllowanceRequest
    • Charge
    • ChargeLineItems - Charge is related to all line items in a message as a default charge. It may be overridden per line item.
    • ChargeMessage - Charge is related to the entire message.
    • ChargePerCallOf
    • ChargeRequest
    • Exact - Indicates that this is the exact amount.
    • LineItemAllowance - Allowance is related to a line item. It can override a default allowance.
    • LineItemCharge - Charge is related to a line item. It can override a default charge.
    • Maximum - Highest possible value; maximum; not exceeding; up to.
    • Minus-Amount - The lesser value expressed in amount.
    • Minus-Percentage - The lesser value expressed in percentage.
    • NoAllowance
    • NoAllowanceOrCharge - No increases or reduction in price (list or stated) are included.
    • NoCharge
    • Plus-Amount - The greater value expressed in amount.
    • Plus-Percentage - The greater value expressed in percentage.
    • PlusOrMinusOrAmount - The greater/lesser value expressed in amount.
    • PlusOrMinus-Percentage - The greater/lesser value expressed in percentage.
    • Promotion
    • Service
    • TotalOther - The total for items other than those primarily reported upon in the message.

[^]Code Fragment

    <xsd:simpleType name="IndicatorCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="About">
        <xsd:enumeration value="Adjustment">
        <xsd:enumeration value="Allowance">
        <xsd:enumeration value="AllowanceLineItems">
        <xsd:enumeration value="AllowanceMessage">
        <xsd:enumeration value="AllowancePerCallOf">
        <xsd:enumeration value="AllowanceRequest">
        <xsd:enumeration value="Charge">
        <xsd:enumeration value="ChargeLineItems">
        <xsd:enumeration value="ChargeMessage">
        <xsd:enumeration value="ChargePerCallOf">
        <xsd:enumeration value="ChargeRequest">
        <xsd:enumeration value="Exact">
        <xsd:enumeration value="LineItemAllowance">
        <xsd:enumeration value="LineItemCharge">
        <xsd:enumeration value="Maximum">
        <xsd:enumeration value="Minus-Amount">
        <xsd:enumeration value="Minus-Percentage">
        <xsd:enumeration value="NoAllowance">
        <xsd:enumeration value="NoAllowanceOrCharge">
        <xsd:enumeration value="NoCharge">
        <xsd:enumeration value="Plus-Amount">
        <xsd:enumeration value="Plus-Percentage">
        <xsd:enumeration value="PlusOrMinusOrAmount">
        <xsd:enumeration value="PlusOrMinus-Percentage">
        <xsd:enumeration value="Promotion">
        <xsd:enumeration value="Service">
        <xsd:enumeration value="TotalOther">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: ItemCharacteristicCodeType

ItemCharacteristicCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the characteristic of an item. This code list is derived from EDIFACT 7081 (Item characteristic code) and X12 750 (Product/process characteristic code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • AdditionalSectorialCharacteristics - A code issued on a sectorial basis which identifies any additional characteristics of a product.
    • Age
    • AlcoholBeverageClass - Class characteristics for different compositions of alcoholic beverages.
    • AlcoholBeverageType - A descriptive term that further defines the class of an alcoholic beverage.
    • Alloy - A homogeneous mixture or solid solution usually of two or more metals.
    • AnatomicalOriginOfSample - Anatomical origin of sample.
    • Appearance - The outward aspect or semblance.
    • Artist - The performing artist(es) of a recorded song or piece of music.
    • AssemblyRequired
    • Author - The author of a written work.
    • BalanceOutArticle -
    • BasisWeightSize
    • Behind-the-CounterDrugs
    • BeverageAge - The period during which, after distillation and before bottling, distilled spirits have been stored in containers.
    • BeverageBrand - A grouping of beverage products similar in name only, but of different size, age, proof, quality and flavour.
    • BeverageCategory - A description to designate the beverage category.
    • BeverageContainerCharacteristics - A description of various beverage container characteristics.
    • BeverageFlavour - Distinctions from the base product that results in a different taste.
    • BeverageSegment
    • Binding - A description of the type of binding used for a written work.
    • BottomholeLocationMethod - Code indicating the method for locating the lowest part or surface of a works.
    • BottomholePressureMethod - Code indicating the method for measuring pressures at the lowest part or surface of a works.
    • BrandGroup
    • BrandGroup-AGroupingOfSimilarBrands
    • BureauofAlcoholTobaccoAndFirearmsClassCode
    • BureauOfAlcoholTobaccoAndFirearmsTypeCode
    • BuyersColorDescription
    • BuyersItemSizeDescription
    • Casing-Liner-TubingType
    • CasingOrLinerType - Code indicating the protective or covering part of a natural or manufactured object.
    • CertificateOfConformity - Product in conformity with specifications.
    • Chassis - Code indicating the discrete identification of the chassis characteristics.
    • ChemicalFamilyName - Code indicating the product's chemical family name.
    • Chemistry - Code indicating the product's chemical characteristics.
    • CID-CommercialItemDescription
    • Coating - Description of any special coating required/available on the product.
    • CoatingOrPaintSystemCode
    • CoatingOrPaintSystemName
    • Collateral - Code indicating the product's accompanying or coinciding characteristics.
    • CollectionMethodCode
    • Color
    • Color-LowerBody
    • Color-UpperBody
    • CommercialStatus
    • CommonChemicalName - Code indicating the product's common chemical name.
    • CompanyFieldCode
    • ComplianceMethod - Code indicating the product's compliance method characteristics.
    • Composer - The composer of a recorded song or piece of music.
    • ConditionedCode
    • ConstructionMethod - Description of the method of construction.
    • ConsumableResource - A code to identify resources that are consumed.
    • ConsumerInstructions
    • ControlItem - Security relevant product with special quality control and control documentation prescriptions.
    • ControlledSubstance - Code indicating the controlled substance characteristics.
    • ControlledSubstance-Class2
    • ControlledSubstance-Class3Narcotic
    • ControlledSubstance-Class3NNon-narcotic
    • ControlledSubstance-Class4
    • ControlledSubstance-Class5
    • CoordinateDescriptionCode
    • Coordinates - Code indicating the product's coordinates in non-numeric terms.
    • CorrosionResistance - The characteristics describing the resistance to chemical deterioration.
    • Coupling
    • CurrentArticle -
    • CurrentArticleSpares -
    • CustomsSpecifications - Item characteristic is described following Customs specifications.
    • DamageCode
    • DamageFault
    • Denier - The unit of fineness for yarns.
    • Density - A code indicating the relation of weight to volume using non-discrete values.
    • Dimensional - Code indicating the product's dimensional characteristics in non-numeric terms.
    • DirectionalIndicator
    • Dispersion - The separation of visible light into its colour components by refraction or diffraction.
    • DosageForm - Code indicating the physical form of the dosage.
    • DrugEfficacy - Code indicating the drug's capacity or ability to produce the desired effects.
    • DrugEfficacyStudyImplementation
    • DyeLot - Code indicating the product's dye lot characteristics.
    • DyeLotDescription
    • EdgeTreatment - Description of any special edge treatment required/performed on the product.
    • Edition - Description of the edition of a written work.
    • Editor
    • Electrical - Code indicating the product's electrical characteristics.
    • ElectronicallyCleaned
    • ElectronicField - Code indicating the product's electronic field characteristics.
    • Ends-Slitting-Splitting-Cutting
    • EndTreatment - Description of any special treatment required/performed on the ends the product.
    • EndUseApplication - Description of what the end use application of the product will be.
    • Engine - Code indicating the discrete identification of the engine characteristics.
    • EnginewithTransmission
    • Equipment - Code indicating the category of equipment.
    • EscrowCode
    • EuropeanCommunityRiskClass - European community classification "CE" indicating the safety risk of an article.
    • Fabric - Code indicating the product's fabric characteristics.
    • FabricDescription
    • FailureAnalysisProcess
    • FEDSPEC-FederalSpecification
    • FED-STD-FederalStandard
    • Fiber - A threadlike or filament forming part of a product.
    • FibreTow - The fibre of flax, hemp or jute prepared for low-grade spinning.
    • FieldCode-EIAOrDOD
    • FieldTest - First series of a new item to be tested by end users.
    • Filament - A fine wire heated electrically to incandescence.
    • Filter - Code indicating the product's filter characteristics.
    • Finish - Description of the finish required/available on the product.
    • FinishOrSurfaceRoughness
    • Flavor
    • Flow - The movement or run in the manner of a liquid.
    • Fluid - Code indicating the product's fluid characteristics.
    • FoldConfiguration - Code indicating the product's fold configuration characteristics.
    • Font - This value identifies a font by name.
    • ForecastDeviation
    • Forming - Description of any forming required/performed on the product.
    • Formula - Code indicating the formula characteristics in non- numeric terms.
    • Fragrance
    • Fuel - Code indicating the fuel characteristics.
    • FunctionalPerformance - Code indicating the product's functional performance characteristics.
    • FurtherIdentifyingCharacteristic - Description of further identifying characteristic of a product which enables the product to be distinguished from any similar products.
    • GeneralDescription
    • GeneralMerchandise
    • GeneralProductForm - Description of general product form.
    • GenericDrug - A drug name specially given in order that it may be freely used without legal restriction.
    • Goods
    • Grade - Specification of the grade required/available for the product.
    • GrainDirection - Specifies the direction of the grain of the product.
    • GrapeVariety
    • HazardousMaterial
    • HazardRatingSystem
    • HealthAndBeautyAids
    • HeatTreatOrAnneal - Description of any heat treatment or annealing required/performed on the product.
    • Hydraulics - The characteristics of a liquid conveyed under pressure through pipes or channels.
    • Ingredient - A component part of a mixture.
    • InitialSample -
    • Injectables
    • Key-Word - A word which may be used as a search key.
    • Kit
    • Labour - Characteristic being described is labour.
    • LabourDoubleTime - Characteristic being described is labour double time.
    • LabourOvertime - Characteristic being described is overtime labour.
    • LeadOrCopperSampleType
    • LeasedResource - A code to identify the characteristics of a leased resource.
    • LimitingOperation - Code indicating that the item has a limiting operation.
    • Luster - A reflected light or sheen.
    • MachineRun - Description of the machine run characteristics for a product.
    • Magnetic - Code indicating the product's magnetic characteristics.
    • MajorGrade - Specification of the major grade of the item.
    • ManufacturingMethod - Code indicating the product's manufacturing method characteristics.
    • ManufacturingProcess
    • MarketSegment - Code indicating the market segment associated with a product.
    • Marking
    • Material
    • MaterialClassification
    • MaterialDescription - Description of material used to manufacture a product.
    • MaterialResource - A code to identify the characteristics of a material resource.
    • MaterialStatus-OutsideProcessor
    • Mechanical - Code indicating the product's mechanical characteristics.
    • MedicalSupplies
    • Metallographic - Code indicating the product's metallographic characteristics.
    • MILSPEC-MilitarySpecification
    • MMSBLM-IndianLandPropertyOrUnitNumber - MineralsManagementService/BureauOfLandManagement(IndianLand)PropertyOrUnitNumber
    • Moisture - Code indicating the product's moisture characteristics.
    • Multi-Media
    • MusicStyle - The style of music.
    • MutuallyDefined
    • NewArticle -
    • Non-HazardousMaterial
    • Non-PrescriptionDrug - Code indicating the non-prescription drug's characteristics.
    • NonRecurringResource - A code to identify a resource that is non recurring.
    • Nutrition
    • ObsoleteArticle -
    • Odor
    • Odorized
    • Options - An item available in addition to standard features of a product.
    • Orientation
    • OtherDirectResource - A code to identify other direct resources that are charged to a task.
    • OtherPhysicalDescription - Any other relevant physical description.
    • Over-the-CounterDrug
    • PackageIntegrity
    • Parameter
    • Pattern - Code indicating the product's pattern characteristics.
    • PercentageOfAlcohol
    • PerforationContinuityIndicator
    • PerforationInterval
    • PerforationType
    • Physical - Code indicating the product's physical characteristics.
    • PhysicalForm - Code indicating the physical form of a product.
    • PhysicalForm-Aerosol
    • PhysicalForm-AsDiluted
    • PhysicalForm-Concentrate
    • PhysicalForm-Emulsion
    • PhysicalForm-Gas
    • PhysicalForm-Liquid
    • PhysicalForm-Powder
    • PhysicalForm-Semisolid
    • PhysicalForm-Solid
    • PipeCoupling - A collar with internal threads used to join a section of threaded pipe.
    • PipelineStream - Code indicating the product's pipeline stream characteristics.
    • PrecautionaryInstructions
    • PrescriptionDrug - Code indicating the prescription drug's characteristics.
    • PresentationEffect - To indicate a presentation effect.
    • Preservative
    • PrimaryGrape - The type of grape that comprises the largest percentage of grape in the wine product.
    • PrintOrientation - The orientation of the back printing on a form to the front printing on the same form.
    • PrivateLabelName - Describes the private label name of a product.
    • ProcessActionTaken
    • ProcessOrProductionUnit
    • Product -
    • ProductApplication
    • ProductDataBaseManagementDescription - A description indicating how a product should be managed in a data base.
    • ProductLifeCycle - Code indicating the period of time between product creation and obsolescence.
    • Program
    • ProjectSubject - To identify the subject of a given project.
    • PromotionalEvent - Describes the promotional event associated with a product.
    • PromotionalOffer - Describes the additions to the basic product for a promotional event.
    • Proof
    • Proprietary
    • PublicInformation
    • Publisher - The publisher of a written piece of work as part of the item description.
    • PureForm
    • Put-upDescription
    • Quality -
    • QualityAssuranceStatus
    • Quality-QualityLevel
    • RecordingMedium - The medium on which a musical recording is made.
    • RecurringResource - A code to identify a recurring resource.
    • Recycle
    • RefurbishedArticle - Description to be provided.
    • RegulatoryOrStateDistrict
    • Regulatory-StateOrEntityCode
    • ReinstatedArticle -
    • RejectionReason
    • ReservoirCode-Company
    • ResultsMethodCode
    • RevisedArticle - Item design revised.
    • RevisedDesign -
    • RouteOfAdministration
    • SampleType
    • SecondaryGrape - The grape that comprises the second largest percentage of the ingredients used in wine product.
    • SecretOrConfidentialInformation
    • SectionProfile - Description of the section and profile of the product.
    • SeriesTitle - Title of a series of works.
    • ServiceFeature
    • Services
    • Shade - The degree to which a colour is mixed with black or is decreasingly illuminated.
    • Shelf-LifeCode - A code indicating the shelf-life of a product.
    • ShelfTag
    • ShippingUnitComponent - Any designed component of a fixture or container, typically detachable from the base unit for empty return or for cleaning, which provides rigidity, stability, or security when loaded and are an integral part of the container or shipping device and are essential to its functionality.
    • ShipToLine - Product without quality control at customer's, and packed according production needs.
    • ShipToStock - Product without quality control when received.
    • Silhouette - Describes the outline of the item.
    • Size - Description of size in non-numeric terms.
    • SizeSystem - A code identifying a size system, comprising a set of sizes.
    • SocietyGovernmentAndOrCustomerSpecifications
    • Solubility - A code indicating the amount of a substance that can be dissolved using a non-discrete value.
    • Source - The derivation of a material thing.
    • SpecialProcessing - Description of any special processing requirements performed or required.
    • SpecialSpecification
    • Specification - Description of the specification of the item.
    • StateControlled
    • StorageAndDisplay - Code indicating the product's storage or display characteristics.
    • SubcontractResource - A code to identify resources that are part of a subcontract.
    • Sub-Product - Description of a sub-product.
    • SurfaceCondition - Description of the surface condition (e.g. roughness) of the product.
    • SurfaceLocationMethod - Code indicating the product's surface location method characteristics.
    • SurfaceProtection - Description of the surface protection required/available for the product.
    • SurfaceTreatment-Chemical - Description of any chemical surface treatment required/performed on the product.
    • SurfaceTreatment-Mechanical - Description of any mechanical surface treatment required/performed on the product.
    • Synonym
    • Temper - To bring to a required degree of hardness and elasticity by heating and then cooling.
    • TestingAndInspectionAgencies
    • TestPanelType - Specifies the type of test panel used for the item.
    • TestSampleDirection - Description of test sample direction. Used when ordering special testing requirements on a product.
    • TestSampleFrequency - Indication of test sample frequency. Used when ordering special testing requirements on a product.
    • TestSampleLocation
    • TheoreticalWeightFormula
    • TherapeuticClass - Code indicating the product's therapeutic class characteristics.
    • TherapeuticEquivalency - Code indicating the product's therapeutic equivalency characteristics.
    • Threshold - Code indicating the product's threshold characteristics.
    • Tint - A gradation of colour made by adding white to lessen the saturation.
    • Tire
    • Title - The title of a work.
    • TitleInsuranceForm
    • Tow
    • TradeName
    • Translator
    • Transmission - Code indicating the discrete identification of the transmission characteristics.
    • Trim - Code indicating the product's trim characteristics.
    • Twist - Description of any special twisting requirements for the product.
    • TypeAndOrProcess - Description of the type and/or process involved in making the product. E.g. in steel, description of the steelmaking process.
    • Typeface
    • TypeOfSample - Type of sample such as blood or urine.
    • TypeOfTest-Inspection - Description of type of test or inspection. Used to order special tests to be performed on the product.
    • TypeSpinning
    • Vehicle
    • VendorColorDescription
    • VendorSizeDescription
    • Vintage - The harvest year of the grapes that are part of the composition of a particular wine.
    • Visual - Capable of being seen by the eye or with the aid of optics.
    • VolatileOrganicCompoundControl
    • VolumeTitle - The title of a volume of work.
    • WarrantyDescription
    • WarrantyTypeDescription - The warranty type description of the item.
    • Waste - Code indicating unusable material left over from a process of manufacturing.
    • WaxCode
    • WeldsOrSplices - Description of any special welds and or splices required/performed on the product.
    • WellClassification - Code indicating the well classification characteristics.
    • WellDirection - Code indicating the well drilling direction.
    • WellPerforationContinuity - Code indicating the well perforation continuity characteristics.
    • WellPerforationInterval - Code indicating the well perforation interval characteristics.
    • WellTestType - Code indicating the well test type characteristics.
    • WindingInstructions - Description of any special winding instructions for the product.
    • WineFruit - The fruit that is used as a base to produce a wine.
    • WineGrowingRegion - The area where the grape used to produce a wine was harvested.
    • YarnCount - Describes the fineness of the yarn in the cloth.

[^]Code Fragment

    <xsd:simpleType name="ItemCharacteristicCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="AdditionalSectorialCharacteristics">
        <xsd:enumeration value="Age">
        <xsd:enumeration value="AlcoholBeverageClass">
        <xsd:enumeration value="AlcoholBeverageType">
        <xsd:enumeration value="Alloy">
        <xsd:enumeration value="AnatomicalOriginOfSample">
        <xsd:enumeration value="Appearance">
        <xsd:enumeration value="Artist">
        <xsd:enumeration value="AssemblyRequired">
        <xsd:enumeration value="Author">
        <xsd:enumeration value="BalanceOutArticle">
        <xsd:enumeration value="BasisWeightSize">
        <xsd:enumeration value="Behind-the-CounterDrugs">
        <xsd:enumeration value="BeverageAge">
        <xsd:enumeration value="BeverageBrand">
        <xsd:enumeration value="BeverageCategory">
        <xsd:enumeration value="BeverageContainerCharacteristics">
        <xsd:enumeration value="BeverageFlavour">
        <xsd:enumeration value="BeverageSegment">
        <xsd:enumeration value="Binding">
        <xsd:enumeration value="BottomholeLocationMethod">
        <xsd:enumeration value="BottomholePressureMethod">
        <xsd:enumeration value="BrandGroup">
        <xsd:enumeration value="BrandGroup-AGroupingOfSimilarBrands">
        <xsd:enumeration value="BureauofAlcoholTobaccoAndFirearmsClassCode">
        <xsd:enumeration value="BureauOfAlcoholTobaccoAndFirearmsTypeCode">
        <xsd:enumeration value="BuyersColorDescription">
        <xsd:enumeration value="BuyersItemSizeDescription">
        <xsd:enumeration value="Casing-Liner-TubingType">
        <xsd:enumeration value="CasingOrLinerType">
        <xsd:enumeration value="CertificateOfConformity">
        <xsd:enumeration value="Chassis">
        <xsd:enumeration value="ChemicalFamilyName">
        <xsd:enumeration value="Chemistry">
        <xsd:enumeration value="CID-CommercialItemDescription">
        <xsd:enumeration value="Coating">
        <xsd:enumeration value="CoatingOrPaintSystemCode">
        <xsd:enumeration value="CoatingOrPaintSystemName">
        <xsd:enumeration value="Collateral">
        <xsd:enumeration value="CollectionMethodCode">
        <xsd:enumeration value="Color">
        <xsd:enumeration value="Color-LowerBody">
        <xsd:enumeration value="Color-UpperBody">
        <xsd:enumeration value="CommercialStatus">
        <xsd:enumeration value="CommonChemicalName">
        <xsd:enumeration value="CompanyFieldCode">
        <xsd:enumeration value="ComplianceMethod">
        <xsd:enumeration value="Composer">
        <xsd:enumeration value="ConditionedCode">
        <xsd:enumeration value="ConstructionMethod">
        <xsd:enumeration value="ConsumableResource">
        <xsd:enumeration value="ConsumerInstructions">
        <xsd:enumeration value="ControlItem">
        <xsd:enumeration value="ControlledSubstance">
        <xsd:enumeration value="ControlledSubstance-Class2">
        <xsd:enumeration value="ControlledSubstance-Class3Narcotic">
        <xsd:enumeration value="ControlledSubstance-Class3NNon-narcotic">
        <xsd:enumeration value="ControlledSubstance-Class4">
        <xsd:enumeration value="ControlledSubstance-Class5">
        <xsd:enumeration value="CoordinateDescriptionCode">
        <xsd:enumeration value="Coordinates">
        <xsd:enumeration value="CorrosionResistance">
        <xsd:enumeration value="Coupling">
        <xsd:enumeration value="CurrentArticle">
        <xsd:enumeration value="CurrentArticleSpares">
        <xsd:enumeration value="CustomsSpecifications">
        <xsd:enumeration value="DamageCode">
        <xsd:enumeration value="DamageFault">
        <xsd:enumeration value="Denier">
        <xsd:enumeration value="Density">
        <xsd:enumeration value="Dimensional">
        <xsd:enumeration value="DirectionalIndicator">
        <xsd:enumeration value="Dispersion">
        <xsd:enumeration value="DosageForm">
        <xsd:enumeration value="DrugEfficacy">
        <xsd:enumeration value="DrugEfficacyStudyImplementation">
        <xsd:enumeration value="DyeLot">
        <xsd:enumeration value="DyeLotDescription">
        <xsd:enumeration value="EdgeTreatment">
        <xsd:enumeration value="Edition">
        <xsd:enumeration value="Editor">
        <xsd:enumeration value="Electrical">
        <xsd:enumeration value="ElectronicallyCleaned">
        <xsd:enumeration value="ElectronicField">
        <xsd:enumeration value="Ends-Slitting-Splitting-Cutting">
        <xsd:enumeration value="EndTreatment">
        <xsd:enumeration value="EndUseApplication">
        <xsd:enumeration value="Engine">
        <xsd:enumeration value="EnginewithTransmission">
        <xsd:enumeration value="Equipment">
        <xsd:enumeration value="EscrowCode">
        <xsd:enumeration value="EuropeanCommunityRiskClass">
        <xsd:enumeration value="Fabric">
        <xsd:enumeration value="FabricDescription">
        <xsd:enumeration value="FailureAnalysisProcess">
        <xsd:enumeration value="FEDSPEC-FederalSpecification">
        <xsd:enumeration value="FED-STD-FederalStandard">
        <xsd:enumeration value="Fiber">
        <xsd:enumeration value="FibreTow">
        <xsd:enumeration value="FieldCode-EIAOrDOD">
        <xsd:enumeration value="FieldTest">
        <xsd:enumeration value="Filament">
        <xsd:enumeration value="Filter">
        <xsd:enumeration value="Finish">
        <xsd:enumeration value="FinishOrSurfaceRoughness">
        <xsd:enumeration value="Flavor">
        <xsd:enumeration value="Flow">
        <xsd:enumeration value="Fluid">
        <xsd:enumeration value="FoldConfiguration">
        <xsd:enumeration value="Font">
        <xsd:enumeration value="ForecastDeviation">
        <xsd:enumeration value="Forming">
        <xsd:enumeration value="Formula">
        <xsd:enumeration value="Fragrance">
        <xsd:enumeration value="Fuel">
        <xsd:enumeration value="FunctionalPerformance">
        <xsd:enumeration value="FurtherIdentifyingCharacteristic">
        <xsd:enumeration value="GeneralDescription">
        <xsd:enumeration value="GeneralMerchandise">
        <xsd:enumeration value="GeneralProductForm">
        <xsd:enumeration value="GenericDrug">
        <xsd:enumeration value="Goods">
        <xsd:enumeration value="Grade">
        <xsd:enumeration value="GrainDirection">
        <xsd:enumeration value="GrapeVariety">
        <xsd:enumeration value="HazardousMaterial">
        <xsd:enumeration value="HazardRatingSystem">
        <xsd:enumeration value="HealthAndBeautyAids">
        <xsd:enumeration value="HeatTreatOrAnneal">
        <xsd:enumeration value="Hydraulics">
        <xsd:enumeration value="Ingredient">
        <xsd:enumeration value="InitialSample">
        <xsd:enumeration value="Injectables">
        <xsd:enumeration value="Key-Word">
        <xsd:enumeration value="Kit">
        <xsd:enumeration value="Labour">
        <xsd:enumeration value="LabourDoubleTime">
        <xsd:enumeration value="LabourOvertime">
        <xsd:enumeration value="LeadOrCopperSampleType">
        <xsd:enumeration value="LeasedResource">
        <xsd:enumeration value="LimitingOperation">
        <xsd:enumeration value="Luster">
        <xsd:enumeration value="MachineRun">
        <xsd:enumeration value="Magnetic">
        <xsd:enumeration value="MajorGrade">
        <xsd:enumeration value="ManufacturingMethod">
        <xsd:enumeration value="ManufacturingProcess">
        <xsd:enumeration value="MarketSegment">
        <xsd:enumeration value="Marking">
        <xsd:enumeration value="Material">
        <xsd:enumeration value="MaterialClassification">
        <xsd:enumeration value="MaterialDescription">
        <xsd:enumeration value="MaterialResource">
        <xsd:enumeration value="MaterialStatus-OutsideProcessor">
        <xsd:enumeration value="Mechanical">
        <xsd:enumeration value="MedicalSupplies">
        <xsd:enumeration value="Metallographic">
        <xsd:enumeration value="MILSPEC-MilitarySpecification">
        <xsd:enumeration value="MMSBLM-IndianLandPropertyOrUnitNumber">
        <xsd:enumeration value="Moisture">
        <xsd:enumeration value="Multi-Media">
        <xsd:enumeration value="MusicStyle">
        <xsd:enumeration value="MutuallyDefined">
        <xsd:enumeration value="NewArticle">
        <xsd:enumeration value="Non-HazardousMaterial">
        <xsd:enumeration value="Non-PrescriptionDrug">
        <xsd:enumeration value="NonRecurringResource">
        <xsd:enumeration value="Nutrition">
        <xsd:enumeration value="ObsoleteArticle">
        <xsd:enumeration value="Odor">
        <xsd:enumeration value="Odorized">
        <xsd:enumeration value="Options">
        <xsd:enumeration value="Orientation">
        <xsd:enumeration value="OtherDirectResource">
        <xsd:enumeration value="OtherPhysicalDescription">
        <xsd:enumeration value="Over-the-CounterDrug">
        <xsd:enumeration value="PackageIntegrity">
        <xsd:enumeration value="Parameter">
        <xsd:enumeration value="Pattern">
        <xsd:enumeration value="PercentageOfAlcohol">
        <xsd:enumeration value="PerforationContinuityIndicator">
        <xsd:enumeration value="PerforationInterval">
        <xsd:enumeration value="PerforationType">
        <xsd:enumeration value="Physical">
        <xsd:enumeration value="PhysicalForm">
        <xsd:enumeration value="PhysicalForm-Aerosol">
        <xsd:enumeration value="PhysicalForm-AsDiluted">
        <xsd:enumeration value="PhysicalForm-Concentrate">
        <xsd:enumeration value="PhysicalForm-Emulsion">
        <xsd:enumeration value="PhysicalForm-Gas">
        <xsd:enumeration value="PhysicalForm-Liquid">
        <xsd:enumeration value="PhysicalForm-Powder">
        <xsd:enumeration value="PhysicalForm-Semisolid">
        <xsd:enumeration value="PhysicalForm-Solid">
        <xsd:enumeration value="PipeCoupling">
        <xsd:enumeration value="PipelineStream">
        <xsd:enumeration value="PrecautionaryInstructions">
        <xsd:enumeration value="PrescriptionDrug">
        <xsd:enumeration value="PresentationEffect">
        <xsd:enumeration value="Preservative">
        <xsd:enumeration value="PrimaryGrape">
        <xsd:enumeration value="PrintOrientation">
        <xsd:enumeration value="PrivateLabelName">
        <xsd:enumeration value="ProcessActionTaken">
        <xsd:enumeration value="ProcessOrProductionUnit">
        <xsd:enumeration value="Product">
        <xsd:enumeration value="ProductApplication">
        <xsd:enumeration value="ProductDataBaseManagementDescription">
        <xsd:enumeration value="ProductLifeCycle">
        <xsd:enumeration value="Program">
        <xsd:enumeration value="ProjectSubject">
        <xsd:enumeration value="PromotionalEvent">
        <xsd:enumeration value="PromotionalOffer">
        <xsd:enumeration value="Proof">
        <xsd:enumeration value="Proprietary">
        <xsd:enumeration value="PublicInformation">
        <xsd:enumeration value="Publisher">
        <xsd:enumeration value="PureForm">
        <xsd:enumeration value="Put-upDescription">
        <xsd:enumeration value="Quality">
        <xsd:enumeration value="QualityAssuranceStatus">
        <xsd:enumeration value="Quality-QualityLevel">
        <xsd:enumeration value="RecordingMedium">
        <xsd:enumeration value="RecurringResource">
        <xsd:enumeration value="Recycle">
        <xsd:enumeration value="RefurbishedArticle">
        <xsd:enumeration value="RegulatoryOrStateDistrict">
        <xsd:enumeration value="Regulatory-StateOrEntityCode">
        <xsd:enumeration value="ReinstatedArticle">
        <xsd:enumeration value="RejectionReason">
        <xsd:enumeration value="ReservoirCode-Company">
        <xsd:enumeration value="ResultsMethodCode">
        <xsd:enumeration value="RevisedArticle">
        <xsd:enumeration value="RevisedDesign">
        <xsd:enumeration value="RouteOfAdministration">
        <xsd:enumeration value="SampleType">
        <xsd:enumeration value="SecondaryGrape">
        <xsd:enumeration value="SecretOrConfidentialInformation">
        <xsd:enumeration value="SectionProfile">
        <xsd:enumeration value="SeriesTitle">
        <xsd:enumeration value="ServiceFeature">
        <xsd:enumeration value="Services">
        <xsd:enumeration value="Shade">
        <xsd:enumeration value="Shelf-LifeCode">
        <xsd:enumeration value="ShelfTag">
        <xsd:enumeration value="ShippingUnitComponent">
        <xsd:enumeration value="ShipToLine">
        <xsd:enumeration value="ShipToStock">
        <xsd:enumeration value="Silhouette">
        <xsd:enumeration value="Size">
        <xsd:enumeration value="SizeSystem">
        <xsd:enumeration value="SocietyGovernmentAndOrCustomerSpecifications">
        <xsd:enumeration value="Solubility">
        <xsd:enumeration value="Source">
        <xsd:enumeration value="SpecialProcessing">
        <xsd:enumeration value="SpecialSpecification">
        <xsd:enumeration value="Specification">
        <xsd:enumeration value="StateControlled">
        <xsd:enumeration value="StorageAndDisplay">
        <xsd:enumeration value="SubcontractResource">
        <xsd:enumeration value="Sub-Product">
        <xsd:enumeration value="SurfaceCondition">
        <xsd:enumeration value="SurfaceLocationMethod">
        <xsd:enumeration value="SurfaceProtection">
        <xsd:enumeration value="SurfaceTreatment-Chemical">
        <xsd:enumeration value="SurfaceTreatment-Mechanical">
        <xsd:enumeration value="Synonym">
        <xsd:enumeration value="Temper">
        <xsd:enumeration value="TestingAndInspectionAgencies">
        <xsd:enumeration value="TestPanelType">
        <xsd:enumeration value="TestSampleDirection">
        <xsd:enumeration value="TestSampleFrequency">
        <xsd:enumeration value="TestSampleLocation">
        <xsd:enumeration value="TheoreticalWeightFormula">
        <xsd:enumeration value="TherapeuticClass">
        <xsd:enumeration value="TherapeuticEquivalency">
        <xsd:enumeration value="Threshold">
        <xsd:enumeration value="Tint">
        <xsd:enumeration value="Tire">
        <xsd:enumeration value="Title">
        <xsd:enumeration value="TitleInsuranceForm">
        <xsd:enumeration value="Tow">
        <xsd:enumeration value="TradeName">
        <xsd:enumeration value="Translator">
        <xsd:enumeration value="Transmission">
        <xsd:enumeration value="Trim">
        <xsd:enumeration value="Twist">
        <xsd:enumeration value="TypeAndOrProcess">
        <xsd:enumeration value="Typeface">
        <xsd:enumeration value="TypeOfSample">
        <xsd:enumeration value="TypeOfTest-Inspection">
        <xsd:enumeration value="TypeSpinning">
        <xsd:enumeration value="Vehicle">
        <xsd:enumeration value="VendorColorDescription">
        <xsd:enumeration value="VendorSizeDescription">
        <xsd:enumeration value="Vintage">
        <xsd:enumeration value="Visual">
        <xsd:enumeration value="VolatileOrganicCompoundControl">
        <xsd:enumeration value="VolumeTitle">
        <xsd:enumeration value="WarrantyDescription">
        <xsd:enumeration value="WarrantyTypeDescription">
        <xsd:enumeration value="Waste">
        <xsd:enumeration value="WaxCode">
        <xsd:enumeration value="WeldsOrSplices">
        <xsd:enumeration value="WellClassification">
        <xsd:enumeration value="WellDirection">
        <xsd:enumeration value="WellPerforationContinuity">
        <xsd:enumeration value="WellPerforationInterval">
        <xsd:enumeration value="WellTestType">
        <xsd:enumeration value="WindingInstructions">
        <xsd:enumeration value="WineFruit">
        <xsd:enumeration value="WineGrowingRegion">
        <xsd:enumeration value="YarnCount">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: ItemCharacteristicType

ItemCharacteristicType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ItemCharacteristicCoded[ItemCharacteristicCodeType]? , ItemCharacteristicCodedOther[xsd:string]? , SurfaceLayerPositionCoded[SurfaceLayerPositionCodeType]? , SurfaceLayerPositionCodedOther[xsd:string]? , ( ItemCharacteristicValue[xsd:string] | Identifier[IdentifierType] ) , UnitOfMeasurement[UnitOfMeasurementType]? , ListOfDimension[ListOfDimensionType]? )

    Description: ItemCharacteristicType is a container element that contains the physical attributes other than dimensions of an item.

    Elements:

    • ItemCharacteristicCoded - identifies the characteristic being described by the ItemCharacteristic element using a standard codelist.
    • ItemCharacteristicCodedOther - is used to provide a non-standard ItemCharacteristicCode. This element is mandatory if the value of ItemCharacteristicCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • SurfaceLayerPositionCoded - identifies the surface layer or the position of the item being described by the ItemCharacteristic element using a standard codelist.
    • SurfaceLayerPositionCodedOther - is used to provide a non-standard SurfaceLayerPositionCode This element is mandatory if the value of SurfaceLayerPositionCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • ItemCharacteristicValue - is the value of the characteristic being described by the ItemCharacteristic element.
    • Identifier - is used to provide a structured description of the characteristic being described. If this element is used, ItemCharacteristicValue should be an empty string.
    • UnitOfMeasurement - is the unit of measure for the value of the characteristic.
    • ListOfDimension - contains any other measurements associated with the item characteristic being described.

[^]Code Fragment

    <xsd:complexType name="ItemCharacteristicType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ItemCharacteristicCoded" type="ItemCharacteristicCodeType">
        <xsd:element minOccurs="0" name="ItemCharacteristicCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="SurfaceLayerPositionCoded" type="SurfaceLayerPositionCodeType">
        <xsd:element minOccurs="0" name="SurfaceLayerPositionCodedOther" type="xsd:string">
        <xsd:choice>
            <xsd:element name="ItemCharacteristicValue" type="xsd:string">
            <xsd:element name="Identifier" type="IdentifierType">
        </xsd:choice>
        <xsd:element minOccurs="0" name="UnitOfMeasurement" type="UnitOfMeasurementType">
        <xsd:element minOccurs="0" name="ListOfDimension" type="ListOfDimensionType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ItemIdentifiersType

ItemIdentifiersType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PartNumbers[PartNumbersType]? , Service[xsd:boolean]? , ItemDescription[xsd:string]? , ListOfItemCharacteristic[ListOfItemCharacteristicType]? , CommodityCode[IdentifierType]? , Category[CategoryType]? )

    Description: ItemIdentifiersType details all of the part numbers, descriptions, and characteristics of an item.

    Elements:

    • PartNumbers - identifies all identification numbers for the item.
    • Service - identifies the item as a service. A value of true will identify the line item as a service. If this elment does not exist, or is set to false, the item is assumed to be goods.
    • ItemDescription - is a free form field that can be used to give a text description of the item.
    • ListOfItemCharacteristic - is a collection of physical attributes other than dimensions of an item.
    • CommodityCode - contains the harmonized (HS) system code. This is the international notation to categorize individual commodities. These are also known as customs codes.
    • Category - identifies the product category

[^]Code Fragment

    <xsd:complexType name="ItemIdentifiersType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="PartNumbers" type="PartNumbersType">
        <xsd:element minOccurs="0" name="Service" type="xsd:boolean">
        <xsd:element minOccurs="0" name="ItemDescription" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfItemCharacteristic" type="ListOfItemCharacteristicType">
        <xsd:element minOccurs="0" name="CommodityCode" type="IdentifierType">
        <xsd:element minOccurs="0" name="Category" type="CategoryType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ItemPackagingReferenceType

ItemPackagingReferenceType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PackageReference[PackageReferenceType]+ )

    Description: ItemPackagingReferenceType contains reference information when detailed packaging information contained in list of package detail is to be associated with the line item.

    Elements:

    • PackageReference - provides a reference for the packaging of the item.

[^]Code Fragment

    <xsd:complexType name="ItemPackagingReferenceType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="PackageReference" type="PackageReferenceType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: LanguageCodeType

LanguageCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the language being used. This code list is derived from ISO 639-1998

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • aa - Afar
    • ab - Abkhazian
    • af - Afrikaans
    • am - Amharic
    • ar - Arabic
    • as - Assamese
    • ay - Aymara
    • az - Azerbaijani
    • ba - Bashkir
    • be - Byelorussian
    • bg - Bulgarian
    • bh - Bihari
    • bi - Bislama
    • bn - Bengali; Bangla
    • bo - Tibetan
    • br - Breton
    • ca - Catalan
    • co - Corsican
    • cs - Czech
    • cy - Welsh
    • da - Danish
    • de - German
    • dz - Bhutani
    • el - Greek
    • en - English
    • eo - Esperanto
    • es - Spanish
    • et - Estonian
    • eu - Basque
    • fa - Persian
    • fi - Finnish
    • fj - Fiji
    • fo - Faroese
    • fr - French
    • fy - Frisian
    • ga - Irish
    • gd - Scots Gaelic
    • gl - Galician
    • gn - Guarani
    • gu - Gujarati
    • ha - Hausa
    • he - Hebrew
    • hi - Hindi
    • hr - Croatian
    • hu - Hungarian
    • hy - Armenian
    • ia - Interlingua
    • id - Indonesian
    • ie - Interlingue
    • ik - Inupiak
    • is - Icelandic
    • it - Italian
    • iu - Inuktitut
    • ja - Japanese
    • jw - Javanese
    • ka - Georgian
    • kk - Kazakh
    • kl - Greenlandic
    • km - Cambodian
    • kn - Kannada
    • ko - Korean
    • ks - Kashmiri
    • ku - Kurdish
    • ky - Kirghiz
    • la - Latin
    • ln - Lingala
    • lo - Laothian
    • lt - Lithuanian
    • lv - Latvian; Lettish
    • mg - Malagasy
    • mi - Maori
    • mk - Macedonian
    • ml - Malayalam
    • mn - Mongolian
    • mo - Moldavian
    • mr - Marathi
    • ms - Malay
    • mt - Maltese
    • my - Burmese
    • na - Nauru
    • ne - Nepali
    • nl - Dutch
    • no - Norwegian
    • oc - Occitan
    • om - (Afan) Oromo
    • or - Oriya
    • pa - Punjabi
    • pl - Polish
    • ps - Pashto, Pushto
    • pt - Portuguese
    • qu - Quechua
    • rm - Rhaeto-Romance
    • rn - Kirundi
    • ro - Romanian
    • ru - Russian
    • rw - Kinyarwanda
    • sa - Sanskrit
    • sd - Sindhi
    • sg - Sangho
    • sh - Serbo-Croatian
    • si - Singhalese
    • sk - Slovak
    • sl - Slovenian
    • sm - Samoan
    • sn - Shona
    • so - Somali
    • sq - Albanian
    • sr - Serbian
    • ss - Siswati
    • st - Sesotho
    • su - Sundanese
    • sv - Swedish
    • sw - Swahili
    • ta - Tamil
    • te - Telugu
    • tg - Tajik
    • th - Thai
    • ti - Tigrinya
    • tk - Turkmen
    • tl - Tagalog
    • tn - Setswana
    • to - Tonga
    • tr - Turkish
    • ts - Tsonga
    • tt - Tatar
    • tw - Twi
    • ug - Uigur
    • uk - Ukrainian
    • ur - Urdu
    • uz - Uzbek
    • vi - Vietnamese
    • vo - Volapuk
    • wo - Wolof
    • xh - Xhosa
    • yi - Yiddish
    • yo - Yoruba
    • za - Zhuang
    • zh - Chinese
    • zu - Zulu

[^]Code Fragment

    <xsd:simpleType name="LanguageCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="aa">
        <xsd:enumeration value="ab">
        <xsd:enumeration value="af">
        <xsd:enumeration value="am">
        <xsd:enumeration value="ar">
        <xsd:enumeration value="as">
        <xsd:enumeration value="ay">
        <xsd:enumeration value="az">
        <xsd:enumeration value="ba">
        <xsd:enumeration value="be">
        <xsd:enumeration value="bg">
        <xsd:enumeration value="bh">
        <xsd:enumeration value="bi">
        <xsd:enumeration value="bn">
        <xsd:enumeration value="bo">
        <xsd:enumeration value="br">
        <xsd:enumeration value="ca">
        <xsd:enumeration value="co">
        <xsd:enumeration value="cs">
        <xsd:enumeration value="cy">
        <xsd:enumeration value="da">
        <xsd:enumeration value="de">
        <xsd:enumeration value="dz">
        <xsd:enumeration value="el">
        <xsd:enumeration value="en">
        <xsd:enumeration value="eo">
        <xsd:enumeration value="es">
        <xsd:enumeration value="et">
        <xsd:enumeration value="eu">
        <xsd:enumeration value="fa">
        <xsd:enumeration value="fi">
        <xsd:enumeration value="fj">
        <xsd:enumeration value="fo">
        <xsd:enumeration value="fr">
        <xsd:enumeration value="fy">
        <xsd:enumeration value="ga">
        <xsd:enumeration value="gd">
        <xsd:enumeration value="gl">
        <xsd:enumeration value="gn">
        <xsd:enumeration value="gu">
        <xsd:enumeration value="ha">
        <xsd:enumeration value="he">
        <xsd:enumeration value="hi">
        <xsd:enumeration value="hr">
        <xsd:enumeration value="hu">
        <xsd:enumeration value="hy">
        <xsd:enumeration value="ia">
        <xsd:enumeration value="id">
        <xsd:enumeration value="ie">
        <xsd:enumeration value="ik">
        <xsd:enumeration value="is">
        <xsd:enumeration value="it">
        <xsd:enumeration value="iu">
        <xsd:enumeration value="ja">
        <xsd:enumeration value="jw">
        <xsd:enumeration value="ka">
        <xsd:enumeration value="kk">
        <xsd:enumeration value="kl">
        <xsd:enumeration value="km">
        <xsd:enumeration value="kn">
        <xsd:enumeration value="ko">
        <xsd:enumeration value="ks">
        <xsd:enumeration value="ku">
        <xsd:enumeration value="ky">
        <xsd:enumeration value="la">
        <xsd:enumeration value="ln">
        <xsd:enumeration value="lo">
        <xsd:enumeration value="lt">
        <xsd:enumeration value="lv">
        <xsd:enumeration value="mg">
        <xsd:enumeration value="mi">
        <xsd:enumeration value="mk">
        <xsd:enumeration value="ml">
        <xsd:enumeration value="mn">
        <xsd:enumeration value="mo">
        <xsd:enumeration value="mr">
        <xsd:enumeration value="ms">
        <xsd:enumeration value="mt">
        <xsd:enumeration value="my">
        <xsd:enumeration value="na">
        <xsd:enumeration value="ne">
        <xsd:enumeration value="nl">
        <xsd:enumeration value="no">
        <xsd:enumeration value="oc">
        <xsd:enumeration value="om">
        <xsd:enumeration value="or">
        <xsd:enumeration value="pa">
        <xsd:enumeration value="pl">
        <xsd:enumeration value="ps">
        <xsd:enumeration value="pt">
        <xsd:enumeration value="qu">
        <xsd:enumeration value="rm">
        <xsd:enumeration value="rn">
        <xsd:enumeration value="ro">
        <xsd:enumeration value="ru">
        <xsd:enumeration value="rw">
        <xsd:enumeration value="sa">
        <xsd:enumeration value="sd">
        <xsd:enumeration value="sg">
        <xsd:enumeration value="sh">
        <xsd:enumeration value="si">
        <xsd:enumeration value="sk">
        <xsd:enumeration value="sl">
        <xsd:enumeration value="sm">
        <xsd:enumeration value="sn">
        <xsd:enumeration value="so">
        <xsd:enumeration value="sq">
        <xsd:enumeration value="sr">
        <xsd:enumeration value="ss">
        <xsd:enumeration value="st">
        <xsd:enumeration value="su">
        <xsd:enumeration value="sv">
        <xsd:enumeration value="sw">
        <xsd:enumeration value="ta">
        <xsd:enumeration value="te">
        <xsd:enumeration value="tg">
        <xsd:enumeration value="th">
        <xsd:enumeration value="ti">
        <xsd:enumeration value="tk">
        <xsd:enumeration value="tl">
        <xsd:enumeration value="tn">
        <xsd:enumeration value="to">
        <xsd:enumeration value="tr">
        <xsd:enumeration value="ts">
        <xsd:enumeration value="tt">
        <xsd:enumeration value="tw">
        <xsd:enumeration value="ug">
        <xsd:enumeration value="uk">
        <xsd:enumeration value="ur">
        <xsd:enumeration value="uz">
        <xsd:enumeration value="vi">
        <xsd:enumeration value="vo">
        <xsd:enumeration value="wo">
        <xsd:enumeration value="xh">
        <xsd:enumeration value="yi">
        <xsd:enumeration value="yo">
        <xsd:enumeration value="za">
        <xsd:enumeration value="zh">
        <xsd:enumeration value="zu">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: LanguageStringType

LanguageStringType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( LangString[xsd:string] , Language[LanguageType] )

    Description: LanguageStringType is a string with an optional language specification. If the language is not provided, it is assumed that the language is known from the context in which the LanguageString is used.

    Elements:

    • LangString - is the free form text field.
    • Language - identifies the language that the text is written in.

[^]Code Fragment

    <xsd:complexType name="LanguageStringType">
    <xsd:sequence>
        <xsd:element name="LangString" type="xsd:string">
        <xsd:element name="Language" type="LanguageType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: LanguageType

LanguageType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( LanguageCoded[LanguageCodeType] , LanguageCodedOther[xsd:string]? , LocaleCoded[LocaleCodeType]? , LocaleCodedOther[xsd:string]? )

    Attribute:Name: LanguageDependent, Type: xsd:boolean, Use: 'optional'

    Description: LanguageType is used to provide information about the language which text is written in.

    Elements:

    • LanguageCoded - identifies the language using ISO standards.
    • LanguageCodedOther - is used to provide a non-standard LanguageCode. This element is mandatory if the value of LanguageCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • LocaleCoded - identifies the locale/location where the language is spoken.
    • LocaleCodedOther - is used to provide a non-standard LocaleCode. This element is mandatory if the value of LocaleCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    Attributes:
    • LanguageDependent - defines whether a document is language dependent or not.

[^]Code Fragment

    <xsd:complexType name="LanguageType">
    <xsd:sequence>
        <xsd:element name="LanguageCoded" type="LanguageCodeType">
        <xsd:element minOccurs="0" name="LanguageCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="LocaleCoded" type="LocaleCodeType">
        <xsd:element minOccurs="0" name="LocaleCodedOther" type="xsd:string">
    </xsd:sequence>
    <xsd:attribute name="LanguageDependent" type="xsd:boolean" use="optional">
</xsd:complexType>


complexType definition: LineItemNumberReferenceType

LineItemNumberReferenceType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: Extension of type: xsd:int

    Attribute:Name: LineItemNumTypeCoded, Type: LineItemNumTypeCodeType, Default: 'Buyer'

    Description: LineItemNumberReferenceType identifies a line item number and whether that number was assigned by the buyer or the seller. This is a string content model.

    Attributes:

    • LineItemNumTypeCoded - identifies whether the line item number was assigned by the buyer or seller using a standard codelist.

[^]Code Fragment

    <xsd:complexType name="LineItemNumberReferenceType">
    <xsd:simpleContent>
        <xsd:extension base="xsd:int">
            <xsd:attribute name="LineItemNumTypeCoded" type="LineItemNumTypeCodeType" use="optional" default="Buyer">
        </xsd:extension>
    </xsd:simpleContent>
</xsd:complexType>


complexType definition: LineItemNumType

LineItemNumType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( BuyerLineItemNum[xsd:int] , SellerLineItemNum[xsd:int]? )

    Description: LineItemNumType a set of numbers uniquely identifying the line item for the number. In the case where the seller's system. splits a line item number into 2 line items, the buyer item number will remain the same for both line items, but the seller item number will be different.

    Elements:

    • BuyerLineItemNum - buyer's assigned line item number.
    • SellerLineItemNum - seller's assigned line item number.

[^]Code Fragment

    <xsd:complexType name="LineItemNumType">
    <xsd:sequence>
        <xsd:element name="BuyerLineItemNum" type="xsd:int">
        <xsd:element minOccurs="0" name="SellerLineItemNum" type="xsd:int">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: LineItemNumTypeCodeType

LineItemNumTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Buyer
    • Seller

[^]Code Fragment

    <xsd:simpleType name="LineItemNumTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Buyer">
        <xsd:enumeration value="Seller">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: LineItemRequisitionReferenceType

LineItemRequisitionReferenceType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( RequisitionReference[ReferenceType]? , RequisitionLineItemNumber[xsd:string] )

    Description: LineItemRequisitionReferenceType provides a reference to a requistion and a line item within that requisition, that created the line item. This is used to reconcile an Order with the ERP system that created it.

    Elements:

    • RequisitionReference - identifies the requisition in an ERP system which created this item.
    • RequisitionLineItemNumber - identifies the specific line item within the requisitioned referenced which created the line item.

[^]Code Fragment

    <xsd:complexType name="LineItemRequisitionReferenceType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="RequisitionReference" type="ReferenceType">
        <xsd:element name="RequisitionLineItemNumber" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: LineItemTypeCodeType

LineItemTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Item - Standard Line Item
    • ComponentGroup - Other line items referencing this line item from their parent item number fields are components of this item.
    • TextItem - The line item only contains textual information. Line items of this type cannot have any component relationships, and do not have any item or pricing information associated with them.
    • Other - Custom Code

[^]Code Fragment

    <xsd:simpleType name="LineItemTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Item">
        <xsd:enumeration value="ComponentGroup">
        <xsd:enumeration value="TextItem">
        <xsd:enumeration value="Other">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: LineItemTypeType

LineItemTypeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( LineItemTypeCoded[LineItemTypeCodeType] , LineItemTypeCodedOther[xsd:string]? )

    Description: LineItemTypeType contains information on whether the line item is part of a component group.

    Elements:

    • LineItemTypeCoded - is used to indicate whether the line item is a single or component line item.
    • LineItemTypeCodedOther - is used to provide a non-standard LineItemTypeCode. This element is mandatory if the value of LineItemTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="LineItemTypeType">
    <xsd:sequence>
        <xsd:element name="LineItemTypeCoded" type="LineItemTypeCodeType">
        <xsd:element minOccurs="0" name="LineItemTypeCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfAccountAssignmentType

ListOfAccountAssignmentType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( AccountAssignment[AccountAssignmentType]+ )

    Description: ListOfAccountAssignmentType is a list of account assignment information that references items in internal documents.

    Elements:

    • AccountAssignment - contains account assignment information

[^]Code Fragment

    <xsd:complexType name="ListOfAccountAssignmentType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="AccountAssignment" type="AccountAssignmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfActualPaymentType

ListOfActualPaymentType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ActualPayment[ActualPaymentType]+ )

    Description: ListOfActualPaymentType contains a list of information relating to payment(s) made on the invoice at the time the invoice was produced.

    Elements:

    • ActualPayment - contains information relating to a payment.

[^]Code Fragment

    <xsd:complexType name="ListOfActualPaymentType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="ActualPayment" type="ActualPaymentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfAllowOrChargeType

ListOfAllowOrChargeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( AllowOrCharge[AllowOrChargeType]+ )

    Description: ListOfAllowOrChargeType contains one or more services, promotions, allowances or charges.

    Elements:

    • AllowOrCharge - requests or identifies a service, promotion, allowance, or charge and specifies the amount or percentage for the service, promotion, allowance, or charge.

[^]Code Fragment

    <xsd:complexType name="ListOfAllowOrChargeType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="AllowOrCharge" type="AllowOrChargeType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfAttachmentType

ListOfAttachmentType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( Attachment[AttachmentType]+ )

    Description: ListOfAttachmentType is container that holds one or more Attachment elements.

    Elements:

    • Attachment - is a container for specifying the attachments to a document.

[^]Code Fragment

    <xsd:complexType name="ListOfAttachmentType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="Attachment" type="AttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfContactNumberType

ListOfContactNumberType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ContactNumber[ContactNumberType]+ )

    Description: ListOfContactNumberType lists one or more communication points.

    Elements:

    • ContactNumber - contains the channel and value of a communication point.

[^]Code Fragment

    <xsd:complexType name="ListOfContactNumberType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="ContactNumber" type="ContactNumberType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfContactType

ListOfContactType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( Contact[ContactType]+ )

    Description: ListOfContactType lists the information on one or more contacts for an entity.

    Elements:

    • Contact - is a container for the contact details.

[^]Code Fragment

    <xsd:complexType name="ListOfContactType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="Contact" type="ContactType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfContractType

ListOfContractType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( Contract[ContractType]+ )

    Description: ListOfContractType provides the details of an agreement between trading partners.

    Elements:

    • Contract - provides the details of the contract.

[^]Code Fragment

    <xsd:complexType name="ListOfContractType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="Contract" type="ContractType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfCostCenterType

ListOfCostCenterType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( CostCenter[CostCenterType]+ )

    Description: ListOfCostCenterType defines a collection of cost centers, and the allocations to them.

    Elements:

    • CostCenter - identifies a cost center, and any or all of the amount, quantity, or percentage allocated to it.

[^]Code Fragment

    <xsd:complexType name="ListOfCostCenterType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="CostCenter" type="CostCenterType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfCurrencyType

ListOfCurrencyType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( Currency[CurrencyType]+ )

    Description: ListOfCurrencyType contains a collection of currency identifications.

    Elements:

    • Currency - identifies a currency.

[^]Code Fragment

    <xsd:complexType name="ListOfCurrencyType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="Currency" type="CurrencyType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfDateCodedType

ListOfDateCodedType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( DateCoded[DateCodedType]+ )

    Description: ListOfDateCodedType lists one or more dates that are qualified with a function.

    Elements:

    • DateCoded - is a container for a date that has its function indicated with a qualifier.

[^]Code Fragment

    <xsd:complexType name="ListOfDateCodedType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="DateCoded" type="DateCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfDestinationRefType

ListOfDestinationRefType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( DestinationRef[DestinationRefType]+ )

    Description: ListOfDestinationRefType holds a list of all the destinations for the line item.

    Elements:

    • DestinationRef - holds the references for the destinations to the line item.

[^]Code Fragment

    <xsd:complexType name="ListOfDestinationRefType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="DestinationRef" type="DestinationRefType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfDimensionType

ListOfDimensionType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( Dimension[DimensionType]+ )

    Description: ListOfDimensionType is a container for a list of one or more dimension elements.

    Elements:

    • Dimension - is quantitative physical characteristic.

[^]Code Fragment

    <xsd:complexType name="ListOfDimensionType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="Dimension" type="DimensionType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfErrorInfoType

ListOfErrorInfoType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ErrorInfo[ErrorInfoType]+ )

    Description: ListOfErrorInfoType is a collection of one or more ErrorInfo elements.

    Elements:

    • ErrorInfo - is used by the receiving application to return complete information about errors encountered during processing of a message.

[^]Code Fragment

    <xsd:complexType name="ListOfErrorInfoType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="ErrorInfo" type="ErrorInfoType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfHazardousIdentifiersType

ListOfHazardousIdentifiersType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( HazardousIdentifiers[HazardousIdentifiersType]+ )

    Description: ListOfHazardousIdentifiersType is a list of identifiers that are in reference to the hazardous material being described.

    Elements:

    • HazardousIdentifiers - are identifiers that describe specifics of the hazardous codes associated with an item or packaging.

[^]Code Fragment

    <xsd:complexType name="ListOfHazardousIdentifiersType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="HazardousIdentifiers" type="HazardousIdentifiersType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfHazardousType

ListOfHazardousType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( Hazardous[HazardousType]+ )

    Description: ListOfHazardousType contains one or more Hazardous elements.

    Elements:

    • Hazardous - specifies the hazardous information required for safe handling of an item or package.

[^]Code Fragment

    <xsd:complexType name="ListOfHazardousType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="Hazardous" type="HazardousType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfIdentifierType

ListOfIdentifierType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( Identifier[IdentifierType]+ )

    Description: ListOfIdentifierType contains one or more Identifier elements.

    Elements:

    • Identifier - is used to provide an identification number that is assigned by a standards agency.

[^]Code Fragment

    <xsd:complexType name="ListOfIdentifierType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="Identifier" type="IdentifierType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfItemCharacteristicType

ListOfItemCharacteristicType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ItemCharacteristic[ItemCharacteristicType]+ )

    Description: ListOfItemCharacteristicType is a collection of one or more characteristics that describe the item such as surface finishes.

    Elements:

    • ItemCharacteristic - is a container element that contains the characteristics of an item.

[^]Code Fragment

    <xsd:complexType name="ListOfItemCharacteristicType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="ItemCharacteristic" type="ItemCharacteristicType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfLanguageStringType

ListOfLanguageStringType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( LanguageString[LanguageStringType]+ )

    Description: ListOfLanguageStringType contains one or more LanguageString elements.

    Elements:

    • LanguageString - is a string with an optional language specification. If the language is not provided, it is assumed that the language is known from the context in which the LanguageString is used.

[^]Code Fragment

    <xsd:complexType name="ListOfLanguageStringType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="LanguageString" type="LanguageStringType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfLanguageType

ListOfLanguageType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( Language[LanguageType]+ )

    Description: ListOfLanguageType contains a list of languages.

    Elements:

    • Language - is used to provide information about the language which text is written in.

[^]Code Fragment

    <xsd:complexType name="ListOfLanguageType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="Language" type="LanguageType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfLocationType

ListOfLocationType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( Location[LocationType]+ )

    Description: ListOfLocationType contains a list of locations.

    Elements:

    • Location - identifies a place by its function and either an identifier, an identification assigned to an address, or an address.

[^]Code Fragment

    <xsd:complexType name="ListOfLocationType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="Location" type="LocationType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfMeasurementType

ListOfMeasurementType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( Measurement[MeasurementType]+ )

    Description: ListOfMeasurementType lists one or more measurements.

    Elements:

    • Measurement - is the quantitative value expressed as either a value or a range and unit of measure.

[^]Code Fragment

    <xsd:complexType name="ListOfMeasurementType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="Measurement" type="MeasurementType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfNameAddressType

ListOfNameAddressType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( NameAddress[NameAddressType]+ )

    Description: ListOfNameAddressType contains one or more addresses for an entity.

    Elements:

    • NameAddress - contains the name and the address information for an entity.

[^]Code Fragment

    <xsd:complexType name="ListOfNameAddressType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="NameAddress" type="NameAddressType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfNameValuePairType

ListOfNameValuePairType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( NameValuePair[NameValuePairType]+ )

    Description: ListOfNameValuePairType contains a collection of name and value pairs.

    Elements:

    • NameValuePair - contains the generic name and value pair.

[^]Code Fragment

    <xsd:complexType name="ListOfNameValuePairType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="NameValuePair" type="NameValuePairType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfNameValueSetType

ListOfNameValueSetType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( NameValueSet[NameValueSetType]+ )

    Description: ListOfNameValueSetType contains a collection of name and value sets.

    Elements:

    • NameValueSet - is a set of collections of name value pairs.

[^]Code Fragment

    <xsd:complexType name="ListOfNameValueSetType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="NameValueSet" type="NameValueSetType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfPackageCharacteristicType

ListOfPackageCharacteristicType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PackageCharacteristic[PackageCharacteristicType]+ )

    Description: ListOfPackageCharacteristicType contains one or more PackageCharacteristic elements.

    Elements:

    • PackageCharacteristic - contains the code and the description of the packaging characteristics.

[^]Code Fragment

    <xsd:complexType name="ListOfPackageCharacteristicType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="PackageCharacteristic" type="PackageCharacteristicType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfPackageDescriptionType

ListOfPackageDescriptionType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PackageDescription[PackageDescriptionType]+ )

    Description: ListOfPackageDescriptionType is a list of package descriptions. To be used to identify individual packages.

    Elements:

    • PackageDescription - identifies specific information relating to an individual package. Includes the package identifier, the container counter, and the load order counter.

[^]Code Fragment

    <xsd:complexType name="ListOfPackageDescriptionType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="PackageDescription" type="PackageDescriptionType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfPackageDetailType

ListOfPackageDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PackageDetail[PackageDetailType]+ )

    Description: ListOfPackageDetailType is a container to hold one or more PackageDetail elements.

    Elements:

    • PackageDetail - is the packaging information at the detail level for the items, packages, and equipment. This also provides information on hazardous materials, returnable containers, and marks and numbers. This is used to describe a collection of packages of the same type. For instance, a collection of multiple pallets would be described by one PackageDetail element. The PackageDetail element is recursive to allow for sub packaging descriptions. For instance, if a collection of boxes are contained on a pallet, the first recurrence of the PackageDetail element would describe the boxes that are contained on the pallet.

[^]Code Fragment

    <xsd:complexType name="ListOfPackageDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="PackageDetail" type="PackageDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfPackageDocType

ListOfPackageDocType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PackageDocLoose[PackageDocType]+ )

    Description: ListOfPackageDocType

    Elements:

    • PackageDocLoose

[^]Code Fragment

    <xsd:complexType name="ListOfPackageDocType">
    <xsd:sequence>
        <xsd:element name="PackageDocLoose" type="PackageDocType" maxOccurs="unbounded">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfPackageIdentifierType

ListOfPackageIdentifierType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PackageIdentifier[PackageIdentifierType]+ )

    Description: ListOfPackageIdentifierType is a list of the identifiers for the individual package.

    Elements:

    • PackageIdentifier - is the identifier on the package that is unique in relation to other packages.

[^]Code Fragment

    <xsd:complexType name="ListOfPackageIdentifierType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="PackageIdentifier" type="PackageIdentifierType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfPackageItemReferenceType

ListOfPackageItemReferenceType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PackageItemReference[PackageItemReferenceType]+ )

    Description: ListOfPackageItemReferenceType

    Elements:

    • PackageItemReference -

[^]Code Fragment

    <xsd:complexType name="ListOfPackageItemReferenceType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="PackageItemReference" type="PackageItemReferenceType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfPackageMarkType

ListOfPackageMarkType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PackageMark[PackageMarkType]+ )

    Description: ListOfPackageMarkType contains one or more PackageMark elements.

    Elements:

    • PackageMark - specifies the type and value of markings on packages.

[^]Code Fragment

    <xsd:complexType name="ListOfPackageMarkType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="PackageMark" type="PackageMarkType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfPackageType

ListOfPackageType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( Package[PackageType]+ )

    Description: ListOfPackageType is used to describe one or more Package element as necessary by the complexity of the use of PackageDetail element.

    Elements:

    • Package - contains information about the specifics of the collection of packages being described by the PackageDetail element. If the collection of packages all contain the same things, and there is no need to identify specifically which packages are contained in which, the only one Package element should be use. If the contents of the package differ or if there needs to be a distinction between which package a sub package is contained in, then multiple Package elements should be used.

[^]Code Fragment

    <xsd:complexType name="ListOfPackageType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="Package" type="PackageType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfPackageTypeType

ListOfPackageTypeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PackageType[PackageTypeType]+ )

    Description: ListOfPackageTypeType is used to describe one or more Package element as necessary by the complexity of the use of PackageDetail element.

    Elements:

    • PackageType - identifies and describes the material used for packaging.

[^]Code Fragment

    <xsd:complexType name="ListOfPackageTypeType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="PackageType" type="PackageTypeType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfParameterType

ListOfParameterType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( Parameter[xsd:string]+ )

    Description: ListOfParameterType

    Elements:

    • Parameter

[^]Code Fragment

    <xsd:complexType name="ListOfParameterType">
    <xsd:sequence>
        <xsd:element name="Parameter" type="xsd:string" maxOccurs="unbounded">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfPartNumType

ListOfPartNumType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PartNum[PartNumType]+ )

    Description: ListOfPartNumType a list of one or more part numbers

    Elements:

    • PartNum - is a part number

[^]Code Fragment

    <xsd:complexType name="ListOfPartNumType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="PartNum" type="PartNumType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfPartyCodedType

ListOfPartyCodedType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PartyCoded[PartyCodedType]+ )

    Description: ListOfPartyCodedType is a collection of all other party information not explicitly stated as the content of another element.

    Elements:

    • PartyCoded - identifies an entity doing business not explicitly stated as the content of another element with its role and the relevant information pertaining to the entity.

[^]Code Fragment

    <xsd:complexType name="ListOfPartyCodedType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="PartyCoded" type="PartyCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfPartyType

ListOfPartyType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( Party[PartyType]+ )

    Description: ListOfPartyType is a collection of entities doing business and the relevant information pertaining to them.

    Elements:

    • Party - identifies an entity doing business and the relevant information pertaining to it.

[^]Code Fragment

    <xsd:complexType name="ListOfPartyType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="Party" type="PartyType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfPaymentInstructionsType

ListOfPaymentInstructionsType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PaymentInstructions[PaymentInstructionsType]+ )

    Description: ListOfPaymentInstructionsType is a collection of one or more elements to communication the terms and the method of payment for goods or services received.

    Elements:

    • PaymentInstructions - contains the terms and the method of payment for goods or services received.

[^]Code Fragment

    <xsd:complexType name="ListOfPaymentInstructionsType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="PaymentInstructions" type="PaymentInstructionsType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfPriceType

ListOfPriceType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( Price[PriceType]+ )

    Description: ListOfPriceType contains one or more pricing schemes.

    Elements:

    • Price - contains a pricing scheme for an item.

[^]Code Fragment

    <xsd:complexType name="ListOfPriceType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="Price" type="PriceType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfProductIdentifierCodedType

ListOfProductIdentifierCodedType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ProductIdentifierCoded[ProductIdentifierCodedType]+ )

    Description: ListOfProductIdentifierCodedType contains one or more identifications of a product or service where the source or function of the identification is not explicitly stated in another element.

    Elements:

    • ProductIdentifierCoded - is an identification of a product or service where the source or function of the identification is not explicitly stated by another element.

[^]Code Fragment

    <xsd:complexType name="ListOfProductIdentifierCodedType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="ProductIdentifierCoded" type="ProductIdentifierCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfPurchaseOrderReferenceType

ListOfPurchaseOrderReferenceType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PurchaseOrderReference[PurchaseOrderReferenceType]+ )

    Description: ListOfPurchaseOrderReferenceType contains references to multiple orders.

    Elements:

    • PurchaseOrderReference - contains references to a purchase order.

[^]Code Fragment

    <xsd:complexType name="ListOfPurchaseOrderReferenceType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="PurchaseOrderReference" type="PurchaseOrderReferenceType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfQuantityCodedType

ListOfQuantityCodedType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( QuantityCoded[QuantityCodedType]+ )

    Description: ListOfQuantityCodedType is a container holding a list of quantities not explicitly stated in other elements.

    Elements:

    • QuantityCoded - contains a quantity not explicitly stated in another element.

[^]Code Fragment

    <xsd:complexType name="ListOfQuantityCodedType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="QuantityCoded" type="QuantityCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfQuantityType

ListOfQuantityType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( Quantity[QuantityType]+ )

    Description: ListOfQuantityType contains a list of one or more quantities.

    Elements:

    • Quantity - is used to specify a specific value of a quantity. A container for a list of one or more Quantity elements.

[^]Code Fragment

    <xsd:complexType name="ListOfQuantityType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="Quantity" type="QuantityType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfRateOfExchangeDetailType

ListOfRateOfExchangeDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( RateOfExchangeDetail[RateOfExchangeDetailType]+ )

    Description: ListOfRateOfExchangeDetailType contains one or more elements detailing information on the rate of exchange between currencies.

    Elements:

    • RateOfExchangeDetail - holds information on the rate of exchange between two currencies.

[^]Code Fragment

    <xsd:complexType name="ListOfRateOfExchangeDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="RateOfExchangeDetail" type="RateOfExchangeDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfReferenceCodedType

ListOfReferenceCodedType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ReferenceCoded[ReferenceCodedType]+ )

    Description: ListOfReferenceCodedType contains one or more elements containing information that can be used to find further information elsewhere that is not explicitly stated in another element.

    Elements:

    • ReferenceCoded - identifies the source of the information using a standard codelist.

[^]Code Fragment

    <xsd:complexType name="ListOfReferenceCodedType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="ReferenceCoded" type="ReferenceCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfReferenceType

ListOfReferenceType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( Reference[ReferenceType]+ )

    Description: ListOfReferenceType contains one or more elements containing information that can be used to find further information elsewhere.

    Elements:

    • Reference - contains information that can be used to find further information elsewhere.

[^]Code Fragment

    <xsd:complexType name="ListOfReferenceType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="Reference" type="ReferenceType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfRegionType

ListOfRegionType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( Region[RegionType]+ )

    Description: ListOfRegionType holds the information regarding regions within countries.

    Elements:

    • Region - holds the basic list of regions within a country.

[^]Code Fragment

    <xsd:complexType name="ListOfRegionType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="Region" type="RegionType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfScheduleLineType

ListOfScheduleLineType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ScheduleLine[ScheduleLineType]+ )

    Description: ListOfScheduleLineType is all of the schedule information relevant to the line item for the shipping parties. This may indicate several shipments to the same location over a period of time.

    Elements:

    • ScheduleLine - contains the information on a portion of the line item shipment to be sent on particular set of dates with a particular set of transport information.

[^]Code Fragment

    <xsd:complexType name="ListOfScheduleLineType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="ScheduleLine" type="ScheduleLineType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfSealInfoType

ListOfSealInfoType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( SealInfo[SealInfoType]+ )

    Description: ListOfSealInfoType provides the information regarding the seals affixed to the equipment.

    Elements:

    • SealInfo - provides seal information for the equipment.

[^]Code Fragment

    <xsd:complexType name="ListOfSealInfoType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="SealInfo" type="SealInfoType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfShipToSubInformationType

ListOfShipToSubInformationType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ShipToSubInformation[ShipToSubInformationType]+ )

    Description: ListOfShipToSubInformationType details place and quantity information regarding the shipto sub-location.

    Elements:

    • ShipToSubInformation - contains the information for the locations and quantities of the goods for the schedule lines.

[^]Code Fragment

    <xsd:complexType name="ListOfShipToSubInformationType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="ShipToSubInformation" type="ShipToSubInformationType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfStatusReasonType

ListOfStatusReasonType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( StatusReason[StatusReasonType]+ )

    Description: ListOfStatusReasonType holds a list of status reason.

    Elements:

    • StatusReason - provides a reason for the status.

[^]Code Fragment

    <xsd:complexType name="ListOfStatusReasonType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="StatusReason" type="StatusReasonType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfStructuredNoteType

ListOfStructuredNoteType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( StructuredNote[StructuredNoteType]+ )

    Description: ListOfStructuredNoteType contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. Such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.

    Elements:

    • StructuredNote - is a note that allows for an ID, URL, and a free form note field.

[^]Code Fragment

    <xsd:complexType name="ListOfStructuredNoteType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="StructuredNote" type="StructuredNoteType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfTaxSummaryType

ListOfTaxSummaryType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( TaxSummary[TaxSummaryType]+ )

    Description: ListOfTaxSummaryType

    Elements:

    • TaxSummary

[^]Code Fragment

    <xsd:complexType name="ListOfTaxSummaryType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="TaxSummary" type="TaxSummaryType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfTimezoneType

ListOfTimezoneType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( Timezone[TimezoneType]+ )

    Description: ListOfTimezoneType lists the time zones for the location.

    Elements:

    • Timezone - defines the time zone.

[^]Code Fragment

    <xsd:complexType name="ListOfTimezoneType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="Timezone" type="TimezoneType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfTransportEquipmentType

ListOfTransportEquipmentType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( TransportEquipment[TransportEquipmentType]+ )

    Description: ListOfTransportEquipmentType contains a list of one or more vessel/vehicle or package serving as the equipment for this leg of transport.

    Elements:

    • TransportEquipment - identifies the vessel/vehicle or package serving as the equipment for this leg of transport.

[^]Code Fragment

    <xsd:complexType name="ListOfTransportEquipmentType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="TransportEquipment" type="TransportEquipmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfTransportRoutingType

ListOfTransportRoutingType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( TransportRouting[TransportRoutingType]+ )

    Description: ListOfTransportRoutingType defines the information on the movement of the goods, including the carrier, equipment, locations and dates.

    Elements:

    • TransportRouting - holds the definition of the transport routing. A single TransportRouting is defined by one carrier (that is, one organization operating equipment) moving between two or more locations with a single mode of transport. You may have more than one vehicle acting as part of the transport, but all must use the same route, be of the same mode, and be operated by the same carrier.

[^]Code Fragment

    <xsd:complexType name="ListOfTransportRoutingType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="TransportRouting" type="TransportRoutingType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfValuesType

ListOfValuesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( NameValuePair[NameValuePairType]+ )

    Description: ListOfValuesType

    Elements:

    • NameValuePair

[^]Code Fragment

    <xsd:complexType name="ListOfValuesType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="NameValuePair" type="NameValuePairType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: LocaleCodeType

LocaleCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the location where the language is spoken.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom code
    • ae - United Arab Emirates
    • af - Afghanistan
    • ag - Antigua and Barbuda
    • ai - Anguilla
    • al - Albania
    • am - Armenia
    • an - Netherlands Antilles
    • ao - Angola
    • aq - Antarctica
    • ar - Argentina
    • as - American Samoa
    • at - Austria
    • au - Australia
    • aw - Aruba
    • az - Azerbaijan
    • ba - Bosnia-Hercegovina
    • bb - Barbados
    • bd - Bangladesh
    • be - Belgium
    • bf - Burkina Faso
    • bg - Bulgaria
    • bh - Bahrain
    • bi - Burundi
    • bj - Benin
    • bm - Bermuda
    • bn - Brunei Darussalam
    • bo - Bolivia
    • br - Brazil
    • bs - Bahamas
    • bt - Bhutan
    • bu - Burma (See MM Myanmar)
    • bw - Botswana
    • by - Belarus
    • bz - Belize
    • ca - Canada
    • cc - Cocos (Keeling) Islands
    • cd - Congo, Democratic Republic Of
    • cf - Central African Republic
    • cg - Congo
    • ch - Switzerland
    • ci - Cote D'Ivoire
    • ck - Cook Islands
    • cl - Chile
    • cm - Cameroon
    • cn - China
    • co - Colombia
    • cr - Costa Rica
    • cs - Former Czechoslovakia
    • cu - Cuba
    • cv - Cape Verde
    • cx - Christmas Islands
    • cy - Cyprus
    • cz - Czech Republic
    • de - Germany, Federal Republic Of
    • dj - Djibouti
    • dk - Denmark
    • dm - Dominica
    • do - Dominican Republic
    • dz - Algeria
    • ec - Ecuador
    • ee - Estonia
    • eg - Egypt
    • eh - Western Sahara
    • er - Eritrea
    • es - Spain
    • et - Ethiopia
    • fi - Finland
    • fj - Fiji
    • fk - Falkland Islands (Malvinas)
    • fm - Fed States Of Micronesia
    • fo - Faeroe Islands
    • fr - France
    • ga - Gabon
    • gb - United Kingdom
    • gd - Grenada
    • ge - Georgia
    • gf - French Guiana
    • gh - Ghana
    • gi - Gibraltar
    • gl - Greenland
    • gm - Gambia
    • gn - Guinea
    • gp - Guadeloupe
    • gq - Equatorial Guinea
    • gr - Greece
    • gs - S. Georgia and S. Sandwich Islands
    • gt - Guatemala
    • gu - Guam
    • gw - Guinea-Bissau
    • gy - Guyana
    • hk - Hong Kong
    • hn - Honduras
    • hr - Croatia
    • ht - Haiti
    • hu - Hungary
    • id - Indonesia
    • ie - Ireland
    • il - Israel
    • in - India
    • io - Indian Ocean Territory
    • iq - Iraq
    • ir - Iran, Islamic Republic Of
    • is - Iceland
    • it - Italy
    • jm - Jamaica
    • jo - Jordan
    • jp - Japan
    • ke - Kenya
    • kg - Kyrgyzstan
    • kh - Cambodia
    • ki - Kiribati
    • km - Comoros
    • kn - St Kitts-Nevis
    • kp - Korea, Democratic People's Rep
    • kr - Korea, Republic Of
    • kw - Kuwait
    • ky - Cayman Islands
    • kz - Kazakhstan
    • la - Lao, People's Democratic Rep
    • lb - Lebanon
    • lc - Saint Lucia
    • li - Liechtenstein
    • lk - Sri Lanka
    • lr - Liberia
    • ls - Lesotho
    • lt - Lithuania
    • lu - Luxembourg
    • lv - Latvia
    • ly - Lybian Arab Jamahiriya
    • ma - Morocco
    • mc - Monaco
    • md - Moldova
    • mg - Madagascar
    • mh - Marshall Islands
    • mk - Frmr Yugoslav Rep Of Macedonia
    • ml - Mali
    • mm - Myanmar (Former Burma)
    • mn - Mongolia
    • mo - Macau
    • mp - Northern Marianas
    • mq - Martinique
    • mr - Mauritania
    • ms - Montserrat
    • mt - Malta
    • mu - Mauritius
    • mv - Maldives
    • mw - Malawi
    • mx - Mexico
    • my - Malaysia
    • mz - Mozambique
    • na - Namibia
    • nc - New Caledonia
    • ne - Niger
    • nf - Norfolk Island
    • ng - Nigeria
    • ni - Nicaragua
    • nl - Netherlands
    • no - Norway
    • np - Nepal
    • nr - Nauru
    • nu - Niue
    • nz - New Zealand
    • om - Oman
    • pa - Panama
    • pe - Peru
    • pf - French Polynesia
    • pg - Papua New Guinea
    • ph - Philippines
    • pk - Pakistan
    • pl - Poland
    • pm - St Pierre and Miquelon
    • pn - Pitcairn
    • pr - Puerto Rico
    • pt - Portugal
    • pw - Palau
    • py - Paraguay
    • qa - Qatar
    • re - Reunion
    • ro - Romania
    • ru - Russian Federation
    • rw - Rwanda
    • sa - Saudi Arabia
    • sb - Solomon Islands
    • sc - Seychelles
    • sd - Sudan
    • se - Sweden
    • sg - Singapore
    • sh - St Helena
    • si - Slovenia
    • sj - Svalbard and Jan Mayen
    • sk - Slovakia
    • sl - Sierra Leone
    • sm - San Marino
    • sn - Senegal
    • so - Somalia
    • sr - Suriname
    • st - Sao Tome and Principe
    • sv - El Salvador
    • sy - Syrian Arab Republic
    • sz - Swaziland
    • tc - Turks and Caicos Islands
    • td - Chad
    • tf - French Southern Territories
    • tg - Togo
    • th - Thailand
    • tj - Tajikistan
    • tm - Turkmenistan
    • tn - Tunisia
    • to - Tonga
    • tp - East Timor
    • tr - Turkey
    • tt - Trinidad and Tobago
    • tv - Tuvalu
    • tw - Taiwan, Province Of China
    • tz - Tanzania, United Republic Of
    • ua - Ukraine
    • ug - Uganda
    • um - US Minor Outlying Islands
    • us - United States
    • uy - Uruguay
    • uz - Uzbekistan
    • va - Vatican City State (Holy See)
    • vc - St Vincent and Grenadines
    • ve - Venezuela
    • vg - Virgin Islands, British
    • vi - United States Virgin Islands
    • vn - Viet Nam
    • vu - Vanuatu
    • wf - Wallis and Futuna Islands
    • ws - Samoa
    • ye - Yemen
    • yt - Mayotte
    • yu - Yugoslavia (Fed Rep Of)
    • za - South Africa
    • zm - Zambia
    • zw - Zimbabwe

[^]Code Fragment

    <xsd:simpleType name="LocaleCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="ae">
        <xsd:enumeration value="af">
        <xsd:enumeration value="ag">
        <xsd:enumeration value="ai">
        <xsd:enumeration value="al">
        <xsd:enumeration value="am">
        <xsd:enumeration value="an">
        <xsd:enumeration value="ao">
        <xsd:enumeration value="aq">
        <xsd:enumeration value="ar">
        <xsd:enumeration value="as">
        <xsd:enumeration value="at">
        <xsd:enumeration value="au">
        <xsd:enumeration value="aw">
        <xsd:enumeration value="az">
        <xsd:enumeration value="ba">
        <xsd:enumeration value="bb">
        <xsd:enumeration value="bd">
        <xsd:enumeration value="be">
        <xsd:enumeration value="bf">
        <xsd:enumeration value="bg">
        <xsd:enumeration value="bh">
        <xsd:enumeration value="bi">
        <xsd:enumeration value="bj">
        <xsd:enumeration value="bm">
        <xsd:enumeration value="bn">
        <xsd:enumeration value="bo">
        <xsd:enumeration value="br">
        <xsd:enumeration value="bs">
        <xsd:enumeration value="bt">
        <xsd:enumeration value="bu">
        <xsd:enumeration value="bw">
        <xsd:enumeration value="by">
        <xsd:enumeration value="bz">
        <xsd:enumeration value="ca">
        <xsd:enumeration value="cc">
        <xsd:enumeration value="cd">
        <xsd:enumeration value="cf">
        <xsd:enumeration value="cg">
        <xsd:enumeration value="ch">
        <xsd:enumeration value="ci">
        <xsd:enumeration value="ck">
        <xsd:enumeration value="cl">
        <xsd:enumeration value="cm">
        <xsd:enumeration value="cn">
        <xsd:enumeration value="co">
        <xsd:enumeration value="cr">
        <xsd:enumeration value="cs">
        <xsd:enumeration value="cu">
        <xsd:enumeration value="cv">
        <xsd:enumeration value="cx">
        <xsd:enumeration value="cy">
        <xsd:enumeration value="cz">
        <xsd:enumeration value="de">
        <xsd:enumeration value="dj">
        <xsd:enumeration value="dk">
        <xsd:enumeration value="dm">
        <xsd:enumeration value="do">
        <xsd:enumeration value="dz">
        <xsd:enumeration value="ec">
        <xsd:enumeration value="ee">
        <xsd:enumeration value="eg">
        <xsd:enumeration value="eh">
        <xsd:enumeration value="er">
        <xsd:enumeration value="es">
        <xsd:enumeration value="et">
        <xsd:enumeration value="fi">
        <xsd:enumeration value="fj">
        <xsd:enumeration value="fk">
        <xsd:enumeration value="fm">
        <xsd:enumeration value="fo">
        <xsd:enumeration value="fr">
        <xsd:enumeration value="ga">
        <xsd:enumeration value="gb">
        <xsd:enumeration value="gd">
        <xsd:enumeration value="ge">
        <xsd:enumeration value="gf">
        <xsd:enumeration value="gh">
        <xsd:enumeration value="gi">
        <xsd:enumeration value="gl">
        <xsd:enumeration value="gm">
        <xsd:enumeration value="gn">
        <xsd:enumeration value="gp">
        <xsd:enumeration value="gq">
        <xsd:enumeration value="gr">
        <xsd:enumeration value="gs">
        <xsd:enumeration value="gt">
        <xsd:enumeration value="gu">
        <xsd:enumeration value="gw">
        <xsd:enumeration value="gy">
        <xsd:enumeration value="hk">
        <xsd:enumeration value="hn">
        <xsd:enumeration value="hr">
        <xsd:enumeration value="ht">
        <xsd:enumeration value="hu">
        <xsd:enumeration value="id">
        <xsd:enumeration value="ie">
        <xsd:enumeration value="il">
        <xsd:enumeration value="in">
        <xsd:enumeration value="io">
        <xsd:enumeration value="iq">
        <xsd:enumeration value="ir">
        <xsd:enumeration value="is">
        <xsd:enumeration value="it">
        <xsd:enumeration value="jm">
        <xsd:enumeration value="jo">
        <xsd:enumeration value="jp">
        <xsd:enumeration value="ke">
        <xsd:enumeration value="kg">
        <xsd:enumeration value="kh">
        <xsd:enumeration value="ki">
        <xsd:enumeration value="km">
        <xsd:enumeration value="kn">
        <xsd:enumeration value="kp">
        <xsd:enumeration value="kr">
        <xsd:enumeration value="kw">
        <xsd:enumeration value="ky">
        <xsd:enumeration value="kz">
        <xsd:enumeration value="la">
        <xsd:enumeration value="lb">
        <xsd:enumeration value="lc">
        <xsd:enumeration value="li">
        <xsd:enumeration value="lk">
        <xsd:enumeration value="lr">
        <xsd:enumeration value="ls">
        <xsd:enumeration value="lt">
        <xsd:enumeration value="lu">
        <xsd:enumeration value="lv">
        <xsd:enumeration value="ly">
        <xsd:enumeration value="ma">
        <xsd:enumeration value="mc">
        <xsd:enumeration value="md">
        <xsd:enumeration value="mg">
        <xsd:enumeration value="mh">
        <xsd:enumeration value="mk">
        <xsd:enumeration value="ml">
        <xsd:enumeration value="mm">
        <xsd:enumeration value="mn">
        <xsd:enumeration value="mo">
        <xsd:enumeration value="mp">
        <xsd:enumeration value="mq">
        <xsd:enumeration value="mr">
        <xsd:enumeration value="ms">
        <xsd:enumeration value="mt">
        <xsd:enumeration value="mu">
        <xsd:enumeration value="mv">
        <xsd:enumeration value="mw">
        <xsd:enumeration value="mx">
        <xsd:enumeration value="my">
        <xsd:enumeration value="mz">
        <xsd:enumeration value="na">
        <xsd:enumeration value="nc">
        <xsd:enumeration value="ne">
        <xsd:enumeration value="nf">
        <xsd:enumeration value="ng">
        <xsd:enumeration value="ni">
        <xsd:enumeration value="nl">
        <xsd:enumeration value="no">
        <xsd:enumeration value="np">
        <xsd:enumeration value="nr">
        <xsd:enumeration value="nu">
        <xsd:enumeration value="nz">
        <xsd:enumeration value="om">
        <xsd:enumeration value="pa">
        <xsd:enumeration value="pe">
        <xsd:enumeration value="pf">
        <xsd:enumeration value="pg">
        <xsd:enumeration value="ph">
        <xsd:enumeration value="pk">
        <xsd:enumeration value="pl">
        <xsd:enumeration value="pm">
        <xsd:enumeration value="pn">
        <xsd:enumeration value="pr">
        <xsd:enumeration value="pt">
        <xsd:enumeration value="pw">
        <xsd:enumeration value="py">
        <xsd:enumeration value="qa">
        <xsd:enumeration value="re">
        <xsd:enumeration value="ro">
        <xsd:enumeration value="ru">
        <xsd:enumeration value="rw">
        <xsd:enumeration value="sa">
        <xsd:enumeration value="sb">
        <xsd:enumeration value="sc">
        <xsd:enumeration value="sd">
        <xsd:enumeration value="se">
        <xsd:enumeration value="sg">
        <xsd:enumeration value="sh">
        <xsd:enumeration value="si">
        <xsd:enumeration value="sj">
        <xsd:enumeration value="sk">
        <xsd:enumeration value="sl">
        <xsd:enumeration value="sm">
        <xsd:enumeration value="sn">
        <xsd:enumeration value="so">
        <xsd:enumeration value="sr">
        <xsd:enumeration value="st">
        <xsd:enumeration value="sv">
        <xsd:enumeration value="sy">
        <xsd:enumeration value="sz">
        <xsd:enumeration value="tc">
        <xsd:enumeration value="td">
        <xsd:enumeration value="tf">
        <xsd:enumeration value="tg">
        <xsd:enumeration value="th">
        <xsd:enumeration value="tj">
        <xsd:enumeration value="tm">
        <xsd:enumeration value="tn">
        <xsd:enumeration value="to">
        <xsd:enumeration value="tp">
        <xsd:enumeration value="tr">
        <xsd:enumeration value="tt">
        <xsd:enumeration value="tv">
        <xsd:enumeration value="tw">
        <xsd:enumeration value="tz">
        <xsd:enumeration value="ua">
        <xsd:enumeration value="ug">
        <xsd:enumeration value="um">
        <xsd:enumeration value="us">
        <xsd:enumeration value="uy">
        <xsd:enumeration value="uz">
        <xsd:enumeration value="va">
        <xsd:enumeration value="vc">
        <xsd:enumeration value="ve">
        <xsd:enumeration value="vg">
        <xsd:enumeration value="vi">
        <xsd:enumeration value="vn">
        <xsd:enumeration value="vu">
        <xsd:enumeration value="wf">
        <xsd:enumeration value="ws">
        <xsd:enumeration value="ye">
        <xsd:enumeration value="yt">
        <xsd:enumeration value="yu">
        <xsd:enumeration value="za">
        <xsd:enumeration value="zm">
        <xsd:enumeration value="zw">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: LocationIdentifierType

LocationIdentifierType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( LocID[IdentifierType] , LocationDescription[xsd:string]? )

    Description: LocationIdentifierType contains the location identifier and the agency responsible for issuing the identifier.

    Elements:

    • LocID - specifies the location using an identifier such as a UNLOC code, EAN code or other similar code system.
    • LocationDescription - describes the location such as a city in a free text format.

[^]Code Fragment

    <xsd:complexType name="LocationIdentifierType">
    <xsd:sequence>
        <xsd:element name="LocID" type="IdentifierType">
        <xsd:element minOccurs="0" name="LocationDescription" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: LocationQualifierCodeType

LocationQualifierCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the type of the location. This code list is derived from X12 309 (Location Qualifier)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • JurisdictionToReceiveCreditForUniformCommercialCodeFiling
    • TransmittingUtility
    • Consignor
    • CensusScheduleD
    • UniformCommercialCodeFilingOffice
    • CurrentAddress
    • CensusBlockGroup
    • HomeAddress
    • HomeBaseAddress
    • CensusTract
    • CensusScheduleK
    • LocalAddress
    • MailingAddress
    • OfficeAddress
    • PermanentAddress
    • Birthplace
    • WorldwideGeographicLocationCode
    • NearestCrossStreet
    • SecondaryCrossStreet
    • Range
    • Section
    • QuarterSection
    • MarkerIdentifierLocation
    • Route
    • RouteSubdivision
    • GridLocation
    • Page
    • MarkerType
    • Latitude-LongitudeSource
    • MapSource
    • MapReference
    • GridSource
    • Aliquot
    • Block
    • District
    • DrainholeNumber
    • CityBlock
    • FootageCallDirection
    • LocationDirection
    • OuterContinentalLeaseLocation
    • Lot
    • MapQuadrangle
    • PrincipalMeridian
    • OuterContinentalShelfArea
    • OuterContinentalShelfBlock
    • OfficialProtractionDiagram
    • QuarterQuarterQuarterSection
    • QuarterQuarterSection
    • SectionType
    • Abstract
    • Labor
    • League
    • Survey
    • Tier
    • Tract
    • UniversalTransverseMercatorQuadrant
    • CourseDirection
    • Area
    • SendersLocationCode
    • ReceiversLocationCode
    • Office
    • AnnualStatementsMailingAddress
    • CityandState
    • AllPoints
    • ArmedServicesLocationDesignation
    • Branch
    • BusinessEconomicAreaRegionCode
    • GovernmentBillofLadingOfficeCode
    • PlaceOfBusiness
    • GeopoliticalNameCode
    • CountryOfOrigin
    • ConfirmationMailingAddress
    • Country
    • CanadianCustomsOfficeCode
    • CorrespondenceMailingAddress
    • City
    • NationalRateBasis
    • CountyOrParishAndState
    • InTankCar
    • CanadianSPLC
    • CountyOrParish
    • DistributionCenterNumber
    • Destination-Shipping
    • DeliveryLocation
    • DistrictOffice
    • Department
    • DistrictOfResidence
    • DomicileTypeCode
    • EventLocation
    • EmployerLocation
    • Factory
    • FreightEqualizationPoint
    • ForeignFreightForwarderLocation
    • FederalInformationProcessingStandards55-NamedPopulatedPlaces
    • U.S.CustomsFacilitiesInformationandResourceManagementSystems
    • FreightStationAccountingCode
    • ForeignTradeZone
    • FreeAlongsideVessel-FreeOnBoardPoint
    • FreightStationGeographicLocation
    • InternationalAirTransportAssociationLocationQualifier
    • IssueLocation
    • MilitaryStandardMovementProcedures
    • Postal
    • InStore
    • IntermediateFOBPoint
    • PortOfEmbarkation
    • GovernmentFurnishedPropertyFOBPoint
    • LocalOffice
    • Mill
    • MetropolitanSamplingAreaRegionCode
    • MexicanPostalCode
    • CityOrStateFromPoints
    • Origin-AfterLoadingOnEquipment
    • OtherUnlistedFreeOnBoardPoint
    • OpenandPrepayStationListCode
    • OtherUnlistedAcceptancePoint
    • Origin-ShippingPoint
    • OnVessel-FreeOnBoardPoint
    • PortofArrival
    • PolicyMailingAddress
    • ParentsAddress
    • Primary
    • PriorBusiness
    • Plant
    • PrincipalServicingOffice
    • PoolPoint
    • 3DigitUSZIP
    • 4DigitUSZIP
    • 5DigitUSZIP
    • 3DigitCanadianPostalCode
    • 6DigitCanadianPostalCode
    • RateAreaCode
    • InRailCar
    • RegionalEducationServiceAgency
    • RegionCode
    • Region
    • Rural
    • StandardCarrierAlphaCode
    • RouteAdministrativeMessageTo
    • Secondary
    • Suburban
    • CityOrStateAndPointsWithin
    • SchoolDistrict
    • Summer
    • Storage
    • SchoolCampusCode
    • US-SPLC
    • StoreNumber
    • StateOrProvince
    • School
    • InStorageTank
    • SwitchingDistrict
    • Tank
    • TranscontinentalFreightBureau
    • TerminalCargoLocation
    • Terminal
    • Township
    • Temporary
    • RailTerritory
    • TaxingDistrict
    • UnitedNationsLocationCode
    • Urban
    • BusinessUnit
    • Vacation
    • Village
    • VesselStowageLocation
    • Wharf
    • Warehouse
    • Winter
    • ZoneCode
    • OverseasAndPointLocation
    • FinalPortOfDischarge - Final Port of Discharge (Operational)
    • CollectChargeLocation - Collect Charge Location (Operational)
    • CustomsOfficeOfManifestOrigin - Customs Office of Manifest Origin
    • CustomsOfficeOfManifestDestination - Customs Office of Manifest Destination
    • ActivityLocation - Activity Location (Operational)
    • OriginRailIntermodalTerminal - Origin Rail Intermodal Terminal
    • DestinationRailIntermodalTerminal - Destination Rail Intermodal Terminal
    • FirstOptionalPortOfDischarge - First Optional Port of Discharge
    • SecondOptionalPortOfDischarge - Second Optional Port of Discharge
    • PlaceOfAcceptance - Place of Acceptance (Operational)
    • ReconsolidationPoint - Reconsolidation Point (Operational)
    • De-ConsolidationPoint - De-Consolidation Point (Operational)
    • PortOfDischarge - Port of Discharge (Operational)
    • PlaceOfDelivery - Place of Delivery (Contractual)
    • FreightPayableAt - Freight Payable At (Contractual)
    • PortOfEntry - Port of Entry (Operational)
    • PortOfExit - Port of Exit (Operational)
    • InterimPoint - Interim Point (Operational)
    • BillOfLadingPortOfLoading - Bill of Lading Port of Loading (Contractual)
    • BillOfLadingPortOfDischarge - Bill of Lading Port of Discharge (Contractual)
    • PortOfLoading - Port of Loading (Operational)
    • Destination - Destination (Operational)
    • FinalDestination - Final Destination (Operational)
    • Origin - Origin (Operational)
    • DispatchingPool - Dispatching Pool (Operational)
    • BillOfLadingOriginOfGoods - Bill of Lading Origin of Goods (Contractual)
    • PlaceOfReceipt - Place of Receipt (Contractual)
    • ReturnPool - Return Pool (Operational)
    • TransshipmentPort - Transshipment Port (Contractual)
    • PrepaidChargeLocation - Prepaid Charge Location (Operational)
    • BillOfLadingReleaseOffice - Bill of Lading Release Office (Operational)
    • ThirdOptionalPortOfDischarge - Third Optional Port of Discharge
    • RelayPort - Relay Port (Operational)

[^]Code Fragment

    <xsd:simpleType name="LocationQualifierCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="JurisdictionToReceiveCreditForUniformCommercialCodeFiling">
        <xsd:enumeration value="TransmittingUtility">
        <xsd:enumeration value="Consignor">
        <xsd:enumeration value="CensusScheduleD">
        <xsd:enumeration value="UniformCommercialCodeFilingOffice">
        <xsd:enumeration value="CurrentAddress">
        <xsd:enumeration value="CensusBlockGroup">
        <xsd:enumeration value="HomeAddress">
        <xsd:enumeration value="HomeBaseAddress">
        <xsd:enumeration value="CensusTract">
        <xsd:enumeration value="CensusScheduleK">
        <xsd:enumeration value="LocalAddress">
        <xsd:enumeration value="MailingAddress">
        <xsd:enumeration value="OfficeAddress">
        <xsd:enumeration value="PermanentAddress">
        <xsd:enumeration value="Birthplace">
        <xsd:enumeration value="WorldwideGeographicLocationCode">
        <xsd:enumeration value="NearestCrossStreet">
        <xsd:enumeration value="SecondaryCrossStreet">
        <xsd:enumeration value="Range">
        <xsd:enumeration value="Section">
        <xsd:enumeration value="QuarterSection">
        <xsd:enumeration value="MarkerIdentifierLocation">
        <xsd:enumeration value="Route">
        <xsd:enumeration value="RouteSubdivision">
        <xsd:enumeration value="GridLocation">
        <xsd:enumeration value="Page">
        <xsd:enumeration value="MarkerType">
        <xsd:enumeration value="Latitude-LongitudeSource">
        <xsd:enumeration value="MapSource">
        <xsd:enumeration value="MapReference">
        <xsd:enumeration value="GridSource">
        <xsd:enumeration value="Aliquot">
        <xsd:enumeration value="Block">
        <xsd:enumeration value="District">
        <xsd:enumeration value="DrainholeNumber">
        <xsd:enumeration value="CityBlock">
        <xsd:enumeration value="FootageCallDirection">
        <xsd:enumeration value="LocationDirection">
        <xsd:enumeration value="OuterContinentalLeaseLocation">
        <xsd:enumeration value="Lot">
        <xsd:enumeration value="MapQuadrangle">
        <xsd:enumeration value="PrincipalMeridian">
        <xsd:enumeration value="OuterContinentalShelfArea">
        <xsd:enumeration value="OuterContinentalShelfBlock">
        <xsd:enumeration value="OfficialProtractionDiagram">
        <xsd:enumeration value="QuarterQuarterQuarterSection">
        <xsd:enumeration value="QuarterQuarterSection">
        <xsd:enumeration value="SectionType">
        <xsd:enumeration value="Abstract">
        <xsd:enumeration value="Labor">
        <xsd:enumeration value="League">
        <xsd:enumeration value="Survey">
        <xsd:enumeration value="Tier">
        <xsd:enumeration value="Tract">
        <xsd:enumeration value="UniversalTransverseMercatorQuadrant">
        <xsd:enumeration value="CourseDirection">
        <xsd:enumeration value="Area">
        <xsd:enumeration value="SendersLocationCode">
        <xsd:enumeration value="ReceiversLocationCode">
        <xsd:enumeration value="Office">
        <xsd:enumeration value="AnnualStatementsMailingAddress">
        <xsd:enumeration value="CityandState">
        <xsd:enumeration value="AllPoints">
        <xsd:enumeration value="ArmedServicesLocationDesignation">
        <xsd:enumeration value="Branch">
        <xsd:enumeration value="BusinessEconomicAreaRegionCode">
        <xsd:enumeration value="GovernmentBillofLadingOfficeCode">
        <xsd:enumeration value="PlaceOfBusiness">
        <xsd:enumeration value="GeopoliticalNameCode">
        <xsd:enumeration value="CountryOfOrigin">
        <xsd:enumeration value="ConfirmationMailingAddress">
        <xsd:enumeration value="Country">
        <xsd:enumeration value="CanadianCustomsOfficeCode">
        <xsd:enumeration value="CorrespondenceMailingAddress">
        <xsd:enumeration value="City">
        <xsd:enumeration value="NationalRateBasis">
        <xsd:enumeration value="CountyOrParishAndState">
        <xsd:enumeration value="InTankCar">
        <xsd:enumeration value="CanadianSPLC">
        <xsd:enumeration value="CountyOrParish">
        <xsd:enumeration value="DistributionCenterNumber">
        <xsd:enumeration value="Destination-Shipping">
        <xsd:enumeration value="DeliveryLocation">
        <xsd:enumeration value="DistrictOffice">
        <xsd:enumeration value="Department">
        <xsd:enumeration value="DistrictOfResidence">
        <xsd:enumeration value="DomicileTypeCode">
        <xsd:enumeration value="EventLocation">
        <xsd:enumeration value="EmployerLocation">
        <xsd:enumeration value="Factory">
        <xsd:enumeration value="FreightEqualizationPoint">
        <xsd:enumeration value="ForeignFreightForwarderLocation">
        <xsd:enumeration value="FederalInformationProcessingStandards55-NamedPopulatedPlaces">
        <xsd:enumeration value="U.S.CustomsFacilitiesInformationandResourceManagementSystems">
        <xsd:enumeration value="FreightStationAccountingCode">
        <xsd:enumeration value="ForeignTradeZone">
        <xsd:enumeration value="FreeAlongsideVessel-FreeOnBoardPoint">
        <xsd:enumeration value="FreightStationGeographicLocation">
        <xsd:enumeration value="InternationalAirTransportAssociationLocationQualifier">
        <xsd:enumeration value="IssueLocation">
        <xsd:enumeration value="MilitaryStandardMovementProcedures">
        <xsd:enumeration value="Postal">
        <xsd:enumeration value="InStore">
        <xsd:enumeration value="IntermediateFOBPoint">
        <xsd:enumeration value="PortOfEmbarkation">
        <xsd:enumeration value="GovernmentFurnishedPropertyFOBPoint">
        <xsd:enumeration value="LocalOffice">
        <xsd:enumeration value="Mill">
        <xsd:enumeration value="MetropolitanSamplingAreaRegionCode">
        <xsd:enumeration value="MexicanPostalCode">
        <xsd:enumeration value="CityOrStateFromPoints">
        <xsd:enumeration value="Origin-AfterLoadingOnEquipment">
        <xsd:enumeration value="OtherUnlistedFreeOnBoardPoint">
        <xsd:enumeration value="OpenandPrepayStationListCode">
        <xsd:enumeration value="OtherUnlistedAcceptancePoint">
        <xsd:enumeration value="Origin-ShippingPoint">
        <xsd:enumeration value="OnVessel-FreeOnBoardPoint">
        <xsd:enumeration value="PortofArrival">
        <xsd:enumeration value="PolicyMailingAddress">
        <xsd:enumeration value="ParentsAddress">
        <xsd:enumeration value="Primary">
        <xsd:enumeration value="PriorBusiness">
        <xsd:enumeration value="Plant">
        <xsd:enumeration value="PrincipalServicingOffice">
        <xsd:enumeration value="PoolPoint">
        <xsd:enumeration value="3DigitUSZIP">
        <xsd:enumeration value="4DigitUSZIP">
        <xsd:enumeration value="5DigitUSZIP">
        <xsd:enumeration value="3DigitCanadianPostalCode">
        <xsd:enumeration value="6DigitCanadianPostalCode">
        <xsd:enumeration value="RateAreaCode">
        <xsd:enumeration value="InRailCar">
        <xsd:enumeration value="RegionalEducationServiceAgency">
        <xsd:enumeration value="RegionCode">
        <xsd:enumeration value="Region">
        <xsd:enumeration value="Rural">
        <xsd:enumeration value="StandardCarrierAlphaCode">
        <xsd:enumeration value="RouteAdministrativeMessageTo">
        <xsd:enumeration value="Secondary">
        <xsd:enumeration value="Suburban">
        <xsd:enumeration value="CityOrStateAndPointsWithin">
        <xsd:enumeration value="SchoolDistrict">
        <xsd:enumeration value="Summer">
        <xsd:enumeration value="Storage">
        <xsd:enumeration value="SchoolCampusCode">
        <xsd:enumeration value="US-SPLC">
        <xsd:enumeration value="StoreNumber">
        <xsd:enumeration value="StateOrProvince">
        <xsd:enumeration value="School">
        <xsd:enumeration value="InStorageTank">
        <xsd:enumeration value="SwitchingDistrict">
        <xsd:enumeration value="Tank">
        <xsd:enumeration value="TranscontinentalFreightBureau">
        <xsd:enumeration value="TerminalCargoLocation">
        <xsd:enumeration value="Terminal">
        <xsd:enumeration value="Township">
        <xsd:enumeration value="Temporary">
        <xsd:enumeration value="RailTerritory">
        <xsd:enumeration value="TaxingDistrict">
        <xsd:enumeration value="UnitedNationsLocationCode">
        <xsd:enumeration value="Urban">
        <xsd:enumeration value="BusinessUnit">
        <xsd:enumeration value="Vacation">
        <xsd:enumeration value="Village">
        <xsd:enumeration value="VesselStowageLocation">
        <xsd:enumeration value="Wharf">
        <xsd:enumeration value="Warehouse">
        <xsd:enumeration value="Winter">
        <xsd:enumeration value="ZoneCode">
        <xsd:enumeration value="OverseasAndPointLocation">
        <xsd:enumeration value="FinalPortOfDischarge">
        <xsd:enumeration value="CollectChargeLocation">
        <xsd:enumeration value="CustomsOfficeOfManifestOrigin">
        <xsd:enumeration value="CustomsOfficeOfManifestDestination">
        <xsd:enumeration value="ActivityLocation">
        <xsd:enumeration value="OriginRailIntermodalTerminal">
        <xsd:enumeration value="DestinationRailIntermodalTerminal">
        <xsd:enumeration value="FirstOptionalPortOfDischarge">
        <xsd:enumeration value="SecondOptionalPortOfDischarge">
        <xsd:enumeration value="PlaceOfAcceptance">
        <xsd:enumeration value="ReconsolidationPoint">
        <xsd:enumeration value="De-ConsolidationPoint">
        <xsd:enumeration value="PortOfDischarge">
        <xsd:enumeration value="PlaceOfDelivery">
        <xsd:enumeration value="FreightPayableAt">
        <xsd:enumeration value="PortOfEntry">
        <xsd:enumeration value="PortOfExit">
        <xsd:enumeration value="InterimPoint">
        <xsd:enumeration value="BillOfLadingPortOfLoading">
        <xsd:enumeration value="BillOfLadingPortOfDischarge">
        <xsd:enumeration value="PortOfLoading">
        <xsd:enumeration value="Destination">
        <xsd:enumeration value="FinalDestination">
        <xsd:enumeration value="Origin">
        <xsd:enumeration value="DispatchingPool">
        <xsd:enumeration value="BillOfLadingOriginOfGoods">
        <xsd:enumeration value="PlaceOfReceipt">
        <xsd:enumeration value="ReturnPool">
        <xsd:enumeration value="TransshipmentPort">
        <xsd:enumeration value="PrepaidChargeLocation">
        <xsd:enumeration value="BillOfLadingReleaseOffice">
        <xsd:enumeration value="ThirdOptionalPortOfDischarge">
        <xsd:enumeration value="RelayPort">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: LocationType

LocationType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( LocationQualifierCoded[LocationQualifierCodeType]? , LocationQualifierCodedOther[xsd:string]? , ( LocationIdentifier[LocationIdentifierType] | ExternalAddressID[xsd:string] | NameAddress[NameAddressType] ) , GPSCoordinates[GPSCoordinatesType]? )

    Description: LocationType identifies a place by its function and either an identifier, an identification assigned to an address, or an address.

    Elements:

    • LocationQualifierCoded - provides the function of the location using a standard codelist.
    • LocationQualifierCodedOther - is used to provide a non-standard LocationQualifierCode. This element is mandatory if the value of LocationQualifierCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • LocationIdentifier - contains the location identifier and the agency responsible for issuing the identifier.
    • ExternalAddressID - contains the information to identify the address.
    • NameAddress - identifies the location as a specific name and/or address.
    • GPSCoordinates - identifies the location by specific co-ordinates.

[^]Code Fragment

    <xsd:complexType name="LocationType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="LocationQualifierCoded" type="LocationQualifierCodeType">
        <xsd:element minOccurs="0" name="LocationQualifierCodedOther" type="xsd:string">
        <xsd:choice>
            <xsd:element name="LocationIdentifier" type="LocationIdentifierType">
            <xsd:element name="ExternalAddressID" type="xsd:string">
            <xsd:element name="NameAddress" type="NameAddressType">
        </xsd:choice>
        <xsd:element minOccurs="0" name="GPSCoordinates" type="GPSCoordinatesType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ManufacturerPartNumberType

ManufacturerPartNumberType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: Extends: PartNumType

      Append:( ManufacturerID[IdentifierType]? , ManufacturerName[xsd:string]? )

    Description: ManufacturerPartNumberType is the identification of a product as assigned by the manufacturer of the product and identification of the manufacturer.

    Elements:

    • ManufacturerID - is the identification of the manufacturer as assigned by a standards agency.
    • ManufacturerName - is the name of the manufacturer that assigned the part number.

[^]Code Fragment

    <xsd:complexType name="ManufacturerPartNumberType">
    <xsd:complexContent>
        <xsd:extension base="PartNumType">
            <xsd:sequence>
                <xsd:element minOccurs="0" name="ManufacturerID" type="IdentifierType">
                <xsd:element minOccurs="0" name="ManufacturerName" type="xsd:string">
            </xsd:sequence>
        </xsd:extension>
    </xsd:complexContent>
</xsd:complexType>


complexType definition: MaximumValueType

MaximumValueType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: Extension of type: xsd:decimal

    Attribute:Name: SignificanceCoded, Type: SignificanceCodeType, Use: 'optional'
    Attribute:Name: SignificanceCodedOther, Type: xsd:string, Use: 'optional'

    Description: MaximumValueType specifies the maximum value and its inclusiveness. This is a string content model of a number datatype.

    Attributes:

    • SignificanceCoded - describes the inclusiveness of the maximum value using a standard codelist.
    • SignificanceCodedOther - is used to provide a non-standard

[^]Code Fragment

    <xsd:complexType name="MaximumValueType">
    <xsd:simpleContent>
        <xsd:extension base="xsd:decimal">
            <xsd:attribute name="SignificanceCoded" type="SignificanceCodeType" use="optional">
            <xsd:attribute name="SignificanceCodedOther" type="xsd:string" use="optional">
        </xsd:extension>
    </xsd:simpleContent>
</xsd:complexType>


complexType definition: MeasurementRangeType

MeasurementRangeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( MinimumValue[MinimumValueType] , MaximumValue[MaximumValueType] )

    Description: MeasurementRangeType defines a range which a measurement may fall in by a minimum and maximum value.

    Elements:

    • MinimumValue - specifies the minimum value of the range.
    • MaximumValue - specifies the maximum value of the range.

[^]Code Fragment

    <xsd:complexType name="MeasurementRangeType">
    <xsd:sequence>
        <xsd:element name="MinimumValue" type="MinimumValueType">
        <xsd:element name="MaximumValue" type="MaximumValueType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: MeasurementType

MeasurementType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ( MeasurementValue[MeasurementValueType] | MeasurementRange[MeasurementRangeType] ) , UnitOfMeasurement[UnitOfMeasurementType] )

    Description: MeasurementType is the quantitative value expressed as either a value or a range and unit of measure.

    Elements:

    • MeasurementValue - contains the value of the measurement.
    • MeasurementRange - defines the minimum and maximum value of a measurement.
    • UnitOfMeasurement - contains the unit of measure for the measurement.

[^]Code Fragment

    <xsd:complexType name="MeasurementType">
    <xsd:sequence>
        <xsd:choice>
            <xsd:element name="MeasurementValue" type="MeasurementValueType">
            <xsd:element name="MeasurementRange" type="MeasurementRangeType">
        </xsd:choice>
        <xsd:element name="UnitOfMeasurement" type="UnitOfMeasurementType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: MeasurementValueType

MeasurementValueType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: Extension of type: xsd:decimal

    Attribute:Name: SignificanceCoded, Type: SignificanceCodeType, Use: 'optional'
    Attribute:Name: SignificanceCodedOther, Type: xsd:string, Use: 'optional'
    Attribute:Name: ConditionsCoded, Type: ConditionsCodeType, Use: 'optional'
    Attribute:Name: ConditionsCodedOther, Type: xsd:string, Use: 'optional'

    Description: MeasurementValueType contains the value of the measurement.

    Attributes:

    • SignificanceCoded - describes the significance of the a quantity using a standard codelist.
    • SignificanceCodedOther - is used to provide a non-standard
    • ConditionsCoded - describes the conditions that apply to the quantity.
    • ConditionsCodedOther - is used to provide a non-standard

[^]Code Fragment

    <xsd:complexType name="MeasurementValueType">
    <xsd:simpleContent>
        <xsd:extension base="xsd:decimal">
            <xsd:attribute name="SignificanceCoded" type="SignificanceCodeType" use="optional">
            <xsd:attribute name="SignificanceCodedOther" type="xsd:string" use="optional">
            <xsd:attribute name="ConditionsCoded" type="ConditionsCodeType" use="optional">
            <xsd:attribute name="ConditionsCodedOther" type="xsd:string" use="optional">
        </xsd:extension>
    </xsd:simpleContent>
</xsd:complexType>


simpleType definition: MethodOfHandlingCodeType

MethodOfHandlingCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the method of handling for an allowance or charge. This code list is derived from X12 331 (Allowance or charge method of handling code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • BillBack
    • OffInvoice
    • VendorCheckToCustomer
    • CreditCustomerAccount
    • ChargeToBePaidByVendor
    • ChargeToBePaidByCustomer
    • Optional
    • OffGrossQuantityInvoiced
    • AllowanceToBeIssuedByVendor
    • AllowanceToBeIssuedByReseller
    • ChargeDeniedByVendor
    • CancelAllowance
    • ProvideAmount
    • InformationOnly
    • Non-PayableTax
    • AccrualFund
    • FlatFund
    • CashInAdvance
    • CalculateAndAddtoInvoice
    • Collect
    • Prepaid

[^]Code Fragment

    <xsd:simpleType name="MethodOfHandlingCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="BillBack">
        <xsd:enumeration value="OffInvoice">
        <xsd:enumeration value="VendorCheckToCustomer">
        <xsd:enumeration value="CreditCustomerAccount">
        <xsd:enumeration value="ChargeToBePaidByVendor">
        <xsd:enumeration value="ChargeToBePaidByCustomer">
        <xsd:enumeration value="Optional">
        <xsd:enumeration value="OffGrossQuantityInvoiced">
        <xsd:enumeration value="AllowanceToBeIssuedByVendor">
        <xsd:enumeration value="AllowanceToBeIssuedByReseller">
        <xsd:enumeration value="ChargeDeniedByVendor">
        <xsd:enumeration value="CancelAllowance">
        <xsd:enumeration value="ProvideAmount">
        <xsd:enumeration value="InformationOnly">
        <xsd:enumeration value="Non-PayableTax">
        <xsd:enumeration value="AccrualFund">
        <xsd:enumeration value="FlatFund">
        <xsd:enumeration value="CashInAdvance">
        <xsd:enumeration value="CalculateAndAddtoInvoice">
        <xsd:enumeration value="Collect">
        <xsd:enumeration value="Prepaid">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: MinimumValueType

MinimumValueType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: Extension of type: xsd:decimal

    Attribute:Name: SignificanceCoded, Type: SignificanceCodeType, Use: 'optional'
    Attribute:Name: SignificanceCodedOther, Type: xsd:string, Use: 'optional'

    Description: MinimumValueType specifies the minimum value and its inclusiveness. This is a string content model of a number datatype.

    Attributes:

    • SignificanceCoded - describes the inclusiveness of the minimum value using a standard codelist.
    • SignificanceCodedOther - is used to provide a non-standard

[^]Code Fragment

    <xsd:complexType name="MinimumValueType">
    <xsd:simpleContent>
        <xsd:extension base="xsd:decimal">
            <xsd:attribute name="SignificanceCoded" type="SignificanceCodeType" use="optional">
            <xsd:attribute name="SignificanceCodedOther" type="xsd:string" use="optional">
        </xsd:extension>
    </xsd:simpleContent>
</xsd:complexType>


complexType definition: MonetaryLimitType

MonetaryLimitType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( MonetaryLimitValue[Decimal21_6Type] , Currency[CurrencyType]? )

    Attribute:Name: SignificanceCoded, Type: SignificanceCodeType, Use: 'optional'
    Attribute:Name: SignificanceCodedOther, Type: xsd:string, Use: 'optional'

    Description: MonetaryLimitType is used to specify either a lower or upper bound, beyond which an allowance or charge will apply.

    Elements:

    • MonetaryLimitValue - is a number representing the monetary limit.
    • Currency - specifies the currency that MonetaryLimitValue is expressed.
    Attributes:
    • SignificanceCoded - is used to specify whether the
    • SignificanceCodedOther - is used to provide a non-standard

[^]Code Fragment

    <xsd:complexType name="MonetaryLimitType">
    <xsd:sequence>
        <xsd:element name="MonetaryLimitValue" type="Decimal21_6Type">
        <xsd:element minOccurs="0" name="Currency" type="CurrencyType">
    </xsd:sequence>
    <xsd:attribute name="SignificanceCoded" type="SignificanceCodeType" use="optional">
    <xsd:attribute name="SignificanceCodedOther" type="xsd:string" use="optional">
</xsd:complexType>


complexType definition: MonetaryRangeType

MonetaryRangeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( MinimumMonetaryValue[Decimal21_6Type] , MaximumMonetaryValue[Decimal21_6Type] , Currency[CurrencyType]? )

    Description: MonetaryRangeType identifies a range of monetary values.

    Elements:

    • MinimumMonetaryValue - specifies the minimum monetary value in the range.
    • MaximumMonetaryValue - specifies the maximum monetary value in the range.
    • Currency - is a container for the currency code.

[^]Code Fragment

    <xsd:complexType name="MonetaryRangeType">
    <xsd:sequence>
        <xsd:element name="MinimumMonetaryValue" type="Decimal21_6Type">
        <xsd:element name="MaximumMonetaryValue" type="Decimal21_6Type">
        <xsd:element minOccurs="0" name="Currency" type="CurrencyType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: MonetaryValueType

MonetaryValueType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( MonetaryAmount[Decimal21_6Type] , Currency[CurrencyType]? , RateOfExchangeDetail[RateOfExchangeDetailType]? )

    Description: MonetaryValueType is used to specify an amount of money and the currency.

    Elements:

    • MonetaryAmount - contains the value of the monetary amount.
    • Currency - specifies the currency that the MonetaryValue is expressed in.
    • RateOfExchangeDetail - can be used if the exchange rate to another currency needs to be set for the monetary value expressed.

[^]Code Fragment

    <xsd:complexType name="MonetaryValueType">
    <xsd:sequence>
        <xsd:element name="MonetaryAmount" type="Decimal21_6Type">
        <xsd:element minOccurs="0" name="Currency" type="CurrencyType">
        <xsd:element minOccurs="0" name="RateOfExchangeDetail" type="RateOfExchangeDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: NameAddressType

NameAddressType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ExternalAddressID[xsd:string]? , Name1[xsd:string] , Name2[xsd:string]? , Name3[xsd:string]? , Identifier[IdentifierType]? , POBox[POBoxType]? , Street[xsd:string]? , HouseNumber[xsd:string]? , StreetSupplement1[xsd:string]? , StreetSupplement2[xsd:string]? , Building[xsd:string]? , Floor[xsd:string]? , RoomNumber[xsd:string]? , InhouseMail[xsd:string]? , Department[xsd:string]? , PostalCode[xsd:string]? , City[xsd:string]? , County[xsd:string]? , Region[RegionType]? , District[xsd:string]? , Country[CountryType]? , Timezone[TimezoneType]? )

    Description: NameAddressType contains the name and the address information for an entity.

    Elements:

    • ExternalAddressID - contains a GUID that is used for referencing the address when specifying specific user information (unique within partner organization).
    • Name1 - contains the name of an entity.
    • Name2 - contains additional name information.
    • Name3 - contains further additional name information.
    • Identifier - contains a specific identifier for the name.
    • POBox - contains a post office box number.
    • Street - contains the name of the street.
    • HouseNumber - contains the house number.
    • StreetSupplement1 - contains any additional information to identify the street.
    • StreetSupplement2 - contains any further additional information to identify the street.
    • Building - contains the name of the building.
    • Floor - contains the number of the floor.
    • RoomNumber - contains the room identifier.
    • InhouseMail - contains the inhouse mail identifier.
    • Department - contains the department number or name.
    • PostalCode - contains the identifier for one or more properties according to the postal service of that country (Zip-Code in US)
    • City - contains the name of the city.
    • County - contains the name of the county.
    • Region - contains the name of the region within a country specific to this address. Used to hold the state in US addresses.
    • District - contains the name of the district.
    • Country - identifies the country.
    • Timezone - identifies the time zone that the location operates to.

[^]Code Fragment

    <xsd:complexType name="NameAddressType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ExternalAddressID" type="xsd:string">
        <xsd:element name="Name1" type="xsd:string">
        <xsd:element minOccurs="0" name="Name2" type="xsd:string">
        <xsd:element minOccurs="0" name="Name3" type="xsd:string">
        <xsd:element minOccurs="0" name="Identifier" type="IdentifierType">
        <xsd:element minOccurs="0" name="POBox" type="POBoxType">
        <xsd:element minOccurs="0" name="Street" type="xsd:string">
        <xsd:element minOccurs="0" name="HouseNumber" type="xsd:string">
        <xsd:element minOccurs="0" name="StreetSupplement1" type="xsd:string">
        <xsd:element minOccurs="0" name="StreetSupplement2" type="xsd:string">
        <xsd:element minOccurs="0" name="Building" type="xsd:string">
        <xsd:element minOccurs="0" name="Floor" type="xsd:string">
        <xsd:element minOccurs="0" name="RoomNumber" type="xsd:string">
        <xsd:element minOccurs="0" name="InhouseMail" type="xsd:string">
        <xsd:element minOccurs="0" name="Department" type="xsd:string">
        <xsd:element minOccurs="0" name="PostalCode" type="xsd:string">
        <xsd:element minOccurs="0" name="City" type="xsd:string">
        <xsd:element minOccurs="0" name="County" type="xsd:string">
        <xsd:element minOccurs="0" name="Region" type="RegionType">
        <xsd:element minOccurs="0" name="District" type="xsd:string">
        <xsd:element minOccurs="0" name="Country" type="CountryType">
        <xsd:element minOccurs="0" name="Timezone" type="TimezoneType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: NameValuePairType

NameValuePairType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( Name[xsd:string] , Value[xsd:string] , Datatype[xsd:string]? )

    Description: NameValuePairType contains a generic name and value.

    Elements:

    • Name - contains the generic name.
    • Value - contains the generic value.
    • Datatype - is an optional descriptive attribute used to type cast the value in an implementation specific fashion.

[^]Code Fragment

    <xsd:complexType name="NameValuePairType">
    <xsd:sequence>
        <xsd:element name="Name" type="xsd:string">
        <xsd:element name="Value" type="xsd:string">
        <xsd:element minOccurs="0" name="Datatype" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: NameValueSetType

NameValueSetType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( SetName[xsd:string] , SetID[xsd:string]? , ListOfNameValuePair[ListOfNameValuePairType] )

    Description: NameValueSetType is a set of collections of name value pairs.

    Elements:

    • SetName - contains the generic name for the set.
    • SetID - is the optional identification of the set.
    • ListOfNameValuePair - is a collection of name value pairs that belong to the set.

[^]Code Fragment

    <xsd:complexType name="NameValueSetType">
    <xsd:sequence>
        <xsd:element name="SetName" type="xsd:string">
        <xsd:element minOccurs="0" name="SetID" type="xsd:string">
        <xsd:element name="ListOfNameValuePair" type="ListOfNameValuePairType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: OperationalTypeCodeType

OperationalTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other
    • Documents
    • LowValueNon-DutiableConsignments
    • LowValueDutiableConsignments
    • HighValueConsignments
    • OtherNon-Containerized
    • Vehicles
    • Roll-OnRoll-Off
    • Palletized
    • Containerized
    • Breakbulk
    • HazardousCargo
    • GeneralCargo
    • LiquidCargo
    • TemperatureControlledCargo
    • EnvironmentalPollutantCargo
    • Not-HazardousCargo
    • Diplomatic
    • Military
    • Obnoxious
    • OutOfGauge
    • HouseholdGoodsAndPersonalEffects
    • FrozenCargo

[^]Code Fragment

    <xsd:simpleType name="OperationalTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Documents">
        <xsd:enumeration value="LowValueNon-DutiableConsignments">
        <xsd:enumeration value="LowValueDutiableConsignments">
        <xsd:enumeration value="HighValueConsignments">
        <xsd:enumeration value="OtherNon-Containerized">
        <xsd:enumeration value="Vehicles">
        <xsd:enumeration value="Roll-OnRoll-Off">
        <xsd:enumeration value="Palletized">
        <xsd:enumeration value="Containerized">
        <xsd:enumeration value="Breakbulk">
        <xsd:enumeration value="HazardousCargo">
        <xsd:enumeration value="GeneralCargo">
        <xsd:enumeration value="LiquidCargo">
        <xsd:enumeration value="TemperatureControlledCargo">
        <xsd:enumeration value="EnvironmentalPollutantCargo">
        <xsd:enumeration value="Not-HazardousCargo">
        <xsd:enumeration value="Diplomatic">
        <xsd:enumeration value="Military">
        <xsd:enumeration value="Obnoxious">
        <xsd:enumeration value="OutOfGauge">
        <xsd:enumeration value="HouseholdGoodsAndPersonalEffects">
        <xsd:enumeration value="FrozenCargo">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: OrderTypeCodeType

OrderTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • AcknowledgementMessage - Message providing acknowledgement information at the business application level concerning the processing of a message.
    • AcknowledgementOfOrder - Document/message acknowledging an undertaking to fulfil an order and confirming conditions or acceptance of conditions.
    • AClaimForPartsAndOrLabourCharges - A claim for parts and/or labor charges incurred.
    • AdviceOfAnAmendmentOfADocumentaryCredit - Advice of an amendment of a documentary credit.
    • AdviceOfCollection - Document that is joined to the transport or sent by separate means giving to the departure rail organization the proof that the cash-on delivery amount has been encashed by the arrival rail organization before reimbursement of the consignor.
    • AdviceOfDistributionOfDocuments - Document/message in which the party responsible for the issue of a set of trade documents specifies the various recipients of originals and copies of these documents with an indication of the number of copies distributed to each of them.
    • AdvisingItemsToBeBookedToAFinancialAccount - A document and/or message advising of items which have to be booked to a financial account.
    • Agreement - Agreement
    • AgreementToPay - Document/message in which the debtor expresses the intention to pay.
    • AirWaybill - Document/message made out by or on behalf of the shipper which evidences the contract between the shipper and carrier(s) for carriage of goods over routes of the carrier(s) and which is identified by the airline prefix issuing the document plus a serial (IATA).
    • AOGCritical - AOG (Aircraft on Ground) Critical
    • AOGService - AOG (Aircraft on Ground) Service
    • ApplicationAcknowledgementAndErrorReport - A message used by an application to acknowledge reception of a message and/or to report any errors.
    • ApplicationErrorAndAcknowledgement - A message to inform a message issuer that a previously sent message has been received by the addressee's application or that a previously sent message has been rejected by the addressee's application.
    • ApplicationErrorMessage - Message indicating that a message was rejected due to errors encountered at the application level.
    • ApplicationForBankersDraft - Application by a customer to his bank to issue a banker's draft stating the amount and currency of the draft the name of the payee and the place and country of payment.
    • ApplicationForBankersGuarantee - Document/message whereby a customer requests his bank to issue a guarantee in favor of a nominated party in another country stating the amount and currency and the specific conditions of the guarantee.
    • ApplicationForDesignationOfBerthingPlaces - Document to apply for designation of berthing places.
    • ApplicationForDocumentaryCredit - Message with application for opening of a documentary credit.
    • ApplicationForExchangeAllocation - Document/message whereby an importer/buyer requests the competent body to allocate an amount of foreign exchange to be transferred to an exporter/seller in payment for goods.
    • ApplicationForGoodsControlCertificate - Document/message submitted to a competent body by party requesting a Goods control certificate to be issued in accordance with national or international standards or conforming to legislation in the importing country or as specified in the contract.
    • ApplicationForInspectionCertificate - Document/message submitted to a competent body by a party requesting an Inspection certificate to be issued in accordance with national or international standards or conforming to legislation in the country in which it is required or as specified in the contract.
    • ApplicationForPhytosanitaryCertificate - Document/message submitted to a competent body by party requesting a Phytosanitary certificate to be issued.
    • ApplicationForShiftingFromTheDesignatedPlaceInPort - Document to apply for shifting from the designated place in port.
    • ApplicationForUsageOfBerthOrMooringFacilities - Document to apply for usage of berth or mooring facilities.
    • ApplicationForVesselsEnteringIntoPortAreaInNight-Time - Document to apply for vessel's entering into port area in night-time.
    • ApprovedUnpricedBillOfQuantity - Document/message providing an approved detailed quantity based specification (bill of quantity) in an unpriced form.
    • ArrivalInformation - Message reporting the arrival details of goods or cargo.
    • ArrivalNoticeGoods - Notification from the carrier to the consignee in writing by telephone or by any other means (express letter message telegram etc.) informing him that a consignment addressed to him is being or will shortly be held at his disposal at a specified point in the place of destination.
    • AssortmentAgainstBlanket - Assortment Against Blanket
    • AtaCarnet - International Customs document (Admission Temporaire / Temporary Admission) which issued under the terms of the ATA Convention (1961) incorporates an internationally valid guarantee and may be used in lieu of national Customs documents and as security for import duties and taxes to cover the temporary admission of goods and where appropriate the transit of goods. If accepted for controlling the temporary export and reimport of goods international guarantee does not apply (CCC).
    • AuthorizationToPlanAndShipOrders - Document or message that authorizes receiver to plan and ship orders based on information in this message.
    • AuthorizationToPlanAndSuggestOrders - Document or message that authorizes receiver to plan orders based on information in this message and send these orders as suggestions to the sender.
    • AuthorityToProceed - Authority to Proceed
    • Bailment - Bailment
    • BailmentContract - A document authorizing the bailing of goods.
    • BalanceConfirmation - Confirmation of a balance at an entry date.
    • BankersDraft - Draft drawn in favor of a third party either by one bank on another bank or by a branch of a bank on its head office (or vice versa) or upon another branch of the same bank. In either case the draft should comply with the specifications laid down for cheques in the country in which it is to be payable.
    • BankersGuarantee - Document/message in which a bank undertakes to pay out a limited amount of money to a designated party on conditions stated therein (other than those laid down in the Uniform Customs Practice).
    • BankingStatus - A banking status document and/or message.
    • BankToBankFundsTransfer - The message is a bank to bank funds transfer.
    • BasicAgreement - A document indicating an agreement containing basic terms and conditions applicable to future contracts between two parties.
    • BasicOrderingAgreement - Basic Ordering Agreement
    • Bidding - Bidding
    • BillandHold - Bill and Hold
    • BillOfExchange - Document/message issued and signed in conformity with the applicable legislation which contains an unconditional order whereby the drawer directs the drawee to pay a definite sum of money to the payee or to his order on demand or at a definite time against the surrender of the document itself.
    • BillOfLading - Negotiable document/message which evidences a contract of carriage by sea and the taking over or loading of goods by carrier and by which carrier undertakes to deliver goods against surrender of the document. A provision in the document that goods are to be delivered to the order of a named person or to order or to bearer constitutes such an undertaking.
    • BillOfLadingCopy - A copy of the bill of lading issued by a transport company.
    • BillOfLadingOriginal - The original of the bill of lading issued by a transport company. When issued by the maritime industry it could signify ownership of the cargo.
    • BlanketOrder - Usage of document/message for general order purposes with later split into quantities and delivery dates and maybe delivery locations.
    • BlanketOrderEstimatedQuantities - Blanket Order/Estimated Quantities (Not firm Commitment)
    • BlanketPurchaseAgreement - Blanket Purchase Agreement
    • BookingConfirmation - Document/message issued by a carrier to confirm that space has been reserved for a consignment in means of transport.
    • BookingRequest - Document/message issued by a supplier to a carrier requesting space to be reserved for a specified consignment indicating desirable conveyance dispatch time etc.
    • Bordereau - Document/message used in road transport listing the cargo carried on a road vehicle often referring to appended copies of Road consignment note.
    • BudgetaryQuote - Budgetary Quote
    • BuyAmericaCertificateOfCompliance - A document certifying that more than 50 percent of the cost of an item is attributed to US origin.
    • Buying - Buying
    • CallingForwardNotice - Instructions for release or delivery of goods.
    • CallOffDelivery - Document/message to provide split quantities and delivery dates referring to a previous delivery instruction.
    • CallOffOrder - Document/message to provide split quantities and delivery dates referring to a previous blanket order.
    • CampaignPriceSalesCatalogue - A price/sales catalogue containing special prices which are valid only for a specified period or under specified conditions.
    • CargoAcceptanceOrder - Order to accept cargo to be delivered by a carrier.
    • CargoAnalysisVoyageReport - An analysis of the cargo for a voyage.
    • CargoDeclarationArrival - Generic term sometimes referred to as Freight declaration applied to the documents providing the particulars required by the Customs concerning the cargo (freight) carried by commercial means of transport (CCC).
    • CargoDeclarationDeparture - Generic term sometimes referred to as Freight declaration applied to the documents providing the particulars required by the Customs concerning the cargo (freight) carried by commercial means of transport (CCC).
    • CargoManifest - Listing of goods comprising the cargo carried in a means of transport or in a transport-unit. The cargo manifest gives the commercial particulars of the goods such as transport document numbers consignors consignees shipping marks number and kind of packages and descriptions and quantities of the goods.
    • CargoMovementEventLog - A document detailing times and dates of events pertaining to a cargo movement.
    • CargoMovementVoyageSummary - A consolidated voyage summary which contains the information in a certificate of analysis a voyage analysis and a cargo movement time log for a voyage.
    • CargoReleaseNotification - Message/document sent by the cargo handler indicating that the cargo has moved from a Customs controlled premise.
    • CargoStatus - Message identifying the status of cargo.
    • CargoVesselDischargeOrder - Order that the containers or cargo specified are to be discharged from a vessel.
    • CargoVesselLoadingOrder - Order that specified cargo containers or groups of containers are to be loaded in or on a vessel.
    • CartageOrderLocalTransport - Document/message giving instructions regarding local transport of goods e.g. from the premises of an enterprise to those of a carrier undertaking further transport.
    • CashPoolFinancialStatement - A financial statement for a cash pool.
    • CasingSanitaryCertificate - Document or message issued by the competent authority in the exporting country evidencing that casing products comply with the requirements set by the importing country.
    • CatalogOrder - Catalog Order
    • Certificate - Document by means of which the documentary credit applicant specifies the conditions for the certificate and by whom the certificate is to
    • CertificateOfAnalysis - Certificate providing the values of an analysis.
    • CertificateOfConformity - Certificate certifying the conformity to predefined definitions.
    • CertificateOfOrigin - Document/message identifying goods in which the authority or body authorized to issue it certifies expressly that the goods to which the certificate relates originate in a specific country. The word "country" may include a group of countries a region or a part of a country. This certificate may also include a declaration by the manufacturer producer supplier exporter or other competent person.
    • ApplicationForCertificateOfOrigin - Document/message submitted to a competent body by an interested party requesting a Certificate of origin to be issued in accordance with relevant criteria and on the basis of evidence of the origin of the goods.
    • CertificateOfOriginFormGsp - Specific form of certificate of origin for goods qualifying for preferential treatment under the generalized system of preferences (includes a combined declaration of origin and certificate Form A).
    • CertificateOfQuality - Certificate certifying the quality of goods services etc.
    • CertificateOfQuantity - Certificate certifying the quantity of goods services etc.
    • CertificateOfRegistry - Official certificate stating the vessel's registry.
    • CertificateOfSealingOfExportMeatLockers - Document / message issued by the authority in the exporting country evidencing the sealing of export meat lockers.
    • CertifiedCostAndPriceData - A document indicating cost and price data whose accuracy has been certified.
    • CertifiedInspectionAndTestResults - A certification as to the accuracy of inspection and test results.
    • ChangeToContract - Change to Contract
    • ChangeToPurchaseOrder - Change to Purchase Order
    • ChangeToRelease - Change to Release
    • Chargeback - Document/message issued by a factor to a seller or to another factor to indicate that the rest of the amounts of one or more invoices uncollectable from buyers are charged back to clear the invoice(s) off the ledger.
    • ChargesNote - Document used by the rail organization to indicate freight charges or additional charges in each case where the departure station is not able to calculate the charges for the total voyage (e.g. tariff not yet updated part of voyage not covered by the tariff). This document must be considered as joined to the transport.
    • CivilLiabilityForOilCertificate - Document declaring a ship owner's liability for oil propelling or carried on a vessel.
    • CloseOut - Close Out
    • ClosingStatementOfAnAccount - Last statement of a period containing the interest calculation and the final balance of the last entry date.
    • CodeChangeRequest - Request a change to an existing code.
    • Co-InsuranceCedingBordereau - The document or message contains a bordereau describing co-insurance ceding information.
    • CollateralAccount - Document message issued by a factor to indicate the movements of invoices credit notes and payments of a seller's account.
    • CollectionOrder - Document/message whereby a bank is instructed (or requested) to handle financial and/or commercial documents in order to obtain acceptance and/or payment or to deliver documents on such other terms and conditions as may be specified.
    • CollectionPaymentAdvice - Document/message whereby a bank advises that a collection has been paid giving details and methods of funds disposal.
    • CombinedCertificateOfValueAndOrigin - Document identifying goods in which the issuing authority expressly certifies that the goods originate in a specific country or part of o
    • CombinedTransportBillOfLadingMultimodalBillOfLading - Document which evidences a multimodal transport contract the taking in charge of the goods by the multimodal transport operator and an undertaking by him to deliver the goods in accordance with the terms of the contract.
    • CombinedTransportDocumentGeneric - Negotiable or non-negotiable document evidencing a contract for the performance and/or procurement of performance of combined transport of goods and bearing on its face either the heading "Negotiable combined transport document issued subject to Uniform Rules for a Combined Transport Document (ICC Brochure No. 298)" or the heading "Non-negotiable Combined Transport Document issued subject to Uniform Rules for a Combined Transport Document (ICC Brochure No. 298)".
    • CommercialAccountSummaryResponse - A document providing a response to a previously sent commercial account summary message.
    • CommercialDispute - Document/message issued by a party (usually the buyer) to indicate that one or more invoices or one or more credit notes are disputed for payment.
    • CommercialInvoice - Document/message claiming payment for goods or services supplied under conditions agreed between seller and buyer.
    • CommercialInvoiceWhichIncludesAPackingList - Commercial transaction (invoice) will include a packing list.
    • CommissionNote - Document/message in which a seller specifies the amount of commission the percentage of the invoice amount or some other basis for the calculation of the commission to which a sales agent is entitled.
    • CompositeDataElementChangeRequest - Request a change to an existing composite data element.
    • CompositeDataElementRequest - Requesting a new composite data element.
    • Confirmation - Confirmation
    • ConsignmentInvoice - Commercial invoice that covers a transaction other than one involving a sale.
    • ConsignmentOrder - Order to deliver goods into stock with agreement on payment when goods are sold out of this stock.
    • ConsignmentStatusReport - Message covers information about the consignment status.
    • ConsignmentUnpackReport - A document code to indicate that the message being transmitted is a consignment unpack report only.
    • ConsolidatedCreditNoteGoodsAndServices - Credit note for goods and services that covers multiple transactions involving more than one invoice.
    • ConsolidatedInvoice - Commercial invoice that covers multiple transactions involving more than one vendor.
    • ConsularInvoice - Document/message to be prepared by an exporter in his country and presented to a diplomatic representation of the importing country for endorsement and subsequently to be presented by the importer in connection with the import of the goods described therein.
    • ContainerDischargeList - Message/document itemizing containers to be discharged from vessel.
    • ContainerList - Document or message issued by party identifying the containers for which they are responsible.
    • ContainerManifestUnitPackingList - Document/message specifying the contents of particular freight containers or other transport units prepared by the party responsible for their loading into the container or unit.
    • ContainerOffHireNotice - Notice to return leased containers.
    • ContainerStrippingOrder - Order to unload goods from a container.
    • ContainerStuffingOrder - Order to stuff specified goods or consignments in a container.
    • Contract - Document/message evidencing an agreement between the seller and the buyer for the supply of goods or services; its effects are equivalent to those of an order followed by an acknowledgement of order.
    • ContractAwardNotification - Contract Award Notification
    • ContractBillOfQuantities - Document/message providing a formal specification identifying quantities and prices that are the basis of a contract for a construction project. BOQ means: Bill of quantity.
    • ContractFundsStatusReport - A report to provide the status of funds applicable to the contract.
    • ContractSecurityClassificationSpecification - A document that indicates the specification contains the security and classification requirements for a contract.
    • ControlDocumentT5 - Control document (export declaration) used particularly in case of re-sending without use with only VAT collection refusal unconformity with contract etc.
    • ConveyanceDeclarationArrival - Declaration to the public authority upon arrival of the conveyance.
    • ConveyanceDeclarationCombined - Combined declaration of arrival and departure to the public authority.
    • ConveyanceDeclarationDeparture - Declaration to the public authority upon departure of the conveyance.
    • CorporateSuperannuationContributionsAdvice - Document/message providing contributions advice used for corporate superannuation schemes.
    • CorporateSuperannuationMemberMaintenanceMessage - Member maintenance message used for corporate superannuation schemes.
    • CorrectedInvoice - Commercial invoice that includes revised information differing from an earlier submission of the same invoice.
    • CostDataSummary - A document indicating a summary of cost data.
    • CostPerformanceReport - A report to convey cost performance data for a project or contract.
    • CostPerformanceReportFormat1 - A report identifying the cost performance on a contract including the current month's values at specified levels of the work breakdown structure (format 1 - work breakdown structure).
    • CostPerformanceReportFormat2 - A report identifying the cost performance on a contract at specified levels of the work breakdown structure (format 2 - organizational categories).
    • CostPerformanceReportFormat3 - A report identifying the cost performance on a contract that summarizes changes to a contract over a given reporting period with beginning and ending values (format 3 - baseline).
    • CostPerformanceReportFormat4 - A report identifying the cost performance on a contract including forecasts of labor requirements for the remaining portion of the contract (format 4 - staffing).
    • CostPerformanceReportFormat5 - A report identifying the cost performance on a contract that summarizes cost or schedule variances (format 5 - explanations and problem analysis).
    • CostScheduleStatusReport - A report providing the status of the cost and schedule applicable to a contract.
    • CoverNote - Document/message issued by an insurer (insurance broker agent etc.) to notify the insured that his insurance have been carried out.
    • CreditAdvice - Document/message sent by an account servicing institution to one of its account owners to inform the account owner of an entry which has been or will be credited to its account for a specified amount on the date indicated.
    • CreditCover - Document/message issued either by a factor to give a credit cover on a buyer or by a seller to request a factor's credit cover.
    • CreditNote - Document/message for providing credit information to the relevant party.
    • CreditNoteForPriceVariation - A credit note which is issued against a price variation invoice.
    • CreditNoteRelatedToFinancialAdjustments - Document message for providing credit information related to financial adjustments to the relevant party e.g. bonuses.
    • CreditNoteRelatedToGoodsOrServices - Document message used to provide credit information related to a transaction for goods or services to the relevant party.
    • CrewListDeclaration - Declaration regarding crew members aboard the conveyance.
    • CrewsEffectsDeclaration - Declaration to Customs regarding the personal effects of crew members aboard the conveyance; equivalent to IMO FAL 4.
    • CrossDockingDespatchAdvice - Document by means of which the supplier or consignor informs the buyer consignee or the distribution center about the dispatch of goods for cross docking.
    • CrossDockingOrder - An order requesting the supply of products which will be de-consolidated in the distribution center and re- consolidated according to final delivery location.
    • CrossDockingServicesOrder - A document or message to order cross docking services.
    • CurrentAccount - Document/message issued by a factor to indicate the money movements of a seller's or another factor's account with him.
    • CustomerPaymentOrder - The message contains customer payment order(s).
    • CustomsClearanceNotice - Notification of customs clearance of cargo or items of transport equipment.
    • CustomsCrewAndConveyance - Document/message contains information regarding the crew list and conveyance.
    • CustomsDeclarationPostParcels - Document/message which according to Article 106 of the "Agreement concerning Postal Parcels" under the UPU Convention must accompany post parcels and in which the contents of such parcels are specified.
    • CustomsDeclarationForCargoExamination - Declaration provided to customs for cargo examination.
    • CustomsDeclarationForCargoExaminationAlternate - Alternate declaration provided to customs for cargo examination.
    • CustomsDeclarationWithCommercialAndItemDetail - CUSDEC transmission that includes data from both the commercial detail and item detail sections of the message.
    • CustomsDeclarationWithoutCommercialDetail - CUSDEC transmission that does not include data from the commercial detail section of the message.
    • CustomsDeclarationWithoutItemDetail - CUSDEC transmission that does not include data from the item detail section of the message.
    • CustomsDeliveryNote - Document/message whereby a Customs authority releases goods under its control to be placed at the disposal of the party concerned. Synonym: Customs release note.
    • CustomsDocumentsExpirationNotice - Notice specifying expiration of Customs documents relating to cargo or items of transport equipment.
    • CustomsImmediateReleaseDeclaration - Document/message issued by an importer notifying Customs that goods have been removed from an importing means of transport to the importer's premises under a Customs- approved arrangement for immediate release or requesting authorization to do so.
    • CustomsInvoice - Document/message required by the Customs in an importing country in which an exporter states the invoice or other price (e.g. selling price of identical goods) and specifies costs for freight insurance and packing etc. terms of delivery and payment for the purpose of determining the Customs value in the importing country of goods consigned to that country.
    • CustomsManifest - Message/document identifying a customs manifest. The document itemizes a list of cargo prepared by shipping companies from bills of landing and presented to customs for formal report of cargo.
    • CustomsSummaryDeclarationWithCommercialDetailAlternate - Alternate Customs declaration summary with commercial transaction details.
    • CustomsSummaryDeclarationWithoutCommercialDetailAlternate - Alternate Customs declaration summary without any commercial transaction details.
    • DamageCertification - Official certification that damages to the goods to be transported have been discovered.
    • DangerousGoodsDeclaration - Document/message issued by a consignor in accordance with applicable conventions or regulations describing hazardous goods or materials for transport purposes and stating that the latter have been packed and labeled in accordance with the provisions of the relevant conventions or regulations.
    • DangerousGoodsList - Listing of all details of dangerous goods carried.
    • DebitAdvice - Advice on a debit.
    • DebitNote - Document/message for providing debit information to the relevant party.
    • DebitNoteRelatedToFinancialAdjustments - Document/message for providing debit information related to financial adjustments to the relevant party.
    • DebitNoteRelatedToGoodsOrServices - Debit information related to a transaction for goods or services to the relevant party.
    • DeclarationOfOrigin - Appropriate statement as to the origin of the goods made in connection with their exportation by the manufacturer producer supplier exporter or other competent person on the Commercial invoice or any other document relating to the goods (CCC).
    • DeclarationRegardingTheInwardAndOutwardMovementOfVessel - Document to declare inward and outward movement of a vessel.
    • DelcredereCreditNote - A credit note sent to the party paying on behalf of a number of buyers.
    • DelcredereInvoice - An invoice sent to the party paying for a number of buyers.
    • DeliveryForecast - A message which enables the transmission of delivery or product forecasting requirements.
    • DeliveryInstructions - Document/message issued by a buyer giving instructions regarding the details of the delivery of goods ordered.
    • DeliveryJustInTime - Usage of DELJIT-message.
    • DeliveryNote - Paper document attached to a consignment informing the receiving party about contents of this consignment.
    • DeliveryNoticeGoods - Notification in writing sent by the carrier to the sender to inform him at his request of the actual date of delivery of the goods.
    • DeliveryNoticeRailTransport - Document/message created by the consignor or by the departure station joined to the transport or sent to the consignee giving the possibility to the consignee or the arrival station to attest the delivery of the goods. The document must be returned to the consignor or to the departure station.
    • DeliveryOrder - Document/message issued by a party entitled to authorize the release of goods specified therein to a named consignee to be retained by the custodian of the goods.
    • DeliveryRelease - Document/message issued by a buyer releasing the dispatch of goods after receipt of the Ready for dispatch advice from the seller.
    • DeliverySchedule - Usage of DELFOR-message.
    • DeliveryScheduleResponse - A message providing a response to a previously transmitted delivery schedule.
    • DeliveryVerificationCertificate - Document/message whereby an official authority (Customs or governmental) certifies that goods have been delivered.
    • DeratDocument - Document certifying that a ship is free of rats valid to a specified date.
    • DespatchAdvice - Document/message by means of which the seller or consignor informs the consignee about the dispatch of goods.
    • DespatchNotePostParcels - Document/message which according to Article 106 of the "Agreement concerning Postal Parcels" under the UPU convention is to accompany post parcels.
    • DespatchNoteModelT - European community transit declaration.
    • DespatchNoteModelT1 - Transit declaration for goods circulating under internal community transit procedures (between European Union (EU) countries).
    • DespatchNoteModelT2 - Ascertainment that the declared goods were originally produced in an European Union (EU) country.
    • DespatchNoteModelT2L - Ascertainment that the declared goods were originally produced in an European Union (EU) country. May only be used for goods that are loaded on one single means of transport in one single departure point for one single delivery point.
    • DespatchOrder - Document/message issued by a supplier initiating the dispatch of goods to a buyer (consignee).
    • DirectPaymentValuation - Document/message addressed for instance by a general contractor to the owner in order that a direct payment be made to a subcontractor.
    • DirectPaymentValuationRequest - Request to establish a direct payment valuation.
    • DirectShip - Direct Ship
    • DocumentaryCredit - Document/message in which a bank states that it has issued a documentary credit under which the beneficiary is to obtain payment acceptance or negotiation on compliance with certain terms and conditions and against presentation of stipulated documents and such drafts as may be specified. The credit may or may not be confirmed by another bank.
    • DocumentaryCreditAcceptanceAdvice - Document/message whereby a bank advises acceptance under a documentary credit.
    • DocumentaryCreditAmendment - Document/message whereby a bank notifies a beneficiary of the details of an amendment to the terms and conditions of a documentary credit.
    • DocumentaryCreditAmendmentInformation - Documentary credit amendment information.
    • DocumentaryCreditAmendmentNotification - Document/message whereby a bank advises that the terms and conditions of a documentary credit have been amended.
    • DocumentaryCreditApplication - Document/message whereby a bank is requested to issue a documentary credit on the conditions specified therein.
    • DocumentaryCreditCollectionInstruction - Instruction for the collection of the documentary credit.
    • DocumentaryCreditIssuanceInformation - Provides information on documentary credit issuance.
    • DocumentaryCreditLetterOfIndemnity - Document/message in which a beneficiary of a documentary credit accepts responsibility for non-compliance with the terms and conditions of the credit and undertakes to refund the money received under the credit with interest and charges accrued.
    • DocumentaryCreditNegotiationAdvice - Document/message whereby a bank advises negotiation under a documentary credit.
    • DocumentaryCreditNotification - Document/message issued by an advising bank in order to transmit a documentary credit to a beneficiary or to another advising bank.
    • DocumentaryCreditPaymentAdvice - Document/message whereby a bank advises payment under a documentary credit.
    • DocumentaryCreditTransferAdvice - Document/message whereby a bank advises that (part of) a documentary credit is being or has been transferred in favor of a second beneficiary.
    • DocumentResponseCustoms - Document response message to permit the transfer of data from Customs to the transmitter of the previous message.
    • DocumentsPresentationForm - Document/message whereby a draft or similar instrument and/or commercial documents are presented to a bank for acceptance discounting negotiation payment or collection whether or not against a documentary credit.
    • DraftBillOfQuantity - Document/message providing a draft bill of quantity issued in an unpriced form.
    • Drawing - The document or message is a drawing.
    • DrivingLicenceInternational - An official document giving a native of one country permission to drive a vehicle in certain other countries.
    • DrivingLicenceNational - An official document giving permission to drive a car in a given country.
    • Dropship - Dropship
    • EcCarnet - EC customs transit document issued by EC customs authorities for transit and/or temporary user of goods within the EC.
    • EdiAssociatedObjectAdministrationMessage - A message giving additional information about the exchange of an EDI associated object.
    • EmbargoPermit - Document/message giving the permission to export specified goods.
    • EmergencyOrder - Emergency Order
    • EmptyContainerBill - Bill of lading indicating an empty container.
    • EmptyContainerDispositionOrder - Order to make available empty containers.
    • EndUseAuthorization - Description to be provided.
    • Enquiry - Document/message issued by a party interested in the purchase of goods specified therein and indicating particular desirable conditions regarding delivery terms etc. addressed to a prospective supplier with a view to obtaining an offer.
    • ErrorResponseCustoms - Error response message to permit the transfer of data from Customs to the transmitter of the previous message.
    • EscortOfficialRecognition - Document/message which gives right to the owner to exert all functions normally transferred to a guard in a train by which an escorted consignment is transported.
    • EstimatedPricedBillOfQuantity - An estimate based upon a detailed quantity based specification (bill of quantity).
    • Eur1CertificateOfOrigin - Customs certificate used in preferential goods interchanges between EC countries and EC external countries.
    • ExceptionalOrder - An order which falls outside the framework of an agreement.
    • ExchangeControlDeclarationImport - Document/message completed by an importer/buyer as a means for the competent body to control that a trade transaction for which foreign exchange has been allocated has been executed and that money has been transferred in accordance with the conditions of payment and the exchange control regulations in force.
    • ExchangeControlDeclarationExport - Document/message completed by an exporter/seller as a means whereby the competent body may control that the amount of foreign exchange accrued from a trade transaction is repatriated in accordance with the conditions of payment and exchange control regulations in force.
    • ExciseCertificate - Certificate asserting that the goods have been submitted to the excise authorities before departure from the exporting country or before delivery in case of import traffic.
    • ExportLicence - Permit issued by a government authority permitting exportation of a specified commodity subject to specified conditions as quantity country of destination etc. Synonym: Embargo permit.
    • ApplicationForExportLicence - Application for a permit issued by a government authority permitting exportation of a specified commodity subject to specified conditions as quantity country of destination etc.
    • ExtendedCreditAdvice - Document/message sent by an account servicing institution to one of its account owners to inform the account owner of an entry that has been or will be credited to its account for a specified amount on the date indicated. It provides extended commercial information concerning the relevant remittance advice.
    • ExtendedPaymentOrder - Document/message containing information needed to initiate the payment. It may cover the financial settlement for several commercial trade transactions which it is possible to specify in a special payments detail part. It is an instruction to the ordered bank to arrange for the payment of one specified amount to the beneficiary.
    • Extra-CommunityTradeStatisticalDeclaration - Document/message in which a declarant provides information about extra-Community trade of goods required by the body responsible for the collection of trade statistics. Trade by a country in the European Union with a country outside the European Union.
    • FabricateAndHold - Fabricate and Hold
    • FactoredCreditNote - Credit note related to assigned invoice(s).
    • FactoredInvoice - Invoice assigned to a third party for collection.
    • FederalLabelApproval - A pre-approved document relating to federal label approval requirements.
    • FinalPaymentRequestBasedOnCompletionOfWork - The final payment request of a series of payment requests submitted upon completion of all the work.
    • FinancialStatementOfAccount - Statement giving the status of a financial account.
    • FirstSampleTestReport
    • ForeignExchangePermit - Document/message issued by the competent body authorizing an importer/buyer to transfer an amount of foreign exchange to an exporter/seller in payment for goods.
    • FormulaFunds - Formula Funds
    • ForwardersAdviceToExporter - Document/message issued by a freight forwarder informing an exporter of the action taken in fulfillment of instructions received.
    • ForwardersAdviceToImportAgent - Document/message issued by a freight forwarder in an exporting country advising his counterpart in an importing country about the forwarding of goods described therein.
    • ForwardersBillOfLading - Non-negotiable document issued by a freight forwarder evidencing a contract for the carriage of goods by sea and the taking over or loading of the goods by the freight forwarder and by which the freight forwarder undertakes to deliver the goods to the consignee named in the document.
    • ForwardersCertificateOfReceipt - Non-negotiable document issued by a forwarder to certify that he has assumed control of a specified consignment with irrevocable instructions to send it to the consignee indicated in the document or to hold it at his disposal. E.g. FIATA-FCR.
    • ForwardersCertificateOfTransport - Negotiable document/message issued by a forwarder to certify that he has taken charge of a specified consignment for dispatch and delivery in accordance with the consignor's instructions as indicated in the document and that he accepts responsibility for delivery of the goods to the holder of the document through the intermediary of a delivery agent of his choice. E.g. FIATA-FCT.
    • ForwardersInvoice - Invoice issued by a freight forwarder specifying services rendered and costs incurred and claiming payment therefore.
    • ForwardersWarehouseReceipt - Document/message issued by a forwarder acting as Warehouse Keeper acknowledging receipt of goods placed in a warehouse and stating or referring to the conditions which govern the warehousing and the release of goods. The document contains detailed provisions regarding the rights of holders-by-endorsement transfer of ownership etc. E.g. FIATA-FWR.
    • ForwardingInstructions - Document/message issued to a freight forwarder giving instructions regarding the action to be taken by the forwarder for the forwarding of goods described therein.
    • FreePass - A document giving free access to a service.
    • FreightInvoice - Document/message issued by a transport operation specifying freight costs and charges incurred for a transport operation and stating conditions of payment.
    • FreightManifest - Document/message containing the same information as a cargo manifest and additional details on freight amounts charges etc.
    • FumigationCertificate - Certificate attesting that fumigation has been performed.
    • GatePass - Document/message authorizing goods specified therein to be brought out of a fenced-in port or terminal area.
    • GeneralCargoSummaryManifestReport - A document code to indicate that the message being transmitted is summary manifest information for general cargo.
    • GeneralResponseCustoms - General response message to permit the transfer of data from Customs to the transmitter of the previous message.
    • GoodsControlCertificate - Document/message issued by a competent body evidencing the quality of the goods described therein in accordance with national or international standards or conforming to legislation in the importing country or as specified in the contract.
    • GoodsDeclarationForCustomsTransit - Document/message by which the sender declares goods for Customs transit according to Annex E.1 (concerning Customs transit) to the Kyoto convention (CCC).
    • GoodsDeclarationForExportation - Document/message by which goods are declared for export Customs clearance conforming to the layout key set out at Appendix I to Annex C.1 concerning outright exportation to the Kyoto convention (CCC). Within a Customs union "for dispatch" may have the same meaning as "for exportation".
    • GoodsDeclarationForHomeUse - Document/message by which goods are declared for import Customs clearance according to Annex B.1 (concerning clearance for home use) to the Kyoto Convention (CCC).
    • GoodsDeclarationForImportation - Document/message by which goods are declared for import Customs clearance [sister entry of 830].
    • GoodsReceipt - Document/message issued by a port warehouse/shed or terminal operator acknowledging receipt of goods specified therein on conditions stated or referred to in the document.
    • GoodsReceiptCarriage - Document/message issued by a carrier or a carrier's agent acknowledging receipt for carriage of goods specified therein on conditions stated or referred to in the document enabling the carrier to issue a transport document.
    • GovernmentContract - Description to be provided.
    • Grant - A document indicating the granting of funds.
    • HandlingOrder - Document/message issued by a cargo handling organization (port administration terminal operator etc.) for the removal or other handling of goods under their care.
    • HireInvoice - Document/message for invoicing the hiring of human resources or renting goods or equipment.
    • HireOrder - Document/message for hiring human resources or renting goods or equipment.
    • HorsemeatSanitaryCertificate - Document or message issued by the competent authority in the exporting country evidencing that horsemeat products comply with the requirements set by the importing country.
    • HouseBillOfLading - The bill of lading issued not by the carrier but by the freight forwarder/consolidator known by the carrier.
    • HouseWaybill - The document made out by an agent/consolidator which evidences the contract between the shipper and the agent/consolidator for the arrangement of carriage of goods.
    • IdentityCard - Official document to identify a person.
    • ImpendingArrival - Notification of impending arrival details for vessel.
    • ImplementationGuideline - A document specifying the criterion and format for exchanging information in an electronic data interchange syntax.
    • ImportLicence - Document/message issued by the competent body in accordance with import regulations in force by which authorization is granted to a named party to import either a limited quantity of designated articles or an unlimited quantity of such articles during a limited period under conditions specified in the document.
    • ApplicationForImportLicence - Document/message in which an interested party applies to the competent body for authorization to import either a limited quantity of articles subject to import restrictions or an unlimited quantity of such articles during a limited period and specifies the kind of articles their origin and value etc.
    • IndefiniteDeliveryDefiniteQuantity - Indefinite Delivery Definite Quantity
    • IndefiniteDeliveryDefiniteQuantityContract - A document indicating a contract calling for indefinite deliveries of definite quantities.
    • IndefiniteDeliveryIndefiniteQuantity - Indefinite Delivery Indefinite Quantity
    • IndefiniteDeliveryIndefiniteQuantityContract - A document indicating a contract calling for the indefinite deliveries of indefinite quantities of goods.
    • IndustrySuperannuationContributionsAdvice - Document/message providing contributions advice used for superannuation schemes which are industry wide.
    • IndustrySuperannuationMemberMaintenanceMessage - Member maintenance message used for industry wide superannuation schemes.
    • InedibleSanitaryCertificate - Document or message issued by the competent authority in the exporting country evidencing that inedible products comply with the requirements set by the importing country.
    • InformationCopy - Information Copy
    • InlandWaterwayBillOfLading - Negotiable transport document made out to a named person to order or to bearer signed by the carrier and handed to the sender after receipt of the goods.
    • Inquiry - This is a request for information.
    • InspectionCertificate - Document/message issued by a competent body evidencing that the goods described therein have been inspected in accordance with national or international standards in conformity with legislation in the country in which the inspection is required or as specified in the contract.
    • InspectionReport - A message informing a party of the results of an inspection.
    • InspectionRequest - A message requesting a party to inspect items.
    • InstructionsForBankTransfer - Document/message containing instructions from a customer to his bank to pay an amount in a specified currency to a nominated party in another country by a method either specified (e.g. teletransmission air mail) or left to the discretion of the bank.
    • InstructionToCollect - A message instructing a party to collect goods.
    • InsuranceCertificate - Document/message issued to the insured certifying that insurance has been effected and that a policy has been issued. Such a certificate for a particular cargo is primarily used when good are insured under the terms of a floating or an open policy; at the request of the insured it can be exchanged for a policy.
    • InsuranceDeclarationSheetBordereau - A document/message used when an insured reports to his insurer details of individual shipments which are covered by an insurance contract
    • InsurancePolicy - Document/message issued by the insurer evidencing an agreement to insure and containing the conditions of the agreement concluded whereby the insurer undertakes for a specific fee to indemnify the insured for the losses arising out of the perils and accidents specified in the contract.
    • InsurersInvoice - Document/message issued by an insurer specifying the cost of an insurance which has been effected and claiming payment therefore.
    • InterimApplicationForPayment - Document/message containing a provisional assessment in support of a request for payment for completed work for a construction contract.
    • InternalTransportOrder - Document/message giving instructions about the transport of goods within an enterprise.
    • IntrastatDeclaration - Document/message in which a declarant provides information about goods required by the body responsible for the collection of trade statistics.
    • InventoryAdjustmentStatusReport - A message detailing statuses related to the adjustment of inventory.
    • InventoryMovementAdvice - Advice of inventory movements.
    • InventoryReport - A message specifying information relating to held inventories.
    • InventoryStatusAdvice - Advice of stock on hand.
    • InvoicingDataSheet - Document/message issued within an enterprise containing data about goods sold to be used as the basis for the preparation of an invoice.
    • ItemsBookedToAFinancialAccountReport - A message reporting items which have been booked to a financial account.
    • JobLot - Job Lot
    • KanbanSchedule - Message to describe a Kanban schedule.
    • Lease - Lease
    • LeaseBlanketAgreement - Lease (Blanket Agreement)
    • LeaseInvoice - Usage of INVOIC-message for goods in leasing contracts.
    • LeaseOrder - Document/message for goods in leasing contracts.
    • LegalStatementOfAnAccount - A statement of an account containing the booked items as in the ledger of the account servicing financial institution.
    • LetterContract - Letter Contract
    • LetterOfIndemnityForNon-SurrenderOfBillOfLading - Document/message issued by a commercial party or a bank of an insurance company accepting responsibility to the beneficiary of the indemnity in accordance with the terms thereof.
    • LetterOfIntent - Document/message by means of which a buyer informs a seller that the buyer intends to enter into contractual negotiations.
    • LifeInsurancePayrollDeductionsAdvice - Payroll deductions advice used in the life insurance industry.
    • ListingStatementOfAnAccount - A statement from the account servicing financial institution containing items pending to be booked.
    • LoadlineDocument - Document specifying the limit of a ship's legal submersion under various conditions.
    • Loan - Loan
    • LowValuePaymentOrder - The message contains low value payment order(s) only.
    • MakeOrBuyPlan - A document indicating a plan that identifies which items will be made and which items will be bought.
    • ManufacturingInstructions - Document/message issued within an enterprise to initiate the manufacture of goods to be offered for sale.
    • ManufacturingSpecification - A document indicating the specification of how an item is to be manufactured.
    • MaritimeDeclarationOfHealth - Document certifying the health condition on board a vessel valid to a specified date.
    • MasterAirWaybill - Document/message made out by or on behalf of the agent/consolidator which evidences the contract between the agent/consolidator and carrier(s) for carriage of goods over routes of the carrier(s) for a consignment consisting of goods originated by more than one shipper (IATA).
    • MasterBillOfLading - A bill of lading issued by the master of a vessel (in actuality the owner or charterer of the vessel). It could cover a number of house bills.
    • MaterialInspectionAndReceivingReport - A report that is both an inspection report for materials and a receiving document.
    • MateSReceipt - Document/message issued by a ship's officer to acknowledge that a specified consignment has been received on board a vessel and the apparent condition of the goods; enabling the carrier to issue a Bill of lading.
    • MeansOfTransportAdvice - Message reporting the means of transport used to carry goods or cargo.
    • MeansOfTransportationAvailabilityInformation - Information giving the various availabilities of a means of transportation.
    • MeansOfTransportationScheduleInformation - Information giving the various schedules of a means of transportation.
    • MeatAndMeatBy-ProductsSanitaryCertificate - Document or message issued by the competent authority in the exporting country evidencing that meat or meat by- products comply with the requirements set by the importing country.
    • MeatFoodProductsSanitaryCertificate - Document or message issued by the competent authority in the exporting country evidencing that meat food products comply with the requirements set by the importing country.
    • MessageInDevelopmentRequest - Requesting a Message in Development (MiD).
    • MeteredServicesInvoice - Document/message claiming payment for the supply of metered services (e.g. gas electricity etc.) supplied to a fixed meter whose consume
    • MillCertificate - Certificate certifying a specific quality of agricultural products.
    • ModificationOfExistingMessage - Requesting a change to an existing message.
    • MovementCertificateATr1 - Specific form of transit declaration issued by the exporter (movement certificate).
    • MultidropOrder - One purchase order that contains the orders of two or more vendors and the associated delivery points for each.
    • MultimodalCombinedTransportDocumentGeneric - A transport document used when more than one mode of transportation is involved in the movement of cargo. It is a contract of carriage and receipt of the cargo for a multimodal transport. It indicates the place where the responsible transport company in the move takes responsibility for the cargo the place where the responsibility of this transport company in the move ends and the conveyances involved.
    • MultimodalTransportDocumentGeneric - Document/message which evidences a multimodal transport contract the taking in charge of the goods by the multimodal transport operator and an undertaking by him to deliver the goods in accordance with the terms of the contract. (International Convention on Multimodal Transport of Goods).
    • MultiplePaymentOrder - Document/message containing a payment order to debit one or more accounts and to credit one or more beneficiaries.
    • NameProductPlate - Plates on goods identifying and describing an article.
    • NewCodeRequest - Requesting a new code.
    • NewMessageRequest - Request for a new message (NMR).
    • NewOrder - New Order
    • NewProductIntroduction - New Product Introduction
    • NewStoreOpening - New Store Opening
    • Non-NegotiableMaritimeTransportDocumentGeneric - Non-negotiable document which evidences a contract for the carriage of goods by sea and the taking over or loading of the goods by the carrier and by which the carrier undertakes to deliver the goods to the consignee named in the document. E.g. Sea waybill. Remark: Synonymous with "straight" or "non-negotiable Bill of lading" used in certain countries e.g. Canada.
    • Non-Pre-AuthorisedDirectDebit - The message contains non-pre-authorized direct debit(s).
    • Non-Pre-AuthorisedDirectDebitRequest - The message contains non-pre-authorized direct debit request(s).
    • NotForSale - Not for Sale
    • NoticeOfCircumstancesPreventingDeliveryGoods - Request made by the carrier to the sender or as the case may be the consignee for instructions as to the disposal of the consignment when circumstances prevent delivery and the return of the goods has not been requested by the consignor in the transport document.
    • NoticeOfCircumstancesPreventingTransportGoods - Request made by the carrier to the sender or the consignee as the case may be for instructions as to the disposal of the goods when circumstances prevent transport before departure or en route after acceptance of the consignment concerned.
    • NotificationOfEmergencyShiftingFromTheDesignatedPlaceInPort - Document to notify shifting from designated place in port once secured at the designated place.
    • NotificationOfUsageOfBerthOrMooringFacilities - Document to notify usage of berth or mooring facilities.
    • OfferQuotation - Document/message which with a view to concluding a contract sets out the conditions under which the goods are offered.
    • OperatingInstructions
    • OpticalCharacterReadingPayment - Payment effected by an Optical Character Reading (OCR) document.
    • Order - Document/message by means of which a buyer initiates a transaction with a seller involving the supply of goods or services as specified according to conditions set out in an offer or otherwise known to the buyer.
    • OrderStatusEnquiry - A message enquiring the status of previously sent orders.
    • OrderStatusReport - A message reporting the status of previously sent orders.
    • PackageResponseCustoms - Package response message to permit the transfer of data from Customs to the transmitter of the previous message.
    • PackingInstructions - Document/message within an enterprise giving instructions on how goods are to be packed.
    • PackingList - Document/message specifying the distribution of goods in individual packages (in trade environment the dispatch advice message is used for the packing list).
    • PartialInvoice
    • PartyInformation - Document/message providing basic data concerning a party.
    • PassengerList - Declaration to Customs regarding passengers aboard the conveyance; equivalent to IMO FAL 6.
    • Passport - An official document giving permission to travel in foreign countries.
    • PaymentBond - A document that guarantees the payment of monies.
    • PaymentOrder - Document/message containing information needed to initiate the payment. It may cover the financial settlement for one or more commercial trade transactions. A payment order is an instruction to the ordered bank to arrange for the payment of one specified amount to the beneficiary.
    • PaymentOrPerformanceBond - A document indicating a bond that guarantees the payment of monies or a performance.
    • PaymentRequestForCompletedUnits - A request for payment for completed units.
    • PaymentValuation - Document/message establishing the financial elements of a situation of works.
    • PaymentValuationForUnscheduledItems - A payment valuation for unscheduled items.
    • PerformanceBond - A document that guarantees performance.
    • PharmaceuticalSanitaryCertificate - Document or message issued by the competent authority in the exporting country evidencing that pharmaceutical products comply with the requirements set by the importing country.
    • PhytosanitaryCertificate - Document/message issued by the competent body in the exporting country evidencing that plants fruit or vegetables are free from disease and fit for consumption and giving details on fumigation or other treatment to which they may have been subjected.
    • PickUpNotice - Notice specifying the pick-up of released cargo or containers from a certain address.
    • PortChargesDocuments - Documents/messages specifying services rendered storage and handling costs demurrage and other charges due to the owner of goods described therein.
    • PostReceipt - Document/message which evidences the transport of goods by post (e.g. mail parcel etc.).
    • PoultrySanitaryCertificate - Document or message issued by the competent authority in the exporting country evidencing that poultry products comply with the requirements set by the importing country.
    • PreadviceOfACredit - Preadvice indicating a credit to happen in the future.
    • PreAuthorizedDirectDebit - The message contains pre-authorized direct debit(s).
    • PreAuthorizedDirectDebitRequest - The message contains pre-authorized direct debit request(s).
    • PreferenceCertificateOfOrigin - Description to be provided.
    • PreliminaryCreditAssessment - Document/message issued either by a factor to indicate his preliminary credit assessment on a buyer or by a seller to request a factor's preliminary credit assessment on a buyer.
    • PreliminarySalesReport - Preliminary sales report sent before all the information is available.
    • PrepaymentInvoice - An invoice to pay amounts for goods and services in advance; these amounts will be subtracted from the final invoice.
    • PreviousCustomsDocumentMessage - Indication of the previous Customs document/message concerning the same transaction.
    • PriceSalesCatalogue
    • PriceSalesCatalogueResponse - A document providing a response to a previously sent price/sales catalogue.
    • PricedAlternateTenderBillOfQuantity - A priced tender based upon an alternate specification.
    • PricedTenderBoq - Document/message providing a detailed quantity based specification updated with prices to form a tender submission for a construction contract. BOQ means: Bill of quantity.
    • PriceNegotiationResult - A document providing the result of price negotiations.
    • PriceVariationInvoice - An invoice which requests payment for the difference in price between an original invoice and the result of the application of a price variation formula.
    • ProcessDataReport - Reports on events during production process.
    • ProductDataMessage - A message to submit master data a set of data that is rarely changed to identify and describe products a supplier offers to their (potential) customer or buyer.
    • ProductPerformanceReport - Report specifying the performance values of products.
    • ProductSpecificationReport - Report providing specification values of products.
    • ProformaInvoice - Document/message serving as a preliminary invoice containing - on the whole - the same information as the final invoice but not actually claiming payment.
    • ProgressiveDischargeReport - Document or message progressively issued by the container terminal operator in charge of discharging a vessel identifying containers that have been discharged from a specific vessel at that point in time.
    • ProjectMasterPlan - A high level all encompassing master plan to complete a project.
    • ProjectMasterSchedule - A high level all encompassing master schedule of activities to complete a project.
    • ProjectPlan - A plan for project work to be completed.
    • ProjectPlanningAvailableResources - Available resources for project planning purposes.
    • ProjectPlanningCalendar - Work calendar information for project planning purposes.
    • ProjectProductionPlan - A project plan for the production of goods.
    • ProjectRecoveryPlan - A project plan for recovery after a delay or problem resolution.
    • ProjectSchedule - A schedule of project activities to be completed.
    • PromissoryNote - Document/message issued and signed in conformity with the applicable legislation which contains an unconditional promise whereby the maker undertakes to pay a definite sum of money to the payee or to his order on demand or at a definite time against the surrender of the document itself.
    • Promotion - Promotion
    • ProvisionalPaymentValuation - Document/message establishing a provisional payment valuation.
    • PurchaseOrder - Document/message issued within an enterprise to initiate the purchase of articles materials or services required for the production or ma
    • PurchaseOrderChangeRequest - Change to an purchase order already sent.
    • PurchaseOrderResponse - Response to an purchase order already received.
    • PurchasingSpecification - A document indicating a specification used to purchase an item.
    • QualityDataMessage - Usage of QALITY-message.
    • QuantityValuation - Document/message providing a confirmed assessment by quantity of the completed work for a construction contract.
    • QuantityValuationRequest - Document/message providing an initial assessment by quantity of the completed work for a construction contract.
    • Query - Request information based on defined criteria.
    • QuotaPriorAllocationCertificate - Document/message issued by the competent body for prior allocation of a quota.
    • RailConsignmentNoteGenericTerm - Transport document constituting a contract for the carriage of goods between the sender and the carrier (the railway). For international rail traffic this document must conform to the model prescribed by the international conventions concerning carriage of goods by rail e.g. CIM Convention SMGS Convention.
    • ReadyForDespatchAdvice - Document/message issued by a supplier informing a buyer that goods ordered are ready for dispatch.
    • Reassignment - Document/message issued by a factor to a seller or to another factor to reassign an invoice or credit note previously assigned to him.
    • ReceiptCustoms - Receipt for Customs duty/tax/fee paid.
    • RechargingDocument - Fictitious transport document regarding a previous transport enabling a carrier's agent to give to another carrier's agent (in a different country) the possibility to collect charges relating to the original transport (rail environment).
    • RecordUpdateService - Record Update Service
    • RegionalAppellationCertificate - Certificate drawn up in accordance with the rules laid down by an authority or approved body certifying that the goods described therein qualify for a designation specific to the given region (e.g. champagne port wine Parmesan cheese).
    • RegistrationChange - Code specifying the modification of previously submitted registration information.
    • RegistrationDocument - An official document providing registration details.
    • RegistrationRenewal - Code specifying the continued validity of previously submitted registration information.
    • RejectedDirectDebit - The message contains rejected direct debit(s).
    • RelatedDocument - Description to be provided.
    • ReleaseAgainstAssortment - Release Against Assortment
    • ReleaseOrDeliveryOrder - Release or Delivery Order
    • RemittanceAdvice - Document/message advising of the remittance of payment.
    • RenewalOrder - Renewal Order
    • Rental - Rental
    • Reorder - Reorder
    • RepairAndReturn - Repair and Return
    • RepairOrder - Document/message to order repair of goods.
    • ReportOfTransactionsForInformationOnly - A message reporting transactions for information only.
    • ReportOfTransactionsWhichNeedFurtherInformationFromTheReceiver - A message reporting transactions which need further information from the receiver.
    • RequestForAnAmendmentOfADocumentaryCredit - Request for an amendment of a documentary credit.
    • RequestForDeliveryInstructions - Document/message issued by a supplier requesting instructions from the buyer regarding the details of the delivery of goods ordered.
    • RequestForFinancialCancellation - The message is a request for financial cancellation.
    • RequestForPayment - Document/message issued by a creditor to a debtor to request payment of one or more invoices past due.
    • RequestForQuote - Document/message requesting a quote on specified goods or services.
    • RequestForStatisticalData - Request for one or more items or data sets of statistical data.
    • RequestForTransfer - Document/message is a request for transfer.
    • Requirements - Requirements
    • RequirementsContract - A document indicating a requirements contract that authorizes the filling of all purchase requirements during a specified contract period.
    • Re-SendingConsignmentNote - Rail consignment note prepared by the consignor for the facilitation of an eventual return to the origin of the goods.
    • ResponseToAnAmendmentOfADocumentaryCredit - Response to an amendment of a documentary credit.
    • ResponseToATradeStatisticsMessage - Document/message in which the competent national authorities provide a declarant with an acceptance or a rejection about a received declaration for European statistical purposes.
    • ResponseToPreviousBankingStatusMessage - A response to a previously sent banking status message.
    • ResponseToQuery - Self-explanatory.
    • ResponseToRegistration - Code specifying a response to an occurrence of a registration message.
    • Restow - Message/document identifying containers that have been unloaded and then reloaded onto the same means of transport.
    • ResumeWorkOrder - Resume Work Order
    • RetailerPrecommitment - Retailer Pre-commitment
    • ReversalOfCredit - Reversal of credit accounting entry by bank.
    • ReversalOfDebit - Reversal of debit accounting entry by bank.
    • RoadConsignmentNote - Transport document/message which evidences a contract between a carrier and a sender for the carriage of goods by road (generic term). Remark: For international road traffic this document must contain at least the particulars prescribed by the convention on the contract for the international carriage of goods by road (CMR).
    • RoadList-Smgs - Accounting document one copy of which is drawn up for each consignment note; it accompanies the consignment over the whole route and is a rail transport document
    • RushOrder - Document/message for urgent ordering.
    • SafetyAndHazardDataSheet - Document or message to supply advice on a dangerous or hazardous material to industrial customers so as to enable them to take measures to protect their employees and the environment from any potential harmful effects from these material.
    • SafetyOfEquipmentCertificate - Document certifying the safety of a ship's equipment to a specified date.
    • SafetyOfRadioCertificate - Document certifying the safety of a ship's radio facilities to a specified date.
    • SafetyOfShipCertificate - Document certifying a ship's safety to a specified date.
    • SampleOrder - Document/message to order samples.
    • SanitaryCertificate - Document/message issued by the competent authority in the exporting country evidencing that alimentary and animal products including dead animals are fit for human consumption and giving details when relevant of controls undertaken.
    • SeasonTicket - A document giving access to a service for a determined period of time.
    • SeaWaybill - Non-negotiable document which evidences a contract for the carriage of goods by sea and the taking over of the goods by the carrier and by which the carrier undertakes to deliver the goods to the consignee named in the document.
    • SegmentChangeRequest - Requesting a change to an existing segment.
    • SegmentRequest - Request a new segment.
    • SelfBilledCreditNote - A document which indicates that the customer is claiming credit in a self billing environment.
    • Self-BilledInvoice - An invoice the invoicee is producing instead of the seller.
    • SequencedDeliverySchedule - Message to describe a sequence of product delivery.
    • ServiceDirectoryDefinition - Document/message defining the contents of a service directory set or parts thereof.
    • SettlementOfALetterOfCredit - Settlement of a letter of credit.
    • ShippedOrder - Shipped Order
    • ShippersLetterOfInstructionsAir - Document/message issued by a consignor in which he gives details of a consignment of goods that enables an airline or its agent to prepare an air waybill.
    • ShippingInstructions - Document/message advising details of cargo and exporter's requirements for its physical movement.
    • ShippingNote - Document/message provided by the shipper or his agent to the carrier multimodal transport operator terminal or other receiving authority giving information about export consignments offered for transport and providing for the necessary receipts and declarations of liability. (Sometimes a multipurpose cargo handling document also fulfilling the functions of document 632 633 650 and 655).
    • ShipsStoresDeclaration - Declaration to Customs regarding the contents of the ship's stores (equivalent to IMO FAL 3) i.e. goods intended for consumption by passengers/crew on board vessels aircraft or trains whether or not sold or landed; goods necessary for operation/maintenance of conveyance including fuel/lubricants excluding spare parts/equipment (IMO).
    • SimpleDataElementChangeRequest - Request a change to an existing simple data element.
    • SimpleDataElementRequest - Requesting a new simple data element.
    • SingleAdministrativeDocument - A set of documents replacing the various (national) forms for Customs declaration within the EC implemented on 01-01-1988.
    • SparePartsOrder - Document/message to order spare parts.
    • SpecialOrder - Special Order
    • SpotOrder - Document/message ordering the remainder of a production's batch.
    • StandAloneOrder - Stand-alone Order
    • StandingOrder - An order to supply fixed quantities of products at fixed regular intervals.
    • StatementOfAccountMessage - Usage of STATAC-message.
    • StatisticalAndOtherAdministrativeInternalDocuments - Documents/messages issued within an enterprise for the for the purpose of collection of production and other internal statistics and for other administration purposes.
    • StatisticalData - Transmission of one or more items of data or data sets.
    • StatisticalDefinitions - Transmission of one or more statistical definitions.
    • StatisticalDocumentExport - Document/message in which an exporter provides information about exported goods required by the body responsible for the collection of international trade statistics.
    • StatisticalDocumentImport - Description to be provided.
    • StatusInformation - Information regarding the status of a related message.
    • StatusReport - Message covers information about the status.
    • StopWork - Stop Work
    • StoresRequisition - Document/message issued within an enterprise ordering the taking out of stock of goods.
    • SubcontractorPlan - A document indicating a plan that identifies the manufacturer's subcontracting strategy for a specific contract.
    • SubstituteAirWaybill - A temporary air waybill which contains only limited information because of the absence of the original.
    • SummarySalesReport - Sales report containing summaries for several earlier sent sales reports.
    • SupplementaryDocumentForApplicationForCargoOperationOfDangerousGoods - Supplementary document to apply for cargo operation of dangerous goods.
    • SupplementaryDocumentForApplicationForTransportOfDangerousGoods - Supplementary document to apply for transport of dangerous goods.
    • SupplyOrServiceOrder - Supply or Service Order
    • SwapOrder - Document/message informing buyer or seller of the replacement of goods previously ordered.
    • TankerBillOfLading - Document which evidences a transport of liquid bulk cargo.
    • TaskOrder - A document indicating an order that tasks a contractor to perform a specified function.
    • TaxCalculationConfirmationResponseCustoms - Tax calculation/confirmation response message to permit the transfer of data from Customs to the transmitter of the previous message.
    • TaxDeclarationGeneral - Document/message containing a general tax declaration.
    • TaxDeclarationValueAddedTax - Document/message in which an importer states the pertinent information required by the competent body for assessment of value-added tax.
    • TaxDemand - Document/message containing the demand of tax.
    • TaxInvoice - An invoice for tax purposes.
    • TaxNotification - Used to specify that the message is a tax notification.
    • Termination - Termination
    • TestReport - Report providing the results of a test session.
    • ThroughBillOfLading - Bill of lading which evidences a contract of carriage from one place to another in separate stages of which at least one stage is a sea transit and by which the issuing carrier accepts responsibility for the carriage as set forth in the through bill of lading.
    • TifForm - International Customs transit document by which the sender declares goods for carriage by rail in accordance with the provisions of the 1952 International Convention to facilitate the crossing of frontiers for goods carried by rail (TIF Convention of UIC).
    • TimeMaterials - Time and Materials
    • TirCarnet - International Customs document (International Transit by Road) issued by a guaranteeing association approved by the Customs authorities under the cover of which goods are carried in most cases under Customs seal in road vehicles and/or containers in compliance with the requirements of the Customs TIR Convention of the International Transport of Goods under cover of TIR Carnets (UN/ECE).
    • TollConversionOrder - Toll Conversion Order
    • TrackingNumberAssignmentReport - Report of assigned tracking numbers.
    • TradeData - Document/message is for trade data.
    • TransportCargoReleaseOrder - Order to release cargo or items of transport equipment to a specified party.
    • TransportDepartureReport - Report of the departure of a means of transport from a particular facility.
    • TransportDischargeInstruction - Instruction to unload specified cargo containers or transport equipment from a means of transport.
    • TransportDischargeReport - Report on cargo containers or transport equipment unloaded from a particular means of transport.
    • TransportEmergencyCard - Official document specifying for a given dangerous goods item information such as nature of hazard protective devices actions to be taken in case of accident spillage or fire and first aid to be given.
    • TransportEmptyEquipmentAdvice - Advice that an item or items of empty transport equipment are available for return.
    • TransportEquipmentAcceptanceOrder - Order to accept items of transport equipment which are to be delivered by an inland carrier (rail road or barge) to a specified facility.
    • TransportEquipmentDamageReport - Report of damaged items of transport equipment that have been returned.
    • TransportEquipmentDeliveryNotice - Notification regarding the delivery of transport equipment.
    • TransportEquipmentDirectInterchangeReport - Report on the movement of containers or other items of transport equipment being exchanged establishing relevant rental periods.
    • TransportEquipmentEmptyReleaseInstruction - Instruction to release an item of empty transport equipment to a specified party or parties.
    • TransportEquipmentImpendingArrivalAdvice - Advice that containers or other items of transport equipment may be expected to be delivered to a certain location.
    • TransportEquipmentMaintenanceAndRepairNotice - Report of transport equipment which has been repaired or has had maintenance performed.
    • TransportEquipmentMaintenanceAndRepairWorkAuthorization - Authorization to have transport equipment repaired or to have maintenance performed.
    • TransportEquipmentMaintenanceAndRepairWorkEstimateAdvice - Advice providing estimates of transport equipment maintenance and repair costs.
    • TransportEquipmentMaintenanceAndRepairWorkEstimateOrder - Order to draw up an estimate of the costs of maintenance or repair of transport equipment.
    • TransportEquipmentMovementInstruction - Instruction to perform one or more different movements of transport equipment.
    • TransportEquipmentMovementReport - Report on one or more different movements of transport equipment.
    • TransportEquipmentOffHireReport - Report on the movement of containers or other items of transport equipment to record physical movement activity and establish the end of a rental period.
    • TransportEquipmentOffHireRequest - Request to terminate the lease on an item of transport equipment at a specified time.
    • TransportEquipmentOnHireOrder - Order to release empty items of transport equipment for on-hire to a lessee and authorizing collection by or on behalf of a specified party.
    • TransportEquipmentOnHireReport - Report on the movement of containers or other items of transport equipment to record physical movement activity and establish the beginning of a rental period.
    • TransportEquipmentOnHireRequest - Request for transport equipment to be made available for hire.
    • TransportEquipmentPackingInstruction - Instruction to pack cargo into a container or other item of transport equipment.
    • TransportEquipmentPickUpAvailabilityConfirmation - Confirmation that an item of transport equipment is available for collection.
    • TransportEquipmentPickUpAvailabilityRequest - Request for confirmation that an item of transport equipment will be available for collection.
    • TransportEquipmentPickUpReport - Report that an item of transport equipment has been collected.
    • TransportEquipmentShiftReport - Report on the movement of containers or other items of transport within a facility.
    • TransportEquipmentSpecialServiceInstruction - Instruction to perform a specified service or services on an item or items of transport equipment.
    • TransportEquipmentStatusChangeReport - Report on one or more changes of status associated with an item or items of transport equipment.
    • TransportEquipmentStockReport - Report on the number of items of transport equipment stored at one or more locations.
    • TransportEquipmentSurveyOrder - Order to perform a survey on specified items of transport equipment.
    • TransportEquipmentSurveyOrderResponse - Response to an order to conduct a survey of transport equipment.
    • TransportEquipmentSurveyReport - Survey report of specified items of transport equipment.
    • TransportEquipmentUnpackingInstruction - Instruction to unpack specified cargo from specified containers or other items of transport equipment.
    • TransportEquipmentUnpackingReport - Report on the completion of unpacking specified containers or other items of transport equipment.
    • TransportLoadingInstruction - Instruction to load cargo containers or transport equipment onto a means of transport.
    • TransportLoadingReport - Report on completion of loading cargo containers or other transport equipment onto a means of transport.
    • TransportMovementGateInReport - Report on the inward movement of cargo containers or other items of transport equipment which have been delivered to a facility by an inland carrier.
    • TransportMovementGateOutReport - Report on the outward movement of cargo containers or other items of transport equipment (either full or empty) which have been picked up by an inland carrier.
    • TransportStatusReport - A message to report the transport status and/or change in the transport status (i.e. event) between agreed parties.
    • TransportStatusRequest - A message to request a transport status report (e.g. through the International multimodal status report message IFSTA).
    • TransshipmentDespatchAdvice - Document by means of which the supplier or consignor informs the buyer consignee or the distribution center about the dispatch of goods for transshipment.
    • TransshipmentOrder - An order requesting the supply of products packed according to the final delivery point which will be moved across a dock in a distribution center without further handling.
    • TreatmentNilOutturn - No shortage surplus or damaged outturn resulting from container vessel unpacking.
    • TreatmentPersonalEffect - Cargo consists of personal effects.
    • TreatmentTimber - Cargo consists of timber.
    • TreatmentTimeUpUnderbond - Movement type indicator: goods are moved under customs control for warehousing due to being time-up.
    • TreatmentUnderbondBySea - Movement type indicator: goods are to move by sea under customs control to a customs office where formalities will be completed.
    • UnderbondApproval - A message/document issuing Customs approval to move cargo from one Customs control point to another.
    • UnderbondRequest - A Message/document requesting to move cargo from one Customs control point to another.
    • UnitDown - Unit Down
    • UnitedNationsStandardMessageRequest - Requesting a United Nations Standard Message (UNSM).
    • UnitExchange - Unit Exchange
    • UniversalMultipurposeTransportDocument - Document/message evidencing a contract of carriage covering the movement of goods by any mode of transport or combination of modes for national as well as international transport under any applicable international convention or national law and under the conditions of carriage of any carrier or transport operator undertaking or arranging the transport referred to in the document.
    • UnpricedBillOfQuantity - Document/message providing a detailed quantity based specification issued in an unpriced form to invite tender prices.
    • UnshipPermit - A message or document issuing permission to unship cargo.
    • UrgentServiceRequest - Urgent Service Request
    • UserDirectoryDefinition - Document/message defining the contents of a user directory set or parts thereof.
    • VaccinationCertificate - Official document proving immunization against certain diseases.
    • ValidatedPricedTender - A validated priced tender.
    • ValueDeclaration - Document/message in which a declarant (importer) states the invoice or other price (e.g. selling price of identical goods) and specifies costs for freight insurance and packing etc. terms of delivery and payment any relationship with the trading partner etc. for the purpose of determining the Customs value of goods imported.
    • VesselUnpackReport - A document code to indicate that the message being transmitted identifies all short and surplus cargoes off-loaded from a vessel at a specified discharging port.
    • VeterinaryCertificate - Document/message issued by the competent authority in the exporting country evidencing that live animals or birds are not infested or infected with disease and giving details regarding their provenance and of vaccinations and other treatment to which they have been subjected.
    • WageDetermination - A document indicating a determination of the wages to be paid.
    • WarehouseWarrant - Negotiable receipt document issued by a Warehouse Keeper to a person placing goods in a warehouse and conferring title to the goods stored.
    • WarrantyOrder - Warranty Order
    • Waybill - Non-negotiable document evidencing the contract for the transport of cargo.
    • WeightCertificate - Certificate certifying the weight of goods.
    • WeightList - Document/message specifying the weight of goods.
    • WineCertificate - Certificate attesting to the quality origin or appellation of wine.
    • WoolHealthCertificate - Certificate attesting that wool is free from specified risks to human or animal health.
    • WrittenInstructionsInConformanceWithAdrArticleNumber10385 - Written instructions relating to dangerous goods and defined in the European Agreement of Dangerous Transport by Road known as ADR (Accord europeen relatif au transport international des merchandises Dangereuses par Route).

[^]Code Fragment

    <xsd:simpleType name="OrderTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="AcknowledgementMessage">
        <xsd:enumeration value="AcknowledgementOfOrder">
        <xsd:enumeration value="AClaimForPartsAndOrLabourCharges">
        <xsd:enumeration value="AdviceOfAnAmendmentOfADocumentaryCredit">
        <xsd:enumeration value="AdviceOfCollection">
        <xsd:enumeration value="AdviceOfDistributionOfDocuments">
        <xsd:enumeration value="AdvisingItemsToBeBookedToAFinancialAccount">
        <xsd:enumeration value="Agreement">
        <xsd:enumeration value="AgreementToPay">
        <xsd:enumeration value="AirWaybill">
        <xsd:enumeration value="AOGCritical">
        <xsd:enumeration value="AOGService">
        <xsd:enumeration value="ApplicationAcknowledgementAndErrorReport">
        <xsd:enumeration value="ApplicationErrorAndAcknowledgement">
        <xsd:enumeration value="ApplicationErrorMessage">
        <xsd:enumeration value="ApplicationForBankersDraft">
        <xsd:enumeration value="ApplicationForBankersGuarantee">
        <xsd:enumeration value="ApplicationForDesignationOfBerthingPlaces">
        <xsd:enumeration value="ApplicationForDocumentaryCredit">
        <xsd:enumeration value="ApplicationForExchangeAllocation">
        <xsd:enumeration value="ApplicationForGoodsControlCertificate">
        <xsd:enumeration value="ApplicationForInspectionCertificate">
        <xsd:enumeration value="ApplicationForPhytosanitaryCertificate">
        <xsd:enumeration value="ApplicationForShiftingFromTheDesignatedPlaceInPort">
        <xsd:enumeration value="ApplicationForUsageOfBerthOrMooringFacilities">
        <xsd:enumeration value="ApplicationForVesselsEnteringIntoPortAreaInNight-Time">
        <xsd:enumeration value="ApprovedUnpricedBillOfQuantity">
        <xsd:enumeration value="ArrivalInformation">
        <xsd:enumeration value="ArrivalNoticeGoods">
        <xsd:enumeration value="AssortmentAgainstBlanket">
        <xsd:enumeration value="AtaCarnet">
        <xsd:enumeration value="AuthorizationToPlanAndShipOrders">
        <xsd:enumeration value="AuthorizationToPlanAndSuggestOrders">
        <xsd:enumeration value="AuthorityToProceed">
        <xsd:enumeration value="Bailment">
        <xsd:enumeration value="BailmentContract">
        <xsd:enumeration value="BalanceConfirmation">
        <xsd:enumeration value="BankersDraft">
        <xsd:enumeration value="BankersGuarantee">
        <xsd:enumeration value="BankingStatus">
        <xsd:enumeration value="BankToBankFundsTransfer">
        <xsd:enumeration value="BasicAgreement">
        <xsd:enumeration value="BasicOrderingAgreement">
        <xsd:enumeration value="Bidding">
        <xsd:enumeration value="BillandHold">
        <xsd:enumeration value="BillOfExchange">
        <xsd:enumeration value="BillOfLading">
        <xsd:enumeration value="BillOfLadingCopy">
        <xsd:enumeration value="BillOfLadingOriginal">
        <xsd:enumeration value="BlanketOrder">
        <xsd:enumeration value="BlanketOrderEstimatedQuantities">
        <xsd:enumeration value="BlanketPurchaseAgreement">
        <xsd:enumeration value="BookingConfirmation">
        <xsd:enumeration value="BookingRequest">
        <xsd:enumeration value="Bordereau">
        <xsd:enumeration value="BudgetaryQuote">
        <xsd:enumeration value="BuyAmericaCertificateOfCompliance">
        <xsd:enumeration value="Buying">
        <xsd:enumeration value="CallingForwardNotice">
        <xsd:enumeration value="CallOffDelivery">
        <xsd:enumeration value="CallOffOrder">
        <xsd:enumeration value="CampaignPriceSalesCatalogue">
        <xsd:enumeration value="CargoAcceptanceOrder">
        <xsd:enumeration value="CargoAnalysisVoyageReport">
        <xsd:enumeration value="CargoDeclarationArrival">
        <xsd:enumeration value="CargoDeclarationDeparture">
        <xsd:enumeration value="CargoManifest">
        <xsd:enumeration value="CargoMovementEventLog">
        <xsd:enumeration value="CargoMovementVoyageSummary">
        <xsd:enumeration value="CargoReleaseNotification">
        <xsd:enumeration value="CargoStatus">
        <xsd:enumeration value="CargoVesselDischargeOrder">
        <xsd:enumeration value="CargoVesselLoadingOrder">
        <xsd:enumeration value="CartageOrderLocalTransport">
        <xsd:enumeration value="CashPoolFinancialStatement">
        <xsd:enumeration value="CasingSanitaryCertificate">
        <xsd:enumeration value="CatalogOrder">
        <xsd:enumeration value="Certificate">
        <xsd:enumeration value="CertificateOfAnalysis">
        <xsd:enumeration value="CertificateOfConformity">
        <xsd:enumeration value="CertificateOfOrigin">
        <xsd:enumeration value="ApplicationForCertificateOfOrigin">
        <xsd:enumeration value="CertificateOfOriginFormGsp">
        <xsd:enumeration value="CertificateOfQuality">
        <xsd:enumeration value="CertificateOfQuantity">
        <xsd:enumeration value="CertificateOfRegistry">
        <xsd:enumeration value="CertificateOfSealingOfExportMeatLockers">
        <xsd:enumeration value="CertifiedCostAndPriceData">
        <xsd:enumeration value="CertifiedInspectionAndTestResults">
        <xsd:enumeration value="ChangeToContract">
        <xsd:enumeration value="ChangeToPurchaseOrder">
        <xsd:enumeration value="ChangeToRelease">
        <xsd:enumeration value="Chargeback">
        <xsd:enumeration value="ChargesNote">
        <xsd:enumeration value="CivilLiabilityForOilCertificate">
        <xsd:enumeration value="CloseOut">
        <xsd:enumeration value="ClosingStatementOfAnAccount">
        <xsd:enumeration value="CodeChangeRequest">
        <xsd:enumeration value="Co-InsuranceCedingBordereau">
        <xsd:enumeration value="CollateralAccount">
        <xsd:enumeration value="CollectionOrder">
        <xsd:enumeration value="CollectionPaymentAdvice">
        <xsd:enumeration value="CombinedCertificateOfValueAndOrigin">
        <xsd:enumeration value="CombinedTransportBillOfLadingMultimodalBillOfLading">
        <xsd:enumeration value="CombinedTransportDocumentGeneric">
        <xsd:enumeration value="CommercialAccountSummaryResponse">
        <xsd:enumeration value="CommercialDispute">
        <xsd:enumeration value="CommercialInvoice">
        <xsd:enumeration value="CommercialInvoiceWhichIncludesAPackingList">
        <xsd:enumeration value="CommissionNote">
        <xsd:enumeration value="CompositeDataElementChangeRequest">
        <xsd:enumeration value="CompositeDataElementRequest">
        <xsd:enumeration value="Confirmation">
        <xsd:enumeration value="ConsignmentInvoice">
        <xsd:enumeration value="ConsignmentOrder">
        <xsd:enumeration value="ConsignmentStatusReport">
        <xsd:enumeration value="ConsignmentUnpackReport">
        <xsd:enumeration value="ConsolidatedCreditNoteGoodsAndServices">
        <xsd:enumeration value="ConsolidatedInvoice">
        <xsd:enumeration value="ConsularInvoice">
        <xsd:enumeration value="ContainerDischargeList">
        <xsd:enumeration value="ContainerList">
        <xsd:enumeration value="ContainerManifestUnitPackingList">
        <xsd:enumeration value="ContainerOffHireNotice">
        <xsd:enumeration value="ContainerStrippingOrder">
        <xsd:enumeration value="ContainerStuffingOrder">
        <xsd:enumeration value="Contract">
        <xsd:enumeration value="ContractAwardNotification">
        <xsd:enumeration value="ContractBillOfQuantities">
        <xsd:enumeration value="ContractFundsStatusReport">
        <xsd:enumeration value="ContractSecurityClassificationSpecification">
        <xsd:enumeration value="ControlDocumentT5">
        <xsd:enumeration value="ConveyanceDeclarationArrival">
        <xsd:enumeration value="ConveyanceDeclarationCombined">
        <xsd:enumeration value="ConveyanceDeclarationDeparture">
        <xsd:enumeration value="CorporateSuperannuationContributionsAdvice">
        <xsd:enumeration value="CorporateSuperannuationMemberMaintenanceMessage">
        <xsd:enumeration value="CorrectedInvoice">
        <xsd:enumeration value="CostDataSummary">
        <xsd:enumeration value="CostPerformanceReport">
        <xsd:enumeration value="CostPerformanceReportFormat1">
        <xsd:enumeration value="CostPerformanceReportFormat2">
        <xsd:enumeration value="CostPerformanceReportFormat3">
        <xsd:enumeration value="CostPerformanceReportFormat4">
        <xsd:enumeration value="CostPerformanceReportFormat5">
        <xsd:enumeration value="CostScheduleStatusReport">
        <xsd:enumeration value="CoverNote">
        <xsd:enumeration value="CreditAdvice">
        <xsd:enumeration value="CreditCover">
        <xsd:enumeration value="CreditNote">
        <xsd:enumeration value="CreditNoteForPriceVariation">
        <xsd:enumeration value="CreditNoteRelatedToFinancialAdjustments">
        <xsd:enumeration value="CreditNoteRelatedToGoodsOrServices">
        <xsd:enumeration value="CrewListDeclaration">
        <xsd:enumeration value="CrewsEffectsDeclaration">
        <xsd:enumeration value="CrossDockingDespatchAdvice">
        <xsd:enumeration value="CrossDockingOrder">
        <xsd:enumeration value="CrossDockingServicesOrder">
        <xsd:enumeration value="CurrentAccount">
        <xsd:enumeration value="CustomerPaymentOrder">
        <xsd:enumeration value="CustomsClearanceNotice">
        <xsd:enumeration value="CustomsCrewAndConveyance">
        <xsd:enumeration value="CustomsDeclarationPostParcels">
        <xsd:enumeration value="CustomsDeclarationForCargoExamination">
        <xsd:enumeration value="CustomsDeclarationForCargoExaminationAlternate">
        <xsd:enumeration value="CustomsDeclarationWithCommercialAndItemDetail">
        <xsd:enumeration value="CustomsDeclarationWithoutCommercialDetail">
        <xsd:enumeration value="CustomsDeclarationWithoutItemDetail">
        <xsd:enumeration value="CustomsDeliveryNote">
        <xsd:enumeration value="CustomsDocumentsExpirationNotice">
        <xsd:enumeration value="CustomsImmediateReleaseDeclaration">
        <xsd:enumeration value="CustomsInvoice">
        <xsd:enumeration value="CustomsManifest">
        <xsd:enumeration value="CustomsSummaryDeclarationWithCommercialDetailAlternate">
        <xsd:enumeration value="CustomsSummaryDeclarationWithoutCommercialDetailAlternate">
        <xsd:enumeration value="DamageCertification">
        <xsd:enumeration value="DangerousGoodsDeclaration">
        <xsd:enumeration value="DangerousGoodsList">
        <xsd:enumeration value="DebitAdvice">
        <xsd:enumeration value="DebitNote">
        <xsd:enumeration value="DebitNoteRelatedToFinancialAdjustments">
        <xsd:enumeration value="DebitNoteRelatedToGoodsOrServices">
        <xsd:enumeration value="DeclarationOfOrigin">
        <xsd:enumeration value="DeclarationRegardingTheInwardAndOutwardMovementOfVessel">
        <xsd:enumeration value="DelcredereCreditNote">
        <xsd:enumeration value="DelcredereInvoice">
        <xsd:enumeration value="DeliveryForecast">
        <xsd:enumeration value="DeliveryInstructions">
        <xsd:enumeration value="DeliveryJustInTime">
        <xsd:enumeration value="DeliveryNote">
        <xsd:enumeration value="DeliveryNoticeGoods">
        <xsd:enumeration value="DeliveryNoticeRailTransport">
        <xsd:enumeration value="DeliveryOrder">
        <xsd:enumeration value="DeliveryRelease">
        <xsd:enumeration value="DeliverySchedule">
        <xsd:enumeration value="DeliveryScheduleResponse">
        <xsd:enumeration value="DeliveryVerificationCertificate">
        <xsd:enumeration value="DeratDocument">
        <xsd:enumeration value="DespatchAdvice">
        <xsd:enumeration value="DespatchNotePostParcels">
        <xsd:enumeration value="DespatchNoteModelT">
        <xsd:enumeration value="DespatchNoteModelT1">
        <xsd:enumeration value="DespatchNoteModelT2">
        <xsd:enumeration value="DespatchNoteModelT2L">
        <xsd:enumeration value="DespatchOrder">
        <xsd:enumeration value="DirectPaymentValuation">
        <xsd:enumeration value="DirectPaymentValuationRequest">
        <xsd:enumeration value="DirectShip">
        <xsd:enumeration value="DocumentaryCredit">
        <xsd:enumeration value="DocumentaryCreditAcceptanceAdvice">
        <xsd:enumeration value="DocumentaryCreditAmendment">
        <xsd:enumeration value="DocumentaryCreditAmendmentInformation">
        <xsd:enumeration value="DocumentaryCreditAmendmentNotification">
        <xsd:enumeration value="DocumentaryCreditApplication">
        <xsd:enumeration value="DocumentaryCreditCollectionInstruction">
        <xsd:enumeration value="DocumentaryCreditIssuanceInformation">
        <xsd:enumeration value="DocumentaryCreditLetterOfIndemnity">
        <xsd:enumeration value="DocumentaryCreditNegotiationAdvice">
        <xsd:enumeration value="DocumentaryCreditNotification">
        <xsd:enumeration value="DocumentaryCreditPaymentAdvice">
        <xsd:enumeration value="DocumentaryCreditTransferAdvice">
        <xsd:enumeration value="DocumentResponseCustoms">
        <xsd:enumeration value="DocumentsPresentationForm">
        <xsd:enumeration value="DraftBillOfQuantity">
        <xsd:enumeration value="Drawing">
        <xsd:enumeration value="DrivingLicenceInternational">
        <xsd:enumeration value="DrivingLicenceNational">
        <xsd:enumeration value="Dropship">
        <xsd:enumeration value="EcCarnet">
        <xsd:enumeration value="EdiAssociatedObjectAdministrationMessage">
        <xsd:enumeration value="EmbargoPermit">
        <xsd:enumeration value="EmergencyOrder">
        <xsd:enumeration value="EmptyContainerBill">
        <xsd:enumeration value="EmptyContainerDispositionOrder">
        <xsd:enumeration value="EndUseAuthorization">
        <xsd:enumeration value="Enquiry">
        <xsd:enumeration value="ErrorResponseCustoms">
        <xsd:enumeration value="EscortOfficialRecognition">
        <xsd:enumeration value="EstimatedPricedBillOfQuantity">
        <xsd:enumeration value="Eur1CertificateOfOrigin">
        <xsd:enumeration value="ExceptionalOrder">
        <xsd:enumeration value="ExchangeControlDeclarationImport">
        <xsd:enumeration value="ExchangeControlDeclarationExport">
        <xsd:enumeration value="ExciseCertificate">
        <xsd:enumeration value="ExportLicence">
        <xsd:enumeration value="ApplicationForExportLicence">
        <xsd:enumeration value="ExtendedCreditAdvice">
        <xsd:enumeration value="ExtendedPaymentOrder">
        <xsd:enumeration value="Extra-CommunityTradeStatisticalDeclaration">
        <xsd:enumeration value="FabricateAndHold">
        <xsd:enumeration value="FactoredCreditNote">
        <xsd:enumeration value="FactoredInvoice">
        <xsd:enumeration value="FederalLabelApproval">
        <xsd:enumeration value="FinalPaymentRequestBasedOnCompletionOfWork">
        <xsd:enumeration value="FinancialStatementOfAccount">
        <xsd:enumeration value="FirstSampleTestReport">
        <xsd:enumeration value="ForeignExchangePermit">
        <xsd:enumeration value="FormulaFunds">
        <xsd:enumeration value="ForwardersAdviceToExporter">
        <xsd:enumeration value="ForwardersAdviceToImportAgent">
        <xsd:enumeration value="ForwardersBillOfLading">
        <xsd:enumeration value="ForwardersCertificateOfReceipt">
        <xsd:enumeration value="ForwardersCertificateOfTransport">
        <xsd:enumeration value="ForwardersInvoice">
        <xsd:enumeration value="ForwardersWarehouseReceipt">
        <xsd:enumeration value="ForwardingInstructions">
        <xsd:enumeration value="FreePass">
        <xsd:enumeration value="FreightInvoice">
        <xsd:enumeration value="FreightManifest">
        <xsd:enumeration value="FumigationCertificate">
        <xsd:enumeration value="GatePass">
        <xsd:enumeration value="GeneralCargoSummaryManifestReport">
        <xsd:enumeration value="GeneralResponseCustoms">
        <xsd:enumeration value="GoodsControlCertificate">
        <xsd:enumeration value="GoodsDeclarationForCustomsTransit">
        <xsd:enumeration value="GoodsDeclarationForExportation">
        <xsd:enumeration value="GoodsDeclarationForHomeUse">
        <xsd:enumeration value="GoodsDeclarationForImportation">
        <xsd:enumeration value="GoodsReceipt">
        <xsd:enumeration value="GoodsReceiptCarriage">
        <xsd:enumeration value="GovernmentContract">
        <xsd:enumeration value="Grant">
        <xsd:enumeration value="HandlingOrder">
        <xsd:enumeration value="HireInvoice">
        <xsd:enumeration value="HireOrder">
        <xsd:enumeration value="HorsemeatSanitaryCertificate">
        <xsd:enumeration value="HouseBillOfLading">
        <xsd:enumeration value="HouseWaybill">
        <xsd:enumeration value="IdentityCard">
        <xsd:enumeration value="ImpendingArrival">
        <xsd:enumeration value="ImplementationGuideline">
        <xsd:enumeration value="ImportLicence">
        <xsd:enumeration value="ApplicationForImportLicence">
        <xsd:enumeration value="IndefiniteDeliveryDefiniteQuantity">
        <xsd:enumeration value="IndefiniteDeliveryDefiniteQuantityContract">
        <xsd:enumeration value="IndefiniteDeliveryIndefiniteQuantity">
        <xsd:enumeration value="IndefiniteDeliveryIndefiniteQuantityContract">
        <xsd:enumeration value="IndustrySuperannuationContributionsAdvice">
        <xsd:enumeration value="IndustrySuperannuationMemberMaintenanceMessage">
        <xsd:enumeration value="InedibleSanitaryCertificate">
        <xsd:enumeration value="InformationCopy">
        <xsd:enumeration value="InlandWaterwayBillOfLading">
        <xsd:enumeration value="Inquiry">
        <xsd:enumeration value="InspectionCertificate">
        <xsd:enumeration value="InspectionReport">
        <xsd:enumeration value="InspectionRequest">
        <xsd:enumeration value="InstructionsForBankTransfer">
        <xsd:enumeration value="InstructionToCollect">
        <xsd:enumeration value="InsuranceCertificate">
        <xsd:enumeration value="InsuranceDeclarationSheetBordereau">
        <xsd:enumeration value="InsurancePolicy">
        <xsd:enumeration value="InsurersInvoice">
        <xsd:enumeration value="InterimApplicationForPayment">
        <xsd:enumeration value="InternalTransportOrder">
        <xsd:enumeration value="IntrastatDeclaration">
        <xsd:enumeration value="InventoryAdjustmentStatusReport">
        <xsd:enumeration value="InventoryMovementAdvice">
        <xsd:enumeration value="InventoryReport">
        <xsd:enumeration value="InventoryStatusAdvice">
        <xsd:enumeration value="InvoicingDataSheet">
        <xsd:enumeration value="ItemsBookedToAFinancialAccountReport">
        <xsd:enumeration value="JobLot">
        <xsd:enumeration value="KanbanSchedule">
        <xsd:enumeration value="Lease">
        <xsd:enumeration value="LeaseBlanketAgreement">
        <xsd:enumeration value="LeaseInvoice">
        <xsd:enumeration value="LeaseOrder">
        <xsd:enumeration value="LegalStatementOfAnAccount">
        <xsd:enumeration value="LetterContract">
        <xsd:enumeration value="LetterOfIndemnityForNon-SurrenderOfBillOfLading">
        <xsd:enumeration value="LetterOfIntent">
        <xsd:enumeration value="LifeInsurancePayrollDeductionsAdvice">
        <xsd:enumeration value="ListingStatementOfAnAccount">
        <xsd:enumeration value="LoadlineDocument">
        <xsd:enumeration value="Loan">
        <xsd:enumeration value="LowValuePaymentOrder">
        <xsd:enumeration value="MakeOrBuyPlan">
        <xsd:enumeration value="ManufacturingInstructions">
        <xsd:enumeration value="ManufacturingSpecification">
        <xsd:enumeration value="MaritimeDeclarationOfHealth">
        <xsd:enumeration value="MasterAirWaybill">
        <xsd:enumeration value="MasterBillOfLading">
        <xsd:enumeration value="MaterialInspectionAndReceivingReport">
        <xsd:enumeration value="MateSReceipt">
        <xsd:enumeration value="MeansOfTransportAdvice">
        <xsd:enumeration value="MeansOfTransportationAvailabilityInformation">
        <xsd:enumeration value="MeansOfTransportationScheduleInformation">
        <xsd:enumeration value="MeatAndMeatBy-ProductsSanitaryCertificate">
        <xsd:enumeration value="MeatFoodProductsSanitaryCertificate">
        <xsd:enumeration value="MessageInDevelopmentRequest">
        <xsd:enumeration value="MeteredServicesInvoice">
        <xsd:enumeration value="MillCertificate">
        <xsd:enumeration value="ModificationOfExistingMessage">
        <xsd:enumeration value="MovementCertificateATr1">
        <xsd:enumeration value="MultidropOrder">
        <xsd:enumeration value="MultimodalCombinedTransportDocumentGeneric">
        <xsd:enumeration value="MultimodalTransportDocumentGeneric">
        <xsd:enumeration value="MultiplePaymentOrder">
        <xsd:enumeration value="NameProductPlate">
        <xsd:enumeration value="NewCodeRequest">
        <xsd:enumeration value="NewMessageRequest">
        <xsd:enumeration value="NewOrder">
        <xsd:enumeration value="NewProductIntroduction">
        <xsd:enumeration value="NewStoreOpening">
        <xsd:enumeration value="Non-NegotiableMaritimeTransportDocumentGeneric">
        <xsd:enumeration value="Non-Pre-AuthorisedDirectDebit">
        <xsd:enumeration value="Non-Pre-AuthorisedDirectDebitRequest">
        <xsd:enumeration value="NotForSale">
        <xsd:enumeration value="NoticeOfCircumstancesPreventingDeliveryGoods">
        <xsd:enumeration value="NoticeOfCircumstancesPreventingTransportGoods">
        <xsd:enumeration value="NotificationOfEmergencyShiftingFromTheDesignatedPlaceInPort">
        <xsd:enumeration value="NotificationOfUsageOfBerthOrMooringFacilities">
        <xsd:enumeration value="OfferQuotation">
        <xsd:enumeration value="OperatingInstructions">
        <xsd:enumeration value="OpticalCharacterReadingPayment">
        <xsd:enumeration value="Order">
        <xsd:enumeration value="OrderStatusEnquiry">
        <xsd:enumeration value="OrderStatusReport">
        <xsd:enumeration value="PackageResponseCustoms">
        <xsd:enumeration value="PackingInstructions">
        <xsd:enumeration value="PackingList">
        <xsd:enumeration value="PartialInvoice">
        <xsd:enumeration value="PartyInformation">
        <xsd:enumeration value="PassengerList">
        <xsd:enumeration value="Passport">
        <xsd:enumeration value="PaymentBond">
        <xsd:enumeration value="PaymentOrder">
        <xsd:enumeration value="PaymentOrPerformanceBond">
        <xsd:enumeration value="PaymentRequestForCompletedUnits">
        <xsd:enumeration value="PaymentValuation">
        <xsd:enumeration value="PaymentValuationForUnscheduledItems">
        <xsd:enumeration value="PerformanceBond">
        <xsd:enumeration value="PharmaceuticalSanitaryCertificate">
        <xsd:enumeration value="PhytosanitaryCertificate">
        <xsd:enumeration value="PickUpNotice">
        <xsd:enumeration value="PortChargesDocuments">
        <xsd:enumeration value="PostReceipt">
        <xsd:enumeration value="PoultrySanitaryCertificate">
        <xsd:enumeration value="PreadviceOfACredit">
        <xsd:enumeration value="PreAuthorizedDirectDebit">
        <xsd:enumeration value="PreAuthorizedDirectDebitRequest">
        <xsd:enumeration value="PreferenceCertificateOfOrigin">
        <xsd:enumeration value="PreliminaryCreditAssessment">
        <xsd:enumeration value="PreliminarySalesReport">
        <xsd:enumeration value="PrepaymentInvoice">
        <xsd:enumeration value="PreviousCustomsDocumentMessage">
        <xsd:enumeration value="PriceSalesCatalogue">
        <xsd:enumeration value="PriceSalesCatalogueResponse">
        <xsd:enumeration value="PricedAlternateTenderBillOfQuantity">
        <xsd:enumeration value="PricedTenderBoq">
        <xsd:enumeration value="PriceNegotiationResult">
        <xsd:enumeration value="PriceVariationInvoice">
        <xsd:enumeration value="ProcessDataReport">
        <xsd:enumeration value="ProductDataMessage">
        <xsd:enumeration value="ProductPerformanceReport">
        <xsd:enumeration value="ProductSpecificationReport">
        <xsd:enumeration value="ProformaInvoice">
        <xsd:enumeration value="ProgressiveDischargeReport">
        <xsd:enumeration value="ProjectMasterPlan">
        <xsd:enumeration value="ProjectMasterSchedule">
        <xsd:enumeration value="ProjectPlan">
        <xsd:enumeration value="ProjectPlanningAvailableResources">
        <xsd:enumeration value="ProjectPlanningCalendar">
        <xsd:enumeration value="ProjectProductionPlan">
        <xsd:enumeration value="ProjectRecoveryPlan">
        <xsd:enumeration value="ProjectSchedule">
        <xsd:enumeration value="PromissoryNote">
        <xsd:enumeration value="Promotion">
        <xsd:enumeration value="ProvisionalPaymentValuation">
        <xsd:enumeration value="PurchaseOrder">
        <xsd:enumeration value="PurchaseOrderChangeRequest">
        <xsd:enumeration value="PurchaseOrderResponse">
        <xsd:enumeration value="PurchasingSpecification">
        <xsd:enumeration value="QualityDataMessage">
        <xsd:enumeration value="QuantityValuation">
        <xsd:enumeration value="QuantityValuationRequest">
        <xsd:enumeration value="Query">
        <xsd:enumeration value="QuotaPriorAllocationCertificate">
        <xsd:enumeration value="RailConsignmentNoteGenericTerm">
        <xsd:enumeration value="ReadyForDespatchAdvice">
        <xsd:enumeration value="Reassignment">
        <xsd:enumeration value="ReceiptCustoms">
        <xsd:enumeration value="RechargingDocument">
        <xsd:enumeration value="RecordUpdateService">
        <xsd:enumeration value="RegionalAppellationCertificate">
        <xsd:enumeration value="RegistrationChange">
        <xsd:enumeration value="RegistrationDocument">
        <xsd:enumeration value="RegistrationRenewal">
        <xsd:enumeration value="RejectedDirectDebit">
        <xsd:enumeration value="RelatedDocument">
        <xsd:enumeration value="ReleaseAgainstAssortment">
        <xsd:enumeration value="ReleaseOrDeliveryOrder">
        <xsd:enumeration value="RemittanceAdvice">
        <xsd:enumeration value="RenewalOrder">
        <xsd:enumeration value="Rental">
        <xsd:enumeration value="Reorder">
        <xsd:enumeration value="RepairAndReturn">
        <xsd:enumeration value="RepairOrder">
        <xsd:enumeration value="ReportOfTransactionsForInformationOnly">
        <xsd:enumeration value="ReportOfTransactionsWhichNeedFurtherInformationFromTheReceiver">
        <xsd:enumeration value="RequestForAnAmendmentOfADocumentaryCredit">
        <xsd:enumeration value="RequestForDeliveryInstructions">
        <xsd:enumeration value="RequestForFinancialCancellation">
        <xsd:enumeration value="RequestForPayment">
        <xsd:enumeration value="RequestForQuote">
        <xsd:enumeration value="RequestForStatisticalData">
        <xsd:enumeration value="RequestForTransfer">
        <xsd:enumeration value="Requirements">
        <xsd:enumeration value="RequirementsContract">
        <xsd:enumeration value="Re-SendingConsignmentNote">
        <xsd:enumeration value="ResponseToAnAmendmentOfADocumentaryCredit">
        <xsd:enumeration value="ResponseToATradeStatisticsMessage">
        <xsd:enumeration value="ResponseToPreviousBankingStatusMessage">
        <xsd:enumeration value="ResponseToQuery">
        <xsd:enumeration value="ResponseToRegistration">
        <xsd:enumeration value="Restow">
        <xsd:enumeration value="ResumeWorkOrder">
        <xsd:enumeration value="RetailerPrecommitment">
        <xsd:enumeration value="ReversalOfCredit">
        <xsd:enumeration value="ReversalOfDebit">
        <xsd:enumeration value="RoadConsignmentNote">
        <xsd:enumeration value="RoadList-Smgs">
        <xsd:enumeration value="RushOrder">
        <xsd:enumeration value="SafetyAndHazardDataSheet">
        <xsd:enumeration value="SafetyOfEquipmentCertificate">
        <xsd:enumeration value="SafetyOfRadioCertificate">
        <xsd:enumeration value="SafetyOfShipCertificate">
        <xsd:enumeration value="SampleOrder">
        <xsd:enumeration value="SanitaryCertificate">
        <xsd:enumeration value="SeasonTicket">
        <xsd:enumeration value="SeaWaybill">
        <xsd:enumeration value="SegmentChangeRequest">
        <xsd:enumeration value="SegmentRequest">
        <xsd:enumeration value="SelfBilledCreditNote">
        <xsd:enumeration value="Self-BilledInvoice">
        <xsd:enumeration value="SequencedDeliverySchedule">
        <xsd:enumeration value="ServiceDirectoryDefinition">
        <xsd:enumeration value="SettlementOfALetterOfCredit">
        <xsd:enumeration value="ShippedOrder">
        <xsd:enumeration value="ShippersLetterOfInstructionsAir">
        <xsd:enumeration value="ShippingInstructions">
        <xsd:enumeration value="ShippingNote">
        <xsd:enumeration value="ShipsStoresDeclaration">
        <xsd:enumeration value="SimpleDataElementChangeRequest">
        <xsd:enumeration value="SimpleDataElementRequest">
        <xsd:enumeration value="SingleAdministrativeDocument">
        <xsd:enumeration value="SparePartsOrder">
        <xsd:enumeration value="SpecialOrder">
        <xsd:enumeration value="SpotOrder">
        <xsd:enumeration value="StandAloneOrder">
        <xsd:enumeration value="StandingOrder">
        <xsd:enumeration value="StatementOfAccountMessage">
        <xsd:enumeration value="StatisticalAndOtherAdministrativeInternalDocuments">
        <xsd:enumeration value="StatisticalData">
        <xsd:enumeration value="StatisticalDefinitions">
        <xsd:enumeration value="StatisticalDocumentExport">
        <xsd:enumeration value="StatisticalDocumentImport">
        <xsd:enumeration value="StatusInformation">
        <xsd:enumeration value="StatusReport">
        <xsd:enumeration value="StopWork">
        <xsd:enumeration value="StoresRequisition">
        <xsd:enumeration value="SubcontractorPlan">
        <xsd:enumeration value="SubstituteAirWaybill">
        <xsd:enumeration value="SummarySalesReport">
        <xsd:enumeration value="SupplementaryDocumentForApplicationForCargoOperationOfDangerousGoods">
        <xsd:enumeration value="SupplementaryDocumentForApplicationForTransportOfDangerousGoods">
        <xsd:enumeration value="SupplyOrServiceOrder">
        <xsd:enumeration value="SwapOrder">
        <xsd:enumeration value="TankerBillOfLading">
        <xsd:enumeration value="TaskOrder">
        <xsd:enumeration value="TaxCalculationConfirmationResponseCustoms">
        <xsd:enumeration value="TaxDeclarationGeneral">
        <xsd:enumeration value="TaxDeclarationValueAddedTax">
        <xsd:enumeration value="TaxDemand">
        <xsd:enumeration value="TaxInvoice">
        <xsd:enumeration value="TaxNotification">
        <xsd:enumeration value="Termination">
        <xsd:enumeration value="TestReport">
        <xsd:enumeration value="ThroughBillOfLading">
        <xsd:enumeration value="TifForm">
        <xsd:enumeration value="TimeMaterials">
        <xsd:enumeration value="TirCarnet">
        <xsd:enumeration value="TollConversionOrder">
        <xsd:enumeration value="TrackingNumberAssignmentReport">
        <xsd:enumeration value="TradeData">
        <xsd:enumeration value="TransportCargoReleaseOrder">
        <xsd:enumeration value="TransportDepartureReport">
        <xsd:enumeration value="TransportDischargeInstruction">
        <xsd:enumeration value="TransportDischargeReport">
        <xsd:enumeration value="TransportEmergencyCard">
        <xsd:enumeration value="TransportEmptyEquipmentAdvice">
        <xsd:enumeration value="TransportEquipmentAcceptanceOrder">
        <xsd:enumeration value="TransportEquipmentDamageReport">
        <xsd:enumeration value="TransportEquipmentDeliveryNotice">
        <xsd:enumeration value="TransportEquipmentDirectInterchangeReport">
        <xsd:enumeration value="TransportEquipmentEmptyReleaseInstruction">
        <xsd:enumeration value="TransportEquipmentImpendingArrivalAdvice">
        <xsd:enumeration value="TransportEquipmentMaintenanceAndRepairNotice">
        <xsd:enumeration value="TransportEquipmentMaintenanceAndRepairWorkAuthorization">
        <xsd:enumeration value="TransportEquipmentMaintenanceAndRepairWorkEstimateAdvice">
        <xsd:enumeration value="TransportEquipmentMaintenanceAndRepairWorkEstimateOrder">
        <xsd:enumeration value="TransportEquipmentMovementInstruction">
        <xsd:enumeration value="TransportEquipmentMovementReport">
        <xsd:enumeration value="TransportEquipmentOffHireReport">
        <xsd:enumeration value="TransportEquipmentOffHireRequest">
        <xsd:enumeration value="TransportEquipmentOnHireOrder">
        <xsd:enumeration value="TransportEquipmentOnHireReport">
        <xsd:enumeration value="TransportEquipmentOnHireRequest">
        <xsd:enumeration value="TransportEquipmentPackingInstruction">
        <xsd:enumeration value="TransportEquipmentPickUpAvailabilityConfirmation">
        <xsd:enumeration value="TransportEquipmentPickUpAvailabilityRequest">
        <xsd:enumeration value="TransportEquipmentPickUpReport">
        <xsd:enumeration value="TransportEquipmentShiftReport">
        <xsd:enumeration value="TransportEquipmentSpecialServiceInstruction">
        <xsd:enumeration value="TransportEquipmentStatusChangeReport">
        <xsd:enumeration value="TransportEquipmentStockReport">
        <xsd:enumeration value="TransportEquipmentSurveyOrder">
        <xsd:enumeration value="TransportEquipmentSurveyOrderResponse">
        <xsd:enumeration value="TransportEquipmentSurveyReport">
        <xsd:enumeration value="TransportEquipmentUnpackingInstruction">
        <xsd:enumeration value="TransportEquipmentUnpackingReport">
        <xsd:enumeration value="TransportLoadingInstruction">
        <xsd:enumeration value="TransportLoadingReport">
        <xsd:enumeration value="TransportMovementGateInReport">
        <xsd:enumeration value="TransportMovementGateOutReport">
        <xsd:enumeration value="TransportStatusReport">
        <xsd:enumeration value="TransportStatusRequest">
        <xsd:enumeration value="TransshipmentDespatchAdvice">
        <xsd:enumeration value="TransshipmentOrder">
        <xsd:enumeration value="TreatmentNilOutturn">
        <xsd:enumeration value="TreatmentPersonalEffect">
        <xsd:enumeration value="TreatmentTimber">
        <xsd:enumeration value="TreatmentTimeUpUnderbond">
        <xsd:enumeration value="TreatmentUnderbondBySea">
        <xsd:enumeration value="UnderbondApproval">
        <xsd:enumeration value="UnderbondRequest">
        <xsd:enumeration value="UnitDown">
        <xsd:enumeration value="UnitedNationsStandardMessageRequest">
        <xsd:enumeration value="UnitExchange">
        <xsd:enumeration value="UniversalMultipurposeTransportDocument">
        <xsd:enumeration value="UnpricedBillOfQuantity">
        <xsd:enumeration value="UnshipPermit">
        <xsd:enumeration value="UrgentServiceRequest">
        <xsd:enumeration value="UserDirectoryDefinition">
        <xsd:enumeration value="VaccinationCertificate">
        <xsd:enumeration value="ValidatedPricedTender">
        <xsd:enumeration value="ValueDeclaration">
        <xsd:enumeration value="VesselUnpackReport">
        <xsd:enumeration value="VeterinaryCertificate">
        <xsd:enumeration value="WageDetermination">
        <xsd:enumeration value="WarehouseWarrant">
        <xsd:enumeration value="WarrantyOrder">
        <xsd:enumeration value="Waybill">
        <xsd:enumeration value="WeightCertificate">
        <xsd:enumeration value="WeightList">
        <xsd:enumeration value="WineCertificate">
        <xsd:enumeration value="WoolHealthCertificate">
        <xsd:enumeration value="WrittenInstructionsInConformanceWithAdrArticleNumber10385">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: OrderTypeType

OrderTypeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( OrderTypeCoded[OrderTypeCodeType] , OrderTypeCodedOther[xsd:string]? )

    Description: OrderTypeType comprises the creation of a purchase order that is sent for acceptance or rejection by a seller. A requisitioner, buyer, or buying organization can initiate an Order in response to a variety of factors in the electronic business arena, contracts, auctions, order requests, etc. A requisitioner, or buyer, can initiate a change to an already existing order. A seller uses the OrderResponse document to accept or reject an Order or a changed order.

    Elements:

    • OrderTypeCoded - defines the type of order. Typically the value is Stand Alone.
    • OrderTypeCodedOther - is used to provide a non-standard OrderTypeCode. This element is mandatory if the value of OrderTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="OrderTypeType">
    <xsd:sequence>
        <xsd:element name="OrderTypeCoded" type="OrderTypeCodeType">
        <xsd:element minOccurs="0" name="OrderTypeCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: PackageCharacteristicCodeType

PackageCharacteristicCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the characteristics of the package. This codelist is derived from X12 753 (packaging characteristic code).

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • CasingType
    • ShippingPackageLabeling
    • ShippingPackageSealing
    • ProductMarking
    • TypeofPackage
    • PackageSpecifications
    • PackageProtection
    • Tarping
    • PlatformOrSkidLocation
    • BearingPieceLocation
    • PlacementonCarrier
    • SpacingDirections
    • UnloadingDevice
    • UnloadingEquipment
    • ProductMarkingPattern
    • ProductMarkingLocation
    • PackageOrContainerMarkLocation
    • MarkingMethod
    • CoreCharacteristics
    • ReceivingFacilityLimitations
    • TaggingOrBarCodeInstructions
    • SkidOrPalletType

[^]Code Fragment

    <xsd:simpleType name="PackageCharacteristicCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="CasingType">
        <xsd:enumeration value="ShippingPackageLabeling">
        <xsd:enumeration value="ShippingPackageSealing">
        <xsd:enumeration value="ProductMarking">
        <xsd:enumeration value="TypeofPackage">
        <xsd:enumeration value="PackageSpecifications">
        <xsd:enumeration value="PackageProtection">
        <xsd:enumeration value="Tarping">
        <xsd:enumeration value="PlatformOrSkidLocation">
        <xsd:enumeration value="BearingPieceLocation">
        <xsd:enumeration value="PlacementonCarrier">
        <xsd:enumeration value="SpacingDirections">
        <xsd:enumeration value="UnloadingDevice">
        <xsd:enumeration value="UnloadingEquipment">
        <xsd:enumeration value="ProductMarkingPattern">
        <xsd:enumeration value="ProductMarkingLocation">
        <xsd:enumeration value="PackageOrContainerMarkLocation">
        <xsd:enumeration value="MarkingMethod">
        <xsd:enumeration value="CoreCharacteristics">
        <xsd:enumeration value="ReceivingFacilityLimitations">
        <xsd:enumeration value="TaggingOrBarCodeInstructions">
        <xsd:enumeration value="SkidOrPalletType">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: PackageCharacteristicType

PackageCharacteristicType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PackageCharacteristicCoded[PackageCharacteristicCodeType] , PackageCharacteristicCodedOther[xsd:string]? , PackageCharacteristicDescription[IdentifierType] )

    Description: PackageCharacteristicType contains the code and the description of the packaging characteristics.

    Elements:

    • PackageCharacteristicCoded - specifies the marking, packaging, loading and related characteristics being described.
    • PackageCharacteristicCodedOther - is used to provide a non-standard PackageCharacteristicCode. This element is mandatory if the value of PackageCharacteristicCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • PackageCharacteristicDescription - holds a code from an industry code list which provides specific data about the marking, packaging, or loading and unloading of a product.

[^]Code Fragment

    <xsd:complexType name="PackageCharacteristicType">
    <xsd:sequence>
        <xsd:element name="PackageCharacteristicCoded" type="PackageCharacteristicCodeType">
        <xsd:element minOccurs="0" name="PackageCharacteristicCodedOther" type="xsd:string">
        <xsd:element name="PackageCharacteristicDescription" type="IdentifierType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PackageDescriptionType

PackageDescriptionType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ListOfPackageIdentifier[ListOfPackageIdentifierType]? , ContainerCounter[xsd:string]? , LoadOrderCounter[xsd:int]? )

    Description: PackageDescriptionType identifies specific information relating to an individual package. Includes the package identifier, the container counter, and the load order counter.

    Elements:

    • ListOfPackageIdentifier - is a list of the identifiers for the individual package.
    • ContainerCounter - identifies the order in which this package was placed inside it's container. Can also be used to identify locations in a compartmentalized tank car or a pallet, such 3p or 2nd from brake.
    • LoadOrderCounter - identifies the package sequence with respect to its location to the inner and outer packages.

[^]Code Fragment

    <xsd:complexType name="PackageDescriptionType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ListOfPackageIdentifier" type="ListOfPackageIdentifierType">
        <xsd:element minOccurs="0" name="ContainerCounter" type="xsd:string">
        <xsd:element minOccurs="0" name="LoadOrderCounter" type="xsd:int">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PackageDetailType

PackageDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PackageType[PackageTypeType] , NumberOfPackages[xsd:int] , ListOfPackage[ListOfPackageType]? )

    Description: PackageDetailType is the packaging information at the detail level for the items, packages, and equipment. This also provides information on hazardous materials, returnable containers, and marks and numbers. This is used to describe a collection of packages of the same type. For instance, a collection of multiple pallets would be described by one PackageDetail element. The PackageDetail element is recursive to allow for sub packaging descriptions. For instance, if a collection of boxes are contained on a pallet, the first recurrence of the PackageDetail element would describe the boxes that are contained on the pallet.

    Elements:

    • PackageType - is a container element that identifies and describes the kind of package that the PackageDetail element represents.
    • NumberOfPackages - identifies the number of packages that are being described by the PackageDetail element. For example, if the PackageDetail element is describing five pallets, then the NumberOfPackages would be 5.
    • ListOfPackage - is used to describe the specifics of one or more packages being described by the PackageDetail element.

[^]Code Fragment

    <xsd:complexType name="PackageDetailType">
    <xsd:sequence>
        <xsd:element name="PackageType" type="PackageTypeType">
        <xsd:element name="NumberOfPackages" type="xsd:int">
        <xsd:element minOccurs="0" name="ListOfPackage" type="ListOfPackageType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PackageDocType

PackageDocType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( DocumentTitle[xsd:string]? )

    Attribute:Name: DocumentTypeCoded, Type: DocumentTypeCodeType, Use: 'required'
    Attribute:Name: DocumentTypeCodedOther, Type: xsd:string, Use: 'optional'

    Description: PackageDocType describes a document that is included with a package.

    Elements:

    • DocumentTitle - holds the title of the loose document.
    Attributes:
    • DocumentTypeCoded - contains the code for the loose document.
    • DocumentTypeCodedOther - is used to provide a non-standard

[^]Code Fragment

    <xsd:complexType name="PackageDocType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="DocumentTitle" type="xsd:string">
    </xsd:sequence>
    <xsd:attribute name="DocumentTypeCoded" type="DocumentTypeCodeType" use="required">
    <xsd:attribute name="DocumentTypeCodedOther" type="xsd:string" use="optional">
</xsd:complexType>


simpleType definition: PackageIdentifierCodeType

PackageIdentifierCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the type of barcode that is used to identify a package.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • EAN8OrEAN13Barcoded
    • ITF14OrITF6Barcoded
    • UCCOrEAN128Barcoded
    • ADR

[^]Code Fragment

    <xsd:simpleType name="PackageIdentifierCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="EAN8OrEAN13Barcoded">
        <xsd:enumeration value="ITF14OrITF6Barcoded">
        <xsd:enumeration value="UCCOrEAN128Barcoded">
        <xsd:enumeration value="ADR">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: PackageIdentifierType

PackageIdentifierType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PackageIdentifierCoded[PackageIdentifierCodeType] , PackageIdentifierCodedOther[xsd:string]? , PackageIdentifierValue[xsd:string]? )

    Description: PackageIdentifierType is the identifier on the package that is unique in relation to other packages.

    Elements:

    • PackageIdentifierCoded - contains the identifier on the package.
    • PackageIdentifierCodedOther - is used to provide a non-standard PackageIdentifierCode. This element is mandatory if the value of PackageIdentifierCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • PackageIdentifierValue - identifies the value of the identifier. This should be the unique value.

[^]Code Fragment

    <xsd:complexType name="PackageIdentifierType">
    <xsd:sequence>
        <xsd:element name="PackageIdentifierCoded" type="PackageIdentifierCodeType">
        <xsd:element minOccurs="0" name="PackageIdentifierCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="PackageIdentifierValue" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PackageItemReferenceType

PackageItemReferenceType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( LineItemReference[xsd:string] , Quantity[QuantityType]? , ListOfReferenceCoded[ListOfReferenceCodedType]? )

    Description: PackageItemReferenceType provides a mean to reference an item, and the amount of that item that is contained in a package.

    Elements:

    • LineItemReference - references a line item number within the reference. This is assumed to be the buyer's line item number.
    • Quantity - is the quantity of the item referenced in the package, or the quantity of the itme per package, depending on the use. If this element is not used, the entire amount of the item is assumed to be contained in the package
    • ListOfReferenceCoded - contains any other references pertaining to the item contained within the package.

[^]Code Fragment

    <xsd:complexType name="PackageItemReferenceType">
    <xsd:sequence>
        <xsd:element name="LineItemReference" type="xsd:string">
        <xsd:element minOccurs="0" name="Quantity" type="QuantityType">
        <xsd:element minOccurs="0" name="ListOfReferenceCoded" type="ListOfReferenceCodedType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: PackageMarkCodeType

PackageMarkCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code list is derived from EDIFACT 4233 and 7405 and X12 88

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • BuyersInstructions - Markings as specified by the buyer.
    • Carrier-AssignedPackageIdNumber
    • CarriersInstructions - Markings as specified by carrier.
    • DoNotMarkSuppliersCompanyName
    • EntireShipment - Markings refer to the entire shipment.
    • IndustryInstructions - Markings as specified by industry.
    • LegalRequirements - Markings as specified by law.
    • LineItemOnly - Exclusive reference markings for this line.
    • MarkAdditionallyCustomersArticleDescription
    • MarkArticleNumberCustomer
    • MarkBatchNumber
    • MarkCaseNumber - Case numbers to be used for marking.
    • MarkCustomersCompanyName
    • MarkCustomersReferences
    • MarkDateOfProduction
    • MarkExclusivelyCustomersArticleDescription
    • MarkExpiryDate
    • MarkFreeText
    • MarkGrossWeight
    • MarkNetWeight
    • MarkPackagesDimensions
    • MarkRunningNumberOfPackages
    • MarkSerialShippingContainerCode - Requests the marking of the serial shipping container code to the transport container or packaging.
    • MarkSupplierNumber
    • MarkTareWeight
    • MasterCartonNumber
    • OriginatorAssigned
    • PalletConfigurationNumber
    • PalletNumber
    • PreMarkedByBuyer
    • ReceiverAssignedDropZone
    • Self-IdentifyingContainerViaRadioFrequencyIdDevice
    • SellersInstructions - Markings as specified by the seller.
    • ShipperAssigned - Markings to identify a shipment, package or carton as assigned by shipper.
    • Shipper-AssignedCaseNumber
    • ShipperAssignedRollNumber - Markings to identify a roll as assigned by the shipper.
    • ShipperAssignedSkidNumber - Markings used to identify a skid as assigned by shipper.
    • SSCC-18
    • SSCC-18AndApplicationIdentifier
    • UPCShippingContainerCode
    • UCCOrEAN128ApplicationIdentifierAndData
    • UniformCodeCouncilFormat - Markings according to UCC format are required. System of coding products where by each item/multipack case type is uniquely identified. A unique manufacturer Id is assigned by the UCC.
    • UPCConsumerPackageCode-1-5-5-1

[^]Code Fragment

    <xsd:simpleType name="PackageMarkCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="BuyersInstructions">
        <xsd:enumeration value="Carrier-AssignedPackageIdNumber">
        <xsd:enumeration value="CarriersInstructions">
        <xsd:enumeration value="DoNotMarkSuppliersCompanyName">
        <xsd:enumeration value="EntireShipment">
        <xsd:enumeration value="IndustryInstructions">
        <xsd:enumeration value="LegalRequirements">
        <xsd:enumeration value="LineItemOnly">
        <xsd:enumeration value="MarkAdditionallyCustomersArticleDescription">
        <xsd:enumeration value="MarkArticleNumberCustomer">
        <xsd:enumeration value="MarkBatchNumber">
        <xsd:enumeration value="MarkCaseNumber">
        <xsd:enumeration value="MarkCustomersCompanyName">
        <xsd:enumeration value="MarkCustomersReferences">
        <xsd:enumeration value="MarkDateOfProduction">
        <xsd:enumeration value="MarkExclusivelyCustomersArticleDescription">
        <xsd:enumeration value="MarkExpiryDate">
        <xsd:enumeration value="MarkFreeText">
        <xsd:enumeration value="MarkGrossWeight">
        <xsd:enumeration value="MarkNetWeight">
        <xsd:enumeration value="MarkPackagesDimensions">
        <xsd:enumeration value="MarkRunningNumberOfPackages">
        <xsd:enumeration value="MarkSerialShippingContainerCode">
        <xsd:enumeration value="MarkSupplierNumber">
        <xsd:enumeration value="MarkTareWeight">
        <xsd:enumeration value="MasterCartonNumber">
        <xsd:enumeration value="OriginatorAssigned">
        <xsd:enumeration value="PalletConfigurationNumber">
        <xsd:enumeration value="PalletNumber">
        <xsd:enumeration value="PreMarkedByBuyer">
        <xsd:enumeration value="ReceiverAssignedDropZone">
        <xsd:enumeration value="Self-IdentifyingContainerViaRadioFrequencyIdDevice">
        <xsd:enumeration value="SellersInstructions">
        <xsd:enumeration value="ShipperAssigned">
        <xsd:enumeration value="Shipper-AssignedCaseNumber">
        <xsd:enumeration value="ShipperAssignedRollNumber">
        <xsd:enumeration value="ShipperAssignedSkidNumber">
        <xsd:enumeration value="SSCC-18">
        <xsd:enumeration value="SSCC-18AndApplicationIdentifier">
        <xsd:enumeration value="UPCShippingContainerCode">
        <xsd:enumeration value="UCCOrEAN128ApplicationIdentifierAndData">
        <xsd:enumeration value="UniformCodeCouncilFormat">
        <xsd:enumeration value="UPCConsumerPackageCode-1-5-5-1">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: PackageMarkType

PackageMarkType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PackageMarkCoded[PackageMarkCodeType] , PackageMarkCodedOther[xsd:string]? , PackageMarkValue[xsd:string]? )

    Description: PackageMarkType specifies the type and value of markings on packages.

    Elements:

    • PackageMarkCoded - indicates how the package is marked or is to be marked.
    • PackageMarkCodedOther - is used to provide a non-standard PackageMarkCode. This element is mandatory if the value of PackageMarkCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • PackageMarkValue - is the value of the package mark, company or bar code, free text, etc.

[^]Code Fragment

    <xsd:complexType name="PackageMarkType">
    <xsd:sequence>
        <xsd:element name="PackageMarkCoded" type="PackageMarkCodeType">
        <xsd:element minOccurs="0" name="PackageMarkCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="PackageMarkValue" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PackageReferenceType

PackageReferenceType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( Quantity[QuantityType]? , PackageIDReference[xsd:int] , PackageReference[PackageReferenceType]? )

    Description: PackageReferenceType provides a reference for the packaging of the item.

    Elements:

    • Quantity - is the quantity of the item in the referenced package, or the quantity of the item per package, depending on the use.
    • PackageIDReference - references the package ID of the package containing the item found in the PackageDetail element.
    • PackageReference - provides a reference for the packaging of the item.

[^]Code Fragment

    <xsd:complexType name="PackageReferenceType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="Quantity" type="QuantityType">
        <xsd:element name="PackageIDReference" type="xsd:int">
        <xsd:element minOccurs="0" name="PackageReference" type="PackageReferenceType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PackageType

PackageType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PackageID[xsd:int] , ListOfItemReference[ListOfPackageItemReferenceType]? , ListOfPackageMark[ListOfPackageMarkType]? , ListOfPackageCharacteristic[ListOfPackageCharacteristicType]? , ListOfDimension[ListOfDimensionType]? , ListOfPackageDescription[ListOfPackageDescriptionType]? , ListOfDestinationReference[ListOfDestinationRefType]? , SpecialHandling[SpecialHandlingType]? , HazardousPackaging[HazardousType]? , AssociatedDocuments[AssociatedDocumentsType]? , ShippingInstructions[xsd:string]? , ReturnableContainerInfo[ReturnableContainerInfoType]? , PackageDetail[PackageDetailType]* )

    Description: PackageType contains information about the specifics of the collection of packages being described by the PackageDetail element. If the collection of packages all contain the same things, and there is no need to identify specifically which packages are contained in which, then only one Package element should be used. If the contents of the package differ or if there needs to be a distinction between which package a sub package is contained in, then multiple Package elements should be used.

    Elements:

    • PackageID - is used to identify a particular container within the document domain for references from line item detail. (package detail is a recursive element-packages contain other packages- consequently within each package the sub packages is determined by being nested inside its parent.
    • ListOfItemReference - lists all of the line items that are contained in the package. Only the ListOfReferenceCoded element in the ListOfOrderReferences element should be used to identify the line item with in the particualr doucment. This is not meant to reference, an Order document. To reference a line item, ReferenceTypeCoded should be set to "LineItemIdentifier" and PrimaryReference.Reference.RefNum set to the line item number of the item within the document.
    • ListOfPackageMark - indicates how the package should be marked. This could be used to identify common markings on a collection of packages.
    • ListOfPackageCharacteristic - describes the characteristics of a packages.
    • ListOfDimension - describes the physical dimensions of the package.
    • ListOfPackageDescription - is a list of package descriptions used to identify individual packages. If only one package is being described by the Package element, then only one PackageDescription is used. If a collection of packages is being described, then multiple descriptions can be used to uniquely identify the packages within the collection.
    • ListOfDestinationReference - references the transport routing element to identify which transport legs the package is travelling on.
    • SpecialHandling - describes any special handling relating to the package.
    • HazardousPackaging - includes all hazardous regulations regarding to the package. Identification of the instructions on how specified goods, packages or containers should be handled.
    • AssociatedDocuments - identifies documents with information related to the hazardous packaging of this order.
    • ShippingInstructions - is free form text for special shipping instructions.
    • ReturnableContainerInfo - describes shipping, payment and miscellaneous information regarding containers that are returned after they have been used in shipment.
    • PackageDetail - is recursive, to indicate sub-package relationships.

[^]Code Fragment

    <xsd:complexType name="PackageType">
    <xsd:sequence>
        <xsd:element name="PackageID" type="xsd:int">
        <xsd:element minOccurs="0" name="ListOfItemReference" type="ListOfPackageItemReferenceType">
        <xsd:element minOccurs="0" name="ListOfPackageMark" type="ListOfPackageMarkType">
        <xsd:element minOccurs="0" name="ListOfPackageCharacteristic" type="ListOfPackageCharacteristicType">
        <xsd:element minOccurs="0" name="ListOfDimension" type="ListOfDimensionType">
        <xsd:element minOccurs="0" name="ListOfPackageDescription" type="ListOfPackageDescriptionType">
        <xsd:element minOccurs="0" name="ListOfDestinationReference" type="ListOfDestinationRefType">
        <xsd:element minOccurs="0" name="SpecialHandling" type="SpecialHandlingType">
        <xsd:element minOccurs="0" name="HazardousPackaging" type="HazardousType">
        <xsd:element minOccurs="0" name="AssociatedDocuments" type="AssociatedDocumentsType">
        <xsd:element minOccurs="0" name="ShippingInstructions" type="xsd:string">
        <xsd:element minOccurs="0" name="ReturnableContainerInfo" type="ReturnableContainerInfoType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="PackageDetail" type="PackageDetailType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: PackageTypeCodeType

PackageTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other
    • Aerosol
    • Aluminum
    • AmmoPack
    • Ampoule
    • Ampoule-Non-Protected
    • Ampoule-Protected
    • AsSpecifiedByTheDOT
    • Atomizer
    • Attachment
    • Bag
    • Bale
    • Bale-Compressed
    • Bale-Non-Compressed
    • Balloon-Non-Protected
    • Balloon-Protected
    • Banding
    • Bar
    • Barge
    • Barrel
    • Bars-InBundleOrBunchOrTruss
    • Basket
    • Beam
    • BeerCrate
    • Belting
    • Bin
    • BingChest
    • Board
    • Board-InBundleOrBunchOrTruss
    • Bobbin
    • Bolt
    • Bottle
    • Bottlecrate-Bottlerack
    • Bottle-Non-Protected-Bulbous
    • Bottle-Non-Protected-Cylindrical
    • Bottle-ProtectedBulbous
    • Bottle-ProtectedCylindrical
    • Box
    • BoxWithInnerContainer
    • Bracing
    • Bucket
    • Bulk
    • Bulk-Gas-At1031MbarAnd15DegC
    • Bulk-LiquefiedGas-AtAbnormalTemperatureOrPressure
    • Bulk-Liquid
    • Bulk-Solid-FineParticles-Powders
    • Bulk-Solid-GranularParticles-Grains
    • Bulk-Solid-LargeParticles-Nodules
    • Bunch
    • Bundle
    • Burlap
    • Butt
    • Cabinet
    • Cage
    • CanCase
    • Can-Cylindrical
    • Canister
    • Can-Rectangular
    • Canvas
    • Carboy
    • Carboy-Non-Protected
    • Carboy-Protected
    • CarLoad-Rail
    • Carrier
    • Carton
    • Case
    • Cask
    • Cheeses
    • ChemicallyHardenedFibre
    • Chest
    • Churn
    • Cloth
    • ClothOrFabric
    • ClothTop
    • Coffer
    • Coffin
    • Coil
    • CollapsibleTube
    • Compressed
    • Cones
    • Conex
    • Container
    • Container-CommercialHighwayLift
    • Container-Engine
    • Container-Mac-Iso-Lt.Wgt8X8X20FootAir
    • Container-Multi-Walled-SecuredToWarehousePallet
    • Container-NavyCargoTransporter
    • ContainersOfBulkCargo
    • Core
    • CornerReinforcement
    • CorrugatedOrSolid
    • Cover
    • Cradle
    • Crate
    • Creel
    • Cup
    • Cylinder
    • Demijohn-Non-Protected
    • Demijohn-Protected
    • Double-LengthRack
    • Double-LengthSkid
    • Double-LengthToteBin
    • DoubleWallCorrugatedBoard
    • Double-WallPaper
    • Drum
    • DryBulk
    • Duffelbag
    • EdgeProtection
    • EggCrating
    • Envelope
    • Fiberboard
    • FiberboardMetal
    • Fibre
    • Fibre-Paperboard
    • Filmpack
    • Firkin
    • Flask
    • Flo-Bin
    • Foam
    • Footlocker
    • ForwardReel
    • Frame
    • FramedCrate
    • FruitCrate
    • GasBottle
    • Girder
    • Girders-InBundleOrBunchOrTruss
    • Glass
    • Half-StandardRack
    • Half-StandardToteBin
    • Hamper
    • HeadsOfBeef
    • Hogshead
    • HopperTruck
    • HouseholdGoodsContainer-Wood
    • Ingot
    • Ingots-InBundleBunchTruss
    • InInnerContainers
    • Insulated
    • IntermediateContainer
    • IntermodalTrailerOrContainerLoad-Rail
    • IronOrSteel
    • Jar
    • Jerrican-Cylindrical
    • Jerrican-Rectangular
    • Jug
    • Jumbo
    • Jutebag
    • Keg
    • Kit
    • KnockdownRack
    • KnockdownToteBin
    • Lead
    • Lifts
    • LiftVan
    • Liners
    • LipOrTop
    • LiquidBulk
    • Log
    • Logs-InBundleOrBunchOrTruss
    • Loose
    • Lug
    • Mat
    • MatchBox
    • Metal
    • MetalCans
    • MilkCrate
    • Milvan
    • Mixed
    • MixedContainerTypes
    • MoistureResistant
    • MoldedPlastic
    • Mscvan
    • Multiple-WallPaper-2OrMoreWalls
    • Multiple-WallPaper3OrMoreWalls
    • MultiplyBag
    • Multi-RollPack
    • MultiwallSack
    • Nest
    • Net
    • Noil
    • NotOtherwiseSpecified
    • OnHangerOrRackInBoxes
    • OnOwnWheel
    • OtherThanGlass
    • OtherThanMetalOrPlasticTubesOrGlass
    • Package
    • Packed-NotOtherwiseSpecified
    • Packet
    • Pail
    • Pallet
    • AluminumPallet
    • MetalPallet
    • StandardPallet
    • SteelPallet
    • WoodPallet
    • SlipSheetPallet
    • DOTPallet
    • Pallet-2Way
    • Pallet-4Way
    • Paper
    • Paper-Vci
    • Parcel
    • Partitioning
    • Pieces
    • Pipe
    • Pipeline
    • PipeRack
    • Pipes-InBundleOrBunchOrTruss
    • Pirns
    • Pitcher
    • Plank
    • Planks-InBundleOrBunchOrTruss
    • Plastic
    • Plastic-InjectionMolded
    • Plastic-Regrind
    • Plastic-StructuralFoam
    • Plastic-VacuumFormed
    • Plastic-Virgin
    • Plastic-WrappedTray
    • Plate
    • Plates-InBundleOrBunchOrTruss
    • Platform
    • PolyethyleneLined
    • Polystyrene
    • Pot
    • Pouch
    • PrimaryLiftContainer
    • PrivateVehicle
    • Pulpboard
    • QuarterOfBeef
    • Rack
    • Rail-Semiconductor
    • Rednet
    • Reel
    • Reinforcement
    • ReverseReel
    • Ring
    • Rod
    • Rods-InBundleOrBunchOrTruss
    • Roll
    • Rubber
    • RubberAndFabric
    • Sachet
    • Sack
    • Sea-Chest
    • Seavan
    • SeparatorOrDivider
    • ShallowCrate
    • Sheet
    • Sheetmetal
    • Sheets-InBundleOrBunchOrTruss
    • Shook
    • ShrinkWrap
    • Shrinkwrapped
    • SideOfBeef
    • SingleWallCorrugatedBoard
    • SkeletonCase
    • Skid
    • Skid-ElevatingOrLiftTruck
    • Sleeve
    • Slipsheet
    • Special
    • SpecialJumbo
    • SpinCylinders
    • Spindle
    • Spool
    • StainlessSteel
    • Standard
    • Steel-VinylCoated
    • StretchWrap
    • Suitcase
    • Tank
    • TankCar
    • Tank-Cylindrical
    • Tank-Rectangular
    • TankTruck
    • Tea-Chest
    • Tierce
    • Tin
    • ToteBin
    • Tray
    • TrayPack
    • TripleWallCorrugatedBoard
    • Truck
    • TrunkAndChest
    • Trunk-SalesmenSample
    • Truss
    • Tub
    • Tube
    • Tube-Collapsible
    • Tubes-InBundleOrBunchOrTruss
    • Tubes-MetalOrPlastic
    • Tun
    • Unit
    • UnpackedOrUnpackaged
    • Vacuum-Packed
    • VanPack
    • Vat
    • VehicleInOperatingCondition
    • Vehicles
    • Vial
    • WheeledCarrier
    • Wickerbottle
    • WireMesh
    • WireOrCord
    • Wood
    • Wrapped

[^]Code Fragment

    <xsd:simpleType name="PackageTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Aerosol">
        <xsd:enumeration value="Aluminum">
        <xsd:enumeration value="AmmoPack">
        <xsd:enumeration value="Ampoule">
        <xsd:enumeration value="Ampoule-Non-Protected">
        <xsd:enumeration value="Ampoule-Protected">
        <xsd:enumeration value="AsSpecifiedByTheDOT">
        <xsd:enumeration value="Atomizer">
        <xsd:enumeration value="Attachment">
        <xsd:enumeration value="Bag">
        <xsd:enumeration value="Bale">
        <xsd:enumeration value="Bale-Compressed">
        <xsd:enumeration value="Bale-Non-Compressed">
        <xsd:enumeration value="Balloon-Non-Protected">
        <xsd:enumeration value="Balloon-Protected">
        <xsd:enumeration value="Banding">
        <xsd:enumeration value="Bar">
        <xsd:enumeration value="Barge">
        <xsd:enumeration value="Barrel">
        <xsd:enumeration value="Bars-InBundleOrBunchOrTruss">
        <xsd:enumeration value="Basket">
        <xsd:enumeration value="Beam">
        <xsd:enumeration value="BeerCrate">
        <xsd:enumeration value="Belting">
        <xsd:enumeration value="Bin">
        <xsd:enumeration value="BingChest">
        <xsd:enumeration value="Board">
        <xsd:enumeration value="Board-InBundleOrBunchOrTruss">
        <xsd:enumeration value="Bobbin">
        <xsd:enumeration value="Bolt">
        <xsd:enumeration value="Bottle">
        <xsd:enumeration value="Bottlecrate-Bottlerack">
        <xsd:enumeration value="Bottle-Non-Protected-Bulbous">
        <xsd:enumeration value="Bottle-Non-Protected-Cylindrical">
        <xsd:enumeration value="Bottle-ProtectedBulbous">
        <xsd:enumeration value="Bottle-ProtectedCylindrical">
        <xsd:enumeration value="Box">
        <xsd:enumeration value="BoxWithInnerContainer">
        <xsd:enumeration value="Bracing">
        <xsd:enumeration value="Bucket">
        <xsd:enumeration value="Bulk">
        <xsd:enumeration value="Bulk-Gas-At1031MbarAnd15DegC">
        <xsd:enumeration value="Bulk-LiquefiedGas-AtAbnormalTemperatureOrPressure">
        <xsd:enumeration value="Bulk-Liquid">
        <xsd:enumeration value="Bulk-Solid-FineParticles-Powders">
        <xsd:enumeration value="Bulk-Solid-GranularParticles-Grains">
        <xsd:enumeration value="Bulk-Solid-LargeParticles-Nodules">
        <xsd:enumeration value="Bunch">
        <xsd:enumeration value="Bundle">
        <xsd:enumeration value="Burlap">
        <xsd:enumeration value="Butt">
        <xsd:enumeration value="Cabinet">
        <xsd:enumeration value="Cage">
        <xsd:enumeration value="CanCase">
        <xsd:enumeration value="Can-Cylindrical">
        <xsd:enumeration value="Canister">
        <xsd:enumeration value="Can-Rectangular">
        <xsd:enumeration value="Canvas">
        <xsd:enumeration value="Carboy">
        <xsd:enumeration value="Carboy-Non-Protected">
        <xsd:enumeration value="Carboy-Protected">
        <xsd:enumeration value="CarLoad-Rail">
        <xsd:enumeration value="Carrier">
        <xsd:enumeration value="Carton">
        <xsd:enumeration value="Case">
        <xsd:enumeration value="Cask">
        <xsd:enumeration value="Cheeses">
        <xsd:enumeration value="ChemicallyHardenedFibre">
        <xsd:enumeration value="Chest">
        <xsd:enumeration value="Churn">
        <xsd:enumeration value="Cloth">
        <xsd:enumeration value="ClothOrFabric">
        <xsd:enumeration value="ClothTop">
        <xsd:enumeration value="Coffer">
        <xsd:enumeration value="Coffin">
        <xsd:enumeration value="Coil">
        <xsd:enumeration value="CollapsibleTube">
        <xsd:enumeration value="Compressed">
        <xsd:enumeration value="Cones">
        <xsd:enumeration value="Conex">
        <xsd:enumeration value="Container">
        <xsd:enumeration value="Container-CommercialHighwayLift">
        <xsd:enumeration value="Container-Engine">
        <xsd:enumeration value="Container-Mac-Iso-Lt.Wgt8X8X20FootAir">
        <xsd:enumeration value="Container-Multi-Walled-SecuredToWarehousePallet">
        <xsd:enumeration value="Container-NavyCargoTransporter">
        <xsd:enumeration value="ContainersOfBulkCargo">
        <xsd:enumeration value="Core">
        <xsd:enumeration value="CornerReinforcement">
        <xsd:enumeration value="CorrugatedOrSolid">
        <xsd:enumeration value="Cover">
        <xsd:enumeration value="Cradle">
        <xsd:enumeration value="Crate">
        <xsd:enumeration value="Creel">
        <xsd:enumeration value="Cup">
        <xsd:enumeration value="Cylinder">
        <xsd:enumeration value="Demijohn-Non-Protected">
        <xsd:enumeration value="Demijohn-Protected">
        <xsd:enumeration value="Double-LengthRack">
        <xsd:enumeration value="Double-LengthSkid">
        <xsd:enumeration value="Double-LengthToteBin">
        <xsd:enumeration value="DoubleWallCorrugatedBoard">
        <xsd:enumeration value="Double-WallPaper">
        <xsd:enumeration value="Drum">
        <xsd:enumeration value="DryBulk">
        <xsd:enumeration value="Duffelbag">
        <xsd:enumeration value="EdgeProtection">
        <xsd:enumeration value="EggCrating">
        <xsd:enumeration value="Envelope">
        <xsd:enumeration value="Fiberboard">
        <xsd:enumeration value="FiberboardMetal">
        <xsd:enumeration value="Fibre">
        <xsd:enumeration value="Fibre-Paperboard">
        <xsd:enumeration value="Filmpack">
        <xsd:enumeration value="Firkin">
        <xsd:enumeration value="Flask">
        <xsd:enumeration value="Flo-Bin">
        <xsd:enumeration value="Foam">
        <xsd:enumeration value="Footlocker">
        <xsd:enumeration value="ForwardReel">
        <xsd:enumeration value="Frame">
        <xsd:enumeration value="FramedCrate">
        <xsd:enumeration value="FruitCrate">
        <xsd:enumeration value="GasBottle">
        <xsd:enumeration value="Girder">
        <xsd:enumeration value="Girders-InBundleOrBunchOrTruss">
        <xsd:enumeration value="Glass">
        <xsd:enumeration value="Half-StandardRack">
        <xsd:enumeration value="Half-StandardToteBin">
        <xsd:enumeration value="Hamper">
        <xsd:enumeration value="HeadsOfBeef">
        <xsd:enumeration value="Hogshead">
        <xsd:enumeration value="HopperTruck">
        <xsd:enumeration value="HouseholdGoodsContainer-Wood">
        <xsd:enumeration value="Ingot">
        <xsd:enumeration value="Ingots-InBundleBunchTruss">
        <xsd:enumeration value="InInnerContainers">
        <xsd:enumeration value="Insulated">
        <xsd:enumeration value="IntermediateContainer">
        <xsd:enumeration value="IntermodalTrailerOrContainerLoad-Rail">
        <xsd:enumeration value="IronOrSteel">
        <xsd:enumeration value="Jar">
        <xsd:enumeration value="Jerrican-Cylindrical">
        <xsd:enumeration value="Jerrican-Rectangular">
        <xsd:enumeration value="Jug">
        <xsd:enumeration value="Jumbo">
        <xsd:enumeration value="Jutebag">
        <xsd:enumeration value="Keg">
        <xsd:enumeration value="Kit">
        <xsd:enumeration value="KnockdownRack">
        <xsd:enumeration value="KnockdownToteBin">
        <xsd:enumeration value="Lead">
        <xsd:enumeration value="Lifts">
        <xsd:enumeration value="LiftVan">
        <xsd:enumeration value="Liners">
        <xsd:enumeration value="LipOrTop">
        <xsd:enumeration value="LiquidBulk">
        <xsd:enumeration value="Log">
        <xsd:enumeration value="Logs-InBundleOrBunchOrTruss">
        <xsd:enumeration value="Loose">
        <xsd:enumeration value="Lug">
        <xsd:enumeration value="Mat">
        <xsd:enumeration value="MatchBox">
        <xsd:enumeration value="Metal">
        <xsd:enumeration value="MetalCans">
        <xsd:enumeration value="MilkCrate">
        <xsd:enumeration value="Milvan">
        <xsd:enumeration value="Mixed">
        <xsd:enumeration value="MixedContainerTypes">
        <xsd:enumeration value="MoistureResistant">
        <xsd:enumeration value="MoldedPlastic">
        <xsd:enumeration value="Mscvan">
        <xsd:enumeration value="Multiple-WallPaper-2OrMoreWalls">
        <xsd:enumeration value="Multiple-WallPaper3OrMoreWalls">
        <xsd:enumeration value="MultiplyBag">
        <xsd:enumeration value="Multi-RollPack">
        <xsd:enumeration value="MultiwallSack">
        <xsd:enumeration value="Nest">
        <xsd:enumeration value="Net">
        <xsd:enumeration value="Noil">
        <xsd:enumeration value="NotOtherwiseSpecified">
        <xsd:enumeration value="OnHangerOrRackInBoxes">
        <xsd:enumeration value="OnOwnWheel">
        <xsd:enumeration value="OtherThanGlass">
        <xsd:enumeration value="OtherThanMetalOrPlasticTubesOrGlass">
        <xsd:enumeration value="Package">
        <xsd:enumeration value="Packed-NotOtherwiseSpecified">
        <xsd:enumeration value="Packet">
        <xsd:enumeration value="Pail">
        <xsd:enumeration value="Pallet">
        <xsd:enumeration value="AluminumPallet">
        <xsd:enumeration value="MetalPallet">
        <xsd:enumeration value="StandardPallet">
        <xsd:enumeration value="SteelPallet">
        <xsd:enumeration value="WoodPallet">
        <xsd:enumeration value="SlipSheetPallet">
        <xsd:enumeration value="DOTPallet">
        <xsd:enumeration value="Pallet-2Way">
        <xsd:enumeration value="Pallet-4Way">
        <xsd:enumeration value="Paper">
        <xsd:enumeration value="Paper-Vci">
        <xsd:enumeration value="Parcel">
        <xsd:enumeration value="Partitioning">
        <xsd:enumeration value="Pieces">
        <xsd:enumeration value="Pipe">
        <xsd:enumeration value="Pipeline">
        <xsd:enumeration value="PipeRack">
        <xsd:enumeration value="Pipes-InBundleOrBunchOrTruss">
        <xsd:enumeration value="Pirns">
        <xsd:enumeration value="Pitcher">
        <xsd:enumeration value="Plank">
        <xsd:enumeration value="Planks-InBundleOrBunchOrTruss">
        <xsd:enumeration value="Plastic">
        <xsd:enumeration value="Plastic-InjectionMolded">
        <xsd:enumeration value="Plastic-Regrind">
        <xsd:enumeration value="Plastic-StructuralFoam">
        <xsd:enumeration value="Plastic-VacuumFormed">
        <xsd:enumeration value="Plastic-Virgin">
        <xsd:enumeration value="Plastic-WrappedTray">
        <xsd:enumeration value="Plate">
        <xsd:enumeration value="Plates-InBundleOrBunchOrTruss">
        <xsd:enumeration value="Platform">
        <xsd:enumeration value="PolyethyleneLined">
        <xsd:enumeration value="Polystyrene">
        <xsd:enumeration value="Pot">
        <xsd:enumeration value="Pouch">
        <xsd:enumeration value="PrimaryLiftContainer">
        <xsd:enumeration value="PrivateVehicle">
        <xsd:enumeration value="Pulpboard">
        <xsd:enumeration value="QuarterOfBeef">
        <xsd:enumeration value="Rack">
        <xsd:enumeration value="Rail-Semiconductor">
        <xsd:enumeration value="Rednet">
        <xsd:enumeration value="Reel">
        <xsd:enumeration value="Reinforcement">
        <xsd:enumeration value="ReverseReel">
        <xsd:enumeration value="Ring">
        <xsd:enumeration value="Rod">
        <xsd:enumeration value="Rods-InBundleOrBunchOrTruss">
        <xsd:enumeration value="Roll">
        <xsd:enumeration value="Rubber">
        <xsd:enumeration value="RubberAndFabric">
        <xsd:enumeration value="Sachet">
        <xsd:enumeration value="Sack">
        <xsd:enumeration value="Sea-Chest">
        <xsd:enumeration value="Seavan">
        <xsd:enumeration value="SeparatorOrDivider">
        <xsd:enumeration value="ShallowCrate">
        <xsd:enumeration value="Sheet">
        <xsd:enumeration value="Sheetmetal">
        <xsd:enumeration value="Sheets-InBundleOrBunchOrTruss">
        <xsd:enumeration value="Shook">
        <xsd:enumeration value="ShrinkWrap">
        <xsd:enumeration value="Shrinkwrapped">
        <xsd:enumeration value="SideOfBeef">
        <xsd:enumeration value="SingleWallCorrugatedBoard">
        <xsd:enumeration value="SkeletonCase">
        <xsd:enumeration value="Skid">
        <xsd:enumeration value="Skid-ElevatingOrLiftTruck">
        <xsd:enumeration value="Sleeve">
        <xsd:enumeration value="Slipsheet">
        <xsd:enumeration value="Special">
        <xsd:enumeration value="SpecialJumbo">
        <xsd:enumeration value="SpinCylinders">
        <xsd:enumeration value="Spindle">
        <xsd:enumeration value="Spool">
        <xsd:enumeration value="StainlessSteel">
        <xsd:enumeration value="Standard">
        <xsd:enumeration value="Steel-VinylCoated">
        <xsd:enumeration value="StretchWrap">
        <xsd:enumeration value="Suitcase">
        <xsd:enumeration value="Tank">
        <xsd:enumeration value="TankCar">
        <xsd:enumeration value="Tank-Cylindrical">
        <xsd:enumeration value="Tank-Rectangular">
        <xsd:enumeration value="TankTruck">
        <xsd:enumeration value="Tea-Chest">
        <xsd:enumeration value="Tierce">
        <xsd:enumeration value="Tin">
        <xsd:enumeration value="ToteBin">
        <xsd:enumeration value="Tray">
        <xsd:enumeration value="TrayPack">
        <xsd:enumeration value="TripleWallCorrugatedBoard">
        <xsd:enumeration value="Truck">
        <xsd:enumeration value="TrunkAndChest">
        <xsd:enumeration value="Trunk-SalesmenSample">
        <xsd:enumeration value="Truss">
        <xsd:enumeration value="Tub">
        <xsd:enumeration value="Tube">
        <xsd:enumeration value="Tube-Collapsible">
        <xsd:enumeration value="Tubes-InBundleOrBunchOrTruss">
        <xsd:enumeration value="Tubes-MetalOrPlastic">
        <xsd:enumeration value="Tun">
        <xsd:enumeration value="Unit">
        <xsd:enumeration value="UnpackedOrUnpackaged">
        <xsd:enumeration value="Vacuum-Packed">
        <xsd:enumeration value="VanPack">
        <xsd:enumeration value="Vat">
        <xsd:enumeration value="VehicleInOperatingCondition">
        <xsd:enumeration value="Vehicles">
        <xsd:enumeration value="Vial">
        <xsd:enumeration value="WheeledCarrier">
        <xsd:enumeration value="Wickerbottle">
        <xsd:enumeration value="WireMesh">
        <xsd:enumeration value="WireOrCord">
        <xsd:enumeration value="Wood">
        <xsd:enumeration value="Wrapped">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: PackageTypeType

PackageTypeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PackageTypeCoded[PackageTypeCodeType] , PackageTypeCodedOther[xsd:string]? , PackageTypeDescription[xsd:string]? )

    Description: PackageTypeType contains information about the specifics of the collection of packages being described by the PackageDetail element. If the collection of packages all contain the same things, and there is no need to identify specifically which packages are contained in which, then only one Package element should be used. If the contents of the package differ or if there needs to be a distinction between which package a sub package is contained in, then multiple Package elements should be used.

    Elements:

    • PackageTypeCoded - identifies the kind of packaging using a standard codelist.
    • PackageTypeCodedOther - is used to provide a non-standard PackageTypeCode. This element is mandatory if the value of PackageTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • PackageTypeDescription - describes the material used for packaging using free form text.

[^]Code Fragment

    <xsd:complexType name="PackageTypeType">
    <xsd:sequence>
        <xsd:element name="PackageTypeCoded" type="PackageTypeCodeType">
        <xsd:element minOccurs="0" name="PackageTypeCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="PackageTypeDescription" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: PartialOrderCodeType

PartialOrderCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other
    • CompleteOrder
    • PartialOrder

[^]Code Fragment

    <xsd:simpleType name="PartialOrderCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="CompleteOrder">
        <xsd:enumeration value="PartialOrder">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: PartialOrderType

PartialOrderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PartialOrderCoded[PartialOrderCodeType] , PartialOrderCodedOther[xsd:string]? )

    Description: PartialOrderType indicates the status of the shipment with respect to the purchase order referenced.

    Elements:

    • PartialOrderCoded - indicates the status of the shipment with respect to the purchase order.
    • PartialOrderCodedOther - is used to provide a non-standard PartialOrderCode. This element is mandatory if the value of PartialOrderCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="PartialOrderType">
    <xsd:sequence>
        <xsd:element name="PartialOrderCoded" type="PartialOrderCodeType">
        <xsd:element minOccurs="0" name="PartialOrderCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PartNumbersType

PartNumbersType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( SellerPartNumber[PartNumType]? , BuyerPartNumber[PartNumType]? , ManufacturerPartNumber[ManufacturerPartNumberType]? , StandardPartNumber[ProductIdentifierCodedType]? , SubstitutePartNumbers[ListOfProductIdentifierCodedType]? , OtherItemIdentifiers[ListOfProductIdentifierCodedType]? )

    Description: PartNumbersType identifies all identification numbers for the item.

    Elements:

    • SellerPartNumber - is the identification of a product or service as assigned by the seller of the product or service.
    • BuyerPartNumber - is the identification of a product or service as assigned by the buyer.
    • ManufacturerPartNumber - is the identification of a product as assigned by the manufacturer of the product and identification of the manufacturer.
    • StandardPartNumber - is the commonly accepted identification of a product or service that is assigned by a standards agency.
    • SubstitutePartNumbers - is a collection of identifications of products or services that are acceptable substitutions for the product or service identified in the PartNumbers element.
    • OtherItemIdentifiers - is a collection of any other identifications of the product or service identified by the PartNumbers element that are not explicitly stated as the content of the other elements contained in the PartNumbers element.

[^]Code Fragment

    <xsd:complexType name="PartNumbersType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="SellerPartNumber" type="PartNumType">
        <xsd:element minOccurs="0" name="BuyerPartNumber" type="PartNumType">
        <xsd:element minOccurs="0" name="ManufacturerPartNumber" type="ManufacturerPartNumberType">
        <xsd:element minOccurs="0" name="StandardPartNumber" type="ProductIdentifierCodedType">
        <xsd:element minOccurs="0" name="SubstitutePartNumbers" type="ListOfProductIdentifierCodedType">
        <xsd:element minOccurs="0" name="OtherItemIdentifiers" type="ListOfProductIdentifierCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PartNumType

PartNumType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PartID[xsd:string] , PartIDExt[xsd:string]? , RevisionNumber[xsd:string]? )

    Description: PartNumType is a complete identification for a product or service.

    Elements:

    • PartID - is the basic identification for a product or service.
    • PartIDExt - provides additional identification for a product or service. An example of this would be a color code for a specific product.
    • RevisionNumber - is a revision number for the part being identified.

[^]Code Fragment

    <xsd:complexType name="PartNumType">
    <xsd:sequence>
        <xsd:element name="PartID" type="xsd:string">
        <xsd:element minOccurs="0" name="PartIDExt" type="xsd:string">
        <xsd:element minOccurs="0" name="RevisionNumber" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PartyCodedType

PartyCodedType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: Extends: PartyType

      Append:( PartyRoleCoded[PartyRoleCodeType] , PartyRoleCodedOther[xsd:string]? )

    Description: PartyCodedType identifies an entity doing business not explicitly stated as the content of another element with its role and the relevant information pertaining to the entity.

    Elements:

    • PartyRoleCoded - identifies the function or role of the entity in relation to a document.
    • PartyRoleCodedOther - is used to provide a non-standard PartyRoleCode. This element is mandatory if the value of PartyRoleCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="PartyCodedType">
    <xsd:complexContent>
        <xsd:extension base="PartyType">
            <xsd:sequence>
                <xsd:element name="PartyRoleCoded" type="PartyRoleCodeType">
                <xsd:element minOccurs="0" name="PartyRoleCodedOther" type="xsd:string">
            </xsd:sequence>
        </xsd:extension>
    </xsd:complexContent>
</xsd:complexType>


simpleType definition: PartyRoleCodeType

PartyRoleCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the party role of the person relating to the package. This code list is derived from EDIFACT 3035 (party function code qualifier) and X12 98 (entity identifier code).

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • AcceptanceLocation
    • AcceptingParty - (3352) Party accepting goods, products, services etc.
    • Accountant - Identifies the accountant.
    • AccountCoordinator - An individual with coordination responsibilities for a specific account.
    • AccountingStation
    • AccountOf - Party account is assigned to.
    • AccountOfDestinationParty
    • AccountOf-OriginParty
    • AccountOwner - Identifies the owner of the account.
    • AccountOwnersServicingBankOnTheReceivingSide - Identifies the financial institution on the receiving side which services the account owner's bank account(s).
    • AccountOwnersServicingBankOnTheSendingSide - Identifies the financial institution on the sending side which services the account owner's bank account(s).
    • AccountServicingFinancialInstitution - Identifies the financial institution servicing the account(s).
    • AccountsPayableOffice
    • AcknowledgementRecipient - Party to whom acknowledgement should be sent.
    • Acronym
    • ActionParty
    • ActualPurchasersCustomer - Party the purchaser within the actual message is selling the ordered goods or services to.
    • ActualReferredByOrganization
    • ActualReferredToOrganization
    • AcuteCareHospital
    • AdditionalAddress
    • AdditionalDebtor
    • AdditionalDeliveryAddress
    • AdditionalPickUpAddress
    • Adjuster
    • AdministrationCentre - Identification of an administration centre.
    • Administrator
    • AdmittingHealthCareProvider - Health care provider that admitted the patient.
    • AdmittingServices
    • AdmittingSurgeon
    • AdultDayCareProgramFacility
    • Advertiser
    • AdvertisingGroup
    • AdviseThroughBank - Identifies the financial institution through which the advising bank is to advise.
    • AdvisingBank - Identifies the financial institution used by the issuing bank to advise the documentary credit.
    • Advisor - Identifies the advisor.
    • Affiant
    • Affiliate
    • AffiliatedCompany - Identifies the affiliated company.
    • AffiliatedParty - A party attached or connected to another party.
    • Agency - The business or establishment of an agent.
    • AgencyGrantingSecurityClearance
    • AgentOrRepresentative - (3196) Party authorized to act on behalf of another party.
    • AgentsBank - Bank of the agent.
    • AIDSOrARCUnit
    • AirAmbulanceServices
    • AirCargoCompany
    • AirForceFacility
    • Airline
    • AirportAuthority
    • AlcoholBeverageDepartment
    • AlcoholismAndOtherChemicalDependencyFacility
    • AlcoholOrDrugAbuseOrDependencyInpatientUnit
    • AlcoholOrDrugAbuseOrDependencyOutpatientServices
    • Alias
    • AlienAffiliate
    • AllegedDebtor
    • Alliance
    • AlliedHealthProfessional
    • AllotmentCustomer
    • AllowableRecipient
    • AlternateReturnAddress
    • AlternativeAddressee
    • AlternativeManufacturer - Party identification of an alternative manufacturer for a product.
    • AlzheimersDiagnosticOrAssessmentServices
    • AmendedName
    • AmericanIndian-OwnedBusiness
    • AmicusCuriae
    • AnesthesiologyServices
    • AngioplastyFacility
    • AnimalBeingInvestigated - Animal being investigated.
    • AnimalSource
    • Annuitant
    • AnnuitantPayor
    • AntennaSite
    • Appellant
    • Appellee
    • Applicant
    • ApplicantComaker
    • ApplicantForJob - A person who applied for a job.
    • ApplicantsBank - Financial institution which is requested to issue the documentary credit.
    • ApplicantsCosigner
    • ApplicantsEmployer
    • ApplicantsReference
    • ApplicationParty
    • AppraisalCompany
    • AppraiserName
    • ApprovedConsignor - Person or company approved by the relevant authority in the country to pack and export specific goods under Customs supervision.
    • ApprovedImporter - Person or company which is authorised by the relevant Customs authority to import goods without payment all taxes or specific taxes at the point of entry into the country.
    • Approver
    • Arbitrator
    • Architect
    • Architect-Designer - Designer of the construction project.
    • AreaOfOperation
    • ArmedServicesLocationDesignation
    • ArmyFacility
    • ArrestingOfficer
    • ArthritisTreatmentCenter
    • AssetAccountHolder
    • Assignee - Identifies the assignee.
    • Assigner - Identifies the entity who assigns.
    • Assignor - Identifies the assignor.
    • AssistantSurgeon - Physician assisting in surgery.
    • AssistantUSTrustee
    • AssociateGeneralAgent
    • Association
    • AttendingPhysician
    • Attorney - To specify that the party is an attorney.
    • AttorneyForDefendantPrivate
    • AttorneyForDefendantPublic
    • AttorneyForPlaintiff
    • AttorneyOfRecord
    • Auctioneer - Identifies the auctioneer.
    • AuditOffice - The office responsible for conducting audits.
    • Auditor
    • AuthenticatingParty - Party which certifies that a document is authentic.
    • Author - Identifies the author.
    • AuthorityForShipment
    • AuthorizationAssignedBy
    • AuthorizedAcceptingOfficial
    • AuthorizedEntity
    • AuthorizedExporter - Exporter authorized/approved by Customs for special Customs procedures e.g. simplified procedure.
    • AuthorizedFrom
    • AuthorizedImporter - Importer authorized/approved by Customs for special Customs procedures e.g. simplified procedure.
    • AuthorizedMarketer
    • AuthorizedOfficial - Employee of a company or firm authorized to act on behalf of that company or firm e.g. to make a Customs declaration.
    • AuthorizedTo
    • AuthorizedTrader - Trader authorized/approved by Customs for special transit procedures e.g. simplified procedure.
    • AuthorizingOfficial - Party that has delegated the authority to take a certain action on behalf of a company or agency.
    • AutomatedDataProcessingPoint
    • AutomatedUnderwritingSystem
    • AvailableWithBank - Financial institution with whom the documentary credit is available.
    • AvailabilityShipToParty
    • Bailiff - Identifies the bailiff.
    • BailmentWarehouse
    • BailPayor
    • BakeryDepartment
    • Bank
    • Banker
    • BankruptcyReferee - To specify that the party is a referee in a bankruptcy case.
    • BankruptcyTrustee
    • BaseJurisdiction
    • BasePeriodEmployer
    • Battery
    • BeneficialOwner
    • Beneficiary - The ultimate recipient of the funds. Normally the account owner who is reimbursed by the payor.
    • BeneficiarysBank - Identifies the account servicer for the beneficiary or the payee.
    • Bidder
    • BidOpeningLocation
    • BillAndShipTo - Party receiving goods and relevant invoice.
    • BilledFrom
    • BillingProvider
    • BillingService
    • BillOfLadingRecipient - Party to receive B/L.
    • BillTo
    • Bill-ToPartyForDiversionCharges
    • BirthingRoomOrLDRPRoom
    • BirthName
    • Birthplace
    • BloodBank
    • BoardOfRealtors
    • BobtailServicePoint
    • Bondsman
    • BookingAgent - Party acting as a booking office for transport and forwarding services.
    • BookingOffice
    • Bookkeeper
    • BorderCrossing
    • Borrower
    • BorrowersEmployer
    • Bottler
    • Brakeman
    • Branch - Identifies the branch.
    • BrandName
    • BreakBulkBerthOperator - Party who offers facilities for berthing of vessels, handling and storage of break bulk cargo.
    • BreakBulkPoint
    • Broadcaster
    • Broker
    • BrokerDealer
    • BrokerOpinionOrAnalysisRequester
    • BrokerOrSalesOffice - Party acting in the name of the seller as broker or as sales office.
    • BrokersAssistant
    • BuilderName
    • BuildingInspectorate - Party controlling the conformity of works to legal and regulation rules.
    • BuildingSiteEngineer - Party at the building site responsible for engineering matters for that particular site.
    • BuildingSiteForwarder - Party at the building site responsible for forwarding the received goods on that particular site.
    • BuildingSitePurchaser - Party at the building site responsible for the purchasing of goods and services for that particular site.
    • BureauOfLandManagementPropertyUnit
    • BurnCareUnit
    • Business - Identifies the business.
    • BusinessArea
    • BusinessAssociate
    • BusinessEntity
    • BusinessPartner
    • Buyer - Party to whom merchandise and/or service is sold.
    • BuyerAsOfficiallyRegistered - Buying party as officially registered with government.
    • BuyersAgentOrRepresentative - Third party who arranged the purchase of merchandise on behalf of the actual buyer.
    • BuyersBank - [3420] Bank employed by the buyer to make payment.
    • BuyersCorporateOffice - The identification of the buyer's corporate office.
    • BuyersFinancialInstitution - Financial institution designated by buyer to make payment.
    • BuyersParentCompany - Parent company, e.g. holding company.
    • BuyersQualityReviewBoard
    • BuyingGroup
    • BuyingParty
    • CanadianCustomsBroker
    • Candidate
    • CandyAndConfectionsDepartment
    • CardiacCatherizationLaboratory
    • CardiacIntensiveCareUnit
    • CardiacRehabilitationProgramFacility
    • CardiacRehabilitationServices
    • CarnetIssuer
    • Carrier - (3126) Party undertaking or arranging transport of goods between named points.
    • CarriersAgent - Party authorized to act for or on behalf of carrier.
    • CaseManager
    • CaseOfNeedParty - Party to be approached in case of difficulty.
    • CashPoolLevelAccountServicingFinancialInstitution - Identification of a financial institution servicing the level account of a cash pool.
    • CashPoolSub-AccountServicingFinancialInstitution - Identification of a financial institution servicing the sub-account of a cash pool.
    • CashPoolTopAccountServicingFinancialInstitution - Identification of a financial institution servicing the top account of a cash pool.
    • CedingCompany - Description to be provided.
    • CentralBankOrRegulatoryAuthority - Identifies central bank or regulatory authority which must be informed of certain aspects of a message.
    • CentralCatalogueParty - Party controlling a central catalogue.
    • CertifiedAccountant - Code identifying the party as a certified accountant.
    • CertifyingParty
    • Chairperson - Identifies the chairperson.
    • ChamberOfCommerce - Name of the Chamber of Commerce of the town where the company is registered.
    • ChangedAddress
    • ChargesPayerAtDestination - Party, other than the ordering party, which has to pay the charges concerning the destination operations.
    • Charity
    • CharterSchool
    • ChassisProvider
    • CheckingParty - Party or contact designated on behalf of carrier or his agent to establish the actual figures for quantities, weight, volume and/or (cube) measurements of goods or containers which are to appear in the transport contract and on which charges will be based.
    • ChequeDrawnBank - Identifies the bank on which the cheque should be drawn, as instructed by the ordering customer.
    • ChequeOrder - Party to which the cheque will be ordered, when different from the beneficiary.
    • ChiefDeputyClerkOfCourt
    • Child
    • ChildrensChronicDiseaseFacility
    • ChildrensDayCareCenter
    • ChildrensEyeEarNoseAndThroatFacility
    • ChildrensGeneralFacility
    • ChildrensHospitalUnitOfAnInstitution
    • ChildrensOrthopedicFacility
    • ChildrensOtherSpecialtyFacility
    • ChildrensPsychiatricFacility
    • ChildrensRehabilitationFacility
    • ChildrensTuberculosisAndOtherRespiratoryDiseasesFacility
    • Chiropractor
    • ChronicDiseaseFacility
    • ChronicObstructivePulmonaryDiseaseServiceFacility
    • ChurchOperatedFacility
    • CigarettesAndTobaccoDepartment
    • CircuitLocationIdentifier
    • City
    • ClaimAdministrator
    • Claimant - Party who claims goods or insurance.
    • ClaimantAuthorizedRepresentative
    • ClaimRecipient
    • ClearingHouse - Institution through which funds will be paid.
    • Clerk
    • ClerkOfCourt
    • Clinic
    • ClosedDoorPharmacy
    • ClosedSale
    • ClosingAgent
    • CoatingOrPaintSupplier
    • Co-Borrower
    • Co-Contractor - Member of a grouping of co-contractors.
    • Co-Counsel
    • Co-Debtor - Identifies an entity as a joint or mutual debtor.
    • Co-Defendant - Identifies the co-defendant.
    • Co-Driver
    • Co-Investigator
    • CollateralAssignee
    • CollectingBank - Any bank, other than the remitting bank, involved in processing the collection.
    • CollectionPrincipal - The party entrusting the handling of a collection to a bank.
    • CommercialInsurer
    • CommissionableAgent - IATA cargo agent entitled to commission.
    • CommissionProcessor - Party who provides extra treatment to goods on commission base.
    • CommunityAgent
    • CommunityHealthPromotionFacility
    • CompanyAssignedWell
    • CompanyInterviewerWorksFor
    • CompanyInWhichInterestHeld
    • CompanyMergedWith
    • Company-OwnedOilField
    • CompanyWhichHoldsFinancialInterest - Identifies a company which holds any financial stake in an undertaking or organization.
    • ComparableProperty
    • ComparablePropertyListing
    • ComparableRentals
    • CompetingProperty
    • CompetitivePropertyListing
    • CompilationAgency - The agency responsible for the compilation of information.
    • Complainant
    • ComplainantsAttorney
    • ComponentManufacturer
    • ComprehensiveGeriatricAssessmentFacility
    • ConcurrentEmployer
    • Conductor
    • ConductorPilot
    • Conduit
    • ConnectingCarrier - Owner or operator of a transportation conveyance to which goods in a given transaction will be transferred.
    • Connection
    • Consignee - (3132) Party to which goods are consigned.
    • ConsigneeCourierTransferStation
    • ConsigneeOfVessel - Description to be provided.
    • ConsigneesAgent - Party authorized to act on behalf of the consignee.
    • ConsigneeToBeSpecified - The party to be identified at a later time as the consignee.
    • Consignee-ToReceiveLargeParcelsAndFreight
    • Consignee-ToReceiveMailAndSmallParcels
    • Consignor - (3336) Party which, by contract with a carrier, consigns or sends goods with the carrier, or has them conveyed by him. Synonym: shipper, sender.
    • ConsignorCourierTransferStation
    • ConsignorsRepresentative - Party authorised to represent the consignor.
    • ConsolidatedDebtor
    • Consolidator - Party consolidating various consignments, payments etc.
    • ConstructionContractor
    • ConstructionFirm
    • ConsultantsOffice
    • ConsultingPhysician
    • ConsumerCreditAccountCompany
    • ConsumerReferralContact
    • ConsumerServiceProvider
    • ConsumerServiceProviderCustomer
    • Contact
    • ContactBank1 - Identifies an additional bank which must be informed of certain aspects of the message.
    • ContactBank2 - Identifies an additional bank which must be informed of certain aspects of the message.
    • ContactOffice
    • ContactParty - Party to contact.
    • ContactParty1 - First party to contact.
    • ContactParty2 - Second party to contact.
    • ContactParty3 - Third party to contact.
    • ContactParty4 - Fourth party to contact.
    • ContactPerson
    • ContainerLocation
    • ContainerLocationParty - Party from whose premises container will be or has been despatched.
    • ContainerOperatorOrLessee - Party to whom the possession of specified property (e.g. container) has been conveyed for a period of time in return for rental payments.
    • ContainerReturnCompany - The company to which containers have to be returned.
    • ContainerSurveyAgent - The container survey agency that will survey the containers.
    • ContingentAnnuitant
    • ContingentBeneficiary
    • ContingentOwner
    • ContractAdministrationOffice - The office responsible for the administration of a contract.
    • ContractedServiceProvider
    • ContractHolder
    • ContractingOfficerRepresentative
    • Contractor-General - Single contractor for the whole construction project, working by his own or with subcontractors.
    • ContractOrCognizantSecurityOffice
    • Contractor-Lead - Leader representing a grouping of co-contractors.
    • Contractor-Main - Firm or grouping of co-contractors which has been awarded the contract.
    • ContractualDeliveryMeter
    • ContractualReceiptMeter
    • ControllerQuality - Party controlling the quality of goods and workmanship for the project.
    • Converter
    • ConvoyingParty - Party designated to escort the transported goods.
    • Co-Occupant - The party is a co-occupant.
    • Co-Operative
    • CooperativeBuyingGroup
    • Coordinator
    • Co-Owner
    • Co-Participant - Identifies another party who participates in an activity.
    • Co-Producer - A code used to identify a party who participates in production.
    • CopyMessageTo - Party that is to receive a copy of a message.
    • CorporateOffice - Identification of the Head Office within a company.
    • Corporation
    • CorporationFor-ProfitFacility
    • CorrectedAddress
    • CorrectedInsured
    • CorrectedName
    • Cosigner
    • CosignersEmployer
    • CouncilOfGovernments
    • CounterClaimant
    • Country
    • CountryOfDestination
    • CountryOfExport
    • CountryOfOrigin
    • County
    • Court - Identifies the court.
    • CourtAppointedAttorney
    • CreditGrantor
    • Creditor - Party to whom payment is due.
    • CreditorsAttorney
    • CreditRatingAgency
    • CreditReportingAgency
    • CrewMember - A person manning a means of transport.
    • CrimeVictim
    • CrossClaimant
    • Cross-TownSwitch
    • CTScannerUnit
    • CurrentEmployer-Primary
    • CurrentEmployer-Secondary
    • CurrentReceiver - Current receiver of the goods in a multi-step transportation process (indirect flow) involving at least one grouping centre.
    • CurrentSender - Current sender of the goods in a multi-step transportation process (indirect flow) involving at least one grouping centre.
    • CustodialParent
    • Custodian
    • Customer
    • CustomerFOrWhomSameOrSimilarWOrkWasPerFormed
    • CustomerIdentificationFileCustomerIdentifier
    • Customs - Identification of customs authority relevant to the transaction or shipment.
    • CustomsBroker - Agent or representative or a professional Customs clearing agent who deals directly with Customs on behalf of the importer or exporter (CCC).
    • CustomsOfficeOfClearance - Identifies the office where customs clearance procedures take place.
    • DairyDepartment
    • DataProcessingServiceBureau
    • Dealer
    • Debtor - Party from whom payment is due.
    • DebtorCompany
    • DebtorIndividual
    • Debtor-In-Possession
    • DebtorsAttorney
    • DebtPaymentAuthorisationParty - A party which authorises the payment of a debt.
    • DecisionMaker
    • Declarant - (3140) Party who makes a declaration to an official body or - where legally permitted - in whose name, or on whose behalf, a declaration to an official body is made.
    • DeclarantsAgentOrRepresentative - Any natural or legal person who makes a declaration to an official body on behalf of another natural or legal person, where legally permitted (CCC).
    • Deconsolidator - Party that splits up a large consignment composed of separate consignments of goods. The smaller consignments of goods were grouped together into that large consignment for carriage as a larger unit in order to obtain a reduced rate.
    • DefaultOrForeclosureSpecialist
    • Defendant - Identifies the defendant.
    • DelicatessenDepartment
    • DeliveryAddress
    • DeliveryParty - (3144) Party to which goods should be delivered, if not identical with consignee.
    • DeliveryZone
    • Dentist
    • DepartmentOfJusticeFacility
    • Dependent
    • DependentInsured
    • DependentName
    • Depositor - Party depositing goods, financial payments or documents.
    • DesignatedHazardousWasteFacility
    • DesignEngineering
    • Designer
    • DespatchChargePayer - Party, other than the ordering party, which has to pay the charges concerning the despatch operations.
    • DespatchParty - (3282) Party where goods are collected or taken over by the carrier (i.e. if other than consignor).
    • DestinationCarrier
    • DestinationDrayman
    • DestinationIntermodalRamp
    • DestinationMailFacility
    • DestinationTerminal
    • DiagnosticRadioisotopeFacility
    • DialysisCenters
    • DifferentPremiseAddress
    • Director
    • DisabledIndividual
    • DisbursingOfficer
    • DischargePoint
    • DisciplinaryContact
    • Dispatcher - An individual responsible for sending something to a destination.
    • Distiller
    • DistributionRecipient
    • Distributor - Party distributing goods, financial payments or documents.
    • DistributorBranch - The affiliate of a retailer or distributor.
    • District
    • DistrictAttorney
    • DistrictJustice
    • Division
    • DoctorOfOptometry
    • DoctorOfOsteopathy
    • DocumentaryCreditAccountParty - Party which is responsible for the payment settlement of the documentary credit with the applicant's bank/issuing bank, if different from the documentary credit applicant.
    • DocumentaryCreditAccountPartysBank - Bank of the documentary credit account party.
    • DocumentaryCreditApplicant - Party at whose request the applicant's bank/issuing bank is to issue a documentary credit.
    • DocumentaryCreditBeneficiary - Party in whose favour the documentary credit is to be issued and the party that must comply with the credit's terms and conditions.
    • DocumentaryCreditBeneficiarysBank - Financial institution with which the beneficiary of the documentary credit maintains an account.
    • DocumentaryCreditReimbursingBank - Self-explanatory.
    • DocumentaryCreditSecondBeneficiary - Party to whom the documentary credit can be transferred.
    • DocumentCustodian
    • DocumentOrMessageIssuerOrSender - Issuer of a document and/or sender of a message.
    • DocumentRecipient - (1370) Party which should receive a specified document.
    • DoingBusinessAs - The name under which business is conducted.
    • DomesticFinancialInstitution - Domestic party acting as financial institution.
    • DownstreamFirstSupplier
    • DownstreamMeterLocation
    • DownstreamParty
    • Drawee - Party on whom drafts must be drawn.
    • DrillingContractor
    • Driver - Person who drives a means of transport.
    • Drop-OffLocation
    • DryGroceryDepartment
    • DurableMedicalEquipmentSupplier
    • EconomicallyDisadvantagedIndividual
    • EducationalInstitution - Identifies a university, college or school.
    • ElectronicDataInterchangeCoordinatorPointAddress
    • ElectronicFiler
    • ElectronicRegistrationUtility
    • ElectronicReturnOriginator
    • ElementarySchool
    • EligiblePartyToTheContract
    • EligiblePartyToTheRate
    • EmergencyDepartment
    • EmergencyDepartmentSocialWorkServices
    • EmergencyMedicalTechnician
    • EmergencyProvider
    • EmergencyResponseUnit
    • EmergingSmallBusiness
    • Employee
    • EmployeeName
    • Employer - Self-explanatory.
    • EmptyContainerResponsibleParty - Party responsible for the empty container.
    • EmptyContainerReturnAgent - Party, designated by owner of containers, responsible for their collection as agreed between the owner and customer/ consignee.
    • EmptyEquipmentDespatchParty - Party from whose premises empty equipment will be or has been despatched.
    • EmptyEquipmentReturnParty - Party to whose premises empty equipment will be or has been returned.
    • EndItemManufacturer
    • EndUser
    • EnergyInformationAdministration-OwnedOilField
    • Engineer
    • Engineer-Construction - Party representing the contractor to advise and supervise engineering aspects of the works.
    • Engineer-Consultant - Party providing professional engineering services.
    • Engineering
    • EngineerMeasurement - Party responsible for quantity measurements.
    • EngineerPilot
    • Engineer-ResidentConstruction - Party commissioned by the owner to advise and supervise engineering aspects of the works.
    • Enroller
    • EntityHoldingTheInformation
    • EntityInWhichAFinancialInterestIsHeld - Business in which a financial interest is held.
    • EntityProvidingTheService
    • EntityResponsibleForFollow-Up
    • EntryPointTechnicalAssessmentGroup - Party acts as an entry point for technical assessment.
    • EquipmentDrop-OffParty - The party which drops off equipment.
    • EquipmentOwner - Owner of equipment (container, etc.).
    • EquipmentRepairParty - A party making repairs to equipment.
    • EstablishedLocation
    • Estimator
    • EventLocation
    • Examiner
    • Exchanger - Party exchanging currencies or goods.
    • ExciseParty - Party to whom excise must be paid.
    • ExcludedParty
    • ExecutiveCommitteeMember
    • ExecutorOfEstate
    • Exhibitor
    • ExpertWitness
    • Exporter - (3030) Party who makes - or on whose behalf a Customs clearing agent or other authorized person makes - an export declaration. This may include a manufacturer, seller or other person. Within a Customs union, consignor may have the same meaning as exporter.
    • Ex-Spouse
    • ExtendedCareFacility
    • ExtracorporealShock-WaveLithotripterUnit
    • EyeEarNoseAndThroatFacility
    • Facility
    • Factor - Company offering a financial service whereby a firm sells or transfers title to its accounts receivable to the factoring company.
    • Factor-Correspondent - Factoring company engaged by another factoring company to assist the letter with the services provided to the clients (sellers).
    • FamilyMember - Identifies a family member.
    • Father - Person is a father.
    • FederalFacility
    • FederalGovernment
    • FederallyCharteredFacility
    • FederalStateCountyOrCityFacility
    • FellowshipInstitution
    • Felon
    • Field
    • FieldorBranchOffice
    • FilerName
    • FilingAddress
    • FilingLocation
    • FilingOffice - Identifies the filing office.
    • FinalCustomerOrganization
    • FinalMaintenanceOrganization
    • FinalMaintenancePeriodDesignatingOrganization
    • FinalMessageRecipient - To identify the final recipient of the message.
    • FinalRecipient
    • FinalReferredToOrganization
    • FinalScheduledDestination
    • FinancialInstitution - Party acting as financial institution.
    • FinancialPlanner
    • FinancialStatementRecipient
    • Fireman
    • FirstAppraiser
    • FirstBreakTerminal
    • FirstContact
    • FirstSupplier
    • FitnessCenter
    • FloodCertifier
    • FloodDeterminationProvider
    • FloralDepartment
    • FoodServiceOperator
    • ForeclosingLender
    • ForeignDisclosureInformationOffice - The office that reviews sensitive information for foreign disclosure.
    • ForeignLanguageSynonym
    • ForeignOffice
    • ForeignRegistrationLocation
    • ForeignSupplier
    • Formation
    • FormerAddress
    • FormerlyDoingBusinessAs
    • FormerlyKnownAs
    • FormerPresident
    • FormerRegisteredAddress
    • FormerResidence
    • ForProfitHealthCareProvider
    • Forwarder
    • Foundation
    • Founder - Identifies the founder.
    • Franchisee
    • Franchisor
    • FreeonBoardPoint
    • FreightForwarder - Party arranging forwarding of goods.
    • FreightManagementFacilitator
    • FreightOrChargesPayer - Party responsible for the payment of freight.
    • FreightPayerOnBehalfOfTheConsignee - Freight payer is a third party acting on behalf of the consignee.
    • FreightPayerOnBehalfOfTheConsignor - Freight payer is a third party acting on behalf of the consignor.
    • FrozenDepartment
    • FutureAddress
    • GainingInventoryManager
    • GaragedLocation
    • Garnishee
    • GasPlant
    • GasTransactionEndingPoint
    • GasTransactionPoint1
    • GasTransactionPoint2
    • GasTransactionStartingPoint
    • GatewayProvider
    • GeneralAgency
    • GeneralInpatientCareForAIDSOrARCFacility
    • GeneralMedicalAndSurgicalFacility
    • GeneralMerchandiseDepartment
    • GeneticCounselingOrScreeningServices
    • GeriatricAcuteCareUnit
    • GeriatricClinics
    • GiftRecipient
    • GoodsCollectionParty - Party that will collect or has collected the goods.
    • GoodsCustodian - (3024) Party responsible for the keeping of goods.
    • GoodsOwner - The party which owns the goods.
    • GoodsReleaser - (3026) Party entitled to authorize release of goods from custodian.
    • Government
    • Government-CombinedControl
    • Government-Federal-Military
    • Government-Federal-Other
    • Government-Federal-Veterans
    • GovernmentFurnishedPropertyFOBPoint
    • GovernmentLoanAgencySponsorOrAgent
    • Government-Local
    • Grandparent
    • Grantor
    • GroundAmbulanceServices
    • Group
    • GroupAffiliate
    • GroupAffiliation
    • GroupingCentre - A party in charge of groupage, including degroupage and regroupage.
    • GroupPractice
    • GroupPurchasingOrganization
    • GuaranteeAgency - Identifies the guarantee agency.
    • Guardian
    • HazardousMaterialOffice - The office responsible for providing information regarding hazardous material.
    • HazardousWasteGenerator
    • HeadOffice
    • HealthAndBeautyDepartment
    • HealthcareProfessionalShortageAreaFacility
    • HealthMaintenanceOrganization
    • HealthMiscellaneous
    • HealthSciencesLibrary
    • HemodialysisFacility
    • HighSchool
    • HisopathologyLaboratory
    • HispanicServiceInstitute
    • HistoricallyBlackCollegeOrUniversity
    • HomeHealthAgency
    • HomeHealthCare
    • HomeHealthCorporation
    • HomeHealthServices
    • HomeOffice
    • HomeSchool
    • HomeStateName
    • Hospice
    • Hospital
    • HospitalAuxiliaryUnit
    • HospitalDistrictOrAuthority
    • HospitalUnitOfAnInstitution
    • HospitalUnitWithinAnInstitutionForTheMentallyRetarded
    • HostileWitness
    • ImportedFromLocation
    • Importer - (3020) Party who makes - or on whose behalf a Customs clearing agent or other authorized person makes - an import declaration. This may include a person who has possession of the goods or to whom the goods are consigned.
    • InCareOfPartyNo1 - Description to be provided.
    • InCareOfPartyNo2 - Description to be provided.
    • IncorporatedBy
    • IncorporatedLocation
    • IncorporationJurisdiction
    • IncorporationStatePlaceOfBusiness
    • IncorporationStatePrincipalOffice
    • IndependentAdjuster
    • IndependentLab
    • IndependentPhysiciansAssociation
    • Individual
    • IndividualFor-ProfitFacility
    • IndustryAssociation - Identifies the industry association.
    • IndustryBureau
    • IneligibleParty
    • InformationDisseminationAgency - The agency responsible for the dissemination of information.
    • InformationMaintenanceAgency - The agency responsible for the maintenance of information.
    • InformationProvider
    • InformationReferenceAgency - The agency responsible for the reference of information.
    • InformationSource
    • InitialDealer
    • InitialMedicalProvider
    • InitialSubscriber
    • Initiating
    • InjectionPoint
    • In-PatientPharmacy
    • InquiringParty
    • InquiryAddress
    • In-ServiceSource
    • InspectionAddress - Specifies the address for an inspection.
    • InspectionAndAcceptanceLocation
    • InspectionAndAcceptanceParty - The party who will perform inspection and acceptance.
    • InspectionCompany
    • InspectionLeader - An individual responsible for an inspection team.
    • InspectionLocation
    • Inspector
    • InstallationOnSite - Description to be provided.
    • InstalledAt
    • InstitutionalProvider - The institution providing the service.
    • InstitutionForMentalRetardation
    • In-StoreBakeryDepartment
    • InsuranceBeneficiary - Party which benefits from insurance coverage.
    • InsuranceClaimAdjuster - Description to be provided.
    • InsuranceCompany - Description to be provided.
    • InsuranceInstitute
    • Insured - Party which is the object of an insurance contract.
    • InsuredLocation
    • InsuredOrSubscriber
    • Insurer - Description to be provided.
    • IntegratedMaterialManager
    • IntellectualPropertyOwner
    • InterestedParty
    • InterimFundingOrganization
    • InterimTrustee
    • InterlineServiceCommitmentCustomer
    • Intermediary
    • IntermediaryBank1 - A financial institution between the ordered bank and the beneficiary's bank.
    • IntermediaryBank2 - A financial institution between the ordered bank and the beneficiary's bank.
    • IntermediaryOrBroker - Description to be provided.
    • IntermediateCarrier
    • IntermediateConsignee - The intermediate consignee.
    • IntermediateLevelParentCompany - Identifies an intermediate parent company.
    • InternationalFreightForwarder
    • InternationalOrganization
    • InternshipEntity
    • Interpreter
    • Interviewee
    • Interviewer
    • Inventor
    • InventoryController - To specifically identify the party in charge of inventory control.
    • InventoryControlPoint
    • InventoryReportingParty - Party reporting inventory information.
    • Investigator - A party who conducts investigations.
    • InvestmentAdvisor
    • Investor
    • Invoicee - (3006) Party to whom an invoice is issued.
    • InvoicingDealer
    • InvolvedParty - Party which is involved in an activity.
    • IrrevocableBeneficiary
    • Issuer
    • IssuerOfDebitOrCreditMemo
    • IssuerOfInvoice - (3028) Party issuing an invoice.
    • IssuerOfWaybill - Party issuing the contract (waybill) for carriage.
    • IssuingBank - Financial institution which issues the documentary credit, if the applicant's bank is not acting as the issuing bank.
    • ItemManager
    • ItemShipTo
    • ItemShipFrom
    • JointAnnuitant
    • JointAnnuitantOwner
    • JointDebtor
    • JointDebtorAttorney
    • JointOwner - Identifies the joint owner.
    • JointOwnerAnnuitant
    • JointOwnerAnnuitantPayor
    • JointOwnerJointAnnuitant
    • JointOwnerJointAnnuitantPayor
    • JointOwnerPayor
    • JointVenture - Identifies the joint venture.
    • Judge - To specify that the party is a judge.
    • JuniorHighSchool
    • Jurisdiction
    • JuvenileDefendant
    • JuvenileOwner
    • JuvenileVictim
    • JuvenileWitness
    • KeyPerson - Identifies the key person.
    • KidneyDialysisUnit
    • Labeler
    • Laboratory
    • LaborSurplusAreaFirm
    • Landlord
    • LargeBusiness
    • LastBreakTerminal
    • LastEmployer
    • LastKnownSourceOfSupply
    • LastSupplier
    • LawEnforcementAgency
    • LawFirm - To specify that the party is a law firm.
    • LeaseLocation
    • LegalReceiver - The party responsible for a receivership.
    • LegalRepresentative
    • LegalTitleHolder - Identifies the legal title holder.
    • Lender - Party lending goods or equipment.
    • LendingInstitution
    • Lessee
    • LesseesSurveyor - Surveyor hired by the lessee of the item.
    • Lessor - The party is a lessor.
    • LiabilityHolder - Identifies the liability holder.
    • Licensee
    • LienHolder
    • LimitedLiabilityCompany
    • LimitedLiabilityPartnership
    • LimitedPartner
    • Liquidator - The party responsible for settling or paying a debt.
    • ListingAgent
    • ListingCompany
    • ListingOffice
    • ListMailer
    • ListOwner
    • LiterallyTranslatedName
    • LoadingParty - Party responsible for the loading when other than carrier.
    • LoanApplicant
    • LoanBroker
    • LoanCorrespondent
    • LoanHolderForRealEstateAsset
    • LoanOriginator
    • LoanServicer
    • LocalChain
    • LocalGovernmentSponsor - Identifies the local government sponsor.
    • LocationOfGoods
    • LocationOfGoodsForCustomsExaminationBeforeClearance - SE.
    • LocationOfLoadExchange
    • LocationOfPrincipalAssets
    • LocationOfSpotForStorage
    • LongTermCareFacility
    • Long-TermDisabilityCarrier
    • LosingInventoryManager
    • LossPayee
    • Lot
    • MagistrateJudge
    • MagneticResonanceImagingFacility
    • MaidenName
    • MailAddress
    • MailTo
    • Mainline
    • MaintenanceOrganizationUsedForEstimate
    • MammographyScreeningCenter
    • ManagedCare
    • ManagedCareOrganization
    • ManagementControlActivity
    • ManagementNon-Officer
    • Manager
    • ManagingAgent
    • ManagingGeneralAgent
    • ManufacturerOfGoods - Party who manufactures the goods.
    • ManufacturersRepresentative
    • Manufacturing
    • ManufacturingPlant
    • MarineSurveyor
    • MarkerOwner
    • MarketTimer
    • Mark-ForParty - The party within an organization for whom the material is marked to be delivered.
    • MasterAgent
    • MasterGeneralAgent
    • MasterProperty
    • Material
    • MaterialChangeNoticeAddress
    • MaterialDispositionAuthorizationLocation
    • MaterialIssuer
    • MaterialSafetyDataSheetRecipient
    • MeansOfTransportCharterer - Charterer of the means of transport.
    • MeatDepartment
    • MedicalDoctor
    • MedicalInsuranceCarrier
    • MedicalNurse
    • MedicalSchool
    • MedicalSurgicalOrOtherIntensiveCareUnit
    • MedicalTreatmentExecutant - The party who executes a medical treatment.
    • MedicalTreatmentPrescriber - The party who prescribes a medical treatment.
    • MeetingLocation
    • MegavoltageRadiationTherapyUnit
    • Member - Member of a group (e.g. of a group of persons or a service scheme).
    • MerchantBanker
    • MergedCompany - Identifies the company involved in a merger.
    • MergedCompanyWithRetainedIdentity - Company whose identity has been retained from a merger.
    • MergedName
    • MessageFrom - Party where the message comes from.
    • MessageRecipient
    • MessageTo
    • MeteringLocation
    • MexicanCustomsBroker
    • MiddleSchool
    • MigrantHealthClinic
    • MilitaryBranch - Identifies the branch of the military.
    • MilitaryFacility
    • MinimumRoyaltyPayor
    • Minister
    • MinorityInstitution
    • Minority-OwnedBusinessLarge
    • Minority-OwnedBusinessSmall
    • MiscellaneousHealthCareFacility
    • MonitoringParty
    • MortgageCompany - Identifies the mortgage company.
    • MortgageInsurer
    • MortgageLiabilityAccountHolder
    • MostRecentEmployer
    • Mother - Person is a mother.
    • MotorCarrier
    • MotorVehicleReportProviderCompany
    • MultipleListingService
    • Municipality
    • NameChangedTo
    • NameNotToBeConfusedWith
    • NameonCreditCard
    • NameUnderWhichFiled
    • NameVariationSynonym
    • NationalChain
    • NationalOrganization
    • NativeHawaiianOrganization
    • NavyFacility
    • NeglectedOrDelinquentInstitution
    • NegotiatingBank - Financial institution to whom a negotiable documentary credit is directed.
    • Neighbor
    • Neighborhood
    • NeonatalIntensiveCareUnit
    • NetworkName
    • NewAddress
    • NewAssignee
    • NewDebtor
    • NewSecuredParty
    • NewServiceProvider
    • Newspaper
    • NewSupplySource
    • NextDestination
    • NextScheduledDestination
    • Nickname
    • NoHeading - Description to be provided.
    • NominatedBank - Identifies the nominated bank.
    • NominatedFreightCompany - Party nominated to act as transport company or carrier for the goods.
    • Non-DomesticFinancialInstitution - Non-domestic party acting as financial institution.
    • NonemploymentIncomeSource
    • Non-HealthCareMiscellaneousFacility
    • Non-Insured
    • Non-InvasiveCardiacAssessmentServices
    • Non-MortgageLiabilityAccountHolder
    • Non-OccupantCo-Borrower
    • Non-ProductionSupplier
    • Non-ProfitHealthCareProvider
    • NonprofitInstitution
    • Non-RailroadEntity
    • NonRegisteredBusinessName
    • Non-RegisteredInvestmentAdvisor
    • Non-ResidentBeneficiary - The ultimate non-resident recipient of the funds. Normally the account owner who is reimbursed by the payor.
    • Non-ResidentCreditor - Non-resident party receiving the payment or against whom a liability exists.
    • Non-ResidentDebtor - Non-resident party who makes the payment or against whom a claim exists.
    • Non-ResidentGroupCompanyWithWhomFinancialAccountIs - held Identifies the non-resident group company with whom the financial account is held.
    • Non-ResidentInstructingParty - Identifies the non-resident party originating the instruction.
    • Non-ResidentThirdPartyCompanyWithWhomFinancial - account is held Identifies the non-resident third party company with whom the financial account is held.
    • Non-TemporaryStorageFacility
    • Notary
    • NotaryPublic - Identifies the notary public.
    • NoteCo-Signer
    • NotForProfitHealthCareProvider
    • NotifyParty - (3180) Party to be notified of arrival of goods.
    • NotifyPartyForShippersOrder
    • NotifyPartyNo1 - The first party which is to be notified.
    • NotifyPartyNo2 - The second party which is to be notified.
    • NursingHome
    • NursingHomeChain
    • ObservationRoomServices
    • ObstetricsAndGynecologyFacility
    • ObstetricsUnit
    • Occupant - The party is an occupant.
    • OccupationalHealthServices
    • OccupationalTherapyServices
    • OceanTariffConference
    • OfficeManager
    • Officer - Identifies the officer.
    • OffsetOperator
    • OilAndGasCustodian
    • OilAndGasRegulatoryAgency
    • OldAssignee
    • OldDebtor
    • OldSecuredParty
    • OnBehalfOf - Party on behalf of which an action is executed.
    • On-CallProvider
    • OncologyCenter
    • Open-HeartSurgeryFacility
    • OperatingPhysician
    • Operator-CommunicationChannel - Operator of a communication channel.
    • Operator-EssentialServices - Operator of essential services e.g. water, sewerage system, power.
    • OperatorOfPropertyOrEquipment - The party which operates property or a unit of equipment.
    • OperatorOfPropertyOrUnit
    • OperatorOfTheSourceTransferPoint
    • OperatorOfTheTransferPoint
    • OrderedBank - Identifies the account servicer for the ordering customer or payor.
    • OrderedBy - Party who issued an order.
    • OrderingBank - Bank which instructed the sender to act on the transaction(s).
    • OrderingCustomer - Identifies the originator of the instruction.
    • OrderingParty - To be used only if ordering party and buyer are not identical.
    • OrderingPhysician
    • OrderOfShippersOrders-Transportation
    • OrderOfTheShipperParty - The owner of goods under consignment which are moving under a negotiable transport document and will only be released upon receipt of the original transport document.
    • OrderWriter
    • Organization
    • OrganizationCompletingConfigurationChange
    • OrganizationGroup - Identifies the organization group.
    • OrganizationHavingSourceControl
    • OrganizedOutpatientServices
    • OrganizedSocialWorkServiceFacility
    • Organizer
    • OrganOrTissueTransplantUnit
    • OriginalClaimant
    • OriginalIntermodalRamp
    • OriginalJurisdiction
    • OriginalLocation
    • OriginalName
    • OriginalShipper - The original supplier of the goods.
    • OriginatingBank
    • OriginatingCompany
    • OriginatorOfArticleNumber - A code identifying the party which created a specific article number.
    • OriginCarrier
    • OriginDrayman
    • OriginMailFacility
    • OriginSublocation
    • OriginTerminal
    • OrthopedicFacility
    • OrthopedicSurgeryFacility
    • OtherDepartments
    • OtherDisadvantagedBusiness
    • OtherIndividualDisabilityCarrier
    • OtherInsured
    • OtherNot-For-ProfitFacility
    • OtherPersonOrEntityAssociatedWithStudent
    • OtherPhysician
    • OtherRelatedParty - Identifies an entity as an unspecified but related party.
    • OtherSpecialtyFacility
    • OtherUnlistedTypeOfOrganizationalEntity
    • OuterContinentalShelfAreaLocation
    • Out-Of-StatePrincipalOffice
    • OutpatientSocialWorkServices
    • OutpatientSurgeryServices
    • OutpatientSurgicenter
    • OutsideInspectionAgency - Third party inspecting goods or equipment.
    • OutsideProcessor
    • OutsideTestAgency - Third party testing goods, equipment or services.
    • OverrideInstitution
    • Owner
    • OwnerAnnuitant
    • OwnerAnnuitantPayor
    • OwnerJointAnnuitantPayor
    • OwnerOfEquipment - Party who owns equipment.
    • OwnerOfMeansOfTransport - (3126) Party owning the means of transport. No synonym of carrier = CA.
    • OwnerOfOperation - Owner of the operation.
    • OwnerOfProperty - Party owning a property.
    • OwnerOfPropertyOrUnit
    • OwnerOfResidence - Identifies the owner of a residence.
    • OwnerOfVehicle
    • OwnerOfVessel
    • OwnerOrLessorsSurveyor - Surveyor hired by the owner or lessor of the item.
    • OwnerPayor
    • OwnersAgent - Person acting on delegation of powers of the owner.
    • OwnersRepresentative - Person commissioned by the owner to represent him in certain circumstances.
    • OwningInventoryControlPoint
    • OxygenTherapyFacility
    • Packer - Party or person who has undertaken or will undertake packing.
    • Paramedic
    • ParamedicalCompany
    • Parent
    • ParentCompany - Identifies the parent company.
    • Participant
    • ParticipatingArea
    • ParticipatingLaboratory
    • Partner
    • Partnership
    • PartnershipFor-ProfitFacility
    • PartRemanufacturer
    • PartsDistributor
    • PartSource
    • PartyAccordingToDocumentaryCreditTransaction - Party related to documentary credit transaction.
    • PartyAssigningAStatus - Party responsible for assigning a status.
    • PartyAtFinalPlaceOfPositioning - Identifies the party at the final place of positioning.
    • PartyAtPick-UpLocation
    • PartyAuthorizedtoDefinitizeContractAction
    • PartyAuthorizedToMakeDefiniteAContractAction - Party who has the authority to make definite a contract action.
    • PartyAuthorizingDisposition
    • PartyAuthorizingReleaseOfSecurityInformation
    • PartyDataResponsibleParty - The party responsible for all party data.
    • PartyDeclaringTheValueAddedTax - A code to identify the party who is responsible for declaring the Value Added Tax (VAT) on the sale of goods or services.
    • PartyDesignatedToExecuteRe-Icing - Party designated to execute re-icing, selected in the official list of mandatories competent for this kind of operation.
    • PartyDesignatedToExecuteSanitaryProcedures
    • PartyDesignatedToProvideLivingAnimalCare - Party responsible to take care of transported living animals.
    • PartyExecutingAndVerifying
    • PartyFillingShippersOrder
    • PartyForWhomItemIsUltimatelyIntended
    • PartyFromWhomCustomsDocumentsAreToBePickedUp - Identification of the party from whom customs documents are to be picked up.
    • PartyFromWhomNon-CustomsDocumentsAreToBePickedUp - Identification of the party from whom non-customs documents are to be picked up.
    • PartyFulfillingAllOperations - Code indicating the fact that the party identified carries out all operations within that company's activities.
    • PartyInPossession
    • PartyIssuingMutuallyAgreedCodes - The party which has issued all mutually agreed codes used in the message.
    • PartyMaintainingTheCodesUsedInTheMessage - The party which maintains the codes used in the message.
    • PartyMaintainingTheIdentifiersUsedInTheMessage - The party which maintains the identifiers used in the message.
    • PartyMandatedToLiquidateAnEnterprise - A code to identify the party who has been legally mandated to sell off an enterprise.
    • PartyManufacturedFor - Identifies the party for whom manufacturing of goods is done.
    • PartyNotToBeConfusedWith - Identifies a party not to be confused with another party.
    • PartyPassingTheTransaction
    • PartyPerformingCertification
    • PartyPerformingCount
    • PartyPerformingInspection
    • PartyPerformingTask - An entity responsible for performing a task to be undertaken.
    • PartyPerformingVerification
    • PartyProvidingFinancing - Identifies the party providing the financing.
    • PartyProvidingGovernmentFurnishedProperty - The party responsible for providing government furnished property.
    • PartyRecoveringTheValueAddedTax - A code to identify the party who is eligible to recover the Value Added Tax (VAT) on the sale of goods or services.
    • PartyRepresented - Identifies the party represented.
    • PartyResponsibleForDisinfection - Party responsible for performing disinfection operations.
    • PartyResponsibleForFinancialSettlement - (3450) Party responsible for either the transfer or repatriation of the funds relating to a transaction.
    • PartyResponsibleForRefueling - Party responsible for performing refueling operations.
    • PartySubmittingQuote - The party stating the price of something to be purchased.
    • PartyThatReceivedDisclosureStatement
    • PartyThatRemitsPayment
    • PartytoAppearBefore
    • PartyToApproveSpecification
    • Partytobeadvised-WrittenOrders
    • PartyToBeBilled - Party to be billed in accordance with AAR Accounting rule 11.
    • PartyToBeBilledForOtherThanFreight - Party receiving invoice excluding freight costs.
    • PartytoContract
    • PartyToFilePersonalPropertyTax
    • PartytoLease
    • PartytoPerformPackaging
    • PartyToPrintSomeDocument - The party that is to print a specific document.
    • PartytoProvideDiscount
    • PartyToReceiveAllDocuments
    • PartytoReceiveBillOfLading
    • PartyToReceiveCertificateOfCompliance - Party acting for or on behalf of seller in matters concerning compliance.
    • PartyToReceiveCertificateOfConformance
    • PartyToReceiveCertifiedInspectionReport - Party (at buyer) to receive certified inspection report.
    • PartyToReceiveCertifiedTestResults - Party to whom the certified test results should be sent.
    • PartyToReceiveCommercialInvoiceRemittance - Party to whom payment for a commercial invoice or bill should be remitted.
    • PartyToReceiveContractSecurityClassificationSpecification
    • PartyToReceiveCopy
    • PartyToReceiveCorrespondence - Second party designated by a first party to receive certain correspondence in lieu of it being mailed directly to this first party.
    • PartytoReceiveCredit
    • PartyToReceiveCustomsDocuments - Identification of the party to whom customs documents are to be delivered.
    • PartyToReceiveElectronicMemoOfInvoice - Party being informed about invoice issue (via EDI).
    • PartyToReceiveEquipment
    • PartyToReceiveFreightBill - Party to whom the freight bill should be sent.
    • PartyToReceiveInspectionReport - Party to whom the inspection report should be sent.
    • PartyToReceiveInvitationToOffer - An entity to receive an invitation to offer.
    • PartytoReceiveInvoiceFOrGoodsOrServices
    • PartyToReceiveInvoiceForLeasePayments
    • PartytoReceiveLimitationsOfHeavyElementsReport
    • PartytoReceiveMaterialRelease
    • PartyToReceiveNon-CustomsDocuments - Identification of the party to whom non-customs documents are to be delivered.
    • PartyToReceiveOrderToSupply - Party designated by the registering party to receive a binding direction to supply something.
    • PartyToReceivePackingCratingAndHandlingCredit
    • PartyToReceivePaperMemoOfInvoice - Party being informed about invoice issue (via paper).
    • PartytoReceiveProposal
    • PartyToReceivePurchaseOrder
    • PartyToReceiveReports - The party to whom reports are to be submitted.
    • PartytoReceiveScaleTicket
    • PartytoReceiveShippingManifest
    • PartyToReceiveShippingNotice - The party is to be the recipient of the shipping notice.
    • PartytoReceiveSolicitation
    • PartyToReceiveStatementOfAccount - Party to whom the statement of account should be sent.
    • PartyToReceiveStatementOfFeesDue
    • PartytoReceiveStatus
    • PartyToReceiveTechnicalDocumentation - Party to whom technical documentation should be sent.
    • PartyToReceiveTestReport
    • PartytoReceiveTransportationCredit
    • PartytoWhomAcknowledgmentShouldBeSent
    • PartyToWhomDocumentsAreToBePresented
    • PartytoWhomProtestSubmitted
    • PartyWaivingRequirements
    • PartyWhichDeliversConsignmentsToTheTerminal - Party which delivers consignments to a terminal.
    • PartyWhichPicksUpConsignmentsFromTheTerminal - Party which picks up consignments from a terminal.
    • PartyWhoSignedTheDeliveryReceipt
    • PartyWithKnowledgeOfAffairsOfTheCompany
    • PartyWithPowerToVoteSecurities
    • Passenger - A person conveyed by a means of transport, other than the crew.
    • Patient - A person receiving or registered to receive medical treatment.
    • PatientCompanion - Person accompanying the patient.
    • PatientEducationUnit
    • PatientFacility
    • PatientRepresentativeServices
    • Payee - Identifies the credit party when other than the beneficiary.
    • PayeesCompanyNameOrId - Receiving company name/ID (ACH transfers).
    • Payer - (3308) Party initiating payment.
    • PayerOfLastResort
    • PayersCompanyNameOrId
    • PayersFinancialInstitution
    • PayingAgent
    • PayingBank
    • PayingFinancialInstitution - Financial institution designated to make payment.
    • PaymentAddress
    • Payor - Identifies the debit party when other than the ordering customer (for banking purposes).
    • Pay-ToProvider
    • Pedestrian
    • PediatricAcuteInpatientUnit
    • PerformedAt
    • PermitHolder
    • PersonForWhoseBenefitPropertywasSeized
    • PersonnelOffice
    • PersonOnClaim - To identify the person who is the subject of the claim.
    • PersonOrOtherEntityLegallyResponsibleForAChild
    • PersonOrOtherEntityLegallyResponsibleForAndWithWhomAChildResides
    • PersonOrOtherEntityWithWhomAChildResides
    • PetitioningCreditor - Identifies the petitioning creditor.
    • PetitioningCreditorsAttorney
    • Pharmacist
    • Pharmacy
    • PharmacyDepartment
    • PhysicalAddress
    • PhysicalTherapyServices
    • Physician
    • PhysicianClinicOrGroupPractice
    • PhysicianHospitalOrganization
    • Physician-Specialists
    • PickUpAddress
    • PierName
    • Pipeline
    • PipelineSegment
    • PipelineSegmentBoundary
    • PlaceOfBottling
    • PlaceOfBusiness
    • PlaceOfDistilling
    • PlaceOfOccurrence
    • PlaceOfPerformanceCognizantSecurityOffice
    • Plaintiff - Identifies the plaintiff.
    • PlanAdministrator
    • PlanningOrMaintenanceOrganization
    • PlanningCommission
    • PlanningScheduleOrMaterialReleaseIssuer
    • PlanSponsor
    • Plant
    • PlantClearanceOfficer
    • Podiatrist
    • PointOfService
    • PolicyHolder
    • PolicyWritingAgent
    • PollingSite
    • PortAuthority
    • PostalMailingAddress
    • PostsecondaryEducationRecipient
    • PostsecondaryEducationSender
    • Post-SecondaryInstitution
    • PotentialSourceOfSupply
    • PowerOfAttorney
    • PreferredProviderOrganization
    • Pre-KDayCare
    • Pre-kindergartenToGrade12Recipient
    • Pre-kindergartenToGrade12Sender
    • PreliminaryCustomerOrganization
    • PreliminaryInspectionLocation
    • PreliminaryMaintenanceOrganization
    • PreliminaryMaintenancePeriodDesignatingOrganization
    • PreliminaryReferredToOrganization
    • Premises
    • Preparer
    • PresentAddress
    • PresentingBank - The bank which presents documents to the drawee.
    • President - Identifies the president.
    • PreviousBusinessPartner
    • PreviousCreditGrantor
    • PreviousDebtHolder
    • PreviousDistributor
    • PreviousEmployer - Previous employer of a person(s).
    • PreviousGroup
    • PreviousInsured
    • PreviousMember - Previous member of a group of persons or a service scheme.
    • PreviousName - Name of an entity used before the current name.
    • PreviousNameOfFirm
    • PreviousNeighbor
    • PreviousOccupant
    • PreviousOwner - Identifies the previous owner.
    • PreviousResidence
    • PreviousStation
    • PreviousTitleCompany
    • PreviousTradeUnion - Employee organisation who previously represented an employee .
    • PriceAdministration
    • PrimaryBeneficiary
    • PrimaryCareProvider
    • PriceCheckShipTo
    • PrimaryControlPointLocation
    • PrimaryHealthCareProvider - Health care provider that has primary responsibility for patient.
    • PrimaryInsuredOrSubscriber
    • PrimaryInterexchangeCarrier
    • PrimaryInternationalTelecomCarrier
    • PrimaryIntra-LATACarrier
    • PrimaryInventoryControlActivity
    • PrimaryOwner
    • PrimaryPayer
    • PrimaryPhysician
    • PrimaryResidence
    • PrimarySupportOrganization
    • PrimarySurgeon
    • PrimaryTaxpayer
    • PrimeContractor - Party responsible for the whole project if other than the buyer.
    • Principal - (3340) Party accepting liability for goods held or moving (e.g. transit) under a Customs authorization and - when applicable - a guarantee.
    • PrincipalBorrower
    • PrincipalExecutiveOffice
    • PrincipalPerson
    • Printer
    • PriorBaseJurisdiction
    • PriorIncorrectInsured
    • PriorInsuranceCarrier
    • PriorTitleEvidenceHolder
    • PrivatePre-KEducation
    • PrivateSchool
    • ProBonoAttorney
    • Processor - Party or person who has or will apply a process.
    • ProcurementResponsibilityForOrder - A code used to identify the organization which is responsible for the procurement.
    • ProduceDepartment
    • Producer - Party or person who has produced the produce.
    • Production
    • ProductionManager
    • ProductPositionHolder
    • ProductServicesAndRepairsCentre - A centre which services and repairs products.
    • ProfessionalOrganization
    • Project - Party responsible for a project, e.g. a construction project.
    • ProjectCoordinationOffice - Party responsible for technical coordination of works.
    • ProjectManagementOffice - Party commissioned by the owner to follow through the execution of all works.
    • ProjectManager
    • ProjectName
    • ProjectProperty
    • Property
    • PropertyOrBuildingManager
    • ProposedInsured
    • Proposer
    • ProSeCounsel
    • PrototypeSupplier
    • Provider - Identifies the provider.
    • PsychiatricChildOrAdolescentServices
    • PsychiatricConsultation-LiaisonServices
    • PsychiatricEducationServices
    • PsychiatricEmergencyServices
    • PsychiatricFacility
    • PsychiatricGeriatricServices
    • PsychiatricHealthFacility
    • PsychiatricInpatientUnit
    • PsychiatricOutpatientServices
    • PsychiatricPartialHospitalizationProgram
    • Psychiatrist
    • Psychologist
    • PublicAlternativeSchool
    • PublicHealthServiceFacility
    • PublicHealthServiceIndianServiceFacility
    • PublicorPrivateOrganizationForTheDisabled
    • PublicPre-KEducation
    • PublicSchool
    • Publisher - Identifies the publisher.
    • Pumper
    • PurchasedCompany - Identifies the purchased company.
    • PurchasersDepartmentBuyer - Purchasing department of buyer.
    • PurchaseServiceProvider
    • QualifyingOfficer
    • QualityControl
    • QuotationRequestingParty - Party sending a request for a quotation.
    • RadioactiveImplantsUnit
    • RadioControlStationLocation
    • RadioStation
    • RailCarrier - A carrier moving cargo, including containers, via rail.
    • Railroad
    • RatingOrganization - Identifies an organization responsible for assigning a classification or rating.
    • ReceiptMeterLocation
    • ReceiptZone
    • ReceivedFrom - Name of a person or department which actually delivers the goods.
    • Receiver
    • ReceiverManager - Manager of a business which is in receivership status and which will not be liquidated.
    • ReceiverOfCheque - Identifies the party which is to receive the actual cheque, when different from the receiver of funds.
    • ReceiverOfFunds - Identifies the party that receives the funds.
    • ReceiversCorrespondentBank - The branch of the receiver, or another financial institution, at which the funds will be made available to the receiver.
    • ReceiverSite
    • ReceiversSub-Entity - Identifies a sub-entity within the receiver's organization.
    • ReceivingBank
    • ReceivingCompany
    • ReceivingFacilityScheduler
    • ReceivingFinancialInstitution - Financial institution designated to receive payment.
    • ReceivingLocation
    • ReceivingPointForCustomerSamples
    • ReceivingSub-Location
    • RecipientOfCivilorLegalLiabilityPayment
    • ReclamationCenter
    • Record-KeepingAddress
    • RecoveryRoom
    • RecreationalTherapyServices
    • Referee
    • Reference
    • ReferencesEmployer
    • ReferralProvider
    • ReferringHealthCareProvider - Health care provider that referred patient to current provider of services.
    • ReferringProvider
    • Refinery
    • RefineryOperator
    • RefusalParty - Identification of the party responsible for a refusal.
    • Region
    • RegionalOffice
    • RegisteredBusinessName
    • RegisteredInvestmentAdvisor
    • RegisteredOffice
    • RegisteredOwner
    • RegisteredPrincipal - An individual who is registered as a principal for an entity.
    • RegisteringNonparentParty
    • RegisteringParentParty
    • RegisteringParty - Party performing the registration.
    • Registrar
    • RegistrationTribunal - Name of the tribunal where the company is registered.
    • RegularDealer
    • RegulatoryStateDistrict
    • RegulatoryStateEntity
    • RehabilitationFacility
    • RehabilitationInpatientUnit
    • RehabilitationOutpatientServices
    • ReimbursingBank - Identifies the financial institution through which the reimbursement is to be effected.
    • ReinsuranceIntermediaryOrBroker - Intermediary party between ceding company and reinsurance.
    • Reinsurer
    • Relative
    • ReleaseDrayman
    • ReleaseToParty - Party to which the goods or container(s) is (are) to be released.
    • RemittingBank - The bank to which the principal has entrusted the handling of a collection.
    • RemitTo
    • RenderingProvider
    • Renter
    • RentPayor
    • RepairingOutlet
    • RepairOrRefurbishLocation
    • ReplacingManufacturer - A code used to identify a party who replaces the previous party for the manufacture of an article.
    • Reporter
    • ReportingCarrier - Party who makes the cargo report to Customs.
    • ReportingCarriersNominatedAgentOrRepresentative - (Customs) Agent who formally makes a cargo report to Customs on behalf of the carrier.
    • ReportingLocation
    • ReportingOfficer
    • Representative
    • ReproductiveHealthServices
    • RequestedLender
    • Requestor - The party requesting an action.
    • ResaleCustomer
    • ResaleDealer
    • ResearchInstitute
    • Reservoir
    • ResidenceOrDomicile
    • ResidencyInstitution
    • ResidentBeneficiary - The ultimate resident recipient of the funds. Normally the account owner who is reimbursed by the payor.
    • ResidentInstructingParty - Identifies the resident party originating the instruction.
    • RespiratoryTherapyServices
    • RespiteCareFacility
    • ResponsibleExhibitor
    • ResponsibleGovernmentAgency - Identifies the responsible government agency.
    • ResponsibleInstallationDestination
    • ResponsibleInstallationOrigin
    • ResponsibleParty - Identifies the party that can be called to account.
    • RetailAccount
    • RetailPharmacy
    • Retrocessionaire
    • ReturnedTo
    • RoadCarrier - A road carrier moving cargo.
    • RoutingParty - Party responsible for the selection of the carrier(s).
    • RoutingPoint
    • RoyaltyOwner
    • RuralHealthClinic
    • SalesAssistant
    • SalesOffice
    • Salesperson
    • SalesResponsibility - Description to be provided.
    • SalvageCarrier
    • SamplesToBeReturnedTo
    • SamplingLocation
    • School-BasedServiceProvider
    • SchoolDistrict
    • SCorporation
    • ScreeningPoint
    • SealingCompany
    • SecondaryInventoryControlActivity
    • SecondaryLocationAddress
    • SecondaryPayer
    • SecondaryTaxpayer
    • SecondaryWarranter
    • SecondContact
    • SecondContactOrganization
    • SecondHome
    • SecondLevelParentCompany
    • Secretariat - Party is a secretariat.
    • Section8AProgramParticipantFirm
    • SecuredParty - Identifies a party that is guaranteed against loss.
    • SecuredPartyCompany
    • SecuredPartyIndividual
    • SelfInsured
    • Seller - (3346) Party selling merchandise to a buyer.
    • SellerAsOfficiallyRegistered - Selling party as officially registered with government.
    • SellersAgentOrRepresentative - (3254) Party representing the seller for the purpose of the trade transaction.
    • SellersFinancialInstitution - Financial institution designated by seller to receive payment. RDFI (ACH transfers).
    • SellingAgent
    • SellingOffice
    • SellingParty
    • SenderOfFunds - Identifies the party that sends the funds.
    • SendersCorrespondentBank - The account, or branch of the sender, or another financial institution, through which the sender will reimburse the receiver.
    • SeniorMembershipProgram
    • ServiceBureau - Party carrying out service bureau processing work, (e.g. a payroll bureau).
    • ServiceLocation
    • ServiceManager
    • ServiceOrganization
    • ServicePerformanceSite
    • ServicePerformer - The party who is performing a service.
    • ServiceProvider
    • ServiceRequester
    • ServiceSupplier
    • ServicingAgent
    • ServicingBroker
    • ServicingDealer
    • ServicingOrganization
    • SharedService
    • Shareholder - Identifies a shareholder.
    • ShelteredWorkshop
    • ShipFrom - Identification of the party from where goods will be or have been shipped.
    • Shipper
    • ShippersAssociation - An association of shippers.
    • ShippingLineService - Identifies the shipping line service organization.
    • ShippingScheduleIssuer - The party which issues a shipping schedule.
    • ShipTo - Identification of the party to where goods will be or have been shipped.
    • ShowingAgent
    • Sibling
    • Signatory - To specify that the party is a signatory.
    • Signer
    • SignificantOther
    • SinglePhotonEmissionComputerizedTomographyUnit
    • SiteOperator
    • SkilledNursingFacility
    • SkilledNursingorOtherLong-TermCareUnit
    • SkilledNursingServices
    • Slaughterer - Party or person who has undertaken or will undertake a slaughter.
    • SlotCharterParty - An identification code of a participant or user that books slots (space) on a ship, more likely on a long term basis on a series of sailings. He pays for the space whether he uses it or not.
    • SmallBaseStationLocation
    • SmallBusiness
    • SmallControlStationLocation
    • SmallDisadvantagedBusiness
    • SociallyDisadvantagedBusiness
    • SociallyDisadvantagedIndividual
    • SociallyInsuredPerson - A person who is registered in a social security scheme.
    • SocialSecuritiesCollectorsOffice - Party collecting social securities premiums.
    • SocietyOfPropertyInformationCompilersAndAnalysts
    • SoldTo
    • SoldToAndShipTo
    • SoldToIfDifferentFromBillTo
    • SoleProprietor - Identifies the sole proprietor.
    • Source
    • SourceMeterLocation
    • SourceOfInformation - To specify that the party is the source of information.
    • SourcePartyOfInformation
    • SpecialAccount
    • SpecialCounsel
    • SpecializedMobileRadioServiceLicensee
    • SpecializedOutpatientProgramForAIDSOrARC
    • SpecifiedRepository
    • SpeechTherapyServices
    • SportsMedicineClinicOrServices
    • Spouse - Person is a spouse.
    • SpouseInsured
    • SpudContractor
    • State
    • StateCharteredFacility
    • StateDivision
    • SteamshipCompany
    • Stockholder
    • StorageArea
    • StorageFacilityatDestination
    • StorageFacilityAtOrigin
    • Store
    • StoreClass
    • StoreGroup - Description to be provided.
    • StoreKeeper
    • StoreManager
    • Student
    • StudySubmitter
    • Sub-Account
    • Subcontractor - Firm carrying out a part of the works for a contractor.
    • SubcontractOrCognizantSecurityOffice
    • Subcontractor-Nominated - Subcontractor authorized by the owner after having been proposed.
    • SubcontractorWithDirectPayment - Subcontractor benefiting from direct payments.
    • Sub-Entity - A part into which an entity has been divided.
    • Subgroup
    • SubjectOfInquiry - The party is the subject of an inquiry.
    • SubjectProperty
    • Submitter - To specify that the party is a submitter.
    • SubmitterOfSample - An entity responsible for the submission of a sample.
    • Sub-Office
    • Subscriber
    • SubscribersEmployer
    • SubscribersSchool
    • SubsequentOwner
    • Sub-Servicer
    • Subsidiary - Identifies the subsidiary.
    • SubsidiaryDivision
    • SubstituteSupplier - Party which may be in a position to supply products or services should the main usual supplier be unable to do so.
    • SuccessfulJobApplicant - Person who has been chosen for a job.
    • SupervisingHealthCareProvider - Health care provider that supervised the rendering of a service.
    • SupervisingPhysician
    • Supervisor
    • SupervisoryAppraiserName
    • Supplier - Party who supplies goods and/or services.
    • SupplierOrManufacturer
    • SuppliersCorporateOffice - The identification of the supplier's corporate office.
    • SupplierWorkTeam - The supplier's team responsible for performing the work.
    • SupplySource
    • SupportingPersonnel
    • SupportParty
    • Surety - Natural or legal person (generally a bank or insurance company) who accepts responsibility in due legal form for the financial consequences of non-fulfillment of another's obligations to the Customs (CCC).
    • SuretyForAdditions - Natural of legal person (generally a bank of insurance company) who accepts responsibility in due legal form for the financial guarantee to Customs of the payment of additional duties or fees that become due against a particular shipment, which have not previously been covered by surety.
    • SuretyForAntidumpingOrCountervailingDuty - Natural or legal person that has been contracted by the importer to guarantee to Customs the payment of antidumping and/or countervailing duties that become due against a particular shipment.
    • SurfaceDischargeAgency
    • SurfaceManagementEntity
    • Surgeon
    • SurplusDealer
    • Surveyor-PofessionalQuantity - Party responsible to the owner for the quantification and valuation of the works.
    • SurveyorQuantity - Party responsible for the quantification and valuation of the works on behalf of the contractor.
    • SurveyorTopographical - Party responsible for topographical measurements.
    • System
    • TankFarm
    • TankFarmOwner
    • TariffIssuer - The issuer of a tariff, e.g. a freight tariff.
    • TaxAddress
    • TaxAuthority
    • TaxCollectorsOffice - Party collecting taxes.
    • TaxExemptOrganization
    • Team
    • TechnicalOffice
    • TelephoneAnsweringServiceBureau
    • Tenant
    • TenantManager - A code to identify the party who rents the rights to use the goodwill and facilities of an enterprise.
    • Tenderer - Firm answering an invitation to tender.
    • Terminal
    • TerminalLocation
    • TerminalOperator - A party which handles the loading and unloading of marine vessels.
    • TertiaryPayer
    • TestingLaboratory
    • TestingService
    • TestSponsor
    • TheaterCircuit
    • Theatre
    • TherapeuticRadioisotopeFacility
    • ThirdParty - Another party besides the two principals.
    • ThirdPartyAdministrator
    • ThirdPartyInvestmentAdvisor
    • ThirdPartyMarketer
    • ThirdPartyRepricingOrganization
    • ThirdPartyRepricingPreferredProviderOrganization
    • ThirdPartyReviewingOrganization
    • ThirdPartyReviewingPreferredProviderOrganization
    • Titleholder
    • TitleInsuranceServicesProvider
    • TitleUnderwriter
    • Tooling
    • ToolingDesign
    • ToolingFabrication
    • ToolSource
    • TopParentCompanyInSameCountry
    • TowingAgency
    • Tradename
    • TradeNameSynonym
    • TradeUnion - Organisation representing employees.
    • TrainingInstitution
    • TransferPoint
    • TransferringParty
    • TransferTo - The party which is the recipient of a transfer.
    • TransitAuthority
    • TransitChargePayer - Party, other than the ordering party, which has to pay the charges concerning the transit operations.
    • TransitFreightForwarder - Freight forwarder to whom transit consignments are addressed, and from whom they are to be on-forwarded.
    • TransitPrincipal - Natural or legal person responsible for the satisfactory performance of a Customs transit operation. Source: CCC.
    • TransitPrincipalsAgentOrRepresentative - Agent acting on behalf of the transit principal (CCC).
    • Transmitter
    • TransportationOffice - The office that provides transportation information.
    • TransporterOfHazardousWaste
    • TransshipmentParty - A party responsible for transshipment.
    • TraumaCenter
    • TreatmentFacility
    • TribalGovernment
    • Trust
    • Trustee - To specify that the party is a trustee.
    • TrusteesAttorney
    • TrustOfficer
    • TrustOrEstate
    • TuberculosisAndOTherRespiratoryDiseasesFacility
    • UltimateConsignee - Party who has been designated on the invoice or packing list as the final recipient of the stated merchandise.
    • UltimateCustomer - The final recipient of goods.
    • UltimateParentCompany - Identifies the ultimate parent company.
    • UltimateSameCountryParentCompany - Identifies the highest level parent company in the same country.
    • UltrasoundUnit
    • UnassignedAgent
    • Underwriter
    • UnexpectedHandlingParty - Party authorized (during a voyage) to apply unexpected handling procedures or party having applied these procedures.
    • Union
    • UnitedStatesCustomsBroker
    • UnitedStatesOverseasSecurityAdministrationOffice
    • UnitProperty
    • University-CollegeOrSchool
    • UnloadingParty - Description to be provided.
    • UnserviceableMaterialConsignee
    • UpstreamMeterLocation
    • UpstreamParty
    • USTrustee
    • UtilizationManagementOrganization
    • VacationHome
    • ValidatingParty
    • ValueAddedNetworkProvider - A party that provides telecommunications interconnectivity services in an electronic data interchange environment.
    • Vehicle
    • VehicleCustodian
    • VehicleSalvageAssignment
    • Vendor - Party vending goods or services.
    • VesselMaster - Master of the conveyance.
    • VesselName
    • Veteran-OwnedBusiness
    • VeteransAdministrationFacility
    • VeteransAdministrationLoanAuthorizedSupplier
    • VeteransAdministrationLoanGuarantyAuthority
    • Veterinarian
    • VeterinaryHospital
    • Victim
    • VideoDepartment
    • VolunteerServicesDepartment
    • Voter
    • WageEarner
    • Warehouse - The name of the warehouse where product is held.
    • WarehouseDepositor - (3004) Party depositing goods in a warehouse.
    • WarehouseKeeper - (3022) Party taking responsibility for goods entered into a warehouse.
    • Warranter
    • WaterAmbulanceServices
    • WaterSystem
    • WeightingParty - Party designated (legally accepted) to ascertain the weight.
    • WellCasingDepthAuthority
    • WellPadConstructionContractor
    • Wholesaler - Seller of articles, often in large quantities, to be retailed by others.
    • Wholly-OwnedSubsidiary
    • Winner
    • WithdrawalPoint
    • Witness
    • WitnessForDefendant
    • WitnessForPlaintiff
    • WitnessForProsecution
    • Woman-OwnedBusiness
    • Woman-OwnedBusinessLarge
    • Woman-OwnedBusinessSmall
    • WomensHealthCenterOrServices
    • WorksiteHealthPromotionFacility
    • WorksManager
    • WorkTeam - Team responsible for performing work.
    • WritingAgent
    • X-RayRadiationTherapyUnit

[^]Code Fragment

    <xsd:simpleType name="PartyRoleCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="AcceptanceLocation">
        <xsd:enumeration value="AcceptingParty">
        <xsd:enumeration value="Accountant">
        <xsd:enumeration value="AccountCoordinator">
        <xsd:enumeration value="AccountingStation">
        <xsd:enumeration value="AccountOf">
        <xsd:enumeration value="AccountOfDestinationParty">
        <xsd:enumeration value="AccountOf-OriginParty">
        <xsd:enumeration value="AccountOwner">
        <xsd:enumeration value="AccountOwnersServicingBankOnTheReceivingSide">
        <xsd:enumeration value="AccountOwnersServicingBankOnTheSendingSide">
        <xsd:enumeration value="AccountServicingFinancialInstitution">
        <xsd:enumeration value="AccountsPayableOffice">
        <xsd:enumeration value="AcknowledgementRecipient">
        <xsd:enumeration value="Acronym">
        <xsd:enumeration value="ActionParty">
        <xsd:enumeration value="ActualPurchasersCustomer">
        <xsd:enumeration value="ActualReferredByOrganization">
        <xsd:enumeration value="ActualReferredToOrganization">
        <xsd:enumeration value="AcuteCareHospital">
        <xsd:enumeration value="AdditionalAddress">
        <xsd:enumeration value="AdditionalDebtor">
        <xsd:enumeration value="AdditionalDeliveryAddress">
        <xsd:enumeration value="AdditionalPickUpAddress">
        <xsd:enumeration value="Adjuster">
        <xsd:enumeration value="AdministrationCentre">
        <xsd:enumeration value="Administrator">
        <xsd:enumeration value="AdmittingHealthCareProvider">
        <xsd:enumeration value="AdmittingServices">
        <xsd:enumeration value="AdmittingSurgeon">
        <xsd:enumeration value="AdultDayCareProgramFacility">
        <xsd:enumeration value="Advertiser">
        <xsd:enumeration value="AdvertisingGroup">
        <xsd:enumeration value="AdviseThroughBank">
        <xsd:enumeration value="AdvisingBank">
        <xsd:enumeration value="Advisor">
        <xsd:enumeration value="Affiant">
        <xsd:enumeration value="Affiliate">
        <xsd:enumeration value="AffiliatedCompany">
        <xsd:enumeration value="AffiliatedParty">
        <xsd:enumeration value="Agency">
        <xsd:enumeration value="AgencyGrantingSecurityClearance">
        <xsd:enumeration value="AgentOrRepresentative">
        <xsd:enumeration value="AgentsBank">
        <xsd:enumeration value="AIDSOrARCUnit">
        <xsd:enumeration value="AirAmbulanceServices">
        <xsd:enumeration value="AirCargoCompany">
        <xsd:enumeration value="AirForceFacility">
        <xsd:enumeration value="Airline">
        <xsd:enumeration value="AirportAuthority">
        <xsd:enumeration value="AlcoholBeverageDepartment">
        <xsd:enumeration value="AlcoholismAndOtherChemicalDependencyFacility">
        <xsd:enumeration value="AlcoholOrDrugAbuseOrDependencyInpatientUnit">
        <xsd:enumeration value="AlcoholOrDrugAbuseOrDependencyOutpatientServices">
        <xsd:enumeration value="Alias">
        <xsd:enumeration value="AlienAffiliate">
        <xsd:enumeration value="AllegedDebtor">
        <xsd:enumeration value="Alliance">
        <xsd:enumeration value="AlliedHealthProfessional">
        <xsd:enumeration value="AllotmentCustomer">
        <xsd:enumeration value="AllowableRecipient">
        <xsd:enumeration value="AlternateReturnAddress">
        <xsd:enumeration value="AlternativeAddressee">
        <xsd:enumeration value="AlternativeManufacturer">
        <xsd:enumeration value="AlzheimersDiagnosticOrAssessmentServices">
        <xsd:enumeration value="AmendedName">
        <xsd:enumeration value="AmericanIndian-OwnedBusiness">
        <xsd:enumeration value="AmicusCuriae">
        <xsd:enumeration value="AnesthesiologyServices">
        <xsd:enumeration value="AngioplastyFacility">
        <xsd:enumeration value="AnimalBeingInvestigated">
        <xsd:enumeration value="AnimalSource">
        <xsd:enumeration value="Annuitant">
        <xsd:enumeration value="AnnuitantPayor">
        <xsd:enumeration value="AntennaSite">
        <xsd:enumeration value="Appellant">
        <xsd:enumeration value="Appellee">
        <xsd:enumeration value="Applicant">
        <xsd:enumeration value="ApplicantComaker">
        <xsd:enumeration value="ApplicantForJob">
        <xsd:enumeration value="ApplicantsBank">
        <xsd:enumeration value="ApplicantsCosigner">
        <xsd:enumeration value="ApplicantsEmployer">
        <xsd:enumeration value="ApplicantsReference">
        <xsd:enumeration value="ApplicationParty">
        <xsd:enumeration value="AppraisalCompany">
        <xsd:enumeration value="AppraiserName">
        <xsd:enumeration value="ApprovedConsignor">
        <xsd:enumeration value="ApprovedImporter">
        <xsd:enumeration value="Approver">
        <xsd:enumeration value="Arbitrator">
        <xsd:enumeration value="Architect">
        <xsd:enumeration value="Architect-Designer">
        <xsd:enumeration value="AreaOfOperation">
        <xsd:enumeration value="ArmedServicesLocationDesignation">
        <xsd:enumeration value="ArmyFacility">
        <xsd:enumeration value="ArrestingOfficer">
        <xsd:enumeration value="ArthritisTreatmentCenter">
        <xsd:enumeration value="AssetAccountHolder">
        <xsd:enumeration value="Assignee">
        <xsd:enumeration value="Assigner">
        <xsd:enumeration value="Assignor">
        <xsd:enumeration value="AssistantSurgeon">
        <xsd:enumeration value="AssistantUSTrustee">
        <xsd:enumeration value="AssociateGeneralAgent">
        <xsd:enumeration value="Association">
        <xsd:enumeration value="AttendingPhysician">
        <xsd:enumeration value="Attorney">
        <xsd:enumeration value="AttorneyForDefendantPrivate">
        <xsd:enumeration value="AttorneyForDefendantPublic">
        <xsd:enumeration value="AttorneyForPlaintiff">
        <xsd:enumeration value="AttorneyOfRecord">
        <xsd:enumeration value="Auctioneer">
        <xsd:enumeration value="AuditOffice">
        <xsd:enumeration value="Auditor">
        <xsd:enumeration value="AuthenticatingParty">
        <xsd:enumeration value="Author">
        <xsd:enumeration value="AuthorityForShipment">
        <xsd:enumeration value="AuthorizationAssignedBy">
        <xsd:enumeration value="AuthorizedAcceptingOfficial">
        <xsd:enumeration value="AuthorizedEntity">
        <xsd:enumeration value="AuthorizedExporter">
        <xsd:enumeration value="AuthorizedFrom">
        <xsd:enumeration value="AuthorizedImporter">
        <xsd:enumeration value="AuthorizedMarketer">
        <xsd:enumeration value="AuthorizedOfficial">
        <xsd:enumeration value="AuthorizedTo">
        <xsd:enumeration value="AuthorizedTrader">
        <xsd:enumeration value="AuthorizingOfficial">
        <xsd:enumeration value="AutomatedDataProcessingPoint">
        <xsd:enumeration value="AutomatedUnderwritingSystem">
        <xsd:enumeration value="AvailableWithBank">
        <xsd:enumeration value="AvailabilityShipToParty">
        <xsd:enumeration value="Bailiff">
        <xsd:enumeration value="BailmentWarehouse">
        <xsd:enumeration value="BailPayor">
        <xsd:enumeration value="BakeryDepartment">
        <xsd:enumeration value="Bank">
        <xsd:enumeration value="Banker">
        <xsd:enumeration value="BankruptcyReferee">
        <xsd:enumeration value="BankruptcyTrustee">
        <xsd:enumeration value="BaseJurisdiction">
        <xsd:enumeration value="BasePeriodEmployer">
        <xsd:enumeration value="Battery">
        <xsd:enumeration value="BeneficialOwner">
        <xsd:enumeration value="Beneficiary">
        <xsd:enumeration value="BeneficiarysBank">
        <xsd:enumeration value="Bidder">
        <xsd:enumeration value="BidOpeningLocation">
        <xsd:enumeration value="BillAndShipTo">
        <xsd:enumeration value="BilledFrom">
        <xsd:enumeration value="BillingProvider">
        <xsd:enumeration value="BillingService">
        <xsd:enumeration value="BillOfLadingRecipient">
        <xsd:enumeration value="BillTo">
        <xsd:enumeration value="Bill-ToPartyForDiversionCharges">
        <xsd:enumeration value="BirthingRoomOrLDRPRoom">
        <xsd:enumeration value="BirthName">
        <xsd:enumeration value="Birthplace">
        <xsd:enumeration value="BloodBank">
        <xsd:enumeration value="BoardOfRealtors">
        <xsd:enumeration value="BobtailServicePoint">
        <xsd:enumeration value="Bondsman">
        <xsd:enumeration value="BookingAgent">
        <xsd:enumeration value="BookingOffice">
        <xsd:enumeration value="Bookkeeper">
        <xsd:enumeration value="BorderCrossing">
        <xsd:enumeration value="Borrower">
        <xsd:enumeration value="BorrowersEmployer">
        <xsd:enumeration value="Bottler">
        <xsd:enumeration value="Brakeman">
        <xsd:enumeration value="Branch">
        <xsd:enumeration value="BrandName">
        <xsd:enumeration value="BreakBulkBerthOperator">
        <xsd:enumeration value="BreakBulkPoint">
        <xsd:enumeration value="Broadcaster">
        <xsd:enumeration value="Broker">
        <xsd:enumeration value="BrokerDealer">
        <xsd:enumeration value="BrokerOpinionOrAnalysisRequester">
        <xsd:enumeration value="BrokerOrSalesOffice">
        <xsd:enumeration value="BrokersAssistant">
        <xsd:enumeration value="BuilderName">
        <xsd:enumeration value="BuildingInspectorate">
        <xsd:enumeration value="BuildingSiteEngineer">
        <xsd:enumeration value="BuildingSiteForwarder">
        <xsd:enumeration value="BuildingSitePurchaser">
        <xsd:enumeration value="BureauOfLandManagementPropertyUnit">
        <xsd:enumeration value="BurnCareUnit">
        <xsd:enumeration value="Business">
        <xsd:enumeration value="BusinessArea">
        <xsd:enumeration value="BusinessAssociate">
        <xsd:enumeration value="BusinessEntity">
        <xsd:enumeration value="BusinessPartner">
        <xsd:enumeration value="Buyer">
        <xsd:enumeration value="BuyerAsOfficiallyRegistered">
        <xsd:enumeration value="BuyersAgentOrRepresentative">
        <xsd:enumeration value="BuyersBank">
        <xsd:enumeration value="BuyersCorporateOffice">
        <xsd:enumeration value="BuyersFinancialInstitution">
        <xsd:enumeration value="BuyersParentCompany">
        <xsd:enumeration value="BuyersQualityReviewBoard">
        <xsd:enumeration value="BuyingGroup">
        <xsd:enumeration value="BuyingParty">
        <xsd:enumeration value="CanadianCustomsBroker">
        <xsd:enumeration value="Candidate">
        <xsd:enumeration value="CandyAndConfectionsDepartment">
        <xsd:enumeration value="CardiacCatherizationLaboratory">
        <xsd:enumeration value="CardiacIntensiveCareUnit">
        <xsd:enumeration value="CardiacRehabilitationProgramFacility">
        <xsd:enumeration value="CardiacRehabilitationServices">
        <xsd:enumeration value="CarnetIssuer">
        <xsd:enumeration value="Carrier">
        <xsd:enumeration value="CarriersAgent">
        <xsd:enumeration value="CaseManager">
        <xsd:enumeration value="CaseOfNeedParty">
        <xsd:enumeration value="CashPoolLevelAccountServicingFinancialInstitution">
        <xsd:enumeration value="CashPoolSub-AccountServicingFinancialInstitution">
        <xsd:enumeration value="CashPoolTopAccountServicingFinancialInstitution">
        <xsd:enumeration value="CedingCompany">
        <xsd:enumeration value="CentralBankOrRegulatoryAuthority">
        <xsd:enumeration value="CentralCatalogueParty">
        <xsd:enumeration value="CertifiedAccountant">
        <xsd:enumeration value="CertifyingParty">
        <xsd:enumeration value="Chairperson">
        <xsd:enumeration value="ChamberOfCommerce">
        <xsd:enumeration value="ChangedAddress">
        <xsd:enumeration value="ChargesPayerAtDestination">
        <xsd:enumeration value="Charity">
        <xsd:enumeration value="CharterSchool">
        <xsd:enumeration value="ChassisProvider">
        <xsd:enumeration value="CheckingParty">
        <xsd:enumeration value="ChequeDrawnBank">
        <xsd:enumeration value="ChequeOrder">
        <xsd:enumeration value="ChiefDeputyClerkOfCourt">
        <xsd:enumeration value="Child">
        <xsd:enumeration value="ChildrensChronicDiseaseFacility">
        <xsd:enumeration value="ChildrensDayCareCenter">
        <xsd:enumeration value="ChildrensEyeEarNoseAndThroatFacility">
        <xsd:enumeration value="ChildrensGeneralFacility">
        <xsd:enumeration value="ChildrensHospitalUnitOfAnInstitution">
        <xsd:enumeration value="ChildrensOrthopedicFacility">
        <xsd:enumeration value="ChildrensOtherSpecialtyFacility">
        <xsd:enumeration value="ChildrensPsychiatricFacility">
        <xsd:enumeration value="ChildrensRehabilitationFacility">
        <xsd:enumeration value="ChildrensTuberculosisAndOtherRespiratoryDiseasesFacility">
        <xsd:enumeration value="Chiropractor">
        <xsd:enumeration value="ChronicDiseaseFacility">
        <xsd:enumeration value="ChronicObstructivePulmonaryDiseaseServiceFacility">
        <xsd:enumeration value="ChurchOperatedFacility">
        <xsd:enumeration value="CigarettesAndTobaccoDepartment">
        <xsd:enumeration value="CircuitLocationIdentifier">
        <xsd:enumeration value="City">
        <xsd:enumeration value="ClaimAdministrator">
        <xsd:enumeration value="Claimant">
        <xsd:enumeration value="ClaimantAuthorizedRepresentative">
        <xsd:enumeration value="ClaimRecipient">
        <xsd:enumeration value="ClearingHouse">
        <xsd:enumeration value="Clerk">
        <xsd:enumeration value="ClerkOfCourt">
        <xsd:enumeration value="Clinic">
        <xsd:enumeration value="ClosedDoorPharmacy">
        <xsd:enumeration value="ClosedSale">
        <xsd:enumeration value="ClosingAgent">
        <xsd:enumeration value="CoatingOrPaintSupplier">
        <xsd:enumeration value="Co-Borrower">
        <xsd:enumeration value="Co-Contractor">
        <xsd:enumeration value="Co-Counsel">
        <xsd:enumeration value="Co-Debtor">
        <xsd:enumeration value="Co-Defendant">
        <xsd:enumeration value="Co-Driver">
        <xsd:enumeration value="Co-Investigator">
        <xsd:enumeration value="CollateralAssignee">
        <xsd:enumeration value="CollectingBank">
        <xsd:enumeration value="CollectionPrincipal">
        <xsd:enumeration value="CommercialInsurer">
        <xsd:enumeration value="CommissionableAgent">
        <xsd:enumeration value="CommissionProcessor">
        <xsd:enumeration value="CommunityAgent">
        <xsd:enumeration value="CommunityHealthPromotionFacility">
        <xsd:enumeration value="CompanyAssignedWell">
        <xsd:enumeration value="CompanyInterviewerWorksFor">
        <xsd:enumeration value="CompanyInWhichInterestHeld">
        <xsd:enumeration value="CompanyMergedWith">
        <xsd:enumeration value="Company-OwnedOilField">
        <xsd:enumeration value="CompanyWhichHoldsFinancialInterest">
        <xsd:enumeration value="ComparableProperty">
        <xsd:enumeration value="ComparablePropertyListing">
        <xsd:enumeration value="ComparableRentals">
        <xsd:enumeration value="CompetingProperty">
        <xsd:enumeration value="CompetitivePropertyListing">
        <xsd:enumeration value="CompilationAgency">
        <xsd:enumeration value="Complainant">
        <xsd:enumeration value="ComplainantsAttorney">
        <xsd:enumeration value="ComponentManufacturer">
        <xsd:enumeration value="ComprehensiveGeriatricAssessmentFacility">
        <xsd:enumeration value="ConcurrentEmployer">
        <xsd:enumeration value="Conductor">
        <xsd:enumeration value="ConductorPilot">
        <xsd:enumeration value="Conduit">
        <xsd:enumeration value="ConnectingCarrier">
        <xsd:enumeration value="Connection">
        <xsd:enumeration value="Consignee">
        <xsd:enumeration value="ConsigneeCourierTransferStation">
        <xsd:enumeration value="ConsigneeOfVessel">
        <xsd:enumeration value="ConsigneesAgent">
        <xsd:enumeration value="ConsigneeToBeSpecified">
        <xsd:enumeration value="Consignee-ToReceiveLargeParcelsAndFreight">
        <xsd:enumeration value="Consignee-ToReceiveMailAndSmallParcels">
        <xsd:enumeration value="Consignor">
        <xsd:enumeration value="ConsignorCourierTransferStation">
        <xsd:enumeration value="ConsignorsRepresentative">
        <xsd:enumeration value="ConsolidatedDebtor">
        <xsd:enumeration value="Consolidator">
        <xsd:enumeration value="ConstructionContractor">
        <xsd:enumeration value="ConstructionFirm">
        <xsd:enumeration value="ConsultantsOffice">
        <xsd:enumeration value="ConsultingPhysician">
        <xsd:enumeration value="ConsumerCreditAccountCompany">
        <xsd:enumeration value="ConsumerReferralContact">
        <xsd:enumeration value="ConsumerServiceProvider">
        <xsd:enumeration value="ConsumerServiceProviderCustomer">
        <xsd:enumeration value="Contact">
        <xsd:enumeration value="ContactBank1">
        <xsd:enumeration value="ContactBank2">
        <xsd:enumeration value="ContactOffice">
        <xsd:enumeration value="ContactParty">
        <xsd:enumeration value="ContactParty1">
        <xsd:enumeration value="ContactParty2">
        <xsd:enumeration value="ContactParty3">
        <xsd:enumeration value="ContactParty4">
        <xsd:enumeration value="ContactPerson">
        <xsd:enumeration value="ContainerLocation">
        <xsd:enumeration value="ContainerLocationParty">
        <xsd:enumeration value="ContainerOperatorOrLessee">
        <xsd:enumeration value="ContainerReturnCompany">
        <xsd:enumeration value="ContainerSurveyAgent">
        <xsd:enumeration value="ContingentAnnuitant">
        <xsd:enumeration value="ContingentBeneficiary">
        <xsd:enumeration value="ContingentOwner">
        <xsd:enumeration value="ContractAdministrationOffice">
        <xsd:enumeration value="ContractedServiceProvider">
        <xsd:enumeration value="ContractHolder">
        <xsd:enumeration value="ContractingOfficerRepresentative">
        <xsd:enumeration value="Contractor-General">
        <xsd:enumeration value="ContractOrCognizantSecurityOffice">
        <xsd:enumeration value="Contractor-Lead">
        <xsd:enumeration value="Contractor-Main">
        <xsd:enumeration value="ContractualDeliveryMeter">
        <xsd:enumeration value="ContractualReceiptMeter">
        <xsd:enumeration value="ControllerQuality">
        <xsd:enumeration value="Converter">
        <xsd:enumeration value="ConvoyingParty">
        <xsd:enumeration value="Co-Occupant">
        <xsd:enumeration value="Co-Operative">
        <xsd:enumeration value="CooperativeBuyingGroup">
        <xsd:enumeration value="Coordinator">
        <xsd:enumeration value="Co-Owner">
        <xsd:enumeration value="Co-Participant">
        <xsd:enumeration value="Co-Producer">
        <xsd:enumeration value="CopyMessageTo">
        <xsd:enumeration value="CorporateOffice">
        <xsd:enumeration value="Corporation">
        <xsd:enumeration value="CorporationFor-ProfitFacility">
        <xsd:enumeration value="CorrectedAddress">
        <xsd:enumeration value="CorrectedInsured">
        <xsd:enumeration value="CorrectedName">
        <xsd:enumeration value="Cosigner">
        <xsd:enumeration value="CosignersEmployer">
        <xsd:enumeration value="CouncilOfGovernments">
        <xsd:enumeration value="CounterClaimant">
        <xsd:enumeration value="Country">
        <xsd:enumeration value="CountryOfDestination">
        <xsd:enumeration value="CountryOfExport">
        <xsd:enumeration value="CountryOfOrigin">
        <xsd:enumeration value="County">
        <xsd:enumeration value="Court">
        <xsd:enumeration value="CourtAppointedAttorney">
        <xsd:enumeration value="CreditGrantor">
        <xsd:enumeration value="Creditor">
        <xsd:enumeration value="CreditorsAttorney">
        <xsd:enumeration value="CreditRatingAgency">
        <xsd:enumeration value="CreditReportingAgency">
        <xsd:enumeration value="CrewMember">
        <xsd:enumeration value="CrimeVictim">
        <xsd:enumeration value="CrossClaimant">
        <xsd:enumeration value="Cross-TownSwitch">
        <xsd:enumeration value="CTScannerUnit">
        <xsd:enumeration value="CurrentEmployer-Primary">
        <xsd:enumeration value="CurrentEmployer-Secondary">
        <xsd:enumeration value="CurrentReceiver">
        <xsd:enumeration value="CurrentSender">
        <xsd:enumeration value="CustodialParent">
        <xsd:enumeration value="Custodian">
        <xsd:enumeration value="Customer">
        <xsd:enumeration value="CustomerFOrWhomSameOrSimilarWOrkWasPerFormed">
        <xsd:enumeration value="CustomerIdentificationFileCustomerIdentifier">
        <xsd:enumeration value="Customs">
        <xsd:enumeration value="CustomsBroker">
        <xsd:enumeration value="CustomsOfficeOfClearance">
        <xsd:enumeration value="DairyDepartment">
        <xsd:enumeration value="DataProcessingServiceBureau">
        <xsd:enumeration value="Dealer">
        <xsd:enumeration value="Debtor">
        <xsd:enumeration value="DebtorCompany">
        <xsd:enumeration value="DebtorIndividual">
        <xsd:enumeration value="Debtor-In-Possession">
        <xsd:enumeration value="DebtorsAttorney">
        <xsd:enumeration value="DebtPaymentAuthorisationParty">
        <xsd:enumeration value="DecisionMaker">
        <xsd:enumeration value="Declarant">
        <xsd:enumeration value="DeclarantsAgentOrRepresentative">
        <xsd:enumeration value="Deconsolidator">
        <xsd:enumeration value="DefaultOrForeclosureSpecialist">
        <xsd:enumeration value="Defendant">
        <xsd:enumeration value="DelicatessenDepartment">
        <xsd:enumeration value="DeliveryAddress">
        <xsd:enumeration value="DeliveryParty">
        <xsd:enumeration value="DeliveryZone">
        <xsd:enumeration value="Dentist">
        <xsd:enumeration value="DepartmentOfJusticeFacility">
        <xsd:enumeration value="Dependent">
        <xsd:enumeration value="DependentInsured">
        <xsd:enumeration value="DependentName">
        <xsd:enumeration value="Depositor">
        <xsd:enumeration value="DesignatedHazardousWasteFacility">
        <xsd:enumeration value="DesignEngineering">
        <xsd:enumeration value="Designer">
        <xsd:enumeration value="DespatchChargePayer">
        <xsd:enumeration value="DespatchParty">
        <xsd:enumeration value="DestinationCarrier">
        <xsd:enumeration value="DestinationDrayman">
        <xsd:enumeration value="DestinationIntermodalRamp">
        <xsd:enumeration value="DestinationMailFacility">
        <xsd:enumeration value="DestinationTerminal">
        <xsd:enumeration value="DiagnosticRadioisotopeFacility">
        <xsd:enumeration value="DialysisCenters">
        <xsd:enumeration value="DifferentPremiseAddress">
        <xsd:enumeration value="Director">
        <xsd:enumeration value="DisabledIndividual">
        <xsd:enumeration value="DisbursingOfficer">
        <xsd:enumeration value="DischargePoint">
        <xsd:enumeration value="DisciplinaryContact">
        <xsd:enumeration value="Dispatcher">
        <xsd:enumeration value="Distiller">
        <xsd:enumeration value="DistributionRecipient">
        <xsd:enumeration value="Distributor">
        <xsd:enumeration value="DistributorBranch">
        <xsd:enumeration value="District">
        <xsd:enumeration value="DistrictAttorney">
        <xsd:enumeration value="DistrictJustice">
        <xsd:enumeration value="Division">
        <xsd:enumeration value="DoctorOfOptometry">
        <xsd:enumeration value="DoctorOfOsteopathy">
        <xsd:enumeration value="DocumentaryCreditAccountParty">
        <xsd:enumeration value="DocumentaryCreditAccountPartysBank">
        <xsd:enumeration value="DocumentaryCreditApplicant">
        <xsd:enumeration value="DocumentaryCreditBeneficiary">
        <xsd:enumeration value="DocumentaryCreditBeneficiarysBank">
        <xsd:enumeration value="DocumentaryCreditReimbursingBank">
        <xsd:enumeration value="DocumentaryCreditSecondBeneficiary">
        <xsd:enumeration value="DocumentCustodian">
        <xsd:enumeration value="DocumentOrMessageIssuerOrSender">
        <xsd:enumeration value="DocumentRecipient">
        <xsd:enumeration value="DoingBusinessAs">
        <xsd:enumeration value="DomesticFinancialInstitution">
        <xsd:enumeration value="DownstreamFirstSupplier">
        <xsd:enumeration value="DownstreamMeterLocation">
        <xsd:enumeration value="DownstreamParty">
        <xsd:enumeration value="Drawee">
        <xsd:enumeration value="DrillingContractor">
        <xsd:enumeration value="Driver">
        <xsd:enumeration value="Drop-OffLocation">
        <xsd:enumeration value="DryGroceryDepartment">
        <xsd:enumeration value="DurableMedicalEquipmentSupplier">
        <xsd:enumeration value="EconomicallyDisadvantagedIndividual">
        <xsd:enumeration value="EducationalInstitution">
        <xsd:enumeration value="ElectronicDataInterchangeCoordinatorPointAddress">
        <xsd:enumeration value="ElectronicFiler">
        <xsd:enumeration value="ElectronicRegistrationUtility">
        <xsd:enumeration value="ElectronicReturnOriginator">
        <xsd:enumeration value="ElementarySchool">
        <xsd:enumeration value="EligiblePartyToTheContract">
        <xsd:enumeration value="EligiblePartyToTheRate">
        <xsd:enumeration value="EmergencyDepartment">
        <xsd:enumeration value="EmergencyDepartmentSocialWorkServices">
        <xsd:enumeration value="EmergencyMedicalTechnician">
        <xsd:enumeration value="EmergencyProvider">
        <xsd:enumeration value="EmergencyResponseUnit">
        <xsd:enumeration value="EmergingSmallBusiness">
        <xsd:enumeration value="Employee">
        <xsd:enumeration value="EmployeeName">
        <xsd:enumeration value="Employer">
        <xsd:enumeration value="EmptyContainerResponsibleParty">
        <xsd:enumeration value="EmptyContainerReturnAgent">
        <xsd:enumeration value="EmptyEquipmentDespatchParty">
        <xsd:enumeration value="EmptyEquipmentReturnParty">
        <xsd:enumeration value="EndItemManufacturer">
        <xsd:enumeration value="EndUser">
        <xsd:enumeration value="EnergyInformationAdministration-OwnedOilField">
        <xsd:enumeration value="Engineer">
        <xsd:enumeration value="Engineer-Construction">
        <xsd:enumeration value="Engineer-Consultant">
        <xsd:enumeration value="Engineering">
        <xsd:enumeration value="EngineerMeasurement">
        <xsd:enumeration value="EngineerPilot">
        <xsd:enumeration value="Engineer-ResidentConstruction">
        <xsd:enumeration value="Enroller">
        <xsd:enumeration value="EntityHoldingTheInformation">
        <xsd:enumeration value="EntityInWhichAFinancialInterestIsHeld">
        <xsd:enumeration value="EntityProvidingTheService">
        <xsd:enumeration value="EntityResponsibleForFollow-Up">
        <xsd:enumeration value="EntryPointTechnicalAssessmentGroup">
        <xsd:enumeration value="EquipmentDrop-OffParty">
        <xsd:enumeration value="EquipmentOwner">
        <xsd:enumeration value="EquipmentRepairParty">
        <xsd:enumeration value="EstablishedLocation">
        <xsd:enumeration value="Estimator">
        <xsd:enumeration value="EventLocation">
        <xsd:enumeration value="Examiner">
        <xsd:enumeration value="Exchanger">
        <xsd:enumeration value="ExciseParty">
        <xsd:enumeration value="ExcludedParty">
        <xsd:enumeration value="ExecutiveCommitteeMember">
        <xsd:enumeration value="ExecutorOfEstate">
        <xsd:enumeration value="Exhibitor">
        <xsd:enumeration value="ExpertWitness">
        <xsd:enumeration value="Exporter">
        <xsd:enumeration value="Ex-Spouse">
        <xsd:enumeration value="ExtendedCareFacility">
        <xsd:enumeration value="ExtracorporealShock-WaveLithotripterUnit">
        <xsd:enumeration value="EyeEarNoseAndThroatFacility">
        <xsd:enumeration value="Facility">
        <xsd:enumeration value="Factor">
        <xsd:enumeration value="Factor-Correspondent">
        <xsd:enumeration value="FamilyMember">
        <xsd:enumeration value="Father">
        <xsd:enumeration value="FederalFacility">
        <xsd:enumeration value="FederalGovernment">
        <xsd:enumeration value="FederallyCharteredFacility">
        <xsd:enumeration value="FederalStateCountyOrCityFacility">
        <xsd:enumeration value="FellowshipInstitution">
        <xsd:enumeration value="Felon">
        <xsd:enumeration value="Field">
        <xsd:enumeration value="FieldorBranchOffice">
        <xsd:enumeration value="FilerName">
        <xsd:enumeration value="FilingAddress">
        <xsd:enumeration value="FilingLocation">
        <xsd:enumeration value="FilingOffice">
        <xsd:enumeration value="FinalCustomerOrganization">
        <xsd:enumeration value="FinalMaintenanceOrganization">
        <xsd:enumeration value="FinalMaintenancePeriodDesignatingOrganization">
        <xsd:enumeration value="FinalMessageRecipient">
        <xsd:enumeration value="FinalRecipient">
        <xsd:enumeration value="FinalReferredToOrganization">
        <xsd:enumeration value="FinalScheduledDestination">
        <xsd:enumeration value="FinancialInstitution">
        <xsd:enumeration value="FinancialPlanner">
        <xsd:enumeration value="FinancialStatementRecipient">
        <xsd:enumeration value="Fireman">
        <xsd:enumeration value="FirstAppraiser">
        <xsd:enumeration value="FirstBreakTerminal">
        <xsd:enumeration value="FirstContact">
        <xsd:enumeration value="FirstSupplier">
        <xsd:enumeration value="FitnessCenter">
        <xsd:enumeration value="FloodCertifier">
        <xsd:enumeration value="FloodDeterminationProvider">
        <xsd:enumeration value="FloralDepartment">
        <xsd:enumeration value="FoodServiceOperator">
        <xsd:enumeration value="ForeclosingLender">
        <xsd:enumeration value="ForeignDisclosureInformationOffice">
        <xsd:enumeration value="ForeignLanguageSynonym">
        <xsd:enumeration value="ForeignOffice">
        <xsd:enumeration value="ForeignRegistrationLocation">
        <xsd:enumeration value="ForeignSupplier">
        <xsd:enumeration value="Formation">
        <xsd:enumeration value="FormerAddress">
        <xsd:enumeration value="FormerlyDoingBusinessAs">
        <xsd:enumeration value="FormerlyKnownAs">
        <xsd:enumeration value="FormerPresident">
        <xsd:enumeration value="FormerRegisteredAddress">
        <xsd:enumeration value="FormerResidence">
        <xsd:enumeration value="ForProfitHealthCareProvider">
        <xsd:enumeration value="Forwarder">
        <xsd:enumeration value="Foundation">
        <xsd:enumeration value="Founder">
        <xsd:enumeration value="Franchisee">
        <xsd:enumeration value="Franchisor">
        <xsd:enumeration value="FreeonBoardPoint">
        <xsd:enumeration value="FreightForwarder">
        <xsd:enumeration value="FreightManagementFacilitator">
        <xsd:enumeration value="FreightOrChargesPayer">
        <xsd:enumeration value="FreightPayerOnBehalfOfTheConsignee">
        <xsd:enumeration value="FreightPayerOnBehalfOfTheConsignor">
        <xsd:enumeration value="FrozenDepartment">
        <xsd:enumeration value="FutureAddress">
        <xsd:enumeration value="GainingInventoryManager">
        <xsd:enumeration value="GaragedLocation">
        <xsd:enumeration value="Garnishee">
        <xsd:enumeration value="GasPlant">
        <xsd:enumeration value="GasTransactionEndingPoint">
        <xsd:enumeration value="GasTransactionPoint1">
        <xsd:enumeration value="GasTransactionPoint2">
        <xsd:enumeration value="GasTransactionStartingPoint">
        <xsd:enumeration value="GatewayProvider">
        <xsd:enumeration value="GeneralAgency">
        <xsd:enumeration value="GeneralInpatientCareForAIDSOrARCFacility">
        <xsd:enumeration value="GeneralMedicalAndSurgicalFacility">
        <xsd:enumeration value="GeneralMerchandiseDepartment">
        <xsd:enumeration value="GeneticCounselingOrScreeningServices">
        <xsd:enumeration value="GeriatricAcuteCareUnit">
        <xsd:enumeration value="GeriatricClinics">
        <xsd:enumeration value="GiftRecipient">
        <xsd:enumeration value="GoodsCollectionParty">
        <xsd:enumeration value="GoodsCustodian">
        <xsd:enumeration value="GoodsOwner">
        <xsd:enumeration value="GoodsReleaser">
        <xsd:enumeration value="Government">
        <xsd:enumeration value="Government-CombinedControl">
        <xsd:enumeration value="Government-Federal-Military">
        <xsd:enumeration value="Government-Federal-Other">
        <xsd:enumeration value="Government-Federal-Veterans">
        <xsd:enumeration value="GovernmentFurnishedPropertyFOBPoint">
        <xsd:enumeration value="GovernmentLoanAgencySponsorOrAgent">
        <xsd:enumeration value="Government-Local">
        <xsd:enumeration value="Grandparent">
        <xsd:enumeration value="Grantor">
        <xsd:enumeration value="GroundAmbulanceServices">
        <xsd:enumeration value="Group">
        <xsd:enumeration value="GroupAffiliate">
        <xsd:enumeration value="GroupAffiliation">
        <xsd:enumeration value="GroupingCentre">
        <xsd:enumeration value="GroupPractice">
        <xsd:enumeration value="GroupPurchasingOrganization">
        <xsd:enumeration value="GuaranteeAgency">
        <xsd:enumeration value="Guardian">
        <xsd:enumeration value="HazardousMaterialOffice">
        <xsd:enumeration value="HazardousWasteGenerator">
        <xsd:enumeration value="HeadOffice">
        <xsd:enumeration value="HealthAndBeautyDepartment">
        <xsd:enumeration value="HealthcareProfessionalShortageAreaFacility">
        <xsd:enumeration value="HealthMaintenanceOrganization">
        <xsd:enumeration value="HealthMiscellaneous">
        <xsd:enumeration value="HealthSciencesLibrary">
        <xsd:enumeration value="HemodialysisFacility">
        <xsd:enumeration value="HighSchool">
        <xsd:enumeration value="HisopathologyLaboratory">
        <xsd:enumeration value="HispanicServiceInstitute">
        <xsd:enumeration value="HistoricallyBlackCollegeOrUniversity">
        <xsd:enumeration value="HomeHealthAgency">
        <xsd:enumeration value="HomeHealthCare">
        <xsd:enumeration value="HomeHealthCorporation">
        <xsd:enumeration value="HomeHealthServices">
        <xsd:enumeration value="HomeOffice">
        <xsd:enumeration value="HomeSchool">
        <xsd:enumeration value="HomeStateName">
        <xsd:enumeration value="Hospice">
        <xsd:enumeration value="Hospital">
        <xsd:enumeration value="HospitalAuxiliaryUnit">
        <xsd:enumeration value="HospitalDistrictOrAuthority">
        <xsd:enumeration value="HospitalUnitOfAnInstitution">
        <xsd:enumeration value="HospitalUnitWithinAnInstitutionForTheMentallyRetarded">
        <xsd:enumeration value="HostileWitness">
        <xsd:enumeration value="ImportedFromLocation">
        <xsd:enumeration value="Importer">
        <xsd:enumeration value="InCareOfPartyNo1">
        <xsd:enumeration value="InCareOfPartyNo2">
        <xsd:enumeration value="IncorporatedBy">
        <xsd:enumeration value="IncorporatedLocation">
        <xsd:enumeration value="IncorporationJurisdiction">
        <xsd:enumeration value="IncorporationStatePlaceOfBusiness">
        <xsd:enumeration value="IncorporationStatePrincipalOffice">
        <xsd:enumeration value="IndependentAdjuster">
        <xsd:enumeration value="IndependentLab">
        <xsd:enumeration value="IndependentPhysiciansAssociation">
        <xsd:enumeration value="Individual">
        <xsd:enumeration value="IndividualFor-ProfitFacility">
        <xsd:enumeration value="IndustryAssociation">
        <xsd:enumeration value="IndustryBureau">
        <xsd:enumeration value="IneligibleParty">
        <xsd:enumeration value="InformationDisseminationAgency">
        <xsd:enumeration value="InformationMaintenanceAgency">
        <xsd:enumeration value="InformationProvider">
        <xsd:enumeration value="InformationReferenceAgency">
        <xsd:enumeration value="InformationSource">
        <xsd:enumeration value="InitialDealer">
        <xsd:enumeration value="InitialMedicalProvider">
        <xsd:enumeration value="InitialSubscriber">
        <xsd:enumeration value="Initiating">
        <xsd:enumeration value="InjectionPoint">
        <xsd:enumeration value="In-PatientPharmacy">
        <xsd:enumeration value="InquiringParty">
        <xsd:enumeration value="InquiryAddress">
        <xsd:enumeration value="In-ServiceSource">
        <xsd:enumeration value="InspectionAddress">
        <xsd:enumeration value="InspectionAndAcceptanceLocation">
        <xsd:enumeration value="InspectionAndAcceptanceParty">
        <xsd:enumeration value="InspectionCompany">
        <xsd:enumeration value="InspectionLeader">
        <xsd:enumeration value="InspectionLocation">
        <xsd:enumeration value="Inspector">
        <xsd:enumeration value="InstallationOnSite">
        <xsd:enumeration value="InstalledAt">
        <xsd:enumeration value="InstitutionalProvider">
        <xsd:enumeration value="InstitutionForMentalRetardation">
        <xsd:enumeration value="In-StoreBakeryDepartment">
        <xsd:enumeration value="InsuranceBeneficiary">
        <xsd:enumeration value="InsuranceClaimAdjuster">
        <xsd:enumeration value="InsuranceCompany">
        <xsd:enumeration value="InsuranceInstitute">
        <xsd:enumeration value="Insured">
        <xsd:enumeration value="InsuredLocation">
        <xsd:enumeration value="InsuredOrSubscriber">
        <xsd:enumeration value="Insurer">
        <xsd:enumeration value="IntegratedMaterialManager">
        <xsd:enumeration value="IntellectualPropertyOwner">
        <xsd:enumeration value="InterestedParty">
        <xsd:enumeration value="InterimFundingOrganization">
        <xsd:enumeration value="InterimTrustee">
        <xsd:enumeration value="InterlineServiceCommitmentCustomer">
        <xsd:enumeration value="Intermediary">
        <xsd:enumeration value="IntermediaryBank1">
        <xsd:enumeration value="IntermediaryBank2">
        <xsd:enumeration value="IntermediaryOrBroker">
        <xsd:enumeration value="IntermediateCarrier">
        <xsd:enumeration value="IntermediateConsignee">
        <xsd:enumeration value="IntermediateLevelParentCompany">
        <xsd:enumeration value="InternationalFreightForwarder">
        <xsd:enumeration value="InternationalOrganization">
        <xsd:enumeration value="InternshipEntity">
        <xsd:enumeration value="Interpreter">
        <xsd:enumeration value="Interviewee">
        <xsd:enumeration value="Interviewer">
        <xsd:enumeration value="Inventor">
        <xsd:enumeration value="InventoryController">
        <xsd:enumeration value="InventoryControlPoint">
        <xsd:enumeration value="InventoryReportingParty">
        <xsd:enumeration value="Investigator">
        <xsd:enumeration value="InvestmentAdvisor">
        <xsd:enumeration value="Investor">
        <xsd:enumeration value="Invoicee">
        <xsd:enumeration value="InvoicingDealer">
        <xsd:enumeration value="InvolvedParty">
        <xsd:enumeration value="IrrevocableBeneficiary">
        <xsd:enumeration value="Issuer">
        <xsd:enumeration value="IssuerOfDebitOrCreditMemo">
        <xsd:enumeration value="IssuerOfInvoice">
        <xsd:enumeration value="IssuerOfWaybill">
        <xsd:enumeration value="IssuingBank">
        <xsd:enumeration value="ItemManager">
        <xsd:enumeration value="ItemShipTo">
        <xsd:enumeration value="ItemShipFrom">
        <xsd:enumeration value="JointAnnuitant">
        <xsd:enumeration value="JointAnnuitantOwner">
        <xsd:enumeration value="JointDebtor">
        <xsd:enumeration value="JointDebtorAttorney">
        <xsd:enumeration value="JointOwner">
        <xsd:enumeration value="JointOwnerAnnuitant">
        <xsd:enumeration value="JointOwnerAnnuitantPayor">
        <xsd:enumeration value="JointOwnerJointAnnuitant">
        <xsd:enumeration value="JointOwnerJointAnnuitantPayor">
        <xsd:enumeration value="JointOwnerPayor">
        <xsd:enumeration value="JointVenture">
        <xsd:enumeration value="Judge">
        <xsd:enumeration value="JuniorHighSchool">
        <xsd:enumeration value="Jurisdiction">
        <xsd:enumeration value="JuvenileDefendant">
        <xsd:enumeration value="JuvenileOwner">
        <xsd:enumeration value="JuvenileVictim">
        <xsd:enumeration value="JuvenileWitness">
        <xsd:enumeration value="KeyPerson">
        <xsd:enumeration value="KidneyDialysisUnit">
        <xsd:enumeration value="Labeler">
        <xsd:enumeration value="Laboratory">
        <xsd:enumeration value="LaborSurplusAreaFirm">
        <xsd:enumeration value="Landlord">
        <xsd:enumeration value="LargeBusiness">
        <xsd:enumeration value="LastBreakTerminal">
        <xsd:enumeration value="LastEmployer">
        <xsd:enumeration value="LastKnownSourceOfSupply">
        <xsd:enumeration value="LastSupplier">
        <xsd:enumeration value="LawEnforcementAgency">
        <xsd:enumeration value="LawFirm">
        <xsd:enumeration value="LeaseLocation">
        <xsd:enumeration value="LegalReceiver">
        <xsd:enumeration value="LegalRepresentative">
        <xsd:enumeration value="LegalTitleHolder">
        <xsd:enumeration value="Lender">
        <xsd:enumeration value="LendingInstitution">
        <xsd:enumeration value="Lessee">
        <xsd:enumeration value="LesseesSurveyor">
        <xsd:enumeration value="Lessor">
        <xsd:enumeration value="LiabilityHolder">
        <xsd:enumeration value="Licensee">
        <xsd:enumeration value="LienHolder">
        <xsd:enumeration value="LimitedLiabilityCompany">
        <xsd:enumeration value="LimitedLiabilityPartnership">
        <xsd:enumeration value="LimitedPartner">
        <xsd:enumeration value="Liquidator">
        <xsd:enumeration value="ListingAgent">
        <xsd:enumeration value="ListingCompany">
        <xsd:enumeration value="ListingOffice">
        <xsd:enumeration value="ListMailer">
        <xsd:enumeration value="ListOwner">
        <xsd:enumeration value="LiterallyTranslatedName">
        <xsd:enumeration value="LoadingParty">
        <xsd:enumeration value="LoanApplicant">
        <xsd:enumeration value="LoanBroker">
        <xsd:enumeration value="LoanCorrespondent">
        <xsd:enumeration value="LoanHolderForRealEstateAsset">
        <xsd:enumeration value="LoanOriginator">
        <xsd:enumeration value="LoanServicer">
        <xsd:enumeration value="LocalChain">
        <xsd:enumeration value="LocalGovernmentSponsor">
        <xsd:enumeration value="LocationOfGoods">
        <xsd:enumeration value="LocationOfGoodsForCustomsExaminationBeforeClearance">
        <xsd:enumeration value="LocationOfLoadExchange">
        <xsd:enumeration value="LocationOfPrincipalAssets">
        <xsd:enumeration value="LocationOfSpotForStorage">
        <xsd:enumeration value="LongTermCareFacility">
        <xsd:enumeration value="Long-TermDisabilityCarrier">
        <xsd:enumeration value="LosingInventoryManager">
        <xsd:enumeration value="LossPayee">
        <xsd:enumeration value="Lot">
        <xsd:enumeration value="MagistrateJudge">
        <xsd:enumeration value="MagneticResonanceImagingFacility">
        <xsd:enumeration value="MaidenName">
        <xsd:enumeration value="MailAddress">
        <xsd:enumeration value="MailTo">
        <xsd:enumeration value="Mainline">
        <xsd:enumeration value="MaintenanceOrganizationUsedForEstimate">
        <xsd:enumeration value="MammographyScreeningCenter">
        <xsd:enumeration value="ManagedCare">
        <xsd:enumeration value="ManagedCareOrganization">
        <xsd:enumeration value="ManagementControlActivity">
        <xsd:enumeration value="ManagementNon-Officer">
        <xsd:enumeration value="Manager">
        <xsd:enumeration value="ManagingAgent">
        <xsd:enumeration value="ManagingGeneralAgent">
        <xsd:enumeration value="ManufacturerOfGoods">
        <xsd:enumeration value="ManufacturersRepresentative">
        <xsd:enumeration value="Manufacturing">
        <xsd:enumeration value="ManufacturingPlant">
        <xsd:enumeration value="MarineSurveyor">
        <xsd:enumeration value="MarkerOwner">
        <xsd:enumeration value="MarketTimer">
        <xsd:enumeration value="Mark-ForParty">
        <xsd:enumeration value="MasterAgent">
        <xsd:enumeration value="MasterGeneralAgent">
        <xsd:enumeration value="MasterProperty">
        <xsd:enumeration value="Material">
        <xsd:enumeration value="MaterialChangeNoticeAddress">
        <xsd:enumeration value="MaterialDispositionAuthorizationLocation">
        <xsd:enumeration value="MaterialIssuer">
        <xsd:enumeration value="MaterialSafetyDataSheetRecipient">
        <xsd:enumeration value="MeansOfTransportCharterer">
        <xsd:enumeration value="MeatDepartment">
        <xsd:enumeration value="MedicalDoctor">
        <xsd:enumeration value="MedicalInsuranceCarrier">
        <xsd:enumeration value="MedicalNurse">
        <xsd:enumeration value="MedicalSchool">
        <xsd:enumeration value="MedicalSurgicalOrOtherIntensiveCareUnit">
        <xsd:enumeration value="MedicalTreatmentExecutant">
        <xsd:enumeration value="MedicalTreatmentPrescriber">
        <xsd:enumeration value="MeetingLocation">
        <xsd:enumeration value="MegavoltageRadiationTherapyUnit">
        <xsd:enumeration value="Member">
        <xsd:enumeration value="MerchantBanker">
        <xsd:enumeration value="MergedCompany">
        <xsd:enumeration value="MergedCompanyWithRetainedIdentity">
        <xsd:enumeration value="MergedName">
        <xsd:enumeration value="MessageFrom">
        <xsd:enumeration value="MessageRecipient">
        <xsd:enumeration value="MessageTo">
        <xsd:enumeration value="MeteringLocation">
        <xsd:enumeration value="MexicanCustomsBroker">
        <xsd:enumeration value="MiddleSchool">
        <xsd:enumeration value="MigrantHealthClinic">
        <xsd:enumeration value="MilitaryBranch">
        <xsd:enumeration value="MilitaryFacility">
        <xsd:enumeration value="MinimumRoyaltyPayor">
        <xsd:enumeration value="Minister">
        <xsd:enumeration value="MinorityInstitution">
        <xsd:enumeration value="Minority-OwnedBusinessLarge">
        <xsd:enumeration value="Minority-OwnedBusinessSmall">
        <xsd:enumeration value="MiscellaneousHealthCareFacility">
        <xsd:enumeration value="MonitoringParty">
        <xsd:enumeration value="MortgageCompany">
        <xsd:enumeration value="MortgageInsurer">
        <xsd:enumeration value="MortgageLiabilityAccountHolder">
        <xsd:enumeration value="MostRecentEmployer">
        <xsd:enumeration value="Mother">
        <xsd:enumeration value="MotorCarrier">
        <xsd:enumeration value="MotorVehicleReportProviderCompany">
        <xsd:enumeration value="MultipleListingService">
        <xsd:enumeration value="Municipality">
        <xsd:enumeration value="NameChangedTo">
        <xsd:enumeration value="NameNotToBeConfusedWith">
        <xsd:enumeration value="NameonCreditCard">
        <xsd:enumeration value="NameUnderWhichFiled">
        <xsd:enumeration value="NameVariationSynonym">
        <xsd:enumeration value="NationalChain">
        <xsd:enumeration value="NationalOrganization">
        <xsd:enumeration value="NativeHawaiianOrganization">
        <xsd:enumeration value="NavyFacility">
        <xsd:enumeration value="NeglectedOrDelinquentInstitution">
        <xsd:enumeration value="NegotiatingBank">
        <xsd:enumeration value="Neighbor">
        <xsd:enumeration value="Neighborhood">
        <xsd:enumeration value="NeonatalIntensiveCareUnit">
        <xsd:enumeration value="NetworkName">
        <xsd:enumeration value="NewAddress">
        <xsd:enumeration value="NewAssignee">
        <xsd:enumeration value="NewDebtor">
        <xsd:enumeration value="NewSecuredParty">
        <xsd:enumeration value="NewServiceProvider">
        <xsd:enumeration value="Newspaper">
        <xsd:enumeration value="NewSupplySource">
        <xsd:enumeration value="NextDestination">
        <xsd:enumeration value="NextScheduledDestination">
        <xsd:enumeration value="Nickname">
        <xsd:enumeration value="NoHeading">
        <xsd:enumeration value="NominatedBank">
        <xsd:enumeration value="NominatedFreightCompany">
        <xsd:enumeration value="Non-DomesticFinancialInstitution">
        <xsd:enumeration value="NonemploymentIncomeSource">
        <xsd:enumeration value="Non-HealthCareMiscellaneousFacility">
        <xsd:enumeration value="Non-Insured">
        <xsd:enumeration value="Non-InvasiveCardiacAssessmentServices">
        <xsd:enumeration value="Non-MortgageLiabilityAccountHolder">
        <xsd:enumeration value="Non-OccupantCo-Borrower">
        <xsd:enumeration value="Non-ProductionSupplier">
        <xsd:enumeration value="Non-ProfitHealthCareProvider">
        <xsd:enumeration value="NonprofitInstitution">
        <xsd:enumeration value="Non-RailroadEntity">
        <xsd:enumeration value="NonRegisteredBusinessName">
        <xsd:enumeration value="Non-RegisteredInvestmentAdvisor">
        <xsd:enumeration value="Non-ResidentBeneficiary">
        <xsd:enumeration value="Non-ResidentCreditor">
        <xsd:enumeration value="Non-ResidentDebtor">
        <xsd:enumeration value="Non-ResidentGroupCompanyWithWhomFinancialAccountIs">
        <xsd:enumeration value="Non-ResidentInstructingParty">
        <xsd:enumeration value="Non-ResidentThirdPartyCompanyWithWhomFinancial">
        <xsd:enumeration value="Non-TemporaryStorageFacility">
        <xsd:enumeration value="Notary">
        <xsd:enumeration value="NotaryPublic">
        <xsd:enumeration value="NoteCo-Signer">
        <xsd:enumeration value="NotForProfitHealthCareProvider">
        <xsd:enumeration value="NotifyParty">
        <xsd:enumeration value="NotifyPartyForShippersOrder">
        <xsd:enumeration value="NotifyPartyNo1">
        <xsd:enumeration value="NotifyPartyNo2">
        <xsd:enumeration value="NursingHome">
        <xsd:enumeration value="NursingHomeChain">
        <xsd:enumeration value="ObservationRoomServices">
        <xsd:enumeration value="ObstetricsAndGynecologyFacility">
        <xsd:enumeration value="ObstetricsUnit">
        <xsd:enumeration value="Occupant">
        <xsd:enumeration value="OccupationalHealthServices">
        <xsd:enumeration value="OccupationalTherapyServices">
        <xsd:enumeration value="OceanTariffConference">
        <xsd:enumeration value="OfficeManager">
        <xsd:enumeration value="Officer">
        <xsd:enumeration value="OffsetOperator">
        <xsd:enumeration value="OilAndGasCustodian">
        <xsd:enumeration value="OilAndGasRegulatoryAgency">
        <xsd:enumeration value="OldAssignee">
        <xsd:enumeration value="OldDebtor">
        <xsd:enumeration value="OldSecuredParty">
        <xsd:enumeration value="OnBehalfOf">
        <xsd:enumeration value="On-CallProvider">
        <xsd:enumeration value="OncologyCenter">
        <xsd:enumeration value="Open-HeartSurgeryFacility">
        <xsd:enumeration value="OperatingPhysician">
        <xsd:enumeration value="Operator-CommunicationChannel">
        <xsd:enumeration value="Operator-EssentialServices">
        <xsd:enumeration value="OperatorOfPropertyOrEquipment">
        <xsd:enumeration value="OperatorOfPropertyOrUnit">
        <xsd:enumeration value="OperatorOfTheSourceTransferPoint">
        <xsd:enumeration value="OperatorOfTheTransferPoint">
        <xsd:enumeration value="OrderedBank">
        <xsd:enumeration value="OrderedBy">
        <xsd:enumeration value="OrderingBank">
        <xsd:enumeration value="OrderingCustomer">
        <xsd:enumeration value="OrderingParty">
        <xsd:enumeration value="OrderingPhysician">
        <xsd:enumeration value="OrderOfShippersOrders-Transportation">
        <xsd:enumeration value="OrderOfTheShipperParty">
        <xsd:enumeration value="OrderWriter">
        <xsd:enumeration value="Organization">
        <xsd:enumeration value="OrganizationCompletingConfigurationChange">
        <xsd:enumeration value="OrganizationGroup">
        <xsd:enumeration value="OrganizationHavingSourceControl">
        <xsd:enumeration value="OrganizedOutpatientServices">
        <xsd:enumeration value="OrganizedSocialWorkServiceFacility">
        <xsd:enumeration value="Organizer">
        <xsd:enumeration value="OrganOrTissueTransplantUnit">
        <xsd:enumeration value="OriginalClaimant">
        <xsd:enumeration value="OriginalIntermodalRamp">
        <xsd:enumeration value="OriginalJurisdiction">
        <xsd:enumeration value="OriginalLocation">
        <xsd:enumeration value="OriginalName">
        <xsd:enumeration value="OriginalShipper">
        <xsd:enumeration value="OriginatingBank">
        <xsd:enumeration value="OriginatingCompany">
        <xsd:enumeration value="OriginatorOfArticleNumber">
        <xsd:enumeration value="OriginCarrier">
        <xsd:enumeration value="OriginDrayman">
        <xsd:enumeration value="OriginMailFacility">
        <xsd:enumeration value="OriginSublocation">
        <xsd:enumeration value="OriginTerminal">
        <xsd:enumeration value="OrthopedicFacility">
        <xsd:enumeration value="OrthopedicSurgeryFacility">
        <xsd:enumeration value="OtherDepartments">
        <xsd:enumeration value="OtherDisadvantagedBusiness">
        <xsd:enumeration value="OtherIndividualDisabilityCarrier">
        <xsd:enumeration value="OtherInsured">
        <xsd:enumeration value="OtherNot-For-ProfitFacility">
        <xsd:enumeration value="OtherPersonOrEntityAssociatedWithStudent">
        <xsd:enumeration value="OtherPhysician">
        <xsd:enumeration value="OtherRelatedParty">
        <xsd:enumeration value="OtherSpecialtyFacility">
        <xsd:enumeration value="OtherUnlistedTypeOfOrganizationalEntity">
        <xsd:enumeration value="OuterContinentalShelfAreaLocation">
        <xsd:enumeration value="Out-Of-StatePrincipalOffice">
        <xsd:enumeration value="OutpatientSocialWorkServices">
        <xsd:enumeration value="OutpatientSurgeryServices">
        <xsd:enumeration value="OutpatientSurgicenter">
        <xsd:enumeration value="OutsideInspectionAgency">
        <xsd:enumeration value="OutsideProcessor">
        <xsd:enumeration value="OutsideTestAgency">
        <xsd:enumeration value="OverrideInstitution">
        <xsd:enumeration value="Owner">
        <xsd:enumeration value="OwnerAnnuitant">
        <xsd:enumeration value="OwnerAnnuitantPayor">
        <xsd:enumeration value="OwnerJointAnnuitantPayor">
        <xsd:enumeration value="OwnerOfEquipment">
        <xsd:enumeration value="OwnerOfMeansOfTransport">
        <xsd:enumeration value="OwnerOfOperation">
        <xsd:enumeration value="OwnerOfProperty">
        <xsd:enumeration value="OwnerOfPropertyOrUnit">
        <xsd:enumeration value="OwnerOfResidence">
        <xsd:enumeration value="OwnerOfVehicle">
        <xsd:enumeration value="OwnerOfVessel">
        <xsd:enumeration value="OwnerOrLessorsSurveyor">
        <xsd:enumeration value="OwnerPayor">
        <xsd:enumeration value="OwnersAgent">
        <xsd:enumeration value="OwnersRepresentative">
        <xsd:enumeration value="OwningInventoryControlPoint">
        <xsd:enumeration value="OxygenTherapyFacility">
        <xsd:enumeration value="Packer">
        <xsd:enumeration value="Paramedic">
        <xsd:enumeration value="ParamedicalCompany">
        <xsd:enumeration value="Parent">
        <xsd:enumeration value="ParentCompany">
        <xsd:enumeration value="Participant">
        <xsd:enumeration value="ParticipatingArea">
        <xsd:enumeration value="ParticipatingLaboratory">
        <xsd:enumeration value="Partner">
        <xsd:enumeration value="Partnership">
        <xsd:enumeration value="PartnershipFor-ProfitFacility">
        <xsd:enumeration value="PartRemanufacturer">
        <xsd:enumeration value="PartsDistributor">
        <xsd:enumeration value="PartSource">
        <xsd:enumeration value="PartyAccordingToDocumentaryCreditTransaction">
        <xsd:enumeration value="PartyAssigningAStatus">
        <xsd:enumeration value="PartyAtFinalPlaceOfPositioning">
        <xsd:enumeration value="PartyAtPick-UpLocation">
        <xsd:enumeration value="PartyAuthorizedtoDefinitizeContractAction">
        <xsd:enumeration value="PartyAuthorizedToMakeDefiniteAContractAction">
        <xsd:enumeration value="PartyAuthorizingDisposition">
        <xsd:enumeration value="PartyAuthorizingReleaseOfSecurityInformation">
        <xsd:enumeration value="PartyDataResponsibleParty">
        <xsd:enumeration value="PartyDeclaringTheValueAddedTax">
        <xsd:enumeration value="PartyDesignatedToExecuteRe-Icing">
        <xsd:enumeration value="PartyDesignatedToExecuteSanitaryProcedures">
        <xsd:enumeration value="PartyDesignatedToProvideLivingAnimalCare">
        <xsd:enumeration value="PartyExecutingAndVerifying">
        <xsd:enumeration value="PartyFillingShippersOrder">
        <xsd:enumeration value="PartyForWhomItemIsUltimatelyIntended">
        <xsd:enumeration value="PartyFromWhomCustomsDocumentsAreToBePickedUp">
        <xsd:enumeration value="PartyFromWhomNon-CustomsDocumentsAreToBePickedUp">
        <xsd:enumeration value="PartyFulfillingAllOperations">
        <xsd:enumeration value="PartyInPossession">
        <xsd:enumeration value="PartyIssuingMutuallyAgreedCodes">
        <xsd:enumeration value="PartyMaintainingTheCodesUsedInTheMessage">
        <xsd:enumeration value="PartyMaintainingTheIdentifiersUsedInTheMessage">
        <xsd:enumeration value="PartyMandatedToLiquidateAnEnterprise">
        <xsd:enumeration value="PartyManufacturedFor">
        <xsd:enumeration value="PartyNotToBeConfusedWith">
        <xsd:enumeration value="PartyPassingTheTransaction">
        <xsd:enumeration value="PartyPerformingCertification">
        <xsd:enumeration value="PartyPerformingCount">
        <xsd:enumeration value="PartyPerformingInspection">
        <xsd:enumeration value="PartyPerformingTask">
        <xsd:enumeration value="PartyPerformingVerification">
        <xsd:enumeration value="PartyProvidingFinancing">
        <xsd:enumeration value="PartyProvidingGovernmentFurnishedProperty">
        <xsd:enumeration value="PartyRecoveringTheValueAddedTax">
        <xsd:enumeration value="PartyRepresented">
        <xsd:enumeration value="PartyResponsibleForDisinfection">
        <xsd:enumeration value="PartyResponsibleForFinancialSettlement">
        <xsd:enumeration value="PartyResponsibleForRefueling">
        <xsd:enumeration value="PartySubmittingQuote">
        <xsd:enumeration value="PartyThatReceivedDisclosureStatement">
        <xsd:enumeration value="PartyThatRemitsPayment">
        <xsd:enumeration value="PartytoAppearBefore">
        <xsd:enumeration value="PartyToApproveSpecification">
        <xsd:enumeration value="Partytobeadvised-WrittenOrders">
        <xsd:enumeration value="PartyToBeBilled">
        <xsd:enumeration value="PartyToBeBilledForOtherThanFreight">
        <xsd:enumeration value="PartytoContract">
        <xsd:enumeration value="PartyToFilePersonalPropertyTax">
        <xsd:enumeration value="PartytoLease">
        <xsd:enumeration value="PartytoPerformPackaging">
        <xsd:enumeration value="PartyToPrintSomeDocument">
        <xsd:enumeration value="PartytoProvideDiscount">
        <xsd:enumeration value="PartyToReceiveAllDocuments">
        <xsd:enumeration value="PartytoReceiveBillOfLading">
        <xsd:enumeration value="PartyToReceiveCertificateOfCompliance">
        <xsd:enumeration value="PartyToReceiveCertificateOfConformance">
        <xsd:enumeration value="PartyToReceiveCertifiedInspectionReport">
        <xsd:enumeration value="PartyToReceiveCertifiedTestResults">
        <xsd:enumeration value="PartyToReceiveCommercialInvoiceRemittance">
        <xsd:enumeration value="PartyToReceiveContractSecurityClassificationSpecification">
        <xsd:enumeration value="PartyToReceiveCopy">
        <xsd:enumeration value="PartyToReceiveCorrespondence">
        <xsd:enumeration value="PartytoReceiveCredit">
        <xsd:enumeration value="PartyToReceiveCustomsDocuments">
        <xsd:enumeration value="PartyToReceiveElectronicMemoOfInvoice">
        <xsd:enumeration value="PartyToReceiveEquipment">
        <xsd:enumeration value="PartyToReceiveFreightBill">
        <xsd:enumeration value="PartyToReceiveInspectionReport">
        <xsd:enumeration value="PartyToReceiveInvitationToOffer">
        <xsd:enumeration value="PartytoReceiveInvoiceFOrGoodsOrServices">
        <xsd:enumeration value="PartyToReceiveInvoiceForLeasePayments">
        <xsd:enumeration value="PartytoReceiveLimitationsOfHeavyElementsReport">
        <xsd:enumeration value="PartytoReceiveMaterialRelease">
        <xsd:enumeration value="PartyToReceiveNon-CustomsDocuments">
        <xsd:enumeration value="PartyToReceiveOrderToSupply">
        <xsd:enumeration value="PartyToReceivePackingCratingAndHandlingCredit">
        <xsd:enumeration value="PartyToReceivePaperMemoOfInvoice">
        <xsd:enumeration value="PartytoReceiveProposal">
        <xsd:enumeration value="PartyToReceivePurchaseOrder">
        <xsd:enumeration value="PartyToReceiveReports">
        <xsd:enumeration value="PartytoReceiveScaleTicket">
        <xsd:enumeration value="PartytoReceiveShippingManifest">
        <xsd:enumeration value="PartyToReceiveShippingNotice">
        <xsd:enumeration value="PartytoReceiveSolicitation">
        <xsd:enumeration value="PartyToReceiveStatementOfAccount">
        <xsd:enumeration value="PartyToReceiveStatementOfFeesDue">
        <xsd:enumeration value="PartytoReceiveStatus">
        <xsd:enumeration value="PartyToReceiveTechnicalDocumentation">
        <xsd:enumeration value="PartyToReceiveTestReport">
        <xsd:enumeration value="PartytoReceiveTransportationCredit">
        <xsd:enumeration value="PartytoWhomAcknowledgmentShouldBeSent">
        <xsd:enumeration value="PartyToWhomDocumentsAreToBePresented">
        <xsd:enumeration value="PartytoWhomProtestSubmitted">
        <xsd:enumeration value="PartyWaivingRequirements">
        <xsd:enumeration value="PartyWhichDeliversConsignmentsToTheTerminal">
        <xsd:enumeration value="PartyWhichPicksUpConsignmentsFromTheTerminal">
        <xsd:enumeration value="PartyWhoSignedTheDeliveryReceipt">
        <xsd:enumeration value="PartyWithKnowledgeOfAffairsOfTheCompany">
        <xsd:enumeration value="PartyWithPowerToVoteSecurities">
        <xsd:enumeration value="Passenger">
        <xsd:enumeration value="Patient">
        <xsd:enumeration value="PatientCompanion">
        <xsd:enumeration value="PatientEducationUnit">
        <xsd:enumeration value="PatientFacility">
        <xsd:enumeration value="PatientRepresentativeServices">
        <xsd:enumeration value="Payee">
        <xsd:enumeration value="PayeesCompanyNameOrId">
        <xsd:enumeration value="Payer">
        <xsd:enumeration value="PayerOfLastResort">
        <xsd:enumeration value="PayersCompanyNameOrId">
        <xsd:enumeration value="PayersFinancialInstitution">
        <xsd:enumeration value="PayingAgent">
        <xsd:enumeration value="PayingBank">
        <xsd:enumeration value="PayingFinancialInstitution">
        <xsd:enumeration value="PaymentAddress">
        <xsd:enumeration value="Payor">
        <xsd:enumeration value="Pay-ToProvider">
        <xsd:enumeration value="Pedestrian">
        <xsd:enumeration value="PediatricAcuteInpatientUnit">
        <xsd:enumeration value="PerformedAt">
        <xsd:enumeration value="PermitHolder">
        <xsd:enumeration value="PersonForWhoseBenefitPropertywasSeized">
        <xsd:enumeration value="PersonnelOffice">
        <xsd:enumeration value="PersonOnClaim">
        <xsd:enumeration value="PersonOrOtherEntityLegallyResponsibleForAChild">
        <xsd:enumeration value="PersonOrOtherEntityLegallyResponsibleForAndWithWhomAChildResides">
        <xsd:enumeration value="PersonOrOtherEntityWithWhomAChildResides">
        <xsd:enumeration value="PetitioningCreditor">
        <xsd:enumeration value="PetitioningCreditorsAttorney">
        <xsd:enumeration value="Pharmacist">
        <xsd:enumeration value="Pharmacy">
        <xsd:enumeration value="PharmacyDepartment">
        <xsd:enumeration value="PhysicalAddress">
        <xsd:enumeration value="PhysicalTherapyServices">
        <xsd:enumeration value="Physician">
        <xsd:enumeration value="PhysicianClinicOrGroupPractice">
        <xsd:enumeration value="PhysicianHospitalOrganization">
        <xsd:enumeration value="Physician-Specialists">
        <xsd:enumeration value="PickUpAddress">
        <xsd:enumeration value="PierName">
        <xsd:enumeration value="Pipeline">
        <xsd:enumeration value="PipelineSegment">
        <xsd:enumeration value="PipelineSegmentBoundary">
        <xsd:enumeration value="PlaceOfBottling">
        <xsd:enumeration value="PlaceOfBusiness">
        <xsd:enumeration value="PlaceOfDistilling">
        <xsd:enumeration value="PlaceOfOccurrence">
        <xsd:enumeration value="PlaceOfPerformanceCognizantSecurityOffice">
        <xsd:enumeration value="Plaintiff">
        <xsd:enumeration value="PlanAdministrator">
        <xsd:enumeration value="PlanningOrMaintenanceOrganization">
        <xsd:enumeration value="PlanningCommission">
        <xsd:enumeration value="PlanningScheduleOrMaterialReleaseIssuer">
        <xsd:enumeration value="PlanSponsor">
        <xsd:enumeration value="Plant">
        <xsd:enumeration value="PlantClearanceOfficer">
        <xsd:enumeration value="Podiatrist">
        <xsd:enumeration value="PointOfService">
        <xsd:enumeration value="PolicyHolder">
        <xsd:enumeration value="PolicyWritingAgent">
        <xsd:enumeration value="PollingSite">
        <xsd:enumeration value="PortAuthority">
        <xsd:enumeration value="PostalMailingAddress">
        <xsd:enumeration value="PostsecondaryEducationRecipient">
        <xsd:enumeration value="PostsecondaryEducationSender">
        <xsd:enumeration value="Post-SecondaryInstitution">
        <xsd:enumeration value="PotentialSourceOfSupply">
        <xsd:enumeration value="PowerOfAttorney">
        <xsd:enumeration value="PreferredProviderOrganization">
        <xsd:enumeration value="Pre-KDayCare">
        <xsd:enumeration value="Pre-kindergartenToGrade12Recipient">
        <xsd:enumeration value="Pre-kindergartenToGrade12Sender">
        <xsd:enumeration value="PreliminaryCustomerOrganization">
        <xsd:enumeration value="PreliminaryInspectionLocation">
        <xsd:enumeration value="PreliminaryMaintenanceOrganization">
        <xsd:enumeration value="PreliminaryMaintenancePeriodDesignatingOrganization">
        <xsd:enumeration value="PreliminaryReferredToOrganization">
        <xsd:enumeration value="Premises">
        <xsd:enumeration value="Preparer">
        <xsd:enumeration value="PresentAddress">
        <xsd:enumeration value="PresentingBank">
        <xsd:enumeration value="President">
        <xsd:enumeration value="PreviousBusinessPartner">
        <xsd:enumeration value="PreviousCreditGrantor">
        <xsd:enumeration value="PreviousDebtHolder">
        <xsd:enumeration value="PreviousDistributor">
        <xsd:enumeration value="PreviousEmployer">
        <xsd:enumeration value="PreviousGroup">
        <xsd:enumeration value="PreviousInsured">
        <xsd:enumeration value="PreviousMember">
        <xsd:enumeration value="PreviousName">
        <xsd:enumeration value="PreviousNameOfFirm">
        <xsd:enumeration value="PreviousNeighbor">
        <xsd:enumeration value="PreviousOccupant">
        <xsd:enumeration value="PreviousOwner">
        <xsd:enumeration value="PreviousResidence">
        <xsd:enumeration value="PreviousStation">
        <xsd:enumeration value="PreviousTitleCompany">
        <xsd:enumeration value="PreviousTradeUnion">
        <xsd:enumeration value="PriceAdministration">
        <xsd:enumeration value="PrimaryBeneficiary">
        <xsd:enumeration value="PrimaryCareProvider">
        <xsd:enumeration value="PriceCheckShipTo">
        <xsd:enumeration value="PrimaryControlPointLocation">
        <xsd:enumeration value="PrimaryHealthCareProvider">
        <xsd:enumeration value="PrimaryInsuredOrSubscriber">
        <xsd:enumeration value="PrimaryInterexchangeCarrier">
        <xsd:enumeration value="PrimaryInternationalTelecomCarrier">
        <xsd:enumeration value="PrimaryIntra-LATACarrier">
        <xsd:enumeration value="PrimaryInventoryControlActivity">
        <xsd:enumeration value="PrimaryOwner">
        <xsd:enumeration value="PrimaryPayer">
        <xsd:enumeration value="PrimaryPhysician">
        <xsd:enumeration value="PrimaryResidence">
        <xsd:enumeration value="PrimarySupportOrganization">
        <xsd:enumeration value="PrimarySurgeon">
        <xsd:enumeration value="PrimaryTaxpayer">
        <xsd:enumeration value="PrimeContractor">
        <xsd:enumeration value="Principal">
        <xsd:enumeration value="PrincipalBorrower">
        <xsd:enumeration value="PrincipalExecutiveOffice">
        <xsd:enumeration value="PrincipalPerson">
        <xsd:enumeration value="Printer">
        <xsd:enumeration value="PriorBaseJurisdiction">
        <xsd:enumeration value="PriorIncorrectInsured">
        <xsd:enumeration value="PriorInsuranceCarrier">
        <xsd:enumeration value="PriorTitleEvidenceHolder">
        <xsd:enumeration value="PrivatePre-KEducation">
        <xsd:enumeration value="PrivateSchool">
        <xsd:enumeration value="ProBonoAttorney">
        <xsd:enumeration value="Processor">
        <xsd:enumeration value="ProcurementResponsibilityForOrder">
        <xsd:enumeration value="ProduceDepartment">
        <xsd:enumeration value="Producer">
        <xsd:enumeration value="Production">
        <xsd:enumeration value="ProductionManager">
        <xsd:enumeration value="ProductPositionHolder">
        <xsd:enumeration value="ProductServicesAndRepairsCentre">
        <xsd:enumeration value="ProfessionalOrganization">
        <xsd:enumeration value="Project">
        <xsd:enumeration value="ProjectCoordinationOffice">
        <xsd:enumeration value="ProjectManagementOffice">
        <xsd:enumeration value="ProjectManager">
        <xsd:enumeration value="ProjectName">
        <xsd:enumeration value="ProjectProperty">
        <xsd:enumeration value="Property">
        <xsd:enumeration value="PropertyOrBuildingManager">
        <xsd:enumeration value="ProposedInsured">
        <xsd:enumeration value="Proposer">
        <xsd:enumeration value="ProSeCounsel">
        <xsd:enumeration value="PrototypeSupplier">
        <xsd:enumeration value="Provider">
        <xsd:enumeration value="PsychiatricChildOrAdolescentServices">
        <xsd:enumeration value="PsychiatricConsultation-LiaisonServices">
        <xsd:enumeration value="PsychiatricEducationServices">
        <xsd:enumeration value="PsychiatricEmergencyServices">
        <xsd:enumeration value="PsychiatricFacility">
        <xsd:enumeration value="PsychiatricGeriatricServices">
        <xsd:enumeration value="PsychiatricHealthFacility">
        <xsd:enumeration value="PsychiatricInpatientUnit">
        <xsd:enumeration value="PsychiatricOutpatientServices">
        <xsd:enumeration value="PsychiatricPartialHospitalizationProgram">
        <xsd:enumeration value="Psychiatrist">
        <xsd:enumeration value="Psychologist">
        <xsd:enumeration value="PublicAlternativeSchool">
        <xsd:enumeration value="PublicHealthServiceFacility">
        <xsd:enumeration value="PublicHealthServiceIndianServiceFacility">
        <xsd:enumeration value="PublicorPrivateOrganizationForTheDisabled">
        <xsd:enumeration value="PublicPre-KEducation">
        <xsd:enumeration value="PublicSchool">
        <xsd:enumeration value="Publisher">
        <xsd:enumeration value="Pumper">
        <xsd:enumeration value="PurchasedCompany">
        <xsd:enumeration value="PurchasersDepartmentBuyer">
        <xsd:enumeration value="PurchaseServiceProvider">
        <xsd:enumeration value="QualifyingOfficer">
        <xsd:enumeration value="QualityControl">
        <xsd:enumeration value="QuotationRequestingParty">
        <xsd:enumeration value="RadioactiveImplantsUnit">
        <xsd:enumeration value="RadioControlStationLocation">
        <xsd:enumeration value="RadioStation">
        <xsd:enumeration value="RailCarrier">
        <xsd:enumeration value="Railroad">
        <xsd:enumeration value="RatingOrganization">
        <xsd:enumeration value="ReceiptMeterLocation">
        <xsd:enumeration value="ReceiptZone">
        <xsd:enumeration value="ReceivedFrom">
        <xsd:enumeration value="Receiver">
        <xsd:enumeration value="ReceiverManager">
        <xsd:enumeration value="ReceiverOfCheque">
        <xsd:enumeration value="ReceiverOfFunds">
        <xsd:enumeration value="ReceiversCorrespondentBank">
        <xsd:enumeration value="ReceiverSite">
        <xsd:enumeration value="ReceiversSub-Entity">
        <xsd:enumeration value="ReceivingBank">
        <xsd:enumeration value="ReceivingCompany">
        <xsd:enumeration value="ReceivingFacilityScheduler">
        <xsd:enumeration value="ReceivingFinancialInstitution">
        <xsd:enumeration value="ReceivingLocation">
        <xsd:enumeration value="ReceivingPointForCustomerSamples">
        <xsd:enumeration value="ReceivingSub-Location">
        <xsd:enumeration value="RecipientOfCivilorLegalLiabilityPayment">
        <xsd:enumeration value="ReclamationCenter">
        <xsd:enumeration value="Record-KeepingAddress">
        <xsd:enumeration value="RecoveryRoom">
        <xsd:enumeration value="RecreationalTherapyServices">
        <xsd:enumeration value="Referee">
        <xsd:enumeration value="Reference">
        <xsd:enumeration value="ReferencesEmployer">
        <xsd:enumeration value="ReferralProvider">
        <xsd:enumeration value="ReferringHealthCareProvider">
        <xsd:enumeration value="ReferringProvider">
        <xsd:enumeration value="Refinery">
        <xsd:enumeration value="RefineryOperator">
        <xsd:enumeration value="RefusalParty">
        <xsd:enumeration value="Region">
        <xsd:enumeration value="RegionalOffice">
        <xsd:enumeration value="RegisteredBusinessName">
        <xsd:enumeration value="RegisteredInvestmentAdvisor">
        <xsd:enumeration value="RegisteredOffice">
        <xsd:enumeration value="RegisteredOwner">
        <xsd:enumeration value="RegisteredPrincipal">
        <xsd:enumeration value="RegisteringNonparentParty">
        <xsd:enumeration value="RegisteringParentParty">
        <xsd:enumeration value="RegisteringParty">
        <xsd:enumeration value="Registrar">
        <xsd:enumeration value="RegistrationTribunal">
        <xsd:enumeration value="RegularDealer">
        <xsd:enumeration value="RegulatoryStateDistrict">
        <xsd:enumeration value="RegulatoryStateEntity">
        <xsd:enumeration value="RehabilitationFacility">
        <xsd:enumeration value="RehabilitationInpatientUnit">
        <xsd:enumeration value="RehabilitationOutpatientServices">
        <xsd:enumeration value="ReimbursingBank">
        <xsd:enumeration value="ReinsuranceIntermediaryOrBroker">
        <xsd:enumeration value="Reinsurer">
        <xsd:enumeration value="Relative">
        <xsd:enumeration value="ReleaseDrayman">
        <xsd:enumeration value="ReleaseToParty">
        <xsd:enumeration value="RemittingBank">
        <xsd:enumeration value="RemitTo">
        <xsd:enumeration value="RenderingProvider">
        <xsd:enumeration value="Renter">
        <xsd:enumeration value="RentPayor">
        <xsd:enumeration value="RepairingOutlet">
        <xsd:enumeration value="RepairOrRefurbishLocation">
        <xsd:enumeration value="ReplacingManufacturer">
        <xsd:enumeration value="Reporter">
        <xsd:enumeration value="ReportingCarrier">
        <xsd:enumeration value="ReportingCarriersNominatedAgentOrRepresentative">
        <xsd:enumeration value="ReportingLocation">
        <xsd:enumeration value="ReportingOfficer">
        <xsd:enumeration value="Representative">
        <xsd:enumeration value="ReproductiveHealthServices">
        <xsd:enumeration value="RequestedLender">
        <xsd:enumeration value="Requestor">
        <xsd:enumeration value="ResaleCustomer">
        <xsd:enumeration value="ResaleDealer">
        <xsd:enumeration value="ResearchInstitute">
        <xsd:enumeration value="Reservoir">
        <xsd:enumeration value="ResidenceOrDomicile">
        <xsd:enumeration value="ResidencyInstitution">
        <xsd:enumeration value="ResidentBeneficiary">
        <xsd:enumeration value="ResidentInstructingParty">
        <xsd:enumeration value="RespiratoryTherapyServices">
        <xsd:enumeration value="RespiteCareFacility">
        <xsd:enumeration value="ResponsibleExhibitor">
        <xsd:enumeration value="ResponsibleGovernmentAgency">
        <xsd:enumeration value="ResponsibleInstallationDestination">
        <xsd:enumeration value="ResponsibleInstallationOrigin">
        <xsd:enumeration value="ResponsibleParty">
        <xsd:enumeration value="RetailAccount">
        <xsd:enumeration value="RetailPharmacy">
        <xsd:enumeration value="Retrocessionaire">
        <xsd:enumeration value="ReturnedTo">
        <xsd:enumeration value="RoadCarrier">
        <xsd:enumeration value="RoutingParty">
        <xsd:enumeration value="RoutingPoint">
        <xsd:enumeration value="RoyaltyOwner">
        <xsd:enumeration value="RuralHealthClinic">
        <xsd:enumeration value="SalesAssistant">
        <xsd:enumeration value="SalesOffice">
        <xsd:enumeration value="Salesperson">
        <xsd:enumeration value="SalesResponsibility">
        <xsd:enumeration value="SalvageCarrier">
        <xsd:enumeration value="SamplesToBeReturnedTo">
        <xsd:enumeration value="SamplingLocation">
        <xsd:enumeration value="School-BasedServiceProvider">
        <xsd:enumeration value="SchoolDistrict">
        <xsd:enumeration value="SCorporation">
        <xsd:enumeration value="ScreeningPoint">
        <xsd:enumeration value="SealingCompany">
        <xsd:enumeration value="SecondaryInventoryControlActivity">
        <xsd:enumeration value="SecondaryLocationAddress">
        <xsd:enumeration value="SecondaryPayer">
        <xsd:enumeration value="SecondaryTaxpayer">
        <xsd:enumeration value="SecondaryWarranter">
        <xsd:enumeration value="SecondContact">
        <xsd:enumeration value="SecondContactOrganization">
        <xsd:enumeration value="SecondHome">
        <xsd:enumeration value="SecondLevelParentCompany">
        <xsd:enumeration value="Secretariat">
        <xsd:enumeration value="Section8AProgramParticipantFirm">
        <xsd:enumeration value="SecuredParty">
        <xsd:enumeration value="SecuredPartyCompany">
        <xsd:enumeration value="SecuredPartyIndividual">
        <xsd:enumeration value="SelfInsured">
        <xsd:enumeration value="Seller">
        <xsd:enumeration value="SellerAsOfficiallyRegistered">
        <xsd:enumeration value="SellersAgentOrRepresentative">
        <xsd:enumeration value="SellersFinancialInstitution">
        <xsd:enumeration value="SellingAgent">
        <xsd:enumeration value="SellingOffice">
        <xsd:enumeration value="SellingParty">
        <xsd:enumeration value="SenderOfFunds">
        <xsd:enumeration value="SendersCorrespondentBank">
        <xsd:enumeration value="SeniorMembershipProgram">
        <xsd:enumeration value="ServiceBureau">
        <xsd:enumeration value="ServiceLocation">
        <xsd:enumeration value="ServiceManager">
        <xsd:enumeration value="ServiceOrganization">
        <xsd:enumeration value="ServicePerformanceSite">
        <xsd:enumeration value="ServicePerformer">
        <xsd:enumeration value="ServiceProvider">
        <xsd:enumeration value="ServiceRequester">
        <xsd:enumeration value="ServiceSupplier">
        <xsd:enumeration value="ServicingAgent">
        <xsd:enumeration value="ServicingBroker">
        <xsd:enumeration value="ServicingDealer">
        <xsd:enumeration value="ServicingOrganization">
        <xsd:enumeration value="SharedService">
        <xsd:enumeration value="Shareholder">
        <xsd:enumeration value="ShelteredWorkshop">
        <xsd:enumeration value="ShipFrom">
        <xsd:enumeration value="Shipper">
        <xsd:enumeration value="ShippersAssociation">
        <xsd:enumeration value="ShippingLineService">
        <xsd:enumeration value="ShippingScheduleIssuer">
        <xsd:enumeration value="ShipTo">
        <xsd:enumeration value="ShowingAgent">
        <xsd:enumeration value="Sibling">
        <xsd:enumeration value="Signatory">
        <xsd:enumeration value="Signer">
        <xsd:enumeration value="SignificantOther">
        <xsd:enumeration value="SinglePhotonEmissionComputerizedTomographyUnit">
        <xsd:enumeration value="SiteOperator">
        <xsd:enumeration value="SkilledNursingFacility">
        <xsd:enumeration value="SkilledNursingorOtherLong-TermCareUnit">
        <xsd:enumeration value="SkilledNursingServices">
        <xsd:enumeration value="Slaughterer">
        <xsd:enumeration value="SlotCharterParty">
        <xsd:enumeration value="SmallBaseStationLocation">
        <xsd:enumeration value="SmallBusiness">
        <xsd:enumeration value="SmallControlStationLocation">
        <xsd:enumeration value="SmallDisadvantagedBusiness">
        <xsd:enumeration value="SociallyDisadvantagedBusiness">
        <xsd:enumeration value="SociallyDisadvantagedIndividual">
        <xsd:enumeration value="SociallyInsuredPerson">
        <xsd:enumeration value="SocialSecuritiesCollectorsOffice">
        <xsd:enumeration value="SocietyOfPropertyInformationCompilersAndAnalysts">
        <xsd:enumeration value="SoldTo">
        <xsd:enumeration value="SoldToAndShipTo">
        <xsd:enumeration value="SoldToIfDifferentFromBillTo">
        <xsd:enumeration value="SoleProprietor">
        <xsd:enumeration value="Source">
        <xsd:enumeration value="SourceMeterLocation">
        <xsd:enumeration value="SourceOfInformation">
        <xsd:enumeration value="SourcePartyOfInformation">
        <xsd:enumeration value="SpecialAccount">
        <xsd:enumeration value="SpecialCounsel">
        <xsd:enumeration value="SpecializedMobileRadioServiceLicensee">
        <xsd:enumeration value="SpecializedOutpatientProgramForAIDSOrARC">
        <xsd:enumeration value="SpecifiedRepository">
        <xsd:enumeration value="SpeechTherapyServices">
        <xsd:enumeration value="SportsMedicineClinicOrServices">
        <xsd:enumeration value="Spouse">
        <xsd:enumeration value="SpouseInsured">
        <xsd:enumeration value="SpudContractor">
        <xsd:enumeration value="State">
        <xsd:enumeration value="StateCharteredFacility">
        <xsd:enumeration value="StateDivision">
        <xsd:enumeration value="SteamshipCompany">
        <xsd:enumeration value="Stockholder">
        <xsd:enumeration value="StorageArea">
        <xsd:enumeration value="StorageFacilityatDestination">
        <xsd:enumeration value="StorageFacilityAtOrigin">
        <xsd:enumeration value="Store">
        <xsd:enumeration value="StoreClass">
        <xsd:enumeration value="StoreGroup">
        <xsd:enumeration value="StoreKeeper">
        <xsd:enumeration value="StoreManager">
        <xsd:enumeration value="Student">
        <xsd:enumeration value="StudySubmitter">
        <xsd:enumeration value="Sub-Account">
        <xsd:enumeration value="Subcontractor">
        <xsd:enumeration value="SubcontractOrCognizantSecurityOffice">
        <xsd:enumeration value="Subcontractor-Nominated">
        <xsd:enumeration value="SubcontractorWithDirectPayment">
        <xsd:enumeration value="Sub-Entity">
        <xsd:enumeration value="Subgroup">
        <xsd:enumeration value="SubjectOfInquiry">
        <xsd:enumeration value="SubjectProperty">
        <xsd:enumeration value="Submitter">
        <xsd:enumeration value="SubmitterOfSample">
        <xsd:enumeration value="Sub-Office">
        <xsd:enumeration value="Subscriber">
        <xsd:enumeration value="SubscribersEmployer">
        <xsd:enumeration value="SubscribersSchool">
        <xsd:enumeration value="SubsequentOwner">
        <xsd:enumeration value="Sub-Servicer">
        <xsd:enumeration value="Subsidiary">
        <xsd:enumeration value="SubsidiaryDivision">
        <xsd:enumeration value="SubstituteSupplier">
        <xsd:enumeration value="SuccessfulJobApplicant">
        <xsd:enumeration value="SupervisingHealthCareProvider">
        <xsd:enumeration value="SupervisingPhysician">
        <xsd:enumeration value="Supervisor">
        <xsd:enumeration value="SupervisoryAppraiserName">
        <xsd:enumeration value="Supplier">
        <xsd:enumeration value="SupplierOrManufacturer">
        <xsd:enumeration value="SuppliersCorporateOffice">
        <xsd:enumeration value="SupplierWorkTeam">
        <xsd:enumeration value="SupplySource">
        <xsd:enumeration value="SupportingPersonnel">
        <xsd:enumeration value="SupportParty">
        <xsd:enumeration value="Surety">
        <xsd:enumeration value="SuretyForAdditions">
        <xsd:enumeration value="SuretyForAntidumpingOrCountervailingDuty">
        <xsd:enumeration value="SurfaceDischargeAgency">
        <xsd:enumeration value="SurfaceManagementEntity">
        <xsd:enumeration value="Surgeon">
        <xsd:enumeration value="SurplusDealer">
        <xsd:enumeration value="Surveyor-PofessionalQuantity">
        <xsd:enumeration value="SurveyorQuantity">
        <xsd:enumeration value="SurveyorTopographical">
        <xsd:enumeration value="System">
        <xsd:enumeration value="TankFarm">
        <xsd:enumeration value="TankFarmOwner">
        <xsd:enumeration value="TariffIssuer">
        <xsd:enumeration value="TaxAddress">
        <xsd:enumeration value="TaxAuthority">
        <xsd:enumeration value="TaxCollectorsOffice">
        <xsd:enumeration value="TaxExemptOrganization">
        <xsd:enumeration value="Team">
        <xsd:enumeration value="TechnicalOffice">
        <xsd:enumeration value="TelephoneAnsweringServiceBureau">
        <xsd:enumeration value="Tenant">
        <xsd:enumeration value="TenantManager">
        <xsd:enumeration value="Tenderer">
        <xsd:enumeration value="Terminal">
        <xsd:enumeration value="TerminalLocation">
        <xsd:enumeration value="TerminalOperator">
        <xsd:enumeration value="TertiaryPayer">
        <xsd:enumeration value="TestingLaboratory">
        <xsd:enumeration value="TestingService">
        <xsd:enumeration value="TestSponsor">
        <xsd:enumeration value="TheaterCircuit">
        <xsd:enumeration value="Theatre">
        <xsd:enumeration value="TherapeuticRadioisotopeFacility">
        <xsd:enumeration value="ThirdParty">
        <xsd:enumeration value="ThirdPartyAdministrator">
        <xsd:enumeration value="ThirdPartyInvestmentAdvisor">
        <xsd:enumeration value="ThirdPartyMarketer">
        <xsd:enumeration value="ThirdPartyRepricingOrganization">
        <xsd:enumeration value="ThirdPartyRepricingPreferredProviderOrganization">
        <xsd:enumeration value="ThirdPartyReviewingOrganization">
        <xsd:enumeration value="ThirdPartyReviewingPreferredProviderOrganization">
        <xsd:enumeration value="Titleholder">
        <xsd:enumeration value="TitleInsuranceServicesProvider">
        <xsd:enumeration value="TitleUnderwriter">
        <xsd:enumeration value="Tooling">
        <xsd:enumeration value="ToolingDesign">
        <xsd:enumeration value="ToolingFabrication">
        <xsd:enumeration value="ToolSource">
        <xsd:enumeration value="TopParentCompanyInSameCountry">
        <xsd:enumeration value="TowingAgency">
        <xsd:enumeration value="Tradename">
        <xsd:enumeration value="TradeNameSynonym">
        <xsd:enumeration value="TradeUnion">
        <xsd:enumeration value="TrainingInstitution">
        <xsd:enumeration value="TransferPoint">
        <xsd:enumeration value="TransferringParty">
        <xsd:enumeration value="TransferTo">
        <xsd:enumeration value="TransitAuthority">
        <xsd:enumeration value="TransitChargePayer">
        <xsd:enumeration value="TransitFreightForwarder">
        <xsd:enumeration value="TransitPrincipal">
        <xsd:enumeration value="TransitPrincipalsAgentOrRepresentative">
        <xsd:enumeration value="Transmitter">
        <xsd:enumeration value="TransportationOffice">
        <xsd:enumeration value="TransporterOfHazardousWaste">
        <xsd:enumeration value="TransshipmentParty">
        <xsd:enumeration value="TraumaCenter">
        <xsd:enumeration value="TreatmentFacility">
        <xsd:enumeration value="TribalGovernment">
        <xsd:enumeration value="Trust">
        <xsd:enumeration value="Trustee">
        <xsd:enumeration value="TrusteesAttorney">
        <xsd:enumeration value="TrustOfficer">
        <xsd:enumeration value="TrustOrEstate">
        <xsd:enumeration value="TuberculosisAndOTherRespiratoryDiseasesFacility">
        <xsd:enumeration value="UltimateConsignee">
        <xsd:enumeration value="UltimateCustomer">
        <xsd:enumeration value="UltimateParentCompany">
        <xsd:enumeration value="UltimateSameCountryParentCompany">
        <xsd:enumeration value="UltrasoundUnit">
        <xsd:enumeration value="UnassignedAgent">
        <xsd:enumeration value="Underwriter">
        <xsd:enumeration value="UnexpectedHandlingParty">
        <xsd:enumeration value="Union">
        <xsd:enumeration value="UnitedStatesCustomsBroker">
        <xsd:enumeration value="UnitedStatesOverseasSecurityAdministrationOffice">
        <xsd:enumeration value="UnitProperty">
        <xsd:enumeration value="University-CollegeOrSchool">
        <xsd:enumeration value="UnloadingParty">
        <xsd:enumeration value="UnserviceableMaterialConsignee">
        <xsd:enumeration value="UpstreamMeterLocation">
        <xsd:enumeration value="UpstreamParty">
        <xsd:enumeration value="USTrustee">
        <xsd:enumeration value="UtilizationManagementOrganization">
        <xsd:enumeration value="VacationHome">
        <xsd:enumeration value="ValidatingParty">
        <xsd:enumeration value="ValueAddedNetworkProvider">
        <xsd:enumeration value="Vehicle">
        <xsd:enumeration value="VehicleCustodian">
        <xsd:enumeration value="VehicleSalvageAssignment">
        <xsd:enumeration value="Vendor">
        <xsd:enumeration value="VesselMaster">
        <xsd:enumeration value="VesselName">
        <xsd:enumeration value="Veteran-OwnedBusiness">
        <xsd:enumeration value="VeteransAdministrationFacility">
        <xsd:enumeration value="VeteransAdministrationLoanAuthorizedSupplier">
        <xsd:enumeration value="VeteransAdministrationLoanGuarantyAuthority">
        <xsd:enumeration value="Veterinarian">
        <xsd:enumeration value="VeterinaryHospital">
        <xsd:enumeration value="Victim">
        <xsd:enumeration value="VideoDepartment">
        <xsd:enumeration value="VolunteerServicesDepartment">
        <xsd:enumeration value="Voter">
        <xsd:enumeration value="WageEarner">
        <xsd:enumeration value="Warehouse">
        <xsd:enumeration value="WarehouseDepositor">
        <xsd:enumeration value="WarehouseKeeper">
        <xsd:enumeration value="Warranter">
        <xsd:enumeration value="WaterAmbulanceServices">
        <xsd:enumeration value="WaterSystem">
        <xsd:enumeration value="WeightingParty">
        <xsd:enumeration value="WellCasingDepthAuthority">
        <xsd:enumeration value="WellPadConstructionContractor">
        <xsd:enumeration value="Wholesaler">
        <xsd:enumeration value="Wholly-OwnedSubsidiary">
        <xsd:enumeration value="Winner">
        <xsd:enumeration value="WithdrawalPoint">
        <xsd:enumeration value="Witness">
        <xsd:enumeration value="WitnessForDefendant">
        <xsd:enumeration value="WitnessForPlaintiff">
        <xsd:enumeration value="WitnessForProsecution">
        <xsd:enumeration value="Woman-OwnedBusiness">
        <xsd:enumeration value="Woman-OwnedBusinessLarge">
        <xsd:enumeration value="Woman-OwnedBusinessSmall">
        <xsd:enumeration value="WomensHealthCenterOrServices">
        <xsd:enumeration value="WorksiteHealthPromotionFacility">
        <xsd:enumeration value="WorksManager">
        <xsd:enumeration value="WorkTeam">
        <xsd:enumeration value="WritingAgent">
        <xsd:enumeration value="X-RayRadiationTherapyUnit">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: PartyTaxInformationType

PartyTaxInformationType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( TaxIdentifier[IdentifierType]? , RegisteredName[xsd:string]? , RegisteredOffice[xsd:string]? , TaxLocation[LocationType]? , CompanyRegistrationNumber[xsd:string]? )

    Description: PartyTaxInformationType describes the tax information for a party.

    Elements:

    • TaxIdentifier - is the tax identifier or registration number of the party. The agency that allocated this identifier is dependent on the tax jurisdiction of the party. Can also be referred to as the tax exemption or certificate number.
    • RegisteredName - is the name of the party as registered with the tax authority. This must be present if a) the tax regulations require it, and b) it is different from the Name element in the NameAddress element of the party.
    • RegisteredOffice - is the registered office of the party. This must be present if a) the tax regulations require it, and b) it is different from the Address element in the NameAddress element of the party.
    • TaxLocation - holds the tax location.
    • CompanyRegistrationNumber - is the company registration number of the party. This must be present if tax regulations require it.

[^]Code Fragment

    <xsd:complexType name="PartyTaxInformationType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="TaxIdentifier" type="IdentifierType">
        <xsd:element minOccurs="0" name="RegisteredName" type="xsd:string">
        <xsd:element minOccurs="0" name="RegisteredOffice" type="xsd:string">
        <xsd:element minOccurs="0" name="TaxLocation" type="LocationType">
        <xsd:element minOccurs="0" name="CompanyRegistrationNumber" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PartyType

PartyType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PartyID[IdentifierType] , ListOfIdentifier[ListOfIdentifierType]? , MDFBusiness[xsd:boolean]? , NameAddress[NameAddressType]? , PrimaryContact[ContactType]? , OtherContacts[ListOfContactType]? , PartyTaxInformation[PartyTaxInformationType]? )

    Description: PartyType identifies an entity doing business and the relevant information pertaining to it.

    Elements:

    • PartyID - is a standard identification of an entity doing business as assigned by a standards agency.
    • ListOfIdentifier - is a collection of all other identifications of the party being described by the Party element.
    • MDFBusiness - is an indicator of whether the party is a minority, disadvantaged, or female owned business.
    • NameAddress - contains the name and address information for the entity being described by the Party element.
    • PrimaryContact - identifies the main contact and contact information for this party.
    • OtherContacts - is a collection of name and contact information for any other communication purposes not explicitly stated in the Party element.
    • PartyTaxInformation - describes the taxing information for the party.

[^]Code Fragment

    <xsd:complexType name="PartyType">
    <xsd:sequence>
        <xsd:element name="PartyID" type="IdentifierType">
        <xsd:element minOccurs="0" name="ListOfIdentifier" type="ListOfIdentifierType">
        <xsd:element minOccurs="0" name="MDFBusiness" type="xsd:boolean">
        <xsd:element minOccurs="0" name="NameAddress" type="NameAddressType">
        <xsd:element minOccurs="0" name="PrimaryContact" type="ContactType">
        <xsd:element minOccurs="0" name="OtherContacts" type="ListOfContactType">
        <xsd:element minOccurs="0" name="PartyTaxInformation" type="PartyTaxInformationType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PaymentAmountType

PaymentAmountType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( InvoiceCurrencyAmt[MonetaryValueType] , ForeignCurrencyPayment[MonetaryValueType] )

    Description: PaymentAmountType contains detailed information on amounts, date, mean, method, card information and references relating to the ActualPayment.

    Elements:

    • InvoiceCurrencyAmt - holds the amount in the invoice currency, for this payment.
    • ForeignCurrencyPayment - holds the currency and amount if the payment was not made in the invoice currency. This element is mandatory if the payment was not made in the invoice currency.

[^]Code Fragment

    <xsd:complexType name="PaymentAmountType">
    <xsd:sequence>
        <xsd:element name="InvoiceCurrencyAmt" type="MonetaryValueType">
        <xsd:element name="ForeignCurrencyPayment" type="MonetaryValueType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PaymentInstructionsType

PaymentInstructionsType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PaymentTerms[PaymentTermsType]? , PaymentMethod[PaymentMethodType]* )

    Description: PaymentInstructionsType contains the terms and the method of payment for goods or services received.

    Elements:

    • PaymentTerms - is used to communicate one or more of the terms relating to the instructions for payment of goods or services received.
    • PaymentMethod - communicates the specific manner in which a payment is to be made.

[^]Code Fragment

    <xsd:complexType name="PaymentInstructionsType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="PaymentTerms" type="PaymentTermsType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="PaymentMethod" type="PaymentMethodType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: PaymentMeanCodeType

PaymentMeanCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the type of payment to be made for the package. This code list is derived from EDIFACT 4461 (payment means code) and X12 107 (payment method code) and 591 (payment method code).

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • 1035Exchange
    • AcceptedBillOfExchange - Bill drawn by the creditor on the debtor and accepted by the debtor.
    • ACHDemandCashConcentrationOrDisbursementCredit - A credit transaction made through the ACH system to a demand deposit account using the CCD payment format.
    • ACHDemandCashConcentrationOrDisbursementDebit - A debit transaction made through the ACH system to a demand deposit account using the CCD payment format.
    • ACHDemandCashConcentrationOrDisbursementPlusCredit - A credit transaction made through the ACH system to a demand deposit account using the CCD+ payment format.
    • ACHDemandCashConcentrationOrDisbursementPlusDebit - A debit transaction made through the ACH system to a demand deposit account using the CCD+ payment format.
    • ACHDemandCorporateTradeExchangeCredit - A credit transaction made through the ACH system to a demand deposit account using the CTX payment format.
    • ACHDemandCorporateTradeExchangeDebit - A debit transaction made through the ACH system to a demand account using the CTX payment format.
    • ACHDemandCorporateTradePaymentCredit - A credit transaction made through the ACH system to a demand deposit account using the CTP payment format.
    • ACHDemandCorporateTradePaymentDebit - A debit transaction made through the ACH system to a demand deposit account using the CTP payment format.
    • ACHDemandCredit - A credit transaction made through the ACH system to a demand deposit account.
    • ACHDemandCreditReversal - A request to reverse a credit transaction to a demand deposit account.
    • ACHDemandDebit - A debit transaction made through the ACH system to a demand deposit account.
    • ACHDemandDebitReversal - A request to reverse an ACH debit transaction to a demand deposit account.
    • ACHPreArrangedPaymentAndDeposit - A consumer credit transaction made through the ACH system to a demand deposit or savings account.
    • ACHReversal
    • ACHSavingsCashConcentrationOrDisbursementCredit - A credit transaction made through the ACH system to a demand deposit or savings account using the CCD payment format.
    • ACHSavingsCashConcentrationOrDisbursementDebit - A debit transaction made through the ACH system to a savings account using the CCD payment format.
    • ACHSavingsCashConcentrationOrDisbursementPPDCredit - A credit transaction made through the ACH system to a demand deposit or savings account using the PPD payment format.
    • ACHSavingsCashConcentrationOrDisbursementPPDDebit - A debit transaction made through the ACH system to a savings account using the PPD payment format.
    • ACHSavingsCashConcentrationOrDisbursementPPDPlusCredit - A credit transaction made through the ACH system to a demand deposit or savings account using the PPD+ payment format.
    • ACHSavingsCashConcentrationOrDisbursementPPDPlusDebit - A debit transaction made through the ACH system to a savings account using the PPD+ payment format.
    • ACHSavingsCashConcentrationOrDisbursementPlusCredit - A credit transaction made through the ACH system to a savings account using the CCD+ payment format.
    • ACHSavingsCashConcentrationOrDisbursementPlusDebit - A debit transaction made through the ACH system to a savings account using the CCD+ payment format.
    • ACHSavingsCorporateTradeExchangeCredit - A credit transaction made through the ACH system to a savings account using the CTX payment format.
    • ACHSavingsCorporateTradeExchangeDebit - A debit transaction made through the ACH system to a savings account using the CTX payment format.
    • ACHSavingsCorporateTradePaymentCredit - A credit transaction made through the ACH system to a savings account using the CTP payment format.
    • ACHSavingsCorporateTradePaymentDebit - A debit transaction made through the ACH system to a savings account using the CTP payment format.
    • ACHSavingsCredit - A credit transaction made through the ACH system to a savings account.
    • ACHSavingsCreditReversal - A request to reverse an ACH credit transaction to a savings account.
    • ACHSavingsDebit - A debit transaction made through the ACH system to a savings account.
    • ACHSavingsDebitReversal - A request to reverse an ACH debit transaction to a savings account.
    • AutomatedClearingHouse - Payment instructions made through the automated clearing house system.
    • AutomatedClearingHouseCredit - A credit transaction made through the automated clearing house system.
    • AutomatedClearingHouseDebit - A debit transaction made through the automated clearing house system.
    • BankCard - Payment by means of a card issued by a bank or other financial institution.
    • Bankcheque-IssuedByABankingOrSimilarEstablishment
    • BankDraft
    • BankersDraft - Issue of a banker's draft in payment of the funds.
    • BillDrawnByCreditorOnThirdPartyAndAcceptedAndEndorsedByABank - Description to be provided.
    • BillDrawnByTheCreditorAndEndorsedByAnotherBank - Description to be provided.
    • BillDrawnByTheCreditorOnABank - Description to be provided.
    • BillDrawnByTheCreditorOnABankAndEndorsedByAThirdParty - Description to be provided.
    • BillDrawnByTheCreditorOnAThirdParty - Description to be provided.
    • BillDrawnByTheCreditorOnTheDebtor
    • BillingAccount
    • BookEntry - Payment Instructions, initiated from the buyer's account to the seller's account at the save financial institution.
    • BookEntryCredit - A credit transaction, initiated from the buyer's account to the seller's account at the save financial institution.
    • BookEntryDebit - A debit transaction initiated from the seller's account to the seller's account at the same financial institution.
    • Cash
    • CashiersCheck
    • Ccd - Nacha Cash Concentration Or Disbursement-Funds Transacted Without Remittance Information
    • CcdPlus - Nacha Cash Concentration/Disbursement- Funds Transacted Plus An 80 Record Remittance Detail
    • CertifiedBankersDraft
    • CertifiedCheque
    • Cheque
    • ClearingBetweenPartners - Amounts which two partners owe to each other to be compensated in order to avoid useless payments.
    • ClearingHouse
    • ClearingHouseInterbankPaymentSystem - (CHIPs) Clearing House Interbank Payment System Funds/Wire Transfer
    • CollectPaymentByCertifiedFunds
    • CollectPaymentByCompanyCheck
    • CompensationByBalance
    • Credit
    • CreditAccount
    • CreditDebitAccount - Credit / Debit Account
    • CreditCard
    • CreditTransfer
    • Ctp - (NachaCorporateTradePayment-TransactionPlusRemittanceDetailInFixedFormat)
    • Ctx - NachaCorporateTradeExchange-TransactionPlusRemittanceDetailInAnsiStandardFlexibleFormat
    • Debited
    • DebitCard
    • DebitTransfer
    • DeductionFromFilmRental
    • DirectDebit - The amount is to be, or has been, directly debited to the customer's bank account.
    • DirectDeposit
    • DirectPayToOthers
    • Draft
    • EBINAXClearingNetwork
    • ElectronicPaymentSystem
    • FederalReserveFundsOrWireTransferRepetitive
    • FederalReserveFundsOrWireTransferNonRepetitive
    • FinancialInstitutionOption
    • FreeFormatGiro - Ordering customer tells the ordering bank to use the bank service 'Free Format Giro' when transferring the payment. Used in Finnish national banking system.
    • FreightPaymentBank
    • Graduated
    • Hold - Indicates that the bank should hold the payment for collection by the beneficiary or other instructions.
    • Home-BankingDebitTransfer - A debit transfer initiated through home-banking.
    • InCash
    • IncomeContingent
    • IncomeSensitive
    • InKindPayment
    • InstrumentNotDefined
    • InterBankDebitTransfer - A debit transfer via interbank means.
    • InvoicedSeparately
    • LetterOfCredit
    • Level-SumConstant
    • LocalCheque - Indicates that the cheque is given local to the recipient.
    • LockBox
    • MoneyOrder
    • NationalOrRegionalClearing - Indicates that the payment should be made using the national or regional clearing.
    • NonPaymentData
    • NotTransferableBankersDraft - Issue a bankers draft not endorsable.
    • NotTransferableLocalCheque - Issue a cheque not endorsable in payment of the funds.
    • PayByCheck
    • PaymentByPostGiro
    • PaymentToBankAccount
    • PayrollDeduction
    • PetroleumClearinghouseBank
    • PPDCreditToDemandDepositAccount - Pre-Arranged Payment or Deposit (PPD) Credit to a Demand Deposit Account
    • PPDDebitToDemandDepositAccount - Pre-Arranged Payment or Deposit (PPD) Debit to a Demand Deposit Account
    • PPDPlusAddendumCreditToDemandDepositAccount - Pre-Arranged Payment or Deposit Plus Addendum (PPD+) Credit to a Demand Deposit Account
    • PPDPlusAddendumDebitToDemandDepositAccount - Pre-Arranged Payment or Deposit Plus Addendum (PPD+) Debit to a Demand Deposit Account
    • PreauthroizedCheck
    • PreviouslyCharged
    • PrivateNettingAgreementPayByWireTransfer
    • PrivateNettingPayByCheck
    • PromissoryNote
    • PromissoryNoteSignedByABank
    • PromissoryNoteSignedByABankAndEndorsedByAnotherBank
    • PromissoryNoteSignedByAThirdParty
    • PromissoryNoteSignedByAThirdPartyAndEndorsedByABank
    • PromissoryNoteSignedByTheDebtor
    • PromissoryNoteSignedByTheDebtorAndEndorsedByAThirdParty
    • PromissoryNoteSignedByTheDebtorAndEndorsedByBank
    • ProprietaryNetwork
    • ReferencedHome-BankingCreditTransfer - A referenced credit transfer initiated through home-banking.
    • ReferenceGiro - Ordering customer tells the bank to use the payment system 'Reference giro'. Used in the Finnish national banking system.
    • RelatedDetailAccount
    • RequestedMethodForPaymentWasNotUsed - If the requested method for payment was or could not be used, this code indicates that.
    • SpecialAccount
    • SummaryAccount
    • SWIFT - Society for Worldwide Interbank Financial Telecommunications
    • TravelersCheck
    • UrgentGiro - Ordering customer tells the bank to use the bank service 'Urgent Giro' when transferring the payment. Used in Finnish national banking system.
    • VISASpecialElectronicFundsTransferNetwork
    • Waived
    • WireTransfer
    • X12

[^]Code Fragment

    <xsd:simpleType name="PaymentMeanCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="1035Exchange">
        <xsd:enumeration value="AcceptedBillOfExchange">
        <xsd:enumeration value="ACHDemandCashConcentrationOrDisbursementCredit">
        <xsd:enumeration value="ACHDemandCashConcentrationOrDisbursementDebit">
        <xsd:enumeration value="ACHDemandCashConcentrationOrDisbursementPlusCredit">
        <xsd:enumeration value="ACHDemandCashConcentrationOrDisbursementPlusDebit">
        <xsd:enumeration value="ACHDemandCorporateTradeExchangeCredit">
        <xsd:enumeration value="ACHDemandCorporateTradeExchangeDebit">
        <xsd:enumeration value="ACHDemandCorporateTradePaymentCredit">
        <xsd:enumeration value="ACHDemandCorporateTradePaymentDebit">
        <xsd:enumeration value="ACHDemandCredit">
        <xsd:enumeration value="ACHDemandCreditReversal">
        <xsd:enumeration value="ACHDemandDebit">
        <xsd:enumeration value="ACHDemandDebitReversal">
        <xsd:enumeration value="ACHPreArrangedPaymentAndDeposit">
        <xsd:enumeration value="ACHReversal">
        <xsd:enumeration value="ACHSavingsCashConcentrationOrDisbursementCredit">
        <xsd:enumeration value="ACHSavingsCashConcentrationOrDisbursementDebit">
        <xsd:enumeration value="ACHSavingsCashConcentrationOrDisbursementPPDCredit">
        <xsd:enumeration value="ACHSavingsCashConcentrationOrDisbursementPPDDebit">
        <xsd:enumeration value="ACHSavingsCashConcentrationOrDisbursementPPDPlusCredit">
        <xsd:enumeration value="ACHSavingsCashConcentrationOrDisbursementPPDPlusDebit">
        <xsd:enumeration value="ACHSavingsCashConcentrationOrDisbursementPlusCredit">
        <xsd:enumeration value="ACHSavingsCashConcentrationOrDisbursementPlusDebit">
        <xsd:enumeration value="ACHSavingsCorporateTradeExchangeCredit">
        <xsd:enumeration value="ACHSavingsCorporateTradeExchangeDebit">
        <xsd:enumeration value="ACHSavingsCorporateTradePaymentCredit">
        <xsd:enumeration value="ACHSavingsCorporateTradePaymentDebit">
        <xsd:enumeration value="ACHSavingsCredit">
        <xsd:enumeration value="ACHSavingsCreditReversal">
        <xsd:enumeration value="ACHSavingsDebit">
        <xsd:enumeration value="ACHSavingsDebitReversal">
        <xsd:enumeration value="AutomatedClearingHouse">
        <xsd:enumeration value="AutomatedClearingHouseCredit">
        <xsd:enumeration value="AutomatedClearingHouseDebit">
        <xsd:enumeration value="BankCard">
        <xsd:enumeration value="Bankcheque-IssuedByABankingOrSimilarEstablishment">
        <xsd:enumeration value="BankDraft">
        <xsd:enumeration value="BankersDraft">
        <xsd:enumeration value="BillDrawnByCreditorOnThirdPartyAndAcceptedAndEndorsedByABank">
        <xsd:enumeration value="BillDrawnByTheCreditorAndEndorsedByAnotherBank">
        <xsd:enumeration value="BillDrawnByTheCreditorOnABank">
        <xsd:enumeration value="BillDrawnByTheCreditorOnABankAndEndorsedByAThirdParty">
        <xsd:enumeration value="BillDrawnByTheCreditorOnAThirdParty">
        <xsd:enumeration value="BillDrawnByTheCreditorOnTheDebtor">
        <xsd:enumeration value="BillingAccount">
        <xsd:enumeration value="BookEntry">
        <xsd:enumeration value="BookEntryCredit">
        <xsd:enumeration value="BookEntryDebit">
        <xsd:enumeration value="Cash">
        <xsd:enumeration value="CashiersCheck">
        <xsd:enumeration value="Ccd">
        <xsd:enumeration value="CcdPlus">
        <xsd:enumeration value="CertifiedBankersDraft">
        <xsd:enumeration value="CertifiedCheque">
        <xsd:enumeration value="Cheque">
        <xsd:enumeration value="ClearingBetweenPartners">
        <xsd:enumeration value="ClearingHouse">
        <xsd:enumeration value="ClearingHouseInterbankPaymentSystem">
        <xsd:enumeration value="CollectPaymentByCertifiedFunds">
        <xsd:enumeration value="CollectPaymentByCompanyCheck">
        <xsd:enumeration value="CompensationByBalance">
        <xsd:enumeration value="Credit">
        <xsd:enumeration value="CreditAccount">
        <xsd:enumeration value="CreditDebitAccount">
        <xsd:enumeration value="CreditCard">
        <xsd:enumeration value="CreditTransfer">
        <xsd:enumeration value="Ctp">
        <xsd:enumeration value="Ctx">
        <xsd:enumeration value="Debited">
        <xsd:enumeration value="DebitCard">
        <xsd:enumeration value="DebitTransfer">
        <xsd:enumeration value="DeductionFromFilmRental">
        <xsd:enumeration value="DirectDebit">
        <xsd:enumeration value="DirectDeposit">
        <xsd:enumeration value="DirectPayToOthers">
        <xsd:enumeration value="Draft">
        <xsd:enumeration value="EBINAXClearingNetwork">
        <xsd:enumeration value="ElectronicPaymentSystem">
        <xsd:enumeration value="FederalReserveFundsOrWireTransferRepetitive">
        <xsd:enumeration value="FederalReserveFundsOrWireTransferNonRepetitive">
        <xsd:enumeration value="FinancialInstitutionOption">
        <xsd:enumeration value="FreeFormatGiro">
        <xsd:enumeration value="FreightPaymentBank">
        <xsd:enumeration value="Graduated">
        <xsd:enumeration value="Hold">
        <xsd:enumeration value="Home-BankingDebitTransfer">
        <xsd:enumeration value="InCash">
        <xsd:enumeration value="IncomeContingent">
        <xsd:enumeration value="IncomeSensitive">
        <xsd:enumeration value="InKindPayment">
        <xsd:enumeration value="InstrumentNotDefined">
        <xsd:enumeration value="InterBankDebitTransfer">
        <xsd:enumeration value="InvoicedSeparately">
        <xsd:enumeration value="LetterOfCredit">
        <xsd:enumeration value="Level-SumConstant">
        <xsd:enumeration value="LocalCheque">
        <xsd:enumeration value="LockBox">
        <xsd:enumeration value="MoneyOrder">
        <xsd:enumeration value="NationalOrRegionalClearing">
        <xsd:enumeration value="NonPaymentData">
        <xsd:enumeration value="NotTransferableBankersDraft">
        <xsd:enumeration value="NotTransferableLocalCheque">
        <xsd:enumeration value="PayByCheck">
        <xsd:enumeration value="PaymentByPostGiro">
        <xsd:enumeration value="PaymentToBankAccount">
        <xsd:enumeration value="PayrollDeduction">
        <xsd:enumeration value="PetroleumClearinghouseBank">
        <xsd:enumeration value="PPDCreditToDemandDepositAccount">
        <xsd:enumeration value="PPDDebitToDemandDepositAccount">
        <xsd:enumeration value="PPDPlusAddendumCreditToDemandDepositAccount">
        <xsd:enumeration value="PPDPlusAddendumDebitToDemandDepositAccount">
        <xsd:enumeration value="PreauthroizedCheck">
        <xsd:enumeration value="PreviouslyCharged">
        <xsd:enumeration value="PrivateNettingAgreementPayByWireTransfer">
        <xsd:enumeration value="PrivateNettingPayByCheck">
        <xsd:enumeration value="PromissoryNote">
        <xsd:enumeration value="PromissoryNoteSignedByABank">
        <xsd:enumeration value="PromissoryNoteSignedByABankAndEndorsedByAnotherBank">
        <xsd:enumeration value="PromissoryNoteSignedByAThirdParty">
        <xsd:enumeration value="PromissoryNoteSignedByAThirdPartyAndEndorsedByABank">
        <xsd:enumeration value="PromissoryNoteSignedByTheDebtor">
        <xsd:enumeration value="PromissoryNoteSignedByTheDebtorAndEndorsedByAThirdParty">
        <xsd:enumeration value="PromissoryNoteSignedByTheDebtorAndEndorsedByBank">
        <xsd:enumeration value="ProprietaryNetwork">
        <xsd:enumeration value="ReferencedHome-BankingCreditTransfer">
        <xsd:enumeration value="ReferenceGiro">
        <xsd:enumeration value="RelatedDetailAccount">
        <xsd:enumeration value="RequestedMethodForPaymentWasNotUsed">
        <xsd:enumeration value="SpecialAccount">
        <xsd:enumeration value="SummaryAccount">
        <xsd:enumeration value="SWIFT">
        <xsd:enumeration value="TravelersCheck">
        <xsd:enumeration value="UrgentGiro">
        <xsd:enumeration value="VISASpecialElectronicFundsTransferNetwork">
        <xsd:enumeration value="Waived">
        <xsd:enumeration value="WireTransfer">
        <xsd:enumeration value="X12">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: PaymentMeanType

PaymentMeanType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PaymentMeanCoded[PaymentMeanCodeType] , PaymentCodedMeanOther[xsd:string]? )

    Description: PaymentMeanType contains information about a particular payment method that is used.

    Elements:

    • PaymentMeanCoded - contains a valid means of extinguishing the debt to which it relates.
    • PaymentCodedMeanOther -

[^]Code Fragment

    <xsd:complexType name="PaymentMeanType">
    <xsd:sequence>
        <xsd:element name="PaymentMeanCoded" type="PaymentMeanCodeType">
        <xsd:element minOccurs="0" name="PaymentCodedMeanOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PaymentMethodType

PaymentMethodType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PaymentMeanCoded[PaymentMeanCodeType] , PaymentMeanCodedOther[xsd:string]? , PaymentMeanReference[ReferenceType]? , PaymentSystemCoded[PaymentSystemCodeType]? , PaymentSystemCodedOther[xsd:string]? , ( FITransfer[FITransferType] | CardInfo[CardInfoType] )? )

    Description: PaymentMethodType communicates the specific manner in which a payment is to be made.

    Elements:

    • PaymentMeanCoded - contains a valid means of extinguishing the debt to which it relates.
    • PaymentMeanCodedOther - is used to provide a non-standard PaymentMeanCode. This element is mandatory if the value of PaymentMeanCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • PaymentMeanReference - identifies specific information relating to the specified payment mean. For example, if the selected payment mean were check, then PaymentMeanReference would be used to communicate the check number.
    • PaymentSystemCoded - indicates the system through which the payment is processed using a standard codelist.
    • PaymentSystemCodedOther - is used to provide a non-standard PaymentSystemCode. This element is mandatory if the value of PaymentSystemCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • FITransfer - contains information for the financial institution and associated account details for both the recieving and originating account.
    • CardInfo - contains details of the credit or debit card that is being used for the payment.

[^]Code Fragment

    <xsd:complexType name="PaymentMethodType">
    <xsd:sequence>
        <xsd:element name="PaymentMeanCoded" type="PaymentMeanCodeType">
        <xsd:element minOccurs="0" name="PaymentMeanCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="PaymentMeanReference" type="ReferenceType">
        <xsd:element minOccurs="0" name="PaymentSystemCoded" type="PaymentSystemCodeType">
        <xsd:element minOccurs="0" name="PaymentSystemCodedOther" type="xsd:string">
        <xsd:choice minOccurs="0">
            <xsd:element name="FITransfer" type="FITransferType">
            <xsd:element name="CardInfo" type="CardInfoType">
        </xsd:choice>
    </xsd:sequence>
</xsd:complexType>


complexType definition: PaymentRecordType

PaymentRecordType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PaymentRef[ReferenceType]? , ( CardInfo[CardInfoType] | FITransfer[FITransferType] ) )

    Description: PaymentRecordType contains a record of the type of payment instrument or other method used to make the payment.

    Elements:

    • PaymentRef - contains a reference or other code provided by the financial institution that authorizes or settled the payment that may be used to identify the payment record.
    • CardInfo - contains details of the credit or debit card that is being used for the payment.
    • FITransfer - contains details about the transfer from one financial institution to another.

[^]Code Fragment

    <xsd:complexType name="PaymentRecordType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="PaymentRef" type="ReferenceType">
        <xsd:choice>
            <xsd:element name="CardInfo" type="CardInfoType">
            <xsd:element name="FITransfer" type="FITransferType">
        </xsd:choice>
    </xsd:sequence>
</xsd:complexType>


simpleType definition: PaymentResponsibilityCodeType

PaymentResponsibilityCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies which party pays for the package. This code list is derived from EDIFACT 8395 (Returnable package freight payment responsibility code) and X12 743 (Returnable container freight payment responsibility code).

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • PaidByCustomer
    • Free
    • PaidBySupplier

[^]Code Fragment

    <xsd:simpleType name="PaymentResponsibilityCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="PaidByCustomer">
        <xsd:enumeration value="Free">
        <xsd:enumeration value="PaidBySupplier">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: PaymentSystemCodeType

PaymentSystemCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This identifies the system over which the payment will be transmitted. This code list is derived from EDIFACT 4435 (Payment channel code) and X12 812 (Payment Format Code).

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • OrdinaryPost
    • AirMail
    • BillPayment
    • ConsumerEmployeeCheck
    • CashConcentrationDisbursement
    • CashConcentrationDisbursementPlusAddenda
    • CustomerInitiatedEntry
    • CustomerInitiatedEntryPlusAddenda
    • CorporateTradeExchange
    • CorporateCheck
    • Telegraph
    • Telex
    • SWIFT - Society for Worldwide Interbank Financial Telecommunications s.c.
    • OtherTransmissionNetworks
    • NetworksNotDefined
    • Fedwire
    • Personal-Face-To-Face - Indicates that payment should be made by the bank to the beneficiary or his identified agent, in person.
    • PrearrangedPaymentAndDeposit
    • PrearrangedPaymentAndDepositPlusAddenda
    • PreauthorizedDraft
    • RegisteredAirMail
    • RegisteredMail
    • Courier - Public courier service.
    • Messenger - Private messenger service.
    • NationalACH - Nation wide clearing house for automated payment.
    • OtherACH - Other than nation wide clearing house system.

[^]Code Fragment

    <xsd:simpleType name="PaymentSystemCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="OrdinaryPost">
        <xsd:enumeration value="AirMail">
        <xsd:enumeration value="BillPayment">
        <xsd:enumeration value="ConsumerEmployeeCheck">
        <xsd:enumeration value="CashConcentrationDisbursement">
        <xsd:enumeration value="CashConcentrationDisbursementPlusAddenda">
        <xsd:enumeration value="CustomerInitiatedEntry">
        <xsd:enumeration value="CustomerInitiatedEntryPlusAddenda">
        <xsd:enumeration value="CorporateTradeExchange">
        <xsd:enumeration value="CorporateCheck">
        <xsd:enumeration value="Telegraph">
        <xsd:enumeration value="Telex">
        <xsd:enumeration value="SWIFT">
        <xsd:enumeration value="OtherTransmissionNetworks">
        <xsd:enumeration value="NetworksNotDefined">
        <xsd:enumeration value="Fedwire">
        <xsd:enumeration value="Personal-Face-To-Face">
        <xsd:enumeration value="PrearrangedPaymentAndDeposit">
        <xsd:enumeration value="PrearrangedPaymentAndDepositPlusAddenda">
        <xsd:enumeration value="PreauthorizedDraft">
        <xsd:enumeration value="RegisteredAirMail">
        <xsd:enumeration value="RegisteredMail">
        <xsd:enumeration value="Courier">
        <xsd:enumeration value="Messenger">
        <xsd:enumeration value="NationalACH">
        <xsd:enumeration value="OtherACH">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: PaymentTermCodeType

PaymentTermCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the payment term. This code list is derived from EDIFACT 4279 (Payment terms type code qualifier) and X12 336 (Terms type code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • 10DaysAfterEndOfMonth - Payment due ten days after end of a calendar month.
    • AdjustmentPayment - Payment adjusted for outstanding credits or debits.
    • AdvancedPayment - Payment in advance of due date.
    • Anticipation
    • AvailableByAcceptance - Payment on acceptance.
    • AvailableByDeferredPayment - Payment made at deferred date.
    • AvailableByNegotiation - Payment made by negotiation.
    • AvailableByNegotiationByNamedBank - Payment made by negotiation with a specified financial institution.
    • AvailableByNegotiationWithAnyBank - Payment made by negotiation with any bank.
    • AvailableByNegotiationWithAnyBankin - Payment made by negotiation with any bank in a specified location.
    • AvailableBySightPayment - Payment made at sight.
    • BankTransfer - The payment terms require the use of bank transfer.
    • Basic - Payment conditions normally applied.
    • BasicCommissionTerms - The payment terms call for the use of basic commission terms.
    • BasicDiscountOffered
    • BillOfExchange - The payment terms require the use of bill of exchange.
    • BillToBill
    • CancellationOption
    • Cash - The payment terms are that payments are made in cash.
    • CashAccount
    • CashAgainstDocuments - The payment terms require cash payment before document transfer.
    • CashByStateLaw - The payment terms are dictated by state law requiring payment of cash.
    • CashDiscountTermsApply - The payment terms are that a discount is applicable if the payment is made in cash.
    • CashonAdvance
    • CashonArrival - The payment terms require payment by cash on arrival of the goods or services.
    • CashOnDelivery - The payment terms are cash is due on delivery of merchandise.
    • CashPerVendorRequest - The payment terms involve a vendor request for payment by cash.
    • CashWithOrder - The payment terms require the payment in cash with placement of the order.
    • CertifiedCheck - The payment terms require the use of a certified cheque.
    • ChargeCard - The payment terms permit the use of a charge card to effect payment.
    • CompletePayment - Payment must be made for complete value and may not be paid in instalments.
    • Consignment - The payment terms are that the goods will be paid for when they are sold or consumed.
    • ContractBasis - The payment terms are based on a contract with a vendor.
    • CostPlus - The payment terms permit reimbursement of costs plus other authorised changes.
    • CreditControlled - The payment terms involve the monitoring of credit by the grantor.
    • DatingGiven - The payment terms in which suppliers may extend seasonal dating.
    • DeferredOrInstallment
    • DepositRequired - The payment terms require a deposit be provided.
    • Discount
    • DiscountNotApplicable
    • DiscountWithAdvancePayment - The payment terms include a discount when payment is made in advance.
    • DiscountWithPromptPay - The payment terms include a discount when payment is made within a time frame designated as prompt pay.
    • DocumentsAgainstAcceptance - The payment terms require acceptance of liability before document of transfer.
    • DocumentsAgainstPayment - The payment terms require payment before document transfer.
    • Elective - Payment terms to be chosen by buyer (from options separately advised)
    • EndOfMonth
    • Extended
    • FastPay
    • FixedDate
    • FixedDateLatePaymentPenaltyApplies
    • FixedFee - The payment term requires a fixed fee payment.
    • InstallmentPaymentsAreDueAnnually
    • InstallmentPaymentsAreDueMonthly
    • InstallmentPaymentsAreDueQuarterly
    • InstallmentPaymentsAreDueSemiAnnually
    • Instant - Payment is due on receipt of invoice.
    • InterCompanyAccount - The payment terms involve the use of an inter-company account.
    • IrrevocableLetterOfCredit - The payment terms require the use of an irrevocable letter of credit.
    • LatePayment - Payment after due date.
    • LeaseAgreement - The payment terms are included in the lease agreement.
    • LetterOfCredit - The payment terms require the use of a letter of credit.
    • LetterOfCreditAtSight - The payment terms require the presentation of a letter of credit.
    • Liquidation
    • LumpSum - The payment term requires a lump sum payment.
    • Mixed - Different payment terms negotiated under a documentary credit.
    • NetMonthFollowingInvoice
    • NoCharge
    • NonStandard - Terms of payment differ from the normal terms.
    • NotYetDefined
    • PaidAgainstStatement
    • PartialAdvance - The payment terms require a partial payment in advance of completion.
    • PaymentByInstalment
    • PaymentByinstalmentsAccordingToProgressAA - Payment by instalments according to progress (as agreed)
    • PaymentByInstalmentsAccordingToProgressTBA - Payment by instalments according to progress (to be agreed)
    • PaymentDueUponReceiptOfInvoice
    • PaymentOrderThroughBank
    • PaymentTermsDefinedInConsolidatedInvoice - Payment terms are specified in a consolidated invoice.
    • PaymentUponCompletion - The payment terms require payment upon completion.
    • PenaltyTerms - Penalty terms.
    • Prepayment
    • PreviouslyAgreedUpon
    • ProgressPayment
    • PromissoryNotes
    • PromptPaymentAct
    • Proximo - Occurring in the next month after present.
    • SecuredAccount - The payment terms call for the use of a secured account.
    • SellByNote - The payment terms involve a debtor who promises to pay a definite sum of money on demand or at a definite time in the future.
    • SellerToAdviseBuyer - Seller will advise buyer of payment terms by separate transaction.
    • SpecialProximo
    • SupplierFloorPlan - The payment terms involve payment for merchandise owned as a third party.
    • TenorPaymentTerms - Payment to be made according to bilaterally agreed conditions between buyer and seller.
    • TermsNotApplicable
    • TradeAcceptance - A trade acceptance is a written acknowledgement of the sale of goods and promise to pay at a definite date and place.
    • Ultimo - Payment is due the end of the current or specified month.
    • UnitedStatesFundsRequired - The payment terms require the use of United States funds.
    • Unknown
    • UsanceBill - The payment terms are based on the time allowed by commercial usage for the payment of foreign bills of exchange.

[^]Code Fragment

    <xsd:simpleType name="PaymentTermCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="10DaysAfterEndOfMonth">
        <xsd:enumeration value="AdjustmentPayment">
        <xsd:enumeration value="AdvancedPayment">
        <xsd:enumeration value="Anticipation">
        <xsd:enumeration value="AvailableByAcceptance">
        <xsd:enumeration value="AvailableByDeferredPayment">
        <xsd:enumeration value="AvailableByNegotiation">
        <xsd:enumeration value="AvailableByNegotiationByNamedBank">
        <xsd:enumeration value="AvailableByNegotiationWithAnyBank">
        <xsd:enumeration value="AvailableByNegotiationWithAnyBankin">
        <xsd:enumeration value="AvailableBySightPayment">
        <xsd:enumeration value="BankTransfer">
        <xsd:enumeration value="Basic">
        <xsd:enumeration value="BasicCommissionTerms">
        <xsd:enumeration value="BasicDiscountOffered">
        <xsd:enumeration value="BillOfExchange">
        <xsd:enumeration value="BillToBill">
        <xsd:enumeration value="CancellationOption">
        <xsd:enumeration value="Cash">
        <xsd:enumeration value="CashAccount">
        <xsd:enumeration value="CashAgainstDocuments">
        <xsd:enumeration value="CashByStateLaw">
        <xsd:enumeration value="CashDiscountTermsApply">
        <xsd:enumeration value="CashonAdvance">
        <xsd:enumeration value="CashonArrival">
        <xsd:enumeration value="CashOnDelivery">
        <xsd:enumeration value="CashPerVendorRequest">
        <xsd:enumeration value="CashWithOrder">
        <xsd:enumeration value="CertifiedCheck">
        <xsd:enumeration value="ChargeCard">
        <xsd:enumeration value="CompletePayment">
        <xsd:enumeration value="Consignment">
        <xsd:enumeration value="ContractBasis">
        <xsd:enumeration value="CostPlus">
        <xsd:enumeration value="CreditControlled">
        <xsd:enumeration value="DatingGiven">
        <xsd:enumeration value="DeferredOrInstallment">
        <xsd:enumeration value="DepositRequired">
        <xsd:enumeration value="Discount">
        <xsd:enumeration value="DiscountNotApplicable">
        <xsd:enumeration value="DiscountWithAdvancePayment">
        <xsd:enumeration value="DiscountWithPromptPay">
        <xsd:enumeration value="DocumentsAgainstAcceptance">
        <xsd:enumeration value="DocumentsAgainstPayment">
        <xsd:enumeration value="Elective">
        <xsd:enumeration value="EndOfMonth">
        <xsd:enumeration value="Extended">
        <xsd:enumeration value="FastPay">
        <xsd:enumeration value="FixedDate">
        <xsd:enumeration value="FixedDateLatePaymentPenaltyApplies">
        <xsd:enumeration value="FixedFee">
        <xsd:enumeration value="InstallmentPaymentsAreDueAnnually">
        <xsd:enumeration value="InstallmentPaymentsAreDueMonthly">
        <xsd:enumeration value="InstallmentPaymentsAreDueQuarterly">
        <xsd:enumeration value="InstallmentPaymentsAreDueSemiAnnually">
        <xsd:enumeration value="Instant">
        <xsd:enumeration value="InterCompanyAccount">
        <xsd:enumeration value="IrrevocableLetterOfCredit">
        <xsd:enumeration value="LatePayment">
        <xsd:enumeration value="LeaseAgreement">
        <xsd:enumeration value="LetterOfCredit">
        <xsd:enumeration value="LetterOfCreditAtSight">
        <xsd:enumeration value="Liquidation">
        <xsd:enumeration value="LumpSum">
        <xsd:enumeration value="Mixed">
        <xsd:enumeration value="NetMonthFollowingInvoice">
        <xsd:enumeration value="NoCharge">
        <xsd:enumeration value="NonStandard">
        <xsd:enumeration value="NotYetDefined">
        <xsd:enumeration value="PaidAgainstStatement">
        <xsd:enumeration value="PartialAdvance">
        <xsd:enumeration value="PaymentByInstalment">
        <xsd:enumeration value="PaymentByinstalmentsAccordingToProgressAA">
        <xsd:enumeration value="PaymentByInstalmentsAccordingToProgressTBA">
        <xsd:enumeration value="PaymentDueUponReceiptOfInvoice">
        <xsd:enumeration value="PaymentOrderThroughBank">
        <xsd:enumeration value="PaymentTermsDefinedInConsolidatedInvoice">
        <xsd:enumeration value="PaymentUponCompletion">
        <xsd:enumeration value="PenaltyTerms">
        <xsd:enumeration value="Prepayment">
        <xsd:enumeration value="PreviouslyAgreedUpon">
        <xsd:enumeration value="ProgressPayment">
        <xsd:enumeration value="PromissoryNotes">
        <xsd:enumeration value="PromptPaymentAct">
        <xsd:enumeration value="Proximo">
        <xsd:enumeration value="SecuredAccount">
        <xsd:enumeration value="SellByNote">
        <xsd:enumeration value="SellerToAdviseBuyer">
        <xsd:enumeration value="SpecialProximo">
        <xsd:enumeration value="SupplierFloorPlan">
        <xsd:enumeration value="TenorPaymentTerms">
        <xsd:enumeration value="TermsNotApplicable">
        <xsd:enumeration value="TradeAcceptance">
        <xsd:enumeration value="Ultimo">
        <xsd:enumeration value="UnitedStatesFundsRequired">
        <xsd:enumeration value="Unknown">
        <xsd:enumeration value="UsanceBill">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: PaymentTermsType

PaymentTermsType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( NetDueDate[xsd:dateTime]? , NetTimeDue[TimeDueType]? , PaymentTerm[PaymentTermType]+ , PaymentTermsNote[xsd:string]? )

    Description: PaymentTermsType is used to communicate one or more of terms relating to the instructions for payment of goods or services received.

    Elements:

    • NetDueDate - is the day the full balance is due.
    • NetTimeDue - provides a structured element that allows the payment due date to expressed in a period time from a specific occurence, such as reciept of the goods ordered.
    • PaymentTerm - contains details about one payment condition, such as discount eligibility.
    • PaymentTermsNote - contains a note to further describe the payment terms.

[^]Code Fragment

    <xsd:complexType name="PaymentTermsType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="NetDueDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="NetTimeDue" type="TimeDueType">
        <xsd:element maxOccurs="unbounded" name="PaymentTerm" type="PaymentTermType">
        <xsd:element minOccurs="0" name="PaymentTermsNote" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PaymentTermType

PaymentTermType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PaymentTermCoded[PaymentTermCodeType] , PaymentTermCodedOther[xsd:string]? , PaymentTermValue[xsd:int]? , PaymentTermDescription[xsd:string]? , DiscountInformation[DiscountsType]? )

    Description: PaymentTermType contains information about one payment condition, such as discount eligibility.

    Elements:

    • PaymentTermCoded - identifies a payment condition using a standard code list.
    • PaymentTermCodedOther - is used to provide a non-standard PaymentTermCode. This element is mandatory if the value of PaymentTermCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • PaymentTermValue - specifies the value that pertains to the PaymentTermCode.
    • PaymentTermDescription - is a plain text description of the payment term.
    • DiscountInformation - is used to communicate any discounts that may be associated with the payment term.

[^]Code Fragment

    <xsd:complexType name="PaymentTermType">
    <xsd:sequence>
        <xsd:element name="PaymentTermCoded" type="PaymentTermCodeType">
        <xsd:element minOccurs="0" name="PaymentTermCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="PaymentTermValue" type="xsd:int">
        <xsd:element minOccurs="0" name="PaymentTermDescription" type="xsd:string">
        <xsd:element minOccurs="0" name="DiscountInformation" type="DiscountsType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PercentageAllowanceOrChargeType

PercentageAllowanceOrChargeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PercentQualifier[PercentQualifierType] , Percent[PercentType] , PercentageMonetaryValue[MonetaryValueType]? )

    Description: PercentageAllowanceOrChargeType specifies the allowance or charge based on a percentage.

    Elements:

    • PercentQualifier - contains information on how the percentage is calculated.
    • Percent - is the percentage of the charge.
    • PercentageMonetaryValue - is the value of the percentage allowance or charge.

[^]Code Fragment

    <xsd:complexType name="PercentageAllowanceOrChargeType">
    <xsd:sequence>
        <xsd:element name="PercentQualifier" type="PercentQualifierType">
        <xsd:element name="Percent" type="PercentType">
        <xsd:element minOccurs="0" name="PercentageMonetaryValue" type="MonetaryValueType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: PercentQualifierCodeType

PercentQualifierCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies how a percentage is calculated. This code list is derived from X12 378 (Allowance or Charge Percent Qualifier)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom code
    • ItemListCost
    • ItemNetCost
    • Discount-Gross
    • Discount-Net
    • BasePriceperUnit
    • BasePriceAmount
    • BasePriceAmountLessPreviousDiscount
    • NetMonthlyOnAllInvoicesPastDue
    • LatePaymentChargeBaseAmount
    • FuelRate

[^]Code Fragment

    <xsd:simpleType name="PercentQualifierCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="ItemListCost">
        <xsd:enumeration value="ItemNetCost">
        <xsd:enumeration value="Discount-Gross">
        <xsd:enumeration value="Discount-Net">
        <xsd:enumeration value="BasePriceperUnit">
        <xsd:enumeration value="BasePriceAmount">
        <xsd:enumeration value="BasePriceAmountLessPreviousDiscount">
        <xsd:enumeration value="NetMonthlyOnAllInvoicesPastDue">
        <xsd:enumeration value="LatePaymentChargeBaseAmount">
        <xsd:enumeration value="FuelRate">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: PercentQualifierType

PercentQualifierType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PercentQualifierCoded[PercentQualifierCodeType] , PercentQualifierCodedOther[xsd:string]? )

    Description: PercentQualifierType contains information on how the percentage is calculated.

    Elements:

    • PercentQualifierCoded - defines what the percentage is calculated against using a standard codelist.
    • PercentQualifierCodedOther - is used to provide a non-standard PercentQualifierCode This element is mandatory when the value of PercentQualifierCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="PercentQualifierType">
    <xsd:sequence>
        <xsd:element name="PercentQualifierCoded" type="PercentQualifierCodeType">
        <xsd:element minOccurs="0" name="PercentQualifierCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PercentType

PercentType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: Extension of type: Decimal10_4Type

    Attribute:Name: UnitOfMeasurement, Type: UOMCodeType, Fixed: 'P1'

    Description: PercentType defines a percnetage. The syntax for this element is to express the percentage as a whole number. For instance, if 3/4 of a whole is to be expressed, the actual value of the Percent would be 75.00. The unit of measure is fixed to "P1", or percent. The given exampel would thus read 75%.

    Attributes:

    • UnitOfMeasurement

[^]Code Fragment

    <xsd:complexType name="PercentType">
    <xsd:simpleContent>
        <xsd:extension base="Decimal10_4Type">
            <xsd:attribute name="UnitOfMeasurement" type="UOMCodeType" fixed="P1">
        </xsd:extension>
    </xsd:simpleContent>
</xsd:complexType>


complexType definition: POBoxType

POBoxType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: Extension of type: xsd:string

    Attribute:Name: POBoxPostalCode, Type: xsd:string, Use: 'optional'

    Description: POBoxType contains the post office box number. This is a string content model.

    Attributes:

    • POBoxPostalCode - is used to hold the postal code associated with the post office box.

[^]Code Fragment

    <xsd:complexType name="POBoxType">
    <xsd:simpleContent>
        <xsd:extension base="xsd:string">
            <xsd:attribute name="POBoxPostalCode" type="xsd:string" use="optional">
        </xsd:extension>
    </xsd:simpleContent>
</xsd:complexType>


simpleType definition: PosInt_6Type

PosInt_6Type (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    is intended to hold a positive integer comprised of up to 6 base 10 characters

    Content: Restriction of base type xsd:decimal

      xsd:totalDigits: 6
      xsd:fractionDigits: 0
      xsd:minInclusive: 0

[^]Code Fragment

    <xsd:simpleType name="PosInt_6Type">
    <xsd:restriction base="xsd:decimal">
        <xsd:totalDigits value="6">
        <xsd:fractionDigits value="0">
        <xsd:minInclusive value="0">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: PriceMultiplierCodeType

PriceMultiplierCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the reason for which a price is to be multiplied by a factor to obtain the final price. This code list is derived from EDIFACT 5393 (Price Multiplier Qualifier) and X12 648 (Price Multiplier Qualifier)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom code
    • CostMarkupMultiplier-OriginalCost
    • CostMarkupMultiplier-RetailCost
    • DiscountMultiplier
    • CostMarkupMultiplier-WholesaleCost
    • PercentSolutionMultiplier
    • SellingMultiplier

[^]Code Fragment

    <xsd:simpleType name="PriceMultiplierCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="CostMarkupMultiplier-OriginalCost">
        <xsd:enumeration value="CostMarkupMultiplier-RetailCost">
        <xsd:enumeration value="DiscountMultiplier">
        <xsd:enumeration value="CostMarkupMultiplier-WholesaleCost">
        <xsd:enumeration value="PercentSolutionMultiplier">
        <xsd:enumeration value="SellingMultiplier">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: PriceMultiplierType

PriceMultiplierType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PriceMultiplierCoded[PriceMultiplierCodeType] , PriceMultiplierCodedOther[xsd:string]? , Multiplier[xsd:decimal] )

    Description: PriceMultiplierType contains a reason and value by which the unit price is multiplied by to arrive at the final price for an item. This can be used to apply a discount to a basic unit price.

    Elements:

    • PriceMultiplierCoded - specifies the function of the multiplier using a standard codelist.
    • PriceMultiplierCodedOther - is used to provide a non-standard PriceMultiplerCode. This element is only used if the value of PriceMultiplierCoded is 'Other.' These codes should not contain white space unless absolutely necessary.
    • Multiplier - contains a value by which the unit price is multiplied by to arrive at the final price for an item. For example, if the unit price is to be discounted by 10%, the value of PriceMultiplier would be 0.9

[^]Code Fragment

    <xsd:complexType name="PriceMultiplierType">
    <xsd:sequence>
        <xsd:element name="PriceMultiplierCoded" type="PriceMultiplierCodeType">
        <xsd:element minOccurs="0" name="PriceMultiplierCodedOther" type="xsd:string">
        <xsd:element name="Multiplier" type="xsd:decimal">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PriceType

PriceType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PricingType[PricingTypeType]? , UnitPrice[UnitPriceType] , ( UnitOfMeasurement[UnitOfMeasurementType]? | PriceBasisQuantity[QuantityType]? ) , CalculatedPriceBasisQuantity[QuantityType]? , ValidityDates[ValidityDatesType]? , PriceQuantityRange[QuantityType]? , PriceMultiplier[PriceMultiplierType]? )

    Description: PriceType contains a pricing scheme for an item.

    Elements:

    • PricingType - identifies the type of price. Price is always assumed to be a catalog price, so this should only be used if the price is not a catalog price.
    • UnitPrice - is a container element that holds the pricing information for a basic unit of an item.
    • UnitOfMeasurement - contains the unit of measurement that the unit price is based on. This is used if the PriceBasisQuantity is one. For example, if the unit price is $50/1 lb, then the UnitOfMeasurment would be specified as pounds.
    • PriceBasisQuantity - contains a quantity and unit of measurement that the unit price is based on. For example if a pricing scheme were $50/500 lbs, then 500 lbs would be contained in this element and 50 would be containd in the UnitPrice. If this is used, then UnitOfMeasurement element in the UnitPrice element must not be used.
    • CalculatedPriceBasisQuantity - is the price basis quantity, expressed in the unit of measure that the line item is ordered in. For example, if the price basis quantity is 100mL, and the item is ordered in 1L increments, the calculated price basis quantity would be 0.1L.
    • ValidityDates - specifies the start and end date for the pricing if a range dates applies to the pricing scheme.
    • PriceQuantityRange - contains a range of quantity over which the pricing information is applicable. This is commonly used for step pricing scenarios.
    • PriceMultiplier - contains a reason and value by which the unit price is multiplied by to arrive at the final price for an item. This can be used to apply a discount to a basic unit price.

[^]Code Fragment

    <xsd:complexType name="PriceType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="PricingType" type="PricingTypeType">
        <xsd:element name="UnitPrice" type="UnitPriceType">
        <xsd:choice>
            <xsd:element minOccurs="0" name="UnitOfMeasurement" type="UnitOfMeasurementType">
            <xsd:element minOccurs="0" name="PriceBasisQuantity" type="QuantityType">
        </xsd:choice>
        <xsd:element minOccurs="0" name="CalculatedPriceBasisQuantity" type="QuantityType">
        <xsd:element minOccurs="0" name="ValidityDates" type="ValidityDatesType">
        <xsd:element minOccurs="0" name="PriceQuantityRange" type="QuantityType">
        <xsd:element minOccurs="0" name="PriceMultiplier" type="PriceMultiplierType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: PriceTypeCodeType

PriceTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • CancellationPrice - Price authorized to be charged in the event of an order being cancelled.
    • PerTon - To indicate that the price applies per ton.
    • MinimumOrderPrice - A code to identify the price when the minimum number is purchased
    • ExportPrice - A code to identify a price for the export market.
    • RangeDependentPrice - A code identifying the price for a specific range of purchase quantities.
    • ActiveIngredient - The price is referring to the active ingredient.
    • AsIsQuantity - The price is referring to the measured quantity.
    • CalculationNet - The price stated is the net price including allowances/charges. Allowances/charges may be stated for information only.
    • CalculationGross - The price stated is the gross price to which allowances/ charges must be applied.
    • TaxIncludedAllowancesAndChargesNotIncluded - The price does not include the allowances and charges, but includes the taxes
    • Actual - Actual
    • AverageSellingPrice - Average selling price of a product.
    • InformationPriceTaxIncludedExcludingAllowancesOrCharges - The price stated is for information purposes only and excludes all allowances and charges. Taxes however are included in the price
    • InformationPriceExcludingAllowancesOrChargesAndTaxes - The price stated is for information purposes only and excludes all allowances, charges and taxes.
    • AdditiveUnitPriceComponent - A code to indicate that the price described is an additive component of the total price.
    • AverageGenericProductPrice - Average Generic Product Price
    • AlternatePrice - Alternate Price
    • AverageWholesalePrice - Average Wholesale Price
    • BaseCharge - Base Charge
    • ContractTier1 - Contract Tier 1
    • ContractTier2 - Contract Tier 2
    • ContractTier3 - Contract Tier 3
    • ContractTier4 - Contract Tier 4
    • ContractTier5 - Contract Tier 5
    • ContractTier6 - Contract Tier 6
    • ContractTier7 - Contract Tier 7
    • ContractTier8 - Contract Tier 8
    • ContractTier9 - Contract Tier 9
    • ContractTier10 - Contract Tier 10
    • ContractTier11 - Contract Tier 11
    • ContractTier12 - Contract Tier 12
    • ContractTier13 - Contract Tier 13
    • ContractTier14 - Contract Tier 14
    • ContractTier15 - Contract Tier 15
    • ContractTier16 - Contract Tier 16
    • ContractTier17 - Contract Tier 17
    • ContractTier18 - Contract Tier 18
    • ContractTier19 - Contract Tier 19
    • ContractTier20 - Contract Tier 20
    • ContractTier21 - Contract Tier 21
    • ContractTier22 - Contract Tier 22
    • ContractTier23 - Contract Tier 23
    • ContractTier24 - Contract Tier 24
    • ContractTier25 - Contract Tier 25
    • ContractTier26 - Contract Tier 26
    • ContractTier27 - Contract Tier 27
    • ContractTier28 - Contract Tier 28
    • ContractTier29 - Contract Tier 29
    • ContractTier30 - Contract Tier 30
    • CalculationPrice - Calculation Price
    • CatalogPrice - The price stated is the price for the calculation of the line item amount.
    • CentralDistributionFacility - Central Distribution Facility (Warehouse)
    • CurrentDomesticValue - Current Domestic Value
    • ChangedPrice - Changed Price
    • ContractPrice - Contract Price
    • ConsumerUnit - The price is referring to the consumer unit.
    • ConfirmedUnitPrice - Confirmed Unit Price
    • DeclaredCustomsUnitValue - Declared Customs Unit Value
    • DealerAdjustedPrice - Dealer Adjusted Price
    • DistributorsPrice - Distributor's Price
    • DiscountPrice - Discount Price
    • DiscountAmountAllowed - Discount Amount Allowed
    • DirectStoreDelivery - Direct Store Delivery
    • DirectShipProgramPrice - Direct Ship Program Price
    • EcscPrice - Price registered at European Commission Steel and Carbon office (DG III).
    • EmergencyDirectShipPriceOriginalEquipmentManufacturer - Emergency Direct Ship Price (Original Equipment Manufacturer)
    • EmergencyDirectShipPrice - Emergency Direct Ship Price
    • EmergencyDirectShipPriceSupplier - Emergency Direct Ship Price (Supplier)
    • EmergencyDirectShipPriceWarehouse - Emergency Direct Ship Price (Warehouse)
    • EstimatedPrice - Estimated Price
    • ExpectedUnitPrice - Expected Unit Price
    • FlatCharge - Flat Charge
    • FrequentDeliveryService - Frequent Delivery Service
    • FederalExciseTax - Federal Excise Tax
    • FreeGoodsPrice - Free Goods Price
    • FederalUpperLimitPriceMaximumAllowableCostPricingForDrugs - Federal Upper Limit Price (Maximum Allowable Cost Pricing for Drugs)
    • FirmPriceDoNotAdvise - Firm Price - Do Not Advise
    • GovernmentPrice - Government Price
    • UnitPriceThroughQuantity - Unit Price Through Quantity
    • IndustrialPrice - Industrial Price
    • InformationPrice - The price is provided for information.
    • InstitutionalPrice - Institutional Price
    • InvoiceBillingPrice - Referenced price taken from an invoice.
    • ListPrice - List Price
    • MandatoryToAdviseUnitPrice - Mandatory To Advise Unit Price
    • MinimumActivitySurcharge - Minimum Activity Surcharge
    • MaximumOrderQuantityPrice - Maximum Order Quantity Price
    • MinimumOrderQuantityPrice - Minimum Order Quantity Price
    • MinimumCharge - Minimum Charge
    • MinimumReleaseQuantityPrice - Minimum Release Quantity Price
    • MaximumPriceReduction - Maximum Price Reduction
    • ManufacturersSuggestedRetail - Manufacturer's Suggested Retail
    • MaximumReleaseQuantityPrice - Maximum Release Quantity Price
    • NoncontractTier1 - Noncontract Tier 1
    • NoncontractTier2 - Noncontract Tier 2
    • NoncontractTier3 - Noncontract Tier 3
    • NoncontractTier4 - Noncontract Tier 4
    • NoncontractTier5 - Noncontract Tier 5
    • NoncontractTier6 - Noncontract Tier 6
    • NoncontractTier7 - Noncontract Tier 7
    • NoncontractTier8 - Noncontract Tier 8
    • NoncontractTier9 - Noncontract Tier 9
    • NoncontractTier10 - Noncontract Tier 10
    • NoncontractTier11 - Noncontract Tier 11
    • NoncontractTier12 - Noncontract Tier 12
    • NoncontractTier13 - Noncontract Tier 13
    • NoncontractTier14 - Noncontract Tier 14
    • NoncontractTier15 - Noncontract Tier 15
    • NoncontractTier16 - Noncontract Tier 16
    • NoncontractTier17 - Noncontract Tier 17
    • NoncontractTier18 - Noncontract Tier 18
    • NoncontractTier19 - Noncontract Tier 19
    • NoncontractTier20 - Noncontract Tier 20
    • NoncontractTier21 - Noncontract Tier 21
    • NoncontractTier22 - Noncontract Tier 22
    • NoncontractTier23 - Noncontract Tier 23
    • NoncontractTier24 - Noncontract Tier 24
    • NoncontractTier25 - Noncontract Tier 25
    • NoncontractTier26 - Noncontract Tier 26
    • NoncontractTier27 - Noncontract Tier 27
    • NoncontractTier28 - Noncontract Tier 28
    • NoncontractTier29 - Noncontract Tier 29
    • NoncontractTier30 - Noncontract Tier 30
    • NetItemPrice - Net Item Price
    • NetWeight - Net Weight
    • OptionalToAdviseUnitPrice - Optional To Advise Unit Price
    • OriginalPurchaseOrderPrice - Original Purchase Order Price
    • PriceBreakQuantity - Price Break Quantity
    • UnitPriceBeginningQuantity - Unit Price Beginning Quantity
    • PriceBreakPurchaseOrderCount - Price Break Purchase Order Count
    • PriceCatalogue - Price Catalogue
    • PerEach - Per Each
    • PriceInEffectAtTimeOfShipment - Price In Effect At Time Of Shipment
    • PerKilogram - Per Kilogram
    • PerLiter - Per Liter
    • PrepaidFreightCharges - Prepaid Freight Charges
    • ProfessionalPrice - Professional Price
    • ProducersPrice - Producer's Price
    • PromotionalPrice - Promotional Price
    • PerTonne - Per Tonne
    • SpecifiedUnit - Specified Unit
    • ProvisionalPrice - Provisional Price
    • GrossWeight - Gross Weight
    • Purchase - Purchase
    • QuotePrice - Quote Price
    • Resale - Resale
    • Retail - Retail
    • SuggestedDealerNetPrice - Suggested Dealer Net Price
    • SuggestedFleetPrice - Suggested Fleet Price
    • ShipAndDebit - Ship And Debit
    • SuggestedListPrice - Suggested List Price
    • SpecialPrice - Special Price
    • SinglePriceFactorsEqualized - Single Price (Factors Equalized)
    • SuggestedRetail - Suggested Retail
    • StandardPrice - Standard Price
    • SumOfLineItems - Sum Of Line Items
    • SuggestedWholesalePrice - Suggested Wholesale Price
    • ToBeNegotiated - To Be Negotiated
    • ThresholdPrice - Threshold Price
    • TotalInvoiceAmountDue - Total Invoice Amount Due
    • Transfer - Transfer
    • TradedUnit - The price is referring to the traded unit.
    • TheoreticalWeight - Weight calculated on ordered dimension (length, width,thickness) not on final dimension (e.g. steel products).
    • UnitCostPrice - Unit Cost Price
    • Wholesale - Wholesale
    • ZonePrice - Zone Price

[^]Code Fragment

    <xsd:simpleType name="PriceTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="CancellationPrice">
        <xsd:enumeration value="PerTon">
        <xsd:enumeration value="MinimumOrderPrice">
        <xsd:enumeration value="ExportPrice">
        <xsd:enumeration value="RangeDependentPrice">
        <xsd:enumeration value="ActiveIngredient">
        <xsd:enumeration value="AsIsQuantity">
        <xsd:enumeration value="CalculationNet">
        <xsd:enumeration value="CalculationGross">
        <xsd:enumeration value="TaxIncludedAllowancesAndChargesNotIncluded">
        <xsd:enumeration value="Actual">
        <xsd:enumeration value="AverageSellingPrice">
        <xsd:enumeration value="InformationPriceTaxIncludedExcludingAllowancesOrCharges">
        <xsd:enumeration value="InformationPriceExcludingAllowancesOrChargesAndTaxes">
        <xsd:enumeration value="AdditiveUnitPriceComponent">
        <xsd:enumeration value="AverageGenericProductPrice">
        <xsd:enumeration value="AlternatePrice">
        <xsd:enumeration value="AverageWholesalePrice">
        <xsd:enumeration value="BaseCharge">
        <xsd:enumeration value="ContractTier1">
        <xsd:enumeration value="ContractTier2">
        <xsd:enumeration value="ContractTier3">
        <xsd:enumeration value="ContractTier4">
        <xsd:enumeration value="ContractTier5">
        <xsd:enumeration value="ContractTier6">
        <xsd:enumeration value="ContractTier7">
        <xsd:enumeration value="ContractTier8">
        <xsd:enumeration value="ContractTier9">
        <xsd:enumeration value="ContractTier10">
        <xsd:enumeration value="ContractTier11">
        <xsd:enumeration value="ContractTier12">
        <xsd:enumeration value="ContractTier13">
        <xsd:enumeration value="ContractTier14">
        <xsd:enumeration value="ContractTier15">
        <xsd:enumeration value="ContractTier16">
        <xsd:enumeration value="ContractTier17">
        <xsd:enumeration value="ContractTier18">
        <xsd:enumeration value="ContractTier19">
        <xsd:enumeration value="ContractTier20">
        <xsd:enumeration value="ContractTier21">
        <xsd:enumeration value="ContractTier22">
        <xsd:enumeration value="ContractTier23">
        <xsd:enumeration value="ContractTier24">
        <xsd:enumeration value="ContractTier25">
        <xsd:enumeration value="ContractTier26">
        <xsd:enumeration value="ContractTier27">
        <xsd:enumeration value="ContractTier28">
        <xsd:enumeration value="ContractTier29">
        <xsd:enumeration value="ContractTier30">
        <xsd:enumeration value="CalculationPrice">
        <xsd:enumeration value="CatalogPrice">
        <xsd:enumeration value="CentralDistributionFacility">
        <xsd:enumeration value="CurrentDomesticValue">
        <xsd:enumeration value="ChangedPrice">
        <xsd:enumeration value="ContractPrice">
        <xsd:enumeration value="ConsumerUnit">
        <xsd:enumeration value="ConfirmedUnitPrice">
        <xsd:enumeration value="DeclaredCustomsUnitValue">
        <xsd:enumeration value="DealerAdjustedPrice">
        <xsd:enumeration value="DistributorsPrice">
        <xsd:enumeration value="DiscountPrice">
        <xsd:enumeration value="DiscountAmountAllowed">
        <xsd:enumeration value="DirectStoreDelivery">
        <xsd:enumeration value="DirectShipProgramPrice">
        <xsd:enumeration value="EcscPrice">
        <xsd:enumeration value="EmergencyDirectShipPriceOriginalEquipmentManufacturer">
        <xsd:enumeration value="EmergencyDirectShipPrice">
        <xsd:enumeration value="EmergencyDirectShipPriceSupplier">
        <xsd:enumeration value="EmergencyDirectShipPriceWarehouse">
        <xsd:enumeration value="EstimatedPrice">
        <xsd:enumeration value="ExpectedUnitPrice">
        <xsd:enumeration value="FlatCharge">
        <xsd:enumeration value="FrequentDeliveryService">
        <xsd:enumeration value="FederalExciseTax">
        <xsd:enumeration value="FreeGoodsPrice">
        <xsd:enumeration value="FederalUpperLimitPriceMaximumAllowableCostPricingForDrugs">
        <xsd:enumeration value="FirmPriceDoNotAdvise">
        <xsd:enumeration value="GovernmentPrice">
        <xsd:enumeration value="UnitPriceThroughQuantity">
        <xsd:enumeration value="IndustrialPrice">
        <xsd:enumeration value="InformationPrice">
        <xsd:enumeration value="InstitutionalPrice">
        <xsd:enumeration value="InvoiceBillingPrice">
        <xsd:enumeration value="ListPrice">
        <xsd:enumeration value="MandatoryToAdviseUnitPrice">
        <xsd:enumeration value="MinimumActivitySurcharge">
        <xsd:enumeration value="MaximumOrderQuantityPrice">
        <xsd:enumeration value="MinimumOrderQuantityPrice">
        <xsd:enumeration value="MinimumCharge">
        <xsd:enumeration value="MinimumReleaseQuantityPrice">
        <xsd:enumeration value="MaximumPriceReduction">
        <xsd:enumeration value="ManufacturersSuggestedRetail">
        <xsd:enumeration value="MaximumReleaseQuantityPrice">
        <xsd:enumeration value="NoncontractTier1">
        <xsd:enumeration value="NoncontractTier2">
        <xsd:enumeration value="NoncontractTier3">
        <xsd:enumeration value="NoncontractTier4">
        <xsd:enumeration value="NoncontractTier5">
        <xsd:enumeration value="NoncontractTier6">
        <xsd:enumeration value="NoncontractTier7">
        <xsd:enumeration value="NoncontractTier8">
        <xsd:enumeration value="NoncontractTier9">
        <xsd:enumeration value="NoncontractTier10">
        <xsd:enumeration value="NoncontractTier11">
        <xsd:enumeration value="NoncontractTier12">
        <xsd:enumeration value="NoncontractTier13">
        <xsd:enumeration value="NoncontractTier14">
        <xsd:enumeration value="NoncontractTier15">
        <xsd:enumeration value="NoncontractTier16">
        <xsd:enumeration value="NoncontractTier17">
        <xsd:enumeration value="NoncontractTier18">
        <xsd:enumeration value="NoncontractTier19">
        <xsd:enumeration value="NoncontractTier20">
        <xsd:enumeration value="NoncontractTier21">
        <xsd:enumeration value="NoncontractTier22">
        <xsd:enumeration value="NoncontractTier23">
        <xsd:enumeration value="NoncontractTier24">
        <xsd:enumeration value="NoncontractTier25">
        <xsd:enumeration value="NoncontractTier26">
        <xsd:enumeration value="NoncontractTier27">
        <xsd:enumeration value="NoncontractTier28">
        <xsd:enumeration value="NoncontractTier29">
        <xsd:enumeration value="NoncontractTier30">
        <xsd:enumeration value="NetItemPrice">
        <xsd:enumeration value="NetWeight">
        <xsd:enumeration value="OptionalToAdviseUnitPrice">
        <xsd:enumeration value="OriginalPurchaseOrderPrice">
        <xsd:enumeration value="PriceBreakQuantity">
        <xsd:enumeration value="UnitPriceBeginningQuantity">
        <xsd:enumeration value="PriceBreakPurchaseOrderCount">
        <xsd:enumeration value="PriceCatalogue">
        <xsd:enumeration value="PerEach">
        <xsd:enumeration value="PriceInEffectAtTimeOfShipment">
        <xsd:enumeration value="PerKilogram">
        <xsd:enumeration value="PerLiter">
        <xsd:enumeration value="PrepaidFreightCharges">
        <xsd:enumeration value="ProfessionalPrice">
        <xsd:enumeration value="ProducersPrice">
        <xsd:enumeration value="PromotionalPrice">
        <xsd:enumeration value="PerTonne">
        <xsd:enumeration value="SpecifiedUnit">
        <xsd:enumeration value="ProvisionalPrice">
        <xsd:enumeration value="GrossWeight">
        <xsd:enumeration value="Purchase">
        <xsd:enumeration value="QuotePrice">
        <xsd:enumeration value="Resale">
        <xsd:enumeration value="Retail">
        <xsd:enumeration value="SuggestedDealerNetPrice">
        <xsd:enumeration value="SuggestedFleetPrice">
        <xsd:enumeration value="ShipAndDebit">
        <xsd:enumeration value="SuggestedListPrice">
        <xsd:enumeration value="SpecialPrice">
        <xsd:enumeration value="SinglePriceFactorsEqualized">
        <xsd:enumeration value="SuggestedRetail">
        <xsd:enumeration value="StandardPrice">
        <xsd:enumeration value="SumOfLineItems">
        <xsd:enumeration value="SuggestedWholesalePrice">
        <xsd:enumeration value="ToBeNegotiated">
        <xsd:enumeration value="ThresholdPrice">
        <xsd:enumeration value="TotalInvoiceAmountDue">
        <xsd:enumeration value="Transfer">
        <xsd:enumeration value="TradedUnit">
        <xsd:enumeration value="TheoreticalWeight">
        <xsd:enumeration value="UnitCostPrice">
        <xsd:enumeration value="Wholesale">
        <xsd:enumeration value="ZonePrice">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: PricingDetailType

PricingDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ListOfPrice[ListOfPriceType] , Tax[TaxType]* , TotalTaxAmount[MonetaryValueType]? , ItemAllowancesOrCharges[ListOfAllowOrChargeType]? , LineItemSubTotal[MonetaryValueType]? , LineItemTotal[MonetaryValueType]? )

    Description: PricingDetailType contains all pricing information, including taxes, allowances and charges, and total price for an item.

    Elements:

    • ListOfPrice - contains one or more pricing schemes for an item.
    • Tax - contains tax information as it relates to the pricing of an item.
    • TotalTaxAmount - holds the sum of all types of taxes for the line item.
    • ItemAllowancesOrCharges - contains the allowances and/or charges that apply to the pricing of an item.
    • LineItemSubTotal - is the sub total of the line item. This should be equal to the unit price times the quantity ordered.
    • LineItemTotal - is the total of the item, including all taxes, allowances, and charges.

[^]Code Fragment

    <xsd:complexType name="PricingDetailType">
    <xsd:sequence>
        <xsd:element name="ListOfPrice" type="ListOfPriceType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="Tax" type="TaxType">
        <xsd:element minOccurs="0" name="TotalTaxAmount" type="MonetaryValueType">
        <xsd:element minOccurs="0" name="ItemAllowancesOrCharges" type="ListOfAllowOrChargeType">
        <xsd:element minOccurs="0" name="LineItemSubTotal" type="MonetaryValueType">
        <xsd:element minOccurs="0" name="LineItemTotal" type="MonetaryValueType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PricingTypeType

PricingTypeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PriceTypeCoded[PriceTypeCodeType] , PriceTypeCodedOther[xsd:string]? )

    Description: PricingTypeType contains all prices associated with a particular product from a particular price catalog.

    Elements:

    • PriceTypeCoded - specifies the price type.
    • PriceTypeCodedOther - is used to provide a non-standard PriceTypeCode. This element is mandatory if the value of PriceTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="PricingTypeType">
    <xsd:sequence>
        <xsd:element name="PriceTypeCoded" type="PriceTypeCodeType">
        <xsd:element minOccurs="0" name="PriceTypeCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ProductIdentifierCodedType

ProductIdentifierCodedType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ProductIdentifierQualifierCoded[ProductIdentifierQualifierCodeType] , ProductIdentifierQualifierCodedOther[xsd:string]? , ProductIdentifier[xsd:string] , ProductIdentifierExt[xsd:string]? )

    Description: ProductIdentifierCodedType is an identification of a product or service where the source or function of the identification is not explicitly stated by another element.

    Elements:

    • ProductIdentifierQualifierCoded - qualifies a product or service identification using a standard codelist.
    • ProductIdentifierQualifierCodedOther - is used to provide a non-standard ProductIdentifierQualifierCode. This element is mandatory if the value of ProductIdentifierQualifierCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • ProductIdentifier - contains a basic identification for a product or service in text format.
    • ProductIdentifierExt - contains an extension to the basic identification for a product or service. This can be used to supply a color code for a specific product.

[^]Code Fragment

    <xsd:complexType name="ProductIdentifierCodedType">
    <xsd:sequence>
        <xsd:element name="ProductIdentifierQualifierCoded" type="ProductIdentifierQualifierCodeType">
        <xsd:element minOccurs="0" name="ProductIdentifierQualifierCodedOther" type="xsd:string">
        <xsd:element name="ProductIdentifier" type="xsd:string">
        <xsd:element minOccurs="0" name="ProductIdentifierExt" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: ProductIdentifierQualifierCodeType

ProductIdentifierQualifierCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code shows the qualifier used to identify the product.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom code
    • AdditionalProductIdentificationAssignedByTheManufacturer - Additional product identification assigned by the manufacturer
    • AdvertisingPackageIdentificationCode - Advertising package identification code
    • Age - Age
    • AggregationCode - Aggregation code (Used to consolidate part families)
    • AirTransportationAssociationProprietaryRightsCode - Air transportation association proprietary rights code
    • AllocationMethodologyIdentificationCode - Allocation methodology identification code
    • AlternateISBN - Alternate ISBN
    • AmericanDentalAssociationCodes - American dental association codes
    • AmericanTruckingAssociationsAssembly - American trucking associations assembly
    • AmericanTruckingAssociationsPart - American trucking associations part
    • AmericanTruckingAssociationsSystem - American trucking associations sSystem
    • Anniversary - Anniversary
    • ApplicationCompletionMethod - Application completion method
    • ApplicationState - Application state
    • AppraisalProductType - Appraisal product type
    • AppraisalService - Appraisal service
    • ARNICPartNumber - ARINC part number
    • Assembly - Assembly
    • AssemblyLotNumber - Assembly lot number
    • AssetCategory - Asset category
    • AssetNumber - Asset number
    • AssetType - Asset type
    • AssortabilityCode - Assortability code
    • AuthorCode - Author code
    • AuthorizedPartsListNumber - Authorized parts list number
    • AutomaticTransmissionSerialNumber - Automatic transmission serial number
    • AuxiliaryTransmissionSerialNumber - Auxiliary transmission serial number
    • AuxillaryTransmission - Transmission, auxiliary
    • AxleRatio - Axle ratio
    • AxleSerialNumber - Axle serial number
    • Backing - Backing
    • BaleNumber - Bale number
    • Bar-CodedSerialNumber - Bar-coded serial number
    • BatchNumber - Batch number
    • BeamNumber - Beam number
    • BenefitID - Benefit ID
    • BeverageCommonCode - Beverage common code
    • BillboardsCommercial - Billboards commercial
    • BillCreditCode - Bill credit code
    • BillSubgroupCode - Bill subgroup code
    • BindingCode - Binding code
    • BrandOrLabel - Brand/Label
    • BrokerPriceOpinionService - Broker price opinion service
    • BusBodySerialNumber - Bus body serial number
    • BuyerGroundShadeIdentifier - Buyer ground shade identifier
    • BuyersCatalogNumber - Buyer's catalog number
    • BuyersColor - Buyers color
    • BuyersEndProductNumber - Buyer's end product number
    • BuyersEngineeringChangeLevelNumber - Buyer's engineering change level number
    • BuyersInternalProductGroupCode - Product group code used within a buyer's internal systems.
    • BuyersItemNumber - Buyer's item number
    • BuyersPartNumber - Buyer's part number
    • BuyersQualifierForSize
    • BuyersSizeCode - Buyer's size code
    • BuyersStyleNumber - Buyer's style number
    • BuyersSublineItemNumber - Buyer's subline item number
    • CAGECode - Commercial and Government Entity (CAGE) code
    • CandidateOil - Candidate oil
    • Carry-OverPartNumber - Carry-over part number
    • Case - Case
    • CatalogNumber - Catalog number
    • Channel - Channel
    • ChassisSerialNumber - Chassis serial number
    • ChemicalAbstractServiceRegistryNumber - Chemical Abstract Service (CAS) registry number
    • Classification - Classification
    • ClassOfContractCode - Class of contract code
    • CLEICode - Old Common Language Equipment Identifier (CLEI) code
    • CognizanceSymbol - Cognizance symbol
    • ColdRollNumber - Number assigned to a cold roll.
    • Color - Color
    • CombinedNCCMAOrBankServiceCode - Combined NCCMA/Bank service code
    • CommissionIdentifier - Commission identifier
    • CommissionYear - Commission year
    • CommitteeForUniformSecurityIdentificationProcedureNumber - Committee for Uniform Security Identification Procedure (CUSIP)
    • CommodityGrouping - Code for a group of articles with common characteristics (e.g. used for statistical purposes).
    • CommodityName - Commodity name
    • CommonLanguageEquipmentIdentifier - Common Language Equipment Identifier (CLEI)
    • Company-OwnedUnitTrainNumber - Company-owned unit train number
    • CompanyPartNumber - Company part number
    • CompatibleCutNumber - Compatible cut number
    • CompensationAllocationCode - Compensation allocation code
    • CompensationTypeCode - Compensation type code
    • CompletionNumber - Completion number
    • ConceptCode - Concept code
    • ConfigurationItemIdentifier - Configuration item identifier
    • ConnectorType - Connector type
    • Continuation - Continuation (ID number spans multiple product ID data elements)
    • ContractActivityCode - Contract activity code
    • ContractBreakdown - To specify as an item, the contract breakdown.
    • ContractChangeAuthorizationType - Contract change authorization type
    • ContractNumber - Contract number
    • ContractorEstablishmentCode - Contractor establishment code
    • ContractTransferReasonCode - Contract transfer reason code
    • ContributionYear - Contribution year
    • ControlNumber - To specify the control number.
    • CountryFromWhichProcured - Country from which procured
    • CountryOfOriginCode - Country of origin code
    • CouponFamilyCode - Coupon family code
    • CouponNumber - A number identifying a coupon.
    • CoverageRiskType - Coverage risk type
    • CoverageType - Coverage type
    • CurrentProceduralTerminologyCodes - Current Procedural Terminology (CPT) codes
    • CustomerCompanyRegistryNumber - Customer company registry number
    • CustomerOrderNumber - Customer order number
    • CustomerProvidedEquipment - Customer provided equipment
    • CustomsArticleNumber - Code defined by Customs authorities to an article or a group of articles for Customs purposes.
    • CutNumber - Cut number
    • DataCategory - A code specifying a category of data.
    • DepartmentOfDefenseIdentificationCode - Department of Defense Identification Code (DoDIC)
    • DepositItemNumber - Deposit item number
    • DesignNumber - Design number
    • DeviceFamily - Device family
    • DeviceType - Device type
    • DiagnosisCodePointer - Diagnosis code pointer
    • DieNumber - Die number
    • DiscontinuedPartNumber - Discontinued part number
    • DiscountGrouping - Discount grouping
    • Distributor - Distributor
    • DividendUse - Dividend use
    • DocumentIdentificationCode - Document identification code
    • Drawing - Reference number identifying a drawing of an article.
    • DrawingRevisionNumber - Reference number indicating that a change or revision has been applied to a drawing.
    • DrugUPCConsumerPackageCode1-4-6-1 - Drug U.P.C. consumer package code (1-4-6-1)
    • DrugUPCShippingContainerCode1-2-4-6-1 - Drug U.P.C. shipping container code (1-2-4-6-1)
    • DunAndBradstreetStandardProductAndServiceCode - Dun And Bradstreet standard product and service code
    • DyeLotNumber - Dye lot number
    • EAN2-5-5-1 - European Article Number (EAN) (2-5-5-1)
    • EAN-99In-StoreCouponCode - EAN-99 In-store coupon code
    • EditionCode - Edition code
    • EndItemNumber - A number specifying an end item.
    • End-ItemDescription - End-Item description
    • EngineDisplacementIdentification - Engine displacement identification
    • EngineeringChangeLevel - Engineering change level
    • EngineeringDataList - A code specifying the product's engineering data list.
    • EngineSerialNumber - Engine serial number
    • EquipmentCodePerCOPASStandard - Equipment code per COPAS standard
    • EquipmentHierarchicalSequenceIdentifier - Equipment hierarchical sequence identifier
    • EquipmentIdentificationNumber - Equipment identification number
    • EquipmentLocation - Equipment location
    • EquipmentType - Equipment type
    • EventType - Event type
    • ExchangedPartOrAssemblyOrProduct - Exchanged part, assembly or product
    • Exhibit - A code indicating that the product is identified by an exhibit number.
    • ExhibitIdentifier - Exhibit identifier
    • ExhibitLineItemNumber - Exhibit line item number
    • ExpendableContainerIdentification - Expendable container identification
    • ExpenseIdentifier - Expense identifier
    • FAAServiceBulletinNumber - Federal Aviation Administration (FAA) service bulletin number
    • FabricPiecesPerRoll - Fabric pieces per roll
    • FailedSubassemblyModelNumber - Failed subassembly model number
    • FailedSubassemblySerialNumber - Failed subassembly serial number
    • FannieMaeAffordableLendingProductCode - Fannie Mae affordable lending product code
    • FannieMaeProjectCondominiumClassificationCode - Fannie Mae project condominium classification code
    • Feature - Feature
    • FederalSupplyClassification - A code to specify a product's Federal supply classification.
    • FifthWheelSerialNumber - Fifth wheel serial number
    • FinalTestLotNumber - Final test lot number
    • FinancialPhase - To specify as an item, the financial phase.
    • FinishLotNumber - Finish lot number
    • FinishNumber - Finish number
    • FinishOrHandStandardReference - Finish/Hand standard Reference
    • FirePump - Pump, Fire
    • FirstPriorIdentifier - First prior identifier
    • FormerPublisher - Former publisher
    • FormNumber - Form number
    • FreddieMacAffordableLendingProductCode - Freddie Mac affordable lending product code
    • FreddieMacProjectCondominiumClassificationCode - Freddie Mac project condominium classification code
    • FrontAxle-Rear - Front axle, rear
    • FrontAxleDrivenSerialNumber - Front axle driven serial number
    • FrontAxleNonDrivenSerialNumber - Front axle non driven serial number
    • FrontAxleSerialNumber - Front axle serial number
    • FuelTankSerialNumber - Fuel tank serial number
    • Fund - Fund
    • FundAbbreviation - Fund abbreviation
    • FundManager - Fund manager
    • FundSub-Advisor - Fund sub-advisor
    • FundType - Fund type
    • GASFLOWInvoicePostingCode - GAS*FLOW invoice posting code
    • GASFLOWProductorServiceChargeCode - GAS*FLOW product or service charge code
    • Gathering - Gathering
    • GearRatio - Gear ratio
    • GeneralSpecificationNumber - General specification number
    • GenericNameDescription - Generic name description
    • GliderKit - Glider kit
    • GradeCode - Grade code
    • GradeName - Grade name
    • GrainDirection - Grain direction
    • GraphicsIndustryBarCode - Graphics Industry Bar Code (GIBC)
    • GroundShadeStandardReference - Ground shade standard reference
    • GroupID - Group ID
    • GroupQualifierCode - Group qualifier code
    • GTIN - Global Trade Identification Number
    • HarmonisedSystem
    • HCPCS - Health Care Financing Administration Common Procedural Coding System (HCPCS) codes
    • HeatNumber - Number assigned to the heat (also known as the iron charge) for the production of steel products.
    • HIBC-HealthIndustryBarCode - Article identifier used within health sector to indicate data used conforms to HIBC.
    • HIBCSupplierLabelingStandardPrimaryDataMessage - HIBC (Health Care Industry Bar Code) supplier labeling standard primary data message
    • HIECProductOrServiceCode - Home Infusion EDI Coalition (HIEC) Product/Service Code
    • HotRollNumber - Number assigned to a hot roll.
    • ICD-9-CM-Procedure - International Classification of Diseases Clinical Modification (ICD-9-CM) - procedure
    • IgnitionKeyNumber - Ignition key number
    • Imprint-TrademarkCodeOfSubsidiary - Imprint (Trademark code of subsidiary)
    • IndustryCommodityCode - The codes given to certain commodities by an industry.
    • InformationMediaType - Information Media type
    • Ingredient - Ingredient
    • InsurancePlanDescriptionCharacteristics - Insurance plan description characteristics
    • InsurersFundCode - Insurer's fund code
    • InterchangeabilityCode - Interchangeability code
    • InteriorColorNumber - Interior color number
    • InternalNumber - Internal number
    • InternationalArticleNumberingAssociation - Number assigned to a manufacturer's product according to the International Article Numbering Association.
    • ICD-9-CM-Diagnosis - International Classification of Diseases Clinical Modification (ICD-9-CM) - diagnosis
    • InternationalHarmonizedCommodityCode - International harmonized commodity code
    • InternationalStandardBookNumber - International Standard Book Number (ISBN)
    • InvestmentFundType - Investment fund type
    • IRSQualificationCode - IRS qualification code
    • ISBN
    • ISSN - International Standard Serial Number (ISSN)
    • ItemManagementCode - Item management code
    • ItemTypeNumber - Item type number
    • JobNumber - Job number
    • JobSequenceNumber - Job sequence number
    • JointLifeType - Joint life type
    • JurisdictionSpecificProcedureAndSupplyCodes - Jurisdiction specific procedure and supply codes
    • KanbanPlanNumber - Kanban plan number
    • LaboratorySampleIdentification - Laboratory sample identification
    • LaboratoryTestConditionCode - Laboratory test condition code
    • LaborGroup - Labor group
    • LeaseNumber - Lease number
    • LibraryOfCongressCode - Library of congress code
    • LifeOrAnnuityProductCode - Life/Annuity product code
    • LifeOrAnnuityServiceFeatures - Life/Annuity service features
    • LiftGateSerialNumber - Lift gate serial number
    • LineOfAuthority - Line of authority
    • LineOfBusiness - Line of business
    • LoadSequence - Load sequence
    • LocallyAssignedControlNumber - Locally assigned control number
    • LocalStockNumber - A local number assigned to an item of stock.
    • LocationCode - Location code
    • LOINCCodes - Logical Observation Identifier Names and Codes (LOINC) codes
    • LotNumber - Lot number
    • LotPricingUnitNumber - Lot pricing unit number
    • MachineNumber - Machine number
    • MaintenanceIndexPageReferenceNumber - Maintenance index page reference number
    • MajorProductOrMaterialOrMachineType - Major product/material/machine type
    • ManualTransmissionSerialNumber - Manual transmission serial number
    • Manufacturer - Manufacturer
    • ManufacturersArticleNumber - The number given to an article by its manufacturer.
    • ManufacturersPartNumber - Manufacturer's part number
    • MarketProgramCode - Market program code
    • MaterialCode - Code defining the material's type, surface, geometric form plus various classifying characteristics.
    • MaterialControlCode - Material control code
    • MaterialDischargeNumber - Material discharge number
    • MeasurementTypeCode - Measurement type code
    • MedicalInformationBureauAuthorization - Medical Information Bureau (MIB) authorization
    • MedicalStopLossCoverageCodes - Medical stop loss coverage codes
    • MedicalStopLossLevelCodes - Medical stop loss level codes
    • MedicalStopLossProductLineCodes - Medical stop loss product line codes
    • MedicationCode - Medication code
    • MEMAProductTypeCode - Motor Equipment Manufacturing Association (MEMA) product type code
    • MethodOfDeliveryCode - Method of delivery code
    • MilestoneEventNumber - A number to identify a milestone event.
    • MilitaryStandard - Military standard
    • MILSPECNumber - Military Specification (MILSPEC) number
    • ModelNumber - Model number
    • MortgageCreditDataOrderType - Mortgage credit data order type
    • MortgageInsuranceProductCodeOrNumber - Mortgage insurance product code or number
    • MortgageProductCode - Mortgage product code
    • MortgageUnderwritingType - Mortgage underwriting type
    • MotorVehicleIdNumber - Motor vehicle id number
    • MotorVehicle-LineDesignator - Motor vehicle-line designator
    • MovementTypeCode - Movement type code
    • NationalDrugCode - A code specifying the national drug classification.
    • NationalDrugCode4-4-2Format - A code identifying the product in national drug format 4- 4-2.
    • NationalDrugCode5-3-2Format - A code identifying the product in national drug format 5- 3-2.
    • NationalDrugCode5-4-1Format - A code identifying the product in national drug format 5- 4-1.
    • NationalDrugCode5-4-2Format - A code identifying the product in national drug format 5- 4-2.
    • NationalHealthRelatedItemCode - National health related item code
    • NationalHealthRelatedItemCodeIn4-6Format - National health related item code in 4-6 format
    • NationalHealthRelatedItemCodeIn5-5Format - National health related item code in 5-5 format
    • NationalProductGroupCode - National product group code. Administered by a national agency.
    • NationalRetailFederationColorCode - National retail federation color code
    • NationalRetailFederationSizeCode - National retail federation size code
    • NationalStockNumber - National stock number
    • NDC - National Drug Code (NDC)
    • NewMicrocode - New microcode
    • NewReplacementPartOrAssemblyDefective - New replacement part or assembly defective
    • NextHigherAssemblyNumber - A number specifying the next higher assembly or component into which the product is being incorporated.
    • NextHigherUsedAssembly - Next higher used assembly
    • NonforfeitureOption - Nonforfeiture option
    • Non-ResaleableItemExcludingDepositNumber - Non-resaleable item (excluding deposit) number
    • NSN-NorthAtlanticTreatyOrganizationStockNumber - Number assigned under the NATO (North Atlantic Treaty Organization) codification system to provide the identification of an approved item of supply.
    • NUBCUB82Codes - National Uniform Billing Committee (NUBC) UB82 codes
    • NUBCUB92Codes - National Uniform Billing Committee (NUBC) UB92 codes
    • NumberOfPositionsOnMachine - Number of Positions on Machine
    • ObligationAuthorityNumber - Obligation authority number
    • ObsoletePartNumber - Obsolete part number
    • OfferNumber - Offer number
    • OldMicrocode - Old microcode
    • OldUPCOrEANCaseCode - Old U.P.C./EAN case code
    • OldUPCOrEANConsumerPackageCode - Old U.P.C./EAN consumer package code
    • OldUPCOrEANModuleCode - Old U.P.C./EAN module code
    • OldUPCOrEANMultipackCode - Old U.P.C./EAN multipack code
    • OperatorAssignedPropertyIdentification - Operator assigned property identification
    • Opposite-HandPartNumber - Opposite-hand part number
    • OpticalCableCode - Optical cable code
    • OpticalIndustryProductCode - Optical industry product code
    • OriginalEquipmentNumber - Original equipment number
    • OutsideProductionOperationSheetNumber - Outside production operation sheet number
    • PackageTypeCode - Package type code
    • PackagingDrawing - Packaging drawing
    • PackagingSpecificationNumber - Packaging specification number
    • PackNumber - Number assigned to a pack containing a stack of items put together (e.g. cold roll sheets (steel product)).
    • PartDrawing - Part drawing
    • PartNumber - A number indicating the part.
    • PartNumberDescription - Part number description
    • PartReferenceNumber - Part reference number
    • PatternNumber - Pattern number
    • PASCCEC-GoodsAndServicesTaxForwarded - Petroleum Accountants Society of Canada Capital Expenditure code - Goods and services tax forwarded
    • PASCCEC-GoodsAndServicesTaxNotApplicable - Petroleum Accountants Society of Canada Capital Expenditure code - Goods and services tax not applicable
    • PASC-NonTubularCode - Petroleum Accountants Society of Canada Non-tubular code
    • PASCOMC-GoodsAndServicesTaxForwarded - Petroleum Accountants Society of Canada Operating and Maintenance code - Goods and services tax forwarded
    • PASCOMC-GoodsAndServicesTaxNotApplicable - Petroleum Accountants Society of Canada Operating and Maintenance code - Goods and services tax not applicable
    • PetroleumAccountantsSocietyOfCanadaTubularCode - Petroleum Accountants Society of Canada tubular code
    • Phase - Phase
    • PiecesInRoll - Pieces in roll
    • PiggybackCommercial - Piggyback commercial
    • PipelineTransactionCode - Pipeline transaction code
    • PlanCode - Plan code
    • PlantEquipmentNumber - Plant equipment number
    • Ply - Ply
    • PolicyForm - Policy form
    • Position - Position
    • PreferredManufacturer - Preferred manufacturer
    • PreferredNationalStockNumber - Preferred national stock number
    • PreferredPartNumber - Preferred part number
    • PremiumRateType - Premium rate type
    • PremiumUse - Premium use
    • PreviousCarrier - Previous carrier
    • PreviousSampleIdentification - Previous sample identification
    • PriceLookUpNumber - Identification number on a product allowing a quick electronic retrieval of price information for that product.
    • PrimeContractorPartNumber - Prime contractor part number
    • PrintColorStandardReference - Print color standard reference
    • PrintOrDrawing - Print or drawing
    • ProcessNumber - Process number
    • ProductOrServiceIdentificationNumber - Reference number identifying a product or service.
    • ProductChangeNoticeNumber - Product change notice number
    • ProductDateCode - Product date code (A code indicating the period during which a product was manufactured.)
    • ProductIdAttributeCode - Product ID attribute code
    • ProductTypeCode - Product type code
    • ProductVersionNumber - Number assigned by manufacturer or seller to identify the release of a product.
    • ProgramCode - Program code
    • ProgramDescriptionIdentifier - Program description identifier
    • ProgramLevel - Program level
    • PromotionalVariantNumber
    • PropertyAndCasualtyServiceCode - Property and casualty service code
    • PublicationNumber - Publication number
    • PublisherCode - Publisher code
    • PurchaseOrderNumber - Purchase order number
    • PurchasersItemCode - Purchaser's item code
    • PurchasersOrderLineNumber - Purchaser's order line number
    • PurposeOfInsurance - Purpose of insurance
    • RackNumber - Rack number
    • RadiatorSerialNumber - Radiator serial number
    • Railroad-OwnedUnitTrainNumber - Railroad-owned unit train number
    • RandomWeightAggregationCode - Random weight aggregation code
    • RateDetailCard - Rate detail card
    • RealEstatePropertyInformationService - Real estate property information service
    • RearAxleExtendedTag - Rear axle, extended tag
    • RearAxleFrontRearDrivenSerialNumber - Rear axle front rear driven serial number
    • RearAxleMiddle - Rear axle, middle
    • RearAxlePusher - Rear axle, pusher
    • RearAxleRearDrivenSerialNumber - Rear axle rear driven serial number
    • RearAxleRearNonDrivenSerialNumber - Rear axle rear non driven serial number
    • RearAxleSerialNumber - Rear axle serial number
    • RearAxleTag - Rear axle, tag
    • ReclamationProcess - Reclamation process
    • RecordKeepingOrModelYear - Record keeping or model year
    • ReeferSerialNumber - Reefer serial number
    • ReelNumber - Reel number
    • ReelType - Reel type
    • ReferenceOil - Reference oil
    • RefinedProductCode - A code specifying the product refinement designation.
    • RelatedModelNumber - Related model number
    • RelatedModelType - Related model type
    • RelatedPolicyIdentification - Related policy identification
    • RelativeValueUnits - Relative value units
    • ReleaseNumber - Release number
    • ReligiousRetailNon-BookItem - Religious retail non-book item
    • RepairFromProductCode - Repair from product code
    • RepairInductionIdentifier - Repair induction identifier
    • RepairTagNumber - Repair tag number
    • ReplacedPartNumber - Replaced part number
    • ReplacementNationalStockNumber - Replacement national stock number
    • ReplacementProductNumber - Replacement product number
    • ReplacementSubassemblyModelNumber - Replacement subassembly model number
    • ReplacementSubassemblySerialNumber - Replacement subassembly serial number
    • ResourceNumber - A number to identify a resource.
    • RetailPLU - Retail Price Look Up number (PLU)
    • ReturnableContainerNumber - Returnable container number
    • ReturnCode - Return code
    • RollNumber - Roll number
    • RollSequenceNumber - Roll sequence number
    • RSKNumber - Plumbing and heating.
    • RunNumber - Run number
    • SalesPresentationID - Sales presentation ID
    • SampleNumber - Number assigned to a sample.
    • SchematicDiagramReferenceNumber - Schematic diagram reference number
    • SeatSerialNumber - Seat serial number
    • SecondaryPly - Secondary ply
    • SecondPriorIdentifier - Second prior identifier
    • SectionPrintNumber - Section print number
    • SellersDateCode - Seller's date code
    • SellersLotNumber - Seller's lot number
    • SerialItemAndContributionIdentifier - Serial item and contribution identifier (Defined in ANSI 239.56)
    • SerialNumber - Serial number
    • SeriesIdentifier - Series identifier
    • ServiceCodePerCOPASStandard - Service code per COPAS standard
    • ServiceControlIdentification - Service control identification
    • ServiceFeatureID - Service feature ID
    • ServiceRendered - Service rendered
    • ServiceRequested - Service requested
    • SetNumber - Set number
    • SettlementOrPayoutOption - Settlement/payout option
    • Shelf-LifeActionCode - Shelf-life action code
    • Shelf-LifeCode - Shelf-life code
    • ShiftWorked - Shift worked
    • SideUpOrSideDown - Side up/side down
    • SkillCode - Skill code
    • SKU - Stock keeping unit (SKU)
    • SlabNumber - Number assigned to a slab, which is produced in a particular production step.
    • SleeperBoxKeyNumber - Sleeper box key number
    • SleeperBoxSerialNumber - Sleeper box serial number
    • SNOMED - Systematized Nomenclature of Human and Veterinary Medicine (SNOMED)
    • SoftwareRevisionNumber - A number assigned to indicate a revision of software.
    • SourceOfDepositCode - Source of deposit code
    • SourceOfLeadCode - Source of lead code
    • SpecialMaterialIdentificationCode - A number to identify the special material code.
    • SSCC-18AndApplicationIdentifier - SSCC-18 and application identifier
    • StandardGroupOfProducts-MixedAssortment
    • StandardIndustrialClassificationCode - Standard industrial classification code
    • StateLabelCode - A code which specifies the codification of the state's labelling requirements.
    • StateSampleIdentification - State sample identification
    • StockNumber - Stock number
    • StyleNumber - Style number
    • SublineItemNumber - Subline item number
    • SubmissionNumber - Submission number
    • SubsistenceIdentificationNumber - Subsistence identification number
    • SubstituteProductNumber - Substitute product number
    • SubtopicLevel - Subtopic level
    • SupersededPartNumber - Superseded part number
    • SupersededPurchaseOrderNumber - Superseded purchase order number
    • SupplierBrandCode - Supplier brand code
    • SupplierCompanyRegistryNumber - Supplier company registry number
    • SuppliersArticleNumber - Number assigned to an article by the supplier of that article.
    • SuppliersSupplierArticleNumber - Article number referring to a sales catalogue of supplier's supplier.
    • SurfaceFinish - Surface finish
    • SyntheticLube - Lube, synthetic
    • SystemIdentifier - System identifier
    • TACTCommodityCode - The air cargo tariff (TACT) commodity code
    • TaxCode - Tax code
    • TechnicalManualNumber - Technical manual number
    • TechnicalOrderNumber - Technical order number
    • TechnicalPhase - To specify as an item, the technical phase.
    • TelecommunicationsCircuitId - Telecommunications circuit ID
    • TelecommunicationsIndustryServiceCode - Telecommunications industry service code
    • TelecomServiceType - Telecom service type
    • TelephoneIndustryManufacturerCode - Telephone industry manufacturer code
    • TestedMaterialIdentificationNumber - Tested material identification number
    • Tex - Tex
    • ThirdPriorIdentifier - Third prior identifier
    • TimeCompliantTechnicalOrder - Time compliant technical order
    • TitleCode - Title code
    • TopicLevel - Topic level
    • TradeInIdentifier - Trade in identifier
    • TransferCaseSerialNumber - Transfer case serial number
    • TransmissionSerialNumber - Transmission serial number
    • TransportGroupNumber - Additional number to form article groups for packing and/or transportation purposes.
    • TreasuryManagementAssociation - Treasury management association
    • TreasuryManagementAssociationServiceCode - Treasury management association service code
    • TreasuryManagementAssociationServiceCodeAndBankServiceCode - Treasury management association service code and bank service code
    • TreatmentCodes - Treatment codes
    • TruckBodySerialNumber - Truck body serial number
    • TypeSelvage - Type selvage
    • UCCOrEAN-128CouponExtendedCode - UCC/EAN-128 coupon extended code
    • UltimateCustomersArticleNumber - Number assigned by ultimate customer to identify relevant article.
    • UNCCS - United Nations Common Coding System (UNCCS)
    • UnderwritingMethodOfDirectWriter - Underwriting method of direct writer
    • UniformStockSymbolSystemCodeNumber - Uniform stock symbol system code number
    • UniversalProductNumber - Universal product number
    • UNNumberDangerousGoods - United Nations (UN) number (dangerous goods)
    • UPC - Number assigned to a manufacturer's product by the Product Code Council.
    • UPCOrEAN - Shipping container code (1-2-5-5-1) A 14-digit code that uniquely identifies the manufacturer's shipping unit, including the packaging indicator and the check digit.
    • UPCCaseCodeNumber1-1-5-5 - U.P.C. case code number (1-1-5-5)
    • UPCConsumerPackageCode1-5-5 - U.P.C. consumer package code (1-5-5)
    • UPCConsumerPackageCode1-5-5-1 - U.P.C. consumer package code (1-5-5-1)
    • UPCCouponCode1-5-5-1 - U.P.C. coupon code (1-5-5-1)
    • UPCOrEANCaseCode2-5-5 - U.P.C./EAN case code (2-5-5)
    • UPCOrEANConsumerPackageCode2-5-5 - U.P.C./EAN consumer package code (2-5-5)
    • UPCOrEANCouponCode2-5-5 - U.P.C./EAN coupon code (2-5-5)
    • UPCOrEANModuleCode2-5-5 - U.P.C./EAN module code (2-5-5)
    • UPCOrEANMultipackCode - U.P.C./EAN multipack code
    • UPCOrEANShippingContainerCode1-2-5-5-1 - U.P.C./EAN shipping container code (1-2-5-5-1)
    • UPCShippingContainerCode1-2-5-5 - U.P.C. shipping container code (1-2-5-5)
    • UPCSuffix - A suffix used in conjunction with a higher level UPC (Universal product code) to define packing variations for a product.
    • UPCSuffix-DefinesPackingVariations - U.P.C. suffix (defines packing variations)
    • User-DefinedShippingContainerIdentifier - User-defined shipping container identifier
    • UVMRPMLines - Universal vendor marking, long code (UVM, R,P,M Lines) R,P,M Lines)
    • UVMULine - Universal vendor marking, short code (UVM, U Line) U Line)
    • VariableMeasureProductCode - A code assigned to identify a variable measure item.
    • VaryItemProductNumber - Vary item product number
    • VehicleMaintenanceReportingStandards - Vehicle maintenance reporting standards
    • VendorAlphanumericSizeCode - Vendor alphanumeric size code
    • VendorColor - Vendor color
    • VendorGroundShadeIdentifier - Vendor ground shade identifier
    • VendorItemNumber - Reference number assigned by a vendor/seller identifying a product/service/article.
    • VendorsCatalogNumber - Vendor's (seller's) catalog number
    • VendorsItemNumber - Vendor's (seller's) item number
    • VendorsPartNumber - Vendor's (seller's) part number
    • VendorsBasicUnitNumber - Vendor's basic unit number
    • VendorsEngineeringChangeLevelNumber - Vendor's engineering change level number
    • VendorsOrderNumber - Vendor's order number
    • VendorSpecificationNumber - Vendor's specification number
    • VendorsStyleNumber - Vendor's style number
    • VendorsSupplementalItemNumber - Vendor's supplemental item number
    • Vintage - Vintage
    • VolumeSet - Volume set
    • VolumeTypeIdentificationCode - Volume type identification code
    • VolumeUsageIdentificationCode - Volume usage identification code
    • WaferLotIdentifier - Wafer lot identifier
    • WellNumber - Well number
    • WheelChairLiftSerialNumber - Wheel chair lift serial number
    • WoolenCut - Woolen cut
    • WoolenRun - Woolen run
    • WorkTaskNumber - A number to identify a work task.
    • WorkUnitNumber - Work unit number
    • WorldCode - World code
    • YarnCount-English - Yarn count - english
    • YarnCount-Metric - Yarn count - metric
    • YarnCountWorsted - Yarn count worsted

[^]Code Fragment

    <xsd:simpleType name="ProductIdentifierQualifierCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="AdditionalProductIdentificationAssignedByTheManufacturer">
        <xsd:enumeration value="AdvertisingPackageIdentificationCode">
        <xsd:enumeration value="Age">
        <xsd:enumeration value="AggregationCode">
        <xsd:enumeration value="AirTransportationAssociationProprietaryRightsCode">
        <xsd:enumeration value="AllocationMethodologyIdentificationCode">
        <xsd:enumeration value="AlternateISBN">
        <xsd:enumeration value="AmericanDentalAssociationCodes">
        <xsd:enumeration value="AmericanTruckingAssociationsAssembly">
        <xsd:enumeration value="AmericanTruckingAssociationsPart">
        <xsd:enumeration value="AmericanTruckingAssociationsSystem">
        <xsd:enumeration value="Anniversary">
        <xsd:enumeration value="ApplicationCompletionMethod">
        <xsd:enumeration value="ApplicationState">
        <xsd:enumeration value="AppraisalProductType">
        <xsd:enumeration value="AppraisalService">
        <xsd:enumeration value="ARNICPartNumber">
        <xsd:enumeration value="Assembly">
        <xsd:enumeration value="AssemblyLotNumber">
        <xsd:enumeration value="AssetCategory">
        <xsd:enumeration value="AssetNumber">
        <xsd:enumeration value="AssetType">
        <xsd:enumeration value="AssortabilityCode">
        <xsd:enumeration value="AuthorCode">
        <xsd:enumeration value="AuthorizedPartsListNumber">
        <xsd:enumeration value="AutomaticTransmissionSerialNumber">
        <xsd:enumeration value="AuxiliaryTransmissionSerialNumber">
        <xsd:enumeration value="AuxillaryTransmission">
        <xsd:enumeration value="AxleRatio">
        <xsd:enumeration value="AxleSerialNumber">
        <xsd:enumeration value="Backing">
        <xsd:enumeration value="BaleNumber">
        <xsd:enumeration value="Bar-CodedSerialNumber">
        <xsd:enumeration value="BatchNumber">
        <xsd:enumeration value="BeamNumber">
        <xsd:enumeration value="BenefitID">
        <xsd:enumeration value="BeverageCommonCode">
        <xsd:enumeration value="BillboardsCommercial">
        <xsd:enumeration value="BillCreditCode">
        <xsd:enumeration value="BillSubgroupCode">
        <xsd:enumeration value="BindingCode">
        <xsd:enumeration value="BrandOrLabel">
        <xsd:enumeration value="BrokerPriceOpinionService">
        <xsd:enumeration value="BusBodySerialNumber">
        <xsd:enumeration value="BuyerGroundShadeIdentifier">
        <xsd:enumeration value="BuyersCatalogNumber">
        <xsd:enumeration value="BuyersColor">
        <xsd:enumeration value="BuyersEndProductNumber">
        <xsd:enumeration value="BuyersEngineeringChangeLevelNumber">
        <xsd:enumeration value="BuyersInternalProductGroupCode">
        <xsd:enumeration value="BuyersItemNumber">
        <xsd:enumeration value="BuyersPartNumber">
        <xsd:enumeration value="BuyersQualifierForSize">
        <xsd:enumeration value="BuyersSizeCode">
        <xsd:enumeration value="BuyersStyleNumber">
        <xsd:enumeration value="BuyersSublineItemNumber">
        <xsd:enumeration value="CAGECode">
        <xsd:enumeration value="CandidateOil">
        <xsd:enumeration value="Carry-OverPartNumber">
        <xsd:enumeration value="Case">
        <xsd:enumeration value="CatalogNumber">
        <xsd:enumeration value="Channel">
        <xsd:enumeration value="ChassisSerialNumber">
        <xsd:enumeration value="ChemicalAbstractServiceRegistryNumber">
        <xsd:enumeration value="Classification">
        <xsd:enumeration value="ClassOfContractCode">
        <xsd:enumeration value="CLEICode">
        <xsd:enumeration value="CognizanceSymbol">
        <xsd:enumeration value="ColdRollNumber">
        <xsd:enumeration value="Color">
        <xsd:enumeration value="CombinedNCCMAOrBankServiceCode">
        <xsd:enumeration value="CommissionIdentifier">
        <xsd:enumeration value="CommissionYear">
        <xsd:enumeration value="CommitteeForUniformSecurityIdentificationProcedureNumber">
        <xsd:enumeration value="CommodityGrouping">
        <xsd:enumeration value="CommodityName">
        <xsd:enumeration value="CommonLanguageEquipmentIdentifier">
        <xsd:enumeration value="Company-OwnedUnitTrainNumber">
        <xsd:enumeration value="CompanyPartNumber">
        <xsd:enumeration value="CompatibleCutNumber">
        <xsd:enumeration value="CompensationAllocationCode">
        <xsd:enumeration value="CompensationTypeCode">
        <xsd:enumeration value="CompletionNumber">
        <xsd:enumeration value="ConceptCode">
        <xsd:enumeration value="ConfigurationItemIdentifier">
        <xsd:enumeration value="ConnectorType">
        <xsd:enumeration value="Continuation">
        <xsd:enumeration value="ContractActivityCode">
        <xsd:enumeration value="ContractBreakdown">
        <xsd:enumeration value="ContractChangeAuthorizationType">
        <xsd:enumeration value="ContractNumber">
        <xsd:enumeration value="ContractorEstablishmentCode">
        <xsd:enumeration value="ContractTransferReasonCode">
        <xsd:enumeration value="ContributionYear">
        <xsd:enumeration value="ControlNumber">
        <xsd:enumeration value="CountryFromWhichProcured">
        <xsd:enumeration value="CountryOfOriginCode">
        <xsd:enumeration value="CouponFamilyCode">
        <xsd:enumeration value="CouponNumber">
        <xsd:enumeration value="CoverageRiskType">
        <xsd:enumeration value="CoverageType">
        <xsd:enumeration value="CurrentProceduralTerminologyCodes">
        <xsd:enumeration value="CustomerCompanyRegistryNumber">
        <xsd:enumeration value="CustomerOrderNumber">
        <xsd:enumeration value="CustomerProvidedEquipment">
        <xsd:enumeration value="CustomsArticleNumber">
        <xsd:enumeration value="CutNumber">
        <xsd:enumeration value="DataCategory">
        <xsd:enumeration value="DepartmentOfDefenseIdentificationCode">
        <xsd:enumeration value="DepositItemNumber">
        <xsd:enumeration value="DesignNumber">
        <xsd:enumeration value="DeviceFamily">
        <xsd:enumeration value="DeviceType">
        <xsd:enumeration value="DiagnosisCodePointer">
        <xsd:enumeration value="DieNumber">
        <xsd:enumeration value="DiscontinuedPartNumber">
        <xsd:enumeration value="DiscountGrouping">
        <xsd:enumeration value="Distributor">
        <xsd:enumeration value="DividendUse">
        <xsd:enumeration value="DocumentIdentificationCode">
        <xsd:enumeration value="Drawing">
        <xsd:enumeration value="DrawingRevisionNumber">
        <xsd:enumeration value="DrugUPCConsumerPackageCode1-4-6-1">
        <xsd:enumeration value="DrugUPCShippingContainerCode1-2-4-6-1">
        <xsd:enumeration value="DunAndBradstreetStandardProductAndServiceCode">
        <xsd:enumeration value="DyeLotNumber">
        <xsd:enumeration value="EAN2-5-5-1">
        <xsd:enumeration value="EAN-99In-StoreCouponCode">
        <xsd:enumeration value="EditionCode">
        <xsd:enumeration value="EndItemNumber">
        <xsd:enumeration value="End-ItemDescription">
        <xsd:enumeration value="EngineDisplacementIdentification">
        <xsd:enumeration value="EngineeringChangeLevel">
        <xsd:enumeration value="EngineeringDataList">
        <xsd:enumeration value="EngineSerialNumber">
        <xsd:enumeration value="EquipmentCodePerCOPASStandard">
        <xsd:enumeration value="EquipmentHierarchicalSequenceIdentifier">
        <xsd:enumeration value="EquipmentIdentificationNumber">
        <xsd:enumeration value="EquipmentLocation">
        <xsd:enumeration value="EquipmentType">
        <xsd:enumeration value="EventType">
        <xsd:enumeration value="ExchangedPartOrAssemblyOrProduct">
        <xsd:enumeration value="Exhibit">
        <xsd:enumeration value="ExhibitIdentifier">
        <xsd:enumeration value="ExhibitLineItemNumber">
        <xsd:enumeration value="ExpendableContainerIdentification">
        <xsd:enumeration value="ExpenseIdentifier">
        <xsd:enumeration value="FAAServiceBulletinNumber">
        <xsd:enumeration value="FabricPiecesPerRoll">
        <xsd:enumeration value="FailedSubassemblyModelNumber">
        <xsd:enumeration value="FailedSubassemblySerialNumber">
        <xsd:enumeration value="FannieMaeAffordableLendingProductCode">
        <xsd:enumeration value="FannieMaeProjectCondominiumClassificationCode">
        <xsd:enumeration value="Feature">
        <xsd:enumeration value="FederalSupplyClassification">
        <xsd:enumeration value="FifthWheelSerialNumber">
        <xsd:enumeration value="FinalTestLotNumber">
        <xsd:enumeration value="FinancialPhase">
        <xsd:enumeration value="FinishLotNumber">
        <xsd:enumeration value="FinishNumber">
        <xsd:enumeration value="FinishOrHandStandardReference">
        <xsd:enumeration value="FirePump">
        <xsd:enumeration value="FirstPriorIdentifier">
        <xsd:enumeration value="FormerPublisher">
        <xsd:enumeration value="FormNumber">
        <xsd:enumeration value="FreddieMacAffordableLendingProductCode">
        <xsd:enumeration value="FreddieMacProjectCondominiumClassificationCode">
        <xsd:enumeration value="FrontAxle-Rear">
        <xsd:enumeration value="FrontAxleDrivenSerialNumber">
        <xsd:enumeration value="FrontAxleNonDrivenSerialNumber">
        <xsd:enumeration value="FrontAxleSerialNumber">
        <xsd:enumeration value="FuelTankSerialNumber">
        <xsd:enumeration value="Fund">
        <xsd:enumeration value="FundAbbreviation">
        <xsd:enumeration value="FundManager">
        <xsd:enumeration value="FundSub-Advisor">
        <xsd:enumeration value="FundType">
        <xsd:enumeration value="GASFLOWInvoicePostingCode">
        <xsd:enumeration value="GASFLOWProductorServiceChargeCode">
        <xsd:enumeration value="Gathering">
        <xsd:enumeration value="GearRatio">
        <xsd:enumeration value="GeneralSpecificationNumber">
        <xsd:enumeration value="GenericNameDescription">
        <xsd:enumeration value="GliderKit">
        <xsd:enumeration value="GradeCode">
        <xsd:enumeration value="GradeName">
        <xsd:enumeration value="GrainDirection">
        <xsd:enumeration value="GraphicsIndustryBarCode">
        <xsd:enumeration value="GroundShadeStandardReference">
        <xsd:enumeration value="GroupID">
        <xsd:enumeration value="GroupQualifierCode">
        <xsd:enumeration value="GTIN">
        <xsd:enumeration value="HarmonisedSystem">
        <xsd:enumeration value="HCPCS">
        <xsd:enumeration value="HeatNumber">
        <xsd:enumeration value="HIBC-HealthIndustryBarCode">
        <xsd:enumeration value="HIBCSupplierLabelingStandardPrimaryDataMessage">
        <xsd:enumeration value="HIECProductOrServiceCode">
        <xsd:enumeration value="HotRollNumber">
        <xsd:enumeration value="ICD-9-CM-Procedure">
        <xsd:enumeration value="IgnitionKeyNumber">
        <xsd:enumeration value="Imprint-TrademarkCodeOfSubsidiary">
        <xsd:enumeration value="IndustryCommodityCode">
        <xsd:enumeration value="InformationMediaType">
        <xsd:enumeration value="Ingredient">
        <xsd:enumeration value="InsurancePlanDescriptionCharacteristics">
        <xsd:enumeration value="InsurersFundCode">
        <xsd:enumeration value="InterchangeabilityCode">
        <xsd:enumeration value="InteriorColorNumber">
        <xsd:enumeration value="InternalNumber">
        <xsd:enumeration value="InternationalArticleNumberingAssociation">
        <xsd:enumeration value="ICD-9-CM-Diagnosis">
        <xsd:enumeration value="InternationalHarmonizedCommodityCode">
        <xsd:enumeration value="InternationalStandardBookNumber">
        <xsd:enumeration value="InvestmentFundType">
        <xsd:enumeration value="IRSQualificationCode">
        <xsd:enumeration value="ISBN">
        <xsd:enumeration value="ISSN">
        <xsd:enumeration value="ItemManagementCode">
        <xsd:enumeration value="ItemTypeNumber">
        <xsd:enumeration value="JobNumber">
        <xsd:enumeration value="JobSequenceNumber">
        <xsd:enumeration value="JointLifeType">
        <xsd:enumeration value="JurisdictionSpecificProcedureAndSupplyCodes">
        <xsd:enumeration value="KanbanPlanNumber">
        <xsd:enumeration value="LaboratorySampleIdentification">
        <xsd:enumeration value="LaboratoryTestConditionCode">
        <xsd:enumeration value="LaborGroup">
        <xsd:enumeration value="LeaseNumber">
        <xsd:enumeration value="LibraryOfCongressCode">
        <xsd:enumeration value="LifeOrAnnuityProductCode">
        <xsd:enumeration value="LifeOrAnnuityServiceFeatures">
        <xsd:enumeration value="LiftGateSerialNumber">
        <xsd:enumeration value="LineOfAuthority">
        <xsd:enumeration value="LineOfBusiness">
        <xsd:enumeration value="LoadSequence">
        <xsd:enumeration value="LocallyAssignedControlNumber">
        <xsd:enumeration value="LocalStockNumber">
        <xsd:enumeration value="LocationCode">
        <xsd:enumeration value="LOINCCodes">
        <xsd:enumeration value="LotNumber">
        <xsd:enumeration value="LotPricingUnitNumber">
        <xsd:enumeration value="MachineNumber">
        <xsd:enumeration value="MaintenanceIndexPageReferenceNumber">
        <xsd:enumeration value="MajorProductOrMaterialOrMachineType">
        <xsd:enumeration value="ManualTransmissionSerialNumber">
        <xsd:enumeration value="Manufacturer">
        <xsd:enumeration value="ManufacturersArticleNumber">
        <xsd:enumeration value="ManufacturersPartNumber">
        <xsd:enumeration value="MarketProgramCode">
        <xsd:enumeration value="MaterialCode">
        <xsd:enumeration value="MaterialControlCode">
        <xsd:enumeration value="MaterialDischargeNumber">
        <xsd:enumeration value="MeasurementTypeCode">
        <xsd:enumeration value="MedicalInformationBureauAuthorization">
        <xsd:enumeration value="MedicalStopLossCoverageCodes">
        <xsd:enumeration value="MedicalStopLossLevelCodes">
        <xsd:enumeration value="MedicalStopLossProductLineCodes">
        <xsd:enumeration value="MedicationCode">
        <xsd:enumeration value="MEMAProductTypeCode">
        <xsd:enumeration value="MethodOfDeliveryCode">
        <xsd:enumeration value="MilestoneEventNumber">
        <xsd:enumeration value="MilitaryStandard">
        <xsd:enumeration value="MILSPECNumber">
        <xsd:enumeration value="ModelNumber">
        <xsd:enumeration value="MortgageCreditDataOrderType">
        <xsd:enumeration value="MortgageInsuranceProductCodeOrNumber">
        <xsd:enumeration value="MortgageProductCode">
        <xsd:enumeration value="MortgageUnderwritingType">
        <xsd:enumeration value="MotorVehicleIdNumber">
        <xsd:enumeration value="MotorVehicle-LineDesignator">
        <xsd:enumeration value="MovementTypeCode">
        <xsd:enumeration value="NationalDrugCode">
        <xsd:enumeration value="NationalDrugCode4-4-2Format">
        <xsd:enumeration value="NationalDrugCode5-3-2Format">
        <xsd:enumeration value="NationalDrugCode5-4-1Format">
        <xsd:enumeration value="NationalDrugCode5-4-2Format">
        <xsd:enumeration value="NationalHealthRelatedItemCode">
        <xsd:enumeration value="NationalHealthRelatedItemCodeIn4-6Format">
        <xsd:enumeration value="NationalHealthRelatedItemCodeIn5-5Format">
        <xsd:enumeration value="NationalProductGroupCode">
        <xsd:enumeration value="NationalRetailFederationColorCode">
        <xsd:enumeration value="NationalRetailFederationSizeCode">
        <xsd:enumeration value="NationalStockNumber">
        <xsd:enumeration value="NDC">
        <xsd:enumeration value="NewMicrocode">
        <xsd:enumeration value="NewReplacementPartOrAssemblyDefective">
        <xsd:enumeration value="NextHigherAssemblyNumber">
        <xsd:enumeration value="NextHigherUsedAssembly">
        <xsd:enumeration value="NonforfeitureOption">
        <xsd:enumeration value="Non-ResaleableItemExcludingDepositNumber">
        <xsd:enumeration value="NSN-NorthAtlanticTreatyOrganizationStockNumber">
        <xsd:enumeration value="NUBCUB82Codes">
        <xsd:enumeration value="NUBCUB92Codes">
        <xsd:enumeration value="NumberOfPositionsOnMachine">
        <xsd:enumeration value="ObligationAuthorityNumber">
        <xsd:enumeration value="ObsoletePartNumber">
        <xsd:enumeration value="OfferNumber">
        <xsd:enumeration value="OldMicrocode">
        <xsd:enumeration value="OldUPCOrEANCaseCode">
        <xsd:enumeration value="OldUPCOrEANConsumerPackageCode">
        <xsd:enumeration value="OldUPCOrEANModuleCode">
        <xsd:enumeration value="OldUPCOrEANMultipackCode">
        <xsd:enumeration value="OperatorAssignedPropertyIdentification">
        <xsd:enumeration value="Opposite-HandPartNumber">
        <xsd:enumeration value="OpticalCableCode">
        <xsd:enumeration value="OpticalIndustryProductCode">
        <xsd:enumeration value="OriginalEquipmentNumber">
        <xsd:enumeration value="OutsideProductionOperationSheetNumber">
        <xsd:enumeration value="PackageTypeCode">
        <xsd:enumeration value="PackagingDrawing">
        <xsd:enumeration value="PackagingSpecificationNumber">
        <xsd:enumeration value="PackNumber">
        <xsd:enumeration value="PartDrawing">
        <xsd:enumeration value="PartNumber">
        <xsd:enumeration value="PartNumberDescription">
        <xsd:enumeration value="PartReferenceNumber">
        <xsd:enumeration value="PatternNumber">
        <xsd:enumeration value="PASCCEC-GoodsAndServicesTaxForwarded">
        <xsd:enumeration value="PASCCEC-GoodsAndServicesTaxNotApplicable">
        <xsd:enumeration value="PASC-NonTubularCode">
        <xsd:enumeration value="PASCOMC-GoodsAndServicesTaxForwarded">
        <xsd:enumeration value="PASCOMC-GoodsAndServicesTaxNotApplicable">
        <xsd:enumeration value="PetroleumAccountantsSocietyOfCanadaTubularCode">
        <xsd:enumeration value="Phase">
        <xsd:enumeration value="PiecesInRoll">
        <xsd:enumeration value="PiggybackCommercial">
        <xsd:enumeration value="PipelineTransactionCode">
        <xsd:enumeration value="PlanCode">
        <xsd:enumeration value="PlantEquipmentNumber">
        <xsd:enumeration value="Ply">
        <xsd:enumeration value="PolicyForm">
        <xsd:enumeration value="Position">
        <xsd:enumeration value="PreferredManufacturer">
        <xsd:enumeration value="PreferredNationalStockNumber">
        <xsd:enumeration value="PreferredPartNumber">
        <xsd:enumeration value="PremiumRateType">
        <xsd:enumeration value="PremiumUse">
        <xsd:enumeration value="PreviousCarrier">
        <xsd:enumeration value="PreviousSampleIdentification">
        <xsd:enumeration value="PriceLookUpNumber">
        <xsd:enumeration value="PrimeContractorPartNumber">
        <xsd:enumeration value="PrintColorStandardReference">
        <xsd:enumeration value="PrintOrDrawing">
        <xsd:enumeration value="ProcessNumber">
        <xsd:enumeration value="ProductOrServiceIdentificationNumber">
        <xsd:enumeration value="ProductChangeNoticeNumber">
        <xsd:enumeration value="ProductDateCode">
        <xsd:enumeration value="ProductIdAttributeCode">
        <xsd:enumeration value="ProductTypeCode">
        <xsd:enumeration value="ProductVersionNumber">
        <xsd:enumeration value="ProgramCode">
        <xsd:enumeration value="ProgramDescriptionIdentifier">
        <xsd:enumeration value="ProgramLevel">
        <xsd:enumeration value="PromotionalVariantNumber">
        <xsd:enumeration value="PropertyAndCasualtyServiceCode">
        <xsd:enumeration value="PublicationNumber">
        <xsd:enumeration value="PublisherCode">
        <xsd:enumeration value="PurchaseOrderNumber">
        <xsd:enumeration value="PurchasersItemCode">
        <xsd:enumeration value="PurchasersOrderLineNumber">
        <xsd:enumeration value="PurposeOfInsurance">
        <xsd:enumeration value="RackNumber">
        <xsd:enumeration value="RadiatorSerialNumber">
        <xsd:enumeration value="Railroad-OwnedUnitTrainNumber">
        <xsd:enumeration value="RandomWeightAggregationCode">
        <xsd:enumeration value="RateDetailCard">
        <xsd:enumeration value="RealEstatePropertyInformationService">
        <xsd:enumeration value="RearAxleExtendedTag">
        <xsd:enumeration value="RearAxleFrontRearDrivenSerialNumber">
        <xsd:enumeration value="RearAxleMiddle">
        <xsd:enumeration value="RearAxlePusher">
        <xsd:enumeration value="RearAxleRearDrivenSerialNumber">
        <xsd:enumeration value="RearAxleRearNonDrivenSerialNumber">
        <xsd:enumeration value="RearAxleSerialNumber">
        <xsd:enumeration value="RearAxleTag">
        <xsd:enumeration value="ReclamationProcess">
        <xsd:enumeration value="RecordKeepingOrModelYear">
        <xsd:enumeration value="ReeferSerialNumber">
        <xsd:enumeration value="ReelNumber">
        <xsd:enumeration value="ReelType">
        <xsd:enumeration value="ReferenceOil">
        <xsd:enumeration value="RefinedProductCode">
        <xsd:enumeration value="RelatedModelNumber">
        <xsd:enumeration value="RelatedModelType">
        <xsd:enumeration value="RelatedPolicyIdentification">
        <xsd:enumeration value="RelativeValueUnits">
        <xsd:enumeration value="ReleaseNumber">
        <xsd:enumeration value="ReligiousRetailNon-BookItem">
        <xsd:enumeration value="RepairFromProductCode">
        <xsd:enumeration value="RepairInductionIdentifier">
        <xsd:enumeration value="RepairTagNumber">
        <xsd:enumeration value="ReplacedPartNumber">
        <xsd:enumeration value="ReplacementNationalStockNumber">
        <xsd:enumeration value="ReplacementProductNumber">
        <xsd:enumeration value="ReplacementSubassemblyModelNumber">
        <xsd:enumeration value="ReplacementSubassemblySerialNumber">
        <xsd:enumeration value="ResourceNumber">
        <xsd:enumeration value="RetailPLU">
        <xsd:enumeration value="ReturnableContainerNumber">
        <xsd:enumeration value="ReturnCode">
        <xsd:enumeration value="RollNumber">
        <xsd:enumeration value="RollSequenceNumber">
        <xsd:enumeration value="RSKNumber">
        <xsd:enumeration value="RunNumber">
        <xsd:enumeration value="SalesPresentationID">
        <xsd:enumeration value="SampleNumber">
        <xsd:enumeration value="SchematicDiagramReferenceNumber">
        <xsd:enumeration value="SeatSerialNumber">
        <xsd:enumeration value="SecondaryPly">
        <xsd:enumeration value="SecondPriorIdentifier">
        <xsd:enumeration value="SectionPrintNumber">
        <xsd:enumeration value="SellersDateCode">
        <xsd:enumeration value="SellersLotNumber">
        <xsd:enumeration value="SerialItemAndContributionIdentifier">
        <xsd:enumeration value="SerialNumber">
        <xsd:enumeration value="SeriesIdentifier">
        <xsd:enumeration value="ServiceCodePerCOPASStandard">
        <xsd:enumeration value="ServiceControlIdentification">
        <xsd:enumeration value="ServiceFeatureID">
        <xsd:enumeration value="ServiceRendered">
        <xsd:enumeration value="ServiceRequested">
        <xsd:enumeration value="SetNumber">
        <xsd:enumeration value="SettlementOrPayoutOption">
        <xsd:enumeration value="Shelf-LifeActionCode">
        <xsd:enumeration value="Shelf-LifeCode">
        <xsd:enumeration value="ShiftWorked">
        <xsd:enumeration value="SideUpOrSideDown">
        <xsd:enumeration value="SkillCode">
        <xsd:enumeration value="SKU">
        <xsd:enumeration value="SlabNumber">
        <xsd:enumeration value="SleeperBoxKeyNumber">
        <xsd:enumeration value="SleeperBoxSerialNumber">
        <xsd:enumeration value="SNOMED">
        <xsd:enumeration value="SoftwareRevisionNumber">
        <xsd:enumeration value="SourceOfDepositCode">
        <xsd:enumeration value="SourceOfLeadCode">
        <xsd:enumeration value="SpecialMaterialIdentificationCode">
        <xsd:enumeration value="SSCC-18AndApplicationIdentifier">
        <xsd:enumeration value="StandardGroupOfProducts-MixedAssortment">
        <xsd:enumeration value="StandardIndustrialClassificationCode">
        <xsd:enumeration value="StateLabelCode">
        <xsd:enumeration value="StateSampleIdentification">
        <xsd:enumeration value="StockNumber">
        <xsd:enumeration value="StyleNumber">
        <xsd:enumeration value="SublineItemNumber">
        <xsd:enumeration value="SubmissionNumber">
        <xsd:enumeration value="SubsistenceIdentificationNumber">
        <xsd:enumeration value="SubstituteProductNumber">
        <xsd:enumeration value="SubtopicLevel">
        <xsd:enumeration value="SupersededPartNumber">
        <xsd:enumeration value="SupersededPurchaseOrderNumber">
        <xsd:enumeration value="SupplierBrandCode">
        <xsd:enumeration value="SupplierCompanyRegistryNumber">
        <xsd:enumeration value="SuppliersArticleNumber">
        <xsd:enumeration value="SuppliersSupplierArticleNumber">
        <xsd:enumeration value="SurfaceFinish">
        <xsd:enumeration value="SyntheticLube">
        <xsd:enumeration value="SystemIdentifier">
        <xsd:enumeration value="TACTCommodityCode">
        <xsd:enumeration value="TaxCode">
        <xsd:enumeration value="TechnicalManualNumber">
        <xsd:enumeration value="TechnicalOrderNumber">
        <xsd:enumeration value="TechnicalPhase">
        <xsd:enumeration value="TelecommunicationsCircuitId">
        <xsd:enumeration value="TelecommunicationsIndustryServiceCode">
        <xsd:enumeration value="TelecomServiceType">
        <xsd:enumeration value="TelephoneIndustryManufacturerCode">
        <xsd:enumeration value="TestedMaterialIdentificationNumber">
        <xsd:enumeration value="Tex">
        <xsd:enumeration value="ThirdPriorIdentifier">
        <xsd:enumeration value="TimeCompliantTechnicalOrder">
        <xsd:enumeration value="TitleCode">
        <xsd:enumeration value="TopicLevel">
        <xsd:enumeration value="TradeInIdentifier">
        <xsd:enumeration value="TransferCaseSerialNumber">
        <xsd:enumeration value="TransmissionSerialNumber">
        <xsd:enumeration value="TransportGroupNumber">
        <xsd:enumeration value="TreasuryManagementAssociation">
        <xsd:enumeration value="TreasuryManagementAssociationServiceCode">
        <xsd:enumeration value="TreasuryManagementAssociationServiceCodeAndBankServiceCode">
        <xsd:enumeration value="TreatmentCodes">
        <xsd:enumeration value="TruckBodySerialNumber">
        <xsd:enumeration value="TypeSelvage">
        <xsd:enumeration value="UCCOrEAN-128CouponExtendedCode">
        <xsd:enumeration value="UltimateCustomersArticleNumber">
        <xsd:enumeration value="UNCCS">
        <xsd:enumeration value="UnderwritingMethodOfDirectWriter">
        <xsd:enumeration value="UniformStockSymbolSystemCodeNumber">
        <xsd:enumeration value="UniversalProductNumber">
        <xsd:enumeration value="UNNumberDangerousGoods">
        <xsd:enumeration value="UPC">
        <xsd:enumeration value="UPCOrEAN">
        <xsd:enumeration value="UPCCaseCodeNumber1-1-5-5">
        <xsd:enumeration value="UPCConsumerPackageCode1-5-5">
        <xsd:enumeration value="UPCConsumerPackageCode1-5-5-1">
        <xsd:enumeration value="UPCCouponCode1-5-5-1">
        <xsd:enumeration value="UPCOrEANCaseCode2-5-5">
        <xsd:enumeration value="UPCOrEANConsumerPackageCode2-5-5">
        <xsd:enumeration value="UPCOrEANCouponCode2-5-5">
        <xsd:enumeration value="UPCOrEANModuleCode2-5-5">
        <xsd:enumeration value="UPCOrEANMultipackCode">
        <xsd:enumeration value="UPCOrEANShippingContainerCode1-2-5-5-1">
        <xsd:enumeration value="UPCShippingContainerCode1-2-5-5">
        <xsd:enumeration value="UPCSuffix">
        <xsd:enumeration value="UPCSuffix-DefinesPackingVariations">
        <xsd:enumeration value="User-DefinedShippingContainerIdentifier">
        <xsd:enumeration value="UVMRPMLines">
        <xsd:enumeration value="UVMULine">
        <xsd:enumeration value="VariableMeasureProductCode">
        <xsd:enumeration value="VaryItemProductNumber">
        <xsd:enumeration value="VehicleMaintenanceReportingStandards">
        <xsd:enumeration value="VendorAlphanumericSizeCode">
        <xsd:enumeration value="VendorColor">
        <xsd:enumeration value="VendorGroundShadeIdentifier">
        <xsd:enumeration value="VendorItemNumber">
        <xsd:enumeration value="VendorsCatalogNumber">
        <xsd:enumeration value="VendorsItemNumber">
        <xsd:enumeration value="VendorsPartNumber">
        <xsd:enumeration value="VendorsBasicUnitNumber">
        <xsd:enumeration value="VendorsEngineeringChangeLevelNumber">
        <xsd:enumeration value="VendorsOrderNumber">
        <xsd:enumeration value="VendorSpecificationNumber">
        <xsd:enumeration value="VendorsStyleNumber">
        <xsd:enumeration value="VendorsSupplementalItemNumber">
        <xsd:enumeration value="Vintage">
        <xsd:enumeration value="VolumeSet">
        <xsd:enumeration value="VolumeTypeIdentificationCode">
        <xsd:enumeration value="VolumeUsageIdentificationCode">
        <xsd:enumeration value="WaferLotIdentifier">
        <xsd:enumeration value="WellNumber">
        <xsd:enumeration value="WheelChairLiftSerialNumber">
        <xsd:enumeration value="WoolenCut">
        <xsd:enumeration value="WoolenRun">
        <xsd:enumeration value="WorkTaskNumber">
        <xsd:enumeration value="WorkUnitNumber">
        <xsd:enumeration value="WorldCode">
        <xsd:enumeration value="YarnCount-English">
        <xsd:enumeration value="YarnCount-Metric">
        <xsd:enumeration value="YarnCountWorsted">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: PurchaseOrderReferenceType

PurchaseOrderReferenceType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( BuyerOrderNumber[xsd:string] , SellerOrderNumber[xsd:string]? , AccountCode[ReferenceType]? , PurchaseOrderDate[xsd:dateTime]? , PurchaseOrderLineItemNumber[xsd:string]? , PartialOrderCoded[PartialOrderCodeType]? , PartialOrderCodedOther[xsd:string]? , OrderType[OrderTypeType]? , ReleaseNumber[xsd:string]? , ChangeOrderSequenceNumber[xsd:string]? )

    Description: PurchaseOrderReferenceType contains information relevant to the purchase order the invoice is issued against.

    Elements:

    • BuyerOrderNumber - holds the buyer's identification of the order.
    • SellerOrderNumber - holds the seller's identification of the order.
    • AccountCode - holds the seller's account number for the buyer.
    • PurchaseOrderDate - holds the date of issue of the purchase order.
    • PurchaseOrderLineItemNumber - holds the line item number of the referenced purchase order.
    • PartialOrderCoded - is a code specifying the status of the order.
    • PartialOrderCodedOther - is used to provide a non-standard ASNPartialOrderCode. This element is mandatory if the value of PartialOrderCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • OrderType - identifies the type of order being referenced.
    • ReleaseNumber - identifies the specific iteration of the release against a given contract, purchase order, etc.
    • ChangeOrderSequenceNumber - number assigned by the initiator of the order identifying a specific change or revision to a previously transmitted transaction set.

[^]Code Fragment

    <xsd:complexType name="PurchaseOrderReferenceType">
    <xsd:sequence>
        <xsd:element name="BuyerOrderNumber" type="xsd:string">
        <xsd:element minOccurs="0" name="SellerOrderNumber" type="xsd:string">
        <xsd:element minOccurs="0" name="AccountCode" type="ReferenceType">
        <xsd:element minOccurs="0" name="PurchaseOrderDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="PurchaseOrderLineItemNumber" type="xsd:string">
        <xsd:element minOccurs="0" name="PartialOrderCoded" type="PartialOrderCodeType">
        <xsd:element minOccurs="0" name="PartialOrderCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="OrderType" type="OrderTypeType">
        <xsd:element minOccurs="0" name="ReleaseNumber" type="xsd:string">
        <xsd:element minOccurs="0" name="ChangeOrderSequenceNumber" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: PurposeCodeType

PurposeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This identifies the function of a document. This code list is derived from EDIFACT 1225 (Message function, coded) and X12 353 (Transaction Set Purpose Code).

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom code
    • Cancellation - Indicates that a previous transmission of the message is to be cancelled.
    • Replace - Indicates that this transmission is to replace a previous message.
    • Confirmation - Indicates that this transmission is to confirm details of a previous message.
    • Duplicate - Indicates that this transmission is a duplicate of a previously generated message.
    • Original - Refers to the initial transmission of the message.
    • Change - Indicates that this transmission contains details of items to be changed.
    • InformationOnly - Indicates that there is no action needed, this transmission is for information only.

[^]Code Fragment

    <xsd:simpleType name="PurposeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Cancellation">
        <xsd:enumeration value="Replace">
        <xsd:enumeration value="Confirmation">
        <xsd:enumeration value="Duplicate">
        <xsd:enumeration value="Original">
        <xsd:enumeration value="Change">
        <xsd:enumeration value="InformationOnly">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: PurposeType

PurposeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( PurposeCoded[PurposeCodeType] , PurposeCodedOther[xsd:string]? )

    Description: PurposeType is used to communicate the function of a document.

    Elements:

    • PurposeCoded - defines the function of the document using a standard codelist.
    • PurposeCodedOther - is used to provide a non-standard PurposeCode. This element is mandatory if the value of PurposeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="PurposeType">
    <xsd:sequence>
        <xsd:element name="PurposeCoded" type="PurposeCodeType">
        <xsd:element minOccurs="0" name="PurposeCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: QuantityAllowanceOrChargeType

QuantityAllowanceOrChargeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( Quantity[QuantityType] , Rate[RateType] , QuantityMonetaryValue[MonetaryValueType]? )

    Description: QuantityAllowanceOrChargeType specifies the allowance or charge where the calculation is based on quantity.

    Elements:

    • Quantity - is the quantity of the allowance or charge.
    • Rate - specifies the rate that the allowance or charge is calculated on.
    • QuantityMonetaryValue - is the monetary amount of the allowance or charge.

[^]Code Fragment

    <xsd:complexType name="QuantityAllowanceOrChargeType">
    <xsd:sequence>
        <xsd:element name="Quantity" type="QuantityType">
        <xsd:element name="Rate" type="RateType">
        <xsd:element minOccurs="0" name="QuantityMonetaryValue" type="MonetaryValueType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: QuantityCodedType

QuantityCodedType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: Extends: QuantityType

      Append:( QuantityQualifierCoded[QuantityQualifierCodeType] , QuantityQualifierCodedOther[xsd:string]? )

    Description: QuantityCodedType contains a quantity not explicitly stated in another element.

    Elements:

    • QuantityQualifierCoded - is the purpose of a quantity using a standard codelist.
    • QuantityQualifierCodedOther - is used to provide a non-standard QuantityQualifierCode. This element is mandatory if the value of QuantityQualifierCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="QuantityCodedType">
    <xsd:complexContent>
        <xsd:extension base="QuantityType">
            <xsd:sequence>
                <xsd:element name="QuantityQualifierCoded" type="QuantityQualifierCodeType">
                <xsd:element minOccurs="0" name="QuantityQualifierCodedOther" type="xsd:string">
            </xsd:sequence>
        </xsd:extension>
    </xsd:complexContent>
</xsd:complexType>


simpleType definition: QuantityQualifierCodeType

QuantityQualifierCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the type of quantities. This code list is derived from EDIFACT 6063 (Quantity type code qualifier) and X12 673 (Quantity qualifier)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • AcceptableUnserviceableQuantity
    • Accidents
    • Accounts - The number of accounts.
    • AccountsPayableAverageOverdueDays - The average number of days accounts payable are overdue.
    • AccountsPlacedForCollection - The number of accounts placed for collection.
    • AcknowledgedQuantity
    • ActiveAccounts - Number of accounts in a current or active status.
    • ActiveContractsDelinquent
    • ActiveContractsDelinquent-BuyingPartyCaused
    • ActiveContractsDelinquent-ContractorCaused
    • ActiveContractsDelinquent-UnknownCauses
    • ActiveIngredient - Quantity at 100% active agent content.
    • ActiveIngredientDosePerUnit - The dosage of active ingredient per unit.
    • ActiveIngredientDosePerUnitDispensed - The dosage of active ingredient per dispensed unit.
    • ActiveLineItemsDelinquent
    • ActiveLineItemsDelinquent-BuyingPartyCaused
    • ActiveLineItemsDelinquent-ContractorCaused
    • ActiveLineItemsDelinquent-UnknownCauses
    • ActiveListings
    • ActiveMaintenanceTime
    • ActivityCodes - The number of activity codes.
    • Actual
    • ActualDuration
    • ActualHours - The Number Of Actual Hours.
    • ActualStock - The stock on hand, undamaged, and available for despatch, sale or use.
    • ActualUnits - The number of actual units.
    • ActualUnitsCumulativeToDate - The number of cumulative to date actual units.
    • AddedEmployees - Number of employees that were added to the workforce.
    • AdditionalAmount
    • AdditionalDemandQuantity
    • AdditionalPromotionSalesForecastQuantity - A forecast of additional quantity which will be sold during a period of promotional activity.
    • AdditionalReplenishmentDemandQuantity - Incremental Needs Over And Above Normal Replenishment Calculations, But Not Intended To Permanently Change The Model Parameters.
    • AdditionalUsageQuantity
    • AdjustedCorrectorReading - A corrector reading after it has been adjusted.
    • AdjustedQuantity
    • AdjustedUnits - The number of adjusted units.
    • AdjustmentToInventoryQuantity - An Adjustment To Inventory Quantity.
    • Administrators - Number of administrators.
    • Age
    • AgeAtDeath
    • AgedActiveLineItemsDelinquent-ContractorCaused
    • AgedLineItemsCompleted-ContractorCaused
    • AgedLineItemsDelinquent
    • AgeHighValue
    • AgeLowValue
    • AgeModifyingUnits
    • AgeNearest
    • AgeNext
    • Agents - The number of agents.
    • AgeOfFinancialInformation
    • AggregateBenefitPeriod
    • AgriculturalWorkers - The number of agricultural workers.
    • AircraftRadios
    • AirlineAttendants - The number of airline attendants.
    • AllocatedQuantity - Quantity Of The Referenced Item Allocated From Available Stock For Delivery.
    • AllottedUsageQuantity
    • Allowance - Quantity relevant for allowance.
    • AllTimeBuy - The Total Quantity Of The Referenced Covering All Future Needs. Further Orders Of The Referenced Item Are Not Expected.
    • AmortisationQuantity - The Quantity Of The Referenced Item Which Has A Cost For Tooling Amortisation Included In The Item Price.
    • AmortizationCumulatedQuantity - Indication of actual cumulated quantity of previous and actual amortization order quantity.
    • AmortizationOrderQuantity - Indication of actual share of the order quantity for amortization.
    • AmortizationTerm
    • AmortizationTotalQuantity - Indication of final quantity for amortization.
    • AnticipatedLengthOfService
    • ApprovalOrOfferDuration
    • ApprovedAmount
    • ApproximateNumberOfHolders
    • ApproximateNumberOfUnitsForSaleProjected
    • ApproximateNumberOfUnitsProjected
    • AreaDamaged
    • AreaOfLevel
    • AreaPerUnits
    • Arrests
    • AsIsQuantity
    • AssetSeizers - Number of entities that seize assets of another entity.
    • Associates
    • AtCompleteVariance
    • AtCompletionQuantityEstimated - The estimated quantity when a project is complete.
    • Attendant-HandledQuantity
    • Auctions - Number of auctions.
    • Auditor - The number of entities that audit accounts.
    • AuthorisedShares - The number of shares authorised for issue.
    • AuthorizedRetentionLevel
    • AuthorizedShares
    • AvailableQuantity
    • AvailableResourceTaskQuantity - Quantity Of A Resource Available To Complete A Task.
    • AvailableUnits
    • Average
    • AverageEmployees
    • AverageNumberOfEmployees
    • Axles
    • BackorderLines
    • BackorderQuantity
    • BankRejectItemCount.
    • BankruptcyPetitionsFiled - Number of bankruptcy petitions that have been filed.
    • BathroomCount
    • BathroomsFinishedAreaAboveGrade
    • BedroomCount
    • BedroomsFinishedAreaAboveGrade
    • Beds - Number of beds.
    • BeginningShares
    • BenefitAmount
    • BenefitPeriod
    • BillableQuantity
    • Billed
    • BillingUnitPerPricingUnit
    • BirthWeight
    • BlankVotes
    • BloodRecord
    • BookInventory
    • BookOrderQuantity
    • Branches
    • BranchLocations - The number of branch locations.
    • BranchLocationsLeased - The number of branch locations being leased by an entity.
    • BranchLocationsOwned - The number of branch locations owned by an entity.
    • BranchOfficeLocationsEstimated - Estimated number of branch office locations.
    • BrothersDeceased
    • BrothersLiving
    • Budget - Budget quantity.
    • BudgetAtComplete
    • BudgetCumulativeToDate - Budget quantity, cumulative to date.
    • BudgetedHours - The Number Of Budgeted Hours.
    • BusinessClassFailureIncidences - Number of firms in a specific class that discontinued with a loss to creditors.
    • BusinessFailureClassIncidence
    • BusinessFailureIndustryIncidence
    • BusinessFailureNationalAverageIncidence
    • Buyer - The number of buyers.
    • BuyupOrBuydownRatePerBasisPoint
    • Bytes
    • CalendarUnits
    • CancelledQuantity - Quantity Of The Referenced Item Which Has Previously Been Ordered And Is Now Cancelled.
    • CapitalChanges - The number of capital changes made.
    • CertifiedRegisteredNurseAnesthetistNumberOfConcurrentProcedures
    • Changes
    • ChangesInCapitalStructure - Number of modifications made to the capital structure of an entity.
    • Charge - Quantity relevant for charge.
    • ChargeableCubicMeasurements - The cubic measurements on which charges are based.
    • ChargeableDistance - Distance really charged by tariff appliance.
    • ChargeableGrossWeight - The gross weight on which charges are based.
    • ChargeableLength - The length on which charges are based.
    • ChargeableNumberOfAxles - The number of axles on which charges are based.
    • ChargeableNumberOfContainers - The number of containers on which charges are based.
    • ChargeableNumberOfPackages - The number of packages on which charges are based.
    • ChargeableNumberOfRailWagons - The number of rail wagons on which charges are based.
    • ChargeableNumberOfUnits - The number of units on which charges are based.
    • ChargeablePeriod - The period of time on which charges are based.
    • ChargeableSurface - The surface area on which charges are based.
    • ChargeableTareWeight - The tare weight on which charges are based.
    • ChargeableVolume - The volume on which charges are based.
    • ChargeableWeight - The weight on which charges are based.
    • Children
    • CirculatingOil
    • Citations
    • ClaimPeriod
    • Clerks - The number of clerks.
    • ClosingStatementBalance
    • ClosingStockBalanceQuantity - To Specify The Quantity Of A Closing Stock Balance.
    • Co2InjectionVolume
    • Co-Insured-Actual
    • Co-Insured-Estimated
    • CollateralRequirements
    • CollectionPeriod
    • CommitmentPeriod
    • CommittedQuantity - Quantity a party is committed to.
    • CommunityServiceDuration
    • CompaniesIncludedInConsolidatedFinancialStatement - The number of companies included in a consolidated financial statement.
    • CompaniesIncludedInConsolidation
    • CompaniesInSameActivity - The number of companies doing business in the same activity category.
    • ComparisonPeriod
    • Completed
    • CompletedContracts
    • CompletedLineItems
    • CompletedProjects - Number of completed projects.
    • ComponentMeterReadingCount
    • ConcurrentItemOutputOfTooling - The Number Of Related Items Which Can Be Produced Simultaneously With A Single Piece Of The Referenced Tooling.
    • Confirmed - Quanity has been confirmed.
    • ConsolidatedDiscountInventory - A quantity of inventory supplied at consolidated discount terms.
    • ConsumerReservedQuantity - Quantity Reserved For Consumer Delivery Or Pickup And Not Yet Withdrawn From Inventory.
    • ContinuanceDuration
    • ContractBuydown
    • ContractBuyup
    • ContractCompletedDelinquent-ContractorCaused
    • ContractLineItemQuantity
    • ContractorAtComplete
    • ContractorCumulativeToDate
    • ContractsCompletedDelinquent-BuyingPartyCaused
    • ContractsCompletedDelinquent-UnknownCauses
    • ContributionTotal
    • ControlQuantity - The quantity designated for control purposes.
    • ConventionalMobiles
    • ConvictionsSent
    • CooperativeShares - The number of cooperative shares.
    • CorrectedQuantity - The quantity has been corrected.
    • CorrectiveActionRequests-MethodC
    • CorrectiveActionRequests-MethodD
    • CorrectiveActionRequests-MethodE
    • CorrectiveActionRequests-Verbal
    • CorrectiveActionRequests-Written
    • CounterClerks - The number of clerks that work behind a flat-topped fitment.
    • CourseSegments
    • Coverage
    • Covered-Actual
    • Covered-Estimated
    • Creditors - The number of creditors.
    • CriminalSentenceDuration
    • CumulativeActual
    • CumulativeBudget
    • CumulativeEarnedValue
    • CumulativeEffectOfPriorPeriodAdjustment
    • CumulativeGasInjectionVolume
    • CumulativeGasVolume
    • CumulativeLiquidInjectionVolume
    • CumulativeOilOrCondensateVolume
    • CumulativeQuantity
    • CumulativeQuantityActualEstimated - Estimated cumulative quantity reached now.
    • CumulativeQuantityActualMeasured - Surveyed cumulative quantity reached now.
    • CumulativeQuantityActualPlanned - Cumulative quantity planned for now.
    • CumulativeQuantityOrdered - Cumulative quantity of all deliveries, outstanding and scheduled orders.
    • CumulativeQuantityPrecedingPeriodEstimated - Estimated cumulative quantity reached in the preceding period.
    • CumulativeQuantityPrecedingPeriodMeasured - Surveyed cumulative quantity reached in the preceding period.
    • CumulativeQuantityPrecedingPeriodPlanned - Cumulative quantity originally planned for the preceding period.
    • CumulativeQuantityPrecedingPeriodReached - Cumulative quantity reached in the preceding period.
    • CumulativeQuantityReceived - Cumulative quantity of all deliveries of this article received by the buyer.
    • CumulativeQuantityReceivedEndOfPriorYear - Cumulative quantity of all deliveries of the product received by the buyer till end of prior year.
    • CumulativeQuantity-RejectedMaterial
    • CumulativeQuantity-RejectedMaterial-DispositionCredit
    • CumulativeQuantity-RejectedMaterial-DispositionPending
    • CumulativeQuantity-RejectedMaterial-DispositionReplacement
    • CumulativeQuantityRequiredPriorToTheFirstScheduledPeriod
    • CumulativeQuantityScheduled - Adding the quantity actually scheduled to previous cumulative quantity.
    • CumulativeQuantityScheduledUpToAccumulationStartDate - The Cumulative Quantity Scheduled Up To The Accumulation Start Date.
    • CumulativeQuantityShipped - Cumulative quantity of all shipments.
    • CumulativeQuantityShippedLong-DispositionChallenged
    • CumulativeQuantityShippedLong-DispositionPending
    • CumulativeQuantityShippedShort-DispositionChallenged
    • CumulativeQuantityShippedShort-DispositionPending
    • CumulativeScheduleVariance
    • CumulativeScrapQuantity - Provides The Cumulative Quantity Of An Item Which Has Been Identified As Scrapped.
    • CumulativeVariance
    • CumulativeWaterVolume
    • CurrentDaysOnMarket
    • DeductibleBloodUnits
    • DefaultNotificationResponsePeriod
    • DegreeSegments
    • Deleted
    • DeliveryBatch - Quantity Of The Referenced Item Which Constitutes A Standard Batch For Deliver Purposes.
    • DeliveryBatchMultiple - The Multiples In Which Delivery Batches Can Be Supplied.
    • DeliveryQuantity - Quantity required by buyer to be delivered.
    • DeliveryQuantityBalance - The difference between the scheduled quantity and the quantity delivered to the consignee at a given date.
    • Departments - The number of departments.
    • DependentCount
    • DependentsAge
    • DependentTotal
    • DesignEmployees - The number of employees involved in the design process.
    • DespatchNoteQuantity - The Item Quantity Specified On The Despatch Note.
    • DespatchQuantity - Quantity despatched by the seller.
    • DestroyedQuantity
    • DetrimentalLegalFilings - Number of detrimental legal filings.
    • DetrimentalLegalFilingsAgainstDirectors - The number of legal filings that are of a detrimental nature that have been filed against the directors.
    • DimensionalSampleQuantity - The Quantity Defined Is A Sample For The Purpose Of Validating Dimensions.
    • Directors - Number of directors.
    • DirectShipmentQuantity - Quantity to be shipped directly to a customer from a manufacturing site.
    • DirectWorkers
    • DisbursementPeriod
    • DiscreetQuantity-RejectedMaterial
    • DiscreteQuantity
    • DiscreteQuantity-RejectedMaterial-DispositionCredit
    • DiscreteQuantity-RejectedMaterial-DispositionPending
    • DiscreteQuantity-RejectedMaterial-DispositionReplacement
    • Disposed
    • DispositionUndeterminedQuantity - Product quantity that has not yet had its disposition determined.
    • Distributed
    • DistributorInventory
    • DomesticAffiliatedCompanies - The number of affiliated companies located within the country.
    • DomesticUses
    • Dose
    • Drafts
    • Drivers - The number of drivers.
    • Due
    • Due-In
    • Duplicates
    • DurationInCurrentJob
    • DwellingArea
    • EarnedValue - Earned value quantity.
    • EarnedValueCumulativeToDate - Earned value quantity accumulated to date.
    • EarnedValueHours - The Number Of Earned Value Hours.
    • EffectiveAge
    • ElapsedDuration - Quantity representing the elapsed duration.
    • ElectronicSignatures
    • EliminationPeriod
    • EliminationPeriod-Accident
    • EliminationPeriod-Sickness
    • EmergencyModifyingUnits
    • EmployedAtLocation - The number of employees at the specified location.
    • EmployedAtThisLocation
    • EmployedByThisCompany - The number of employees at the specified company.
    • EmployedInThisProfession
    • EmployedOnThisJob
    • EmployeeAverage - The average number of employees.
    • Employees - Code specifying the quantity of persons working for a company, whose services are used for pay.
    • EmployeesAge
    • Employees-Nonowner
    • EmployeesNotIncludingOwners - Number of employees excluding business owners.
    • EmployeesNumberOfDaysAwayFromWorkDueToInjury
    • EmployeesNumberOfDaysOfRestrictedWorkActivityDueToInjury
    • Employees-Owner
    • Employees-PartTime
    • Employees-SameDuties
    • Employees-SameOccupation
    • EmployeesShared - The number of employees shared among entities.
    • EmployeesTotalNumberOfDaysAwayFromWorkDueToIllness
    • EmployeeTotal
    • EmployeeTotalFirstMonthOfQuarter
    • EmployeeTotalSecondMonthOfQuarter
    • EmployeeTotalThirdMonthOfQuarter
    • EndingStock
    • EndOfMonthInventoryPriorToShip
    • EndQuantity - The quantity recorded at the end of an agreement or period.
    • EngineeredStandard
    • Engineers - The number of engineers.
    • EquipmentQuantity - A count of a quantity of equipment.
    • EquitySecurityHolder
    • EstimateAtComplete
    • Estimated
    • EstimatedAccounts - The estimated number of accounts.
    • EstimatedAnnualVolume
    • EstimatedDuration
    • EstimatedEmployeesAtLocation - The estimated number of employees at the specified location.
    • EstimatedHours - The Number Of Estimated Hours.
    • EstimatedQuantity
    • EstimatedReadingQuantity - The value that is estimated to be the reading of a measuring device (e.g. meter).
    • EstimatedRemainingEconomicLife
    • EstimatedRemainingPhysicalLife
    • EstimatedTotalEmployees - The total estimated number of employees.
    • EvaporatedWater
    • ExclusiveUses
    • Executives - The number of executives.
    • ExistenceLimitPeriod
    • ExpenditureQuantity
    • Expense
    • ExtendedTerm
    • ExtraUnplannedDelivery - Non scheduled additional quantity.
    • Factor - Number by which the measured unit has to be multiplied to calculate the units used.
    • FederalMedicareOrMedicaidClaimMandate-Category1
    • FederalMedicareOrMedicaidClaimMandate-Category2
    • FederalMedicareOrMedicaidClaimMandate-Category3
    • FederalMedicareOrMedicaidClaimMandate-Category4
    • FederalMedicareOrMedicaidClaimMandate-Category5
    • FederalMedicareOrMedicaidPaymentMandate-Category1
    • FederalMedicareOrMedicaidPaymentMandate-Category2
    • FederalMedicareOrMedicaidPaymentMandate-Category3
    • FederalMedicareOrMedicaidPaymentMandate-Category4
    • FederalMedicareOrMedicaidPaymentMandate-Category5
    • FederalPensionMandate-Category1
    • FederalPensionMandate-Category2
    • FederalPensionMandate-Category3
    • FederalPensionMandate-Category4
    • FederalPensionMandate-Category5
    • FederalVotes
    • FieldWorkers
    • FileSizeAfterCompression - The size of a file after compression.
    • FileSizeBeforeCompression - The size of a file before compression.
    • FinalDeliveryQuantity - Quantity of final delivery to a respective order.
    • FinancialCoveragePeriod
    • FinancialInstitutions - The number of financial institutions.
    • FinishOffset
    • FirstQuarterNon-RecurringDemand
    • FirstQuarterNon-RecurringOrders
    • FirstQuarterRecurringDemand
    • FirstQuarterRecurringOrders
    • FlareOrFlash
    • FlatExtraPremium
    • Floors - The number of floors in a building.
    • FloorsOccupied - The number of floors occupied.
    • Forecast
    • ForecastAtComplete
    • ForecastedScannedQuantity
    • ForecastToComplete
    • ForeignRelatedEntities - The number of related entities located outside the country.
    • Foremen - Number of workers with limited supervisory responsibilities.
    • FourthQuarterNon-RecurringDemand
    • FourthQuarterNon-RecurringOrders
    • FourthQuarterRecurringDemand
    • FourthQuarterRecurringOrders
    • FreeFloat-InCalendarUnits
    • FreeFloatTime - Quantity representing the free float time.
    • FreeGoodsQuantity - Quantity Of Goods Which Are Free Of Charge.
    • FreelanceDebtCollectors - Number of debt collectors who work on a freelance basis.
    • FreelanceSalespersons - Number of salespersons who work on a freelance basis.
    • FreeQuantityIncluded - Quantity Included To Which No Charge Is Applicable.
    • FreeQuantityNotIncluded - Free Quantity Not Included In Ordered Quantity.
    • Frequency
    • Fuel
    • FuelConsumedOrBurnedAmount
    • FuelPumps - Number of fuel pumps.
    • FullBaths
    • FunctionalGroups
    • FunctionalSampleQuantity - The Quantity Defined Is A Sample For The Purpose Of Validating Function And Performance.
    • FurnishedBloodUnits
    • GarageOrCarportArea
    • GasInjectionVolume
    • GasLiftVolume
    • GasReceiptVolume
    • GasReturnedToEarth
    • GasReturnedToPropertyForFuel
    • GasShrinkage
    • GasSold
    • GasUsedForDrilling
    • GasUsedForFuelSystem
    • GasUsedForPlantFuel
    • GasUsedForRepressuringOrPressureMaintenance
    • GasUsedOnProperty
    • GasVented
    • GasVolume
    • GeneralEliminationPeriod
    • GovernmentReportingQuantity
    • GradeTransferAmount
    • GrossAnnualIncomeMultiplier
    • GrossBuildingArea
    • GrossEstimate
    • GrossLivingArea
    • GrossLivingFinishedAreaAboveGrade
    • GrossProduction
    • GrossRentMultiplier
    • GroupEmployees - The number of employees within the group.
    • GuaranteeFeeBuyupMaximum
    • GuaranteeFeeRateAfterAlternatePaymentMethod
    • GuaranteeFeeRateAfterBuyupOrBuydown
    • GuaranteePeriod
    • Height
    • HighFabricationAuthorizationQuantity
    • HighRawMaterialAuthorizationQuantity
    • HoldingPeriod
    • Hours
    • HoursFlown-AircraftOrTypeFlying
    • HoursFlown-AircraftTypeOrLife
    • HoursFlown-AircraftTypeOrPeriod
    • HoursFlown-Lifetime
    • HoursFlown-TypeFlying
    • ImpairmentDuration
    • ImpairmentFrequency
    • IncrementalOrderQuantity - The incremental quantity by which ordering is carried out.
    • IndirectEmployees - The number of employees not associated with direct production.
    • IndustryBusinessFailureIncidences - Number of firms in a specific industry that discontinued with a loss to creditors.
    • InformationProviderStandardizedMotorVehiclePenaltyPoints
    • InformationReadingQuantity - The value recorded or read from a measuring device (e.g. meter) for information purposes.
    • Inspectors - Number of individuals who perform inspections.
    • InstalledCapacity
    • Installers - The number of employees involved with the installation process.
    • InstallmentFrequency
    • InstallmentPayments
    • Installments
    • InsufficientFundsReturnedCheques - The number of cheques returned due to insufficient funds.
    • IntendedChangeTimePeriod
    • InterestForOverdrawnAccount - Interest for overdrawing the account.
    • InterimTermPeriod
    • IntertankTransferAmount
    • InTransitQuantity - A quantity that is en route.
    • In-Use
    • InventoryCategoryTransfer - Inventory that has been moved from one inventory category to another.
    • InventoryDiscrepancy - The difference recorded between theoretical and physical inventory.
    • InventoryMovementQuantity - To Specify The Quantity Of An Inventory Movement.
    • InventoryOnShelfWorkInProgress
    • InventoryQuantityAtSuppliersNotSubjectToInspectionByCustomer - Quantity of goods which the customer requires the supplier to have in inventory but which will not be checked by the customer.
    • InventoryQuantityAtSuppliersSubjectToInspectionByCustomer - Quantity of goods which the customer requires the supplier to have in inventory and which may be inspected by the customer if desired.
    • InventoryWithdrawalQuantity - Quantity Which Has Been Withdrawn From Inventory Since The Last Inventory Report.
    • InvoicedQuantity - The quantity as per invoice.
    • Invoices - The number of invoices.
    • InvolvementPeriod
    • IssuedShares - The number of shares actually issued.
    • JailSentenceDuration
    • JudgementsRegistered - The number of judgements registered against an entity.
    • Judgments
    • JudicialStayDuration
    • Laborers
    • LabourHours - Number Of Labour Hours.
    • LagTime - Quantity representing lag time.
    • LandHolding
    • LandSize
    • Lanes
    • Late
    • LatePaymentPeriod
    • LatestCumulativeQuantity - Cumulative quantity after complete delivery of all scheduled quantities of the product.
    • LawSuits - The number of law suits.
    • LeadTime - Quantity representing lead time.
    • LeasePeriods
    • LengthOfResidency
    • LevelResource-Quantity
    • LevelResourceTaskQuantity - Quantity Of A Resource That Is Level For The Duration Of The Task.
    • LevelsOccupied
    • LicenseWithdrawalDuration
    • LicenseWithdrawalsSent
    • Liens
    • LiensRegistered - The number of liens registered against an entity.
    • LifetimeCapacityOfTooling - Maximum Production Output Of The Referenced Tool Over Its Productive Lifetime.
    • Life-TimeReserve-Actual
    • LifetimeReserveDays-AppliedToThisClaim
    • Life-TimeReserve-Estimated
    • LimitedQuantity
    • LineItemsCompletedDelinquent-BuyingPartyCaused
    • LineItemsCompletedDelinquent-ContractorCaused
    • LineItemsCompletedDelinquent-UnknownCauses
    • LineThreadQuantity
    • LiquidInjectionVolume
    • Livestock - The number of animals kept for use or profit.
    • LoanRate
    • LoanRepaymentTotal
    • LossAllowance
    • LossOrGain
    • LostGas
    • LostGoods - Quantity of goods that disappeared in transport.
    • LostOil
    • LostWorkTimeActual
    • LostWorkTimeEstimated
    • LotSize
    • Machines - Number of machines.
    • MaintenanceUnits
    • Manufactured
    • ManufacturedUnits - The number of units manufactured.
    • MarineRadios
    • MarketPriceChange
    • MatchingEquipment
    • MaterialOn-BoardQuantityPriorToLoading - The material in vessel tanks, void spaces, and pipelines prior to loading.
    • Maximum
    • MaximumAge
    • MaximumBenefitPeriod
    • MaximumBenefitPeriod-Accident
    • MaximumBenefitPeriodAccidentToAge
    • MaximumBenefitPeriod-Sickness
    • MaximumBenefitPeriodSicknessToAge
    • MaximumCriminalSentenceDuration
    • MaximumDeliveryBatch
    • MaximumForecastQuantity
    • MaximumInventory - Maximum stock quantity on which replenishment is based.
    • MaximumMaturityExtension
    • MaximumNumberOfEmployees - The maximum number of people employed.
    • MaximumNumberOfEmployeesAtLocation - The maximum number of people employed at a location.
    • MaximumNumberOfPurchaseOrdersAllowed - Maximum number of purchase orders that are allowed.
    • MaximumNumberOfShipmentsAllowed
    • MaximumOrderQuantity
    • MaximumProductionBatch - The Quantity Specified Is The Maximum Output From A Single Production Run.
    • MaximumQuantityToWhichTaxRateApplies
    • MaximumRequestableQuantity - The Maximum Quantity Which May Be Requested.
    • MaximumShipQuantity
    • MaximumStackability - The Number Of Pallets/Handling Units Which Can Be Safely Stacked One On Top Of Another.
    • MaximumStockLevel
    • MaximumSupplyQuantitySupplierEndorsed - Maximum supply quantity endorsed by a supplier.
    • MaximumTransfer
    • Mechanics - Number of mechanics.
    • MedicationDuration
    • MembersInGroup - The number of members within a group.
    • Messengers - Number of messengers.
    • MeterReading - The Numeric Value Of Measure Units Counted By A Meter.
    • Miles
    • MilitarySalesQuantity - Quantity of goods or services sold to a military organization.
    • MillionDollarRoundtableCredits
    • Minimum
    • MinimumAge
    • MinimumAverageTimeRequirementUnits
    • MinimumContractQuantity
    • MinimumCriminalSentenceDuration
    • MinimumDeliveryBatch
    • MinimumEmployeesAtLocation
    • MinimumFabricationQuantity
    • MinimumForecastQuantity
    • MinimumInventory - Minimum stock quantity on which replenishment is based.
    • MinimumNumberOfEmployees - The minimum number of people employed.
    • MinimumOrderPackageLevel
    • MinimumOrderQuantity
    • MinimumProductionBatch - The Quantity Specified Is The Minimum Output From A Single Production Run.
    • MinimumQuantityToWhichTaxRateApplies
    • MinimumRequestableQuantity - The Minimum Quantity Which May Be Requested.
    • MinimumShipQuantity
    • MinimumStockLevel
    • MinimumTransfer
    • MiscellaneousAllowance
    • MobileLoadingAllocation
    • ModelOrTargetStock - The stock quantity required or planned to have on hand, undamaged and available for use.
    • Month
    • MortgagePoolCount
    • MostLikelyDuration
    • NationalBusinessFailureIncidences - Number of firms in a country that discontinued with a loss to creditors.
    • Net
    • NetQuantityDecrease
    • NetQuantityIncrease
    • NetToPayItemCount.
    • NoDeliveryRequirementInThisInstruction - This Delivery Instruction Does Not Contain Any Delivery Requirements.
    • Non-BillableQuantity
    • NoncommittedInventoryOnShelf
    • NonconformanceQuantity
    • Non-ConsolidatedTotal-DomesticSubsidiaries
    • Non-ConsolidatedTotal-ForeignSubsidiaries
    • Noncovered-Actual
    • Non-Covered-Estimated
    • Non-DomesticStockholders
    • NonexclusiveUses
    • Non-UnionEmployees - The number of employees not belonging to a labour union.
    • Non-UrgentDeliveryQuantity
    • NormalDelivery - Quantity normally delivered by the seller.
    • NormalReadingQuantity - The value recorded or read from a measuring device (e.g. meter) in the normal conditions.
    • NotReplacedBloodUnits
    • NoVotes
    • NumberOfAccountsPastDue
    • NumberOfActiveAccountsThisCycle
    • NumberOfAddedLocations - Number of locations that were added.
    • NumberOfAdjustmentPeriods
    • NumberOfAttacksOrOccurrences
    • NumberOfBatches
    • NumberOfBorrowers
    • NumberOfCardsNotReceived
    • NumberOfCardsOutstanding
    • NumberOfChecks
    • NumberOfClaimants
    • NumberOfClosedLocations - Number of locations that were closed.
    • NumberOfCo-InsuranceDays
    • NumberOfCopiesOfBillOfLading
    • NumberOfCrew - Total number of crew members on the conveyance.
    • NumberOfDaysCoveredByInventory
    • NumberOfDead
    • NumberOfDelinquentInstallments
    • NumberOfDeliveriesPerDespatchPeriod - The Number Of Deliveries Normally Expected To Be Despatched Within Each Despatch Period.
    • NumberOfDependents
    • NumberOfEndUsers
    • NumberOfEntitledExemptions
    • NumberOfFailedBusinessesOfDirectors - The number of failed businesses with which the directors have been associated.
    • NumberOfFranchisees
    • NumberOfFull-TimeEmployees
    • NumberOfHospitals
    • NumberOfIdenticalHandlingUnits - Number Of Identical Handling Units In Terms Of Type And Contents.
    • NumberOfInsuredLives
    • NumberOfInterestPayments
    • NumberOfIrregularInterestPayments
    • NumberOfItemsAuthorizedAtStore
    • NumberOfItemsAuthorizedAtWarehouse
    • NumberOfItemsInStock
    • NumberOfLateCharges
    • NumberOfLevels
    • NumberOfLimitedPartnershipShares - Number of shares held in a limited partnership.
    • NumberOfLiving
    • NumberOfLoans
    • NumberOfLostCards
    • NumberOfMembers
    • NumberOfMessageRecipients
    • NumberOfMonths - The number of months.
    • NumberOfMortgagors
    • NumberOfMoulds - The Number Of Pressing Moulds Contained Within A Single Piece Of The Referenced Tooling.
    • NumberOfNon-CoveredDays
    • NumberOfNonsufficientFundItems
    • NumberOfOpenAccounts
    • NumberOfOperatingPeriodsAtFailure
    • NumberOfOperatorCredits
    • NumberOfOriginals
    • NumberOfPackagesInHandlingUnit - The Number Of Packages Contained In One Handling Unit.
    • NumberOfPassengers - Total number of passengers on the conveyance.
    • NumberOfPatientAdmissions
    • NumberOfPeopleLivingAtResidence
    • NumberOfPhysicians
    • NumberOfProducingWellsRemainingOnPropertyOrFacility
    • NumberOfProducingWellsRemainingOnRoyaltyAccount
    • NumberOfQuantitativeIncentiveSchemeUnits - Number of units allocated to a quantitative incentive scheme.
    • NumberOfServicesOrProcedures
    • NumberOfShelfFacings
    • NumberOfShelfTags
    • NumberOfSignedBillsOfLading
    • NumberOfStations
    • NumberOfStolenCards
    • NumberOfStops - Number Of Times A Means Of Transport Stops Before Arriving At Destination.
    • NumberOfTheatres
    • NumberOfTimes
    • NumberOfTimesDeported
    • NumberOfTransportDocuments - Total number of air waybills, bills of lading, etc. being reported for a specific conveyance.
    • NumberOfUnits - The quantity of units.
    • NumberOfUnits-Housing
    • NumberOfUnitsInTheDepthOfALayer - Number of units which make up the depth of a layer.
    • NumberOfUnitsInTheWidthOfALayer - Number of units which make up the width of a layer.
    • NumberOfUnsignedBillsOfLading
    • NumberOfWithholdingExemptions
    • NumbersOfConsumerUnitsInTheTradedUnit
    • NumberWeeksPaid
    • Nurses - The number of nurses.
    • OemInventory
    • OfficeSize
    • OfficeWorkers - The number of workers in an office.
    • OffLeaseFuel
    • OffPremiseSalesQuantity
    • OffPremisesSales - Sale of product directly to a store.
    • OilCondensateSold
    • OilCondensateUsedOnProperty
    • OilOrCondensateVolume
    • OilSedimentation
    • OilTheft
    • OnHandAndDue-In
    • OnHoldForShipment - Article received which cannot be shipped in its present form.
    • OnOrderQuantity
    • OnPremiseSalesQuantity
    • OnPremisesSales - Sale of product in restaurants or bars.
    • OpeningStatementBalance
    • OpeningStockBalanceQuantity - To Specify The Quantity Of An Opening Stock Balance.
    • OpenQuantity - Quantity remaining after partial delivery.
    • OperatingBeds
    • OperatingDivisions - Number of divisions operating.
    • OperatingQuantity
    • Operators - Number of operators.
    • OperatorsWorkingInterest
    • OptimalQuantity - The optimal quantity for a given purpose.
    • OptimisticDuration
    • OrderCount
    • OrderedQuantity - The quantity which has been ordered.
    • OrderQuantityMultiple
    • Original
    • OriginalDuration - Quantity representing the original duration.
    • OriginalLoanTerm
    • OriginalPaymentItemCount.
    • OriginalQuantity
    • OriginalTermInYears
    • OtherEmployees - The number of employees otherwise categorised.
    • OtherGasDisposition
    • OtherInjectionVolume
    • OtherMiscellaneousDisposition
    • OtherOilCondensateDisposition
    • OtherUnlistedParticipants
    • OtherUnlistedStockholders
    • OtherWarReserveMaterialRequirementsProtectableQuantity
    • OtherWaterDisposition
    • OutlierDays
    • OutOfInventoryQuantity - Quantity Of Inventory Which Was Requested But Was Not Available.
    • OutstandingQuantity - Difference between quantity ordered and quantity received.
    • OutstandingShares
    • Out-TurnedQuantity - The quantity discharged.
    • Overage
    • OverflowQuantity
    • OverShipped - Indication that more goods have been shipped than contracted for delivery.
    • Owner
    • OwnersEquity
    • OwnershipChangeAge
    • OwnershipDuration
    • OwnershipPercentage
    • OwnOccupationQualificationPeriod
    • Pagers
    • Paid
    • Paid-InCommonShares - The number of paid-in common shares.
    • Paid-InPreferredShares - The number of paid-in preferred shares.
    • Paid-InSecurityShares - The number of security shares issued and for which full payment has been made.
    • ParkingSpaces
    • PartialBaths
    • ParticipantTotal
    • ParticipationShares
    • Partners
    • PartTimeEmployees - The number of employees working on a part time basis.
    • PastDueQuantity
    • Patients - Number of patients.
    • PaymentCancellationItemCount
    • PaymentDurationWeeks
    • PaymentExperiencesInTheLast12Months - The number of payment experiences received for an entity over the last 12 months.
    • PaymentExperiencesInTheLast3Months - The number of payment experiences received for an entity over the last 3 months.
    • PaymentFrequency
    • PaymentOrdersFiled - Number of payment orders filed.
    • PaymentsNumber
    • PercentageOfOrderedQuantity
    • PeriodicCapacityOfTooling - Maximum Production Output Of The Referenced Tool Over A Period Of Time.
    • PeriodOfEmployment
    • PeriodQuantityMeasured - Surveyed quantity reached during this period.
    • PeriodQuantityPlanned - Quantity planned for this period.
    • PeriodQuantityReached - Quantity reached during this period.
    • Persistency
    • PessimisticDuration
    • PetitionsFiled - Number of petitions that have been filed.
    • PhysicalStatusIii
    • PhysicalStatusIv
    • PhysicalStatusV
    • Physicians - The number of medical doctors.
    • PictureCount
    • PiecesDelivered - Number of pieces actually received at the final destination.
    • PilferageGoods - Quantity of goods stolen during transport.
    • Pilots - The number of pilots.
    • PipelineAdjustmentOrAllowance
    • Pipes - The number of tubes used to convey a substance.
    • PittedWater
    • PlacementPeriodExpiration
    • PlannedUnitDevelopmentUnits
    • PlantSize
    • PlantWorkers - The number of workers within a plant.
    • PlatformCount
    • PortableRadios
    • PortedTelephoneLines
    • Post-OpDays
    • Poultry - The number of domestic fowl.
    • PredominateAge
    • Pre-OpDays
    • PrepaidQuantityNotShipped
    • PrepaidQuantityShipped
    • Pre-ProductionQuantity - Quantity Of The Referenced Item Required Prior To Full Production.
    • Prescription
    • PrescriptionDosage
    • PrescriptionEffectivePeriod
    • PrescriptionFrequency
    • PresidentialVotes
    • PressureBase
    • PreviousBenefits
    • PreviousCumulativeQuantity - Cumulative quantity prior the actual order.
    • PreviousHighestCumulativeQuantity - Cumulative quantity after complete delivery of all scheduled quantities of the product from a prior schedule period.
    • PreviouslyAmortisedQuantity - The Cumulative Quantity Of The Referenced Item Which Had A Cost For Tooling Amortisation Included In The Item Price.
    • PreviousMonthsUsage
    • PreviousNumberOfAccounts - The number of accounts which preceded the current count.
    • PreviousNumberOfBranchLocations - The number of branch locations which preceded the current count.
    • PreviousNumberOfEmployees - The number of employees for a previous period.
    • PreviousOrderQuantityToBeCancelled
    • PreviousQuantity - Quantity previously referenced.
    • PreviousWeekQuantity
    • PriceBreakFrom - The minimum quantity of a quantity range for a specified (unit) price.
    • PriceBreakTo - Description to be provided.
    • PricingUnitPerBillingUnit
    • PrimaryManagers - Number of primary managers.
    • PrimaryMeterReadingValue
    • PrimaryNetQuantity
    • PrincipalsIncludedAsEmployees - The number of principals which are included in the count of employees.
    • PriorCumulativeImbalance
    • PriorUnitsAccepted
    • ProbationDuration
    • ProducingWells
    • ProductExchangeAmount
    • ProductionRequirements - Quantity needed to meet production requirements.
    • ProductionWorkers - Number of employees engaged in production.
    • ProductSalesAmount
    • Professionals - Number of professionals.
    • Professor - The number of professors.
    • ProjectedAvailableInventory
    • ProjectPhases
    • ProjectsInProcess - Number of projects in process.
    • ProjectUnitsSold
    • Promoters - Number of entities who finance or organize an event or a production.
    • PromotionQuantity - A quantity associated with a promotional event.
    • ProtestedBills - The number of bills which are protested.
    • ProvidedQuantity - The Quantity Of A Referenced Component Supplied By The Buyer For Manufacturing Of An Ordered Item.
    • PublicationTurnSize - The Quantity Of Magazines Or Newspapers Grouped Together With The Spine Facing Alternate Directions In A Bundle.
    • PurchaseOfProduct
    • QualificationPeriod
    • QualifyingWeeks
    • QualityControlFailed - Quantity of goods which have failed quality control.
    • QualityControlHeld - Quantity of goods held pending completion of a quality control assessment.
    • QuantitativeIncentiveSchemeBase - Quantity constituting the base for the quantitative incentive scheme.
    • QuantityAdvised - Quantity advised by supplier or shipper, in contrast to quantity actually received.
    • QuantityApproved
    • QuantityAt100Pct - Equivalent quantity at 100% purity.
    • QuantityAvailableForReturn
    • QuantityAvailableForSale-StockQuantity
    • QuantityAvailableOnShelf
    • QuantityAwaitingDelivery - Quantity of goods which are awaiting delivery.
    • QuantityByPosition
    • QuantityCancelled
    • QuantityCarriedForward
    • QuantityDeferred
    • QuantityDelivered
    • QuantityDisapproved
    • QuantityDispensed
    • QuantityDisplayedNotAvailableForSale - Quantity displayed within a retail outlet but not available for sale.
    • QuantityEarned
    • QuantityHeldByDeliveryVehicle - Quantity of goods held by the delivery vehicle.
    • QuantityHeldByLogisticServiceProvider - Quantity of goods under the control of a logistic service provider.
    • QuantityHeldByRetailOutlet - Quantity held by the retail outlet.
    • QuantityInFloat
    • QuantityInHoldOut
    • QuantityInManufacturingProcess - Quantity currently in the manufacturing process.
    • QuantityInPhysicalInventory - A quantity of goods held in physical inventory.
    • QuantityInQuarantine - A quantity of goods which are held in a restricted area for quarantine purposes.
    • QuantityInTransit - Quantity Which Is Currently In Transit.
    • QuantityLanded - Quantity of goods actually arrived.
    • QuantityLoaded - Quantity of goods loaded onto a means of transport.
    • QuantityManifested - Quantity of goods contracted for delivery by the carrier.
    • QuantityNotAvailableForDespatch - A quantity of goods not available for despatch.
    • QuantityOfDealerLicensePlates
    • QuantityOfMaterialInOrderedTime - Quantity Of The Referenced Material Within The Ordered Time.
    • QuantityOnHand - The total quantity of a product on hand at a location. This includes as well units awaiting return to manufacturer, units unavailable due to inspection procedures and undamaged stock available for despatch, resale or use.
    • QuantityOnHold
    • QuantityPerNextHigherAssembly - To Indicate The Quantity Required For The Next Higher Assembly.
    • QuantityPerPack
    • QuantityPerSkid
    • QuantityPerUnitOfIssue - Provides The Standard Quantity Of An Article In Which One Unit Can Be Issued.
    • QuantityReceived
    • QuantityRemaining - Quantity remaining.
    • QuantityRequirementForMaintenanceAndRepairOf - Equipment Quantity Of The Material Needed To Maintain And Repair Equipment.
    • QuantityRequirementForSampleInspection
    • QuantityRequiringManipulationBeforeDespatch - A quantity of goods which needs manipulation before despatch.
    • QuantityReturnedDefectiveOrDamaged - Quantity Returned In A Damaged Or Defective Condition.
    • QuantityScheduled - The Quantity Scheduled For Delivery.
    • QuantityServiced
    • QuantitySold
    • QuantitySoldNet - Net Quantity Sold Which Includes Returns Of Saleable Inventory And Other Adjustments.
    • QuantitySuspended - The quantity of something which is suspended.
    • QuantityToBeDelivered - The quantity to be delivered.
    • QuantityUsed
    • QuantityWithdrawn - Quantity withdrawn from a location.
    • QuantityWithheldByOwnerOfGoods - A quantity of goods which has been withheld by the owner of the goods.
    • QuoteQuantityOnInventory
    • RangeAverage
    • RangeMaximum
    • RangeMinimum
    • RatePerDay
    • Receipts
    • ReceivedAndAccepted - Quantity Which Has Been Received And Accepted At A Given Location.
    • ReceivedNotAcceptedToBeDestroyed - Quantity Which Has Been Received But Not Accepted At A Given Location And Which Will Consequently Be Destroyed.
    • ReceivedNotAcceptedToBeReturned - Quantity Which Has Been Received But Not Accepted At A Given Location And Which Will Consequently Be Returned To The Relevant Party.
    • ReceivedQuantity - The quantity which has been received.
    • RecommendedMaintenanceQuantity - Recommended Quantity Of An Article Which Is Required To Meet An Agreed Level Of Maintenance.
    • RecommendedOverhaulAndRepairQuantity - To Indicate The Recommended Quantity Of An Article Required To Support Overhaul And Repair Activities.
    • ReconsiderationPeriod
    • RedeliveryAfterPostProcessing
    • RefillsAuthorized
    • RegisteredBrandsDistributed - The number of registered brands which are being distributed.
    • RegisteredBrandsManufactured - The number of registered brands which are being manufactured.
    • RejectedQuantity - The Quantity Of Received Goods Rejected For Quantity Reasons.
    • RejectedReturnQuantity - A quantity for return which has been rejected.
    • RelatedBusinessEntities - The number of related business entities.
    • RelatedEntities
    • RelationshipDuration
    • RelativesEmployed - The number of relatives which are counted as employees.
    • RemainingAuthorizedQuantity
    • RemainingDuration - Quantity representing the remaining duration.
    • RemainingQuantity
    • ReorderingLevel - Quantity At Which An Order May Be Triggered To Replenish.
    • ReorderPointQuantity
    • ReplacedAmount
    • ReplacedBloodUnits
    • ReplenishmentOverrideQuantity - Quantity To Override The Normal Replenishment Model Calculations, But Not Intended To Permanently Change The Model Parameters.
    • ReplenishmentQuantity - Quantity Required To Maintain The Requisite On-Hand Stock Of Goods.
    • ReportDifference - The quantity concerning the same transaction differs between two documents/messages and the source of this difference is a typing error.
    • ReportedDeficiencies
    • Reports
    • RequestedAmount
    • RequirementQuantity
    • RequirementQuantityThatWasPreviouslyReleased
    • RequisitioningObjective
    • ReservedQuantity - Quantity reserved for specific purposes.
    • ReservedQuantityCustomerDirectDeliverySales - Quantity of products reserved for sales delivered direct to the customer.
    • ReservedQuantityRetailSales - Quantity of products reserved for retail sales.
    • ResidenceDuration
    • Resource-Quantity-Available
    • RestingQuantity - A quantity of product that is at rest before it can be used.
    • RestrictionDuration
    • RetailSales - Quantity of retail point of sale activity.
    • RetentionQuantity
    • ReturnedByConsumerQuantity - Quantity Returned By A Consumer.
    • ReturnQuantity
    • ReturnsReplacementQuantity - A quantity of goods issued as a replacement for a returned quantity.
    • RoomCount
    • Rooms - The number of rooms.
    • RoomsFinishedAreaAboveGrade
    • Royalty
    • SafetyLevel
    • Salespersons - The number of salespersons.
    • SalesQuantityNotIncludedInTheReplenishmentCalculation - Sales which will not be included in the calculation of replenishment requirements.
    • SalesQuantityPlanned - Quantity Of Goods Required To Meet Future Demands. - Market Intelligence Quantity.
    • SampleAmount
    • ScatteredVotes
    • ScheduleVariance
    • ScrapAllowed
    • ScrapQuantity - Remainder of the total quantity after split deliveries.
    • Seats - The number of seats.
    • SecondaryNetQuantity
    • SecondQuarterNon-RecurringDemand
    • SecondQuarterNon-RecurringOrders
    • SecondQuarterRecurringDemand
    • SecondQuarterRecurringOrders
    • Secretaries - Number of secretaries.
    • SecuredChargesRegistered - The number of secured charges registered against an entity.
    • SecuritiesShares - Number of shares of securities.
    • Segments
    • Seller - The number of sellers.
    • ServiceResale
    • Shareholders - The number of shareholders.
    • ShareholdersHoldingRemainderOfShares - Number of shareholders owning the remainder of shares.
    • Shares
    • SharesAdded
    • SharesDeleted
    • SharesHeldAsTreasuryStock
    • SharesOfCommonStock - The number of shares of common stock.
    • SharesOfPreferredStock - The number of shares of preferred stock.
    • SharesOwnedByIn-StateResidents
    • SharesOwnedByOut-Of-StateResidents
    • SharesSubscribed
    • SharesSubscribedButNotIssued
    • Shifts
    • Shipments
    • ShipNoticeQuantity
    • ShippedQuantity
    • Shortage
    • Short-LandedGoods - If quantity of goods actually landed is less than the quantity which appears in the documentation. This quantity is the difference between these quantities.
    • ShortShipped - Indication that part of the consignment was not shipped.
    • SilentPartners - The number of silent partners.
    • SinceLastTravel
    • SingleDeliveryQuantity - The Quantity Required By The Buyer To Be Delivered In A Single Shipment.
    • SistersDeceased
    • SistersLiving
    • Site
    • SizeOfHousehold
    • SkilledWorker - The number of skilled workers.
    • SmallBusinessUses
    • Solicited
    • SortedQuantity - Description to be provided.
    • SortedQuantityRejected - Description to be provided.
    • SpaceOccupied
    • SpecialPartners
    • SpeedCapacity
    • SplitQuantity - Part of the whole quantity.
    • SplitShipment - Indication that the consignment has been split into two or more shipments.
    • Standard
    • Started
    • StartOffset
    • StartQuantity - The quantity recorded at the start of an agreement or period.
    • StateOrProvinceMotorVehiclePenaltyPoints
    • StatisticalSalesQuantity - Quantity of goods sold in a specified period.
    • StockTransfersIn
    • StockTransfersOut
    • StolenCheques - The number of stolen cheques.
    • SubcontractorAtComplete
    • SubcontractorCumulativeToDate
    • Subcontractors - The number of subcontractors.
    • SubmittedQuantityReturned
    • SubmittedQuantitySold
    • SubsequentDeliveryQuantity - Quantity delivered to a respective order after it's final delivery.
    • Subsidiaries - The number of subsidiaries.
    • SubstitutionalQuantity - Quantity delivered replacing previous deliveries.
    • Suits
    • Supervisors - Number of supervisors.
    • SuppliedQuantity - Quantity Of The Referenced Item Actually Shipped.
    • SupplierEstimatedLatestMeterReading - Latest meter reading estimated by the supplier.
    • SupplierEstimatedPreviousMeterReading - Previous meter reading estimated by the supplier.
    • SupplierLatestMeterReading - Latest meter reading recorded by the supplier.
    • SupplierPreviousMeterReading - Previous meter reading done by the supplier.
    • Suppliers - The number of suppliers.
    • SuppliersCredit
    • SurplusGoods - If quantity of goods actually landed is more than the quantity which appears in the documentation. This quantity is the difference between these quantities.
    • SurveysInAverageRating
    • SuspendedDuration
    • Swan-Ganz
    • TablesAvailable - Number of tables available for use.
    • TalkPaths
    • TankAllowance
    • TariffLossAllowance
    • TaxableQuantity - Quantity Subject To Taxation.
    • Teachers - The number of teachers.
    • Technicians - The number of technicians.
    • TheoreticalQuantity
    • ThirdQuarterNon-RecurringDemand
    • ThirdQuarterNon-RecurringOrders
    • ThirdQuarterRecurringDemand
    • ThirdQuarterRecurringOrders
    • TimeExpended
    • TimeFrame
    • TimeInCountry
    • TimeInPosition
    • TimeSinceHospitalization
    • TimeSinceLastApplication
    • TimeSinceLastCivilianFlight
    • TimeSinceLastInsuranceMedical
    • TimeSinceLastMilitaryFlight
    • TimeSinceMedicalConsult
    • TimeSinceMedicationEnd
    • TimeSinceMedicationStart
    • TimeSinceOnset
    • TimeSinceSurgery
    • TimeSinceTrip
    • TimeUnits
    • TimeUnitsKnown
    • TimeUnitsPerShift
    • TimeUnitsSpentOnDuty
    • Tires
    • ToCompleteQuantityEstimated - The estimated quantity required to complete a project.
    • Tolerance - Plus or minus tolerance expressed as a monetary amount.
    • Total
    • TotalAdjustmentsVolume
    • TotalAmortisationQuantity - The Total Quantity Of The Referenced Item Which Has A Cost For Tooling Amortisation Included In The Item Price.
    • TotalAtComplete
    • TotalAuthorizedQuantity
    • TotalBeginningInventory
    • TotalClaimsAssociatedWithRepeatedTrauma
    • TotalClaimsWithDaysAwayFromWork
    • TotalClaimsWithDisordersDueToPhysicalAgents
    • TotalClaimsWithDustDiseasesOfTheLungs
    • TotalClaimsWithoutDaysAwayFromWorkAndWithoutRestrictedWorkActivity
    • TotalClaimsWithPoisoningIllnesses
    • TotalClaimsWithRespiratoryConditionsDueToToxicAgents
    • TotalClaimsWithSkinDiseasesOrDisorders
    • TotalConsolidatedDomesticSubsidiaries
    • TotalConsolidatedForeignSubsidiaries
    • TotalConsolidatedSubsidiaries
    • TotalCredits
    • TotalCreditsAccepted
    • TotalCreditsReceived
    • TotalCreditsRejected
    • TotalDaysAwayFromWork
    • TotalDaysAwayFromWorkDueToIllness
    • TotalDaysAwayFromWorkDueToInjury
    • TotalDaysOfRestrictedWorkActivity
    • TotalDaysOfRestrictedWorkActivityDueToIllness
    • TotalDaysOnMarket
    • TotalDaysWithRestrictedWorkActivityDueToInjury
    • TotalDeathClaims
    • TotalDeathsAsAResultOfIllness
    • TotalDeathsAsAResultOfInjury
    • TotalDebits
    • TotalDebitsAccepted
    • TotalDebitsReceived
    • TotalDebitsRejected
    • TotalDeliveryQuantity - The Total Quantity Required By The Buyer To Be Delivered.
    • TotalDemandOrders
    • TotalDemandQuantity
    • TotalEmployees - The total number of employees.
    • TotalEndingInventory
    • TotalFloatTime - Quantity representing the total float time.
    • TotalGasDisposition
    • TotalGasInjectionVolume
    • TotalIllnessClaimsWithDaysAwayFromWork
    • TotalIllnessClaimsWithOccupationalIllnessesNotOtherwiseClassified
    • TotalIllnessClaimsWithoutLostWorkDays
    • TotalIllnessWithLostWorkDaysOrRestrictedWorkActivity
    • TotalInjuryClaimsWithDaysAwayFromWork
    • TotalInjuryClaimsWithDaysAwayFromWorkOrRestrictedWorkActivity
    • TotalInjuryClaimsWithoutLostWorkDays
    • TotalInventory
    • TotalNon-ConsolidatedSubsidiaries
    • TotalNumberOfConvictions
    • TotalNumberOfDomesticSubsidiariesIncludedInFinancial - statement The total number of domestic subsidiaries included in the financial statement.
    • TotalNumberOfDomesticSubsidiariesNotIncludedIn - financial statement The total number of domestic subsidiaries not included in the financial statement.
    • TotalNumberOfForeignSubsidiariesIncludedInFinancial - statement The total number of foreign subsidiaries included in the financial statement.
    • TotalNumberOfForeignSubsidiariesNotIncludedIn - financial statement The total number of foreign subsidiaries not included in the financial statement.
    • TotalNumberOfLoanDetailRecords
    • TotalNumberOfMortgagees
    • TotalNumberOfParkingSpaces
    • TotalNumberOfSubsidiariesNotIncludedInTheFinancial - statement The total number of subsidiaries not included in the financial statement.
    • TotalNumberOfUnits
    • TotalNumberOfUnitsForSale
    • TotalNumberOfWorkersCompensationCombinedReports
    • TotalNumberOfWorkersCompensationFirstReports
    • TotalNumberOfWorkersCompensationSubsequentReports
    • TotalOfIssuableAssets
    • TotalOilAndOrCondensateDisposition
    • TotalOilAndOrCondensateInjectionVolume
    • TotalOtherPropertiesOwnedAndFinanced
    • TotalPaymentsRejected
    • TotalPost-AdvicesAccepted
    • TotalPost-AdvicesReceived
    • TotalPost-AdvicesRejected
    • TotalPre-AdvicesAccepted
    • TotalPre-AdvicesReceived
    • TotalPre-AdvicesRejected
    • TotalPrenotesAccepted
    • TotalPrenotesReceived
    • TotalPrenotesRejected
    • TotalProductionVolume
    • TotalPropertiesOwned - The total number of properties owned by an entity.
    • TotalQuantityPlanned - Total quantity planned.
    • TotalResource-Quantity
    • TotalRooms
    • TotalSales - The summation of total quantity sales.
    • TotalServiceBackorderQuantityHighPriority
    • TotalServiceBackorderQuantityLowPriority
    • TotalSharesOfStock
    • TotalSystemBackorderQuantityHighPriority
    • TotalSystemBackorderQuantityLowPriority
    • TotalToDate
    • TotalTransactions - The total number of transactions.
    • TotalUnidentifiedTransactionsRejected
    • TotalWaterDisposition
    • TotalWaterInjectionVolume
    • TotalWorkedByAllEmployees
    • TotalWorkingInterest
    • TrademarkRepresented - The number of trademarks represented.
    • TrademarksUsed - Number of trademarks used.
    • Trainees - The number of trainees.
    • Trainers - Number of trainers.
    • TransactionSets
    • TransferQuantity
    • TransferredInQuantity - Quantity Which Was Transferred Into This Location.
    • TransferredOutQuantity - Quantity Which Was Transferred Out Of This Location.
    • TravelFrequency
    • TravellingEmployees - Number of travelling employees.
    • TravelPeriod
    • TripDuration
    • Trips
    • TrunkedChannels
    • UnacknowledgedQuantity
    • UnadjustedCorrectorReading - A corrector reading before it has been adjusted.
    • UncoveredCheques - Number of uncovered cheques.
    • UniformCommercialCodeFilings
    • UnionEmployees - The number of employees who are members of a labour union.
    • Units
    • UnitsCompleted
    • UnitsForSale
    • UnitsPerUnitPrice - Number of units per unit price.
    • UnitsProduced - The number of units produced.
    • UnitsRented
    • UnitsWorkedLastDay
    • UnitsWorkedPerDay
    • UnitsWorkedPerQuarter
    • UnitsWorkedPerWeek
    • Unpaid
    • UnsaleableQuantity - Quantity Of Inventory Received Which Cannot Be Sold In Its Present Condition.
    • UnsoldQuantityHeldByWholesaler - Unsold quantity held by the wholesaler.
    • UntilNextTravel
    • UnusableQuantity
    • UnusedAccumulatedSickDays
    • UnverifiedReceipts
    • UrgentDeliveryQuantity
    • Used
    • UseOfExtracorporealCirculation
    • UseOfHyperbaricPressurization
    • UseOfHypertension
    • UseOfHypotension
    • UseOfHypothermia
    • Vacancies
    • Variance
    • VarianceAdjustment
    • VehicularRadios
    • VerifiedReceipts
    • VisitationFrequency
    • Visits
    • VoiceStorageQuantity
    • VoidVotes
    • VolumeShrinkageAdjustmentOrAllowance
    • Votes
    • VotingSharesHeld
    • WarehouseEmployees - The number of employees who work in a warehouse setting.
    • WarehouseSize
    • WaterRe-InjectedOnProperty
    • WaterVolume
    • WeeksWorked
    • Weight
    • WeightChangePeriod
    • WeightGain
    • WeightLoss
    • WholesalerToWholesalerSales - Sale of product to other wholesalers by a wholesaler.
    • WideAreaTelephoneServicePer800ServiceUnits
    • WorkCalendarUnits - Work Calendar Units Of Time.
    • WorkDays - Number of work days, e.g. per respective period.
    • WorkInProcess
    • WorkPeriod
    • WorkTimeUnits - Quantity Of Work Units Of Time.
    • WorkTimeUnitsPerShift - Work Units Of Time Per Work Shift.
    • Years
    • YearsInSchool
    • YearsInThisLineOfWorkOrProfession
    • YearsOnJob
    • YearsRemaining
    • YesVotes
    • CurrentDuration - Quantity representing the current duration
    • CurrentInventoryQuantityAvailableForShipment - Current inventory quantity available for shipment
    • CurrentPeriodImbalance
    • CurrentServiceLife
    • CurrentShareBalance
    • CustomerEstimatedLatestMeterReading - Latest meter reading estimated by the customer
    • CustomerEstimatedPreviousMeterReading - Previous meter reading estimated by the customer
    • CustomerReadingQuantity - The value recorded or read from a measuring device by the customer
    • DailyAdjustments
    • DailyAverageQuantity - The Quantity For A Defined Period Divided By The Number Of Days Of The Period
    • DailyWorkShifts - Quantity Of Work Shifts Per Day
    • DamagedGoods - Quantity of goods which have deteriorated in transport such that they cannot be used for the purpose for which they were originally intended
    • DataStorageQuantity
    • Days
    • DaysOperated
    • DaysProduced
    • DaysSupply
    • DebentureBond - The number of fixed interest bonds of an entity backed by general credit rather than specified assets
    • DebenturesFiledAgainstDirectors - The number of notices of indebtedness filed against an entity's directors
    • Debited
    • DebtCollectors - Number of debt collectors.

[^]Code Fragment

    <xsd:simpleType name="QuantityQualifierCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="AcceptableUnserviceableQuantity">
        <xsd:enumeration value="Accidents">
        <xsd:enumeration value="Accounts">
        <xsd:enumeration value="AccountsPayableAverageOverdueDays">
        <xsd:enumeration value="AccountsPlacedForCollection">
        <xsd:enumeration value="AcknowledgedQuantity">
        <xsd:enumeration value="ActiveAccounts">
        <xsd:enumeration value="ActiveContractsDelinquent">
        <xsd:enumeration value="ActiveContractsDelinquent-BuyingPartyCaused">
        <xsd:enumeration value="ActiveContractsDelinquent-ContractorCaused">
        <xsd:enumeration value="ActiveContractsDelinquent-UnknownCauses">
        <xsd:enumeration value="ActiveIngredient">
        <xsd:enumeration value="ActiveIngredientDosePerUnit">
        <xsd:enumeration value="ActiveIngredientDosePerUnitDispensed">
        <xsd:enumeration value="ActiveLineItemsDelinquent">
        <xsd:enumeration value="ActiveLineItemsDelinquent-BuyingPartyCaused">
        <xsd:enumeration value="ActiveLineItemsDelinquent-ContractorCaused">
        <xsd:enumeration value="ActiveLineItemsDelinquent-UnknownCauses">
        <xsd:enumeration value="ActiveListings">
        <xsd:enumeration value="ActiveMaintenanceTime">
        <xsd:enumeration value="ActivityCodes">
        <xsd:enumeration value="Actual">
        <xsd:enumeration value="ActualDuration">
        <xsd:enumeration value="ActualHours">
        <xsd:enumeration value="ActualStock">
        <xsd:enumeration value="ActualUnits">
        <xsd:enumeration value="ActualUnitsCumulativeToDate">
        <xsd:enumeration value="AddedEmployees">
        <xsd:enumeration value="AdditionalAmount">
        <xsd:enumeration value="AdditionalDemandQuantity">
        <xsd:enumeration value="AdditionalPromotionSalesForecastQuantity">
        <xsd:enumeration value="AdditionalReplenishmentDemandQuantity">
        <xsd:enumeration value="AdditionalUsageQuantity">
        <xsd:enumeration value="AdjustedCorrectorReading">
        <xsd:enumeration value="AdjustedQuantity">
        <xsd:enumeration value="AdjustedUnits">
        <xsd:enumeration value="AdjustmentToInventoryQuantity">
        <xsd:enumeration value="Administrators">
        <xsd:enumeration value="Age">
        <xsd:enumeration value="AgeAtDeath">
        <xsd:enumeration value="AgedActiveLineItemsDelinquent-ContractorCaused">
        <xsd:enumeration value="AgedLineItemsCompleted-ContractorCaused">
        <xsd:enumeration value="AgedLineItemsDelinquent">
        <xsd:enumeration value="AgeHighValue">
        <xsd:enumeration value="AgeLowValue">
        <xsd:enumeration value="AgeModifyingUnits">
        <xsd:enumeration value="AgeNearest">
        <xsd:enumeration value="AgeNext">
        <xsd:enumeration value="Agents">
        <xsd:enumeration value="AgeOfFinancialInformation">
        <xsd:enumeration value="AggregateBenefitPeriod">
        <xsd:enumeration value="AgriculturalWorkers">
        <xsd:enumeration value="AircraftRadios">
        <xsd:enumeration value="AirlineAttendants">
        <xsd:enumeration value="AllocatedQuantity">
        <xsd:enumeration value="AllottedUsageQuantity">
        <xsd:enumeration value="Allowance">
        <xsd:enumeration value="AllTimeBuy">
        <xsd:enumeration value="AmortisationQuantity">
        <xsd:enumeration value="AmortizationCumulatedQuantity">
        <xsd:enumeration value="AmortizationOrderQuantity">
        <xsd:enumeration value="AmortizationTerm">
        <xsd:enumeration value="AmortizationTotalQuantity">
        <xsd:enumeration value="AnticipatedLengthOfService">
        <xsd:enumeration value="ApprovalOrOfferDuration">
        <xsd:enumeration value="ApprovedAmount">
        <xsd:enumeration value="ApproximateNumberOfHolders">
        <xsd:enumeration value="ApproximateNumberOfUnitsForSaleProjected">
        <xsd:enumeration value="ApproximateNumberOfUnitsProjected">
        <xsd:enumeration value="AreaDamaged">
        <xsd:enumeration value="AreaOfLevel">
        <xsd:enumeration value="AreaPerUnits">
        <xsd:enumeration value="Arrests">
        <xsd:enumeration value="AsIsQuantity">
        <xsd:enumeration value="AssetSeizers">
        <xsd:enumeration value="Associates">
        <xsd:enumeration value="AtCompleteVariance">
        <xsd:enumeration value="AtCompletionQuantityEstimated">
        <xsd:enumeration value="Attendant-HandledQuantity">
        <xsd:enumeration value="Auctions">
        <xsd:enumeration value="Auditor">
        <xsd:enumeration value="AuthorisedShares">
        <xsd:enumeration value="AuthorizedRetentionLevel">
        <xsd:enumeration value="AuthorizedShares">
        <xsd:enumeration value="AvailableQuantity">
        <xsd:enumeration value="AvailableResourceTaskQuantity">
        <xsd:enumeration value="AvailableUnits">
        <xsd:enumeration value="Average">
        <xsd:enumeration value="AverageEmployees">
        <xsd:enumeration value="AverageNumberOfEmployees">
        <xsd:enumeration value="Axles">
        <xsd:enumeration value="BackorderLines">
        <xsd:enumeration value="BackorderQuantity">
        <xsd:enumeration value="BankRejectItemCount.">
        <xsd:enumeration value="BankruptcyPetitionsFiled">
        <xsd:enumeration value="BathroomCount">
        <xsd:enumeration value="BathroomsFinishedAreaAboveGrade">
        <xsd:enumeration value="BedroomCount">
        <xsd:enumeration value="BedroomsFinishedAreaAboveGrade">
        <xsd:enumeration value="Beds">
        <xsd:enumeration value="BeginningShares">
        <xsd:enumeration value="BenefitAmount">
        <xsd:enumeration value="BenefitPeriod">
        <xsd:enumeration value="BillableQuantity">
        <xsd:enumeration value="Billed">
        <xsd:enumeration value="BillingUnitPerPricingUnit">
        <xsd:enumeration value="BirthWeight">
        <xsd:enumeration value="BlankVotes">
        <xsd:enumeration value="BloodRecord">
        <xsd:enumeration value="BookInventory">
        <xsd:enumeration value="BookOrderQuantity">
        <xsd:enumeration value="Branches">
        <xsd:enumeration value="BranchLocations">
        <xsd:enumeration value="BranchLocationsLeased">
        <xsd:enumeration value="BranchLocationsOwned">
        <xsd:enumeration value="BranchOfficeLocationsEstimated">
        <xsd:enumeration value="BrothersDeceased">
        <xsd:enumeration value="BrothersLiving">
        <xsd:enumeration value="Budget">
        <xsd:enumeration value="BudgetAtComplete">
        <xsd:enumeration value="BudgetCumulativeToDate">
        <xsd:enumeration value="BudgetedHours">
        <xsd:enumeration value="BusinessClassFailureIncidences">
        <xsd:enumeration value="BusinessFailureClassIncidence">
        <xsd:enumeration value="BusinessFailureIndustryIncidence">
        <xsd:enumeration value="BusinessFailureNationalAverageIncidence">
        <xsd:enumeration value="Buyer">
        <xsd:enumeration value="BuyupOrBuydownRatePerBasisPoint">
        <xsd:enumeration value="Bytes">
        <xsd:enumeration value="CalendarUnits">
        <xsd:enumeration value="CancelledQuantity">
        <xsd:enumeration value="CapitalChanges">
        <xsd:enumeration value="CertifiedRegisteredNurseAnesthetistNumberOfConcurrentProcedures">
        <xsd:enumeration value="Changes">
        <xsd:enumeration value="ChangesInCapitalStructure">
        <xsd:enumeration value="Charge">
        <xsd:enumeration value="ChargeableCubicMeasurements">
        <xsd:enumeration value="ChargeableDistance">
        <xsd:enumeration value="ChargeableGrossWeight">
        <xsd:enumeration value="ChargeableLength">
        <xsd:enumeration value="ChargeableNumberOfAxles">
        <xsd:enumeration value="ChargeableNumberOfContainers">
        <xsd:enumeration value="ChargeableNumberOfPackages">
        <xsd:enumeration value="ChargeableNumberOfRailWagons">
        <xsd:enumeration value="ChargeableNumberOfUnits">
        <xsd:enumeration value="ChargeablePeriod">
        <xsd:enumeration value="ChargeableSurface">
        <xsd:enumeration value="ChargeableTareWeight">
        <xsd:enumeration value="ChargeableVolume">
        <xsd:enumeration value="ChargeableWeight">
        <xsd:enumeration value="Children">
        <xsd:enumeration value="CirculatingOil">
        <xsd:enumeration value="Citations">
        <xsd:enumeration value="ClaimPeriod">
        <xsd:enumeration value="Clerks">
        <xsd:enumeration value="ClosingStatementBalance">
        <xsd:enumeration value="ClosingStockBalanceQuantity">
        <xsd:enumeration value="Co2InjectionVolume">
        <xsd:enumeration value="Co-Insured-Actual">
        <xsd:enumeration value="Co-Insured-Estimated">
        <xsd:enumeration value="CollateralRequirements">
        <xsd:enumeration value="CollectionPeriod">
        <xsd:enumeration value="CommitmentPeriod">
        <xsd:enumeration value="CommittedQuantity">
        <xsd:enumeration value="CommunityServiceDuration">
        <xsd:enumeration value="CompaniesIncludedInConsolidatedFinancialStatement">
        <xsd:enumeration value="CompaniesIncludedInConsolidation">
        <xsd:enumeration value="CompaniesInSameActivity">
        <xsd:enumeration value="ComparisonPeriod">
        <xsd:enumeration value="Completed">
        <xsd:enumeration value="CompletedContracts">
        <xsd:enumeration value="CompletedLineItems">
        <xsd:enumeration value="CompletedProjects">
        <xsd:enumeration value="ComponentMeterReadingCount">
        <xsd:enumeration value="ConcurrentItemOutputOfTooling">
        <xsd:enumeration value="Confirmed">
        <xsd:enumeration value="ConsolidatedDiscountInventory">
        <xsd:enumeration value="ConsumerReservedQuantity">
        <xsd:enumeration value="ContinuanceDuration">
        <xsd:enumeration value="ContractBuydown">
        <xsd:enumeration value="ContractBuyup">
        <xsd:enumeration value="ContractCompletedDelinquent-ContractorCaused">
        <xsd:enumeration value="ContractLineItemQuantity">
        <xsd:enumeration value="ContractorAtComplete">
        <xsd:enumeration value="ContractorCumulativeToDate">
        <xsd:enumeration value="ContractsCompletedDelinquent-BuyingPartyCaused">
        <xsd:enumeration value="ContractsCompletedDelinquent-UnknownCauses">
        <xsd:enumeration value="ContributionTotal">
        <xsd:enumeration value="ControlQuantity">
        <xsd:enumeration value="ConventionalMobiles">
        <xsd:enumeration value="ConvictionsSent">
        <xsd:enumeration value="CooperativeShares">
        <xsd:enumeration value="CorrectedQuantity">
        <xsd:enumeration value="CorrectiveActionRequests-MethodC">
        <xsd:enumeration value="CorrectiveActionRequests-MethodD">
        <xsd:enumeration value="CorrectiveActionRequests-MethodE">
        <xsd:enumeration value="CorrectiveActionRequests-Verbal">
        <xsd:enumeration value="CorrectiveActionRequests-Written">
        <xsd:enumeration value="CounterClerks">
        <xsd:enumeration value="CourseSegments">
        <xsd:enumeration value="Coverage">
        <xsd:enumeration value="Covered-Actual">
        <xsd:enumeration value="Covered-Estimated">
        <xsd:enumeration value="Creditors">
        <xsd:enumeration value="CriminalSentenceDuration">
        <xsd:enumeration value="CumulativeActual">
        <xsd:enumeration value="CumulativeBudget">
        <xsd:enumeration value="CumulativeEarnedValue">
        <xsd:enumeration value="CumulativeEffectOfPriorPeriodAdjustment">
        <xsd:enumeration value="CumulativeGasInjectionVolume">
        <xsd:enumeration value="CumulativeGasVolume">
        <xsd:enumeration value="CumulativeLiquidInjectionVolume">
        <xsd:enumeration value="CumulativeOilOrCondensateVolume">
        <xsd:enumeration value="CumulativeQuantity">
        <xsd:enumeration value="CumulativeQuantityActualEstimated">
        <xsd:enumeration value="CumulativeQuantityActualMeasured">
        <xsd:enumeration value="CumulativeQuantityActualPlanned">
        <xsd:enumeration value="CumulativeQuantityOrdered">
        <xsd:enumeration value="CumulativeQuantityPrecedingPeriodEstimated">
        <xsd:enumeration value="CumulativeQuantityPrecedingPeriodMeasured">
        <xsd:enumeration value="CumulativeQuantityPrecedingPeriodPlanned">
        <xsd:enumeration value="CumulativeQuantityPrecedingPeriodReached">
        <xsd:enumeration value="CumulativeQuantityReceived">
        <xsd:enumeration value="CumulativeQuantityReceivedEndOfPriorYear">
        <xsd:enumeration value="CumulativeQuantity-RejectedMaterial">
        <xsd:enumeration value="CumulativeQuantity-RejectedMaterial-DispositionCredit">
        <xsd:enumeration value="CumulativeQuantity-RejectedMaterial-DispositionPending">
        <xsd:enumeration value="CumulativeQuantity-RejectedMaterial-DispositionReplacement">
        <xsd:enumeration value="CumulativeQuantityRequiredPriorToTheFirstScheduledPeriod">
        <xsd:enumeration value="CumulativeQuantityScheduled">
        <xsd:enumeration value="CumulativeQuantityScheduledUpToAccumulationStartDate">
        <xsd:enumeration value="CumulativeQuantityShipped">
        <xsd:enumeration value="CumulativeQuantityShippedLong-DispositionChallenged">
        <xsd:enumeration value="CumulativeQuantityShippedLong-DispositionPending">
        <xsd:enumeration value="CumulativeQuantityShippedShort-DispositionChallenged">
        <xsd:enumeration value="CumulativeQuantityShippedShort-DispositionPending">
        <xsd:enumeration value="CumulativeScheduleVariance">
        <xsd:enumeration value="CumulativeScrapQuantity">
        <xsd:enumeration value="CumulativeVariance">
        <xsd:enumeration value="CumulativeWaterVolume">
        <xsd:enumeration value="CurrentDaysOnMarket">
        <xsd:enumeration value="DeductibleBloodUnits">
        <xsd:enumeration value="DefaultNotificationResponsePeriod">
        <xsd:enumeration value="DegreeSegments">
        <xsd:enumeration value="Deleted">
        <xsd:enumeration value="DeliveryBatch">
        <xsd:enumeration value="DeliveryBatchMultiple">
        <xsd:enumeration value="DeliveryQuantity">
        <xsd:enumeration value="DeliveryQuantityBalance">
        <xsd:enumeration value="Departments">
        <xsd:enumeration value="DependentCount">
        <xsd:enumeration value="DependentsAge">
        <xsd:enumeration value="DependentTotal">
        <xsd:enumeration value="DesignEmployees">
        <xsd:enumeration value="DespatchNoteQuantity">
        <xsd:enumeration value="DespatchQuantity">
        <xsd:enumeration value="DestroyedQuantity">
        <xsd:enumeration value="DetrimentalLegalFilings">
        <xsd:enumeration value="DetrimentalLegalFilingsAgainstDirectors">
        <xsd:enumeration value="DimensionalSampleQuantity">
        <xsd:enumeration value="Directors">
        <xsd:enumeration value="DirectShipmentQuantity">
        <xsd:enumeration value="DirectWorkers">
        <xsd:enumeration value="DisbursementPeriod">
        <xsd:enumeration value="DiscreetQuantity-RejectedMaterial">
        <xsd:enumeration value="DiscreteQuantity">
        <xsd:enumeration value="DiscreteQuantity-RejectedMaterial-DispositionCredit">
        <xsd:enumeration value="DiscreteQuantity-RejectedMaterial-DispositionPending">
        <xsd:enumeration value="DiscreteQuantity-RejectedMaterial-DispositionReplacement">
        <xsd:enumeration value="Disposed">
        <xsd:enumeration value="DispositionUndeterminedQuantity">
        <xsd:enumeration value="Distributed">
        <xsd:enumeration value="DistributorInventory">
        <xsd:enumeration value="DomesticAffiliatedCompanies">
        <xsd:enumeration value="DomesticUses">
        <xsd:enumeration value="Dose">
        <xsd:enumeration value="Drafts">
        <xsd:enumeration value="Drivers">
        <xsd:enumeration value="Due">
        <xsd:enumeration value="Due-In">
        <xsd:enumeration value="Duplicates">
        <xsd:enumeration value="DurationInCurrentJob">
        <xsd:enumeration value="DwellingArea">
        <xsd:enumeration value="EarnedValue">
        <xsd:enumeration value="EarnedValueCumulativeToDate">
        <xsd:enumeration value="EarnedValueHours">
        <xsd:enumeration value="EffectiveAge">
        <xsd:enumeration value="ElapsedDuration">
        <xsd:enumeration value="ElectronicSignatures">
        <xsd:enumeration value="EliminationPeriod">
        <xsd:enumeration value="EliminationPeriod-Accident">
        <xsd:enumeration value="EliminationPeriod-Sickness">
        <xsd:enumeration value="EmergencyModifyingUnits">
        <xsd:enumeration value="EmployedAtLocation">
        <xsd:enumeration value="EmployedAtThisLocation">
        <xsd:enumeration value="EmployedByThisCompany">
        <xsd:enumeration value="EmployedInThisProfession">
        <xsd:enumeration value="EmployedOnThisJob">
        <xsd:enumeration value="EmployeeAverage">
        <xsd:enumeration value="Employees">
        <xsd:enumeration value="EmployeesAge">
        <xsd:enumeration value="Employees-Nonowner">
        <xsd:enumeration value="EmployeesNotIncludingOwners">
        <xsd:enumeration value="EmployeesNumberOfDaysAwayFromWorkDueToInjury">
        <xsd:enumeration value="EmployeesNumberOfDaysOfRestrictedWorkActivityDueToInjury">
        <xsd:enumeration value="Employees-Owner">
        <xsd:enumeration value="Employees-PartTime">
        <xsd:enumeration value="Employees-SameDuties">
        <xsd:enumeration value="Employees-SameOccupation">
        <xsd:enumeration value="EmployeesShared">
        <xsd:enumeration value="EmployeesTotalNumberOfDaysAwayFromWorkDueToIllness">
        <xsd:enumeration value="EmployeeTotal">
        <xsd:enumeration value="EmployeeTotalFirstMonthOfQuarter">
        <xsd:enumeration value="EmployeeTotalSecondMonthOfQuarter">
        <xsd:enumeration value="EmployeeTotalThirdMonthOfQuarter">
        <xsd:enumeration value="EndingStock">
        <xsd:enumeration value="EndOfMonthInventoryPriorToShip">
        <xsd:enumeration value="EndQuantity">
        <xsd:enumeration value="EngineeredStandard">
        <xsd:enumeration value="Engineers">
        <xsd:enumeration value="EquipmentQuantity">
        <xsd:enumeration value="EquitySecurityHolder">
        <xsd:enumeration value="EstimateAtComplete">
        <xsd:enumeration value="Estimated">
        <xsd:enumeration value="EstimatedAccounts">
        <xsd:enumeration value="EstimatedAnnualVolume">
        <xsd:enumeration value="EstimatedDuration">
        <xsd:enumeration value="EstimatedEmployeesAtLocation">
        <xsd:enumeration value="EstimatedHours">
        <xsd:enumeration value="EstimatedQuantity">
        <xsd:enumeration value="EstimatedReadingQuantity">
        <xsd:enumeration value="EstimatedRemainingEconomicLife">
        <xsd:enumeration value="EstimatedRemainingPhysicalLife">
        <xsd:enumeration value="EstimatedTotalEmployees">
        <xsd:enumeration value="EvaporatedWater">
        <xsd:enumeration value="ExclusiveUses">
        <xsd:enumeration value="Executives">
        <xsd:enumeration value="ExistenceLimitPeriod">
        <xsd:enumeration value="ExpenditureQuantity">
        <xsd:enumeration value="Expense">
        <xsd:enumeration value="ExtendedTerm">
        <xsd:enumeration value="ExtraUnplannedDelivery">
        <xsd:enumeration value="Factor">
        <xsd:enumeration value="FederalMedicareOrMedicaidClaimMandate-Category1">
        <xsd:enumeration value="FederalMedicareOrMedicaidClaimMandate-Category2">
        <xsd:enumeration value="FederalMedicareOrMedicaidClaimMandate-Category3">
        <xsd:enumeration value="FederalMedicareOrMedicaidClaimMandate-Category4">
        <xsd:enumeration value="FederalMedicareOrMedicaidClaimMandate-Category5">
        <xsd:enumeration value="FederalMedicareOrMedicaidPaymentMandate-Category1">
        <xsd:enumeration value="FederalMedicareOrMedicaidPaymentMandate-Category2">
        <xsd:enumeration value="FederalMedicareOrMedicaidPaymentMandate-Category3">
        <xsd:enumeration value="FederalMedicareOrMedicaidPaymentMandate-Category4">
        <xsd:enumeration value="FederalMedicareOrMedicaidPaymentMandate-Category5">
        <xsd:enumeration value="FederalPensionMandate-Category1">
        <xsd:enumeration value="FederalPensionMandate-Category2">
        <xsd:enumeration value="FederalPensionMandate-Category3">
        <xsd:enumeration value="FederalPensionMandate-Category4">
        <xsd:enumeration value="FederalPensionMandate-Category5">
        <xsd:enumeration value="FederalVotes">
        <xsd:enumeration value="FieldWorkers">
        <xsd:enumeration value="FileSizeAfterCompression">
        <xsd:enumeration value="FileSizeBeforeCompression">
        <xsd:enumeration value="FinalDeliveryQuantity">
        <xsd:enumeration value="FinancialCoveragePeriod">
        <xsd:enumeration value="FinancialInstitutions">
        <xsd:enumeration value="FinishOffset">
        <xsd:enumeration value="FirstQuarterNon-RecurringDemand">
        <xsd:enumeration value="FirstQuarterNon-RecurringOrders">
        <xsd:enumeration value="FirstQuarterRecurringDemand">
        <xsd:enumeration value="FirstQuarterRecurringOrders">
        <xsd:enumeration value="FlareOrFlash">
        <xsd:enumeration value="FlatExtraPremium">
        <xsd:enumeration value="Floors">
        <xsd:enumeration value="FloorsOccupied">
        <xsd:enumeration value="Forecast">
        <xsd:enumeration value="ForecastAtComplete">
        <xsd:enumeration value="ForecastedScannedQuantity">
        <xsd:enumeration value="ForecastToComplete">
        <xsd:enumeration value="ForeignRelatedEntities">
        <xsd:enumeration value="Foremen">
        <xsd:enumeration value="FourthQuarterNon-RecurringDemand">
        <xsd:enumeration value="FourthQuarterNon-RecurringOrders">
        <xsd:enumeration value="FourthQuarterRecurringDemand">
        <xsd:enumeration value="FourthQuarterRecurringOrders">
        <xsd:enumeration value="FreeFloat-InCalendarUnits">
        <xsd:enumeration value="FreeFloatTime">
        <xsd:enumeration value="FreeGoodsQuantity">
        <xsd:enumeration value="FreelanceDebtCollectors">
        <xsd:enumeration value="FreelanceSalespersons">
        <xsd:enumeration value="FreeQuantityIncluded">
        <xsd:enumeration value="FreeQuantityNotIncluded">
        <xsd:enumeration value="Frequency">
        <xsd:enumeration value="Fuel">
        <xsd:enumeration value="FuelConsumedOrBurnedAmount">
        <xsd:enumeration value="FuelPumps">
        <xsd:enumeration value="FullBaths">
        <xsd:enumeration value="FunctionalGroups">
        <xsd:enumeration value="FunctionalSampleQuantity">
        <xsd:enumeration value="FurnishedBloodUnits">
        <xsd:enumeration value="GarageOrCarportArea">
        <xsd:enumeration value="GasInjectionVolume">
        <xsd:enumeration value="GasLiftVolume">
        <xsd:enumeration value="GasReceiptVolume">
        <xsd:enumeration value="GasReturnedToEarth">
        <xsd:enumeration value="GasReturnedToPropertyForFuel">
        <xsd:enumeration value="GasShrinkage">
        <xsd:enumeration value="GasSold">
        <xsd:enumeration value="GasUsedForDrilling">
        <xsd:enumeration value="GasUsedForFuelSystem">
        <xsd:enumeration value="GasUsedForPlantFuel">
        <xsd:enumeration value="GasUsedForRepressuringOrPressureMaintenance">
        <xsd:enumeration value="GasUsedOnProperty">
        <xsd:enumeration value="GasVented">
        <xsd:enumeration value="GasVolume">
        <xsd:enumeration value="GeneralEliminationPeriod">
        <xsd:enumeration value="GovernmentReportingQuantity">
        <xsd:enumeration value="GradeTransferAmount">
        <xsd:enumeration value="GrossAnnualIncomeMultiplier">
        <xsd:enumeration value="GrossBuildingArea">
        <xsd:enumeration value="GrossEstimate">
        <xsd:enumeration value="GrossLivingArea">
        <xsd:enumeration value="GrossLivingFinishedAreaAboveGrade">
        <xsd:enumeration value="GrossProduction">
        <xsd:enumeration value="GrossRentMultiplier">
        <xsd:enumeration value="GroupEmployees">
        <xsd:enumeration value="GuaranteeFeeBuyupMaximum">
        <xsd:enumeration value="GuaranteeFeeRateAfterAlternatePaymentMethod">
        <xsd:enumeration value="GuaranteeFeeRateAfterBuyupOrBuydown">
        <xsd:enumeration value="GuaranteePeriod">
        <xsd:enumeration value="Height">
        <xsd:enumeration value="HighFabricationAuthorizationQuantity">
        <xsd:enumeration value="HighRawMaterialAuthorizationQuantity">
        <xsd:enumeration value="HoldingPeriod">
        <xsd:enumeration value="Hours">
        <xsd:enumeration value="HoursFlown-AircraftOrTypeFlying">
        <xsd:enumeration value="HoursFlown-AircraftTypeOrLife">
        <xsd:enumeration value="HoursFlown-AircraftTypeOrPeriod">
        <xsd:enumeration value="HoursFlown-Lifetime">
        <xsd:enumeration value="HoursFlown-TypeFlying">
        <xsd:enumeration value="ImpairmentDuration">
        <xsd:enumeration value="ImpairmentFrequency">
        <xsd:enumeration value="IncrementalOrderQuantity">
        <xsd:enumeration value="IndirectEmployees">
        <xsd:enumeration value="IndustryBusinessFailureIncidences">
        <xsd:enumeration value="InformationProviderStandardizedMotorVehiclePenaltyPoints">
        <xsd:enumeration value="InformationReadingQuantity">
        <xsd:enumeration value="Inspectors">
        <xsd:enumeration value="InstalledCapacity">
        <xsd:enumeration value="Installers">
        <xsd:enumeration value="InstallmentFrequency">
        <xsd:enumeration value="InstallmentPayments">
        <xsd:enumeration value="Installments">
        <xsd:enumeration value="InsufficientFundsReturnedCheques">
        <xsd:enumeration value="IntendedChangeTimePeriod">
        <xsd:enumeration value="InterestForOverdrawnAccount">
        <xsd:enumeration value="InterimTermPeriod">
        <xsd:enumeration value="IntertankTransferAmount">
        <xsd:enumeration value="InTransitQuantity">
        <xsd:enumeration value="In-Use">
        <xsd:enumeration value="InventoryCategoryTransfer">
        <xsd:enumeration value="InventoryDiscrepancy">
        <xsd:enumeration value="InventoryMovementQuantity">
        <xsd:enumeration value="InventoryOnShelfWorkInProgress">
        <xsd:enumeration value="InventoryQuantityAtSuppliersNotSubjectToInspectionByCustomer">
        <xsd:enumeration value="InventoryQuantityAtSuppliersSubjectToInspectionByCustomer">
        <xsd:enumeration value="InventoryWithdrawalQuantity">
        <xsd:enumeration value="InvoicedQuantity">
        <xsd:enumeration value="Invoices">
        <xsd:enumeration value="InvolvementPeriod">
        <xsd:enumeration value="IssuedShares">
        <xsd:enumeration value="JailSentenceDuration">
        <xsd:enumeration value="JudgementsRegistered">
        <xsd:enumeration value="Judgments">
        <xsd:enumeration value="JudicialStayDuration">
        <xsd:enumeration value="Laborers">
        <xsd:enumeration value="LabourHours">
        <xsd:enumeration value="LagTime">
        <xsd:enumeration value="LandHolding">
        <xsd:enumeration value="LandSize">
        <xsd:enumeration value="Lanes">
        <xsd:enumeration value="Late">
        <xsd:enumeration value="LatePaymentPeriod">
        <xsd:enumeration value="LatestCumulativeQuantity">
        <xsd:enumeration value="LawSuits">
        <xsd:enumeration value="LeadTime">
        <xsd:enumeration value="LeasePeriods">
        <xsd:enumeration value="LengthOfResidency">
        <xsd:enumeration value="LevelResource-Quantity">
        <xsd:enumeration value="LevelResourceTaskQuantity">
        <xsd:enumeration value="LevelsOccupied">
        <xsd:enumeration value="LicenseWithdrawalDuration">
        <xsd:enumeration value="LicenseWithdrawalsSent">
        <xsd:enumeration value="Liens">
        <xsd:enumeration value="LiensRegistered">
        <xsd:enumeration value="LifetimeCapacityOfTooling">
        <xsd:enumeration value="Life-TimeReserve-Actual">
        <xsd:enumeration value="LifetimeReserveDays-AppliedToThisClaim">
        <xsd:enumeration value="Life-TimeReserve-Estimated">
        <xsd:enumeration value="LimitedQuantity">
        <xsd:enumeration value="LineItemsCompletedDelinquent-BuyingPartyCaused">
        <xsd:enumeration value="LineItemsCompletedDelinquent-ContractorCaused">
        <xsd:enumeration value="LineItemsCompletedDelinquent-UnknownCauses">
        <xsd:enumeration value="LineThreadQuantity">
        <xsd:enumeration value="LiquidInjectionVolume">
        <xsd:enumeration value="Livestock">
        <xsd:enumeration value="LoanRate">
        <xsd:enumeration value="LoanRepaymentTotal">
        <xsd:enumeration value="LossAllowance">
        <xsd:enumeration value="LossOrGain">
        <xsd:enumeration value="LostGas">
        <xsd:enumeration value="LostGoods">
        <xsd:enumeration value="LostOil">
        <xsd:enumeration value="LostWorkTimeActual">
        <xsd:enumeration value="LostWorkTimeEstimated">
        <xsd:enumeration value="LotSize">
        <xsd:enumeration value="Machines">
        <xsd:enumeration value="MaintenanceUnits">
        <xsd:enumeration value="Manufactured">
        <xsd:enumeration value="ManufacturedUnits">
        <xsd:enumeration value="MarineRadios">
        <xsd:enumeration value="MarketPriceChange">
        <xsd:enumeration value="MatchingEquipment">
        <xsd:enumeration value="MaterialOn-BoardQuantityPriorToLoading">
        <xsd:enumeration value="Maximum">
        <xsd:enumeration value="MaximumAge">
        <xsd:enumeration value="MaximumBenefitPeriod">
        <xsd:enumeration value="MaximumBenefitPeriod-Accident">
        <xsd:enumeration value="MaximumBenefitPeriodAccidentToAge">
        <xsd:enumeration value="MaximumBenefitPeriod-Sickness">
        <xsd:enumeration value="MaximumBenefitPeriodSicknessToAge">
        <xsd:enumeration value="MaximumCriminalSentenceDuration">
        <xsd:enumeration value="MaximumDeliveryBatch">
        <xsd:enumeration value="MaximumForecastQuantity">
        <xsd:enumeration value="MaximumInventory">
        <xsd:enumeration value="MaximumMaturityExtension">
        <xsd:enumeration value="MaximumNumberOfEmployees">
        <xsd:enumeration value="MaximumNumberOfEmployeesAtLocation">
        <xsd:enumeration value="MaximumNumberOfPurchaseOrdersAllowed">
        <xsd:enumeration value="MaximumNumberOfShipmentsAllowed">
        <xsd:enumeration value="MaximumOrderQuantity">
        <xsd:enumeration value="MaximumProductionBatch">
        <xsd:enumeration value="MaximumQuantityToWhichTaxRateApplies">
        <xsd:enumeration value="MaximumRequestableQuantity">
        <xsd:enumeration value="MaximumShipQuantity">
        <xsd:enumeration value="MaximumStackability">
        <xsd:enumeration value="MaximumStockLevel">
        <xsd:enumeration value="MaximumSupplyQuantitySupplierEndorsed">
        <xsd:enumeration value="MaximumTransfer">
        <xsd:enumeration value="Mechanics">
        <xsd:enumeration value="MedicationDuration">
        <xsd:enumeration value="MembersInGroup">
        <xsd:enumeration value="Messengers">
        <xsd:enumeration value="MeterReading">
        <xsd:enumeration value="Miles">
        <xsd:enumeration value="MilitarySalesQuantity">
        <xsd:enumeration value="MillionDollarRoundtableCredits">
        <xsd:enumeration value="Minimum">
        <xsd:enumeration value="MinimumAge">
        <xsd:enumeration value="MinimumAverageTimeRequirementUnits">
        <xsd:enumeration value="MinimumContractQuantity">
        <xsd:enumeration value="MinimumCriminalSentenceDuration">
        <xsd:enumeration value="MinimumDeliveryBatch">
        <xsd:enumeration value="MinimumEmployeesAtLocation">
        <xsd:enumeration value="MinimumFabricationQuantity">
        <xsd:enumeration value="MinimumForecastQuantity">
        <xsd:enumeration value="MinimumInventory">
        <xsd:enumeration value="MinimumNumberOfEmployees">
        <xsd:enumeration value="MinimumOrderPackageLevel">
        <xsd:enumeration value="MinimumOrderQuantity">
        <xsd:enumeration value="MinimumProductionBatch">
        <xsd:enumeration value="MinimumQuantityToWhichTaxRateApplies">
        <xsd:enumeration value="MinimumRequestableQuantity">
        <xsd:enumeration value="MinimumShipQuantity">
        <xsd:enumeration value="MinimumStockLevel">
        <xsd:enumeration value="MinimumTransfer">
        <xsd:enumeration value="MiscellaneousAllowance">
        <xsd:enumeration value="MobileLoadingAllocation">
        <xsd:enumeration value="ModelOrTargetStock">
        <xsd:enumeration value="Month">
        <xsd:enumeration value="MortgagePoolCount">
        <xsd:enumeration value="MostLikelyDuration">
        <xsd:enumeration value="NationalBusinessFailureIncidences">
        <xsd:enumeration value="Net">
        <xsd:enumeration value="NetQuantityDecrease">
        <xsd:enumeration value="NetQuantityIncrease">
        <xsd:enumeration value="NetToPayItemCount.">
        <xsd:enumeration value="NoDeliveryRequirementInThisInstruction">
        <xsd:enumeration value="Non-BillableQuantity">
        <xsd:enumeration value="NoncommittedInventoryOnShelf">
        <xsd:enumeration value="NonconformanceQuantity">
        <xsd:enumeration value="Non-ConsolidatedTotal-DomesticSubsidiaries">
        <xsd:enumeration value="Non-ConsolidatedTotal-ForeignSubsidiaries">
        <xsd:enumeration value="Noncovered-Actual">
        <xsd:enumeration value="Non-Covered-Estimated">
        <xsd:enumeration value="Non-DomesticStockholders">
        <xsd:enumeration value="NonexclusiveUses">
        <xsd:enumeration value="Non-UnionEmployees">
        <xsd:enumeration value="Non-UrgentDeliveryQuantity">
        <xsd:enumeration value="NormalDelivery">
        <xsd:enumeration value="NormalReadingQuantity">
        <xsd:enumeration value="NotReplacedBloodUnits">
        <xsd:enumeration value="NoVotes">
        <xsd:enumeration value="NumberOfAccountsPastDue">
        <xsd:enumeration value="NumberOfActiveAccountsThisCycle">
        <xsd:enumeration value="NumberOfAddedLocations">
        <xsd:enumeration value="NumberOfAdjustmentPeriods">
        <xsd:enumeration value="NumberOfAttacksOrOccurrences">
        <xsd:enumeration value="NumberOfBatches">
        <xsd:enumeration value="NumberOfBorrowers">
        <xsd:enumeration value="NumberOfCardsNotReceived">
        <xsd:enumeration value="NumberOfCardsOutstanding">
        <xsd:enumeration value="NumberOfChecks">
        <xsd:enumeration value="NumberOfClaimants">
        <xsd:enumeration value="NumberOfClosedLocations">
        <xsd:enumeration value="NumberOfCo-InsuranceDays">
        <xsd:enumeration value="NumberOfCopiesOfBillOfLading">
        <xsd:enumeration value="NumberOfCrew">
        <xsd:enumeration value="NumberOfDaysCoveredByInventory">
        <xsd:enumeration value="NumberOfDead">
        <xsd:enumeration value="NumberOfDelinquentInstallments">
        <xsd:enumeration value="NumberOfDeliveriesPerDespatchPeriod">
        <xsd:enumeration value="NumberOfDependents">
        <xsd:enumeration value="NumberOfEndUsers">
        <xsd:enumeration value="NumberOfEntitledExemptions">
        <xsd:enumeration value="NumberOfFailedBusinessesOfDirectors">
        <xsd:enumeration value="NumberOfFranchisees">
        <xsd:enumeration value="NumberOfFull-TimeEmployees">
        <xsd:enumeration value="NumberOfHospitals">
        <xsd:enumeration value="NumberOfIdenticalHandlingUnits">
        <xsd:enumeration value="NumberOfInsuredLives">
        <xsd:enumeration value="NumberOfInterestPayments">
        <xsd:enumeration value="NumberOfIrregularInterestPayments">
        <xsd:enumeration value="NumberOfItemsAuthorizedAtStore">
        <xsd:enumeration value="NumberOfItemsAuthorizedAtWarehouse">
        <xsd:enumeration value="NumberOfItemsInStock">
        <xsd:enumeration value="NumberOfLateCharges">
        <xsd:enumeration value="NumberOfLevels">
        <xsd:enumeration value="NumberOfLimitedPartnershipShares">
        <xsd:enumeration value="NumberOfLiving">
        <xsd:enumeration value="NumberOfLoans">
        <xsd:enumeration value="NumberOfLostCards">
        <xsd:enumeration value="NumberOfMembers">
        <xsd:enumeration value="NumberOfMessageRecipients">
        <xsd:enumeration value="NumberOfMonths">
        <xsd:enumeration value="NumberOfMortgagors">
        <xsd:enumeration value="NumberOfMoulds">
        <xsd:enumeration value="NumberOfNon-CoveredDays">
        <xsd:enumeration value="NumberOfNonsufficientFundItems">
        <xsd:enumeration value="NumberOfOpenAccounts">
        <xsd:enumeration value="NumberOfOperatingPeriodsAtFailure">
        <xsd:enumeration value="NumberOfOperatorCredits">
        <xsd:enumeration value="NumberOfOriginals">
        <xsd:enumeration value="NumberOfPackagesInHandlingUnit">
        <xsd:enumeration value="NumberOfPassengers">
        <xsd:enumeration value="NumberOfPatientAdmissions">
        <xsd:enumeration value="NumberOfPeopleLivingAtResidence">
        <xsd:enumeration value="NumberOfPhysicians">
        <xsd:enumeration value="NumberOfProducingWellsRemainingOnPropertyOrFacility">
        <xsd:enumeration value="NumberOfProducingWellsRemainingOnRoyaltyAccount">
        <xsd:enumeration value="NumberOfQuantitativeIncentiveSchemeUnits">
        <xsd:enumeration value="NumberOfServicesOrProcedures">
        <xsd:enumeration value="NumberOfShelfFacings">
        <xsd:enumeration value="NumberOfShelfTags">
        <xsd:enumeration value="NumberOfSignedBillsOfLading">
        <xsd:enumeration value="NumberOfStations">
        <xsd:enumeration value="NumberOfStolenCards">
        <xsd:enumeration value="NumberOfStops">
        <xsd:enumeration value="NumberOfTheatres">
        <xsd:enumeration value="NumberOfTimes">
        <xsd:enumeration value="NumberOfTimesDeported">
        <xsd:enumeration value="NumberOfTransportDocuments">
        <xsd:enumeration value="NumberOfUnits">
        <xsd:enumeration value="NumberOfUnits-Housing">
        <xsd:enumeration value="NumberOfUnitsInTheDepthOfALayer">
        <xsd:enumeration value="NumberOfUnitsInTheWidthOfALayer">
        <xsd:enumeration value="NumberOfUnsignedBillsOfLading">
        <xsd:enumeration value="NumberOfWithholdingExemptions">
        <xsd:enumeration value="NumbersOfConsumerUnitsInTheTradedUnit">
        <xsd:enumeration value="NumberWeeksPaid">
        <xsd:enumeration value="Nurses">
        <xsd:enumeration value="OemInventory">
        <xsd:enumeration value="OfficeSize">
        <xsd:enumeration value="OfficeWorkers">
        <xsd:enumeration value="OffLeaseFuel">
        <xsd:enumeration value="OffPremiseSalesQuantity">
        <xsd:enumeration value="OffPremisesSales">
        <xsd:enumeration value="OilCondensateSold">
        <xsd:enumeration value="OilCondensateUsedOnProperty">
        <xsd:enumeration value="OilOrCondensateVolume">
        <xsd:enumeration value="OilSedimentation">
        <xsd:enumeration value="OilTheft">
        <xsd:enumeration value="OnHandAndDue-In">
        <xsd:enumeration value="OnHoldForShipment">
        <xsd:enumeration value="OnOrderQuantity">
        <xsd:enumeration value="OnPremiseSalesQuantity">
        <xsd:enumeration value="OnPremisesSales">
        <xsd:enumeration value="OpeningStatementBalance">
        <xsd:enumeration value="OpeningStockBalanceQuantity">
        <xsd:enumeration value="OpenQuantity">
        <xsd:enumeration value="OperatingBeds">
        <xsd:enumeration value="OperatingDivisions">
        <xsd:enumeration value="OperatingQuantity">
        <xsd:enumeration value="Operators">
        <xsd:enumeration value="OperatorsWorkingInterest">
        <xsd:enumeration value="OptimalQuantity">
        <xsd:enumeration value="OptimisticDuration">
        <xsd:enumeration value="OrderCount">
        <xsd:enumeration value="OrderedQuantity">
        <xsd:enumeration value="OrderQuantityMultiple">
        <xsd:enumeration value="Original">
        <xsd:enumeration value="OriginalDuration">
        <xsd:enumeration value="OriginalLoanTerm">
        <xsd:enumeration value="OriginalPaymentItemCount.">
        <xsd:enumeration value="OriginalQuantity">
        <xsd:enumeration value="OriginalTermInYears">
        <xsd:enumeration value="OtherEmployees">
        <xsd:enumeration value="OtherGasDisposition">
        <xsd:enumeration value="OtherInjectionVolume">
        <xsd:enumeration value="OtherMiscellaneousDisposition">
        <xsd:enumeration value="OtherOilCondensateDisposition">
        <xsd:enumeration value="OtherUnlistedParticipants">
        <xsd:enumeration value="OtherUnlistedStockholders">
        <xsd:enumeration value="OtherWarReserveMaterialRequirementsProtectableQuantity">
        <xsd:enumeration value="OtherWaterDisposition">
        <xsd:enumeration value="OutlierDays">
        <xsd:enumeration value="OutOfInventoryQuantity">
        <xsd:enumeration value="OutstandingQuantity">
        <xsd:enumeration value="OutstandingShares">
        <xsd:enumeration value="Out-TurnedQuantity">
        <xsd:enumeration value="Overage">
        <xsd:enumeration value="OverflowQuantity">
        <xsd:enumeration value="OverShipped">
        <xsd:enumeration value="Owner">
        <xsd:enumeration value="OwnersEquity">
        <xsd:enumeration value="OwnershipChangeAge">
        <xsd:enumeration value="OwnershipDuration">
        <xsd:enumeration value="OwnershipPercentage">
        <xsd:enumeration value="OwnOccupationQualificationPeriod">
        <xsd:enumeration value="Pagers">
        <xsd:enumeration value="Paid">
        <xsd:enumeration value="Paid-InCommonShares">
        <xsd:enumeration value="Paid-InPreferredShares">
        <xsd:enumeration value="Paid-InSecurityShares">
        <xsd:enumeration value="ParkingSpaces">
        <xsd:enumeration value="PartialBaths">
        <xsd:enumeration value="ParticipantTotal">
        <xsd:enumeration value="ParticipationShares">
        <xsd:enumeration value="Partners">
        <xsd:enumeration value="PartTimeEmployees">
        <xsd:enumeration value="PastDueQuantity">
        <xsd:enumeration value="Patients">
        <xsd:enumeration value="PaymentCancellationItemCount">
        <xsd:enumeration value="PaymentDurationWeeks">
        <xsd:enumeration value="PaymentExperiencesInTheLast12Months">
        <xsd:enumeration value="PaymentExperiencesInTheLast3Months">
        <xsd:enumeration value="PaymentFrequency">
        <xsd:enumeration value="PaymentOrdersFiled">
        <xsd:enumeration value="PaymentsNumber">
        <xsd:enumeration value="PercentageOfOrderedQuantity">
        <xsd:enumeration value="PeriodicCapacityOfTooling">
        <xsd:enumeration value="PeriodOfEmployment">
        <xsd:enumeration value="PeriodQuantityMeasured">
        <xsd:enumeration value="PeriodQuantityPlanned">
        <xsd:enumeration value="PeriodQuantityReached">
        <xsd:enumeration value="Persistency">
        <xsd:enumeration value="PessimisticDuration">
        <xsd:enumeration value="PetitionsFiled">
        <xsd:enumeration value="PhysicalStatusIii">
        <xsd:enumeration value="PhysicalStatusIv">
        <xsd:enumeration value="PhysicalStatusV">
        <xsd:enumeration value="Physicians">
        <xsd:enumeration value="PictureCount">
        <xsd:enumeration value="PiecesDelivered">
        <xsd:enumeration value="PilferageGoods">
        <xsd:enumeration value="Pilots">
        <xsd:enumeration value="PipelineAdjustmentOrAllowance">
        <xsd:enumeration value="Pipes">
        <xsd:enumeration value="PittedWater">
        <xsd:enumeration value="PlacementPeriodExpiration">
        <xsd:enumeration value="PlannedUnitDevelopmentUnits">
        <xsd:enumeration value="PlantSize">
        <xsd:enumeration value="PlantWorkers">
        <xsd:enumeration value="PlatformCount">
        <xsd:enumeration value="PortableRadios">
        <xsd:enumeration value="PortedTelephoneLines">
        <xsd:enumeration value="Post-OpDays">
        <xsd:enumeration value="Poultry">
        <xsd:enumeration value="PredominateAge">
        <xsd:enumeration value="Pre-OpDays">
        <xsd:enumeration value="PrepaidQuantityNotShipped">
        <xsd:enumeration value="PrepaidQuantityShipped">
        <xsd:enumeration value="Pre-ProductionQuantity">
        <xsd:enumeration value="Prescription">
        <xsd:enumeration value="PrescriptionDosage">
        <xsd:enumeration value="PrescriptionEffectivePeriod">
        <xsd:enumeration value="PrescriptionFrequency">
        <xsd:enumeration value="PresidentialVotes">
        <xsd:enumeration value="PressureBase">
        <xsd:enumeration value="PreviousBenefits">
        <xsd:enumeration value="PreviousCumulativeQuantity">
        <xsd:enumeration value="PreviousHighestCumulativeQuantity">
        <xsd:enumeration value="PreviouslyAmortisedQuantity">
        <xsd:enumeration value="PreviousMonthsUsage">
        <xsd:enumeration value="PreviousNumberOfAccounts">
        <xsd:enumeration value="PreviousNumberOfBranchLocations">
        <xsd:enumeration value="PreviousNumberOfEmployees">
        <xsd:enumeration value="PreviousOrderQuantityToBeCancelled">
        <xsd:enumeration value="PreviousQuantity">
        <xsd:enumeration value="PreviousWeekQuantity">
        <xsd:enumeration value="PriceBreakFrom">
        <xsd:enumeration value="PriceBreakTo">
        <xsd:enumeration value="PricingUnitPerBillingUnit">
        <xsd:enumeration value="PrimaryManagers">
        <xsd:enumeration value="PrimaryMeterReadingValue">
        <xsd:enumeration value="PrimaryNetQuantity">
        <xsd:enumeration value="PrincipalsIncludedAsEmployees">
        <xsd:enumeration value="PriorCumulativeImbalance">
        <xsd:enumeration value="PriorUnitsAccepted">
        <xsd:enumeration value="ProbationDuration">
        <xsd:enumeration value="ProducingWells">
        <xsd:enumeration value="ProductExchangeAmount">
        <xsd:enumeration value="ProductionRequirements">
        <xsd:enumeration value="ProductionWorkers">
        <xsd:enumeration value="ProductSalesAmount">
        <xsd:enumeration value="Professionals">
        <xsd:enumeration value="Professor">
        <xsd:enumeration value="ProjectedAvailableInventory">
        <xsd:enumeration value="ProjectPhases">
        <xsd:enumeration value="ProjectsInProcess">
        <xsd:enumeration value="ProjectUnitsSold">
        <xsd:enumeration value="Promoters">
        <xsd:enumeration value="PromotionQuantity">
        <xsd:enumeration value="ProtestedBills">
        <xsd:enumeration value="ProvidedQuantity">
        <xsd:enumeration value="PublicationTurnSize">
        <xsd:enumeration value="PurchaseOfProduct">
        <xsd:enumeration value="QualificationPeriod">
        <xsd:enumeration value="QualifyingWeeks">
        <xsd:enumeration value="QualityControlFailed">
        <xsd:enumeration value="QualityControlHeld">
        <xsd:enumeration value="QuantitativeIncentiveSchemeBase">
        <xsd:enumeration value="QuantityAdvised">
        <xsd:enumeration value="QuantityApproved">
        <xsd:enumeration value="QuantityAt100Pct">
        <xsd:enumeration value="QuantityAvailableForReturn">
        <xsd:enumeration value="QuantityAvailableForSale-StockQuantity">
        <xsd:enumeration value="QuantityAvailableOnShelf">
        <xsd:enumeration value="QuantityAwaitingDelivery">
        <xsd:enumeration value="QuantityByPosition">
        <xsd:enumeration value="QuantityCancelled">
        <xsd:enumeration value="QuantityCarriedForward">
        <xsd:enumeration value="QuantityDeferred">
        <xsd:enumeration value="QuantityDelivered">
        <xsd:enumeration value="QuantityDisapproved">
        <xsd:enumeration value="QuantityDispensed">
        <xsd:enumeration value="QuantityDisplayedNotAvailableForSale">
        <xsd:enumeration value="QuantityEarned">
        <xsd:enumeration value="QuantityHeldByDeliveryVehicle">
        <xsd:enumeration value="QuantityHeldByLogisticServiceProvider">
        <xsd:enumeration value="QuantityHeldByRetailOutlet">
        <xsd:enumeration value="QuantityInFloat">
        <xsd:enumeration value="QuantityInHoldOut">
        <xsd:enumeration value="QuantityInManufacturingProcess">
        <xsd:enumeration value="QuantityInPhysicalInventory">
        <xsd:enumeration value="QuantityInQuarantine">
        <xsd:enumeration value="QuantityInTransit">
        <xsd:enumeration value="QuantityLanded">
        <xsd:enumeration value="QuantityLoaded">
        <xsd:enumeration value="QuantityManifested">
        <xsd:enumeration value="QuantityNotAvailableForDespatch">
        <xsd:enumeration value="QuantityOfDealerLicensePlates">
        <xsd:enumeration value="QuantityOfMaterialInOrderedTime">
        <xsd:enumeration value="QuantityOnHand">
        <xsd:enumeration value="QuantityOnHold">
        <xsd:enumeration value="QuantityPerNextHigherAssembly">
        <xsd:enumeration value="QuantityPerPack">
        <xsd:enumeration value="QuantityPerSkid">
        <xsd:enumeration value="QuantityPerUnitOfIssue">
        <xsd:enumeration value="QuantityReceived">
        <xsd:enumeration value="QuantityRemaining">
        <xsd:enumeration value="QuantityRequirementForMaintenanceAndRepairOf">
        <xsd:enumeration value="QuantityRequirementForSampleInspection">
        <xsd:enumeration value="QuantityRequiringManipulationBeforeDespatch">
        <xsd:enumeration value="QuantityReturnedDefectiveOrDamaged">
        <xsd:enumeration value="QuantityScheduled">
        <xsd:enumeration value="QuantityServiced">
        <xsd:enumeration value="QuantitySold">
        <xsd:enumeration value="QuantitySoldNet">
        <xsd:enumeration value="QuantitySuspended">
        <xsd:enumeration value="QuantityToBeDelivered">
        <xsd:enumeration value="QuantityUsed">
        <xsd:enumeration value="QuantityWithdrawn">
        <xsd:enumeration value="QuantityWithheldByOwnerOfGoods">
        <xsd:enumeration value="QuoteQuantityOnInventory">
        <xsd:enumeration value="RangeAverage">
        <xsd:enumeration value="RangeMaximum">
        <xsd:enumeration value="RangeMinimum">
        <xsd:enumeration value="RatePerDay">
        <xsd:enumeration value="Receipts">
        <xsd:enumeration value="ReceivedAndAccepted">
        <xsd:enumeration value="ReceivedNotAcceptedToBeDestroyed">
        <xsd:enumeration value="ReceivedNotAcceptedToBeReturned">
        <xsd:enumeration value="ReceivedQuantity">
        <xsd:enumeration value="RecommendedMaintenanceQuantity">
        <xsd:enumeration value="RecommendedOverhaulAndRepairQuantity">
        <xsd:enumeration value="ReconsiderationPeriod">
        <xsd:enumeration value="RedeliveryAfterPostProcessing">
        <xsd:enumeration value="RefillsAuthorized">
        <xsd:enumeration value="RegisteredBrandsDistributed">
        <xsd:enumeration value="RegisteredBrandsManufactured">
        <xsd:enumeration value="RejectedQuantity">
        <xsd:enumeration value="RejectedReturnQuantity">
        <xsd:enumeration value="RelatedBusinessEntities">
        <xsd:enumeration value="RelatedEntities">
        <xsd:enumeration value="RelationshipDuration">
        <xsd:enumeration value="RelativesEmployed">
        <xsd:enumeration value="RemainingAuthorizedQuantity">
        <xsd:enumeration value="RemainingDuration">
        <xsd:enumeration value="RemainingQuantity">
        <xsd:enumeration value="ReorderingLevel">
        <xsd:enumeration value="ReorderPointQuantity">
        <xsd:enumeration value="ReplacedAmount">
        <xsd:enumeration value="ReplacedBloodUnits">
        <xsd:enumeration value="ReplenishmentOverrideQuantity">
        <xsd:enumeration value="ReplenishmentQuantity">
        <xsd:enumeration value="ReportDifference">
        <xsd:enumeration value="ReportedDeficiencies">
        <xsd:enumeration value="Reports">
        <xsd:enumeration value="RequestedAmount">
        <xsd:enumeration value="RequirementQuantity">
        <xsd:enumeration value="RequirementQuantityThatWasPreviouslyReleased">
        <xsd:enumeration value="RequisitioningObjective">
        <xsd:enumeration value="ReservedQuantity">
        <xsd:enumeration value="ReservedQuantityCustomerDirectDeliverySales">
        <xsd:enumeration value="ReservedQuantityRetailSales">
        <xsd:enumeration value="ResidenceDuration">
        <xsd:enumeration value="Resource-Quantity-Available">
        <xsd:enumeration value="RestingQuantity">
        <xsd:enumeration value="RestrictionDuration">
        <xsd:enumeration value="RetailSales">
        <xsd:enumeration value="RetentionQuantity">
        <xsd:enumeration value="ReturnedByConsumerQuantity">
        <xsd:enumeration value="ReturnQuantity">
        <xsd:enumeration value="ReturnsReplacementQuantity">
        <xsd:enumeration value="RoomCount">
        <xsd:enumeration value="Rooms">
        <xsd:enumeration value="RoomsFinishedAreaAboveGrade">
        <xsd:enumeration value="Royalty">
        <xsd:enumeration value="SafetyLevel">
        <xsd:enumeration value="Salespersons">
        <xsd:enumeration value="SalesQuantityNotIncludedInTheReplenishmentCalculation">
        <xsd:enumeration value="SalesQuantityPlanned">
        <xsd:enumeration value="SampleAmount">
        <xsd:enumeration value="ScatteredVotes">
        <xsd:enumeration value="ScheduleVariance">
        <xsd:enumeration value="ScrapAllowed">
        <xsd:enumeration value="ScrapQuantity">
        <xsd:enumeration value="Seats">
        <xsd:enumeration value="SecondaryNetQuantity">
        <xsd:enumeration value="SecondQuarterNon-RecurringDemand">
        <xsd:enumeration value="SecondQuarterNon-RecurringOrders">
        <xsd:enumeration value="SecondQuarterRecurringDemand">
        <xsd:enumeration value="SecondQuarterRecurringOrders">
        <xsd:enumeration value="Secretaries">
        <xsd:enumeration value="SecuredChargesRegistered">
        <xsd:enumeration value="SecuritiesShares">
        <xsd:enumeration value="Segments">
        <xsd:enumeration value="Seller">
        <xsd:enumeration value="ServiceResale">
        <xsd:enumeration value="Shareholders">
        <xsd:enumeration value="ShareholdersHoldingRemainderOfShares">
        <xsd:enumeration value="Shares">
        <xsd:enumeration value="SharesAdded">
        <xsd:enumeration value="SharesDeleted">
        <xsd:enumeration value="SharesHeldAsTreasuryStock">
        <xsd:enumeration value="SharesOfCommonStock">
        <xsd:enumeration value="SharesOfPreferredStock">
        <xsd:enumeration value="SharesOwnedByIn-StateResidents">
        <xsd:enumeration value="SharesOwnedByOut-Of-StateResidents">
        <xsd:enumeration value="SharesSubscribed">
        <xsd:enumeration value="SharesSubscribedButNotIssued">
        <xsd:enumeration value="Shifts">
        <xsd:enumeration value="Shipments">
        <xsd:enumeration value="ShipNoticeQuantity">
        <xsd:enumeration value="ShippedQuantity">
        <xsd:enumeration value="Shortage">
        <xsd:enumeration value="Short-LandedGoods">
        <xsd:enumeration value="ShortShipped">
        <xsd:enumeration value="SilentPartners">
        <xsd:enumeration value="SinceLastTravel">
        <xsd:enumeration value="SingleDeliveryQuantity">
        <xsd:enumeration value="SistersDeceased">
        <xsd:enumeration value="SistersLiving">
        <xsd:enumeration value="Site">
        <xsd:enumeration value="SizeOfHousehold">
        <xsd:enumeration value="SkilledWorker">
        <xsd:enumeration value="SmallBusinessUses">
        <xsd:enumeration value="Solicited">
        <xsd:enumeration value="SortedQuantity">
        <xsd:enumeration value="SortedQuantityRejected">
        <xsd:enumeration value="SpaceOccupied">
        <xsd:enumeration value="SpecialPartners">
        <xsd:enumeration value="SpeedCapacity">
        <xsd:enumeration value="SplitQuantity">
        <xsd:enumeration value="SplitShipment">
        <xsd:enumeration value="Standard">
        <xsd:enumeration value="Started">
        <xsd:enumeration value="StartOffset">
        <xsd:enumeration value="StartQuantity">
        <xsd:enumeration value="StateOrProvinceMotorVehiclePenaltyPoints">
        <xsd:enumeration value="StatisticalSalesQuantity">
        <xsd:enumeration value="StockTransfersIn">
        <xsd:enumeration value="StockTransfersOut">
        <xsd:enumeration value="StolenCheques">
        <xsd:enumeration value="SubcontractorAtComplete">
        <xsd:enumeration value="SubcontractorCumulativeToDate">
        <xsd:enumeration value="Subcontractors">
        <xsd:enumeration value="SubmittedQuantityReturned">
        <xsd:enumeration value="SubmittedQuantitySold">
        <xsd:enumeration value="SubsequentDeliveryQuantity">
        <xsd:enumeration value="Subsidiaries">
        <xsd:enumeration value="SubstitutionalQuantity">
        <xsd:enumeration value="Suits">
        <xsd:enumeration value="Supervisors">
        <xsd:enumeration value="SuppliedQuantity">
        <xsd:enumeration value="SupplierEstimatedLatestMeterReading">
        <xsd:enumeration value="SupplierEstimatedPreviousMeterReading">
        <xsd:enumeration value="SupplierLatestMeterReading">
        <xsd:enumeration value="SupplierPreviousMeterReading">
        <xsd:enumeration value="Suppliers">
        <xsd:enumeration value="SuppliersCredit">
        <xsd:enumeration value="SurplusGoods">
        <xsd:enumeration value="SurveysInAverageRating">
        <xsd:enumeration value="SuspendedDuration">
        <xsd:enumeration value="Swan-Ganz">
        <xsd:enumeration value="TablesAvailable">
        <xsd:enumeration value="TalkPaths">
        <xsd:enumeration value="TankAllowance">
        <xsd:enumeration value="TariffLossAllowance">
        <xsd:enumeration value="TaxableQuantity">
        <xsd:enumeration value="Teachers">
        <xsd:enumeration value="Technicians">
        <xsd:enumeration value="TheoreticalQuantity">
        <xsd:enumeration value="ThirdQuarterNon-RecurringDemand">
        <xsd:enumeration value="ThirdQuarterNon-RecurringOrders">
        <xsd:enumeration value="ThirdQuarterRecurringDemand">
        <xsd:enumeration value="ThirdQuarterRecurringOrders">
        <xsd:enumeration value="TimeExpended">
        <xsd:enumeration value="TimeFrame">
        <xsd:enumeration value="TimeInCountry">
        <xsd:enumeration value="TimeInPosition">
        <xsd:enumeration value="TimeSinceHospitalization">
        <xsd:enumeration value="TimeSinceLastApplication">
        <xsd:enumeration value="TimeSinceLastCivilianFlight">
        <xsd:enumeration value="TimeSinceLastInsuranceMedical">
        <xsd:enumeration value="TimeSinceLastMilitaryFlight">
        <xsd:enumeration value="TimeSinceMedicalConsult">
        <xsd:enumeration value="TimeSinceMedicationEnd">
        <xsd:enumeration value="TimeSinceMedicationStart">
        <xsd:enumeration value="TimeSinceOnset">
        <xsd:enumeration value="TimeSinceSurgery">
        <xsd:enumeration value="TimeSinceTrip">
        <xsd:enumeration value="TimeUnits">
        <xsd:enumeration value="TimeUnitsKnown">
        <xsd:enumeration value="TimeUnitsPerShift">
        <xsd:enumeration value="TimeUnitsSpentOnDuty">
        <xsd:enumeration value="Tires">
        <xsd:enumeration value="ToCompleteQuantityEstimated">
        <xsd:enumeration value="Tolerance">
        <xsd:enumeration value="Total">
        <xsd:enumeration value="TotalAdjustmentsVolume">
        <xsd:enumeration value="TotalAmortisationQuantity">
        <xsd:enumeration value="TotalAtComplete">
        <xsd:enumeration value="TotalAuthorizedQuantity">
        <xsd:enumeration value="TotalBeginningInventory">
        <xsd:enumeration value="TotalClaimsAssociatedWithRepeatedTrauma">
        <xsd:enumeration value="TotalClaimsWithDaysAwayFromWork">
        <xsd:enumeration value="TotalClaimsWithDisordersDueToPhysicalAgents">
        <xsd:enumeration value="TotalClaimsWithDustDiseasesOfTheLungs">
        <xsd:enumeration value="TotalClaimsWithoutDaysAwayFromWorkAndWithoutRestrictedWorkActivity">
        <xsd:enumeration value="TotalClaimsWithPoisoningIllnesses">
        <xsd:enumeration value="TotalClaimsWithRespiratoryConditionsDueToToxicAgents">
        <xsd:enumeration value="TotalClaimsWithSkinDiseasesOrDisorders">
        <xsd:enumeration value="TotalConsolidatedDomesticSubsidiaries">
        <xsd:enumeration value="TotalConsolidatedForeignSubsidiaries">
        <xsd:enumeration value="TotalConsolidatedSubsidiaries">
        <xsd:enumeration value="TotalCredits">
        <xsd:enumeration value="TotalCreditsAccepted">
        <xsd:enumeration value="TotalCreditsReceived">
        <xsd:enumeration value="TotalCreditsRejected">
        <xsd:enumeration value="TotalDaysAwayFromWork">
        <xsd:enumeration value="TotalDaysAwayFromWorkDueToIllness">
        <xsd:enumeration value="TotalDaysAwayFromWorkDueToInjury">
        <xsd:enumeration value="TotalDaysOfRestrictedWorkActivity">
        <xsd:enumeration value="TotalDaysOfRestrictedWorkActivityDueToIllness">
        <xsd:enumeration value="TotalDaysOnMarket">
        <xsd:enumeration value="TotalDaysWithRestrictedWorkActivityDueToInjury">
        <xsd:enumeration value="TotalDeathClaims">
        <xsd:enumeration value="TotalDeathsAsAResultOfIllness">
        <xsd:enumeration value="TotalDeathsAsAResultOfInjury">
        <xsd:enumeration value="TotalDebits">
        <xsd:enumeration value="TotalDebitsAccepted">
        <xsd:enumeration value="TotalDebitsReceived">
        <xsd:enumeration value="TotalDebitsRejected">
        <xsd:enumeration value="TotalDeliveryQuantity">
        <xsd:enumeration value="TotalDemandOrders">
        <xsd:enumeration value="TotalDemandQuantity">
        <xsd:enumeration value="TotalEmployees">
        <xsd:enumeration value="TotalEndingInventory">
        <xsd:enumeration value="TotalFloatTime">
        <xsd:enumeration value="TotalGasDisposition">
        <xsd:enumeration value="TotalGasInjectionVolume">
        <xsd:enumeration value="TotalIllnessClaimsWithDaysAwayFromWork">
        <xsd:enumeration value="TotalIllnessClaimsWithOccupationalIllnessesNotOtherwiseClassified">
        <xsd:enumeration value="TotalIllnessClaimsWithoutLostWorkDays">
        <xsd:enumeration value="TotalIllnessWithLostWorkDaysOrRestrictedWorkActivity">
        <xsd:enumeration value="TotalInjuryClaimsWithDaysAwayFromWork">
        <xsd:enumeration value="TotalInjuryClaimsWithDaysAwayFromWorkOrRestrictedWorkActivity">
        <xsd:enumeration value="TotalInjuryClaimsWithoutLostWorkDays">
        <xsd:enumeration value="TotalInventory">
        <xsd:enumeration value="TotalNon-ConsolidatedSubsidiaries">
        <xsd:enumeration value="TotalNumberOfConvictions">
        <xsd:enumeration value="TotalNumberOfDomesticSubsidiariesIncludedInFinancial">
        <xsd:enumeration value="TotalNumberOfDomesticSubsidiariesNotIncludedIn">
        <xsd:enumeration value="TotalNumberOfForeignSubsidiariesIncludedInFinancial">
        <xsd:enumeration value="TotalNumberOfForeignSubsidiariesNotIncludedIn">
        <xsd:enumeration value="TotalNumberOfLoanDetailRecords">
        <xsd:enumeration value="TotalNumberOfMortgagees">
        <xsd:enumeration value="TotalNumberOfParkingSpaces">
        <xsd:enumeration value="TotalNumberOfSubsidiariesNotIncludedInTheFinancial">
        <xsd:enumeration value="TotalNumberOfUnits">
        <xsd:enumeration value="TotalNumberOfUnitsForSale">
        <xsd:enumeration value="TotalNumberOfWorkersCompensationCombinedReports">
        <xsd:enumeration value="TotalNumberOfWorkersCompensationFirstReports">
        <xsd:enumeration value="TotalNumberOfWorkersCompensationSubsequentReports">
        <xsd:enumeration value="TotalOfIssuableAssets">
        <xsd:enumeration value="TotalOilAndOrCondensateDisposition">
        <xsd:enumeration value="TotalOilAndOrCondensateInjectionVolume">
        <xsd:enumeration value="TotalOtherPropertiesOwnedAndFinanced">
        <xsd:enumeration value="TotalPaymentsRejected">
        <xsd:enumeration value="TotalPost-AdvicesAccepted">
        <xsd:enumeration value="TotalPost-AdvicesReceived">
        <xsd:enumeration value="TotalPost-AdvicesRejected">
        <xsd:enumeration value="TotalPre-AdvicesAccepted">
        <xsd:enumeration value="TotalPre-AdvicesReceived">
        <xsd:enumeration value="TotalPre-AdvicesRejected">
        <xsd:enumeration value="TotalPrenotesAccepted">
        <xsd:enumeration value="TotalPrenotesReceived">
        <xsd:enumeration value="TotalPrenotesRejected">
        <xsd:enumeration value="TotalProductionVolume">
        <xsd:enumeration value="TotalPropertiesOwned">
        <xsd:enumeration value="TotalQuantityPlanned">
        <xsd:enumeration value="TotalResource-Quantity">
        <xsd:enumeration value="TotalRooms">
        <xsd:enumeration value="TotalSales">
        <xsd:enumeration value="TotalServiceBackorderQuantityHighPriority">
        <xsd:enumeration value="TotalServiceBackorderQuantityLowPriority">
        <xsd:enumeration value="TotalSharesOfStock">
        <xsd:enumeration value="TotalSystemBackorderQuantityHighPriority">
        <xsd:enumeration value="TotalSystemBackorderQuantityLowPriority">
        <xsd:enumeration value="TotalToDate">
        <xsd:enumeration value="TotalTransactions">
        <xsd:enumeration value="TotalUnidentifiedTransactionsRejected">
        <xsd:enumeration value="TotalWaterDisposition">
        <xsd:enumeration value="TotalWaterInjectionVolume">
        <xsd:enumeration value="TotalWorkedByAllEmployees">
        <xsd:enumeration value="TotalWorkingInterest">
        <xsd:enumeration value="TrademarkRepresented">
        <xsd:enumeration value="TrademarksUsed">
        <xsd:enumeration value="Trainees">
        <xsd:enumeration value="Trainers">
        <xsd:enumeration value="TransactionSets">
        <xsd:enumeration value="TransferQuantity">
        <xsd:enumeration value="TransferredInQuantity">
        <xsd:enumeration value="TransferredOutQuantity">
        <xsd:enumeration value="TravelFrequency">
        <xsd:enumeration value="TravellingEmployees">
        <xsd:enumeration value="TravelPeriod">
        <xsd:enumeration value="TripDuration">
        <xsd:enumeration value="Trips">
        <xsd:enumeration value="TrunkedChannels">
        <xsd:enumeration value="UnacknowledgedQuantity">
        <xsd:enumeration value="UnadjustedCorrectorReading">
        <xsd:enumeration value="UncoveredCheques">
        <xsd:enumeration value="UniformCommercialCodeFilings">
        <xsd:enumeration value="UnionEmployees">
        <xsd:enumeration value="Units">
        <xsd:enumeration value="UnitsCompleted">
        <xsd:enumeration value="UnitsForSale">
        <xsd:enumeration value="UnitsPerUnitPrice">
        <xsd:enumeration value="UnitsProduced">
        <xsd:enumeration value="UnitsRented">
        <xsd:enumeration value="UnitsWorkedLastDay">
        <xsd:enumeration value="UnitsWorkedPerDay">
        <xsd:enumeration value="UnitsWorkedPerQuarter">
        <xsd:enumeration value="UnitsWorkedPerWeek">
        <xsd:enumeration value="Unpaid">
        <xsd:enumeration value="UnsaleableQuantity">
        <xsd:enumeration value="UnsoldQuantityHeldByWholesaler">
        <xsd:enumeration value="UntilNextTravel">
        <xsd:enumeration value="UnusableQuantity">
        <xsd:enumeration value="UnusedAccumulatedSickDays">
        <xsd:enumeration value="UnverifiedReceipts">
        <xsd:enumeration value="UrgentDeliveryQuantity">
        <xsd:enumeration value="Used">
        <xsd:enumeration value="UseOfExtracorporealCirculation">
        <xsd:enumeration value="UseOfHyperbaricPressurization">
        <xsd:enumeration value="UseOfHypertension">
        <xsd:enumeration value="UseOfHypotension">
        <xsd:enumeration value="UseOfHypothermia">
        <xsd:enumeration value="Vacancies">
        <xsd:enumeration value="Variance">
        <xsd:enumeration value="VarianceAdjustment">
        <xsd:enumeration value="VehicularRadios">
        <xsd:enumeration value="VerifiedReceipts">
        <xsd:enumeration value="VisitationFrequency">
        <xsd:enumeration value="Visits">
        <xsd:enumeration value="VoiceStorageQuantity">
        <xsd:enumeration value="VoidVotes">
        <xsd:enumeration value="VolumeShrinkageAdjustmentOrAllowance">
        <xsd:enumeration value="Votes">
        <xsd:enumeration value="VotingSharesHeld">
        <xsd:enumeration value="WarehouseEmployees">
        <xsd:enumeration value="WarehouseSize">
        <xsd:enumeration value="WaterRe-InjectedOnProperty">
        <xsd:enumeration value="WaterVolume">
        <xsd:enumeration value="WeeksWorked">
        <xsd:enumeration value="Weight">
        <xsd:enumeration value="WeightChangePeriod">
        <xsd:enumeration value="WeightGain">
        <xsd:enumeration value="WeightLoss">
        <xsd:enumeration value="WholesalerToWholesalerSales">
        <xsd:enumeration value="WideAreaTelephoneServicePer800ServiceUnits">
        <xsd:enumeration value="WorkCalendarUnits">
        <xsd:enumeration value="WorkDays">
        <xsd:enumeration value="WorkInProcess">
        <xsd:enumeration value="WorkPeriod">
        <xsd:enumeration value="WorkTimeUnits">
        <xsd:enumeration value="WorkTimeUnitsPerShift">
        <xsd:enumeration value="Years">
        <xsd:enumeration value="YearsInSchool">
        <xsd:enumeration value="YearsInThisLineOfWorkOrProfession">
        <xsd:enumeration value="YearsOnJob">
        <xsd:enumeration value="YearsRemaining">
        <xsd:enumeration value="YesVotes">
        <xsd:enumeration value="CurrentDuration">
        <xsd:enumeration value="CurrentInventoryQuantityAvailableForShipment">
        <xsd:enumeration value="CurrentPeriodImbalance">
        <xsd:enumeration value="CurrentServiceLife">
        <xsd:enumeration value="CurrentShareBalance">
        <xsd:enumeration value="CustomerEstimatedLatestMeterReading">
        <xsd:enumeration value="CustomerEstimatedPreviousMeterReading">
        <xsd:enumeration value="CustomerReadingQuantity">
        <xsd:enumeration value="DailyAdjustments">
        <xsd:enumeration value="DailyAverageQuantity">
        <xsd:enumeration value="DailyWorkShifts">
        <xsd:enumeration value="DamagedGoods">
        <xsd:enumeration value="DataStorageQuantity">
        <xsd:enumeration value="Days">
        <xsd:enumeration value="DaysOperated">
        <xsd:enumeration value="DaysProduced">
        <xsd:enumeration value="DaysSupply">
        <xsd:enumeration value="DebentureBond">
        <xsd:enumeration value="DebenturesFiledAgainstDirectors">
        <xsd:enumeration value="Debited">
        <xsd:enumeration value="DebtCollectors">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: QuantityRangeType

QuantityRangeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( MinimumValue[MinimumValueType] , MaximumValue[MaximumValueType] )

    Description: QuantityRangeType is used to specify a range for a quantity.

    Elements:

    • MinimumValue - specifies the minimum quantity in a range.
    • MaximumValue - specifies the maximum quantity in a range.

[^]Code Fragment

    <xsd:complexType name="QuantityRangeType">
    <xsd:sequence>
        <xsd:element name="MinimumValue" type="MinimumValueType">
        <xsd:element name="MaximumValue" type="MaximumValueType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: QuantityType

QuantityType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ( QuantityValue[QuantityValueType] | QuantityRange[QuantityRangeType] ) , UnitOfMeasurement[UnitOfMeasurementType] )

    Description: QuantityType identifies a quantitative amount of an item.

    Elements:

    • QuantityValue - is used to specify a specific value of a quantity.
    • QuantityRange - is used to specify a range for a quantity.
    • UnitOfMeasurement - specifies the unit of measurement that the value or the range is specified in.

[^]Code Fragment

    <xsd:complexType name="QuantityType">
    <xsd:sequence>
        <xsd:choice>
            <xsd:element name="QuantityValue" type="QuantityValueType">
            <xsd:element name="QuantityRange" type="QuantityRangeType">
        </xsd:choice>
        <xsd:element name="UnitOfMeasurement" type="UnitOfMeasurementType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: QuantityValueType

QuantityValueType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: Extension of type: xsd:decimal

    Attribute:Name: SignificanceCoded, Type: SignificanceCodeType, Use: 'optional'
    Attribute:Name: SignificanceCodedOther, Type: xsd:string, Use: 'optional'

    Description: QuantityValueType is used to specify a specific value of a quantity.

    Attributes:

    • SignificanceCoded - describes the significance of the a quantity using a standard codelist.
    • SignificanceCodedOther - is used to provide a non-standard

[^]Code Fragment

    <xsd:complexType name="QuantityValueType">
    <xsd:simpleContent>
        <xsd:extension base="xsd:decimal">
            <xsd:attribute name="SignificanceCoded" type="SignificanceCodeType" use="optional">
            <xsd:attribute name="SignificanceCodedOther" type="xsd:string" use="optional">
        </xsd:extension>
    </xsd:simpleContent>
</xsd:complexType>


complexType definition: RangeType

RangeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( MinimumValue[MinimumValueType] , MaximumValue[MaximumValueType] )

    Description: RangeType identifies a range of values by a minimum and maximum value.

    Elements:

    • MinimumValue - holds the minimum value of the range and its inclusiveness.
    • MaximumValue - holds the maximum value of the range and its inclusiveness.

[^]Code Fragment

    <xsd:complexType name="RangeType">
    <xsd:sequence>
        <xsd:element name="MinimumValue" type="MinimumValueType">
        <xsd:element name="MaximumValue" type="MaximumValueType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: RateOfExchangeDetailType

RateOfExchangeDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ReferenceCurrency[CurrencyType] , TargetCurrency[CurrencyType] , RateOfExchange[Decimal19_9Type] , InverseRateOfExchange[Decimal19_9Type]? , IndicativeIndicator[xsd:boolean] , DateOfRateOfExchange[xsd:dateTime]? , ListOfRateOfExchangeReference[ListOfReferenceType]? )

    Description: RateOfExchangeDetailType contains the detail of the exchange rate between two currencies.

    Elements:

    • ReferenceCurrency - holds the reference currency of the rate of exchange. This is the currency from which the monetary value is to be converted from.
    • TargetCurrency - is the target currency of the rate of exchange. This is the currency from which the monetary value is to be converted to.
    • RateOfExchange - holds the value that the reference currency is to be multiplied by to convert it to the target currency.
    • InverseRateOfExchange - contains the rate of exchange given as target currency : reference currency
    • IndicativeIndicator - contains a boolean indicator to specify whether or not the FXRateResponse contains indicative rate quotes.
    • DateOfRateOfExchange - holds the date the rate of exchange was quoted.
    • ListOfRateOfExchangeReference - holds a reference to identify the rate of exchange request.

[^]Code Fragment

    <xsd:complexType name="RateOfExchangeDetailType">
    <xsd:sequence>
        <xsd:element name="ReferenceCurrency" type="CurrencyType">
        <xsd:element name="TargetCurrency" type="CurrencyType">
        <xsd:element name="RateOfExchange" type="Decimal19_9Type">
        <xsd:element minOccurs="0" name="InverseRateOfExchange" type="Decimal19_9Type">
        <xsd:element name="IndicativeIndicator" type="xsd:boolean">
        <xsd:element minOccurs="0" name="DateOfRateOfExchange" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ListOfRateOfExchangeReference" type="ListOfReferenceType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: RateType

RateType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( RatePerUnit[UnitPriceType] , UnitPriceBasis[Decimal18_3Type] , UnitOfMeasurement[UnitOfMeasurementType]? )

    Description: RateType specifies the rate that the allowance or charge is calculated on.

    Elements:

    • RatePerUnit - identifies the monetary value of the rate.
    • UnitPriceBasis - identifies the basis on which the price/rate applies.
    • UnitOfMeasurement - specifies the unit of measure of the rate.

[^]Code Fragment

    <xsd:complexType name="RateType">
    <xsd:sequence>
        <xsd:element name="RatePerUnit" type="UnitPriceType">
        <xsd:element name="UnitPriceBasis" type="Decimal18_3Type">
        <xsd:element minOccurs="0" name="UnitOfMeasurement" type="UnitOfMeasurementType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: ReasonTaxExemptCodeType

ReasonTaxExemptCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the reason for exemption from tax. This code list is derived from X12 441 (Tax exempt code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • Exempt-ForExport
    • Yes-TaxExempt
    • No-NotTaxExempt
    • Exempt-ForResale
    • NotExemptOrForResale
    • Exempt-NotForResale
    • NotExemptNotForResale
    • DirectPayId
    • Exempt-SaleToUSGovernment
    • Exempt-PerStateLaw
    • LaborTaxableMaterialExempt
    • MaterialTaxableLaborExempt
    • NotTaxable
    • Disabled
    • ExemptTollService
    • Exempt-GoodsAndServicesTax
    • Exempt-ProvincialSalesTax
    • Homestead
    • Agriculture
    • WorkingFarm
    • OpenSpace
    • ExemptLocalService
    • DisabledVeteran
    • Non-Homestead
    • Over65
    • ExemptFromSchoolPropertyTax
    • ExemptFromLocalPropertyTax
    • RecurringExempt
    • ExemptFromCountyPropertyTax
    • TotallyExempt
    • UsageExempt
    • ExemptFromStatePropertyTax
    • OtherPropertyTaxExemption
    • Exempt-LetterOnFile

[^]Code Fragment

    <xsd:simpleType name="ReasonTaxExemptCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Exempt-ForExport">
        <xsd:enumeration value="Yes-TaxExempt">
        <xsd:enumeration value="No-NotTaxExempt">
        <xsd:enumeration value="Exempt-ForResale">
        <xsd:enumeration value="NotExemptOrForResale">
        <xsd:enumeration value="Exempt-NotForResale">
        <xsd:enumeration value="NotExemptNotForResale">
        <xsd:enumeration value="DirectPayId">
        <xsd:enumeration value="Exempt-SaleToUSGovernment">
        <xsd:enumeration value="Exempt-PerStateLaw">
        <xsd:enumeration value="LaborTaxableMaterialExempt">
        <xsd:enumeration value="MaterialTaxableLaborExempt">
        <xsd:enumeration value="NotTaxable">
        <xsd:enumeration value="Disabled">
        <xsd:enumeration value="ExemptTollService">
        <xsd:enumeration value="Exempt-GoodsAndServicesTax">
        <xsd:enumeration value="Exempt-ProvincialSalesTax">
        <xsd:enumeration value="Homestead">
        <xsd:enumeration value="Agriculture">
        <xsd:enumeration value="WorkingFarm">
        <xsd:enumeration value="OpenSpace">
        <xsd:enumeration value="ExemptLocalService">
        <xsd:enumeration value="DisabledVeteran">
        <xsd:enumeration value="Non-Homestead">
        <xsd:enumeration value="Over65">
        <xsd:enumeration value="ExemptFromSchoolPropertyTax">
        <xsd:enumeration value="ExemptFromLocalPropertyTax">
        <xsd:enumeration value="RecurringExempt">
        <xsd:enumeration value="ExemptFromCountyPropertyTax">
        <xsd:enumeration value="TotallyExempt">
        <xsd:enumeration value="UsageExempt">
        <xsd:enumeration value="ExemptFromStatePropertyTax">
        <xsd:enumeration value="OtherPropertyTaxExemption">
        <xsd:enumeration value="Exempt-LetterOnFile">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: ReferenceCodedType

ReferenceCodedType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ReferenceTypeCoded[ReferenceTypeCodeType] , ReferenceTypeCodedOther[xsd:string]? , PrimaryReference[ReferenceType] , SupportingReference[ReferenceType]? , SupportingSubReference[ReferenceType]? , ReferenceDescription[xsd:string]? )

    Description: ReferenceCodedType identifies the source of the information using a standard codelist.

    Elements:

    • ReferenceTypeCoded - is used to identify the type of source of information by using a standard codelist.
    • ReferenceTypeCodedOther - is used to provide a non-standard ReferenceTypeCode. This element is mandatory if the value of ReferenceTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • PrimaryReference - holds the highest level of identification of the information source. This is typically used to identify a document.
    • SupportingReference - holds the second level of identification of the information source. This is typically used to identify a line item in the document being referenced.
    • SupportingSubReference - holds the lowest level of identification of the information source. This is typically used to reference a sub line item in a document.
    • ReferenceDescription - is used to describe a reference using free form text.

[^]Code Fragment

    <xsd:complexType name="ReferenceCodedType">
    <xsd:sequence>
        <xsd:element name="ReferenceTypeCoded" type="ReferenceTypeCodeType">
        <xsd:element minOccurs="0" name="ReferenceTypeCodedOther" type="xsd:string">
        <xsd:element name="PrimaryReference" type="ReferenceType">
        <xsd:element minOccurs="0" name="SupportingReference" type="ReferenceType">
        <xsd:element minOccurs="0" name="SupportingSubReference" type="ReferenceType">
        <xsd:element minOccurs="0" name="ReferenceDescription" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ReferenceType

ReferenceType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( RefNum[xsd:string] , RefDate[xsd:dateTime]? )

    Description: ReferenceType contains information that can be used to find further information elsewhere.

    Elements:

    • RefNum - is the reference characters which distinguish the source of information.
    • RefDate - holds the date of the reference information.

[^]Code Fragment

    <xsd:complexType name="ReferenceType">
    <xsd:sequence>
        <xsd:element name="RefNum" type="xsd:string">
        <xsd:element minOccurs="0" name="RefDate" type="xsd:dateTime">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: ReferenceTypeCodeType

ReferenceTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • AbbreviatedNewDrugApplicationNumber - Abbreviated New Drug Application Number
    • AcceptableSourceDUNSNumber - Acceptable Source DUNS Number
    • AcceptableSourcePurchaserID - Acceptable Source Purchaser ID
    • AcceptableSourceSupplierID - Acceptable Source Supplier ID
    • AccessCode - Access Code
    • AccessorialRailDiversionReferenceNumber - Accessorial Rail Diversion Reference Number
    • AccessorialStatusCode - Accessorial Status Code
    • AccidentReferenceNumber - Reference number assigned to an accident.
    • AccountCategory - Account Category
    • AccountingCode - Accounting Code
    • AccountingEquipmentLocationNumber - Accounting (Equipment) Location Number
    • AccountingFileReference - Reference of an accounting file.
    • AccountingPeriodReference - Accounting Period Reference
    • AccountManagersCode - Account Managers Code
    • AccountNumber - Identification number of an account.
    • AccountPartysBankReference - Reference number of the account party's bank.
    • AccountPartysReference - Reference of the account party.
    • AccountPayableNumber - Reference number assigned by accounts payable department to the account of a specific creditor.
    • AccountServicingBanksReferenceNumber - Reference number of the account servicing bank.
    • AccountsReceivableCustomerAccount - Accounts Receivable Customer Account
    • AccountsReceivableNumber - Reference number assigned by accounts receivable department to the account of a specific debtor.
    • AccountsReceivableOpenItem - Accounts Receivable Open Item
    • AccountsReceivableStatementNumber - Accounts Receivable Statement Number
    • AccountSuffixCode - Account Suffix Code
    • AcknowledgementOfOrderNumber - [1018] Reference number assigned by the seller to his acknowledgement of an order.
    • ActionAuthorizationNumber - A reference number authorizing an action.
    • AdditionalReferenceNumber - Reference number provided in addition to another given reference.
    • AddOnSystemNumber - Add-On System Number
    • AddresseeReference - Description to be provided.
    • AdjustedRepricedClaimReferenceNumber - Adjusted Repriced Claim Reference Number
    • AdjustedRepricedLineItemReferenceNumber - Adjusted Repriced Line Item Reference Number
    • AdjustmentControlNumber - Adjustment Control Number
    • AdjustmentMemoChargeBack - Adjustment Memo (Charge Back)
    • AdministratorsReferenceNumber - Administrator's Reference Number
    • AdversaryCase - Adversary Case
    • AdvertiserNumber - Advertiser Number
    • AdviceOfCollectionNumber - [1030] Number of the Advice of Collection attached to the Rail Consignment Note (CIM 75).
    • AdviseThroughBanksReference - Financial institution through which the advising bank is to advise the documentary credit.
    • AdvisingBanksReference - Reference number of the advising bank.
    • AeronauticalEquipmentReferenceNumber - Aeronautical Equipment Reference Number (AERNO)
    • AFE - Authorization For Expense (Afe) Number
    • AffectedSubsystemCode - Affected Subsystem Code
    • AffiliationNumber - Affiliation Number
    • AgencyAssignedEmployeeID - Agency Assigned Employee ID
    • AgencyAssignedNumber - Agency Assigned Number
    • AgencyCaseNumber - Agency Case Number
    • AgencyClaimNumber - Agency Claim Number
    • AgencyClauseNumber - A number indicating a clause applicable to a particular agency.
    • AIDAR - Agency for International Development Acquisition Regulation (AIDAR)
    • AgencyHierarchicalLevel - Agency Hierarchical Level
    • AgencyLocationCode - Agency Location Code
    • AgencysStudentNumber - Agency's Student Number. This is the number assigned by an agency other than the institution sending the record.
    • AgentClaimNumber - Agent Claim Number
    • AgentContractNumber - Agent Contract Number
    • AgentNumber - Agent Number
    • AgentsBankReference - Reference number issued by the agent's bank.
    • AgentsReference - Reference number of the agent.
    • AgentsShipmentNumber - Agent's Shipment Number
    • AGERD - Aerospace Ground Equipment Requirement Data Number: Identifies the equipment required to conduct maintenance.
    • AgreementNumber - A number specifying an agreement between parties.
    • AgreementToPayNumber
    • AirCargoTransferManifest - Air Cargo Transfer Manifest
    • AirDimensionCode - Air Dimension Code
    • AirHandlingCode - Air Handling Code
    • AirlinesFlightIdentificationNumber - (8110) Identification of a commercial flight by carrier code and number as assigned by the airline (IATA).
    • AirlineTicketNumber - Airline Ticket Number
    • AirWaybillNumber - Reference number assigned to an air waybill, see: 1001 = 740
    • AllotmentIdentification - Reference assigned to guarantied capacity on one or more specific flights on specific date(s) to third parties as agents and other airlines.
    • AllowanceRecipientIdentification - Allowance Recipient Identification
    • AlterationNumber - Alteration Number
    • AlternateClauseNumber - Alternate Clause Number
    • AmbulatoryPatientGroupNumber - Ambulatory Patient Group (APG) Number
    • AmendedUniformCommercialCodeFilingNumber - Amended Uniform Commercial Code Filing Number
    • Amendment - Amendment
    • AmendmentFiling - Amendment Filing
    • AmericanBankersAssociationTransitOrRoutingNumber - American Bankers Assoc. (ABA) Transit/Routing Number (Including Check Digit, 9 Digits)
    • AmericanGasAssociationEquationNumber - American Gas Association Equation Number
    • AmericanOsteopathicAssociationCertificationNumber - American Osteopathic Association (AOA) Certification Number
    • AmericanPetroleumInstituteDeductionCode - American Petroleum Institute (API) Deduction Code
    • AmericanPetroleumInstituteWell - American Petroleum Institute (API) Well
    • AnalysisNumberOrTestNumber - Number given to a specific analysis or test operation.
    • AnesthesiaLicenseNumber - Anaesthesia License Number
    • AnimalSpecies - Animal Species
    • AnimalStrain - Animal Strain
    • AntiDumpingCaseNumber - Reference issued by a Customs administration pertaining to a past or current investigation of goods "dumped" at a price lower than the exporter's domestic market price.
    • APE - Activate Principale Excercee Identifier: The French industry code for the main activity of a company.
    • ApplicableCoefficientIdentificationNumber - The identification number of the coefficient which is applicable.
    • ApplicableInstructionsOrStandards - Instructions or standards applicable for the whole message or a message line item. These instructions or standards may be published by a neutral organization or authority or another party concerned.
    • ApplicantsBankReference - Reference number of the applicant's bank.
    • ApplicantsReference - Reference number of the applicant.
    • ApplicationNumber - Application Number
    • ApplicationReferenceNumber
    • ApplicationTransactionReferenceNumber - Application Transaction Reference Number
    • AppointmentNumber - Appointment Number
    • AppraiserLicense - Appraiser License
    • AppropriationNumber - The number identifying a type of funding for a specific purpose (appropriation).
    • ApprovalCode - Approval Code
    • Area - Area
    • ArrivalCode - Arrival Code
    • ArticleNumber
    • AssemblyLineFeedLocation - Assembly Line Feed Location
    • AssemblyNumber - Assembly Number
    • AssessmentNumber - Assessment Number
    • AssignedByTransactionSetSender - Assigned by transaction set sender
    • AssignedContractNumber - Assigned Contract Number
    • AssignedSequenceNumber - Assigned Sequence Number
    • AssignmentNumber - Assignment Number
    • AssignmentRecordingNumber - Assignment Recording Number
    • AssociatedCaseControlNumber - Associated Case Control Number
    • AssociatedInvoices - Associated Invoices
    • AssociatedNumberForJoinedUnitNotResubdivided - Associated Number For Joined Unit not re-subdivided
    • AssociatedNumberForLimitedCommonElementParking - Associated Number For Limited Common Element Parking
    • AssociatedNumberForUnitParking - Associated Number For Unit Parking
    • AssociatedPolicyNumber - Associated Policy Number
    • AssociatedProductNumber - Associated Product Number
    • AssociatedPropertyNumber - Associated Property Number
    • AssociatedPurchaseOrders - Associated Purchase Orders
    • AssociationOfAmericanRailroadsRailwayAccountingRules - Association of American Railroads (AAR) Railway Accounting Rules
    • AssumingCompany - Description to be provided.
    • AtaCarnetNumber - Reference number assigned to an ATA carnet.
    • AtomicSafetyandLicensingBoardPanelNumber - Atomic Safety and Licensing Board Panel (ASLBP) Number
    • AttachedTo - Attached To
    • AttachmentCode - Attachment Code
    • Attorney - Attorney
    • AuthorisationForRepairReference - Reference of the authorisation for repair.
    • AuthorityIssuedEquipmentIdentification - Identification issued by an authority, e.g. government, airport authority.
    • AuthorizationNumber - A number which uniquely identifies an authorization.
    • AuthorizationNumberForExceptionToDangerousGoods - regulations Reference number allocated by an authority. This number contains an approval concerning exceptions on the existing dangerous goods regulations.
    • AuthorizationToMeetCompetitionNumber - A number assigned by a requestor to an offer incoming following request for quote.
    • AutoLossItemNumber - Auto Loss Item Number
    • ACHReturnOrNotificationOfChangeCode - Automated Clearinghouse (ACH) Return/Notification of Change (NOC) Code
    • ACHEntryDescription - Automated Clearing House (ACH) Entry Description
    • ACHStandardEntryClass - Automated Clearing House (ACH) Standard Entry Class
    • ACHTraceNumber - Automated Clearinghouse (ACH) Trace Number
    • AutomatedUnderwritingReferenceNumber - Automated Underwriting Reference Number
    • AxleRatio - Axle Ratio
    • BackoutProcedureCode - Backout Procedure Code
    • BadgeNumber - Badge Number
    • BalanceDueReferenceNumber - Balance-due Reference Number
    • BankAssignedBankersReferenceNumber - Bank Assigned Bankers Reference Number
    • BankAssignedSecurityIdentifier - Bank Assigned Security Identifier
    • BankersAcceptance - Reference number for banker's acceptance issued by the accepting financial institution.
    • BankReference - Cross reference issued by financial institution.
    • BankruptcyProcedureNumber - A number identifying a bankruptcy procedure.
    • BanksCommonTransactionReferenceNumber - Bank's reference number allocated by the bank to different underlying individual transactions.
    • BanksIndividualTransactionReferenceNumber - Bank's reference number allocated by the bank to one specific transaction.
    • BankTelegraphicNumber - Bank Telegraphic Number
    • BankToBankInformation - Bank to Bank Information
    • BarCodedLabelSerialNumber
    • BarCodedSerialNumber - Bar-Coded Serial Number
    • BargePermitNumber - Barge Permit Number
    • BasicContractLineItemNumber - Basic Contract Line Item Number
    • BatchNumberOrLotNumber - Reference number assigned by manufacturer to a series of similar products or goods produced under similar conditions.
    • BatchSequenceNumber - Batch Sequence Number
    • BeamAssemblyCode - Beam Assembly Code
    • BeginMileMarker - Begin Mile Marker
    • BeginningJobSequenceNumber - The number designating the beginning of the job sequence.
    • BeginningKanbanSerialNumber - Beginning Kanban Serial Number
    • BeginningMeterReadingActual - Meter reading at the beginning of an invoicing period.
    • BeginningMeterReadingEstimated - Meter reading at the beginning of an invoicing period where an actual reading is not available.
    • BeginningSerialNumber - Beginning Serial Number
    • BeneficiarysBankReference - Reference number of the beneficiary's bank.
    • BeneficiarysReference - Reference of the beneficiary.
    • BidNumber - Number assigned by a submitter of a bid to his bid.
    • BilateralCarServiceAgreements - Bilateral Car Service Agreements
    • BillAndHoldInvoiceNumber - Bill and Hold Invoice Number
    • BillingAccount - Billing Account
    • BillingCenterIdentification - Billing Center Identification
    • BillingType - Billing Type
    • BillOfLadingNumber - Reference number assigned to a bill of lading, see: 1001 705
    • BillofMaterialRevisionNumber - Bill of Material Revision Number
    • BillOfQuantitiesNumber - Reference number assigned to a bill of quantities.
    • BinaryObjectIdentifier - Binary Object Identifier
    • BinLocationNumber - Bin Location Number
    • BlanketOrderNumber - Reference number assigned by the order issuer to a blanket order.
    • BlendedWithBatchNumber - Blended With Batch Number
    • BlendedWithNumber - The batch/lot/package number a product is blended with.
    • Block - Block
    • BlueCrossProviderNumber - Blue Cross Provider Number
    • BlueShieldProviderNumber - Blue Shield Provider Number
    • BondedCarrierInternalRevenueServiceIdentificationNumber - Bonded Carrier Internal Revenue Service Identification Number
    • BookingReferenceNumber - [1016] Reference number assigned by the carrier or his agent when cargo space is reserved prior to loading.
    • BookNumber - A number assigned to identify a book.
    • BordereauNumber - Reference number assigned to a bordereau, see: 1001 = 787
    • BranchIdentifier - Branch Identifier
    • BrokerIdentification - Broker Identification
    • BrokerOrSalesOfficeNumber - Broker or Sales Office Number
    • BrokerReference1 - Description to be provided.
    • BrokerReference2 - Description to be provided.
    • BrokersOrderNumber - Broker's Order Number
    • BrokerReferenceNumber - Broker's Reference Number
    • BudgetChapter - A reference to the chapter in a budget.
    • BureauofLaborandStatisticsScheduleIdentifier - Bureau of Labor and Statistics Schedule Identifier
    • BureauSigningOR - OriginalFDOReference
    • BureauSigningSR - StatementReference
    • BusinessActivity - Business Activity
    • BusinessIdentificationNumber - Business Identification Number
    • BusinessTaxNumber - Business Tax Number
    • BuyerIdentification - Buyer Identification
    • BuyersApprovalMark - Buyer's Approval Mark
    • BuyersCatalogueNumber - Identification of a catalogue maintained by a buyer.
    • BuyersContractNumber - Reference number assigned by buyer to a contract.
    • BuyersCreditMemo - Buyer's Credit Memo
    • BuyersDebitMemo - Buyer's Debit Memo
    • BuyersDebtorNumber - Reference number assigned to a debtor.
    • BuyersItemNumber - Reference number assigned by the buyer to an item.
    • BuyersOrderNumber - [1022] Reference number assigned by the buyer to an order.
    • BuyersShipmentMarkNumber - Buyer's Shipment Mark Number
    • CadFileLayerConvention - Reference number identifying a layer convention for a file in a Computer Aided Design (CAD) environment.
    • Calendar - A calendar reference number.
    • CalendarNumber - Calendar Number
    • CallOffOrderNumber
    • CallSign - Call Sign
    • CanadianExciseEntryNumber - An excise entry number assigned by the Canadian Customs.
    • CanadianFinancialInstitutionBranchAndInstitutionNumber - Canadian Financial Institution Branch and Institution Number
    • CanadianGoodsAndServicesorQuebecSalesTaxReferenceNumber - Canadian Goods and Services or Quebec Sales Tax Reference Number
    • CanadianProvinceOperatingAuthorityNumber - Canadian Province Operating Authority Number
    • CanadianSocialInsuranceNumber - Canadian Social Insurance Number
    • CanadianWheatBoardPermitNumber - Canadian Wheat Board Permit Number
    • CanceledRevisionNumber - Canceled Revision Number
    • CardAccountReportingIdentifier - Card Account Reporting Identifier
    • CardAccountReportingLevel - Card Account Reporting Level
    • CardAccountStatusCode - Card Account Status Code
    • CardAccountTypeCode - Card Account Type Code
    • CardBillingTypeCode - Card Billing Type Code
    • CardIssuerTransactionCode - Card Issuer Transaction Code
    • CargoAcceptanceOrderReferenceNumber - Reference assigned to the cargo acceptance order.
    • CargoControlNumber - Reference used to identify and control a carrier and consignment from initial entry into a country until release of the cargo by Customs.
    • CargoManifestNumber - Reference number assigned to a cargo manifest, see: 1001 785
    • CarnetNumber - Carnet Number
    • CarrierAssignedCode - Carrier Assigned Code
    • CarrierAssignedConsigneeNumber - Carrier-assigned Consignee Number
    • CarrierAssignedPackageIdentificationNumber - Carrier Assigned Package Identification Number
    • CarrierAssignedReferenceNumber - Carrier Assigned Reference Number
    • CarrierAssignedShipperNumber - Carrier-assigned Shipper Number
    • CarriersAgentReferenceNumber - Reference number assigned by the carriers agent to a transaction.
    • CarriersCustomsBondNumber - Carrier's Customs Bond Number
    • CarriersReferenceNumber - Reference number assigned by carrier to a consignment.
    • CaseNumber - Number assigned to a case.
    • CaseOfNeedPartysReference - Reference number of the case of need party.
    • CasualtyReportNumber - Casualty Report Number
    • CasualtyReportSerialNumber - Casualty Report Serial Number
    • Catalog - Catalog
    • CatalogueSequenceNumber - A number which uniquely identifies an item within a catalogue according to a standard numbering system.
    • CatastropheNumber
    • CategoryOfWorkReference - A reference identifying a category of work.
    • CedentsClaimNumber - To identify the number assigned to the claim by the ceding company.
    • CedingCompany - Company selling obligations to a third party.
    • CeilingFormulaReferenceNumber - The reference number which identifies a formula for determining a ceiling.
    • CensusAutomatedFilesID - Census Automated Files ID
    • CensusBlockGroup - Census Block Group
    • CensusStateCode - Census State Code
    • CensusTract - Census Tract
    • CensusTractSuffix - Census Tract Suffix
    • CentralSecretariatLogNumber - The reference log number assigned by the central secretariat for the Data Maintenance Request (DMR).
    • CentralSecretariatLogNumberChildDataMaintenance - Request (DMR) The reference log number assigned by the central secretariat for the child Data Maintenance Request (DMR).
    • CentralSecretariatLogNumberParentDataMaintenance - Request (DMR) The reference log number assigned by the central secretariat for the parent Data Maintenance Request (DMR).
    • CertificateNumber - Certificate Number
    • CertificateOfConformity - Certificate certifying the conformity to predefined definitions.
    • CertificateofIncorporationNumber - Certificate of Incorporation Number
    • CertificateofTransportation - Certificate of Transportation
    • Certification - Certification
    • CertifiedMailNumber - Certified Mail Number
    • CRNA - Certified Registered Nurse Anaesthetist (CRNA) Provider Identification Number
    • ChamberOfCommerceNumber - Chamber of Commerce Number
    • ChamberOfCommerceRegistrationNumber - The registration number by which a company/organization is known to the Chamber of Commerce.
    • CHAMPUSIdentificationNumber - CHAMPUS Identification Number
    • ChangeDocumentNumber - Change Document Number
    • ChangeNumber - Change Number
    • ChangeOrderAuthority - Change Order Authority
    • ChangeVerificationProcedureCode - Change Verification Procedure Code
    • ChargeCardAccountNumber - Number to identify charge card account.
    • ChargeCardNumber - Charge Card Number
    • ChargeNoteReferenceNumber - [1070] Indication in pre-printed form that a Charges note has been established and is attached to the Rail Consignment Note (CIM 76).
    • ChargeNumber - Charge Number
    • CharterNumber - Charter Number
    • CheckingNumber - Number assigned by checking party to one specific check action.
    • CheckListNumber - Check List Number
    • CheckNumber - Check Number
    • ChemicalAbstractServiceRegistryNumber - Chemical Abstract Service Registry Number
    • ChequeNumber - Unique number assigned to one specific cheque.
    • CircuitNumber - Circuit Number
    • Circular - Circular
    • CircularPublicationNumber - A number specifying a circular publication.
    • Citation - Citation
    • CitationOfOpinion - Citation of Opinion
    • CitationOfStatute - Citation of Statute
    • CitizenshipDocumentNumber - Citizenship Document Number
    • CivilActionNumber - Civil Action Number
    • CivilLiabilitiesofOilCertificate - Civil Liabilities of Oil Certificate
    • ClaimAdministratorClaimNumber - Claim Administrator Claim Number
    • ClaimantNumber - Claimant Number
    • ClaimantsClaimNumber - Claimant's Claim Number
    • ClaimNumber - Claim Number
    • ClaimOfficeNumber - Claim Office Number
    • ClassCode - Class Code
    • ClassOfContractCode - Class of Contract Code
    • ClauseNumber - Clause Number
    • ClearingHouseInterbankPaymentsSystemSequenceNumber - Clearing House Interbank Payments System (CHIPS) Sequence Number
    • ClearingHouseInterbankPaymentSystemParticipantNumber - Clearing House Interbank Payment System (CHIPS) Participant Number (3 or 4 Digits)
    • ClearingHouseInterbankPaymentSystemUserIdentification - Clearing House Interbank Payment System (CHIPS) User Identification (6 digits)
    • ClearingReference - Reference allocated by a clearing procedure.
    • ClearTextClause - Clear Text Clause
    • ClientCompanyCode - Client Company Code
    • ClientNumber - Client Number
    • ClientReportingCategory - Client Reporting Category
    • ClinicalLaboratoryImprovementAmendmentNumber - Clinical Laboratory Improvement Amendment Number
    • ClinicNumber - Clinic Number
    • CoalAuthorityNumber - Coal Authority Number
    • CodeOfFederalRegulations - Code of Federal Regulations
    • CoilNumber - Coil Number
    • ColdRollNumber - Number attributed to a cold roll coil.
    • CollectingBanksReference - Reference number of the collecting bank.
    • CollectorIdentification - Collector Identification
    • CollocationIndicator - Collocation Indicator
    • CombinedShipment - Combined Shipment
    • CommercialOrPrivatePassengerVehicleQualifier - Commercial/Private Passenger Vehicle Qualifier
    • CommercialAccountSummaryReferenceNumber - A reference number identifying a commercial account summary.
    • CommercialandGovernmentEntityCode - Commercial and Government Entity (CAGE) Code
    • CommercialDriversLicense - Commercial Driver's License
    • CommercialInvoiceNumber - Commercial Invoice Number
    • CommercialRegistrationNumber - Commercial Registration Number
    • CommercialVehicleSafetyAssuranceNumber - Commercial Vehicle Safety Assurance Number
    • CommitmentNumber - Commitment Number
    • CommitteeOnUniformSecurityIdentificationProceduresNumber - Committee on Uniform Security Identification Procedures (CUSIP) Number
    • CommodityNumber
    • CommonAccessReferenceNumber - Common Access Reference Number
    • CommonTransactionReferenceNumber - Reference number applicable to different underlying individual transactions.
    • CompanyAndPlaceRegistrationNumber - Company registration and place as legally required.
    • CompanyAndSyndicateReference1 - Description to be provided.
    • CompanyAndSyndicateReference2 - Description to be provided.
    • CompanyIssuedEquipmentId - Owner/operator, non-government issued equipment reference number.
    • CRO - Company's Registry Office (CRO) Number
    • ComparableProperty - Comparable Property
    • ComparablePropertyPendingSaleReferenceNumber - Comparable Property Pending Sale Reference Number
    • ComparablePropertySaleReferenceNumber - Comparable Property Sale Reference Number
    • ComparablePropertyVerificationSource - Comparable Property Verification Source
    • CompetentAuthority - Competent Authority
    • Complaint - Complaint
    • ComplaintCode - Complaint Code
    • CompletedUnitsPaymentRequestReference - A reference to a payment request for completed units.
    • ComplianceCodeNumber - Number assigned to indicate regulatory compliance.
    • Component - Component
    • ConditionOfPurchaseDocumentNumber - Reference number identifying the conditions of purchase relevant to a purchase.
    • ConditionOfSaleDocumentNumber - Reference number identifying the conditions of sale relevant to a sale.
    • CondominiumIdentificationNumber - Condominium Identification Number
    • CongressionalDistrict - Congressional District
    • ConnectingCarrier - Connecting Carrier
    • ConsigneeReferenceNumber - Consignee Reference Number
    • ConsigneesFurtherOrder - Reference of an order given by the consignee after departure of the means of transport.
    • ConsigneesInvoiceNumber - The invoice number assigned by a consignee.
    • ConsigneesOrderNumber - Consignee's Order Number
    • ConsigneesReleaseNumber - Consignee's Release Number
    • ConsigneesShipmentReferenceNumber - [1362] Reference assigned by the consignee to a shipment.
    • ConsignmentClassificationID - Consignment Classification ID
    • ConsignorsFurtherOrder - Reference of an order given by the consignor after departure of the means of transport.
    • ConsignorsReferenceNumber - [1140] Reference number assigned by a consignor to a particular shipment for his own purposes or for those of the consignee.
    • ConsolidatedInvoiceNumber - Invoice number into which other invoices are consolidated.
    • ConsolidationShipmentNumber - Consolidation Shipment Number
    • ConsolidatorsReceiptNumber - Consolidator's Receipt Number
    • ConstraintNotation - Identifies a reference to a constraint notation.
    • ConsumerIdentifier - Consumer Identifier
    • ConsumptionDataRequestNumber - A number which identifies a request for consumption data.
    • ContainerOrEquipmentReceiptNumber - Number of the Equipment Interchange Receipt issued for full or empty equipment received.
    • ContainerOrPackagingSpecificationNumber - Container/Packaging Specification Number
    • ContainerDispositionOrderReferenceNumber - Reference assigned to the empty container disposition order.
    • ContainerOperatorsReferenceNumber - Reference number assigned by the party operating or controlling the transport container to a transaction or consignment.
    • ContainerPrefix - The first part of the unique identification of a container formed by an alpha code identifying the owner of the container.
    • ContainerSequenceNumber - Container Sequence Number
    • ContainerWorkOrderReferenceNumber - Reference number assigned by the principal to the work order for a (set of) container(s).
    • ContinuationFiling - Continuation Filing
    • ContinuationUniformCommercialCodeFilingNumber - Continuation Uniform Commercial Code Filing Number
    • ContinuousMoveNumber - Continuous Move Number
    • ContinuousTransferNumber - Continuous Transfer Number
    • ContractAddendumNumber - [1318] Reference number assigned by the issuer to a Contract Addendum.
    • ContractAuditorIDNumber - Contract Auditor ID Number
    • ContractBreakdownReference - A reference which identifies a specific breakdown of a contract.
    • ContractCoopNumber - Contract Co-op Number
    • ContractHolderClaimNumber - Contract Holder Claim Number
    • ContractLineItemNumber - Contract Line Item Number
    • ContractNumber - Reference number of a contract concluded between parties.
    • ContractOptionNumber - Contract Option Number
    • ContractorDataRequirementsList - Contractor Data Requirements List (CDRL)
    • ContractorEstablishmentCode - Contractor Establishment Code (CEC)
    • ContractorRequestReference - Reference identifying a request made by a contractor.
    • ContractPartyReferenceNumber - Reference number assigned to a party for a particular contract.
    • ContractReference - Contract Reference
    • ContractRiderNumber - Contract Rider Number (Used in conjunction with contract number)
    • ConveyanceReferenceNumber - [8028] Unique reference given by the carrier to a certain journey or departure of a means of transport (generic term).
    • CooperationContractNumber - Number issued by a party concerned given to a contract on cooperation of two or more parties.
    • CornboreCertificationNumber - Cornbore Certification Number
    • CorrectedBatchNumber - Corrected Batch Number
    • CorrectedContractNumber - Corrected Contract Number
    • CorrectedSocialSecurityNumber - Corrected Social Security Number
    • CorrectionNumber - Correction Number
    • CorrelationID - Correlation ID
    • CostAccount - A cost control account reference.
    • CostAllocationReference - Cost Allocation Reference
    • CostaRicanJudicialNumber - A number assigned by the government to a business in Costa Rica.
    • CostCentre - A number identifying a cost centre.
    • CostElement - Cost Element
    • CountyBusinessRegistrationNumber - County Business Registration Number
    • CountyCode - County Code
    • CountyLegislativeDistrict - County Legislative District
    • CouponDistributionMethod - Coupon Distribution Method
    • CouponRedemptionNumber - Coupon Redemption Number
    • CoverageCode - Coverage Code
    • CreditCard - Credit Card
    • CreditCounselingIdentificationNumber - Credit Counseling Identification Number
    • CreditMemoNumber - Reference number assigned by issuer to a credit memo.
    • CreditNoteNumber - Reference number assigned to a credit note.
    • Creditor - Creditor
    • CreditorDebitAdjustmentNumber - Credit or Debit Adjustment Number
    • CreditorsReferenceNumber - Reference number of the party to whom a debt is owed.
    • CreditRatingAgencysReferenceNumber - Reference number assigned by a credit rating agency to a debtor.
    • CreditReferenceNumber - The reference number of a credit instruction.
    • CreditReportNumber - Credit Report Number
    • CreditRepositoryCode - Credit Repository Code
    • CriticalApplication - Critical Application
    • CriticalityDesignator - Criticality Designator
    • CropYear - Crop Year
    • CrossListedCourseNumber - Cross-listed Course Number
    • CrossReferenceNumber - Cross Reference Number
    • CS54KeyTrainIndicatorCode - CS54 Key Train Indicator Code
    • CS54KeyTrainIndicatorGroupName - CS54 Key Train Indicator Group Name
    • CurrentCertificateNumber - Current Certificate Number
    • CurrentInvoiceNumber - Reference number identifying the current invoice.
    • CurrentorLatestCourseNumber - Current or Latest Course Number
    • CurrentProceduralTerminologyCode - Current Procedural Terminology Code
    • CurrentRevisionNumber - Current Revision Number
    • CustomerCatalogNumber - Customer Catalog Number
    • CustomerMaintenancePeriodSequenceNumber - Customer Maintenance Period Sequence Number
    • CustomerMaterialSpecificationNumber - Number for a material specification given by customer.
    • CustomerOrderNumber - Customer Order Number
    • CustomerProcessSpecificationNumber - Retrieval number for a process specification defined by customer.
    • CustomerReferenceNumber - Reference number assigned by the customer to a transaction.
    • CustomerReferenceNumberAssignedToPreviousBalanceOf - payment information Identification number of the previous balance of payments information from customer message.
    • CustomersCommonTransactionReferenceNumber - Customer's reference number allocated by the customer to different underlying individual transactions.
    • CustomersIndividualTransactionReferenceNumber - Customer's reference number allocated by the customer to one specific transaction.
    • CustomersPartNumber - Customer's Part Number
    • CustomerSpecificationNumber - Retrieval number for a specification defined by customer.
    • CustomersReleaseNumber - Customer's Release Number
    • CustomersUnitInventoryNumber - Number assigned by customer to a unique unit for inventory purposes.
    • CustomerTrackingNumberForLoanedMaterials - Customer Tracking Number For Loaned Materials
    • CustomsBarCodeNumber - Customs Bar Code Number
    • CustomsBrokerReferenceNumber - Customs Broker Reference Number
    • CustomsDecisionRequestNumber - Reference issued by Customs pertaining to a pending tariff classification decision requested by an importer or agent.
    • CustomsDeclarationNumber - [1426] Number, assigned or accepted by Customs, to identify a Goods declaration.
    • CustomsDrawbackEntryNumber - Customs Drawback Entry Number
    • CustomsGuaranteeNumber - Reference assigned to a Customs guarantee.
    • CustomshouseBrokerLicenseNumber - Customshouse Broker License Number
    • CustomsItemNumber - Number (1496 in CST) assigned by the declarant to an item.
    • CustomsPreferenceInquiryNumber - The number assigned by Customs to a preference inquiry.
    • CustomsReleaseCode - A code associated to a requirement that must be presented to gain the release of goods by Customs.
    • CustomsTariffNumber - [7282] Code number of the goods in accordance with the tariff nomenclature system of classification in use where the Customs declaration is made.
    • CustomsTranshipmentNumber - Approval number issued by Customs for cargo to be transhipped under Customs control.
    • CustomsValuationDecisionNumber - Reference by an importing party to a previous decision made by a Customs administration regarding the valuation of goods.
    • CutNumber - Cut Number
    • DangerousGoodsSecurityNumber - Reference number allocated by an authority in order to control the dangerous goods on board of a specific means of transport for dangerous goods security purposes.
    • DangerousGoodsTransportLicenceNumber - Licence number allocated by an authority as to the permission of carrying dangerous goods by a specific means of transport.
    • DataAuthenticationNumber - Data Authentication Number
    • DataItemDescriptionReference - Data Item Description (DID) Reference
    • DataQualityRejectReason - Data Quality Reject Reason
    • DataReliabilityCode - Data Reliability Code
    • DataSource - Data Source
    • DataStructureTag - The tag assigned to a data structure.
    • DealerIdentification - Dealer Identification
    • DealerNumber - Dealer Number
    • DealerOrderNumber - Dealer Order Number
    • Dealerpurchaseordernumber - Dealer purchase order number
    • DealerTypeIdentification - Dealer Type Identification
    • DebitAccountNumber - Reference number assigned by issuer to a debit account.
    • DebitNoteNumber - Reference number assigned by issuer to a debit note.
    • DebitReferenceNumber - The reference number of a debit instruction.
    • Debtor - Debtor
    • DebtorsAccount - Debtor's Account
    • DebtorsReferenceNumber - Reference number of the party who owes an amount of money.
    • DeclarantsCustomsIdentityNumber - Reference to the party whose posted bond or security is being declared in order to accept responsibility for a goods declaration and the applicable duties and taxes.
    • DeclarantsReferenceNumber - Unique reference number assigned to a document or a message by the declarant for identification purposes.
    • DefectCodeNumber - Defect Code Number
    • DefenseFederalAcquisitionRegulations - Defense Federal Acquisition Regulations (DFAR)
    • DefensePrioritiesAllocationSystemPriorityRating - A reference indicating a priority rating assigned to allocate resources for defense purchases.
    • DefermentApprovalNumber - Number assigned by authorities to a party to approve deferment of payment of tax or duties.
    • DeferredPaymentReference - [1168] Reference or indication of the deferred payment of duty/tax.
    • DeliveryNoteNumber - Reference number assigned by the issuer to a delivery note.
    • DeliveryNumber - Reference number by which a haulier/carrier will announce himself at the container terminal or depot when delivering equipment.
    • DeliveryOrderNumber - Reference number assigned by issuer to a delivery order.
    • DeliveryQuoteNumber - Delivery Quote Number
    • DeliveryReference - Delivery Reference
    • DeliveryRegion - Delivery Region
    • DeliveryScheduleNumber - Reference number assigned by buyer to a delivery schedule.
    • DeliveryTicketNumber - Delivery Ticket Number
    • DeliveryTrailerManifest - Delivery Trailer Manifest
    • DeliveryVerificationCertificate - Formal identification of delivery verification certificate which is a formal document from Customs etc. confirming that physical goods have been delivered. It may be needed to support a tax reclaim based on an invoice.
    • DenialReasonIdentifier - Denial Reason Identifier
    • DensityOrderNumber - Density Order Number
    • DentalInsuranceAccountNumber - Dental Insurance Account Number
    • DentalInsurancePolicyNumber - Dental Insurance Policy Number
    • DentistLicenseNumber - Dentist License Number
    • Department - Section of an organisation.
    • DepartmentOrAgencyNumber - Department/Agency Number
    • DepartmentNumber - Number assigned to a department within an organization.
    • DepartmentofAgricultureAcquisitionRegulation - Department of Agriculture Acquisition Regulation (AGAR)
    • DepartmentofCommerceAcquisitionRegulation - Department of Commerce Acquisition Regulation (CAR)
    • DepartmentOfDefenseForm250RequirementCode - Department of Defense Form 250 Requirement Code
    • DepartmentOfDefenseIdentificationCode - Department of Defense Identification Code (DoDIC)
    • DDTSCN - Department of Defense Transportation Service Code Number (Household Goods)
    • DepartmentofEducationAcquisitionRegulation - Department of Education Acquisition Regulation (EDAR)
    • DepartmentofEnergyAcquisitionRegulation - Department of Energy Acquisition Regulation (DEAR)
    • HHSAR - Department of Health and Human Services Acquisition Regulation (HHSAR)
    • HUDAR - Department of Housing and Urban Development Acquisition Regulation (HUDAR)
    • DepartmentofInteriorAcquisitionRegulation - Department of Interior Acquisition Regulation (DIAR)
    • DepartmentofJusticeAcquisitionRegulation - Department of Justice Acquisition Regulation (JAR)
    • DepartmentofLaborAcquisitionRegulation - Department of Labor Acquisition Regulation (DOLAR)
    • DepartmentofStateAcquisitionRegulation - Department of State Acquisition Regulation (DOSAR)
    • DepartmentoftheTreasuryAcquisitionOrProcurementRegulation - Department of the Treasury Acquisition/Procurement Regulation (TAPR)
    • DepartmentofTransportationAcquisitionRegulation - Department of Transportation Acquisition Regulation (TAR)
    • DepartmentOfTransportationBondNumber - Number of a bond assigned by the department of transportation.
    • DepartmentofTransportationHazardousNumber - Department of Transportation Hazardous Number
    • DepartmentofVeteransAffairsAcquisitionRegulations - Department of Veterans Affairs Acquisition Regulations (VAAR)
    • DepartmentWhereInjuryOccurredIdentification - Department Where Injury Occurred Identification
    • DeparturefromSpecificationClassCode - Departure from Specification Class Code
    • DeparturefromSpecificationNumber - Departure from Specification Number
    • DeparturefromSpecificationTypeCode - Departure from Specification Type Code
    • DependentsInformation - Dependents Information
    • DepositAccountNumber - Deposit Account Number
    • DepositNumber - Deposit Number
    • DepositorNumber - Depositor Number
    • DepositoryTrustCompanyIdentification - Depository Trust Company Identification
    • DepositSequenceNumber - Deposit Sequence Number
    • DeratCertificate - Derat Certificate
    • DescriptionOfChangeCode - Description of Change Code
    • DespatchAdviceNumber - Reference number assigned by issuing party to a despatch advice.
    • DespatchNotePostParcelsNumber - (1128) Reference number assigned to a despatch note (post parcels), see: 1001 = 750.
    • DespatchNoteNumber - [1128] Reference number assigned by the seller to a Despatch Note.
    • DestinationofShipmentHarmonizedBasedCode - Destination of Shipment Harmonized-Based Code
    • DiagnosisRelatedGroupNumber - Diagnosis Related Group (DRG) Number
    • DirectDebitReference - Reference number assigned to the direct debit operation.
    • DirectoryNumber - Directory Number
    • DirectPaymentValuationNumber - Reference number assigned to a direct payment valuation.
    • DirectPaymentValuationRequestNumber - Reference number assigned to a direct payment valuation request.
    • DisabilityInsuranceAccountNumber - Disability Insurance Account Number
    • DisabilityInsurancePolicyNumber - Disability Insurance Policy Number
    • DiscounterRegistrationNumber - Discounter Registration Number
    • DispensationReference - A reference number assigned to an official exemption from a law or obligation.
    • DisposalTurnInDocumentNumber - Disposal Turn-In Document Number
    • DisputeNumber - Reference number to a dispute notice.
    • DistributionCenterNumber - Distribution Center Number
    • DistributionList - Distribution List
    • DistributionStatementCode - Distribution Statement Code
    • DistributorAssignedOrderNumber - Distributor Assigned Order Number
    • DistributorAssignedTransactionNumber - Distributor Assigned Transaction Number
    • DistributOrInvoiceNumber - Reference number assigned by issuer to a distributor invoice.
    • DistributorsAccountIdentification - Distributor's Account Identification
    • DistributorsAccountNumber - Distributor's Account Number
    • DistributorsRepresentativeIdentification - Distributor's Representative Identification
    • DistributorsSplitAgentNumber - Distributor's Split Agent Number
    • DistrictNumber - District Number
    • DiversionAuthorityNumber - Diversion Authority Number
    • DivisionIdentifier - Division Identifier
    • DocketNumber - Docket Number
    • DockNumber - Dock Number
    • DockReceiptNumber - Number of the cargo receipt submitted when cargo is delivered to a marine terminal.
    • DocumentaryCreditAmendmentNumber - Number of the amendment of the documentary credit.
    • DocumentaryCreditNumber - [1172] Reference number assigned by issuing bank to a Documentary credit.
    • DocumentaryPaymentReference - Reference of the documentary payment.
    • DocumentationAffectedNumber - Documentation Affected Number
    • DocumentIdentificationCode - Document Identification Code
    • DocumentNumber - [1004] Reference number assigned to the document by the issuer.
    • DocumentVolumeNumber - The number of a document volume.
    • DomesticFlightNumber - Airline flight number assigned to a flight originating and terminating within the same country.
    • DomesticInventoryManagementCode - Code to identify the management of domestic inventory.
    • DomicileBranchNumber - Domicile Branch Number
    • DominionOfCanadaCode - Dominion of Canada Code
    • DownstreamShipperContractNumber - Downstream Shipper Contract Number
    • DraftNumber - Draft Number
    • DrainholeNumber - Drainhole Number
    • DraweesReference - Reference number of the drawee.
    • DrawingListNumber - Reference number identifying a drawing list.
    • DrawingNumber - Reference number identifying a specific product drawing.
    • DrawingRevisionNumber - Drawing Revision Number
    • DrawingType - Drawing Type
    • DriversLicense - Driver's License
    • DrugEnforcementAdministrationNumber - Drug Enforcement Administration Number
    • DrugEnforcementAdministrationOrderBlankNumber - Drug Enforcement Administration Order Blank Number
    • DrugFormularyNumber - Drug Formulary Number
    • DunAndBradstreetCanadas8DigitStandardIndustrial - Classification (SIC) code Dun and Bradstreet Canada's 8 digit Standard Industrial Classification (SIC) code identifying activities of the company.
    • DunAndBradstreetUS8DigitStandardIndustrial - Classification (SIC) code Dun and Bradstreet United States' 8 digit Standard Industrial Classification (SIC) code identifying activities of the company.
    • DUNSNumberwithFourCharacterSuffix - D-U-N-S+4, D-U-N-S Number with Four Character Suffix
    • DUNSNumberDunAndBradstreet - D-U-N-S Number Dun and Bradstreet
    • DuplicateBillNumber - Duplicate Bill Number
    • DuplicateWaybillinRoute - Duplicate Waybill in Route
    • DuplicateWaybillNotInRoute - Duplicate Waybill Not in Route
    • DutyFreeProductsReceiptAuthorisationNumber - Authorisation number allocated for the receipt of duty free products.
    • DutyFreeProductsSecurityNumber - A security number allocated for duty free products.
    • DutyMemoNumber - Reference number assigned by customs to a duty memo.
    • DyeLotNumber - Dye Lot Number
    • ECCN - Export Control Commodity Number Reference: number to relevant item within Commodity Control List covering actual products change functionality.
    • EducationalInstitutionIdentificationNumber - Educational Institution Identification Number
    • ElectionDistrict - Election District
    • ElectronicDataInterchangeAgreementNumber - Electronic Data Interchange Agreement Number
    • Electronicdevicepinnumber - Electronic device pin number
    • ElectronicFundsTransferIDNumber - Electronic Funds Transfer ID Number
    • ElectronicPaymentReferenceNumber - Electronic Payment Reference Number
    • Elevation - Elevation
    • EmbargoNumber - Number assigned to specific goods or a family of goods in a classification of embargo measures.
    • EmbargoPermitNumber - Reference number assigned by issuer to an embargo permit.
    • EmergencyOrderNumber - Emergency Order Number
    • EmissionDesignator - Emission Designator
    • EmployeeOrNonEmployeeClassificationQualifier - Employee/Non-Employee Classification Qualifier
    • EmployeeIdentificationNumber - Employee Identification Number
    • EmployeeTaxFilingStatusCode - Employee Tax Filing Status Code
    • EmployerIdentificationNumberOfServiceBureau - Reference number assigned by a service/processing bureau to an employer.
    • EmployersIdentificationNumber - Number issued by an authority to identify an employer.
    • EmployersSocialSecurityNumber - Employer's Social Security Number
    • EmploymentVisa - Employment Visa
    • EmptyContainerBillNumber - Reference number assigned to an empty container bill, see: 1001 = 708.
    • EmptyRepositioningNumber - Empty Repositioning Number
    • EndingJobSequenceNumber - Description to be provided.
    • EndingKanbanSerialNumber - Ending Kanban Serial Number
    • EndingMeterReadingActual - Meter reading at the end of an invoicing period.
    • EndingMeterReadingEstimated - Meter reading at the end of an invoicing period where an actual reading is not available.
    • EndingPackageNumber - Ending Package Number
    • EndingSerialNumber - Ending Serial Number
    • EndItem - End Item
    • EndItemNumber - A number specifying the end item applicable to a subordinate item.
    • EndMileMarker - End Mile Marker
    • EndorsementNumber - Endorsement Number
    • EndUseAuthorizationNumber - Reference issued by a Customs administration authorizing a preferential rate of duty if a product is used for a specified purpose, see: 1001 = 990.
    • EndUseNumber - End Use Number
    • EndUsersPurchaseOrderNumber - End User's Purchase Order Number
    • EngineeringChangeOrder - Engineering Change Order
    • EngineeringChangeProposal - Engineering Change Proposal
    • EngineeringDataList - Engineering Data List
    • EngineeringSpecificationNumber - Engineering Specification Number
    • EnquiryNumber - Reference number assigned to an enquiry.
    • EntryPointAssessmentLogNumber - The reference log number assigned by an entry point assessment group for the DMR.
    • EntryPointAssessmentLogNumberChildDmr - The reference log number assigned by an entry point assessment group for a child Data Maintenance Request (DMR).
    • EntryPointAssessmentLogNumberParentDmr - The reference log number assigned by an entry point assessment group for the parent Data Maintenance Request (DMR).
    • EnvironmentalProtectionAgencyAcquisitionRegulation - Environmental Protection Agency Acquisition Regulation (EPAAR)
    • EnvironmentalProtectionAgencyTestTypePurposeCode - Environmental Protection Agency (EPA) Test Type Purpose Code
    • EnvironmentalProtectionAgencyTransporterIdentificationNumber - Environmental Protection Agency Transporter Identification Number
    • EquipmentInitial - Equipment Initial
    • EquipmentNumber - Number assigned by the manufacturer to specific equipment.
    • EquipmentOwnerReferenceNumber - Reference number issued by the owner of the equipment.
    • EquipmentSequenceNumber - A temporary reference number identifying a particular piece of equipment within a series of pieces of equipment.
    • EquipmentTransportChargeNumber - Reference assigned to a specific equipment transportation charge.
    • EquivalentCourseNumberatRequestingInstitution - Equivalent Course Number at Requesting Institution
    • ErrorIdentificationCode - Error Identification Code
    • EscrowFileNumber - Escrow File Number
    • EstimateNumber - Estimate Number
    • EstimateOrderReferenceNumber - Reference number assigned by the ordering party of the estimate order.
    • EstimateSequenceNumber - Estimate Sequence Number
    • EtermsReference - Identifies a reference to the ICC (International Chamber of Commerce) ETERMS(tm) repository of electronic commerce trading terms and conditions.
    • Eur1CertificateNumber - Reference number assigned to a Eur 1 certificate.
    • EventReferenceNumber - A number identifying an event.
    • ExcessTransportationNumber - Number assigned to excess transport.
    • ExhibitDistributionList - Exhibit Distribution List
    • ExhibitIdentifier - Exhibit Identifier
    • ExpansiononEffectofChangeNumber - Expansion on Effect of Change Number
    • ExportClearanceInstructionReferenceNumber - Reference number of the clearance instructions given by the consignor through different means.
    • ExportDeclaration - Number assigned by the exporter to his export declaration number submitted to an authority.
    • ExportersReferenceNumber - Reference to a party exporting goods.
    • ExportEstablishmentNumber - Number to identify export establishment.
    • ExportLicenceNumber - [1208] Reference number assigned by issuing authority to an Export Licence.
    • ExportPermitNumber - Reference number assigned by issuing authority to an export permit for products.
    • ExportReferenceNumber - Reference number given to an export shipment.
    • ExtendedOrExhibitLineItemNumber - Extended (or Exhibit) Line Item Number (ELIN)
    • FacilityCertificationNumber - Facility Certification Number
    • FacilityIDNumber - Facility ID Number
    • FacilityMeasurementPointNumber - Facility Measurement Point Number
    • FacilityNetworkIdentificationNumber - Facility Network Identification Number
    • FailureAnalysisReportNumber - Failure Analysis Report Number
    • Failuremechanismnumber - Failure mechanism number
    • FamilyMemberIdentification - Family Member Identification
    • FamilyUnitNumber - Family Unit Number
    • FannieMaeSellerServicerNumber - Fannie Mae Seller Servicer Number
    • FederalAcquisitionRegulations - Federal Acquisition Regulations (FAR)
    • FederalBureauOfInvestigationIndividualIdentification - Federal Bureau of Investigation Individual Identification
    • FederalCommunicationsCommissionConditionCode - Federal Communications Commission (FCC) Condition Code
    • FederalCommunicationsCommissionIdentifier - Federal Communications Commission (FCC) Identifier
    • FederalCommunicationsCommissionTradeOrBrandIdentifier - Federal Communications Commission (FCC) Trade/Brand Identifier
    • FederalEnergyRegulatoryCommissionCertificateOfPublicConvenience - Federal Energy Regulatory Commission Certificate of Public Convenience
    • FHLMCD - Federal Home Loan Mortgage Corporation Default/Foreclosure Specialist Number
    • FederalHomeLoanMortgageCorporationLoanNumber - Federal Home Loan Mortgage Corporation Loan Number
    • FederalHousingAdministrationCaseNumber - Federal Housing Administration Case Number
    • CHUMS - Federal Housing Administration Computerized Homes Underwriting Management System (CHUMS) Identification Number
    • FederalHousingAdministrationOriginatorIdentification - Federal Housing Administration Originator Identification
    • FederalInformationResourcesManagementRegulation - Federal Information Resources Management Regulation
    • FederalMaritimeCommissionForwardersNumber - Federal Maritime Commission (FMC) Forwarders Number
    • FederalMaritimeCommissionTariffNumber - Federal Maritime Commission (FMC) Tariff Number
    • FederalNationalMortgageAssociationLoanNumber - Federal National Mortgage Association (Fannie Mae) Loan Number
    • FederalRegulation - Federal Regulation
    • FederalSupplyClassificationCode - Federal Supply Classification Code
    • FederalSupplyScheduleItemNumber - A number specifying an item listed in a federal supply schedule.
    • FederalSupplyScheduleNumber - Federal Supply Schedule Number
    • FederalTaxpayersIdentificationNumber - Federal Taxpayer's Identification Number
    • FederalWireTransfer - FEDWIRE (Federal Wire Transfer)
    • FEDWIREConfirmationNumber - FEDWIRE Confirmation Number
    • FeeScheduleIdentifier - Fee Schedule Identifier
    • Field - Field
    • FileConversionJournal - Reference number identifying a journal recording details about conversion operations between file formats.
    • FileIdentificationNumber - A number assigned to identify a file.
    • FileIdentifier - File Identifier
    • FileLineIdentifier - Number assigned by the file issuer or sender to identify a specific line.
    • FilerCodeIssuedbyBureauOfCensus - Filer Code Issued by Bureau of Census
    • FilerCodeIssuedByCustoms - Filer Code Issued by Customs
    • FileTransferFormNumber - File Transfer Form Number
    • FileTransferProtocolLocator - File Transfer Protocol (FTP) Locator
    • FileVersionNumber - Number given to a version of an identified file.
    • FilmNumber - Film Number
    • FinalSequenceNumber - Final Sequence Number
    • FinalWorkCandidateNumber - Final Work Candidate Number
    • FinancialClassificationCode - Financial Classification Code
    • FinancialDetailCode - Financial Detail Code
    • FinancialManagementReference - A financial management reference.
    • FinancialPhaseReference - A reference which identifies a specific financial phase.
    • FinancialSettlementPartysReferenceNumber - Reference number of the party who is responsible for the financial settlement.
    • FinancialTransactionReferenceNumber - Reference number of the financial transaction.
    • FinderNumber - Finder Number
    • FineLineClassification - Fine Line Classification
    • FinishLotNumber - Finish Lot Number
    • FirstTransferNumber - First Transfer Number
    • FiscalCode - Fiscal Code
    • FiscalNumber - Tax payer's number. Number assigned to individual persons as well as to corporates by a public institution; this number is different from the VAT registration number.
    • FleetReferenceNumber - Fleet Reference Number
    • FlexibleSpendingAccountInsuranceAccountNumber - Flexible Spending Account (FSA) Insurance Account Number
    • FlexibleSpendingAccountInsurancePolicyNumber - Flexible Spending Account (FSA) Insurance Policy Number
    • FloodDataIdentifier - Flood Data Identifier
    • FloodZone - Flood Zone
    • FloorNumber - Floor Number
    • FloorPlanApprovalNumber - Floor Plan Approval Number
    • FlowReferenceNumber - Number given to a usual sender which has regular expeditions of the same goods, to the same destination, defining all general conditions of the transport.
    • FolderNumber - Folder Number
    • FoodAndDrugAdministrationAccessionNumber - Food and Drug Administration (FDA) Accession Number
    • FoodAndDrugAdministrationProductCode - Food and Drug Administration (FDA) Product Code
    • FoodAndDrugAdministrationProductType - Food and Drug Administration (FDA) Product Type
    • ForeclosingStatus - Foreclosing Status
    • ForeclosureAccountNumber - Foreclosure Account Number
    • ForeignExchange - Exchange of two currencies at an agreed rate.
    • ForeignExchangeContractNumber - Reference number identifying a foreign exchange contract.
    • ForeignMilitarySalesCaseNumber - Foreign Military Sales Case Number
    • ForeignMilitarySalesNoticeNumber - Foreign Military Sales Notice Number
    • ForeignMilitarySalesNumber - A number specifying a sale to a foreign military.
    • ForeignTradeZone - Foreign Trade Zone
    • ForestryPermitNumber - Forestry Permit Number
    • FormalStatementReference - A reference to a formal statement.
    • Formation - Formation
    • FormationIdentifier - Formation Identifier
    • FormNumber - Form Number
    • ForPickupLimitedFreightTariffNumber - For Pickup Limited Freight Tariff Number
    • ForwardersOrAgentsReferenceNumber - Forwarder's/Agent's Reference Number
    • ForwardingOrderNumber - Reference number assigned to the forwarding order by the ordering customer.
    • Frame - Frame
    • FranchiseTaxAccountNumber - Franchise Tax Account Number
    • FreddieMacSellerServicerNumber - Freddie Mac Seller Servicer Number
    • FreeZoneIdentifier - Identifier to specify the territory of a State where any goods introduced are generally regarded, insofar as import duties and taxes are concerned, as being outside the Customs territory and are not subject to usual Customs control (CCC).
    • FreightBillNumber - Reference number assigned by issuing party to a freight bill.
    • FreightForwarderNumber - An identification code of a Freight Forwarder.
    • FreightForwardersReferenceNumber - [1460] Reference number assigned to the consignment by the freight forwarder.
    • FreightPayorReferenceNumber - Freight Payor Reference Number
    • FullTimeOrPartTimeEmployeeClassificationQualifier - Full Time/Part Time Employee Classification Qualifier
    • FunctionalCategory - Functional Category
    • FunctionalWorkGroup - A reference to identify a functional group performing work.
    • FundCodeNumber - Reference number to identify appropriation and branch chargeable for item.
    • FundIdentificationNumber - Fund Identification Number
    • FundManagersReferenceNumber - Fund Manager's Reference Number
    • FundsAuthorization - Funds Authorization
    • GasAnalysisSourceMeterNumber - Gas Analysis Source Meter Number
    • GasCustodianIdentification - Gas Custodian Identification
    • GaugeTicketNumber - Gauge Ticket Number
    • GeneralAgencyNumber - General Agency Number
    • GeneralCargoConsignmentReferenceNumber - Reference number identifying a particular general cargo (non-containerised or break bulk) consignment.
    • GeneralDeclarationNumber - Number of the declaration of incoming goods out of a vessel.
    • GeneralLedgerAccount - General Ledger Account
    • GeneralOrderNumber - Customs number assigned to imported merchandise that has been left unclaimed and subsequently moved to a Customs bonded warehouse for storage.
    • GeneralPurposeMessageReferenceNumber - A reference number identifying a general purpose message.
    • GeneralServicesAdministrationRegulations - General Services Administration Regulations (GSAR)
    • GeographicDestinationZoneNumber - Geographic Destination Zone Number
    • GeographicIndex - Geographic Index
    • GeographicKey - Geographic Key
    • GeographicNumber - Geographic Number
    • GeographicScore - Geographic Score
    • GinnieMaePoolPackageNumber - Ginnie Mae (Government National Mortgage Association) Pool Package Number
    • GoodsAndServicesTaxIdentificationNumber - An identification number assigned to an organization collecting Goods and Services Taxes (GST).
    • GoodsandServiceTaxRegistrationNumber - Goods and Service Tax Registration Number
    • GoodsDeclarationNumber - Reference number assigned to a goods declaration.
    • GoverningClassCode - Governing Class Code
    • GovernmentAccountingClassReferenceNumber - Government Accounting Class Reference Number (ACRN)
    • GovernmentAdvanceProgress - Government Advance Progress
    • GovernmentAgencyReferenceNumber - Coded reference number that pertains to the business of a government agency.
    • GovernmentBillOfLading - Bill of lading as defined by the government.
    • GovernmentBillofLadingOfficeCode - Government Bill of Lading Office Code
    • GovernmentContractNumber - Number assigned to a specific government/public contract.
    • GovernmentPriorityNumber - Government Priority Number
    • GovernmentQualityAssuranceAndControlLevelNumber - A number which identifies the level of quality assurance and control required by the government for an article.
    • GovernmentReferenceNumber - Description to be provided.
    • GovernmentRegistrationNumber - Government Registration Number
    • GovernmentTransportationRequest - Government Transportation Request
    • GrainBlockNumber - Grain Block Number
    • GrainOrderReferenceNumber - Grain Order Reference Number
    • GravitySourceMeterNumber - Gravity Source Meter Number
    • GreenCard - Green Card
    • GroupAccounting - Description to be provided.
    • GroupNumber - Group Number
    • GroupOrPolicyNumber - Group or Policy Number
    • GroupWorkCandidateSequenceNumber - Group Work Candidate Sequence Number
    • GrowthFactorReference - Growth Factor Reference
    • GuarantorLoanNumber - Guarantor Loan Number
    • GuarantorUse - Guarantor Use
    • HarmonisedSystemNumber - Number specifying the goods classification under the Harmonised Commodity Description and Coding System of the Customs Co-operation Council (CCC).
    • HarmonizedCodeSystem - Harmonized Code System (Canada)
    • HasteningNumber - A number which uniquely identifies a request to hasten an action.
    • HazardousCertificationNumber - Hazardous Certification Number
    • HazardousExemptionNumber - Hazardous Exemption Number
    • HazardousWasteManifestDocumentNumber - Hazardous Waste Manifest Document Number
    • HealthCareFinancingAdministrationNationalPayerIdentificationNumber - Health Care Financing Administration National Payer Identification Number
    • HealthCareFinancingAdministrationNationalProviderIdentifier - Health Care Financing Administration National Provider Identifier
    • HealthcareManpowerShortageAreaFacilityIdentificationNumber - Healthcare Manpower Shortage Area (HMSA) Facility Identification Number
    • HealthCertificateNumber - Health Certificate Number
    • HIBCCLabelerIdentificationCode - Health Industry Business Communications Council (HIBCC) Labeler Identification Code (LIC)
    • HealthIndustryNumber - Health Industry Number (HIN)
    • HealthInsuranceAccountNumber - Health Insurance Account Number
    • HealthInsuranceClaimNumber - Health Insurance Claim (HIC) Number
    • HealthInsurancePolicyNumber - Health Insurance Policy Number
    • HealthInsuranceRatingAccountNumber - Health Insurance Rating Account Number
    • HealthInsuranceRatingSuffixCode - Health Insurance Rating Suffix Code
    • HealthMaintenanceOrganizationReferenceNumber - Health Maintenance Organization (HMO) Reference Number
    • HealthMaintenanceOrganizationAuthorizationNumber - Health Maintenance Organization (HMO) Authorization Number
    • HealthMaintenanceOrganizationCodeNumber - Health Maintenance Organization Code Number
    • HeatCode - Heat Code
    • HighOrWideFileNumber - High/Wide File Number
    • HighFabricationAuthorizationNumber - High Fabrication Authorization Number
    • HighRawMaterialAuthorizationNumber - High Raw Material Authorization Number
    • HomeMortgageDisclosureActCensusTract - Home Mortgage Disclosure Act (HMDA) Census Tract
    • HomeMortgageDisclosureActBlockNumberArea - Home Mortgage Disclosure Act Block Number Area
    • HomeMortgageDisclosureActCountyCode - Home Mortgage Disclosure Act (HMDA) County Code
    • HomeMortgageDisclosureActMetropolitanStatisticalArea - Home Mortgage Disclosure Act (HMDA) Metropolitan Statistical Area (MSA)
    • HomeMortgageDisclosureActStateCode - Home Mortgage Disclosure Act (HMDA) State Code
    • HorizontalCoordinate - Horizontal Coordinate
    • Horsepower - Horsepower
    • HotRollNumber - Number attributed to a hot roll coil.
    • HouseBillOfLadingNumber - Reference number assigned to a house bill of lading, see: 1001 = 714.
    • HouseWaybillNumber - Reference number assigned to a house waybill, see: 1001 = 703
    • IataCargoAgentCassAddressNumber - Code issued by IATA to identify agent locations for CASS billing purposes.
    • IataCargoAgentCodeNumber - Code issued by IATA identify each IATA Cargo Agent whose name is entered on the Cargo Agency List.
    • ICD9CM - ICD-9-CM (International Classification of Diseases)
    • IdentificationCardSerialNumber - Identification Card Serial Number
    • IdentityCardNumber - Identity Card Number
    • ImageIdentifier - Image Identifier
    • ImmediateExportationNoForInBondMovement
    • ImmediateTransportationNoForInBondMovement
    • ImplementationVersionNumber - Identifies a version number of an implementation.
    • ImportClearanceInstructionReferenceNumber - Reference number of the import clearance instructions given by the consignor/consignee through different means.
    • ImporterReferenceNumber - Reference number assigned by the importer to identify a particular shipment for his own purposes.
    • ImportersReferenceNumberToLetterOfCredit - Importer's Reference Number to Letter of Credit
    • ImportLicenceNumber - [1106] Reference number assigned by the issuing authority to an Import Licence.
    • ImportPermitNumber - Reference number assigned by the issuing authority to an import permit for goods.
    • ImputationAccount - An account to which an amount is to be posted.
    • InBondNumber - Customs assigned number that is used to control the movement of imported cargo prior to its formal Customs clearing.
    • InboundToOrOutboundFromParty - Inbound-to or Outbound-from Party
    • InboundToParty - Inbound-to Party
    • Incident - Incident
    • IncorporatedLegalReference - Identifies a legal reference which is deemed incorporated by reference.
    • IndividualTransactionReferenceNumber - Reference number applying to one specific transaction.
    • InitialDealerClaimNumber - Initial Dealer Claim Number
    • InitialFailureClaim - Initial Failure Claim
    • InitialSampleInspectionReportNumber - Inspection report number given to the initial sample inspection.
    • InitialTroubleIndication - Initial Trouble Indication
    • InlandTransportOrderNumber - Reference number assigned by the principal to the transport order for inland carriage.
    • InquiryRequestNumber - Inquiry Request Number
    • InspectionandSurveySequenceNumber - Inspection and Survey Sequence Number
    • InspectionReportNumber - Inspection Report Number
    • InspectorIdentificationNumber - Inspector Identification Number
    • InstituteOfSecurityAndFutureMarketDevelopmentSerialNumber - Institute of Security and Future Market Development (ISFMD) Serial Number
    • InstitutionLoanNumber - Institution Loan Number
    • InstitutionNoteHolderIdentification - Institution Note Holder Identification
    • InstitutionNumber - Institution Number
    • InsuranceCertificateNumber - Insurance Certificate Number
    • InsuranceCertificateReferenceNumber
    • InsuranceContractReferenceNumber
    • InsuranceLicenseNumber - Insurance License Number
    • InsurancePolicyNumber - Insurance Policy Number
    • InsuredLocationIdentifier - Insured Location Identifier
    • InsuredParcelPostNumber - Insured Parcel Post Number
    • InsuredsLoanNumber - Insured's Loan Number
    • InsurerAssignedReferenceNumber - A unique reference number assigned by the insurer.
    • InsurorPoolIdentificationNumber - Insuror Pool Identification Number
    • IntegratedLogisticSupportCrossReferenceNumber - Provides the identification of the reference which allows cross referencing of items between different areas of integrated logistics support.
    • IntegratedMasterPlan - Integrated Master Plan (IMP)
    • IntegratedMasterSchedule - Integrated Master Schedule (IMS)
    • InterchangeAgreementNumber - Interchange Agreement Number
    • InterchangeNumberNew - Number assigned by the interchange sender to identify one specific interchange. This number points to the actual interchange.
    • InterchangeNumberOld - Number assigned by the interchange sender to identify one specific interchange. This number points to the previous interchange.
    • InterchangeTrainIdentification - Interchange Train Identification
    • IntergovernmentalMaritimeOrganizationNumber - Intergovernmental Maritime Organization (IMO) Number
    • InterimFundingOrganizationLoanNumber - Interim Funding Organization Loan Number
    • IntermediaryBroker - Description to be provided.
    • InternalControlNumber - Internal Control Number
    • InternalCustomerNumber - Number assigned by a seller, supplier etc. to identify a customer within his enterprise.
    • InternalDataProcessNumber - A number identifying an internal data process.
    • InternalOrderNumber - Number assigned to an order for internal handling/follow up.
    • InternalPurchaseOrderItemNumber - Internal Purchase Order Item Number
    • InternalPurchaseOrderReleaseNumber - Internal Purchase Order Release Number
    • InternalVendorNumber - Number identifying the company-internal vending department/unit.
    • InternationalAssessmentLogNumber - The reference log number assigned to a Data Maintenance Request (DMR) changed in international assessment.
    • InternationalAssessmentLogNumberChildDataMaintenance - Request (DMR) The reference log number assigned to a Data Maintenance Request (DMR) changed in international assessment that is a child to the current DMR.
    • InternationalAssessmentLogNumberParentDataMaintenance - Request (DMR) The reference log number assigned to a Data Maintenance Request (DMR) changed in international assessment that is a parent to the current DMR.
    • InternationalFlightNumber - Airline flight number assigned to a flight originating and terminating across national borders.
    • InternationalFuelTaxAgreementAccountNumber - International Fuel Tax Agreement Account Number
    • InternationalRegistrationPlanAccountNumber - International Registration Plan Account Number
    • InternationalRegistrationPlanStickerNumber - International Registration Plan Sticker Number
    • InternationalStandardIndustrialClassificationDominionOfCanadaCode - International Standard Industrial Classification (ISIC) Dominion of Canada Code (DCC)
    • InternationalStandardIndustryClassificationCode - International Standard Industry Classification Code (ISIC)
    • InterstateCommerceCommissionAccountNumber - Interstate Commerce Commission (ICC) Account Number
    • InterviewerID - Interviewer ID
    • IntraPlantRouting - Intra Plant Routing
    • InventoryReportReferenceNumber - A reference number identifying an inventory report.
    • InvestigatorialNewDrugNumber - Investigatorial New Drug Number
    • InvestmentReferenceNumber - A reference to a specific investment.
    • Investor - Investor
    • InvestorAssignedIdentificationNumber - Investor Assigned Identification Number
    • InvestorLoanNumber - Investor Loan Number
    • InvestorNoteHolderIdentification - Investor Note Holder Identification
    • InvoiceIdentification - Invoice Identification
    • InvoiceNumber - [1334] Reference number assigned by the seller to a Commercial Invoice.
    • InvoiceNumberSuffix - A number added at the end of an invoice number.
    • InvoicingDataSheetReferenceNumber - A reference number identifying an invoicing data sheet.
    • IronChargeNumber - Number attributed to the iron charge for the production of steel products.
    • ISFMD - Institute of security and future market development: serial number A number used to identify a public but not publicly traded company.
    • IssueNumber - Issue Number
    • IssuerNumber - Issuer Number
    • IssuingBanksReference - Reference number of the issuing bank.
    • ItemNumber - Item Number
    • JobOrProjectNumber - Job (Project) Number
    • JobOrderNumber - Job Order Number
    • JobSequenceNumber - Job Sequence Number
    • JointCreditSpecificationNumber - Joint Credit Specification Number
    • JointlyAdministeredCase - Jointly Administered Case
    • JointVentureReferenceNumber - Reference number assigned to a joint venture agreement.
    • Judge - Judge
    • JudgmentNumber - Judgment Number
    • JudicialDistrict - Judicial District
    • JudicialNumber - Judicial Number
    • JurisdictionalCommunityNameIdentifier - Jurisdictional Community Name Identifier
    • JurisdictionalCommunityNumber - Jurisdictional Community Number
    • LaboratoryNumber - Laboratory Number
    • LaboratoryRegistrationNumber - Reference number is the official registration number of the laboratory.
    • LaborOperationNumber - Labor Operation Number
    • LabororAffiliationIdentification - Labor or Affiliation Identification
    • LaneNumber - Lane Number
    • LastTransferNumber - Last Transfer Number
    • LatitudeExpressedinDegreesMinutesandSeconds - Latitude Expressed in Degrees, Minutes and Seconds
    • LatitudeExpressedinSeconds - Latitude Expressed in Seconds
    • LeadCase - Lead Case
    • LeaseAgreementAmendmentNumberMaster - Lease Agreement Amendment Number - Master
    • LeaseContractReference - Reference number of the lease contract.
    • LeaseNumber - Lease Number
    • LeaseRiderNumber - Lease Rider Number
    • LeaseScheduleNumber - Lease Schedule Number
    • LeaseScheduleNumberBlanket - Lease Schedule Number - Blanket
    • LeaseScheduleNumberPrior - Lease Schedule Number - Prior
    • LeaseScheduleNumberReplacement - Lease Schedule Number - Replacement
    • LenderAccountNumber - Lender Account Number
    • LenderCaseNumber - Lender Case Number
    • LenderEntityNumber - Lender Entity Number
    • LenderUse - Lender Use
    • LesseeBillCodeNumber - Lessee Bill Code Number
    • LesseeIdentification - Lessee Identification
    • LetterofCreditDraftNumber - Letter of Credit Draft Number
    • LetterOfCreditNumber - Reference number identifying the letter of credit document.
    • LettersorNotes - Letters or Notes
    • LevyingOfficerIdentification - Levying Officer Identification
    • LicensePlateNumber - License Plate Number
    • LifeInsuranceBillingAccountNumber - Life Insurance Billing Account Number
    • LifeInsuranceBillingSuffixCode - Life Insurance Billing Suffix Code
    • LifeInsurancePolicyNumber - Life Insurance Policy Number
    • LimitedPartnershipIdentificationNumber - Limited Partnership Identification Number
    • LineItemControlNumber - Line Item Control Number
    • LineItemIdentifier - Line Item Identifier (Seller's)
    • LineItemReferenceNumber - (1156) Reference number identifying a particular line in a document.
    • LineofBusiness - Line of Business
    • LineOfCreditCategory - Line of Credit Category
    • LinkSequenceNumber - Link Sequence Number
    • ListBillNumber - List Bill Number
    • ListOfMaterials - List of Materials
    • LloydsClaimsOfficeReference
    • LoadingAuthorizationNumber - [4092] A number assigned to the loading authorization granted by the forwarding station when the consignment is subject to traffic limitations (CIM 43).
    • LoadLineCertificate - Load Line Certificate
    • LoadPlanningNumber - Load Planning Number
    • LoanAcquisitionNumber - Loan Acquisition Number
    • LoanFeatureCode - Loan Feature Code
    • LoanNumber - Loan Number
    • LoanProspectorKeyNumber - Loan Prospector Key Number
    • LoanRequestNumber - Loan Request Number
    • LoanType - Loan Type
    • LocalJurisdiction - Local Jurisdiction
    • LocallyAssignedControlNumber - Locally Assigned Control Number
    • LocalMediaIdentifier - Local Media Identifier
    • LocalSchoolCourseNumber - Local School Course Number
    • LocalSchoolDistrictCourseNumber - Local School District Course Number
    • LocalStudentIdentificationNumber - Local Student Identification Number
    • LocationExceptionOrderNumber - Location Exception Order Number
    • LocationNumber - Location Number
    • LocationonProductCode - Location on Product Code
    • LocationSpecificServicesReferenceNumber - Location-specific Services Reference Number
    • LocationWithinEquipment - Location Within Equipment
    • Lockbox - Type of cash management system offered by financial institutions to provide for collection of customers 'receivables'.
    • Log - Log
    • LogicalObservationIdentifierNamesandCodes - Logical Observation Identifier Names and Codes (LOINC)
    • LogisticsSupportDocumentationTypeCode - Logistics Support Documentation Type Code
    • LongitudeExpressedInDegreesMinutesandSeconds - Longitude expressed in Degrees, Minutes and Seconds
    • LongitudeExpressedinSeconds - Longitude Expressed in Seconds
    • LongTermDisabilityPolicyNumber - Long-term Disability Policy Number
    • LossOrEventNumber - To reference to the unique number that is assigned to each major loss hitting the reinsurance industry.
    • LossReportNumber - Loss Report Number
    • LotNumber - Lot Number
    • LowerArticleNumberOfRange - Lower article number in a range.
    • MagazineCode - Magazine Code
    • Mailbox - Mailbox
    • MailingReferenceNumber - Identifies the party designated by the importer to receive certain customs correspondence in lieu of its being mailed directly to the importer.
    • MailSlot - Mail Slot
    • MaintenanceAvailabilityType - Maintenance Availability Type
    • MaintenanceRequestNumber - Maintenance Request Number
    • MajorForceProgramNumber - Reference number according to Major Force Program (US).
    • MajorSystemAffectedCode - Major System Affected Code
    • MakegoodCommercialLineNumber - Makegood Commercial Line Number
    • MammographyCertificationNumber - Mammography Certification Number
    • ManagedCareOrganizationCode - Managed Care Organization Code
    • ManagedCareOrganizationIdentificationNumber - Managed Care Organization Identification Number
    • ManifestKeyNumber - Manifest Key Number
    • ManualProcessingAuthorityNumber - Number allocated to allow the manual processing of an entity.
    • ManufacturerDefinedRepairRatesReference - Reference assigned by a manufacturer to their repair rates.
    • ManufacturerNumber - Manufacturer Number
    • ManufacturersMaterialSafetyDataSheetNumber - Manufacturer's Material Safety Data Sheet Number
    • ManufacturersPartNumber - Reference number assigned by the manufacturer to his product or part.
    • ManufacturingDirectiveNumber - Manufacturing Directive Number
    • ManufacturingOperationNumber - Manufacturing Operation Number
    • ManufacturingOrderNumber - Reference number assigned by manufacturer for a given production quantity of products.
    • MapNumber - Map Number
    • MapReference - Map Reference
    • MaritimeDeclarationofHealth - Maritime Declaration of Health
    • MarketArea - Market Area
    • MarkingOrLabelReference - Reference where marking/label information derives from.
    • MasterAccountNumber - Master Account Number
    • MasterAirWaybillNumber - Reference number assigned to a master air waybill, see: 1001 = 741.
    • MasterBillOfLadingNumber - Reference number assigned to a master bill of lading, see: 1001 = 704.
    • MasterContract - Master Contract
    • MasterLabelNumber - Identifies the master label number of any package type.
    • MasterLeaseAgreementNumber - Master Lease Agreement Number
    • MasterPolicyNumber - Master Policy Number
    • MasterPropertyNumber - Master Property Number
    • MasterReferenceNumber - Master Reference (Link) Number
    • MasterSolicitationProceduresTermsAndConditionsNumber - A number indicating a master solicitation containing procedures, terms and conditions.
    • MaterialChangeNoticeNumber - Material Change Notice Number
    • MaterialStorageLocation - Material Storage Location
    • MaturedCertificateOfDeposit - Reference number for certificate of deposit allocated by issuing financial institution.
    • MeatProcessingEstablishmentRegistrationNumber - Registration number allocated to a registered meat packing establishment by the local quarantine and inspection authority.
    • MedicaidProviderNumber - Medicaid Provider Number
    • MedicaidRecipientIdentificationNumber - Medicaid Recipient Identification Number
    • MedicalAssistanceCategory - Medical Assistance Category
    • MedicalRecordIdentificationNumber - Medical Record Identification Number
    • MedicareProviderNumber - Medicare Provider Number
    • MedicareVersionCode - Medicare Version Code
    • MemberIdentificationNumber - Member Identification Number
    • MemberNumber - Reference number assigned to a person as a member of a group of persons or a service scheme.
    • MerchandiseTypeCode - Merchandise Type Code
    • MerchantCategoryCode - Merchant Category Code (MCC)
    • MessageAddressorID - Message Address or ID
    • MessageBatchNumber - A number identifying a batch of messages.
    • MessageDesignGroupNumber - Reference number for a message design group.
    • MessageRecipient
    • MessageSender
    • MeterNumber - Meter Number
    • MeterProvingReportNumber - Meter Proving Report Number
    • MeterReadingAtTheBeginningOfTheDelivery - Meter reading at the beginning of the delivery.
    • MeterReadingAtTheEndOfDelivery - Meter reading at the end of the delivery.
    • MeterTicketNumber - Meter Ticket Number
    • MeterUnitNumber - Number identifying a unique meter unit.
    • MICRNumber - MICR Number
    • MicrofilmNumber - Microfilm Number
    • MigrantNumber - Migrant Number, This number is assigned by the national Migrant Records Transfer System
    • Milestone - Milestone
    • MilitaryCallNumber - Military Call Number
    • MilitaryID - Military ID
    • MilitaryInterdepartmentalPurchaseRequestNumber - Military Interdepartmental Purchase Request (MIPR) Number
    • MilitaryOrdnanceSecurityRiskNumber - Military Ordnance Security Risk Number
    • MilitaryRankOrCivilianPayGradeNumber - Military Rank/Civilian Pay Grade Number
    • MilitarySpecificationNumber - Military Specification (MILSPEC) Number
    • MilitaryStandardNumber - Military Standard (MIL-STD) Number
    • MillinginTransit - Milling in Transit
    • MillOrderNumber - Mill Order Number
    • MinimumRoyaltyPayorIdentification - Minimum Royalty Payor Identification
    • MinisterialCertificateOfHomologation - Certificate of approval for components which are subject to legal restrictions and must be approved by the government.
    • Model - A reference used to identify a model.
    • ModelNumber - Model Number
    • Modelyearnumber - Model year number
    • MORNETPlusCaseNumber - MORNETPlus Case Number
    • MORNETPlusInstitutionNumber - MORNETPlus Institution Number
    • MORNETPlusUserIdentification - MORNETPlus User Identification
    • MortgageBackedSecurityLoanNumber - Mortgage Backed Security (MBS) Loan Number
    • MortgageBackedSecurityPoolNumber - Mortgage Backed Security (MBS) Pool Number
    • MortgageElectronicRegistrationSystemOrganizationIdentifier - Mortgage Electronic Registration System Organization Identifier
    • MortgageeLoanNumber - Mortgagee Loan Number
    • MortgageIdentificationNumber - Mortgage Identification Number
    • MortgageInsuranceCompanyNumber - Mortgage Insurance Company Number
    • MortgageInsuranceIndicatorNumber - Mortgage Insurance Indicator Number
    • MortgageNumber - Mortgage Number
    • MotorCarrierIdentificationNumber - Motor Carrier Identification Number
    • MotorFuelCertificateNumber - Motor Fuel Certificate Number
    • MotorVehicleIDNumber - Motor Vehicle ID Number
    • MultifamilyProjectNumber - Multifamily Project Number
    • MultipleListingNumber - Multiple Listing Number
    • MultipleListingServiceArea - Multiple Listing Service Area
    • MultipleListingServiceBookType - Multiple Listing Service Book Type
    • MultipleListingServiceMapXCoordinate - Multiple Listing Service Map X Coordinate
    • MultipleListingServiceMapYCoordinate - Multiple Listing Service Map Y Coordinate
    • MultipleListingServiceSubArea - Multiple Listing Service Sub-area
    • MultiplePOOfAnInvoice - Multiple P.O.s of an Invoice
    • MultipleZoneOrderNumber - Multiple Zone Order Number
    • MunicipalityAssignedBusinessRegistryNumber - Municipality Assigned Business Registry Number
    • NACE - Nomenclature Activity Classification Economy: identifier A European industry classification code used to identify the activity of a company.
    • NAF - Norme Activite Francaise Identifier: A French industry classification code assigned by the French government to identify the activity of a company.
    • NamedBanksReference - Reference number of the named bank.
    • NationalAeronauticsandSpaceAdministrationFARSupplement - National Aeronautics and Space Administration FAR Supplement (NFS)
    • NationalAssociationOfBoardsOfPharmacyNumber - National Association of Boards of Pharmacy Number
    • NationalAssociationOfInsuranceCommissionersCode - National Association of Insurance Commissioners (NAIC) Code
    • NationalBusinessIdentificationNumber - National Business Identification Number
    • NationalCriminalInformationCenterOriginatingAgencyIdentification - National Criminal Information Center Originating Agency Identification
    • NationalFloodInsuranceProgramCommunityName - National Flood Insurance Program Community Name
    • NationalFloodInsuranceProgramCommunityNumber - National Flood Insurance Program Community Number
    • NationalFloodInsuranceProgramCounty - National Flood Insurance Program County
    • NationalFloodInsuranceProgramMapNumber - National Flood Insurance Program Map Number
    • NationalFloodInsuranceProgramState - National Flood Insurance Program State
    • NationalGovernmentBusinessIdentificationNumber - A business identification number which is assigned by a national government.
    • NationalPropertyRegistrySystemLevel1 - National Property Registry System Level 1
    • NationalPropertyRegistrySystemLevel2 - National Property Registry System Level 2
    • NationalPropertyRegistrySystemLevel3 - National Property Registry System Level 3
    • NationalStockNumber - National Stock Number
    • NaturalGasPolicyActCategoryCode - Natural Gas Policy Act Category Code
    • NewDrugApplicationNumber - New Drug Application Number
    • NewHealthInsuranceClaimNumber - New Health Insurance Claim (HIC) Number
    • NewPartNumber - New Part Number
    • NextRentalAgreementNumber - Number to identify the next rental agreement.
    • NextRentalAgreementReasonNumber - Number to identify the reason for the next rental agreement.
    • NextShipmentIdentificationNumberContinuousMove - Next Shipment Identification Number - Continuous Move
    • NIT - NumeroDeIdentificacionTributaria: A number assigned by the government to a business in some Latin American countries.
    • NominationNumber - Reference number assigned by a shipper to a request/ commitment-to-ship on a pipeline system.
    • NonAmericanIdentificationNumber - Non-American Identification Number
    • NonConformanceReportNumber - Nonconformance Report Number
    • NonNegotiableMaritimeTransportDocumentNumber - Reference number assigned to a sea waybill, see: 1001 = 712
    • NonOriginatingThirdPartyNumber - Non-originating Third Party Number
    • NonPickupLimitedTariffNumber - Non pickup Limited Tariff Number
    • NonProvisionalPatentApplicationNumber - Nonprovisional Patent Application Number
    • NonSpouseTie - Non-Spouse Tie
    • NoOT5AuthorityZeroMileageRate - No OT5 Authority-zero Mileage Rate
    • NorthAmericanDatumStandard - North American Datum Standard (NADS)
    • NorthAmericanFreeTradeAgreementComplianceNumber - North American Free Trade Agreement (NAFTA) Compliance Number
    • NorthAmericanHazardousClassificationNumber - North American Hazardous Classification Number
    • NorthAmericanHazardousGoodsClassificationNumber - Reference to materials designated as hazardous for purposes of transportation in North American commerce.
    • NorthAmericanIndustrialClassificationSystemCode - North American Industrial Classification System Code
    • NOTICOL - Notification For Collection Number: A reference assigned by a consignor to a notification document which indicates the availability of goods for collection.
    • NumberOfTemporaryImportationDocument - Number assigned by customs to identify consignment in transit.
    • NumerodeCeduladeIdentidadNumber - Numero de Cedula de Identidad (CIN) Number
    • NumerodeIdentificacionTributaria - Numero de Identificacion Tributaria (NIT)
    • ObjectIdentifier - Object Identifier
    • OccupationalSafetyandHealthAdministrationClaimNumber - Occupational Safety and Health Administration (OSHA) Claim Number
    • OccupationClassificationCode - Occupation Classification Code
    • OccupationCode - Occupation Code
    • OceanBillofLading - Ocean Bill of Lading
    • OceanContainerNumber - Ocean Container Number
    • OceanManifest - Ocean Manifest
    • OffenderTracking - Offender Tracking
    • OffenseTracking - Offense Tracking
    • OfferGroup - Offer Group
    • OfferNumber - Reference number assigned by issuing party to an offer.
    • OfficeNumber - Office Number
    • OfficerLicenseNumber - Officer License Number
    • OfficeSymbol - Office Symbol
    • OldAccountNumber - Old Account Number
    • OldMeterNumber - Old Meter Number
    • OldPartNumber - Old Part Number
    • OneCallAgencyTicketNumber - One Call Agency Ticket Number
    • OnlineProcurementandAccountingControlTransaction - On-line Procurement and Accounting Control (OPAC) Transaction
    • OpenandPrepaidStationListNumber - Open and Prepaid Station List Number
    • OperationNumber - Operation Number
    • OperatorAssignedUnitNumber - Operator Assigned Unit Number
    • OperatorIdentificationNumber - Operator Identification Number
    • OperatorLeaseNumber - Operator Lease Number
    • OptionPolicyNumber - Option Policy Number
    • OrderOrParagraphNumber - Order/Paragraph Number
    • OrderingCustomerConsignmentReferenceNumber - Reference number assigned to the consignment by the ordering customer.
    • OrderingCustomersSecondReferenceNumber - Ordering customer's second reference number.
    • OrderNumber - Order Number
    • PurchaseOrderNumber - [1022] Reference number assigned by the buyer to an order.
    • VendorOrderNumber - Reference number assigned by supplier to a buyer's purchase order.
    • OrganizationBreakdownStructure - Organization Breakdown Structure
    • OriginalCertificateNumber - Number giving reference to an original certificate number.
    • OriginalFdoTransactionReference - Description to be provided.
    • OriginalFiling - Original Filing
    • OriginalFilingNumber - A number assigned to the original filing.
    • OriginalInvoiceNumber - Original Invoice Number
    • OriginalPurchaseOrder - Reference to the order previously sent.
    • OriginalReferenceNumber - Original Reference Number
    • OriginalReturnRequestReferenceNumber - Original Return Request Reference Number
    • OriginalShippersBillOfLadingNumber - Original Shipper's Bill of Lading Number
    • OriginalSubmitterChildDataMaintenanceRequestLog - number A Data Maintenance Request (DMR) original submitter's reference log number for a child DMR.
    • OriginalSubmitterLogNumber - A control number assigned by the original submitter.
    • OriginalSubmitterParentDataMaintenanceRequest - log number A Data Maintenance Request (DMR) original submitter's reference log number for the parent DMR.
    • OriginalUniformCommercialCodeFilingNumber - Original Uniform Commercial Code Filing Number
    • OriginalVoucherNumber - Original Voucher Number
    • OriginatingCase - Originating Case
    • OriginatingCompanyIdentifier - Originating Company Identifier
    • OriginatingDepositoryFinancialInstitutionIdentifier - Originating Depository Financial Institution Identifier
    • OriginatorsReference
    • OriginHouse - Origin House
    • OriginOfShipmentHarmonizedBasedCode - Origin of Shipment Harmonized-Based Code
    • OT5AuthorityConditionOrRestrictiononCarHireRate - OT5 Authority-Condition or Restriction on Car Hire Rate
    • OtherUnlistedTypeOfReferenceNumber - Other Unlisted Type of Reference Number
    • OutboundFromParty - Outbound-from Party
    • OuterContinentalShelfAreaCode - Outer Continental Shelf Area Code
    • OuterContinentalShelfBlockNumber - Outer Continental Shelf Block Number
    • OuterpackagingUnitIdentification - (7070) Identifying marks on packing units contained within an outermost shipping unit.
    • OutletNumber - Outlet Number
    • OutofServiceNumber - Out of Service Number
    • OwningBureauIdentificationNumber - Owning Bureau Identification Number
    • PackAndHoldInvoiceNumber - Pack and Hold Invoice Number
    • PackageNumber - (7070) Reference number identifying a package or carton within a consignment.
    • PackagingGroupNumber - Packaging Group Number
    • PackagingSpecificationNumber - Reference number of documentation specifying the technical detail of packaging requirements.
    • PackagingUnitIdentification - Identifying marks on packing units.
    • PackerNumber - Packer Number
    • Packet - Packet
    • PackingGroupCode - Packing Group Code
    • PackingListNumber - (1014) Reference number assigned to a packing list, see: 1001 = 271.
    • PackingPlantNumber - Number to identify packing establishment.
    • PageNumber - The number of a page.
    • Paragraph - A reference indicating a paragraph cited as the source of information.
    • ParagraphNumber - Paragraph Number
    • ParamedicalIDNumber - Paramedical ID Number
    • ParentFile - Identifies the parent file in a structure of related files.
    • PartCausingRepairNumber - Part Causing Repair Number
    • PartConsignmentNumber - [1310] Reference to a specific consignment forming part of a contract allowing part deliveries.
    • PartialPaymentNumber - Partial Payment Number
    • ParticipatingArea - Participating Area
    • PartInterchangeability - Part Interchangeability
    • PartNumber - Part Number
    • PartReferenceIndicatorInADrawing - To designate the number which provides a cross reference between parts contained in a drawing and a parts catalogue.
    • PartyInformationMessageReference - Reference identifying a party information message.
    • PartySequenceNumber - Reference identifying a party sequence number.
    • Passport - Passport
    • PassportNumber - Number assigned to a passport.
    • PatentCooperationTreatyApplicationNumber - Patent Cooperation Treaty Application Number
    • PatentNumber - Patent Number
    • PatentType - Patent Type
    • PatientAccountNumber - Patient Account Number
    • PatronNumber - A number assigned by the government to a business in some Latin American countries. Note that "Patron" is a Spanish word, it is not a person who gives financial or other support.
    • PayeeIdentification - Payee Identification
    • PayeeLoanNumber - Payee Loan Number
    • PayeesFinancialInstitutionAccountNumber - Receiving company account number (ACH transfer), check, draft or wire.
    • PayeesFinancialInstitutionTransitRoutingNo - RDFI Transit routing number (ACH transfer).
    • PayeesReferenceNumber - Reference number of the party to be paid.
    • PayerAssignedResubmissionReferenceNumber - Payer Assigned Resubmission Reference Number
    • PayerCategory - Payer Category
    • PayerIdentificationNumber - Payer Identification Number
    • PayersFinancialInstitutionAccountNumber - Originated company account number (ACH transfer), check, draft or wire.
    • PayersFinancialInstitutionTransitRoutingNo - Arch transfers ODFI (ACH transfer).
    • PayersReferenceNumber - Reference number of the party who pays.
    • PayGrade - Pay Grade
    • PaymentCategory - Payment Category
    • PaymentHistoryReferenceNumber - Payment History Reference Number
    • PaymentInAdvanceRequestReference - A reference to a request for payment in advance.
    • PaymentInstalmentReferenceNumber - A reference number given to a payment instalment to identify a specific instance of payment of a debt which can be paid at specified intervals.
    • PaymentLocation - Payment Location
    • PaymentOrderNumber
    • PaymentPlanReference - A number which uniquely identifies a payment plan.
    • PaymentReference - Reference number assigned to a payment.
    • PaymentValuationNumber - Reference number assigned to a payment valuation.
    • PayorsClaimNumber - Payor's Claim Number
    • PayrollAccountNumber - Payroll Account Number
    • PayrollNumber - Reference number assigned to the payroll of an organisation.
    • PcsCatastrophe - Description to be provided.
    • PeerReviewOrganizationApprovalNumber - Peer Review Organization (PRO) Approval Number
    • PendingCase - Pending Case
    • PensionContract - Pension Contract
    • PeriodicityCode - Periodicity Code
    • PermitNumber - Permit Number
    • PersonalIdentificationNumber - Personal Identification Number (PIN)
    • PersonalIdentityCardNumber - An identity card number assigned to a person.
    • PersonalIDNumber - Personal ID Number
    • PetroleumPoolCode - Petroleum Pool Code
    • PharmacyPrescriptionNumber - Pharmacy Prescription Number
    • PhoneCalls - Phone Calls
    • PhysicalInventoryRecountReferenceNumber - A reference to a re-count of physically held inventory.
    • PickupReferenceNumber - Pickup Reference Number
    • PictureNumber - Picture Number
    • PictureOfActualProduct - Reference identifying the picture of an actual product.
    • PictureOfAGenericProduct - Reference identifying a picture of a generic product.
    • PierNumber - Pier Number
    • Piggyback - Piggyback
    • PilotLicenseNumber - Pilot License Number
    • PipelineNumber - Number to identify a pipeline.
    • PlanNetworkIdentificationNumber - Plan Network Identification Number
    • PlanningPackage - A reference for a planning package of work.
    • PlanNumber - Plan Number
    • PlantNumber - Plant Number
    • PlateNumber - Plate Number
    • PlatformIdentificationNumber - Platform Identification Number
    • PlotFile - Reference number indicating that the file is a plot file.
    • PlugNumber - Plug Number
    • PolicyFormNumber - Number assigned to a policy form.
    • PolicyLinkNumber - Policy Link Number
    • PolicyNumber - Number assigned to a policy.
    • PolicyType - Policy Type
    • Pollutant - Pollutant
    • PoolContractCode - Pool Contract Code
    • PoolNumber - Pool Number
    • PoolSuffix - Pool Suffix
    • PositionCode - Position Code
    • PostEntryReference - Reference to a message related to a post-entry.
    • PreAwardSurvey - Pre-Award Survey
    • PrecinctNumber - Precinct Number
    • PredecessorAccount - Predecessor Account
    • PredeterminationofBenefitsIdentificationNumber - Predetermination of Benefits Identification Number
    • PreferredCallSign - Preferred Call Sign
    • PreferredProviderOrganizationAuthorizationNumber - Preferred Provider Organization (PPO) Authorization Number
    • PreferredProviderOrganizationNumber - Preferred Provider Organization Number
    • PreferredProviderOrganizationSiteNumber - Preferred Provider Organization Site Number
    • PreliminaryWorkCandidateNumber - Preliminary Work Candidate Number
    • PremarketApplicationNumber - Premarket Application Number
    • PremarketNotificationNumber - Premarket Notification Number
    • PremiumAuditPriorityIdentifier - Premium Audit Priority Identifier
    • PremiumAuditPurposeIdentifier - Premium Audit Purpose Identifier
    • PremiumAuditTypeIdentifier - Premium Audit Type Identifier
    • PremiumRateTable - Identifies the premium rate table.
    • PreparersVerificationNumber - Preparer's Verification Number
    • PresentingBanksReference - Reference number of the presenting bank.
    • PressFormIdentifier - Press Form Identifier
    • PressIdentifier - Press Identifier
    • PreviousBillofLadingNumber - Previous Bill of Lading Number
    • PreviousCargoControlNumber - Where a consignment is deconsolidated and/or transferred to the control of another carrier or freight forwarder (e.g. housebill, abstract) this references the previous (e.g. master) cargo control number.
    • PreviousClaimHistoryIdentifier - Previous Claim History Identifier
    • PreviousContractNumber - Previous Contract Number
    • PreviousCourseNumber - Previous Course Number
    • PreviousCreditOrDebitAdjustmentNumber - Previous Credit/Debit Adjustment Number
    • PreviousCreditAdviceReferenceNumber - Reference number of the previous "Credit advice" message.
    • PreviousCustomerReferenceNumber - Previous customer reference number
    • PreviousDeliveryInstructionNumber - The identification of a previous delivery instruction.
    • PreviousDeliveryScheduleNumber - A reference number identifying a previous delivery schedule.
    • PreviousDistributorNumber - Previous Distributor Number
    • PreviousDriversLicense - Previous Driver's License
    • PreviousDrugEnforcementAdministrationNumber - Previous Drug Enforcement Administration Number
    • PreviousHighestScheduleNumber - Number of the latest schedule of a previous period (ODETTE DELINS).
    • PreviousInvoiceNumber - Reference number identifying a previously issued invoice.
    • PreviouslyReportedSocialSecurityNumber - Previously Reported Social Security Number
    • PreviousMemberNumber - Reference number previously assigned to a member.
    • PreviousPolicyNumber - Previous Policy Number
    • PreviousRentalAgreementNumber - Number to identify the previous rental agreement number.
    • PreviousReportNumber - Previous Report Number
    • PreviousRequestForMeteredReadingReferenceNumber - Number to identify a previous request for a recording or reading of a measuring device.
    • PreviousSchemeOrPlanNumber - Reference number previously assigned to a service scheme or plan.
    • PreviousSequence - Previous Sequence
    • PreviousShipmentIdentificationNumberContinuousMove - Previous Shipment Identification Number - Continuous Move
    • PreviousTaxControlNumber - A reference number identifying a previous tax control number.
    • PreviousTicketNumber - Previous Ticket Number
    • PriceOrSalesCatalogueResponseReferenceNumber - A reference number identifying a response to a price/sales catalogue.
    • PriceAreaNumber - Price Area Number
    • PriceListChangeorIssueNumber - Price List Change or Issue Number
    • PriceListNumber - Reference number assigned to a price list.
    • PriceListVersionNumber
    • PriceQuoteNumber - Reference number assigned by the seller to a quote.
    • PriceVariationFormulaReferenceNumber - The reference number which identifies a price variation formula.
    • PrimaryReference - Description to be provided.
    • PrimeContractorContractNumber - Reference number assigned by the client to the contract of the prime contractor.
    • PrincipalReferenceNumber - Description to be provided.
    • PrincipalsBankReference - Reference number of the principal's bank.
    • PrincipalsReference - Reference number of the principal.
    • PriorAuthorizationNumber - Prior Authorization Number
    • PriorCase - Prior Case
    • PriorCertificateNumber - Prior Certificate Number
    • PriorContractNumber - Prior Contract Number
    • PriorDataUniversalNumberSystemNumber - A previously assigned Data Universal Number System (DUNS) number.
    • PriorHealthIndustryNumber - Prior Health Industry Number
    • PriorIdentifierNumber - Prior Identifier Number
    • PriorIncorrectBatchNumber - Prior Incorrect Batch Number
    • PriorIncorrectSocialSecurityNumber - Prior Incorrect Social Security Number
    • PriorityRating - Priority Rating
    • PriorLoanNumber - Prior Loan Number
    • PriorPhoneNumber - Prior Phone Number
    • PriorPolicyNumber - The number of the prior policy.
    • PriorPostalZipCode - Prior Postal Zip Code
    • PriorPurchaseOrderNumber - Reference number of a purchase order previously sent to the supplier.
    • PriorTaxIdentificationNumber - Prior Tax Identification Number (TIN)
    • PriorTradingPartnerIdentificationNumber - Code specifying an identification number previously assigned to a trading partner.
    • PriorUniversalProviderIdentificationNumber - Prior Universal Provider Identification Number (UPIN)
    • Proceeding - Proceeding
    • ProcessHandlingCode - Process Handling Code
    • ProcessingArea - Processing Area
    • ProcessingPlantNumber - Number to identify processing plant.
    • ProcessorIdentificationNumber - Processor Identification Number
    • ProcessorsInvoiceNumber - Processor's Invoice Number
    • ProcurementBudgetNumber - A number which uniquely identifies a procurement budget against which commitments or invoices can be allocated.
    • ProcurementRequestNumber - Procurement Request Number
    • ProcuringAgency - Procuring Agency
    • ProductChangeAuthorityNumber - Number which authorises a change in form, fit or function of a product.
    • ProductChangeInformationNumber - Product change information number
    • ProductChangeNoticeNumber - Product Change Notice Number
    • ProductGroup - Product Group
    • ProductionCode - Number assigned by the manufacturer to a specified article or batch to identify the manufacturing date etc. for subsequent reference.
    • ProductLicensingAgreementNumber - Product Licensing Agreement Number
    • ProductLineNumber - Product Line Number
    • ProductNumber - Product Number
    • ProductPeriodForWhichLaborCostsAreFirm - Product Period for which Labor Costs are Firm
    • ProductReservationNumber - Number assigned by seller to identify reservation of specified products.
    • ProductSourcingAgreementNumber - Reference number assigned to a product sourcing agreement.
    • ProductSpecificationDocumentNumber - Product Specification Document Number
    • ProductType - Product Type
    • ProfileNumber - Reference number allocated to a discrete set of criteria.
    • ProformaInvoiceNumber - [1088] Reference number assigned by the seller to a Proforma Invoice.
    • ProgramIdentificationNumber - Program Identification Number
    • ProgressPaymentNumber - Progress Payment Number
    • ProjectCode - Project Code
    • ProjectNumber - Reference number assigned to a project.
    • ProjectParagraphNumber - Project Paragraph Number
    • ProjectPropertyNumber - Project Property Number
    • ProjectSpecificationNumber - Reference number identifying a project specification.
    • PromotionOrDealNumber - Promotion/Deal Number
    • ProofOfDeliveryReferenceNumber - A reference number identifying a proof of delivery which is generated by the goods recipient.
    • PropertyComponentLocation - Property Component Location
    • PropertyControlNumber - Property Control Number
    • PropertyLossItemNumber - Property Loss Item Number
    • ProposalNumber - Proposal Number
    • ProposalParagraphNumber - Proposal Paragraph Number
    • ProposedContractNumber - Proposed Contract Number
    • ProposedGroupWorkCandidateSequenceNumber - Proposed Group Work Candidate Sequence Number
    • ProposedSequenceNumber - Proposed Sequence Number
    • ProposedWorkCandidateSequenceNumber - Proposed Work Candidate Sequence Number
    • ProtocolNumber - Protocol Number
    • ProtractionNumber - Protraction Number
    • ProviderClaimNumber - Provider Claim Number
    • ProviderCommercialNumber - Provider Commercial Number
    • ProviderControlNumber - Provider Control Number
    • ProviderOrderTicketNumber - Provider Order Ticket Number
    • ProviderPlanNetworkIdentificationNumber - Provider Plan Network Identification Number
    • ProviderSiteNumber - Provider Site Number
    • ProviderUPINNumber - Provider UPIN Number
    • ProvincialCanadianSalesTaxExemptionNumber - Provincial (Canadian) Sales Tax Exemption Number
    • ProvincialTaxIdentification - Provincial Tax Identification
    • ProvisionalPatentApplicationNumber - Provisional Patent Application Number
    • PublicationIssueNumber - A number assigned to identify a publication issue.
    • PublicDeedNumber - Public Deed Number
    • PublicFilingRegistrationNumber - A number assigned at the time of registration of a public filing.
    • PublicUtilitiesCommissionCertificateOfPublicConvenience - Public Utilities Commission Certificate of Public Convenience
    • PurchaseDescription - Purchase Description
    • PurchaseOptionAgreement - Purchase Option Agreement
    • PurchaseOrderChangeNumber - Reference number assigned by a buyer for a revision of a purchase order.
    • PurchaseOrderLineItemIdentifierBuyer - Purchase Order Line Item Identifier (Buyer)
    • PurchaseOrderNumberIncludedinOnOrderPosition - Purchase Order Number Included in On-Order Position
    • PurchaseOrderNumberOfOrderReceivedSinceLastReportingDate - Purchase Order Number of Order Received Since Last Reporting Date
    • PurchaseOrderNumberOfShipmentReceivedSinceLastReportingDate - Purchase Order Number of Shipment Received Since Last Reporting Date
    • PurchaseOrderNumberSuffix - A number added at the end of a purchase order number.
    • PurchaseOrderResponseNumber - Reference number assigned by the seller to an order response.
    • PurchaseOrderRevisionNumber - Purchase Order Revision Number
    • PurchaseRequisitionNumber - Purchase Requisition Number
    • PurchasersRequestReference - Reference identifying a request made by the purchaser.
    • PurchasingActivityClauseNumber - A number indicating a clause applicable to a purchasing activity.
    • QualifiedMaterialsList - Qualified Materials List
    • QualifiedProductsList - Qualified Products List
    • QualityClause - Quality Clause
    • QualityDispositionAreaIdentifier - Quality Disposition Area Identifier
    • QualityInspectionAreaIdentifier - Quality Inspection Area Identifier
    • QualityReportNumber - Quality Report Number
    • QualityReviewMaterialCribIdentifier - Quality Review Material Crib Identifier
    • QuantityValuationNumber - Reference number assigned to a quantity valuation.
    • QuantityValuationRequestNumber - Reference number assigned to a quantity valuation request.
    • QuarantineOrTreatmentStatusReferenceNumber - Coded quarantine/treatment status of a container and its cargo and packing materials, generated by a shipping company based upon declarations presented by a shipper.
    • QuarterQuarterSectionNumber - Quarter Quarter Section Number
    • QuarterQuarterSpotNumber - Quarter Quarter Spot Number
    • QuestionNumber - Question Number
    • QuotaNumber - Reference number allocated by a government authority to identify a quota.
    • QuoteOrShoppingCartID - Added per PO requirement
    • RackTypeNumber - Rack Type Number
    • RailOrRoadRoutingCode - International Western and Eastern European route code used in all rail organizations and specified in the international tariffs (rail tariffs) known by the customers.
    • RailroadCommissionOilNumber - Railroad Commission Oil Number
    • RailroadCommissionRecordNumber - Railroad Commission Record Number
    • RailRoutingCode - Rail Routing Code
    • RailWayBillNumber
    • RailwayConsignmentNoteNumber - Reference number assigned to a rail consignment note, see: 1001 = 720.
    • RailwayWagonNumber - (8320) Registered identification initials and numbers of railway wagon. Synonym: Rail car number.
    • RangeNumber - Range Number
    • RateCardNumber - Rate Card Number
    • RateCodeNumber - Number assigned by a buyer to rate a product.
    • RateConferenceIDCode - Rate Conference ID Code
    • RateNoteNumber - Reference assigned to a specific rate.
    • RatingPeriod - Rating Period
    • RawmaterialSupplierDunAndBradstreetNumber - Raw material supplier Dun and Bradstreet number
    • RealEstateOwnedPropertyIdentifier - Real Estate Owned Property Identifier
    • ReasonForChange - Reason for Change
    • ReasonNotLowestCostCode - Reason Not Lowest Cost Code
    • RebateNumber - Rebate Number
    • RecallNumber - Recall Number
    • ReceiptNumber - Receipt Number
    • ReceivedNumber - [1150] Number assigned to a rail consignment upon its arrival at its destination station (CIM 84).
    • ReceiverAssignedDropZone - Receiver Assigned Drop Zone
    • ReceiverClaimNumber - Receiver Claim Number
    • ReceiverIdentificationNumber - Receiver Identification Number
    • ReceiverIDQualifier - Receiver ID Qualifier
    • ReceiversFileReferenceNumber - File reference number assigned by the receiver.
    • ReceiverSubIdentificationNumber - Receiver Sub-identification Number
    • ReceivingAdviceNumber - A reference number to a receiving advice.
    • ReceivingBanksAuthorizationNumber - Authorization number of the receiving bank.
    • ReceivingCompanyIdentifier - Receiving Company Identifier
    • ReceivingDepositoryFinancialInstitutionIdentifier - Receiving Depository Financial Institution Identifier
    • ReceivingNumber - Receiving Number
    • ReceivingPartysMemberIdentification - Identification used by the receiving party for a member of a service scheme or group of persons.
    • ReconciliationReportSectionIdentificationCode - Reconciliation Report Section Identification Code
    • RecordingNumber - Recording Number
    • ReducedEarningWeekIdentifier - Reduced Earning Week Identifier
    • ReelNumber - Reel Number
    • ReferencedBy - Referenced By
    • ReferencedPatternIdentification - Referenced Pattern Identification
    • ReferenceDrawingNumber - Reference Drawing Number
    • ReferenceNumberAssignedByThirdParty - Reference number assigned by a third party.
    • ReferenceNumberOfARequestForMeteredReading - Number to identify a request for a recording or reading of a measuring device to be taken.
    • ReferenceNumberQuotedOnStatement - Reference number quoted on the statement sent to the beneficiary for information purposes.
    • ReferenceNumberToPreviousMessage - Reference number assigned to the message which was previously issued (e.g. in the case of a cancellation, the primary reference of the message to be cancelled will be quoted in this element).
    • ReferenceVersionNumber - Reference Version Number
    • ReferralNumber - Referral Number
    • ReferredProductForChemicalAnalysis - A product number identifying the product which is used for chemical analysis considered valid for a group of products.
    • ReferredProductForMechanicalAnalysis - A product number identifying the product which is used for mechanical analysis considered valid for a group of products.
    • RefinerIdentification - Refiner Identification
    • Region - Region
    • RegionalAccountNumber - Regional Account Number
    • RegiristoFederalDeContribuyentes - A federal tax identification number assigned by the Mexican tax authority.
    • RegisteredCapitalReference - Registered capital reference of a company.
    • RegisteredContractorActivityType - Reference number identifying the type of registered contractor activity.
    • RegisteredMailNumber - Registered Mail Number
    • RegistrationNumber - Registration Number
    • RegistrationNumberOfPreviousCustomsDeclaration - Registration number of the Customs declaration lodged for the previous Customs procedure.
    • RegistroInformacionFiscal - Registro Informacion Fiscal (RIF)
    • RegistroNacionaldeContribuyente - Registro Nacional de Contribuyente (RNC)
    • RegistroUnicodeContribuyente - Registro Unico de Contribuyente (RUC)
    • RegulationPrimaryNumber - Regulation Primary Number
    • RegulationSecondaryNumber - Regulation Secondary Number
    • RegulatoryGuidelineIdentifier - Regulatory Guideline Identifier
    • ReinsuranceReference - Reinsurance Reference
    • ReinsurersClaimNumber - To identify the number assigned to the claim by the reinsurer.
    • ReissueCessionNumber - Reissue Cession Number
    • RejectionNumber - Rejection Number
    • RelatedCase - Related Case
    • RelatedContractLineItemNumber - Related Contract Line Item Number
    • RelatedDocumentNumber - Reference number identifying a related document.
    • RelatedNonconformanceNumber - Related Nonconformance Number
    • RelatedObjectIdentificationNumber - Related Object Identification Number
    • RelatedTransactionReferenceNumber - Related Transaction Reference Number
    • RelatedVendorOrderNumber - Related Vendor Order Number
    • RelativePriority - Relative Priority
    • ReleaseInvoiceNumberForPriorBillAndHold - Release invoice number for prior bill and hold
    • ReleaseNumber - Reference number assigned to identify a release of a set of rules, conventions, conditions, etc.
    • RemittanceAdviceNumber
    • RemittingBanksReference - Reference number of the remitting bank.
    • RemovalNumber - Removal Number
    • RentalAccountNumber - Rental Account Number
    • RentalAgreementNumber - Rental Agreement Number
    • RentPayorIdentification - Rent Payor Identification
    • RepairActionNumber - Repair Action Number
    • RepairCategoryNumber - Repair Category Number
    • RepairDataRequestNumber - A number which uniquely identifies a request for data about repairs.
    • RepairEstimateNumber - A number identifying a repair estimate.
    • RepairOrderNumber - Repair Order Number
    • RepairPartNumber - Repair Part Number
    • RepeatLocation - Repeat Location
    • RepetitiveBookingNumber - Repetitive Booking Number
    • RepetitiveCargoShipmentNumber - Repetitive Cargo Shipment Number
    • RepetitivePatternCode - Repetitive Pattern Code
    • RepetitiveWaybillCode - Repetitive Waybill Code (Origin Carrier, Standard Point Location Code, etc)
    • ReplacementAssemblyModelNumber - Replacement Assembly Model Number
    • ReplacementAssemblySerialNumber - Replacement Assembly Serial Number
    • ReplacementClaimNumber - Replacement Claim Number
    • ReplacementCustomerReferenceNumber - Replacement Customer Reference Number
    • ReplacementDrugEnforcementAdministrationNumber - Replacement Drug Enforcement Administration Number
    • ReplacingPartNumber - New part number which replaces the existing part number.
    • ReplenishmentPurchaseOrderNumber - Purchase order number specified by the buyer for the assignment to vendor's replenishment orders in a vendor managed inventory program.
    • ReplenishmentPurchaseOrderRangeEndNumber - Ending number of a range of purchase order numbers assigned by the buyer to vendor's replenishment orders.
    • ReplenishmentPurchaseOrderRangeStartNumber - Starting number of a range of purchase order numbers assigned by the buyer to vendor's replenishment orders.
    • ReporterIdentification - Reporter Identification
    • ReportingFormNumber - Reference number assigned to the reporting form.
    • ReportNumber - Reference to a report to Customs by a carrier at the point of entry, encompassing both conveyance and consignment information.
    • Representation - Representation
    • RepresentativeIdentificationNumber - Representative Identification Number
    • RepricedClaimReferenceNumber - Repriced Claim Reference Number
    • RepricedLineItemReferenceNumber - Repriced Line Item Reference Number
    • RequestForCancellationNumber
    • RequestforQuotationReference - Request for Quotation Reference
    • RequestForQuoteNumber - Reference number assigned by the requestor to a request for quote.
    • RequestNumber - The reference number of a request.
    • ReservationNumber - Reservation Number
    • ReserveAssemblyLineFeedLocation - Reserve Assembly Line Feed Location
    • ResourceScreeningReference - Resource Screening Reference
    • ResourceUtilizationGroupNumber - Resource Utilization Group (RUG) Number
    • ResponsetoaRequestforQuotationReference - Response to a Request for Quotation Reference
    • RestrictedAvailabilityAuthorization - Restricted Availability Authorization
    • RestrictedAvailabilityNumber - Restricted Availability Number
    • ResubmissionNumber - Resubmission Number
    • ResubmissionReasonCode - Resubmission Reason Code
    • Resubmitnumber - Resubmit number
    • RetailMerchantsCertificationNumber - Retail Merchant's Certification Number
    • RetirementPlanAccountNumber - Retirement Plan Account Number
    • RetirementPlanPolicyNumber - Retirement Plan Policy Number
    • ReturnableContainerReferenceNumber - A reference number identifying a returnable container.
    • ReturnableContainerSerialNumber - Returnable Container Serial Number
    • ReturnedGoodsAuthorizationNumber - Returned Goods Authorization Number
    • ReturnGoodsBillOfLadingNumber - Return Goods Bill of Lading Number
    • ReturnMaterialAuthorizationNumber - Return Material Authorization Number
    • ReturnsNoticeNumber - A reference number to a returns notice.
    • RevenueSource - Revenue Source
    • Review - Review
    • ReviewerFileNumber - Reviewer File Number
    • ReviewPeriodNumber - Review Period Number
    • RevisionNumber - Revision Number
    • RIF - RegistroInformacionFiscal Number: A number assigned by the government to a business in some Latin American countries.
    • RigNumber - Rig Number
    • RoadConsignmentNoteNumber - Reference number assigned to a road consignment note, see: 1001 = 730.
    • RouteNumber - Route Number
    • RouteOrderNumberDomestic - Route Order Number-Domestic
    • RouteOrderNumberEmergency - Route Order Number-Emergency
    • RouteOrderNumberExport - Route Order Number-Export
    • RoutingInstructionNumber - Routing Instruction Number
    • RUC - RegistroUnicoDeContribuyente Number: A number assigned by the government to a business in some Latin American countries.
    • RuleSection - Rule Section
    • RunNumber - Run Number
    • SafekeepingAccountNumber - Safekeeping Account Number
    • SafetyEquipmentCertificate - Safety Equipment Certificate
    • SafetyofRadioCertificate - Safety of Radio Certificate
    • SafetyofShipCertificate - Safety of Ship Certificate
    • SalesOrTerritoryCode - Sales/Territory Code
    • SalesAllowanceNumber - Sales Allowance Number
    • SalesDepartmentNumber - Description to be provided.
    • SalesForecastNumber - A reference number identifying a sales forecast.
    • SalesOfficeNumber - Description to be provided.
    • SalesPersonNumber - Identification number of a sales person.
    • SalesProgramNumber - Sales Program Number
    • SalesRegionNumber - Sales Region Number
    • SalesReportNumber - A reference number identifying a sales report.
    • SalesRepresentativeOrderNumber - Sales Representative Order Number
    • SalesResponsibility - Sales Responsibility
    • SampleNumber - Sample Number
    • Savings - Savings
    • SBA - Statistic Bundes Amt Identifier: A German industry classification code issued by Statistic Bundes Amt (SBA) to identify the activity of a company.
    • ScaleNumber - Scale Number
    • ScanLine - Scan Line
    • ScheduleReferenceNumber - Schedule Reference Number
    • SchemeOrPlanNumber - Reference number assigned to a service scheme or plan.
    • SchoolLoanNumber - School Loan Number
    • SchoolUse - School Use
    • SealNumber - [9308] Identification number on Customs or other seals affixed to containers or other transport units.
    • SealOffNumber - Seal Off Number
    • SealOnNumber - Seal On Number
    • SearchKey - Search Key
    • SecondaryCoverageCertificateNumber - Secondary Coverage Certificate Number
    • SecondaryCoverageCompanyNumber - Secondary Coverage Company Number
    • SecondaryCustomsReference
    • SecondaryEmployeeIdentificationNumber - Secondary Employee Identification Number
    • SecondaryHealthInsuranceIdentificationNumber - Secondary Health Insurance Identification Number
    • SecondaryPolicyNumber - Secondary Policy Number
    • SecondaryProviderNumber - Secondary Provider Number
    • SecondarySuffixCodeIndicator - Secondary Suffix Code Indicator
    • SecondBeneficiarysReference - Reference of the second beneficiary.
    • SecretariadeComerciayFamentaIndustrialNumber - Secretaria de Comercia y Famenta Industrial (SECOFI) Number
    • SecretaryofStateAssignedIdentificationNumber - Secretary of State Assigned Identification Number
    • SectionNumber - Section Number
    • SectionOfTheNationalHousingActCode - Section of the National Housing Act Code
    • SecurityInstrumentNumber - Security Instrument Number
    • SecurityType - Security Type
    • SelfInsuranceIdentificationNumber - Self Insurance Identification Number
    • SelfInsurerAuthorizationTypeCode - Self Insurer Authorization Type Code
    • SelfInsurerOrganizationType - Self Insurer Organization Type
    • SellerLoanNumber - Seller Loan Number
    • SellersCatalogueNumber - Identification number assigned to a seller's catalogue.
    • SellersCreditMemo - Seller's Credit Memo
    • SellersDebitMemo - Seller's Debit Memo
    • SellersInvoiceNumber - Seller's Invoice Number
    • SellersReferenceNumber - Reference number assigned to a transaction by the seller.
    • SellersSaleNumber - Seller's Sale Number
    • SellingArrangement - Selling Arrangement
    • SenderDefinedClause - Sender Defined Clause
    • SendersClauseNumber - The number that identifies the sender's clause.
    • SendersFileReferenceNumber - File reference number assigned by the sender.
    • SendersReferenceToTheOriginalMessage - The reference provided by the sender of the original message.
    • SendingBankReferenceNumber - Reference number of the sending bank.
    • SendingCompanyAuditNumberAutomatedClearinghouseTransfers - Sending Company Audit Number (Automated Clearinghouse Transfers)
    • SequenceNumber - Sequence Number
    • SerialNumber - Serial Number
    • ServiceAuthorizationNumber - Service Authorization Number
    • ServiceBulletinNumber - Service Bulletin Number
    • ServiceBureau - Service Bureau
    • ServiceChangeNumber - Service Change Number
    • ServiceChargeNumber - Service Charge Number
    • ServiceContractNumber - Service Contract (Coverage) Number
    • ServiceEstimateNumber - Service Estimate Number
    • ServiceGroupIdentificationNumber - Identification used for a group of services.
    • ServiceInterruptTrackingNumber - Service Interrupt Tracking Number
    • ServiceOrderNumber - Service Order Number
    • ServicePerformedCode - Service Performed Code
    • Servicer - Servicer
    • ServiceRequestNumber - Service Request Number
    • ServicerLoanNumber - Servicer Loan Number
    • Session - Session
    • SetNumber - Set Number
    • Sheet - Sheet
    • ShelfLifeIndicator - Shelf Life Indicator
    • ShipFrom - Ship From
    • ShipmentDestinationCode - Shipment Destination Code
    • ShipmentOriginCode - Shipment Origin Code
    • ShipmentReferenceNumber - Reference number assigned to a shipment.
    • ShipNoticeOrManifestNumber - Ship Notice/Manifest Number
    • ShipownersAuthorizationNumber - Reference number assigned by the shipowner as an authorization number to transport certain goods (such as hazardous goods, cool or reefer goods).
    • ShipperCarOrderNumber - Shipper Car Order Number
    • ShippersBondNumber - Shippers Bond Number
    • ShippersHazardousNumber - Shipper's Hazardous Number
    • ShippersOrder - Shipper's Order (Invoice Number)
    • ShippingLabelSerialNumber - Shipping Label Serial Number
    • ShippingNoteNumber - Reference number assigned to a shipping note, see: 1001 = 630
    • ShippingUnitIdentification - Identifying marks on the outermost unit that is used to transport merchandise.
    • ShippingZone - Shipping Zone
    • ShortTermDisabilityPolicyNumber - Short-term Disability Policy Number
    • ShowIdentification - Show Identification
    • SIC - Standard Industry Classification Number: A number specifying a standard industry classification.
    • SID - Shipper's Identifying Number for Shipment (SID)
    • SignalCode - Signal Code
    • SignalCodeNumber - Reference number to identify a signal.
    • SingleTransactionSequenceNumber
    • SIRENNumber - SIREN Number
    • SIRETNumber - SIRET Number
    • SiteSpecificProceduresTermsAndConditions - Site Specific Procedures, Terms, and Conditions
    • SituationNumber - Common reference number given to documents concerning a determined period of works.
    • SlaughterPlantNumber - Number to identify slaughter plant.
    • SocialInsuranceNumber - Social Insurance Number
    • SocialSecurityNumber - An identification number assigned to an individual by the social security administration.
    • SocietyofPropertyInformationCompilersandAnalysts - Society of Property Information Compilers and Analysts
    • SoftwareApplicationNumber - Software Application Number
    • Solicitation - Solicitation
    • SortAndSegregate - Sort and Segregate
    • SourceDocumentInternalReference - Reference number assigned to a source document for internal usage.
    • SpacingUnitOrderNumber - Spacing Unit Order Number
    • SpecialApproval - Special Approval
    • SpecialBudgetAccountNumber - The number of a special budget account.
    • SpecialChargeOrAllowanceCode - Special Charge or Allowance Code
    • SpecialClause - Special Clause
    • SpecialGovernmentAccountingClassificationReferenceNumber - Special Government Accounting Classification Reference Number (ACRN)
    • SpecialInstructionsNumber - A number indicating a citation used for special instructions.
    • SpecialMoveReferenceNumber - Special Move Reference Number
    • SpecialPackagingInstructionNumber - Special Packaging Instruction Number
    • SpecialPaymentReferenceNumber - Special Payment Reference Number
    • SpecialProcessingCode - Special Processing Code
    • SpecialQuoteNumber - Special Quote Number
    • SpecialtyLicenseNumber - Specialty License Number
    • SpecificationClassNumber - Specification Class Number
    • SpecificationNumber - Number assigned by the issuer to his specification.
    • SpecificationRevision - Specification Revision
    • SpecimenIdentifier - Specimen Identifier
    • SplitBookingNumber - Split Booking Number
    • SplitPremiumAuditChangeIdentifier - Split Premium Audit Change Identifier
    • SplitShipmentNumber - Split Shipment Number
    • SponsorsReferenceNumber - Sponsor's Reference Number
    • SpouseTie - Spouse Tie
    • StackTrainIdentification - Stack Train Identification
    • Standard - Standard
    • StandardCarrierAlphaCode - Standard Carrier Alpha Code (SCAC)
    • StandardClause - Standard Clause
    • StandardIndustryClassificationCode - Standard Industry Classification (SIC) Code
    • StandardNumberOfInspectionDocument - Code identifying the standard number of the inspection document supplied.
    • StandardPointLocationCode - Standard Point Location Code (SPLC)
    • StandardsCodeNumber - Number to identify a specific parameter within a standardization description (e.g. M5 for screws or DIN A4 for paper).
    • StandardsNumber - Number to identify a standardization description (e.g. ISO 9375).
    • StandardsVersionNumber - The version number assigned to a standard.
    • StandardTransportationCommodityCodeBridgeNumber - Standard Transportation Commodity Code (STCC) Bridge Number
    • StandardTransportationCommodityCodeReplacementCode - Standard Transportation Commodity Code (STCC) Replacement Code
    • StartingPackageNumber - Starting Package Number
    • StateAssemblyDistrict - State Assembly District
    • StateCharterNumber - State Charter Number
    • StateControlledSubstanceLicenseNumber - State Controlled Substance License Number
    • StateCriminalHistoryRepositoryIndividualIdentification - State Criminal History Repository Individual Identification
    • StateDepartmentI20FormNumber - State Department I-20 Form Number
    • StateDepartmentIAP66FormNumber - State Department IAP-66 Form Number
    • StateHazardousWasteEntityIdentifier - State Hazardous Waste Entity Identifier
    • StateIndustrialAccidentProviderNumber - State Industrial Accident Provider Number
    • StateLegislativeDistrict - State Legislative District
    • StateLicenseIdentificationNumber - State License Identification Number
    • StateLicenseNumber - State License Number
    • StatementNumber - Description to be provided.
    • StatementOfWork - A reference number for a statement of work.
    • StateNonResidentViolatorCompact - State Non-Resident Violator Compact
    • StateorProvinceAssignedBusinessRegistryNumber - State or Province Assigned Business Registry Number
    • StateOrProvinceAssignedEntityIdentification - Reference number of an entity assigned by a state or province.
    • StateSalesTaxIdentificationNumber - State Sales Tax Identification Number
    • StateSenateDistrict - State Senate District
    • StateStudentIdentificationNumber - State Student Identification Number
    • StateTaxIdentificationNumber - State Tax Identification Number
    • StatewideCourseNumber - Statewide Course Number
    • StationReferenceNumber - International UIC code assigned to every European rail station (CIM convention).
    • Status - Status
    • StatusReportNumber - The reference number for a status report.
    • StockCertificateNumber - Stock Certificate Number
    • StockExchangeCode - Stock Exchange Code
    • StockExchangeCompanyIdentifier - A reference assigned by the stock exchange to a company.
    • StockKeepingUnitNumber
    • StockNumber - Stock Number
    • StopSequenceNumber - Stop Sequence Number
    • StorageInformationCode - Storage Information Code
    • StoreNumber - Store Number
    • Study - Study
    • SubassemblyNumber - Subassembly Number
    • SubcontractLineItemNumber - Subcontract Line Item Number
    • SubcontractNumber - Subcontract Number
    • SubcontractorDataRequirements - Subcontractor Data Requirements (SDRL)
    • SubdayNumber - Subday Number
    • SubdivisionIdentifier - Subdivision Identifier
    • SubexhibitLineItemNumber - Subexhibit Line Item Number
    • SubFile - Identifies the sub file in a structure of related files.
    • SubhouseBillOfLading - Subhouse Bill of Lading
    • SubjectPropertyNonSaleReferenceNumber - Subject Property Non-Sale Reference Number
    • SubjectPropertyReferenceNumber - Subject Property Reference Number
    • SubjectPropertyVerificationSource - Subject Property Verification Source
    • SublineofInsurance - Subline of Insurance
    • SubmissionNumber - Submission Number
    • SubmitterIdentificationNumber - Submitter Identification Number
    • SubscriberAuthorizationNumber - Subscriber Authorization Number
    • SubscriberNumber - Subscriber Number
    • Subservicer - Subservicer
    • SubServicerLoanNumber - Sub-Servicer Loan Number
    • SubsistenceIdentificationNumber - Subsistence Identification Number
    • SubstantivelyConsolidatedCase - Substantively Consolidated Case
    • SubstituteAirWaybillNumber - Reference number assigned to a substitute air waybill, see: 1001 = 743.
    • SubstituteManufacturersPartNumber - Substitute Manufacturer's Part Number
    • SubstituteNationalStockNumber - Substitute National Stock Number
    • SubstitutePartNumber - Substitute Part Number
    • SubSubhouseBillOfLading - Sub-subhouse Bill of Lading
    • SuccessorAccount - Successor Account
    • Suffix - A reference to specify a suffix added to the end of a basic identifier.
    • SuperintendenciadeInversionesExtranjerasNumber - Superintendencia de Inversiones Extranjeras (SIEX) Number
    • SupervisoryAppraiserCertificationNumber - Supervisory Appraiser Certification Number
    • SupplementalAccountNumber - Supplemental Account Number
    • SupplementalAgreementAuthority - Supplemental Agreement Authority
    • SupplementalClaimNumber - Supplemental Claim Number
    • SupplementNumber - Supplement Number
    • Supplier - Supplier
    • SupplierReplacement - Supplier (Replacement)
    • SupplierDocumentIdentificationNumber - Supplier Document Identification Number
    • SuppliersControlNumber - Reference to a file regarding a control of the supplier carried out on departure of the goods.
    • SuppliersCreditClaimReferenceNumber - A reference number identifying a supplier's credit claim.
    • SupportingDocumentNumber - Supporting Document Number
    • SuretyBondNumber - Surety Bond Number
    • SuspensionIdentifier - Suspension Identifier
    • SwapOrderNumber - Number assigned by the seller to a swap order (see definition of DE 1001, code 229).
    • SWIFT - Society for Worldwide Interbank Financial Telecommunication (S.W.I.F.T.) Identification (8 or 11 Characters)
    • SWIFTMT100 - SWIFT (MT 100)
    • SWIFTMT202 - SWIFT (MT 202)
    • SWIFTConfirmationNumber - Society for Worldwide Interbank Financial Telecommunications (SWIFT) Confirmation Number
    • SymbolNumber
    • SymbolNumberForMilestoneOrLOBReports - Symbol Number (for Milestone or LOB reports)
    • SystematizedNomenclatureofHumanandVeterinaryMedicine - Systematized Nomenclature of Human and Veterinary Medicine (SNOMED)
    • SystemeInformatiquePourLeRepertoireDesEntreprises - (SIREN) number An identification number known as a SIREN assigned to a business in France.
    • SystemeInformatiquePourLeRepertoireDesEtablissements - (SIRET) number An identification number known as a SIRET assigned to a business location in France.
    • SystemNumber - System Number
    • Tag - Tag
    • TankNumber - Tank Number
    • TariffNumber - Tariff Number
    • TariffPageNumber - Tariff Page Number
    • TariffRuleNumber - Tariff Rule Number
    • TariffSectionNumber - Tariff Section Number
    • TariffSuffixNumber - Tariff Suffix Number
    • TariffSupplementNumber - Tariff Supplement Number
    • TaskOrder - Task Order
    • TaxAgencyNumber - Tax Agency Number (MERS [Mortgage Electronic Registration System] Federal Information Processing Standards [FIPS] Based Number)
    • TaxExchangeCode - Tax Exchange Code
    • TaxExemptionLicenceNumber - Number assigned by the tax authorities to a party indicating its tax exemption authorization. This number could relate to a specified business type, a specified local area or a class of products.
    • TaxExemptNumber - Tax Exempt Number
    • TaxFiling - Tax Filing
    • TaxFormCode - Tax Form Code
    • TaxingAuthorityIdentificationNumber - Taxing Authority Identification Number
    • TaxLicenseExemption - Tax License Exemption
    • TaxLienJurisdiction - Tax Lien Jurisdiction
    • TaxRegistrationNumber - The registration number by which a company/organization is identified with the tax administration.
    • TaxScheduleCode - Tax Schedule Code
    • TaxShelterNumber - Tax Shelter Number
    • TaxWorksheet - Tax Worksheet
    • TCN - TransportationControlNumber: A number assigned for transportation purposes.
    • TeamAssignmentNumber - Team number assigned to a group that is responsible for working a particular transaction.
    • TechnicalDocumentationType - Technical Documentation Type
    • TechnicalDocumentNumber - A number specifying a technical document.
    • TechnicalInformationPackage - Technical Information Package
    • TechnicalOrderNumber - A reference to an order that specifies a technical change.
    • TechnicalPhaseReference - A reference which identifies a specific technical phase.
    • TechnicalRegulation - Reference number identifying a technical regulation.
    • TelecommunicationCircuitSupplementalID - Telecommunication Circuit Supplemental ID
    • TelexMessageNumber - Reference number identifying a telex message.
    • TemplateSequenceNumber - Template Sequence Number
    • Tenor - Tenor
    • Term - Term
    • TerminalCode - Terminal Code
    • TerminalOperatorNumber - Terminal Operator Number
    • TerminalReleaseOrderNumber - Terminal Release Order Number
    • TerminationFiling - Termination Filing
    • TesterIdentification - Tester Identification
    • TestReportNumber - Reference number identifying a test report document relevant to the product.
    • TestSpecificationNumber - Test Specification Number
    • TextElementIdentifierDeletionReference - The reference used within a given TEI (Text Element Identifier) which is to be deleted.
    • TheaterScreenNumber - Theater Screen Number
    • ThirdBanksReferenceNumber - Reference number of the third bank.
    • ThirdBanksReference - Reference assigned by a third bank.
    • ThirdPartyAdministratorClaimNumber - Third-Party Administrator Claim Number
    • ThirdPartyNoteHolderIdentification - Third Party Note Holder Identification
    • ThirdPartyOrganizationAuthorizationNumber - Third-party Organization (TPO) Authorization Number
    • ThirdPartyOriginatorNumber - Third Party Originator Number
    • ThirdPartyPurchaseOrderItemNumber - Third Party Purchase Order Item Number
    • ThirdPartyPurchaseOrderNumber - Third Party Purchase Order Number
    • ThirdPartyPurchaseOrderReleaseNumber - Third Party Purchase Order Release Number
    • ThirdPartyReferenceNumber - Third Party Reference Number
    • ThroughBillOfLadingNumber - Reference number assigned to a through bill of lading, see: 1001 = 761.
    • TicketNumber - Ticket Number
    • TimeFailure - Time Failure
    • TirCarnetNumber - Reference number assigned to a TIR carnet.
    • TIRNumber - TIR Number
    • TitleCompanyCodeBookReference - Title Company Code Book Reference
    • TitleDocumentSchedule - Title Document Schedule
    • TitlePolicyNumber - Title Policy Number
    • TitleReference - Title Reference
    • TitleXIXIdentifierNumber - Title XIX Identifier Number
    • TokyoShokoResearchBusinessIdentifier - Tokyo Shoko Research Business Identifier
    • TollBillingTelephoneReferenceNumber - Toll Billing Telephone Reference Number
    • TotalCycleNumber - Total Cycle Number
    • TotalOrderCycleNumber - Total Order Cycle Number
    • TownshipNumber - Township Number
    • ToxicologyID - Toxicology ID
    • TracerActionRequestNumber - Tracer Action Request Number
    • TrackingNumber - Tracking Number
    • Tract - Tract
    • TraderAccountNumber - Number assigned by a Customs authority which uniquely identifies a trader (i.e. importer, exporter or declarant) for Customs purposes.
    • TradingPartnerIdentificationNumber - Code specifying an identification assigned to an entity with whom one conducts trade.
    • TrailerTypeQualifier - Trailer Type Qualifier
    • TrailerUseAgreements - Trailer Use Agreements
    • TrainingFlightNumber - Non-revenue producing airline flight for training purposes.
    • TransactionCategoryOrType - Transaction Category or Type
    • TransactionReferenceNumber - Reference applied to a transaction between two or more parties over a defined life cycle; e.g. number applied by importer or broker to obtain release from Customs, may then used to control declaration through final accounting (synonyms: declaration, entry number).
    • TransferNumber - An extra number assigned to goods or a container which functions as a reference number or as an authorization number to get the goods or container released from a certain party.
    • TransitGuaranteeNumber - Reference number to identify the guarantee or security provided for Customs transit operation (CCC).
    • TransponderNumber - Transponder Number
    • TransportationAccountCode - Transportation Account Code (TAC)
    • TransportationAccountNumber - An account number to be charged or credited for transportation.
    • TransportationControlNumber - Transportation Control Number (TCN)
    • TransportationExportationNoForInBondMovement
    • TransportationPriorityNumber - Transportation Priority Number
    • TransportContractReferenceNumber - Reference number of a transport contract.
    • TransportCostsReferenceNumber - Reference number of the transport costs.
    • TransportDocumentNumber - [1188] Reference assigned by the carrier or his agent to the transport document.
    • TransportEquipmentReturnReference - Reference known at the address to return equipment to.
    • TransportEquipmentStrippingOrder - Reference number assigned to the order to strip goods from transport equipment.
    • TransportEquipmentStuffingOrder - Reference number assigned to the order to stuff goods in transport equipment.
    • TransportEquipmentSurveyReference - Reference number assigned by the ordering party to the transport equipment survey order.
    • TransportEquipmentSurveyReferenceNumber - Reference number known at the address where the transport equipment will be or has been surveyed.
    • TransportEquipmentSurveyReportNumber - Reference number used by a party to identify its transport equipment survey report.
    • TransportRoute - A predefined and identified sequence of points where goods are collected, agreed between partners, e.g. the party in charge of organizing the transport and the parties where goods will be collected. The same collecting points may be included in different transport routes, but in a different sequence.
    • TransportSectionReferenceNumber - A number identifying a transport section.
    • TravelManifest - Travel Manifest (ACI or OTR)
    • TreatyIdentifier - Treaty Identifier
    • TreatyNumber
    • TrialLocationCode - Trial Location Code
    • Tripleback - Tripleback
    • TruckersBillOfLading - A cargo list/description issued by a motor carrier of freight.
    • Trustee - Trustee
    • TSRBusinessIdentifier - Tokyo Shoko Research Business Identifier: A number assigned to a business by TSR.
    • TypeOfComment - Type of Comment
    • TypeOfEscrowNumber - Type of Escrow Number
    • TypeOfHouseholdGoodsCode - Type of Household Goods Code
    • TypeOfLawSuit - Type of Law Suit
    • TypeOfOutstandingJudgment - Type of Outstanding Judgment
    • TypeOfScienceCode - Type of Science Code
    • U.S.DefenseFederalAcquisitionRegulationSupplement - A reference indicating a citation from the U.S. Defense Federal Acquisition Regulation Supplement.
    • U.S.DepartmentOfVeteransAffairsAcquisitionRegulation - A reference indicating a citation from the U.S. Department of Veterans Affairs Acquisition Regulation.
    • U.S.GovernmentTransportationControlNumber - U.S. Government Transportation Control Number
    • UltimateConsignee - Ultimate Consignee
    • UltimateCustomersOrderNumber - The originator's order number as forwarded in a sequence of parties involved.
    • UltimateCustomersReferenceNumber - The originator's reference number as forwarded in a sequence of parties involved.
    • UnacceptableSourceDUNSNumber - Unacceptable Source DUNS Number
    • UnacceptableSourcePurchaserID - Unacceptable Source Purchaser ID
    • UnacceptableSourceSupplierID - Unacceptable Source Supplier ID
    • UnderwriterIdentificationNumber - Underwriter Identification Number
    • UnderwritingAlertReferenceCode - Underwriting Alert Reference Code
    • UNDG - United Nations Dangerous Goods Number: [7124] Unique serial number assigned within the United Nations to substances and articles contained in a list of the dangerous goods most commonly carried.
    • UnemploymentInsuranceNumber - Unemployment Insurance Number
    • UniformCommercialCodeFilingCollateralNumber - Uniform Commercial Code Filing Collateral Number
    • UniformResourceLocator - Uniform Resource Locator
    • UnionNumber - Union Number
    • UniqueClaimsReferenceNumberOfTheSender - Description to be provided.
    • UniqueConsignmentIdentifier - Unique Consignment Identifier
    • UniqueConsignmentReferenceNumber - (1202) Unique reference of a consignment (UCRN) used for identification purposes in documents and messages exchanged between parties in international trade. See also: Unique Identifier Code (UNIC) in UN/ECE Recommendation No. 8, March 1992.
    • UniqueCurracReferenceNumberOfTheSender - Description to be provided.
    • UniqueMarketReference - Description to be provided.
    • UniqueReinacReferenceNumberOfTheSender - Description to be provided.
    • UniqueSupplierIdentificationNumber - Unique Supplier Identification Number (USIN)
    • UnitedNationsHazardousClassificationNumber - United Nations Hazardous Classification Number
    • UnitedStatesGovernmentVisaNumber - United States Government Visa Number
    • UnitedStatesStandardMetropolitanStatisticalAreaCode - United States Standard Metropolitan Statistical Area (MSA) Code
    • UnitLoadDeviceIdentificationNumber - [8260] Marks (letters and/or numbers) which identify a unit load device e.g. freight container.
    • UnitNumber - Unit Number
    • UnitPropertyNumber - Unit Property Number
    • UnitReliefNumber - Unit Relief Number
    • UnitReportPeriod - Unit Report Period
    • UnitReportPeriodID - Unit Report Period ID
    • UnitTrain - Unit Train
    • UniversalRailroadRevenueWaybillIdentifiedNumber - Universal Railroad Revenue Waybill Identified Number (URRWIN)
    • UniversalTransverseMercatorEast - Universal Transverse Mercator - East
    • UniversalTransverseMercatorNorth - Universal Transverse Mercator - North
    • UniversalTransverseMercatorZone - Universal Transverse Mercator - Zone
    • UnpaidInstallmentReferenceNumber - Unpaid Installment Reference Number
    • UpperSerialNumberOfRange - Upper serial number in a range for declaration of incoming goods.
    • UpstreamShipperContractNumber - Upstream Shipper Contract Number
    • USCFR - A reference indicating a citation from the U.S. Code of Federal Regulations (CFR).
    • USCS - UsCustomsService(Uscs)EntryCode: An entry number assigned by the United States (US) customs service.
    • USCustomsServiceAntiDumpingDutyCaseNumber - U.S. Customs Service (USCS) Anti-dumping Duty Case Number
    • USCustomsServiceBindingRulingNumber - U.S. Customs Service (USCS) Binding Ruling Number
    • USCustomsServiceCommercialDescription - U.S. Customs Service (USCS) Commercial Description
    • USCustomsServiceCountervailingDutyCaseNumber - U.S. Customs Service (USCS) Countervailing Duty Case Number
    • USCustomsServiceEntryNumber - U.S. Customs Service (USCS) Entry Number
    • USCustomsServiceEntryTypeCode - U.S. Customs Service (USCS) Entry Type Code
    • USCustomsServicePreApprovalRulingNumber - U.S. Customs Service (USCS) Pre-approval Ruling Number
    • USCustomsServicePreClassificationRulingNumber - U.S. Customs Service (USCS) Pre-classification Ruling Number
    • USCustomsServiceStatementNumber - U.S. Customs Service (USCS) Statement Number
    • USDOEAndNCES - United States Department of Education, National Center for Education Statistics (NCES) Course Number
    • USDOTBondSuretyCode - A bond surety code assigned by the United States Department of Transportation (DOT).
    • UserID - User ID
    • UserIdentification - User Identification
    • USFCCImportCondition - A number known as the United States Federal Communications Commission (FCC) import condition number applying to certain types of regulated communications equipment.
    • USFederalAcquisitionRegulation - A reference indicating a citation from the U.S. Federal Acquisition Regulation.
    • USFederalInformationResourcesManagementRegulation - A reference indicating a citation from U.S. Federal Information Resources Management Regulation.
    • USFoodAndDrugAdministrationEstablishmentIndicator - An establishment indicator assigned by the United States Food and Drug Administration.
    • USGeneralServicesAdministrationRegulation - A reference indicating a citation from U.S. General Services Administration Regulation.
    • USGovernmentAgencyNumber - Description to be provided.
    • ValueAddedTaxRegistrationNumber - Value-Added Tax Registration Number (Europe)
    • VatRegistrationNumber - Unique number assigned by the relevant tax authority to identify a party for use in relation to Value Added Tax (VAT).
    • VehicleBusinessUseQualifier - Vehicle Business Use Qualifier
    • VehicleLicenceNumber - Number of the licence issued for a vehicle by an agency of government.
    • VehicleRadiusofOperationQualifier - Vehicle Radius of Operation Qualifier
    • VehicleRelatedServicesReferenceNumber - Vehicle-related Services Reference Number
    • VehicleSizeClassQualifier - Vehicle Size Class Qualifier
    • VendorAbbreviationCode - Vendor Abbreviation Code
    • VendorChangeIdentificationCode - Vendor Change Identification Code
    • VendorChangeProcedureCode - Vendor Change Procedure Code
    • VendorContractNumber - Number assigned by the vendor to a contract.
    • VendorIDNumber - Vendor ID Number
    • VendorOrderNumberSuffix - Vendor Order Number Suffix
    • VendorProductNumber - Number assigned by vendor to another manufacturer's product.
    • VendorsPreviousJobNumber - Vendor's Previous Job Number
    • VendorTerms - Vendor Terms
    • VerificationSourceCode - Verification Source Code
    • Version - Version
    • VersionCodeLocal - Version Code - Local
    • VersionCodeNational - Version Code - National
    • VerticalCoordinate - Vertical Coordinate
    • Vessel - Vessel
    • VesselAgentNumber - Vessel Agent Number
    • VesselIdentification - (8123) Reference identifying a vessel (UN/ECE Recommendation No 10).
    • VesselName - Vessel Name
    • VeteransAdministrationOriginatorIdentification - Veterans Administration Originator Identification
    • VeteransAffairsCaseNumber - Veterans Affairs Case Number
    • VIN - VehicleIdentificationNumber: The identification number which uniquely distinguishes one vehicle from another through the lifespan of the vehicle.
    • VisaType - Visa Type
    • VolumeNumber - Volume Number
    • VolumePurchaseAgreementNumber - Volume Purchase Agreement Number
    • VoucherNumber - Reference number identifying a voucher.
    • VoyageNumber - [8228] Reference number assigned by the carrier or his agent to the voyage of the vessel.
    • WageDetermination - Wage Determination
    • Waiver - Waiver
    • Ward - Ward
    • WarehouseEntryNumber - Entry number under which imported merchandise was placed in a Customs bonded warehouse.
    • WarehousePickTicketNumber - Warehouse Pick Ticket Number
    • WarehouseReceiptNumber - Warehouse Receipt Number
    • WarehouseStorageLocationNumber - Warehouse storage location number
    • Warrant - Warrant
    • WarrantyCoverageCode - Warranty Coverage Code
    • WarrantyRegistrationNumber - Warranty Registration Number
    • WaybillNumber - Reference number assigned to a waybill, see: 1001 = 700.
    • WeaponSystemNumber - Weapon System Number
    • WeightAgreementNumber - Description to be provided.
    • WellClassificationCode - Well Classification Code
    • WellNumber - A number assigned to a shaft sunk into the ground.
    • WithdrawalAccountNumber - Withdrawal Account Number
    • WithdrawalRecord - Withdrawal Record
    • WoolIdentificationNumber - Shipping Identification Mark (SIM) allocated to a wool consignment by a shipping company.
    • WoolTaxReferenceNumber - Reference or indication of the payment of wool tax.
    • WorkBreakdownStructure - A structure reference that identifies the breakdown of work for a project.
    • WorkCandidateSequenceNumber - Work Candidate Sequence Number
    • WorkCenter - Work Center
    • WorkingShiftNumber - (Working) Shift Number
    • WorkItemQuantityDetermination - A reference assigned to a work item quantity determination.
    • WorkOrderNumber - Work Order Number
    • WorkPackage - A reference for a detailed package of work.
    • WorkShift - A work shift reference number.
    • WorksiteNumber - Worksite Number
    • WorkTaskChargeNumber - A reference assigned to a specific work task charge.
    • WorkTeam - A reference to identify a team performing work.
    • YardPosition - Yard Position
    • Zone - Zone

[^]Code Fragment

    <xsd:simpleType name="ReferenceTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="AbbreviatedNewDrugApplicationNumber">
        <xsd:enumeration value="AcceptableSourceDUNSNumber">
        <xsd:enumeration value="AcceptableSourcePurchaserID">
        <xsd:enumeration value="AcceptableSourceSupplierID">
        <xsd:enumeration value="AccessCode">
        <xsd:enumeration value="AccessorialRailDiversionReferenceNumber">
        <xsd:enumeration value="AccessorialStatusCode">
        <xsd:enumeration value="AccidentReferenceNumber">
        <xsd:enumeration value="AccountCategory">
        <xsd:enumeration value="AccountingCode">
        <xsd:enumeration value="AccountingEquipmentLocationNumber">
        <xsd:enumeration value="AccountingFileReference">
        <xsd:enumeration value="AccountingPeriodReference">
        <xsd:enumeration value="AccountManagersCode">
        <xsd:enumeration value="AccountNumber">
        <xsd:enumeration value="AccountPartysBankReference">
        <xsd:enumeration value="AccountPartysReference">
        <xsd:enumeration value="AccountPayableNumber">
        <xsd:enumeration value="AccountServicingBanksReferenceNumber">
        <xsd:enumeration value="AccountsReceivableCustomerAccount">
        <xsd:enumeration value="AccountsReceivableNumber">
        <xsd:enumeration value="AccountsReceivableOpenItem">
        <xsd:enumeration value="AccountsReceivableStatementNumber">
        <xsd:enumeration value="AccountSuffixCode">
        <xsd:enumeration value="AcknowledgementOfOrderNumber">
        <xsd:enumeration value="ActionAuthorizationNumber">
        <xsd:enumeration value="AdditionalReferenceNumber">
        <xsd:enumeration value="AddOnSystemNumber">
        <xsd:enumeration value="AddresseeReference">
        <xsd:enumeration value="AdjustedRepricedClaimReferenceNumber">
        <xsd:enumeration value="AdjustedRepricedLineItemReferenceNumber">
        <xsd:enumeration value="AdjustmentControlNumber">
        <xsd:enumeration value="AdjustmentMemoChargeBack">
        <xsd:enumeration value="AdministratorsReferenceNumber">
        <xsd:enumeration value="AdversaryCase">
        <xsd:enumeration value="AdvertiserNumber">
        <xsd:enumeration value="AdviceOfCollectionNumber">
        <xsd:enumeration value="AdviseThroughBanksReference">
        <xsd:enumeration value="AdvisingBanksReference">
        <xsd:enumeration value="AeronauticalEquipmentReferenceNumber">
        <xsd:enumeration value="AFE">
        <xsd:enumeration value="AffectedSubsystemCode">
        <xsd:enumeration value="AffiliationNumber">
        <xsd:enumeration value="AgencyAssignedEmployeeID">
        <xsd:enumeration value="AgencyAssignedNumber">
        <xsd:enumeration value="AgencyCaseNumber">
        <xsd:enumeration value="AgencyClaimNumber">
        <xsd:enumeration value="AgencyClauseNumber">
        <xsd:enumeration value="AIDAR">
        <xsd:enumeration value="AgencyHierarchicalLevel">
        <xsd:enumeration value="AgencyLocationCode">
        <xsd:enumeration value="AgencysStudentNumber">
        <xsd:enumeration value="AgentClaimNumber">
        <xsd:enumeration value="AgentContractNumber">
        <xsd:enumeration value="AgentNumber">
        <xsd:enumeration value="AgentsBankReference">
        <xsd:enumeration value="AgentsReference">
        <xsd:enumeration value="AgentsShipmentNumber">
        <xsd:enumeration value="AGERD">
        <xsd:enumeration value="AgreementNumber">
        <xsd:enumeration value="AgreementToPayNumber">
        <xsd:enumeration value="AirCargoTransferManifest">
        <xsd:enumeration value="AirDimensionCode">
        <xsd:enumeration value="AirHandlingCode">
        <xsd:enumeration value="AirlinesFlightIdentificationNumber">
        <xsd:enumeration value="AirlineTicketNumber">
        <xsd:enumeration value="AirWaybillNumber">
        <xsd:enumeration value="AllotmentIdentification">
        <xsd:enumeration value="AllowanceRecipientIdentification">
        <xsd:enumeration value="AlterationNumber">
        <xsd:enumeration value="AlternateClauseNumber">
        <xsd:enumeration value="AmbulatoryPatientGroupNumber">
        <xsd:enumeration value="AmendedUniformCommercialCodeFilingNumber">
        <xsd:enumeration value="Amendment">
        <xsd:enumeration value="AmendmentFiling">
        <xsd:enumeration value="AmericanBankersAssociationTransitOrRoutingNumber">
        <xsd:enumeration value="AmericanGasAssociationEquationNumber">
        <xsd:enumeration value="AmericanOsteopathicAssociationCertificationNumber">
        <xsd:enumeration value="AmericanPetroleumInstituteDeductionCode">
        <xsd:enumeration value="AmericanPetroleumInstituteWell">
        <xsd:enumeration value="AnalysisNumberOrTestNumber">
        <xsd:enumeration value="AnesthesiaLicenseNumber">
        <xsd:enumeration value="AnimalSpecies">
        <xsd:enumeration value="AnimalStrain">
        <xsd:enumeration value="AntiDumpingCaseNumber">
        <xsd:enumeration value="APE">
        <xsd:enumeration value="ApplicableCoefficientIdentificationNumber">
        <xsd:enumeration value="ApplicableInstructionsOrStandards">
        <xsd:enumeration value="ApplicantsBankReference">
        <xsd:enumeration value="ApplicantsReference">
        <xsd:enumeration value="ApplicationNumber">
        <xsd:enumeration value="ApplicationReferenceNumber">
        <xsd:enumeration value="ApplicationTransactionReferenceNumber">
        <xsd:enumeration value="AppointmentNumber">
        <xsd:enumeration value="AppraiserLicense">
        <xsd:enumeration value="AppropriationNumber">
        <xsd:enumeration value="ApprovalCode">
        <xsd:enumeration value="Area">
        <xsd:enumeration value="ArrivalCode">
        <xsd:enumeration value="ArticleNumber">
        <xsd:enumeration value="AssemblyLineFeedLocation">
        <xsd:enumeration value="AssemblyNumber">
        <xsd:enumeration value="AssessmentNumber">
        <xsd:enumeration value="AssignedByTransactionSetSender">
        <xsd:enumeration value="AssignedContractNumber">
        <xsd:enumeration value="AssignedSequenceNumber">
        <xsd:enumeration value="AssignmentNumber">
        <xsd:enumeration value="AssignmentRecordingNumber">
        <xsd:enumeration value="AssociatedCaseControlNumber">
        <xsd:enumeration value="AssociatedInvoices">
        <xsd:enumeration value="AssociatedNumberForJoinedUnitNotResubdivided">
        <xsd:enumeration value="AssociatedNumberForLimitedCommonElementParking">
        <xsd:enumeration value="AssociatedNumberForUnitParking">
        <xsd:enumeration value="AssociatedPolicyNumber">
        <xsd:enumeration value="AssociatedProductNumber">
        <xsd:enumeration value="AssociatedPropertyNumber">
        <xsd:enumeration value="AssociatedPurchaseOrders">
        <xsd:enumeration value="AssociationOfAmericanRailroadsRailwayAccountingRules">
        <xsd:enumeration value="AssumingCompany">
        <xsd:enumeration value="AtaCarnetNumber">
        <xsd:enumeration value="AtomicSafetyandLicensingBoardPanelNumber">
        <xsd:enumeration value="AttachedTo">
        <xsd:enumeration value="AttachmentCode">
        <xsd:enumeration value="Attorney">
        <xsd:enumeration value="AuthorisationForRepairReference">
        <xsd:enumeration value="AuthorityIssuedEquipmentIdentification">
        <xsd:enumeration value="AuthorizationNumber">
        <xsd:enumeration value="AuthorizationNumberForExceptionToDangerousGoods">
        <xsd:enumeration value="AuthorizationToMeetCompetitionNumber">
        <xsd:enumeration value="AutoLossItemNumber">
        <xsd:enumeration value="ACHReturnOrNotificationOfChangeCode">
        <xsd:enumeration value="ACHEntryDescription">
        <xsd:enumeration value="ACHStandardEntryClass">
        <xsd:enumeration value="ACHTraceNumber">
        <xsd:enumeration value="AutomatedUnderwritingReferenceNumber">
        <xsd:enumeration value="AxleRatio">
        <xsd:enumeration value="BackoutProcedureCode">
        <xsd:enumeration value="BadgeNumber">
        <xsd:enumeration value="BalanceDueReferenceNumber">
        <xsd:enumeration value="BankAssignedBankersReferenceNumber">
        <xsd:enumeration value="BankAssignedSecurityIdentifier">
        <xsd:enumeration value="BankersAcceptance">
        <xsd:enumeration value="BankReference">
        <xsd:enumeration value="BankruptcyProcedureNumber">
        <xsd:enumeration value="BanksCommonTransactionReferenceNumber">
        <xsd:enumeration value="BanksIndividualTransactionReferenceNumber">
        <xsd:enumeration value="BankTelegraphicNumber">
        <xsd:enumeration value="BankToBankInformation">
        <xsd:enumeration value="BarCodedLabelSerialNumber">
        <xsd:enumeration value="BarCodedSerialNumber">
        <xsd:enumeration value="BargePermitNumber">
        <xsd:enumeration value="BasicContractLineItemNumber">
        <xsd:enumeration value="BatchNumberOrLotNumber">
        <xsd:enumeration value="BatchSequenceNumber">
        <xsd:enumeration value="BeamAssemblyCode">
        <xsd:enumeration value="BeginMileMarker">
        <xsd:enumeration value="BeginningJobSequenceNumber">
        <xsd:enumeration value="BeginningKanbanSerialNumber">
        <xsd:enumeration value="BeginningMeterReadingActual">
        <xsd:enumeration value="BeginningMeterReadingEstimated">
        <xsd:enumeration value="BeginningSerialNumber">
        <xsd:enumeration value="BeneficiarysBankReference">
        <xsd:enumeration value="BeneficiarysReference">
        <xsd:enumeration value="BidNumber">
        <xsd:enumeration value="BilateralCarServiceAgreements">
        <xsd:enumeration value="BillAndHoldInvoiceNumber">
        <xsd:enumeration value="BillingAccount">
        <xsd:enumeration value="BillingCenterIdentification">
        <xsd:enumeration value="BillingType">
        <xsd:enumeration value="BillOfLadingNumber">
        <xsd:enumeration value="BillofMaterialRevisionNumber">
        <xsd:enumeration value="BillOfQuantitiesNumber">
        <xsd:enumeration value="BinaryObjectIdentifier">
        <xsd:enumeration value="BinLocationNumber">
        <xsd:enumeration value="BlanketOrderNumber">
        <xsd:enumeration value="BlendedWithBatchNumber">
        <xsd:enumeration value="BlendedWithNumber">
        <xsd:enumeration value="Block">
        <xsd:enumeration value="BlueCrossProviderNumber">
        <xsd:enumeration value="BlueShieldProviderNumber">
        <xsd:enumeration value="BondedCarrierInternalRevenueServiceIdentificationNumber">
        <xsd:enumeration value="BookingReferenceNumber">
        <xsd:enumeration value="BookNumber">
        <xsd:enumeration value="BordereauNumber">
        <xsd:enumeration value="BranchIdentifier">
        <xsd:enumeration value="BrokerIdentification">
        <xsd:enumeration value="BrokerOrSalesOfficeNumber">
        <xsd:enumeration value="BrokerReference1">
        <xsd:enumeration value="BrokerReference2">
        <xsd:enumeration value="BrokersOrderNumber">
        <xsd:enumeration value="BrokerReferenceNumber">
        <xsd:enumeration value="BudgetChapter">
        <xsd:enumeration value="BureauofLaborandStatisticsScheduleIdentifier">
        <xsd:enumeration value="BureauSigningOR">
        <xsd:enumeration value="BureauSigningSR">
        <xsd:enumeration value="BusinessActivity">
        <xsd:enumeration value="BusinessIdentificationNumber">
        <xsd:enumeration value="BusinessTaxNumber">
        <xsd:enumeration value="BuyerIdentification">
        <xsd:enumeration value="BuyersApprovalMark">
        <xsd:enumeration value="BuyersCatalogueNumber">
        <xsd:enumeration value="BuyersContractNumber">
        <xsd:enumeration value="BuyersCreditMemo">
        <xsd:enumeration value="BuyersDebitMemo">
        <xsd:enumeration value="BuyersDebtorNumber">
        <xsd:enumeration value="BuyersItemNumber">
        <xsd:enumeration value="BuyersOrderNumber">
        <xsd:enumeration value="BuyersShipmentMarkNumber">
        <xsd:enumeration value="CadFileLayerConvention">
        <xsd:enumeration value="Calendar">
        <xsd:enumeration value="CalendarNumber">
        <xsd:enumeration value="CallOffOrderNumber">
        <xsd:enumeration value="CallSign">
        <xsd:enumeration value="CanadianExciseEntryNumber">
        <xsd:enumeration value="CanadianFinancialInstitutionBranchAndInstitutionNumber">
        <xsd:enumeration value="CanadianGoodsAndServicesorQuebecSalesTaxReferenceNumber">
        <xsd:enumeration value="CanadianProvinceOperatingAuthorityNumber">
        <xsd:enumeration value="CanadianSocialInsuranceNumber">
        <xsd:enumeration value="CanadianWheatBoardPermitNumber">
        <xsd:enumeration value="CanceledRevisionNumber">
        <xsd:enumeration value="CardAccountReportingIdentifier">
        <xsd:enumeration value="CardAccountReportingLevel">
        <xsd:enumeration value="CardAccountStatusCode">
        <xsd:enumeration value="CardAccountTypeCode">
        <xsd:enumeration value="CardBillingTypeCode">
        <xsd:enumeration value="CardIssuerTransactionCode">
        <xsd:enumeration value="CargoAcceptanceOrderReferenceNumber">
        <xsd:enumeration value="CargoControlNumber">
        <xsd:enumeration value="CargoManifestNumber">
        <xsd:enumeration value="CarnetNumber">
        <xsd:enumeration value="CarrierAssignedCode">
        <xsd:enumeration value="CarrierAssignedConsigneeNumber">
        <xsd:enumeration value="CarrierAssignedPackageIdentificationNumber">
        <xsd:enumeration value="CarrierAssignedReferenceNumber">
        <xsd:enumeration value="CarrierAssignedShipperNumber">
        <xsd:enumeration value="CarriersAgentReferenceNumber">
        <xsd:enumeration value="CarriersCustomsBondNumber">
        <xsd:enumeration value="CarriersReferenceNumber">
        <xsd:enumeration value="CaseNumber">
        <xsd:enumeration value="CaseOfNeedPartysReference">
        <xsd:enumeration value="CasualtyReportNumber">
        <xsd:enumeration value="CasualtyReportSerialNumber">
        <xsd:enumeration value="Catalog">
        <xsd:enumeration value="CatalogueSequenceNumber">
        <xsd:enumeration value="CatastropheNumber">
        <xsd:enumeration value="CategoryOfWorkReference">
        <xsd:enumeration value="CedentsClaimNumber">
        <xsd:enumeration value="CedingCompany">
        <xsd:enumeration value="CeilingFormulaReferenceNumber">
        <xsd:enumeration value="CensusAutomatedFilesID">
        <xsd:enumeration value="CensusBlockGroup">
        <xsd:enumeration value="CensusStateCode">
        <xsd:enumeration value="CensusTract">
        <xsd:enumeration value="CensusTractSuffix">
        <xsd:enumeration value="CentralSecretariatLogNumber">
        <xsd:enumeration value="CentralSecretariatLogNumberChildDataMaintenance">
        <xsd:enumeration value="CentralSecretariatLogNumberParentDataMaintenance">
        <xsd:enumeration value="CertificateNumber">
        <xsd:enumeration value="CertificateOfConformity">
        <xsd:enumeration value="CertificateofIncorporationNumber">
        <xsd:enumeration value="CertificateofTransportation">
        <xsd:enumeration value="Certification">
        <xsd:enumeration value="CertifiedMailNumber">
        <xsd:enumeration value="CRNA">
        <xsd:enumeration value="ChamberOfCommerceNumber">
        <xsd:enumeration value="ChamberOfCommerceRegistrationNumber">
        <xsd:enumeration value="CHAMPUSIdentificationNumber">
        <xsd:enumeration value="ChangeDocumentNumber">
        <xsd:enumeration value="ChangeNumber">
        <xsd:enumeration value="ChangeOrderAuthority">
        <xsd:enumeration value="ChangeVerificationProcedureCode">
        <xsd:enumeration value="ChargeCardAccountNumber">
        <xsd:enumeration value="ChargeCardNumber">
        <xsd:enumeration value="ChargeNoteReferenceNumber">
        <xsd:enumeration value="ChargeNumber">
        <xsd:enumeration value="CharterNumber">
        <xsd:enumeration value="CheckingNumber">
        <xsd:enumeration value="CheckListNumber">
        <xsd:enumeration value="CheckNumber">
        <xsd:enumeration value="ChemicalAbstractServiceRegistryNumber">
        <xsd:enumeration value="ChequeNumber">
        <xsd:enumeration value="CircuitNumber">
        <xsd:enumeration value="Circular">
        <xsd:enumeration value="CircularPublicationNumber">
        <xsd:enumeration value="Citation">
        <xsd:enumeration value="CitationOfOpinion">
        <xsd:enumeration value="CitationOfStatute">
        <xsd:enumeration value="CitizenshipDocumentNumber">
        <xsd:enumeration value="CivilActionNumber">
        <xsd:enumeration value="CivilLiabilitiesofOilCertificate">
        <xsd:enumeration value="ClaimAdministratorClaimNumber">
        <xsd:enumeration value="ClaimantNumber">
        <xsd:enumeration value="ClaimantsClaimNumber">
        <xsd:enumeration value="ClaimNumber">
        <xsd:enumeration value="ClaimOfficeNumber">
        <xsd:enumeration value="ClassCode">
        <xsd:enumeration value="ClassOfContractCode">
        <xsd:enumeration value="ClauseNumber">
        <xsd:enumeration value="ClearingHouseInterbankPaymentsSystemSequenceNumber">
        <xsd:enumeration value="ClearingHouseInterbankPaymentSystemParticipantNumber">
        <xsd:enumeration value="ClearingHouseInterbankPaymentSystemUserIdentification">
        <xsd:enumeration value="ClearingReference">
        <xsd:enumeration value="ClearTextClause">
        <xsd:enumeration value="ClientCompanyCode">
        <xsd:enumeration value="ClientNumber">
        <xsd:enumeration value="ClientReportingCategory">
        <xsd:enumeration value="ClinicalLaboratoryImprovementAmendmentNumber">
        <xsd:enumeration value="ClinicNumber">
        <xsd:enumeration value="CoalAuthorityNumber">
        <xsd:enumeration value="CodeOfFederalRegulations">
        <xsd:enumeration value="CoilNumber">
        <xsd:enumeration value="ColdRollNumber">
        <xsd:enumeration value="CollectingBanksReference">
        <xsd:enumeration value="CollectorIdentification">
        <xsd:enumeration value="CollocationIndicator">
        <xsd:enumeration value="CombinedShipment">
        <xsd:enumeration value="CommercialOrPrivatePassengerVehicleQualifier">
        <xsd:enumeration value="CommercialAccountSummaryReferenceNumber">
        <xsd:enumeration value="CommercialandGovernmentEntityCode">
        <xsd:enumeration value="CommercialDriversLicense">
        <xsd:enumeration value="CommercialInvoiceNumber">
        <xsd:enumeration value="CommercialRegistrationNumber">
        <xsd:enumeration value="CommercialVehicleSafetyAssuranceNumber">
        <xsd:enumeration value="CommitmentNumber">
        <xsd:enumeration value="CommitteeOnUniformSecurityIdentificationProceduresNumber">
        <xsd:enumeration value="CommodityNumber">
        <xsd:enumeration value="CommonAccessReferenceNumber">
        <xsd:enumeration value="CommonTransactionReferenceNumber">
        <xsd:enumeration value="CompanyAndPlaceRegistrationNumber">
        <xsd:enumeration value="CompanyAndSyndicateReference1">
        <xsd:enumeration value="CompanyAndSyndicateReference2">
        <xsd:enumeration value="CompanyIssuedEquipmentId">
        <xsd:enumeration value="CRO">
        <xsd:enumeration value="ComparableProperty">
        <xsd:enumeration value="ComparablePropertyPendingSaleReferenceNumber">
        <xsd:enumeration value="ComparablePropertySaleReferenceNumber">
        <xsd:enumeration value="ComparablePropertyVerificationSource">
        <xsd:enumeration value="CompetentAuthority">
        <xsd:enumeration value="Complaint">
        <xsd:enumeration value="ComplaintCode">
        <xsd:enumeration value="CompletedUnitsPaymentRequestReference">
        <xsd:enumeration value="ComplianceCodeNumber">
        <xsd:enumeration value="Component">
        <xsd:enumeration value="ConditionOfPurchaseDocumentNumber">
        <xsd:enumeration value="ConditionOfSaleDocumentNumber">
        <xsd:enumeration value="CondominiumIdentificationNumber">
        <xsd:enumeration value="CongressionalDistrict">
        <xsd:enumeration value="ConnectingCarrier">
        <xsd:enumeration value="ConsigneeReferenceNumber">
        <xsd:enumeration value="ConsigneesFurtherOrder">
        <xsd:enumeration value="ConsigneesInvoiceNumber">
        <xsd:enumeration value="ConsigneesOrderNumber">
        <xsd:enumeration value="ConsigneesReleaseNumber">
        <xsd:enumeration value="ConsigneesShipmentReferenceNumber">
        <xsd:enumeration value="ConsignmentClassificationID">
        <xsd:enumeration value="ConsignorsFurtherOrder">
        <xsd:enumeration value="ConsignorsReferenceNumber">
        <xsd:enumeration value="ConsolidatedInvoiceNumber">
        <xsd:enumeration value="ConsolidationShipmentNumber">
        <xsd:enumeration value="ConsolidatorsReceiptNumber">
        <xsd:enumeration value="ConstraintNotation">
        <xsd:enumeration value="ConsumerIdentifier">
        <xsd:enumeration value="ConsumptionDataRequestNumber">
        <xsd:enumeration value="ContainerOrEquipmentReceiptNumber">
        <xsd:enumeration value="ContainerOrPackagingSpecificationNumber">
        <xsd:enumeration value="ContainerDispositionOrderReferenceNumber">
        <xsd:enumeration value="ContainerOperatorsReferenceNumber">
        <xsd:enumeration value="ContainerPrefix">
        <xsd:enumeration value="ContainerSequenceNumber">
        <xsd:enumeration value="ContainerWorkOrderReferenceNumber">
        <xsd:enumeration value="ContinuationFiling">
        <xsd:enumeration value="ContinuationUniformCommercialCodeFilingNumber">
        <xsd:enumeration value="ContinuousMoveNumber">
        <xsd:enumeration value="ContinuousTransferNumber">
        <xsd:enumeration value="ContractAddendumNumber">
        <xsd:enumeration value="ContractAuditorIDNumber">
        <xsd:enumeration value="ContractBreakdownReference">
        <xsd:enumeration value="ContractCoopNumber">
        <xsd:enumeration value="ContractHolderClaimNumber">
        <xsd:enumeration value="ContractLineItemNumber">
        <xsd:enumeration value="ContractNumber">
        <xsd:enumeration value="ContractOptionNumber">
        <xsd:enumeration value="ContractorDataRequirementsList">
        <xsd:enumeration value="ContractorEstablishmentCode">
        <xsd:enumeration value="ContractorRequestReference">
        <xsd:enumeration value="ContractPartyReferenceNumber">
        <xsd:enumeration value="ContractReference">
        <xsd:enumeration value="ContractRiderNumber">
        <xsd:enumeration value="ConveyanceReferenceNumber">
        <xsd:enumeration value="CooperationContractNumber">
        <xsd:enumeration value="CornboreCertificationNumber">
        <xsd:enumeration value="CorrectedBatchNumber">
        <xsd:enumeration value="CorrectedContractNumber">
        <xsd:enumeration value="CorrectedSocialSecurityNumber">
        <xsd:enumeration value="CorrectionNumber">
        <xsd:enumeration value="CorrelationID">
        <xsd:enumeration value="CostAccount">
        <xsd:enumeration value="CostAllocationReference">
        <xsd:enumeration value="CostaRicanJudicialNumber">
        <xsd:enumeration value="CostCentre">
        <xsd:enumeration value="CostElement">
        <xsd:enumeration value="CountyBusinessRegistrationNumber">
        <xsd:enumeration value="CountyCode">
        <xsd:enumeration value="CountyLegislativeDistrict">
        <xsd:enumeration value="CouponDistributionMethod">
        <xsd:enumeration value="CouponRedemptionNumber">
        <xsd:enumeration value="CoverageCode">
        <xsd:enumeration value="CreditCard">
        <xsd:enumeration value="CreditCounselingIdentificationNumber">
        <xsd:enumeration value="CreditMemoNumber">
        <xsd:enumeration value="CreditNoteNumber">
        <xsd:enumeration value="Creditor">
        <xsd:enumeration value="CreditorDebitAdjustmentNumber">
        <xsd:enumeration value="CreditorsReferenceNumber">
        <xsd:enumeration value="CreditRatingAgencysReferenceNumber">
        <xsd:enumeration value="CreditReferenceNumber">
        <xsd:enumeration value="CreditReportNumber">
        <xsd:enumeration value="CreditRepositoryCode">
        <xsd:enumeration value="CriticalApplication">
        <xsd:enumeration value="CriticalityDesignator">
        <xsd:enumeration value="CropYear">
        <xsd:enumeration value="CrossListedCourseNumber">
        <xsd:enumeration value="CrossReferenceNumber">
        <xsd:enumeration value="CS54KeyTrainIndicatorCode">
        <xsd:enumeration value="CS54KeyTrainIndicatorGroupName">
        <xsd:enumeration value="CurrentCertificateNumber">
        <xsd:enumeration value="CurrentInvoiceNumber">
        <xsd:enumeration value="CurrentorLatestCourseNumber">
        <xsd:enumeration value="CurrentProceduralTerminologyCode">
        <xsd:enumeration value="CurrentRevisionNumber">
        <xsd:enumeration value="CustomerCatalogNumber">
        <xsd:enumeration value="CustomerMaintenancePeriodSequenceNumber">
        <xsd:enumeration value="CustomerMaterialSpecificationNumber">
        <xsd:enumeration value="CustomerOrderNumber">
        <xsd:enumeration value="CustomerProcessSpecificationNumber">
        <xsd:enumeration value="CustomerReferenceNumber">
        <xsd:enumeration value="CustomerReferenceNumberAssignedToPreviousBalanceOf">
        <xsd:enumeration value="CustomersCommonTransactionReferenceNumber">
        <xsd:enumeration value="CustomersIndividualTransactionReferenceNumber">
        <xsd:enumeration value="CustomersPartNumber">
        <xsd:enumeration value="CustomerSpecificationNumber">
        <xsd:enumeration value="CustomersReleaseNumber">
        <xsd:enumeration value="CustomersUnitInventoryNumber">
        <xsd:enumeration value="CustomerTrackingNumberForLoanedMaterials">
        <xsd:enumeration value="CustomsBarCodeNumber">
        <xsd:enumeration value="CustomsBrokerReferenceNumber">
        <xsd:enumeration value="CustomsDecisionRequestNumber">
        <xsd:enumeration value="CustomsDeclarationNumber">
        <xsd:enumeration value="CustomsDrawbackEntryNumber">
        <xsd:enumeration value="CustomsGuaranteeNumber">
        <xsd:enumeration value="CustomshouseBrokerLicenseNumber">
        <xsd:enumeration value="CustomsItemNumber">
        <xsd:enumeration value="CustomsPreferenceInquiryNumber">
        <xsd:enumeration value="CustomsReleaseCode">
        <xsd:enumeration value="CustomsTariffNumber">
        <xsd:enumeration value="CustomsTranshipmentNumber">
        <xsd:enumeration value="CustomsValuationDecisionNumber">
        <xsd:enumeration value="CutNumber">
        <xsd:enumeration value="DangerousGoodsSecurityNumber">
        <xsd:enumeration value="DangerousGoodsTransportLicenceNumber">
        <xsd:enumeration value="DataAuthenticationNumber">
        <xsd:enumeration value="DataItemDescriptionReference">
        <xsd:enumeration value="DataQualityRejectReason">
        <xsd:enumeration value="DataReliabilityCode">
        <xsd:enumeration value="DataSource">
        <xsd:enumeration value="DataStructureTag">
        <xsd:enumeration value="DealerIdentification">
        <xsd:enumeration value="DealerNumber">
        <xsd:enumeration value="DealerOrderNumber">
        <xsd:enumeration value="Dealerpurchaseordernumber">
        <xsd:enumeration value="DealerTypeIdentification">
        <xsd:enumeration value="DebitAccountNumber">
        <xsd:enumeration value="DebitNoteNumber">
        <xsd:enumeration value="DebitReferenceNumber">
        <xsd:enumeration value="Debtor">
        <xsd:enumeration value="DebtorsAccount">
        <xsd:enumeration value="DebtorsReferenceNumber">
        <xsd:enumeration value="DeclarantsCustomsIdentityNumber">
        <xsd:enumeration value="DeclarantsReferenceNumber">
        <xsd:enumeration value="DefectCodeNumber">
        <xsd:enumeration value="DefenseFederalAcquisitionRegulations">
        <xsd:enumeration value="DefensePrioritiesAllocationSystemPriorityRating">
        <xsd:enumeration value="DefermentApprovalNumber">
        <xsd:enumeration value="DeferredPaymentReference">
        <xsd:enumeration value="DeliveryNoteNumber">
        <xsd:enumeration value="DeliveryNumber">
        <xsd:enumeration value="DeliveryOrderNumber">
        <xsd:enumeration value="DeliveryQuoteNumber">
        <xsd:enumeration value="DeliveryReference">
        <xsd:enumeration value="DeliveryRegion">
        <xsd:enumeration value="DeliveryScheduleNumber">
        <xsd:enumeration value="DeliveryTicketNumber">
        <xsd:enumeration value="DeliveryTrailerManifest">
        <xsd:enumeration value="DeliveryVerificationCertificate">
        <xsd:enumeration value="DenialReasonIdentifier">
        <xsd:enumeration value="DensityOrderNumber">
        <xsd:enumeration value="DentalInsuranceAccountNumber">
        <xsd:enumeration value="DentalInsurancePolicyNumber">
        <xsd:enumeration value="DentistLicenseNumber">
        <xsd:enumeration value="Department">
        <xsd:enumeration value="DepartmentOrAgencyNumber">
        <xsd:enumeration value="DepartmentNumber">
        <xsd:enumeration value="DepartmentofAgricultureAcquisitionRegulation">
        <xsd:enumeration value="DepartmentofCommerceAcquisitionRegulation">
        <xsd:enumeration value="DepartmentOfDefenseForm250RequirementCode">
        <xsd:enumeration value="DepartmentOfDefenseIdentificationCode">
        <xsd:enumeration value="DDTSCN">
        <xsd:enumeration value="DepartmentofEducationAcquisitionRegulation">
        <xsd:enumeration value="DepartmentofEnergyAcquisitionRegulation">
        <xsd:enumeration value="HHSAR">
        <xsd:enumeration value="HUDAR">
        <xsd:enumeration value="DepartmentofInteriorAcquisitionRegulation">
        <xsd:enumeration value="DepartmentofJusticeAcquisitionRegulation">
        <xsd:enumeration value="DepartmentofLaborAcquisitionRegulation">
        <xsd:enumeration value="DepartmentofStateAcquisitionRegulation">
        <xsd:enumeration value="DepartmentoftheTreasuryAcquisitionOrProcurementRegulation">
        <xsd:enumeration value="DepartmentofTransportationAcquisitionRegulation">
        <xsd:enumeration value="DepartmentOfTransportationBondNumber">
        <xsd:enumeration value="DepartmentofTransportationHazardousNumber">
        <xsd:enumeration value="DepartmentofVeteransAffairsAcquisitionRegulations">
        <xsd:enumeration value="DepartmentWhereInjuryOccurredIdentification">
        <xsd:enumeration value="DeparturefromSpecificationClassCode">
        <xsd:enumeration value="DeparturefromSpecificationNumber">
        <xsd:enumeration value="DeparturefromSpecificationTypeCode">
        <xsd:enumeration value="DependentsInformation">
        <xsd:enumeration value="DepositAccountNumber">
        <xsd:enumeration value="DepositNumber">
        <xsd:enumeration value="DepositorNumber">
        <xsd:enumeration value="DepositoryTrustCompanyIdentification">
        <xsd:enumeration value="DepositSequenceNumber">
        <xsd:enumeration value="DeratCertificate">
        <xsd:enumeration value="DescriptionOfChangeCode">
        <xsd:enumeration value="DespatchAdviceNumber">
        <xsd:enumeration value="DespatchNotePostParcelsNumber">
        <xsd:enumeration value="DespatchNoteNumber">
        <xsd:enumeration value="DestinationofShipmentHarmonizedBasedCode">
        <xsd:enumeration value="DiagnosisRelatedGroupNumber">
        <xsd:enumeration value="DirectDebitReference">
        <xsd:enumeration value="DirectoryNumber">
        <xsd:enumeration value="DirectPaymentValuationNumber">
        <xsd:enumeration value="DirectPaymentValuationRequestNumber">
        <xsd:enumeration value="DisabilityInsuranceAccountNumber">
        <xsd:enumeration value="DisabilityInsurancePolicyNumber">
        <xsd:enumeration value="DiscounterRegistrationNumber">
        <xsd:enumeration value="DispensationReference">
        <xsd:enumeration value="DisposalTurnInDocumentNumber">
        <xsd:enumeration value="DisputeNumber">
        <xsd:enumeration value="DistributionCenterNumber">
        <xsd:enumeration value="DistributionList">
        <xsd:enumeration value="DistributionStatementCode">
        <xsd:enumeration value="DistributorAssignedOrderNumber">
        <xsd:enumeration value="DistributorAssignedTransactionNumber">
        <xsd:enumeration value="DistributOrInvoiceNumber">
        <xsd:enumeration value="DistributorsAccountIdentification">
        <xsd:enumeration value="DistributorsAccountNumber">
        <xsd:enumeration value="DistributorsRepresentativeIdentification">
        <xsd:enumeration value="DistributorsSplitAgentNumber">
        <xsd:enumeration value="DistrictNumber">
        <xsd:enumeration value="DiversionAuthorityNumber">
        <xsd:enumeration value="DivisionIdentifier">
        <xsd:enumeration value="DocketNumber">
        <xsd:enumeration value="DockNumber">
        <xsd:enumeration value="DockReceiptNumber">
        <xsd:enumeration value="DocumentaryCreditAmendmentNumber">
        <xsd:enumeration value="DocumentaryCreditNumber">
        <xsd:enumeration value="DocumentaryPaymentReference">
        <xsd:enumeration value="DocumentationAffectedNumber">
        <xsd:enumeration value="DocumentIdentificationCode">
        <xsd:enumeration value="DocumentNumber">
        <xsd:enumeration value="DocumentVolumeNumber">
        <xsd:enumeration value="DomesticFlightNumber">
        <xsd:enumeration value="DomesticInventoryManagementCode">
        <xsd:enumeration value="DomicileBranchNumber">
        <xsd:enumeration value="DominionOfCanadaCode">
        <xsd:enumeration value="DownstreamShipperContractNumber">
        <xsd:enumeration value="DraftNumber">
        <xsd:enumeration value="DrainholeNumber">
        <xsd:enumeration value="DraweesReference">
        <xsd:enumeration value="DrawingListNumber">
        <xsd:enumeration value="DrawingNumber">
        <xsd:enumeration value="DrawingRevisionNumber">
        <xsd:enumeration value="DrawingType">
        <xsd:enumeration value="DriversLicense">
        <xsd:enumeration value="DrugEnforcementAdministrationNumber">
        <xsd:enumeration value="DrugEnforcementAdministrationOrderBlankNumber">
        <xsd:enumeration value="DrugFormularyNumber">
        <xsd:enumeration value="DunAndBradstreetCanadas8DigitStandardIndustrial">
        <xsd:enumeration value="DunAndBradstreetUS8DigitStandardIndustrial">
        <xsd:enumeration value="DUNSNumberwithFourCharacterSuffix">
        <xsd:enumeration value="DUNSNumberDunAndBradstreet">
        <xsd:enumeration value="DuplicateBillNumber">
        <xsd:enumeration value="DuplicateWaybillinRoute">
        <xsd:enumeration value="DuplicateWaybillNotInRoute">
        <xsd:enumeration value="DutyFreeProductsReceiptAuthorisationNumber">
        <xsd:enumeration value="DutyFreeProductsSecurityNumber">
        <xsd:enumeration value="DutyMemoNumber">
        <xsd:enumeration value="DyeLotNumber">
        <xsd:enumeration value="ECCN">
        <xsd:enumeration value="EducationalInstitutionIdentificationNumber">
        <xsd:enumeration value="ElectionDistrict">
        <xsd:enumeration value="ElectronicDataInterchangeAgreementNumber">
        <xsd:enumeration value="Electronicdevicepinnumber">
        <xsd:enumeration value="ElectronicFundsTransferIDNumber">
        <xsd:enumeration value="ElectronicPaymentReferenceNumber">
        <xsd:enumeration value="Elevation">
        <xsd:enumeration value="EmbargoNumber">
        <xsd:enumeration value="EmbargoPermitNumber">
        <xsd:enumeration value="EmergencyOrderNumber">
        <xsd:enumeration value="EmissionDesignator">
        <xsd:enumeration value="EmployeeOrNonEmployeeClassificationQualifier">
        <xsd:enumeration value="EmployeeIdentificationNumber">
        <xsd:enumeration value="EmployeeTaxFilingStatusCode">
        <xsd:enumeration value="EmployerIdentificationNumberOfServiceBureau">
        <xsd:enumeration value="EmployersIdentificationNumber">
        <xsd:enumeration value="EmployersSocialSecurityNumber">
        <xsd:enumeration value="EmploymentVisa">
        <xsd:enumeration value="EmptyContainerBillNumber">
        <xsd:enumeration value="EmptyRepositioningNumber">
        <xsd:enumeration value="EndingJobSequenceNumber">
        <xsd:enumeration value="EndingKanbanSerialNumber">
        <xsd:enumeration value="EndingMeterReadingActual">
        <xsd:enumeration value="EndingMeterReadingEstimated">
        <xsd:enumeration value="EndingPackageNumber">
        <xsd:enumeration value="EndingSerialNumber">
        <xsd:enumeration value="EndItem">
        <xsd:enumeration value="EndItemNumber">
        <xsd:enumeration value="EndMileMarker">
        <xsd:enumeration value="EndorsementNumber">
        <xsd:enumeration value="EndUseAuthorizationNumber">
        <xsd:enumeration value="EndUseNumber">
        <xsd:enumeration value="EndUsersPurchaseOrderNumber">
        <xsd:enumeration value="EngineeringChangeOrder">
        <xsd:enumeration value="EngineeringChangeProposal">
        <xsd:enumeration value="EngineeringDataList">
        <xsd:enumeration value="EngineeringSpecificationNumber">
        <xsd:enumeration value="EnquiryNumber">
        <xsd:enumeration value="EntryPointAssessmentLogNumber">
        <xsd:enumeration value="EntryPointAssessmentLogNumberChildDmr">
        <xsd:enumeration value="EntryPointAssessmentLogNumberParentDmr">
        <xsd:enumeration value="EnvironmentalProtectionAgencyAcquisitionRegulation">
        <xsd:enumeration value="EnvironmentalProtectionAgencyTestTypePurposeCode">
        <xsd:enumeration value="EnvironmentalProtectionAgencyTransporterIdentificationNumber">
        <xsd:enumeration value="EquipmentInitial">
        <xsd:enumeration value="EquipmentNumber">
        <xsd:enumeration value="EquipmentOwnerReferenceNumber">
        <xsd:enumeration value="EquipmentSequenceNumber">
        <xsd:enumeration value="EquipmentTransportChargeNumber">
        <xsd:enumeration value="EquivalentCourseNumberatRequestingInstitution">
        <xsd:enumeration value="ErrorIdentificationCode">
        <xsd:enumeration value="EscrowFileNumber">
        <xsd:enumeration value="EstimateNumber">
        <xsd:enumeration value="EstimateOrderReferenceNumber">
        <xsd:enumeration value="EstimateSequenceNumber">
        <xsd:enumeration value="EtermsReference">
        <xsd:enumeration value="Eur1CertificateNumber">
        <xsd:enumeration value="EventReferenceNumber">
        <xsd:enumeration value="ExcessTransportationNumber">
        <xsd:enumeration value="ExhibitDistributionList">
        <xsd:enumeration value="ExhibitIdentifier">
        <xsd:enumeration value="ExpansiononEffectofChangeNumber">
        <xsd:enumeration value="ExportClearanceInstructionReferenceNumber">
        <xsd:enumeration value="ExportDeclaration">
        <xsd:enumeration value="ExportersReferenceNumber">
        <xsd:enumeration value="ExportEstablishmentNumber">
        <xsd:enumeration value="ExportLicenceNumber">
        <xsd:enumeration value="ExportPermitNumber">
        <xsd:enumeration value="ExportReferenceNumber">
        <xsd:enumeration value="ExtendedOrExhibitLineItemNumber">
        <xsd:enumeration value="FacilityCertificationNumber">
        <xsd:enumeration value="FacilityIDNumber">
        <xsd:enumeration value="FacilityMeasurementPointNumber">
        <xsd:enumeration value="FacilityNetworkIdentificationNumber">
        <xsd:enumeration value="FailureAnalysisReportNumber">
        <xsd:enumeration value="Failuremechanismnumber">
        <xsd:enumeration value="FamilyMemberIdentification">
        <xsd:enumeration value="FamilyUnitNumber">
        <xsd:enumeration value="FannieMaeSellerServicerNumber">
        <xsd:enumeration value="FederalAcquisitionRegulations">
        <xsd:enumeration value="FederalBureauOfInvestigationIndividualIdentification">
        <xsd:enumeration value="FederalCommunicationsCommissionConditionCode">
        <xsd:enumeration value="FederalCommunicationsCommissionIdentifier">
        <xsd:enumeration value="FederalCommunicationsCommissionTradeOrBrandIdentifier">
        <xsd:enumeration value="FederalEnergyRegulatoryCommissionCertificateOfPublicConvenience">
        <xsd:enumeration value="FHLMCD">
        <xsd:enumeration value="FederalHomeLoanMortgageCorporationLoanNumber">
        <xsd:enumeration value="FederalHousingAdministrationCaseNumber">
        <xsd:enumeration value="CHUMS">
        <xsd:enumeration value="FederalHousingAdministrationOriginatorIdentification">
        <xsd:enumeration value="FederalInformationResourcesManagementRegulation">
        <xsd:enumeration value="FederalMaritimeCommissionForwardersNumber">
        <xsd:enumeration value="FederalMaritimeCommissionTariffNumber">
        <xsd:enumeration value="FederalNationalMortgageAssociationLoanNumber">
        <xsd:enumeration value="FederalRegulation">
        <xsd:enumeration value="FederalSupplyClassificationCode">
        <xsd:enumeration value="FederalSupplyScheduleItemNumber">
        <xsd:enumeration value="FederalSupplyScheduleNumber">
        <xsd:enumeration value="FederalTaxpayersIdentificationNumber">
        <xsd:enumeration value="FederalWireTransfer">
        <xsd:enumeration value="FEDWIREConfirmationNumber">
        <xsd:enumeration value="FeeScheduleIdentifier">
        <xsd:enumeration value="Field">
        <xsd:enumeration value="FileConversionJournal">
        <xsd:enumeration value="FileIdentificationNumber">
        <xsd:enumeration value="FileIdentifier">
        <xsd:enumeration value="FileLineIdentifier">
        <xsd:enumeration value="FilerCodeIssuedbyBureauOfCensus">
        <xsd:enumeration value="FilerCodeIssuedByCustoms">
        <xsd:enumeration value="FileTransferFormNumber">
        <xsd:enumeration value="FileTransferProtocolLocator">
        <xsd:enumeration value="FileVersionNumber">
        <xsd:enumeration value="FilmNumber">
        <xsd:enumeration value="FinalSequenceNumber">
        <xsd:enumeration value="FinalWorkCandidateNumber">
        <xsd:enumeration value="FinancialClassificationCode">
        <xsd:enumeration value="FinancialDetailCode">
        <xsd:enumeration value="FinancialManagementReference">
        <xsd:enumeration value="FinancialPhaseReference">
        <xsd:enumeration value="FinancialSettlementPartysReferenceNumber">
        <xsd:enumeration value="FinancialTransactionReferenceNumber">
        <xsd:enumeration value="FinderNumber">
        <xsd:enumeration value="FineLineClassification">
        <xsd:enumeration value="FinishLotNumber">
        <xsd:enumeration value="FirstTransferNumber">
        <xsd:enumeration value="FiscalCode">
        <xsd:enumeration value="FiscalNumber">
        <xsd:enumeration value="FleetReferenceNumber">
        <xsd:enumeration value="FlexibleSpendingAccountInsuranceAccountNumber">
        <xsd:enumeration value="FlexibleSpendingAccountInsurancePolicyNumber">
        <xsd:enumeration value="FloodDataIdentifier">
        <xsd:enumeration value="FloodZone">
        <xsd:enumeration value="FloorNumber">
        <xsd:enumeration value="FloorPlanApprovalNumber">
        <xsd:enumeration value="FlowReferenceNumber">
        <xsd:enumeration value="FolderNumber">
        <xsd:enumeration value="FoodAndDrugAdministrationAccessionNumber">
        <xsd:enumeration value="FoodAndDrugAdministrationProductCode">
        <xsd:enumeration value="FoodAndDrugAdministrationProductType">
        <xsd:enumeration value="ForeclosingStatus">
        <xsd:enumeration value="ForeclosureAccountNumber">
        <xsd:enumeration value="ForeignExchange">
        <xsd:enumeration value="ForeignExchangeContractNumber">
        <xsd:enumeration value="ForeignMilitarySalesCaseNumber">
        <xsd:enumeration value="ForeignMilitarySalesNoticeNumber">
        <xsd:enumeration value="ForeignMilitarySalesNumber">
        <xsd:enumeration value="ForeignTradeZone">
        <xsd:enumeration value="ForestryPermitNumber">
        <xsd:enumeration value="FormalStatementReference">
        <xsd:enumeration value="Formation">
        <xsd:enumeration value="FormationIdentifier">
        <xsd:enumeration value="FormNumber">
        <xsd:enumeration value="ForPickupLimitedFreightTariffNumber">
        <xsd:enumeration value="ForwardersOrAgentsReferenceNumber">
        <xsd:enumeration value="ForwardingOrderNumber">
        <xsd:enumeration value="Frame">
        <xsd:enumeration value="FranchiseTaxAccountNumber">
        <xsd:enumeration value="FreddieMacSellerServicerNumber">
        <xsd:enumeration value="FreeZoneIdentifier">
        <xsd:enumeration value="FreightBillNumber">
        <xsd:enumeration value="FreightForwarderNumber">
        <xsd:enumeration value="FreightForwardersReferenceNumber">
        <xsd:enumeration value="FreightPayorReferenceNumber">
        <xsd:enumeration value="FullTimeOrPartTimeEmployeeClassificationQualifier">
        <xsd:enumeration value="FunctionalCategory">
        <xsd:enumeration value="FunctionalWorkGroup">
        <xsd:enumeration value="FundCodeNumber">
        <xsd:enumeration value="FundIdentificationNumber">
        <xsd:enumeration value="FundManagersReferenceNumber">
        <xsd:enumeration value="FundsAuthorization">
        <xsd:enumeration value="GasAnalysisSourceMeterNumber">
        <xsd:enumeration value="GasCustodianIdentification">
        <xsd:enumeration value="GaugeTicketNumber">
        <xsd:enumeration value="GeneralAgencyNumber">
        <xsd:enumeration value="GeneralCargoConsignmentReferenceNumber">
        <xsd:enumeration value="GeneralDeclarationNumber">
        <xsd:enumeration value="GeneralLedgerAccount">
        <xsd:enumeration value="GeneralOrderNumber">
        <xsd:enumeration value="GeneralPurposeMessageReferenceNumber">
        <xsd:enumeration value="GeneralServicesAdministrationRegulations">
        <xsd:enumeration value="GeographicDestinationZoneNumber">
        <xsd:enumeration value="GeographicIndex">
        <xsd:enumeration value="GeographicKey">
        <xsd:enumeration value="GeographicNumber">
        <xsd:enumeration value="GeographicScore">
        <xsd:enumeration value="GinnieMaePoolPackageNumber">
        <xsd:enumeration value="GoodsAndServicesTaxIdentificationNumber">
        <xsd:enumeration value="GoodsandServiceTaxRegistrationNumber">
        <xsd:enumeration value="GoodsDeclarationNumber">
        <xsd:enumeration value="GoverningClassCode">
        <xsd:enumeration value="GovernmentAccountingClassReferenceNumber">
        <xsd:enumeration value="GovernmentAdvanceProgress">
        <xsd:enumeration value="GovernmentAgencyReferenceNumber">
        <xsd:enumeration value="GovernmentBillOfLading">
        <xsd:enumeration value="GovernmentBillofLadingOfficeCode">
        <xsd:enumeration value="GovernmentContractNumber">
        <xsd:enumeration value="GovernmentPriorityNumber">
        <xsd:enumeration value="GovernmentQualityAssuranceAndControlLevelNumber">
        <xsd:enumeration value="GovernmentReferenceNumber">
        <xsd:enumeration value="GovernmentRegistrationNumber">
        <xsd:enumeration value="GovernmentTransportationRequest">
        <xsd:enumeration value="GrainBlockNumber">
        <xsd:enumeration value="GrainOrderReferenceNumber">
        <xsd:enumeration value="GravitySourceMeterNumber">
        <xsd:enumeration value="GreenCard">
        <xsd:enumeration value="GroupAccounting">
        <xsd:enumeration value="GroupNumber">
        <xsd:enumeration value="GroupOrPolicyNumber">
        <xsd:enumeration value="GroupWorkCandidateSequenceNumber">
        <xsd:enumeration value="GrowthFactorReference">
        <xsd:enumeration value="GuarantorLoanNumber">
        <xsd:enumeration value="GuarantorUse">
        <xsd:enumeration value="HarmonisedSystemNumber">
        <xsd:enumeration value="HarmonizedCodeSystem">
        <xsd:enumeration value="HasteningNumber">
        <xsd:enumeration value="HazardousCertificationNumber">
        <xsd:enumeration value="HazardousExemptionNumber">
        <xsd:enumeration value="HazardousWasteManifestDocumentNumber">
        <xsd:enumeration value="HealthCareFinancingAdministrationNationalPayerIdentificationNumber">
        <xsd:enumeration value="HealthCareFinancingAdministrationNationalProviderIdentifier">
        <xsd:enumeration value="HealthcareManpowerShortageAreaFacilityIdentificationNumber">
        <xsd:enumeration value="HealthCertificateNumber">
        <xsd:enumeration value="HIBCCLabelerIdentificationCode">
        <xsd:enumeration value="HealthIndustryNumber">
        <xsd:enumeration value="HealthInsuranceAccountNumber">
        <xsd:enumeration value="HealthInsuranceClaimNumber">
        <xsd:enumeration value="HealthInsurancePolicyNumber">
        <xsd:enumeration value="HealthInsuranceRatingAccountNumber">
        <xsd:enumeration value="HealthInsuranceRatingSuffixCode">
        <xsd:enumeration value="HealthMaintenanceOrganizationReferenceNumber">
        <xsd:enumeration value="HealthMaintenanceOrganizationAuthorizationNumber">
        <xsd:enumeration value="HealthMaintenanceOrganizationCodeNumber">
        <xsd:enumeration value="HeatCode">
        <xsd:enumeration value="HighOrWideFileNumber">
        <xsd:enumeration value="HighFabricationAuthorizationNumber">
        <xsd:enumeration value="HighRawMaterialAuthorizationNumber">
        <xsd:enumeration value="HomeMortgageDisclosureActCensusTract">
        <xsd:enumeration value="HomeMortgageDisclosureActBlockNumberArea">
        <xsd:enumeration value="HomeMortgageDisclosureActCountyCode">
        <xsd:enumeration value="HomeMortgageDisclosureActMetropolitanStatisticalArea">
        <xsd:enumeration value="HomeMortgageDisclosureActStateCode">
        <xsd:enumeration value="HorizontalCoordinate">
        <xsd:enumeration value="Horsepower">
        <xsd:enumeration value="HotRollNumber">
        <xsd:enumeration value="HouseBillOfLadingNumber">
        <xsd:enumeration value="HouseWaybillNumber">
        <xsd:enumeration value="IataCargoAgentCassAddressNumber">
        <xsd:enumeration value="IataCargoAgentCodeNumber">
        <xsd:enumeration value="ICD9CM">
        <xsd:enumeration value="IdentificationCardSerialNumber">
        <xsd:enumeration value="IdentityCardNumber">
        <xsd:enumeration value="ImageIdentifier">
        <xsd:enumeration value="ImmediateExportationNoForInBondMovement">
        <xsd:enumeration value="ImmediateTransportationNoForInBondMovement">
        <xsd:enumeration value="ImplementationVersionNumber">
        <xsd:enumeration value="ImportClearanceInstructionReferenceNumber">
        <xsd:enumeration value="ImporterReferenceNumber">
        <xsd:enumeration value="ImportersReferenceNumberToLetterOfCredit">
        <xsd:enumeration value="ImportLicenceNumber">
        <xsd:enumeration value="ImportPermitNumber">
        <xsd:enumeration value="ImputationAccount">
        <xsd:enumeration value="InBondNumber">
        <xsd:enumeration value="InboundToOrOutboundFromParty">
        <xsd:enumeration value="InboundToParty">
        <xsd:enumeration value="Incident">
        <xsd:enumeration value="IncorporatedLegalReference">
        <xsd:enumeration value="IndividualTransactionReferenceNumber">
        <xsd:enumeration value="InitialDealerClaimNumber">
        <xsd:enumeration value="InitialFailureClaim">
        <xsd:enumeration value="InitialSampleInspectionReportNumber">
        <xsd:enumeration value="InitialTroubleIndication">
        <xsd:enumeration value="InlandTransportOrderNumber">
        <xsd:enumeration value="InquiryRequestNumber">
        <xsd:enumeration value="InspectionandSurveySequenceNumber">
        <xsd:enumeration value="InspectionReportNumber">
        <xsd:enumeration value="InspectorIdentificationNumber">
        <xsd:enumeration value="InstituteOfSecurityAndFutureMarketDevelopmentSerialNumber">
        <xsd:enumeration value="InstitutionLoanNumber">
        <xsd:enumeration value="InstitutionNoteHolderIdentification">
        <xsd:enumeration value="InstitutionNumber">
        <xsd:enumeration value="InsuranceCertificateNumber">
        <xsd:enumeration value="InsuranceCertificateReferenceNumber">
        <xsd:enumeration value="InsuranceContractReferenceNumber">
        <xsd:enumeration value="InsuranceLicenseNumber">
        <xsd:enumeration value="InsurancePolicyNumber">
        <xsd:enumeration value="InsuredLocationIdentifier">
        <xsd:enumeration value="InsuredParcelPostNumber">
        <xsd:enumeration value="InsuredsLoanNumber">
        <xsd:enumeration value="InsurerAssignedReferenceNumber">
        <xsd:enumeration value="InsurorPoolIdentificationNumber">
        <xsd:enumeration value="IntegratedLogisticSupportCrossReferenceNumber">
        <xsd:enumeration value="IntegratedMasterPlan">
        <xsd:enumeration value="IntegratedMasterSchedule">
        <xsd:enumeration value="InterchangeAgreementNumber">
        <xsd:enumeration value="InterchangeNumberNew">
        <xsd:enumeration value="InterchangeNumberOld">
        <xsd:enumeration value="InterchangeTrainIdentification">
        <xsd:enumeration value="IntergovernmentalMaritimeOrganizationNumber">
        <xsd:enumeration value="InterimFundingOrganizationLoanNumber">
        <xsd:enumeration value="IntermediaryBroker">
        <xsd:enumeration value="InternalControlNumber">
        <xsd:enumeration value="InternalCustomerNumber">
        <xsd:enumeration value="InternalDataProcessNumber">
        <xsd:enumeration value="InternalOrderNumber">
        <xsd:enumeration value="InternalPurchaseOrderItemNumber">
        <xsd:enumeration value="InternalPurchaseOrderReleaseNumber">
        <xsd:enumeration value="InternalVendorNumber">
        <xsd:enumeration value="InternationalAssessmentLogNumber">
        <xsd:enumeration value="InternationalAssessmentLogNumberChildDataMaintenance">
        <xsd:enumeration value="InternationalAssessmentLogNumberParentDataMaintenance">
        <xsd:enumeration value="InternationalFlightNumber">
        <xsd:enumeration value="InternationalFuelTaxAgreementAccountNumber">
        <xsd:enumeration value="InternationalRegistrationPlanAccountNumber">
        <xsd:enumeration value="InternationalRegistrationPlanStickerNumber">
        <xsd:enumeration value="InternationalStandardIndustrialClassificationDominionOfCanadaCode">
        <xsd:enumeration value="InternationalStandardIndustryClassificationCode">
        <xsd:enumeration value="InterstateCommerceCommissionAccountNumber">
        <xsd:enumeration value="InterviewerID">
        <xsd:enumeration value="IntraPlantRouting">
        <xsd:enumeration value="InventoryReportReferenceNumber">
        <xsd:enumeration value="InvestigatorialNewDrugNumber">
        <xsd:enumeration value="InvestmentReferenceNumber">
        <xsd:enumeration value="Investor">
        <xsd:enumeration value="InvestorAssignedIdentificationNumber">
        <xsd:enumeration value="InvestorLoanNumber">
        <xsd:enumeration value="InvestorNoteHolderIdentification">
        <xsd:enumeration value="InvoiceIdentification">
        <xsd:enumeration value="InvoiceNumber">
        <xsd:enumeration value="InvoiceNumberSuffix">
        <xsd:enumeration value="InvoicingDataSheetReferenceNumber">
        <xsd:enumeration value="IronChargeNumber">
        <xsd:enumeration value="ISFMD">
        <xsd:enumeration value="IssueNumber">
        <xsd:enumeration value="IssuerNumber">
        <xsd:enumeration value="IssuingBanksReference">
        <xsd:enumeration value="ItemNumber">
        <xsd:enumeration value="JobOrProjectNumber">
        <xsd:enumeration value="JobOrderNumber">
        <xsd:enumeration value="JobSequenceNumber">
        <xsd:enumeration value="JointCreditSpecificationNumber">
        <xsd:enumeration value="JointlyAdministeredCase">
        <xsd:enumeration value="JointVentureReferenceNumber">
        <xsd:enumeration value="Judge">
        <xsd:enumeration value="JudgmentNumber">
        <xsd:enumeration value="JudicialDistrict">
        <xsd:enumeration value="JudicialNumber">
        <xsd:enumeration value="JurisdictionalCommunityNameIdentifier">
        <xsd:enumeration value="JurisdictionalCommunityNumber">
        <xsd:enumeration value="LaboratoryNumber">
        <xsd:enumeration value="LaboratoryRegistrationNumber">
        <xsd:enumeration value="LaborOperationNumber">
        <xsd:enumeration value="LabororAffiliationIdentification">
        <xsd:enumeration value="LaneNumber">
        <xsd:enumeration value="LastTransferNumber">
        <xsd:enumeration value="LatitudeExpressedinDegreesMinutesandSeconds">
        <xsd:enumeration value="LatitudeExpressedinSeconds">
        <xsd:enumeration value="LeadCase">
        <xsd:enumeration value="LeaseAgreementAmendmentNumberMaster">
        <xsd:enumeration value="LeaseContractReference">
        <xsd:enumeration value="LeaseNumber">
        <xsd:enumeration value="LeaseRiderNumber">
        <xsd:enumeration value="LeaseScheduleNumber">
        <xsd:enumeration value="LeaseScheduleNumberBlanket">
        <xsd:enumeration value="LeaseScheduleNumberPrior">
        <xsd:enumeration value="LeaseScheduleNumberReplacement">
        <xsd:enumeration value="LenderAccountNumber">
        <xsd:enumeration value="LenderCaseNumber">
        <xsd:enumeration value="LenderEntityNumber">
        <xsd:enumeration value="LenderUse">
        <xsd:enumeration value="LesseeBillCodeNumber">
        <xsd:enumeration value="LesseeIdentification">
        <xsd:enumeration value="LetterofCreditDraftNumber">
        <xsd:enumeration value="LetterOfCreditNumber">
        <xsd:enumeration value="LettersorNotes">
        <xsd:enumeration value="LevyingOfficerIdentification">
        <xsd:enumeration value="LicensePlateNumber">
        <xsd:enumeration value="LifeInsuranceBillingAccountNumber">
        <xsd:enumeration value="LifeInsuranceBillingSuffixCode">
        <xsd:enumeration value="LifeInsurancePolicyNumber">
        <xsd:enumeration value="LimitedPartnershipIdentificationNumber">
        <xsd:enumeration value="LineItemControlNumber">
        <xsd:enumeration value="LineItemIdentifier">
        <xsd:enumeration value="LineItemReferenceNumber">
        <xsd:enumeration value="LineofBusiness">
        <xsd:enumeration value="LineOfCreditCategory">
        <xsd:enumeration value="LinkSequenceNumber">
        <xsd:enumeration value="ListBillNumber">
        <xsd:enumeration value="ListOfMaterials">
        <xsd:enumeration value="LloydsClaimsOfficeReference">
        <xsd:enumeration value="LoadingAuthorizationNumber">
        <xsd:enumeration value="LoadLineCertificate">
        <xsd:enumeration value="LoadPlanningNumber">
        <xsd:enumeration value="LoanAcquisitionNumber">
        <xsd:enumeration value="LoanFeatureCode">
        <xsd:enumeration value="LoanNumber">
        <xsd:enumeration value="LoanProspectorKeyNumber">
        <xsd:enumeration value="LoanRequestNumber">
        <xsd:enumeration value="LoanType">
        <xsd:enumeration value="LocalJurisdiction">
        <xsd:enumeration value="LocallyAssignedControlNumber">
        <xsd:enumeration value="LocalMediaIdentifier">
        <xsd:enumeration value="LocalSchoolCourseNumber">
        <xsd:enumeration value="LocalSchoolDistrictCourseNumber">
        <xsd:enumeration value="LocalStudentIdentificationNumber">
        <xsd:enumeration value="LocationExceptionOrderNumber">
        <xsd:enumeration value="LocationNumber">
        <xsd:enumeration value="LocationonProductCode">
        <xsd:enumeration value="LocationSpecificServicesReferenceNumber">
        <xsd:enumeration value="LocationWithinEquipment">
        <xsd:enumeration value="Lockbox">
        <xsd:enumeration value="Log">
        <xsd:enumeration value="LogicalObservationIdentifierNamesandCodes">
        <xsd:enumeration value="LogisticsSupportDocumentationTypeCode">
        <xsd:enumeration value="LongitudeExpressedInDegreesMinutesandSeconds">
        <xsd:enumeration value="LongitudeExpressedinSeconds">
        <xsd:enumeration value="LongTermDisabilityPolicyNumber">
        <xsd:enumeration value="LossOrEventNumber">
        <xsd:enumeration value="LossReportNumber">
        <xsd:enumeration value="LotNumber">
        <xsd:enumeration value="LowerArticleNumberOfRange">
        <xsd:enumeration value="MagazineCode">
        <xsd:enumeration value="Mailbox">
        <xsd:enumeration value="MailingReferenceNumber">
        <xsd:enumeration value="MailSlot">
        <xsd:enumeration value="MaintenanceAvailabilityType">
        <xsd:enumeration value="MaintenanceRequestNumber">
        <xsd:enumeration value="MajorForceProgramNumber">
        <xsd:enumeration value="MajorSystemAffectedCode">
        <xsd:enumeration value="MakegoodCommercialLineNumber">
        <xsd:enumeration value="MammographyCertificationNumber">
        <xsd:enumeration value="ManagedCareOrganizationCode">
        <xsd:enumeration value="ManagedCareOrganizationIdentificationNumber">
        <xsd:enumeration value="ManifestKeyNumber">
        <xsd:enumeration value="ManualProcessingAuthorityNumber">
        <xsd:enumeration value="ManufacturerDefinedRepairRatesReference">
        <xsd:enumeration value="ManufacturerNumber">
        <xsd:enumeration value="ManufacturersMaterialSafetyDataSheetNumber">
        <xsd:enumeration value="ManufacturersPartNumber">
        <xsd:enumeration value="ManufacturingDirectiveNumber">
        <xsd:enumeration value="ManufacturingOperationNumber">
        <xsd:enumeration value="ManufacturingOrderNumber">
        <xsd:enumeration value="MapNumber">
        <xsd:enumeration value="MapReference">
        <xsd:enumeration value="MaritimeDeclarationofHealth">
        <xsd:enumeration value="MarketArea">
        <xsd:enumeration value="MarkingOrLabelReference">
        <xsd:enumeration value="MasterAccountNumber">
        <xsd:enumeration value="MasterAirWaybillNumber">
        <xsd:enumeration value="MasterBillOfLadingNumber">
        <xsd:enumeration value="MasterContract">
        <xsd:enumeration value="MasterLabelNumber">
        <xsd:enumeration value="MasterLeaseAgreementNumber">
        <xsd:enumeration value="MasterPolicyNumber">
        <xsd:enumeration value="MasterPropertyNumber">
        <xsd:enumeration value="MasterReferenceNumber">
        <xsd:enumeration value="MasterSolicitationProceduresTermsAndConditionsNumber">
        <xsd:enumeration value="MaterialChangeNoticeNumber">
        <xsd:enumeration value="MaterialStorageLocation">
        <xsd:enumeration value="MaturedCertificateOfDeposit">
        <xsd:enumeration value="MeatProcessingEstablishmentRegistrationNumber">
        <xsd:enumeration value="MedicaidProviderNumber">
        <xsd:enumeration value="MedicaidRecipientIdentificationNumber">
        <xsd:enumeration value="MedicalAssistanceCategory">
        <xsd:enumeration value="MedicalRecordIdentificationNumber">
        <xsd:enumeration value="MedicareProviderNumber">
        <xsd:enumeration value="MedicareVersionCode">
        <xsd:enumeration value="MemberIdentificationNumber">
        <xsd:enumeration value="MemberNumber">
        <xsd:enumeration value="MerchandiseTypeCode">
        <xsd:enumeration value="MerchantCategoryCode">
        <xsd:enumeration value="MessageAddressorID">
        <xsd:enumeration value="MessageBatchNumber">
        <xsd:enumeration value="MessageDesignGroupNumber">
        <xsd:enumeration value="MessageRecipient">
        <xsd:enumeration value="MessageSender">
        <xsd:enumeration value="MeterNumber">
        <xsd:enumeration value="MeterProvingReportNumber">
        <xsd:enumeration value="MeterReadingAtTheBeginningOfTheDelivery">
        <xsd:enumeration value="MeterReadingAtTheEndOfDelivery">
        <xsd:enumeration value="MeterTicketNumber">
        <xsd:enumeration value="MeterUnitNumber">
        <xsd:enumeration value="MICRNumber">
        <xsd:enumeration value="MicrofilmNumber">
        <xsd:enumeration value="MigrantNumber">
        <xsd:enumeration value="Milestone">
        <xsd:enumeration value="MilitaryCallNumber">
        <xsd:enumeration value="MilitaryID">
        <xsd:enumeration value="MilitaryInterdepartmentalPurchaseRequestNumber">
        <xsd:enumeration value="MilitaryOrdnanceSecurityRiskNumber">
        <xsd:enumeration value="MilitaryRankOrCivilianPayGradeNumber">
        <xsd:enumeration value="MilitarySpecificationNumber">
        <xsd:enumeration value="MilitaryStandardNumber">
        <xsd:enumeration value="MillinginTransit">
        <xsd:enumeration value="MillOrderNumber">
        <xsd:enumeration value="MinimumRoyaltyPayorIdentification">
        <xsd:enumeration value="MinisterialCertificateOfHomologation">
        <xsd:enumeration value="Model">
        <xsd:enumeration value="ModelNumber">
        <xsd:enumeration value="Modelyearnumber">
        <xsd:enumeration value="MORNETPlusCaseNumber">
        <xsd:enumeration value="MORNETPlusInstitutionNumber">
        <xsd:enumeration value="MORNETPlusUserIdentification">
        <xsd:enumeration value="MortgageBackedSecurityLoanNumber">
        <xsd:enumeration value="MortgageBackedSecurityPoolNumber">
        <xsd:enumeration value="MortgageElectronicRegistrationSystemOrganizationIdentifier">
        <xsd:enumeration value="MortgageeLoanNumber">
        <xsd:enumeration value="MortgageIdentificationNumber">
        <xsd:enumeration value="MortgageInsuranceCompanyNumber">
        <xsd:enumeration value="MortgageInsuranceIndicatorNumber">
        <xsd:enumeration value="MortgageNumber">
        <xsd:enumeration value="MotorCarrierIdentificationNumber">
        <xsd:enumeration value="MotorFuelCertificateNumber">
        <xsd:enumeration value="MotorVehicleIDNumber">
        <xsd:enumeration value="MultifamilyProjectNumber">
        <xsd:enumeration value="MultipleListingNumber">
        <xsd:enumeration value="MultipleListingServiceArea">
        <xsd:enumeration value="MultipleListingServiceBookType">
        <xsd:enumeration value="MultipleListingServiceMapXCoordinate">
        <xsd:enumeration value="MultipleListingServiceMapYCoordinate">
        <xsd:enumeration value="MultipleListingServiceSubArea">
        <xsd:enumeration value="MultiplePOOfAnInvoice">
        <xsd:enumeration value="MultipleZoneOrderNumber">
        <xsd:enumeration value="MunicipalityAssignedBusinessRegistryNumber">
        <xsd:enumeration value="NACE">
        <xsd:enumeration value="NAF">
        <xsd:enumeration value="NamedBanksReference">
        <xsd:enumeration value="NationalAeronauticsandSpaceAdministrationFARSupplement">
        <xsd:enumeration value="NationalAssociationOfBoardsOfPharmacyNumber">
        <xsd:enumeration value="NationalAssociationOfInsuranceCommissionersCode">
        <xsd:enumeration value="NationalBusinessIdentificationNumber">
        <xsd:enumeration value="NationalCriminalInformationCenterOriginatingAgencyIdentification">
        <xsd:enumeration value="NationalFloodInsuranceProgramCommunityName">
        <xsd:enumeration value="NationalFloodInsuranceProgramCommunityNumber">
        <xsd:enumeration value="NationalFloodInsuranceProgramCounty">
        <xsd:enumeration value="NationalFloodInsuranceProgramMapNumber">
        <xsd:enumeration value="NationalFloodInsuranceProgramState">
        <xsd:enumeration value="NationalGovernmentBusinessIdentificationNumber">
        <xsd:enumeration value="NationalPropertyRegistrySystemLevel1">
        <xsd:enumeration value="NationalPropertyRegistrySystemLevel2">
        <xsd:enumeration value="NationalPropertyRegistrySystemLevel3">
        <xsd:enumeration value="NationalStockNumber">
        <xsd:enumeration value="NaturalGasPolicyActCategoryCode">
        <xsd:enumeration value="NewDrugApplicationNumber">
        <xsd:enumeration value="NewHealthInsuranceClaimNumber">
        <xsd:enumeration value="NewPartNumber">
        <xsd:enumeration value="NextRentalAgreementNumber">
        <xsd:enumeration value="NextRentalAgreementReasonNumber">
        <xsd:enumeration value="NextShipmentIdentificationNumberContinuousMove">
        <xsd:enumeration value="NIT">
        <xsd:enumeration value="NominationNumber">
        <xsd:enumeration value="NonAmericanIdentificationNumber">
        <xsd:enumeration value="NonConformanceReportNumber">
        <xsd:enumeration value="NonNegotiableMaritimeTransportDocumentNumber">
        <xsd:enumeration value="NonOriginatingThirdPartyNumber">
        <xsd:enumeration value="NonPickupLimitedTariffNumber">
        <xsd:enumeration value="NonProvisionalPatentApplicationNumber">
        <xsd:enumeration value="NonSpouseTie">
        <xsd:enumeration value="NoOT5AuthorityZeroMileageRate">
        <xsd:enumeration value="NorthAmericanDatumStandard">
        <xsd:enumeration value="NorthAmericanFreeTradeAgreementComplianceNumber">
        <xsd:enumeration value="NorthAmericanHazardousClassificationNumber">
        <xsd:enumeration value="NorthAmericanHazardousGoodsClassificationNumber">
        <xsd:enumeration value="NorthAmericanIndustrialClassificationSystemCode">
        <xsd:enumeration value="NOTICOL">
        <xsd:enumeration value="NumberOfTemporaryImportationDocument">
        <xsd:enumeration value="NumerodeCeduladeIdentidadNumber">
        <xsd:enumeration value="NumerodeIdentificacionTributaria">
        <xsd:enumeration value="ObjectIdentifier">
        <xsd:enumeration value="OccupationalSafetyandHealthAdministrationClaimNumber">
        <xsd:enumeration value="OccupationClassificationCode">
        <xsd:enumeration value="OccupationCode">
        <xsd:enumeration value="OceanBillofLading">
        <xsd:enumeration value="OceanContainerNumber">
        <xsd:enumeration value="OceanManifest">
        <xsd:enumeration value="OffenderTracking">
        <xsd:enumeration value="OffenseTracking">
        <xsd:enumeration value="OfferGroup">
        <xsd:enumeration value="OfferNumber">
        <xsd:enumeration value="OfficeNumber">
        <xsd:enumeration value="OfficerLicenseNumber">
        <xsd:enumeration value="OfficeSymbol">
        <xsd:enumeration value="OldAccountNumber">
        <xsd:enumeration value="OldMeterNumber">
        <xsd:enumeration value="OldPartNumber">
        <xsd:enumeration value="OneCallAgencyTicketNumber">
        <xsd:enumeration value="OnlineProcurementandAccountingControlTransaction">
        <xsd:enumeration value="OpenandPrepaidStationListNumber">
        <xsd:enumeration value="OperationNumber">
        <xsd:enumeration value="OperatorAssignedUnitNumber">
        <xsd:enumeration value="OperatorIdentificationNumber">
        <xsd:enumeration value="OperatorLeaseNumber">
        <xsd:enumeration value="OptionPolicyNumber">
        <xsd:enumeration value="OrderOrParagraphNumber">
        <xsd:enumeration value="OrderingCustomerConsignmentReferenceNumber">
        <xsd:enumeration value="OrderingCustomersSecondReferenceNumber">
        <xsd:enumeration value="OrderNumber">
        <xsd:enumeration value="PurchaseOrderNumber">
        <xsd:enumeration value="VendorOrderNumber">
        <xsd:enumeration value="OrganizationBreakdownStructure">
        <xsd:enumeration value="OriginalCertificateNumber">
        <xsd:enumeration value="OriginalFdoTransactionReference">
        <xsd:enumeration value="OriginalFiling">
        <xsd:enumeration value="OriginalFilingNumber">
        <xsd:enumeration value="OriginalInvoiceNumber">
        <xsd:enumeration value="OriginalPurchaseOrder">
        <xsd:enumeration value="OriginalReferenceNumber">
        <xsd:enumeration value="OriginalReturnRequestReferenceNumber">
        <xsd:enumeration value="OriginalShippersBillOfLadingNumber">
        <xsd:enumeration value="OriginalSubmitterChildDataMaintenanceRequestLog">
        <xsd:enumeration value="OriginalSubmitterLogNumber">
        <xsd:enumeration value="OriginalSubmitterParentDataMaintenanceRequest">
        <xsd:enumeration value="OriginalUniformCommercialCodeFilingNumber">
        <xsd:enumeration value="OriginalVoucherNumber">
        <xsd:enumeration value="OriginatingCase">
        <xsd:enumeration value="OriginatingCompanyIdentifier">
        <xsd:enumeration value="OriginatingDepositoryFinancialInstitutionIdentifier">
        <xsd:enumeration value="OriginatorsReference">
        <xsd:enumeration value="OriginHouse">
        <xsd:enumeration value="OriginOfShipmentHarmonizedBasedCode">
        <xsd:enumeration value="OT5AuthorityConditionOrRestrictiononCarHireRate">
        <xsd:enumeration value="OtherUnlistedTypeOfReferenceNumber">
        <xsd:enumeration value="OutboundFromParty">
        <xsd:enumeration value="OuterContinentalShelfAreaCode">
        <xsd:enumeration value="OuterContinentalShelfBlockNumber">
        <xsd:enumeration value="OuterpackagingUnitIdentification">
        <xsd:enumeration value="OutletNumber">
        <xsd:enumeration value="OutofServiceNumber">
        <xsd:enumeration value="OwningBureauIdentificationNumber">
        <xsd:enumeration value="PackAndHoldInvoiceNumber">
        <xsd:enumeration value="PackageNumber">
        <xsd:enumeration value="PackagingGroupNumber">
        <xsd:enumeration value="PackagingSpecificationNumber">
        <xsd:enumeration value="PackagingUnitIdentification">
        <xsd:enumeration value="PackerNumber">
        <xsd:enumeration value="Packet">
        <xsd:enumeration value="PackingGroupCode">
        <xsd:enumeration value="PackingListNumber">
        <xsd:enumeration value="PackingPlantNumber">
        <xsd:enumeration value="PageNumber">
        <xsd:enumeration value="Paragraph">
        <xsd:enumeration value="ParagraphNumber">
        <xsd:enumeration value="ParamedicalIDNumber">
        <xsd:enumeration value="ParentFile">
        <xsd:enumeration value="PartCausingRepairNumber">
        <xsd:enumeration value="PartConsignmentNumber">
        <xsd:enumeration value="PartialPaymentNumber">
        <xsd:enumeration value="ParticipatingArea">
        <xsd:enumeration value="PartInterchangeability">
        <xsd:enumeration value="PartNumber">
        <xsd:enumeration value="PartReferenceIndicatorInADrawing">
        <xsd:enumeration value="PartyInformationMessageReference">
        <xsd:enumeration value="PartySequenceNumber">
        <xsd:enumeration value="Passport">
        <xsd:enumeration value="PassportNumber">
        <xsd:enumeration value="PatentCooperationTreatyApplicationNumber">
        <xsd:enumeration value="PatentNumber">
        <xsd:enumeration value="PatentType">
        <xsd:enumeration value="PatientAccountNumber">
        <xsd:enumeration value="PatronNumber">
        <xsd:enumeration value="PayeeIdentification">
        <xsd:enumeration value="PayeeLoanNumber">
        <xsd:enumeration value="PayeesFinancialInstitutionAccountNumber">
        <xsd:enumeration value="PayeesFinancialInstitutionTransitRoutingNo">
        <xsd:enumeration value="PayeesReferenceNumber">
        <xsd:enumeration value="PayerAssignedResubmissionReferenceNumber">
        <xsd:enumeration value="PayerCategory">
        <xsd:enumeration value="PayerIdentificationNumber">
        <xsd:enumeration value="PayersFinancialInstitutionAccountNumber">
        <xsd:enumeration value="PayersFinancialInstitutionTransitRoutingNo">
        <xsd:enumeration value="PayersReferenceNumber">
        <xsd:enumeration value="PayGrade">
        <xsd:enumeration value="PaymentCategory">
        <xsd:enumeration value="PaymentHistoryReferenceNumber">
        <xsd:enumeration value="PaymentInAdvanceRequestReference">
        <xsd:enumeration value="PaymentInstalmentReferenceNumber">
        <xsd:enumeration value="PaymentLocation">
        <xsd:enumeration value="PaymentOrderNumber">
        <xsd:enumeration value="PaymentPlanReference">
        <xsd:enumeration value="PaymentReference">
        <xsd:enumeration value="PaymentValuationNumber">
        <xsd:enumeration value="PayorsClaimNumber">
        <xsd:enumeration value="PayrollAccountNumber">
        <xsd:enumeration value="PayrollNumber">
        <xsd:enumeration value="PcsCatastrophe">
        <xsd:enumeration value="PeerReviewOrganizationApprovalNumber">
        <xsd:enumeration value="PendingCase">
        <xsd:enumeration value="PensionContract">
        <xsd:enumeration value="PeriodicityCode">
        <xsd:enumeration value="PermitNumber">
        <xsd:enumeration value="PersonalIdentificationNumber">
        <xsd:enumeration value="PersonalIdentityCardNumber">
        <xsd:enumeration value="PersonalIDNumber">
        <xsd:enumeration value="PetroleumPoolCode">
        <xsd:enumeration value="PharmacyPrescriptionNumber">
        <xsd:enumeration value="PhoneCalls">
        <xsd:enumeration value="PhysicalInventoryRecountReferenceNumber">
        <xsd:enumeration value="PickupReferenceNumber">
        <xsd:enumeration value="PictureNumber">
        <xsd:enumeration value="PictureOfActualProduct">
        <xsd:enumeration value="PictureOfAGenericProduct">
        <xsd:enumeration value="PierNumber">
        <xsd:enumeration value="Piggyback">
        <xsd:enumeration value="PilotLicenseNumber">
        <xsd:enumeration value="PipelineNumber">
        <xsd:enumeration value="PlanNetworkIdentificationNumber">
        <xsd:enumeration value="PlanningPackage">
        <xsd:enumeration value="PlanNumber">
        <xsd:enumeration value="PlantNumber">
        <xsd:enumeration value="PlateNumber">
        <xsd:enumeration value="PlatformIdentificationNumber">
        <xsd:enumeration value="PlotFile">
        <xsd:enumeration value="PlugNumber">
        <xsd:enumeration value="PolicyFormNumber">
        <xsd:enumeration value="PolicyLinkNumber">
        <xsd:enumeration value="PolicyNumber">
        <xsd:enumeration value="PolicyType">
        <xsd:enumeration value="Pollutant">
        <xsd:enumeration value="PoolContractCode">
        <xsd:enumeration value="PoolNumber">
        <xsd:enumeration value="PoolSuffix">
        <xsd:enumeration value="PositionCode">
        <xsd:enumeration value="PostEntryReference">
        <xsd:enumeration value="PreAwardSurvey">
        <xsd:enumeration value="PrecinctNumber">
        <xsd:enumeration value="PredecessorAccount">
        <xsd:enumeration value="PredeterminationofBenefitsIdentificationNumber">
        <xsd:enumeration value="PreferredCallSign">
        <xsd:enumeration value="PreferredProviderOrganizationAuthorizationNumber">
        <xsd:enumeration value="PreferredProviderOrganizationNumber">
        <xsd:enumeration value="PreferredProviderOrganizationSiteNumber">
        <xsd:enumeration value="PreliminaryWorkCandidateNumber">
        <xsd:enumeration value="PremarketApplicationNumber">
        <xsd:enumeration value="PremarketNotificationNumber">
        <xsd:enumeration value="PremiumAuditPriorityIdentifier">
        <xsd:enumeration value="PremiumAuditPurposeIdentifier">
        <xsd:enumeration value="PremiumAuditTypeIdentifier">
        <xsd:enumeration value="PremiumRateTable">
        <xsd:enumeration value="PreparersVerificationNumber">
        <xsd:enumeration value="PresentingBanksReference">
        <xsd:enumeration value="PressFormIdentifier">
        <xsd:enumeration value="PressIdentifier">
        <xsd:enumeration value="PreviousBillofLadingNumber">
        <xsd:enumeration value="PreviousCargoControlNumber">
        <xsd:enumeration value="PreviousClaimHistoryIdentifier">
        <xsd:enumeration value="PreviousContractNumber">
        <xsd:enumeration value="PreviousCourseNumber">
        <xsd:enumeration value="PreviousCreditOrDebitAdjustmentNumber">
        <xsd:enumeration value="PreviousCreditAdviceReferenceNumber">
        <xsd:enumeration value="PreviousCustomerReferenceNumber">
        <xsd:enumeration value="PreviousDeliveryInstructionNumber">
        <xsd:enumeration value="PreviousDeliveryScheduleNumber">
        <xsd:enumeration value="PreviousDistributorNumber">
        <xsd:enumeration value="PreviousDriversLicense">
        <xsd:enumeration value="PreviousDrugEnforcementAdministrationNumber">
        <xsd:enumeration value="PreviousHighestScheduleNumber">
        <xsd:enumeration value="PreviousInvoiceNumber">
        <xsd:enumeration value="PreviouslyReportedSocialSecurityNumber">
        <xsd:enumeration value="PreviousMemberNumber">
        <xsd:enumeration value="PreviousPolicyNumber">
        <xsd:enumeration value="PreviousRentalAgreementNumber">
        <xsd:enumeration value="PreviousReportNumber">
        <xsd:enumeration value="PreviousRequestForMeteredReadingReferenceNumber">
        <xsd:enumeration value="PreviousSchemeOrPlanNumber">
        <xsd:enumeration value="PreviousSequence">
        <xsd:enumeration value="PreviousShipmentIdentificationNumberContinuousMove">
        <xsd:enumeration value="PreviousTaxControlNumber">
        <xsd:enumeration value="PreviousTicketNumber">
        <xsd:enumeration value="PriceOrSalesCatalogueResponseReferenceNumber">
        <xsd:enumeration value="PriceAreaNumber">
        <xsd:enumeration value="PriceListChangeorIssueNumber">
        <xsd:enumeration value="PriceListNumber">
        <xsd:enumeration value="PriceListVersionNumber">
        <xsd:enumeration value="PriceQuoteNumber">
        <xsd:enumeration value="PriceVariationFormulaReferenceNumber">
        <xsd:enumeration value="PrimaryReference">
        <xsd:enumeration value="PrimeContractorContractNumber">
        <xsd:enumeration value="PrincipalReferenceNumber">
        <xsd:enumeration value="PrincipalsBankReference">
        <xsd:enumeration value="PrincipalsReference">
        <xsd:enumeration value="PriorAuthorizationNumber">
        <xsd:enumeration value="PriorCase">
        <xsd:enumeration value="PriorCertificateNumber">
        <xsd:enumeration value="PriorContractNumber">
        <xsd:enumeration value="PriorDataUniversalNumberSystemNumber">
        <xsd:enumeration value="PriorHealthIndustryNumber">
        <xsd:enumeration value="PriorIdentifierNumber">
        <xsd:enumeration value="PriorIncorrectBatchNumber">
        <xsd:enumeration value="PriorIncorrectSocialSecurityNumber">
        <xsd:enumeration value="PriorityRating">
        <xsd:enumeration value="PriorLoanNumber">
        <xsd:enumeration value="PriorPhoneNumber">
        <xsd:enumeration value="PriorPolicyNumber">
        <xsd:enumeration value="PriorPostalZipCode">
        <xsd:enumeration value="PriorPurchaseOrderNumber">
        <xsd:enumeration value="PriorTaxIdentificationNumber">
        <xsd:enumeration value="PriorTradingPartnerIdentificationNumber">
        <xsd:enumeration value="PriorUniversalProviderIdentificationNumber">
        <xsd:enumeration value="Proceeding">
        <xsd:enumeration value="ProcessHandlingCode">
        <xsd:enumeration value="ProcessingArea">
        <xsd:enumeration value="ProcessingPlantNumber">
        <xsd:enumeration value="ProcessorIdentificationNumber">
        <xsd:enumeration value="ProcessorsInvoiceNumber">
        <xsd:enumeration value="ProcurementBudgetNumber">
        <xsd:enumeration value="ProcurementRequestNumber">
        <xsd:enumeration value="ProcuringAgency">
        <xsd:enumeration value="ProductChangeAuthorityNumber">
        <xsd:enumeration value="ProductChangeInformationNumber">
        <xsd:enumeration value="ProductChangeNoticeNumber">
        <xsd:enumeration value="ProductGroup">
        <xsd:enumeration value="ProductionCode">
        <xsd:enumeration value="ProductLicensingAgreementNumber">
        <xsd:enumeration value="ProductLineNumber">
        <xsd:enumeration value="ProductNumber">
        <xsd:enumeration value="ProductPeriodForWhichLaborCostsAreFirm">
        <xsd:enumeration value="ProductReservationNumber">
        <xsd:enumeration value="ProductSourcingAgreementNumber">
        <xsd:enumeration value="ProductSpecificationDocumentNumber">
        <xsd:enumeration value="ProductType">
        <xsd:enumeration value="ProfileNumber">
        <xsd:enumeration value="ProformaInvoiceNumber">
        <xsd:enumeration value="ProgramIdentificationNumber">
        <xsd:enumeration value="ProgressPaymentNumber">
        <xsd:enumeration value="ProjectCode">
        <xsd:enumeration value="ProjectNumber">
        <xsd:enumeration value="ProjectParagraphNumber">
        <xsd:enumeration value="ProjectPropertyNumber">
        <xsd:enumeration value="ProjectSpecificationNumber">
        <xsd:enumeration value="PromotionOrDealNumber">
        <xsd:enumeration value="ProofOfDeliveryReferenceNumber">
        <xsd:enumeration value="PropertyComponentLocation">
        <xsd:enumeration value="PropertyControlNumber">
        <xsd:enumeration value="PropertyLossItemNumber">
        <xsd:enumeration value="ProposalNumber">
        <xsd:enumeration value="ProposalParagraphNumber">
        <xsd:enumeration value="ProposedContractNumber">
        <xsd:enumeration value="ProposedGroupWorkCandidateSequenceNumber">
        <xsd:enumeration value="ProposedSequenceNumber">
        <xsd:enumeration value="ProposedWorkCandidateSequenceNumber">
        <xsd:enumeration value="ProtocolNumber">
        <xsd:enumeration value="ProtractionNumber">
        <xsd:enumeration value="ProviderClaimNumber">
        <xsd:enumeration value="ProviderCommercialNumber">
        <xsd:enumeration value="ProviderControlNumber">
        <xsd:enumeration value="ProviderOrderTicketNumber">
        <xsd:enumeration value="ProviderPlanNetworkIdentificationNumber">
        <xsd:enumeration value="ProviderSiteNumber">
        <xsd:enumeration value="ProviderUPINNumber">
        <xsd:enumeration value="ProvincialCanadianSalesTaxExemptionNumber">
        <xsd:enumeration value="ProvincialTaxIdentification">
        <xsd:enumeration value="ProvisionalPatentApplicationNumber">
        <xsd:enumeration value="PublicationIssueNumber">
        <xsd:enumeration value="PublicDeedNumber">
        <xsd:enumeration value="PublicFilingRegistrationNumber">
        <xsd:enumeration value="PublicUtilitiesCommissionCertificateOfPublicConvenience">
        <xsd:enumeration value="PurchaseDescription">
        <xsd:enumeration value="PurchaseOptionAgreement">
        <xsd:enumeration value="PurchaseOrderChangeNumber">
        <xsd:enumeration value="PurchaseOrderLineItemIdentifierBuyer">
        <xsd:enumeration value="PurchaseOrderNumberIncludedinOnOrderPosition">
        <xsd:enumeration value="PurchaseOrderNumberOfOrderReceivedSinceLastReportingDate">
        <xsd:enumeration value="PurchaseOrderNumberOfShipmentReceivedSinceLastReportingDate">
        <xsd:enumeration value="PurchaseOrderNumberSuffix">
        <xsd:enumeration value="PurchaseOrderResponseNumber">
        <xsd:enumeration value="PurchaseOrderRevisionNumber">
        <xsd:enumeration value="PurchaseRequisitionNumber">
        <xsd:enumeration value="PurchasersRequestReference">
        <xsd:enumeration value="PurchasingActivityClauseNumber">
        <xsd:enumeration value="QualifiedMaterialsList">
        <xsd:enumeration value="QualifiedProductsList">
        <xsd:enumeration value="QualityClause">
        <xsd:enumeration value="QualityDispositionAreaIdentifier">
        <xsd:enumeration value="QualityInspectionAreaIdentifier">
        <xsd:enumeration value="QualityReportNumber">
        <xsd:enumeration value="QualityReviewMaterialCribIdentifier">
        <xsd:enumeration value="QuantityValuationNumber">
        <xsd:enumeration value="QuantityValuationRequestNumber">
        <xsd:enumeration value="QuarantineOrTreatmentStatusReferenceNumber">
        <xsd:enumeration value="QuarterQuarterSectionNumber">
        <xsd:enumeration value="QuarterQuarterSpotNumber">
        <xsd:enumeration value="QuestionNumber">
        <xsd:enumeration value="QuotaNumber">
        <xsd:enumeration value="QuoteOrShoppingCartID">
        <xsd:enumeration value="RackTypeNumber">
        <xsd:enumeration value="RailOrRoadRoutingCode">
        <xsd:enumeration value="RailroadCommissionOilNumber">
        <xsd:enumeration value="RailroadCommissionRecordNumber">
        <xsd:enumeration value="RailRoutingCode">
        <xsd:enumeration value="RailWayBillNumber">
        <xsd:enumeration value="RailwayConsignmentNoteNumber">
        <xsd:enumeration value="RailwayWagonNumber">
        <xsd:enumeration value="RangeNumber">
        <xsd:enumeration value="RateCardNumber">
        <xsd:enumeration value="RateCodeNumber">
        <xsd:enumeration value="RateConferenceIDCode">
        <xsd:enumeration value="RateNoteNumber">
        <xsd:enumeration value="RatingPeriod">
        <xsd:enumeration value="RawmaterialSupplierDunAndBradstreetNumber">
        <xsd:enumeration value="RealEstateOwnedPropertyIdentifier">
        <xsd:enumeration value="ReasonForChange">
        <xsd:enumeration value="ReasonNotLowestCostCode">
        <xsd:enumeration value="RebateNumber">
        <xsd:enumeration value="RecallNumber">
        <xsd:enumeration value="ReceiptNumber">
        <xsd:enumeration value="ReceivedNumber">
        <xsd:enumeration value="ReceiverAssignedDropZone">
        <xsd:enumeration value="ReceiverClaimNumber">
        <xsd:enumeration value="ReceiverIdentificationNumber">
        <xsd:enumeration value="ReceiverIDQualifier">
        <xsd:enumeration value="ReceiversFileReferenceNumber">
        <xsd:enumeration value="ReceiverSubIdentificationNumber">
        <xsd:enumeration value="ReceivingAdviceNumber">
        <xsd:enumeration value="ReceivingBanksAuthorizationNumber">
        <xsd:enumeration value="ReceivingCompanyIdentifier">
        <xsd:enumeration value="ReceivingDepositoryFinancialInstitutionIdentifier">
        <xsd:enumeration value="ReceivingNumber">
        <xsd:enumeration value="ReceivingPartysMemberIdentification">
        <xsd:enumeration value="ReconciliationReportSectionIdentificationCode">
        <xsd:enumeration value="RecordingNumber">
        <xsd:enumeration value="ReducedEarningWeekIdentifier">
        <xsd:enumeration value="ReelNumber">
        <xsd:enumeration value="ReferencedBy">
        <xsd:enumeration value="ReferencedPatternIdentification">
        <xsd:enumeration value="ReferenceDrawingNumber">
        <xsd:enumeration value="ReferenceNumberAssignedByThirdParty">
        <xsd:enumeration value="ReferenceNumberOfARequestForMeteredReading">
        <xsd:enumeration value="ReferenceNumberQuotedOnStatement">
        <xsd:enumeration value="ReferenceNumberToPreviousMessage">
        <xsd:enumeration value="ReferenceVersionNumber">
        <xsd:enumeration value="ReferralNumber">
        <xsd:enumeration value="ReferredProductForChemicalAnalysis">
        <xsd:enumeration value="ReferredProductForMechanicalAnalysis">
        <xsd:enumeration value="RefinerIdentification">
        <xsd:enumeration value="Region">
        <xsd:enumeration value="RegionalAccountNumber">
        <xsd:enumeration value="RegiristoFederalDeContribuyentes">
        <xsd:enumeration value="RegisteredCapitalReference">
        <xsd:enumeration value="RegisteredContractorActivityType">
        <xsd:enumeration value="RegisteredMailNumber">
        <xsd:enumeration value="RegistrationNumber">
        <xsd:enumeration value="RegistrationNumberOfPreviousCustomsDeclaration">
        <xsd:enumeration value="RegistroInformacionFiscal">
        <xsd:enumeration value="RegistroNacionaldeContribuyente">
        <xsd:enumeration value="RegistroUnicodeContribuyente">
        <xsd:enumeration value="RegulationPrimaryNumber">
        <xsd:enumeration value="RegulationSecondaryNumber">
        <xsd:enumeration value="RegulatoryGuidelineIdentifier">
        <xsd:enumeration value="ReinsuranceReference">
        <xsd:enumeration value="ReinsurersClaimNumber">
        <xsd:enumeration value="ReissueCessionNumber">
        <xsd:enumeration value="RejectionNumber">
        <xsd:enumeration value="RelatedCase">
        <xsd:enumeration value="RelatedContractLineItemNumber">
        <xsd:enumeration value="RelatedDocumentNumber">
        <xsd:enumeration value="RelatedNonconformanceNumber">
        <xsd:enumeration value="RelatedObjectIdentificationNumber">
        <xsd:enumeration value="RelatedTransactionReferenceNumber">
        <xsd:enumeration value="RelatedVendorOrderNumber">
        <xsd:enumeration value="RelativePriority">
        <xsd:enumeration value="ReleaseInvoiceNumberForPriorBillAndHold">
        <xsd:enumeration value="ReleaseNumber">
        <xsd:enumeration value="RemittanceAdviceNumber">
        <xsd:enumeration value="RemittingBanksReference">
        <xsd:enumeration value="RemovalNumber">
        <xsd:enumeration value="RentalAccountNumber">
        <xsd:enumeration value="RentalAgreementNumber">
        <xsd:enumeration value="RentPayorIdentification">
        <xsd:enumeration value="RepairActionNumber">
        <xsd:enumeration value="RepairCategoryNumber">
        <xsd:enumeration value="RepairDataRequestNumber">
        <xsd:enumeration value="RepairEstimateNumber">
        <xsd:enumeration value="RepairOrderNumber">
        <xsd:enumeration value="RepairPartNumber">
        <xsd:enumeration value="RepeatLocation">
        <xsd:enumeration value="RepetitiveBookingNumber">
        <xsd:enumeration value="RepetitiveCargoShipmentNumber">
        <xsd:enumeration value="RepetitivePatternCode">
        <xsd:enumeration value="RepetitiveWaybillCode">
        <xsd:enumeration value="ReplacementAssemblyModelNumber">
        <xsd:enumeration value="ReplacementAssemblySerialNumber">
        <xsd:enumeration value="ReplacementClaimNumber">
        <xsd:enumeration value="ReplacementCustomerReferenceNumber">
        <xsd:enumeration value="ReplacementDrugEnforcementAdministrationNumber">
        <xsd:enumeration value="ReplacingPartNumber">
        <xsd:enumeration value="ReplenishmentPurchaseOrderNumber">
        <xsd:enumeration value="ReplenishmentPurchaseOrderRangeEndNumber">
        <xsd:enumeration value="ReplenishmentPurchaseOrderRangeStartNumber">
        <xsd:enumeration value="ReporterIdentification">
        <xsd:enumeration value="ReportingFormNumber">
        <xsd:enumeration value="ReportNumber">
        <xsd:enumeration value="Representation">
        <xsd:enumeration value="RepresentativeIdentificationNumber">
        <xsd:enumeration value="RepricedClaimReferenceNumber">
        <xsd:enumeration value="RepricedLineItemReferenceNumber">
        <xsd:enumeration value="RequestForCancellationNumber">
        <xsd:enumeration value="RequestforQuotationReference">
        <xsd:enumeration value="RequestForQuoteNumber">
        <xsd:enumeration value="RequestNumber">
        <xsd:enumeration value="ReservationNumber">
        <xsd:enumeration value="ReserveAssemblyLineFeedLocation">
        <xsd:enumeration value="ResourceScreeningReference">
        <xsd:enumeration value="ResourceUtilizationGroupNumber">
        <xsd:enumeration value="ResponsetoaRequestforQuotationReference">
        <xsd:enumeration value="RestrictedAvailabilityAuthorization">
        <xsd:enumeration value="RestrictedAvailabilityNumber">
        <xsd:enumeration value="ResubmissionNumber">
        <xsd:enumeration value="ResubmissionReasonCode">
        <xsd:enumeration value="Resubmitnumber">
        <xsd:enumeration value="RetailMerchantsCertificationNumber">
        <xsd:enumeration value="RetirementPlanAccountNumber">
        <xsd:enumeration value="RetirementPlanPolicyNumber">
        <xsd:enumeration value="ReturnableContainerReferenceNumber">
        <xsd:enumeration value="ReturnableContainerSerialNumber">
        <xsd:enumeration value="ReturnedGoodsAuthorizationNumber">
        <xsd:enumeration value="ReturnGoodsBillOfLadingNumber">
        <xsd:enumeration value="ReturnMaterialAuthorizationNumber">
        <xsd:enumeration value="ReturnsNoticeNumber">
        <xsd:enumeration value="RevenueSource">
        <xsd:enumeration value="Review">
        <xsd:enumeration value="ReviewerFileNumber">
        <xsd:enumeration value="ReviewPeriodNumber">
        <xsd:enumeration value="RevisionNumber">
        <xsd:enumeration value="RIF">
        <xsd:enumeration value="RigNumber">
        <xsd:enumeration value="RoadConsignmentNoteNumber">
        <xsd:enumeration value="RouteNumber">
        <xsd:enumeration value="RouteOrderNumberDomestic">
        <xsd:enumeration value="RouteOrderNumberEmergency">
        <xsd:enumeration value="RouteOrderNumberExport">
        <xsd:enumeration value="RoutingInstructionNumber">
        <xsd:enumeration value="RUC">
        <xsd:enumeration value="RuleSection">
        <xsd:enumeration value="RunNumber">
        <xsd:enumeration value="SafekeepingAccountNumber">
        <xsd:enumeration value="SafetyEquipmentCertificate">
        <xsd:enumeration value="SafetyofRadioCertificate">
        <xsd:enumeration value="SafetyofShipCertificate">
        <xsd:enumeration value="SalesOrTerritoryCode">
        <xsd:enumeration value="SalesAllowanceNumber">
        <xsd:enumeration value="SalesDepartmentNumber">
        <xsd:enumeration value="SalesForecastNumber">
        <xsd:enumeration value="SalesOfficeNumber">
        <xsd:enumeration value="SalesPersonNumber">
        <xsd:enumeration value="SalesProgramNumber">
        <xsd:enumeration value="SalesRegionNumber">
        <xsd:enumeration value="SalesReportNumber">
        <xsd:enumeration value="SalesRepresentativeOrderNumber">
        <xsd:enumeration value="SalesResponsibility">
        <xsd:enumeration value="SampleNumber">
        <xsd:enumeration value="Savings">
        <xsd:enumeration value="SBA">
        <xsd:enumeration value="ScaleNumber">
        <xsd:enumeration value="ScanLine">
        <xsd:enumeration value="ScheduleReferenceNumber">
        <xsd:enumeration value="SchemeOrPlanNumber">
        <xsd:enumeration value="SchoolLoanNumber">
        <xsd:enumeration value="SchoolUse">
        <xsd:enumeration value="SealNumber">
        <xsd:enumeration value="SealOffNumber">
        <xsd:enumeration value="SealOnNumber">
        <xsd:enumeration value="SearchKey">
        <xsd:enumeration value="SecondaryCoverageCertificateNumber">
        <xsd:enumeration value="SecondaryCoverageCompanyNumber">
        <xsd:enumeration value="SecondaryCustomsReference">
        <xsd:enumeration value="SecondaryEmployeeIdentificationNumber">
        <xsd:enumeration value="SecondaryHealthInsuranceIdentificationNumber">
        <xsd:enumeration value="SecondaryPolicyNumber">
        <xsd:enumeration value="SecondaryProviderNumber">
        <xsd:enumeration value="SecondarySuffixCodeIndicator">
        <xsd:enumeration value="SecondBeneficiarysReference">
        <xsd:enumeration value="SecretariadeComerciayFamentaIndustrialNumber">
        <xsd:enumeration value="SecretaryofStateAssignedIdentificationNumber">
        <xsd:enumeration value="SectionNumber">
        <xsd:enumeration value="SectionOfTheNationalHousingActCode">
        <xsd:enumeration value="SecurityInstrumentNumber">
        <xsd:enumeration value="SecurityType">
        <xsd:enumeration value="SelfInsuranceIdentificationNumber">
        <xsd:enumeration value="SelfInsurerAuthorizationTypeCode">
        <xsd:enumeration value="SelfInsurerOrganizationType">
        <xsd:enumeration value="SellerLoanNumber">
        <xsd:enumeration value="SellersCatalogueNumber">
        <xsd:enumeration value="SellersCreditMemo">
        <xsd:enumeration value="SellersDebitMemo">
        <xsd:enumeration value="SellersInvoiceNumber">
        <xsd:enumeration value="SellersReferenceNumber">
        <xsd:enumeration value="SellersSaleNumber">
        <xsd:enumeration value="SellingArrangement">
        <xsd:enumeration value="SenderDefinedClause">
        <xsd:enumeration value="SendersClauseNumber">
        <xsd:enumeration value="SendersFileReferenceNumber">
        <xsd:enumeration value="SendersReferenceToTheOriginalMessage">
        <xsd:enumeration value="SendingBankReferenceNumber">
        <xsd:enumeration value="SendingCompanyAuditNumberAutomatedClearinghouseTransfers">
        <xsd:enumeration value="SequenceNumber">
        <xsd:enumeration value="SerialNumber">
        <xsd:enumeration value="ServiceAuthorizationNumber">
        <xsd:enumeration value="ServiceBulletinNumber">
        <xsd:enumeration value="ServiceBureau">
        <xsd:enumeration value="ServiceChangeNumber">
        <xsd:enumeration value="ServiceChargeNumber">
        <xsd:enumeration value="ServiceContractNumber">
        <xsd:enumeration value="ServiceEstimateNumber">
        <xsd:enumeration value="ServiceGroupIdentificationNumber">
        <xsd:enumeration value="ServiceInterruptTrackingNumber">
        <xsd:enumeration value="ServiceOrderNumber">
        <xsd:enumeration value="ServicePerformedCode">
        <xsd:enumeration value="Servicer">
        <xsd:enumeration value="ServiceRequestNumber">
        <xsd:enumeration value="ServicerLoanNumber">
        <xsd:enumeration value="Session">
        <xsd:enumeration value="SetNumber">
        <xsd:enumeration value="Sheet">
        <xsd:enumeration value="ShelfLifeIndicator">
        <xsd:enumeration value="ShipFrom">
        <xsd:enumeration value="ShipmentDestinationCode">
        <xsd:enumeration value="ShipmentOriginCode">
        <xsd:enumeration value="ShipmentReferenceNumber">
        <xsd:enumeration value="ShipNoticeOrManifestNumber">
        <xsd:enumeration value="ShipownersAuthorizationNumber">
        <xsd:enumeration value="ShipperCarOrderNumber">
        <xsd:enumeration value="ShippersBondNumber">
        <xsd:enumeration value="ShippersHazardousNumber">
        <xsd:enumeration value="ShippersOrder">
        <xsd:enumeration value="ShippingLabelSerialNumber">
        <xsd:enumeration value="ShippingNoteNumber">
        <xsd:enumeration value="ShippingUnitIdentification">
        <xsd:enumeration value="ShippingZone">
        <xsd:enumeration value="ShortTermDisabilityPolicyNumber">
        <xsd:enumeration value="ShowIdentification">
        <xsd:enumeration value="SIC">
        <xsd:enumeration value="SID">
        <xsd:enumeration value="SignalCode">
        <xsd:enumeration value="SignalCodeNumber">
        <xsd:enumeration value="SingleTransactionSequenceNumber">
        <xsd:enumeration value="SIRENNumber">
        <xsd:enumeration value="SIRETNumber">
        <xsd:enumeration value="SiteSpecificProceduresTermsAndConditions">
        <xsd:enumeration value="SituationNumber">
        <xsd:enumeration value="SlaughterPlantNumber">
        <xsd:enumeration value="SocialInsuranceNumber">
        <xsd:enumeration value="SocialSecurityNumber">
        <xsd:enumeration value="SocietyofPropertyInformationCompilersandAnalysts">
        <xsd:enumeration value="SoftwareApplicationNumber">
        <xsd:enumeration value="Solicitation">
        <xsd:enumeration value="SortAndSegregate">
        <xsd:enumeration value="SourceDocumentInternalReference">
        <xsd:enumeration value="SpacingUnitOrderNumber">
        <xsd:enumeration value="SpecialApproval">
        <xsd:enumeration value="SpecialBudgetAccountNumber">
        <xsd:enumeration value="SpecialChargeOrAllowanceCode">
        <xsd:enumeration value="SpecialClause">
        <xsd:enumeration value="SpecialGovernmentAccountingClassificationReferenceNumber">
        <xsd:enumeration value="SpecialInstructionsNumber">
        <xsd:enumeration value="SpecialMoveReferenceNumber">
        <xsd:enumeration value="SpecialPackagingInstructionNumber">
        <xsd:enumeration value="SpecialPaymentReferenceNumber">
        <xsd:enumeration value="SpecialProcessingCode">
        <xsd:enumeration value="SpecialQuoteNumber">
        <xsd:enumeration value="SpecialtyLicenseNumber">
        <xsd:enumeration value="SpecificationClassNumber">
        <xsd:enumeration value="SpecificationNumber">
        <xsd:enumeration value="SpecificationRevision">
        <xsd:enumeration value="SpecimenIdentifier">
        <xsd:enumeration value="SplitBookingNumber">
        <xsd:enumeration value="SplitPremiumAuditChangeIdentifier">
        <xsd:enumeration value="SplitShipmentNumber">
        <xsd:enumeration value="SponsorsReferenceNumber">
        <xsd:enumeration value="SpouseTie">
        <xsd:enumeration value="StackTrainIdentification">
        <xsd:enumeration value="Standard">
        <xsd:enumeration value="StandardCarrierAlphaCode">
        <xsd:enumeration value="StandardClause">
        <xsd:enumeration value="StandardIndustryClassificationCode">
        <xsd:enumeration value="StandardNumberOfInspectionDocument">
        <xsd:enumeration value="StandardPointLocationCode">
        <xsd:enumeration value="StandardsCodeNumber">
        <xsd:enumeration value="StandardsNumber">
        <xsd:enumeration value="StandardsVersionNumber">
        <xsd:enumeration value="StandardTransportationCommodityCodeBridgeNumber">
        <xsd:enumeration value="StandardTransportationCommodityCodeReplacementCode">
        <xsd:enumeration value="StartingPackageNumber">
        <xsd:enumeration value="StateAssemblyDistrict">
        <xsd:enumeration value="StateCharterNumber">
        <xsd:enumeration value="StateControlledSubstanceLicenseNumber">
        <xsd:enumeration value="StateCriminalHistoryRepositoryIndividualIdentification">
        <xsd:enumeration value="StateDepartmentI20FormNumber">
        <xsd:enumeration value="StateDepartmentIAP66FormNumber">
        <xsd:enumeration value="StateHazardousWasteEntityIdentifier">
        <xsd:enumeration value="StateIndustrialAccidentProviderNumber">
        <xsd:enumeration value="StateLegislativeDistrict">
        <xsd:enumeration value="StateLicenseIdentificationNumber">
        <xsd:enumeration value="StateLicenseNumber">
        <xsd:enumeration value="StatementNumber">
        <xsd:enumeration value="StatementOfWork">
        <xsd:enumeration value="StateNonResidentViolatorCompact">
        <xsd:enumeration value="StateorProvinceAssignedBusinessRegistryNumber">
        <xsd:enumeration value="StateOrProvinceAssignedEntityIdentification">
        <xsd:enumeration value="StateSalesTaxIdentificationNumber">
        <xsd:enumeration value="StateSenateDistrict">
        <xsd:enumeration value="StateStudentIdentificationNumber">
        <xsd:enumeration value="StateTaxIdentificationNumber">
        <xsd:enumeration value="StatewideCourseNumber">
        <xsd:enumeration value="StationReferenceNumber">
        <xsd:enumeration value="Status">
        <xsd:enumeration value="StatusReportNumber">
        <xsd:enumeration value="StockCertificateNumber">
        <xsd:enumeration value="StockExchangeCode">
        <xsd:enumeration value="StockExchangeCompanyIdentifier">
        <xsd:enumeration value="StockKeepingUnitNumber">
        <xsd:enumeration value="StockNumber">
        <xsd:enumeration value="StopSequenceNumber">
        <xsd:enumeration value="StorageInformationCode">
        <xsd:enumeration value="StoreNumber">
        <xsd:enumeration value="Study">
        <xsd:enumeration value="SubassemblyNumber">
        <xsd:enumeration value="SubcontractLineItemNumber">
        <xsd:enumeration value="SubcontractNumber">
        <xsd:enumeration value="SubcontractorDataRequirements">
        <xsd:enumeration value="SubdayNumber">
        <xsd:enumeration value="SubdivisionIdentifier">
        <xsd:enumeration value="SubexhibitLineItemNumber">
        <xsd:enumeration value="SubFile">
        <xsd:enumeration value="SubhouseBillOfLading">
        <xsd:enumeration value="SubjectPropertyNonSaleReferenceNumber">
        <xsd:enumeration value="SubjectPropertyReferenceNumber">
        <xsd:enumeration value="SubjectPropertyVerificationSource">
        <xsd:enumeration value="SublineofInsurance">
        <xsd:enumeration value="SubmissionNumber">
        <xsd:enumeration value="SubmitterIdentificationNumber">
        <xsd:enumeration value="SubscriberAuthorizationNumber">
        <xsd:enumeration value="SubscriberNumber">
        <xsd:enumeration value="Subservicer">
        <xsd:enumeration value="SubServicerLoanNumber">
        <xsd:enumeration value="SubsistenceIdentificationNumber">
        <xsd:enumeration value="SubstantivelyConsolidatedCase">
        <xsd:enumeration value="SubstituteAirWaybillNumber">
        <xsd:enumeration value="SubstituteManufacturersPartNumber">
        <xsd:enumeration value="SubstituteNationalStockNumber">
        <xsd:enumeration value="SubstitutePartNumber">
        <xsd:enumeration value="SubSubhouseBillOfLading">
        <xsd:enumeration value="SuccessorAccount">
        <xsd:enumeration value="Suffix">
        <xsd:enumeration value="SuperintendenciadeInversionesExtranjerasNumber">
        <xsd:enumeration value="SupervisoryAppraiserCertificationNumber">
        <xsd:enumeration value="SupplementalAccountNumber">
        <xsd:enumeration value="SupplementalAgreementAuthority">
        <xsd:enumeration value="SupplementalClaimNumber">
        <xsd:enumeration value="SupplementNumber">
        <xsd:enumeration value="Supplier">
        <xsd:enumeration value="SupplierReplacement">
        <xsd:enumeration value="SupplierDocumentIdentificationNumber">
        <xsd:enumeration value="SuppliersControlNumber">
        <xsd:enumeration value="SuppliersCreditClaimReferenceNumber">
        <xsd:enumeration value="SupportingDocumentNumber">
        <xsd:enumeration value="SuretyBondNumber">
        <xsd:enumeration value="SuspensionIdentifier">
        <xsd:enumeration value="SwapOrderNumber">
        <xsd:enumeration value="SWIFT">
        <xsd:enumeration value="SWIFTMT100">
        <xsd:enumeration value="SWIFTMT202">
        <xsd:enumeration value="SWIFTConfirmationNumber">
        <xsd:enumeration value="SymbolNumber">
        <xsd:enumeration value="SymbolNumberForMilestoneOrLOBReports">
        <xsd:enumeration value="SystematizedNomenclatureofHumanandVeterinaryMedicine">
        <xsd:enumeration value="SystemeInformatiquePourLeRepertoireDesEntreprises">
        <xsd:enumeration value="SystemeInformatiquePourLeRepertoireDesEtablissements">
        <xsd:enumeration value="SystemNumber">
        <xsd:enumeration value="Tag">
        <xsd:enumeration value="TankNumber">
        <xsd:enumeration value="TariffNumber">
        <xsd:enumeration value="TariffPageNumber">
        <xsd:enumeration value="TariffRuleNumber">
        <xsd:enumeration value="TariffSectionNumber">
        <xsd:enumeration value="TariffSuffixNumber">
        <xsd:enumeration value="TariffSupplementNumber">
        <xsd:enumeration value="TaskOrder">
        <xsd:enumeration value="TaxAgencyNumber">
        <xsd:enumeration value="TaxExchangeCode">
        <xsd:enumeration value="TaxExemptionLicenceNumber">
        <xsd:enumeration value="TaxExemptNumber">
        <xsd:enumeration value="TaxFiling">
        <xsd:enumeration value="TaxFormCode">
        <xsd:enumeration value="TaxingAuthorityIdentificationNumber">
        <xsd:enumeration value="TaxLicenseExemption">
        <xsd:enumeration value="TaxLienJurisdiction">
        <xsd:enumeration value="TaxRegistrationNumber">
        <xsd:enumeration value="TaxScheduleCode">
        <xsd:enumeration value="TaxShelterNumber">
        <xsd:enumeration value="TaxWorksheet">
        <xsd:enumeration value="TCN">
        <xsd:enumeration value="TeamAssignmentNumber">
        <xsd:enumeration value="TechnicalDocumentationType">
        <xsd:enumeration value="TechnicalDocumentNumber">
        <xsd:enumeration value="TechnicalInformationPackage">
        <xsd:enumeration value="TechnicalOrderNumber">
        <xsd:enumeration value="TechnicalPhaseReference">
        <xsd:enumeration value="TechnicalRegulation">
        <xsd:enumeration value="TelecommunicationCircuitSupplementalID">
        <xsd:enumeration value="TelexMessageNumber">
        <xsd:enumeration value="TemplateSequenceNumber">
        <xsd:enumeration value="Tenor">
        <xsd:enumeration value="Term">
        <xsd:enumeration value="TerminalCode">
        <xsd:enumeration value="TerminalOperatorNumber">
        <xsd:enumeration value="TerminalReleaseOrderNumber">
        <xsd:enumeration value="TerminationFiling">
        <xsd:enumeration value="TesterIdentification">
        <xsd:enumeration value="TestReportNumber">
        <xsd:enumeration value="TestSpecificationNumber">
        <xsd:enumeration value="TextElementIdentifierDeletionReference">
        <xsd:enumeration value="TheaterScreenNumber">
        <xsd:enumeration value="ThirdBanksReferenceNumber">
        <xsd:enumeration value="ThirdBanksReference">
        <xsd:enumeration value="ThirdPartyAdministratorClaimNumber">
        <xsd:enumeration value="ThirdPartyNoteHolderIdentification">
        <xsd:enumeration value="ThirdPartyOrganizationAuthorizationNumber">
        <xsd:enumeration value="ThirdPartyOriginatorNumber">
        <xsd:enumeration value="ThirdPartyPurchaseOrderItemNumber">
        <xsd:enumeration value="ThirdPartyPurchaseOrderNumber">
        <xsd:enumeration value="ThirdPartyPurchaseOrderReleaseNumber">
        <xsd:enumeration value="ThirdPartyReferenceNumber">
        <xsd:enumeration value="ThroughBillOfLadingNumber">
        <xsd:enumeration value="TicketNumber">
        <xsd:enumeration value="TimeFailure">
        <xsd:enumeration value="TirCarnetNumber">
        <xsd:enumeration value="TIRNumber">
        <xsd:enumeration value="TitleCompanyCodeBookReference">
        <xsd:enumeration value="TitleDocumentSchedule">
        <xsd:enumeration value="TitlePolicyNumber">
        <xsd:enumeration value="TitleReference">
        <xsd:enumeration value="TitleXIXIdentifierNumber">
        <xsd:enumeration value="TokyoShokoResearchBusinessIdentifier">
        <xsd:enumeration value="TollBillingTelephoneReferenceNumber">
        <xsd:enumeration value="TotalCycleNumber">
        <xsd:enumeration value="TotalOrderCycleNumber">
        <xsd:enumeration value="TownshipNumber">
        <xsd:enumeration value="ToxicologyID">
        <xsd:enumeration value="TracerActionRequestNumber">
        <xsd:enumeration value="TrackingNumber">
        <xsd:enumeration value="Tract">
        <xsd:enumeration value="TraderAccountNumber">
        <xsd:enumeration value="TradingPartnerIdentificationNumber">
        <xsd:enumeration value="TrailerTypeQualifier">
        <xsd:enumeration value="TrailerUseAgreements">
        <xsd:enumeration value="TrainingFlightNumber">
        <xsd:enumeration value="TransactionCategoryOrType">
        <xsd:enumeration value="TransactionReferenceNumber">
        <xsd:enumeration value="TransferNumber">
        <xsd:enumeration value="TransitGuaranteeNumber">
        <xsd:enumeration value="TransponderNumber">
        <xsd:enumeration value="TransportationAccountCode">
        <xsd:enumeration value="TransportationAccountNumber">
        <xsd:enumeration value="TransportationControlNumber">
        <xsd:enumeration value="TransportationExportationNoForInBondMovement">
        <xsd:enumeration value="TransportationPriorityNumber">
        <xsd:enumeration value="TransportContractReferenceNumber">
        <xsd:enumeration value="TransportCostsReferenceNumber">
        <xsd:enumeration value="TransportDocumentNumber">
        <xsd:enumeration value="TransportEquipmentReturnReference">
        <xsd:enumeration value="TransportEquipmentStrippingOrder">
        <xsd:enumeration value="TransportEquipmentStuffingOrder">
        <xsd:enumeration value="TransportEquipmentSurveyReference">
        <xsd:enumeration value="TransportEquipmentSurveyReferenceNumber">
        <xsd:enumeration value="TransportEquipmentSurveyReportNumber">
        <xsd:enumeration value="TransportRoute">
        <xsd:enumeration value="TransportSectionReferenceNumber">
        <xsd:enumeration value="TravelManifest">
        <xsd:enumeration value="TreatyIdentifier">
        <xsd:enumeration value="TreatyNumber">
        <xsd:enumeration value="TrialLocationCode">
        <xsd:enumeration value="Tripleback">
        <xsd:enumeration value="TruckersBillOfLading">
        <xsd:enumeration value="Trustee">
        <xsd:enumeration value="TSRBusinessIdentifier">
        <xsd:enumeration value="TypeOfComment">
        <xsd:enumeration value="TypeOfEscrowNumber">
        <xsd:enumeration value="TypeOfHouseholdGoodsCode">
        <xsd:enumeration value="TypeOfLawSuit">
        <xsd:enumeration value="TypeOfOutstandingJudgment">
        <xsd:enumeration value="TypeOfScienceCode">
        <xsd:enumeration value="U.S.DefenseFederalAcquisitionRegulationSupplement">
        <xsd:enumeration value="U.S.DepartmentOfVeteransAffairsAcquisitionRegulation">
        <xsd:enumeration value="U.S.GovernmentTransportationControlNumber">
        <xsd:enumeration value="UltimateConsignee">
        <xsd:enumeration value="UltimateCustomersOrderNumber">
        <xsd:enumeration value="UltimateCustomersReferenceNumber">
        <xsd:enumeration value="UnacceptableSourceDUNSNumber">
        <xsd:enumeration value="UnacceptableSourcePurchaserID">
        <xsd:enumeration value="UnacceptableSourceSupplierID">
        <xsd:enumeration value="UnderwriterIdentificationNumber">
        <xsd:enumeration value="UnderwritingAlertReferenceCode">
        <xsd:enumeration value="UNDG">
        <xsd:enumeration value="UnemploymentInsuranceNumber">
        <xsd:enumeration value="UniformCommercialCodeFilingCollateralNumber">
        <xsd:enumeration value="UniformResourceLocator">
        <xsd:enumeration value="UnionNumber">
        <xsd:enumeration value="UniqueClaimsReferenceNumberOfTheSender">
        <xsd:enumeration value="UniqueConsignmentIdentifier">
        <xsd:enumeration value="UniqueConsignmentReferenceNumber">
        <xsd:enumeration value="UniqueCurracReferenceNumberOfTheSender">
        <xsd:enumeration value="UniqueMarketReference">
        <xsd:enumeration value="UniqueReinacReferenceNumberOfTheSender">
        <xsd:enumeration value="UniqueSupplierIdentificationNumber">
        <xsd:enumeration value="UnitedNationsHazardousClassificationNumber">
        <xsd:enumeration value="UnitedStatesGovernmentVisaNumber">
        <xsd:enumeration value="UnitedStatesStandardMetropolitanStatisticalAreaCode">
        <xsd:enumeration value="UnitLoadDeviceIdentificationNumber">
        <xsd:enumeration value="UnitNumber">
        <xsd:enumeration value="UnitPropertyNumber">
        <xsd:enumeration value="UnitReliefNumber">
        <xsd:enumeration value="UnitReportPeriod">
        <xsd:enumeration value="UnitReportPeriodID">
        <xsd:enumeration value="UnitTrain">
        <xsd:enumeration value="UniversalRailroadRevenueWaybillIdentifiedNumber">
        <xsd:enumeration value="UniversalTransverseMercatorEast">
        <xsd:enumeration value="UniversalTransverseMercatorNorth">
        <xsd:enumeration value="UniversalTransverseMercatorZone">
        <xsd:enumeration value="UnpaidInstallmentReferenceNumber">
        <xsd:enumeration value="UpperSerialNumberOfRange">
        <xsd:enumeration value="UpstreamShipperContractNumber">
        <xsd:enumeration value="USCFR">
        <xsd:enumeration value="USCS">
        <xsd:enumeration value="USCustomsServiceAntiDumpingDutyCaseNumber">
        <xsd:enumeration value="USCustomsServiceBindingRulingNumber">
        <xsd:enumeration value="USCustomsServiceCommercialDescription">
        <xsd:enumeration value="USCustomsServiceCountervailingDutyCaseNumber">
        <xsd:enumeration value="USCustomsServiceEntryNumber">
        <xsd:enumeration value="USCustomsServiceEntryTypeCode">
        <xsd:enumeration value="USCustomsServicePreApprovalRulingNumber">
        <xsd:enumeration value="USCustomsServicePreClassificationRulingNumber">
        <xsd:enumeration value="USCustomsServiceStatementNumber">
        <xsd:enumeration value="USDOEAndNCES">
        <xsd:enumeration value="USDOTBondSuretyCode">
        <xsd:enumeration value="UserID">
        <xsd:enumeration value="UserIdentification">
        <xsd:enumeration value="USFCCImportCondition">
        <xsd:enumeration value="USFederalAcquisitionRegulation">
        <xsd:enumeration value="USFederalInformationResourcesManagementRegulation">
        <xsd:enumeration value="USFoodAndDrugAdministrationEstablishmentIndicator">
        <xsd:enumeration value="USGeneralServicesAdministrationRegulation">
        <xsd:enumeration value="USGovernmentAgencyNumber">
        <xsd:enumeration value="ValueAddedTaxRegistrationNumber">
        <xsd:enumeration value="VatRegistrationNumber">
        <xsd:enumeration value="VehicleBusinessUseQualifier">
        <xsd:enumeration value="VehicleLicenceNumber">
        <xsd:enumeration value="VehicleRadiusofOperationQualifier">
        <xsd:enumeration value="VehicleRelatedServicesReferenceNumber">
        <xsd:enumeration value="VehicleSizeClassQualifier">
        <xsd:enumeration value="VendorAbbreviationCode">
        <xsd:enumeration value="VendorChangeIdentificationCode">
        <xsd:enumeration value="VendorChangeProcedureCode">
        <xsd:enumeration value="VendorContractNumber">
        <xsd:enumeration value="VendorIDNumber">
        <xsd:enumeration value="VendorOrderNumberSuffix">
        <xsd:enumeration value="VendorProductNumber">
        <xsd:enumeration value="VendorsPreviousJobNumber">
        <xsd:enumeration value="VendorTerms">
        <xsd:enumeration value="VerificationSourceCode">
        <xsd:enumeration value="Version">
        <xsd:enumeration value="VersionCodeLocal">
        <xsd:enumeration value="VersionCodeNational">
        <xsd:enumeration value="VerticalCoordinate">
        <xsd:enumeration value="Vessel">
        <xsd:enumeration value="VesselAgentNumber">
        <xsd:enumeration value="VesselIdentification">
        <xsd:enumeration value="VesselName">
        <xsd:enumeration value="VeteransAdministrationOriginatorIdentification">
        <xsd:enumeration value="VeteransAffairsCaseNumber">
        <xsd:enumeration value="VIN">
        <xsd:enumeration value="VisaType">
        <xsd:enumeration value="VolumeNumber">
        <xsd:enumeration value="VolumePurchaseAgreementNumber">
        <xsd:enumeration value="VoucherNumber">
        <xsd:enumeration value="VoyageNumber">
        <xsd:enumeration value="WageDetermination">
        <xsd:enumeration value="Waiver">
        <xsd:enumeration value="Ward">
        <xsd:enumeration value="WarehouseEntryNumber">
        <xsd:enumeration value="WarehousePickTicketNumber">
        <xsd:enumeration value="WarehouseReceiptNumber">
        <xsd:enumeration value="WarehouseStorageLocationNumber">
        <xsd:enumeration value="Warrant">
        <xsd:enumeration value="WarrantyCoverageCode">
        <xsd:enumeration value="WarrantyRegistrationNumber">
        <xsd:enumeration value="WaybillNumber">
        <xsd:enumeration value="WeaponSystemNumber">
        <xsd:enumeration value="WeightAgreementNumber">
        <xsd:enumeration value="WellClassificationCode">
        <xsd:enumeration value="WellNumber">
        <xsd:enumeration value="WithdrawalAccountNumber">
        <xsd:enumeration value="WithdrawalRecord">
        <xsd:enumeration value="WoolIdentificationNumber">
        <xsd:enumeration value="WoolTaxReferenceNumber">
        <xsd:enumeration value="WorkBreakdownStructure">
        <xsd:enumeration value="WorkCandidateSequenceNumber">
        <xsd:enumeration value="WorkCenter">
        <xsd:enumeration value="WorkingShiftNumber">
        <xsd:enumeration value="WorkItemQuantityDetermination">
        <xsd:enumeration value="WorkOrderNumber">
        <xsd:enumeration value="WorkPackage">
        <xsd:enumeration value="WorkShift">
        <xsd:enumeration value="WorksiteNumber">
        <xsd:enumeration value="WorkTaskChargeNumber">
        <xsd:enumeration value="WorkTeam">
        <xsd:enumeration value="YardPosition">
        <xsd:enumeration value="Zone">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: RegionCodeType

RegionCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the region within a country. This code list is derived from ISO 3166/1998 (Country code subdivision code, UN/LOCODE 2000)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • ARA - Argentina-Salta
    • ARB - Argentina-Buenos Aires
    • ARC - Argentina-Distrito Federal
    • ARD - Argentina-San Luis
    • ARE - Argentina-Entre Rios
    • ARF - Argentina-La Rioja
    • ARG - Argentina-Santiago del Estero
    • ARH - Argentina-Chaco
    • ARJ - Argentina-San Juan
    • ARK - Argentina-Catamarca
    • ARL - Argentina-La Pampa
    • ARM - Argentina-Mendoza
    • ARN - Argentina-Misiones
    • ARP - Argentina-Formosa
    • ARQ - Argentina-Neuquen
    • ARR - Argentina-Rio Negro
    • ARS - Argentina-Santa FeSanta Fe
    • ART - Argentina-Tucuman
    • ARU - Argentina-Chubut
    • ARV - Argentina-Tierra del Fuego
    • ARW - Argentina-Corrientes
    • ARX - Argentina-Cordoba
    • ARY - Argentina-Jujuy
    • ARZ - Argentina-Santa Cruz
    • AUCT - Australia-Australian Capital Territory
    • AUNS - Australia-New South Wales
    • AUNT - Australia-Northern Territory
    • AUQL - Australia- Queensland
    • AUSA - Australia-South Australia
    • AUTS - Australia-Tasmania
    • AUVI - Australia-Victoria
    • AUWA - Australia-Western Australia
    • BEVAN - Belgium-Antwerpen
    • BEVBR - Belgium-Vlaams Brabant
    • BEVLI - Belgium-Limburg
    • BEVOV - Belgium-Oost-Vlaanderen
    • BEVWV - Belgium-West-Vlaanderen
    • BEWBR - Belgium-Brabant Wallon
    • BEWHT - Belgium-Hainaut
    • BEWLG - Belgium-Liège
    • BEWLX - Belgium-Luxembourg
    • BEWNA - Belgium-Namur
    • BRAC - Brazil-Acre
    • BRAL - Brazil-Alagoas
    • BRAM - Brazil-Amazonas
    • BRAP - Brazil-Amapa
    • BRBA - Brazil-Bahia
    • BRCE - Brazil-Ceara
    • BRDF - Brazil-Distrito Federal
    • BRES - Brazil-Espirito Santo
    • BRGO - Brazil-Goias
    • BRMA - Brazil-Maranhao
    • BRMT - Brazil-Mato Grosso
    • BRMS - Brazil-Mato Grosso do Sul
    • BRMG - Brazil-Minas Gerais
    • BRPA - Brazil-Para
    • BRPB - Brazil-Paraiba
    • BRPE - Brazil-Pernambuco
    • BRPI - Brazil-Piaui
    • BRPR - Brazil-Parana
    • BRRJ - Brazil-Rio de Janeiro
    • BRRN - Brazil-Rio Grande do Norte
    • BRRO - Brazil-Rondonia
    • BRRR - Brazil-Roraima
    • BRRS - Brazil-Rio Grande do Sul
    • BRSC - Brazil-Santa Catarina
    • BRSE - Brazil-Sergipe
    • BRSP - Brazil-Sao Paulo
    • BRTO - Brazil-Tocantina
    • CAAB - Canada-Alberta
    • CABC - Canada-British Columbia
    • CAMB - Canada-Manitoba
    • CANB - Canada-New Brunswick
    • CANF - Canada-Newfoundland
    • CANS - Canada-Nova Scotia
    • CANT - Canada-Northwest Territories
    • CANU - Canada-Nunavut
    • CAON - Canada-Ontario
    • CAPE - Canada-Prince Edward Island
    • CAQC - Canada-Quebec
    • CASK - Canada-Saskatchewan
    • CAYT - Canada-Yukon Territory
    • CLAI - Chile-Aisen del General Carlos Ibañez del Campo
    • CLAN - Chile-Antofagasta
    • CLAR - Chile-Araucania
    • CLAT - Chile-Atacama
    • CLBI - Chile-Bio-Bio
    • CLCO - Chile-Coquimbo
    • CLLI - Chile-Libertador General Bernardo O'Higgins
    • CLLL - Chile-Los Lagos
    • CLMA - Chile-Magallanes
    • CLML - Chile-Maule
    • CLRM - Chile-Región Metropolitana de Santiago
    • CLTA - Chile-Tarapaca
    • CLVS - Chile-Valparaiso
    • CN11 - China-Beijing
    • CN12 - China-Tianjin
    • CN13 - China-Hebei
    • CN14 - China-Shanxi
    • CN15 - China-Nei Mongol
    • CN21 - China-Liaoning
    • CN22 - China-Jilin
    • CN23 - China-Heilongjiang
    • CN31 - China-Shanghai
    • CN32 - China-Jiangsu
    • CN33 - China-Zhejiang
    • CN34 - China-Anhui
    • CN35 - China-Fujian
    • CN36 - China-Jiangxi
    • CN37 - China-Shandong
    • CN41 - China-Henan
    • CN42 - China-Hubei
    • CN43 - China-Hunan
    • CN44 - China-Guangdong
    • CN45 - China-Guangxi
    • CN46 - China-Hainan
    • CN51 - China-Sichuan
    • CN52 - China-Guizhou
    • CN53 - China-Yunnan
    • CN54 - China-Xizang
    • CN61 - China-Shaanxi
    • CN62 - China-Gansu
    • CN63 - China-Qinghai
    • CN64 - China-Ningxia
    • CN65 - China-Xinjiang
    • CN71 - China-Taiwan
    • CN91 - China-Xianggang (Hong Kong)
    • CN92 - China-Aomen (Macau)
    • FIAL - Finland-Ahvenanmaan Maakunta
    • FIES - Finland-Etela-Suomen laani
    • FIIS - Finland-Ita-Suomen laani
    • FILL - Finland-Lapin laani
    • FILS - Finland-Lansi-Suomen laani
    • FIOL - Finland-Oulun laani
    • FR01 - France-Ain
    • FR02 - France-Aisne
    • FR2A - France-Corse-du-Sud
    • FR2B - France-Haute-Corse
    • FR03 - France-Allier
    • FR04 - France-Alpes-de-Haute-Provence
    • FR05 - France-Hautes-Alpes
    • FR06 - France-Alpes-Maritimes
    • FR07 - France-Ardèche
    • FR08 - France-Ardennes
    • FR09 - France-Ariège
    • FR10 - France-Aube
    • FR11 - France-Aude
    • FR12 - France-Aveyron
    • FR13 - France-Bouches-du-Rhone
    • FR14 - France-Calvados
    • FR15 - France-Cantal
    • FR16 - France-Charente
    • FR17 - France-Charente-Maritime
    • FR18 - France-Cher
    • FR19 - France-Corrèze
    • FR21 - France-Cote-d'Or
    • FR22 - France-Cotes-d'Armor
    • FR23 - France-Creuse
    • FR24 - France-Dordogne
    • FR25 - France-Doubs
    • FR26 - France-Drome
    • FR27 - France-Eure
    • FR28 - France-Eure-et-Loir
    • FR29 - France-Finistère
    • FR30 - France-Gard
    • FR31 - France-Haute-Garonne
    • FR32 - France-Gers
    • FR33 - France-Gironde
    • FR34 - France-Herault
    • FR35 - France-Ille-et-Vilaine
    • FR36 - France-Indre
    • FR37 - France-Indre-et-Loire
    • FR38 - France-Isère
    • FR39 - France-Jura
    • FR40 - France-Landes
    • FR41 - France-Loir-et-Cher
    • FR42 - France-Loire
    • FR43 - France-Haute-Loire
    • FR44 - France-Loire-Atlantique
    • FR45 - France-Loiret
    • FR46 - France-Lot
    • FR47 - France-Lot-et-Garonne
    • FR48 - France-Lozère
    • FR49 - France-Maine-et-Loire
    • FR50 - France-Manche
    • FR51 - France-Marne
    • FR52 - France-Haute-Marne
    • FR53 - France-Mayenne
    • FR54 - France-Meurthe-et-Moselle
    • FR55 - France-Meuse
    • FR56 - France-Morbihan
    • FR57 - France-Moselle
    • FR58 - France-Nièvre
    • FR59 - France-Nord
    • FR60 - France-Oise
    • FR61 - France-Orne
    • FR62 - France-Pas-de-Calais
    • FR63 - France-Puy-de-Dome
    • FR64 - France-Pyrenees-Atlantiques
    • FR65 - France-Hautes-Pyrenees
    • FR66 - France-Pyrenees-Orientales
    • FR67 - France-Bas-Rhin
    • FR68 - France-Haut-Rhin
    • FR69 - France-Rhone
    • FR70 - France-Haute-Saone
    • FR71 - France-Saone-et-Loire
    • FR72 - France-Sarthe
    • FR73 - France-Savoie
    • FR74 - France-Haute-Savoie
    • FR75 - France-Paris
    • FR76 - France-Seine-Maritime
    • FR77 - France-Seine-et-Marne
    • FR78 - France-Yvelines
    • FR79 - France-Deux-Sèvres
    • FR80 - France-Somme
    • FR81 - France-Tarn
    • FR82 - France-Tarn-et-Garonne
    • FR83 - France-Var
    • FR84 - France-Vaucluse
    • FR85 - France-Vendee
    • FR86 - France-Vienne
    • FR87 - France-Haute-Vienne
    • FR88 - France-Vosges
    • FR89 - France-Yonne
    • FR90 - France-Territoire de Belfort
    • FR91 - France-Essonne
    • FR92 - France-Hauts-de-Seine
    • FR93 - France-Seine-Saint-Denis
    • FR94 - France-Val-de-Marne
    • FR95 - France-Val-d'Oise
    • DEBE - Germany-Berlin
    • DEBR - Germany-Brandenburg
    • DEBW - Germany-Baden-Wurttemberg
    • DEBY - Germany-Bayern
    • DEHB - Germany-Bremen (Hansestadt)
    • DEHE - Germany-Hessen
    • DEHH - Germany-Hamburg (Hansestadt)
    • DEMV - Germany-Mecklenburg-Vorpommern
    • DENI - Germany-Niedersachsen
    • DENW - Germany-Nordrhein-Westfalen
    • DERP - Germany-Rheinland-Pfalz
    • DEST - Germany-Sachsen-Anhalt
    • DESH - Germany-Schleswig-Holstein
    • DESL - Germany-Saarland
    • DESN - Germany-Sachsen
    • DETH - Germany-Thuringen
    • ITAG - Agriento
    • ITAL - Alessandria
    • ITAN - Ancona
    • ITAO - Aosta
    • ITAP - Ascoli Piceno
    • ITAQ - L Aquila
    • ITAR - Arezzo
    • ITAT - Asti
    • ITAV - Avellino
    • ITBA - Bari
    • ITBG - Bergamo
    • ITBI - Biella
    • ITBL - Belluno
    • ITBN - Benevento
    • ITBO - Bologna
    • ITBR - Brindisi
    • ITBS - Brescia
    • ITBZ - Bolzano
    • ITCA - Cagliari
    • ITCB - Campobasso
    • ITCE - Caserta
    • ITCH - Chieti
    • ITCL - Caltanisetta
    • ITCN - Cuneo
    • ITCO - Como
    • ITCR - Cremona
    • ITCS - Cosenza
    • ITCT - Catania
    • ITCZ - Catanzaro
    • ITEN - Enna
    • ITFE - Ferrara
    • ITFG - Foggia
    • ITFI - Florence
    • ITFO - Forli
    • ITFR - Frosinone
    • ITGE - Genova
    • ITGO - Gorizia
    • ITGR - Grosseto
    • ITIM - Imperia
    • ITIS - Isernia
    • ITKR - Crotone
    • ITLC - Lecco
    • ITLE - Lecce
    • ITLI - Livorno
    • ITLO - Lodi
    • ITLT - Latina
    • ITLU - Lucca
    • ITMC - Macerata
    • ITME - Messina
    • ITMI - Milan
    • ITMN - Mantova
    • ITMO - Modena
    • ITMS - Massa Carrara
    • ITMT - Matera
    • ITNA - Naples
    • ITNO - Novara
    • ITNU - Nuoro
    • ITOR - Oristano
    • ITPA - Palermo
    • ITPC - Piacenza
    • ITPD - Padova
    • ITPE - Pescara
    • ITPG - Perugia
    • ITPI - Pisa
    • ITPN - Pordenone
    • ITPO - Prato
    • ITPR - Parma
    • ITPS - Pesaro
    • ITPT - Pistoia
    • ITPV - Pavia
    • ITPZ - Potenza
    • ITRA - Ravenna
    • ITRC - Reggio Calabria
    • ITRE - Reggio Emilia
    • ITRG - Ragusa
    • ITRI - Rieti
    • ITRM - Rome
    • ITRN - Rimini
    • ITRO - Rovigo
    • ITRV - Rovigo
    • ITSA - Salerno
    • ITSI - Siena
    • ITSO - Sondrio
    • ITSP - La Spezia
    • ITSR - Siracusa
    • ITSS - Sassari
    • ITSV - Savona
    • ITTA - Taranto
    • ITTE - Teramo
    • ITTN - Trento
    • ITTO - Turin
    • ITTP - Trapani
    • ITTR - Terni
    • ITTS - Trieste
    • ITTV - Treviso
    • ITUD - Udine
    • ITVA - Varese
    • ITVC - Vercelli
    • ITVE - Venice
    • ITVI - Vicenza
    • ITVR - Verona
    • ITVT - Viterbo
    • ITVV - Vibo Valentia
    • JP01 - Japan-Hokkaido
    • JP02 - Japan-Aomori
    • JP03 - Japan-Iwate
    • JP04 - Japan-Miyagi
    • JP05 - Japan-Akita
    • JP06 - Japan-Yamagata
    • JP07 - Japan-Hukusima (Fukushima)
    • JP08 - Japan-Ibaraki
    • JP09 - Japan-Totigi (Tochigi)
    • JP10 - Japan-Gunma
    • JP11 - Japan-Saitama
    • JP12 - Japan-Tiba (Chiba)
    • JP13 - Japan-Tokyo
    • JP14 - Japan-Kanagawa
    • JP15 - Japan-Niigata
    • JP16 - Japan-Toyama
    • JP17 - Japan-Isikawa (Ishikawa)
    • JP18 - Japan-Hukui (Fukui)
    • JP19 - Japan-Yamanasi (Yamanashi)
    • JP20 - Japan-Nagano
    • JP21 - Japan-Gihu (Gifu)
    • JP22 - Japan-Sizuoka (Shizuoka)
    • JP23 - Japan-Aiti (Aichi)
    • JP24 - Japan-Mie
    • JP25 - Japan-Siga (Shiga)
    • JP26 - Japan-Kyoto
    • JP27 - Japan-Osaka
    • JP28 - Japan-Hyogo
    • JP29 - Japan-Nara
    • JP30 - Japan-Wakayama
    • JP31 - Japan-Tottori
    • JP32 - Japan-Simane (Shimane)
    • JP33 - Japan-Okayama
    • JP34 - Japan-Hirosima (Hiroshima)
    • JP35 - Japan-Yamaguti (Yamaguchi)
    • JP36 - Japan- Tokusima (Tokushima)
    • JP37 - Japan-Kagawa
    • JP38 - Japan-Ehime
    • JP39 - Japan-Koti (Kochi)
    • JP40 - Japan-Hukuoka (Fukuoka)
    • JP41 - Japan-Saga
    • JP42 - Japan-Nagasaki
    • JP43 - Japan-Kumamoto
    • JP44 - Japan-Oita
    • JP45 - Japan-Miyazaki
    • JP46 - Japan-Kagosima (Kagoshima)
    • JP47 - Japan-Okinawa
    • MXAGU - Mexico-Aguascalientes
    • MXBCN - Mexico-Baja California
    • MXBCS - Mexico-Baja California Sur
    • MXCAM - Mexico-Campeche
    • MXCHH - Mexico-Chihuahua
    • MXCHP - Mexico-Chiapas
    • MXCOA - Mexico-Coahuila
    • MXCOL - Mexico-Colima
    • MXDF - Mexico-Distrito Federal
    • MXDUR - Mexico-Durango
    • MXGRO - Mexico-Guerrero
    • MXGUA - Mexico-Guanajuato
    • MXHID - Mexico-Hidalgo
    • MXJAL - Mexico-Jalisco
    • MXMEX - Mexico-Mexico
    • MXMIC - Mexico-Michoacan
    • MXMOR - Mexico-Morelos
    • MXNAY - Mexico-Nayarit
    • MXNLE - Mexico-Nuevo Leon
    • MXOAX - Mexico-Oaxaca
    • MXPUE - Mexico-Puebla
    • MXQUE - Mexico-Queretaro
    • MXROO - Mexico-Quintana Roo
    • MXSIN - Mexico-Sinaloa
    • MXSLP - Mexico-San Luis Potosi
    • MXSON - Mexico-Sonora
    • MXTAB - Mexico-Tabasco
    • MXTAM - Mexico-Tamaulipas
    • MXTLA - Mexico-Tlaxcala
    • MXVER - Mexico-Veracruz
    • MXYUC - Mexico-Yucatan
    • MXZAC - Mexico-Zacatecas
    • NZAUK - New Zealand-Auckland
    • NZBOP - New Zealand-Bay of Plenty
    • NZCAN - New Zealand-Canterbury
    • NZGIS - New Zealand-Gisborne
    • NZHKB - New Zealand-Hawkes's Bay
    • NZMBH - New Zealand-Marlborough
    • NZMWT - New Zealand-Manawatu-Wanganui
    • NZNSN - New Zealand-Nelson
    • NZNTL - New Zealand-Northland
    • NZOTA - New Zealand-Otago
    • NZSTL - New Zealand-Southland
    • NZTAS - New Zealand-Tasman
    • NZTKI - New Zealand-Taranaki
    • NZWGN - New Zealand-Wellington
    • NZWKO - New Zealand-Waikato
    • NZWTC - New Zealand-West Coast
    • NO01 - Norway-ostfold
    • NO02 - Norway-Akershus
    • NO03 - Norway-Oslo
    • NO04 - Norway-Hedmark
    • NO05 - Norway-Oppland
    • NO06 - Norway-Buskerud
    • NO07 - Norway-Vestfold
    • NO08 - Norway-Telemark
    • NO09 - Norway-Aust-Agder
    • NO10 - Norway-Vest-Agder
    • NO11 - Norway-Rogaland
    • NO12 - Norway-Nordaland
    • NO14 - Norway-Sogn og Fjordane
    • NO15 - Norway-More og Romsdal
    • NO16 - Norway-Sor-Trondelag
    • NO17 - Norway-Nord-Trondelag
    • NO18 - Norway-Nordland
    • NO19 - Norway-Troms
    • NO20 - Norway-Finnmark
    • SEAB - Sweden-Stockholms lan
    • SEAC - Sweden-Vasterbottens lan
    • SEBD - Sweden-Norrbottens lan
    • SEC - Sweden-Uppsala lan
    • SED - Sweden-Sodermanlands lan
    • SEE - Sweden-ostergotlands lan
    • SEF - Sweden-Jonkopings lan
    • SEG - Sweden-Kronoborgs lan
    • SEH - Sweden-Kalmar lan
    • SEI - Sweden-Gotlands lan
    • SEK - Sweden-Blekinge lan
    • SEM - Sweden-Skåne lan
    • SEN - Sweden-Hallands lan
    • SEO - Sweden-Vastra Gotalands lan
    • SES - Sweden-Varmlands lan
    • SET - Sweden-orebro lan
    • SEU - Sweden-Vastmanlands lan
    • SEW - Sweden-Dalarnes lan
    • SEX - Sweden-Gavleborgs lan
    • SEY - Sweden-Vasternorrlands lan
    • SEZ - Sweden-Jamtlands lan
    • CHAG - Switzerland-Aargau
    • CHAR - Switzerland-Appenzell Ausser-Rhoden
    • CHAI - Switzerland-Appenzell Inner-Rhoden
    • CHBL - Switzerland-Basel-Landschaft
    • CHBS - Switzerland-Basel-Stadt
    • CHBE - Switzerland-Bern
    • CHFR - Switzerland-Fribourg
    • CHGE - Switzerland-Genève
    • CHGL - Switzerland-Glarus
    • CHGR - Switzerland-Graubunden
    • CHJU - Switzerland-Jura
    • CHLU - Switzerland-Luzern
    • CHNE - Switzerland-Neuchatel
    • CHNW - Switzerland-Nidwalden
    • CHOW - Switzerland-Obwalden
    • CHSG - Switzerland-St Gallen
    • CHSH - Switzerland-Schaffhausen
    • CHSZ - Switzerland-Schwyz
    • CHSO - Switzerland-Solothurn
    • CHTG - Switzerland-Thurgau
    • CHTI - Switzerland-Ticino
    • CHUR - Switzerland-Uri
    • CHVS - Switzerland-Valais
    • CHVD - Switzerland-Vaud
    • CHZG - Switzerland-Zug
    • CHZH - Switzerland-Zurich
    • TR01 - Turkey-Adana
    • TR02 - Turkey-Adiyaman
    • TR03 - Turkey-Afyon
    • TR04 - Turkey-Agri
    • TR05 - Turkey-Amasya
    • TR06 - Turkey-Ankara
    • TR07 - Turkey-Antalya
    • TR08 - Turkey-Artvin
    • TR09 - Turkey-Aydin
    • TR10 - Turkey-Balikesir
    • TR11 - Turkey-Bilecik
    • TR12 - Turkey-Bingol
    • TR13 - Turkey-Bitlis
    • TR14 - Turkey-Bolu
    • TR15 - Turkey-Burdur
    • TR16 - Turkey-Bursa
    • TR17 - Turkey-Canakkale
    • TR18 - Turkey-Cankiri
    • TR19 - Turkey-Corum
    • TR20 - Turkey-Denizli
    • TR21 - Turkey-Diyarbakir
    • TR22 - Turkey-Edirne
    • TR23 - Turkey-Elazig
    • TR24 - Turkey-Erzincan
    • TR25 - Turkey-Erzurum
    • TR26 - Turkey-Eskisehir
    • TR27 - Turkey-Gaziantep
    • TR28 - Turkey-Giresun
    • TR29 - Turkey-Gumushane
    • TR30 - Turkey-Hakkari
    • TR31 - Turkey-Hatay
    • TR32 - Turkey-Isparta
    • TR33 - Turkey-Icel
    • TR34 - Turkey-Istanbul
    • TR35 - Turkey-Izmir
    • TR36 - Turkey-Kars
    • TR37 - Turkey-Kastamonu
    • TR38 - Turkey-Kayseri
    • TR39 - Turkey-Kirklareli
    • TR40 - Turkey-Kirsehir
    • TR41 - Turkey-Kocaeli
    • TR42 - Turkey-Konya
    • TR43 - Turkey-Kutahya
    • TR44 - Turkey-Malatya
    • TR45 - Turkey-Manisa
    • TR46 - Turkey-Kahramanmaras
    • TR47 - Turkey-Mardin
    • TR48 - Turkey-Mugla
    • TR49 - Turkey-Mus
    • TR50 - Turkey-Nevsehir
    • TR51 - Turkey-Nigde
    • TR52 - Turkey-Ordu
    • TR53 - Turkey-Rize
    • TR54 - Turkey-Sakarya
    • TR55 - Turkey-Samsun
    • TR56 - Turkey-Siirt
    • TR57 - Turkey-Sinop
    • TR58 - Turkey-Sivas
    • TR59 - Turkey-Tekirdag
    • TR60 - Turkey-Tokat
    • TR61 - Turkey-Trabzon
    • TR62 - Turkey-Tunceli
    • TR63 - Turkey-Sanliurfa
    • TR64 - Turkey-Usak
    • TR65 - Turkey-Van
    • TR66 - Turkey-Yozgat
    • TR67 - Turkey-Zonguldak
    • TR68 - Turkey-Aksaray
    • TR69 - Turkey-Bayburt
    • TR70 - Turkey-Karaman
    • TR71 - Turkey-Kirkkale
    • TR72 - Turkey-Batman
    • TR73 - Turkey-Sirnak
    • TR74 - Turkey-Bartin
    • TR75 - Turkey-Ardahan
    • TR76 - Turkey-Igdir
    • TR77 - Turkey-Yalova
    • TR78 - Turkey-Karabuk
    • TR79 - Turkey-Kilis
    • TR80 - Turkey-Osmaniye
    • GBANT - United Kingdom-Antrim
    • GBARD - United Kingdom-Ards
    • GBARM - United Kingdom-Armagh
    • GBAVN - United Kingdom-Avon
    • GBBDF - United Kingdom-Bedfordshire
    • GBBFS - United Kingdom-Belfast
    • GBBKM - United Kingdom-Buckinghamshire
    • GBBLA - United Kingdom-Ballymena
    • GBBLY - United Kingdom-Ballymoney
    • GBBNB - United Kingdom-Banbridge
    • GBBOR - United Kingdom-Borders Region
    • GBBRK - United Kingdom-Berkshire
    • GBCAM - United Kingdom-Cambridgeshire
    • GBCEN - United Kingdom-Central Region
    • GBCGV - United Kingdom-Craigavon
    • GBCHS - United Kingdom-Cheshire
    • GBCKF - United Kingdom-Carrickfergus
    • GBCKT - United Kingdom-Cookstown
    • GBCLR - United Kingdom-Coleraine
    • GBCLV - United Kingdom-Cleveland
    • GBCMA - United Kingdom-Cumbria
    • GBCON - United Kingdom-Cornwall
    • GBCSR - United Kingdom-Castlereagh
    • GBCWD - United Kingdom-Clwyd
    • GBDBY - United Kingdom-Derbyshire
    • GBDFD - United Kingdom-Dyfed
    • GBDGN - United Kingdom-Dungannon
    • GBDGY - United Kingdom-Dumfries And Galloway Region
    • GBDOR - United Kingdom-Dorset
    • GBDOW - United Kingdom-Down
    • GBDRY - United Kingdom-Derry
    • GBDUR - United Kingdom-Durham
    • GBDVV - United Kingdom-Devon
    • GBESS - United Kingdom-Essex
    • GBESX - United Kingdom-East Sussex
    • GBFER - United Kingdom-Fermanagh
    • GBFIF - United Kingdom-Fife Region
    • GBGLS - United Kingdom-Gloucestershire
    • GBGMP - United Kingdom-Grampian Region
    • GBGNT - United Kingdom-Gwent
    • GBGSY - United Kingdom-Guernsey
    • GBGTL - United Kingdom-Greater London
    • GBGTM - United Kingdom-Greater Manchester
    • GBGWN - United Kingdom-Gwynedd
    • GBHAM - United Kingdom-Hampshire
    • GBHLD - United Kingdom-Highland Region
    • GBHRT - United Kingdom-Hertfordshire
    • GBHUM - United Kingdom-Humberside
    • GBHWR - United Kingdom-Hereford and Worcester
    • GBIOM - United Kingdom-Isle of Man
    • GBIOS - United Kingdom-Isles of Scilly
    • GBIOW - United Kingdom-Isle of Wight
    • GBJSY - United Kingdom-Jersey
    • GBKEN - United Kingdom-Kent
    • GBLAN - United Kingdom-Lancashire
    • GBLEC - United Kingdom-Leicestershire
    • GBLIN - United Kingdom-Lincolnshire
    • GBLMV - United Kingdom-Limavady
    • GBLRN - United Kingdom-Larne
    • GBLSB - United Kingdom-Lisburn
    • GBLTN - United Kingdom-Lothian Region
    • GBMFT - United Kingdom-Magherafelt
    • GBMGM - United Kingdom-Mid Glamorgan
    • GBMSY - United Kingdom-Merseyside
    • GBMYL - United Kingdom-Moyle
    • GBNBL - United Kingdom-Northumberland
    • GBNDN - United Kingdom-North Down
    • GBNFK - United Kingdom-Norfolk
    • GBNTA - United Kingdom-Newtonabbey
    • GBNTH - United Kingdom-Northamptonshire
    • GBNTT - United Kingdom-Nottinghamshire
    • GBNYK - United Kingdom-North Yorkshire
    • GBNYM - United Kingdom-Newry and Mourne
    • GBOMH - United Kingdom-Omagh
    • GBORK - United Kingdom-Orkney
    • GBOXF - United Kingdom-Oxfordshire
    • GBPOW - United Kingdom-Powys
    • GBSFK - United Kingdom-Suffolk
    • GBSGM - United Kingdom-South Glamorgan
    • GBSHR - United Kingdom-Shropshire
    • GBSOM - United Kingdom-Somerset
    • GBSRY - United Kingdom-Surrey
    • GBSTB - United Kingdom-Strabane
    • GBSTD - United Kingdom-Strathclyde Region
    • GBSTS - United Kingdom-Staffordshire
    • GBSYK - United Kingdom-South Yorkshire
    • GBTAY - United Kingdom-Tayside Region
    • GBTWR - United Kingdom-Tyne and Wear
    • GBWAR - United Kingdom-Warwickshire
    • GBWGM - United Kingdom-West Glamorgan
    • GBWIL - United Kingdom-Wiltshire
    • GBWIS - United Kingdom-Western Isles
    • GBWMD - United Kingdom-West Midlands
    • GBWSX - United Kingdom-West Sussex
    • GBWYK - United Kingdom-West Yorkshire
    • GBZET - United Kingdom-Shetland (Zetland)
    • USAK - United States-Alaska
    • USAL - United States-Alabama
    • USAR - United States-Arkansas
    • USAS - United States-American Samoa (see also separate entry under AS)
    • USAZ - United States-Arizona
    • USCA - United States-California
    • USCO - United States-Colorado
    • USCT - United States-Connecticut
    • USDC - United States-District of Columbia
    • USDE - United States-Delaware
    • USFL - United States-Florida
    • USGA - United States-Georgia
    • USGU - United States-Guam (see also separate entry under GU)
    • USHI - United States-Hawaii
    • USIA - United States-Iowa
    • USID - United States-Idaho
    • USIL - United States-Illinois
    • USIN - United States-Indiana
    • USKS - United States-Kansas
    • USKY - United States-Kentucky
    • USLA - United States-Louisiana
    • USMA - United States-Massachusetts
    • USMD - United States-Maryland
    • USME - United States-Maine
    • USMI - United States-Michigan
    • USMN - United States-Minnesota
    • USMO - United States-Missouri
    • USMP - United States-Northern Mariana Islands (see also separate entry MP)
    • USMS - United States-Mississippi
    • USMT - United States-Montana
    • USNC - United States-North Carolina
    • USND - United States-North Dakota
    • USNE - United States-Nebraska
    • USNH - United States-New Hampshire
    • USNJ - United States-New Jersey
    • USNM - United States-New Mexico
    • USNV - United States-Nevada
    • USNY - United States-New York
    • USOH - United States-Ohio
    • USOK - United States-Oklahoma
    • USOR - United States-Oregon
    • USPA - United States-Pennsylvania
    • USPR - United States-Puerto Rico (see also separate entry under PR)
    • USRI - United States-Rhode Island
    • USSC - United States-South Carolina
    • USSD - United States-South Dakota
    • USTN - United States-Tennessee
    • USTX - United States-Texas
    • USUM - United States-U.S. Minor Outlying Islands (cf. separate entry UM)
    • USUT - United States-Utah
    • USVA - United States-Virginia
    • USVI - United States-Virgin Islands of the U.S. (see also separate entry VI)
    • USVT - United States-Vermont
    • USWA - United States-Washington
    • USWI - United States-Wisconsin
    • USWV - United States-West Virginia
    • USWY - United States-Wyoming
    • UM67 - US Minor Outlying Islands-Johnston Atoll (ISO reserved code = JT)
    • UM71 - US Minor Outlying Islands-Midway Islands (ISO reserved code = I)
    • UM76 - US Minor Outlying Islands-Navassa Island (ISO reserved code = NV)
    • UM79 - US Minor Outlying Islands-Wake Island (ISO reserved code = WK)
    • UM81 - US Minor Outlying Islands-Baker Island
    • UM84 - US Minor Outlying Islands-Howland Island
    • UM86 - US Minor Outlying Islands-Jarvis Island
    • UM89 - US Minor Outlying Islands-Kingman Reef
    • UM95 - US Minor Outlying Islands-Palmyra Atoll

[^]Code Fragment

    <xsd:simpleType name="RegionCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="ARA">
        <xsd:enumeration value="ARB">
        <xsd:enumeration value="ARC">
        <xsd:enumeration value="ARD">
        <xsd:enumeration value="ARE">
        <xsd:enumeration value="ARF">
        <xsd:enumeration value="ARG">
        <xsd:enumeration value="ARH">
        <xsd:enumeration value="ARJ">
        <xsd:enumeration value="ARK">
        <xsd:enumeration value="ARL">
        <xsd:enumeration value="ARM">
        <xsd:enumeration value="ARN">
        <xsd:enumeration value="ARP">
        <xsd:enumeration value="ARQ">
        <xsd:enumeration value="ARR">
        <xsd:enumeration value="ARS">
        <xsd:enumeration value="ART">
        <xsd:enumeration value="ARU">
        <xsd:enumeration value="ARV">
        <xsd:enumeration value="ARW">
        <xsd:enumeration value="ARX">
        <xsd:enumeration value="ARY">
        <xsd:enumeration value="ARZ">
        <xsd:enumeration value="AUCT">
        <xsd:enumeration value="AUNS">
        <xsd:enumeration value="AUNT">
        <xsd:enumeration value="AUQL">
        <xsd:enumeration value="AUSA">
        <xsd:enumeration value="AUTS">
        <xsd:enumeration value="AUVI">
        <xsd:enumeration value="AUWA">
        <xsd:enumeration value="BEVAN">
        <xsd:enumeration value="BEVBR">
        <xsd:enumeration value="BEVLI">
        <xsd:enumeration value="BEVOV">
        <xsd:enumeration value="BEVWV">
        <xsd:enumeration value="BEWBR">
        <xsd:enumeration value="BEWHT">
        <xsd:enumeration value="BEWLG">
        <xsd:enumeration value="BEWLX">
        <xsd:enumeration value="BEWNA">
        <xsd:enumeration value="BRAC">
        <xsd:enumeration value="BRAL">
        <xsd:enumeration value="BRAM">
        <xsd:enumeration value="BRAP">
        <xsd:enumeration value="BRBA">
        <xsd:enumeration value="BRCE">
        <xsd:enumeration value="BRDF">
        <xsd:enumeration value="BRES">
        <xsd:enumeration value="BRGO">
        <xsd:enumeration value="BRMA">
        <xsd:enumeration value="BRMT">
        <xsd:enumeration value="BRMS">
        <xsd:enumeration value="BRMG">
        <xsd:enumeration value="BRPA">
        <xsd:enumeration value="BRPB">
        <xsd:enumeration value="BRPE">
        <xsd:enumeration value="BRPI">
        <xsd:enumeration value="BRPR">
        <xsd:enumeration value="BRRJ">
        <xsd:enumeration value="BRRN">
        <xsd:enumeration value="BRRO">
        <xsd:enumeration value="BRRR">
        <xsd:enumeration value="BRRS">
        <xsd:enumeration value="BRSC">
        <xsd:enumeration value="BRSE">
        <xsd:enumeration value="BRSP">
        <xsd:enumeration value="BRTO">
        <xsd:enumeration value="CAAB">
        <xsd:enumeration value="CABC">
        <xsd:enumeration value="CAMB">
        <xsd:enumeration value="CANB">
        <xsd:enumeration value="CANF">
        <xsd:enumeration value="CANS">
        <xsd:enumeration value="CANT">
        <xsd:enumeration value="CANU">
        <xsd:enumeration value="CAON">
        <xsd:enumeration value="CAPE">
        <xsd:enumeration value="CAQC">
        <xsd:enumeration value="CASK">
        <xsd:enumeration value="CAYT">
        <xsd:enumeration value="CLAI">
        <xsd:enumeration value="CLAN">
        <xsd:enumeration value="CLAR">
        <xsd:enumeration value="CLAT">
        <xsd:enumeration value="CLBI">
        <xsd:enumeration value="CLCO">
        <xsd:enumeration value="CLLI">
        <xsd:enumeration value="CLLL">
        <xsd:enumeration value="CLMA">
        <xsd:enumeration value="CLML">
        <xsd:enumeration value="CLRM">
        <xsd:enumeration value="CLTA">
        <xsd:enumeration value="CLVS">
        <xsd:enumeration value="CN11">
        <xsd:enumeration value="CN12">
        <xsd:enumeration value="CN13">
        <xsd:enumeration value="CN14">
        <xsd:enumeration value="CN15">
        <xsd:enumeration value="CN21">
        <xsd:enumeration value="CN22">
        <xsd:enumeration value="CN23">
        <xsd:enumeration value="CN31">
        <xsd:enumeration value="CN32">
        <xsd:enumeration value="CN33">
        <xsd:enumeration value="CN34">
        <xsd:enumeration value="CN35">
        <xsd:enumeration value="CN36">
        <xsd:enumeration value="CN37">
        <xsd:enumeration value="CN41">
        <xsd:enumeration value="CN42">
        <xsd:enumeration value="CN43">
        <xsd:enumeration value="CN44">
        <xsd:enumeration value="CN45">
        <xsd:enumeration value="CN46">
        <xsd:enumeration value="CN51">
        <xsd:enumeration value="CN52">
        <xsd:enumeration value="CN53">
        <xsd:enumeration value="CN54">
        <xsd:enumeration value="CN61">
        <xsd:enumeration value="CN62">
        <xsd:enumeration value="CN63">
        <xsd:enumeration value="CN64">
        <xsd:enumeration value="CN65">
        <xsd:enumeration value="CN71">
        <xsd:enumeration value="CN91">
        <xsd:enumeration value="CN92">
        <xsd:enumeration value="FIAL">
        <xsd:enumeration value="FIES">
        <xsd:enumeration value="FIIS">
        <xsd:enumeration value="FILL">
        <xsd:enumeration value="FILS">
        <xsd:enumeration value="FIOL">
        <xsd:enumeration value="FR01">
        <xsd:enumeration value="FR02">
        <xsd:enumeration value="FR2A">
        <xsd:enumeration value="FR2B">
        <xsd:enumeration value="FR03">
        <xsd:enumeration value="FR04">
        <xsd:enumeration value="FR05">
        <xsd:enumeration value="FR06">
        <xsd:enumeration value="FR07">
        <xsd:enumeration value="FR08">
        <xsd:enumeration value="FR09">
        <xsd:enumeration value="FR10">
        <xsd:enumeration value="FR11">
        <xsd:enumeration value="FR12">
        <xsd:enumeration value="FR13">
        <xsd:enumeration value="FR14">
        <xsd:enumeration value="FR15">
        <xsd:enumeration value="FR16">
        <xsd:enumeration value="FR17">
        <xsd:enumeration value="FR18">
        <xsd:enumeration value="FR19">
        <xsd:enumeration value="FR21">
        <xsd:enumeration value="FR22">
        <xsd:enumeration value="FR23">
        <xsd:enumeration value="FR24">
        <xsd:enumeration value="FR25">
        <xsd:enumeration value="FR26">
        <xsd:enumeration value="FR27">
        <xsd:enumeration value="FR28">
        <xsd:enumeration value="FR29">
        <xsd:enumeration value="FR30">
        <xsd:enumeration value="FR31">
        <xsd:enumeration value="FR32">
        <xsd:enumeration value="FR33">
        <xsd:enumeration value="FR34">
        <xsd:enumeration value="FR35">
        <xsd:enumeration value="FR36">
        <xsd:enumeration value="FR37">
        <xsd:enumeration value="FR38">
        <xsd:enumeration value="FR39">
        <xsd:enumeration value="FR40">
        <xsd:enumeration value="FR41">
        <xsd:enumeration value="FR42">
        <xsd:enumeration value="FR43">
        <xsd:enumeration value="FR44">
        <xsd:enumeration value="FR45">
        <xsd:enumeration value="FR46">
        <xsd:enumeration value="FR47">
        <xsd:enumeration value="FR48">
        <xsd:enumeration value="FR49">
        <xsd:enumeration value="FR50">
        <xsd:enumeration value="FR51">
        <xsd:enumeration value="FR52">
        <xsd:enumeration value="FR53">
        <xsd:enumeration value="FR54">
        <xsd:enumeration value="FR55">
        <xsd:enumeration value="FR56">
        <xsd:enumeration value="FR57">
        <xsd:enumeration value="FR58">
        <xsd:enumeration value="FR59">
        <xsd:enumeration value="FR60">
        <xsd:enumeration value="FR61">
        <xsd:enumeration value="FR62">
        <xsd:enumeration value="FR63">
        <xsd:enumeration value="FR64">
        <xsd:enumeration value="FR65">
        <xsd:enumeration value="FR66">
        <xsd:enumeration value="FR67">
        <xsd:enumeration value="FR68">
        <xsd:enumeration value="FR69">
        <xsd:enumeration value="FR70">
        <xsd:enumeration value="FR71">
        <xsd:enumeration value="FR72">
        <xsd:enumeration value="FR73">
        <xsd:enumeration value="FR74">
        <xsd:enumeration value="FR75">
        <xsd:enumeration value="FR76">
        <xsd:enumeration value="FR77">
        <xsd:enumeration value="FR78">
        <xsd:enumeration value="FR79">
        <xsd:enumeration value="FR80">
        <xsd:enumeration value="FR81">
        <xsd:enumeration value="FR82">
        <xsd:enumeration value="FR83">
        <xsd:enumeration value="FR84">
        <xsd:enumeration value="FR85">
        <xsd:enumeration value="FR86">
        <xsd:enumeration value="FR87">
        <xsd:enumeration value="FR88">
        <xsd:enumeration value="FR89">
        <xsd:enumeration value="FR90">
        <xsd:enumeration value="FR91">
        <xsd:enumeration value="FR92">
        <xsd:enumeration value="FR93">
        <xsd:enumeration value="FR94">
        <xsd:enumeration value="FR95">
        <xsd:enumeration value="DEBE">
        <xsd:enumeration value="DEBR">
        <xsd:enumeration value="DEBW">
        <xsd:enumeration value="DEBY">
        <xsd:enumeration value="DEHB">
        <xsd:enumeration value="DEHE">
        <xsd:enumeration value="DEHH">
        <xsd:enumeration value="DEMV">
        <xsd:enumeration value="DENI">
        <xsd:enumeration value="DENW">
        <xsd:enumeration value="DERP">
        <xsd:enumeration value="DEST">
        <xsd:enumeration value="DESH">
        <xsd:enumeration value="DESL">
        <xsd:enumeration value="DESN">
        <xsd:enumeration value="DETH">
        <xsd:enumeration value="ITAG">
        <xsd:enumeration value="ITAL">
        <xsd:enumeration value="ITAN">
        <xsd:enumeration value="ITAO">
        <xsd:enumeration value="ITAP">
        <xsd:enumeration value="ITAQ">
        <xsd:enumeration value="ITAR">
        <xsd:enumeration value="ITAT">
        <xsd:enumeration value="ITAV">
        <xsd:enumeration value="ITBA">
        <xsd:enumeration value="ITBG">
        <xsd:enumeration value="ITBI">
        <xsd:enumeration value="ITBL">
        <xsd:enumeration value="ITBN">
        <xsd:enumeration value="ITBO">
        <xsd:enumeration value="ITBR">
        <xsd:enumeration value="ITBS">
        <xsd:enumeration value="ITBZ">
        <xsd:enumeration value="ITCA">
        <xsd:enumeration value="ITCB">
        <xsd:enumeration value="ITCE">
        <xsd:enumeration value="ITCH">
        <xsd:enumeration value="ITCL">
        <xsd:enumeration value="ITCN">
        <xsd:enumeration value="ITCO">
        <xsd:enumeration value="ITCR">
        <xsd:enumeration value="ITCS">
        <xsd:enumeration value="ITCT">
        <xsd:enumeration value="ITCZ">
        <xsd:enumeration value="ITEN">
        <xsd:enumeration value="ITFE">
        <xsd:enumeration value="ITFG">
        <xsd:enumeration value="ITFI">
        <xsd:enumeration value="ITFO">
        <xsd:enumeration value="ITFR">
        <xsd:enumeration value="ITGE">
        <xsd:enumeration value="ITGO">
        <xsd:enumeration value="ITGR">
        <xsd:enumeration value="ITIM">
        <xsd:enumeration value="ITIS">
        <xsd:enumeration value="ITKR">
        <xsd:enumeration value="ITLC">
        <xsd:enumeration value="ITLE">
        <xsd:enumeration value="ITLI">
        <xsd:enumeration value="ITLO">
        <xsd:enumeration value="ITLT">
        <xsd:enumeration value="ITLU">
        <xsd:enumeration value="ITMC">
        <xsd:enumeration value="ITME">
        <xsd:enumeration value="ITMI">
        <xsd:enumeration value="ITMN">
        <xsd:enumeration value="ITMO">
        <xsd:enumeration value="ITMS">
        <xsd:enumeration value="ITMT">
        <xsd:enumeration value="ITNA">
        <xsd:enumeration value="ITNO">
        <xsd:enumeration value="ITNU">
        <xsd:enumeration value="ITOR">
        <xsd:enumeration value="ITPA">
        <xsd:enumeration value="ITPC">
        <xsd:enumeration value="ITPD">
        <xsd:enumeration value="ITPE">
        <xsd:enumeration value="ITPG">
        <xsd:enumeration value="ITPI">
        <xsd:enumeration value="ITPN">
        <xsd:enumeration value="ITPO">
        <xsd:enumeration value="ITPR">
        <xsd:enumeration value="ITPS">
        <xsd:enumeration value="ITPT">
        <xsd:enumeration value="ITPV">
        <xsd:enumeration value="ITPZ">
        <xsd:enumeration value="ITRA">
        <xsd:enumeration value="ITRC">
        <xsd:enumeration value="ITRE">
        <xsd:enumeration value="ITRG">
        <xsd:enumeration value="ITRI">
        <xsd:enumeration value="ITRM">
        <xsd:enumeration value="ITRN">
        <xsd:enumeration value="ITRO">
        <xsd:enumeration value="ITRV">
        <xsd:enumeration value="ITSA">
        <xsd:enumeration value="ITSI">
        <xsd:enumeration value="ITSO">
        <xsd:enumeration value="ITSP">
        <xsd:enumeration value="ITSR">
        <xsd:enumeration value="ITSS">
        <xsd:enumeration value="ITSV">
        <xsd:enumeration value="ITTA">
        <xsd:enumeration value="ITTE">
        <xsd:enumeration value="ITTN">
        <xsd:enumeration value="ITTO">
        <xsd:enumeration value="ITTP">
        <xsd:enumeration value="ITTR">
        <xsd:enumeration value="ITTS">
        <xsd:enumeration value="ITTV">
        <xsd:enumeration value="ITUD">
        <xsd:enumeration value="ITVA">
        <xsd:enumeration value="ITVC">
        <xsd:enumeration value="ITVE">
        <xsd:enumeration value="ITVI">
        <xsd:enumeration value="ITVR">
        <xsd:enumeration value="ITVT">
        <xsd:enumeration value="ITVV">
        <xsd:enumeration value="JP01">
        <xsd:enumeration value="JP02">
        <xsd:enumeration value="JP03">
        <xsd:enumeration value="JP04">
        <xsd:enumeration value="JP05">
        <xsd:enumeration value="JP06">
        <xsd:enumeration value="JP07">
        <xsd:enumeration value="JP08">
        <xsd:enumeration value="JP09">
        <xsd:enumeration value="JP10">
        <xsd:enumeration value="JP11">
        <xsd:enumeration value="JP12">
        <xsd:enumeration value="JP13">
        <xsd:enumeration value="JP14">
        <xsd:enumeration value="JP15">
        <xsd:enumeration value="JP16">
        <xsd:enumeration value="JP17">
        <xsd:enumeration value="JP18">
        <xsd:enumeration value="JP19">
        <xsd:enumeration value="JP20">
        <xsd:enumeration value="JP21">
        <xsd:enumeration value="JP22">
        <xsd:enumeration value="JP23">
        <xsd:enumeration value="JP24">
        <xsd:enumeration value="JP25">
        <xsd:enumeration value="JP26">
        <xsd:enumeration value="JP27">
        <xsd:enumeration value="JP28">
        <xsd:enumeration value="JP29">
        <xsd:enumeration value="JP30">
        <xsd:enumeration value="JP31">
        <xsd:enumeration value="JP32">
        <xsd:enumeration value="JP33">
        <xsd:enumeration value="JP34">
        <xsd:enumeration value="JP35">
        <xsd:enumeration value="JP36">
        <xsd:enumeration value="JP37">
        <xsd:enumeration value="JP38">
        <xsd:enumeration value="JP39">
        <xsd:enumeration value="JP40">
        <xsd:enumeration value="JP41">
        <xsd:enumeration value="JP42">
        <xsd:enumeration value="JP43">
        <xsd:enumeration value="JP44">
        <xsd:enumeration value="JP45">
        <xsd:enumeration value="JP46">
        <xsd:enumeration value="JP47">
        <xsd:enumeration value="MXAGU">
        <xsd:enumeration value="MXBCN">
        <xsd:enumeration value="MXBCS">
        <xsd:enumeration value="MXCAM">
        <xsd:enumeration value="MXCHH">
        <xsd:enumeration value="MXCHP">
        <xsd:enumeration value="MXCOA">
        <xsd:enumeration value="MXCOL">
        <xsd:enumeration value="MXDF">
        <xsd:enumeration value="MXDUR">
        <xsd:enumeration value="MXGRO">
        <xsd:enumeration value="MXGUA">
        <xsd:enumeration value="MXHID">
        <xsd:enumeration value="MXJAL">
        <xsd:enumeration value="MXMEX">
        <xsd:enumeration value="MXMIC">
        <xsd:enumeration value="MXMOR">
        <xsd:enumeration value="MXNAY">
        <xsd:enumeration value="MXNLE">
        <xsd:enumeration value="MXOAX">
        <xsd:enumeration value="MXPUE">
        <xsd:enumeration value="MXQUE">
        <xsd:enumeration value="MXROO">
        <xsd:enumeration value="MXSIN">
        <xsd:enumeration value="MXSLP">
        <xsd:enumeration value="MXSON">
        <xsd:enumeration value="MXTAB">
        <xsd:enumeration value="MXTAM">
        <xsd:enumeration value="MXTLA">
        <xsd:enumeration value="MXVER">
        <xsd:enumeration value="MXYUC">
        <xsd:enumeration value="MXZAC">
        <xsd:enumeration value="NZAUK">
        <xsd:enumeration value="NZBOP">
        <xsd:enumeration value="NZCAN">
        <xsd:enumeration value="NZGIS">
        <xsd:enumeration value="NZHKB">
        <xsd:enumeration value="NZMBH">
        <xsd:enumeration value="NZMWT">
        <xsd:enumeration value="NZNSN">
        <xsd:enumeration value="NZNTL">
        <xsd:enumeration value="NZOTA">
        <xsd:enumeration value="NZSTL">
        <xsd:enumeration value="NZTAS">
        <xsd:enumeration value="NZTKI">
        <xsd:enumeration value="NZWGN">
        <xsd:enumeration value="NZWKO">
        <xsd:enumeration value="NZWTC">
        <xsd:enumeration value="NO01">
        <xsd:enumeration value="NO02">
        <xsd:enumeration value="NO03">
        <xsd:enumeration value="NO04">
        <xsd:enumeration value="NO05">
        <xsd:enumeration value="NO06">
        <xsd:enumeration value="NO07">
        <xsd:enumeration value="NO08">
        <xsd:enumeration value="NO09">
        <xsd:enumeration value="NO10">
        <xsd:enumeration value="NO11">
        <xsd:enumeration value="NO12">
        <xsd:enumeration value="NO14">
        <xsd:enumeration value="NO15">
        <xsd:enumeration value="NO16">
        <xsd:enumeration value="NO17">
        <xsd:enumeration value="NO18">
        <xsd:enumeration value="NO19">
        <xsd:enumeration value="NO20">
        <xsd:enumeration value="SEAB">
        <xsd:enumeration value="SEAC">
        <xsd:enumeration value="SEBD">
        <xsd:enumeration value="SEC">
        <xsd:enumeration value="SED">
        <xsd:enumeration value="SEE">
        <xsd:enumeration value="SEF">
        <xsd:enumeration value="SEG">
        <xsd:enumeration value="SEH">
        <xsd:enumeration value="SEI">
        <xsd:enumeration value="SEK">
        <xsd:enumeration value="SEM">
        <xsd:enumeration value="SEN">
        <xsd:enumeration value="SEO">
        <xsd:enumeration value="SES">
        <xsd:enumeration value="SET">
        <xsd:enumeration value="SEU">
        <xsd:enumeration value="SEW">
        <xsd:enumeration value="SEX">
        <xsd:enumeration value="SEY">
        <xsd:enumeration value="SEZ">
        <xsd:enumeration value="CHAG">
        <xsd:enumeration value="CHAR">
        <xsd:enumeration value="CHAI">
        <xsd:enumeration value="CHBL">
        <xsd:enumeration value="CHBS">
        <xsd:enumeration value="CHBE">
        <xsd:enumeration value="CHFR">
        <xsd:enumeration value="CHGE">
        <xsd:enumeration value="CHGL">
        <xsd:enumeration value="CHGR">
        <xsd:enumeration value="CHJU">
        <xsd:enumeration value="CHLU">
        <xsd:enumeration value="CHNE">
        <xsd:enumeration value="CHNW">
        <xsd:enumeration value="CHOW">
        <xsd:enumeration value="CHSG">
        <xsd:enumeration value="CHSH">
        <xsd:enumeration value="CHSZ">
        <xsd:enumeration value="CHSO">
        <xsd:enumeration value="CHTG">
        <xsd:enumeration value="CHTI">
        <xsd:enumeration value="CHUR">
        <xsd:enumeration value="CHVS">
        <xsd:enumeration value="CHVD">
        <xsd:enumeration value="CHZG">
        <xsd:enumeration value="CHZH">
        <xsd:enumeration value="TR01">
        <xsd:enumeration value="TR02">
        <xsd:enumeration value="TR03">
        <xsd:enumeration value="TR04">
        <xsd:enumeration value="TR05">
        <xsd:enumeration value="TR06">
        <xsd:enumeration value="TR07">
        <xsd:enumeration value="TR08">
        <xsd:enumeration value="TR09">
        <xsd:enumeration value="TR10">
        <xsd:enumeration value="TR11">
        <xsd:enumeration value="TR12">
        <xsd:enumeration value="TR13">
        <xsd:enumeration value="TR14">
        <xsd:enumeration value="TR15">
        <xsd:enumeration value="TR16">
        <xsd:enumeration value="TR17">
        <xsd:enumeration value="TR18">
        <xsd:enumeration value="TR19">
        <xsd:enumeration value="TR20">
        <xsd:enumeration value="TR21">
        <xsd:enumeration value="TR22">
        <xsd:enumeration value="TR23">
        <xsd:enumeration value="TR24">
        <xsd:enumeration value="TR25">
        <xsd:enumeration value="TR26">
        <xsd:enumeration value="TR27">
        <xsd:enumeration value="TR28">
        <xsd:enumeration value="TR29">
        <xsd:enumeration value="TR30">
        <xsd:enumeration value="TR31">
        <xsd:enumeration value="TR32">
        <xsd:enumeration value="TR33">
        <xsd:enumeration value="TR34">
        <xsd:enumeration value="TR35">
        <xsd:enumeration value="TR36">
        <xsd:enumeration value="TR37">
        <xsd:enumeration value="TR38">
        <xsd:enumeration value="TR39">
        <xsd:enumeration value="TR40">
        <xsd:enumeration value="TR41">
        <xsd:enumeration value="TR42">
        <xsd:enumeration value="TR43">
        <xsd:enumeration value="TR44">
        <xsd:enumeration value="TR45">
        <xsd:enumeration value="TR46">
        <xsd:enumeration value="TR47">
        <xsd:enumeration value="TR48">
        <xsd:enumeration value="TR49">
        <xsd:enumeration value="TR50">
        <xsd:enumeration value="TR51">
        <xsd:enumeration value="TR52">
        <xsd:enumeration value="TR53">
        <xsd:enumeration value="TR54">
        <xsd:enumeration value="TR55">
        <xsd:enumeration value="TR56">
        <xsd:enumeration value="TR57">
        <xsd:enumeration value="TR58">
        <xsd:enumeration value="TR59">
        <xsd:enumeration value="TR60">
        <xsd:enumeration value="TR61">
        <xsd:enumeration value="TR62">
        <xsd:enumeration value="TR63">
        <xsd:enumeration value="TR64">
        <xsd:enumeration value="TR65">
        <xsd:enumeration value="TR66">
        <xsd:enumeration value="TR67">
        <xsd:enumeration value="TR68">
        <xsd:enumeration value="TR69">
        <xsd:enumeration value="TR70">
        <xsd:enumeration value="TR71">
        <xsd:enumeration value="TR72">
        <xsd:enumeration value="TR73">
        <xsd:enumeration value="TR74">
        <xsd:enumeration value="TR75">
        <xsd:enumeration value="TR76">
        <xsd:enumeration value="TR77">
        <xsd:enumeration value="TR78">
        <xsd:enumeration value="TR79">
        <xsd:enumeration value="TR80">
        <xsd:enumeration value="GBANT">
        <xsd:enumeration value="GBARD">
        <xsd:enumeration value="GBARM">
        <xsd:enumeration value="GBAVN">
        <xsd:enumeration value="GBBDF">
        <xsd:enumeration value="GBBFS">
        <xsd:enumeration value="GBBKM">
        <xsd:enumeration value="GBBLA">
        <xsd:enumeration value="GBBLY">
        <xsd:enumeration value="GBBNB">
        <xsd:enumeration value="GBBOR">
        <xsd:enumeration value="GBBRK">
        <xsd:enumeration value="GBCAM">
        <xsd:enumeration value="GBCEN">
        <xsd:enumeration value="GBCGV">
        <xsd:enumeration value="GBCHS">
        <xsd:enumeration value="GBCKF">
        <xsd:enumeration value="GBCKT">
        <xsd:enumeration value="GBCLR">
        <xsd:enumeration value="GBCLV">
        <xsd:enumeration value="GBCMA">
        <xsd:enumeration value="GBCON">
        <xsd:enumeration value="GBCSR">
        <xsd:enumeration value="GBCWD">
        <xsd:enumeration value="GBDBY">
        <xsd:enumeration value="GBDFD">
        <xsd:enumeration value="GBDGN">
        <xsd:enumeration value="GBDGY">
        <xsd:enumeration value="GBDOR">
        <xsd:enumeration value="GBDOW">
        <xsd:enumeration value="GBDRY">
        <xsd:enumeration value="GBDUR">
        <xsd:enumeration value="GBDVV">
        <xsd:enumeration value="GBESS">
        <xsd:enumeration value="GBESX">
        <xsd:enumeration value="GBFER">
        <xsd:enumeration value="GBFIF">
        <xsd:enumeration value="GBGLS">
        <xsd:enumeration value="GBGMP">
        <xsd:enumeration value="GBGNT">
        <xsd:enumeration value="GBGSY">
        <xsd:enumeration value="GBGTL">
        <xsd:enumeration value="GBGTM">
        <xsd:enumeration value="GBGWN">
        <xsd:enumeration value="GBHAM">
        <xsd:enumeration value="GBHLD">
        <xsd:enumeration value="GBHRT">
        <xsd:enumeration value="GBHUM">
        <xsd:enumeration value="GBHWR">
        <xsd:enumeration value="GBIOM">
        <xsd:enumeration value="GBIOS">
        <xsd:enumeration value="GBIOW">
        <xsd:enumeration value="GBJSY">
        <xsd:enumeration value="GBKEN">
        <xsd:enumeration value="GBLAN">
        <xsd:enumeration value="GBLEC">
        <xsd:enumeration value="GBLIN">
        <xsd:enumeration value="GBLMV">
        <xsd:enumeration value="GBLRN">
        <xsd:enumeration value="GBLSB">
        <xsd:enumeration value="GBLTN">
        <xsd:enumeration value="GBMFT">
        <xsd:enumeration value="GBMGM">
        <xsd:enumeration value="GBMSY">
        <xsd:enumeration value="GBMYL">
        <xsd:enumeration value="GBNBL">
        <xsd:enumeration value="GBNDN">
        <xsd:enumeration value="GBNFK">
        <xsd:enumeration value="GBNTA">
        <xsd:enumeration value="GBNTH">
        <xsd:enumeration value="GBNTT">
        <xsd:enumeration value="GBNYK">
        <xsd:enumeration value="GBNYM">
        <xsd:enumeration value="GBOMH">
        <xsd:enumeration value="GBORK">
        <xsd:enumeration value="GBOXF">
        <xsd:enumeration value="GBPOW">
        <xsd:enumeration value="GBSFK">
        <xsd:enumeration value="GBSGM">
        <xsd:enumeration value="GBSHR">
        <xsd:enumeration value="GBSOM">
        <xsd:enumeration value="GBSRY">
        <xsd:enumeration value="GBSTB">
        <xsd:enumeration value="GBSTD">
        <xsd:enumeration value="GBSTS">
        <xsd:enumeration value="GBSYK">
        <xsd:enumeration value="GBTAY">
        <xsd:enumeration value="GBTWR">
        <xsd:enumeration value="GBWAR">
        <xsd:enumeration value="GBWGM">
        <xsd:enumeration value="GBWIL">
        <xsd:enumeration value="GBWIS">
        <xsd:enumeration value="GBWMD">
        <xsd:enumeration value="GBWSX">
        <xsd:enumeration value="GBWYK">
        <xsd:enumeration value="GBZET">
        <xsd:enumeration value="USAK">
        <xsd:enumeration value="USAL">
        <xsd:enumeration value="USAR">
        <xsd:enumeration value="USAS">
        <xsd:enumeration value="USAZ">
        <xsd:enumeration value="USCA">
        <xsd:enumeration value="USCO">
        <xsd:enumeration value="USCT">
        <xsd:enumeration value="USDC">
        <xsd:enumeration value="USDE">
        <xsd:enumeration value="USFL">
        <xsd:enumeration value="USGA">
        <xsd:enumeration value="USGU">
        <xsd:enumeration value="USHI">
        <xsd:enumeration value="USIA">
        <xsd:enumeration value="USID">
        <xsd:enumeration value="USIL">
        <xsd:enumeration value="USIN">
        <xsd:enumeration value="USKS">
        <xsd:enumeration value="USKY">
        <xsd:enumeration value="USLA">
        <xsd:enumeration value="USMA">
        <xsd:enumeration value="USMD">
        <xsd:enumeration value="USME">
        <xsd:enumeration value="USMI">
        <xsd:enumeration value="USMN">
        <xsd:enumeration value="USMO">
        <xsd:enumeration value="USMP">
        <xsd:enumeration value="USMS">
        <xsd:enumeration value="USMT">
        <xsd:enumeration value="USNC">
        <xsd:enumeration value="USND">
        <xsd:enumeration value="USNE">
        <xsd:enumeration value="USNH">
        <xsd:enumeration value="USNJ">
        <xsd:enumeration value="USNM">
        <xsd:enumeration value="USNV">
        <xsd:enumeration value="USNY">
        <xsd:enumeration value="USOH">
        <xsd:enumeration value="USOK">
        <xsd:enumeration value="USOR">
        <xsd:enumeration value="USPA">
        <xsd:enumeration value="USPR">
        <xsd:enumeration value="USRI">
        <xsd:enumeration value="USSC">
        <xsd:enumeration value="USSD">
        <xsd:enumeration value="USTN">
        <xsd:enumeration value="USTX">
        <xsd:enumeration value="USUM">
        <xsd:enumeration value="USUT">
        <xsd:enumeration value="USVA">
        <xsd:enumeration value="USVI">
        <xsd:enumeration value="USVT">
        <xsd:enumeration value="USWA">
        <xsd:enumeration value="USWI">
        <xsd:enumeration value="USWV">
        <xsd:enumeration value="USWY">
        <xsd:enumeration value="UM67">
        <xsd:enumeration value="UM71">
        <xsd:enumeration value="UM76">
        <xsd:enumeration value="UM79">
        <xsd:enumeration value="UM81">
        <xsd:enumeration value="UM84">
        <xsd:enumeration value="UM86">
        <xsd:enumeration value="UM89">
        <xsd:enumeration value="UM95">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: RegionType

RegionType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( RegionCoded[RegionCodeType] , RegionCodedOther[xsd:string]? )

    Description: RegionType identifies a region within a country.

    Elements:

    • RegionCoded - identifies the region within a country using a standard code list.
    • RegionCodedOther - is used to provide a non-standard RegionCode. This element is mandatory if the value of RegionCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="RegionType">
    <xsd:sequence>
        <xsd:element name="RegionCoded" type="RegionCodeType">
        <xsd:element minOccurs="0" name="RegionCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: RequestedResponseCodeType

RequestedResponseCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the type of response requested. This code list is derived from EDIFACT 1225 (Message function code) and 1229 (Action request/notification description code) and X12 353 (Transaction set purpose code) and 587 (Acknowledgment type)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • DebitAdvice
    • AcknowledgeHoldStatus
    • AcknowledgementWhenError
    • AcknowledgeNoDetailOrChange
    • AcknowledgeOnlyChanges
    • AcknowledgeProductReplenishment
    • AcknowledgeWithDetailAndChange
    • AcknowledgeWithDetailNoChange
    • AdviceWithDetails
    • AdviceWithoutDetails
    • Authentication
    • CreditAdviceAndAcknowledgementForDirectDebit
    • CreditAdviceMessageAcknowledgement
    • CreditAdviceRequestedForDirectDebit
    • DebitAdviceForEachTransaction
    • DebitAdviceMessageAcknowledgement
    • DebitAdviceMessageAcknowledgementForEachTransaction
    • DebitAdviceRequested
    • MessageAcknowledgement
    • NoAcknowledgementNeeded
    • RequestAuthority
    • ResponseExpected

[^]Code Fragment

    <xsd:simpleType name="RequestedResponseCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="DebitAdvice">
        <xsd:enumeration value="AcknowledgeHoldStatus">
        <xsd:enumeration value="AcknowledgementWhenError">
        <xsd:enumeration value="AcknowledgeNoDetailOrChange">
        <xsd:enumeration value="AcknowledgeOnlyChanges">
        <xsd:enumeration value="AcknowledgeProductReplenishment">
        <xsd:enumeration value="AcknowledgeWithDetailAndChange">
        <xsd:enumeration value="AcknowledgeWithDetailNoChange">
        <xsd:enumeration value="AdviceWithDetails">
        <xsd:enumeration value="AdviceWithoutDetails">
        <xsd:enumeration value="Authentication">
        <xsd:enumeration value="CreditAdviceAndAcknowledgementForDirectDebit">
        <xsd:enumeration value="CreditAdviceMessageAcknowledgement">
        <xsd:enumeration value="CreditAdviceRequestedForDirectDebit">
        <xsd:enumeration value="DebitAdviceForEachTransaction">
        <xsd:enumeration value="DebitAdviceMessageAcknowledgement">
        <xsd:enumeration value="DebitAdviceMessageAcknowledgementForEachTransaction">
        <xsd:enumeration value="DebitAdviceRequested">
        <xsd:enumeration value="MessageAcknowledgement">
        <xsd:enumeration value="NoAcknowledgementNeeded">
        <xsd:enumeration value="RequestAuthority">
        <xsd:enumeration value="ResponseExpected">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: RequestedResponseType

RequestedResponseType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( RequestedResponseCoded[RequestedResponseCodeType] , RequestedResponseCodedOther[xsd:string]? )

    Description: RequestedResponseType specifies the type of acknowledgment requested by the buyer from the seller.

    Elements:

    • RequestedResponseCoded - is the code value of the requested acknowledgment.
    • RequestedResponseCodedOther - is used to provide a non-standard RequestedResponseCode. This element is mandatory if the value of RequestedResponseCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="RequestedResponseType">
    <xsd:sequence>
        <xsd:element name="RequestedResponseCoded" type="RequestedResponseCodeType">
        <xsd:element minOccurs="0" name="RequestedResponseCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: ResponseTypeCodeType

ResponseTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other
    • Accepted
    • AcceptedContentsRejected
    • AcceptedWithAmendment
    • AcceptedWithAmendmentInDetailSection
    • AcceptedWithAmendmentInHeadingSection
    • AcceptedWithAmendmentNoConfirmationIsRequired
    • AcceptedWithoutAmendment
    • AcceptedWithoutReserves
    • AcceptedWithReserves
    • AcknowledgeWithDetailAndChange
    • Agreed
    • AlreadyDelivered
    • ApprovedAsAmended
    • ApprovedAsSubmitted
    • ConditionallyAccepted
    • NotAccepted
    • NotAcceptedProvisional
    • Rejected
    • RejectedDuplicate
    • RejectedNoDetail
    • RejectedNotAsAgreed
    • RejectedResubmitWithCorrections
    • RejectedViolatesIndustryPractice
    • RejectedWithCounterOffer
    • RejectItemChange
    • RejectWithDetail
    • RejectWithExceptionDetailOnly
    • SellerRejectsDispute

[^]Code Fragment

    <xsd:simpleType name="ResponseTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Accepted">
        <xsd:enumeration value="AcceptedContentsRejected">
        <xsd:enumeration value="AcceptedWithAmendment">
        <xsd:enumeration value="AcceptedWithAmendmentInDetailSection">
        <xsd:enumeration value="AcceptedWithAmendmentInHeadingSection">
        <xsd:enumeration value="AcceptedWithAmendmentNoConfirmationIsRequired">
        <xsd:enumeration value="AcceptedWithoutAmendment">
        <xsd:enumeration value="AcceptedWithoutReserves">
        <xsd:enumeration value="AcceptedWithReserves">
        <xsd:enumeration value="AcknowledgeWithDetailAndChange">
        <xsd:enumeration value="Agreed">
        <xsd:enumeration value="AlreadyDelivered">
        <xsd:enumeration value="ApprovedAsAmended">
        <xsd:enumeration value="ApprovedAsSubmitted">
        <xsd:enumeration value="ConditionallyAccepted">
        <xsd:enumeration value="NotAccepted">
        <xsd:enumeration value="NotAcceptedProvisional">
        <xsd:enumeration value="Rejected">
        <xsd:enumeration value="RejectedDuplicate">
        <xsd:enumeration value="RejectedNoDetail">
        <xsd:enumeration value="RejectedNotAsAgreed">
        <xsd:enumeration value="RejectedResubmitWithCorrections">
        <xsd:enumeration value="RejectedViolatesIndustryPractice">
        <xsd:enumeration value="RejectedWithCounterOffer">
        <xsd:enumeration value="RejectItemChange">
        <xsd:enumeration value="RejectWithDetail">
        <xsd:enumeration value="RejectWithExceptionDetailOnly">
        <xsd:enumeration value="SellerRejectsDispute">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: ResponseTypeType

ResponseTypeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ResponseTypeCoded[ResponseTypeCodeType] , ResponseTypeCodedOther[xsd:string]? )

    Description: ResponseTypeType defines the type of response sent between seller and buyer.

    Elements:

    • ResponseTypeCoded - specifies the type of acknowledgment sent by the seller to the buyer in response to an Order or ChangeOrder document.
    • ResponseTypeCodedOther - is used to provide a non-standard ResponseTypeCode. This element is mandatory if the value of ResponseTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="ResponseTypeType">
    <xsd:sequence>
        <xsd:element name="ResponseTypeCoded" type="ResponseTypeCodeType">
        <xsd:element minOccurs="0" name="ResponseTypeCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ReturnableContainerInfoType

ReturnableContainerInfoType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ReturnableContainerPartNumber[PartNumType]? , PaymentResponsibilityCoded[PaymentResponsibilityCodeType]? , PaymentResponsibilityCodedOther[xsd:string]? , ReturnLoadCoded[ReturnLoadCodeType]? , ReturnLoadCodedOther[xsd:string]? , ReturnNote[xsd:string]? )

    Description: ReturnableContainerInfoType describes shipping, payment and miscellaneous information regarding containers that are returned after they have been used in shipment.

    Elements:

    • ReturnableContainerPartNumber - is the part number of the returnable container.
    • PaymentResponsibilityCoded - designates which party is responsible for payment of the returnable containers.
    • PaymentResponsibilityCodedOther - is used to provide a non-standard PaymentResponsibilityCode. This element is mandatory if the value of PaymentResponsibilityCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • ReturnLoadCoded - describes the contents or state of contents of the returnable container.
    • ReturnLoadCodedOther - is used to provide a non-standard ReturnLoadCode. This element is mandatory if the value of ReturnLoadCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • ReturnNote - contains text notes and instructions relating to the returnable container.

[^]Code Fragment

    <xsd:complexType name="ReturnableContainerInfoType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ReturnableContainerPartNumber" type="PartNumType">
        <xsd:element minOccurs="0" name="PaymentResponsibilityCoded" type="PaymentResponsibilityCodeType">
        <xsd:element minOccurs="0" name="PaymentResponsibilityCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="ReturnLoadCoded" type="ReturnLoadCodeType">
        <xsd:element minOccurs="0" name="ReturnLoadCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="ReturnNote" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: ReturnLoadCodeType

ReturnLoadCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code indicates the contents or state of goods on a returnable container. This code list is derived from EDIFACT 8393 (Returnable package load contents coded) and X12 728 (Returnable container load make-up code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • LoadedEithEmpty4BlockForBlockingPurposes
    • EmptyContainerWithDunnage
    • EmptyContainer
    • LoadedWithProductionMaterial
    • MixedEmptyAndLoaded
    • ObsoleteMaterial
    • LoadedWithExcessReturnedProductionMaterial
    • LoadedWithRejectedMaterial
    • ServicePartObsoleteContainer
    • LoadedWithReturnedProcessedMaterial

[^]Code Fragment

    <xsd:simpleType name="ReturnLoadCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="LoadedEithEmpty4BlockForBlockingPurposes">
        <xsd:enumeration value="EmptyContainerWithDunnage">
        <xsd:enumeration value="EmptyContainer">
        <xsd:enumeration value="LoadedWithProductionMaterial">
        <xsd:enumeration value="MixedEmptyAndLoaded">
        <xsd:enumeration value="ObsoleteMaterial">
        <xsd:enumeration value="LoadedWithExcessReturnedProductionMaterial">
        <xsd:enumeration value="LoadedWithRejectedMaterial">
        <xsd:enumeration value="ServicePartObsoleteContainer">
        <xsd:enumeration value="LoadedWithReturnedProcessedMaterial">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: RiskOfLossCodeType

RiskOfLossCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code indicates the responsibility for risk of loss. This code list is derived from X12 54 (Risk of loss qualifier)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • RiskOfLossInTransitToDestinationIsBuyers
    • RiskOfLossInTransitToFreightEqualizationPointIsSellers
    • RiskOfLossInTransitToPoolPointIsSellers
    • RiskOfLossInTransitToDestinationIsSellers

[^]Code Fragment

    <xsd:simpleType name="RiskOfLossCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="RiskOfLossInTransitToDestinationIsBuyers">
        <xsd:enumeration value="RiskOfLossInTransitToFreightEqualizationPointIsSellers">
        <xsd:enumeration value="RiskOfLossInTransitToPoolPointIsSellers">
        <xsd:enumeration value="RiskOfLossInTransitToDestinationIsSellers">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: RoundTripInformationType

RoundTripInformationType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( Immutable[xsd:boolean]? , ReLink[xsd:anyURI]? , ReLinkID[xsd:string]? , SellerShoppingCartID[xsd:string]? )

    Attribute:Name: RoundTripOrder, Type: xsd:boolean, Fixed: 'true'

    Description: RoundTripInformationType contains information specific to the round trip ordering process.

    Elements:

    • Immutable - is a boolean, that if true, indicates that order/item should not be changed in any way by the receiving application.
    • ReLink - is a URL that can be used to link back into the supplier site for viewing and/or editing of the order/item
    • ReLinkID - is an identifier to the link back to the supplier site for viewing and/or editing of the order/item.
    • SellerShoppingCartID - is an identifier to be passed through the procurement phase untouched. The supplier can use this to 'validate' the order with their record of the original shopping basket.
    Attributes:
    • RoundTripOrder - is a fixed boolean that indicates that this is a round trip ordering process. The presence of the

[^]Code Fragment

    <xsd:complexType name="RoundTripInformationType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="Immutable" type="xsd:boolean">
        <xsd:element minOccurs="0" name="ReLink" type="xsd:anyURI">
        <xsd:element minOccurs="0" name="ReLinkID" type="xsd:string">
        <xsd:element minOccurs="0" name="SellerShoppingCartID" type="xsd:string">
    </xsd:sequence>
    <xsd:attribute name="RoundTripOrder" type="xsd:boolean" fixed="true">
</xsd:complexType>


simpleType definition: SalesActionCodeType

SalesActionCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code indicates the type of sales action. This code list is derived from X12 306 (Action code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • CancelBalanceThatExceedsSalesActionValues - Cancel Balance of Order that exceeds SalesActionValue
    • CancelEntire - Cancel Entire Order Or Item

[^]Code Fragment

    <xsd:simpleType name="SalesActionCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="CancelBalanceThatExceedsSalesActionValues">
        <xsd:enumeration value="CancelEntire">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: SalesRequirementCodeType

SalesRequirementCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies a specific requirement or agreement of sale. This code list is derived from X12 563 (Sales requirement code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • AddQuantityToMakeMinimumWeightRequirement
    • BackOrderIfItemsAreOutOfStockOrNotYetPublished
    • BackOrderIfOutOfStock
    • BackOrderOnlyIfNewItem
    • BidGuarantee
    • CombinedSmallDisadvantagedBusinessAndLaborSurplusAreaSet-Aside
    • Consignment
    • DoNotPreship
    • EqualProductAllowed
    • ExcludeImportQuotaInFirstCost
    • FactoryShip
    • GuaranteedSale
    • IncludeImportQuotaInFirstCost
    • LaborSurplusAreaSet-Aside
    • LargePurchaseSet-AsideForSmallBusiness
    • MayPreship
    • Multi-yearAward
    • NoBackOrder
    • NoSubstitutes
    • NotifyPriorToShipmentIfQuantitySpecifiedIsNotAvailable
    • OnQualifiedBiddersList
    • OnQualifiedManufacturersList
    • OtherUnlistedSalesCondition
    • PartialLaborSurplusAreaSetAside
    • RestrictedToApprovedSources
    • RestrictedToEducationalInstitutions
    • RestrictedToHistoricallyBlackCollegeOrUniversityOrMinorityInstitution
    • RestrictedToIndustrialPreparednessProgramParticipants
    • RestrictedToQualifiedProductsListProducts
    • RestrictedToUSAndCanadianSources
    • RestrictedToYoungInvestigatorProgram
    • Section8aSet-Aside
    • Set-asideForAmericanIndian-ownedBusiness
    • ShipAsSoonAsPossible
    • ShipComplete
    • ShipFullTruckOnly
    • ShipIn-Place
    • ShipPartial-BalanceBackOrder
    • ShipPartialBalanceCancel
    • ShipPartialBalanceSubstitute
    • ShipPartialCarloadLotsOnly
    • ShipPartialItemQtyProportionalToTotalOrder
    • ShipPartialTruckloadLotsOnly
    • ShipPerRelease
    • ShipPerReleaseorBuyerAuthorization
    • ShipPerSchedule
    • SmallBusinessWithSmallDisadvantagedBusinessConsiderationSet-Aside
    • SmallDisadvantagedBusinessSet-Aside
    • SmallPurchaseSetAsideForSmallBusinesses
    • SmallRemainingBalanceCancellationAllowed
    • SmallRemainingBalanceCancellationNotAllowed
    • SubstituteItemAllowed
    • UnrestrictedProcurement
    • WarehouseShip
    • Warranty

[^]Code Fragment

    <xsd:simpleType name="SalesRequirementCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="AddQuantityToMakeMinimumWeightRequirement">
        <xsd:enumeration value="BackOrderIfItemsAreOutOfStockOrNotYetPublished">
        <xsd:enumeration value="BackOrderIfOutOfStock">
        <xsd:enumeration value="BackOrderOnlyIfNewItem">
        <xsd:enumeration value="BidGuarantee">
        <xsd:enumeration value="CombinedSmallDisadvantagedBusinessAndLaborSurplusAreaSet-Aside">
        <xsd:enumeration value="Consignment">
        <xsd:enumeration value="DoNotPreship">
        <xsd:enumeration value="EqualProductAllowed">
        <xsd:enumeration value="ExcludeImportQuotaInFirstCost">
        <xsd:enumeration value="FactoryShip">
        <xsd:enumeration value="GuaranteedSale">
        <xsd:enumeration value="IncludeImportQuotaInFirstCost">
        <xsd:enumeration value="LaborSurplusAreaSet-Aside">
        <xsd:enumeration value="LargePurchaseSet-AsideForSmallBusiness">
        <xsd:enumeration value="MayPreship">
        <xsd:enumeration value="Multi-yearAward">
        <xsd:enumeration value="NoBackOrder">
        <xsd:enumeration value="NoSubstitutes">
        <xsd:enumeration value="NotifyPriorToShipmentIfQuantitySpecifiedIsNotAvailable">
        <xsd:enumeration value="OnQualifiedBiddersList">
        <xsd:enumeration value="OnQualifiedManufacturersList">
        <xsd:enumeration value="OtherUnlistedSalesCondition">
        <xsd:enumeration value="PartialLaborSurplusAreaSetAside">
        <xsd:enumeration value="RestrictedToApprovedSources">
        <xsd:enumeration value="RestrictedToEducationalInstitutions">
        <xsd:enumeration value="RestrictedToHistoricallyBlackCollegeOrUniversityOrMinorityInstitution">
        <xsd:enumeration value="RestrictedToIndustrialPreparednessProgramParticipants">
        <xsd:enumeration value="RestrictedToQualifiedProductsListProducts">
        <xsd:enumeration value="RestrictedToUSAndCanadianSources">
        <xsd:enumeration value="RestrictedToYoungInvestigatorProgram">
        <xsd:enumeration value="Section8aSet-Aside">
        <xsd:enumeration value="Set-asideForAmericanIndian-ownedBusiness">
        <xsd:enumeration value="ShipAsSoonAsPossible">
        <xsd:enumeration value="ShipComplete">
        <xsd:enumeration value="ShipFullTruckOnly">
        <xsd:enumeration value="ShipIn-Place">
        <xsd:enumeration value="ShipPartial-BalanceBackOrder">
        <xsd:enumeration value="ShipPartialBalanceCancel">
        <xsd:enumeration value="ShipPartialBalanceSubstitute">
        <xsd:enumeration value="ShipPartialCarloadLotsOnly">
        <xsd:enumeration value="ShipPartialItemQtyProportionalToTotalOrder">
        <xsd:enumeration value="ShipPartialTruckloadLotsOnly">
        <xsd:enumeration value="ShipPerRelease">
        <xsd:enumeration value="ShipPerReleaseorBuyerAuthorization">
        <xsd:enumeration value="ShipPerSchedule">
        <xsd:enumeration value="SmallBusinessWithSmallDisadvantagedBusinessConsiderationSet-Aside">
        <xsd:enumeration value="SmallDisadvantagedBusinessSet-Aside">
        <xsd:enumeration value="SmallPurchaseSetAsideForSmallBusinesses">
        <xsd:enumeration value="SmallRemainingBalanceCancellationAllowed">
        <xsd:enumeration value="SmallRemainingBalanceCancellationNotAllowed">
        <xsd:enumeration value="SubstituteItemAllowed">
        <xsd:enumeration value="UnrestrictedProcurement">
        <xsd:enumeration value="WarehouseShip">
        <xsd:enumeration value="Warranty">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: SalesRequirementType

SalesRequirementType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( SalesRequirementCoded[SalesRequirementCodeType] , SalesRequirementCodedOther[xsd:string]? )

    Description: SalesRequirementType outlines any specific sales information relating to the item.

    Elements:

    • SalesRequirementCoded - identifies a specific requirement or agreement of sale.
    • SalesRequirementCodedOther - is used to provide a non-standard SalesRequirementCode. This element is mandatory if the value of SalesRequirementCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="SalesRequirementType">
    <xsd:sequence>
        <xsd:element name="SalesRequirementCoded" type="SalesRequirementCodeType">
        <xsd:element minOccurs="0" name="SalesRequirementCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ScheduleLineType

ScheduleLineType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ScheduleLineID[xsd:int]? , Quantity[QuantityType] , ( RequestedDeliveryDate[xsd:dateTime]? | ListOfOtherDeliveryDate[ListOfDateCodedType]? )1,2 , ScheduleLineNote[xsd:string]? , ( TransportRouting[TransportRoutingType]? | TransportReference[xsd:int]? )? , ListOfShipToSubInformation[ListOfShipToSubInformationType]? )

    Description: ScheduleLineType contains the information on a portion of the line item shipment to be sent on particular set of dates with a particular set of transport information.

    Elements:

    • ScheduleLineID - uniquely identifies the schedule line within the line item. This is used for external reference.
    • Quantity - contains the sub-quantity to be shipped on a particular set of dates.
    • RequestedDeliveryDate - is the date the buyer requested for delivery.
    • ListOfOtherDeliveryDate - lists the dates revolving around delivery.This is used to express simple date information that is not tied to particular carriers, transport, etc.
    • ScheduleLineNote - is a free form text field that is used to provide any additional information relating to this schedule.
    • TransportRouting - contains carrier, equipment, and mode of transport information.
    • TransportReference - references the transport routing element to identify which transport legs the package is travelling on. This element is repeated if the package travels on more than one transport route.
    • ListOfShipToSubInformation - details place and quantity information regarding the shipto sub-location.

[^]Code Fragment

    <xsd:complexType name="ScheduleLineType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ScheduleLineID" type="xsd:int">
        <xsd:element name="Quantity" type="QuantityType">
        <xsd:choice maxOccurs="2">
            <xsd:element minOccurs="0" name="RequestedDeliveryDate" type="xsd:dateTime">
            <xsd:element minOccurs="0" name="ListOfOtherDeliveryDate" type="ListOfDateCodedType">
        </xsd:choice>
        <xsd:element minOccurs="0" name="ScheduleLineNote" type="xsd:string">
        <xsd:choice minOccurs="0">
            <xsd:element minOccurs="0" name="TransportRouting" type="TransportRoutingType">
            <xsd:element minOccurs="0" name="TransportReference" type="xsd:int">
        </xsd:choice>
        <xsd:element minOccurs="0" name="ListOfShipToSubInformation" type="ListOfShipToSubInformationType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: SealInfoType

SealInfoType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( SealNumber[xsd:string] , SealIssuer[SealIssuerType]? , SealStatusDescription[SealStatusDescriptionType]? )

    Description: SealInfoType provides seal information for the equipment.

    Elements:

    • SealNumber - identifies the seal number of the equipment.
    • SealIssuer - provides information about the issuer of the seal for the equipment.
    • SealStatusDescription - provides information on the status of the seal.

[^]Code Fragment

    <xsd:complexType name="SealInfoType">
    <xsd:sequence>
        <xsd:element name="SealNumber" type="xsd:string">
        <xsd:element minOccurs="0" name="SealIssuer" type="SealIssuerType">
        <xsd:element minOccurs="0" name="SealStatusDescription" type="SealStatusDescriptionType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: SealIssuerCodeType

SealIssuerCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the issuer of the seal number. This code list is derived from EDIFACT 9303 (Sealing party coded)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • Consolidator - Party which consolidates cargo.
    • Unknown - The sealing party is unknown.
    • QuarantineAgency - Agency responsible for the administration of statutory disease controls on the movement of people, animals and plants.
    • Carrier - Party undertaking or arranging transport of goods between named points.
    • Customs
    • Shipper - Party which, by contract with a carrier, consigns or sends goods with the carrier, or has conveyed by him.
    • TerminalOperator - Party which handles the loading and unloading of marine vessels.

[^]Code Fragment

    <xsd:simpleType name="SealIssuerCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Consolidator">
        <xsd:enumeration value="Unknown">
        <xsd:enumeration value="QuarantineAgency">
        <xsd:enumeration value="Carrier">
        <xsd:enumeration value="Customs">
        <xsd:enumeration value="Shipper">
        <xsd:enumeration value="TerminalOperator">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: SealIssuerType

SealIssuerType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( SealIssuerCoded[SealIssuerCodeType] , SealIssuerCodedOther[xsd:string]? )

    Description: SealIssuerType provides information about the issuer of the seal for the equipment.

    Elements:

    • SealIssuerCoded - lists the issuer of the seal for the equipment.
    • SealIssuerCodedOther - is used to provide a non-standard SealIssuerCode. This element is mandatory if the value of SealIssuerCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="SealIssuerType">
    <xsd:sequence>
        <xsd:element name="SealIssuerCoded" type="SealIssuerCodeType">
        <xsd:element minOccurs="0" name="SealIssuerCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: SealStatusCodeType

SealStatusCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the status of the seal. This code list is derived from EDIFACT 4517 (Seal condition coded) and X12 407 (Seal status code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom code
    • Broken - Used to specify that the seal is broken.
    • Damaged - The seal is damaged.
    • InRightCondition - The seal is in right condition.
    • Missing - A seal that is missing.
    • Replaced - The seal has been replaced.
    • TheElectronicSealIsFaulty - The electronic seal is faulty.

[^]Code Fragment

    <xsd:simpleType name="SealStatusCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Broken">
        <xsd:enumeration value="Damaged">
        <xsd:enumeration value="InRightCondition">
        <xsd:enumeration value="Missing">
        <xsd:enumeration value="Replaced">
        <xsd:enumeration value="TheElectronicSealIsFaulty">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: SealStatusDescriptionType

SealStatusDescriptionType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( SealStatusCoded[SealStatusCodeType]? , SealStatusCodedOther[xsd:string]? , SealStatusInfo[xsd:string]? )

    Description: SealStatusDescriptionType provides information on the status of the seal.

    Elements:

    • SealStatusCoded - lists the status of the seal.
    • SealStatusCodedOther - is used to provide a non-standard SealStatusCode. This element is mandatory if the value of SealStatusCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • SealStatusInfo - provides text information regarding the seal status.

[^]Code Fragment

    <xsd:complexType name="SealStatusDescriptionType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="SealStatusCoded" type="SealStatusCodeType">
        <xsd:element minOccurs="0" name="SealStatusCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="SealStatusInfo" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: ServiceCodeType

ServiceCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code indicates the special service required. This code list is derived from X12 1300 (Service, promotion, allowance or charge code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom code
    • About - To be construed as allowing a difference not exceeding 10 % more or 10 % less than the amount which it refers.
    • AbsoluteMinimumCharge - Absolute minimum charge
    • AccessCharge-Federal - Access charge - federal
    • AccessCharges - Access charges
    • AccessCharge-State - Access charge - state
    • AccountNumberCorrectionCharge - Account number correction charge
    • AcidBattery - Acid (battery)
    • AcknowledgmentofDeliveryFeeAOD - Acknowledgment of Delivery Fee (AOD)
    • ActivationOfCarnet - Activation of carnet
    • AdditionalCommercialInvoices - Additional commercial invoices
    • AdditionalCopiesOfFreightBill - Additional copies of freight bill
    • AdditionalMaterial - Additional material
    • AdditionalTariffClassifications - Additional tariff classifications
    • AddOn-Destination - Add on - destination
    • AddOn-Origin - Add on - origin
    • AddressCorrection - Address correction
    • AddToMakeMarketValue - Add to make market value
    • Adjustment
    • AdjustmentForMaximumChargesBilling - Adjustment for maximum charges billing
    • AdjustmentForMinimumAverageTimeRequirementBilling - Adjustment for minimum average time requirement billing
    • Adjustments - Adjustments
    • Administrative - Administrative
    • AdValorem - Ad valorem
    • AdvanceChargesHandling - Advance charges handling
    • AdvanceDestinationAmount - Advance destination amount
    • AdvanceDestinationFee - Advance destination fee
    • AdvanceFee - Advance fee
    • AdvanceLadingCharge - Advance lading charge
    • AdvanceOriginAmount - Advance origin amount
    • AdvanceOriginFee - Advance origin fee
    • Advances - Advances
    • AdvertisingAllowance - Advertising allowance
    • Affidavit - Affidavit
    • AgentDisbursement-Destination - Agent disbursement - destination
    • AgentDisbursement-Origin - Agent disbursement - origin
    • AircraftOnGround - Aircraft on ground (AOG)
    • AirExportCertificate - Air export certificate
    • AirExpressCharge - Air express charge
    • AirlineOpeningFee - Airline opening fee
    • AirportTerminalHandlingCharge - Airport terminal handling charge
    • AirTransportationCharge - Air transportation charge
    • AlcoholicBeverageReportCharge - Alcoholic beverage report charge
    • AlleghenyCountyPADeliveryCharge - Allegheny county, PA delivery charge
    • Allowance
    • AllowanceLineItems - Allowance is related to all line items in a message as a default allowance. It may be overridden per line item.
    • AllowanceMessage - Allowance is related to the entire message.
    • AllowancePerCallOf
    • AllowanceAdvance - Allowance advance
    • AllowanceForConsignmentMerchandise - Allowance for consignment merchandise
    • AllowanceNon-Performance - Allowance Non-performance
    • AllowanceRequest
    • Alterations - Alterations
    • AmendingExportDocumentation - Amending export documentation
    • AnnealHeatSteelorGlassTreatment - Anneal/Heat (steel or glass treatment)
    • AnodizingCharge - Anodizing charge
    • Anti-dumpingDuty - Anti-dumping duty
    • AppointmentNotification - Appointment (notification)
    • ArbitraryInAdditionToThroughRatesandCharges - Arbitrary (In addition to through rates and charges)
    • ArtWork - Art work
    • Assembly - Assembly
    • AssistAmount - Assist amount
    • AttachmentsToBillOfLadingCharge - Attachments to Bill of Lading charge
    • BadDebt - Bad debt
    • BankingDrafts - Banking drafts
    • BargeFreightAllKindsService - Barge freight all kinds service
    • BaseCharge - Base charge
    • BasicReorderAllowance - Basic reorder allowance
    • BeamingCharge - Beaming charge
    • BeddingFeedingDisinfecting - Bedding/feeding/disinfecting
    • BeefFee - Beef fee
    • BeyondCharge - Beyond charge
    • BeyondFreightCharges - Beyond freight charges
    • BillAndHold - Bill and hold
    • BilledDemand - Billed demand
    • BillOfLadingAttendancy - Bill of Lading attendancy
    • BillOfLadingCharge - Bill of Lading charge
    • BlackLungTax - Black lung tax
    • BlockingAndBracingCharge - Blocking and bracing charge
    • BlowerCharge - Blower charge
    • BobtailCharges - Bobtail charges
    • BondAmount - Bond amount
    • BondCharge - Bond charge
    • BopSheet - Bop sheet
    • BordeauxArbitraries - Bordeaux arbitraries
    • Both-Flat - Both-flat
    • BreakbulkServices - Breakbulk services
    • BreakBulkSurfaceCharge - Break bulk surface charge
    • BridgeToll - Bridge toll
    • BrokenLot - Broken lot
    • BrokenPackageCharge - Broken package charge
    • Brokerage - Brokerage
    • BrokerageOrDuty - Brokerage or duty
    • BunkerAdjustment - Bunker adjustment
    • BunkerAdjustment-20FootContainer - Bunker adjustment - 20 foot container
    • BunkerAdjustment-40FootContainer - Bunker adjustment - 40 foot container
    • BunkerSurcharge - Bunker surcharge
    • BurdenOverheadOrAllowanceForIndirectCosts - Burden, overhead, or allowance for indirect costs
    • Burning - Burning
    • BuyerHandCarry - Buyer hand carry
    • BuyersCarAllowance - Buyers car allowance
    • CablePressurization - Cable pressurization
    • CablesSendingOf - Cables (sending of)
    • CallTag - Call tag
    • CampArbitrary - Camp arbitrary
    • CanadaGreatLakesAdditionals - Canada great lakes additionals
    • CanadianCQCustomsClearance - Canadian C.Q.customs clearance
    • CanadianCurrencyExchange - Canadian currency exchange
    • CanadianImportTerminationFee - Canadian import termination fee
    • CanadianReconsignmentFee - Canadian reconsignment fee
    • CanadianRemanifestFee - Canadian remanifest fee
    • CancellationCharge - Cancellation charge
    • CancelledOrderHeavyDutyFlatcar - Cancelled order, heavy duty flatcar
    • Capping - Capping
    • CaptureAdditionalData - Capture additional data
    • CargoTaxes - Cargo taxes
    • CarLoading - Car loading
    • CarRental - Car rental
    • Carrier - Carrier
    • CarrierCreditAllowance - Carrier credit allowance
    • CarrierDebitAllowance - Carrier debit allowance
    • CarrierNotificationCharge - Carrier notification charge
    • Cartage - Cartage
    • CartageCharge - Cartage charge
    • CatalogingServices - Cataloging services
    • CentralBuy - Central buy
    • CentsOff - Cents off
    • CertificateOfConformance - Certificate of conformance
    • CertificateOfOrigin - Certificate of origin
    • CertificateOfRegistration - Certificate of registration
    • Certification - Certification
    • ChainAndBinders - Chain and binders
    • ChamberOfCommerceServiceCharge - Chamber of commerce service charge
    • ChangeOfAirbill-ServiceFee - Change of airbill - service fee
    • Charge
    • ChargeLineItems - Charge is related to all line items in a message as a default charge. It may be overridden per line item.
    • ChargeMessage - Charge is related to the entire message.
    • ChargePerCallOf
    • ChargesForwardAdvanceCharge - Charges forward/advance charge
    • CharterServices - Charter services
    • ChassisTransfer - Chassis transfer
    • ChemicalMillingCharge - Chemical milling charge
    • ChicagoLoopCharge - Chicago loop charge
    • CigaretteStamping - Cigarette stamping
    • CityDelivery - City delivery
    • CityMaintenanceFee - City maintenance fee
    • CityPick-up - City pick-up
    • CityTerminalCharge - City terminal charge
    • CleaningCharge - Cleaning charge
    • ClosingSealing - Closing and sealing
    • CoatingDipRustproofEDP - Coating (dip, rustproof, EDP)
    • CODAmount - Cod amount
    • CODCharges - Cod charges
    • CollectOnDeliveryAlterationCharge - Collect on delivery alteration charge
    • CollectOnDeliveryDeletionCharge - Collect on delivery deletion charge
    • CollectSurcharge - Collect surcharge
    • Co-manufacturingDiscount - Co-manufacturing discount
    • Combination - Combination
    • CombinationPerformanceAndNon-performance - Combination performance and non-performance
    • CombineAllSameDayShipment - Combine all same day shipment
    • CommissionAmount - Commission amount
    • CommunicationsCharges - Communications charges
    • CompetitiveAllowance - Competitive allowance
    • CompetitiveCarAllowance - Competitive car allowance
    • CompetitivePrice - Competitive price
    • CompressorCharge - Compressor charge
    • ConcessionCredit - Concession credit
    • ConcessionMoney - Concession money
    • CongestionSurcharge - Congestion surcharge
    • ConnectCharge - Connect charge
    • ConservationResearchFee - Conservation research fee
    • ConsigneeUnload - Consignee unload
    • Consolidation - Consolidation
    • ConstantSurveillanceService - Constant surveillance service
    • ConstantSurveillanceService-Armed - Constant surveillance service - armed
    • ConsularizationFee - Consularization fee
    • ConsularLegalizationService - Consular legalization service
    • ConsultingService - Consulting service
    • ConsumerServiceProviderCharge - Consumer service provider charge
    • ContainerAllowance - Container allowance
    • ContainerDeposits - Container deposits
    • ContainerDestuffing - Container destuffing
    • ContainerDiscount - Container discount
    • ContainerDiversion - Container diversion
    • ContainerLease - Container lease
    • ContainerLeasing - Container leasing
    • ContainerLossDamage - Container loss/damage
    • ContainerServiceChargeUKEUR - Container service charge UK/EUR
    • ContainerServiceChargeUSACanada - Container service charge USA/Canada
    • ContainerStuffing - Container stuffing
    • ContainerTrailerAllowance - Container/trailer allowance
    • ContinuousMileage - Continuous mileage
    • ContractAllowance - Contract allowance
    • ContractEscalation - Contract escalation
    • ContractServiceCharge - Contract service charge
    • ControlledAtmosphere - Controlled atmosphere
    • Converting - Converting
    • Co-opCredit - Co-op credit
    • CooperativeAdvertisingMerchandisingAllowancePerformance - Cooperative advertising/merchandising allowance (performance)
    • Copying - Copying
    • CopyOfBillOfLadingCharge - Copy of Bill of Lading charge
    • CopyOfDeliveryReceiptCharge - Copy of delivery receipt charge
    • CoreCharge - Core charge
    • CostRecoveryAdjustment - Cost recovery/adjustment
    • CostRecoveryFactor - Cost recovery factor
    • CottonFee - Cotton fee
    • CountAndRecount - Count and recount
    • CountervailingDuty - Countervailing duty
    • CouponReimbursement - Coupon reimbursement
    • Crafting - Crafting
    • Crating - Crating
    • Credit - Credit
    • CurrencyAdjustment - Currency adjustment
    • CurrencyAdjustment-20FootContainer - Currency adjustment - 20 foot container
    • CurrencyAdjustment-40FootContainer - Currency adjustment - 40 foot container
    • CurrencyAdjustment-BreakBulk - Currency adjustment - break bulk
    • CurrencyAdjustmentFactor - Currency adjustment factor
    • CurrencyDiscount - Currency discount
    • CustomerAccountIdentification - Customer account identification
    • CustomerEquipmentAllowance - Customer equipment allowance
    • CustomsBrokerFee - Customs broker fee
    • CustomsCharge - Customs charge
    • CustomsDuty - Customs duty
    • CustomsEntry - Customs entry
    • CustomsExam - Customs exam
    • CustomsFees-ContainerLevel - Customs fees - container level
    • CustomsFees-LiftLevel - Customs fees - lift level
    • CustomsFormalities - Customs formalities
    • CustomsInvoice - Customs invoice
    • CustomsInvoice-AdditionalPage - Customs invoice - additional page
    • CustomsPenalty - Customs penalty
    • Cut - Cut
    • CutAndParallel - Cut and parallel
    • CuttingCharge - Cutting charge
    • DamagedMerchandise - Damaged merchandise
    • DamageToCarrierEquipment - Damage to carrier equipment
    • DamageToCarrierVessel - Damage to carrier vessel
    • DamageToGovernmentEquipment - Damage to government equipment
    • DataDrawingCharge - Data/drawing charge
    • DeadheadMileageCharge - Deadhead mileage charge
    • DeafAndDisabledSurcharge - Deaf and disabled surcharge
    • DeclaredValueForCarriage - Declared value for carriage
    • DeclaredValueForCustoms - Declared value for customs
    • DeclaredValueForInsurance - Declared value for insurance
    • DeductToMakeMarketValue - Deduct to make market value
    • DefectiveAllowance - Defective allowance
    • DeficitFreight - Deficit freight
    • De-Installation - De-installation
    • DelayFurnishingDestinationWeights - Delay furnishing destination weights
    • Delivery - Delivery
    • DeliverySurcharge - Delivery surcharge
    • DemandCharge - Demand charge
    • Demurrage - Demurrage
    • Demurrage-AverageAgreement - Demurrage - average agreement
    • Demurrage-Special - Demurrage - special
    • Deposit - Deposit
    • DepositCharges - Deposit charges
    • DepositInLieuOfOrder - Deposit in lieu of order
    • Deramping - Deramping
    • DerrickCharge - Derrick charge
    • DesignatedSupplierInspection - Designated supplier inspection
    • DestinationCharge - Destination charge
    • DetentionLoading - Detention loading
    • DetentionOfPowerUnits - Detention of power units
    • DetentionOfTrailers - Detention of trailers
    • Detention-SpecialTypeFlatCar - Detention - special type flat car
    • DetentionUnloading - Detention unloading
    • DeterminedFreight - Determined freight
    • DevelopmentCharge - Development charge
    • DieServiceCharge - Die service charge
    • DirectProductHandling - Direct product handling (DPC)
    • Disbursement - Disbursement
    • DisconnectCharge - Disconnect charge
    • Discount - Discount
    • Discount-DropBoxConvenienceCtr - Discount - drop box/convenience ctr.
    • Discount-Incentive - Discount - incentive
    • Discount-MultipleShipment - Discount - multiple shipment
    • Discount-ServiceOptionDelivery - Discount - service option (delivery)
    • Discount-ServiceOptionPickup - Discount - service option (pickup)
    • Discount-Special - Discount - special
    • DisplayAllowance - Display allowance
    • DistributionFee - Distribution fee
    • DistributionService - Distribution service
    • DistributorDiscountAllowance - Distributor discount/allowance
    • DiversionAndReconsignment - Diversion and reconsignment
    • DiversionCharge - Diversion charge
    • DiversionToAirCharge - Diversion to air charge
    • Dockage-BoatDetention - Dockage - boat detention
    • DocumentationCharge - Documentation charge
    • DocumentHandling - Document handling
    • Door-To-Door - Door-to-Door
    • DowelPinCharge - Dowel pin charge
    • DrayagAtPortOfDebarkation - Drayage at port of debarkation
    • Drayage - Drayage
    • DrayageatPortOfDebarkationRateZone - Drayage at port of debarkation (rate zone)
    • DrayageAtPortOfEmbarkation - Drayage at port of embarkation
    • DrayageatPortOfEmbarkationRateZone - Drayage at port of embarkation (rate zone)
    • DrayageLineHaul - Drayage/line haul
    • DriverAssistedUnloading - Driver assisted unloading
    • DriversWages - Driver's wages
    • DropDock - Drop dock
    • DropYard - Drop yard
    • DrumCost - Drum cost
    • DrumDeposit - Drum deposit
    • DrumUpCharge - Drum up charge
    • DryerCharge - Dryer charge
    • DryIce - Dry ice
    • Dunnage - Dunnage
    • DutyCharge - Duty charge
    • DutyDrawback - Duty drawback
    • EarlyBuyAllowance - Early buy allowance
    • EarlyPaymentAllowance - Early payment allowance
    • EarlyShipAllowance - Early ship allowance
    • EmergencyPortCharge - Emergency port charge
    • EmergencyService - Emergency service
    • EmergencySurcharge - Emergency surcharge
    • EmptyWeighingCharge - Empty weighing charge
    • Enclosure - Enclosure
    • EndorsementFee - Endorsement fee
    • Energycharge - Energy charge
    • EnergySurchargeFuelAdjustmentFactor - Energy surcharge (fuel adjustment factor)
    • EngineeringCharge - Engineering charge
    • EngineeringSupplies - Engineering supplies
    • Engraving - Engraving
    • EnteredValue - Entered value
    • EnvironmentalProtectionService - Environmental protection service
    • EquipmentManufacturerRestorationAudit - Equipment manufacturer restoration audit
    • Escalation - Escalation
    • EscortService - Escort service
    • Escrow - Escrow
    • Eur1PresentationFee - Eur1 presentation fee
    • EuropeanPortCharges - European port charges
    • Exact - Indicates that this is the exact amount.
    • ExcessiveValueCharge - Excessive value charge
    • ExcessMileageCharge - Excess mileage charge
    • ExcessPeriods - Excess periods
    • ExcessValueFee - Excess value fee
    • ExcessWeight - Excess weight
    • ExchangeAccessCredit - Exchange access credit
    • ExclusiveUse - Exclusive use
    • ExclusiveUseOfEquipment - Exclusive use of equipment
    • ExhibitionDeliveryCharge - Exhibition delivery charge
    • ExhibitionPickupCharge - Exhibition pickup charge
    • ExpandedService - Expanded service
    • ExpeditedOneDayConsularService - Expedited one day consular service
    • ExpeditedServiceCharge - Expedited service charge
    • ExpeditedShipments - Expedited shipments
    • ExpeditingFee - Expediting fee
    • ExpeditingPremium - Expediting premium
    • ExportCustomsClearance - Export customs clearance
    • ExportDeclarations-Automated - Export declarations - automated
    • ExportDeclarations-USShippers - Export declarations - U.S. shippers
    • ExportImportCharge - Export/import charge
    • ExportLicenseApplication - Export license application
    • ExportShippingCharge - Export shipping charge
    • ExtraCopiesandMailings - Extra copies and mailings
    • ExtraLaborHelperService - Extra labor (helper service)
    • ExtraLength - Extra length
    • ExtraLengthSurcharge - Extra length surcharge
    • ExtraService-Counter-To-Counter - Extra Service - counter-to-counter
    • FabricationCharge - Fabrication charge
    • FacsimileCharges - Facsimile charges
    • FacsimileCharges-AdditionalPages - Facsimile charges - additional pages
    • FailedLampPanelCharge - Failed lamp panel charge
    • FaxPre-alert - Fax pre-alert
    • FederalTransferSurcharge - Federal transfer surcharge
    • Fee - Fee
    • FinanceCharge - Finance charge
    • FirstArticleCharge - First article charge
    • FirstFlightOut - First flight out
    • FlatrackSurcharge - Flatrack surcharge
    • FlatRate - Flat rate
    • FloorStockProtection - Floor stock protection
    • FoodAndLodging - Food and Lodging
    • ForeignCustomsDuty - Foreign customs duty
    • ForeignMilitarySalesRental - Foreign military sales (FMS) rental
    • ForeignMilitarySalesSpecialCharge - Foreign military sales (FMS) special charge
    • ForeignOfficeAdvance - Foreign office advance
    • ForwardCoupons - Forward coupons
    • ForwardingAgentCommission - Forwarding agent commission
    • ForwardingCharge - Forwarding charge
    • FranchiseFee - Franchise fee
    • FreeDomicileShipmentProcessing - Free domicile shipment processing
    • FreeGoods - Free goods
    • Freight - Freight
    • FreightBasedOnDollarMinimum - Freight based on dollar minimum
    • FreightChargesToBorder - Freight charges to border
    • FreightChargesToDestination - Freight charges to destination
    • FreightEqualization - Freight equalization
    • FreightInternational - Freight, international
    • FreightInternationalNon-USDollars - Freight, international, non-U.S. dollars
    • FreightInternationalUSDollars - Freight, international, U.S. dollars
    • FreightPassthrough - Freight passthrough
    • FreightSurcharge - Freight surcharge
    • FreshnessLeakerAllowance - Freshness/leaker allowance
    • FuelCharge - Fuel charge
    • FuelSurcharge - Fuel surcharge
    • FullService - Full service
    • FullTruckloadAllowance - Full truckload allowance
    • Fumigation - Fumigation
    • GarmentDistrict - Garment district
    • GarmentSurcharge - Garment surcharge
    • GasPressure - Gas pressure
    • GatewayFee - Gateway fee
    • Glaze - Glaze
    • GoldFactor - Gold factor
    • GoodsAndServicesCharge - Goods and services charge
    • GoodsAndServicesCreditAllowance - Goods and services credit allowance
    • GoodsAndServicesTaxCharge - Goods and services tax charge
    • GovernmentInspection - Government inspection
    • GovernmentWarehouseFee-Destination - Government warehouse fee - destination
    • GovernmentWarehouseFee-Origin - Government warehouse fee - origin
    • GrainDoors - Grain doors
    • GrainFlowCharge - Grain flow charge
    • Gratuity - Gratuity
    • Grinding - Grinding
    • GrossReceiptsSurcharge - Gross receipts surcharge
    • GroupageDiscount - Groupage discount
    • GroupedItems - Grouped items
    • GuaranteedInspectionTechnicalService - Guaranteed inspection technical service
    • GulfPortDeliveryCharge - Gulf port delivery charge
    • Handling - Handling
    • HandlingChargesOnDistributionFreightForwardedBeyond - Handling charges on distribution freight forwarded beyond
    • HandlingFreightAtPositionsNotImmediatelyAdjacentToVehicleCharge - Handling freight at positions not immediately adjacent to vehicle charge
    • HarborMaintenanceFee - Harbor maintenance fee
    • HarborMaintenanceReport - Harbor maintenance report
    • HaulingAndHoisting - Hauling and hoisting
    • HaulingAndHoistingToBeDirectBilled - Hauling and hoisting to be direct billed
    • HazardousCargoCharge - Hazardous cargo charge
    • HazardousCargoOnDeck - Hazardous cargo on deck
    • HazardousMaterialsHandlingFee-Domestic - Hazardous materials handling fee - domestic
    • HazardousMaterialsHandlingFee-International - Hazardous materials handling fee - international
    • HazardousStorage - Hazardous storage
    • HeatInTransitCharges - Heat in transit charges
    • HeatTreatCharge - Heat treat charge
    • HeavyDutyFlatCarCharge - Heavy duty flat car charge
    • HeavyLift - Heavy lift
    • HighSecurityRedIn-bondSealCharge - High security red in-bond seal charge
    • HighwayInterchange - Highway interchange
    • HointinsAndHauling - Hointins and hauling
    • HoldingCharge - Holding charge
    • HomeLineFreightCharge - Home line freight charge
    • HoneyFee - Honey fee
    • Hook-upcharge - Hook-up charge
    • HoseCharge - Hose charge
    • HoseChargeSpecial - Hose charge special
    • HouseholdGoodsPick-upOrDelivery - Household goods pick-up or delivery
    • IATAAirbillPreparation - IATA airbill preparation
    • IATAFee - IATA fee
    • Identification - Identification
    • ImportServiceFee - Import service fee
    • ImproperDocumentation - Improper documentation
    • InboundFreightCharges - Inbound freight charges
    • IncomeFreightManufacturingToShippingPoint - Income Freight (manufacturing to shipping point)
    • IncorrectBillingAccountCharge - Incorrect billing account charge
    • IndustryPriceAllowance - Industry price allowance
    • InitialLicenseFee - Initial license fee
    • InlandTransportation - Inland transportation
    • InsideCableConnectors - Inside cable connectors
    • InsideDelivery - Inside delivery
    • InsidePick-up - Inside Pick-up
    • InspectAtDestination - Inspect at Destination
    • InspectAtOrigin - Inspect at Origin
    • Inspection - Inspection
    • Installation - Installation
    • InstallationAndTraining - Installation and Training
    • InstallationWarranty - Installation and Warranty
    • InsulatedTankCharge - Insulated tank charge
    • Insurance - Insurance
    • InsuranceFee - Insurance fee
    • InsurancePlacementCostCharge - Insurance placement cost charge
    • InsurancePremium - Insurance premium
    • InsuranceProvidedByLessee - Insurance Provided by Lessee
    • InsuranceProvidedByLessor - Insurance Provided by Lessor
    • InsuranceSurcharge - Insurance surcharge
    • InterdivisionProfit - Interdivision profit
    • InterestAmount - Interest amount
    • InterestOnRefund - Interest on refund
    • InterestOnSecurityDeposit - Interest on security deposit
    • InterimUsePermittedAtSpecialRate - Interim use permitted at special rate
    • InternationalAirTransportAssociationCommission - International air transport association (IATA) commission
    • InternationalAirTransportAssociationMarkup - International air transport association (IATA) markup
    • InternationalCourier - International courier
    • InternationalDoor-to-DoorHandlingFee - International door-to-door handling fee
    • InterplantCharge - Interplant charge
    • InterstateHighwayToll - Interstate/highway toll
    • InTransitPriceProtection - In transit price protection
    • Intra-plantCharge - Intra-plant charge
    • InvoiceAdditionalAmount - Invoice additional amount
    • InvoiceAdjustment - Invoice adjustment
    • InvoiceAt-CostAmount - Invoice at-cost amount
    • InvoiceDeliveryTermsAmount - Invoice delivery terms amount
    • InvoiceNo-ChargeAmount - Invoice no-charge amount
    • InvoiceServices - Invoice services
    • InvoiceWithGoods - Invoice with Goods
    • IrishArbitraries - Irish arbitraries
    • IslandDeliveryCharge - Island delivery charge
    • IslandPick-UpCharge - Island pick-up charge
    • ItalianReleaseCharge - Italian release charge
    • ItemPercentage - Item percentage
    • Item-Unit - Item-unit
    • KeepFromFreezingPercentDifferential - Keep from freezing percent differential
    • Koshering - Koshering
    • LabelAllowance - Label allowance
    • Labeling - Labeling
    • LaborCharges - Labor charges
    • LaborCostOfRemoval - Labor cost of removal
    • LaborModify - Labor, modify
    • LaborNoTroubleFound - Labor, no trouble found
    • LaborOvertime - Labor, overtime
    • LaborPremiumOvertime - Labor, premium overtime
    • LaborRepairAndReturnOrders - Labor (repair and return orders)
    • LaborService - Labor service
    • LaborStraight-time - Labor, straight-time
    • LaborTestAndCalibrate - Labor, test and calibrate
    • LadingAdjustmentCharge - Lading adjustment charge
    • LandCurrencyAdjustmentFactor-20FootContainer - Land currency adjustment factor - 20 foot container
    • LandCurrencyAdjustmentFactor-40FootContainer - Land currency adjustment factor - 40 foot container
    • Lashing - Lashing
    • LateOrderCharge - Late order charge
    • LatePaymentCharge - Late payment charge
    • LayoutDesign - Layout/design
    • LayoverCharges - Layover charges
    • LeadFactor - Lead factor
    • LeakingUndergroundStorageTax - Leaking underground storage tax (LUST)
    • LeaseShortfallConsideration - Lease shortfall consideration
    • LessThanContainer - Less than container
    • LessThanTruckloadCharge - Less than truckload (LTL) charge
    • LetterOfCreditProcessing - Letter of credit processing
    • LicenseAndTitle - License and title
    • LifelineSurcharge - Lifeline surcharge
    • LiftGateTruckOrForkliftServiceAtPick-upDelivery - Lift gate (Truck) or forklift service at pick-up/delivery
    • LimeFee - Lime fee
    • LineItemAllowance - Allowance is related to a line item. It can override a default allowance.
    • LineItemCharge - Charge is related to a line item. It can override a default charge.
    • LinehaulFromPortOfDebarkation - Linehaul from port of debarkation
    • LinehaulPercentDifferential - Linehaul percent differential
    • LinehaulToPortOfEmbarkation - Linehaul to port of embarkation
    • LinerTermsAtPortOfDebarkation - Liner Terms at port of debarkation
    • LinerTermsAtPortOfEmbarkation - Liner Terms at port of embarkation
    • LiquidatedDamages - Liquidated damages
    • LiquidationAnti-DumpingDuty - Liquidation anti-dumping duty
    • LiquidationCountervailingDuty - Liquidation countervailing duty
    • LiquidationTaxAmount - Liquidation tax amount
    • LiquidationTotalDueUSCustomsService - Liquidation total due U.S. customs service (USCS)
    • LiquidationTotalFees - Liquidation total fees
    • Loading - Loading
    • LoadingLaborCharges - Loading (labor charges)
    • LoadWeighingCharge - Load weighing charge
    • LoanFee - Loan fee
    • LocalDeliveryDrayage - Local delivery/drayage
    • LocomotiveDelayedInSwitchingService - Locomotive delayed in switching service
    • LocomotiveUnderOwnPower - Locomotive under own power
    • LotCharge - Lot charge
    • LotteryChargeBack - Lottery charge back
    • LotteryCrossRedeemed - Lottery cross redeemed
    • Low-TierLotteryCashingBonus - Low-tier lottery cashing bonus
    • Low-TierLotteryWinners - Low-tier lottery winners
    • LumpSum - Lump sum
    • MachiningCharge - Machining charge
    • MailFee - Mail fee
    • Mailing-PostageCost - Mailing - postage cost
    • Mailing-ServiceFee - Mailing - service fee
    • MailInvoice - Mail invoice
    • MailInvoiceToEachLocation - Mail invoice to each location
    • ManifestCharge - Manifest charge
    • Manufacturing - Manufacturing
    • MarketDevelopmentFunds - Market development funds
    • MarkingOrTaggingCharge - Marking or tagging charge
    • MarriageRule - Marriage rule
    • Maximum - Highest possible value maximum not exceeding up to.
    • MemoReturnableContainer - Memo returnable container
    • MerchandiseProcessingFee - Merchandise processing fee
    • MessageCharge - Message charge
    • MessageRateAdjustment - Message rate adjustment
    • MessengerService - Messenger service
    • MetalsSurcharge - Metals surcharge
    • MeterCharge - Meter charge
    • Mid-TierLotteryCashingBonus - Mid-tier lottery cashing bonus
    • Mid-TierLotteryWinners - Mid-tier lottery winners
    • MileageFeeForRepairAndReturn - Mileage fee (for repair and return)
    • MileageOrTravel - Mileage or travel
    • Minus-Amount - The lesser value expressed in amount.
    • Minus-Percentage - The lesser value expressed in percentage.
    • ModifiedAtmosphere - Modified atmosphere
    • MonthlyRental - Monthly rental
    • MountDemount - Mount/demount
    • Mounting - Mounting
    • MunicipalSurcharge - Municipal surcharge
    • MushroomFee - Mushroom fee
    • NewDiscount - New discount
    • NewDistributionAllowance - New distribution allowance
    • NewItemAllowance - New item allowance
    • NewStoreAllowance - New store allowance
    • NewStoreDiscount - New store discount
    • NewWarehouse - New warehouse
    • NewWarehouseDiscount - New warehouse discount
    • NewYorkDeliveryCharge - New York delivery charge
    • NewYorkPick-upCharge - New York pick-up charge
    • NHDWharfage - N.H.D. wharfage
    • NoAllowance
    • NoAllowanceOrCharge - No increases or reduction in price (list or stated) are included.
    • NoCharge
    • Non-DutiableCharges - Non-dutiable charges
    • NonGeneratedFreight - Non generated freight
    • Non-returnableContainers - Non-returnable containers
    • NoReturnCreditAllowance - No return credit allowance
    • NormalPumpCharge - Normal pump charge
    • NotarizedAffidavit - Notarized affidavit
    • NotifyConsignee - Notify consignee
    • NotifyConsigneeBeforeDelivery - Notify consignee before delivery
    • NozzleCharge - Nozzle charge
    • OceanCharges-Hazardous - Ocean charges - hazardous
    • OceanFreight - Ocean freight
    • OfficeSupplies - Office supplies
    • Offshore-AlaskaHawaii - Offshore - Alaska/Hawaii
    • OnCarriage - On carriage
    • OnDeckBreakBulkDifferential - On deck break bulk differential
    • One-DayService - One - day service
    • OneTimeEngineeringCharge - One time engineering charge
    • One-TimeLicenseFee - One-time license fee
    • One-Time-OnlyCharge - One-time-only charge
    • OnetimeTooling - Onetime tooling
    • OnHandService - On hand service
    • OperatorCredit - Operator credit
    • OptionalCharge - Optional charge
    • OptionalSoftwareSupportForOperationalSupportSystems - Optional software support for operational support systems
    • OptionalSoftwareSupportForSwitchingSystems - Optional software support for switching systems
    • OptionChargeColorFabricOfficeFurniture - Option charge (color fabric office furniture)
    • Order-Flat - Order-flat
    • OrderNotifyCharge - Order notify charge
    • OtherAccessorialServiceCharge - Other accessorial service charge
    • OtherAdvances - Other advances
    • OtherExportCharges - Other export charges
    • OtherGovernmentAgencyDeclaration - Other government agency declaration
    • OtherGovernmentAgencyExam - Other government agency exam
    • OtherImportCharge - Other import charge
    • OtherMiscellaneousEarningOrAdditive - Other miscellaneous earning or additive
    • OtherSeeRelatedDescription - Other (See related description)
    • OutOfRouteMiles - Out of route miles
    • OutOfZonePick-upOrDelivery - Out of zone pick-up or delivery
    • OutsideCableConnectors - Outside cable connectors
    • OverDimension - Over dimension
    • OverHeightContainer - Over height container
    • OverrunCharge - Overrun charge
    • OversizedPremium - Oversized premium
    • OvertimeLoading - Overtime loading
    • OverWidthContainer - Over width container
    • Packaging - Packaging
    • PackagingService - Packaging service
    • PackingCratingAndHandlingCharge - Packing, crating, and handling charge
    • PackingCratingHandlingAndTransportationCharge - Packing, crating, handling, and transportation charge
    • PackInvoiceWithShipment - Pack invoice with shipment
    • PaintingPrimerOrFinish - Painting (primer or finish)
    • Pallet - Pallet
    • PalletExchangeCharge - Pallet exchange charge
    • Palletizing - Palletizing
    • Paralleling - Paralleling
    • ParishCountySalesTaxOnly - Parish/county sales tax (only)
    • PassingShippersExportEntry - Passing shippers export entry
    • Payment - Payment
    • PayrollAdditivesOvertimeLabor - Payroll additives, overtime labor
    • PayrollAdditivesStraightTimeLabor - Payroll additives, straight time labor
    • PayrollTaxes - Payroll taxes
    • PecanFee - Pecan fee
    • PenaltyCharge - Penalty charge
    • PercentDifferential-LessThanContainer - Percent differential - less than container
    • PercentOfProduct - Percent of product
    • PercentOfShipmentValueThatIsReturnable - Percent of shipment value that is returnable
    • PercentOfShippedQuantityThatIsReturnable - Percent of shipped quantity that is returnable
    • PerformanceAllowance - Performance allowance
    • PerformanceAward - Performance award
    • PerItemCharge - Per item charge
    • PermitCharge - Permit charge
    • PermitsBondsEscortAttendant - Permits bonds escort attendant
    • PerOrderCharge - Per order charge
    • PerPoundCharge - Per pound charge
    • PersonalPropertyMember - Personal property, member
    • PersonalPropertySpouse - Personal property, spouse
    • PhosphatizingSteelTreatment - Phosphatizing (steel treatment)
    • PickleAndOil - Pickle and oil
    • PickUp - Pick/up
    • Pick-upAndDelivery - Pick-up and delivery
    • Pickup-OutOfArea - Pickup - out of area
    • PickupSurcharge - Pickup surcharge
    • PierChargesOtherThanWharfage - Pier charges other than wharfage
    • PierCharges-Wharfage - Pier charges - wharfage
    • PierPick-upAndOrDelivery - Pier Pick-up and/or delivery
    • PierUnloading - Pier unloading
    • PilotInspection - Pilot inspection
    • PlacementAndOrRemovalCharge - Placement and/or removal charge
    • Plating - Plating
    • Plus-Amount - The greater value expressed in amount.
    • Plus-Percentage - The greater value expressed in percentage.
    • PlusOrMinus-Amount - The greater/lesser value expressed in amount.
    • PlusOrMinus-Percentage - The greater/lesser value expressed in percentage.
    • PoleLashingEquipmentSurcharge - Pole lashing equipment (PLE) surcharge
    • PoleWood-ServiceCharge - Pole, wood-service charge
    • PorkFee - Pork fee
    • PortChanges - Port changes
    • PortHandlingAndUnloading - Port handling and unloading
    • PositioningAtOrigin - Positioning at origin
    • Postage - Postage
    • PostDamagedHandling - Post damaged handling (PDC)
    • PotatoFee - Potato fee
    • PowerFactorAdjustment - Power factor adjustment
    • Pre-carriage - Pre-carriage
    • Pre-carriageExcess - Pre-carriage excess
    • PreciousMetalContent - Precious metal content
    • PreloadingCharge - Preloading charge
    • PrelodgeCharge - Prelodge charge
    • PremiseUse - Premise use
    • PremiumCharge - Premium charge
    • PremiumTransportation - Premium transportation
    • PrepaidUsageAllowance - Prepaid usage allowance
    • Preparation - Preparation
    • PreparationAndDelivery - Preparation and delivery
    • PreparationOfAirWaybill-Origin - Preparation of air waybill - origin
    • PreparationOfCanadianCustomsInvoice - Preparation of Canadian customs invoice
    • PreparationOfCommercialInvoice - Preparation of commercial invoice
    • PreparationOfExportEntry - Preparation of export entry
    • PreparationOfInsuranceCertificate - Preparation of insurance certificate
    • PreparationOfUSExportDocumentation - Preparation of U.S. export documentation
    • Pre-PositionedInventoryService - Pre-positioned inventory service
    • PreviousBilling - Previous billing
    • PriceAdjustmentPercent - Price adjustment percent (PCT)
    • PriceAndMarketingAllowance - Price and marketing allowance
    • PriceDeviation - Price deviation
    • PriorBalance - Prior balance
    • PriorBillingAmount - Prior billing amount
    • PriorDeliveryOfBillCharge - Prior delivery of bill charge
    • PriorityService - Priority service
    • PriorMonthCredit - Prior month credit
    • PrivateOwnedVehicleProcessing - Private owned vehicle processing
    • Processing - Processing
    • ProcessingCharge - Processing charge
    • ProcessInTransitPrivilege - Process in transit privilege
    • ProcurementCharge - Procurement charge
    • ProfessionalFees - Professional fees
    • ProformaInvoice - Proforma invoice
    • ProgressPaymentRequirement - Progress payment requirement
    • PromotionalAllowance - Promotional allowance
    • PromotionalDiscount - Promotional discount
    • ProofComposition - Proof and composition
    • ProofOfDelivery - Proof of delivery
    • ProtectiveServiceCharge - Protective service charge
    • ProtectiveService-Cold - Protective service - cold
    • ProtectiveService-Heat - Protective service - heat
    • ProvideHouseholdIdentifier - Provide household identifier
    • ProvideNameAndAddress - Provide name and address
    • PullingEyes - Pulling eyes
    • PumpAirCharge - Pump air charge
    • PumpCharge - Pump charge
    • PurchaseOption - Purchase option
    • QuantityDiscount - Quantity discount
    • QuantitySurcharge - Quantity surcharge
    • RailheadHandling - Railhead handling
    • Ramping - Ramping
    • RateCode - Rate code
    • RateReductionBond - Rate reduction bond
    • Rebate - Rebate
    • Re-BillCharge - Re-bill charge
    • RebilledDrayage-Destination - Rebilled drayage - destination
    • RebilledDrayage-Origin - Rebilled drayage - origin
    • Receiving - Receiving
    • RecipientAddressCorrection - Recipient address correction
    • ReclamationCenterHandlingChute - Reclamation center handling (chute)
    • ReclamationFederal - Reclamation, federal
    • ReclamationSharedResponsibility - Reclamation shared responsibility (SRS)
    • ReclamationState - Reclamation, state
    • Reconciliation - Reconciliation
    • Reconnectcharge - Reconnect charge
    • ReconsignConsigneeCharge - Reconsign consignee charge
    • ReconsignDeliveryCharge - Reconsign delivery charge
    • ReconsignmentCharge - Reconsignment charge
    • RecooperingAtOwnersOrShippersExpense - Recoopering (at owner's or shipper's expense)
    • RecordFiling - Record/filing
    • Recovery - Recovery
    • RecoveryFee - Recovery fee
    • RecratingRecoopering-Destination - Recrating/recoopering - destination
    • RecratingRecoopering-Origin - Recrating/recoopering - origin
    • RecurringHardwareMaintenanceCharge - Recurring hardware maintenance charge
    • RecurringLicenseFee - Recurring license fee
    • RecurringSoftwareMaintenanceCharge - Recurring software maintenance charge
    • Redelivery - Redelivery
    • RedistributionAllowance - Redistribution allowance
    • ReductionPrepalletizedCargo - Reduction prepalletized cargo
    • ReeferCargoPercentDifferential - Reefer cargo percent differential
    • ReeferMaintenance - Reefer maintenance
    • Reel - Reel
    • ReelCable - Reel cable
    • ReelDeposit - Reel deposit
    • Refrigeration - Refrigeration
    • RefrigerationMechanicalDetention - Refrigeration/mechanical detention
    • Refund - Refund
    • RefurbishingCharge - Refurbishing charge
    • Regain - Regain
    • RegistrationOfExportForReentry - Registration of export for reentry
    • RegistrationOfExportShipments - Registration of export shipments
    • RegulatoryFee - Regulatory fee
    • RegulatoryRequiredRefund - Regulatory required refund
    • ReliabilityCharge - Reliability charge
    • RelinquishmentCharge - Relinquishment charge
    • ReliquidationAnti-DumpingDuty - Reliquidation anti-dumping duty
    • ReliquidationCountervailingDuty - Reliquidation countervailing duty
    • ReliquidationTaxAmount - Reliquidation tax amount
    • ReliquidationTotalDueUSCustomsService - Reliquidation total due u.s. customs service (USCS)
    • ReliquidationTotalFees - Reliquidation total fees
    • RentalCharge - Rental charge
    • RentalDeduction - Rental deduction
    • RentsAndLeases - Rents and Leases
    • RepackCharge - Repack charge
    • Repair - Repair
    • RepairAtBuyersExpenseCharge - Repair at buyers expense charge
    • RepairAtCustomerExpenseCharge - Repair at customer expense charge
    • RepairAtGovernmentExpenseCharge - Repair at government expense charge
    • Repickup - Repickup
    • RequestViaCanada - Request via Canada
    • ResearchDevelopmentFee - Research and development fee
    • ResellersDiscount - Resellers discount
    • ResidentialDelivery - Residential delivery
    • ResidentialPick-up - Residential Pick-up
    • Respotting - Respotting
    • RestockingCharge - Restocking charge
    • RestrictedArticleFee - Restricted article fee
    • Retainer - Retainer
    • ReturnableContainer - Returnable container
    • ReturnCargoCharge - Return cargo charge
    • ReturnedLoad - Returned load
    • Rework - Rework
    • RidingAttendantCharge - Riding attendant charge
    • RockyMountainBureau583Item1100ArbitraryCharge - Rocky mountain bureau 583 item 1100 arbitrary charge
    • RollOutAdjustment - Roll out adjustment
    • RollRebate - Roll rebate
    • Royalties - Royalties
    • Salvage - Salvage
    • Same-DayService - Same - day service
    • SaturdayDelivery - Saturday delivery
    • SaturdayPick-Up - Saturday pick-up
    • SaturdayPick-upOrDeliveryCharge - Saturday pick-up or delivery charge
    • ScaleCharge - Scale charge
    • ScaleChargeUnloading - Scale charge unloading
    • ScrapAllowance - Scrap allowance
    • SecuritySignatureService - Security signature service
    • SegregatingSorting - Segregating (sorting)
    • SelectCharge - Select charge
    • SelfUnloader - Self unloader
    • SellerHandCarry - Seller hand carry
    • ServiceAssistanceProgramSurcharge - Service assistance program surcharge
    • ServiceCharge - Service charge
    • ServiceChargeWithCashDiscount - Service charge (with cash discount)
    • ServiceUpgrade - Service upgrade
    • Set-up - Set-up
    • Shearing - Shearing
    • SheepFee - Sheep fee
    • ShipperLoad - Shipper load
    • ShipperLoadAndCount - Shipper load and count
    • ShipperLoadCarrierCount - Shipper load carrier count
    • ShipperLoadConsigneeUnload - Shipper load consignee unload
    • Shipping - Shipping
    • ShippingAndHandling - Shipping and handling
    • ShipsidePickup - Shipside pickup
    • ShipToStockQualityAudit - Ship to stock quality audit
    • Shotblasting - Shotblasting
    • ShrinkageAllowance - Shrinkage allowance
    • ShrinkAllowance - Shrink allowance
    • Shrink-WrapCharge - Shrink-wrap charge
    • SingleFactorOriginationDestination - Single factor origination/destination
    • SingleFactorOriginationPortOfDebarkation - Single factor origination/port of debarkation
    • SingleFactorPortOfEmbarkationDestination - Single factor port of embarkation/destination
    • SingleInvoiceAllowance - Single invoice allowance
    • SinglePick-up - Single pick-up
    • SingleShipmentFee - Single shipment fee
    • Sleeving - Sleeving
    • SlipSheetRail - Slip sheet, rail
    • SlipSheetTruck - Slip sheet, truck
    • SlipSheetUnloadingAllowance - Slip sheet unloading allowance
    • SlottingAllowance - Slotting allowance
    • SmallOrderCharge - Small order charge
    • SoftwareSupportService - Software support service
    • SourceInspection - Source inspection
    • SpecialAllowance - Special allowance
    • SpecialBuy - Special buy
    • SpecialCircusTrains - Special circus trains
    • SpecialCredit - Special credit
    • SpecialDelivery - Special delivery
    • SpecialDetentionCharge - Special detention charge
    • SpecialEquipmentCharge - Special equipment charge
    • SpecialFinishCharge - Special finish charge
    • SpecialFreightSupplements - Special freight supplements
    • SpecialHandling - Special handling
    • SpecialMileageMovements - Special mileage movements
    • SpecialPackaging - Special packaging
    • SpecialPermits - Special permits
    • SpecialPickup - Special pickup
    • SpecialPumpCharge - Special pump charge
    • SpecialSealCharge - Special seal charge
    • SpecialServices - Special services
    • SpecialTestEquipmentCharge - Special test equipment charge
    • SpecialToolingCharge - Special tooling charge
    • SpecialToolingreworkcharge - Special Tooling rework charge
    • SpecialTrainMovement - Special train movement
    • SpecialUse - Special use
    • SpecialVehicleRent - Special vehicle rent
    • SpecificationReview - Specification review
    • SpecificDuty - Specific duty
    • SplitDelivery - Split delivery
    • SplitPick-up - Split pick-up
    • SplitPick-UpAtPierCharge - Split pick-up at pier charge
    • SpoolCharge - Spool charge
    • SpottingOfTrailer - Spotting of trailer
    • SpreaderCharge - Spreader charge
    • StampFee - Stamp fee
    • Stamping - Stamping
    • StandbyCharge - Standby charge
    • StateMetropolitanTransitAuthoritySurcharge - State/metropolitan transit authority surcharge
    • StateMotorFuel - State motor fuel
    • StateSalesCharge - State sales charge
    • StateSurcharge - State surcharge
    • SteamingCharge - Steaming charge
    • StencilingCharge - Stenciling charge
    • Stopcharge - Stopcharge
    • Stop-offAtDestination - Stop-off at destination
    • Stop-offAtOrigination - Stop-off at origination
    • Stop-offAtPierCharge - Stop-off at pier charge
    • Stop-offCharge - Stop-off charge
    • StoppingInTransit - Stopping in transit
    • Storage - Storage
    • StorageInTransit - Storage in transit
    • StraighteningCharge - Straightening charge
    • Strapping - Strapping
    • StreetLampsCharge - Street lamps charge
    • StrippingSortingAndConsolidation - Stripping, sorting, and consolidation
    • Stuffing - Stuffing
    • StuffingCharge - Stuffing charge
    • SubjectToCooperativeAdvertisingAllowance - Subject to cooperative advertising allowance
    • SubjectToTaxOnResale - Subject to tax on resale
    • SufferanceWarehouseChargeExportOrImport - Sufferance warehouse charge (export or import)
    • SugarFee - Sugar fee
    • SumOfAddsAndDeductsToMakeMarketValue - Sum of adds and deducts to make market value
    • SundayOrHolidayPick-upOrDelivery - Sunday or holiday pick-up or delivery
    • SuperBagCharge - Super bag charge
    • SupervisorCharge - Supervisor charge
    • SupplementalDuty - Supplemental duty
    • SupplementalItems - Supplemental items
    • Surcharge - Surcharge
    • SuretyBond - Surety bond
    • Swell - Swell
    • SwitchCharge - Switch charge
    • SwitchingCharge - Switching charge
    • TankCarAllowance - Tank car allowance
    • TankRental - Tank rental
    • Tarping - Tarping
    • Tax - Tax
    • Tax-AirportTaxDestination - Tax - airport tax, destination
    • Tax-AirportTaxOrigin - Tax - airport tax, origin
    • Tax-BeverageTax - Tax - beverage tax
    • Tax-CitySalesTaxOnly - Tax - city sales tax (only)
    • TaxCredit - Tax credit
    • Tax-ExciseTax-Destination - Tax - excise tax - destination
    • Tax-ExciseTax-Origin - Tax - excise tax - origin
    • Tax-FederalExciseTax - Tax - Federal excise tax, FET
    • Tax-FederalExciseTaxOnTires - Tax - Federal excise tax, FET, on Tires
    • Tax-Governmental - Tax - governmental
    • Tax-HandlingChargeTax - Tax - handling charge tax
    • TaxLiability-Amortized - Tax liability - amortized
    • TaxLiability-OneTime - Tax liability - one time
    • Tax-LocalSalesTax - Tax - local sales tax
    • Tax-LocalTax - Tax - local tax
    • Tax-MetropolitanTransitTax - Tax - metropolitan transit tax
    • TaxOnMiscellaneousCharges - Tax on miscellaneous charges
    • TaxOnTransportation - Tax on transportation
    • Tax-RegulatoryTax - Tax - regulatory tax
    • Tax-SalesandUse - Tax - sales and use
    • Tax-SalesTaxStateAndLocal - Tax - sales tax (state and local)
    • Tax-StateHazardousSubstance - Tax - state hazardous substance
    • Tax-StateTax - Tax - state tax
    • Tax-SuperFundExciseTax - Tax - super fund excise tax
    • Tax-UseTax - Tax - use tax
    • Tax-ValueAddedTax - Tax - value added tax (VAT)
    • TeaFee - Tea fee
    • TechnologyExchange - Technology exchange
    • TelegramChargeback - Telegram chargeback
    • TelephoneCharge - Telephone charge
    • Telephone-Destination - Telephone - destination
    • Telephone-Origin - Telephone - origin
    • TemperatureProtection - Temperature protection
    • TemporaryAllowance - Temporary allowance
    • TemporaryVoluntaryAllowance - Temporary voluntary allowance
    • TenderedAsTruckload - Tendered as truckload
    • TerminalCharge - Terminal charge
    • TerminalDifferential - Terminal differential
    • TerminalHandlingCharges - Terminal handling charges
    • TerminalServiceFee - Terminal service fee
    • TermsAllowance - Terms allowance
    • Testing - Testing
    • TestingServicesCharge - Testing services charge
    • TestQualificationCharge - Test/qualification charge
    • ThirdPartyAllowance - Third party allowance
    • ThirdPartyPallets - Third party pallets
    • ThroughputAllowance - Throughput allowance
    • ThroughputContainerCharge - Throughput container charge
    • ThruwayCharge - Thruway charge
    • TicketingService - Ticketing service
    • TobaccoProductsReportCharge - Tobacco products report charge
    • TOFCServiceCharge - Tofc service charge
    • ToolCharge - Tool charge
    • Tooling - Tooling
    • ToolingReworkCharge - Tooling rework charge
    • ToolsForPrinting - Tools for printing
    • TotalOther - The total for items other than those primarily reported upon in the message.
    • TotalAssessorialCharges - Total assessorial charges
    • TotalDueUSCustomsService - Total due U.S. customs service (USCS)
    • TotalFees - Total fees
    • TotalInvoiceAmount - Total invoice amount
    • TotalInvoiceAmountNon-USDollars - Total invoice amount, non-U.S. dollars
    • TotalInvoiceAmountUSDollars - Total invoice amount, U.S. dollars
    • TotalMaterialInvoiceAmount - Total material invoice amount
    • TracingInboundViaOtherCarriers - Tracing inbound via other carriers
    • TracingServiceFee - Tracing service fee
    • TrackStorage - Track storage
    • TradeDiscount - Trade discount
    • TradeIn - Trade in
    • TrailerRentalCharge - Trailer rental charge
    • TransferCharge - Transfer charge
    • TransferOfLadingCharge - Transfer of lading charge
    • TransferredCharges - Transferred charges
    • Transit - Transit
    • TransmissionCharge - Transmission charge
    • TransportationAndSetup - Transportation and setup
    • TransportationChargeMinimumRate - Transportation charge (minimum rate)
    • TransportationDirectBilling - Transportation direct billing
    • TransportationThirdPartyBilling - Transportation third party billing
    • TransportationVendorProvided - Transportation vendor provided
    • TrimmingCharge - Trimming charge
    • TruckDetention - Truck detention
    • TruckloadDiscount - Truckload discount
    • TurningCharge - Turning charge
    • Two-DayService - Two - day service
    • TwoDoorPickUp - Two door pick up
    • UnabsorbedSwitching - Unabsorbed switching
    • Unitized - Unitized
    • Unloading - Unloading
    • UnloadingLaborCharges - Unloading (labor charges)
    • UnloadingReloadingCharge - Unloading/reloading charge
    • UnsaleableMerchandiseAllowance - Unsaleable merchandise allowance
    • UnscheduledFee - Unscheduled fee
    • UpCharge - Up charge
    • UsagePlanDetailCharge - Usage plan detail charge
    • USCustomsServiceFlatAssistAmount - U.S. customs service (USCS) flat assist amount
    • USCustomsServiceMaximumAssistAmount - U.S. customs service (USCS) maximum assist amount
    • USDAInspectedStampingCertification - USDA inspected, stamping certification
    • UseChargeToolingPersonnel - Use charge tooling/personnel
    • Use-SpecialTypeFlatCar - Use - special type flat car
    • USVehicles - U.S. vehicles
    • ValuationFee - Valuation fee
    • VanCleaning - Van cleaning
    • VehicleOrderedButNotUsed - Vehicle ordered but not used
    • VehiclePrepChargeCourtesyDelivery - Vehicle prep charge (courtesy delivery)
    • VehicleRoadCharge - Vehicle road charge
    • VendorFreight - Vendor freight
    • VentingInstructions - Venting instructions
    • VirginIslandTransferCharge - Virgin island transfer charge
    • VolumeDiscount - Volume discount
    • VoluntaryContributionCharge - Voluntary contribution charge
    • WaitingTime - Waiting time
    • Warehouse - Warehouse
    • Warehousing - Warehousing
    • Warranties - Warranties
    • WarRiskCrewInsurance - War risk crew insurance
    • WarRiskInsurance - War risk insurance
    • WarRiskSurcharge - War risk surcharge
    • WastedFutileTrip - Wasted/futile trip
    • WatermelonFee - Watermelon fee
    • WaybillAndInvoiceDistribution - Waybill and invoice distribution
    • WeatherProtection - Weather protection
    • WeightVerificationCharge - Weight verification charge
    • Wharfage-Breakbulk - Wharfage - breakbulk
    • WharfageCharge - Wharfage charge
    • Wharfage-Container - Wharfage - container
    • WharfageHandling - Wharfage and Handling
    • WideAreaTelephoneServiceUsageCredit - Wide area telephone service (WATS) usage credit
    • WillCallCharge - Will call charge
    • WrittenProofOfDelivery - Written proof of delivery
    • X-rayCharge - X-ray charge

[^]Code Fragment

    <xsd:simpleType name="ServiceCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="About">
        <xsd:enumeration value="AbsoluteMinimumCharge">
        <xsd:enumeration value="AccessCharge-Federal">
        <xsd:enumeration value="AccessCharges">
        <xsd:enumeration value="AccessCharge-State">
        <xsd:enumeration value="AccountNumberCorrectionCharge">
        <xsd:enumeration value="AcidBattery">
        <xsd:enumeration value="AcknowledgmentofDeliveryFeeAOD">
        <xsd:enumeration value="ActivationOfCarnet">
        <xsd:enumeration value="AdditionalCommercialInvoices">
        <xsd:enumeration value="AdditionalCopiesOfFreightBill">
        <xsd:enumeration value="AdditionalMaterial">
        <xsd:enumeration value="AdditionalTariffClassifications">
        <xsd:enumeration value="AddOn-Destination">
        <xsd:enumeration value="AddOn-Origin">
        <xsd:enumeration value="AddressCorrection">
        <xsd:enumeration value="AddToMakeMarketValue">
        <xsd:enumeration value="Adjustment">
        <xsd:enumeration value="AdjustmentForMaximumChargesBilling">
        <xsd:enumeration value="AdjustmentForMinimumAverageTimeRequirementBilling">
        <xsd:enumeration value="Adjustments">
        <xsd:enumeration value="Administrative">
        <xsd:enumeration value="AdValorem">
        <xsd:enumeration value="AdvanceChargesHandling">
        <xsd:enumeration value="AdvanceDestinationAmount">
        <xsd:enumeration value="AdvanceDestinationFee">
        <xsd:enumeration value="AdvanceFee">
        <xsd:enumeration value="AdvanceLadingCharge">
        <xsd:enumeration value="AdvanceOriginAmount">
        <xsd:enumeration value="AdvanceOriginFee">
        <xsd:enumeration value="Advances">
        <xsd:enumeration value="AdvertisingAllowance">
        <xsd:enumeration value="Affidavit">
        <xsd:enumeration value="AgentDisbursement-Destination">
        <xsd:enumeration value="AgentDisbursement-Origin">
        <xsd:enumeration value="AircraftOnGround">
        <xsd:enumeration value="AirExportCertificate">
        <xsd:enumeration value="AirExpressCharge">
        <xsd:enumeration value="AirlineOpeningFee">
        <xsd:enumeration value="AirportTerminalHandlingCharge">
        <xsd:enumeration value="AirTransportationCharge">
        <xsd:enumeration value="AlcoholicBeverageReportCharge">
        <xsd:enumeration value="AlleghenyCountyPADeliveryCharge">
        <xsd:enumeration value="Allowance">
        <xsd:enumeration value="AllowanceLineItems">
        <xsd:enumeration value="AllowanceMessage">
        <xsd:enumeration value="AllowancePerCallOf">
        <xsd:enumeration value="AllowanceAdvance">
        <xsd:enumeration value="AllowanceForConsignmentMerchandise">
        <xsd:enumeration value="AllowanceNon-Performance">
        <xsd:enumeration value="AllowanceRequest">
        <xsd:enumeration value="Alterations">
        <xsd:enumeration value="AmendingExportDocumentation">
        <xsd:enumeration value="AnnealHeatSteelorGlassTreatment">
        <xsd:enumeration value="AnodizingCharge">
        <xsd:enumeration value="Anti-dumpingDuty">
        <xsd:enumeration value="AppointmentNotification">
        <xsd:enumeration value="ArbitraryInAdditionToThroughRatesandCharges">
        <xsd:enumeration value="ArtWork">
        <xsd:enumeration value="Assembly">
        <xsd:enumeration value="AssistAmount">
        <xsd:enumeration value="AttachmentsToBillOfLadingCharge">
        <xsd:enumeration value="BadDebt">
        <xsd:enumeration value="BankingDrafts">
        <xsd:enumeration value="BargeFreightAllKindsService">
        <xsd:enumeration value="BaseCharge">
        <xsd:enumeration value="BasicReorderAllowance">
        <xsd:enumeration value="BeamingCharge">
        <xsd:enumeration value="BeddingFeedingDisinfecting">
        <xsd:enumeration value="BeefFee">
        <xsd:enumeration value="BeyondCharge">
        <xsd:enumeration value="BeyondFreightCharges">
        <xsd:enumeration value="BillAndHold">
        <xsd:enumeration value="BilledDemand">
        <xsd:enumeration value="BillOfLadingAttendancy">
        <xsd:enumeration value="BillOfLadingCharge">
        <xsd:enumeration value="BlackLungTax">
        <xsd:enumeration value="BlockingAndBracingCharge">
        <xsd:enumeration value="BlowerCharge">
        <xsd:enumeration value="BobtailCharges">
        <xsd:enumeration value="BondAmount">
        <xsd:enumeration value="BondCharge">
        <xsd:enumeration value="BopSheet">
        <xsd:enumeration value="BordeauxArbitraries">
        <xsd:enumeration value="Both-Flat">
        <xsd:enumeration value="BreakbulkServices">
        <xsd:enumeration value="BreakBulkSurfaceCharge">
        <xsd:enumeration value="BridgeToll">
        <xsd:enumeration value="BrokenLot">
        <xsd:enumeration value="BrokenPackageCharge">
        <xsd:enumeration value="Brokerage">
        <xsd:enumeration value="BrokerageOrDuty">
        <xsd:enumeration value="BunkerAdjustment">
        <xsd:enumeration value="BunkerAdjustment-20FootContainer">
        <xsd:enumeration value="BunkerAdjustment-40FootContainer">
        <xsd:enumeration value="BunkerSurcharge">
        <xsd:enumeration value="BurdenOverheadOrAllowanceForIndirectCosts">
        <xsd:enumeration value="Burning">
        <xsd:enumeration value="BuyerHandCarry">
        <xsd:enumeration value="BuyersCarAllowance">
        <xsd:enumeration value="CablePressurization">
        <xsd:enumeration value="CablesSendingOf">
        <xsd:enumeration value="CallTag">
        <xsd:enumeration value="CampArbitrary">
        <xsd:enumeration value="CanadaGreatLakesAdditionals">
        <xsd:enumeration value="CanadianCQCustomsClearance">
        <xsd:enumeration value="CanadianCurrencyExchange">
        <xsd:enumeration value="CanadianImportTerminationFee">
        <xsd:enumeration value="CanadianReconsignmentFee">
        <xsd:enumeration value="CanadianRemanifestFee">
        <xsd:enumeration value="CancellationCharge">
        <xsd:enumeration value="CancelledOrderHeavyDutyFlatcar">
        <xsd:enumeration value="Capping">
        <xsd:enumeration value="CaptureAdditionalData">
        <xsd:enumeration value="CargoTaxes">
        <xsd:enumeration value="CarLoading">
        <xsd:enumeration value="CarRental">
        <xsd:enumeration value="Carrier">
        <xsd:enumeration value="CarrierCreditAllowance">
        <xsd:enumeration value="CarrierDebitAllowance">
        <xsd:enumeration value="CarrierNotificationCharge">
        <xsd:enumeration value="Cartage">
        <xsd:enumeration value="CartageCharge">
        <xsd:enumeration value="CatalogingServices">
        <xsd:enumeration value="CentralBuy">
        <xsd:enumeration value="CentsOff">
        <xsd:enumeration value="CertificateOfConformance">
        <xsd:enumeration value="CertificateOfOrigin">
        <xsd:enumeration value="CertificateOfRegistration">
        <xsd:enumeration value="Certification">
        <xsd:enumeration value="ChainAndBinders">
        <xsd:enumeration value="ChamberOfCommerceServiceCharge">
        <xsd:enumeration value="ChangeOfAirbill-ServiceFee">
        <xsd:enumeration value="Charge">
        <xsd:enumeration value="ChargeLineItems">
        <xsd:enumeration value="ChargeMessage">
        <xsd:enumeration value="ChargePerCallOf">
        <xsd:enumeration value="ChargesForwardAdvanceCharge">
        <xsd:enumeration value="CharterServices">
        <xsd:enumeration value="ChassisTransfer">
        <xsd:enumeration value="ChemicalMillingCharge">
        <xsd:enumeration value="ChicagoLoopCharge">
        <xsd:enumeration value="CigaretteStamping">
        <xsd:enumeration value="CityDelivery">
        <xsd:enumeration value="CityMaintenanceFee">
        <xsd:enumeration value="CityPick-up">
        <xsd:enumeration value="CityTerminalCharge">
        <xsd:enumeration value="CleaningCharge">
        <xsd:enumeration value="ClosingSealing">
        <xsd:enumeration value="CoatingDipRustproofEDP">
        <xsd:enumeration value="CODAmount">
        <xsd:enumeration value="CODCharges">
        <xsd:enumeration value="CollectOnDeliveryAlterationCharge">
        <xsd:enumeration value="CollectOnDeliveryDeletionCharge">
        <xsd:enumeration value="CollectSurcharge">
        <xsd:enumeration value="Co-manufacturingDiscount">
        <xsd:enumeration value="Combination">
        <xsd:enumeration value="CombinationPerformanceAndNon-performance">
        <xsd:enumeration value="CombineAllSameDayShipment">
        <xsd:enumeration value="CommissionAmount">
        <xsd:enumeration value="CommunicationsCharges">
        <xsd:enumeration value="CompetitiveAllowance">
        <xsd:enumeration value="CompetitiveCarAllowance">
        <xsd:enumeration value="CompetitivePrice">
        <xsd:enumeration value="CompressorCharge">
        <xsd:enumeration value="ConcessionCredit">
        <xsd:enumeration value="ConcessionMoney">
        <xsd:enumeration value="CongestionSurcharge">
        <xsd:enumeration value="ConnectCharge">
        <xsd:enumeration value="ConservationResearchFee">
        <xsd:enumeration value="ConsigneeUnload">
        <xsd:enumeration value="Consolidation">
        <xsd:enumeration value="ConstantSurveillanceService">
        <xsd:enumeration value="ConstantSurveillanceService-Armed">
        <xsd:enumeration value="ConsularizationFee">
        <xsd:enumeration value="ConsularLegalizationService">
        <xsd:enumeration value="ConsultingService">
        <xsd:enumeration value="ConsumerServiceProviderCharge">
        <xsd:enumeration value="ContainerAllowance">
        <xsd:enumeration value="ContainerDeposits">
        <xsd:enumeration value="ContainerDestuffing">
        <xsd:enumeration value="ContainerDiscount">
        <xsd:enumeration value="ContainerDiversion">
        <xsd:enumeration value="ContainerLease">
        <xsd:enumeration value="ContainerLeasing">
        <xsd:enumeration value="ContainerLossDamage">
        <xsd:enumeration value="ContainerServiceChargeUKEUR">
        <xsd:enumeration value="ContainerServiceChargeUSACanada">
        <xsd:enumeration value="ContainerStuffing">
        <xsd:enumeration value="ContainerTrailerAllowance">
        <xsd:enumeration value="ContinuousMileage">
        <xsd:enumeration value="ContractAllowance">
        <xsd:enumeration value="ContractEscalation">
        <xsd:enumeration value="ContractServiceCharge">
        <xsd:enumeration value="ControlledAtmosphere">
        <xsd:enumeration value="Converting">
        <xsd:enumeration value="Co-opCredit">
        <xsd:enumeration value="CooperativeAdvertisingMerchandisingAllowancePerformance">
        <xsd:enumeration value="Copying">
        <xsd:enumeration value="CopyOfBillOfLadingCharge">
        <xsd:enumeration value="CopyOfDeliveryReceiptCharge">
        <xsd:enumeration value="CoreCharge">
        <xsd:enumeration value="CostRecoveryAdjustment">
        <xsd:enumeration value="CostRecoveryFactor">
        <xsd:enumeration value="CottonFee">
        <xsd:enumeration value="CountAndRecount">
        <xsd:enumeration value="CountervailingDuty">
        <xsd:enumeration value="CouponReimbursement">
        <xsd:enumeration value="Crafting">
        <xsd:enumeration value="Crating">
        <xsd:enumeration value="Credit">
        <xsd:enumeration value="CurrencyAdjustment">
        <xsd:enumeration value="CurrencyAdjustment-20FootContainer">
        <xsd:enumeration value="CurrencyAdjustment-40FootContainer">
        <xsd:enumeration value="CurrencyAdjustment-BreakBulk">
        <xsd:enumeration value="CurrencyAdjustmentFactor">
        <xsd:enumeration value="CurrencyDiscount">
        <xsd:enumeration value="CustomerAccountIdentification">
        <xsd:enumeration value="CustomerEquipmentAllowance">
        <xsd:enumeration value="CustomsBrokerFee">
        <xsd:enumeration value="CustomsCharge">
        <xsd:enumeration value="CustomsDuty">
        <xsd:enumeration value="CustomsEntry">
        <xsd:enumeration value="CustomsExam">
        <xsd:enumeration value="CustomsFees-ContainerLevel">
        <xsd:enumeration value="CustomsFees-LiftLevel">
        <xsd:enumeration value="CustomsFormalities">
        <xsd:enumeration value="CustomsInvoice">
        <xsd:enumeration value="CustomsInvoice-AdditionalPage">
        <xsd:enumeration value="CustomsPenalty">
        <xsd:enumeration value="Cut">
        <xsd:enumeration value="CutAndParallel">
        <xsd:enumeration value="CuttingCharge">
        <xsd:enumeration value="DamagedMerchandise">
        <xsd:enumeration value="DamageToCarrierEquipment">
        <xsd:enumeration value="DamageToCarrierVessel">
        <xsd:enumeration value="DamageToGovernmentEquipment">
        <xsd:enumeration value="DataDrawingCharge">
        <xsd:enumeration value="DeadheadMileageCharge">
        <xsd:enumeration value="DeafAndDisabledSurcharge">
        <xsd:enumeration value="DeclaredValueForCarriage">
        <xsd:enumeration value="DeclaredValueForCustoms">
        <xsd:enumeration value="DeclaredValueForInsurance">
        <xsd:enumeration value="DeductToMakeMarketValue">
        <xsd:enumeration value="DefectiveAllowance">
        <xsd:enumeration value="DeficitFreight">
        <xsd:enumeration value="De-Installation">
        <xsd:enumeration value="DelayFurnishingDestinationWeights">
        <xsd:enumeration value="Delivery">
        <xsd:enumeration value="DeliverySurcharge">
        <xsd:enumeration value="DemandCharge">
        <xsd:enumeration value="Demurrage">
        <xsd:enumeration value="Demurrage-AverageAgreement">
        <xsd:enumeration value="Demurrage-Special">
        <xsd:enumeration value="Deposit">
        <xsd:enumeration value="DepositCharges">
        <xsd:enumeration value="DepositInLieuOfOrder">
        <xsd:enumeration value="Deramping">
        <xsd:enumeration value="DerrickCharge">
        <xsd:enumeration value="DesignatedSupplierInspection">
        <xsd:enumeration value="DestinationCharge">
        <xsd:enumeration value="DetentionLoading">
        <xsd:enumeration value="DetentionOfPowerUnits">
        <xsd:enumeration value="DetentionOfTrailers">
        <xsd:enumeration value="Detention-SpecialTypeFlatCar">
        <xsd:enumeration value="DetentionUnloading">
        <xsd:enumeration value="DeterminedFreight">
        <xsd:enumeration value="DevelopmentCharge">
        <xsd:enumeration value="DieServiceCharge">
        <xsd:enumeration value="DirectProductHandling">
        <xsd:enumeration value="Disbursement">
        <xsd:enumeration value="DisconnectCharge">
        <xsd:enumeration value="Discount">
        <xsd:enumeration value="Discount-DropBoxConvenienceCtr">
        <xsd:enumeration value="Discount-Incentive">
        <xsd:enumeration value="Discount-MultipleShipment">
        <xsd:enumeration value="Discount-ServiceOptionDelivery">
        <xsd:enumeration value="Discount-ServiceOptionPickup">
        <xsd:enumeration value="Discount-Special">
        <xsd:enumeration value="DisplayAllowance">
        <xsd:enumeration value="DistributionFee">
        <xsd:enumeration value="DistributionService">
        <xsd:enumeration value="DistributorDiscountAllowance">
        <xsd:enumeration value="DiversionAndReconsignment">
        <xsd:enumeration value="DiversionCharge">
        <xsd:enumeration value="DiversionToAirCharge">
        <xsd:enumeration value="Dockage-BoatDetention">
        <xsd:enumeration value="DocumentationCharge">
        <xsd:enumeration value="DocumentHandling">
        <xsd:enumeration value="Door-To-Door">
        <xsd:enumeration value="DowelPinCharge">
        <xsd:enumeration value="DrayagAtPortOfDebarkation">
        <xsd:enumeration value="Drayage">
        <xsd:enumeration value="DrayageatPortOfDebarkationRateZone">
        <xsd:enumeration value="DrayageAtPortOfEmbarkation">
        <xsd:enumeration value="DrayageatPortOfEmbarkationRateZone">
        <xsd:enumeration value="DrayageLineHaul">
        <xsd:enumeration value="DriverAssistedUnloading">
        <xsd:enumeration value="DriversWages">
        <xsd:enumeration value="DropDock">
        <xsd:enumeration value="DropYard">
        <xsd:enumeration value="DrumCost">
        <xsd:enumeration value="DrumDeposit">
        <xsd:enumeration value="DrumUpCharge">
        <xsd:enumeration value="DryerCharge">
        <xsd:enumeration value="DryIce">
        <xsd:enumeration value="Dunnage">
        <xsd:enumeration value="DutyCharge">
        <xsd:enumeration value="DutyDrawback">
        <xsd:enumeration value="EarlyBuyAllowance">
        <xsd:enumeration value="EarlyPaymentAllowance">
        <xsd:enumeration value="EarlyShipAllowance">
        <xsd:enumeration value="EmergencyPortCharge">
        <xsd:enumeration value="EmergencyService">
        <xsd:enumeration value="EmergencySurcharge">
        <xsd:enumeration value="EmptyWeighingCharge">
        <xsd:enumeration value="Enclosure">
        <xsd:enumeration value="EndorsementFee">
        <xsd:enumeration value="Energycharge">
        <xsd:enumeration value="EnergySurchargeFuelAdjustmentFactor">
        <xsd:enumeration value="EngineeringCharge">
        <xsd:enumeration value="EngineeringSupplies">
        <xsd:enumeration value="Engraving">
        <xsd:enumeration value="EnteredValue">
        <xsd:enumeration value="EnvironmentalProtectionService">
        <xsd:enumeration value="EquipmentManufacturerRestorationAudit">
        <xsd:enumeration value="Escalation">
        <xsd:enumeration value="EscortService">
        <xsd:enumeration value="Escrow">
        <xsd:enumeration value="Eur1PresentationFee">
        <xsd:enumeration value="EuropeanPortCharges">
        <xsd:enumeration value="Exact">
        <xsd:enumeration value="ExcessiveValueCharge">
        <xsd:enumeration value="ExcessMileageCharge">
        <xsd:enumeration value="ExcessPeriods">
        <xsd:enumeration value="ExcessValueFee">
        <xsd:enumeration value="ExcessWeight">
        <xsd:enumeration value="ExchangeAccessCredit">
        <xsd:enumeration value="ExclusiveUse">
        <xsd:enumeration value="ExclusiveUseOfEquipment">
        <xsd:enumeration value="ExhibitionDeliveryCharge">
        <xsd:enumeration value="ExhibitionPickupCharge">
        <xsd:enumeration value="ExpandedService">
        <xsd:enumeration value="ExpeditedOneDayConsularService">
        <xsd:enumeration value="ExpeditedServiceCharge">
        <xsd:enumeration value="ExpeditedShipments">
        <xsd:enumeration value="ExpeditingFee">
        <xsd:enumeration value="ExpeditingPremium">
        <xsd:enumeration value="ExportCustomsClearance">
        <xsd:enumeration value="ExportDeclarations-Automated">
        <xsd:enumeration value="ExportDeclarations-USShippers">
        <xsd:enumeration value="ExportImportCharge">
        <xsd:enumeration value="ExportLicenseApplication">
        <xsd:enumeration value="ExportShippingCharge">
        <xsd:enumeration value="ExtraCopiesandMailings">
        <xsd:enumeration value="ExtraLaborHelperService">
        <xsd:enumeration value="ExtraLength">
        <xsd:enumeration value="ExtraLengthSurcharge">
        <xsd:enumeration value="ExtraService-Counter-To-Counter">
        <xsd:enumeration value="FabricationCharge">
        <xsd:enumeration value="FacsimileCharges">
        <xsd:enumeration value="FacsimileCharges-AdditionalPages">
        <xsd:enumeration value="FailedLampPanelCharge">
        <xsd:enumeration value="FaxPre-alert">
        <xsd:enumeration value="FederalTransferSurcharge">
        <xsd:enumeration value="Fee">
        <xsd:enumeration value="FinanceCharge">
        <xsd:enumeration value="FirstArticleCharge">
        <xsd:enumeration value="FirstFlightOut">
        <xsd:enumeration value="FlatrackSurcharge">
        <xsd:enumeration value="FlatRate">
        <xsd:enumeration value="FloorStockProtection">
        <xsd:enumeration value="FoodAndLodging">
        <xsd:enumeration value="ForeignCustomsDuty">
        <xsd:enumeration value="ForeignMilitarySalesRental">
        <xsd:enumeration value="ForeignMilitarySalesSpecialCharge">
        <xsd:enumeration value="ForeignOfficeAdvance">
        <xsd:enumeration value="ForwardCoupons">
        <xsd:enumeration value="ForwardingAgentCommission">
        <xsd:enumeration value="ForwardingCharge">
        <xsd:enumeration value="FranchiseFee">
        <xsd:enumeration value="FreeDomicileShipmentProcessing">
        <xsd:enumeration value="FreeGoods">
        <xsd:enumeration value="Freight">
        <xsd:enumeration value="FreightBasedOnDollarMinimum">
        <xsd:enumeration value="FreightChargesToBorder">
        <xsd:enumeration value="FreightChargesToDestination">
        <xsd:enumeration value="FreightEqualization">
        <xsd:enumeration value="FreightInternational">
        <xsd:enumeration value="FreightInternationalNon-USDollars">
        <xsd:enumeration value="FreightInternationalUSDollars">
        <xsd:enumeration value="FreightPassthrough">
        <xsd:enumeration value="FreightSurcharge">
        <xsd:enumeration value="FreshnessLeakerAllowance">
        <xsd:enumeration value="FuelCharge">
        <xsd:enumeration value="FuelSurcharge">
        <xsd:enumeration value="FullService">
        <xsd:enumeration value="FullTruckloadAllowance">
        <xsd:enumeration value="Fumigation">
        <xsd:enumeration value="GarmentDistrict">
        <xsd:enumeration value="GarmentSurcharge">
        <xsd:enumeration value="GasPressure">
        <xsd:enumeration value="GatewayFee">
        <xsd:enumeration value="Glaze">
        <xsd:enumeration value="GoldFactor">
        <xsd:enumeration value="GoodsAndServicesCharge">
        <xsd:enumeration value="GoodsAndServicesCreditAllowance">
        <xsd:enumeration value="GoodsAndServicesTaxCharge">
        <xsd:enumeration value="GovernmentInspection">
        <xsd:enumeration value="GovernmentWarehouseFee-Destination">
        <xsd:enumeration value="GovernmentWarehouseFee-Origin">
        <xsd:enumeration value="GrainDoors">
        <xsd:enumeration value="GrainFlowCharge">
        <xsd:enumeration value="Gratuity">
        <xsd:enumeration value="Grinding">
        <xsd:enumeration value="GrossReceiptsSurcharge">
        <xsd:enumeration value="GroupageDiscount">
        <xsd:enumeration value="GroupedItems">
        <xsd:enumeration value="GuaranteedInspectionTechnicalService">
        <xsd:enumeration value="GulfPortDeliveryCharge">
        <xsd:enumeration value="Handling">
        <xsd:enumeration value="HandlingChargesOnDistributionFreightForwardedBeyond">
        <xsd:enumeration value="HandlingFreightAtPositionsNotImmediatelyAdjacentToVehicleCharge">
        <xsd:enumeration value="HarborMaintenanceFee">
        <xsd:enumeration value="HarborMaintenanceReport">
        <xsd:enumeration value="HaulingAndHoisting">
        <xsd:enumeration value="HaulingAndHoistingToBeDirectBilled">
        <xsd:enumeration value="HazardousCargoCharge">
        <xsd:enumeration value="HazardousCargoOnDeck">
        <xsd:enumeration value="HazardousMaterialsHandlingFee-Domestic">
        <xsd:enumeration value="HazardousMaterialsHandlingFee-International">
        <xsd:enumeration value="HazardousStorage">
        <xsd:enumeration value="HeatInTransitCharges">
        <xsd:enumeration value="HeatTreatCharge">
        <xsd:enumeration value="HeavyDutyFlatCarCharge">
        <xsd:enumeration value="HeavyLift">
        <xsd:enumeration value="HighSecurityRedIn-bondSealCharge">
        <xsd:enumeration value="HighwayInterchange">
        <xsd:enumeration value="HointinsAndHauling">
        <xsd:enumeration value="HoldingCharge">
        <xsd:enumeration value="HomeLineFreightCharge">
        <xsd:enumeration value="HoneyFee">
        <xsd:enumeration value="Hook-upcharge">
        <xsd:enumeration value="HoseCharge">
        <xsd:enumeration value="HoseChargeSpecial">
        <xsd:enumeration value="HouseholdGoodsPick-upOrDelivery">
        <xsd:enumeration value="IATAAirbillPreparation">
        <xsd:enumeration value="IATAFee">
        <xsd:enumeration value="Identification">
        <xsd:enumeration value="ImportServiceFee">
        <xsd:enumeration value="ImproperDocumentation">
        <xsd:enumeration value="InboundFreightCharges">
        <xsd:enumeration value="IncomeFreightManufacturingToShippingPoint">
        <xsd:enumeration value="IncorrectBillingAccountCharge">
        <xsd:enumeration value="IndustryPriceAllowance">
        <xsd:enumeration value="InitialLicenseFee">
        <xsd:enumeration value="InlandTransportation">
        <xsd:enumeration value="InsideCableConnectors">
        <xsd:enumeration value="InsideDelivery">
        <xsd:enumeration value="InsidePick-up">
        <xsd:enumeration value="InspectAtDestination">
        <xsd:enumeration value="InspectAtOrigin">
        <xsd:enumeration value="Inspection">
        <xsd:enumeration value="Installation">
        <xsd:enumeration value="InstallationAndTraining">
        <xsd:enumeration value="InstallationWarranty">
        <xsd:enumeration value="InsulatedTankCharge">
        <xsd:enumeration value="Insurance">
        <xsd:enumeration value="InsuranceFee">
        <xsd:enumeration value="InsurancePlacementCostCharge">
        <xsd:enumeration value="InsurancePremium">
        <xsd:enumeration value="InsuranceProvidedByLessee">
        <xsd:enumeration value="InsuranceProvidedByLessor">
        <xsd:enumeration value="InsuranceSurcharge">
        <xsd:enumeration value="InterdivisionProfit">
        <xsd:enumeration value="InterestAmount">
        <xsd:enumeration value="InterestOnRefund">
        <xsd:enumeration value="InterestOnSecurityDeposit">
        <xsd:enumeration value="InterimUsePermittedAtSpecialRate">
        <xsd:enumeration value="InternationalAirTransportAssociationCommission">
        <xsd:enumeration value="InternationalAirTransportAssociationMarkup">
        <xsd:enumeration value="InternationalCourier">
        <xsd:enumeration value="InternationalDoor-to-DoorHandlingFee">
        <xsd:enumeration value="InterplantCharge">
        <xsd:enumeration value="InterstateHighwayToll">
        <xsd:enumeration value="InTransitPriceProtection">
        <xsd:enumeration value="Intra-plantCharge">
        <xsd:enumeration value="InvoiceAdditionalAmount">
        <xsd:enumeration value="InvoiceAdjustment">
        <xsd:enumeration value="InvoiceAt-CostAmount">
        <xsd:enumeration value="InvoiceDeliveryTermsAmount">
        <xsd:enumeration value="InvoiceNo-ChargeAmount">
        <xsd:enumeration value="InvoiceServices">
        <xsd:enumeration value="InvoiceWithGoods">
        <xsd:enumeration value="IrishArbitraries">
        <xsd:enumeration value="IslandDeliveryCharge">
        <xsd:enumeration value="IslandPick-UpCharge">
        <xsd:enumeration value="ItalianReleaseCharge">
        <xsd:enumeration value="ItemPercentage">
        <xsd:enumeration value="Item-Unit">
        <xsd:enumeration value="KeepFromFreezingPercentDifferential">
        <xsd:enumeration value="Koshering">
        <xsd:enumeration value="LabelAllowance">
        <xsd:enumeration value="Labeling">
        <xsd:enumeration value="LaborCharges">
        <xsd:enumeration value="LaborCostOfRemoval">
        <xsd:enumeration value="LaborModify">
        <xsd:enumeration value="LaborNoTroubleFound">
        <xsd:enumeration value="LaborOvertime">
        <xsd:enumeration value="LaborPremiumOvertime">
        <xsd:enumeration value="LaborRepairAndReturnOrders">
        <xsd:enumeration value="LaborService">
        <xsd:enumeration value="LaborStraight-time">
        <xsd:enumeration value="LaborTestAndCalibrate">
        <xsd:enumeration value="LadingAdjustmentCharge">
        <xsd:enumeration value="LandCurrencyAdjustmentFactor-20FootContainer">
        <xsd:enumeration value="LandCurrencyAdjustmentFactor-40FootContainer">
        <xsd:enumeration value="Lashing">
        <xsd:enumeration value="LateOrderCharge">
        <xsd:enumeration value="LatePaymentCharge">
        <xsd:enumeration value="LayoutDesign">
        <xsd:enumeration value="LayoverCharges">
        <xsd:enumeration value="LeadFactor">
        <xsd:enumeration value="LeakingUndergroundStorageTax">
        <xsd:enumeration value="LeaseShortfallConsideration">
        <xsd:enumeration value="LessThanContainer">
        <xsd:enumeration value="LessThanTruckloadCharge">
        <xsd:enumeration value="LetterOfCreditProcessing">
        <xsd:enumeration value="LicenseAndTitle">
        <xsd:enumeration value="LifelineSurcharge">
        <xsd:enumeration value="LiftGateTruckOrForkliftServiceAtPick-upDelivery">
        <xsd:enumeration value="LimeFee">
        <xsd:enumeration value="LineItemAllowance">
        <xsd:enumeration value="LineItemCharge">
        <xsd:enumeration value="LinehaulFromPortOfDebarkation">
        <xsd:enumeration value="LinehaulPercentDifferential">
        <xsd:enumeration value="LinehaulToPortOfEmbarkation">
        <xsd:enumeration value="LinerTermsAtPortOfDebarkation">
        <xsd:enumeration value="LinerTermsAtPortOfEmbarkation">
        <xsd:enumeration value="LiquidatedDamages">
        <xsd:enumeration value="LiquidationAnti-DumpingDuty">
        <xsd:enumeration value="LiquidationCountervailingDuty">
        <xsd:enumeration value="LiquidationTaxAmount">
        <xsd:enumeration value="LiquidationTotalDueUSCustomsService">
        <xsd:enumeration value="LiquidationTotalFees">
        <xsd:enumeration value="Loading">
        <xsd:enumeration value="LoadingLaborCharges">
        <xsd:enumeration value="LoadWeighingCharge">
        <xsd:enumeration value="LoanFee">
        <xsd:enumeration value="LocalDeliveryDrayage">
        <xsd:enumeration value="LocomotiveDelayedInSwitchingService">
        <xsd:enumeration value="LocomotiveUnderOwnPower">
        <xsd:enumeration value="LotCharge">
        <xsd:enumeration value="LotteryChargeBack">
        <xsd:enumeration value="LotteryCrossRedeemed">
        <xsd:enumeration value="Low-TierLotteryCashingBonus">
        <xsd:enumeration value="Low-TierLotteryWinners">
        <xsd:enumeration value="LumpSum">
        <xsd:enumeration value="MachiningCharge">
        <xsd:enumeration value="MailFee">
        <xsd:enumeration value="Mailing-PostageCost">
        <xsd:enumeration value="Mailing-ServiceFee">
        <xsd:enumeration value="MailInvoice">
        <xsd:enumeration value="MailInvoiceToEachLocation">
        <xsd:enumeration value="ManifestCharge">
        <xsd:enumeration value="Manufacturing">
        <xsd:enumeration value="MarketDevelopmentFunds">
        <xsd:enumeration value="MarkingOrTaggingCharge">
        <xsd:enumeration value="MarriageRule">
        <xsd:enumeration value="Maximum">
        <xsd:enumeration value="MemoReturnableContainer">
        <xsd:enumeration value="MerchandiseProcessingFee">
        <xsd:enumeration value="MessageCharge">
        <xsd:enumeration value="MessageRateAdjustment">
        <xsd:enumeration value="MessengerService">
        <xsd:enumeration value="MetalsSurcharge">
        <xsd:enumeration value="MeterCharge">
        <xsd:enumeration value="Mid-TierLotteryCashingBonus">
        <xsd:enumeration value="Mid-TierLotteryWinners">
        <xsd:enumeration value="MileageFeeForRepairAndReturn">
        <xsd:enumeration value="MileageOrTravel">
        <xsd:enumeration value="Minus-Amount">
        <xsd:enumeration value="Minus-Percentage">
        <xsd:enumeration value="ModifiedAtmosphere">
        <xsd:enumeration value="MonthlyRental">
        <xsd:enumeration value="MountDemount">
        <xsd:enumeration value="Mounting">
        <xsd:enumeration value="MunicipalSurcharge">
        <xsd:enumeration value="MushroomFee">
        <xsd:enumeration value="NewDiscount">
        <xsd:enumeration value="NewDistributionAllowance">
        <xsd:enumeration value="NewItemAllowance">
        <xsd:enumeration value="NewStoreAllowance">
        <xsd:enumeration value="NewStoreDiscount">
        <xsd:enumeration value="NewWarehouse">
        <xsd:enumeration value="NewWarehouseDiscount">
        <xsd:enumeration value="NewYorkDeliveryCharge">
        <xsd:enumeration value="NewYorkPick-upCharge">
        <xsd:enumeration value="NHDWharfage">
        <xsd:enumeration value="NoAllowance">
        <xsd:enumeration value="NoAllowanceOrCharge">
        <xsd:enumeration value="NoCharge">
        <xsd:enumeration value="Non-DutiableCharges">
        <xsd:enumeration value="NonGeneratedFreight">
        <xsd:enumeration value="Non-returnableContainers">
        <xsd:enumeration value="NoReturnCreditAllowance">
        <xsd:enumeration value="NormalPumpCharge">
        <xsd:enumeration value="NotarizedAffidavit">
        <xsd:enumeration value="NotifyConsignee">
        <xsd:enumeration value="NotifyConsigneeBeforeDelivery">
        <xsd:enumeration value="NozzleCharge">
        <xsd:enumeration value="OceanCharges-Hazardous">
        <xsd:enumeration value="OceanFreight">
        <xsd:enumeration value="OfficeSupplies">
        <xsd:enumeration value="Offshore-AlaskaHawaii">
        <xsd:enumeration value="OnCarriage">
        <xsd:enumeration value="OnDeckBreakBulkDifferential">
        <xsd:enumeration value="One-DayService">
        <xsd:enumeration value="OneTimeEngineeringCharge">
        <xsd:enumeration value="One-TimeLicenseFee">
        <xsd:enumeration value="One-Time-OnlyCharge">
        <xsd:enumeration value="OnetimeTooling">
        <xsd:enumeration value="OnHandService">
        <xsd:enumeration value="OperatorCredit">
        <xsd:enumeration value="OptionalCharge">
        <xsd:enumeration value="OptionalSoftwareSupportForOperationalSupportSystems">
        <xsd:enumeration value="OptionalSoftwareSupportForSwitchingSystems">
        <xsd:enumeration value="OptionChargeColorFabricOfficeFurniture">
        <xsd:enumeration value="Order-Flat">
        <xsd:enumeration value="OrderNotifyCharge">
        <xsd:enumeration value="OtherAccessorialServiceCharge">
        <xsd:enumeration value="OtherAdvances">
        <xsd:enumeration value="OtherExportCharges">
        <xsd:enumeration value="OtherGovernmentAgencyDeclaration">
        <xsd:enumeration value="OtherGovernmentAgencyExam">
        <xsd:enumeration value="OtherImportCharge">
        <xsd:enumeration value="OtherMiscellaneousEarningOrAdditive">
        <xsd:enumeration value="OtherSeeRelatedDescription">
        <xsd:enumeration value="OutOfRouteMiles">
        <xsd:enumeration value="OutOfZonePick-upOrDelivery">
        <xsd:enumeration value="OutsideCableConnectors">
        <xsd:enumeration value="OverDimension">
        <xsd:enumeration value="OverHeightContainer">
        <xsd:enumeration value="OverrunCharge">
        <xsd:enumeration value="OversizedPremium">
        <xsd:enumeration value="OvertimeLoading">
        <xsd:enumeration value="OverWidthContainer">
        <xsd:enumeration value="Packaging">
        <xsd:enumeration value="PackagingService">
        <xsd:enumeration value="PackingCratingAndHandlingCharge">
        <xsd:enumeration value="PackingCratingHandlingAndTransportationCharge">
        <xsd:enumeration value="PackInvoiceWithShipment">
        <xsd:enumeration value="PaintingPrimerOrFinish">
        <xsd:enumeration value="Pallet">
        <xsd:enumeration value="PalletExchangeCharge">
        <xsd:enumeration value="Palletizing">
        <xsd:enumeration value="Paralleling">
        <xsd:enumeration value="ParishCountySalesTaxOnly">
        <xsd:enumeration value="PassingShippersExportEntry">
        <xsd:enumeration value="Payment">
        <xsd:enumeration value="PayrollAdditivesOvertimeLabor">
        <xsd:enumeration value="PayrollAdditivesStraightTimeLabor">
        <xsd:enumeration value="PayrollTaxes">
        <xsd:enumeration value="PecanFee">
        <xsd:enumeration value="PenaltyCharge">
        <xsd:enumeration value="PercentDifferential-LessThanContainer">
        <xsd:enumeration value="PercentOfProduct">
        <xsd:enumeration value="PercentOfShipmentValueThatIsReturnable">
        <xsd:enumeration value="PercentOfShippedQuantityThatIsReturnable">
        <xsd:enumeration value="PerformanceAllowance">
        <xsd:enumeration value="PerformanceAward">
        <xsd:enumeration value="PerItemCharge">
        <xsd:enumeration value="PermitCharge">
        <xsd:enumeration value="PermitsBondsEscortAttendant">
        <xsd:enumeration value="PerOrderCharge">
        <xsd:enumeration value="PerPoundCharge">
        <xsd:enumeration value="PersonalPropertyMember">
        <xsd:enumeration value="PersonalPropertySpouse">
        <xsd:enumeration value="PhosphatizingSteelTreatment">
        <xsd:enumeration value="PickleAndOil">
        <xsd:enumeration value="PickUp">
        <xsd:enumeration value="Pick-upAndDelivery">
        <xsd:enumeration value="Pickup-OutOfArea">
        <xsd:enumeration value="PickupSurcharge">
        <xsd:enumeration value="PierChargesOtherThanWharfage">
        <xsd:enumeration value="PierCharges-Wharfage">
        <xsd:enumeration value="PierPick-upAndOrDelivery">
        <xsd:enumeration value="PierUnloading">
        <xsd:enumeration value="PilotInspection">
        <xsd:enumeration value="PlacementAndOrRemovalCharge">
        <xsd:enumeration value="Plating">
        <xsd:enumeration value="Plus-Amount">
        <xsd:enumeration value="Plus-Percentage">
        <xsd:enumeration value="PlusOrMinus-Amount">
        <xsd:enumeration value="PlusOrMinus-Percentage">
        <xsd:enumeration value="PoleLashingEquipmentSurcharge">
        <xsd:enumeration value="PoleWood-ServiceCharge">
        <xsd:enumeration value="PorkFee">
        <xsd:enumeration value="PortChanges">
        <xsd:enumeration value="PortHandlingAndUnloading">
        <xsd:enumeration value="PositioningAtOrigin">
        <xsd:enumeration value="Postage">
        <xsd:enumeration value="PostDamagedHandling">
        <xsd:enumeration value="PotatoFee">
        <xsd:enumeration value="PowerFactorAdjustment">
        <xsd:enumeration value="Pre-carriage">
        <xsd:enumeration value="Pre-carriageExcess">
        <xsd:enumeration value="PreciousMetalContent">
        <xsd:enumeration value="PreloadingCharge">
        <xsd:enumeration value="PrelodgeCharge">
        <xsd:enumeration value="PremiseUse">
        <xsd:enumeration value="PremiumCharge">
        <xsd:enumeration value="PremiumTransportation">
        <xsd:enumeration value="PrepaidUsageAllowance">
        <xsd:enumeration value="Preparation">
        <xsd:enumeration value="PreparationAndDelivery">
        <xsd:enumeration value="PreparationOfAirWaybill-Origin">
        <xsd:enumeration value="PreparationOfCanadianCustomsInvoice">
        <xsd:enumeration value="PreparationOfCommercialInvoice">
        <xsd:enumeration value="PreparationOfExportEntry">
        <xsd:enumeration value="PreparationOfInsuranceCertificate">
        <xsd:enumeration value="PreparationOfUSExportDocumentation">
        <xsd:enumeration value="Pre-PositionedInventoryService">
        <xsd:enumeration value="PreviousBilling">
        <xsd:enumeration value="PriceAdjustmentPercent">
        <xsd:enumeration value="PriceAndMarketingAllowance">
        <xsd:enumeration value="PriceDeviation">
        <xsd:enumeration value="PriorBalance">
        <xsd:enumeration value="PriorBillingAmount">
        <xsd:enumeration value="PriorDeliveryOfBillCharge">
        <xsd:enumeration value="PriorityService">
        <xsd:enumeration value="PriorMonthCredit">
        <xsd:enumeration value="PrivateOwnedVehicleProcessing">
        <xsd:enumeration value="Processing">
        <xsd:enumeration value="ProcessingCharge">
        <xsd:enumeration value="ProcessInTransitPrivilege">
        <xsd:enumeration value="ProcurementCharge">
        <xsd:enumeration value="ProfessionalFees">
        <xsd:enumeration value="ProformaInvoice">
        <xsd:enumeration value="ProgressPaymentRequirement">
        <xsd:enumeration value="PromotionalAllowance">
        <xsd:enumeration value="PromotionalDiscount">
        <xsd:enumeration value="ProofComposition">
        <xsd:enumeration value="ProofOfDelivery">
        <xsd:enumeration value="ProtectiveServiceCharge">
        <xsd:enumeration value="ProtectiveService-Cold">
        <xsd:enumeration value="ProtectiveService-Heat">
        <xsd:enumeration value="ProvideHouseholdIdentifier">
        <xsd:enumeration value="ProvideNameAndAddress">
        <xsd:enumeration value="PullingEyes">
        <xsd:enumeration value="PumpAirCharge">
        <xsd:enumeration value="PumpCharge">
        <xsd:enumeration value="PurchaseOption">
        <xsd:enumeration value="QuantityDiscount">
        <xsd:enumeration value="QuantitySurcharge">
        <xsd:enumeration value="RailheadHandling">
        <xsd:enumeration value="Ramping">
        <xsd:enumeration value="RateCode">
        <xsd:enumeration value="RateReductionBond">
        <xsd:enumeration value="Rebate">
        <xsd:enumeration value="Re-BillCharge">
        <xsd:enumeration value="RebilledDrayage-Destination">
        <xsd:enumeration value="RebilledDrayage-Origin">
        <xsd:enumeration value="Receiving">
        <xsd:enumeration value="RecipientAddressCorrection">
        <xsd:enumeration value="ReclamationCenterHandlingChute">
        <xsd:enumeration value="ReclamationFederal">
        <xsd:enumeration value="ReclamationSharedResponsibility">
        <xsd:enumeration value="ReclamationState">
        <xsd:enumeration value="Reconciliation">
        <xsd:enumeration value="Reconnectcharge">
        <xsd:enumeration value="ReconsignConsigneeCharge">
        <xsd:enumeration value="ReconsignDeliveryCharge">
        <xsd:enumeration value="ReconsignmentCharge">
        <xsd:enumeration value="RecooperingAtOwnersOrShippersExpense">
        <xsd:enumeration value="RecordFiling">
        <xsd:enumeration value="Recovery">
        <xsd:enumeration value="RecoveryFee">
        <xsd:enumeration value="RecratingRecoopering-Destination">
        <xsd:enumeration value="RecratingRecoopering-Origin">
        <xsd:enumeration value="RecurringHardwareMaintenanceCharge">
        <xsd:enumeration value="RecurringLicenseFee">
        <xsd:enumeration value="RecurringSoftwareMaintenanceCharge">
        <xsd:enumeration value="Redelivery">
        <xsd:enumeration value="RedistributionAllowance">
        <xsd:enumeration value="ReductionPrepalletizedCargo">
        <xsd:enumeration value="ReeferCargoPercentDifferential">
        <xsd:enumeration value="ReeferMaintenance">
        <xsd:enumeration value="Reel">
        <xsd:enumeration value="ReelCable">
        <xsd:enumeration value="ReelDeposit">
        <xsd:enumeration value="Refrigeration">
        <xsd:enumeration value="RefrigerationMechanicalDetention">
        <xsd:enumeration value="Refund">
        <xsd:enumeration value="RefurbishingCharge">
        <xsd:enumeration value="Regain">
        <xsd:enumeration value="RegistrationOfExportForReentry">
        <xsd:enumeration value="RegistrationOfExportShipments">
        <xsd:enumeration value="RegulatoryFee">
        <xsd:enumeration value="RegulatoryRequiredRefund">
        <xsd:enumeration value="ReliabilityCharge">
        <xsd:enumeration value="RelinquishmentCharge">
        <xsd:enumeration value="ReliquidationAnti-DumpingDuty">
        <xsd:enumeration value="ReliquidationCountervailingDuty">
        <xsd:enumeration value="ReliquidationTaxAmount">
        <xsd:enumeration value="ReliquidationTotalDueUSCustomsService">
        <xsd:enumeration value="ReliquidationTotalFees">
        <xsd:enumeration value="RentalCharge">
        <xsd:enumeration value="RentalDeduction">
        <xsd:enumeration value="RentsAndLeases">
        <xsd:enumeration value="RepackCharge">
        <xsd:enumeration value="Repair">
        <xsd:enumeration value="RepairAtBuyersExpenseCharge">
        <xsd:enumeration value="RepairAtCustomerExpenseCharge">
        <xsd:enumeration value="RepairAtGovernmentExpenseCharge">
        <xsd:enumeration value="Repickup">
        <xsd:enumeration value="RequestViaCanada">
        <xsd:enumeration value="ResearchDevelopmentFee">
        <xsd:enumeration value="ResellersDiscount">
        <xsd:enumeration value="ResidentialDelivery">
        <xsd:enumeration value="ResidentialPick-up">
        <xsd:enumeration value="Respotting">
        <xsd:enumeration value="RestockingCharge">
        <xsd:enumeration value="RestrictedArticleFee">
        <xsd:enumeration value="Retainer">
        <xsd:enumeration value="ReturnableContainer">
        <xsd:enumeration value="ReturnCargoCharge">
        <xsd:enumeration value="ReturnedLoad">
        <xsd:enumeration value="Rework">
        <xsd:enumeration value="RidingAttendantCharge">
        <xsd:enumeration value="RockyMountainBureau583Item1100ArbitraryCharge">
        <xsd:enumeration value="RollOutAdjustment">
        <xsd:enumeration value="RollRebate">
        <xsd:enumeration value="Royalties">
        <xsd:enumeration value="Salvage">
        <xsd:enumeration value="Same-DayService">
        <xsd:enumeration value="SaturdayDelivery">
        <xsd:enumeration value="SaturdayPick-Up">
        <xsd:enumeration value="SaturdayPick-upOrDeliveryCharge">
        <xsd:enumeration value="ScaleCharge">
        <xsd:enumeration value="ScaleChargeUnloading">
        <xsd:enumeration value="ScrapAllowance">
        <xsd:enumeration value="SecuritySignatureService">
        <xsd:enumeration value="SegregatingSorting">
        <xsd:enumeration value="SelectCharge">
        <xsd:enumeration value="SelfUnloader">
        <xsd:enumeration value="SellerHandCarry">
        <xsd:enumeration value="ServiceAssistanceProgramSurcharge">
        <xsd:enumeration value="ServiceCharge">
        <xsd:enumeration value="ServiceChargeWithCashDiscount">
        <xsd:enumeration value="ServiceUpgrade">
        <xsd:enumeration value="Set-up">
        <xsd:enumeration value="Shearing">
        <xsd:enumeration value="SheepFee">
        <xsd:enumeration value="ShipperLoad">
        <xsd:enumeration value="ShipperLoadAndCount">
        <xsd:enumeration value="ShipperLoadCarrierCount">
        <xsd:enumeration value="ShipperLoadConsigneeUnload">
        <xsd:enumeration value="Shipping">
        <xsd:enumeration value="ShippingAndHandling">
        <xsd:enumeration value="ShipsidePickup">
        <xsd:enumeration value="ShipToStockQualityAudit">
        <xsd:enumeration value="Shotblasting">
        <xsd:enumeration value="ShrinkageAllowance">
        <xsd:enumeration value="ShrinkAllowance">
        <xsd:enumeration value="Shrink-WrapCharge">
        <xsd:enumeration value="SingleFactorOriginationDestination">
        <xsd:enumeration value="SingleFactorOriginationPortOfDebarkation">
        <xsd:enumeration value="SingleFactorPortOfEmbarkationDestination">
        <xsd:enumeration value="SingleInvoiceAllowance">
        <xsd:enumeration value="SinglePick-up">
        <xsd:enumeration value="SingleShipmentFee">
        <xsd:enumeration value="Sleeving">
        <xsd:enumeration value="SlipSheetRail">
        <xsd:enumeration value="SlipSheetTruck">
        <xsd:enumeration value="SlipSheetUnloadingAllowance">
        <xsd:enumeration value="SlottingAllowance">
        <xsd:enumeration value="SmallOrderCharge">
        <xsd:enumeration value="SoftwareSupportService">
        <xsd:enumeration value="SourceInspection">
        <xsd:enumeration value="SpecialAllowance">
        <xsd:enumeration value="SpecialBuy">
        <xsd:enumeration value="SpecialCircusTrains">
        <xsd:enumeration value="SpecialCredit">
        <xsd:enumeration value="SpecialDelivery">
        <xsd:enumeration value="SpecialDetentionCharge">
        <xsd:enumeration value="SpecialEquipmentCharge">
        <xsd:enumeration value="SpecialFinishCharge">
        <xsd:enumeration value="SpecialFreightSupplements">
        <xsd:enumeration value="SpecialHandling">
        <xsd:enumeration value="SpecialMileageMovements">
        <xsd:enumeration value="SpecialPackaging">
        <xsd:enumeration value="SpecialPermits">
        <xsd:enumeration value="SpecialPickup">
        <xsd:enumeration value="SpecialPumpCharge">
        <xsd:enumeration value="SpecialSealCharge">
        <xsd:enumeration value="SpecialServices">
        <xsd:enumeration value="SpecialTestEquipmentCharge">
        <xsd:enumeration value="SpecialToolingCharge">
        <xsd:enumeration value="SpecialToolingreworkcharge">
        <xsd:enumeration value="SpecialTrainMovement">
        <xsd:enumeration value="SpecialUse">
        <xsd:enumeration value="SpecialVehicleRent">
        <xsd:enumeration value="SpecificationReview">
        <xsd:enumeration value="SpecificDuty">
        <xsd:enumeration value="SplitDelivery">
        <xsd:enumeration value="SplitPick-up">
        <xsd:enumeration value="SplitPick-UpAtPierCharge">
        <xsd:enumeration value="SpoolCharge">
        <xsd:enumeration value="SpottingOfTrailer">
        <xsd:enumeration value="SpreaderCharge">
        <xsd:enumeration value="StampFee">
        <xsd:enumeration value="Stamping">
        <xsd:enumeration value="StandbyCharge">
        <xsd:enumeration value="StateMetropolitanTransitAuthoritySurcharge">
        <xsd:enumeration value="StateMotorFuel">
        <xsd:enumeration value="StateSalesCharge">
        <xsd:enumeration value="StateSurcharge">
        <xsd:enumeration value="SteamingCharge">
        <xsd:enumeration value="StencilingCharge">
        <xsd:enumeration value="Stopcharge">
        <xsd:enumeration value="Stop-offAtDestination">
        <xsd:enumeration value="Stop-offAtOrigination">
        <xsd:enumeration value="Stop-offAtPierCharge">
        <xsd:enumeration value="Stop-offCharge">
        <xsd:enumeration value="StoppingInTransit">
        <xsd:enumeration value="Storage">
        <xsd:enumeration value="StorageInTransit">
        <xsd:enumeration value="StraighteningCharge">
        <xsd:enumeration value="Strapping">
        <xsd:enumeration value="StreetLampsCharge">
        <xsd:enumeration value="StrippingSortingAndConsolidation">
        <xsd:enumeration value="Stuffing">
        <xsd:enumeration value="StuffingCharge">
        <xsd:enumeration value="SubjectToCooperativeAdvertisingAllowance">
        <xsd:enumeration value="SubjectToTaxOnResale">
        <xsd:enumeration value="SufferanceWarehouseChargeExportOrImport">
        <xsd:enumeration value="SugarFee">
        <xsd:enumeration value="SumOfAddsAndDeductsToMakeMarketValue">
        <xsd:enumeration value="SundayOrHolidayPick-upOrDelivery">
        <xsd:enumeration value="SuperBagCharge">
        <xsd:enumeration value="SupervisorCharge">
        <xsd:enumeration value="SupplementalDuty">
        <xsd:enumeration value="SupplementalItems">
        <xsd:enumeration value="Surcharge">
        <xsd:enumeration value="SuretyBond">
        <xsd:enumeration value="Swell">
        <xsd:enumeration value="SwitchCharge">
        <xsd:enumeration value="SwitchingCharge">
        <xsd:enumeration value="TankCarAllowance">
        <xsd:enumeration value="TankRental">
        <xsd:enumeration value="Tarping">
        <xsd:enumeration value="Tax">
        <xsd:enumeration value="Tax-AirportTaxDestination">
        <xsd:enumeration value="Tax-AirportTaxOrigin">
        <xsd:enumeration value="Tax-BeverageTax">
        <xsd:enumeration value="Tax-CitySalesTaxOnly">
        <xsd:enumeration value="TaxCredit">
        <xsd:enumeration value="Tax-ExciseTax-Destination">
        <xsd:enumeration value="Tax-ExciseTax-Origin">
        <xsd:enumeration value="Tax-FederalExciseTax">
        <xsd:enumeration value="Tax-FederalExciseTaxOnTires">
        <xsd:enumeration value="Tax-Governmental">
        <xsd:enumeration value="Tax-HandlingChargeTax">
        <xsd:enumeration value="TaxLiability-Amortized">
        <xsd:enumeration value="TaxLiability-OneTime">
        <xsd:enumeration value="Tax-LocalSalesTax">
        <xsd:enumeration value="Tax-LocalTax">
        <xsd:enumeration value="Tax-MetropolitanTransitTax">
        <xsd:enumeration value="TaxOnMiscellaneousCharges">
        <xsd:enumeration value="TaxOnTransportation">
        <xsd:enumeration value="Tax-RegulatoryTax">
        <xsd:enumeration value="Tax-SalesandUse">
        <xsd:enumeration value="Tax-SalesTaxStateAndLocal">
        <xsd:enumeration value="Tax-StateHazardousSubstance">
        <xsd:enumeration value="Tax-StateTax">
        <xsd:enumeration value="Tax-SuperFundExciseTax">
        <xsd:enumeration value="Tax-UseTax">
        <xsd:enumeration value="Tax-ValueAddedTax">
        <xsd:enumeration value="TeaFee">
        <xsd:enumeration value="TechnologyExchange">
        <xsd:enumeration value="TelegramChargeback">
        <xsd:enumeration value="TelephoneCharge">
        <xsd:enumeration value="Telephone-Destination">
        <xsd:enumeration value="Telephone-Origin">
        <xsd:enumeration value="TemperatureProtection">
        <xsd:enumeration value="TemporaryAllowance">
        <xsd:enumeration value="TemporaryVoluntaryAllowance">
        <xsd:enumeration value="TenderedAsTruckload">
        <xsd:enumeration value="TerminalCharge">
        <xsd:enumeration value="TerminalDifferential">
        <xsd:enumeration value="TerminalHandlingCharges">
        <xsd:enumeration value="TerminalServiceFee">
        <xsd:enumeration value="TermsAllowance">
        <xsd:enumeration value="Testing">
        <xsd:enumeration value="TestingServicesCharge">
        <xsd:enumeration value="TestQualificationCharge">
        <xsd:enumeration value="ThirdPartyAllowance">
        <xsd:enumeration value="ThirdPartyPallets">
        <xsd:enumeration value="ThroughputAllowance">
        <xsd:enumeration value="ThroughputContainerCharge">
        <xsd:enumeration value="ThruwayCharge">
        <xsd:enumeration value="TicketingService">
        <xsd:enumeration value="TobaccoProductsReportCharge">
        <xsd:enumeration value="TOFCServiceCharge">
        <xsd:enumeration value="ToolCharge">
        <xsd:enumeration value="Tooling">
        <xsd:enumeration value="ToolingReworkCharge">
        <xsd:enumeration value="ToolsForPrinting">
        <xsd:enumeration value="TotalOther">
        <xsd:enumeration value="TotalAssessorialCharges">
        <xsd:enumeration value="TotalDueUSCustomsService">
        <xsd:enumeration value="TotalFees">
        <xsd:enumeration value="TotalInvoiceAmount">
        <xsd:enumeration value="TotalInvoiceAmountNon-USDollars">
        <xsd:enumeration value="TotalInvoiceAmountUSDollars">
        <xsd:enumeration value="TotalMaterialInvoiceAmount">
        <xsd:enumeration value="TracingInboundViaOtherCarriers">
        <xsd:enumeration value="TracingServiceFee">
        <xsd:enumeration value="TrackStorage">
        <xsd:enumeration value="TradeDiscount">
        <xsd:enumeration value="TradeIn">
        <xsd:enumeration value="TrailerRentalCharge">
        <xsd:enumeration value="TransferCharge">
        <xsd:enumeration value="TransferOfLadingCharge">
        <xsd:enumeration value="TransferredCharges">
        <xsd:enumeration value="Transit">
        <xsd:enumeration value="TransmissionCharge">
        <xsd:enumeration value="TransportationAndSetup">
        <xsd:enumeration value="TransportationChargeMinimumRate">
        <xsd:enumeration value="TransportationDirectBilling">
        <xsd:enumeration value="TransportationThirdPartyBilling">
        <xsd:enumeration value="TransportationVendorProvided">
        <xsd:enumeration value="TrimmingCharge">
        <xsd:enumeration value="TruckDetention">
        <xsd:enumeration value="TruckloadDiscount">
        <xsd:enumeration value="TurningCharge">
        <xsd:enumeration value="Two-DayService">
        <xsd:enumeration value="TwoDoorPickUp">
        <xsd:enumeration value="UnabsorbedSwitching">
        <xsd:enumeration value="Unitized">
        <xsd:enumeration value="Unloading">
        <xsd:enumeration value="UnloadingLaborCharges">
        <xsd:enumeration value="UnloadingReloadingCharge">
        <xsd:enumeration value="UnsaleableMerchandiseAllowance">
        <xsd:enumeration value="UnscheduledFee">
        <xsd:enumeration value="UpCharge">
        <xsd:enumeration value="UsagePlanDetailCharge">
        <xsd:enumeration value="USCustomsServiceFlatAssistAmount">
        <xsd:enumeration value="USCustomsServiceMaximumAssistAmount">
        <xsd:enumeration value="USDAInspectedStampingCertification">
        <xsd:enumeration value="UseChargeToolingPersonnel">
        <xsd:enumeration value="Use-SpecialTypeFlatCar">
        <xsd:enumeration value="USVehicles">
        <xsd:enumeration value="ValuationFee">
        <xsd:enumeration value="VanCleaning">
        <xsd:enumeration value="VehicleOrderedButNotUsed">
        <xsd:enumeration value="VehiclePrepChargeCourtesyDelivery">
        <xsd:enumeration value="VehicleRoadCharge">
        <xsd:enumeration value="VendorFreight">
        <xsd:enumeration value="VentingInstructions">
        <xsd:enumeration value="VirginIslandTransferCharge">
        <xsd:enumeration value="VolumeDiscount">
        <xsd:enumeration value="VoluntaryContributionCharge">
        <xsd:enumeration value="WaitingTime">
        <xsd:enumeration value="Warehouse">
        <xsd:enumeration value="Warehousing">
        <xsd:enumeration value="Warranties">
        <xsd:enumeration value="WarRiskCrewInsurance">
        <xsd:enumeration value="WarRiskInsurance">
        <xsd:enumeration value="WarRiskSurcharge">
        <xsd:enumeration value="WastedFutileTrip">
        <xsd:enumeration value="WatermelonFee">
        <xsd:enumeration value="WaybillAndInvoiceDistribution">
        <xsd:enumeration value="WeatherProtection">
        <xsd:enumeration value="WeightVerificationCharge">
        <xsd:enumeration value="Wharfage-Breakbulk">
        <xsd:enumeration value="WharfageCharge">
        <xsd:enumeration value="Wharfage-Container">
        <xsd:enumeration value="WharfageHandling">
        <xsd:enumeration value="WideAreaTelephoneServiceUsageCredit">
        <xsd:enumeration value="WillCallCharge">
        <xsd:enumeration value="WrittenProofOfDelivery">
        <xsd:enumeration value="X-rayCharge">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: ServiceLevelCodeType

ServiceLevelCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code indicates the level of service required. This code list is derived from EDIFACT 4183 (Special condition code), 4219 (Transport priority coded), and 8335 (Movement type description code) and X12 284 (Service level code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom code
    • BulkCommodityTrain - Bulk commodity train
    • PremiumSurface - Premium surface
    • ThreeDayService - Three day service
    • 9AM - 9 a.m.
    • AirCargo - Air cargo
    • AirEconomy - Air economy
    • AM - A.m.
    • BusinessClass - Business class
    • ConsigneeBillingService - Consignee billing service
    • CourierExpress - Courier express
    • Ground - Ground
    • ExpressService - Express service
    • DeliveryScheduledNextDayByCartageAgent - Delivery scheduled next day by cartage agent
    • DeliveryScheduledSecondDayByCartageAgent - Delivery scheduled second day by cartage agent
    • DeliveryScheduledThirdDayByCartageAgent - Delivery scheduled third day by cartage agent
    • DeliveryConfirmation - Delivery confirmation
    • DeferredService - Deferred service
    • DeliveryConfirmationReturn - Delivery confirmation return
    • DoorService - Door service
    • DeliveryNotificationOnly - Delivery notification only
    • ExpeditedService - Expedited service
    • ProofOfDeliveryWithSignature - Proof of delivery (POD) with signature
    • FirstClass - First class
    • StandardService - Standard service
    • ExpressServicePlus - Express service plus
    • TrackingGround - Tracking - ground
    • Iata - Iata
    • ExpeditedServiceWorldwide - Expedited service - worldwide
    • ExpressServiceWorldwide - Express service - worldwide
    • Metro - Metro
    • Multiweight - Multiweight
    • NextDayAir - Next day air
    • NextFlightOut - Next flight out
    • NextDayHundredWeight - Next day hundred weight
    • NextMorning - Next morning
    • NotServed - Not served
    • Overnight - Overnight
    • PrimaryServiceAreaNextDayBy1030AM - Primary service area - next day by 10:30 a.m.
    • PriorityMail - Priority mail
    • PrimaryServiceAreaNextDayBy930AM - Primary service area - next day by 9:30 am
    • PriorityMailInsured - Priority mail insured
    • PM - Pm
    • PrimaryServiceAreaNextDayByNoon - Primary service area - next day by noon
    • POBoxZipCode - P.O. box/zip code
    • PrimaryServiceAreaNextDayBy500PM - Primary service area - next day by 5:00 p.m.
    • PrimaryServiceAreaSecondDayByNoon - Primary service area - second day by noon
    • PassengerService - Passenger service
    • QualityIntermodalHighSpeed70MilesPerHour - Quality intermodal high speed 70 miles per hour (mph)
    • OtherIntermodalAndStackService - Other Intermodal and stack service
    • 60MilesPerHourService - 60 miles per hour (mph) service
    • ManifestFreight - Manifest freight
    • CircusTrain - Circus train
    • WorkTrain - Work train
    • CommuterService - Commuter service
    • AuthorizedReturnService - Authorized return service
    • SameDay - Same day
    • SecondDayAir - Second day air
    • Saturday - Saturday
    • SecondDay - Second day
    • StandardGround - Standard ground
    • SecondDayHundredWeight - Second day hundred weight
    • StandardGroundHundredWeight - Standard ground hundred weight
    • SecondMorning - Second morning
    • SaturdayPickup - Saturday pickup
    • StandardClass - Standard class
    • Express - Express treatment (if by rail, legal express regime for parcels transport).
    • HighSpeed - Transport under legal international rail convention (CIM) concluded between rail organizations and based on fast routing and specified timetables.
    • NormalSpeed - Transport under legal international rail convention (CIM) concluded between rail organizations.
    • PostService - Transport under conditions specified by UPU (Universal Postal Union) and rail organizations (parcels transport only).

[^]Code Fragment

    <xsd:simpleType name="ServiceLevelCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="BulkCommodityTrain">
        <xsd:enumeration value="PremiumSurface">
        <xsd:enumeration value="ThreeDayService">
        <xsd:enumeration value="9AM">
        <xsd:enumeration value="AirCargo">
        <xsd:enumeration value="AirEconomy">
        <xsd:enumeration value="AM">
        <xsd:enumeration value="BusinessClass">
        <xsd:enumeration value="ConsigneeBillingService">
        <xsd:enumeration value="CourierExpress">
        <xsd:enumeration value="Ground">
        <xsd:enumeration value="ExpressService">
        <xsd:enumeration value="DeliveryScheduledNextDayByCartageAgent">
        <xsd:enumeration value="DeliveryScheduledSecondDayByCartageAgent">
        <xsd:enumeration value="DeliveryScheduledThirdDayByCartageAgent">
        <xsd:enumeration value="DeliveryConfirmation">
        <xsd:enumeration value="DeferredService">
        <xsd:enumeration value="DeliveryConfirmationReturn">
        <xsd:enumeration value="DoorService">
        <xsd:enumeration value="DeliveryNotificationOnly">
        <xsd:enumeration value="ExpeditedService">
        <xsd:enumeration value="ProofOfDeliveryWithSignature">
        <xsd:enumeration value="FirstClass">
        <xsd:enumeration value="StandardService">
        <xsd:enumeration value="ExpressServicePlus">
        <xsd:enumeration value="TrackingGround">
        <xsd:enumeration value="Iata">
        <xsd:enumeration value="ExpeditedServiceWorldwide">
        <xsd:enumeration value="ExpressServiceWorldwide">
        <xsd:enumeration value="Metro">
        <xsd:enumeration value="Multiweight">
        <xsd:enumeration value="NextDayAir">
        <xsd:enumeration value="NextFlightOut">
        <xsd:enumeration value="NextDayHundredWeight">
        <xsd:enumeration value="NextMorning">
        <xsd:enumeration value="NotServed">
        <xsd:enumeration value="Overnight">
        <xsd:enumeration value="PrimaryServiceAreaNextDayBy1030AM">
        <xsd:enumeration value="PriorityMail">
        <xsd:enumeration value="PrimaryServiceAreaNextDayBy930AM">
        <xsd:enumeration value="PriorityMailInsured">
        <xsd:enumeration value="PM">
        <xsd:enumeration value="PrimaryServiceAreaNextDayByNoon">
        <xsd:enumeration value="POBoxZipCode">
        <xsd:enumeration value="PrimaryServiceAreaNextDayBy500PM">
        <xsd:enumeration value="PrimaryServiceAreaSecondDayByNoon">
        <xsd:enumeration value="PassengerService">
        <xsd:enumeration value="QualityIntermodalHighSpeed70MilesPerHour">
        <xsd:enumeration value="OtherIntermodalAndStackService">
        <xsd:enumeration value="60MilesPerHourService">
        <xsd:enumeration value="ManifestFreight">
        <xsd:enumeration value="CircusTrain">
        <xsd:enumeration value="WorkTrain">
        <xsd:enumeration value="CommuterService">
        <xsd:enumeration value="AuthorizedReturnService">
        <xsd:enumeration value="SameDay">
        <xsd:enumeration value="SecondDayAir">
        <xsd:enumeration value="Saturday">
        <xsd:enumeration value="SecondDay">
        <xsd:enumeration value="StandardGround">
        <xsd:enumeration value="SecondDayHundredWeight">
        <xsd:enumeration value="StandardGroundHundredWeight">
        <xsd:enumeration value="SecondMorning">
        <xsd:enumeration value="SaturdayPickup">
        <xsd:enumeration value="StandardClass">
        <xsd:enumeration value="Express">
        <xsd:enumeration value="HighSpeed">
        <xsd:enumeration value="NormalSpeed">
        <xsd:enumeration value="PostService">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: ServiceLevelReasonCodeType

ServiceLevelReasonCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the reason for shipment via premium transportation rather than the normal mode. This code list is derived from X12 626 (Excess transportation reason code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom code
    • ScheduleIncreaseForecastChangeOrSpecialCarOrder - Schedule increase, forecast change or cpecial car order
    • EngineeringChangeOrLateRelease - Engineering change or late release
    • SpecificationError-Overbuilding - Specification (schedule) error/overbuilding
    • ShipmentTracingDelay - Shipment tracing delay
    • PlantInventoryLoss - Plant inventory loss
    • BuildingAheadOfSchedule - Building ahead of schedule
    • VendorBehindSchedule - Vendor behind schedule
    • FailedToIncludeInLastShipmentorUnauthorizedPremium - Failed to include in last shipment or unauthorized premium
    • CarrierLossClaim - Carrier loss claim
    • TransportationFailure - Transportation failure
    • InsufficientWeightForCarload - Insufficient weight for carload
    • RejectorDiscrepancy - Reject or discrepancy
    • TransportationDelay - Transportation delay
    • LackOfRailCarOrRailroadEquipment - Lack of railcar or railroad equipment
    • ReleasingError - Releasing error
    • RecordErrorOrLateReportedDiscrepancyReport - Record error or late reported discrepancy report
    • CommonOrPeculiarPartScheduleIncrease - Common or peculiar part schedule increase
    • AlternateSupplierShippingForResponsibleSupplier - Alternate supplier shipping for responsible supplier
    • DirectScheduleOrLocallyControlled - Direct schedule or locally controlled
    • PurchasingWaiverApproval - Purchasing waiver approval
    • AuthorizationCodeToBeDetermined - Authorization code to be determined
    • PilotMaterialSamplesOrPre-Production - Pilot material, samples or pre-production

[^]Code Fragment

    <xsd:simpleType name="ServiceLevelReasonCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="ScheduleIncreaseForecastChangeOrSpecialCarOrder">
        <xsd:enumeration value="EngineeringChangeOrLateRelease">
        <xsd:enumeration value="SpecificationError-Overbuilding">
        <xsd:enumeration value="ShipmentTracingDelay">
        <xsd:enumeration value="PlantInventoryLoss">
        <xsd:enumeration value="BuildingAheadOfSchedule">
        <xsd:enumeration value="VendorBehindSchedule">
        <xsd:enumeration value="FailedToIncludeInLastShipmentorUnauthorizedPremium">
        <xsd:enumeration value="CarrierLossClaim">
        <xsd:enumeration value="TransportationFailure">
        <xsd:enumeration value="InsufficientWeightForCarload">
        <xsd:enumeration value="RejectorDiscrepancy">
        <xsd:enumeration value="TransportationDelay">
        <xsd:enumeration value="LackOfRailCarOrRailroadEquipment">
        <xsd:enumeration value="ReleasingError">
        <xsd:enumeration value="RecordErrorOrLateReportedDiscrepancyReport">
        <xsd:enumeration value="CommonOrPeculiarPartScheduleIncrease">
        <xsd:enumeration value="AlternateSupplierShippingForResponsibleSupplier">
        <xsd:enumeration value="DirectScheduleOrLocallyControlled">
        <xsd:enumeration value="PurchasingWaiverApproval">
        <xsd:enumeration value="AuthorizationCodeToBeDetermined">
        <xsd:enumeration value="PilotMaterialSamplesOrPre-Production">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: ServiceLevelResponsibilityCodeType

ServiceLevelResponsibilityCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code indicates the party responsible for the level of service requested. This code list is derived from X12 627 (Excess transportation responsibility code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • CustomerPlant
    • MaterialReleaseIssuer
    • SupplierAuthority
    • ResponsibilityToBeDetermined

[^]Code Fragment

    <xsd:simpleType name="ServiceLevelResponsibilityCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="CustomerPlant">
        <xsd:enumeration value="MaterialReleaseIssuer">
        <xsd:enumeration value="SupplierAuthority">
        <xsd:enumeration value="ResponsibilityToBeDetermined">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: ServiceLevelType

ServiceLevelType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ServiceLevelCoded[ServiceLevelCodeType]? , ServiceLevelCodedOther[xsd:string]? , ServiceLevelReasonCoded[ServiceLevelReasonCodeType]? , ServiceLevelReasonCodedOther[xsd:string]? , ServiceLevelResponsibilityCoded[ServiceLevelResponsibilityCodeType]? , ServiceLevelResponsibilityCodedOther[xsd:string]? )

    Description: ServiceLevelType is used to hold information about the level of service associated with the transportation.

    Elements:

    • ServiceLevelCoded - is a code defining the level of service required.
    • ServiceLevelCodedOther - is used to provide a non-standard ServiceLevelCode. This element is mandatory if the value of ServiceLevelCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • ServiceLevelReasonCoded - defines the reason the level of service is required using a standard codelist.
    • ServiceLevelReasonCodedOther - is used to provide a non-standard ServiceLevelReasonCode. This element is mandatory if the value of ServiceLevelReasonCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • ServiceLevelResponsibilityCoded - identifies the party responsible for the level of service.
    • ServiceLevelResponsibilityCodedOther - is used to provide a non-standard ServiceLevelResponsibilityCode. This element is mandatory if the value of ServiceLevelResponsibilityCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="ServiceLevelType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ServiceLevelCoded" type="ServiceLevelCodeType">
        <xsd:element minOccurs="0" name="ServiceLevelCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="ServiceLevelReasonCoded" type="ServiceLevelReasonCodeType">
        <xsd:element minOccurs="0" name="ServiceLevelReasonCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="ServiceLevelResponsibilityCoded" type="ServiceLevelResponsibilityCodeType">
        <xsd:element minOccurs="0" name="ServiceLevelResponsibilityCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: SeverityCodeType

SeverityCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code indicates the severity of an error.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - This option should not be used under normal circumstances.
    • Informational - For caller information only.
    • Warning - Non fatal error.
    • Diagnostic - For diagnostic or debugging purposes
    • Transient - Errors are temporary in nature and request possibly can be resent in the future. The interval before resend can occurs can be specified as one of the parameters.
    • Error - A business error has occurred.

[^]Code Fragment

    <xsd:simpleType name="SeverityCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Informational">
        <xsd:enumeration value="Warning">
        <xsd:enumeration value="Diagnostic">
        <xsd:enumeration value="Transient">
        <xsd:enumeration value="Error">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: SeverityType

SeverityType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( SeverityCoded[SeverityCodeType] , SeverityCodedOther[xsd:string]? )

    Description: SeverityType is a container for stating the severity of an error.

    Elements:

    • SeverityCoded - contains a code qualifying the type of severity.
    • SeverityCodedOther - is used to specify a non-standard SeverityCode. This element is mandatory if the value of SeverityCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="SeverityType">
    <xsd:sequence>
        <xsd:element name="SeverityCoded" type="SeverityCodeType">
        <xsd:element minOccurs="0" name="SeverityCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: ShipmentMethodOfPaymentCodeType

ShipmentMethodOfPaymentCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies payment terms for transportation charges. This code list is derived from EDIFACT 4215 (Transport charges payment method code) and X12 146 (Shipment method of payment)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • Account - The charges are to be charged to an account.
    • AdvanceCollect - The amount of freight or other charge on a shipment advanced by one transportation line to another or to the shipper, to be collected from consignee.
    • AdvancePrepaid - Costs have been paid in advance.
    • CashOnDeliveryServiceChargePaidByConsignee - An indication that the consignee is responsible for the payment of the cash on delivery service charge.
    • CashOnDeliveryServiceChargePaidByConsignor - An indication that the consignor is responsible for the payment of the cash on delivery service charge.
    • Collect - A shipment on which freight charges will be paid by consignee.
    • CollectFreightCreditedToPaymentCustomer - The freight is collect but has been paid by the shipper and will be credited to that party.
    • CollectOnDelivery
    • CustomerPick-UpOrBackhaul - Buyer's private carriage picks up the goods as a return load to the buyer's facility.
    • DefinedByBuyerAndSeller -
    • FobPortOfCall - Title and control of goods pass to the buyer at port of call. Responsibility for export taxes and cost of documents for overseas shipments have not been specified.
    • HalfPrepaid
    • InformationCopy-NoPaymentDue - Transaction set has been provided for information only.
    • InsuranceCostsPaidByConsignee - An indication that the consignee is responsible for the payment of the insurance costs.
    • InsuranceCostsPaidByConsignor - An indication that the consignor is responsible for the payment of the insurance costs.
    • Mixed - The consignment is partially collect and partially prepaid.
    • NonRevenue
    • NotSpecified -
    • PaidByBuyer - Transport charges will be paid by the buyer.
    • PaidBySupplierOrSeller - Transport charges will be paid by the supplier.
    • PayableElsewhere - Place of payment not known at the begin of conveyance.
    • PerContract
    • Pickup - Customer is responsible for payment of pickup charges at shipping point.
    • PrepaidAndSummaryBill
    • PrepaidButChargedToCustomer - shipping charges have been paid in advance of shipment but are charged back to consignee usually as line item on invoice for the purchased goods.
    • PrepaidByProcessor
    • Prepaid-BySeller - Seller of goods makes payment to carrier for freight charges prior to shipment.
    • PrepaidLocalCollectOutstate
    • PrepaidOnly - Payment in advance of freight and/or other charges prior to delivery of shipment at destination, usually by shipper at point of origin.
    • ReturnContainerFreightFree - There is no freight charge for returning the container.
    • ReturnContainerFreightPaidByCustomer - The freight for returning the container is paid by the customer.
    • ReturnContainerFreightPaidBySupplier - The freight charge for returning the container is paid by the supplier.
    • Rule11Shipment
    • ServiceFreight-NoCharge - The consignment is shipped on a service basis and there is no freight charge.
    • ThirdPartyPay - A third party, someone other than buyer or seller, is identified as responsible for payment of shipping charges.
    • WeightCondition - Description to be provided.

[^]Code Fragment

    <xsd:simpleType name="ShipmentMethodOfPaymentCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Account">
        <xsd:enumeration value="AdvanceCollect">
        <xsd:enumeration value="AdvancePrepaid">
        <xsd:enumeration value="CashOnDeliveryServiceChargePaidByConsignee">
        <xsd:enumeration value="CashOnDeliveryServiceChargePaidByConsignor">
        <xsd:enumeration value="Collect">
        <xsd:enumeration value="CollectFreightCreditedToPaymentCustomer">
        <xsd:enumeration value="CollectOnDelivery">
        <xsd:enumeration value="CustomerPick-UpOrBackhaul">
        <xsd:enumeration value="DefinedByBuyerAndSeller">
        <xsd:enumeration value="FobPortOfCall">
        <xsd:enumeration value="HalfPrepaid">
        <xsd:enumeration value="InformationCopy-NoPaymentDue">
        <xsd:enumeration value="InsuranceCostsPaidByConsignee">
        <xsd:enumeration value="InsuranceCostsPaidByConsignor">
        <xsd:enumeration value="Mixed">
        <xsd:enumeration value="NonRevenue">
        <xsd:enumeration value="NotSpecified">
        <xsd:enumeration value="PaidByBuyer">
        <xsd:enumeration value="PaidBySupplierOrSeller">
        <xsd:enumeration value="PayableElsewhere">
        <xsd:enumeration value="PerContract">
        <xsd:enumeration value="Pickup">
        <xsd:enumeration value="PrepaidAndSummaryBill">
        <xsd:enumeration value="PrepaidButChargedToCustomer">
        <xsd:enumeration value="PrepaidByProcessor">
        <xsd:enumeration value="Prepaid-BySeller">
        <xsd:enumeration value="PrepaidLocalCollectOutstate">
        <xsd:enumeration value="PrepaidOnly">
        <xsd:enumeration value="ReturnContainerFreightFree">
        <xsd:enumeration value="ReturnContainerFreightPaidByCustomer">
        <xsd:enumeration value="ReturnContainerFreightPaidBySupplier">
        <xsd:enumeration value="Rule11Shipment">
        <xsd:enumeration value="ServiceFreight-NoCharge">
        <xsd:enumeration value="ThirdPartyPay">
        <xsd:enumeration value="WeightCondition">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: ShipmentStatusEventCodeType

ShipmentStatusEventCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the shipping status for a given quantity.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom code
    • NotApplicable - Shipping Status Does Not Apply
    • NotYetShipped - Order or Item Has Not Been Shipped
    • BackOrdered - Item Has Been Back Ordered
    • BackOrderShipped - Back Ordered Goods Have Been Shipped
    • ReadyForPickup - Order or Item is Ready For Pick Up
    • InTransit - Order or Item Is In Transit
    • PartiallyShipped - Order or Item Has Been Partially Shipped
    • PartiallyDelivered - Part of the Order or Item Has Been Delivered
    • ShipmentComplete - All Order or All Item Has Been Shipped
    • Delivered - Order of Item Has Been Delivered

[^]Code Fragment

    <xsd:simpleType name="ShipmentStatusEventCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="NotApplicable">
        <xsd:enumeration value="NotYetShipped">
        <xsd:enumeration value="BackOrdered">
        <xsd:enumeration value="BackOrderShipped">
        <xsd:enumeration value="ReadyForPickup">
        <xsd:enumeration value="InTransit">
        <xsd:enumeration value="PartiallyShipped">
        <xsd:enumeration value="PartiallyDelivered">
        <xsd:enumeration value="ShipmentComplete">
        <xsd:enumeration value="Delivered">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: ShipmentStatusEventType

ShipmentStatusEventType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: Extends: StatusType

      Append:( ShipDate[xsd:dateTime]? )

    Description: ShipmentStatusEventType provides a status related to the ship date of the item(s).

    Elements:

    • ShipDate - holds the ship date relative to the reported status.

[^]Code Fragment

    <xsd:complexType name="ShipmentStatusEventType">
    <xsd:complexContent>
        <xsd:extension base="StatusType">
            <xsd:sequence>
                <xsd:element minOccurs="0" name="ShipDate" type="xsd:dateTime">
            </xsd:sequence>
        </xsd:extension>
    </xsd:complexContent>
</xsd:complexType>


complexType definition: ShipToSubInformationType

ShipToSubInformationType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( ShipToSubLocation[LocationType] , ShipToSubQuantity[QuantityType] , SubLocationItemPackagingReference[ItemPackagingReferenceType]? )

    Description: ShipToSubInformationType contains the information for the locations and quantities of the goods for the schedule lines.

    Elements:

    • ShipToSubLocation - identifies places inside the ship to location where specific sub deliveries will be made. This is also called a mail stop.
    • ShipToSubQuantity - identifies the quantity associated with the ship to sub location.
    • SubLocationItemPackagingReference - is to be used when specifying packaging details related to each shipment to a sub location. The quantity fields should match the values in shipto sub quantity. These values override packaging references supplied at the delivery detail level.

[^]Code Fragment

    <xsd:complexType name="ShipToSubInformationType">
    <xsd:sequence>
        <xsd:element name="ShipToSubLocation" type="LocationType">
        <xsd:element name="ShipToSubQuantity" type="QuantityType">
        <xsd:element minOccurs="0" name="SubLocationItemPackagingReference" type="ItemPackagingReferenceType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: SignificanceCodeType

SignificanceCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code indicates the significance of a measurement value. This code list is derived from EDIFACT 6321 (Measurement significance coded)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • Approximately
    • EqualTo
    • GreaterThanOrEqualTo
    • GreaterThan
    • LessThan
    • LessThanOrEqualTo
    • NotEqualTo
    • Trace - Description to be provided.
    • TrueValue - Description to be provided.
    • ObservedValue - Description to be provided.
    • OutOfRange

[^]Code Fragment

    <xsd:simpleType name="SignificanceCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Approximately">
        <xsd:enumeration value="EqualTo">
        <xsd:enumeration value="GreaterThanOrEqualTo">
        <xsd:enumeration value="GreaterThan">
        <xsd:enumeration value="LessThan">
        <xsd:enumeration value="LessThanOrEqualTo">
        <xsd:enumeration value="NotEqualTo">
        <xsd:enumeration value="Trace">
        <xsd:enumeration value="TrueValue">
        <xsd:enumeration value="ObservedValue">
        <xsd:enumeration value="OutOfRange">
    </xsd:restriction>
</xsd:simpleType>


Simple Types:

AcademicTitleCodeType
AccountTypeCodeType
ActionValueCodeType
ActualPaymentStatusCodeType
AgencyCodeType
AllowOrChargeIndicatorCodeType
AllowOrChargeTreatmentCodeType
AlphaNum10Type
AlphaNum14Type
AlphaNum17Type
AlphaNum20Type
AlphaNum256Type
AlphaNum30Type
AlphaNum35Type
AlphaNum3Type
AlphaNum40Type
AlphaNum50Type
AlphaNum512Type
AlphaNum60Type
AlphaNum6Type
AlphaNum70Type
AlphaNum80Type
AlphaNum9Type
AttachmentActionCodeType
BasicResponseCodeType
BasisCodeType
CardTypeCodeType
ChangeTypeCodeType
CodeListIdentifierCodeType
ConditionsCodeType
ContactFunctionCodeType
ContactNumberTypeCodeType
ContractTypeCodeType
CountryCodeType
CurrencyCodeType
DateQualifierCodeType
DateTimeRefCodeType
Decimal10_4Type
Decimal15_3Type
Decimal15_4Type
Decimal18_3Type
Decimal19_9Type
Decimal2_0Type
Decimal21_6Type
Decimal6_0Type
Decimal8_2Type
DetailChangeCodeType
DetailResponseCodeType
DimensionCodeType
DocumentTypeCodeType
EquipmentOwnerCodeType
EquipmentProviderCodeType
EquipmentSizeTypeCodeType
EquipmentStatusCodeType
Float_16Type
FullIndicatorCodeType
HazardClassCodeType
HazardousShipmentCodeType
HazardousZoneCodeType
HazardPackingCodeType
IBANType
IndicatorCodeType
ItemCharacteristicCodeType
LanguageCodeType
LineItemNumTypeCodeType
LineItemTypeCodeType
LocaleCodeType
LocationQualifierCodeType
MethodOfHandlingCodeType
OperationalTypeCodeType
OrderTypeCodeType
PackageCharacteristicCodeType
PackageIdentifierCodeType
PackageMarkCodeType
PackageTypeCodeType
PartialOrderCodeType
PartyRoleCodeType
PaymentMeanCodeType
PaymentResponsibilityCodeType
PaymentSystemCodeType
PaymentTermCodeType
PercentQualifierCodeType
PosInt_6Type
PriceMultiplierCodeType
PriceTypeCodeType
ProductIdentifierQualifierCodeType
PurposeCodeType
QuantityQualifierCodeType
ReasonTaxExemptCodeType
ReferenceTypeCodeType
RegionCodeType
RequestedResponseCodeType
ResponseTypeCodeType
ReturnLoadCodeType
RiskOfLossCodeType
SalesActionCodeType
SalesRequirementCodeType
SealIssuerCodeType
SealStatusCodeType
ServiceCodeType
ServiceLevelCodeType
ServiceLevelReasonCodeType
ServiceLevelResponsibilityCodeType
SeverityCodeType
ShipmentMethodOfPaymentCodeType
ShipmentStatusEventCodeType
SignificanceCodeType
SpecialHandlingCodeType
StatusEventCodeType
StatusReasonCodeType
SurfaceLayerPositionCodeType
TaxCategoryCodeType
TaxFunctionQualifierCodeType
TaxPaymentMethodCodeType
TaxTreatmentCodeType
TaxTypeCodeType
TermsOfDeliveryFunctionCodeType
TextTypeCodeType
TimezoneCodeType
TitleCodeType
TransitDirectionCodeType
TransitTimeQualifierCodeType
TransportLegCodeType
TransportMeansCodeType
TransportModeCodeType
TransportRequirementCodeType
TransportTermsCodeType
UOMCodeType


simpleType definition: SpecialHandlingCodeType

SpecialHandlingCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies any special transportation handling instructions. This code list is derived from X12 152 (Special handling code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • SpeedRestrictedTo15MilesPerHour - Speed restricted to 15 miles per hour
    • SpeedRestrictedTo25MilesPerHour - Speed restricted to 25 miles per hour
    • SpeedRestrictedTo35MilesPerHour - Speed restricted to 35 miles per hour
    • SpeedRestrictedTo45MilesPerHour - Speed restricted to 45 miles per hour
    • NoFacialHair - No facial hair
    • CarIsAirBrakeControlled - Car is air brake controlled
    • CustomerRequiredPackingList - Customer required packing list
    • CustomerRequiredPRONumber - Customer required pro number
    • CustomerRequiredAppointmentNumber - Customer required appointment number
    • LoadOnTopOfResidue - Load on top of residue heel
    • DisposeOfResidue - Dispose of residue heel
    • Attachment-AutoKeys - Attachment - auto keys
    • AttachmentToMoveWithCar - Attachment to move with car
    • AnnualVolume - Annual volume
    • Attachments-AdvanceOnlyWaybill - Attachments - advance only waybill
    • ClearinghouseBalance - Clearinghouse balance
    • BlowableLoad - Blowable load
    • IfBadOrderedNotifyShipper - If bad ordered notify shipper
    • BillShipperForWeighCharge - Bill shipper for weigh charge
    • ContainerConsolidatorLoad - Container consolidator load
    • Attachment-CustomersDocument - Attachment - customers document
    • ClearedForExport - Cleared for export
    • ContainerFactoryLoad - Container factory load
    • Carrier - Carrier
    • CustomsInspection - Customs inspection
    • Attachment-CottonManifest - Attachment - cotton manifest
    • NoMarshallingRequiredForHazardousMaterials - No marshalling required for hazardous materials
    • CircusRampOnlyTOFCVan - Circus ramp only TOFC van
    • BillConsigneeForWeighCharges - Bill consignee for weigh charges
    • TopLoadOnly - Top load only
    • CertificationThatThisShipmentIsForRecyclingAsDefinedInApplicableTariffsContainingSuchProvisions - Certification that this shipment is for recycling as defined in applicable tariffs containing such provisions
    • Dangerous - Dangerous
    • Demurrage - Demurrage
    • Domestic - Domestic
    • ShipperAuthorizationRequiredForDiversionOrConsignment - Shipper authorization required for diversion or consignment
    • DropYard - Drop yard
    • DeliveryOnlyOnSurrenderOfWrittenOrder - Delivery only on surrender of written order
    • DeadInTow - Dead in tow
    • DoNotUncouple - Do not uncouple
    • Equipment - Equipment
    • DestinationWeightsApply - Destination weights apply
    • ExcessiveDimensions - Excessive dimensions
    • ElectronicEquipmentTransfer - Electronic equipment transfer
    • EnvironmentalControlLimits - Environmental control limits
    • Expedite - Expedite
    • ReturnEmptyViaReverseRoute - Return empty via reverse route
    • DamagesIncurredIfShipmentFailsToMeetVesselLoading - Damages incurred if shipment fails to meet vessel loading
    • ExcessiveWeight - Excessive weight
    • ExplosiveFlammableGas - Explosive flammable gas
    • FaceA-EndToHeadOfTrain - Face "A-end" to head of train
    • FaceB-EndToHeadOfTrain - Face "B-end" to head of train
    • MovingUnderForFurtheranceInstructionsAndMayBeDelivered - Moving under "for furtherance instructions" and may be delivered
    • FullService - Full service
    • FlammableGas - Flammable gas
    • Flammable - Flammable
    • FlammablePoisonGas - Flammable poison gas
    • Fragile-HandleWithCare - Fragile - handle with care
    • NontransitFlatShipment - Nontransit flat shipment
    • GrainInspection - Grain inspection
    • HeadEndCar - Head end car
    • Household - Household
    • EndorsedAsHazardousMaterial - Endorsed as hazardous material
    • HoldForOrders - Hold for orders
    • HeatedPriorToLoading - Heated prior to loading
    • HomeForRepair - Home for repair
    • Heat - Heat
    • HighValueLoad - High value load
    • HighWideLoad - High wide load
    • In-Bond - In-bond
    • Ice - Ice
    • ShipmentToBeInspectedAtDestinationAndDispositionInstructionsWillBeFurnished - Shipment to be inspected at destination and disposition instructions will be furnished
    • InterofficeMove - Interoffice move
    • ImportShipment - Import shipment
    • RailIncentiveRate - Rail incentive rate
    • SurveillanceService - Surveillance service
    • JunctionSettlementAccount - Junction settlement account
    • LandBridgeImportOrExport - Land bridge import/export
    • CarTripLeasedToConsignee - Car trip leased to consignee
    • LoadingDevices - Loading devices
    • LoadedToFullVisibleCapacity - Loaded to full visible capacity
    • LessThanContainerConsolidatorLoad - Less than container consolidator load
    • ProtectLowestThroughRate - Protect lowest through rate
    • LessThanContainerFactoryLoad - Less than container factory load
    • LocalServiceOnly - Local service only
    • LessThanFullCarload - Less than full carload
    • PersonInChargeOfCar - Person in charge of car
    • ClearedForBorderCrossing - Cleared for border crossing
    • MultiplePickup - Multiple pickup
    • MechanicalRefrigeration - Mechanical refrigeration
    • NotifyConsigneeBeforeDelivery - Notify consignee before delivery
    • DoNotDivert - Do not divert
    • NoSpecialEntrainmentRequired - No special entrainment required
    • DoNotHump - Do not hump
    • NewEquipmentFirstTransborderMovement - New equipment first transborder movement
    • DoNotPool - Do not pool
    • NotifyShipperBeforeReconsignment - Notify shipper before reconsignment
    • DoNotTransferContents - Do not transfer contents
    • InCaseOfFireDoNotUseWater - In case of fire do not use water
    • NotForExport - Not for export
    • CommodityLoadedLessThanOrEqualToTheCarOrdered - Commodity loaded less than or equal to the car ordered
    • Overweight - Overweight
    • PerishableInBoxCar - Perishable in box car
    • PrivatelyControlledPrivateEquipmentSubjectToDemurrage - Privately controlled private equipment subject to demurrage
    • PoisonousGas - Poisonous gas
    • IcedPriorToLoading - Iced prior to loading
    • ProductProtectionService - Product protection service
    • Attachment-PrepaidWaybill - Attachment - prepaid waybill
    • ReturnAuthorization - Return authorization
    • RenderBillForCharges - Render bill for charges
    • RailroadControlledPrivateEquipmentSubjectToDemurrage - Railroad controlled private equipment subject to demurrage
    • RadioactiveMaterial - Radioactive material
    • RushOrder - Rush order
    • RearRider - Rear rider
    • InspectHourlyIfCarStopped - Inspect hourly if car stopped
    • RecordForTransit - Record for transit
    • ShipperLoadOrCarrierCount - Shipper load/carrier count
    • ShoveToRestAndCover - Shove to rest and cover
    • SubjectToSpecialDetentionRulesOrCharges - Subject to special detention rules/charges
    • Attachment-ShippersExportDocument - Attachment - shippers export document
    • ShiftableLoad - Shiftable load
    • ShipToCrossDockOrPool - Ship to cross dock or pool
    • RequiresShelfCouplers - Requires shelf couplers
    • Attachment-ShippersManifest - Attachment - shippers manifest
    • Attachment-ShippersPackingInstructions - Attachment - shippers packing instructions
    • SpeedRestricted - Speed restricted
    • StackTrain - Stack train
    • StretchWrap - Stretch wrap
    • CarsTemporarilyArticulated - Cars temporarily articulated
    • TrailerConsolidatorLoad - Trailer consolidator load
    • TrailerFactoryLoad - Trailer factory load
    • TurnCar - Turn car
    • TransitShipment - Transit shipment
    • TeamTrackDelivery - Team track delivery
    • TimeVolumeRatesOnly - Time volume rates only
    • UnloadAtBumperCircusRamp - Unload at bumper circus ramp
    • Unitized - Unitized
    • UnloadFromLeftSideOfCar - Unload from left side of car
    • UnloadAsPlacarded - Unload as placarded
    • UnprotectedPerishable - Unprotected perishable
    • UnloadFromRightSideOfCar - Unload from right side of car
    • ShipperCertifiesGrossWeightUnder240000Pounds - Shipper certifies gross weight under 240000 pounds
    • VerificationWeigh - Verification weigh
    • VentilationInstructions - Ventilation instructions
    • Wide-BodyPickupTruckAppliesToFinishedVehicleLoading - Wide-body pickup truck applies to finished vehicle loading
    • WaivedInspection-SetDirect - Waived inspection - set direct
    • WeighEmpty - Weigh empty
    • Attachments-HighWideNotice - Attachments - high wide notice
    • WaiveInspection - Waive inspection
    • ManifestMustAccompanyWaybill - Manifest must accompany waybill
    • WeighToCheckForOverload - Weigh to check for overload
    • WasteWater - Waste water
    • Export - Export
    • CrossTown - Cross town
    • AdvancedFee - Advanced fee
    • CertificateOfOrigin - Certificate of origin
    • FuelSurchargeAuthorized - Fuel surcharge authorized
    • Offshore-AlaskaOrHawaiiService - Offshore - Alaska/Hawaii service
    • OversizedPremium - Oversized premium
    • PreparationOfAirWaybill-Origin - Preparation of air waybill - origin
    • PreparationOfCanadianCustomsInvoice - Preparation of Canadian customs invoice
    • PreparationOfExportEntry - Preparation of export entry
    • PreparationOfInsuranceCertificate - Preparation of insurance certificate
    • PreparationOfU.S.ExportDocumentation - Preparation of U.S. export documentation
    • SaturdayDelivery - Saturday delivery
    • SaturdayPick-Up - Saturday pick-up
    • SecuritySignatureService - Security signature service
    • WrittenProofOfDelivery - Written proof of delivery
    • Aggregate1000 - Aggregate 1000
    • Aggregate3000 - Aggregate 3000
    • Aggregate5000 - Aggregate 5000
    • AttendantsAccompanying - Attendants accompanying
    • AdvanceLoading - Advance loading
    • AirCraftFurnishedAndNotUsed - Air craft furnished and not used
    • AggregateTenderDiscount - Aggregate tender discount
    • ArmedGuardService - Armed guard service
    • AdditionalInjectionOrBlendingService - Additional injection/blending service
    • PortChanges - Port changes
    • UseOfAlternateTerminal - Use of Alternate Terminal
    • A.M.DeliveryRequirement - A.m. delivery requirement
    • AnchoringAndUnanchoring - Anchoring and unanchoring
    • AdditionalCopyOfShippingPapersForProofOfDelivery - Additional copy of shipping papers for proof of delivery
    • ApplianceServicing - Appliance servicing
    • AirConditioningDisconnectAndConnect - Air conditioning disconnect and connect
    • RailArmedGuardService - Rail armed guard service
    • AirRideTractorService - Air ride tractor service
    • AirRideTruckService - Air ride truck service
    • AssemblyServiceRequested - Assembly service requested
    • AuxiliaryService - Auxiliary service
    • BypassConsolidationPoint - Bypass consolidation point
    • BulkyArticle - Bulky article
    • BlockingAndBracing - Blocking and bracing
    • BlindShipment - Blind shipment
    • BolsterLoadDoNotSwitch - Bolster load do not switch
    • BoxingService-DryBulk - Boxing service - dry bulk
    • BunkerSurchargeAuthorized - Bunker surcharge authorized
    • BunkerAdjustment-20FootContainer - Bunker adjustment - 20 foot container
    • BunkerAdjustment-40FootContainer - Bunker adjustment - 40 foot container
    • BunkerAdjustment - Bunker adjustment
    • CurrencyAdjustment-20FootContainer - Currency adjustment - 20 foot container
    • CurrencyAdjustment-40FootContainer - Currency adjustment - 40 foot container
    • RoeeCarOrPick-UpTruck - ROEE car or pick-up truck
    • ConvertCommercialBillOfLadingBolToGovernmentBol - Convert commercial bill of lading BOL to government BOL
    • Certification - Certification
    • CarrierCaboose - Carrier caboose
    • CorrosionAdditiveService - Corrosion additive service
    • CustomsFees-ContainerLevel - Customs fees - container level
    • CustomsFees-LiftLevel - Customs fees - lift level
    • CarrierGuardCarService - Carrier guard car service
    • ReturnCarrierGuardCarService - Return carrier guard car service
    • CargoTaxes - Cargo taxes
    • ChainAndBinders - Chain and binders
    • CommercialInvoicePreparation - Commercial invoice preparation
    • ConstantSurveillance - Constant surveillance
    • Cleaning - Cleaning
    • ClassRatesApplied - Class rates applied
    • Comb.RatesOverDetroit - Comb. rates over Detroit
    • ConsolidationAndLineHaul - Consolidation and line haul
    • Consolidation - Consolidation
    • ContractRatesApply - Contract rates apply
    • CertificationThatTheNewsprintWindingCoresBeingReturnedEmptyWereReceivedFilledByRailFreightService - Certification that the newsprint winding cores being returned empty were received filled by rail freight service
    • ConsigneeUnload - Consignee unload
    • CourierOvernight - Courier overnight
    • CopilotService - Copilot service
    • CustomsPapersMailed - Customs papers mailed
    • ContainerLease - Container lease
    • CourierSameDay - Courier same day
    • GovernmentCaboose - Government caboose
    • ControlledAtmosphere - Controlled atmosphere
    • ContainerMounting - Container mounting
    • CircuitousRouting - Circuitous routing
    • CurrencyAdjustment-BreakBulk - Currency adjustment - break bulk
    • DoubleWideSeparateAndReassemble - Double wide separate and reassemble
    • DeliveryOfFuelFromBargeToPipeline - Delivery of fuel from barge to pipeline
    • DodConstantSurveillanceService - Dod constant surveillance service
    • DualDriverWithNationalAgencyCheck - Dual driver with national agency check
    • DualDriverProtectiveService - Dual driver protective service
    • DirectDelivery - Direct delivery
    • DrayageAtPortOfDebarkationRateZone - Drayage at port of debarkation rate zone
    • DeliveryService - Delivery service
    • DetentionOfConveyingEquipmentAndThePowerUnit - Detention of conveying equipment and the power unit
    • DetentionOfConveyingEquipmentExcludingThePowerUnit - Detention of conveying equipment excluding the power unit
    • DrayageAtPortOfEmbarkationRateZone - Drayage at port of embarkation rate zone
    • KeepFromFreezingPercentDifferential - Keep from freezing percent differential
    • 410DromedaryWithMechanicalRestrainingDevices - 410 dromedary with mechanical restraining devices
    • 410Dromedary - 410 dromedary
    • DistributionServiceRequested - Distribution service requested
    • DeliveryOfFuelFromRailTankCarToPipeline - Delivery of fuel from rail tank car to pipeline
    • NotifyShipperImmediatelyIfShipmentIsDelayedEnRoute - Notify shipper immediately if shipment is delayed en route
    • DoNotCoupleToOtherDiaphragmedCars - Do not couple to other diaphragmed cars
    • DoNotFreeze - Do not freeze
    • DoNotCoupleToTankCars - Do not couple to tank cars
    • Documentation-Special - Documentation - special
    • ContainerDiversion - Container diversion
    • DeliveryOfFuelFromPipelineToBarge - Delivery of fuel from pipeline to barge
    • DrayageAtPortOfDebarkation - Drayage at port of debarkation
    • DrayageAtPortOfEmbarkation - Drayage at port of embarkation
    • DeliveryOfFuelFromPipelineToRailTankCar - Delivery of fuel from pipeline to rail tank car
    • DeliveryOfFuelFromPipelineToTankTruckOrTrailer - Delivery of fuel from pipeline to tank truck or trailer
    • DetentionWithPowerUnits30MinutePeriods - Detention with power units 30 minute periods
    • Drop-OffDelivery - Drop-off delivery
    • DrummingService - Drumming service
    • DoNotCoupleToDoubleShelfCouples - Do not couple to double shelf couples
    • DromedaryWithMechanicalRestrainingDevices - Dromedary with mechanical restraining devices
    • DromedaryServiceRequested - Dromedary service requested
    • DoorSideVanning - Door side vanning
    • LaborAssociatedWithDetentionOfConveyingEquipment - Labor associated with detention of conveying equipment
    • DeliveryOfFuelFromTankTruckOrTrailerToPipeline - Delivery of fuel from tank truck or trailer to pipeline
    • DetentionVehicle - Detention vehicle
    • DetentionWithPowerUnits60MinutePeriods - Detention with power units 60 minute periods
    • ExtraAxles - Extra axles
    • EscortOrCourierService - Escort/courier service
    • EmptyRailcarOrderedButNotUsed - Empty railcar ordered but not used
    • EquipmentHoseAtDestination - Equipment hose at destination
    • EquipmentHoseAtOrigin - Equipment hose at origin
    • ExclusiveUse - Exclusive use
    • ExtraLights - Extra lights
    • EmergencyService - Emergency service
    • EmptyMovement - Empty movement
    • Endorsement - Endorsement
    • EmptyReturn - Empty return
    • SatisfactoryServiceStandards - Satisfactory service standards
    • ExcessiveValuationAuthorized - Excessive valuation authorized
    • ExclusiveUseOfVehicle - Exclusive use of vehicle
    • ExtraDriver - Extra driver
    • ExtraLengthSurcharge - Extra length surcharge
    • ExportPreparation - Export preparation
    • ExpeditedRatesApplied - Expedited rates applied
    • ExpeditedService - Expedited service
    • ExtraLabor - Extra labor
    • ExclusiveUseOfVehicleDamaged - Exclusive use of vehicle damaged
    • ExpandRemoveAndInstall - Expand remove and install
    • RoadwayEasyRatesApplied - Roadway easy rates applied
    • BargeFreightAllKindsService - Barge freight all kinds service
    • Firearms - Firearms
    • FurnishingChassis - Furnishing chassis
    • FuelFiltersFurnishedByCarrier - Fuel filters furnished by carrier
    • FuelFiltersFurnishedByShipper - Fuel filters furnished by shipper
    • FlatrackSurcharge - Flatrack surcharge
    • ForProcessingInTransit - For processing in transit
    • AcceptedByCarrierAtOwnerSRiskOfFreezing - Accepted by carrier at owners risk of freezing
    • ForStorageInTransit - For storage in transit
    • FiltrationService - Filtration service
    • GarmentSurcharge - Garment surcharge
    • Government-OwnedContainers - Government-owned containers
    • GovernmentGuardCar - Government guard car
    • GreaterSecurityService - Greater security service
    • HoldAtLocation - Hold at location
    • Handling - Handling
    • HandBrakesAtEachEndMustBeReleased - Hand brakes at each end must be released
    • ShipmentHoldoverForHolidays - Shipment holdover for holidays
    • ShipmentHoldoverForWeekends - Shipment holdover for weekends
    • HeatInTransit - Heat in Transit
    • Heat-Special - Heat - special
    • HeatWithSteam - Heat with steam
    • AccessibleHazardousMaterial - Accessible hazardous material
    • InaccessibleHazardousMaterial - Inaccessible hazardous material
    • SundayOrHolidayPickupOrDelivery - Sunday or holiday pickup or delivery
    • 24HourAvailability - 24 hour availability
    • Hose - Hose
    • SpecialHose - Special hose
    • HighCubeTrailerRates - High cube trailer rates
    • HeaterOrRefrigeration - Heater or refrigeration
    • HitchInstallation - Hitch installation
    • HazardousMaterialsSurcharge - Hazardous materials surcharge
    • HazardousCargoOnDeck - Hazardous cargo on deck
    • IdlerCar - Idler car
    • InsideDelivery - Inside delivery
    • IcingInhibitorService - Icing inhibitor service
    • Impactographs - Impactographs
    • IntermodalShipmentService - Intermodal shipment service
    • Intra-PlantMove - Intra-plant move
    • InsidePickup - Inside pickup
    • InterlineTransferService - Interline transfer service
    • Just-In-TimeJit - Just-in-time JIT
    • JointLineException - Joint line exception
    • CertificationThatTheContainersBeingReturnedEmptyWereReceivedFilledByRailFreightService - Certification that the containers being returned empty were received filled by rail freight service
    • KeepMaterialDry - Keep material dry
    • LaborDisturbance - Labor disturbance
    • Layover - Layover
    • ApplyAUCCOrEANSerialShippingContainerLabelToTheShippingContainers - Apply a uniform code council/international article numbering association UCC/EAN serial shipping container label to the Shipping Containers
    • LightBarService - Light bar service
    • LowBoyTrailerOrFlatBed - Low boy trailer/flat bed
    • LandCurrencyAdjustmentFactor-20FootContainer - Land currency adjustment factor - 20 foot container
    • LandCurrencyAdjustment-40FootContainer - Land currency adjustment - 40 foot container
    • PercentDifferential-LessThanContainer - Percent differential - less than container
    • LessThanContainer - Less than container
    • LinehaulFromPortOfDebarkation - Linehaul from port of debarkation
    • LinehaulService - Linehaul service
    • LiabilityOfCarrier - Liability of Carrier
    • LinerTermsAtPortOfDebarkation - Liner terms at port of debarkation
    • LinerTermsAtPortOfEmbarkation - Liner terms at port of embarkation
    • LinehaulPercentDifferential - Linehaul percent differential
    • LinehaulToPortOfEmbarkation - Linehaul to port of embarkation
    • LessThanTruckload - Less than truckload
    • LayoverService - Layover service
    • ModifiedAtmosphere - Modified atmosphere
    • EscortServiceWithOvernightSubsistence - Escort service with overnight subsistence
    • Escort - Escort
    • EscortServicesTelephone - Escort services telephone
    • Insulated - Insulated
    • MotorSurveillanceService - Motor surveillance service
    • Other - Other
    • Refrigerated - Refrigerated
    • MilitaryTrafficExpeditingService - Military traffic expediting service
    • SpecialMotorSurveillance - Special motor surveillance
    • DoNotHumpOrHumpInto - Do not hump or hump into
    • DoNotUseHelperLocomotiveToPush - Do not use helper locomotive to push
    • NoPlacardsRequired - No placards required
    • NoseSideVanning - Nose side vanning
    • StowAwayFromHeat - Stow Away from Heat
    • BlockStowage - Block stowage
    • CargoAboard - Cargo aboard
    • CarrierLoadAndConsigneeUnload - Carrier load and consignee unload
    • OverHeightContainer - Over height container
    • CompletingShipment - Completing shipment
    • DeliveryVerificationNotRequired - Delivery verification not required
    • StowWithDoorsFacingInward - Stow with doors facing inward
    • ExemptCommodity - Exempt commodity
    • InFrontOfHouseStowage - In front of house stowage
    • Fumigation - Fumigation
    • Harmless - Harmless
    • OilFieldService - Oil field service
    • UseNoHooks - Use no hooks
    • NotRestrictedCargo - Not restricted cargo
    • CargoOnBoardCertificationRequired - Cargo on board certification required
    • OnDeckStowage - On deck stowage
    • CarrierLoadAndCarrierUnload - Carrier load and carrier unload
    • Perishable - Perishable
    • PartialShipment - Partial shipment
    • StowBelowDeck - Stow below deck
    • StowBetweenDecks - Stow between decks
    • TemperatureControl - Temperature control
    • TimeOfDeliveryAndSignatureRequired - Time of delivery and signature required
    • OnTopIn-HatchStowage - On top in-hatch stowage
    • OnTopOn-DeckStowage - On top on-deck stowage
    • TotalShipment - Total shipment
    • UnderContainerOn-DeckStowage - Under container on-deck stowage
    • BelowWaterLineStowage - Below water line stowage
    • Overflow - Overflow
    • OverWidthContainer - Over width container
    • OneWayRatesApplied - One way rates applied
    • PumpingEquipment - Pumping equipment
    • PickupOfShipmentsOnSaturdaySundayAndOrHolidaysRequiringAbsoluteNextDayDelivery - Pickup of shipments on saturday sunday and/or holidays requiring absolute next day delivery
    • PickupAndDeliveryFromStorageInTransit - Pickup and delivery from storage in transit
    • PickupAndDeliveryBeyondServiceArea - Pickup and delivery beyond service area
    • SpecialPermits - Special permits
    • ProtectFromHeat - Protect from heat
    • PerHourRatesApplied - Per hour rates applied
    • PierTime - Pier time
    • PalletsOrSkidsOrPlatforms - Pallets/skids/platforms
    • P.M.DeliveryRequirement - P.m. delivery requirement
    • PerMileRatesApply - Per mile rates apply
    • PickupOfShipmentsRequiringSameDayDeliveryService - Pickup of shipments requiring same day delivery service
    • PickupOfShipmentsRequiringSameDayDeliveryServiceAndOrDeliveryAtASpecifiedTime - Pickup of shipments requiring same day delivery service and/or delivery at a specified time
    • PianoOrOrganCarry - Piano/organ carry
    • PositioningAtOrigin - Positioning at Origin
    • PickupAndDeliveryServiceForPerishables - Pickup and delivery service for perishables
    • Prelodge - Prelodge
    • StuffingCharge - Stuffing charge
    • ProtectiveServiceSecurityWithArmedGuards - Protective service security with armed guards
    • ProtectiveSecurityService - Protective security service
    • ProtectiveTarpForSecurityPurposes - Protective tarp for security purposes
    • Pickup - Pickup
    • PickupAndDelivery - Pickup and Delivery
    • PackAndUnpack - Pack and Unpack
    • PUPTrailerRatesApply - Pup trailer rates apply
    • BondedPrivatelyOwnedVehicle - Bonded privately owned vehicle
    • DetentionOfPrivatelyOwnedVehicle - Detention of privately owned vehicle
    • InoperablePrivatelyOwnedVehicle - Inoperable privately owned vehicle
    • LoadingOrUnloadingOfPrivatelyOwnedVehicle - Loading/unloading of privately owned vehicle
    • PrivateOwnedVehicleProcessing - Private owned vehicle processing
    • Stop-OffsForPrivatelyOwnedVehicleShipment - Stop-offs for privately owned vehicle shipment
    • PrivatelyOwnedVehicleInTruckawayService - Privately owned vehicle in truckaway service
    • PriorityService - Priority service
    • Reconsignment - Reconsignment
    • Redelivery - Redelivery
    • RailheadHandling - Railhead handling
    • RoadrailerService - Roadrailer service
    • Respotting - Respotting
    • ResidentialDelivery - Residential delivery
    • ReeferMaintenance - Reefer maintenance
    • ReleasedValueChargeInExcessOfCarrierMaximumLiability - Released value charge in excess of carrier maximum liability
    • RelocationOfVehicle - Relocation of vehicle
    • ReturnOfEmptyContainer - Return of empty container
    • ReturnMovementOfPallet - Return movement of pallet
    • RailSurveillance - Rail surveillance
    • ReeferCargoPercentDifferential - Reefer cargo percent differential
    • RoundTripService - Round trip service
    • Reshipment - Reshipment
    • RestrictedSpeeds - Restricted speeds
    • Reservations - Reservations
    • ReweightRequested - Reweight requested
    • ShipmentHoldoverOnWeekends - Shipment holdover on weekends
    • SaturdayPickupOrDelivery - Saturday pickup or delivery
    • SpecialContainers - Special containers
    • ShipperLoadAndConsigneeUnload - Shipper load and consignee unload
    • SplitDelivery - Split delivery
    • SpecialDromedaryService - Special dromedary service
    • SpecialEquipmentCharge - Special equipment charge
    • ShipperExportDeclarationRequired - Shipper export declaration required
    • StairsElevatorExcessCarry - Stairs elevator excess carry
    • ServiceChargeApplies - Service charge applies
    • SecurityEscortVehicleService - Security escort vehicle service
    • SingleFactorOriginationOrDestination - Single factor origination/destination
    • SingleFactorOriginationOrPortOfDebarkation - Single factor origination/port of debarkation
    • SingleFactorPortOfEmbarkationOrDestination - Single factor port of embarkation/destination
    • SpecialTrainMovement - Special train movement
    • SingleShipment - Single shipment
    • ShipmentHoldoverOnHolidays - Shipment holdover on holidays
    • ShipperLoad - Shipper load
    • ShipmentHoldoverOnWeekdays - Shipment holdover on weekdays
    • SkirtingAndUnskirting - Skirting and unskirting
    • ShipperLoadAndCount - Shipper load and count
    • SmallPackage - Small package
    • TransmitAShipNoticeOrManifestTransactionSet - Transmit a ship notice/manifest transaction set
    • SatelliteSurveillanceService - Satellite surveillance service
    • ShipmentFromNon-TempStorage - Shipment from non-temp storage
    • Stop-Off - Stop-off
    • ShipperLoadAndCarrierUnload - Shipper load and carrier unload
    • SpecialPermit - Special permit
    • SpreaderService - Spreader service
    • SpotForStorage-NoShipment - Spot for storage - no shipment
    • SplitPickup - Split pickup
    • Storage - Storage
    • SurveyingRoutes - Surveying routes
    • StrippingSortingAndConsolidation - Stripping sorting and consolidation
    • SubstituteServiceNotToBeUsed - Substitute service not to be used
    • PoleLashingEquipmentPleSurcharge - Pole lashing equipment PLE surcharge
    • ConductivityOrAnti-StaticAdditive - Conductivity/anti-static additive
    • Stop-OffAtDestination - Stop-off at destination
    • Stowage - Stowage
    • Stop-OffAtOrigination - Stop-off at origination
    • SignatureAndTallyRecord - Signature and tally record
    • SpotForUnloadingFromAEnd - Spot for unloading from a end
    • SpotForUnloadingFromBBrakeEnd - Spot for unloading from b brake end
    • SupervisorRequested - Supervisor requested
    • StorageOfVehicles - Storage of vehicles
    • Truckload-DoubleOperator-CommonCarrier - Truckload-double operator-common carrier
    • Truckload-DoubleOperator-PaddedVan - Truckload-double operator-padded van
    • TerminalHandlingCharges - Terminal handling charges
    • TenderedAsTruckloadTruckloadServiceRequested - Tendered as truckload truckload service requested
    • Multi-TankSurveillanceService - Multi-tank surveillance service
    • TenderingOfMultipleVehicles - Tendering of multiple vehicles
    • TrailerOnFlatCar - Trailer on flat car
    • ThirdPartyService - Third party service
    • TractorOnly - Tractor only
    • TruckRatesApplicable - Truck rates applicable
    • TrailerPreparation-Special - Trailer preparation - special
    • Termination - Termination
    • TransferProduct - Transfer product
    • TireRepairAndReplace - Tire repair and replace
    • TradeShow - Trade show
    • TractorAndTrailer - Tractor and trailer
    • Truckload-SingleOperator-CommonCarrier - Truckload-single operator-common carrier
    • Truckload-SingleOperator-PaddedVan - Truckload-single operator-padded van
    • TankSurveillanceService - Tank surveillance service
    • UnderCarriageFurnishedByCarrier - Under carriage furnished by carrier
    • Unpacking - Unpacking
    • UnloadingOrReloading - Unloading or reloading
    • UtilitiesDisconnectAndConnect - Utilities disconnect and connect
    • VacuumService - Vacuum service
    • RoeeVanTypeTruck - Roee van type truck
    • VanCleaning - Van cleaning
    • VehiclesFurnishedButNotUsed - Vehicles furnished but not used
    • VehiclesInoperable - Vehicles inoperable
    • Stop-OffDeliveryOfPersonalVehicles - Stop-off delivery of personal vehicles
    • VehiclesInTruckaway - Vehicles in truckaway
    • Wharfage-Breakbulk - Wharfage - breakbulk
    • Wharfage-Container - Wharfage - container
    • WaterfrontDelivery - Waterfront delivery
    • Wharfage - Wharfage
    • WarRiskCrewBonus - War risk crew bonus
    • WarRiskInsurance - War risk insurance
    • WaitingTimeAuthorized - Waiting time authorized
    • WeightVerification - Weight verification

[^]Code Fragment

    <xsd:simpleType name="SpecialHandlingCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="SpeedRestrictedTo15MilesPerHour">
        <xsd:enumeration value="SpeedRestrictedTo25MilesPerHour">
        <xsd:enumeration value="SpeedRestrictedTo35MilesPerHour">
        <xsd:enumeration value="SpeedRestrictedTo45MilesPerHour">
        <xsd:enumeration value="NoFacialHair">
        <xsd:enumeration value="CarIsAirBrakeControlled">
        <xsd:enumeration value="CustomerRequiredPackingList">
        <xsd:enumeration value="CustomerRequiredPRONumber">
        <xsd:enumeration value="CustomerRequiredAppointmentNumber">
        <xsd:enumeration value="LoadOnTopOfResidue">
        <xsd:enumeration value="DisposeOfResidue">
        <xsd:enumeration value="Attachment-AutoKeys">
        <xsd:enumeration value="AttachmentToMoveWithCar">
        <xsd:enumeration value="AnnualVolume">
        <xsd:enumeration value="Attachments-AdvanceOnlyWaybill">
        <xsd:enumeration value="ClearinghouseBalance">
        <xsd:enumeration value="BlowableLoad">
        <xsd:enumeration value="IfBadOrderedNotifyShipper">
        <xsd:enumeration value="BillShipperForWeighCharge">
        <xsd:enumeration value="ContainerConsolidatorLoad">
        <xsd:enumeration value="Attachment-CustomersDocument">
        <xsd:enumeration value="ClearedForExport">
        <xsd:enumeration value="ContainerFactoryLoad">
        <xsd:enumeration value="Carrier">
        <xsd:enumeration value="CustomsInspection">
        <xsd:enumeration value="Attachment-CottonManifest">
        <xsd:enumeration value="NoMarshallingRequiredForHazardousMaterials">
        <xsd:enumeration value="CircusRampOnlyTOFCVan">
        <xsd:enumeration value="BillConsigneeForWeighCharges">
        <xsd:enumeration value="TopLoadOnly">
        <xsd:enumeration value="CertificationThatThisShipmentIsForRecyclingAsDefinedInApplicableTariffsContainingSuchProvisions">
        <xsd:enumeration value="Dangerous">
        <xsd:enumeration value="Demurrage">
        <xsd:enumeration value="Domestic">
        <xsd:enumeration value="ShipperAuthorizationRequiredForDiversionOrConsignment">
        <xsd:enumeration value="DropYard">
        <xsd:enumeration value="DeliveryOnlyOnSurrenderOfWrittenOrder">
        <xsd:enumeration value="DeadInTow">
        <xsd:enumeration value="DoNotUncouple">
        <xsd:enumeration value="Equipment">
        <xsd:enumeration value="DestinationWeightsApply">
        <xsd:enumeration value="ExcessiveDimensions">
        <xsd:enumeration value="ElectronicEquipmentTransfer">
        <xsd:enumeration value="EnvironmentalControlLimits">
        <xsd:enumeration value="Expedite">
        <xsd:enumeration value="ReturnEmptyViaReverseRoute">
        <xsd:enumeration value="DamagesIncurredIfShipmentFailsToMeetVesselLoading">
        <xsd:enumeration value="ExcessiveWeight">
        <xsd:enumeration value="ExplosiveFlammableGas">
        <xsd:enumeration value="FaceA-EndToHeadOfTrain">
        <xsd:enumeration value="FaceB-EndToHeadOfTrain">
        <xsd:enumeration value="MovingUnderForFurtheranceInstructionsAndMayBeDelivered">
        <xsd:enumeration value="FullService">
        <xsd:enumeration value="FlammableGas">
        <xsd:enumeration value="Flammable">
        <xsd:enumeration value="FlammablePoisonGas">
        <xsd:enumeration value="Fragile-HandleWithCare">
        <xsd:enumeration value="NontransitFlatShipment">
        <xsd:enumeration value="GrainInspection">
        <xsd:enumeration value="HeadEndCar">
        <xsd:enumeration value="Household">
        <xsd:enumeration value="EndorsedAsHazardousMaterial">
        <xsd:enumeration value="HoldForOrders">
        <xsd:enumeration value="HeatedPriorToLoading">
        <xsd:enumeration value="HomeForRepair">
        <xsd:enumeration value="Heat">
        <xsd:enumeration value="HighValueLoad">
        <xsd:enumeration value="HighWideLoad">
        <xsd:enumeration value="In-Bond">
        <xsd:enumeration value="Ice">
        <xsd:enumeration value="ShipmentToBeInspectedAtDestinationAndDispositionInstructionsWillBeFurnished">
        <xsd:enumeration value="InterofficeMove">
        <xsd:enumeration value="ImportShipment">
        <xsd:enumeration value="RailIncentiveRate">
        <xsd:enumeration value="SurveillanceService">
        <xsd:enumeration value="JunctionSettlementAccount">
        <xsd:enumeration value="LandBridgeImportOrExport">
        <xsd:enumeration value="CarTripLeasedToConsignee">
        <xsd:enumeration value="LoadingDevices">
        <xsd:enumeration value="LoadedToFullVisibleCapacity">
        <xsd:enumeration value="LessThanContainerConsolidatorLoad">
        <xsd:enumeration value="ProtectLowestThroughRate">
        <xsd:enumeration value="LessThanContainerFactoryLoad">
        <xsd:enumeration value="LocalServiceOnly">
        <xsd:enumeration value="LessThanFullCarload">
        <xsd:enumeration value="PersonInChargeOfCar">
        <xsd:enumeration value="ClearedForBorderCrossing">
        <xsd:enumeration value="MultiplePickup">
        <xsd:enumeration value="MechanicalRefrigeration">
        <xsd:enumeration value="NotifyConsigneeBeforeDelivery">
        <xsd:enumeration value="DoNotDivert">
        <xsd:enumeration value="NoSpecialEntrainmentRequired">
        <xsd:enumeration value="DoNotHump">
        <xsd:enumeration value="NewEquipmentFirstTransborderMovement">
        <xsd:enumeration value="DoNotPool">
        <xsd:enumeration value="NotifyShipperBeforeReconsignment">
        <xsd:enumeration value="DoNotTransferContents">
        <xsd:enumeration value="InCaseOfFireDoNotUseWater">
        <xsd:enumeration value="NotForExport">
        <xsd:enumeration value="CommodityLoadedLessThanOrEqualToTheCarOrdered">
        <xsd:enumeration value="Overweight">
        <xsd:enumeration value="PerishableInBoxCar">
        <xsd:enumeration value="PrivatelyControlledPrivateEquipmentSubjectToDemurrage">
        <xsd:enumeration value="PoisonousGas">
        <xsd:enumeration value="IcedPriorToLoading">
        <xsd:enumeration value="ProductProtectionService">
        <xsd:enumeration value="Attachment-PrepaidWaybill">
        <xsd:enumeration value="ReturnAuthorization">
        <xsd:enumeration value="RenderBillForCharges">
        <xsd:enumeration value="RailroadControlledPrivateEquipmentSubjectToDemurrage">
        <xsd:enumeration value="RadioactiveMaterial">
        <xsd:enumeration value="RushOrder">
        <xsd:enumeration value="RearRider">
        <xsd:enumeration value="InspectHourlyIfCarStopped">
        <xsd:enumeration value="RecordForTransit">
        <xsd:enumeration value="ShipperLoadOrCarrierCount">
        <xsd:enumeration value="ShoveToRestAndCover">
        <xsd:enumeration value="SubjectToSpecialDetentionRulesOrCharges">
        <xsd:enumeration value="Attachment-ShippersExportDocument">
        <xsd:enumeration value="ShiftableLoad">
        <xsd:enumeration value="ShipToCrossDockOrPool">
        <xsd:enumeration value="RequiresShelfCouplers">
        <xsd:enumeration value="Attachment-ShippersManifest">
        <xsd:enumeration value="Attachment-ShippersPackingInstructions">
        <xsd:enumeration value="SpeedRestricted">
        <xsd:enumeration value="StackTrain">
        <xsd:enumeration value="StretchWrap">
        <xsd:enumeration value="CarsTemporarilyArticulated">
        <xsd:enumeration value="TrailerConsolidatorLoad">
        <xsd:enumeration value="TrailerFactoryLoad">
        <xsd:enumeration value="TurnCar">
        <xsd:enumeration value="TransitShipment">
        <xsd:enumeration value="TeamTrackDelivery">
        <xsd:enumeration value="TimeVolumeRatesOnly">
        <xsd:enumeration value="UnloadAtBumperCircusRamp">
        <xsd:enumeration value="Unitized">
        <xsd:enumeration value="UnloadFromLeftSideOfCar">
        <xsd:enumeration value="UnloadAsPlacarded">
        <xsd:enumeration value="UnprotectedPerishable">
        <xsd:enumeration value="UnloadFromRightSideOfCar">
        <xsd:enumeration value="ShipperCertifiesGrossWeightUnder240000Pounds">
        <xsd:enumeration value="VerificationWeigh">
        <xsd:enumeration value="VentilationInstructions">
        <xsd:enumeration value="Wide-BodyPickupTruckAppliesToFinishedVehicleLoading">
        <xsd:enumeration value="WaivedInspection-SetDirect">
        <xsd:enumeration value="WeighEmpty">
        <xsd:enumeration value="Attachments-HighWideNotice">
        <xsd:enumeration value="WaiveInspection">
        <xsd:enumeration value="ManifestMustAccompanyWaybill">
        <xsd:enumeration value="WeighToCheckForOverload">
        <xsd:enumeration value="WasteWater">
        <xsd:enumeration value="Export">
        <xsd:enumeration value="CrossTown">
        <xsd:enumeration value="AdvancedFee">
        <xsd:enumeration value="CertificateOfOrigin">
        <xsd:enumeration value="FuelSurchargeAuthorized">
        <xsd:enumeration value="Offshore-AlaskaOrHawaiiService">
        <xsd:enumeration value="OversizedPremium">
        <xsd:enumeration value="PreparationOfAirWaybill-Origin">
        <xsd:enumeration value="PreparationOfCanadianCustomsInvoice">
        <xsd:enumeration value="PreparationOfExportEntry">
        <xsd:enumeration value="PreparationOfInsuranceCertificate">
        <xsd:enumeration value="PreparationOfU.S.ExportDocumentation">
        <xsd:enumeration value="SaturdayDelivery">
        <xsd:enumeration value="SaturdayPick-Up">
        <xsd:enumeration value="SecuritySignatureService">
        <xsd:enumeration value="WrittenProofOfDelivery">
        <xsd:enumeration value="Aggregate1000">
        <xsd:enumeration value="Aggregate3000">
        <xsd:enumeration value="Aggregate5000">
        <xsd:enumeration value="AttendantsAccompanying">
        <xsd:enumeration value="AdvanceLoading">
        <xsd:enumeration value="AirCraftFurnishedAndNotUsed">
        <xsd:enumeration value="AggregateTenderDiscount">
        <xsd:enumeration value="ArmedGuardService">
        <xsd:enumeration value="AdditionalInjectionOrBlendingService">
        <xsd:enumeration value="PortChanges">
        <xsd:enumeration value="UseOfAlternateTerminal">
        <xsd:enumeration value="A.M.DeliveryRequirement">
        <xsd:enumeration value="AnchoringAndUnanchoring">
        <xsd:enumeration value="AdditionalCopyOfShippingPapersForProofOfDelivery">
        <xsd:enumeration value="ApplianceServicing">
        <xsd:enumeration value="AirConditioningDisconnectAndConnect">
        <xsd:enumeration value="RailArmedGuardService">
        <xsd:enumeration value="AirRideTractorService">
        <xsd:enumeration value="AirRideTruckService">
        <xsd:enumeration value="AssemblyServiceRequested">
        <xsd:enumeration value="AuxiliaryService">
        <xsd:enumeration value="BypassConsolidationPoint">
        <xsd:enumeration value="BulkyArticle">
        <xsd:enumeration value="BlockingAndBracing">
        <xsd:enumeration value="BlindShipment">
        <xsd:enumeration value="BolsterLoadDoNotSwitch">
        <xsd:enumeration value="BoxingService-DryBulk">
        <xsd:enumeration value="BunkerSurchargeAuthorized">
        <xsd:enumeration value="BunkerAdjustment-20FootContainer">
        <xsd:enumeration value="BunkerAdjustment-40FootContainer">
        <xsd:enumeration value="BunkerAdjustment">
        <xsd:enumeration value="CurrencyAdjustment-20FootContainer">
        <xsd:enumeration value="CurrencyAdjustment-40FootContainer">
        <xsd:enumeration value="RoeeCarOrPick-UpTruck">
        <xsd:enumeration value="ConvertCommercialBillOfLadingBolToGovernmentBol">
        <xsd:enumeration value="Certification">
        <xsd:enumeration value="CarrierCaboose">
        <xsd:enumeration value="CorrosionAdditiveService">
        <xsd:enumeration value="CustomsFees-ContainerLevel">
        <xsd:enumeration value="CustomsFees-LiftLevel">
        <xsd:enumeration value="CarrierGuardCarService">
        <xsd:enumeration value="ReturnCarrierGuardCarService">
        <xsd:enumeration value="CargoTaxes">
        <xsd:enumeration value="ChainAndBinders">
        <xsd:enumeration value="CommercialInvoicePreparation">
        <xsd:enumeration value="ConstantSurveillance">
        <xsd:enumeration value="Cleaning">
        <xsd:enumeration value="ClassRatesApplied">
        <xsd:enumeration value="Comb.RatesOverDetroit">
        <xsd:enumeration value="ConsolidationAndLineHaul">
        <xsd:enumeration value="Consolidation">
        <xsd:enumeration value="ContractRatesApply">
        <xsd:enumeration value="CertificationThatTheNewsprintWindingCoresBeingReturnedEmptyWereReceivedFilledByRailFreightService">
        <xsd:enumeration value="ConsigneeUnload">
        <xsd:enumeration value="CourierOvernight">
        <xsd:enumeration value="CopilotService">
        <xsd:enumeration value="CustomsPapersMailed">
        <xsd:enumeration value="ContainerLease">
        <xsd:enumeration value="CourierSameDay">
        <xsd:enumeration value="GovernmentCaboose">
        <xsd:enumeration value="ControlledAtmosphere">
        <xsd:enumeration value="ContainerMounting">
        <xsd:enumeration value="CircuitousRouting">
        <xsd:enumeration value="CurrencyAdjustment-BreakBulk">
        <xsd:enumeration value="DoubleWideSeparateAndReassemble">
        <xsd:enumeration value="DeliveryOfFuelFromBargeToPipeline">
        <xsd:enumeration value="DodConstantSurveillanceService">
        <xsd:enumeration value="DualDriverWithNationalAgencyCheck">
        <xsd:enumeration value="DualDriverProtectiveService">
        <xsd:enumeration value="DirectDelivery">
        <xsd:enumeration value="DrayageAtPortOfDebarkationRateZone">
        <xsd:enumeration value="DeliveryService">
        <xsd:enumeration value="DetentionOfConveyingEquipmentAndThePowerUnit">
        <xsd:enumeration value="DetentionOfConveyingEquipmentExcludingThePowerUnit">
        <xsd:enumeration value="DrayageAtPortOfEmbarkationRateZone">
        <xsd:enumeration value="KeepFromFreezingPercentDifferential">
        <xsd:enumeration value="410DromedaryWithMechanicalRestrainingDevices">
        <xsd:enumeration value="410Dromedary">
        <xsd:enumeration value="DistributionServiceRequested">
        <xsd:enumeration value="DeliveryOfFuelFromRailTankCarToPipeline">
        <xsd:enumeration value="NotifyShipperImmediatelyIfShipmentIsDelayedEnRoute">
        <xsd:enumeration value="DoNotCoupleToOtherDiaphragmedCars">
        <xsd:enumeration value="DoNotFreeze">
        <xsd:enumeration value="DoNotCoupleToTankCars">
        <xsd:enumeration value="Documentation-Special">
        <xsd:enumeration value="ContainerDiversion">
        <xsd:enumeration value="DeliveryOfFuelFromPipelineToBarge">
        <xsd:enumeration value="DrayageAtPortOfDebarkation">
        <xsd:enumeration value="DrayageAtPortOfEmbarkation">
        <xsd:enumeration value="DeliveryOfFuelFromPipelineToRailTankCar">
        <xsd:enumeration value="DeliveryOfFuelFromPipelineToTankTruckOrTrailer">
        <xsd:enumeration value="DetentionWithPowerUnits30MinutePeriods">
        <xsd:enumeration value="Drop-OffDelivery">
        <xsd:enumeration value="DrummingService">
        <xsd:enumeration value="DoNotCoupleToDoubleShelfCouples">
        <xsd:enumeration value="DromedaryWithMechanicalRestrainingDevices">
        <xsd:enumeration value="DromedaryServiceRequested">
        <xsd:enumeration value="DoorSideVanning">
        <xsd:enumeration value="LaborAssociatedWithDetentionOfConveyingEquipment">
        <xsd:enumeration value="DeliveryOfFuelFromTankTruckOrTrailerToPipeline">
        <xsd:enumeration value="DetentionVehicle">
        <xsd:enumeration value="DetentionWithPowerUnits60MinutePeriods">
        <xsd:enumeration value="ExtraAxles">
        <xsd:enumeration value="EscortOrCourierService">
        <xsd:enumeration value="EmptyRailcarOrderedButNotUsed">
        <xsd:enumeration value="EquipmentHoseAtDestination">
        <xsd:enumeration value="EquipmentHoseAtOrigin">
        <xsd:enumeration value="ExclusiveUse">
        <xsd:enumeration value="ExtraLights">
        <xsd:enumeration value="EmergencyService">
        <xsd:enumeration value="EmptyMovement">
        <xsd:enumeration value="Endorsement">
        <xsd:enumeration value="EmptyReturn">
        <xsd:enumeration value="SatisfactoryServiceStandards">
        <xsd:enumeration value="ExcessiveValuationAuthorized">
        <xsd:enumeration value="ExclusiveUseOfVehicle">
        <xsd:enumeration value="ExtraDriver">
        <xsd:enumeration value="ExtraLengthSurcharge">
        <xsd:enumeration value="ExportPreparation">
        <xsd:enumeration value="ExpeditedRatesApplied">
        <xsd:enumeration value="ExpeditedService">
        <xsd:enumeration value="ExtraLabor">
        <xsd:enumeration value="ExclusiveUseOfVehicleDamaged">
        <xsd:enumeration value="ExpandRemoveAndInstall">
        <xsd:enumeration value="RoadwayEasyRatesApplied">
        <xsd:enumeration value="BargeFreightAllKindsService">
        <xsd:enumeration value="Firearms">
        <xsd:enumeration value="FurnishingChassis">
        <xsd:enumeration value="FuelFiltersFurnishedByCarrier">
        <xsd:enumeration value="FuelFiltersFurnishedByShipper">
        <xsd:enumeration value="FlatrackSurcharge">
        <xsd:enumeration value="ForProcessingInTransit">
        <xsd:enumeration value="AcceptedByCarrierAtOwnerSRiskOfFreezing">
        <xsd:enumeration value="ForStorageInTransit">
        <xsd:enumeration value="FiltrationService">
        <xsd:enumeration value="GarmentSurcharge">
        <xsd:enumeration value="Government-OwnedContainers">
        <xsd:enumeration value="GovernmentGuardCar">
        <xsd:enumeration value="GreaterSecurityService">
        <xsd:enumeration value="HoldAtLocation">
        <xsd:enumeration value="Handling">
        <xsd:enumeration value="HandBrakesAtEachEndMustBeReleased">
        <xsd:enumeration value="ShipmentHoldoverForHolidays">
        <xsd:enumeration value="ShipmentHoldoverForWeekends">
        <xsd:enumeration value="HeatInTransit">
        <xsd:enumeration value="Heat-Special">
        <xsd:enumeration value="HeatWithSteam">
        <xsd:enumeration value="AccessibleHazardousMaterial">
        <xsd:enumeration value="InaccessibleHazardousMaterial">
        <xsd:enumeration value="SundayOrHolidayPickupOrDelivery">
        <xsd:enumeration value="24HourAvailability">
        <xsd:enumeration value="Hose">
        <xsd:enumeration value="SpecialHose">
        <xsd:enumeration value="HighCubeTrailerRates">
        <xsd:enumeration value="HeaterOrRefrigeration">
        <xsd:enumeration value="HitchInstallation">
        <xsd:enumeration value="HazardousMaterialsSurcharge">
        <xsd:enumeration value="HazardousCargoOnDeck">
        <xsd:enumeration value="IdlerCar">
        <xsd:enumeration value="InsideDelivery">
        <xsd:enumeration value="IcingInhibitorService">
        <xsd:enumeration value="Impactographs">
        <xsd:enumeration value="IntermodalShipmentService">
        <xsd:enumeration value="Intra-PlantMove">
        <xsd:enumeration value="InsidePickup">
        <xsd:enumeration value="InterlineTransferService">
        <xsd:enumeration value="Just-In-TimeJit">
        <xsd:enumeration value="JointLineException">
        <xsd:enumeration value="CertificationThatTheContainersBeingReturnedEmptyWereReceivedFilledByRailFreightService">
        <xsd:enumeration value="KeepMaterialDry">
        <xsd:enumeration value="LaborDisturbance">
        <xsd:enumeration value="Layover">
        <xsd:enumeration value="ApplyAUCCOrEANSerialShippingContainerLabelToTheShippingContainers">
        <xsd:enumeration value="LightBarService">
        <xsd:enumeration value="LowBoyTrailerOrFlatBed">
        <xsd:enumeration value="LandCurrencyAdjustmentFactor-20FootContainer">
        <xsd:enumeration value="LandCurrencyAdjustment-40FootContainer">
        <xsd:enumeration value="PercentDifferential-LessThanContainer">
        <xsd:enumeration value="LessThanContainer">
        <xsd:enumeration value="LinehaulFromPortOfDebarkation">
        <xsd:enumeration value="LinehaulService">
        <xsd:enumeration value="LiabilityOfCarrier">
        <xsd:enumeration value="LinerTermsAtPortOfDebarkation">
        <xsd:enumeration value="LinerTermsAtPortOfEmbarkation">
        <xsd:enumeration value="LinehaulPercentDifferential">
        <xsd:enumeration value="LinehaulToPortOfEmbarkation">
        <xsd:enumeration value="LessThanTruckload">
        <xsd:enumeration value="LayoverService">
        <xsd:enumeration value="ModifiedAtmosphere">
        <xsd:enumeration value="EscortServiceWithOvernightSubsistence">
        <xsd:enumeration value="Escort">
        <xsd:enumeration value="EscortServicesTelephone">
        <xsd:enumeration value="Insulated">
        <xsd:enumeration value="MotorSurveillanceService">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Refrigerated">
        <xsd:enumeration value="MilitaryTrafficExpeditingService">
        <xsd:enumeration value="SpecialMotorSurveillance">
        <xsd:enumeration value="DoNotHumpOrHumpInto">
        <xsd:enumeration value="DoNotUseHelperLocomotiveToPush">
        <xsd:enumeration value="NoPlacardsRequired">
        <xsd:enumeration value="NoseSideVanning">
        <xsd:enumeration value="StowAwayFromHeat">
        <xsd:enumeration value="BlockStowage">
        <xsd:enumeration value="CargoAboard">
        <xsd:enumeration value="CarrierLoadAndConsigneeUnload">
        <xsd:enumeration value="OverHeightContainer">
        <xsd:enumeration value="CompletingShipment">
        <xsd:enumeration value="DeliveryVerificationNotRequired">
        <xsd:enumeration value="StowWithDoorsFacingInward">
        <xsd:enumeration value="ExemptCommodity">
        <xsd:enumeration value="InFrontOfHouseStowage">
        <xsd:enumeration value="Fumigation">
        <xsd:enumeration value="Harmless">
        <xsd:enumeration value="OilFieldService">
        <xsd:enumeration value="UseNoHooks">
        <xsd:enumeration value="NotRestrictedCargo">
        <xsd:enumeration value="CargoOnBoardCertificationRequired">
        <xsd:enumeration value="OnDeckStowage">
        <xsd:enumeration value="CarrierLoadAndCarrierUnload">
        <xsd:enumeration value="Perishable">
        <xsd:enumeration value="PartialShipment">
        <xsd:enumeration value="StowBelowDeck">
        <xsd:enumeration value="StowBetweenDecks">
        <xsd:enumeration value="TemperatureControl">
        <xsd:enumeration value="TimeOfDeliveryAndSignatureRequired">
        <xsd:enumeration value="OnTopIn-HatchStowage">
        <xsd:enumeration value="OnTopOn-DeckStowage">
        <xsd:enumeration value="TotalShipment">
        <xsd:enumeration value="UnderContainerOn-DeckStowage">
        <xsd:enumeration value="BelowWaterLineStowage">
        <xsd:enumeration value="Overflow">
        <xsd:enumeration value="OverWidthContainer">
        <xsd:enumeration value="OneWayRatesApplied">
        <xsd:enumeration value="PumpingEquipment">
        <xsd:enumeration value="PickupOfShipmentsOnSaturdaySundayAndOrHolidaysRequiringAbsoluteNextDayDelivery">
        <xsd:enumeration value="PickupAndDeliveryFromStorageInTransit">
        <xsd:enumeration value="PickupAndDeliveryBeyondServiceArea">
        <xsd:enumeration value="SpecialPermits">
        <xsd:enumeration value="ProtectFromHeat">
        <xsd:enumeration value="PerHourRatesApplied">
        <xsd:enumeration value="PierTime">
        <xsd:enumeration value="PalletsOrSkidsOrPlatforms">
        <xsd:enumeration value="P.M.DeliveryRequirement">
        <xsd:enumeration value="PerMileRatesApply">
        <xsd:enumeration value="PickupOfShipmentsRequiringSameDayDeliveryService">
        <xsd:enumeration value="PickupOfShipmentsRequiringSameDayDeliveryServiceAndOrDeliveryAtASpecifiedTime">
        <xsd:enumeration value="PianoOrOrganCarry">
        <xsd:enumeration value="PositioningAtOrigin">
        <xsd:enumeration value="PickupAndDeliveryServiceForPerishables">
        <xsd:enumeration value="Prelodge">
        <xsd:enumeration value="StuffingCharge">
        <xsd:enumeration value="ProtectiveServiceSecurityWithArmedGuards">
        <xsd:enumeration value="ProtectiveSecurityService">
        <xsd:enumeration value="ProtectiveTarpForSecurityPurposes">
        <xsd:enumeration value="Pickup">
        <xsd:enumeration value="PickupAndDelivery">
        <xsd:enumeration value="PackAndUnpack">
        <xsd:enumeration value="PUPTrailerRatesApply">
        <xsd:enumeration value="BondedPrivatelyOwnedVehicle">
        <xsd:enumeration value="DetentionOfPrivatelyOwnedVehicle">
        <xsd:enumeration value="InoperablePrivatelyOwnedVehicle">
        <xsd:enumeration value="LoadingOrUnloadingOfPrivatelyOwnedVehicle">
        <xsd:enumeration value="PrivateOwnedVehicleProcessing">
        <xsd:enumeration value="Stop-OffsForPrivatelyOwnedVehicleShipment">
        <xsd:enumeration value="PrivatelyOwnedVehicleInTruckawayService">
        <xsd:enumeration value="PriorityService">
        <xsd:enumeration value="Reconsignment">
        <xsd:enumeration value="Redelivery">
        <xsd:enumeration value="RailheadHandling">
        <xsd:enumeration value="RoadrailerService">
        <xsd:enumeration value="Respotting">
        <xsd:enumeration value="ResidentialDelivery">
        <xsd:enumeration value="ReeferMaintenance">
        <xsd:enumeration value="ReleasedValueChargeInExcessOfCarrierMaximumLiability">
        <xsd:enumeration value="RelocationOfVehicle">
        <xsd:enumeration value="ReturnOfEmptyContainer">
        <xsd:enumeration value="ReturnMovementOfPallet">
        <xsd:enumeration value="RailSurveillance">
        <xsd:enumeration value="ReeferCargoPercentDifferential">
        <xsd:enumeration value="RoundTripService">
        <xsd:enumeration value="Reshipment">
        <xsd:enumeration value="RestrictedSpeeds">
        <xsd:enumeration value="Reservations">
        <xsd:enumeration value="ReweightRequested">
        <xsd:enumeration value="ShipmentHoldoverOnWeekends">
        <xsd:enumeration value="SaturdayPickupOrDelivery">
        <xsd:enumeration value="SpecialContainers">
        <xsd:enumeration value="ShipperLoadAndConsigneeUnload">
        <xsd:enumeration value="SplitDelivery">
        <xsd:enumeration value="SpecialDromedaryService">
        <xsd:enumeration value="SpecialEquipmentCharge">
        <xsd:enumeration value="ShipperExportDeclarationRequired">
        <xsd:enumeration value="StairsElevatorExcessCarry">
        <xsd:enumeration value="ServiceChargeApplies">
        <xsd:enumeration value="SecurityEscortVehicleService">
        <xsd:enumeration value="SingleFactorOriginationOrDestination">
        <xsd:enumeration value="SingleFactorOriginationOrPortOfDebarkation">
        <xsd:enumeration value="SingleFactorPortOfEmbarkationOrDestination">
        <xsd:enumeration value="SpecialTrainMovement">
        <xsd:enumeration value="SingleShipment">
        <xsd:enumeration value="ShipmentHoldoverOnHolidays">
        <xsd:enumeration value="ShipperLoad">
        <xsd:enumeration value="ShipmentHoldoverOnWeekdays">
        <xsd:enumeration value="SkirtingAndUnskirting">
        <xsd:enumeration value="ShipperLoadAndCount">
        <xsd:enumeration value="SmallPackage">
        <xsd:enumeration value="TransmitAShipNoticeOrManifestTransactionSet">
        <xsd:enumeration value="SatelliteSurveillanceService">
        <xsd:enumeration value="ShipmentFromNon-TempStorage">
        <xsd:enumeration value="Stop-Off">
        <xsd:enumeration value="ShipperLoadAndCarrierUnload">
        <xsd:enumeration value="SpecialPermit">
        <xsd:enumeration value="SpreaderService">
        <xsd:enumeration value="SpotForStorage-NoShipment">
        <xsd:enumeration value="SplitPickup">
        <xsd:enumeration value="Storage">
        <xsd:enumeration value="SurveyingRoutes">
        <xsd:enumeration value="StrippingSortingAndConsolidation">
        <xsd:enumeration value="SubstituteServiceNotToBeUsed">
        <xsd:enumeration value="PoleLashingEquipmentPleSurcharge">
        <xsd:enumeration value="ConductivityOrAnti-StaticAdditive">
        <xsd:enumeration value="Stop-OffAtDestination">
        <xsd:enumeration value="Stowage">
        <xsd:enumeration value="Stop-OffAtOrigination">
        <xsd:enumeration value="SignatureAndTallyRecord">
        <xsd:enumeration value="SpotForUnloadingFromAEnd">
        <xsd:enumeration value="SpotForUnloadingFromBBrakeEnd">
        <xsd:enumeration value="SupervisorRequested">
        <xsd:enumeration value="StorageOfVehicles">
        <xsd:enumeration value="Truckload-DoubleOperator-CommonCarrier">
        <xsd:enumeration value="Truckload-DoubleOperator-PaddedVan">
        <xsd:enumeration value="TerminalHandlingCharges">
        <xsd:enumeration value="TenderedAsTruckloadTruckloadServiceRequested">
        <xsd:enumeration value="Multi-TankSurveillanceService">
        <xsd:enumeration value="TenderingOfMultipleVehicles">
        <xsd:enumeration value="TrailerOnFlatCar">
        <xsd:enumeration value="ThirdPartyService">
        <xsd:enumeration value="TractorOnly">
        <xsd:enumeration value="TruckRatesApplicable">
        <xsd:enumeration value="TrailerPreparation-Special">
        <xsd:enumeration value="Termination">
        <xsd:enumeration value="TransferProduct">
        <xsd:enumeration value="TireRepairAndReplace">
        <xsd:enumeration value="TradeShow">
        <xsd:enumeration value="TractorAndTrailer">
        <xsd:enumeration value="Truckload-SingleOperator-CommonCarrier">
        <xsd:enumeration value="Truckload-SingleOperator-PaddedVan">
        <xsd:enumeration value="TankSurveillanceService">
        <xsd:enumeration value="UnderCarriageFurnishedByCarrier">
        <xsd:enumeration value="Unpacking">
        <xsd:enumeration value="UnloadingOrReloading">
        <xsd:enumeration value="UtilitiesDisconnectAndConnect">
        <xsd:enumeration value="VacuumService">
        <xsd:enumeration value="RoeeVanTypeTruck">
        <xsd:enumeration value="VanCleaning">
        <xsd:enumeration value="VehiclesFurnishedButNotUsed">
        <xsd:enumeration value="VehiclesInoperable">
        <xsd:enumeration value="Stop-OffDeliveryOfPersonalVehicles">
        <xsd:enumeration value="VehiclesInTruckaway">
        <xsd:enumeration value="Wharfage-Breakbulk">
        <xsd:enumeration value="Wharfage-Container">
        <xsd:enumeration value="WaterfrontDelivery">
        <xsd:enumeration value="Wharfage">
        <xsd:enumeration value="WarRiskCrewBonus">
        <xsd:enumeration value="WarRiskInsurance">
        <xsd:enumeration value="WaitingTimeAuthorized">
        <xsd:enumeration value="WeightVerification">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: SpecialHandlingType

SpecialHandlingType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( SpecialHandlingCoded[SpecialHandlingCodeType]? , SpecialHandlingCodedOther[xsd:string]? , SpecialHandlingNote[xsd:string]? )

    Description: SpecialHandlingType describes any special handling relating to the package.

    Elements:

    • SpecialHandlingCoded - contains the handling code.
    • SpecialHandlingCodedOther - is used to provide a non-standard SpecialHandlingCode. This element is mandatory if the value of SpecialHandlingCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • SpecialHandlingNote - contains any notes relating to the special handling of the package.

[^]Code Fragment

    <xsd:complexType name="SpecialHandlingType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="SpecialHandlingCoded" type="SpecialHandlingCodeType">
        <xsd:element minOccurs="0" name="SpecialHandlingCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="SpecialHandlingNote" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: StandardCategoryIDType

StandardCategoryIDType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( StandardCategoryType[xsd:string] , ClassificationID[xsd:string] , TechnicalID[xsd:string]? )

    Description: StandardCategoryIDType contains the standard product category in accordance with UNSPSC or eClass.

    Elements:

    • StandardCategoryType - is a standard category group number of UNSPSC or eClass
    • ClassificationID - is a version dependent category identifier.
    • TechnicalID - is a non-version unique dependent category identifier.

[^]Code Fragment

    <xsd:complexType name="StandardCategoryIDType">
    <xsd:sequence>
        <xsd:element name="StandardCategoryType" type="xsd:string">
        <xsd:element name="ClassificationID" type="xsd:string">
        <xsd:element minOccurs="0" name="TechnicalID" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: StatusEventCodeType

StatusEventCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the status of the event.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Pending - Pending
    • Accepted - Accepted
    • AcceptedWithChanges - Accepted with changes
    • NotAccepted - Notaccepted
    • Despatched - Despatched
    • NotApplicable - A status does not apply
    • CreditReviewInProcess - Payment status - credit review in progress
    • CreditApproved - Payment status - credit approved
    • PrepaymentRequired - Payment status - prepayment is required
    • CardCharged - Payment status - card has been charged
    • Invoiced - Payment status - customer has been invoiced
    • PaymentReceived - Payment status - payment has been received
    • AutomatedPaymentInitiated - Payment status - an automated payment has been initiated
    • PaidInFull - Payment status - paid in full
    • PartiallyCharged - Payment status - only part of the items have been charged.
    • NotYetShipped - Shipment status - order or item has not been shipped
    • BackOrdered - Shipment status - item has been back ordered
    • BackOrderShipped - Shipment status - back ordered goods have been shipped
    • ReadyForPickup - Shipment status - order or item is ready for pick up
    • InTransit - Shipment status - order or item is in transit
    • PartiallyShipped - Shipment status - order or item has been partially shipped
    • PartiallyDelivered - Shipment status - part of the order or item has been delivered
    • ShipmentComplete - Shipment status - all order or all item has been shipped
    • Delivered - Shipment status - order of item has been delivered
    • NoInfo - No info
    • NewOrder - New order
    • ChangeOrder - Change order
    • Processing - Processing
    • Cancelled - Cancelled
    • Completed - Completed
    • ItemOnHold - Item on hold
    • Other - Custom code

[^]Code Fragment

    <xsd:simpleType name="StatusEventCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Pending">
        <xsd:enumeration value="Accepted">
        <xsd:enumeration value="AcceptedWithChanges">
        <xsd:enumeration value="NotAccepted">
        <xsd:enumeration value="Despatched">
        <xsd:enumeration value="NotApplicable">
        <xsd:enumeration value="CreditReviewInProcess">
        <xsd:enumeration value="CreditApproved">
        <xsd:enumeration value="PrepaymentRequired">
        <xsd:enumeration value="CardCharged">
        <xsd:enumeration value="Invoiced">
        <xsd:enumeration value="PaymentReceived">
        <xsd:enumeration value="AutomatedPaymentInitiated">
        <xsd:enumeration value="PaidInFull">
        <xsd:enumeration value="PartiallyCharged">
        <xsd:enumeration value="NotYetShipped">
        <xsd:enumeration value="BackOrdered">
        <xsd:enumeration value="BackOrderShipped">
        <xsd:enumeration value="ReadyForPickup">
        <xsd:enumeration value="InTransit">
        <xsd:enumeration value="PartiallyShipped">
        <xsd:enumeration value="PartiallyDelivered">
        <xsd:enumeration value="ShipmentComplete">
        <xsd:enumeration value="Delivered">
        <xsd:enumeration value="NoInfo">
        <xsd:enumeration value="NewOrder">
        <xsd:enumeration value="ChangeOrder">
        <xsd:enumeration value="Processing">
        <xsd:enumeration value="Cancelled">
        <xsd:enumeration value="Completed">
        <xsd:enumeration value="ItemOnHold">
        <xsd:enumeration value="Other">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: StatusEventType

StatusEventType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( StatusEventCoded[StatusEventCodeType] , StatusEventCodedOther[xsd:string]? )

    Description: StatusEventType identifies the status of the purchase order.

    Elements:

    • StatusEventCoded - lists the status of the event.
    • StatusEventCodedOther - is used to provide a non-standard StatusEventCode. This element is mandatory if the value of StatusEventCoded is 'Other". These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="StatusEventType">
    <xsd:sequence>
        <xsd:element name="StatusEventCoded" type="StatusEventCodeType">
        <xsd:element minOccurs="0" name="StatusEventCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: StatusReasonCodeType

StatusReasonCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the reason for the status.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • ChangedSchedule - Changed schedule
    • InstructionsAwaited - Instructions awaited
    • Damaged - Damaged
    • Other - Other
    • CustomsRefusal - Customs refusal
    • EmptyOnInspection - Empty On Inspection
    • DestinationIncorrect - Destination incorrect
    • ExportRestrictions - Export restrictions
    • ImportRestrictions - Import restrictions
    • PaymentNotReceived - Payment not recieved
    • DeliveryDifferentDate - Delivery different date
    • DeliveryTooLate - Delivery date
    • IncidentAttributedToSeller - Incident attributed to seller
    • IncidentAttributedToTheBuyer - Incident attributed to buyer
    • IncidentAttributedToTheCarrier - Incident attributed to carrier

[^]Code Fragment

    <xsd:simpleType name="StatusReasonCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="ChangedSchedule">
        <xsd:enumeration value="InstructionsAwaited">
        <xsd:enumeration value="Damaged">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="CustomsRefusal">
        <xsd:enumeration value="EmptyOnInspection">
        <xsd:enumeration value="DestinationIncorrect">
        <xsd:enumeration value="ExportRestrictions">
        <xsd:enumeration value="ImportRestrictions">
        <xsd:enumeration value="PaymentNotReceived">
        <xsd:enumeration value="DeliveryDifferentDate">
        <xsd:enumeration value="DeliveryTooLate">
        <xsd:enumeration value="IncidentAttributedToSeller">
        <xsd:enumeration value="IncidentAttributedToTheBuyer">
        <xsd:enumeration value="IncidentAttributedToTheCarrier">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: StatusReasonType

StatusReasonType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( StatusReasonCoded[StatusReasonCodeType] , StatusReasonCodedOther[xsd:string]? )

    Description: StatusReasonType provides a reason for the status.

    Elements:

    • StatusReasonCoded - lists the status reason.
    • StatusReasonCodedOther - is used to provide a non-standard StatusReasonCode. This element is mandatory if the value of StatusReasonCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="StatusReasonType">
    <xsd:sequence>
        <xsd:element name="StatusReasonCoded" type="StatusReasonCodeType">
        <xsd:element minOccurs="0" name="StatusReasonCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: StatusType

StatusType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( StatusEvent[StatusEventType] , ListOfStatusReason[ListOfStatusReasonType]? , StatusNote[xsd:string]? , ErrorInfo[ErrorInfoType]? )

    Description: StatusType contains the information necessary for reporting a status, this includes the event, the reason, notes and error information if applicable.

    Elements:

    • StatusEvent - identifies the status of the purchase order.
    • ListOfStatusReason - holds a list of status reason.
    • StatusNote - contains general information about the status of an order.
    • ErrorInfo - is a container for the error details.

[^]Code Fragment

    <xsd:complexType name="StatusType">
    <xsd:sequence>
        <xsd:element name="StatusEvent" type="StatusEventType">
        <xsd:element minOccurs="0" name="ListOfStatusReason" type="ListOfStatusReasonType">
        <xsd:element minOccurs="0" name="StatusNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ErrorInfo" type="ErrorInfoType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: StructuredNoteType

StructuredNoteType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( GeneralNote[xsd:string]? , NoteID[xsd:string]? , Agency[AgencyType]? , NoteURL[xsd:anyURI]? , TextTypeCoded[TextTypeCodeType]? , TextTypeCodedOther[xsd:string]? )

    Description: StructuredNoteType is a note that allows for an ID, URL, and a free form note field.

    Elements:

    • GeneralNote - is used to provide a note in text form if desired.
    • NoteID - is an ID assigned to this note. This element is an implied attribute.
    • Agency - is used to identify the agency that assigned the NoteID.
    • NoteURL - is the URL that this note is referencing. This is an implied attribute.
    • TextTypeCoded - identifies the type of text contained in the structured note. This should only be used if the identification of the type of note is necessary.
    • TextTypeCodedOther - is used to provide a non-standard TextTypeCode. This element is mandatory if the value of TextTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="StructuredNoteType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="GeneralNote" type="xsd:string">
        <xsd:element minOccurs="0" name="NoteID" type="xsd:string">
        <xsd:element minOccurs="0" name="Agency" type="AgencyType">
        <xsd:element minOccurs="0" name="NoteURL" type="xsd:anyURI">
        <xsd:element minOccurs="0" name="TextTypeCoded" type="TextTypeCodeType">
        <xsd:element minOccurs="0" name="TextTypeCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: SurfaceLayerPositionCodeType

SurfaceLayerPositionCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the surface layer or the position of the item that is being described by the ItemCharacteristic element. This code list is derived from EDIFACT 7383 (Surface layer code) and X12 752 (Surface/layer/position code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • All
    • BackOfCab -
    • Bilateral
    • Block
    • Bolster
    • BothSides -
    • Bottom -
    • Brick
    • CasingHeadFlange
    • Center
    • CornerDiagonals - The surface or layer of the product being described are the corner diagonals.
    • DoubleEndOverhang
    • DownstreamTap
    • DualFuelTankPositions -
    • Exterior
    • Front -
    • FrontSpare
    • Inside -
    • InsideLeftRear
    • InsideRightRear
    • Interior
    • KellyBushing
    • Left -
    • LeftFront
    • LeftRear
    • LessCriticalSurface
    • Lower
    • Middle
    • MoreCriticalSurface
    • Multiple
    • NextRelativePosition
    • NotSpecified
    • OffSurface - To indicate that the entity being specified is off the surface.
    • OneSide -
    • OnSurface - To indicate that the entity being specified is on the surface.
    • OppositeCorners - The surface or layer of the product being described is the opposite corners.
    • Outside -
    • OutsideLeftRear
    • OutsideRightRear
    • Overall -
    • Port - The left-hand side (looking forward) of a ship, boat or aircraft.
    • Rear -
    • RearSpare
    • RelativePosition1
    • RelativePosition10
    • RelativePosition11
    • RelativePosition12
    • RelativePosition13
    • RelativePosition14
    • RelativePosition15
    • RelativePosition16
    • RelativePosition17
    • RelativePosition18
    • RelativePosition19
    • RelativePosition2
    • RelativePosition20
    • RelativePosition21
    • RelativePosition22
    • RelativePosition23
    • RelativePosition24
    • RelativePosition25
    • RelativePosition26
    • RelativePosition27
    • RelativePosition28
    • RelativePosition29
    • RelativePosition3
    • RelativePosition30
    • RelativePosition31
    • RelativePosition32
    • RelativePosition33
    • RelativePosition34
    • RelativePosition35
    • RelativePosition36
    • RelativePosition37
    • RelativePosition38
    • RelativePosition39
    • RelativePosition4
    • RelativePosition40
    • RelativePosition41
    • RelativePosition42
    • RelativePosition43
    • RelativePosition44
    • RelativePosition45
    • RelativePosition46
    • RelativePosition47
    • RelativePosition48
    • RelativePosition49
    • RelativePosition5
    • RelativePosition50
    • RelativePosition6
    • RelativePosition7
    • RelativePosition8
    • RelativePosition9
    • RigFloor
    • Right -
    • RightFront
    • RightRear
    • SideOne -
    • SideTwo -
    • Siding
    • Single
    • SingleEndOverhang
    • Soluble - Specifies that the surface/layer/position being described is the soluble portion.
    • SpareTirePosition
    • Starboard - The right-hand side (looking forward) of a ship, boat or aircraft.
    • Stone
    • Stucco
    • Sub-Sea
    • TankBottom -
    • ToothBuccalSurface - Surface of the tooth pertaining to or around the cheek.
    • ToothDistalSurface - Surface of the tooth toward the back of the dental arch, or away from the midline.
    • ToothFacialSurface - Surface of a tooth directed toward the face and opposite the lingual surface.
    • ToothIncisalSurface - Surface of the tooth relating to the cutting edge of the anterior teeth, incisors or canines.
    • ToothLingualSurface - Surface of the tooth pertaining to or around the tongue.
    • ToothMesialSurface - Surface of the tooth toward the midline of the dental arch.
    • ToothOcclusalSurface - Surface of the tooth pertaining to the masticating surfaces of the posterior teeth.
    • Top -
    • TwoSides -
    • UnderCab -
    • Unilateral
    • Upper
    • UpstreamTap
    • Wood

[^]Code Fragment

    <xsd:simpleType name="SurfaceLayerPositionCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="All">
        <xsd:enumeration value="BackOfCab">
        <xsd:enumeration value="Bilateral">
        <xsd:enumeration value="Block">
        <xsd:enumeration value="Bolster">
        <xsd:enumeration value="BothSides">
        <xsd:enumeration value="Bottom">
        <xsd:enumeration value="Brick">
        <xsd:enumeration value="CasingHeadFlange">
        <xsd:enumeration value="Center">
        <xsd:enumeration value="CornerDiagonals">
        <xsd:enumeration value="DoubleEndOverhang">
        <xsd:enumeration value="DownstreamTap">
        <xsd:enumeration value="DualFuelTankPositions">
        <xsd:enumeration value="Exterior">
        <xsd:enumeration value="Front">
        <xsd:enumeration value="FrontSpare">
        <xsd:enumeration value="Inside">
        <xsd:enumeration value="InsideLeftRear">
        <xsd:enumeration value="InsideRightRear">
        <xsd:enumeration value="Interior">
        <xsd:enumeration value="KellyBushing">
        <xsd:enumeration value="Left">
        <xsd:enumeration value="LeftFront">
        <xsd:enumeration value="LeftRear">
        <xsd:enumeration value="LessCriticalSurface">
        <xsd:enumeration value="Lower">
        <xsd:enumeration value="Middle">
        <xsd:enumeration value="MoreCriticalSurface">
        <xsd:enumeration value="Multiple">
        <xsd:enumeration value="NextRelativePosition">
        <xsd:enumeration value="NotSpecified">
        <xsd:enumeration value="OffSurface">
        <xsd:enumeration value="OneSide">
        <xsd:enumeration value="OnSurface">
        <xsd:enumeration value="OppositeCorners">
        <xsd:enumeration value="Outside">
        <xsd:enumeration value="OutsideLeftRear">
        <xsd:enumeration value="OutsideRightRear">
        <xsd:enumeration value="Overall">
        <xsd:enumeration value="Port">
        <xsd:enumeration value="Rear">
        <xsd:enumeration value="RearSpare">
        <xsd:enumeration value="RelativePosition1">
        <xsd:enumeration value="RelativePosition10">
        <xsd:enumeration value="RelativePosition11">
        <xsd:enumeration value="RelativePosition12">
        <xsd:enumeration value="RelativePosition13">
        <xsd:enumeration value="RelativePosition14">
        <xsd:enumeration value="RelativePosition15">
        <xsd:enumeration value="RelativePosition16">
        <xsd:enumeration value="RelativePosition17">
        <xsd:enumeration value="RelativePosition18">
        <xsd:enumeration value="RelativePosition19">
        <xsd:enumeration value="RelativePosition2">
        <xsd:enumeration value="RelativePosition20">
        <xsd:enumeration value="RelativePosition21">
        <xsd:enumeration value="RelativePosition22">
        <xsd:enumeration value="RelativePosition23">
        <xsd:enumeration value="RelativePosition24">
        <xsd:enumeration value="RelativePosition25">
        <xsd:enumeration value="RelativePosition26">
        <xsd:enumeration value="RelativePosition27">
        <xsd:enumeration value="RelativePosition28">
        <xsd:enumeration value="RelativePosition29">
        <xsd:enumeration value="RelativePosition3">
        <xsd:enumeration value="RelativePosition30">
        <xsd:enumeration value="RelativePosition31">
        <xsd:enumeration value="RelativePosition32">
        <xsd:enumeration value="RelativePosition33">
        <xsd:enumeration value="RelativePosition34">
        <xsd:enumeration value="RelativePosition35">
        <xsd:enumeration value="RelativePosition36">
        <xsd:enumeration value="RelativePosition37">
        <xsd:enumeration value="RelativePosition38">
        <xsd:enumeration value="RelativePosition39">
        <xsd:enumeration value="RelativePosition4">
        <xsd:enumeration value="RelativePosition40">
        <xsd:enumeration value="RelativePosition41">
        <xsd:enumeration value="RelativePosition42">
        <xsd:enumeration value="RelativePosition43">
        <xsd:enumeration value="RelativePosition44">
        <xsd:enumeration value="RelativePosition45">
        <xsd:enumeration value="RelativePosition46">
        <xsd:enumeration value="RelativePosition47">
        <xsd:enumeration value="RelativePosition48">
        <xsd:enumeration value="RelativePosition49">
        <xsd:enumeration value="RelativePosition5">
        <xsd:enumeration value="RelativePosition50">
        <xsd:enumeration value="RelativePosition6">
        <xsd:enumeration value="RelativePosition7">
        <xsd:enumeration value="RelativePosition8">
        <xsd:enumeration value="RelativePosition9">
        <xsd:enumeration value="RigFloor">
        <xsd:enumeration value="Right">
        <xsd:enumeration value="RightFront">
        <xsd:enumeration value="RightRear">
        <xsd:enumeration value="SideOne">
        <xsd:enumeration value="SideTwo">
        <xsd:enumeration value="Siding">
        <xsd:enumeration value="Single">
        <xsd:enumeration value="SingleEndOverhang">
        <xsd:enumeration value="Soluble">
        <xsd:enumeration value="SpareTirePosition">
        <xsd:enumeration value="Starboard">
        <xsd:enumeration value="Stone">
        <xsd:enumeration value="Stucco">
        <xsd:enumeration value="Sub-Sea">
        <xsd:enumeration value="TankBottom">
        <xsd:enumeration value="ToothBuccalSurface">
        <xsd:enumeration value="ToothDistalSurface">
        <xsd:enumeration value="ToothFacialSurface">
        <xsd:enumeration value="ToothIncisalSurface">
        <xsd:enumeration value="ToothLingualSurface">
        <xsd:enumeration value="ToothMesialSurface">
        <xsd:enumeration value="ToothOcclusalSurface">
        <xsd:enumeration value="Top">
        <xsd:enumeration value="TwoSides">
        <xsd:enumeration value="UnderCab">
        <xsd:enumeration value="Unilateral">
        <xsd:enumeration value="Upper">
        <xsd:enumeration value="UpstreamTap">
        <xsd:enumeration value="Wood">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: TaxCategoryCodeType

TaxCategoryCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the category of the tax, and by implication, the tax rate that applies. This code list is derived from EDIFACT 5305(Duty or tax or fee category code) and X12 441 (Tax exempt code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • DutyPaidBySupplier - Duty associated with shipment of goods is paid by the supplier; customer receives goods with duty paid.
    • ExemptForResale - A tax category code indicating the item is tax exempt when the item is bought for future resale.
    • ExemptFromTax
    • FreeExportItemTaxNotCharged
    • HigherRate
    • LowerRate - Tax rate is lower than standard rate.
    • MixedTaxRate
    • ServicesOutsideScopeOfTax
    • StandardRate
    • Transferred - VAT not to be paid to the issuer of the invoice but directly to relevant tax authority.
    • ValueAddedTaxDueFromAPreviousInvoice - A code to indicate that the Value Added Tax (VAT) amount of a previous invoice is to be paid.
    • ValueAddedTaxNotNowDueForPayment - A code to indicate that the Value Added Tax (VAT) amount which is due on the current invoice is to be paid on receipt of a separate VAT payment request.
    • ZeroRatedGoods

[^]Code Fragment

    <xsd:simpleType name="TaxCategoryCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="DutyPaidBySupplier">
        <xsd:enumeration value="ExemptForResale">
        <xsd:enumeration value="ExemptFromTax">
        <xsd:enumeration value="FreeExportItemTaxNotCharged">
        <xsd:enumeration value="HigherRate">
        <xsd:enumeration value="LowerRate">
        <xsd:enumeration value="MixedTaxRate">
        <xsd:enumeration value="ServicesOutsideScopeOfTax">
        <xsd:enumeration value="StandardRate">
        <xsd:enumeration value="Transferred">
        <xsd:enumeration value="ValueAddedTaxDueFromAPreviousInvoice">
        <xsd:enumeration value="ValueAddedTaxNotNowDueForPayment">
        <xsd:enumeration value="ZeroRatedGoods">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: TaxFunctionQualifierCodeType

TaxFunctionQualifierCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the function of the tax element. This code list is derived from EDIFACT 5283 (Duty or tax or fee function code qualifier)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • IndividualDutyTaxOrFeeCustomsItem - Individual duty, tax or fee charged on a single Customs item line of the goods declaration (CCC).
    • TotalOfAllDutiesTaxesAndFeesCustomsItem - Total of all duties, taxes and fees charged on a single Customs item line of the goods declaration (CCC).
    • TotalOfEachDutyTaxOrFeeTypeCustomsDeclaration - Total of each duty, tax or fee charged on the goods declaration (CCC).
    • TotalOfAllDutiesTaxesAndFeeTypesCustomsDeclaration - Total of all duties, taxes and fees charged on the goods declaration (CCC).
    • CustomsDuty - Duties laid down in the Customs tariff to which goods are liable on entering or leaving the Customs territory (CCC).
    • Fee - Charge for services rendered.
    • Tax - Contribution levied by an authority.
    • TaxRelatedInformation - Specifies information related to the tax.

[^]Code Fragment

    <xsd:simpleType name="TaxFunctionQualifierCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="IndividualDutyTaxOrFeeCustomsItem">
        <xsd:enumeration value="TotalOfAllDutiesTaxesAndFeesCustomsItem">
        <xsd:enumeration value="TotalOfEachDutyTaxOrFeeTypeCustomsDeclaration">
        <xsd:enumeration value="TotalOfAllDutiesTaxesAndFeeTypesCustomsDeclaration">
        <xsd:enumeration value="CustomsDuty">
        <xsd:enumeration value="Fee">
        <xsd:enumeration value="Tax">
        <xsd:enumeration value="TaxRelatedInformation">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: TaxPaymentMethodCodeType

TaxPaymentMethodCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the method by which the Tax will be paid.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • Normal - Default
    • DirectPay - The buyer collects the tax due as specified on the Invoice and pays it to the tax authority
    • SelfAssess - The buyer calculates the tax due and pays it to the tax authority
    • PayVendor - The buyer pays the tax due as specified on the Invoice to the supplier

[^]Code Fragment

    <xsd:simpleType name="TaxPaymentMethodCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Normal">
        <xsd:enumeration value="DirectPay">
        <xsd:enumeration value="SelfAssess">
        <xsd:enumeration value="PayVendor">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: TaxReferenceType

TaxReferenceType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( TaxTypeCoded[TaxTypeCodeType] , TaxTypeCodedOther[IdentifierType]? , TaxFunctionQualifierCoded[TaxFunctionQualifierCodeType] , TaxFunctionQualifierCodedOther[xsd:string]? , TaxCategoryCoded[TaxCategoryCodeType] , TaxCategoryCodedOther[xsd:string]? , ReasonTaxExemptCoded[ReasonTaxExemptCodeType]? , ReasonTaxExemptCodedOther[xsd:string]? , TaxPercent[PercentType]? , TaxPaymentMethodCoded[TaxPaymentMethodCodeType]? , TaxPaymentMethodCodedOther[xsd:string]? , TaxTreatmentCoded[TaxTreatmentCodeType] , TaxTreatmentCodedOther[xsd:string]? , TaxAmount[Decimal21_6Type]? , TaxAmountInTaxAccountingCurrency[Decimal21_6Type]? , TaxLocation[LocationType]? )

    Description: TaxReferenceType contains a reference to the tax information relevant to the order.

    Elements:

    • TaxTypeCoded - identifies the type of the tax.
    • TaxTypeCodedOther - is used to provide a non-standard TaxTypeCode. This element is mandatory if the value of TaxTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • TaxFunctionQualifierCoded - indicates the function of the Tax element, e.g. tax, customs duty.
    • TaxFunctionQualifierCodedOther - is used to provide a non-standard TaxQualifierCode. This element is mandatory if the value of TaxQualifierCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • TaxCategoryCoded - indicates the category of the tax and, by implication, the tax rate that applies. The actual percentage is dependent on the tax jurisdiction.
    • TaxCategoryCodedOther - is used to provide a non-standard TaxCategoryCode. This element is mandatory if the value of TaxCategoryCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • ReasonTaxExemptCoded - explains why a TaxCategory is exempt.
    • ReasonTaxExemptCodedOther - is used to provide a non-standard ReasonTaxExemptCode. This element is mandatory if the value of ReasonTaxExemptCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • TaxPercent - holds the default tax percent for the tax identified.
    • TaxPaymentMethodCoded - indicates the default method by which the tax will be paid.
    • TaxPaymentMethodCodedOther - is used to provide a non-standard TaxPaymentMethodCode. This element is mandatory if the value of TaxPaymentMethodCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • TaxTreatmentCoded - indicates the tax treatment. This element is mandatory. It indicates how the LineItemSubTotal on an InvoiceDetail is calculated.
    • TaxTreatmentCodedOther - is used to provide a non-standard TaxTreatmentCode. This element is mandatory if the value of TaxTreatmentCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • TaxAmount - can be used in the case where a flat tax or duty applies to a document. This specifies the amount of that flat tax or duty. This should not be used, unless the tax or duty applies to the entire order. This is implied to be in the default currency of the document.
    • TaxAmountInTaxAccountingCurrency - holds the tax amount in the tax accounting currency.
    • TaxLocation - holds the location for which the tax applies.

[^]Code Fragment

    <xsd:complexType name="TaxReferenceType">
    <xsd:sequence>
        <xsd:element name="TaxTypeCoded" type="TaxTypeCodeType">
        <xsd:element minOccurs="0" name="TaxTypeCodedOther" type="IdentifierType">
        <xsd:element name="TaxFunctionQualifierCoded" type="TaxFunctionQualifierCodeType">
        <xsd:element minOccurs="0" name="TaxFunctionQualifierCodedOther" type="xsd:string">
        <xsd:element name="TaxCategoryCoded" type="TaxCategoryCodeType">
        <xsd:element minOccurs="0" name="TaxCategoryCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="ReasonTaxExemptCoded" type="ReasonTaxExemptCodeType">
        <xsd:element minOccurs="0" name="ReasonTaxExemptCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="TaxPercent" type="PercentType">
        <xsd:element minOccurs="0" name="TaxPaymentMethodCoded" type="TaxPaymentMethodCodeType">
        <xsd:element minOccurs="0" name="TaxPaymentMethodCodedOther" type="xsd:string">
        <xsd:element name="TaxTreatmentCoded" type="TaxTreatmentCodeType">
        <xsd:element minOccurs="0" name="TaxTreatmentCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="TaxAmount" type="Decimal21_6Type">
        <xsd:element minOccurs="0" name="TaxAmountInTaxAccountingCurrency" type="Decimal21_6Type">
        <xsd:element minOccurs="0" name="TaxLocation" type="LocationType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: TaxSummaryType

TaxSummaryType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( TaxTypeCoded[TaxTypeCodeType] , TaxTypeCodedOther[IdentifierType]? , TaxFunctionQualifierCoded[TaxFunctionQualifierCodeType] , TaxFunctionQualifierCodedOther[xsd:string]? , TaxCategoryCoded[TaxCategoryCodeType] , TaxCategoryCodedOther[xsd:string]? , TaxableAmount[Decimal21_6Type]? , TaxableAmountInTaxAccountingCurrency[Decimal21_6Type]? , TaxAmount[Decimal21_6Type] , TaxAmountInTaxAccountingCurrency[Decimal21_6Type]? )

    Description: TaxSummaryType is used to specify tax information.

    Elements:

    • TaxTypeCoded - identifies the type of the tax.
    • TaxTypeCodedOther - is used to provide a non-standard TaxTypeCode. This element is mandatory if the value of TaxTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • TaxFunctionQualifierCoded - indicates the function of the Tax element, e.g. tax, customs duty.
    • TaxFunctionQualifierCodedOther - is used to provide a non-standard TaxQualifierCode. This element is mandatory if the value of TaxQualifierCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • TaxCategoryCoded - indicates the category of the tax and, by implication, the tax rate that applies. The actual percentage is dependent on the tax jurisdiction.
    • TaxCategoryCodedOther - is used to provide a non-standard TaxCategoryCode. This element is mandatory if the value of TaxCategoryCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • TaxableAmount - holds the taxable amount in the invoice currency.
    • TaxableAmountInTaxAccountingCurrency - holds the taxable amount in the tax accounting currency.
    • TaxAmount - holds the tax amount in the invoice currency.
    • TaxAmountInTaxAccountingCurrency - holds the tax amount in the tax accounting currency.

[^]Code Fragment

    <xsd:complexType name="TaxSummaryType">
    <xsd:sequence>
        <xsd:element name="TaxTypeCoded" type="TaxTypeCodeType">
        <xsd:element minOccurs="0" name="TaxTypeCodedOther" type="IdentifierType">
        <xsd:element name="TaxFunctionQualifierCoded" type="TaxFunctionQualifierCodeType">
        <xsd:element minOccurs="0" name="TaxFunctionQualifierCodedOther" type="xsd:string">
        <xsd:element name="TaxCategoryCoded" type="TaxCategoryCodeType">
        <xsd:element minOccurs="0" name="TaxCategoryCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="TaxableAmount" type="Decimal21_6Type">
        <xsd:element minOccurs="0" name="TaxableAmountInTaxAccountingCurrency" type="Decimal21_6Type">
        <xsd:element name="TaxAmount" type="Decimal21_6Type">
        <xsd:element minOccurs="0" name="TaxAmountInTaxAccountingCurrency" type="Decimal21_6Type">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: TaxTreatmentCodeType

TaxTreatmentCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code indicates the level of tax deduction.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • NoTaxApplies - Tax does not apply to this invoice
    • NetInvoiceLevel - Line item amounts are net amounts, and tax is calculated at invoice level in the Invoice Summary. Tax amounts must not be present on the InvoiceDetail
    • GrossInvoiceLevel - Line item amounts are gross amounts, and tax is calculated at invoice level in the Invoice Summary. Tax amounts must not be present on the InvoiceDetail
    • NetLineLevel - Line item amounts are net amounts, and tax amounts are calculated at the line level
    • GrossLineLevel - Line item amounts are gross amounts, and tax amounts are calculated at the line level

[^]Code Fragment

    <xsd:simpleType name="TaxTreatmentCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="NoTaxApplies">
        <xsd:enumeration value="NetInvoiceLevel">
        <xsd:enumeration value="GrossInvoiceLevel">
        <xsd:enumeration value="NetLineLevel">
        <xsd:enumeration value="GrossLineLevel">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: TaxType

TaxType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( TaxTypeCoded[TaxTypeCodeType] , TaxTypeCodedOther[IdentifierType]? , TaxFunctionQualifierCoded[TaxFunctionQualifierCodeType] , TaxFunctionQualifierCodedOther[xsd:string]? , TaxCategoryCoded[TaxCategoryCodeType] , TaxCategoryCodedOther[xsd:string]? , ReasonTaxExemptCoded[ReasonTaxExemptCodeType]? , ReasonTaxExemptCodedOther[xsd:string]? , TaxPercent[PercentType]? , TaxPaymentMethodCoded[TaxPaymentMethodCodeType]? , TaxPaymentMethodCodedOther[xsd:string]? , TaxableAmount[Decimal21_6Type]? , TaxableAmountInTaxAccountingCurrency[Decimal21_6Type]? , TaxAmount[Decimal21_6Type] , TaxAmountInTaxAccountingCurrency[Decimal21_6Type]? , TaxLocation[LocationType]? )

    Description: TaxType is used to specify tax information.

    Elements:

    • TaxTypeCoded - identifies the type of the tax.
    • TaxTypeCodedOther - is used to provide a non-standard TaxTypeCode. This element is mandatory if the value of TaxTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • TaxFunctionQualifierCoded - indicates the function of the Tax element, e.g. tax, customs duty.
    • TaxFunctionQualifierCodedOther - is used to provide a non-standard TaxQualifierCode. This element is mandatory if the value of TaxQualifierCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • TaxCategoryCoded - indicates the category of the tax and, by implication, the tax rate that applies. The actual percentage is dependent on the tax jurisdiction.
    • TaxCategoryCodedOther - is used to provide a non-standard TaxCategoryCode. This element is mandatory if the value of TaxCategoryCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • ReasonTaxExemptCoded - explains why a TaxCategory is exempt.
    • ReasonTaxExemptCodedOther - is used to provide a non-standard ReasonTaxExemptCode. This element is mandatory if the value of ReasonTaxExemptCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • TaxPercent - holds the tax rate as a percentage.
    • TaxPaymentMethodCoded - indicates the method by which the tax will be paid.
    • TaxPaymentMethodCodedOther - is used to provide a non-standard TaxPaymentMethodCode. This element is mandatory if the value of TaxPaymentMethodCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • TaxableAmount - holds the taxable amount in the invoice currency.
    • TaxableAmountInTaxAccountingCurrency - holds the taxable amount in the tax accounting currency.
    • TaxAmount - holds the tax amount in the invoice currency.
    • TaxAmountInTaxAccountingCurrency - holds the tax amount in the tax accounting currency.
    • TaxLocation - holds the location for which the tax applies.

[^]Code Fragment

    <xsd:complexType name="TaxType">
    <xsd:sequence>
        <xsd:element name="TaxTypeCoded" type="TaxTypeCodeType">
        <xsd:element minOccurs="0" name="TaxTypeCodedOther" type="IdentifierType">
        <xsd:element name="TaxFunctionQualifierCoded" type="TaxFunctionQualifierCodeType">
        <xsd:element minOccurs="0" name="TaxFunctionQualifierCodedOther" type="xsd:string">
        <xsd:element name="TaxCategoryCoded" type="TaxCategoryCodeType">
        <xsd:element minOccurs="0" name="TaxCategoryCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="ReasonTaxExemptCoded" type="ReasonTaxExemptCodeType">
        <xsd:element minOccurs="0" name="ReasonTaxExemptCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="TaxPercent" type="PercentType">
        <xsd:element minOccurs="0" name="TaxPaymentMethodCoded" type="TaxPaymentMethodCodeType">
        <xsd:element minOccurs="0" name="TaxPaymentMethodCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="TaxableAmount" type="Decimal21_6Type">
        <xsd:element minOccurs="0" name="TaxableAmountInTaxAccountingCurrency" type="Decimal21_6Type">
        <xsd:element name="TaxAmount" type="Decimal21_6Type">
        <xsd:element minOccurs="0" name="TaxAmountInTaxAccountingCurrency" type="Decimal21_6Type">
        <xsd:element minOccurs="0" name="TaxLocation" type="LocationType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: TaxTypeCodeType

TaxTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • 911CityTax
    • 911CountyTax
    • 911ExciseTax
    • 911StateTax
    • 911Tax
    • AccommodationsTax
    • AdValoremTax
    • AgriculturalExportRebate - Monetary rebate given to the seller in certain circumstances when agricultural products are exported.
    • Agriculturallevy - Levy imposed on agricultural products where there is a difference between the selling price between trading countries.
    • AlcoholicBeverageTax
    • AlcoholMarkTax
    • AllTaxes
    • Anti-DumpingDuty - Duty applied to goods ruled to have been dumped in an import market at a price lower than that in the exporter's domestic market.
    • Assessment
    • BusinessLicenseFee - Government assessed charge for permit to do business.
    • BusinessPrivilegeTax
    • CarTax
    • CityRentalTax
    • CitySalesTax
    • CityTax
    • CoffeeTax - A tax levied specifically on coffee products.
    • CoinOperatedDeviceTax
    • CommoditySpecificTax - Tax related to a specified commodity, e.g. illuminants, salts.
    • CorporateIncomeTax
    • CountervailingDuty - A duty on imported goods applied for compensate for subsidies granted to those goods in the exporting country.
    • CountyOrParishSalesTax
    • CountyRentalTax
    • CountyTax
    • CustomsDuty - Duties laid down in the Customs tariff, to which goods are liable on entering or leaving the Customs territory (CCC).
    • DefaultLaborTax
    • EmploymentTax
    • EnergyTax - General fee or tax for the use of energy.
    • Enhanced911StateExciseTax
    • EnvironmentalTax - Tax assessed for funding or assuring environmental protection or clean-up.
    • EquipmentTax
    • EstateTax
    • ExciseDuty - Customs or fiscal authorities code to identify a specific or ad valorem levy on a specific commodity, applied either domestically or at time of importation.
    • FederalExciseTax - Tax levied by the federal government on the manufacture of specific items.
    • FederalIncomeTaxWithholding
    • FederalTax
    • FederalValueAddedTaxOnGoods
    • FederalValueAddedTaxOnServices
    • FeeInLieu
    • FICAMedicareTax
    • FICASocialSecurityTax
    • FICATax
    • FranchiseTax
    • Free
    • FuelLUSTTax
    • FuelSpillTax
    • FuelSuperFundTax
    • GamingTax
    • GeneralConstructionTax - General tax for construction.
    • GiftTax
    • GoodsAndServicesTax - Tax levied on the final consumption of goods and services throughout the production and distribution chains.
    • GrossReceiptsTax
    • HandicapTax
    • HazardousWasteTax
    • HighwayUseTax
    • IlluminantsTax - Tax of illuminants.
    • ImportTax - Tax assessed on imports.
    • IndividualIncomeTax
    • IndividualTax
    • InheritanceTax
    • InternationalFuelTaxAgreementTax
    • LaborByTradeTax
    • LeakyUndergroundStorageTankTaxFederal
    • LeakyUndergroundStorageTankTaxState
    • LicenseTax
    • LightDuesPayable - Fee levied on a vessel to pay for port navigation lights.
    • LocalConstructionTax - Local tax for construction.
    • LocalSalesTax - Assessment charges on sale of goods or services by city, borough country or other taxing authorities below state or provincial level.
    • LocalTax
    • LustTax - Tax imposed for clean-up of leaky underground storage tanks.
    • MaterialTax
    • MetropolitanTransitTax
    • MinimumTax
    • MiscellaneousCashDeposit - Duty paid and held on deposit, by Customs, during an investigation period prior to a final decision being made on any aspect related to imported goods (except valuation ) by Customs.
    • MiscellaneousStateTax
    • MonetaryCompensatoryAmount - Levy on Common Agricultural Policy (European Union) goods used to compensate for fluctuating currencies between member states
    • MotorFuelTax
    • MunicipalTax
    • OccupationalTax
    • OtherTaxes - Unspecified, miscellaneous tax charges.
    • PaperConsortiumTax-Italy - Description to be provided.
    • PersonalPropertyTax
    • PetroleumTax
    • PostThresholdTax
    • PreferenceDuty
    • PreThresholdTax
    • ProvisionalcountervailingDutyBond - Countervailing duty paid by posting a bond during an investigation period prior to a formal decision on subsidization by Customs.
    • ProvisionalCountervailingDutyCash - Countervailing duty paid in cash prior to a formal finding of subsidization by Customs.
    • ProvisionalDutyBond - Anti-dumping duty paid by posting a bond during an investigation period prior to a formal decision on dumping by Customs.
    • ProvisionalDutyCash - Anti-dumping duty paid in cash prior to a formal finding of dumping by Customs.
    • PublicHealthAndEducationTax
    • RealPropertyTax
    • SalesAndUseTax
    • SchoolTax
    • SecondaryPercentageTax
    • SeveranceTax
    • ShiftedSocialSecurities - Social securities share of the invoice amount to be paid directly to the social securities collector.
    • ShiftedWageTax - Wage tax share of the invoice amount to be paid directly to the tax collector(s office).
    • SolidWasteTax
    • SpecialConstructionTax - Special tax for construction.
    • StadiumTax
    • StampDuty-ImpostadiBollo - Tax required in Italy, which may be fixed or graduated bank receipts.
    • StateandLocalSalesTax
    • StateAndLocalTax
    • StateAndProvincialTax
    • StateExciseTax
    • StateorProvincialFuelTax
    • StateOrProvincialSalesTax - All applicable sale taxes by authorities at the state or provincial level, below national level.
    • StateorProvincialTaxOnGoods
    • StateorProvincialTaxOnServices
    • StateRentalTax
    • StateTaxonSpecificLabor
    • SuperfundTax
    • SurTax - A tax or duty applied on and in addition to existing duties and taxes.
    • SuspendedDuty - Duty suspended or deferred from payment.
    • TelecommunicationsDeviceForTheDeafServiceExciseTax
    • TelecommunicationsTax
    • ThresholdTax
    • TobaccoTax - A tax levied on tobacco products.
    • TonnageTaxes - Tax levied based on the vessel's net tonnage.
    • Total
    • TourismTax
    • TransitTax
    • TurnOverTax - Tax levied on the total sales/turnover of a corporation.
    • UnemploymentTax
    • UseTax
    • UtilityUsersTax
    • ValuationDeposit - Duty paid and held on deposit, by Customs, during an investigation period prior to a formal decision on valuation of the goods being made.
    • ValueAddedTax - A tax on domestic or imported goods applied to the value added at each stage in the production/distribution cycle
    • WellService
    • WithholdingTax
    • WorkersCompensationTax

[^]Code Fragment

    <xsd:simpleType name="TaxTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="911CityTax">
        <xsd:enumeration value="911CountyTax">
        <xsd:enumeration value="911ExciseTax">
        <xsd:enumeration value="911StateTax">
        <xsd:enumeration value="911Tax">
        <xsd:enumeration value="AccommodationsTax">
        <xsd:enumeration value="AdValoremTax">
        <xsd:enumeration value="AgriculturalExportRebate">
        <xsd:enumeration value="Agriculturallevy">
        <xsd:enumeration value="AlcoholicBeverageTax">
        <xsd:enumeration value="AlcoholMarkTax">
        <xsd:enumeration value="AllTaxes">
        <xsd:enumeration value="Anti-DumpingDuty">
        <xsd:enumeration value="Assessment">
        <xsd:enumeration value="BusinessLicenseFee">
        <xsd:enumeration value="BusinessPrivilegeTax">
        <xsd:enumeration value="CarTax">
        <xsd:enumeration value="CityRentalTax">
        <xsd:enumeration value="CitySalesTax">
        <xsd:enumeration value="CityTax">
        <xsd:enumeration value="CoffeeTax">
        <xsd:enumeration value="CoinOperatedDeviceTax">
        <xsd:enumeration value="CommoditySpecificTax">
        <xsd:enumeration value="CorporateIncomeTax">
        <xsd:enumeration value="CountervailingDuty">
        <xsd:enumeration value="CountyOrParishSalesTax">
        <xsd:enumeration value="CountyRentalTax">
        <xsd:enumeration value="CountyTax">
        <xsd:enumeration value="CustomsDuty">
        <xsd:enumeration value="DefaultLaborTax">
        <xsd:enumeration value="EmploymentTax">
        <xsd:enumeration value="EnergyTax">
        <xsd:enumeration value="Enhanced911StateExciseTax">
        <xsd:enumeration value="EnvironmentalTax">
        <xsd:enumeration value="EquipmentTax">
        <xsd:enumeration value="EstateTax">
        <xsd:enumeration value="ExciseDuty">
        <xsd:enumeration value="FederalExciseTax">
        <xsd:enumeration value="FederalIncomeTaxWithholding">
        <xsd:enumeration value="FederalTax">
        <xsd:enumeration value="FederalValueAddedTaxOnGoods">
        <xsd:enumeration value="FederalValueAddedTaxOnServices">
        <xsd:enumeration value="FeeInLieu">
        <xsd:enumeration value="FICAMedicareTax">
        <xsd:enumeration value="FICASocialSecurityTax">
        <xsd:enumeration value="FICATax">
        <xsd:enumeration value="FranchiseTax">
        <xsd:enumeration value="Free">
        <xsd:enumeration value="FuelLUSTTax">
        <xsd:enumeration value="FuelSpillTax">
        <xsd:enumeration value="FuelSuperFundTax">
        <xsd:enumeration value="GamingTax">
        <xsd:enumeration value="GeneralConstructionTax">
        <xsd:enumeration value="GiftTax">
        <xsd:enumeration value="GoodsAndServicesTax">
        <xsd:enumeration value="GrossReceiptsTax">
        <xsd:enumeration value="HandicapTax">
        <xsd:enumeration value="HazardousWasteTax">
        <xsd:enumeration value="HighwayUseTax">
        <xsd:enumeration value="IlluminantsTax">
        <xsd:enumeration value="ImportTax">
        <xsd:enumeration value="IndividualIncomeTax">
        <xsd:enumeration value="IndividualTax">
        <xsd:enumeration value="InheritanceTax">
        <xsd:enumeration value="InternationalFuelTaxAgreementTax">
        <xsd:enumeration value="LaborByTradeTax">
        <xsd:enumeration value="LeakyUndergroundStorageTankTaxFederal">
        <xsd:enumeration value="LeakyUndergroundStorageTankTaxState">
        <xsd:enumeration value="LicenseTax">
        <xsd:enumeration value="LightDuesPayable">
        <xsd:enumeration value="LocalConstructionTax">
        <xsd:enumeration value="LocalSalesTax">
        <xsd:enumeration value="LocalTax">
        <xsd:enumeration value="LustTax">
        <xsd:enumeration value="MaterialTax">
        <xsd:enumeration value="MetropolitanTransitTax">
        <xsd:enumeration value="MinimumTax">
        <xsd:enumeration value="MiscellaneousCashDeposit">
        <xsd:enumeration value="MiscellaneousStateTax">
        <xsd:enumeration value="MonetaryCompensatoryAmount">
        <xsd:enumeration value="MotorFuelTax">
        <xsd:enumeration value="MunicipalTax">
        <xsd:enumeration value="OccupationalTax">
        <xsd:enumeration value="OtherTaxes">
        <xsd:enumeration value="PaperConsortiumTax-Italy">
        <xsd:enumeration value="PersonalPropertyTax">
        <xsd:enumeration value="PetroleumTax">
        <xsd:enumeration value="PostThresholdTax">
        <xsd:enumeration value="PreferenceDuty">
        <xsd:enumeration value="PreThresholdTax">
        <xsd:enumeration value="ProvisionalcountervailingDutyBond">
        <xsd:enumeration value="ProvisionalCountervailingDutyCash">
        <xsd:enumeration value="ProvisionalDutyBond">
        <xsd:enumeration value="ProvisionalDutyCash">
        <xsd:enumeration value="PublicHealthAndEducationTax">
        <xsd:enumeration value="RealPropertyTax">
        <xsd:enumeration value="SalesAndUseTax">
        <xsd:enumeration value="SchoolTax">
        <xsd:enumeration value="SecondaryPercentageTax">
        <xsd:enumeration value="SeveranceTax">
        <xsd:enumeration value="ShiftedSocialSecurities">
        <xsd:enumeration value="ShiftedWageTax">
        <xsd:enumeration value="SolidWasteTax">
        <xsd:enumeration value="SpecialConstructionTax">
        <xsd:enumeration value="StadiumTax">
        <xsd:enumeration value="StampDuty-ImpostadiBollo">
        <xsd:enumeration value="StateandLocalSalesTax">
        <xsd:enumeration value="StateAndLocalTax">
        <xsd:enumeration value="StateAndProvincialTax">
        <xsd:enumeration value="StateExciseTax">
        <xsd:enumeration value="StateorProvincialFuelTax">
        <xsd:enumeration value="StateOrProvincialSalesTax">
        <xsd:enumeration value="StateorProvincialTaxOnGoods">
        <xsd:enumeration value="StateorProvincialTaxOnServices">
        <xsd:enumeration value="StateRentalTax">
        <xsd:enumeration value="StateTaxonSpecificLabor">
        <xsd:enumeration value="SuperfundTax">
        <xsd:enumeration value="SurTax">
        <xsd:enumeration value="SuspendedDuty">
        <xsd:enumeration value="TelecommunicationsDeviceForTheDeafServiceExciseTax">
        <xsd:enumeration value="TelecommunicationsTax">
        <xsd:enumeration value="ThresholdTax">
        <xsd:enumeration value="TobaccoTax">
        <xsd:enumeration value="TonnageTaxes">
        <xsd:enumeration value="Total">
        <xsd:enumeration value="TourismTax">
        <xsd:enumeration value="TransitTax">
        <xsd:enumeration value="TurnOverTax">
        <xsd:enumeration value="UnemploymentTax">
        <xsd:enumeration value="UseTax">
        <xsd:enumeration value="UtilityUsersTax">
        <xsd:enumeration value="ValuationDeposit">
        <xsd:enumeration value="ValueAddedTax">
        <xsd:enumeration value="WellService">
        <xsd:enumeration value="WithholdingTax">
        <xsd:enumeration value="WorkersCompensationTax">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: TermsOfDeliveryFunctionCodeType

TermsOfDeliveryFunctionCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code indicates what terms the delivery is based on. This code list is derived from EDIFACT 4055 (Delivery or transport terms function code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom code
    • PriceCondition - Specifies a price related condition which a seller must fulfill before the buyer will complete a purchase.
    • DespatchCondition - Condition requested by the customer under which the supplier shall deliver: Extent of freight costs, means of transport.
    • PriceandDespatchCondition - Specifies a price and despatch related condition that the seller must complete before the customer will agree payment.
    • CollectedByCustomer - Indicates that the customer will pick up the goods at the supplier. He will take care of the means of transport.
    • TransportCondition - Specifies the conditions under which the transport takes place under the responsibility of the carrier.
    • DeliveryCondition - Specifies the conditions under which the goods must be delivered to the consignee.

[^]Code Fragment

    <xsd:simpleType name="TermsOfDeliveryFunctionCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="PriceCondition">
        <xsd:enumeration value="DespatchCondition">
        <xsd:enumeration value="PriceandDespatchCondition">
        <xsd:enumeration value="CollectedByCustomer">
        <xsd:enumeration value="TransportCondition">
        <xsd:enumeration value="DeliveryCondition">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: TermsOfDeliveryType

TermsOfDeliveryType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( TermsOfDeliveryFunctionCoded[TermsOfDeliveryFunctionCodeType] , TermsOfDeliveryFunctionCodedOther[xsd:string]? , TransportTermsCoded[TransportTermsCodeType]? , TransportTermsCodedOther[xsd:string]? , ShipmentMethodOfPaymentCoded[ShipmentMethodOfPaymentCodeType] , ShipmentMethodOfPaymentCodedOther[xsd:string]? , Location[LocationType]? , TermsOfDeliveryDescription[xsd:string]? , TransportDescription[xsd:string]? , RiskOfLossCoded[RiskOfLossCodeType]? , RiskOfLossCodedOther[xsd:string]? , RiskOfLossDescription[xsd:string]? )

    Description: TermsOfDeliveryType includes the information related to delivery including shipment method of payment and transport.

    Elements:

    • TermsOfDeliveryFunctionCoded - indicates whether the terms relate to e.g. price conditions, delivery conditions, transport conditions, or a combination of these.
    • TermsOfDeliveryFunctionCodedOther - is used to provide a non-standard TermsOfDeliveryFunctionCode. This element is mandatory if the value of TermsOfDeliveryFunctionCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • TransportTermsCoded - is the terms of delivery or transport.
    • TransportTermsCodedOther - is used to provide a non-standard TransportTermsCode. This element is mandatory if the value of TransportTermsCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • ShipmentMethodOfPaymentCoded - is the method of payment for shipping charges, etc. Coded list.
    • ShipmentMethodOfPaymentCodedOther - is used to provide a non-standard ShipmentMethodOfPaymentCode. This element is mandatory if the value of ShipmentMethodOfPaymentCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • Location - is the location relevant to the terms of delivery specified.
    • TermsOfDeliveryDescription - is the text description on special conditions or notes on the delivery.
    • TransportDescription - is a description of transport.
    • RiskOfLossCoded - qualifies the risk of loss.
    • RiskOfLossCodedOther - is used to provide a non-standard RiskOfLossCode. This element is mandatory if the value of RiskOfLossCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • RiskOfLossDescription - is a text description of the risk of loss information.

[^]Code Fragment

    <xsd:complexType name="TermsOfDeliveryType">
    <xsd:sequence>
        <xsd:element name="TermsOfDeliveryFunctionCoded" type="TermsOfDeliveryFunctionCodeType">
        <xsd:element minOccurs="0" name="TermsOfDeliveryFunctionCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="TransportTermsCoded" type="TransportTermsCodeType">
        <xsd:element minOccurs="0" name="TransportTermsCodedOther" type="xsd:string">
        <xsd:element name="ShipmentMethodOfPaymentCoded" type="ShipmentMethodOfPaymentCodeType">
        <xsd:element minOccurs="0" name="ShipmentMethodOfPaymentCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="Location" type="LocationType">
        <xsd:element minOccurs="0" name="TermsOfDeliveryDescription" type="xsd:string">
        <xsd:element minOccurs="0" name="TransportDescription" type="xsd:string">
        <xsd:element minOccurs="0" name="RiskOfLossCoded" type="RiskOfLossCodeType">
        <xsd:element minOccurs="0" name="RiskOfLossCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="RiskOfLossDescription" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: TextTypeCodeType

TextTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Other
    • Deadlines - Deadlines
    • Warranties - Warranties
    • PenaltyForBreachOfContract - Penalty For Breach Of Contract
    • Guarantees - Guarantees
    • ContractRiders - Contract Riders
    • Asset - Asset
    • OtherContractualStipulations - Other Contractual Stipulations
    • InfoRecordPOText - Info Record PO Text
    • MaterialPOText - Material PO Text

[^]Code Fragment

    <xsd:simpleType name="TextTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Deadlines">
        <xsd:enumeration value="Warranties">
        <xsd:enumeration value="PenaltyForBreachOfContract">
        <xsd:enumeration value="Guarantees">
        <xsd:enumeration value="ContractRiders">
        <xsd:enumeration value="Asset">
        <xsd:enumeration value="OtherContractualStipulations">
        <xsd:enumeration value="InfoRecordPOText">
        <xsd:enumeration value="MaterialPOText">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: TimeDueType

TimeDueType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( TimeDue[MeasurementType] , DateTimeRefCoded[DateTimeRefCodeType] , DateTimeRefCodedOther[xsd:string]? )

    Description: TimeDueType is used to express the time a payment is due in a structured manner.

    Elements:

    • TimeDue - expresses the amount of time, from a given date that a payment is due.
    • DateTimeRefCoded - is a coded list used to express the starting point, from which the payment is due, given the TimeDue.
    • DateTimeRefCodedOther - is used to provide a non-standard DateTimeRefCode. This element is mandatory if the value of DateTimeRefCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="TimeDueType">
    <xsd:sequence>
        <xsd:element name="TimeDue" type="MeasurementType">
        <xsd:element name="DateTimeRefCoded" type="DateTimeRefCodeType">
        <xsd:element minOccurs="0" name="DateTimeRefCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: TimezoneCodeType

TimezoneCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the actual time zone for a location.

    Content: Restriction of base type xsd:string

    Enumerated List:

    • Other - Custom Code
    • 12.00 - 12.00
    • 11.45 - 11.45
    • 11.30 - 11.30
    • 11.15 - 11.15
    • 11.00 - 11.00
    • 10.45 - 10.45
    • 10.30 - 10.30
    • 10.15 - 10.15
    • 10.00 - 10.00
    • 09.45 - 09.45
    • 09.30 - 09.30
    • 09.15 - 09.15
    • 09.00 - 09.00
    • 08.45 - 08.45
    • 08.30 - 08.30
    • 08.15 - 08.15
    • 08.00 - 08.00
    • 07.45 - 07.45
    • 07.30 - 07.30
    • 07.15 - 07.15
    • 07.00 - 07.00
    • 06.45 - 06.45
    • 06.30 - 06.30
    • 06.15 - 06.15
    • 06.00 - 06.00
    • 05.45 - 05.45
    • 05.30 - 05.30
    • 05.15 - 05.15
    • 05.00 - 05.00
    • 04.45 - 04.45
    • 04.30 - 04.30
    • 04.15 - 04.15
    • 04.00 - 04.00
    • 03.45 - 03.45
    • 03.30 - 03.30
    • 03.15 - 03.15
    • 03.00 - 03.00
    • 02.45 - 02.45
    • 02.30 - 02.30
    • 02.15 - 02.15
    • 02.00 - 02.00
    • 01.45 - 01.45
    • 01.30 - 01.30
    • 01.15 - 01.15
    • 01.00 - 01.00
    • 00.45 - 00.45
    • 00.30 - 00.30
    • 00.15 - 00.15
    • 00.00 - 00.00
    • -00.15 - -00.15
    • -00.30 - -00.30
    • -00.45 - -00.45
    • -01.00 - -01.00
    • -01.15 - -01.15
    • -01.30 - -01.30
    • -01.45 - -01.45
    • -02.00 - -02.00
    • -02.15 - -02.15
    • -02.30 - -02.30
    • -02.45 - -02.45
    • -03.00 - -03.00
    • -03.15 - -03.15
    • -03.30 - -03.30
    • -03.45 - -03.45
    • -04.00 - -04.00
    • -04.15 - -04.15
    • -04.30 - -04.30
    • -04.45 - -04.45
    • -05.00 - -05.00
    • -05.15 - -05.15
    • -05.30 - -05.30
    • -05.45 - -05.45
    • -06.00 - -06.00
    • -06.15 - -06.15
    • -06.30 - -06.30
    • -06.45 - -06.45
    • -07.00 - -07.00
    • -07.15 - -07.15
    • -07.30 - -07.30
    • -07.45 - -07.45
    • -08.00 - -08.00
    • -08.15 - -08.15
    • -08.30 - -08.30
    • -08.45 - -08.45
    • -09.00 - -09.00
    • -09.15 - -09.15
    • -09.30 - -09.30
    • -09.45 - -09.45
    • -10.00 - -10.00
    • -10.15 - -10.15
    • -10.30 - -10.30
    • -10.45 - -10.45
    • -11.00 - -11.00
    • -11.15 - -11.15
    • -11.30 - -11.30
    • -11.45 - -11.45
    • -12.00 - -12.00

[^]Code Fragment

    <xsd:simpleType name="TimezoneCodeType">
    <xsd:restriction base="xsd:string">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="12.00">
        <xsd:enumeration value="11.45">
        <xsd:enumeration value="11.30">
        <xsd:enumeration value="11.15">
        <xsd:enumeration value="11.00">
        <xsd:enumeration value="10.45">
        <xsd:enumeration value="10.30">
        <xsd:enumeration value="10.15">
        <xsd:enumeration value="10.00">
        <xsd:enumeration value="09.45">
        <xsd:enumeration value="09.30">
        <xsd:enumeration value="09.15">
        <xsd:enumeration value="09.00">
        <xsd:enumeration value="08.45">
        <xsd:enumeration value="08.30">
        <xsd:enumeration value="08.15">
        <xsd:enumeration value="08.00">
        <xsd:enumeration value="07.45">
        <xsd:enumeration value="07.30">
        <xsd:enumeration value="07.15">
        <xsd:enumeration value="07.00">
        <xsd:enumeration value="06.45">
        <xsd:enumeration value="06.30">
        <xsd:enumeration value="06.15">
        <xsd:enumeration value="06.00">
        <xsd:enumeration value="05.45">
        <xsd:enumeration value="05.30">
        <xsd:enumeration value="05.15">
        <xsd:enumeration value="05.00">
        <xsd:enumeration value="04.45">
        <xsd:enumeration value="04.30">
        <xsd:enumeration value="04.15">
        <xsd:enumeration value="04.00">
        <xsd:enumeration value="03.45">
        <xsd:enumeration value="03.30">
        <xsd:enumeration value="03.15">
        <xsd:enumeration value="03.00">
        <xsd:enumeration value="02.45">
        <xsd:enumeration value="02.30">
        <xsd:enumeration value="02.15">
        <xsd:enumeration value="02.00">
        <xsd:enumeration value="01.45">
        <xsd:enumeration value="01.30">
        <xsd:enumeration value="01.15">
        <xsd:enumeration value="01.00">
        <xsd:enumeration value="00.45">
        <xsd:enumeration value="00.30">
        <xsd:enumeration value="00.15">
        <xsd:enumeration value="00.00">
        <xsd:enumeration value="-00.15">
        <xsd:enumeration value="-00.30">
        <xsd:enumeration value="-00.45">
        <xsd:enumeration value="-01.00">
        <xsd:enumeration value="-01.15">
        <xsd:enumeration value="-01.30">
        <xsd:enumeration value="-01.45">
        <xsd:enumeration value="-02.00">
        <xsd:enumeration value="-02.15">
        <xsd:enumeration value="-02.30">
        <xsd:enumeration value="-02.45">
        <xsd:enumeration value="-03.00">
        <xsd:enumeration value="-03.15">
        <xsd:enumeration value="-03.30">
        <xsd:enumeration value="-03.45">
        <xsd:enumeration value="-04.00">
        <xsd:enumeration value="-04.15">
        <xsd:enumeration value="-04.30">
        <xsd:enumeration value="-04.45">
        <xsd:enumeration value="-05.00">
        <xsd:enumeration value="-05.15">
        <xsd:enumeration value="-05.30">
        <xsd:enumeration value="-05.45">
        <xsd:enumeration value="-06.00">
        <xsd:enumeration value="-06.15">
        <xsd:enumeration value="-06.30">
        <xsd:enumeration value="-06.45">
        <xsd:enumeration value="-07.00">
        <xsd:enumeration value="-07.15">
        <xsd:enumeration value="-07.30">
        <xsd:enumeration value="-07.45">
        <xsd:enumeration value="-08.00">
        <xsd:enumeration value="-08.15">
        <xsd:enumeration value="-08.30">
        <xsd:enumeration value="-08.45">
        <xsd:enumeration value="-09.00">
        <xsd:enumeration value="-09.15">
        <xsd:enumeration value="-09.30">
        <xsd:enumeration value="-09.45">
        <xsd:enumeration value="-10.00">
        <xsd:enumeration value="-10.15">
        <xsd:enumeration value="-10.30">
        <xsd:enumeration value="-10.45">
        <xsd:enumeration value="-11.00">
        <xsd:enumeration value="-11.15">
        <xsd:enumeration value="-11.30">
        <xsd:enumeration value="-11.45">
        <xsd:enumeration value="-12.00">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: TimezoneType

TimezoneType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( TimezoneCoded[TimezoneCodeType] , TimezoneCodedOther[xsd:string]? )

    Description: TimezoneType identifies the time zone.

    Elements:

    • TimezoneCoded - specifies the value of the timezone. This is an offset from Greenwich Mean Time.
    • TimezoneCodedOther - is used to provide a non-standard TimezoneCode. This element is mandatory if the value of TimezoneCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="TimezoneType">
    <xsd:sequence>
        <xsd:element name="TimezoneCoded" type="TimezoneCodeType">
        <xsd:element minOccurs="0" name="TimezoneCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: TitleCodeType

TitleCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the title of the user.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • Mr
    • Mrs
    • Miss
    • Ms

[^]Code Fragment

    <xsd:simpleType name="TitleCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Mr">
        <xsd:enumeration value="Mrs">
        <xsd:enumeration value="Miss">
        <xsd:enumeration value="Ms">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: TitleType

TitleType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( TitleCoded[TitleCodeType] , TitleCodedOther[xsd:string]? )

    Description: TitleType contains the title of the user related to gender and marital status.

    Elements:

    • TitleCoded - contains the individual's title.
    • TitleCodedOther - is used to provide a non-standard TitleCode. This element is mandatory if the value of TitleCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="TitleType">
    <xsd:sequence>
        <xsd:element name="TitleCoded" type="TitleCodeType">
        <xsd:element minOccurs="0" name="TitleCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: TotalAllowOrChargeType

TotalAllowOrChargeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( AllowOrChargeIndicatorCoded[AllowOrChargeIndicatorCodeType] , AllowOrChargeIndicatorCodedOther[xsd:string]? , AllowanceOrChargeDescription[AllowOrChgDescType] , SummaryAllowOrCharge[MonetaryValueType] )

    Description: TotalAllowOrChargeType contain the details of the summerized totals of the allowance or charge categorized by the AllowOrChargeDesc.

    Elements:

    • AllowOrChargeIndicatorCoded - identifies whether the allowance or charge applies.
    • AllowOrChargeIndicatorCodedOther - is used to provide a non-standard AllowanceOrChargeIndicatorCode. This element is mandatory if the value of AllowanceOrChargeIndicatorCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • AllowanceOrChargeDescription - describes the allowance or charge using references or free text.
    • SummaryAllowOrCharge - contains the summarized totals of the allowance or charge.

[^]Code Fragment

    <xsd:complexType name="TotalAllowOrChargeType">
    <xsd:sequence>
        <xsd:element name="AllowOrChargeIndicatorCoded" type="AllowOrChargeIndicatorCodeType">
        <xsd:element minOccurs="0" name="AllowOrChargeIndicatorCodedOther" type="xsd:string">
        <xsd:element name="AllowanceOrChargeDescription" type="AllowOrChgDescType">
        <xsd:element name="SummaryAllowOrCharge" type="MonetaryValueType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: TransitDirectionCodeType

TransitDirectionCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the transit direction for a shipment. This code list is derived from EDIFACT 8101 (Transit direction indicator code) and X12 731 (Transit direction code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • BuyerToSeller
    • SellerToBuyer
    • SubcontractorToSeller
    • SellerToDropShipDesignatedLocation
    • SellerToFreightForwarder
    • SellerToSubcontractor
    • MotherVesselToLighter - Cargo is transferred from the main carriage or mother vessel to a lighter.
    • LighterToMotherVessel - Cargo is transferred from the lighter vessel to a main carriage or mother vessel.

[^]Code Fragment

    <xsd:simpleType name="TransitDirectionCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="BuyerToSeller">
        <xsd:enumeration value="SellerToBuyer">
        <xsd:enumeration value="SubcontractorToSeller">
        <xsd:enumeration value="SellerToDropShipDesignatedLocation">
        <xsd:enumeration value="SellerToFreightForwarder">
        <xsd:enumeration value="SellerToSubcontractor">
        <xsd:enumeration value="MotherVesselToLighter">
        <xsd:enumeration value="LighterToMotherVessel">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: TransitDirectionType

TransitDirectionType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( TransitDirectionCoded[TransitDirectionCodeType] , TransitDirectionCodedOther[xsd:string]? , TransitTimeQualifierCoded[TransitTimeQualifierCodeType]? , TransitTimeQualifierCodedOther[xsd:string]? , TransitTime[xsd:decimal]? )

    Description: TransitDirectionType details the direction of the transport.

    Elements:

    • TransitDirectionCoded - outlines the transit direction for the shipment.
    • TransitDirectionCodedOther - is used to provide a non-standard TransitDirectionCode. This element is mandatory if the value of TransitDirectionCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • TransitTimeQualifierCoded - specifies the value of time used to measure the transit time.
    • TransitTimeQualifierCodedOther - is used to provide a non-standard TransitTimeQualifierCode. This element is mandatory if the value of TransitTimeQualifierCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • TransitTime - is the numeric amount of transit time.

[^]Code Fragment

    <xsd:complexType name="TransitDirectionType">
    <xsd:sequence>
        <xsd:element name="TransitDirectionCoded" type="TransitDirectionCodeType">
        <xsd:element minOccurs="0" name="TransitDirectionCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="TransitTimeQualifierCoded" type="TransitTimeQualifierCodeType">
        <xsd:element minOccurs="0" name="TransitTimeQualifierCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="TransitTime" type="xsd:decimal">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: TransitTimeQualifierCodeType

TransitTimeQualifierCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code indicates the unit of time used to measure the transit time. This code list is derived from X12 732 (Transit time direction qualifier)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • AirHours - AirHours
    • AirDays - Air Days
    • CalendarDays - Calendar Days (Includes weekends and Holidays)
    • CalendarWeeks - Calendar Weeks (7 Day)
    • Hours - Hours
    • SurfaceDays - Surface Days
    • SurfaceHours - Surface Hours
    • WorkingDays - Working Days (Excludes weekends and holidays)
    • 5DayWorkWeek - 5 Day Work Week

[^]Code Fragment

    <xsd:simpleType name="TransitTimeQualifierCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="AirHours">
        <xsd:enumeration value="AirDays">
        <xsd:enumeration value="CalendarDays">
        <xsd:enumeration value="CalendarWeeks">
        <xsd:enumeration value="Hours">
        <xsd:enumeration value="SurfaceDays">
        <xsd:enumeration value="SurfaceHours">
        <xsd:enumeration value="WorkingDays">
        <xsd:enumeration value="5DayWorkWeek">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: TransportEquipmentType

TransportEquipmentType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( EquipmentProviderCoded[EquipmentProviderCodeType]? , EquipmentProviderCodedOther[xsd:string]? , EquipmentOwnerCoded[EquipmentOwnerCodeType]? , EquipmentOwnerCodedOther[xsd:string]? , EquipmentID[xsd:string] , EquipmentSizeTypeCoded[EquipmentSizeTypeCodeType]? , EquipementSizeTypeCodedOther[xsd:string]? , EquipmentStatusCoded[EquipmentStatusCodeType]? , EquipmentStatusCodedOther[xsd:string]? , FullIndicatorCoded[FullIndicatorCodeType]? , FullIndicatorCodedOther[xsd:string]? , Conditions[ConditionsType]? , EquipmentNote[xsd:string]? , ListOfSealInfo[ListOfSealInfoType]? , ListOfEquipmentMeasurements[ListOfDimensionType]? )

    Description: TransportEquipmentType identifies the vessel/vehicle or package serving as the equipment for this leg of transport.

    Elements:

    • EquipmentProviderCoded - identifies the provider of the transport equipment.
    • EquipmentProviderCodedOther - is used to provide a non-standard EquipmentProviderCode. This element is mandatory if the value of EquipmentProviderCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • EquipmentOwnerCoded - lists the code indicating the relationship of equipment to carrier or ownership of equipment.
    • EquipmentOwnerCodedOther - is used to provide a non-standard EquipmentOwnerCode. This element is mandatory if the value of EquipmentOwnerCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • EquipmentID - holds the identification number for the equipment for the purposes of referencing within the document domain.
    • EquipmentSizeTypeCoded - lists the size and type codes for the equipment.
    • EquipementSizeTypeCodedOther -
    • EquipmentStatusCoded - describes the status of the equipment.
    • EquipmentStatusCodedOther - is used to provide a non-standard EquipmentStatusCode. This element is mandatory if the value of EquipmentStatusCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • FullIndicatorCoded - describes the fill status of the equipment.
    • FullIndicatorCodedOther - is used to provide a non-standard FullIndicatorCode. This element is mandatory if the value of FullIndicatorCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • Conditions - describes the special conditions regarding the equipment.
    • EquipmentNote - holds free text information for the equipment
    • ListOfSealInfo - provides the information regarding the seals affixed to the equipment.
    • ListOfEquipmentMeasurements - lists measurement information on the piece of equipment.

[^]Code Fragment

    <xsd:complexType name="TransportEquipmentType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="EquipmentProviderCoded" type="EquipmentProviderCodeType">
        <xsd:element minOccurs="0" name="EquipmentProviderCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="EquipmentOwnerCoded" type="EquipmentOwnerCodeType">
        <xsd:element minOccurs="0" name="EquipmentOwnerCodedOther" type="xsd:string">
        <xsd:element name="EquipmentID" type="xsd:string">
        <xsd:element minOccurs="0" name="EquipmentSizeTypeCoded" type="EquipmentSizeTypeCodeType">
        <xsd:element minOccurs="0" name="EquipementSizeTypeCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="EquipmentStatusCoded" type="EquipmentStatusCodeType">
        <xsd:element minOccurs="0" name="EquipmentStatusCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="FullIndicatorCoded" type="FullIndicatorCodeType">
        <xsd:element minOccurs="0" name="FullIndicatorCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="Conditions" type="ConditionsType">
        <xsd:element minOccurs="0" name="EquipmentNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfSealInfo" type="ListOfSealInfoType">
        <xsd:element minOccurs="0" name="ListOfEquipmentMeasurements" type="ListOfDimensionType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: TransportLegCodeType

TransportLegCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code indicates the stages of the transportation. This code list is derived from EDIFACT 8051 (Transport Stage Code Qualifier) and X12 133 (Routing Sequence code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • InlandTransport - Transport by which goods are moved from or to the frontier, or between inland points.
    • AtTheStatisticalTerritoryLimit - Point by which the means of transport are presumed to have left the statistical territory of despatch or to have entered the statistical territory of arrival.
    • Pre-CarriageTransport - Transport by which the goods are moved prior to their main carriage transport.
    • AtBorder - Transport by which goods are moved to the Customs frontier.
    • AtDeparture - Transport by which goods are moved from the place of departure.
    • AtDestination - Transport by which goods are moved at the place of destination.
    • MainCarriage-FourthCarrier - The fourth carrier of the ordered transport.
    • MainCarriage-FifthCarrier - The fifth carrier of the ordered transport.
    • MainCarriage-SixthCarrier - The sixth carrier of the ordered transport.
    • MainCarriage-SeventhCarrier - The seventh carrier of the ordered transport.
    • MainCarriage-EighthCarrier - The eighth carrier of the ordered transport.
    • Main-CarriageTransport - The primary stage in the movement of cargo from the point of origin to the intended destination.
    • MainCarriage-FirstCarrier - The first carrier of the ordered transport when more than one carrier is involved.
    • MaiCarriage-SecondCarrier - The second carrier of the ordered transport when more than one carrier is involved.
    • MainCarriage-ThirdCarrier - The third carrier of the ordered transport when more than one carrier is involved.
    • InlandWaterwayTransport - Transport by which goods are moved via an inland body of water.
    • DeliveryCarrierAllTransport - Carrier responsible from the point of origin to the final delivery destination.
    • SecondPre-CarriageTransport - Second transport by which the goods are moved prior to their main carriage transport.
    • Pre-AcceptanceTransport - The transport by which the goods are moved to the place of acceptance.
    • SecondOn-CarriageTransport - Second transport by which the goods are moved after the main carriage transport.
    • MainCarriage-NinthCarrier - The ninth carrier of the ordered transport.
    • On-CarriageTransport - Transport by which the goods are moved after the main carriage transport.
    • MainCarriage-TenthCarrier - The tenth carrier of the ordered transport.
    • MainCarriage-EleventhCarrier - The eleventh carrier of the ordered transport.
    • MainCarriage-TwelfthCarrier - The twelfth carrier of the ordered transport.
    • 1stCarrierAfterOriginCarrier - 1st Carrier after Origin CarrierX12 Value = 1
    • 2ndCarrierAfterOriginCarrier - 2nd Carrier after Origin CarrierX12 Value = 2
    • 3rdCarrierAfterOriginCarrier - 3rd Carrier after Origin CarrierX12 Value = 3
    • 4thCarrierAfterOriginCarrier - 4th Carrier after Origin CarrierX12 Value = 4
    • 5thCarrierAfterOriginCarrier - 5th Carrier after Origin CarrierX12 Value = 5
    • 6thCarrierAfterOriginCarrier - 6th Carrier after Origin CarrierX12 Value = 6
    • 7thCarrierAfterOriginCarrier - 7th Carrier after Origin CarrierX12 Value = 7
    • 8thCarrierAfterOriginCarrier - 8th Carrier after Origin CarrierX12 Value = 8
    • 9thCarrierAfterOriginCarrier - 9th Carrier after Origin CarrierX12 Value = 9
    • AgentsRoutingOriginCarrier - Origin Carrier, Agent's Routing (Rail)X12 Value = A
    • OriginDeliveryCarrier - Origin/Delivery Carrier (Any Mode)X12 Value = B
    • DELY - DELY (Delivery Switch Carrier)X12 Value = D
    • HaulageRightsCarrierAndJunction - Haulage Rights Carrier and JunctionX12 Value = H
    • OriginSwitchCarrier - Origin Switch CarrierX12 Value = I
    • HaulageMovementCarrierAndJunction - Haulage Movement Carrier and JunctionX12 Value = M
    • OriginCarrierAirMotorOrOcean - Origin Carrier (Air, Motor, or Ocean)X12 Value = O
    • OriginCarrierRule11Shipment - Origin Carrier, Rule 11 ShipmentX12 Value = R
    • ShippersRoutingOriginCarrier - Origin Carrier, Shipper's Routing (Rail)X12 Value = S
    • IntermediateSwitchCarrier - Intermediate Switch CarrierX12 Value = V
    • LastCarrierInRouteOnReturnRouteMove - Last Carrier in Route on Return Route MoveX12 Value = X
    • JunctionSettlementCarrierFollowing - Junction Settlement Carrier Following (Destination carrier receiving revenues resulting from junction contract)X12 Value = JD
    • JunctionSettlementCarrierPredecessor - Junction Settlement Carrier Predecessor (Origin carrier receiving revenues resulting from junction contract)X12 Value = JO

[^]Code Fragment

    <xsd:simpleType name="TransportLegCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="InlandTransport">
        <xsd:enumeration value="AtTheStatisticalTerritoryLimit">
        <xsd:enumeration value="Pre-CarriageTransport">
        <xsd:enumeration value="AtBorder">
        <xsd:enumeration value="AtDeparture">
        <xsd:enumeration value="AtDestination">
        <xsd:enumeration value="MainCarriage-FourthCarrier">
        <xsd:enumeration value="MainCarriage-FifthCarrier">
        <xsd:enumeration value="MainCarriage-SixthCarrier">
        <xsd:enumeration value="MainCarriage-SeventhCarrier">
        <xsd:enumeration value="MainCarriage-EighthCarrier">
        <xsd:enumeration value="Main-CarriageTransport">
        <xsd:enumeration value="MainCarriage-FirstCarrier">
        <xsd:enumeration value="MaiCarriage-SecondCarrier">
        <xsd:enumeration value="MainCarriage-ThirdCarrier">
        <xsd:enumeration value="InlandWaterwayTransport">
        <xsd:enumeration value="DeliveryCarrierAllTransport">
        <xsd:enumeration value="SecondPre-CarriageTransport">
        <xsd:enumeration value="Pre-AcceptanceTransport">
        <xsd:enumeration value="SecondOn-CarriageTransport">
        <xsd:enumeration value="MainCarriage-NinthCarrier">
        <xsd:enumeration value="On-CarriageTransport">
        <xsd:enumeration value="MainCarriage-TenthCarrier">
        <xsd:enumeration value="MainCarriage-EleventhCarrier">
        <xsd:enumeration value="MainCarriage-TwelfthCarrier">
        <xsd:enumeration value="1stCarrierAfterOriginCarrier">
        <xsd:enumeration value="2ndCarrierAfterOriginCarrier">
        <xsd:enumeration value="3rdCarrierAfterOriginCarrier">
        <xsd:enumeration value="4thCarrierAfterOriginCarrier">
        <xsd:enumeration value="5thCarrierAfterOriginCarrier">
        <xsd:enumeration value="6thCarrierAfterOriginCarrier">
        <xsd:enumeration value="7thCarrierAfterOriginCarrier">
        <xsd:enumeration value="8thCarrierAfterOriginCarrier">
        <xsd:enumeration value="9thCarrierAfterOriginCarrier">
        <xsd:enumeration value="AgentsRoutingOriginCarrier">
        <xsd:enumeration value="OriginDeliveryCarrier">
        <xsd:enumeration value="DELY">
        <xsd:enumeration value="HaulageRightsCarrierAndJunction">
        <xsd:enumeration value="OriginSwitchCarrier">
        <xsd:enumeration value="HaulageMovementCarrierAndJunction">
        <xsd:enumeration value="OriginCarrierAirMotorOrOcean">
        <xsd:enumeration value="OriginCarrierRule11Shipment">
        <xsd:enumeration value="ShippersRoutingOriginCarrier">
        <xsd:enumeration value="IntermediateSwitchCarrier">
        <xsd:enumeration value="LastCarrierInRouteOnReturnRouteMove">
        <xsd:enumeration value="JunctionSettlementCarrierFollowing">
        <xsd:enumeration value="JunctionSettlementCarrierPredecessor">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: TransportLocationListType

TransportLocationListType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( StartTransportLocation[TransportLocationType] , InterimTransportLocation[TransportLocationType]* , EndTransportLocation[TransportLocationType] )

    Description: TransportLocationListType lists the locations through which the transportation goes.

    Elements:

    • StartTransportLocation - identifies the location where the transport routing starts.
    • InterimTransportLocation - identifies all locations along the route between the start and end locations.
    • EndTransportLocation - identifies the end transport location information.

[^]Code Fragment

    <xsd:complexType name="TransportLocationListType">
    <xsd:sequence>
        <xsd:element name="StartTransportLocation" type="TransportLocationType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="InterimTransportLocation" type="TransportLocationType">
        <xsd:element name="EndTransportLocation" type="TransportLocationType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: TransportLocationType

TransportLocationType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( Location[LocationType] , LocationID[xsd:int] , Sequence[xsd:int]? , EstimatedArrivalDate[xsd:dateTime]? , ActualArrivalDate[xsd:dateTime]? , EstimatedDepartureDate[xsd:dateTime]? , ActualDepartureDate[xsd:dateTime]? )

    Description: TransportLocationType provides information about a stop along a transport route.

    Elements:

    • Location - identifies a specific location of the stop either by an identifier or by an explicit address.
    • LocationID - holds the unique number referenced internally from line item package and detail.
    • Sequence - holds the counter that indicates the sequence of stops within the transport routing. Start transport location always has a sequence of one.
    • EstimatedArrivalDate - identifies the estimated date that the transport arrives at the location.
    • ActualArrivalDate - identifies the actual date that the transport arrives at the location.
    • EstimatedDepartureDate - identifies the estimated date that the transport departs from the location .
    • ActualDepartureDate - identifies the actual date that the transport departs from the location.

[^]Code Fragment

    <xsd:complexType name="TransportLocationType">
    <xsd:sequence>
        <xsd:element name="Location" type="LocationType">
        <xsd:element name="LocationID" type="xsd:int">
        <xsd:element minOccurs="0" name="Sequence" type="xsd:int">
        <xsd:element minOccurs="0" name="EstimatedArrivalDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ActualArrivalDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="EstimatedDepartureDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ActualDepartureDate" type="xsd:dateTime">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: TransportMeansCodeType

TransportMeansCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the means of transportation. This codelist is derived from EDIFACT 8179(Transport Means Description Code) and X12 40 (Equipment Description Code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • 20FtILContainer-ClosedTop
    • 20FtILContainer-OpenTop
    • 40FtILContainer-OpenTop
    • 40FtILContainer-ClosedTop
    • Aircraft - A machine capable of flight.
    • AirFreight-BreakBulk
    • AirRideVan
    • Barge - A category of boat used to transport material over water.
    • BargeChemicalTanker - A barge equipped to transport liquid chemicals.
    • BargeOpen
    • BilevelRailcarFullyEnclosed
    • BilevelRailcarFullyOpen
    • BilevelRailcarScreened-NoRoof
    • BilevelRailcarScreened-WithRoof
    • Bogie
    • Boxcar
    • BoxcarCushionUnderFrameOF
    • Boxcar-DamageFreeEquipped
    • Boxcar-Insulated
    • Boxcar-InteriorBulkheads
    • Bulktruck - A truck suitable for transporting bulk goods.
    • BulkTruckAndBulkTrailer - A combined truck and a trailer both capable of carrying liquids or bulk goods.
    • BulkTruckAndExtendableGondolaTrailer - A combined truck capable of carrying liquids or bulk goods and a extendable gondola trailer. An extendable gondola trailer is a trailer fitted with a rear axle which can be extended to cater for variable length and is suitable for the transport of heavy machinery.
    • BulkTruckAndExtendableTrailer - A combined truck capable of carrying liquids or bulk goods and an extendable trailer.
    • BulkTruckAndGondolaTrailer - A combined truck capable of carrying liquids or bulk goods and a gondola trailer. A gondola trailer is a split level trailer suitable for the transport of heavy machinery.
    • BulkTruckAndTankTrailer - A combined truck capable of carrying liquids or bulk goods and a tank trailer.
    • BulkTruckAndTrailerWithOpeningFloor - A combined truck capable of carrying liquids or bulk goods and a trailer with opening floor.
    • Bus - To specify that the means of transportation is a bus.
    • Caboose
    • Car - Car.
    • CarCarrier - Vessel for carrying complete cars and/or their knock-down parts.
    • CargoAndPassengerVessel - Vessel for carrying cargo and passengers.
    • CarWithCaravan - A caravan towed by a car.
    • CementVessel - Vessel for carrying cement in bulk.
    • Chassis
    • Chassis-Gooseneck
    • ClosedContainer
    • ClosedContainer-ControlledTemperature
    • ClosedVan
    • CoalVessel - Vessel for carrying coal.
    • CoasterChemicalTanker - A coaster vessel equipped to transport liquid chemicals.
    • Coil-CarCovered
    • CoilCarOpen
    • Container
    • Container-Aluminum
    • Container-Bulk
    • Container-ClosedTop-LengthUnspecified
    • Container-HeatedOrInsulatedOrVentilated
    • Container-HighSideOpenTop
    • Container-Insulated
    • Container-InsulatedOrVentilated
    • Container-LowSideOpenTop
    • ContainerOnlyVessel - Vessel for carrying containers only.
    • Container-Open-Sided
    • Container-OpenTop-LengthUnspecified
    • Container-Platform
    • ContainerrestingonaChassis
    • ContainerShip - Vessel capable of carrying containers and other cargo.
    • Container-Steel
    • Container-Tank
    • Container-TankChemicals
    • Container-TankFoodGrade-Liquid
    • Container-TankGas
    • Container-Upgraded
    • Container-Vented
    • ContainerwithBagHangers
    • ContainerwithFloorSecuringRings
    • ContainerwithFlushDoors
    • ContainerwithHangarBars
    • ContainerWithSmoothSides
    • ContainerWithWavyOrRippleSides
    • ControlledTemperatureTrailer
    • ControlUnit
    • CoveredBarge
    • CrudeOilTanker - Vessel for carrying crude oil.
    • CustomerDeterminedDeansOfTransport - The type of means of transport is to be determined by the customer.
    • CustomerRailTanker - A customer-owned rail wagon equipped to transport liquids.
    • Cut-InHelper
    • DeepSeaChemicalTanker - An ocean-going vessel equipped to transport liquid chemicals
    • Double-DropTrailer
    • DropBackTrailer
    • DryBulkCarrier
    • EndofTrainDevice
    • ExceptionalTransport - Transport for which common characteristics are not applicable (e.g. big transformers requiring special wagons, special tackles, special routing etc.).
    • Ferry - A means of transport for carrying passengers and/or vehicles on a regular basis.
    • FishingVessel - Vessel used in the catching of fish.
    • Fixed-RackDoubleDropTrailer
    • FixedRack-FlatBedTrailer
    • FixedRack-SingleDropTrailer
    • FlatbedSlidingTandem
    • FlatBedTrailer
    • FlatBedTrailer-RemovableSides
    • FlatBedTrailerwithHeadboards
    • FlatBedTrailerwithNoHeadboards
    • FlatCar
    • FlatCar-EndBulkheads
    • FlatcarWithPedestal
    • FreezerTruck - A truck equipped to maintain freezing temperatures.
    • FreezerTruckAndIsothermicTrailer - A combined freezer truck and isothermic trailer.
    • FreezerTruckAndRefrigeratedTrailer - A combined freezer truck and refrigerated trailer.
    • FreezerTruckAndTrailer - A combined truck and trailer equipped to maintain freezing temperatures.
    • FreezerVan - A small rigid covered vehicle for conveying frozen goods.
    • FrozenFoodTrailer
    • FurnitureTruck - A truck used explicitly for the conveyance of furniture.
    • GasTanker - A vessel equipped to transport gas.
    • GeneralCargoVessel - Vessel for carrying general cargo.
    • GeneratorSet
    • GondolaCar-CoveredInteriorBulkheads
    • GondolaCar-Open
    • GondolaCovered
    • Graincarrier - Vessel for carrying grain.
    • GravelVessel - Vessel for carrying gravel.
    • HalfHeightFlatRack
    • Head-EndHelperUnit
    • HeadofTrainDevice
    • HighCubeVan
    • HopperCar-Covered
    • HopperCar-CoveredPneumaticDischarge
    • HopperCar-Open
    • HydrantCart - Vehicle used at large airports with installed distribution systems to make into-plane deliveries of fuel; distinguished from other types of fuelling vehicles.
    • IdlerCar
    • IsothermicTruck - A truck equipped to maintain controlled temperatures.
    • IsothermicTruckAndFreezerTrailer - heavy machinery.
    • IsothermicTruckAndIsothermicTrailer - A truck and a trailer equipped to maintain controlled temperatures.
    • Isothermictruckandrefrigeratedtrailer - A combined isothermic truck and refrigerated trailer.
    • IsothermicVan - A small rigid covered vehicle for conveying temperature controlled goods.
    • LiquefiedNaturalGasCarrier - Vessel for carrying Liquefied Natural Gas (LNG).
    • LiquefiedPetroleumGasCarrier - Vessel for carrying Liquefied Petroleum Gas (LPG).
    • LoadOrUnloadDeviceOnEquipment
    • Locomotive
    • OceanVessel - An ocean-going vessel that is not a ship.
    • OilProductsTanker - A vessel for carrying products derived from crude oil.
    • Open-TopOrFlatBedTrailer
    • OpenTopVan
    • OreCarrier - Vessel for carrying ore in bulk.
    • PassengerVessel - Vessel for carrying passengers.
    • PatrolVessel - A vessel to patrol port or coastal area.
    • Pick-UpTruck
    • Pipeline - A line of pipes for conveying water, gas, oil, etc.
    • PowerPack
    • ProtectedTrailer
    • RailBulkCar - A rail wagon equipped to transport bulk cargo.
    • RailCar
    • RailExpress - Description to be provided.
    • RailroadMaintenanceOfWayCar
    • RailSiloTanker
    • RailTanker - A rail wagon equipped to transport liquids.
    • Rear-EndHelperUnit
    • RefrigeratedCar
    • RefrigeratedContainer
    • RefrigeratedTruck - A truck equipped to maintain refrigerated temperatures.
    • RefrigeratedTruckAndFreezerTrailer - A combined refrigerated truck and freezer trailer.
    • RefrigeratedTruckAndIsothermicTrailer - A combined refrigerated truck and isothermic trailer.
    • RefrigeratedTruckAndTrailer - A combined truck and trailer equipped to maintain refrigerated temperatures.
    • RefrigeratedVan - A small rigid covered vehicle for conveying refrigerated goods.
    • RemovableSideTrailer
    • RemovalTruckAndTrailer - A combined truck and trailer capable of carrying household effects.
    • RigidTruckWithTank - A rigid truck fitted with a tank capable of carrying liquids or bulk goods.
    • RigidTruckWithTankAndBulkTrailer - A combined rigid truck with tank and a trailer capable of carrying liquids or bulk goods.
    • RigidTruckWithTankAndTankTrailer - A combined rigid truck with tank and tank trailer.
    • RoadRailer - Used for shipments that travel by multimodal rail or highway trailer (roadrailer).
    • RoadSiloTanker - Description to be provided.
    • RoadTanker - An over-the-road tank trucker or trailer.
    • RollOn-RollOffVessel - A vessel capable of carrying roll on - roll off cargo.
    • Saddle
    • SellerDeterminedMeansOfTransport - The type of means of transport is to be determined by the seller.
    • ServiceCar
    • Ship - A large vessel navigating deep water.
    • ShipTanker - A large vessel equipped to transport liquids.
    • Single-DropTrailer
    • StackCar
    • STAK-RAK
    • SteelProductsVessel - Vessel for carrying steel products.
    • TankCar
    • Tautliner25TonneWith90CubicMeterTrailer - A truck with non-ridged sides, 25 tonne capacity combined with a 90 cubic meter trailer with removable roof
    • TautlinerTruck - A truck with non-ridged sides.
    • TautlinerTruckAndExtendableGondolaTrailer - A combined tautliner truck and extendable gondola trailer. An extendable gondola trailer is a trailer fitted with a rear axle which can be extended to cater for variable length and is suitable for the transport of
    • TautlinerTruckAndExtendableTrailer - A combined tautliner truck and extendable trailer.
    • TautlinerTruckAndGondolaTrailer - A combined tautliner truck and gondola trailer. A gondola trailer is a split level trailer suitable for the transport of heavy machinery.
    • TautlinerTruckAndRemovalTrailer - A combined tautliner truck and trailer capable of carrying household effects.
    • TautlinerTruckAndTrailerWithOpeningFloor - A combined tautliner truck and trailer with opening floor.
    • TautlinerTruckWithRemovableRoof - A truck with non-ridged sides and removable roof.
    • TautlinerTruckWithRemovableRoofAndExtendableGondolaTrailer - A combined tautliner truck with removable roof and extendable gondola trailer. An extendable gondola trailer is a trailer fitted with a rear axle which can be extended to cater for variable length and is suitable for the transport of heavy machinery.
    • TautlinerTruckWithRemovableRoofAndExtendableTrailer - A combined tautliner truck with removable roof and extendable trailer.
    • TautlinerTruckWithRemovableRoofAndGondolaTrailer - A combined tautliner truck with removable roof and gondola trailer. A gondola trailer is a split level trailer suitable for the transport of heavy machinery.
    • TautlinerTruckWithRemovableRoofAndRemovalTrailer - A combined tautliner truck with a removable roof and a trailer capable of carrying household effects.
    • TautlinerTruckWithRemovableRoofandTrailerWithOpeningFloor - A combined tautliner truck with removable roof and trailer with opening floor.
    • Taxi - A means of transport identification code indicating a taxi.
    • TelescopingTrailer
    • TimberOrLogCarrier - Vessel for carrying timber or logs.
    • Tip-UpArticulatedTruck - An articulated truck capable of tipping up in order to deliver its load.
    • Tip-Uptruck - A truck capable of tipping up in order to deliver its load.
    • Tip-UpTruckAndExtendableGondolaTrailer - A combined tip-up truck with extendable gondola trailer. An extendable gondola trailer is a trailer fitted with a rear axle which can be extended to cater for variable length and is suitable for the transport of heavy machinery.
    • Tip-UpTruckAndGondolaTrailer - A combined tip-up truck and gondola trailer. A gondola trailer is a split level trailer suitable for the transport of heavy machinery.
    • Tip-UpTruckAndTrailerWithOpeningFloor - A combined tip-up truck and trailer with opening floor.
    • Tractor
    • Trailer-Boat
    • Trailer-Car
    • Trailer-DryFreight
    • Trailer-ElectricHeat
    • Trailer-HeatedOrInsulatedOrVentilated
    • Trailer-Insulated
    • Trailer-InsulatedOrVentilated
    • Trailer-NotOtherwiseSpecified
    • Trailer-Pneumatic
    • Trailer-Refrigerated
    • Trailer-Tank-Chemicals
    • Trailer-Tank-FoodGradeLiquid
    • Trailer-Tank-Gas
    • TrainingVessel - A vessel for learning maritime skills.
    • TrainWith20OrMoreWagons - A train with 20 or more wagons used to carry goods.
    • TrainWithMoreThanOneAndLessThan20Wagons - A train with more than one and less than 20 wagons used to carry goods.
    • TrainWithOneWagon - A train with a single wagon used to carry goods.
    • TrilevelRailcar20Feet
    • TrilevelRailcarScreened-FullyEnclosed
    • TrilevelRailcarScreened-NoRoof
    • TrilevelRailcarScreened-WithDoorsNoRoof
    • TrilevelRailcarScreened-WithRoof
    • Truck - An automotive vehicle for hauling goods.
    • TruckAndTrailerWithOpeningFloor - A combined truck and a trailer with an opening floor.
    • Truck-OpenTop
    • Truck-OpenTopHighSide
    • Truck-OpenTopLowSide
    • TruckOrTrailerWithTilt - A truck and trailer combination with a tilting capability.
    • Truck-Van
    • TruckWithOpeningFloor - A truck with an opening floor mechanism which is used to discharge the cargo.
    • TruckWithOpeningFloorAndExtendableGondolaTrailer - A combined truck with opening floor and extendable gondola trailer. An extendable gondola trailer is a trailer fitted with a rear axle which can be extended to cater for variable length and is suitable for the transport of heavy machinery.
    • TruckWithOpeningFloorAndExtendableTrailer - A combined truck with opening floor and extendable trailer.
    • TruckWithOpeningFloorAndGondolaTrailer - A combined truck with opening floor and gondola trailer. A gondola trailer is a split level trailer suitable for the transport of heavy machinery.
    • TugandOrPushboat - A vessel to push and/or pull other vessels.
    • UnitLoadDevice
    • Van
    • Van-SpecialInsideLengthWidthOrHeightRequirements
    • Vessel-Lake
    • Vessel-Ocean
    • Vessel-Ocean-Containership
    • Vessel-Ocean-Lash
    • Vessel-Ocean-RollOn-RollOff
    • Woodchipcarrier - Vessel for carrying wood chips.
    • WorkVessel - A vessel engaged in "port and harbour work", which means construction, improvement, maintenance or rehabilitation of port and harbour facilities. Dredger, floating crane, sand carrier with grab bucket are included in this type of the means of transport.

[^]Code Fragment

    <xsd:simpleType name="TransportMeansCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="20FtILContainer-ClosedTop">
        <xsd:enumeration value="20FtILContainer-OpenTop">
        <xsd:enumeration value="40FtILContainer-OpenTop">
        <xsd:enumeration value="40FtILContainer-ClosedTop">
        <xsd:enumeration value="Aircraft">
        <xsd:enumeration value="AirFreight-BreakBulk">
        <xsd:enumeration value="AirRideVan">
        <xsd:enumeration value="Barge">
        <xsd:enumeration value="BargeChemicalTanker">
        <xsd:enumeration value="BargeOpen">
        <xsd:enumeration value="BilevelRailcarFullyEnclosed">
        <xsd:enumeration value="BilevelRailcarFullyOpen">
        <xsd:enumeration value="BilevelRailcarScreened-NoRoof">
        <xsd:enumeration value="BilevelRailcarScreened-WithRoof">
        <xsd:enumeration value="Bogie">
        <xsd:enumeration value="Boxcar">
        <xsd:enumeration value="BoxcarCushionUnderFrameOF">
        <xsd:enumeration value="Boxcar-DamageFreeEquipped">
        <xsd:enumeration value="Boxcar-Insulated">
        <xsd:enumeration value="Boxcar-InteriorBulkheads">
        <xsd:enumeration value="Bulktruck">
        <xsd:enumeration value="BulkTruckAndBulkTrailer">
        <xsd:enumeration value="BulkTruckAndExtendableGondolaTrailer">
        <xsd:enumeration value="BulkTruckAndExtendableTrailer">
        <xsd:enumeration value="BulkTruckAndGondolaTrailer">
        <xsd:enumeration value="BulkTruckAndTankTrailer">
        <xsd:enumeration value="BulkTruckAndTrailerWithOpeningFloor">
        <xsd:enumeration value="Bus">
        <xsd:enumeration value="Caboose">
        <xsd:enumeration value="Car">
        <xsd:enumeration value="CarCarrier">
        <xsd:enumeration value="CargoAndPassengerVessel">
        <xsd:enumeration value="CarWithCaravan">
        <xsd:enumeration value="CementVessel">
        <xsd:enumeration value="Chassis">
        <xsd:enumeration value="Chassis-Gooseneck">
        <xsd:enumeration value="ClosedContainer">
        <xsd:enumeration value="ClosedContainer-ControlledTemperature">
        <xsd:enumeration value="ClosedVan">
        <xsd:enumeration value="CoalVessel">
        <xsd:enumeration value="CoasterChemicalTanker">
        <xsd:enumeration value="Coil-CarCovered">
        <xsd:enumeration value="CoilCarOpen">
        <xsd:enumeration value="Container">
        <xsd:enumeration value="Container-Aluminum">
        <xsd:enumeration value="Container-Bulk">
        <xsd:enumeration value="Container-ClosedTop-LengthUnspecified">
        <xsd:enumeration value="Container-HeatedOrInsulatedOrVentilated">
        <xsd:enumeration value="Container-HighSideOpenTop">
        <xsd:enumeration value="Container-Insulated">
        <xsd:enumeration value="Container-InsulatedOrVentilated">
        <xsd:enumeration value="Container-LowSideOpenTop">
        <xsd:enumeration value="ContainerOnlyVessel">
        <xsd:enumeration value="Container-Open-Sided">
        <xsd:enumeration value="Container-OpenTop-LengthUnspecified">
        <xsd:enumeration value="Container-Platform">
        <xsd:enumeration value="ContainerrestingonaChassis">
        <xsd:enumeration value="ContainerShip">
        <xsd:enumeration value="Container-Steel">
        <xsd:enumeration value="Container-Tank">
        <xsd:enumeration value="Container-TankChemicals">
        <xsd:enumeration value="Container-TankFoodGrade-Liquid">
        <xsd:enumeration value="Container-TankGas">
        <xsd:enumeration value="Container-Upgraded">
        <xsd:enumeration value="Container-Vented">
        <xsd:enumeration value="ContainerwithBagHangers">
        <xsd:enumeration value="ContainerwithFloorSecuringRings">
        <xsd:enumeration value="ContainerwithFlushDoors">
        <xsd:enumeration value="ContainerwithHangarBars">
        <xsd:enumeration value="ContainerWithSmoothSides">
        <xsd:enumeration value="ContainerWithWavyOrRippleSides">
        <xsd:enumeration value="ControlledTemperatureTrailer">
        <xsd:enumeration value="ControlUnit">
        <xsd:enumeration value="CoveredBarge">
        <xsd:enumeration value="CrudeOilTanker">
        <xsd:enumeration value="CustomerDeterminedDeansOfTransport">
        <xsd:enumeration value="CustomerRailTanker">
        <xsd:enumeration value="Cut-InHelper">
        <xsd:enumeration value="DeepSeaChemicalTanker">
        <xsd:enumeration value="Double-DropTrailer">
        <xsd:enumeration value="DropBackTrailer">
        <xsd:enumeration value="DryBulkCarrier">
        <xsd:enumeration value="EndofTrainDevice">
        <xsd:enumeration value="ExceptionalTransport">
        <xsd:enumeration value="Ferry">
        <xsd:enumeration value="FishingVessel">
        <xsd:enumeration value="Fixed-RackDoubleDropTrailer">
        <xsd:enumeration value="FixedRack-FlatBedTrailer">
        <xsd:enumeration value="FixedRack-SingleDropTrailer">
        <xsd:enumeration value="FlatbedSlidingTandem">
        <xsd:enumeration value="FlatBedTrailer">
        <xsd:enumeration value="FlatBedTrailer-RemovableSides">
        <xsd:enumeration value="FlatBedTrailerwithHeadboards">
        <xsd:enumeration value="FlatBedTrailerwithNoHeadboards">
        <xsd:enumeration value="FlatCar">
        <xsd:enumeration value="FlatCar-EndBulkheads">
        <xsd:enumeration value="FlatcarWithPedestal">
        <xsd:enumeration value="FreezerTruck">
        <xsd:enumeration value="FreezerTruckAndIsothermicTrailer">
        <xsd:enumeration value="FreezerTruckAndRefrigeratedTrailer">
        <xsd:enumeration value="FreezerTruckAndTrailer">
        <xsd:enumeration value="FreezerVan">
        <xsd:enumeration value="FrozenFoodTrailer">
        <xsd:enumeration value="FurnitureTruck">
        <xsd:enumeration value="GasTanker">
        <xsd:enumeration value="GeneralCargoVessel">
        <xsd:enumeration value="GeneratorSet">
        <xsd:enumeration value="GondolaCar-CoveredInteriorBulkheads">
        <xsd:enumeration value="GondolaCar-Open">
        <xsd:enumeration value="GondolaCovered">
        <xsd:enumeration value="Graincarrier">
        <xsd:enumeration value="GravelVessel">
        <xsd:enumeration value="HalfHeightFlatRack">
        <xsd:enumeration value="Head-EndHelperUnit">
        <xsd:enumeration value="HeadofTrainDevice">
        <xsd:enumeration value="HighCubeVan">
        <xsd:enumeration value="HopperCar-Covered">
        <xsd:enumeration value="HopperCar-CoveredPneumaticDischarge">
        <xsd:enumeration value="HopperCar-Open">
        <xsd:enumeration value="HydrantCart">
        <xsd:enumeration value="IdlerCar">
        <xsd:enumeration value="IsothermicTruck">
        <xsd:enumeration value="IsothermicTruckAndFreezerTrailer">
        <xsd:enumeration value="IsothermicTruckAndIsothermicTrailer">
        <xsd:enumeration value="Isothermictruckandrefrigeratedtrailer">
        <xsd:enumeration value="IsothermicVan">
        <xsd:enumeration value="LiquefiedNaturalGasCarrier">
        <xsd:enumeration value="LiquefiedPetroleumGasCarrier">
        <xsd:enumeration value="LoadOrUnloadDeviceOnEquipment">
        <xsd:enumeration value="Locomotive">
        <xsd:enumeration value="OceanVessel">
        <xsd:enumeration value="OilProductsTanker">
        <xsd:enumeration value="Open-TopOrFlatBedTrailer">
        <xsd:enumeration value="OpenTopVan">
        <xsd:enumeration value="OreCarrier">
        <xsd:enumeration value="PassengerVessel">
        <xsd:enumeration value="PatrolVessel">
        <xsd:enumeration value="Pick-UpTruck">
        <xsd:enumeration value="Pipeline">
        <xsd:enumeration value="PowerPack">
        <xsd:enumeration value="ProtectedTrailer">
        <xsd:enumeration value="RailBulkCar">
        <xsd:enumeration value="RailCar">
        <xsd:enumeration value="RailExpress">
        <xsd:enumeration value="RailroadMaintenanceOfWayCar">
        <xsd:enumeration value="RailSiloTanker">
        <xsd:enumeration value="RailTanker">
        <xsd:enumeration value="Rear-EndHelperUnit">
        <xsd:enumeration value="RefrigeratedCar">
        <xsd:enumeration value="RefrigeratedContainer">
        <xsd:enumeration value="RefrigeratedTruck">
        <xsd:enumeration value="RefrigeratedTruckAndFreezerTrailer">
        <xsd:enumeration value="RefrigeratedTruckAndIsothermicTrailer">
        <xsd:enumeration value="RefrigeratedTruckAndTrailer">
        <xsd:enumeration value="RefrigeratedVan">
        <xsd:enumeration value="RemovableSideTrailer">
        <xsd:enumeration value="RemovalTruckAndTrailer">
        <xsd:enumeration value="RigidTruckWithTank">
        <xsd:enumeration value="RigidTruckWithTankAndBulkTrailer">
        <xsd:enumeration value="RigidTruckWithTankAndTankTrailer">
        <xsd:enumeration value="RoadRailer">
        <xsd:enumeration value="RoadSiloTanker">
        <xsd:enumeration value="RoadTanker">
        <xsd:enumeration value="RollOn-RollOffVessel">
        <xsd:enumeration value="Saddle">
        <xsd:enumeration value="SellerDeterminedMeansOfTransport">
        <xsd:enumeration value="ServiceCar">
        <xsd:enumeration value="Ship">
        <xsd:enumeration value="ShipTanker">
        <xsd:enumeration value="Single-DropTrailer">
        <xsd:enumeration value="StackCar">
        <xsd:enumeration value="STAK-RAK">
        <xsd:enumeration value="SteelProductsVessel">
        <xsd:enumeration value="TankCar">
        <xsd:enumeration value="Tautliner25TonneWith90CubicMeterTrailer">
        <xsd:enumeration value="TautlinerTruck">
        <xsd:enumeration value="TautlinerTruckAndExtendableGondolaTrailer">
        <xsd:enumeration value="TautlinerTruckAndExtendableTrailer">
        <xsd:enumeration value="TautlinerTruckAndGondolaTrailer">
        <xsd:enumeration value="TautlinerTruckAndRemovalTrailer">
        <xsd:enumeration value="TautlinerTruckAndTrailerWithOpeningFloor">
        <xsd:enumeration value="TautlinerTruckWithRemovableRoof">
        <xsd:enumeration value="TautlinerTruckWithRemovableRoofAndExtendableGondolaTrailer">
        <xsd:enumeration value="TautlinerTruckWithRemovableRoofAndExtendableTrailer">
        <xsd:enumeration value="TautlinerTruckWithRemovableRoofAndGondolaTrailer">
        <xsd:enumeration value="TautlinerTruckWithRemovableRoofAndRemovalTrailer">
        <xsd:enumeration value="TautlinerTruckWithRemovableRoofandTrailerWithOpeningFloor">
        <xsd:enumeration value="Taxi">
        <xsd:enumeration value="TelescopingTrailer">
        <xsd:enumeration value="TimberOrLogCarrier">
        <xsd:enumeration value="Tip-UpArticulatedTruck">
        <xsd:enumeration value="Tip-Uptruck">
        <xsd:enumeration value="Tip-UpTruckAndExtendableGondolaTrailer">
        <xsd:enumeration value="Tip-UpTruckAndGondolaTrailer">
        <xsd:enumeration value="Tip-UpTruckAndTrailerWithOpeningFloor">
        <xsd:enumeration value="Tractor">
        <xsd:enumeration value="Trailer-Boat">
        <xsd:enumeration value="Trailer-Car">
        <xsd:enumeration value="Trailer-DryFreight">
        <xsd:enumeration value="Trailer-ElectricHeat">
        <xsd:enumeration value="Trailer-HeatedOrInsulatedOrVentilated">
        <xsd:enumeration value="Trailer-Insulated">
        <xsd:enumeration value="Trailer-InsulatedOrVentilated">
        <xsd:enumeration value="Trailer-NotOtherwiseSpecified">
        <xsd:enumeration value="Trailer-Pneumatic">
        <xsd:enumeration value="Trailer-Refrigerated">
        <xsd:enumeration value="Trailer-Tank-Chemicals">
        <xsd:enumeration value="Trailer-Tank-FoodGradeLiquid">
        <xsd:enumeration value="Trailer-Tank-Gas">
        <xsd:enumeration value="TrainingVessel">
        <xsd:enumeration value="TrainWith20OrMoreWagons">
        <xsd:enumeration value="TrainWithMoreThanOneAndLessThan20Wagons">
        <xsd:enumeration value="TrainWithOneWagon">
        <xsd:enumeration value="TrilevelRailcar20Feet">
        <xsd:enumeration value="TrilevelRailcarScreened-FullyEnclosed">
        <xsd:enumeration value="TrilevelRailcarScreened-NoRoof">
        <xsd:enumeration value="TrilevelRailcarScreened-WithDoorsNoRoof">
        <xsd:enumeration value="TrilevelRailcarScreened-WithRoof">
        <xsd:enumeration value="Truck">
        <xsd:enumeration value="TruckAndTrailerWithOpeningFloor">
        <xsd:enumeration value="Truck-OpenTop">
        <xsd:enumeration value="Truck-OpenTopHighSide">
        <xsd:enumeration value="Truck-OpenTopLowSide">
        <xsd:enumeration value="TruckOrTrailerWithTilt">
        <xsd:enumeration value="Truck-Van">
        <xsd:enumeration value="TruckWithOpeningFloor">
        <xsd:enumeration value="TruckWithOpeningFloorAndExtendableGondolaTrailer">
        <xsd:enumeration value="TruckWithOpeningFloorAndExtendableTrailer">
        <xsd:enumeration value="TruckWithOpeningFloorAndGondolaTrailer">
        <xsd:enumeration value="TugandOrPushboat">
        <xsd:enumeration value="UnitLoadDevice">
        <xsd:enumeration value="Van">
        <xsd:enumeration value="Van-SpecialInsideLengthWidthOrHeightRequirements">
        <xsd:enumeration value="Vessel-Lake">
        <xsd:enumeration value="Vessel-Ocean">
        <xsd:enumeration value="Vessel-Ocean-Containership">
        <xsd:enumeration value="Vessel-Ocean-Lash">
        <xsd:enumeration value="Vessel-Ocean-RollOn-RollOff">
        <xsd:enumeration value="Woodchipcarrier">
        <xsd:enumeration value="WorkVessel">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: TransportMeansType

TransportMeansType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( TransportMeansCoded[TransportMeansCodeType] , TransportMeansCodedOther[xsd:string]? )

    Description: TransportMeansType contains the information on the means of transport for the route.

    Elements:

    • TransportMeansCoded - lists the means of transport for this route.
    • TransportMeansCodedOther - is used to provide a non-standard TransportMeansCode. This element is mandatory if the value of TransportMeansCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="TransportMeansType">
    <xsd:sequence>
        <xsd:element name="TransportMeansCoded" type="TransportMeansCodeType">
        <xsd:element minOccurs="0" name="TransportMeansCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: TransportModeCodeType

TransportModeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the mode of transportation. This code list is derived from EDIFACT Recommendation 19 (Mode of Transport) and X12 91 (Transportation Method/Type Code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • Air
    • AirCharter
    • AirExpress
    • AirFreight
    • AirFrieghtForwarder
    • AirTaxi
    • AirTransport
    • ArmedForcesCourierService
    • Backhaul
    • Barge
    • BestWay-ShippersOption
    • BookPostal
    • Bus
    • CabOrTaxi
    • CommonIrregularCarrier
    • Consolidation
    • ContainerizedOcean
    • ContractCarrier
    • ConventionalOcean
    • CustomerPickup
    • CustomerPickupOrCustomersExpense
    • Driveaway
    • DriveawayService
    • EuropeanOrPacificDistributionSystem
    • ExpeditedTruck
    • FixedTransportInstallation - This code applies to installations for continuous transport such as pipelines, ropeways and electric power lines
    • Flyaway
    • GeographicReceiving
    • GeographicReceivingOrShipping
    • GeographicShipping
    • InlandWaterTransport - This code is used only in such cases where the application of waterborne transport is reported separately with in the framework of a one-digit code
    • InlandWaterway
    • Intermodal-Piggyback
    • LessThanTrailerLoad
    • Logair
    • Mail - (Active mode of transport unknown) This code is provided for practical reasons, despite the fact that mail is not a genuine mode of transport. In many countries, the value of merchandise exported and imported by mail is considerable, but the exporter or importer concerned would be unable to state by which mode postal items had passed the national border.
    • MaritimeTransport - Provision is made for separate reporting of inland water transport under code 8, assuming that appropriate definitions and rules of application will be given, particularly when transport covers sea as well as inland waterways.
    • MilitaryIntratheaterAirliftService
    • MilitaryOfficialMail
    • ModeUnknown - This code can be used when the mode is not known or when information on it is not available at the time of issuing the document concerned
    • Motor
    • Motor-BulkCarrier
    • Motor-CommonCarrier
    • Motor-Flatbed
    • Motor-PackageCarrier
    • Motor-Van
    • MutimodalTransport
    • Ocean
    • OceanConferenceCarrier
    • OceanNon-ConferenceCarrier
    • ParcelPost
    • Pipeline
    • PooledAir
    • PooledPiggyback
    • PooledRail
    • PooledTruck
    • PoolToPool
    • PrivateCarrier
    • PrivateParcelService
    • PrivateVessel
    • Quicktrans
    • Rail
    • RailTransport
    • Roadrailer
    • RoadTransport
    • SeaOrAir
    • ShipperAgent
    • ShipperAgent-Truck
    • ShipperAssociation
    • StackTrain
    • Steamship
    • SupplierTruck
    • TowawayService
    • Vessel
    • WaterOrPipelineIntermodalMovement

[^]Code Fragment

    <xsd:simpleType name="TransportModeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Air">
        <xsd:enumeration value="AirCharter">
        <xsd:enumeration value="AirExpress">
        <xsd:enumeration value="AirFreight">
        <xsd:enumeration value="AirFrieghtForwarder">
        <xsd:enumeration value="AirTaxi">
        <xsd:enumeration value="AirTransport">
        <xsd:enumeration value="ArmedForcesCourierService">
        <xsd:enumeration value="Backhaul">
        <xsd:enumeration value="Barge">
        <xsd:enumeration value="BestWay-ShippersOption">
        <xsd:enumeration value="BookPostal">
        <xsd:enumeration value="Bus">
        <xsd:enumeration value="CabOrTaxi">
        <xsd:enumeration value="CommonIrregularCarrier">
        <xsd:enumeration value="Consolidation">
        <xsd:enumeration value="ContainerizedOcean">
        <xsd:enumeration value="ContractCarrier">
        <xsd:enumeration value="ConventionalOcean">
        <xsd:enumeration value="CustomerPickup">
        <xsd:enumeration value="CustomerPickupOrCustomersExpense">
        <xsd:enumeration value="Driveaway">
        <xsd:enumeration value="DriveawayService">
        <xsd:enumeration value="EuropeanOrPacificDistributionSystem">
        <xsd:enumeration value="ExpeditedTruck">
        <xsd:enumeration value="FixedTransportInstallation">
        <xsd:enumeration value="Flyaway">
        <xsd:enumeration value="GeographicReceiving">
        <xsd:enumeration value="GeographicReceivingOrShipping">
        <xsd:enumeration value="GeographicShipping">
        <xsd:enumeration value="InlandWaterTransport">
        <xsd:enumeration value="InlandWaterway">
        <xsd:enumeration value="Intermodal-Piggyback">
        <xsd:enumeration value="LessThanTrailerLoad">
        <xsd:enumeration value="Logair">
        <xsd:enumeration value="Mail">
        <xsd:enumeration value="MaritimeTransport">
        <xsd:enumeration value="MilitaryIntratheaterAirliftService">
        <xsd:enumeration value="MilitaryOfficialMail">
        <xsd:enumeration value="ModeUnknown">
        <xsd:enumeration value="Motor">
        <xsd:enumeration value="Motor-BulkCarrier">
        <xsd:enumeration value="Motor-CommonCarrier">
        <xsd:enumeration value="Motor-Flatbed">
        <xsd:enumeration value="Motor-PackageCarrier">
        <xsd:enumeration value="Motor-Van">
        <xsd:enumeration value="MutimodalTransport">
        <xsd:enumeration value="Ocean">
        <xsd:enumeration value="OceanConferenceCarrier">
        <xsd:enumeration value="OceanNon-ConferenceCarrier">
        <xsd:enumeration value="ParcelPost">
        <xsd:enumeration value="Pipeline">
        <xsd:enumeration value="PooledAir">
        <xsd:enumeration value="PooledPiggyback">
        <xsd:enumeration value="PooledRail">
        <xsd:enumeration value="PooledTruck">
        <xsd:enumeration value="PoolToPool">
        <xsd:enumeration value="PrivateCarrier">
        <xsd:enumeration value="PrivateParcelService">
        <xsd:enumeration value="PrivateVessel">
        <xsd:enumeration value="Quicktrans">
        <xsd:enumeration value="Rail">
        <xsd:enumeration value="RailTransport">
        <xsd:enumeration value="Roadrailer">
        <xsd:enumeration value="RoadTransport">
        <xsd:enumeration value="SeaOrAir">
        <xsd:enumeration value="ShipperAgent">
        <xsd:enumeration value="ShipperAgent-Truck">
        <xsd:enumeration value="ShipperAssociation">
        <xsd:enumeration value="StackTrain">
        <xsd:enumeration value="Steamship">
        <xsd:enumeration value="SupplierTruck">
        <xsd:enumeration value="TowawayService">
        <xsd:enumeration value="Vessel">
        <xsd:enumeration value="WaterOrPipelineIntermodalMovement">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: TransportModeType

TransportModeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( TransportModeCoded[TransportModeCodeType] , TransportModeCodedOther[xsd:string]? )

    Description: TransportModeType is a container for the TransportModeCode.

    Elements:

    • TransportModeCoded - holds the mode of transportation for this route.
    • TransportModeCodedOther - is used to provide a non-standard TransportModeCode. This element is mandatory if the value of TransportModeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="TransportModeType">
    <xsd:sequence>
        <xsd:element name="TransportModeCoded" type="TransportModeCodeType">
        <xsd:element minOccurs="0" name="TransportModeCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: TransportPackagingTotalsType

TransportPackagingTotalsType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( TotalPackages[xsd:int]? , TotalPackageDepth[xsd:int]? , TotalTransport[xsd:int]? , TotalGrossWeight[MeasurementType]? , TotalNetWeight[MeasurementType]? , TotalNetNetWeight[MeasurementType]? , TotalTareWeight[MeasurementType]? , GrossVolume[MeasurementType]? )

    Description: TransportPackagingTotalsType summarizes the transport and packaging information if included in a document.

    Elements:

    • TotalPackages - is the summation of total packages contained in the document.
    • TotalPackageDepth - describes the nesting level of the package count in the preceding element, if that number counts other than top-level packages.
    • TotalTransport - is the summation of the total top level packages contained in the document, unless otherwise described. Total transport is the number of top-level packages, unless described otherwise in TotalPackageDepth.
    • TotalGrossWeight - is the total gross weight of the shipment.
    • TotalNetWeight - is the total net weight of the shipment.
    • TotalNetNetWeight - is the weight (mass) of the goods themselves without any packing. This is particularly important for the industries like tobacco where tax is calculated on the weight of the cigarettes rather than on the retail item.
    • TotalTareWeight - is the weight of the goods minus the transport equipment.
    • GrossVolume - is the total volume of the shipment

[^]Code Fragment

    <xsd:complexType name="TransportPackagingTotalsType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="TotalPackages" type="xsd:int">
        <xsd:element minOccurs="0" name="TotalPackageDepth" type="xsd:int">
        <xsd:element minOccurs="0" name="TotalTransport" type="xsd:int">
        <xsd:element minOccurs="0" name="TotalGrossWeight" type="MeasurementType">
        <xsd:element minOccurs="0" name="TotalNetWeight" type="MeasurementType">
        <xsd:element minOccurs="0" name="TotalNetNetWeight" type="MeasurementType">
        <xsd:element minOccurs="0" name="TotalTareWeight" type="MeasurementType">
        <xsd:element minOccurs="0" name="GrossVolume" type="MeasurementType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: TransportQuantitiesType

TransportQuantitiesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( LadingQuantity[QuantityType]? , ListOfQuantityCoded[ListOfQuantityCodedType]? )

    Description: TransportQuantitiesType is used to identify quantities relative to the shipment such as lading and hazardous reportable, and radioactive quantities.

    Elements:

    • LadingQuantity - is the quantity of items being transported by the carrier.
    • ListOfQuantityCoded - is used to define other quantities relative to the shipment.

[^]Code Fragment

    <xsd:complexType name="TransportQuantitiesType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="LadingQuantity" type="QuantityType">
        <xsd:element minOccurs="0" name="ListOfQuantityCoded" type="ListOfQuantityCodedType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: TransportRequirementCodeType

TransportRequirementCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies specific transport or vessel requirements. This code list is derived from X12 249 (Vessel requirement code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • SpecifiedFlagRequired
    • MustComply
    • ForwarderOption
    • RollBookingtoAnotherVessel
    • SubstitutionOK

[^]Code Fragment

    <xsd:simpleType name="TransportRequirementCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="SpecifiedFlagRequired">
        <xsd:enumeration value="MustComply">
        <xsd:enumeration value="ForwarderOption">
        <xsd:enumeration value="RollBookingtoAnotherVessel">
        <xsd:enumeration value="SubstitutionOK">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: TransportRoutingType

TransportRoutingType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( TransportRouteID[xsd:int]? , TransportMode[TransportModeType]? , TransportMeans[TransportMeansType]? , TransportMeansIdentifier[IdentifierType]? , TransportMeansReference[IdentifierType]? , TransportRequirementCoded[TransportRequirementCodeType]? , TransportRequirementCodedOther[xsd:string]? , CarrierName[xsd:string]? , CarrierID[IdentifierType]? , TransportQuantities[TransportQuantitiesType]? , CustShippingContractNum[xsd:string]? , ServiceLevel[ServiceLevelType]? , ShippingInstructions[xsd:string]? , TransportLegCoded[TransportLegCodeType]? , TransportLegCodedOther[xsd:string]? , ListOfTransportEquipment[ListOfTransportEquipmentType]? , TransitDirection[TransitDirectionType]? , TransportLocationList[TransportLocationListType]? )

    Description: TransportRoutingType holds the definition of the transport routing. A single TransportRouting is defined by one carrier (that is, one organization operating equipment) moving between two or more locations with a single mode of transport. You may have more than one vehicle acting as part of the transport, but all must use the same route, be of the same mode, and be operated by the same carrier.

    Elements:

    • TransportRouteID - holds a unique identifier for this route of transport to be referenced. Intended to be used as an internal reference for the document.
    • TransportMode - is a container for the TransportModeCode.
    • TransportMeans - contains the information on the means of transport for the route.
    • TransportMeansIdentifier - holds a name or number appearing visibly on the outside of the transport means. Transport mean values include the vehicle registration number, flight number or vessel name.
    • TransportMeansReference - references a means of transport. Typically, this is an identifier assigned by some organization that is not obvious or apparent on the outside of the vessel. Possible transport means reference values include (eg Lloyds number or call sign for maritime vessels).
    • TransportRequirementCoded - is used to specify options for satisfying vessel or transport requirements.
    • TransportRequirementCodedOther - is used to provide a non-standard TransportRequirementCode. This element is mandatory if the value of TransportRequirementCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • CarrierName - is a free form text field used to hold the name of the carrier. For example, Federal Express may be used here.
    • CarrierID - is the ID assigned by an agency to the carrier.
    • TransportQuantities - is used to identify quantities relative to the shipment such as lading and hazardous reportable, and radioactive quantities.
    • CustShippingContractNum - provides a shipping contract number to allow supplier to ship goods under specific freight conditions or the carrier to bill against a specific contract number.
    • ServiceLevel - is used to hold information about the level of service associated with the transportation.
    • ShippingInstructions - holds any notes specific to shipping.
    • TransportLegCoded - lists the stages of the transport.
    • TransportLegCodedOther - is used to provide a non-standard TransportLegCode. This element is mandatory if the value of TransportLegCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • ListOfTransportEquipment - provides details about the equipment used for transportation.
    • TransitDirection - details the direction of transportation.
    • TransportLocationList - lists the locations through which the transportation goes.

[^]Code Fragment

    <xsd:complexType name="TransportRoutingType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="TransportRouteID" type="xsd:int">
        <xsd:element minOccurs="0" name="TransportMode" type="TransportModeType">
        <xsd:element minOccurs="0" name="TransportMeans" type="TransportMeansType">
        <xsd:element minOccurs="0" name="TransportMeansIdentifier" type="IdentifierType">
        <xsd:element minOccurs="0" name="TransportMeansReference" type="IdentifierType">
        <xsd:element minOccurs="0" name="TransportRequirementCoded" type="TransportRequirementCodeType">
        <xsd:element minOccurs="0" name="TransportRequirementCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="CarrierName" type="xsd:string">
        <xsd:element minOccurs="0" name="CarrierID" type="IdentifierType">
        <xsd:element minOccurs="0" name="TransportQuantities" type="TransportQuantitiesType">
        <xsd:element minOccurs="0" name="CustShippingContractNum" type="xsd:string">
        <xsd:element minOccurs="0" name="ServiceLevel" type="ServiceLevelType">
        <xsd:element minOccurs="0" name="ShippingInstructions" type="xsd:string">
        <xsd:element minOccurs="0" name="TransportLegCoded" type="TransportLegCodeType">
        <xsd:element minOccurs="0" name="TransportLegCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfTransportEquipment" type="ListOfTransportEquipmentType">
        <xsd:element minOccurs="0" name="TransitDirection" type="TransitDirectionType">
        <xsd:element minOccurs="0" name="TransportLocationList" type="TransportLocationListType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: TransportTermsCodeType

TransportTermsCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code indicates the terms of delivery. This code list is derived from INCOTERMS 1990

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom code
    • Ex-Works - Title and risk pass to buyer including payment of all transportation and insurance cost from the seller's door. Used for any mode of transportation.
    • Free-Carrier - Title and risk pass to buyer including transportation and insurance cost when the seller delivers goods cleared for export to the carrier.Seller is obligated to load the goods on the Buyer's collecting vehicle; it is the Buyer's obligation to receive the Seller's arriving vehicle unloaded.
    • FreeAlongsideShip - Title and risk pass to buyer including payment of all transportation and insurance cost once delivered alongside ship by the seller. Used for sea or inland waterway transportation. The export clearance obligation rests with the seller.
    • FreeOnBoard - FOB - Free On Board and risk pass to buyer including payment of all transportation and insurance cost once delivered on board the ship by the seller. Used for sea or inland waterway transportation
    • CostAndFreight - CFR - Cost and Freight -- Title, risk and insurance cost pass to buyer when delivered on board the ship by seller who pays the transportation cost to the destination port. Used for sea or inland waterway transportation
    • Cost-InsuranceAndFreight - CIF - Cost, Insurance and Freight -- Title and risk pass to buyer when delivered on board the ship by seller who pays transportation and insurance cost to destination port. Used for sea or inland waterway transportation.
    • CarriagePaidTo - Title, risk and insurance cost pass to buyer when delivered to carrier by seller who pays transportation cost to destination. Used for any mode of transportation.
    • Carriage-InsurancePaidTo - Title and risk pass to buyer when delivered to carrier by seller who pays transportation and insurance cost to destination. Used for any mode of transportation.
    • DeliveredAtFrontier - Title, risk and responsibility for import clearance pass to buyer when delivered to named border point by seller. Used for any mode of transportation.
    • DeliveredEx-Ship - Title, risk, responsibility for vessel discharge and import clearance pass to buyer when seller delivers goods on board the ship to destination port. Used for sea or inland waterway transportation
    • DeliveredEx-Quay - Title and risk pass to buyer when delivered on board the ship at the destination point by the seller who delivers goods on dock at destination point cleared for import. Used for sea or inland waterway transportation. DDU - Delivered Duty Unpaid -- Title, risk and responsibility of import clearance pass to buyer when seller delivers goods to named destination point. Used for any mode of transportation. Buyer is obligated for import clearance.
    • DeliveredDutyUnpaid - Seller fulfills his obligation when goods have been made available at the named place in the country of importation
    • DeliveredDutyPaid - Title and risk pass to buyer when seller delivers goods to named destination point cleared for import. Used for any mode of transportation.

[^]Code Fragment

    <xsd:simpleType name="TransportTermsCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Ex-Works">
        <xsd:enumeration value="Free-Carrier">
        <xsd:enumeration value="FreeAlongsideShip">
        <xsd:enumeration value="FreeOnBoard">
        <xsd:enumeration value="CostAndFreight">
        <xsd:enumeration value="Cost-InsuranceAndFreight">
        <xsd:enumeration value="CarriagePaidTo">
        <xsd:enumeration value="Carriage-InsurancePaidTo">
        <xsd:enumeration value="DeliveredAtFrontier">
        <xsd:enumeration value="DeliveredEx-Ship">
        <xsd:enumeration value="DeliveredEx-Quay">
        <xsd:enumeration value="DeliveredDutyUnpaid">
        <xsd:enumeration value="DeliveredDutyPaid">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: TypeOfAllowanceOrChargeType

TypeOfAllowanceOrChargeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( QuantityAllowanceOrCharge[QuantityAllowanceOrChargeType] | PercentageAllowanceOrCharge[PercentageAllowanceOrChargeType] | MonetaryValue[MonetaryValueType] )

    Description: TypeOfAllowanceOrChargeType is a container for the information on the type of allowance or charge. Only one method of calculating the allowance or charge can be specified.

    Elements:

    • QuantityAllowanceOrCharge - specifies the allowance or charge where the calculation is based on quantity.
    • PercentageAllowanceOrCharge - specifies the allowance or charge based on a percentage.
    • MonetaryValue - is the monetary amount of the allowance or charge when charged as a lump sum.

[^]Code Fragment

    <xsd:complexType name="TypeOfAllowanceOrChargeType">
    <xsd:choice>
        <xsd:element name="QuantityAllowanceOrCharge" type="QuantityAllowanceOrChargeType">
        <xsd:element name="PercentageAllowanceOrCharge" type="PercentageAllowanceOrChargeType">
        <xsd:element name="MonetaryValue" type="MonetaryValueType">
    </xsd:choice>
</xsd:complexType>


complexType definition: UnitOfMeasurementType

UnitOfMeasurementType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( UOMCoded[UOMCodeType] , UOMCodedOther[xsd:string]? )

    Description: UnitOfMeasurementType specifies the units which relate to the measurement or quantity

    Elements:

    • UOMCoded - is used to define the unit of measure.
    • UOMCodedOther - is used to provide a non-standard UOMCode. This element is mandatory if the value of UOMCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="UnitOfMeasurementType">
    <xsd:sequence>
        <xsd:element name="UOMCoded" type="UOMCodeType">
        <xsd:element minOccurs="0" name="UOMCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: UnitPriceType

UnitPriceType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( UnitPriceValue[Decimal21_6Type] , Currency[CurrencyType]? )

    Description: UnitPriceType container element that holds the pricing information for a basic unit of an item.

    Elements:

    • UnitPriceValue - contains the value of the unit price.
    • Currency - contains the currency that UnitPriceValue is expressed in.

[^]Code Fragment

    <xsd:complexType name="UnitPriceType">
    <xsd:sequence>
        <xsd:element name="UnitPriceValue" type="Decimal21_6Type">
        <xsd:element minOccurs="0" name="Currency" type="CurrencyType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: UOMCodeType

UOMCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code identifies the unit of measurement. This code list is derived from UNECE Rec 20 and X12 355 (Unit or Basis for measurement code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • 1 - ActualPounds
    • 4 - SmallSpray
    • 5 - Lift
    • 8 - HeatLot
    • 10 - Group
    • 11 - Outfit
    • 13 - Ration
    • 14 - Shot
    • 15 - Stick
    • 16 - 115KilogramDrum
    • 17 - 100PoundDrum
    • 18 - 55GallonDrum
    • 19 - TankTruck
    • 20 - 20FootContainer
    • 21 - 40FootContainer
    • 22 - DeciliterPerGram
    • 23 - GramsperCubicCentimeter
    • 24 - TheoreticalPound
    • 25 - GramsperSquareCentimeter
    • 26 - ActualTon
    • 27 - TheoreticalTon
    • 28 - KilogramsPerSquareMeter
    • 29 - PoundPerThousandSquareFeet
    • 30 - HorsePowerDayPerAirDryMetricTon
    • 31 - CatchWeight
    • 32 - KilogramPerAirDryMetricTon
    • 33 - KilopascalSquareMetersPerGram
    • 34 - KilopascalsPerMillimeter
    • 35 - MillilitersPerSquareCentimeterSecond
    • 36 - CubicFeetPerMinutePerSquareFoot
    • 37 - OuncePerSquareFoot
    • 38 - OuncesPerSquareFootPer0.01Inch
    • 40 - MilliliterPerSecond
    • 41 - MilliliterPerMinute
    • 43 - SuperBulkBag
    • 44 - 500KilogramBulkBag
    • 45 - 300KilogramBulkBag
    • 46 - FiftyLbBulkBag
    • 47 - 50PoundBag
    • 48 - BulkCarLoad
    • 50 - ActualKilograms
    • 51 - ActualTonnes
    • 53 - TheoreticalKilograms
    • 54 - TheoreticalTonne
    • 56 - Sitas
    • 57 - Mesh
    • 58 - NetKilogram
    • 59 - PartsPerMillion
    • 60 - PercentWeight
    • 61 - PartsPerBillion
    • 62 - PercentPer1000Hours
    • 63 - FailureRateInTime
    • 64 - PoundPerSquareInch-Gauge
    • 66 - Oersted
    • 69 - TestSpecificScale
    • 71 - VoltAmperePerPound
    • 72 - WattPerPound
    • 73 - AmpereTumPerCentimeter
    • 74 - MilliPascals
    • 76 - Gauss
    • 77 - Mil
    • 78 - Kilogauss
    • 80 - PoundsPerSquareInchAbsolute
    • 81 - Henry
    • 84 - KilopoundPerSquareInch
    • 85 - FootPounds
    • 86 - Joules
    • 87 - PoundPerCubicFoot
    • 89 - Poise
    • 90 - SayboldUniversalSecond
    • 91 - Stokes
    • 92 - CaloriePerCubicCentimeter
    • 93 - CaloriePerGram
    • 94 - CurlUnit
    • 95 - TwentyThousandGallon-USTankcar
    • 96 - TenThousandGallon-USTankcar
    • 97 - 10KilogramDrum
    • 98 - 15KilogramDrum
    • 1A - CarMile
    • 1B - CarCount
    • 1C - LocomotiveCount
    • 1D - CabooseCount
    • 1E - EmptyCar
    • 1F - TrainMile
    • 1G - FuelUsage-Gallons
    • 1H - CabooseMile
    • 1I - FixedRate
    • 1J - TonMile
    • 1K - LocomotiveMile
    • 1L - TotalCarCount
    • 1M - TotalCarMile
    • 1X - QuarterMile
    • 2A - RadiansPerSecond
    • 2B - RadianPerSecondSquared
    • 2C - Roentgen
    • 2F - VoltsPerMeter
    • 2G - Volts-AlternatingCurrent
    • 2H - Volts-DirectCurrent
    • 2I - BritishThermalUnitPerHour
    • 2J - CubicCentimetersPerSecond
    • 2K - CubicFeetPerHour
    • 2L - CubicFeetPerMinute
    • 2M - CentimetersPerSecond
    • 2N - Decibel
    • 2P - Kilobyte
    • 2Q - Kilobecquerel
    • 2R - Kilocurie
    • 2U - Megagram
    • 2V - MegagramPerHour
    • 2W - Bin
    • 2X - MetersPerMinute
    • 2Y - Milliroentgen
    • 2Z - Millivolt
    • 3B - Megajoule
    • 3C - Manmonth
    • 3E - PoundPerPoundOfProduct
    • 3F - KilogramsPerLiterOfProduct
    • 3G - PoundPerPieceOfProduct
    • 3H - KilogramsPerKilogramOfProduct
    • 3I - KilogramsPerPieceOfProduct
    • 4A - Bobbin
    • 4B - Cap
    • 4C - Centistokes
    • 4E - 20-Pack
    • 4G - Microliter
    • 4H - Micrometer
    • 4I - MetersPerSecond
    • 4J - MetersPerSecondPerSecond
    • 4K - Milliamperes
    • 4L - Megabyte
    • 4M - MilligramPerHour
    • 4N - Megabecquerel
    • 4O - Microfarad
    • 4P - NewtonsPerMeter
    • 4Q - OunceInch
    • 4R - OunceFoot
    • 4T - Picofarad
    • 4U - PoundPerHour
    • 4W - TonPerHour
    • 4X - KiloliterPerHour
    • 5A - BarrelsPerMinute
    • 5B - Batch
    • 5C - Gallon-US-PerThousand
    • 5E - MmscfPerDay
    • 5F - PoundsPerThousand
    • 5G - Pump
    • 5H - Stage
    • 5I - StandardCubicFoot
    • 5J - HydraulicHorsePower
    • 5K - CountPerMinute
    • 5P - SeismicLevel
    • 5Q - SeismicLine
    • A1 - 15DegreesCCalorie
    • A10 - AmpereSquareMetrePerJouleSecond
    • A11 - Angstrom
    • A12 - AstronomicalUnit
    • A13 - Attojoule
    • A14 - Barn
    • A15 - BarnPerElectronVolt
    • A16 - BarnPerSteradianElectronVolt
    • A17 - BarnPerSterdian
    • A18 - BecquerelPerKilogram
    • A19 - BecquerelPerMetreCubed
    • A2 - AmperePerCentimetre
    • A20 - BritishThermalUnitPerSecondSquareFoot
    • A22 - BritishThermalUnitPerSecondFoot
    • A23 - BritishThermalUnitPerHourSquareFoot
    • A24 - CandelaPerSquareMetre
    • A25 - ChevalVapeur
    • A26 - CoulombMetre
    • A27 - CoulombMetreSquaredPerVolt
    • A28 - CoulombPerCubicCentimetre
    • A29 - CoulombPerCubicMetre
    • A3 - AmperePerMillimetre
    • A30 - CoulombPerCubicMillimetre
    • A31 - CoulombPerKilogramSecond
    • A32 - CoulombPerMole
    • A33 - CoulombPerSquareCentimetre
    • A34 - CoulombPerSquareMetre
    • A35 - CoulombPerSquareMillimetre
    • A36 - CubicCentimetrePerMole
    • A37 - CubicDecimetrePerMole
    • A38 - CubicMetrePerCoulomb
    • A39 - CubicMetrePerKilogram
    • A4 - AmperePerSquareCentimetre
    • A40 - CubicMetrePerMole
    • A41 - AmperePerSquareMetre
    • A42 - CuriePerKilogram
    • A43 - DeadweightTonnage
    • A44 - Decalitre
    • A45 - Decametre
    • A47 - Decitex
    • A48 - DegreeRankin
    • A49 - Denier
    • A5 - AmpereSquareMetre
    • A50 - DynSecondPerCubicCentimetre
    • A51 - DyneSecondPerCentimetre
    • A52 - DyneSecondPerCentimetreToTheFifth
    • A53 - ElectronVolt
    • A54 - ElectronvoltPerMetre
    • A55 - ElectronvoltSquareMetre
    • A56 - ElectronvoltSquareMetrePerKilogram
    • A57 - Erg
    • A58 - ErgPerCentimetre
    • A6 - AmperePerSquareMetreKelvinSquared
    • A60 - ErgPerCubicCentimetre
    • A61 - ErgPerGram
    • A62 - ErgPerGramSecond
    • A63 - ErgPerSecond
    • A64 - ErgPerSecondSquareCentimetre
    • A65 - ErgPerSquareCentimetreSecond
    • A66 - ErgSquareCentimetre
    • A67 - ErgSquareCentimetrePerGram
    • A68 - Exajoule
    • A69 - FaradPerMetre
    • A7 - AmperePerSquareMillimetre
    • A70 - Femtojoule
    • A71 - Femtometre
    • A73 - FootPerSecondSquared
    • A74 - FootPound-ForcePerSecond
    • A75 - FreightTon
    • A76 - Gallon
    • A77 - GaussianCgsUnitOfDisplacement
    • A78 - GaussianCgsUnitOfElecticCurrent
    • A79 - GaussianCgsUnitOfElectricCharge
    • A8 - AmpereSecond
    • A80 - GaussianCgsUnitOfElectricFieldStrength
    • A81 - GaussianCgsUnitOfElectricPolarization
    • A82 - GaussianCgsUnitOfElectricPotential
    • A83 - GaussianCgsUnitOfMagnetization
    • A84 - GigacoulombPerCubicMetre
    • A85 - Gigaelectronvolt
    • A86 - Gigahertz
    • A87 - Gigaohm
    • A88 - GigaohmMetre
    • A89 - Gigapascal
    • A9 - Rate
    • A90 - Gigawatt
    • A91 - Grade
    • A93 - GramPerCubicMetre
    • A94 - GramPerMole
    • A95 - Gray
    • A96 - GrayPerSecond
    • A97 - Hectopascal
    • A98 - HenryPerMetre
    • AA - Ball
    • AB - BulkPack
    • ACR - Acre
    • AD - Byte
    • AE - AmperePerMetre
    • AH - AdditionalMinutes
    • AI - AverageMinutesPerCall
    • AJ - Cop
    • AK - Fathom
    • AL - AccessLine
    • AM - Ampoule
    • AMH - AmpereHour
    • AMP - Ampere
    • AN - MinutesOrMessages
    • ANN - Years
    • AP - AluminiumPoundOnly
    • APZ - TroyOunce
    • AQ - Anti-HemophilicFactorUnits
    • AR - Suppository
    • ARE - Are
    • AS - Assortment
    • ASM - AlcoholicStrengthByMass
    • ASU - AlcoholicStrengthByVolume
    • AT - Atmosphere
    • ATM - StandardAtmosphere
    • ATT - TechnicalAtmosphere
    • AU - OcularInsertSystem
    • AV - Capsule
    • AW - PowderFilledVial
    • AX - Twenty
    • AY - Assembly
    • AZ - BritishThermalUnitPerPound
    • B0 - BritishThermalUnitsPerCubicFoot
    • B1 - BarrelsPerDay
    • B11 - JoulePerKilogramKelvin
    • B12 - JoulePerMetre
    • B13 - JoulePerSquareMetre
    • B14 - JoulePerMetreToTheFourthPower
    • B15 - JoulePerMole
    • B16 - JoulePerMoleKelvin
    • B18 - JouleSecond
    • B2 - Bunk
    • B20 - JouleSquareMetrePerKilogram
    • B21 - KelvinPerWatt
    • B22 - Kiloampere
    • B23 - KiloamperePerSquareMetre
    • B24 - KiloamperePerMetre
    • B25 - KilobecquerelPerKilogram
    • B26 - Kilocoulomb
    • B27 - KilocoulombPerCubicMetre
    • B28 - KilocoulombPerSquareMetre
    • B29 - Kiloelectronvolt
    • B3 - BattingPound
    • B31 - KilogramMetrePerSecond
    • B32 - KilogramMetreSquared
    • B33 - KilogramMetreSquaredPerSecond
    • B34 - KilogramPerCubicDecimetre
    • B35 - KilogramPerLitre
    • B36 - ThermochemicalCaloriePerGram
    • B37 - Kilogram-Force
    • B38 - Kilogram-ForceMetre
    • B39 - Kilogram-ForceMetrePerSecond
    • B4 - Barrel
    • B40 - Kilogram-ForcePerSquareMetre
    • B41 - KilojoulePerKelvin
    • B42 - KilojoulePerKilogram
    • B43 - KilojoulePerKilogramKelvin
    • B44 - KilojoulePerMole
    • B45 - Kilomole
    • B46 - KilomolePerCubicMetre
    • B47 - Kilonewton
    • B48 - KilonewtonMetre
    • B49 - Kiloohm
    • B5 - Billet
    • B50 - KiloohmMetre
    • B51 - Kilopond
    • B52 - Kilosecond
    • B53 - Kilosiemens
    • B54 - KilosiemensPerMetre
    • B55 - KilovoltPerMetre
    • B56 - KiloweberPerMetre
    • B57 - LightYear
    • B58 - LitrePerMole
    • B59 - LumenHour
    • B6 - Bun
    • B60 - LumenPerSquareMetre
    • B61 - LumenPerWatt
    • B62 - LumenSecond
    • B63 - LuxHour
    • B64 - LuxSecond
    • B65 - Maxwell
    • B66 - MegaamperePerSquareMetre
    • B67 - MegabecquerelPerKilogram
    • B69 - MegacoulombPerCubicMetre
    • B7 - Cycle
    • B70 - MegacoulombPerSquareMetre
    • B71 - Megaelectronvolt
    • B72 - MegagramPerCubicMetre
    • B73 - Meganewton
    • B74 - MeganewtonMetre
    • B75 - Megaohm
    • B76 - MegaohmMetre
    • B77 - MegasiemensPerMetre
    • B78 - Megavolt
    • B79 - MegavoltPerMetre
    • B8 - JoulePerCubicMetre
    • B81 - ReciprocalMetreSquaredReciprocalSecond
    • B83 - MetreToTheFourthPower
    • B84 - Microampere
    • B85 - Microbar
    • B86 - Microcoulomb
    • B87 - MicrocoulombPerCubicMetre
    • B88 - MicrocoulombPerSquareMetre
    • B89 - MicrofaradPerMetre
    • B9 - Batt
    • B90 - Microhenry
    • B91 - MicrohenryPerMetre
    • B92 - Micronewton
    • B93 - MicronewtonMetre
    • B94 - Microohm
    • B95 - MicroohmMetre
    • B96 - Micropascal
    • B97 - Microradian
    • B98 - Microsecond
    • B99 - Microsiemens
    • BAR - Bar
    • BB - BaseBox
    • BD - Board
    • BE - Bundle
    • BFT - BoardFoot
    • BG - Bag
    • BH - Brush
    • BHP - BrakeHorsePower
    • BIL - Billion-Eur
    • BJ - Bucket
    • BK - Basket
    • BL - Bale
    • BLD - DryBarrel-US
    • BLL - Barrel-USPetroleumEtc
    • BO - Bottle
    • BP - 100BoardFeet
    • BQL - Becquerel
    • BT - Bolt
    • BTU - BritishThermalUnit
    • BU - Bushel
    • BUA - Bushel-US
    • BUI - Bushel-UK
    • BW - BaseWeight
    • BX - Box
    • BZ - MillionBTUs
    • C0 - Call
    • C1 - CompositeProductPounds-TotalWeight
    • C10 - Millifarad
    • C11 - Milligal
    • C12 - MilligramPerMetre
    • C13 - Milligray
    • C14 - Millihenry
    • C15 - Millijoule
    • C16 - MillimetrePerSecond
    • C17 - MillimetreSquaredPerSecond
    • C18 - Millimole
    • C19 - MolePerKilogram
    • C2 - Carset
    • C20 - Millinewton
    • C22 - MillinewtonPerMetre
    • C23 - MilliohmMetre
    • C24 - MillipascalSecond
    • C25 - Milliradian
    • C26 - Millisecond
    • C27 - Millisiemens
    • C28 - Millisievert
    • C29 - Millitesla
    • C3 - MicrovoltPerMetre
    • C30 - MillivoltPerMetre
    • C31 - Milliwatt
    • C32 - MilliwattPerSquareMetre
    • C33 - Milliweber
    • C34 - Mole
    • C35 - MolePerCubicDecimetre
    • C36 - MolePerCubicMetre
    • C38 - MolePerLitre
    • C39 - Nanoampere
    • C4 - Carload
    • C40 - Nanocoulomb
    • C41 - Nanofarad
    • C42 - NanofaradPerMetre
    • C43 - Nanohenry
    • C44 - NanohenryPerMetre
    • C45 - Nanometre
    • C46 - NanoohmMetre
    • C47 - Nanosecond
    • C48 - Nanotesla
    • C49 - Nanowatt
    • C5 - Cost
    • C50 - Neper
    • C51 - NeperPerSecond
    • C52 - Picometre
    • C53 - NewtonMetreSecond
    • C54 - NewtonMetreSquaredKilogramSquared
    • C55 - NewtonPerSquareMetre
    • C56 - NewtonPerSquareMillimetre
    • C57 - NewtonSecond
    • C58 - NewtonSecondPerMetre
    • C59 - Octave
    • C6 - Cell
    • C60 - OhmCentimetre
    • C61 - OhmMetre
    • C62 - One, Piece, Unit
    • C63 - Parsec
    • C64 - PascalPerKelvin
    • C65 - PascalSecond
    • C66 - PascalSecondPerCubicMetre
    • C67 - PascalSecondPerMetre
    • C68 - Petajoule
    • C69 - Phon
    • C7 - Centipoise
    • C70 - Picoampere
    • C71 - Picocoulomb
    • C72 - PicofaradPerMetre
    • C73 - Picohenry
    • C75 - Picowatt
    • C76 - PicowattPerSquareMetre
    • C77 - PoundGage
    • C78 - Pound-Force
    • C8 - MillicoulombPerKilogram
    • C80 - Rad
    • C81 - Radian
    • C82 - RadianMeterSquaredPerMole
    • C83 - RadianMetreSquaredPerKilogram
    • C84 - RadianPerMetre
    • C85 - ReciprocalAngstrom
    • C86 - ReciprocalCubicMetre
    • C87 - ReciprocalCubicMetrePerSecond
    • C88 - ReciprocalElectronVoltPerCubicMetre
    • C89 - ReciprocalHenry
    • C9 - CoilGroup
    • C90 - ReciprocalJoulePerCubicMetre
    • C91 - ReciprocalKelvinOrKelvinToThePower
    • C92 - ReciprocalMetre
    • C93 - ReciprocalSquareMetre
    • C94 - ReciprocalMinute
    • C95 - ReciprocalMole
    • C96 - ReciprocalPascalOrPascalToThePowerMinusOne
    • C97 - ReciprocalSecond
    • C98 - ReciprocalSecondPerCubicMetre
    • C99 - ReciprocalSecondPerMetreSquared
    • CA - Can
    • CCT - CarryingCapacityInMetricTon
    • CD - Carat
    • CDL - Candela
    • CE - Centigrade
    • CEL - DegreeCelsius
    • CEN - Hundred
    • CG - Card
    • CGM - Centigram
    • CH - Container
    • CJ - Cone
    • CK - Connector
    • CKG - CoulombPerKilogram
    • CL - Coil
    • CLF - HundredLeave
    • CLT - Centiliter
    • CMK - SquareCentimeter
    • CMQ - CubicCentimeter
    • CMT - Centimeter
    • CNP - 100-Pack
    • CNT - Cental-UK
    • CO - Carboy
    • COU - Coulomb
    • CQ - Cartridge
    • CR - Crate
    • CS - Case
    • CT - Carton
    • CTM - MetricCarat
    • CU - Cup
    • CUR - Curie
    • CV - Cover
    • CWA - HundredPounds-CWT/HundredWeight-US
    • CWI - HundredWeight-UK
    • CY - Cylinder
    • CZ - Combo
    • D1 - ReciprocalSecondPerSteradian
    • D10 - SiemensPerMetre
    • D12 - SiemensSquareMetrePerMole
    • D13 - Sievert
    • D14 - ThousandLinearYards
    • D16 - SquareCentimetrePerErg
    • D17 - SquareCentimetrePerSteradianErg
    • D18 - MetreKelvin
    • D19 - SquareMetreKelvinPerWatt
    • D2 - ReciprocalSecondPerSteradianMetreSquared
    • D20 - SquareMetrePerJoule
    • D21 - SquareMetrePerKilogram
    • D22 - SquareMetrePerMole
    • D23 - PenGrams-Protein
    • D24 - SquareMetrePerSteradian
    • D25 - SquareMetrePerSteradianJoule
    • D26 - SquareMetrePerVoltSecond
    • D27 - Steradian
    • D28 - Syphon
    • D29 - Terahertz
    • D30 - Terajoule
    • D31 - Terawatt
    • D33 - Tesla
    • D34 - Tex
    • D35 - ThermochemicalCalorie
    • D37 - ThermochemicalCaloriePerGramKelvin
    • D38 - ThermochemicalCaloriePerSecondCentimetreKelvin
    • D39 - ThermochemicalCaloriePerSecondSquareCentimetreKelvin
    • D40 - ThousandLitre
    • D41 - TonnePerCubicMetre
    • D42 - TropicalYear
    • D43 - UnifiedAtomicMassUnit
    • D44 - Var
    • D45 - VoltSquaredPerKelvinSquared
    • D46 - Volt-Ampere
    • D47 - VoltPerCentimetre
    • D48 - VoltPerKelvin
    • D49 - MillivoltPerKelvin
    • D5 - KilogramPerSquareCentimeter
    • D50 - VoltPerMetre
    • D51 - VoltPerMillimetre
    • D52 - WattPerKelvin
    • D53 - WattPerMetreKelvin
    • D54 - WattPerSquareMetre
    • D55 - WattPerSquareMetreKelvin
    • D56 - WattPerSquareMetreKelvinToTheFourthPower
    • D57 - WattPerSteradian
    • D58 - WattPerSteradianSquareMetre
    • D59 - WeberPerMetre
    • D6 - RontgenPerSecond
    • D60 - WeberPerMillimetre
    • D63 - Book
    • D64 - Block
    • D65 - Round
    • D66 - Cassette
    • D67 - DollarPerHour
    • D69 - InchToTheFourthPower
    • D7 - Sandwich
    • D70 - InternationalTableCalorie
    • D71 - InternationalTableCaloriePerSecondCentimetreKelvin
    • D72 - InternationalTableCaloriePerSecondSquareCentimetreKelvin
    • D73 - JouleSquareMetre
    • D74 - KilogramPerMole
    • D75 - InternationalTableCaloriePerGram
    • D76 - InternationalTableCaloriePerGramKelvin
    • D77 - Megacoulomb
    • D79 - Beam
    • D8 - DraizeScore
    • D80 - Microwatt
    • D81 - Microtesla
    • D82 - Microvolt
    • D83 - MillinewtonMetre
    • D85 - MicrowattPerSquareMetre
    • D86 - Millicoulomb
    • D87 - MillimolePerKilogram
    • D88 - MillicoulombPerCubicMetre
    • D89 - MillicoulombPerSquareMetre
    • D9 - DynePerSquareCentemeter
    • D90 - CubicMeters-Net
    • D91 - Rem
    • D92 - Band
    • D93 - SecondPerCubicMetre
    • D94 - SecondPerRadianCubicMetre
    • D95 - JoulePerGram
    • D96 - PoundGross
    • D97 - PalletPerUnitLoad
    • D98 - MassPound
    • D99 - Sleeve
    • DAA - Decare
    • DAD - TenDay
    • DAY - Day
    • DB - DryPound
    • DC - Disk
    • DD - Degree
    • DE - Deal
    • DEC - Decade
    • DF - Dram
    • DG - Decigram
    • DH - Miles
    • DI - Dispenser
    • DJ - Decagram
    • DLT - Deciliter
    • DMK - SquareDecimeter
    • DMQ - CubicDecimeter
    • DMT - Decimeter
    • DN - DeciNewton-Meter
    • DO - Dollars
    • DPC - DozenPiece
    • DPR - DozenPair
    • DPT - DisplacementTonnage
    • DQ - DataRecord
    • DR - Drum
    • DRA - Dram-US
    • DRI - Dram-UK
    • DRL - DozenRoll
    • DRM - Drachm-UK
    • DS - Display
    • DT - DryTon
    • DTN - Decitonne
    • DU - Dyne
    • DWT - PennyWeight
    • DX - DynesPerCentimeter
    • DY - DirectoryBook
    • DZN - Dozen
    • DZP - DozenPack
    • E2 - Belt
    • E3 - Trailer
    • E4 - GrossKilogram
    • E5 - MetricLongTon
    • E9 - English
    • EA - Each
    • EB - ElectronicMailBox
    • EC - EachPerMonth
    • EP - ElevenPack
    • EQ - EquivalentGallon
    • EV - Envelope
    • EX - Feet
    • EZ - FeetAndDecimal
    • F1 - ThousandCubicFeetPerDay
    • F9 - FibersPerCubicCentimeterOfAir
    • FAH - DegreeFahrenheit
    • FAR - Farad
    • FB - Field
    • FC - 1000CubicFeet
    • FD - MillionParticlePerCubicFoot
    • FE - TrackFoot
    • FF - HundredCubicMeters
    • FG - TransdermalPatch
    • FH - Micromolar
    • FL - FlakeTon
    • FM - MillionCubicFeet
    • FO - FluidOunce
    • FOT - Foot
    • FP - PoundPerSquareFoot
    • FR - FootPerMinute
    • FS - FootPerSecond
    • FTK - SquareFoot
    • FTQ - CubicFeet
    • FZ - FluidOunce-Imperial
    • G2 - USGallonsPerMinute
    • G3 - ImperialGallonsPerMinute
    • G5 - Gill-Imperial
    • G7 - MicroficheSheet
    • GB - Gallon-US-PerDay
    • GBQ - Gigabecquerel
    • GC - GramPer100Gram
    • GD - GrossBarrel
    • GE - PoundPerGallon-US
    • GF - GramsPer100Centimeters
    • GFI - GramOfFissileIsotope
    • GG - GreatGross-DozenGross
    • GGR - GreatGross
    • GH - HalfGallon
    • GI - ImperialGallons
    • GIA - Gill-US
    • GII - Gill-UK
    • GJ - GramsPerMilliliter
    • GK - GramsPerKilogram
    • GL - GramsPerLiter
    • GLD - DryGallon-US
    • GLI - Gallon-UK
    • GLL - Gallon-US
    • GM - GramsPerSquareMeter
    • GN - GrossGallon
    • GO - MilligramsPerSquareMeter
    • GP - MilligramsPerCubicMeter
    • GQ - MicrogramPerCubicMeter
    • GRM - Gram
    • GRN - Grain
    • GRO - Gross
    • GRT - GrossRegisterTon
    • GT - GrossTon
    • GV - Gigajoule
    • GW - GallonsPerThousandCubicFeet
    • GWH - GigawattHour
    • GY - GrossYard
    • GZ - GageSystem
    • H1 - HalfPage-Electronic
    • H2 - HalfLiter
    • HA - Hank
    • HAR - Hectare
    • HBA - Hectobar
    • HBX - HundredBoxes
    • HC - HundredCount
    • HD - HalfDozen
    • HE - HundredthOfACarat
    • HF - HundredFeet
    • HGM - Hectogram
    • HH - HundredCubicFeet
    • HI - HundredSheet
    • HIU - HundredInternationalUnit
    • HJ - Horsepower
    • HK - HundredKilogram
    • HL - HundredFeet-Linear
    • HLT - Hectoliter
    • HM - MilesPerHour
    • HMQ - MillionCubicMetre
    • HMT - Hectometer
    • HN - MillimetersOfMercury
    • HO - HundredTroyOunce
    • HP - MillimeterOfWater
    • HPA - HectolitreOfPureAlcohol
    • HS - HundredSquareFeet
    • HT - HalfHour
    • HTZ - Hertz
    • HUR - Hours
    • HV - HundredWeight-Short
    • HW - HundredWeight-Long
    • HY - HundredYard
    • IA - InchPound
    • IB - InchesPerSecond-VibrationVelocity
    • IC - CountPerInch
    • IE - Person
    • IF - InchesOfWater
    • II - Column-Inches
    • IL - InchesPerMinute
    • IM - Impression
    • INH - Inch
    • INK - SquareInch
    • INQ - CubicInch
    • IP - InsurancePolicy
    • IT - CountsPerCentimeter
    • IU - InchPerSecond-LinearSpeed
    • IV - InchPerSecondSquared-Acceleration
    • IW - InchesPerSecondPerSecond-VibrationAcceleration
    • J2 - JoulePerKilogram
    • JB - Jumbo
    • JE - JoulePerKelvin
    • JG - Jug
    • JK - MegajoulePerKilogram
    • JM - MegajoulePerCubicMeter
    • JO - Joint
    • JOU - Joule
    • JR - Jar
    • K1 - KilowattDemand
    • K2 - KilovoltAmpereReactiveDemand
    • K3 - KilovoltAmpereReactiveHour
    • K5 - KilovoltAmpere-Reactive
    • K6 - Kiloliter
    • KA - Cake
    • KB - Kilocharacter
    • KBA - Kilobar
    • KD - KilogramsDecimal
    • KEL - Kelvin
    • KF - Kilopacket
    • KG - Keg
    • KGM - Kilogram
    • KGS - KilogramPerSecond
    • KHZ - Kilohertz
    • KI - KilogramsPerMillimeterWidth
    • KJ - Kilosegment
    • KJO - Kilojoule
    • KK - 100Kilograms
    • KL - KilogramsPerMeter
    • KMH - KilometersPerHour
    • KMK - SquareKilometre
    • KMQ - KilogramsPerCubicMeter
    • KNI - KilogramOfNitrogen
    • KNS - KilogramNamedSubstance
    • KNT - Knot
    • KO - MillequivalenceCausticPotashPerGramOfProduct
    • KPA - Kilopascal
    • KPH - KilogramOfPotassiumHydroxideOrCausticPotash
    • KPO - KilogramOfPotassiumOxide
    • KPP - KilogramOfPhosphorusPentoxideOrPhosphoricAnhydride
    • KR - Kiloroentgen
    • KS - 1000PoundsPerSquareInch
    • KSD - KilogramOfSubstance90%Dry
    • KSH - KilogramOfSodiumHydroxideOrCausticSoda
    • KT - Kit
    • KMT - Kilometre
    • KTN - Kilotonne
    • KUR - KilogramOfUranium
    • KVA - Kilovolt-Ampere
    • KVR - Kilovar
    • KVT - Kilovolt
    • KW - KilogramsPerMillimeter
    • KWH - KilowattHour
    • KWT - Kilowatt
    • KX - MillilitersPerKilogram
    • L2 - LitersPerMinute
    • LA - PoundPerCubicInch
    • LBR - Pound
    • LBT - TroyPound
    • LC - LinearCentimeter
    • LD - LitersPerDay UN/ECE - Litre Per Day
    • LE - Lite
    • LEF - Leaf
    • LF - LinearFoot
    • LG - LongTon
    • LH - LabourHour
    • LI - LinearInch
    • LJ - LargeSpray
    • LK - Link
    • LM - LinearMeter
    • LN - Length
    • LO - Lot
    • LP - LiquidPounds
    • LPA - LitreOfPureAlcohol
    • LR - Layer
    • LS - LumpSum
    • LTN - Ton-UKOrLongton-US
    • LTR - Liter
    • LUM - Lumen
    • LUX - Lux
    • LX - LinearYardsPerPound
    • LY - LinearYard
    • M0 - MagneticTape
    • M1 - MilligramsPerLiter
    • M2 - Millimeter-Actual
    • M4 - MonetaryValue
    • M5 - Microcurie
    • M7 - MicroInch
    • M9 - MillionBritishThermalUnitsPerOneThousandCubicFeet
    • MA - MachinePerUnit
    • MAL - MegaLitre
    • MAM - Megametre
    • MAW - Megawatt
    • MB - Millimeter-Nominal
    • MBE - ThousandStandardBrickEquivalent
    • MBF - ThousandBoardFeet
    • MBR - Millibar
    • MC - Microgram
    • MCU - Millicurie
    • MD - AirDryMetricTon
    • MF - MilligramPerSquareFootPerSide
    • MGM - Milligram
    • MH - Microns
    • MHZ - Megahertz
    • MI - Metric
    • MIK - SquareMile
    • MIL - Thousand
    • MIN - Minute
    • MIO - Million
    • MIU - MillionInternationalUnit
    • MK - MilligramsPerSquareInch
    • MLD - BillionsOfDollars
    • MLT - Milliliter
    • MMK - SquareMillimeter
    • MMQ - CubicMillimetre
    • MMT - Millimeter
    • MON - Months
    • MPA - Megapascal
    • MQ - 1000Meters
    • MQH - CubicMeterPerHour
    • MQS - CubicMetrePerSecond
    • MSK - MetrePerSecondSquared
    • MT - Mat
    • MTK - SquareMeter
    • MTQ - CubicMeter
    • MTR - Meter
    • MTS - MetrePerSecond
    • MV - NumberOfMults
    • MVA - Megavolt-Ampere
    • MW - MetricTonKilograms
    • MWH - MegawattHourOr1000KwH
    • MX - Mixed
    • MY - Millimeter-Average
    • MZ - Millimeter-Minimum
    • N1 - PenCalories
    • N2 - NumberOfLines
    • N3 - PrintPoint
    • NA - MilligramPerKilogram
    • NAR - NumberOfArticles
    • NB - Barge
    • NBB - NumberOfBobbins
    • NC - Car
    • NCL - NumberOfCells
    • ND - NetBarrel
    • NE - NetLiters
    • NEW - Newton
    • NF - Messages
    • NG - NetGallons
    • NH - MessageHour
    • NI - NetImperialGallon
    • NIU - NumberOfInternationalUnits
    • NJ - NumberOfScreens
    • NL - Load
    • NMI - NauticalMile
    • NMP - NumberOfPacks
    • NN - Train
    • NPL - NumberOfParcels
    • NPR - NumberOfPairs
    • NPT - NumberOfParts
    • NQ - Mho
    • NR - Micromho
    • NRL - NumberOfRolls
    • NT - NetTon
    • NTT - NetRegisterTon
    • NU - Newton-Meter
    • NV - Vehicle
    • NX - PartsPerThousand
    • NY - PoundPerAirDryMetricTon
    • OA - Panel
    • OHM - Ohm
    • ON - OuncePerSquareYard
    • ONZ - Ounce
    • OP - TwoPack
    • OT - OvertimeHours
    • OZ - OunceAv
    • OZA - FluidOunce-US
    • OZI - FluidOunce-UK
    • P0 - Page-Electronic
    • P1 - Percent
    • P2 - PoundPerFoot
    • P3 - ThreePack
    • P4 - FourPack
    • P5 - FivePack
    • P6 - SixPack
    • P7 - SevenPack
    • P8 - EightPack
    • P9 - NinePack
    • PA - Packet
    • PAL - Pascal
    • PB - PairInch
    • PD - Pad
    • PE - PoundEquivalent
    • PF - Pallet-Lift
    • PG - Plate
    • PGL - ProofGallon
    • PI - Pitch
    • PK - Package
    • PL - Pail
    • PM - PoundPercentage
    • PN - PoundNet
    • PO - PoundPerInchOfLength
    • PQ - PagePerInch
    • PR - Pair
    • PS - PoundsPerSquareInch
    • PT - Pint-US
    • PTD - DryPint-US
    • PTI - Pint-UK
    • PTL - LiquidPint-US
    • PU - Tray
    • PV - HalfPint
    • PW - PoundPerInchOfWidth
    • PY - PeckDry-US
    • PZ - PeckDry-UK
    • Q1 - Quarter-Time
    • Q2 - PintUSDry
    • Q3 - Meal
    • Q4 - Fifty
    • Q5 - Twenty-Five
    • Q6 - Thirty-Six
    • Q7 - Twenty-Four
    • QA - Page-Facsimile
    • QAN - Quarter-OfAYear
    • QB - Page-Hardcopy
    • QD - QuarterDozen
    • QH - QuarterHours
    • QK - QuarterKilogram
    • QR - Quire
    • QS - Quart
    • QT - Quart-US
    • QTD - DryQuart-US
    • QTI - Quart-UK
    • QTL - LiquidQuart-US
    • QTR - Quarter-UK
    • R1 - Pica
    • R4 - Calorie
    • R5 - ThousandsOfDollars
    • R6 - MillionsOfDollars
    • R9 - ThousandCubicMeters
    • RA - Rack
    • RD - Rod
    • RG - Ring
    • RH - RunningOrOperatingHours
    • RK - RollMetricMeasure
    • RL - Reel
    • RM - Ream
    • RN - ReamMetricMeasure
    • RO - Roll
    • RP - PoundPerReam
    • RPM - RevolutionsPerMinute
    • RPS - RevolutionsPerSecond
    • RS - Reset
    • RT - RevenueTonMile
    • RU - Run
    • S3 - FootSquaredPerSecond
    • S4 - SquareMetersPerSecond
    • S5 - SixtyFourthsOfAnInch
    • S6 - Session
    • S7 - StorageUnits
    • S8 - StandardAdvertisingUnit
    • SA - Sack
    • SAN - HalfYearOr6Months
    • SCO - Score
    • SCR - Scruple
    • SD - SolidPound
    • SE - Section
    • SEC - Second
    • SET - Set
    • SG - Segment
    • SHT - ShippingTon
    • SIE - Siemens
    • SK - SplitTanktruck
    • SL - Slipsheet
    • SMI - StatuteMile
    • SN - SquareRod
    • SO - Spool
    • SP - ShelfPackage
    • SQ - Square
    • SR - Strip
    • SS - SheetMetricMeasure
    • SST - ShortStandard-7200Matches
    • ST - Sheet
    • STI - Stone-UK
    • STN - NetTon-2000Lb
    • SV - Skid
    • SW - Skein
    • SX - Shipment
    • T0 - TelecommunicationLineInService
    • T1 - ThousandPoundGross
    • T2 - ThousandthsOfAnInch
    • T3 - ThousandPiece
    • T4 - ThousandBag
    • T5 - ThousandCasing
    • T6 - ThousandGallons
    • T7 - ThousandImpression
    • T8 - ThousandLinearInch
    • T9 - ThousandKilowattHours
    • TA - TenthCubicFoot
    • TAH - KiloampereHourOrThousandAmpereHour
    • TC - Truckload
    • TD - Therm
    • TE - Tote
    • TF - TenSquareYard
    • TI - ThousandSquareInch
    • TJ - ThousandSquareCentimeters
    • TK - Tank-Rectangular
    • TL - ThousandFeet-Linear
    • TM - ThousandFeet-Board
    • TN - Tin
    • TNE - MetricTon
    • TP - TenPack
    • TPR - TenPair
    • TQ - ThousandFeet
    • TQD - ThousandCubicMetrePerDay
    • TR - TenSquareFeet
    • TRL - Trillion-EUR
    • TS - ThousandSquareFeet
    • TSD - TonneOfSubstance90%Dry
    • TSH - TonOfSteamPerHour
    • TT - ThousandLinearMeters
    • TU - Tube
    • TV - ThousandKilogram
    • TW - ThousandSheets
    • TY - Tank-Cylindrical
    • U1 - Treatment
    • U2 - Tablet
    • U3 - Ten
    • U5 - TwoHundredFifty
    • UA - Torr
    • UB - TelecommunicationLineInServiceAverage
    • UC - TelecommunicationPort
    • UD - TenthMinute
    • UE - TenthHour
    • UF - UsagePerTelecommunicationLineAverage
    • UH - TenThousandYard
    • UL - Unitless
    • UM - MillionUnits
    • VA - VoltAmperePerKilogram
    • VC - FiveHundred
    • VI - Vial
    • VLT - Volt
    • VQ - Bulk
    • VS - Visit
    • VT - Voltage
    • W2 - WetKilo
    • W4 - TwoWeek
    • WA - WattPerKilogram
    • WB - WetPound
    • WCD - Cord
    • WE - WetTon
    • WEB - Weber
    • WEE - Week
    • WG - WineGallon
    • WH - Wheel
    • WHR - WattHour
    • WI - WeightPerSquareInch
    • WM - WorkingMonth
    • WR - Wrap
    • WSD - Standard
    • WTT - Watt
    • WW - MillilitersOfWater
    • X1 - Chains-LandSurvey
    • YDK - SquareYard
    • YDQ - CubicYard
    • YL - 100LinealYards
    • YRD - Yard
    • YT - TenYard
    • Z1 - LiftVan
    • Z2 - Chest
    • Z3 - Cask
    • Z4 - Hogshead
    • Z5 - Lug
    • Z6 - ConferencePoints
    • Z8 - NewspageAgateLine
    • ZP - Page

[^]Code Fragment

    <xsd:simpleType name="UOMCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="1">
        <xsd:enumeration value="4">
        <xsd:enumeration value="5">
        <xsd:enumeration value="8">
        <xsd:enumeration value="10">
        <xsd:enumeration value="11">
        <xsd:enumeration value="13">
        <xsd:enumeration value="14">
        <xsd:enumeration value="15">
        <xsd:enumeration value="16">
        <xsd:enumeration value="17">
        <xsd:enumeration value="18">
        <xsd:enumeration value="19">
        <xsd:enumeration value="20">
        <xsd:enumeration value="21">
        <xsd:enumeration value="22">
        <xsd:enumeration value="23">
        <xsd:enumeration value="24">
        <xsd:enumeration value="25">
        <xsd:enumeration value="26">
        <xsd:enumeration value="27">
        <xsd:enumeration value="28">
        <xsd:enumeration value="29">
        <xsd:enumeration value="30">
        <xsd:enumeration value="31">
        <xsd:enumeration value="32">
        <xsd:enumeration value="33">
        <xsd:enumeration value="34">
        <xsd:enumeration value="35">
        <xsd:enumeration value="36">
        <xsd:enumeration value="37">
        <xsd:enumeration value="38">
        <xsd:enumeration value="40">
        <xsd:enumeration value="41">
        <xsd:enumeration value="43">
        <xsd:enumeration value="44">
        <xsd:enumeration value="45">
        <xsd:enumeration value="46">
        <xsd:enumeration value="47">
        <xsd:enumeration value="48">
        <xsd:enumeration value="50">
        <xsd:enumeration value="51">
        <xsd:enumeration value="53">
        <xsd:enumeration value="54">
        <xsd:enumeration value="56">
        <xsd:enumeration value="57">
        <xsd:enumeration value="58">
        <xsd:enumeration value="59">
        <xsd:enumeration value="60">
        <xsd:enumeration value="61">
        <xsd:enumeration value="62">
        <xsd:enumeration value="63">
        <xsd:enumeration value="64">
        <xsd:enumeration value="66">
        <xsd:enumeration value="69">
        <xsd:enumeration value="71">
        <xsd:enumeration value="72">
        <xsd:enumeration value="73">
        <xsd:enumeration value="74">
        <xsd:enumeration value="76">
        <xsd:enumeration value="77">
        <xsd:enumeration value="78">
        <xsd:enumeration value="80">
        <xsd:enumeration value="81">
        <xsd:enumeration value="84">
        <xsd:enumeration value="85">
        <xsd:enumeration value="86">
        <xsd:enumeration value="87">
        <xsd:enumeration value="89">
        <xsd:enumeration value="90">
        <xsd:enumeration value="91">
        <xsd:enumeration value="92">
        <xsd:enumeration value="93">
        <xsd:enumeration value="94">
        <xsd:enumeration value="95">
        <xsd:enumeration value="96">
        <xsd:enumeration value="97">
        <xsd:enumeration value="98">
        <xsd:enumeration value="1A">
        <xsd:enumeration value="1B">
        <xsd:enumeration value="1C">
        <xsd:enumeration value="1D">
        <xsd:enumeration value="1E">
        <xsd:enumeration value="1F">
        <xsd:enumeration value="1G">
        <xsd:enumeration value="1H">
        <xsd:enumeration value="1I">
        <xsd:enumeration value="1J">
        <xsd:enumeration value="1K">
        <xsd:enumeration value="1L">
        <xsd:enumeration value="1M">
        <xsd:enumeration value="1X">
        <xsd:enumeration value="2A">
        <xsd:enumeration value="2B">
        <xsd:enumeration value="2C">
        <xsd:enumeration value="2F">
        <xsd:enumeration value="2G">
        <xsd:enumeration value="2H">
        <xsd:enumeration value="2I">
        <xsd:enumeration value="2J">
        <xsd:enumeration value="2K">
        <xsd:enumeration value="2L">
        <xsd:enumeration value="2M">
        <xsd:enumeration value="2N">
        <xsd:enumeration value="2P">
        <xsd:enumeration value="2Q">
        <xsd:enumeration value="2R">
        <xsd:enumeration value="2U">
        <xsd:enumeration value="2V">
        <xsd:enumeration value="2W">
        <xsd:enumeration value="2X">
        <xsd:enumeration value="2Y">
        <xsd:enumeration value="2Z">
        <xsd:enumeration value="3B">
        <xsd:enumeration value="3C">
        <xsd:enumeration value="3E">
        <xsd:enumeration value="3F">
        <xsd:enumeration value="3G">
        <xsd:enumeration value="3H">
        <xsd:enumeration value="3I">
        <xsd:enumeration value="4A">
        <xsd:enumeration value="4B">
        <xsd:enumeration value="4C">
        <xsd:enumeration value="4E">
        <xsd:enumeration value="4G">
        <xsd:enumeration value="4H">
        <xsd:enumeration value="4I">
        <xsd:enumeration value="4J">
        <xsd:enumeration value="4K">
        <xsd:enumeration value="4L">
        <xsd:enumeration value="4M">
        <xsd:enumeration value="4N">
        <xsd:enumeration value="4O">
        <xsd:enumeration value="4P">
        <xsd:enumeration value="4Q">
        <xsd:enumeration value="4R">
        <xsd:enumeration value="4T">
        <xsd:enumeration value="4U">
        <xsd:enumeration value="4W">
        <xsd:enumeration value="4X">
        <xsd:enumeration value="5A">
        <xsd:enumeration value="5B">
        <xsd:enumeration value="5C">
        <xsd:enumeration value="5E">
        <xsd:enumeration value="5F">
        <xsd:enumeration value="5G">
        <xsd:enumeration value="5H">
        <xsd:enumeration value="5I">
        <xsd:enumeration value="5J">
        <xsd:enumeration value="5K">
        <xsd:enumeration value="5P">
        <xsd:enumeration value="5Q">
        <xsd:enumeration value="A1">
        <xsd:enumeration value="A10">
        <xsd:enumeration value="A11">
        <xsd:enumeration value="A12">
        <xsd:enumeration value="A13">
        <xsd:enumeration value="A14">
        <xsd:enumeration value="A15">
        <xsd:enumeration value="A16">
        <xsd:enumeration value="A17">
        <xsd:enumeration value="A18">
        <xsd:enumeration value="A19">
        <xsd:enumeration value="A2">
        <xsd:enumeration value="A20">
        <xsd:enumeration value="A22">
        <xsd:enumeration value="A23">
        <xsd:enumeration value="A24">
        <xsd:enumeration value="A25">
        <xsd:enumeration value="A26">
        <xsd:enumeration value="A27">
        <xsd:enumeration value="A28">
        <xsd:enumeration value="A29">
        <xsd:enumeration value="A3">
        <xsd:enumeration value="A30">
        <xsd:enumeration value="A31">
        <xsd:enumeration value="A32">
        <xsd:enumeration value="A33">
        <xsd:enumeration value="A34">
        <xsd:enumeration value="A35">
        <xsd:enumeration value="A36">
        <xsd:enumeration value="A37">
        <xsd:enumeration value="A38">
        <xsd:enumeration value="A39">
        <xsd:enumeration value="A4">
        <xsd:enumeration value="A40">
        <xsd:enumeration value="A41">
        <xsd:enumeration value="A42">
        <xsd:enumeration value="A43">
        <xsd:enumeration value="A44">
        <xsd:enumeration value="A45">
        <xsd:enumeration value="A47">
        <xsd:enumeration value="A48">
        <xsd:enumeration value="A49">
        <xsd:enumeration value="A5">
        <xsd:enumeration value="A50">
        <xsd:enumeration value="A51">
        <xsd:enumeration value="A52">
        <xsd:enumeration value="A53">
        <xsd:enumeration value="A54">
        <xsd:enumeration value="A55">
        <xsd:enumeration value="A56">
        <xsd:enumeration value="A57">
        <xsd:enumeration value="A58">
        <xsd:enumeration value="A6">
        <xsd:enumeration value="A60">
        <xsd:enumeration value="A61">
        <xsd:enumeration value="A62">
        <xsd:enumeration value="A63">
        <xsd:enumeration value="A64">
        <xsd:enumeration value="A65">
        <xsd:enumeration value="A66">
        <xsd:enumeration value="A67">
        <xsd:enumeration value="A68">
        <xsd:enumeration value="A69">
        <xsd:enumeration value="A7">
        <xsd:enumeration value="A70">
        <xsd:enumeration value="A71">
        <xsd:enumeration value="A73">
        <xsd:enumeration value="A74">
        <xsd:enumeration value="A75">
        <xsd:enumeration value="A76">
        <xsd:enumeration value="A77">
        <xsd:enumeration value="A78">
        <xsd:enumeration value="A79">
        <xsd:enumeration value="A8">
        <xsd:enumeration value="A80">
        <xsd:enumeration value="A81">
        <xsd:enumeration value="A82">
        <xsd:enumeration value="A83">
        <xsd:enumeration value="A84">
        <xsd:enumeration value="A85">
        <xsd:enumeration value="A86">
        <xsd:enumeration value="A87">
        <xsd:enumeration value="A88">
        <xsd:enumeration value="A89">
        <xsd:enumeration value="A9">
        <xsd:enumeration value="A90">
        <xsd:enumeration value="A91">
        <xsd:enumeration value="A93">
        <xsd:enumeration value="A94">
        <xsd:enumeration value="A95">
        <xsd:enumeration value="A96">
        <xsd:enumeration value="A97">
        <xsd:enumeration value="A98">
        <xsd:enumeration value="AA">
        <xsd:enumeration value="AB">
        <xsd:enumeration value="ACR">
        <xsd:enumeration value="AD">
        <xsd:enumeration value="AE">
        <xsd:enumeration value="AH">
        <xsd:enumeration value="AI">
        <xsd:enumeration value="AJ">
        <xsd:enumeration value="AK">
        <xsd:enumeration value="AL">
        <xsd:enumeration value="AM">
        <xsd:enumeration value="AMH">
        <xsd:enumeration value="AMP">
        <xsd:enumeration value="AN">
        <xsd:enumeration value="ANN">
        <xsd:enumeration value="AP">
        <xsd:enumeration value="APZ">
        <xsd:enumeration value="AQ">
        <xsd:enumeration value="AR">
        <xsd:enumeration value="ARE">
        <xsd:enumeration value="AS">
        <xsd:enumeration value="ASM">
        <xsd:enumeration value="ASU">
        <xsd:enumeration value="AT">
        <xsd:enumeration value="ATM">
        <xsd:enumeration value="ATT">
        <xsd:enumeration value="AU">
        <xsd:enumeration value="AV">
        <xsd:enumeration value="AW">
        <xsd:enumeration value="AX">
        <xsd:enumeration value="AY">
        <xsd:enumeration value="AZ">
        <xsd:enumeration value="B0">
        <xsd:enumeration value="B1">
        <xsd:enumeration value="B11">
        <xsd:enumeration value="B12">
        <xsd:enumeration value="B13">
        <xsd:enumeration value="B14">
        <xsd:enumeration value="B15">
        <xsd:enumeration value="B16">
        <xsd:enumeration value="B18">
        <xsd:enumeration value="B2">
        <xsd:enumeration value="B20">
        <xsd:enumeration value="B21">
        <xsd:enumeration value="B22">
        <xsd:enumeration value="B23">
        <xsd:enumeration value="B24">
        <xsd:enumeration value="B25">
        <xsd:enumeration value="B26">
        <xsd:enumeration value="B27">
        <xsd:enumeration value="B28">
        <xsd:enumeration value="B29">
        <xsd:enumeration value="B3">
        <xsd:enumeration value="B31">
        <xsd:enumeration value="B32">
        <xsd:enumeration value="B33">
        <xsd:enumeration value="B34">
        <xsd:enumeration value="B35">
        <xsd:enumeration value="B36">
        <xsd:enumeration value="B37">
        <xsd:enumeration value="B38">
        <xsd:enumeration value="B39">
        <xsd:enumeration value="B4">
        <xsd:enumeration value="B40">
        <xsd:enumeration value="B41">
        <xsd:enumeration value="B42">
        <xsd:enumeration value="B43">
        <xsd:enumeration value="B44">
        <xsd:enumeration value="B45">
        <xsd:enumeration value="B46">
        <xsd:enumeration value="B47">
        <xsd:enumeration value="B48">
        <xsd:enumeration value="B49">
        <xsd:enumeration value="B5">
        <xsd:enumeration value="B50">
        <xsd:enumeration value="B51">
        <xsd:enumeration value="B52">
        <xsd:enumeration value="B53">
        <xsd:enumeration value="B54">
        <xsd:enumeration value="B55">
        <xsd:enumeration value="B56">
        <xsd:enumeration value="B57">
        <xsd:enumeration value="B58">
        <xsd:enumeration value="B59">
        <xsd:enumeration value="B6">
        <xsd:enumeration value="B60">
        <xsd:enumeration value="B61">
        <xsd:enumeration value="B62">
        <xsd:enumeration value="B63">
        <xsd:enumeration value="B64">
        <xsd:enumeration value="B65">
        <xsd:enumeration value="B66">
        <xsd:enumeration value="B67">
        <xsd:enumeration value="B69">
        <xsd:enumeration value="B7">
        <xsd:enumeration value="B70">
        <xsd:enumeration value="B71">
        <xsd:enumeration value="B72">
        <xsd:enumeration value="B73">
        <xsd:enumeration value="B74">
        <xsd:enumeration value="B75">
        <xsd:enumeration value="B76">
        <xsd:enumeration value="B77">
        <xsd:enumeration value="B78">
        <xsd:enumeration value="B79">
        <xsd:enumeration value="B8">
        <xsd:enumeration value="B81">
        <xsd:enumeration value="B83">
        <xsd:enumeration value="B84">
        <xsd:enumeration value="B85">
        <xsd:enumeration value="B86">
        <xsd:enumeration value="B87">
        <xsd:enumeration value="B88">
        <xsd:enumeration value="B89">
        <xsd:enumeration value="B9">
        <xsd:enumeration value="B90">
        <xsd:enumeration value="B91">
        <xsd:enumeration value="B92">
        <xsd:enumeration value="B93">
        <xsd:enumeration value="B94">
        <xsd:enumeration value="B95">
        <xsd:enumeration value="B96">
        <xsd:enumeration value="B97">
        <xsd:enumeration value="B98">
        <xsd:enumeration value="B99">
        <xsd:enumeration value="BAR">
        <xsd:enumeration value="BB">
        <xsd:enumeration value="BD">
        <xsd:enumeration value="BE">
        <xsd:enumeration value="BFT">
        <xsd:enumeration value="BG">
        <xsd:enumeration value="BH">
        <xsd:enumeration value="BHP">
        <xsd:enumeration value="BIL">
        <xsd:enumeration value="BJ">
        <xsd:enumeration value="BK">
        <xsd:enumeration value="BL">
        <xsd:enumeration value="BLD">
        <xsd:enumeration value="BLL">
        <xsd:enumeration value="BO">
        <xsd:enumeration value="BP">
        <xsd:enumeration value="BQL">
        <xsd:enumeration value="BT">
        <xsd:enumeration value="BTU">
        <xsd:enumeration value="BU">
        <xsd:enumeration value="BUA">
        <xsd:enumeration value="BUI">
        <xsd:enumeration value="BW">
        <xsd:enumeration value="BX">
        <xsd:enumeration value="BZ">
        <xsd:enumeration value="C0">
        <xsd:enumeration value="C1">
        <xsd:enumeration value="C10">
        <xsd:enumeration value="C11">
        <xsd:enumeration value="C12">
        <xsd:enumeration value="C13">
        <xsd:enumeration value="C14">
        <xsd:enumeration value="C15">
        <xsd:enumeration value="C16">
        <xsd:enumeration value="C17">
        <xsd:enumeration value="C18">
        <xsd:enumeration value="C19">
        <xsd:enumeration value="C2">
        <xsd:enumeration value="C20">
        <xsd:enumeration value="C22">
        <xsd:enumeration value="C23">
        <xsd:enumeration value="C24">
        <xsd:enumeration value="C25">
        <xsd:enumeration value="C26">
        <xsd:enumeration value="C27">
        <xsd:enumeration value="C28">
        <xsd:enumeration value="C29">
        <xsd:enumeration value="C3">
        <xsd:enumeration value="C30">
        <xsd:enumeration value="C31">
        <xsd:enumeration value="C32">
        <xsd:enumeration value="C33">
        <xsd:enumeration value="C34">
        <xsd:enumeration value="C35">
        <xsd:enumeration value="C36">
        <xsd:enumeration value="C38">
        <xsd:enumeration value="C39">
        <xsd:enumeration value="C4">
        <xsd:enumeration value="C40">
        <xsd:enumeration value="C41">
        <xsd:enumeration value="C42">
        <xsd:enumeration value="C43">
        <xsd:enumeration value="C44">
        <xsd:enumeration value="C45">
        <xsd:enumeration value="C46">
        <xsd:enumeration value="C47">
        <xsd:enumeration value="C48">
        <xsd:enumeration value="C49">
        <xsd:enumeration value="C5">
        <xsd:enumeration value="C50">
        <xsd:enumeration value="C51">
        <xsd:enumeration value="C52">
        <xsd:enumeration value="C53">
        <xsd:enumeration value="C54">
        <xsd:enumeration value="C55">
        <xsd:enumeration value="C56">
        <xsd:enumeration value="C57">
        <xsd:enumeration value="C58">
        <xsd:enumeration value="C59">
        <xsd:enumeration value="C6">
        <xsd:enumeration value="C60">
        <xsd:enumeration value="C61">
        <xsd:enumeration value="C62">
        <xsd:enumeration value="C63">
        <xsd:enumeration value="C64">
        <xsd:enumeration value="C65">
        <xsd:enumeration value="C66">
        <xsd:enumeration value="C67">
        <xsd:enumeration value="C68">
        <xsd:enumeration value="C69">
        <xsd:enumeration value="C7">
        <xsd:enumeration value="C70">
        <xsd:enumeration value="C71">
        <xsd:enumeration value="C72">
        <xsd:enumeration value="C73">
        <xsd:enumeration value="C75">
        <xsd:enumeration value="C76">
        <xsd:enumeration value="C77">
        <xsd:enumeration value="C78">
        <xsd:enumeration value="C8">
        <xsd:enumeration value="C80">
        <xsd:enumeration value="C81">
        <xsd:enumeration value="C82">
        <xsd:enumeration value="C83">
        <xsd:enumeration value="C84">
        <xsd:enumeration value="C85">
        <xsd:enumeration value="C86">
        <xsd:enumeration value="C87">
        <xsd:enumeration value="C88">
        <xsd:enumeration value="C89">
        <xsd:enumeration value="C9">
        <xsd:enumeration value="C90">
        <xsd:enumeration value="C91">
        <xsd:enumeration value="C92">
        <xsd:enumeration value="C93">
        <xsd:enumeration value="C94">
        <xsd:enumeration value="C95">
        <xsd:enumeration value="C96">
        <xsd:enumeration value="C97">
        <xsd:enumeration value="C98">
        <xsd:enumeration value="C99">
        <xsd:enumeration value="CA">
        <xsd:enumeration value="CCT">
        <xsd:enumeration value="CD">
        <xsd:enumeration value="CDL">
        <xsd:enumeration value="CE">
        <xsd:enumeration value="CEL">
        <xsd:enumeration value="CEN">
        <xsd:enumeration value="CG">
        <xsd:enumeration value="CGM">
        <xsd:enumeration value="CH">
        <xsd:enumeration value="CJ">
        <xsd:enumeration value="CK">
        <xsd:enumeration value="CKG">
        <xsd:enumeration value="CL">
        <xsd:enumeration value="CLF">
        <xsd:enumeration value="CLT">
        <xsd:enumeration value="CMK">
        <xsd:enumeration value="CMQ">
        <xsd:enumeration value="CMT">
        <xsd:enumeration value="CNP">
        <xsd:enumeration value="CNT">
        <xsd:enumeration value="CO">
        <xsd:enumeration value="COU">
        <xsd:enumeration value="CQ">
        <xsd:enumeration value="CR">
        <xsd:enumeration value="CS">
        <xsd:enumeration value="CT">
        <xsd:enumeration value="CTM">
        <xsd:enumeration value="CU">
        <xsd:enumeration value="CUR">
        <xsd:enumeration value="CV">
        <xsd:enumeration value="CWA">
        <xsd:enumeration value="CWI">
        <xsd:enumeration value="CY">
        <xsd:enumeration value="CZ">
        <xsd:enumeration value="D1">
        <xsd:enumeration value="D10">
        <xsd:enumeration value="D12">
        <xsd:enumeration value="D13">
        <xsd:enumeration value="D14">
        <xsd:enumeration value="D16">
        <xsd:enumeration value="D17">
        <xsd:enumeration value="D18">
        <xsd:enumeration value="D19">
        <xsd:enumeration value="D2">
        <xsd:enumeration value="D20">
        <xsd:enumeration value="D21">
        <xsd:enumeration value="D22">
        <xsd:enumeration value="D23">
        <xsd:enumeration value="D24">
        <xsd:enumeration value="D25">
        <xsd:enumeration value="D26">
        <xsd:enumeration value="D27">
        <xsd:enumeration value="D28">
        <xsd:enumeration value="D29">
        <xsd:enumeration value="D30">
        <xsd:enumeration value="D31">
        <xsd:enumeration value="D33">
        <xsd:enumeration value="D34">
        <xsd:enumeration value="D35">
        <xsd:enumeration value="D37">
        <xsd:enumeration value="D38">
        <xsd:enumeration value="D39">
        <xsd:enumeration value="D40">
        <xsd:enumeration value="D41">
        <xsd:enumeration value="D42">
        <xsd:enumeration value="D43">
        <xsd:enumeration value="D44">
        <xsd:enumeration value="D45">
        <xsd:enumeration value="D46">
        <xsd:enumeration value="D47">
        <xsd:enumeration value="D48">
        <xsd:enumeration value="D49">
        <xsd:enumeration value="D5">
        <xsd:enumeration value="D50">
        <xsd:enumeration value="D51">
        <xsd:enumeration value="D52">
        <xsd:enumeration value="D53">
        <xsd:enumeration value="D54">
        <xsd:enumeration value="D55">
        <xsd:enumeration value="D56">
        <xsd:enumeration value="D57">
        <xsd:enumeration value="D58">
        <xsd:enumeration value="D59">
        <xsd:enumeration value="D6">
        <xsd:enumeration value="D60">
        <xsd:enumeration value="D63">
        <xsd:enumeration value="D64">
        <xsd:enumeration value="D65">
        <xsd:enumeration value="D66">
        <xsd:enumeration value="D67">
        <xsd:enumeration value="D69">
        <xsd:enumeration value="D7">
        <xsd:enumeration value="D70">
        <xsd:enumeration value="D71">
        <xsd:enumeration value="D72">
        <xsd:enumeration value="D73">
        <xsd:enumeration value="D74">
        <xsd:enumeration value="D75">
        <xsd:enumeration value="D76">
        <xsd:enumeration value="D77">
        <xsd:enumeration value="D79">
        <xsd:enumeration value="D8">
        <xsd:enumeration value="D80">
        <xsd:enumeration value="D81">
        <xsd:enumeration value="D82">
        <xsd:enumeration value="D83">
        <xsd:enumeration value="D85">
        <xsd:enumeration value="D86">
        <xsd:enumeration value="D87">
        <xsd:enumeration value="D88">
        <xsd:enumeration value="D89">
        <xsd:enumeration value="D9">
        <xsd:enumeration value="D90">
        <xsd:enumeration value="D91">
        <xsd:enumeration value="D92">
        <xsd:enumeration value="D93">
        <xsd:enumeration value="D94">
        <xsd:enumeration value="D95">
        <xsd:enumeration value="D96">
        <xsd:enumeration value="D97">
        <xsd:enumeration value="D98">
        <xsd:enumeration value="D99">
        <xsd:enumeration value="DAA">
        <xsd:enumeration value="DAD">
        <xsd:enumeration value="DAY">
        <xsd:enumeration value="DB">
        <xsd:enumeration value="DC">
        <xsd:enumeration value="DD">
        <xsd:enumeration value="DE">
        <xsd:enumeration value="DEC">
        <xsd:enumeration value="DF">
        <xsd:enumeration value="DG">
        <xsd:enumeration value="DH">
        <xsd:enumeration value="DI">
        <xsd:enumeration value="DJ">
        <xsd:enumeration value="DLT">
        <xsd:enumeration value="DMK">
        <xsd:enumeration value="DMQ">
        <xsd:enumeration value="DMT">
        <xsd:enumeration value="DN">
        <xsd:enumeration value="DO">
        <xsd:enumeration value="DPC">
        <xsd:enumeration value="DPR">
        <xsd:enumeration value="DPT">
        <xsd:enumeration value="DQ">
        <xsd:enumeration value="DR">
        <xsd:enumeration value="DRA">
        <xsd:enumeration value="DRI">
        <xsd:enumeration value="DRL">
        <xsd:enumeration value="DRM">
        <xsd:enumeration value="DS">
        <xsd:enumeration value="DT">
        <xsd:enumeration value="DTN">
        <xsd:enumeration value="DU">
        <xsd:enumeration value="DWT">
        <xsd:enumeration value="DX">
        <xsd:enumeration value="DY">
        <xsd:enumeration value="DZN">
        <xsd:enumeration value="DZP">
        <xsd:enumeration value="E2">
        <xsd:enumeration value="E3">
        <xsd:enumeration value="E4">
        <xsd:enumeration value="E5">
        <xsd:enumeration value="E9">
        <xsd:enumeration value="EA">
        <xsd:enumeration value="EB">
        <xsd:enumeration value="EC">
        <xsd:enumeration value="EP">
        <xsd:enumeration value="EQ">
        <xsd:enumeration value="EV">
        <xsd:enumeration value="EX">
        <xsd:enumeration value="EZ">
        <xsd:enumeration value="F1">
        <xsd:enumeration value="F9">
        <xsd:enumeration value="FAH">
        <xsd:enumeration value="FAR">
        <xsd:enumeration value="FB">
        <xsd:enumeration value="FC">
        <xsd:enumeration value="FD">
        <xsd:enumeration value="FE">
        <xsd:enumeration value="FF">
        <xsd:enumeration value="FG">
        <xsd:enumeration value="FH">
        <xsd:enumeration value="FL">
        <xsd:enumeration value="FM">
        <xsd:enumeration value="FO">
        <xsd:enumeration value="FOT">
        <xsd:enumeration value="FP">
        <xsd:enumeration value="FR">
        <xsd:enumeration value="FS">
        <xsd:enumeration value="FTK">
        <xsd:enumeration value="FTQ">
        <xsd:enumeration value="FZ">
        <xsd:enumeration value="G2">
        <xsd:enumeration value="G3">
        <xsd:enumeration value="G5">
        <xsd:enumeration value="G7">
        <xsd:enumeration value="GB">
        <xsd:enumeration value="GBQ">
        <xsd:enumeration value="GC">
        <xsd:enumeration value="GD">
        <xsd:enumeration value="GE">
        <xsd:enumeration value="GF">
        <xsd:enumeration value="GFI">
        <xsd:enumeration value="GG">
        <xsd:enumeration value="GGR">
        <xsd:enumeration value="GH">
        <xsd:enumeration value="GI">
        <xsd:enumeration value="GIA">
        <xsd:enumeration value="GII">
        <xsd:enumeration value="GJ">
        <xsd:enumeration value="GK">
        <xsd:enumeration value="GL">
        <xsd:enumeration value="GLD">
        <xsd:enumeration value="GLI">
        <xsd:enumeration value="GLL">
        <xsd:enumeration value="GM">
        <xsd:enumeration value="GN">
        <xsd:enumeration value="GO">
        <xsd:enumeration value="GP">
        <xsd:enumeration value="GQ">
        <xsd:enumeration value="GRM">
        <xsd:enumeration value="GRN">
        <xsd:enumeration value="GRO">
        <xsd:enumeration value="GRT">
        <xsd:enumeration value="GT">
        <xsd:enumeration value="GV">
        <xsd:enumeration value="GW">
        <xsd:enumeration value="GWH">
        <xsd:enumeration value="GY">
        <xsd:enumeration value="GZ">
        <xsd:enumeration value="H1">
        <xsd:enumeration value="H2">
        <xsd:enumeration value="HA">
        <xsd:enumeration value="HAR">
        <xsd:enumeration value="HBA">
        <xsd:enumeration value="HBX">
        <xsd:enumeration value="HC">
        <xsd:enumeration value="HD">
        <xsd:enumeration value="HE">
        <xsd:enumeration value="HF">
        <xsd:enumeration value="HGM">
        <xsd:enumeration value="HH">
        <xsd:enumeration value="HI">
        <xsd:enumeration value="HIU">
        <xsd:enumeration value="HJ">
        <xsd:enumeration value="HK">
        <xsd:enumeration value="HL">
        <xsd:enumeration value="HLT">
        <xsd:enumeration value="HM">
        <xsd:enumeration value="HMQ">
        <xsd:enumeration value="HMT">
        <xsd:enumeration value="HN">
        <xsd:enumeration value="HO">
        <xsd:enumeration value="HP">
        <xsd:enumeration value="HPA">
        <xsd:enumeration value="HS">
        <xsd:enumeration value="HT">
        <xsd:enumeration value="HTZ">
        <xsd:enumeration value="HUR">
        <xsd:enumeration value="HV">
        <xsd:enumeration value="HW">
        <xsd:enumeration value="HY">
        <xsd:enumeration value="IA">
        <xsd:enumeration value="IB">
        <xsd:enumeration value="IC">
        <xsd:enumeration value="IE">
        <xsd:enumeration value="IF">
        <xsd:enumeration value="II">
        <xsd:enumeration value="IL">
        <xsd:enumeration value="IM">
        <xsd:enumeration value="INH">
        <xsd:enumeration value="INK">
        <xsd:enumeration value="INQ">
        <xsd:enumeration value="IP">
        <xsd:enumeration value="IT">
        <xsd:enumeration value="IU">
        <xsd:enumeration value="IV">
        <xsd:enumeration value="IW">
        <xsd:enumeration value="J2">
        <xsd:enumeration value="JB">
        <xsd:enumeration value="JE">
        <xsd:enumeration value="JG">
        <xsd:enumeration value="JK">
        <xsd:enumeration value="JM">
        <xsd:enumeration value="JO">
        <xsd:enumeration value="JOU">
        <xsd:enumeration value="JR">
        <xsd:enumeration value="K1">
        <xsd:enumeration value="K2">
        <xsd:enumeration value="K3">
        <xsd:enumeration value="K5">
        <xsd:enumeration value="K6">
        <xsd:enumeration value="KA">
        <xsd:enumeration value="KB">
        <xsd:enumeration value="KBA">
        <xsd:enumeration value="KD">
        <xsd:enumeration value="KEL">
        <xsd:enumeration value="KF">
        <xsd:enumeration value="KG">
        <xsd:enumeration value="KGM">
        <xsd:enumeration value="KGS">
        <xsd:enumeration value="KHZ">
        <xsd:enumeration value="KI">
        <xsd:enumeration value="KJ">
        <xsd:enumeration value="KJO">
        <xsd:enumeration value="KK">
        <xsd:enumeration value="KL">
        <xsd:enumeration value="KMH">
        <xsd:enumeration value="KMK">
        <xsd:enumeration value="KMQ">
        <xsd:enumeration value="KNI">
        <xsd:enumeration value="KNS">
        <xsd:enumeration value="KNT">
        <xsd:enumeration value="KO">
        <xsd:enumeration value="KPA">
        <xsd:enumeration value="KPH">
        <xsd:enumeration value="KPO">
        <xsd:enumeration value="KPP">
        <xsd:enumeration value="KR">
        <xsd:enumeration value="KS">
        <xsd:enumeration value="KSD">
        <xsd:enumeration value="KSH">
        <xsd:enumeration value="KT">
        <xsd:enumeration value="KMT">
        <xsd:enumeration value="KTN">
        <xsd:enumeration value="KUR">
        <xsd:enumeration value="KVA">
        <xsd:enumeration value="KVR">
        <xsd:enumeration value="KVT">
        <xsd:enumeration value="KW">
        <xsd:enumeration value="KWH">
        <xsd:enumeration value="KWT">
        <xsd:enumeration value="KX">
        <xsd:enumeration value="L2">
        <xsd:enumeration value="LA">
        <xsd:enumeration value="LBR">
        <xsd:enumeration value="LBT">
        <xsd:enumeration value="LC">
        <xsd:enumeration value="LD">
        <xsd:enumeration value="LE">
        <xsd:enumeration value="LEF">
        <xsd:enumeration value="LF">
        <xsd:enumeration value="LG">
        <xsd:enumeration value="LH">
        <xsd:enumeration value="LI">
        <xsd:enumeration value="LJ">
        <xsd:enumeration value="LK">
        <xsd:enumeration value="LM">
        <xsd:enumeration value="LN">
        <xsd:enumeration value="LO">
        <xsd:enumeration value="LP">
        <xsd:enumeration value="LPA">
        <xsd:enumeration value="LR">
        <xsd:enumeration value="LS">
        <xsd:enumeration value="LTN">
        <xsd:enumeration value="LTR">
        <xsd:enumeration value="LUM">
        <xsd:enumeration value="LUX">
        <xsd:enumeration value="LX">
        <xsd:enumeration value="LY">
        <xsd:enumeration value="M0">
        <xsd:enumeration value="M1">
        <xsd:enumeration value="M2">
        <xsd:enumeration value="M4">
        <xsd:enumeration value="M5">
        <xsd:enumeration value="M7">
        <xsd:enumeration value="M9">
        <xsd:enumeration value="MA">
        <xsd:enumeration value="MAL">
        <xsd:enumeration value="MAM">
        <xsd:enumeration value="MAW">
        <xsd:enumeration value="MB">
        <xsd:enumeration value="MBE">
        <xsd:enumeration value="MBF">
        <xsd:enumeration value="MBR">
        <xsd:enumeration value="MC">
        <xsd:enumeration value="MCU">
        <xsd:enumeration value="MD">
        <xsd:enumeration value="MF">
        <xsd:enumeration value="MGM">
        <xsd:enumeration value="MH">
        <xsd:enumeration value="MHZ">
        <xsd:enumeration value="MI">
        <xsd:enumeration value="MIK">
        <xsd:enumeration value="MIL">
        <xsd:enumeration value="MIN">
        <xsd:enumeration value="MIO">
        <xsd:enumeration value="MIU">
        <xsd:enumeration value="MK">
        <xsd:enumeration value="MLD">
        <xsd:enumeration value="MLT">
        <xsd:enumeration value="MMK">
        <xsd:enumeration value="MMQ">
        <xsd:enumeration value="MMT">
        <xsd:enumeration value="MON">
        <xsd:enumeration value="MPA">
        <xsd:enumeration value="MQ">
        <xsd:enumeration value="MQH">
        <xsd:enumeration value="MQS">
        <xsd:enumeration value="MSK">
        <xsd:enumeration value="MT">
        <xsd:enumeration value="MTK">
        <xsd:enumeration value="MTQ">
        <xsd:enumeration value="MTR">
        <xsd:enumeration value="MTS">
        <xsd:enumeration value="MV">
        <xsd:enumeration value="MVA">
        <xsd:enumeration value="MW">
        <xsd:enumeration value="MWH">
        <xsd:enumeration value="MX">
        <xsd:enumeration value="MY">
        <xsd:enumeration value="MZ">
        <xsd:enumeration value="N1">
        <xsd:enumeration value="N2">
        <xsd:enumeration value="N3">
        <xsd:enumeration value="NA">
        <xsd:enumeration value="NAR">
        <xsd:enumeration value="NB">
        <xsd:enumeration value="NBB">
        <xsd:enumeration value="NC">
        <xsd:enumeration value="NCL">
        <xsd:enumeration value="ND">
        <xsd:enumeration value="NE">
        <xsd:enumeration value="NEW">
        <xsd:enumeration value="NF">
        <xsd:enumeration value="NG">
        <xsd:enumeration value="NH">
        <xsd:enumeration value="NI">
        <xsd:enumeration value="NIU">
        <xsd:enumeration value="NJ">
        <xsd:enumeration value="NL">
        <xsd:enumeration value="NMI">
        <xsd:enumeration value="NMP">
        <xsd:enumeration value="NN">
        <xsd:enumeration value="NPL">
        <xsd:enumeration value="NPR">
        <xsd:enumeration value="NPT">
        <xsd:enumeration value="NQ">
        <xsd:enumeration value="NR">
        <xsd:enumeration value="NRL">
        <xsd:enumeration value="NT">
        <xsd:enumeration value="NTT">
        <xsd:enumeration value="NU">
        <xsd:enumeration value="NV">
        <xsd:enumeration value="NX">
        <xsd:enumeration value="NY">
        <xsd:enumeration value="OA">
        <xsd:enumeration value="OHM">
        <xsd:enumeration value="ON">
        <xsd:enumeration value="ONZ">
        <xsd:enumeration value="OP">
        <xsd:enumeration value="OT">
        <xsd:enumeration value="OZ">
        <xsd:enumeration value="OZA">
        <xsd:enumeration value="OZI">
        <xsd:enumeration value="P0">
        <xsd:enumeration value="P1">
        <xsd:enumeration value="P2">
        <xsd:enumeration value="P3">
        <xsd:enumeration value="P4">
        <xsd:enumeration value="P5">
        <xsd:enumeration value="P6">
        <xsd:enumeration value="P7">
        <xsd:enumeration value="P8">
        <xsd:enumeration value="P9">
        <xsd:enumeration value="PA">
        <xsd:enumeration value="PAL">
        <xsd:enumeration value="PB">
        <xsd:enumeration value="PD">
        <xsd:enumeration value="PE">
        <xsd:enumeration value="PF">
        <xsd:enumeration value="PG">
        <xsd:enumeration value="PGL">
        <xsd:enumeration value="PI">
        <xsd:enumeration value="PK">
        <xsd:enumeration value="PL">
        <xsd:enumeration value="PM">
        <xsd:enumeration value="PN">
        <xsd:enumeration value="PO">
        <xsd:enumeration value="PQ">
        <xsd:enumeration value="PR">
        <xsd:enumeration value="PS">
        <xsd:enumeration value="PT">
        <xsd:enumeration value="PTD">
        <xsd:enumeration value="PTI">
        <xsd:enumeration value="PTL">
        <xsd:enumeration value="PU">
        <xsd:enumeration value="PV">
        <xsd:enumeration value="PW">
        <xsd:enumeration value="PY">
        <xsd:enumeration value="PZ">
        <xsd:enumeration value="Q1">
        <xsd:enumeration value="Q2">
        <xsd:enumeration value="Q3">
        <xsd:enumeration value="Q4">
        <xsd:enumeration value="Q5">
        <xsd:enumeration value="Q6">
        <xsd:enumeration value="Q7">
        <xsd:enumeration value="QA">
        <xsd:enumeration value="QAN">
        <xsd:enumeration value="QB">
        <xsd:enumeration value="QD">
        <xsd:enumeration value="QH">
        <xsd:enumeration value="QK">
        <xsd:enumeration value="QR">
        <xsd:enumeration value="QS">
        <xsd:enumeration value="QT">
        <xsd:enumeration value="QTD">
        <xsd:enumeration value="QTI">
        <xsd:enumeration value="QTL">
        <xsd:enumeration value="QTR">
        <xsd:enumeration value="R1">
        <xsd:enumeration value="R4">
        <xsd:enumeration value="R5">
        <xsd:enumeration value="R6">
        <xsd:enumeration value="R9">
        <xsd:enumeration value="RA">
        <xsd:enumeration value="RD">
        <xsd:enumeration value="RG">
        <xsd:enumeration value="RH">
        <xsd:enumeration value="RK">
        <xsd:enumeration value="RL">
        <xsd:enumeration value="RM">
        <xsd:enumeration value="RN">
        <xsd:enumeration value="RO">
        <xsd:enumeration value="RP">
        <xsd:enumeration value="RPM">
        <xsd:enumeration value="RPS">
        <xsd:enumeration value="RS">
        <xsd:enumeration value="RT">
        <xsd:enumeration value="RU">
        <xsd:enumeration value="S3">
        <xsd:enumeration value="S4">
        <xsd:enumeration value="S5">
        <xsd:enumeration value="S6">
        <xsd:enumeration value="S7">
        <xsd:enumeration value="S8">
        <xsd:enumeration value="SA">
        <xsd:enumeration value="SAN">
        <xsd:enumeration value="SCO">
        <xsd:enumeration value="SCR">
        <xsd:enumeration value="SD">
        <xsd:enumeration value="SE">
        <xsd:enumeration value="SEC">
        <xsd:enumeration value="SET">
        <xsd:enumeration value="SG">
        <xsd:enumeration value="SHT">
        <xsd:enumeration value="SIE">
        <xsd:enumeration value="SK">
        <xsd:enumeration value="SL">
        <xsd:enumeration value="SMI">
        <xsd:enumeration value="SN">
        <xsd:enumeration value="SO">
        <xsd:enumeration value="SP">
        <xsd:enumeration value="SQ">
        <xsd:enumeration value="SR">
        <xsd:enumeration value="SS">
        <xsd:enumeration value="SST">
        <xsd:enumeration value="ST">
        <xsd:enumeration value="STI">
        <xsd:enumeration value="STN">
        <xsd:enumeration value="SV">
        <xsd:enumeration value="SW">
        <xsd:enumeration value="SX">
        <xsd:enumeration value="T0">
        <xsd:enumeration value="T1">
        <xsd:enumeration value="T2">
        <xsd:enumeration value="T3">
        <xsd:enumeration value="T4">
        <xsd:enumeration value="T5">
        <xsd:enumeration value="T6">
        <xsd:enumeration value="T7">
        <xsd:enumeration value="T8">
        <xsd:enumeration value="T9">
        <xsd:enumeration value="TA">
        <xsd:enumeration value="TAH">
        <xsd:enumeration value="TC">
        <xsd:enumeration value="TD">
        <xsd:enumeration value="TE">
        <xsd:enumeration value="TF">
        <xsd:enumeration value="TI">
        <xsd:enumeration value="TJ">
        <xsd:enumeration value="TK">
        <xsd:enumeration value="TL">
        <xsd:enumeration value="TM">
        <xsd:enumeration value="TN">
        <xsd:enumeration value="TNE">
        <xsd:enumeration value="TP">
        <xsd:enumeration value="TPR">
        <xsd:enumeration value="TQ">
        <xsd:enumeration value="TQD">
        <xsd:enumeration value="TR">
        <xsd:enumeration value="TRL">
        <xsd:enumeration value="TS">
        <xsd:enumeration value="TSD">
        <xsd:enumeration value="TSH">
        <xsd:enumeration value="TT">
        <xsd:enumeration value="TU">
        <xsd:enumeration value="TV">
        <xsd:enumeration value="TW">
        <xsd:enumeration value="TY">
        <xsd:enumeration value="U1">
        <xsd:enumeration value="U2">
        <xsd:enumeration value="U3">
        <xsd:enumeration value="U5">
        <xsd:enumeration value="UA">
        <xsd:enumeration value="UB">
        <xsd:enumeration value="UC">
        <xsd:enumeration value="UD">
        <xsd:enumeration value="UE">
        <xsd:enumeration value="UF">
        <xsd:enumeration value="UH">
        <xsd:enumeration value="UL">
        <xsd:enumeration value="UM">
        <xsd:enumeration value="VA">
        <xsd:enumeration value="VC">
        <xsd:enumeration value="VI">
        <xsd:enumeration value="VLT">
        <xsd:enumeration value="VQ">
        <xsd:enumeration value="VS">
        <xsd:enumeration value="VT">
        <xsd:enumeration value="W2">
        <xsd:enumeration value="W4">
        <xsd:enumeration value="WA">
        <xsd:enumeration value="WB">
        <xsd:enumeration value="WCD">
        <xsd:enumeration value="WE">
        <xsd:enumeration value="WEB">
        <xsd:enumeration value="WEE">
        <xsd:enumeration value="WG">
        <xsd:enumeration value="WH">
        <xsd:enumeration value="WHR">
        <xsd:enumeration value="WI">
        <xsd:enumeration value="WM">
        <xsd:enumeration value="WR">
        <xsd:enumeration value="WSD">
        <xsd:enumeration value="WTT">
        <xsd:enumeration value="WW">
        <xsd:enumeration value="X1">
        <xsd:enumeration value="YDK">
        <xsd:enumeration value="YDQ">
        <xsd:enumeration value="YL">
        <xsd:enumeration value="YRD">
        <xsd:enumeration value="YT">
        <xsd:enumeration value="Z1">
        <xsd:enumeration value="Z2">
        <xsd:enumeration value="Z3">
        <xsd:enumeration value="Z4">
        <xsd:enumeration value="Z5">
        <xsd:enumeration value="Z6">
        <xsd:enumeration value="Z8">
        <xsd:enumeration value="ZP">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: UOMType

UOMType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( UOMCoded[UOMCodeType] , UOMCodedOther[xsd:string]? )

    Description: UOMType represents the base unit of measure.

    Elements:

    • UOMCoded - is used to define the unit of measure.
    • UOMCodedOther - is used to provide a non-standard UOMCode. This element is mandatory if the value of UOMCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="UOMType">
    <xsd:sequence>
        <xsd:element name="UOMCoded" type="UOMCodeType">
        <xsd:element minOccurs="0" name="UOMCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ValidityDatesType

ValidityDatesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( StartDate[xsd:dateTime] , EndDate[xsd:dateTime] )

    Description: ValidityDatesType is used to specify a start and end date of a period in which the element they are used is valid.

    Elements:

    • StartDate - specifies the first point in time on which validity/effectivity occurs.
    • EndDate - specifies the last point in time for which a validity/effectivity occurs.

[^]Code Fragment

    <xsd:complexType name="ValidityDatesType">
    <xsd:sequence>
        <xsd:element name="StartDate" type="xsd:dateTime">
        <xsd:element name="EndDate" type="xsd:dateTime">
    </xsd:sequence>
</xsd:complexType>


complexType definition: AdjustmentDetailType

AdjustmentDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( SequenceNum[xsd:int]? , AdjustmentReasonCoded[AdjustmentReasonCodeType] , AdjustmentReasonCodedOther[xsd:string]? , AdjustmentDate[xsd:dateTime]? , AdjustmentAmount[core:MonetaryValueType]? , AdjustmentPercent[core:PercentType]? , AdjustmentDetailNote[xsd:string]? )

    Description: AdjustmentDetailType contains the information relevant to making monetary adjustments.

    Elements:

    • SequenceNum - uniquely identifies the adjustment detail element.
    • AdjustmentReasonCoded - is a reason code for adjustment.
    • AdjustmentReasonCodedOther - is used to provide a non-standard AdjustmentReasonCode. This element is mandatory if the value of AdjustmentReasonCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • AdjustmentDate - is the date on which the adjustment was made.
    • AdjustmentAmount - contains a monetary amount of adjustment.
    • AdjustmentPercent - contains a percent of adjustment.
    • AdjustmentDetailNote - describes any free-form text pertinent to the Adjustment. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.

[^]Code Fragment

    <xsd:complexType name="AdjustmentDetailType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="SequenceNum" type="xsd:int">
        <xsd:element name="AdjustmentReasonCoded" type="AdjustmentReasonCodeType">
        <xsd:element minOccurs="0" name="AdjustmentReasonCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="AdjustmentDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="AdjustmentAmount" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="AdjustmentPercent" type="core:PercentType">
        <xsd:element minOccurs="0" name="AdjustmentDetailNote" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: AdjustmentReasonCodeType

AdjustmentReasonCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:
    This code identifies the reason for adjustment. This codelist is derived from EDIFACT 4465 (Adjustment reason description code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • AgreedSettlement
    • BelowSpecificationGoods - Goods of inferior quality.
    • DamagedGoods
    • ShortDelivery
    • PriceQuery
    • ProofOfDeliveryRequired
    • PaymentOnAccount
    • ReturnableContainerChargeIncluded
    • InvoiceError
    • CostsForDraft - Cost of draft has been deducted from payment.
    • BankCharges - Bank charges have been deducted from payment.
    • AgentCommission - Agent commission has been deducted from payment.
    • CounterClaim - Buyer claims an existing (financial) obligation from the seller which (partly) offsets the outstanding invoice(s).
    • WrongDelivery - Delivery not according to specifications.
    • GoodsReturnedToAgent - Goods returned to agent.
    • GoodsPartlyReturned - Goods partly returned.
    • TransportDamage - Goods damaged in transit.
    • GoodsOnConsignment - Buyer does not accept invoice(s) charge as it relates to the goods where the ownership remains with the seller until sold.
    • TradeDiscount - Trade discount deducted from payment.
    • DeductionForLateDelivery - Penalty amount deducted for later delivery.
    • AdvertisingCosts - Advertising costs deducted from payment.
    • CustomsDuties - Customs duties deducted from payment.
    • TelephoneAndPostalCosts - Telephone and postal costs deducted from payment.
    • RepairCosts - Repair costs deducted from payment.
    • AttorneyFees - Attorney fees deducted from payment.
    • Taxes - Taxes deducted from payment.
    • ReclaimedDeduction - Buyer reclaims an unspecified deduction from the invoice(s) (to be) paid.
    • SeeSeparateAdvice - Buyer or seller refers to separate correspondence a related shipment(s) and/or invoice(s) and/or a payment(s).
    • BuyerRefusedToTakeDelivery - Buyer refused to take delivery.
    • DirectPaymentToSeller - Buyer states to have paid to seller.
    • BuyerDisagreesWithDueDate - Buyer disagrees with due date.
    • GoodsNotDelivered - Buyer has not received the goods.
    • LateDelivery - Goods delivered too late.
    • QuotedAsPaidToYou - Factor informs the seller that a certain invoice( paid by the buyer directly to the seller.
    • GoodsReturned - Buyer returned the goods to seller.
    • InvoiceNotReceived - Buyer claims he did not receive the invoice for w payment is requested.
    • CreditNoteToDebtorOrNotToUs - Factor informs the seller that he did not receive of a credit note sent to the buyer.
    • DeductedBonus - Buyer has/will deduct a bonus he is entitled to f payment.
    • DeductedDiscount - Buyer has/will deduct the discount he is entitled from the payment.
    • DeductedFreightCosts - Buyer has/will deduct freight costs from the payment
    • DeductionAgainstOtherInvoices - Deduction against invoices already settled.
    • CreditBalance - Buyer makes use of existing credit balance(s) to (partly) the outstanding invoice(s).
    • ReasonUnknown - Factor informs the seller that the reason of a commercial dispute raised by the buyer is unknown
    • AwaitingMessageFromSeller - Buyer or factor are waiting for a (reply) message the seller before a commercial dispute can be set
    • DebitNoteToSeller - Buyer issued debit note to seller.
    • DiscountBeyondTerms - Buyer has taken a discount larger than the discount terms agreed with the seller.
    • SeeBuyersLetter - See correspondence from buyer.
    • AllowanceOrChargeError - Error made by seller in the amount of allowance/charge
    • SubstituteProduct - Product delivered not fully according to specification.
    • TermsOfSaleError - Terms of sale not according to purchase order.
    • RequiredDataMissing - A message sent by buyer to seller or by seller to buyer. did not contain data required to take action/decision
    • WrongInvoice - Invoice issued to wrong party.
    • DuplicateInvoice - Invoice sent twice.
    • WeightError - Weight not in accordance with the order.
    • AdditionalChargeNotAuthorized - Additional charge not authorised.
    • IncorrectDiscount - Buyer states that calculated discount on the invoice(s) is wrongly calculated.
    • PriceChange - Price has been changed.
    • Variation - The adjustment is a variation from an agreed value
    • Chargeback - Balance of one or more items charged back to seller
    • Offset - Allocation of one or more debit items to one or more credit items or vice-versa.
    • IndirectPayment - Payment in settlement of an invoice has been made to a party other than the designated creditor.
    • FinancialReassignment - Previously assigned invoice/credit note is being reassigned.
    • ReinstatementOfChargebackOrOffset - Reversal or cancellation of a chargeback and/or offset relating to an incorrect balance.
    • ExpectingNewTerms - Buyer expects that seller revises the terms of payment of an invoice.
    • SettlementToAgent - Invoice has been/to be paid to seller's agent.
    • CashDiscount - An adjustment has been made due to the application of a cash discount.
    • DelcredereCosts - Costs deducted from a total amount to pay for the services of central payment.
    • EarlyPaymentAllowanceAdjustment - Adjustment results from the application of an early payment allowance.
    • IncorrectDueDateForMonetaryAmount - Adjustment has been made because an incorrect due date was referred to with regard to the monetary amount
    • WrongMonetaryAmountResultingFromIncorrectFreeGoods - quantity Adjustment has been made because of a wrong monetary amount resulting from an incorrect free goods quantity
    • RackOrShelfReplenishmentServiceByASupplier - Adjustment due to the replenishment of the racks or shelves by a supplier.
    • TemporarySpecialPromotion - Adjustment due to a temporary special promotion.
    • DifferenceInTaxRate - Adjustment due to a difference in tax rate.
    • Other - Other.

[^]Code Fragment

    <xsd:simpleType name="AdjustmentReasonCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="AgreedSettlement">
        <xsd:enumeration value="BelowSpecificationGoods">
        <xsd:enumeration value="DamagedGoods">
        <xsd:enumeration value="ShortDelivery">
        <xsd:enumeration value="PriceQuery">
        <xsd:enumeration value="ProofOfDeliveryRequired">
        <xsd:enumeration value="PaymentOnAccount">
        <xsd:enumeration value="ReturnableContainerChargeIncluded">
        <xsd:enumeration value="InvoiceError">
        <xsd:enumeration value="CostsForDraft">
        <xsd:enumeration value="BankCharges">
        <xsd:enumeration value="AgentCommission">
        <xsd:enumeration value="CounterClaim">
        <xsd:enumeration value="WrongDelivery">
        <xsd:enumeration value="GoodsReturnedToAgent">
        <xsd:enumeration value="GoodsPartlyReturned">
        <xsd:enumeration value="TransportDamage">
        <xsd:enumeration value="GoodsOnConsignment">
        <xsd:enumeration value="TradeDiscount">
        <xsd:enumeration value="DeductionForLateDelivery">
        <xsd:enumeration value="AdvertisingCosts">
        <xsd:enumeration value="CustomsDuties">
        <xsd:enumeration value="TelephoneAndPostalCosts">
        <xsd:enumeration value="RepairCosts">
        <xsd:enumeration value="AttorneyFees">
        <xsd:enumeration value="Taxes">
        <xsd:enumeration value="ReclaimedDeduction">
        <xsd:enumeration value="SeeSeparateAdvice">
        <xsd:enumeration value="BuyerRefusedToTakeDelivery">
        <xsd:enumeration value="DirectPaymentToSeller">
        <xsd:enumeration value="BuyerDisagreesWithDueDate">
        <xsd:enumeration value="GoodsNotDelivered">
        <xsd:enumeration value="LateDelivery">
        <xsd:enumeration value="QuotedAsPaidToYou">
        <xsd:enumeration value="GoodsReturned">
        <xsd:enumeration value="InvoiceNotReceived">
        <xsd:enumeration value="CreditNoteToDebtorOrNotToUs">
        <xsd:enumeration value="DeductedBonus">
        <xsd:enumeration value="DeductedDiscount">
        <xsd:enumeration value="DeductedFreightCosts">
        <xsd:enumeration value="DeductionAgainstOtherInvoices">
        <xsd:enumeration value="CreditBalance">
        <xsd:enumeration value="ReasonUnknown">
        <xsd:enumeration value="AwaitingMessageFromSeller">
        <xsd:enumeration value="DebitNoteToSeller">
        <xsd:enumeration value="DiscountBeyondTerms">
        <xsd:enumeration value="SeeBuyersLetter">
        <xsd:enumeration value="AllowanceOrChargeError">
        <xsd:enumeration value="SubstituteProduct">
        <xsd:enumeration value="TermsOfSaleError">
        <xsd:enumeration value="RequiredDataMissing">
        <xsd:enumeration value="WrongInvoice">
        <xsd:enumeration value="DuplicateInvoice">
        <xsd:enumeration value="WeightError">
        <xsd:enumeration value="AdditionalChargeNotAuthorized">
        <xsd:enumeration value="IncorrectDiscount">
        <xsd:enumeration value="PriceChange">
        <xsd:enumeration value="Variation">
        <xsd:enumeration value="Chargeback">
        <xsd:enumeration value="Offset">
        <xsd:enumeration value="IndirectPayment">
        <xsd:enumeration value="FinancialReassignment">
        <xsd:enumeration value="ReinstatementOfChargebackOrOffset">
        <xsd:enumeration value="ExpectingNewTerms">
        <xsd:enumeration value="SettlementToAgent">
        <xsd:enumeration value="CashDiscount">
        <xsd:enumeration value="DelcredereCosts">
        <xsd:enumeration value="EarlyPaymentAllowanceAdjustment">
        <xsd:enumeration value="IncorrectDueDateForMonetaryAmount">
        <xsd:enumeration value="WrongMonetaryAmountResultingFromIncorrectFreeGoods">
        <xsd:enumeration value="RackOrShelfReplenishmentServiceByASupplier">
        <xsd:enumeration value="TemporarySpecialPromotion">
        <xsd:enumeration value="DifferenceInTaxRate">
        <xsd:enumeration value="Other">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: AuthorizationReferenceType

AuthorizationReferenceType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( AuthorizationNumber[core:ReferenceType] , AuthorizationAssignedBy[core:PartyType]? )

    Description: AuthorizationReferenceType contains information for the authorization for the purchase order.

    Elements:

    • AuthorizationNumber - holds the authorization number used when a third party needs to authorize the validity of a purchase order.
    • AuthorizationAssignedBy - contains information relating to the party issuing the authorization number.

[^]Code Fragment

    <xsd:complexType name="AuthorizationReferenceType">
    <xsd:sequence>
        <xsd:element name="AuthorizationNumber" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="AuthorizationAssignedBy" type="core:PartyType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: ChargeRegulationCodeType

ChargeRegulationCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:
    This code identifies the party responsible for the payment of fees.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Payer
    • Payee
    • ShareEqually
    • Other

[^]Code Fragment

    <xsd:simpleType name="ChargeRegulationCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Payer">
        <xsd:enumeration value="Payee">
        <xsd:enumeration value="ShareEqually">
        <xsd:enumeration value="Other">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: CompanyType

CompanyType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: Extends: core:PartyType

      Append:( IndustrySectorCoded[IndustrySectorCodeType]? , IndustrySectorCodedOther[xsd:string]? )

    Description: CompanyType contains information pertinent to identifying a company. This element extends the Party definition with an Industry sector code.

    Elements:

    • IndustrySectorCoded - identifies the industry sector for a given company.
    • IndustrySectorCodedOther - is used to provide a non-standard IndustrySectorCode. This element is mandatory if the value of IndustrySectorCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="CompanyType">
    <xsd:complexContent>
        <xsd:extension base="core:PartyType">
            <xsd:sequence>
                <xsd:element minOccurs="0" name="IndustrySectorCoded" type="IndustrySectorCodeType">
                <xsd:element minOccurs="0" name="IndustrySectorCodedOther" type="xsd:string">
            </xsd:sequence>
        </xsd:extension>
    </xsd:complexContent>
</xsd:complexType>


Complex Types:

AdjustmentDetailType
ListOfAdjustmentDetailType
AuthorizationReferenceType
CompanyType
CostAllocationType
CountryRequirementType
ListOfCountryRequirementType
CountrySpecificRequirementsType
CurrencyAvailabilityCheckListType
EncryptedFieldType
ListOfEncryptedFieldType
EncryptedInfoType
ExceptionQuantitiesType
FeeType
ListOfFeeType
FinancialChargesAllocationType
FinancialInstitutionCodedType
ListOfFinancialInstitutionCodedType
FXAmountsType
FXDatesType
FXIdentificationDataType
FXRateRequestDetailType
ListOfFXRateRequestDetailType
FXRateRequestHeaderType
FXRateRequestSummaryType
FXRateRequestType
FXRateResponseDetailType
ListOfFXRateResponseDetailType
FXRateResponseHeaderType
FXRateResponseType
IndicativeRateDetailType
InvoiceBaseItemDetailType
InvoiceDatesType
InvoiceDetailType
InvoiceHeaderType
InvoiceItemDetailType
ListOfInvoiceItemDetailType
InvoiceMediumType
InvoicePartyType
InvoicePaymentStatusType
InvoicePricingDetailType
InvoicePurposeType
InvoiceReferencesType
InvoiceResponseDetailType
ListOfInvoiceResponseDetailType
InvoiceResponseHeaderType
InvoiceResponseType
InvoiceSummaryType
InvoiceTotalsType
InvoiceType
InvoiceTypeType
InvoicingDetailType
ListOfInvoicingDetailType
LegalReportingInformationType
LineItemAdjustmentType
ListOfLineItemAdjustmentType
OtherInvoicePartiesType
PayerPartyType
PaymentDatesType
ListOfPaymentDocumentDetailType
PaymentExceptionType
ListOfPaymentExceptionType
PaymentPartyType
PaymentRequestAcknDetailType
ListOfPaymentRequestAcknDetailType
PaymentRequestAcknHeaderType
PaymentRequestAcknowledgmentType
PaymentRequestDetailType
ListOfPaymentRequestDetailType
PaymentRequestHeaderType
PaymentRequestPartyType
PaymentRequestSummaryType
PaymentRequestType
PaymentStatusRequestDetailType
ListOfPaymentStatusRequestDetailType
PaymentStatusRequestHeaderType
PaymentStatusRequestSummaryType
PaymentStatusRequestType
PaymentStatusResponseDetailType
ListOfPaymentStatusResponseDetailType
PaymentStatusResponseHeaderType
PaymentStatusResponseType
RelatedInvoiceRefType
ListOfRelatedInvoiceRefType
RemittanceAdviceDetailType
RemittanceAdviceHeaderType
RemittanceAdviceType
RemittanceAdviceSummaryType
SpecificRequirementType
ListOfSpecificRequirementType
SpotRateDetailType
SubsidiaryType
ListOfSubsidiaryType
TraceTypeType


simpleType definition: ComputationalMethodCodeType

ComputationalMethodCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Multiply - Self explanatory.
    • Divide - Self explanatory.
    • Other - Self explanatory.

[^]Code Fragment

    <xsd:simpleType name="ComputationalMethodCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Multiply">
        <xsd:enumeration value="Divide">
        <xsd:enumeration value="Other">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: CostAllocationType

CostAllocationType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( CostAllocationNumber[core:ReferenceType] , WorkBreakdownStructure[xsd:string]? , FixedAsset[xsd:string]? )

    Description: CostAllocationType contains information on the cost allocation.

    Elements:

    • CostAllocationNumber - holds the cost allocation number that the invoice will be charged against.
    • WorkBreakdownStructure - holds information relating to the work breakdown.
    • FixedAsset - is used to identify if the invoice is for a fixed asset or a consumable.

[^]Code Fragment

    <xsd:complexType name="CostAllocationType">
    <xsd:sequence>
        <xsd:element name="CostAllocationNumber" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="WorkBreakdownStructure" type="xsd:string">
        <xsd:element minOccurs="0" name="FixedAsset" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: CountryRequirementType

CountryRequirementType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( Country[core:CountryType] , ListOfSpecificRequirement[ListOfSpecificRequirementType] )

    Description: CountryRequirementType allows for any other requirements specific to a country that are not already explicitly stated.

    Elements:

    • Country - identifies the country that requires the information identified in the ListOfSpecificRequirement element.
    • ListOfSpecificRequirement - contains all information required by the country.

[^]Code Fragment

    <xsd:complexType name="CountryRequirementType">
    <xsd:sequence>
        <xsd:element name="Country" type="core:CountryType">
        <xsd:element name="ListOfSpecificRequirement" type="ListOfSpecificRequirementType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: CountrySpecificRequirementsType

CountrySpecificRequirementsType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( NotaFiscalType[xsd:string]? , PaymentReferenceNumber[xsd:string]? , OtherCountryRequirements[ListOfCountryRequirementType]? )

    Description: CountrySpecificRequirementsType contains references and other information that are required in an invoice by some countries.

    Elements:

    • NotaFiscalType - is an invoice specific field legally required by Brazil.
    • PaymentReferenceNumber - is an invoice specific field legally required by Scandanavia.
    • OtherCountryRequirements -

[^]Code Fragment

    <xsd:complexType name="CountrySpecificRequirementsType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="NotaFiscalType" type="xsd:string">
        <xsd:element minOccurs="0" name="PaymentReferenceNumber" type="xsd:string">
        <xsd:element minOccurs="0" name="OtherCountryRequirements" type="ListOfCountryRequirementType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: CurrencyAvailabilityCheckListType

CurrencyAvailabilityCheckListType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( FundsTransferIndicator[xsd:boolean]? , RemoteCheckIndicator[xsd:boolean]? , OnsiteCheckIndicator[xsd:boolean]? , ACHIndicator[xsd:boolean]? , RemitCurrencyIndicator[xsd:boolean]? , OtherPaymentServiceNote[xsd:string]? )

    Description: CurrencyAvailabilityCheckListType indicates multiple types of payment services available for the exchange currency.

    Elements:

    • FundsTransferIndicator - indicates whether payment services for funds transfer is available.
    • RemoteCheckIndicator - indicates whether payment services for remote checks is available.
    • OnsiteCheckIndicator - indicates whether payment services for onsite checks is available.
    • ACHIndicator - indicates whether payment services for ACH is available.
    • RemitCurrencyIndicator - indicates whether payment services for remit currency is available.
    • OtherPaymentServiceNote - contains a general note field to capture details pertaining to other payment services provided by the financial institution.

[^]Code Fragment

    <xsd:complexType name="CurrencyAvailabilityCheckListType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="FundsTransferIndicator" type="xsd:boolean">
        <xsd:element minOccurs="0" name="RemoteCheckIndicator" type="xsd:boolean">
        <xsd:element minOccurs="0" name="OnsiteCheckIndicator" type="xsd:boolean">
        <xsd:element minOccurs="0" name="ACHIndicator" type="xsd:boolean">
        <xsd:element minOccurs="0" name="RemitCurrencyIndicator" type="xsd:boolean">
        <xsd:element minOccurs="0" name="OtherPaymentServiceNote" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: EncryptedFieldType

EncryptedFieldType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( Sequence[xsd:int]? , EncryptedData[xsd:string] )

    Description: EncryptedFieldType contains a generic structure to store encrypted data.

    Elements:

    • Sequence - contains a counter to identify a specific encrypted field in a given set of encrypted fields.
    • EncryptedData - contains the encrypted data.

[^]Code Fragment

    <xsd:complexType name="EncryptedFieldType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="Sequence" type="xsd:int">
        <xsd:element name="EncryptedData" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: EncryptedInfoType

EncryptedInfoType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( CertificateAuthority[xsd:string]? , ListOfEncryptedField[ListOfEncryptedFieldType] )

    Description: EncryptedInfoType contains a placeholder to store customer or bank specific encrypted fields.

    Elements:

    • CertificateAuthority - contains the payer's certificate of authority or digital signature which will be used by the financial institution to verify the origins of the document and validate the payment.
    • ListOfEncryptedField - is a a list of encrypted fields

[^]Code Fragment

    <xsd:complexType name="EncryptedInfoType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="CertificateAuthority" type="xsd:string">
        <xsd:element name="ListOfEncryptedField" type="ListOfEncryptedFieldType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ExceptionQuantitiesType

ExceptionQuantitiesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OrderedQuantity[core:QuantityType]? , DamagedQuantity[core:QuantityType]? , UnusableQuantity[core:QuantityType]? , ReturnedQuantity[core:QuantityType]? , ShippedToDateQuantity[core:QuantityType]? )

    Description: ExceptionQuantitiesType informs why the invoiced quantity is different to the ordered.

    Elements:

    • OrderedQuantity - holds the quantity ordered.
    • DamagedQuantity - holds the quantity received that was damaged.
    • UnusableQuantity - holds the quantity received that was unusable.
    • ReturnedQuantity - holds the quantity that has been returned.
    • ShippedToDateQuantity - holds the total quantity shipped for the line item (partial deliveries).

[^]Code Fragment

    <xsd:complexType name="ExceptionQuantitiesType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="OrderedQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="DamagedQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="UnusableQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="ReturnedQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="ShippedToDateQuantity" type="core:QuantityType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: FeeType

FeeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( FeeType[xsd:string]? , FeeValue[core:MonetaryValueType]? )

    Description: FeeType holds the description and amount elements for the fee.

    Elements:

    • FeeType - contains the description of the Fee.
    • FeeValue - contains the amount of the Fee described in FeeType.

[^]Code Fragment

    <xsd:complexType name="FeeType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="FeeType" type="xsd:string">
        <xsd:element minOccurs="0" name="FeeValue" type="core:MonetaryValueType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: FinancialChargesAllocationType

FinancialChargesAllocationType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ChargeRegulationCoded[ChargeRegulationCodeType] , ChargeRegulationCodedOther[xsd:string]? , FeeAmount[core:MonetaryValueType]? , ChargeAccount[core:AccountDetailType]? , ChargeFinancialInstitution[core:FinancialInstitutionType]? )

    Description: FinancialChargesAllocationType contains information pertaining to how payment of fees will be allocated between partners.

    Elements:

    • ChargeRegulationCoded - specifies the party responsible for the payment of fees.
    • ChargeRegulationCodedOther - is used to provide a non-standard ChargeRegulationCode. This element is mandatory if the value of ChargeRegulationCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • FeeAmount - indicates the monetary amount of the fee.
    • ChargeAccount - specifies the bank account from which the fees should be paid.
    • ChargeFinancialInstitution - identifies the financial institution and branch that hold the account specified by the ChargeAccount element.

[^]Code Fragment

    <xsd:complexType name="FinancialChargesAllocationType">
    <xsd:sequence>
        <xsd:element name="ChargeRegulationCoded" type="ChargeRegulationCodeType">
        <xsd:element minOccurs="0" name="ChargeRegulationCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="FeeAmount" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="ChargeAccount" type="core:AccountDetailType">
        <xsd:element minOccurs="0" name="ChargeFinancialInstitution" type="core:FinancialInstitutionType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: FinancialInstitutionCodedType

FinancialInstitutionCodedType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( FinancialInstitutionQualifierCoded[core:PartyRoleCodeType] , FinancialInstitutionQualifierCodedOther[xsd:string]? , FIAccount[core:FIAccountType] )

    Description: FinancialInstitutionCodedType is a container for financial institution information and a qualifier describing the function of the institution.

    Elements:

    • FinancialInstitutionQualifierCoded -
    • FinancialInstitutionQualifierCodedOther -
    • FIAccount - provides the details of the financial institution.

[^]Code Fragment

    <xsd:complexType name="FinancialInstitutionCodedType">
    <xsd:sequence>
        <xsd:element name="FinancialInstitutionQualifierCoded" type="core:PartyRoleCodeType">
        <xsd:element minOccurs="0" name="FinancialInstitutionQualifierCodedOther" type="xsd:string">
        <xsd:element name="FIAccount" type="core:FIAccountType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: FXAmountsType

FXAmountsType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( SettlementAmount[core:MonetaryValueType]? , DebitAmount[core:MonetaryValueType]? , CreditAmount[core:MonetaryValueType]? )

    Description: FXAmountsType contains all amount data relevant to the spot rate quote.

    Elements:

    • SettlementAmount - contains the transaction settlement amount.
    • DebitAmount - contains the amount to be debited from the payers account.
    • CreditAmount - contains the amount to be credited to the payees account.

[^]Code Fragment

    <xsd:complexType name="FXAmountsType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="SettlementAmount" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="DebitAmount" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="CreditAmount" type="core:MonetaryValueType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: FXDatesType

FXDatesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( FXValueDate[xsd:dateTime]? , RemittanceDate[xsd:dateTime]? , QuoteExpirationDate[xsd:dateTime]? , ListOfDateCoded[core:ListOfDateCodedType]? )

    Description: FXDatesType contains dates relevant to the spot rate quote.

    Elements:

    • FXValueDate - specifies the effective date for the transaction.
    • RemittanceDate - specifies the date the payment will be made.
    • QuoteExpirationDate - specifies the date and time of the expiration of the FX quote.
    • ListOfDateCoded - contains a list of DateCoded which is composed of a date and a date qualifier. This allows users to specify dates pertinent to the rate quote that is not explicitly defined in the document.

[^]Code Fragment

    <xsd:complexType name="FXDatesType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="FXValueDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="RemittanceDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="QuoteExpirationDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ListOfDateCoded" type="core:ListOfDateCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: FXIdentificationDataType

FXIdentificationDataType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OriginatingFinancialInstitution[core:FIAccountDetailType]? , CardInfo[core:CardInfoType]? , PayeeParty[core:PartyType]? )

    Description: FXIdentificationDataType contains data relevant to identifying the parties involved in the spot rate transaction.

    Elements:

    • OriginatingFinancialInstitution - contains information pertinent to identifying a financial institution and an account within the financial institution that will be debited.
    • CardInfo - contains details for payments made via credit card. This includes credit card number, card type, card holder name, expiration date, and other pertinent information.
    • PayeeParty - describes the beneficiary of the payment and their identification number.

[^]Code Fragment

    <xsd:complexType name="FXIdentificationDataType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="OriginatingFinancialInstitution" type="core:FIAccountDetailType">
        <xsd:element minOccurs="0" name="CardInfo" type="core:CardInfoType">
        <xsd:element minOccurs="0" name="PayeeParty" type="core:PartyType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: FXQuoteTypeCodeType

FXQuoteTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Spot
    • Forward
    • Indicated
    • Negotiated
    • Committed
    • Other

[^]Code Fragment

    <xsd:simpleType name="FXQuoteTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Spot">
        <xsd:enumeration value="Forward">
        <xsd:enumeration value="Indicated">
        <xsd:enumeration value="Negotiated">
        <xsd:enumeration value="Committed">
        <xsd:enumeration value="Other">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: FXRateRequestDetailType

FXRateRequestDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( SequenceNumber[xsd:int]? , RateQuoteID[core:ReferenceType]? , ReferenceCurrency[core:CurrencyType] , TargetCurrency[core:CurrencyType] , SettlementAmount[core:MonetaryValueType]? , DebitAmount[core:MonetaryValueType]? , CreditAmount[core:MonetaryValueType]? , OriginatingFinancialInstitution[core:FIAccountType]? , CardInfo[core:CardInfoType]? , ComputationalMethodCoded[ComputationalMethodCodeType]? , ComputationalMethodCodedOther[xsd:string]? , FXQuoteTypeCoded[FXQuoteTypeCodeType]? , FXQuoteTypeCodedOther[xsd:string]? , ListOfReference[core:ListOfReferenceType]? , PayeeParty[core:PartyType]? , PayerParty[PayerPartyType]? , FXRateRequestNote[xsd:string]? )

    Description: FXRateRequestDetailType contains detailed information related to the FX rates being requested.

    Elements:

    • SequenceNumber - contains the sequence number for the rate quote request.
    • RateQuoteID - identifies the unique user identifier for the FXRateRequest.
    • ReferenceCurrency - specifies the reference currency of the rate of exchange.
    • TargetCurrency - indicates the target currency of the rate of exchange.
    • SettlementAmount - contains the monetary amount to be transacted.
    • DebitAmount - contains the amount to be debited from the payers account.
    • CreditAmount - contains the amount to be credited to the payees account.
    • OriginatingFinancialInstitution - contains financial details relating to the customer's deposit account.
    • CardInfo - contains details for payments made via credit card. This includes credit card number, card type, card holder name, expiration date, and other pertinent information.
    • ComputationalMethodCoded - indicates the means by which the requester would like to have the rate quoted.
    • ComputationalMethodCodedOther - is used to provide a non-standard ComputationalMethodCode. This element is mandatory if the value of ComputationalMethodCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • FXQuoteTypeCoded - contains the coded FXRate quote type.
    • FXQuoteTypeCodedOther - is used to provide a non-standard FXQuoteTypeCode. This element is mandatory if the value of FXQuoteTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • ListOfReference - contains additional customer defined reference information.
    • PayeeParty - describes the beneficiary of the payment and their identification number.
    • PayerParty - describes who is responsible for payment. This is assumed to also be the sender of the document. The PayerParty includes an optional CertificateAuthority field to hold the payer's digital signature or certificate of authority.
    • FXRateRequestNote - contains any free-form text pertinent for other FXRateRequest related information This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.

[^]Code Fragment

    <xsd:complexType name="FXRateRequestDetailType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="SequenceNumber" type="xsd:int">
        <xsd:element minOccurs="0" name="RateQuoteID" type="core:ReferenceType">
        <xsd:element name="ReferenceCurrency" type="core:CurrencyType">
        <xsd:element name="TargetCurrency" type="core:CurrencyType">
        <xsd:element minOccurs="0" name="SettlementAmount" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="DebitAmount" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="CreditAmount" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="OriginatingFinancialInstitution" type="core:FIAccountType">
        <xsd:element minOccurs="0" name="CardInfo" type="core:CardInfoType">
        <xsd:element minOccurs="0" name="ComputationalMethodCoded" type="ComputationalMethodCodeType">
        <xsd:element minOccurs="0" name="ComputationalMethodCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="FXQuoteTypeCoded" type="FXQuoteTypeCodeType">
        <xsd:element minOccurs="0" name="FXQuoteTypeCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfReference" type="core:ListOfReferenceType">
        <xsd:element minOccurs="0" name="PayeeParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="PayerParty" type="PayerPartyType">
        <xsd:element minOccurs="0" name="FXRateRequestNote" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: FXRateRequestHeaderType

FXRateRequestHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( FXRateRequestID[xsd:string] , FXRateRequestIssueDate[xsd:dateTime] , Language[core:LanguageType] , PaymentMeanCoded[core:PaymentMeanCodeType]? , PaymentMeanCodedOther[xsd:string]? , PayerParty[PayerPartyType]? , FinancialServicesParty[PayerPartyType]? , IndicativeIndicator[xsd:boolean] , GeneralNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? )

    Description: FXRateRequestHeaderType contains all header-related data associated with the FXRateRequest document.

    Elements:

    • FXRateRequestID - specifies the unique identifier for the FXRateRequest document.
    • FXRateRequestIssueDate - indicates the date the FXRateRequest document is transmitted.
    • Language - identifies the language of the FXRateRequest.
    • PaymentMeanCoded - indicates the intended method of payment.
    • PaymentMeanCodedOther - is used to provide a non-standard PaymentMeanCode. This element is mandatory if the value of PaymentMeanCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • PayerParty - contains information to identify the payer. PayerParty includes an optional CertificateAuthority field to hold the payer's digital signature or certificate of authority.
    • FinancialServicesParty - describes the sender of the document. This is usually assumed to be the financial institution. This element includes an optional CertificateAuthority field to hold the sender's digital signature or certificate of authority.
    • IndicativeIndicator - specifies whether or not the request is for an indicative rate quote. If TRUE, then the detail section of the FXRateRequest document is not required.
    • GeneralNote - contains any free-form text pertinent to the entire FXRateRequest This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.

[^]Code Fragment

    <xsd:complexType name="FXRateRequestHeaderType">
    <xsd:sequence>
        <xsd:element name="FXRateRequestID" type="xsd:string">
        <xsd:element name="FXRateRequestIssueDate" type="xsd:dateTime">
        <xsd:element name="Language" type="core:LanguageType">
        <xsd:element minOccurs="0" name="PaymentMeanCoded" type="core:PaymentMeanCodeType">
        <xsd:element minOccurs="0" name="PaymentMeanCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="PayerParty" type="PayerPartyType">
        <xsd:element minOccurs="0" name="FinancialServicesParty" type="PayerPartyType">
        <xsd:element name="IndicativeIndicator" type="xsd:boolean">
        <xsd:element minOccurs="0" name="GeneralNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: FXRateRequestSummaryType

FXRateRequestSummaryType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( NumberOfFXRateRequest[xsd:int]? )

    Description: FXRateRequestSummaryType contains summary related information for the FXRateRequest document.

    Elements:

    • NumberOfFXRateRequest - contains the total number of FXRates requested in this document.

[^]Code Fragment

    <xsd:complexType name="FXRateRequestSummaryType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="NumberOfFXRateRequest" type="xsd:int">
    </xsd:sequence>
</xsd:complexType>


complexType definition: FXRateRequestType

FXRateRequestType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( FXRateRequestHeader[FXRateRequestHeaderType] , ListOfFXRateRequestDetail[ListOfFXRateRequestDetailType]? , FXRateRequestSummary[FXRateRequestSummaryType]? )

    Description: FXRateRequestType enables payers to retrieve a foreign exchange quote from a financial institution. The payer can initiate a Foreign Exchange Request to get a rate quote and quote reference number on two specific currency pairs. The payer will review the quote information and then decide whether this quote is satisfactory. This will allow the payer the capability to pay for goods and services in a foreign currency when they perform a Payment Request.

    Elements:

    • FXRateRequestHeader - contains all header-related data associated with the FXRateRequest document.
    • ListOfFXRateRequestDetail - contains a list of FXRateRequestDetails. Details are optional in the case where an indicative FX rate is being requested. This is specified by the IndicativeIndicator in the header.
    • FXRateRequestSummary - contains summary related information for the FXRateRequest document.

[^]Code Fragment

    <xsd:complexType name="FXRateRequestType">
    <xsd:sequence>
        <xsd:element name="FXRateRequestHeader" type="FXRateRequestHeaderType">
        <xsd:element minOccurs="0" name="ListOfFXRateRequestDetail" type="ListOfFXRateRequestDetailType">
        <xsd:element minOccurs="0" name="FXRateRequestSummary" type="FXRateRequestSummaryType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: FXRateResponseDetailType

FXRateResponseDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( SequenceNumber[xsd:int]? , RateQuoteID[core:ReferenceType]? , ReferenceCurrency[core:CurrencyType] , TargetCurrency[core:CurrencyType]? , ComputationalMethodCoded[ComputationalMethodCodeType]? , ComputationalMethodCodedOther[xsd:string]? , FXRate[core:Decimal19_9Type] , InverseFXRate[core:Decimal19_9Type]? , PayerParty[PayerPartyType]? , ( IndicativeRateDetail[IndicativeRateDetailType] | SpotRateDetail[SpotRateDetailType] ) , ListOfPaymentReference[core:ListOfReferenceType]? , ListOfOtherPaymentInfo[core:ListOfNameValuePairType]? , ListOfPaymentException[ListOfPaymentExceptionType]? , CertificateAuthority[xsd:string]? , FXRateResponseNote[xsd:string]? )

    Description: FXRateResponseDetailType contains detailed information pertaining to the FXRateResponse. This includes payment document information containing payment-related information at the line item level.

    Elements:

    • SequenceNumber - tracks the payment document associated with the FXRateResponse in the case where the payment request contains more than one payment document.
    • RateQuoteID - identifies the unique user identifier for the FXRateRequest.
    • ReferenceCurrency - contains the reference currency of the rate of exchange (from currency).
    • TargetCurrency - contains the reference currency of the rate of exchange (to currency).
    • ComputationalMethodCoded - contains the rules for the conversion.
    • ComputationalMethodCodedOther - is used to provide a non-standard ComputationalMethodCode. This element is mandatory if the value of ComputationalMethodCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • FXRate - contains the FX rate quoted (Direct/Multiply).
    • InverseFXRate - contains the FX rate quoted (Indirect/Divide).
    • PayerParty - describes who is responsible for payment. This is usually assumed to be the sender of the request document. The PayerParty includes an optional CertificateAuthority field to hold the payer's digital signature or certificate of authority.
    • IndicativeRateDetail - contains fields and elements specific to the indicate rate quote. This structure is provided when the IndicativeIndicator is true.
    • SpotRateDetail - contains fields and elements specific to the spot rate quote. This structure is provided when the IndicativeIndicator is false.
    • ListOfPaymentReference - contains payment related reference detail such as invoice numbers, purchase order numbers, dates etc.
    • ListOfOtherPaymentInfo - contains a list of additional customer providing payment information.
    • ListOfPaymentException - contains a list of exception codes relating to the FXRate request document.
    • CertificateAuthority - specifies an element to contain the digital signature of the financial institution.
    • FXRateResponseNote - contains any free-form text pertinent to the entire FXRateResponse. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.

[^]Code Fragment

    <xsd:complexType name="FXRateResponseDetailType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="SequenceNumber" type="xsd:int">
        <xsd:element minOccurs="0" name="RateQuoteID" type="core:ReferenceType">
        <xsd:element name="ReferenceCurrency" type="core:CurrencyType">
        <xsd:element minOccurs="0" name="TargetCurrency" type="core:CurrencyType">
        <xsd:element minOccurs="0" name="ComputationalMethodCoded" type="ComputationalMethodCodeType">
        <xsd:element minOccurs="0" name="ComputationalMethodCodedOther" type="xsd:string">
        <xsd:element name="FXRate" type="core:Decimal19_9Type">
        <xsd:element minOccurs="0" name="InverseFXRate" type="core:Decimal19_9Type">
        <xsd:element minOccurs="0" name="PayerParty" type="PayerPartyType">
        <xsd:choice>
            <xsd:element name="IndicativeRateDetail" type="IndicativeRateDetailType">
            <xsd:element name="SpotRateDetail" type="SpotRateDetailType">
        </xsd:choice>
        <xsd:element minOccurs="0" name="ListOfPaymentReference" type="core:ListOfReferenceType">
        <xsd:element minOccurs="0" name="ListOfOtherPaymentInfo" type="core:ListOfNameValuePairType">
        <xsd:element minOccurs="0" name="ListOfPaymentException" type="ListOfPaymentExceptionType">
        <xsd:element minOccurs="0" name="CertificateAuthority" type="xsd:string">
        <xsd:element minOccurs="0" name="FXRateResponseNote" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: FXRateResponseHeaderType

FXRateResponseHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( FXRateResponseID[xsd:string] , FXRateResponseIssueDate[xsd:dateTime] , FXRateRequestID[core:ReferenceType] , Language[core:LanguageType] , PayerParty[PayerPartyType]? , FinancialServicesParty[PayerPartyType]? , IndicativeIndicator[xsd:boolean] , GeneralNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? )

    Description: FXRateResponseHeaderType contains all data associated with the FXRateResponse document.

    Elements:

    • FXRateResponseID - specifies the unique identifier for the FXRateResponse document.
    • FXRateResponseIssueDate - indicates the date the FXRateResponse document is transmitted.
    • FXRateRequestID - contains the unique identifier for the FXRateRequest document.
    • Language - identifies the language of the FXRateResponse.
    • PayerParty - contains information to identify the payer. PayerParty includes an optional CertificateAuthority field to hold the payer's digital signature or certificate of authority.
    • FinancialServicesParty - describes the sender of the document. This is usually assumed to be the financial institution. This element includes an optional CertificateAuthority field to hold the sender's digital signature or certificate of authority.
    • IndicativeIndicator - contains a boolean indicator to specify whether or not the FXRateResponse contains indicative rate quotes.
    • GeneralNote - contains any free-form text pertinent to the entire FXRateResponse This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.

[^]Code Fragment

    <xsd:complexType name="FXRateResponseHeaderType">
    <xsd:sequence>
        <xsd:element name="FXRateResponseID" type="xsd:string">
        <xsd:element name="FXRateResponseIssueDate" type="xsd:dateTime">
        <xsd:element name="FXRateRequestID" type="core:ReferenceType">
        <xsd:element name="Language" type="core:LanguageType">
        <xsd:element minOccurs="0" name="PayerParty" type="PayerPartyType">
        <xsd:element minOccurs="0" name="FinancialServicesParty" type="PayerPartyType">
        <xsd:element name="IndicativeIndicator" type="xsd:boolean">
        <xsd:element minOccurs="0" name="GeneralNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: FXRateResponseType

FXRateResponseType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( FXRateResponseHeader[FXRateResponseHeaderType] , ListOfFXRateResponseDetail[ListOfFXRateResponseDetailType] , FXRateResponseSummary[FXRateRequestSummaryType]? )

    Description: FXRateResponseType . The Financial Institution sends this document to the Payer to provide a foreign exchange rate quote to obtain the currency needed to settle the payment.

    Elements:

    • FXRateResponseHeader - contains all data associated with the FXRateResponse document.
    • ListOfFXRateResponseDetail - contains a list of FXRateRequestDetail for a FX rate quote.
    • FXRateResponseSummary - contains summary related information for the FXRateResponse document.

[^]Code Fragment

    <xsd:complexType name="FXRateResponseType">
    <xsd:sequence>
        <xsd:element name="FXRateResponseHeader" type="FXRateResponseHeaderType">
        <xsd:element name="ListOfFXRateResponseDetail" type="ListOfFXRateResponseDetailType">
        <xsd:element minOccurs="0" name="FXRateResponseSummary" type="FXRateRequestSummaryType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: FXTransactionTypeCodeType

FXTransactionTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Spot
    • Forward
    • Future
    • Option
    • Other

[^]Code Fragment

    <xsd:simpleType name="FXTransactionTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Spot">
        <xsd:enumeration value="Forward">
        <xsd:enumeration value="Future">
        <xsd:enumeration value="Option">
        <xsd:enumeration value="Other">
    </xsd:restriction>
</xsd:simpleType>


Global Elements (Document Roots):

FXRateRequest
FXRateResponse
Invoice
InvoiceResponse
PaymentRequest
PaymentRequestAcknowledgment
PaymentStatusRequest
PaymentStatusResponse
RemittanceAdvice


complexType definition: IndicativeRateDetailType

IndicativeRateDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( CurrencyDecimalPlaces[xsd:int]? , CurrencyAvailabilityCheckList[CurrencyAvailabilityCheckListType]? , IndicativeRateRetrievedDate[xsd:dateTime]? , CurrentDateTime[xsd:dateTime]? )

    Description: IndicativeRateDetailType contains fields and elements specific to the indicate rate quote. This structure is provided when the IndicativeIndicator is true.

    Elements:

    • CurrencyDecimalPlaces - contains the number of decimal places that will be used to quote the currency.
    • CurrencyAvailabilityCheckList - indicates multiple types of payment services available for the exchange currency.
    • IndicativeRateRetrievedDate - contains the date and time that the indicative rate was quoted.
    • CurrentDateTime - contains the current date and time.

[^]Code Fragment

    <xsd:complexType name="IndicativeRateDetailType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="CurrencyDecimalPlaces" type="xsd:int">
        <xsd:element minOccurs="0" name="CurrencyAvailabilityCheckList" type="CurrencyAvailabilityCheckListType">
        <xsd:element minOccurs="0" name="IndicativeRateRetrievedDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="CurrentDateTime" type="xsd:dateTime">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: IndustrySectorCodeType

IndustrySectorCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:
    This code identifies the industry sector for a given company. This code list is derived from EDIFACT 7293(Sector/subject identification qualifier)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • ConstructionIndustry
    • GovernmentalExportConditions
    • ChemicalIndustry
    • ElectronicIndustry
    • AutomotiveIndustry
    • SteelIndustry
    • Factoring - Factoring industry.
    • DefenceIndustry - A code to identify the defence industry.
    • AlcoholBeverageIndustry - Alcohol beverage industry.
    • Police - Applies to police formalities.
    • Customs - Applies to customs regulations.
    • HealthRegulation - Applies to health regulation.
    • BalanceOfPayments - Balance of payments.
    • NationalLegislation - National regulations specified by the relevant government.
    • Government - To identify requirements and conditions applicable to government activity.
    • StandardsImplementation - Subject refers to standards implementation.
    • Insurance - The information is related to insurance.
    • CreditInquiry - Applies to credit inquiry.
    • GeneralRequest - Applies to a general request.
    • PaymentTerms - Applies to payment terms.
    • Other - Other.

[^]Code Fragment

    <xsd:simpleType name="IndustrySectorCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="ConstructionIndustry">
        <xsd:enumeration value="GovernmentalExportConditions">
        <xsd:enumeration value="ChemicalIndustry">
        <xsd:enumeration value="ElectronicIndustry">
        <xsd:enumeration value="AutomotiveIndustry">
        <xsd:enumeration value="SteelIndustry">
        <xsd:enumeration value="Factoring">
        <xsd:enumeration value="DefenceIndustry">
        <xsd:enumeration value="AlcoholBeverageIndustry">
        <xsd:enumeration value="Police">
        <xsd:enumeration value="Customs">
        <xsd:enumeration value="HealthRegulation">
        <xsd:enumeration value="BalanceOfPayments">
        <xsd:enumeration value="NationalLegislation">
        <xsd:enumeration value="Government">
        <xsd:enumeration value="StandardsImplementation">
        <xsd:enumeration value="Insurance">
        <xsd:enumeration value="CreditInquiry">
        <xsd:enumeration value="GeneralRequest">
        <xsd:enumeration value="PaymentTerms">
        <xsd:enumeration value="Other">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: InvoiceBaseItemDetailType

InvoiceBaseItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( LineItemNum[core:LineItemNumType] , LineItemType[core:LineItemTypeType]? , ParentItemNumber[core:LineItemNumberReferenceType]? , ItemIdentifiers[core:ItemIdentifiersType]? , ListOfDimension[core:ListOfDimensionType]? , InvoicedQuantity[core:QuantityType] , ExceptionQuantities[ExceptionQuantitiesType]? , ListOfQuantityCoded[core:ListOfQuantityCodedType]? , LineItemReferences[InvoiceReferencesType]? , CountryOfOrigin[core:CountryType]? , CountryOfDestination[core:CountryType]? , ListOfPartyCoded[core:ListOfPartyCodedType]? )

    Description: InvoiceBaseItemDetailType contains the identifying and descriptive information for the line items in the Invoice.

    Elements:

    • LineItemNum - is a set of numbers uniquely identifying the line item for the number. In the case where the seller's system splits a line item number into 2 line items, the buyer item number will remain the same for both line items, but the seller item number will be different.
    • LineItemType - identifies whether the line item is a component group (consists of other line items), a typical line item, or a textual line item.
    • ParentItemNumber - identifies the line item that groups this and other line items. This is done using LineItemNumberReference, which specifies the number of the parent line item and whether this reference is the Buyer or Seller's number. LineItemNumberReference is a string content model of datatype integer that contains an attribute to specify whether the ParentItemNumber is a Seller or Buyer number, with the default being Buyer. This value references the parent item represented a group.
    • ItemIdentifiers - details all of the part numbers assigned to the item.
    • ListOfDimension - lists one or more quantitative measurements of the item.
    • InvoicedQuantity - contains the total amount of the line item pertaining to the document.
    • ExceptionQuantities - identifies if the invoiced quantity is different to the ordered quantity.
    • ListOfQuantityCoded - specifies any other quantities not explicitly stated.
    • LineItemReferences - contains external references that are pertinent to the invoice at line item level if different to the header level.
    • CountryOfOrigin - specifies the country code for the country in which the line item was manufactured.
    • CountryOfDestination - specifies the country code for the country in which the delivery is finally received.
    • ListOfPartyCoded - specifies any other parties associated with the line item that are not already explicitly stated.

[^]Code Fragment

    <xsd:complexType name="InvoiceBaseItemDetailType">
    <xsd:sequence>
        <xsd:element name="LineItemNum" type="core:LineItemNumType">
        <xsd:element minOccurs="0" name="LineItemType" type="core:LineItemTypeType">
        <xsd:element minOccurs="0" name="ParentItemNumber" type="core:LineItemNumberReferenceType">
        <xsd:element minOccurs="0" name="ItemIdentifiers" type="core:ItemIdentifiersType">
        <xsd:element minOccurs="0" name="ListOfDimension" type="core:ListOfDimensionType">
        <xsd:element name="InvoicedQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="ExceptionQuantities" type="ExceptionQuantitiesType">
        <xsd:element minOccurs="0" name="ListOfQuantityCoded" type="core:ListOfQuantityCodedType">
        <xsd:element minOccurs="0" name="LineItemReferences" type="InvoiceReferencesType">
        <xsd:element minOccurs="0" name="CountryOfOrigin" type="core:CountryType">
        <xsd:element minOccurs="0" name="CountryOfDestination" type="core:CountryType">
        <xsd:element minOccurs="0" name="ListOfPartyCoded" type="core:ListOfPartyCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: InvoiceDatesType

InvoiceDatesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( InvoiceDueDate[xsd:dateTime] , ExpectedShipDate[xsd:dateTime]? , ActualShipDate[xsd:dateTime]? , ExpectedDeliveryDate[xsd:dateTime]? , ActualDeliveryDate[xsd:dateTime]? , ReceiptDate[xsd:dateTime]? , TaxPeriod[core:ValidityDatesType]? , InvoicingPeriod[core:ValidityDatesType]? , ListOfOtherInvoiceDates[core:ListOfDateCodedType]? )

    Description: InvoiceDatesType contains pertinent dates for the invoice. These may be overwritten at a lower level within the structure InvoiceDetail.

    Elements:

    • InvoiceDueDate - holds the date that the invoice is due for payment.
    • ExpectedShipDate - holds the date the goods are expected to be shipped.
    • ActualShipDate - holds the date the goods were shipped.
    • ExpectedDeliveryDate - holds the date the goods are expected to be shipped.
    • ActualDeliveryDate - holds the date the goods were shipped.
    • ReceiptDate - holds the date the goods were received at their destination.
    • TaxPeriod - contains the tax period for the invoice.
    • InvoicingPeriod - contains the period for which the invoice is issued.
    • ListOfOtherInvoiceDates - contains all other dates for the invoice that have not been explicitly defined as the content of other elements.

[^]Code Fragment

    <xsd:complexType name="InvoiceDatesType">
    <xsd:sequence>
        <xsd:element name="InvoiceDueDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ExpectedShipDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ActualShipDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ExpectedDeliveryDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ActualDeliveryDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ReceiptDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="TaxPeriod" type="core:ValidityDatesType">
        <xsd:element minOccurs="0" name="InvoicingPeriod" type="core:ValidityDatesType">
        <xsd:element minOccurs="0" name="ListOfOtherInvoiceDates" type="core:ListOfDateCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: InvoiceDetailType

InvoiceDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ListOfInvoiceItemDetail[ListOfInvoiceItemDetailType] , ListOfPackageDetail[core:ListOfPackageDetailType]? )

    Description: InvoiceDetailType contains the line item and package details of the Invoice.

    Elements:

    • ListOfInvoiceItemDetail - contains a list of line items for the Invoice.
    • ListOfPackageDetail - holds a list of packaging information at the item detail level.

[^]Code Fragment

    <xsd:complexType name="InvoiceDetailType">
    <xsd:sequence>
        <xsd:element name="ListOfInvoiceItemDetail" type="ListOfInvoiceItemDetailType">
        <xsd:element minOccurs="0" name="ListOfPackageDetail" type="core:ListOfPackageDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: InvoiceHeaderType

InvoiceHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( InvoiceNumber[xsd:string] , InvoiceIssueDate[xsd:dateTime] , TaxPointDate[xsd:dateTime]? , InvoiceReferences[InvoiceReferencesType]* , InvoicePurpose[InvoicePurposeType] , InvoiceType[InvoiceTypeType] , InvoiceCurrency[core:CurrencyType]? , PaymentCurrency[core:CurrencyType]? , ListOfRateOfExchangeDetail[core:ListOfRateOfExchangeDetailType]? , TaxAccountingCurrency[core:CurrencyType]? , InvoiceLanguage[core:LanguageType] , TaxReference[core:TaxReferenceType]* , InvoiceMedium[InvoiceMediumType]? , InvoiceDates[InvoiceDatesType]? , InvoiceParty[InvoicePartyType] , ListOfTransportRouting[core:ListOfTransportRoutingType]? , InvoiceTermsOfDelivery[core:TermsOfDeliveryType]? , InvoicePaymentInstructions[core:PaymentInstructionsType]? , InvoiceAllowancesOrCharges[core:ListOfAllowOrChargeType]? , CountrySpecificRequirements[CountrySpecificRequirementsType]? , InvoiceHeaderNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? , ListOfAttachment[core:ListOfAttachmentType]? )

    Description: InvoiceHeaderType contains the header information of the Invoice.

    Elements:

    • InvoiceNumber - holds the unique number that identifies the Invoice, typically according to the system that generated the Invoice.
    • InvoiceIssueDate - holds a time stamp provided by the application that created the Invoice document.
    • TaxPointDate - is used to specify the tax point date for tax accounting purpose. This element is mandatory if the tax point date is not the same as the InvoiceIssueDate.
    • InvoiceReferences - contains external references to the Invoice that are important to the processing and use of the Invoice.
    • InvoicePurpose - defines the purpose of the Invoice.
    • InvoiceType - identifies the type of the Invoice being transmitted.
    • InvoiceCurrency - identifies the default currency of the Invoice. This may be overwritten at a lower level within the structure InvoiceDetail.
    • PaymentCurrency - identifies the currency for the payment of the Invoice. This element is used when the payment currency is not the same as the InvoiceCurrency.
    • ListOfRateOfExchangeDetail - contains one or more elements detailing information on the rate of exchange between currencies.
    • TaxAccountingCurrency - identifies the currency to be used for tax accounting purposes. This element is mandatory when the tax accounting currency is not the same as the InvoiceCurrency.
    • InvoiceLanguage - identifies the language of the Invoice.
    • TaxReference - is a reference to the tax information relevant to the Invoice.
    • InvoiceMedium - is the method of communicating the Invoice.
    • InvoiceDates - contains pertinent dates for the Invoice. These may be overwritten at a lower level within the structure InvoiceDetail.
    • InvoiceParty - contains information on the parties to the Invoice, including unique ID's and address information.
    • ListOfTransportRouting - provides information on the movement of the goods, including details on carrier(s) equipment locations and dates.
    • InvoiceTermsOfDelivery - contains information on the terms of delivery for the Invoice.
    • InvoicePaymentInstructions - contains information on the payment instructions for the Invoice.
    • InvoiceAllowancesOrCharges - contains a list of the allowances, discounts or charges applicable for the whole invoice.
    • CountrySpecificRequirements - contains references and other information that are required in an invoice by some countries.
    • InvoiceHeaderNote - contains any free form text pertinent to the entire invoice or to the Invoice message itself. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. Such notes may include the line item text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line, or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfNameValueSet - is used to holds a collection of values qualified by names. The values contianed in this element should be agreed upon by trading partners.
    • ListOfAttachment - holds a list of attachments applicable to the entire Invoice, or to a large part of the invoice it describes.

[^]Code Fragment

    <xsd:complexType name="InvoiceHeaderType">
    <xsd:sequence>
        <xsd:element name="InvoiceNumber" type="xsd:string">
        <xsd:element name="InvoiceIssueDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="TaxPointDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="InvoiceReferences" type="InvoiceReferencesType">
        <xsd:element name="InvoicePurpose" type="InvoicePurposeType">
        <xsd:element name="InvoiceType" type="InvoiceTypeType">
        <xsd:element minOccurs="0" name="InvoiceCurrency" type="core:CurrencyType">
        <xsd:element minOccurs="0" name="PaymentCurrency" type="core:CurrencyType">
        <xsd:element minOccurs="0" name="ListOfRateOfExchangeDetail" type="core:ListOfRateOfExchangeDetailType">
        <xsd:element minOccurs="0" name="TaxAccountingCurrency" type="core:CurrencyType">
        <xsd:element name="InvoiceLanguage" type="core:LanguageType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="TaxReference" type="core:TaxReferenceType">
        <xsd:element minOccurs="0" name="InvoiceMedium" type="InvoiceMediumType">
        <xsd:element minOccurs="0" name="InvoiceDates" type="InvoiceDatesType">
        <xsd:element name="InvoiceParty" type="InvoicePartyType">
        <xsd:element minOccurs="0" name="ListOfTransportRouting" type="core:ListOfTransportRoutingType">
        <xsd:element minOccurs="0" name="InvoiceTermsOfDelivery" type="core:TermsOfDeliveryType">
        <xsd:element minOccurs="0" name="InvoicePaymentInstructions" type="core:PaymentInstructionsType">
        <xsd:element minOccurs="0" name="InvoiceAllowancesOrCharges" type="core:ListOfAllowOrChargeType">
        <xsd:element minOccurs="0" name="CountrySpecificRequirements" type="CountrySpecificRequirementsType">
        <xsd:element minOccurs="0" name="InvoiceHeaderNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
        <xsd:element minOccurs="0" name="ListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: InvoiceItemDetailType

InvoiceItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( InvoiceBaseItemDetail[InvoiceBaseItemDetailType] , InvoicePricingDetail[InvoicePricingDetailType] , LineItemDates[InvoiceDatesType]? , OtherInvoiceParties[OtherInvoicePartiesType]? , DeliveryDetail[core:DeliveryDetailType]? , LineItemNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? , LineItemAttachments[core:ListOfAttachmentType]? )

    Description: InvoiceItemDetailType contains the item detail information for theInvoice.

    Elements:

    • InvoiceBaseItemDetail - contains the identifying and descriptive information for the line items in the Invoice.
    • InvoicePricingDetail - contains the information on the basic unit prices for the line item.
    • LineItemDates - contains pertinent dates for the line item.
    • OtherInvoiceParties - contains information on other parties for the line item, including unique ID's and address information.
    • DeliveryDetail - is used to specify the scheduling information for a distinct set of ShipFrom party, ShipTo party, and transport information for the line item.
    • LineItemNote - describes any free-form text pertinent to the line item. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. Such notes may include the line item text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line, or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfNameValueSet - is used to holds a collection of values qualified by names. The values contained in this element should be agreed upon by trading partners.
    • LineItemAttachments - holds a list of attachments applicable to the line item, or to a large part of the line item it describes.

[^]Code Fragment

    <xsd:complexType name="InvoiceItemDetailType">
    <xsd:sequence>
        <xsd:element name="InvoiceBaseItemDetail" type="InvoiceBaseItemDetailType">
        <xsd:element name="InvoicePricingDetail" type="InvoicePricingDetailType">
        <xsd:element minOccurs="0" name="LineItemDates" type="InvoiceDatesType">
        <xsd:element minOccurs="0" name="OtherInvoiceParties" type="OtherInvoicePartiesType">
        <xsd:element minOccurs="0" name="DeliveryDetail" type="core:DeliveryDetailType">
        <xsd:element minOccurs="0" name="LineItemNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
        <xsd:element minOccurs="0" name="LineItemAttachments" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: InvoiceMediumCodeType

InvoiceMediumCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • ByMail - Invoice By Mail
    • Electronically - Invoice Electronically
    • Supplemental - Supplemental

[^]Code Fragment

    <xsd:simpleType name="InvoiceMediumCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="ByMail">
        <xsd:enumeration value="Electronically">
        <xsd:enumeration value="Supplemental">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: InvoiceMediumType

InvoiceMediumType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( InvoiceMediumCoded[InvoiceMediumCodeType]? , InvoiceMediumCodedOther[xsd:string]? )

    Description: InvoiceMediumType is the method of communicating the invoice.

    Elements:

    • InvoiceMediumCoded - is a code specifying the communication medium used for the invoice.
    • InvoiceMediumCodedOther - is used to provide a non-standard InvoiceMediumCode. This element is mandatory if the value of InvoiceMediumCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="InvoiceMediumType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="InvoiceMediumCoded" type="InvoiceMediumCodeType">
        <xsd:element minOccurs="0" name="InvoiceMediumCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: InvoicePartyType

InvoicePartyType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( BuyerParty[core:PartyType] , BuyerTax[core:TaxType]? , SellerParty[core:PartyType] , ShipToParty[core:PartyType]? , BillToParty[core:PartyType]? , RemitToParty[core:PartyType]? , RemitToTax[core:TaxType]? , ShipFromParty[core:PartyType]? , SoldToParty[core:PartyType]? , ListOfPartyCoded[core:ListOfPartyCodedType]? )

    Description: InvoicePartyType contains information on the parties to the Invoice, including unique ID's and address information.

    Elements:

    • BuyerParty - contains party information for the party buying the goods.
    • BuyerTax - identifies the tax levy information for the party buying the goods.
    • SellerParty - contains party information for the party selling the goods.
    • ShipToParty - contains party information for the party to which the items on the invoice are to be or have been shipped.
    • BillToParty - holds information relating to the party who will receive the bill for the goods.
    • RemitToParty - holds information relating to the party that is to be paid.
    • RemitToTax - identifies the tax levy information for the party that is to be paid.
    • ShipFromParty - contains party information identifying the location from which the items are to be shipped.
    • SoldToParty - contains party information identifying the location where the items were sold.
    • ListOfPartyCoded - contains all other parties for the Invoice not explicitly stated as the content of other elements.

[^]Code Fragment

    <xsd:complexType name="InvoicePartyType">
    <xsd:sequence>
        <xsd:element name="BuyerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="BuyerTax" type="core:TaxType">
        <xsd:element name="SellerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ShipToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="BillToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="RemitToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="RemitToTax" type="core:TaxType">
        <xsd:element minOccurs="0" name="ShipFromParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="SoldToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ListOfPartyCoded" type="core:ListOfPartyCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: InvoicePaymentStatusType

InvoicePaymentStatusType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( InvoicePaymentStatusCoded[core:ActualPaymentStatusCodeType]? , InvoicePaymentStatusCodedOther[xsd:string]? )

    Description: InvoicePaymentStatusType contains information relating to the payment status of the invoice.

    Elements:

    • InvoicePaymentStatusCoded - is a code specifying the status of the invoice payment.
    • InvoicePaymentStatusCodedOther - is used to provide a non-standard ActualPaymentStatusCode. This element is mandatory if the value of InvoicePaymentStatusCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="InvoicePaymentStatusType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="InvoicePaymentStatusCoded" type="core:ActualPaymentStatusCodeType">
        <xsd:element minOccurs="0" name="InvoicePaymentStatusCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: InvoicePricingDetailType

InvoicePricingDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: Extends: core:PricingDetailType

      Append:( PaymentCurrencyTotalValue[core:MonetaryValueType]? , TaxAccountingSubTotalValue[core:MonetaryValueType]? , ActualPaymentStatus[core:ActualPaymentStatusType]? )

    Description: InvoicePricingDetailType contains the information on the basic unit prices for the line item.

    Elements:

    • PaymentCurrencyTotalValue - holds the total value in the payment currency for the line item. This element is used when the PaymentCurrency is not the same as the InvoiceCurrency.
    • TaxAccountingSubTotalValue - holds the equivalent value to the line item TotalValue in the TaxAccountingCurrency.
    • ActualPaymentStatus - contains information relating to the payment status of the line item.

[^]Code Fragment

    <xsd:complexType name="InvoicePricingDetailType">
    <xsd:complexContent>
        <xsd:extension base="core:PricingDetailType">
            <xsd:sequence>
                <xsd:element minOccurs="0" name="PaymentCurrencyTotalValue" type="core:MonetaryValueType">
                <xsd:element minOccurs="0" name="TaxAccountingSubTotalValue" type="core:MonetaryValueType">
                <xsd:element minOccurs="0" name="ActualPaymentStatus" type="core:ActualPaymentStatusType">
            </xsd:sequence>
        </xsd:extension>
    </xsd:complexContent>
</xsd:complexType>


simpleType definition: InvoicePurposeCodeType

InvoicePurposeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:
    This code identifies the purpose of the Invoice message. This is a subset code list derived from EDIFACT 1225 (Message Function, Coded) and X12 353 (Transaction Set Purpose Code) and 587 (Acknowledgement Type Code)

    Content: Restriction of base type core:PurposeCodeType

    Enumerated List:

    • Other - Custom Code
    • Original
    • Duplicate

[^]Code Fragment

    <xsd:simpleType name="InvoicePurposeCodeType">
    <xsd:restriction base="core:PurposeCodeType">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Original">
        <xsd:enumeration value="Duplicate">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: InvoicePurposeType

InvoicePurposeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( InvoicePurposeCoded[InvoicePurposeCodeType] , InvoicePurposeCodedOther[xsd:string]? )

    Description: InvoicePurposeType defines the purpose of the invoice.

    Elements:

    • InvoicePurposeCoded - is a code specifying the purpose of the invoice. This is a subset of PurposeCode.
    • InvoicePurposeCodedOther - is used to provide a non-standard InvoicePurposeCode. This element is mandatory if the value of InvoicePurposeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="InvoicePurposeType">
    <xsd:sequence>
        <xsd:element name="InvoicePurposeCoded" type="InvoicePurposeCodeType">
        <xsd:element minOccurs="0" name="InvoicePurposeCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: InvoiceReferencesType

InvoiceReferencesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PurchaseOrderReference[core:PurchaseOrderReferenceType]? , ContractReference[core:ContractType]? , AccountNumber[core:ReferenceType]? , ProformaInvoiceNumber[core:ReferenceType]? , ASNNumber[core:ReferenceType]? , PriceListNumber[core:ReferenceType]? , PriceListVersionNumber[core:ReferenceType]? , BuyersCatalogNumber[core:ReferenceType]? , BillOfLadingNumber[core:ReferenceType]? , AirWayBillNumber[core:ReferenceType]? , LetterOfCreditNumber[core:ReferenceType]? , AuthorizationReference[AuthorizationReferenceType]? , DeliveryNoteNumber[core:ReferenceType]? , CostAllocation[CostAllocationType]? , ListOfRelatedInvoiceRef[ListOfRelatedInvoiceRefType]? , OtherInvoiceReferences[core:ListOfReferenceCodedType]? )

    Description: InvoiceReferencesType contains external references to the Invoice that are important to the processing and use of the Invoice.

    Elements:

    • PurchaseOrderReference - contains information relevant to the purchase order the invoice is issued against.
    • ContractReference - contains the contract number which the purchase order is referencing.
    • AccountNumber - holds the buyers account code with the supplier.
    • ProformaInvoiceNumber - holds the reference number for the proforma invoice.
    • ASNNumber - holds the ASN or despatch advice number.
    • PriceListNumber - holds the reference number of the price list.
    • PriceListVersionNumber - holds the version number of the price list.
    • BuyersCatalogNumber - holds the catalog number of the buyer.
    • BillOfLadingNumber - holds the bill of lading number for the invoice.
    • AirWayBillNumber - holds the air waybill number of the invoice.
    • LetterOfCreditNumber - holds the number of the letter of credit for the invoice.
    • AuthorizationReference - contains information for the authorization for the purchase order.
    • DeliveryNoteNumber - contains the references for the delivery note.
    • CostAllocation - contains information on the cost allocation.
    • ListOfRelatedInvoiceRef - contains a list of other invoices related to this invoice or InvoiceDetail.
    • OtherInvoiceReferences - contains all other references for the Invoice not explicitly stated as the content of other elements.

[^]Code Fragment

    <xsd:complexType name="InvoiceReferencesType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="PurchaseOrderReference" type="core:PurchaseOrderReferenceType">
        <xsd:element minOccurs="0" name="ContractReference" type="core:ContractType">
        <xsd:element minOccurs="0" name="AccountNumber" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="ProformaInvoiceNumber" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="ASNNumber" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="PriceListNumber" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="PriceListVersionNumber" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="BuyersCatalogNumber" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="BillOfLadingNumber" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="AirWayBillNumber" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="LetterOfCreditNumber" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="AuthorizationReference" type="AuthorizationReferenceType">
        <xsd:element minOccurs="0" name="DeliveryNoteNumber" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="CostAllocation" type="CostAllocationType">
        <xsd:element minOccurs="0" name="ListOfRelatedInvoiceRef" type="ListOfRelatedInvoiceRefType">
        <xsd:element minOccurs="0" name="OtherInvoiceReferences" type="core:ListOfReferenceCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: InvoiceResponseDetailType

InvoiceResponseDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( InvoiceResponseCoded[core:BasicResponseCodeType]? , InvoiceResponseCodedOther[xsd:string]? , LineItemNum[core:LineItemNumType] , LineItemType[core:LineItemTypeType]? , ParentItemNumber[core:LineItemNumberReferenceType]? , ItemIdentifiers[core:ItemIdentifiersType]? , ListOfDimension[core:ListOfDimensionType]? , InvoicedQuantity[core:QuantityType]? , ExceptionQuantities[ExceptionQuantitiesType]? , ListOfQuantityCoded[core:ListOfQuantityCodedType]? , LineItemReferences[InvoiceReferencesType]? , CountryOfOrigin[core:CountryType]? , CountryOfDestination[core:CountryType]? , ListOfPartyCoded[core:ListOfPartyCodedType]? , InvoiceDetailAmountDue[core:MonetaryValueType]? , InvoiceDetailAmountToBePaid[core:MonetaryValueType]? , TotalLineItemAdjustmentAmount[core:MonetaryValueType]? , ListOfAdjustmentDetail[ListOfAdjustmentDetailType]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ErrorInfo[core:ErrorInfoType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? , ListOfAttachment[core:ListOfAttachmentType]? )

    Description: InvoiceResponseDetailType contains the line item details of the invoice response.

    Elements:

    • InvoiceResponseCoded - is the response code. The invoice item can be rejected or accepted by the InvoiceResponse.
    • InvoiceResponseCodedOther - is used to provide a non-standard BasicResponseCode. This element is mandatory if the value of InvoiceResponseCoded is 'Other'. These codes should not contain white space unless absolutely necessary
    • LineItemNum - identifies the line item number from the invoice that the detail is responding to.
    • LineItemType - identifies whether the line item is a component group (consists of other line items), a typical line item, or a textual line item.
    • ParentItemNumber - identifies the line item that groups this and other line items. This is done using LineItemNumberReference, which specifies the number of the parent line item and whether this reference is the Buyer or Seller's number. LineItemNumberReference is a string content model of datatype integer that contains an attribute to specify whether the ParentItemNumber is a Seller or Buyer number, with the default being Buyer. This value references the parent item represented a group.
    • ItemIdentifiers - details all of the part numbers assigned to the item.
    • ListOfDimension - lists one or more quantitative measurements of the item.
    • InvoicedQuantity - contains the total amount of the line item pertaining to the document.
    • ExceptionQuantities - identifies if invoiced quantity is different to the ordered quantity.
    • ListOfQuantityCoded - specifies any other quantities not explicitly stated.
    • LineItemReferences - contains external references that are pertinent to the invoice at line item level if different to the header level.
    • CountryOfOrigin - specifies the country code for the country in which the line item was manufactured.
    • CountryOfDestination - specifies the country code for the country in which the delivery is finally received.
    • ListOfPartyCoded - specifies any other parties associated with the line item that are not already explicitly stated.
    • InvoiceDetailAmountDue -
    • InvoiceDetailAmountToBePaid -
    • TotalLineItemAdjustmentAmount -
    • ListOfAdjustmentDetail -
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. Such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents. Can also be used to contain the document being responded to.
    • ErrorInfo - contains any error information related to the processing of the item in the invoice.
    • ListOfNameValueSet - is used to hold a collection of values qualified by names. The values contained in this element should be agreed upon by trading partners.
    • ListOfAttachment - holds a list of attachments applicable to the entire InvoiceResponse, or to a large part of the InvoiceResponse it describes.

[^]Code Fragment

    <xsd:complexType name="InvoiceResponseDetailType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="InvoiceResponseCoded" type="core:BasicResponseCodeType">
        <xsd:element minOccurs="0" name="InvoiceResponseCodedOther" type="xsd:string">
        <xsd:element name="LineItemNum" type="core:LineItemNumType">
        <xsd:element minOccurs="0" name="LineItemType" type="core:LineItemTypeType">
        <xsd:element minOccurs="0" name="ParentItemNumber" type="core:LineItemNumberReferenceType">
        <xsd:element minOccurs="0" name="ItemIdentifiers" type="core:ItemIdentifiersType">
        <xsd:element minOccurs="0" name="ListOfDimension" type="core:ListOfDimensionType">
        <xsd:element minOccurs="0" name="InvoicedQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="ExceptionQuantities" type="ExceptionQuantitiesType">
        <xsd:element minOccurs="0" name="ListOfQuantityCoded" type="core:ListOfQuantityCodedType">
        <xsd:element minOccurs="0" name="LineItemReferences" type="InvoiceReferencesType">
        <xsd:element minOccurs="0" name="CountryOfOrigin" type="core:CountryType">
        <xsd:element minOccurs="0" name="CountryOfDestination" type="core:CountryType">
        <xsd:element minOccurs="0" name="ListOfPartyCoded" type="core:ListOfPartyCodedType">
        <xsd:element minOccurs="0" name="InvoiceDetailAmountDue" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="InvoiceDetailAmountToBePaid" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="TotalLineItemAdjustmentAmount" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="ListOfAdjustmentDetail" type="ListOfAdjustmentDetailType">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ErrorInfo" type="core:ErrorInfoType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
        <xsd:element minOccurs="0" name="ListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: InvoiceResponseHeaderType

InvoiceResponseHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( InvoiceResponseID[xsd:string] , InvoiceReference[core:ReferenceType] , InvoiceResponseIssueDate[xsd:dateTime]? , InvoiceType[InvoiceTypeType] , Language[core:LanguageType] , InvoiceResponseCoded[core:BasicResponseCodeType] , InvoiceResponseCodedOther[xsd:string]? , InvoiceParty[InvoicePartyType] , InvoiceResponseHeaderNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ErrorInfo[core:ErrorInfoType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? , ListOfAttachment[core:ListOfAttachmentType]? )

    Description: InvoiceResponseHeaderType contains the header info of the InvoiceResponse.

    Elements:

    • InvoiceResponseID - is the invoice number in the buyer system.
    • InvoiceReference - is the invoice number in the invoicing party system.
    • InvoiceResponseIssueDate - holds a time stamp provided by the application that created the InvoiceResponse document.
    • InvoiceType - defines the type of Invoice.
    • Language - is the language of the InvoiceResponse.
    • InvoiceResponseCoded - is the response code. The invoice can be rejected or accepted by the InvoiceResponse.
    • InvoiceResponseCodedOther - is used to provide a non-standard BasicResponseCode. This element is mandatory if the value of InvoiceResponseCoded is 'Other'. These codes should not contain white space unless absolutely necessary
    • InvoiceParty - holds all party information related to the InvoiceResponse.
    • InvoiceResponseHeaderNote - contains any free form text pertinent to the entire invoice response or to the InvoiceResponse message itself. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. Such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ErrorInfo - contains any error information related to the processing of the header section of the invoice.
    • ListOfNameValueSet - is used to hold a collection of values qualified by names. The values contained in this element should be agreed upon by trading partners.
    • ListOfAttachment - holds a list of attachments applicable to the entire InvoiceResponse, or to a large part of the invoice response it describes.

[^]Code Fragment

    <xsd:complexType name="InvoiceResponseHeaderType">
    <xsd:sequence>
        <xsd:element name="InvoiceResponseID" type="xsd:string">
        <xsd:element name="InvoiceReference" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="InvoiceResponseIssueDate" type="xsd:dateTime">
        <xsd:element name="InvoiceType" type="InvoiceTypeType">
        <xsd:element name="Language" type="core:LanguageType">
        <xsd:element name="InvoiceResponseCoded" type="core:BasicResponseCodeType">
        <xsd:element minOccurs="0" name="InvoiceResponseCodedOther" type="xsd:string">
        <xsd:element name="InvoiceParty" type="InvoicePartyType">
        <xsd:element minOccurs="0" name="InvoiceResponseHeaderNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ErrorInfo" type="core:ErrorInfoType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
        <xsd:element minOccurs="0" name="ListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: InvoiceResponseType

InvoiceResponseType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( InvoiceResponseHeader[InvoiceResponseHeaderType] , ListOfInvoiceResponseDetail[ListOfInvoiceResponseDetailType]? )

    Description: InvoiceResponseType describes the response of an invoice receiving party to an invoice. The invoice as a whole can be accepted or rejected by the invoice response.

    Elements:

    • InvoiceResponseHeader - contains the header information of an invoice response.
    • ListOfInvoiceResponseDetail -

[^]Code Fragment

    <xsd:complexType name="InvoiceResponseType">
    <xsd:sequence>
        <xsd:element name="InvoiceResponseHeader" type="InvoiceResponseHeaderType">
        <xsd:element minOccurs="0" name="ListOfInvoiceResponseDetail" type="ListOfInvoiceResponseDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: InvoiceSummaryType

InvoiceSummaryType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( NumberOfLines[xsd:int]? , NumberOfOrders[xsd:int]? , InvoiceTotals[InvoiceTotalsType]? , ListOfTaxSummary[core:ListOfTaxSummaryType]? , AllowOrChargeSummary[core:AllowOrChargeSummaryType]? , ListOfActualPayment[core:ListOfActualPaymentType]? , SummaryNote[xsd:string]? )

    Description: InvoiceSummaryType contains summary information relating to the Invoice.

    Elements:

    • NumberOfLines - contains the number of line items in the Invoice.
    • NumberOfOrders - contains the number of orders in the Invoice, in the case that consolidated invoicing is used.
    • InvoiceTotals - contains a number of totals relevant to the Invoice.
    • ListOfTaxSummary - contains the summary of the tax information specified within the Invoice. This element is mandatory if tax elements occur in either the invoice header or any invoice detail item line.
    • AllowOrChargeSummary - contains the summary amounts, for each category of the allowance or charge.
    • ListOfActualPayment - contains a list of information relating to payment(s) made on the invoice at the time the invoice was produced.
    • SummaryNote - contains any free form text pertinent to the invoice summary. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.

[^]Code Fragment

    <xsd:complexType name="InvoiceSummaryType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="NumberOfLines" type="xsd:int">
        <xsd:element minOccurs="0" name="NumberOfOrders" type="xsd:int">
        <xsd:element minOccurs="0" name="InvoiceTotals" type="InvoiceTotalsType">
        <xsd:element minOccurs="0" name="ListOfTaxSummary" type="core:ListOfTaxSummaryType">
        <xsd:element minOccurs="0" name="AllowOrChargeSummary" type="core:AllowOrChargeSummaryType">
        <xsd:element minOccurs="0" name="ListOfActualPayment" type="core:ListOfActualPaymentType">
        <xsd:element minOccurs="0" name="SummaryNote" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: InvoiceTotalsType

InvoiceTotalsType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( InvoiceTotal[core:MonetaryValueType] , InvoiceSubTotal[core:MonetaryValueType] , TaxableValue[core:MonetaryValueType]? , TaxableValueInTaxAccountingCurrency[core:MonetaryValueType]? , ChargeTotal[core:MonetaryValueType]? , AllowanceTotal[core:MonetaryValueType]? , TotalAmountPayable[core:MonetaryValueType]? , PrepaidAmount[core:MonetaryValueType]? , TotalDiscount[core:MonetaryValueType]? , TotalTaxAmount[core:MonetaryValueType]? , TotalAmountMinusDiscount[core:MonetaryValueType]? )

    Description: InvoiceTotalsType contains a number of totals relevant to the Invoice.

    Elements:

    • InvoiceTotal - holds the value of the invoice in the invoice currency after any deductions, charges, and taxes are applied. This is the amount to be paid on this invoice, assuming no prepayment has been made.
    • InvoiceSubTotal - contains the sub total for all items on the invoice. This should be the sum of the sub totals of all items, not including taxes, allowances, or charges.
    • TaxableValue - holds the total taxable value for the invoice in the invoice currency.
    • TaxableValueInTaxAccountingCurrency - holds the TaxValue in the tax accounting currency.
    • ChargeTotal - holds the total of the invoice summary-level charge information.
    • AllowanceTotal - holds the total of the invoice summary-level allowance information.
    • TotalAmountPayable - holds the total amount to be paid. This is the equivalent of the NetValue - PrepaidAmount.
    • PrepaidAmount - holds the total amount prepaid.
    • TotalDiscount - holds the total discount amount applicable to the invoice.
    • TotalTaxAmount - holds the total amount of tax on the invoice.
    • TotalAmountMinusDiscount - holds the total amount after discount as specified in the PaymentInstructions and line item allowances.

[^]Code Fragment

    <xsd:complexType name="InvoiceTotalsType">
    <xsd:sequence>
        <xsd:element name="InvoiceTotal" type="core:MonetaryValueType">
        <xsd:element name="InvoiceSubTotal" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="TaxableValue" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="TaxableValueInTaxAccountingCurrency" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="ChargeTotal" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="AllowanceTotal" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="TotalAmountPayable" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="PrepaidAmount" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="TotalDiscount" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="TotalTaxAmount" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="TotalAmountMinusDiscount" type="core:MonetaryValueType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: InvoiceType

InvoiceType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( InvoiceHeader[InvoiceHeaderType] , InvoiceDetail[InvoiceDetailType] , InvoiceSummary[InvoiceSummaryType]? , DigitalSignature[dgs:SignatureType]? )

    Description: InvoiceType comprises the creation of an invoice that is sent from a seller to a buyer for payment for the goods or services detailed in the invoice supplied under conditions agreed between buyer and seller. An invoice may refer to goods, items or services related to one or more orders. An invoice may contain references to payment terms and transport information.

    Elements:

    • InvoiceHeader - contains the header information of the Invoice.
    • InvoiceDetail - contains the line item and package details of the Invoice.
    • InvoiceSummary - contains the summary information of the Invoice.
    • DigitalSignature - contains a digital signature for the document.

[^]Code Fragment

    <xsd:complexType name="InvoiceType">
    <xsd:sequence>
        <xsd:element name="InvoiceHeader" type="InvoiceHeaderType">
        <xsd:element name="InvoiceDetail" type="InvoiceDetailType">
        <xsd:element minOccurs="0" name="InvoiceSummary" type="InvoiceSummaryType">
        <xsd:element minOccurs="0" name="DigitalSignature" type="dgs:SignatureType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: InvoiceTypeCodeType

InvoiceTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • MeteredServicesInvoice - Metered Services Invoice
    • CreditNoteFinancialAdjustment - Credit Note Related To Financial Adjustments
    • DebitNoteFinancialAdjustment - Debit Note Related To Financial Adjustment
    • InvoicingDataSheet - Invoicing Data Sheet
    • ProformaInvoice - Proforma Invoice
    • CommercialInvoice - Commercial Invoice
    • CreditNoteGoodsAndServices - Credit Note - Goods and Services
    • DebitNoteGoodsAndServices - Debit Note - Goods and Services
    • CommissionNote - Commission Note
    • CorrectedInvoice - Corrected Invoice
    • ConsolidatedInvoice - Consolidated Invoice
    • PrepaymentInvoice - Prepayment Invoice
    • SelfBilledInvoice - Self-Billed Invoice
    • DelcredereInvoice - Delcredere Invoice
    • FactoredInvoice - Factored Invoice
    • CreditInvoice - Credit Invoice
    • CreditMemo - Credit Memo
    • DetourBilling - Detour Billing
    • ThirdPartyConsolidatedInvoice - Third Party Consolidated Invoice
    • DebitInvoice - Debit Invoice
    • DebitMemo - Debit Memo

[^]Code Fragment

    <xsd:simpleType name="InvoiceTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="MeteredServicesInvoice">
        <xsd:enumeration value="CreditNoteFinancialAdjustment">
        <xsd:enumeration value="DebitNoteFinancialAdjustment">
        <xsd:enumeration value="InvoicingDataSheet">
        <xsd:enumeration value="ProformaInvoice">
        <xsd:enumeration value="CommercialInvoice">
        <xsd:enumeration value="CreditNoteGoodsAndServices">
        <xsd:enumeration value="DebitNoteGoodsAndServices">
        <xsd:enumeration value="CommissionNote">
        <xsd:enumeration value="CorrectedInvoice">
        <xsd:enumeration value="ConsolidatedInvoice">
        <xsd:enumeration value="PrepaymentInvoice">
        <xsd:enumeration value="SelfBilledInvoice">
        <xsd:enumeration value="DelcredereInvoice">
        <xsd:enumeration value="FactoredInvoice">
        <xsd:enumeration value="CreditInvoice">
        <xsd:enumeration value="CreditMemo">
        <xsd:enumeration value="DetourBilling">
        <xsd:enumeration value="ThirdPartyConsolidatedInvoice">
        <xsd:enumeration value="DebitInvoice">
        <xsd:enumeration value="DebitMemo">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: InvoiceTypeType

InvoiceTypeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( InvoiceTypeCoded[InvoiceTypeCodeType] , InvoiceTypeCodedOther[xsd:string]? )

    Description: InvoiceTypeType comprises the creation of an invoice that is sent from a seller to a buyer for payment for the goods or services detailed in the invoice supplied under conditions agreed between buyer and seller. An invoice may refer to goods, items or services related to one or more orders. An invoice may contain references to payment terms and transport information.

    Elements:

    • InvoiceTypeCoded - is a code specifying the type of the invoice.
    • InvoiceTypeCodedOther - is used to provide a non-standard InvoiceTypeCode. This element is mandatory if the value of InvoiceTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="InvoiceTypeType">
    <xsd:sequence>
        <xsd:element name="InvoiceTypeCoded" type="InvoiceTypeCodeType">
        <xsd:element minOccurs="0" name="InvoiceTypeCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: InvoicingDetailType

InvoicingDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( SequenceNum[xsd:int]? , InvoicingDetailReference[core:ReferenceCodedType] , InvoicingDetailAmountDue[core:MonetaryValueType]? , InvoicingDetailAmountPaid[core:MonetaryValueType]? , InvoicingItemDetail[InvoiceItemDetailType]? , ListOfAdjustmentDetail[ListOfAdjustmentDetailType]? )

    Description: InvoicingDetailType contains information relating to the payment document for which the RemittanceAdvice is placed against.

    Elements:

    • SequenceNum - uniquely identifies the invoicing detail.
    • InvoicingDetailReference - contains a unique reference number for the invoicing document. (i.e. Invoice Number, Purchase Order Number). This structure contains a coded reference field along with a line item number.
    • InvoicingDetailAmountDue - contains the total amount due for the line item as stated on the payment document.
    • InvoicingDetailAmountPaid - contains the total amount that is being paid for the line item of the associated payment document.
    • InvoicingItemDetail - contains line item detail relating to the payment document. This structure is an extension of the InvoiceItemDetail data structure.
    • ListOfAdjustmentDetail - contains line item adjustment detail.

[^]Code Fragment

    <xsd:complexType name="InvoicingDetailType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="SequenceNum" type="xsd:int">
        <xsd:element name="InvoicingDetailReference" type="core:ReferenceCodedType">
        <xsd:element minOccurs="0" name="InvoicingDetailAmountDue" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="InvoicingDetailAmountPaid" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="InvoicingItemDetail" type="InvoiceItemDetailType">
        <xsd:element minOccurs="0" name="ListOfAdjustmentDetail" type="ListOfAdjustmentDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: LegalReportingInformationType

LegalReportingInformationType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( LegalReportingIndicator[xsd:string] , LegalReportingSupplementalCode[xsd:string]? , LegalReportingParty[CompanyType]? , LegalReportingInvoicedAmount[core:MonetaryValueType] , LegalReportingPaymentAmount[core:MonetaryValueType]? , LegalReportingSupplyingCountry[core:CountryType]? , LegalReportingPayeeCountry[core:CountryType]? , LegalReportingImportDate[xsd:dateTime]? , LegalReportingPaymentDate[xsd:dateTime]? , LegalReportingDescription[xsd:string]? )

    Description: LegalReportingInformationType contains legal reporting information associated with payments made to a foreign payee. This is used by central banks for processing cross border payments over a certain amount.

    Elements:

    • LegalReportingIndicator - contains a country specific code assigned by the central bank.
    • LegalReportingSupplementalCode - contains an additional code that is country dependent used for further identification.
    • LegalReportingParty - identifies the company responsible for legal reporting.
    • LegalReportingInvoicedAmount - contains the total invoiced amount.
    • LegalReportingPaymentAmount - contains the total amount of payment.
    • LegalReportingSupplyingCountry - specifies the country where the services or goods originate.
    • LegalReportingPayeeCountry - specifies the country in from which the payment is made.
    • LegalReportingImportDate - specifies the import date that is legally reported.
    • LegalReportingPaymentDate - specifies the payment date that is legally reported
    • LegalReportingDescription - is a free form description of the legel reporting information.

[^]Code Fragment

    <xsd:complexType name="LegalReportingInformationType">
    <xsd:sequence>
        <xsd:element name="LegalReportingIndicator" type="xsd:string">
        <xsd:element minOccurs="0" name="LegalReportingSupplementalCode" type="xsd:string">
        <xsd:element minOccurs="0" name="LegalReportingParty" type="CompanyType">
        <xsd:element name="LegalReportingInvoicedAmount" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="LegalReportingPaymentAmount" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="LegalReportingSupplyingCountry" type="core:CountryType">
        <xsd:element minOccurs="0" name="LegalReportingPayeeCountry" type="core:CountryType">
        <xsd:element minOccurs="0" name="LegalReportingImportDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="LegalReportingPaymentDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="LegalReportingDescription" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: LineItemAdjustmentType

LineItemAdjustmentType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( SequenceNum[xsd:int]? , LineItemReference[xsd:string] , ExpectedLineItemAmount[core:MonetaryValueType]? , ActualLineItemAmount[core:MonetaryValueType] , TotalLineItemAdjustmentAmount[core:MonetaryValueType] , LineItemAdjustmentNote[xsd:string]? , ListOfAdjustmentDetail[ListOfAdjustmentDetailType] )

    Description: LineItemAdjustmentType

    Elements:

    • SequenceNum - uniquely identifies the line item adjustment.
    • LineItemReference - is a reference to the line item number of the payment document from which the adjustment was made.
    • ExpectedLineItemAmount - specifies an amount of payment expected as stated on payment document.
    • ActualLineItemAmount - specifies an amount of payment expected as stated on payment document.
    • TotalLineItemAdjustmentAmount - contains a monetary amount of adjustment.
    • LineItemAdjustmentNote - describes any free-form text pertinent to the Adjustment. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfAdjustmentDetail - contains line item adjustment detail.

[^]Code Fragment

    <xsd:complexType name="LineItemAdjustmentType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="SequenceNum" type="xsd:int">
        <xsd:element name="LineItemReference" type="xsd:string">
        <xsd:element minOccurs="0" name="ExpectedLineItemAmount" type="core:MonetaryValueType">
        <xsd:element name="ActualLineItemAmount" type="core:MonetaryValueType">
        <xsd:element name="TotalLineItemAdjustmentAmount" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="LineItemAdjustmentNote" type="xsd:string">
        <xsd:element name="ListOfAdjustmentDetail" type="ListOfAdjustmentDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfAdjustmentDetailType

ListOfAdjustmentDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( AdjustmentDetail[AdjustmentDetailType]+ )

    Description: ListOfAdjustmentDetailType

    Elements:

    • AdjustmentDetail

[^]Code Fragment

    <xsd:complexType name="ListOfAdjustmentDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="AdjustmentDetail" type="AdjustmentDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfCountryRequirementType

ListOfCountryRequirementType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( CountryRequirement[CountryRequirementType]+ )

    Description: ListOfCountryRequirementType identifies specific requirements for one or more countries. Only one CountryRequirement element should be used for a country.

    Elements:

    • CountryRequirement - allows for any other requirements specific to a country that are not already explicitly stated.

[^]Code Fragment

    <xsd:complexType name="ListOfCountryRequirementType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="CountryRequirement" type="CountryRequirementType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfEncryptedFieldType

ListOfEncryptedFieldType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( EncryptedField[EncryptedFieldType]+ )

    Description: ListOfEncryptedFieldType is a list of encrypted fields

    Elements:

    • EncryptedField - contains a generic structure to store encrypted data.

[^]Code Fragment

    <xsd:complexType name="ListOfEncryptedFieldType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="EncryptedField" type="EncryptedFieldType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfFeeType

ListOfFeeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( Fee[FeeType]+ )

    Description: ListOfFeeType contains a list of fees and amounts pertinent to the spot FX rate quote.

    Elements:

    • Fee - holds the description and amount elements for the Fee.

[^]Code Fragment

    <xsd:complexType name="ListOfFeeType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="Fee" type="FeeType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfFinancialInstitutionCodedType

ListOfFinancialInstitutionCodedType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( FinancialInstitutionCoded[FinancialInstitutionCodedType]+ )

    Description: ListOfFinancialInstitutionCodedType lists one or more financial institutions that are qualified with a function.

    Elements:

    • FinancialInstitutionCoded - is a container for financial institution information and a qualifier describing the function of the institution.

[^]Code Fragment

    <xsd:complexType name="ListOfFinancialInstitutionCodedType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="FinancialInstitutionCoded" type="FinancialInstitutionCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfFXRateRequestDetailType

ListOfFXRateRequestDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( FXRateRequestDetail[FXRateRequestDetailType]+ )

    Description: ListOfFXRateRequestDetailType contains a list of FXRateRequestDetails. Details are optional in the case where an indicative FX rate is being requested. This is specified by the IndicativeIndicator in the header.

    Elements:

    • FXRateRequestDetail - contains detailed information related to the FX rates being requested.

[^]Code Fragment

    <xsd:complexType name="ListOfFXRateRequestDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="FXRateRequestDetail" type="FXRateRequestDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfFXRateResponseDetailType

ListOfFXRateResponseDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( FXRateResponseDetail[FXRateResponseDetailType]+ )

    Description: ListOfFXRateResponseDetailType contains a list of FXRateRequestDetail for a FX rate quote.

    Elements:

    • FXRateResponseDetail - contains detailed information pertaining to the FXRateResponse. This includes payment document information containing payment-related information at the line item level.

[^]Code Fragment

    <xsd:complexType name="ListOfFXRateResponseDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="FXRateResponseDetail" type="FXRateResponseDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfInvoiceItemDetailType

ListOfInvoiceItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( InvoiceItemDetail[InvoiceItemDetailType]+ )

    Description: ListOfInvoiceItemDetailType contains a list of line items for the Invoice.

    Elements:

    • InvoiceItemDetail - contains the item detail information for the Invoice.

[^]Code Fragment

    <xsd:complexType name="ListOfInvoiceItemDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="InvoiceItemDetail" type="InvoiceItemDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfInvoiceResponseDetailType

ListOfInvoiceResponseDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( InvoiceResponseDetail[InvoiceResponseDetailType]+ )

    Description: ListOfInvoiceResponseDetailType contains a list of line items for the InvoiceResponse.

    Elements:

    • InvoiceResponseDetail - contains the item detail information for the InvoiceResponse.

[^]Code Fragment

    <xsd:complexType name="ListOfInvoiceResponseDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="InvoiceResponseDetail" type="InvoiceResponseDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfInvoicingDetailType

ListOfInvoicingDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( InvoicingDetail[InvoicingDetailType]+ )

    Description: ListOfInvoicingDetailType contains a set of invoicing detail.

    Elements:

    • InvoicingDetail - contains information relating to the payment document for which the RemittanceAdvice is placed against.

[^]Code Fragment

    <xsd:complexType name="ListOfInvoicingDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="InvoicingDetail" type="InvoicingDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfLineItemAdjustmentType

ListOfLineItemAdjustmentType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( LineItemAdjustment[LineItemAdjustmentType]+ )

    Description: ListOfLineItemAdjustmentType

    Elements:

    • LineItemAdjustment

[^]Code Fragment

    <xsd:complexType name="ListOfLineItemAdjustmentType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="LineItemAdjustment" type="LineItemAdjustmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfPaymentDocumentDetailType

ListOfPaymentDocumentDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PaymentDocumentDetail[RemittanceAdviceDetailType]+ )

    Description: ListOfPaymentDocumentDetailType

    Elements:

    • PaymentDocumentDetail

[^]Code Fragment

    <xsd:complexType name="ListOfPaymentDocumentDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="PaymentDocumentDetail" type="RemittanceAdviceDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfPaymentExceptionType

ListOfPaymentExceptionType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PaymentException[PaymentExceptionType]+ )

    Description: ListOfPaymentExceptionType contains a list of exception codes relating to the PaymentRequest document.

    Elements:

    • PaymentException - contains exception details which include an exception code, exception note and a specifier for the offending element..

[^]Code Fragment

    <xsd:complexType name="ListOfPaymentExceptionType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="PaymentException" type="PaymentExceptionType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfPaymentRequestAcknDetailType

ListOfPaymentRequestAcknDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PaymentRequestAcknDetail[PaymentRequestAcknDetailType]+ )

    Description: ListOfPaymentRequestAcknDetailType contains a list of one or more payment document details for which the PaymentRequestAcknowledgement is referencing from the original PaymentRequest document.

    Elements:

    • PaymentRequestAcknDetail - contains high level information for the PaymentRequest document.

[^]Code Fragment

    <xsd:complexType name="ListOfPaymentRequestAcknDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="PaymentRequestAcknDetail" type="PaymentRequestAcknDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfPaymentRequestDetailType

ListOfPaymentRequestDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PaymentRequestDetail[PaymentRequestDetailType]+ )

    Description: ListOfPaymentRequestDetailType

    Elements:

    • PaymentRequestDetail

[^]Code Fragment

    <xsd:complexType name="ListOfPaymentRequestDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="PaymentRequestDetail" type="PaymentRequestDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfPaymentStatusRequestDetailType

ListOfPaymentStatusRequestDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PaymentStatusRequestDetail[PaymentStatusRequestDetailType]+ )

    Description: ListOfPaymentStatusRequestDetailType contains a list of PaymentStatusRequest details.

    Elements:

    • PaymentStatusRequestDetail - contains detailed information related to the payment status being requested.

[^]Code Fragment

    <xsd:complexType name="ListOfPaymentStatusRequestDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="PaymentStatusRequestDetail" type="PaymentStatusRequestDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfPaymentStatusResponseDetailType

ListOfPaymentStatusResponseDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PaymentStatusResponseDetail[PaymentStatusResponseDetailType]+ )

    Description: ListOfPaymentStatusResponseDetailType contains a list of PaymentStatusResponse details.

    Elements:

    • PaymentStatusResponseDetail - contains detailed information pertaining to the payment status. This includes payment document information containing payment related information at the line item level.

[^]Code Fragment

    <xsd:complexType name="ListOfPaymentStatusResponseDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="PaymentStatusResponseDetail" type="PaymentStatusResponseDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfRelatedInvoiceRefType

ListOfRelatedInvoiceRefType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( RelatedInvoiceRef[RelatedInvoiceRefType]+ )

    Description: ListOfRelatedInvoiceRefType contains a list of other invoices related to this invoice or InvoiceDetail.

    Elements:

    • RelatedInvoiceRef - holds a reference to another invoice.

[^]Code Fragment

    <xsd:complexType name="ListOfRelatedInvoiceRefType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="RelatedInvoiceRef" type="RelatedInvoiceRefType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfSpecificRequirementType

ListOfSpecificRequirementType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( SpecificRequirement[SpecificRequirementType]+ )

    Description: ListOfSpecificRequirementType is used to provide detail about one or more requirement specific to an entity.

    Elements:

    • SpecificRequirement - qualifies and provides detail about any information specifically required.

[^]Code Fragment

    <xsd:complexType name="ListOfSpecificRequirementType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="SpecificRequirement" type="SpecificRequirementType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfSubsidiaryType

ListOfSubsidiaryType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( Subsidiary[SubsidiaryType]+ )

    Description: ListOfSubsidiaryType contains a set of subsidiary detail with associated invoicing and adjustment information. This structure is used in the case where the payment is made by a central party and invoice detail needs to be specified by subsidiary.

    Elements:

    • Subsidiary - contains information relating to a third party or subsidiary associated with the payment document.

[^]Code Fragment

    <xsd:complexType name="ListOfSubsidiaryType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="Subsidiary" type="SubsidiaryType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OtherInvoicePartiesType

OtherInvoicePartiesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( BillToParty[core:PartyType]? , RemitToParty[core:PartyType]? , ListOfPartyCoded[core:ListOfPartyCodedType]? )

    Description: OtherInvoicePartiesType contains information on other parties for the line item, including unique ID's and address information.

    Elements:

    • BillToParty - holds information relating to the BillToParty.
    • RemitToParty - holds information relating to the RemitToParty.
    • ListOfPartyCoded - contains information on the role of a party.

[^]Code Fragment

    <xsd:complexType name="OtherInvoicePartiesType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="BillToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="RemitToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ListOfPartyCoded" type="core:ListOfPartyCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PayerPartyType

PayerPartyType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: Extends: core:PartyType

      Append:( CertificateAuthority[xsd:string]? )

    Description: PayerPartyType describes the partner that is responsible for payment. This is assumed to also be the sender of the document. For PayerParty, the Party definition is extended to include CertificateAuthority.

    Elements:

    • CertificateAuthority - contains the payer's certificate of authority or digital signature which will be used by the financial institution to verify the origins of the document and validate the payment.

[^]Code Fragment

    <xsd:complexType name="PayerPartyType">
    <xsd:complexContent>
        <xsd:extension base="core:PartyType">
            <xsd:sequence>
                <xsd:element minOccurs="0" name="CertificateAuthority" type="xsd:string">
            </xsd:sequence>
        </xsd:extension>
    </xsd:complexContent>
</xsd:complexType>


complexType definition: PaymentDatesType

PaymentDatesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PaymentDueDate[xsd:dateTime]? , RequestedPaymentDate[xsd:dateTime]? , PayBeforeDate[xsd:dateTime]? , ListOfPaymentDates[core:ListOfDateCodedType]? )

    Description: PaymentDatesType contains a list of dates that are pertinent to the payment document.

    Elements:

    • PaymentDueDate - specifies the date that the payment is due.
    • RequestedPaymentDate - specifies the date that the financial institution is requested to process the payment.
    • PayBeforeDate - specifies the date on or before the date that the financial institution should make the payment to the payee. PaymentRequest becomes invalid if payment is not made on or before this date.
    • ListOfPaymentDates - contains all other dates for the PaymentRequest not explicitly stated as the content of other elements.

[^]Code Fragment

    <xsd:complexType name="PaymentDatesType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="PaymentDueDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="RequestedPaymentDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="PayBeforeDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ListOfPaymentDates" type="core:ListOfDateCodedType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: PaymentExceptionCodeType

PaymentExceptionCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:
    This code contains exception codes that relate to the Payment document.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • Success - The service provider successfully processed the request.
    • ClientUpToDate - The client's indicator (i.e., date-time or token) of last update in the request is equal to the server's indicator of last update processed.
    • GeneralError - There was an error that prevented the service provider from processing the transaction. No additional information is provided.
    • GeneralDataError - One or more of the elements in the request is either invalid or is inconsistent with other elements. No additional information is available.
    • SystemNotAvailable - The service provider for this transaction is not available due to a technical problem. Try again later
    • FunctionNotAvailable - The function selected is not available. Other functions may be available.
    • UnsupportedService - The service provider does not support the specified service offering.
    • UnsupportedMessage - The server does not support the message.
    • UnsupportedFunction - The server does not support one or more functions within the request.
    • ObjectAlreadyCommitted - The object cannot be modified or canceled because it has already been committed for processing.
    • MessageAcceptedForAsynchronousProcessing - The message was accepted for future processing.
    • DuplicateRequestID - A request with this client message identifier has already been received and processed.
    • TheCursorReturnedWithinRecCtrlInIsInvalidOrHasExpired - The suggested action is to resend the original message, omitting the cursor, to restart the sequence of messages required to retrieve all of the records.
    • RequiredElementNotIncluded - The request message does not contain one or more required elements.
    • RequestDeclined - The Service Provider has declined your request (e.g., a no pay was received for a payment or a credit limit change request was declined).
    • InvalidEnumValue - Customer input of an Enum value is not valid. The condition may echo the element name in error or the value input by the Customer.
    • CannotModifyElement - The service provider does not allow modifications to one or more elements in a modification request.
    • NoChangesMade - No changes have been made. The requested change matched the existing data on the server.
    • TooManyRecordsRequested - The request has asked for more records than the service provider can satisfy. The quantity that the service provider can satisfy has been provided.
    • NoRecordsMatchSelectionCriteria - No records match the selection criteria of the request.
    • SomeSelectionCriteriaNotSupported - The server does not support one or more of the selection criterion fields in the request. Records returned based on only those supported.
    • NoneOfSelectionCriteriaSupported - The server supports none of the selection criterion fields specified in the request. No records returned.
    • TokenValuePriorToAvailableHistory - The client has sent a token that precedes the history currently available. The client must do an inquiry to resync.
    • InvalidToken - The token is not of the valid format. Used when the client may edit the token format.
    • DetailNotAvailable - Detail for this item is not available at this time.
    • UnknownObjectId - The specified object ID does not exist.
    • ObjectAlreadyExists - The object that the client requested to add already exists. (e.g., the specified service is already activated for the customer or customer account, or customer is already enrolled.)
    • ObjectNotDeleted-DependentObjectsExist - The object was not deleted because dependent objects exist, and the client did not request a cascading delete.
    • CascadeDeleteFailed - The object was not deleted because the dependent objects could not be deleted at this time.
    • ObjectExistsButDoesNotMatchCustomerID - The object exists but does not match the Customer ID. Customer is not authorized to act.
    • ServiceProviderNameInvalid - The Service Provider name specified in a request was not found or invalid.
    • ServiceProviderNameWithinCustomerIDIsInvalid - The Service Provider Name specified within a customer identification aggregate is invalid.
    • ServiceProviderNameWithinBillerIDIsInvalid - The Service Provider Name specified within a biller identification aggregate is invalid.
    • CustomerIDInvalid - The customer identifier Customer ID specified is invalid or not found.
    • EditMaskError - The value specified does not match the edit mask.
    • InvalidAddress - The specified address is incorrect.
    • InvalidCity - The city specified was incorrect.
    • InvalidStateOrProvince - The state or province specified was incorrect.
    • InvalidPostalCode - The postal code specified was incorrect.
    • InvalidCountryCode - The specified country code is not valid in ISO 3166.
    • CryptTypeNotValid - CryptType not valid or not supported.
    • NoServiceProviderName - Ambiguous request, Service Provider Name required
    • NoServiceName - Ambiguous request, Service Name required
    • SecurityViolation - A security violation has occurred.
    • CustomerLoginIdAndPasswordWillBeSentOut-Of-Band - The service provider will send the customer Login ID and password through postal mail, e-mail, or some other means.
    • AuthenticationFailed - The customer could not be authenticated due to an incorrect login ID or password.
    • AuthorizationFailure - Customer is not eligible to perform this function
    • OBOIsNotActiveForThisCustomerID - The currently logged-in customer does not have the authority to act on behalf of another user.
    • ServiceNotEnabled - The customer has not enabled the service with the service provider.
    • CustomerSessionAlreadyInProgress - The service provider supports only one session at a time per customer and there is already an active session for this Customer ID. Please try again later.
    • NoCustomerSessionInProgress - The specified customer does not have a session in progress.
    • ImmediateCustomerLockOut - The customer identity for the current session is suspect. End any active sessions.
    • CustomerLockedOut - The service provider has received too many failed authentication attempts for this customer or has detected other suspicious activity. Please call the technical support telephone number.
    • PasswordChangeRequired - The Logon is successful but the customer must enter a new password before any other messages will be allowed.
    • MustChangePassword - The customer must change his or her password before any other messages will be allowed.
    • InvalidNewCustomerIdentifier - The new customer ID entered is not valid because it does not meet edit criteria.
    • NewCustomerIdentifierInUse - The customer chose a customer identifier that is already in use.
    • InvalidNewPassword - The new password entered as part of a CustPswdModRq is invalid.
    • UnsupportedApplicationId - The ID of the client application is unsupported.
    • InvalidDataInSingleOrLowAmountField - Non-numeric or missing data was encountered in a single or low amount field.
    • InvalidDataInHighAmountField - Non-numeric or missing data was encountered in a high amount field.
    • AmountTooSmall - The amount entered is too small (e.g., less than the minimum required). Please enter a larger amount.
    • AmountTooLarge - The amount entered is too large (e.g., exceeds the limit for this transaction). Please enter a smaller amount.
    • InvalidHighLowAmount - Low amount is greater than high amount in an amount range.
    • FinalAmountExceedsLimit - The service provider has established a maximum value for the amount of the final transfer or payment, which has been exceeded.
    • InvalidDatetime-SingleDateOrLowOfRange - The specified single date/time or the low date/time in a range is not in a valid date/time format.
    • InvalidDatetime-HighOfRange - The specified high date/time in a range is not in a valid date/time format.
    • InvalidDatetimeRange - The date range specified is invalid because the low date exceeds the high date.
    • DatePassed - The date entered is in the past. Please enter a valid date.
    • DatetimeTooSoon - The specified date and time is too near; enter a later date and time.
    • DatetimeTooFarInFuture - The specified date and time is too far in the future. Reenter an earlier date.
    • ProcessingDatePrecedesToday - The processing date required to meet the due date DueDt entered would be earlier than today.
    • RequestedDateAdjusted - The Service Provider successfully processed the request, but the date requested has been adjusted.
    • RequestIsTooLateForTodaysWork - The customer has asked to schedule a transfer or payment for today but the cutoff time for today's work has passed.
    • WeekendOrHoliday - The date entered is a weekend or holiday. The date cannot be adjusted.
    • HistoryNotAvailableForFullDateRange - History is not available for the full date range specified. All transactions that were available were returned.
    • AccountBalanceInformationNotAvailable - One or more account balances for the selected account is currently unavailable.
    • ExtendedAccountBalanceInformationNotAvailable - One or more extended account balances for the selected account is currently unavailable.
    • SingleOrSourceAccountInvalid - The Specified single account or source account identification aggregate contains invalid data or was not found.
    • DestinationAccountInvalid - The specified destination account identification aggregate contains invalid data or was not found.
    • SingleAccountOrSourceAccountNotForCustomer - The specified single account or source account does not correspond to the customer.
    • DestinationAccountNotForCustomer - The specified destination account does not correspond to the customer.
    • SingleOrSourceAccountClosed - The specified single account or source account has been closed.
    • DestinationAccountClosed - The specified destination account has been closed.
    • SourceAndDestinationAccountsAreIdentical - A transfer that indicates that the source and destination accounts are the same is invalid.
    • SingleOrSourceAccountNotAuthorized - The customer is not authorized to perform the requested action on the specified single or source account.
    • DestinationAccountNotAuthorized - The customer is not authorized to perform the requested action on the specified destination account.
    • SingleOrSourceAccountNotAvailable - The single or source account requested is not available for transaction processing at this time. The customer may continue to access other accounts.
    • DestinationAccountNotAvailable - The destination account requested is not available for transaction processing at this time. The customer may continue to access other accounts.
    • SingleOrSourceAccountNotEligibleForTransaction - This single or source account is not authorized for this particular transaction.
    • DestinationAccountNotEligibleForTransaction - This destination account is not authorized for this particular transaction.
    • InvalidSingleOrSourceAccountType - The single or source account type specified is not permitted by the service provider.
    • InvalidDestinationAccountType - The service provider does not permit the destination account type specified.
    • SingleOrSourceAccountBankIDError - The Bank Identifier in the source or single account identification aggregate is incorrect.
    • DestinationAccountBankIDError - The Bank Identifier in the destination account is incorrect.
    • BranchIdMissing - A branch ID value must be provided in the single or source bank account information aggregate, but is missing.
    • InvalidBankInfo - The information contained within Bank Information is either invalid or insufficient to unambiguously identify the single or source bank.
    • InvalidIndustryID - The specified industry number is not valid for the Organization identifier.
    • InvalidCardMagneticStripData - The card magnetic strip data provided is either incorrect or incomplete.
    • InvalidCheckNumberRange - The specified check number range is invalid.
    • RequestIsTooLate-CheckHasBeenPaid - The customer has requested a Stop Payment on a check that has already cleared the bank and settled.
    • CheckNumberNotFound - The specified check number could not be found.
    • StopCheckInProcess - Stop Check is already in process.
    • TooManyChecksToProcess - The check range specified in StpChkAddRq is too large for the service provider to handle.
    • CheckBookStyleNotAvailable - The specified checkbook style is not currently available. Please choose another style
    • InvalidNumberOfChecks - The number of checks specified is not valid for the specified checkbook style.
    • ForeignExchangeNotSupported - The currency code on both accounts involved in a transfer must be the same as the currency code of the input amount, unless ForEx is specified in OptSupt.
    • InvalidCurrencyCode - The specified currency code is not valid in ISO 4217.
    • InvalidLanguageCode - The specified language code is not valid in ISO 639.
    • UnsupportedFrequency - The specified frequency is not supported for this message.
    • DuplicatePaymentTransferExists - The customer has attempted to schedule a payment/transfer that matches a previously entered payment/transfer (I.e., the day, amount and merchant or to account are the same). The client may resubmit using DupChkOverride = True, if the payment or transfer is not a duplicate.
    • DuplicateRecurringModel - The customer has attempted to schedule a recurring model that matches a previously entered model. The client may resubmit using DupChkOverride = True, if the model is not a duplicate.
    • InvalidSkipCount - The number of transfers or payments specified to skip exceeds the number of transfers or payments remaining for this recurring model.
    • InsufficientFunds - The service provider cannot process the transaction because the specified account does not have sufficient funds.
    • NumberOfTransfersExceedsLimit - The number of transfers allowed for a monthly or statement cycle has been exceeded.
    • DailyTransferLimitExceeded - Total transfers for today exceed maximum allowable for one day.
    • TransferPaymentGreaterThanLoanBalance - A transfer to a loan account (a payment) is declined because the loan payoff is less than the transfer amount.
    • InvalidBillerID - The biller identifier specified could not be found or is invalid.
    • InvalidStdPayeeID - The standard payee identifier could not be found or was invalid.
    • InvalidCustomerPayeeID - The specified Customer Payee ID CustPayeeId does not exist or no longer exists.
    • InvalidPayeeName - The name specified for the payee was incorrect or incomplete.
    • PayeeListFull - The payee list is currently full. To add a payee, first delete an existing payee.
    • InvalidCustomerAccountWithPayee - The pay account PayAcct specified by the user is invalid.
    • PayeeTypeNotSupported - This service provider does not support the payee type requested.
    • NumberOfPaymentsInvalid - The number of payments entered is invalid. Please re-enter the number of payments.
    • TotalPaymentAmountsScheduledForTodayExceededDailyLimit - The sum of all payment amounts scheduled for today exceeds the daily limit (either at the SP or customer level).
    • ExpiredCard - The card specified has expired.
    • RecurringModelOpen-Ended - No final date or number of instances has been specified for the recurring model; it has been added as open-ended.
    • DataChangedOrTruncated - The server is responding with a warning that the data in the response is not identical to the data provided in the request. Rather, the data has been changed en route to storage.
    • CurrenciesDoNotMatch - The currencies of the amounts (e.g. in SelRangeCurAmt) are not the same.
    • CardAccountIdMatchesMultipleAccounts - The account cannot be uniquely identified based on the information provided by the Card Account Identifier.
    • AuthorizationIsRejected - The Pay Provider is indicating that the payment has been rejected by the Customer Payment Provider
    • AuthorizationHeldOver - The Pay provider is indicating that a payment has held over (typically for next day payment) by the CPP
    • AuthorizationIsDeclinedForInsufficientFunds - The financial institution has declined the payment authorization because the specified account does not have sufficient funds.
    • AuthorizationIsDeclinedForInactiveAccount - The financial institution has declined the payment authorization because the specified account is inactive.
    • AuthorizationIsDeclinedForClosedAccount - The financial institution has declined the payment authorization because the specified account is closed.
    • AuthorizationIsDeclinedForOtherReason - The financial institution has declined the payment authorization for another reason. Customer should contact the FI for specific reason.

[^]Code Fragment

    <xsd:simpleType name="PaymentExceptionCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Success">
        <xsd:enumeration value="ClientUpToDate">
        <xsd:enumeration value="GeneralError">
        <xsd:enumeration value="GeneralDataError">
        <xsd:enumeration value="SystemNotAvailable">
        <xsd:enumeration value="FunctionNotAvailable">
        <xsd:enumeration value="UnsupportedService">
        <xsd:enumeration value="UnsupportedMessage">
        <xsd:enumeration value="UnsupportedFunction">
        <xsd:enumeration value="ObjectAlreadyCommitted">
        <xsd:enumeration value="MessageAcceptedForAsynchronousProcessing">
        <xsd:enumeration value="DuplicateRequestID">
        <xsd:enumeration value="TheCursorReturnedWithinRecCtrlInIsInvalidOrHasExpired">
        <xsd:enumeration value="RequiredElementNotIncluded">
        <xsd:enumeration value="RequestDeclined">
        <xsd:enumeration value="InvalidEnumValue">
        <xsd:enumeration value="CannotModifyElement">
        <xsd:enumeration value="NoChangesMade">
        <xsd:enumeration value="TooManyRecordsRequested">
        <xsd:enumeration value="NoRecordsMatchSelectionCriteria">
        <xsd:enumeration value="SomeSelectionCriteriaNotSupported">
        <xsd:enumeration value="NoneOfSelectionCriteriaSupported">
        <xsd:enumeration value="TokenValuePriorToAvailableHistory">
        <xsd:enumeration value="InvalidToken">
        <xsd:enumeration value="DetailNotAvailable">
        <xsd:enumeration value="UnknownObjectId">
        <xsd:enumeration value="ObjectAlreadyExists">
        <xsd:enumeration value="ObjectNotDeleted-DependentObjectsExist">
        <xsd:enumeration value="CascadeDeleteFailed">
        <xsd:enumeration value="ObjectExistsButDoesNotMatchCustomerID">
        <xsd:enumeration value="ServiceProviderNameInvalid">
        <xsd:enumeration value="ServiceProviderNameWithinCustomerIDIsInvalid">
        <xsd:enumeration value="ServiceProviderNameWithinBillerIDIsInvalid">
        <xsd:enumeration value="CustomerIDInvalid">
        <xsd:enumeration value="EditMaskError">
        <xsd:enumeration value="InvalidAddress">
        <xsd:enumeration value="InvalidCity">
        <xsd:enumeration value="InvalidStateOrProvince">
        <xsd:enumeration value="InvalidPostalCode">
        <xsd:enumeration value="InvalidCountryCode">
        <xsd:enumeration value="CryptTypeNotValid">
        <xsd:enumeration value="NoServiceProviderName">
        <xsd:enumeration value="NoServiceName">
        <xsd:enumeration value="SecurityViolation">
        <xsd:enumeration value="CustomerLoginIdAndPasswordWillBeSentOut-Of-Band">
        <xsd:enumeration value="AuthenticationFailed">
        <xsd:enumeration value="AuthorizationFailure">
        <xsd:enumeration value="OBOIsNotActiveForThisCustomerID">
        <xsd:enumeration value="ServiceNotEnabled">
        <xsd:enumeration value="CustomerSessionAlreadyInProgress">
        <xsd:enumeration value="NoCustomerSessionInProgress">
        <xsd:enumeration value="ImmediateCustomerLockOut">
        <xsd:enumeration value="CustomerLockedOut">
        <xsd:enumeration value="PasswordChangeRequired">
        <xsd:enumeration value="MustChangePassword">
        <xsd:enumeration value="InvalidNewCustomerIdentifier">
        <xsd:enumeration value="NewCustomerIdentifierInUse">
        <xsd:enumeration value="InvalidNewPassword">
        <xsd:enumeration value="UnsupportedApplicationId">
        <xsd:enumeration value="InvalidDataInSingleOrLowAmountField">
        <xsd:enumeration value="InvalidDataInHighAmountField">
        <xsd:enumeration value="AmountTooSmall">
        <xsd:enumeration value="AmountTooLarge">
        <xsd:enumeration value="InvalidHighLowAmount">
        <xsd:enumeration value="FinalAmountExceedsLimit">
        <xsd:enumeration value="InvalidDatetime-SingleDateOrLowOfRange">
        <xsd:enumeration value="InvalidDatetime-HighOfRange">
        <xsd:enumeration value="InvalidDatetimeRange">
        <xsd:enumeration value="DatePassed">
        <xsd:enumeration value="DatetimeTooSoon">
        <xsd:enumeration value="DatetimeTooFarInFuture">
        <xsd:enumeration value="ProcessingDatePrecedesToday">
        <xsd:enumeration value="RequestedDateAdjusted">
        <xsd:enumeration value="RequestIsTooLateForTodaysWork">
        <xsd:enumeration value="WeekendOrHoliday">
        <xsd:enumeration value="HistoryNotAvailableForFullDateRange">
        <xsd:enumeration value="AccountBalanceInformationNotAvailable">
        <xsd:enumeration value="ExtendedAccountBalanceInformationNotAvailable">
        <xsd:enumeration value="SingleOrSourceAccountInvalid">
        <xsd:enumeration value="DestinationAccountInvalid">
        <xsd:enumeration value="SingleAccountOrSourceAccountNotForCustomer">
        <xsd:enumeration value="DestinationAccountNotForCustomer">
        <xsd:enumeration value="SingleOrSourceAccountClosed">
        <xsd:enumeration value="DestinationAccountClosed">
        <xsd:enumeration value="SourceAndDestinationAccountsAreIdentical">
        <xsd:enumeration value="SingleOrSourceAccountNotAuthorized">
        <xsd:enumeration value="DestinationAccountNotAuthorized">
        <xsd:enumeration value="SingleOrSourceAccountNotAvailable">
        <xsd:enumeration value="DestinationAccountNotAvailable">
        <xsd:enumeration value="SingleOrSourceAccountNotEligibleForTransaction">
        <xsd:enumeration value="DestinationAccountNotEligibleForTransaction">
        <xsd:enumeration value="InvalidSingleOrSourceAccountType">
        <xsd:enumeration value="InvalidDestinationAccountType">
        <xsd:enumeration value="SingleOrSourceAccountBankIDError">
        <xsd:enumeration value="DestinationAccountBankIDError">
        <xsd:enumeration value="BranchIdMissing">
        <xsd:enumeration value="InvalidBankInfo">
        <xsd:enumeration value="InvalidIndustryID">
        <xsd:enumeration value="InvalidCardMagneticStripData">
        <xsd:enumeration value="InvalidCheckNumberRange">
        <xsd:enumeration value="RequestIsTooLate-CheckHasBeenPaid">
        <xsd:enumeration value="CheckNumberNotFound">
        <xsd:enumeration value="StopCheckInProcess">
        <xsd:enumeration value="TooManyChecksToProcess">
        <xsd:enumeration value="CheckBookStyleNotAvailable">
        <xsd:enumeration value="InvalidNumberOfChecks">
        <xsd:enumeration value="ForeignExchangeNotSupported">
        <xsd:enumeration value="InvalidCurrencyCode">
        <xsd:enumeration value="InvalidLanguageCode">
        <xsd:enumeration value="UnsupportedFrequency">
        <xsd:enumeration value="DuplicatePaymentTransferExists">
        <xsd:enumeration value="DuplicateRecurringModel">
        <xsd:enumeration value="InvalidSkipCount">
        <xsd:enumeration value="InsufficientFunds">
        <xsd:enumeration value="NumberOfTransfersExceedsLimit">
        <xsd:enumeration value="DailyTransferLimitExceeded">
        <xsd:enumeration value="TransferPaymentGreaterThanLoanBalance">
        <xsd:enumeration value="InvalidBillerID">
        <xsd:enumeration value="InvalidStdPayeeID">
        <xsd:enumeration value="InvalidCustomerPayeeID">
        <xsd:enumeration value="InvalidPayeeName">
        <xsd:enumeration value="PayeeListFull">
        <xsd:enumeration value="InvalidCustomerAccountWithPayee">
        <xsd:enumeration value="PayeeTypeNotSupported">
        <xsd:enumeration value="NumberOfPaymentsInvalid">
        <xsd:enumeration value="TotalPaymentAmountsScheduledForTodayExceededDailyLimit">
        <xsd:enumeration value="ExpiredCard">
        <xsd:enumeration value="RecurringModelOpen-Ended">
        <xsd:enumeration value="DataChangedOrTruncated">
        <xsd:enumeration value="CurrenciesDoNotMatch">
        <xsd:enumeration value="CardAccountIdMatchesMultipleAccounts">
        <xsd:enumeration value="AuthorizationIsRejected">
        <xsd:enumeration value="AuthorizationHeldOver">
        <xsd:enumeration value="AuthorizationIsDeclinedForInsufficientFunds">
        <xsd:enumeration value="AuthorizationIsDeclinedForInactiveAccount">
        <xsd:enumeration value="AuthorizationIsDeclinedForClosedAccount">
        <xsd:enumeration value="AuthorizationIsDeclinedForOtherReason">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: PaymentExceptionType

PaymentExceptionType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PaymentExceptionCoded[PaymentExceptionCodeType] , PaymentExceptionCodedOther[xsd:string]? , PaymentExceptionNote[xsd:string]? , OffendingPaymentElement[core:NameValuePairType]? )

    Description: PaymentExceptionType holds the exception details that include an exception code, exception note and a specifier for the offending element.

    Elements:

    • PaymentExceptionCoded - contains exception codes that relate to the PaymentRequest document.
    • PaymentExceptionCodedOther - is used to provide a non-standard PaymentExceptionCode. This element is mandatory if the value of PaymentExceptionCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • PaymentExceptionNote - contains any free form text pertinent to the PaymentException. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information. .
    • OffendingPaymentElement - specifies the name and value of the element for which the exception applies.

[^]Code Fragment

    <xsd:complexType name="PaymentExceptionType">
    <xsd:sequence>
        <xsd:element name="PaymentExceptionCoded" type="PaymentExceptionCodeType">
        <xsd:element minOccurs="0" name="PaymentExceptionCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="PaymentExceptionNote" type="xsd:string">
        <xsd:element minOccurs="0" name="OffendingPaymentElement" type="core:NameValuePairType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PaymentPartyType

PaymentPartyType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PayerParty[PayerPartyType] , PayeeParty[core:PartyType] , BuyerParty[core:PartyType]? , SellerParty[core:PartyType]? , BillToParty[core:PartyType]? , ListOfPartyCoded[core:ListOfPartyCodedType]? )

    Description: PaymentPartyType contains all parties relevant to the payment document. The required parties are the PayerParty and the PayeeParty. The PayerParty includes an optional CertificateAuthority field to specify a digital signature.

    Elements:

    • PayerParty - describes the partner that is responsible for payment. This is assumed to also be the sender of the document. For PayerParty, the Party definition is extended to include CertificateAuthority.
    • PayeeParty - describes the party to receive payment.
    • BuyerParty - describes the buyer of the goods or services.
    • SellerParty - describes the supplier of the goods or services.
    • BillToParty - describes the party to receive the invoice.
    • ListOfPartyCoded - contains information relevant to describing parties other than the source target parties which are relevant to the time series data.

[^]Code Fragment

    <xsd:complexType name="PaymentPartyType">
    <xsd:sequence>
        <xsd:element name="PayerParty" type="PayerPartyType">
        <xsd:element name="PayeeParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="BuyerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="SellerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="BillToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ListOfPartyCoded" type="core:ListOfPartyCodedType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: PaymentReasonCodeType

PaymentReasonCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:
    This code identifies the reason or business function for the payment. This code list is derived from EDIFACT 4025 (Business function code).

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • PaymentTerms - The business function is to specify payment terms.
    • MedicalServices - The reason for the transaction is medical services.
    • MultipleTypesOfService - The reason for the transaction is for multiple types of services.
    • NotOtherwiseSpecified - The reason for the transaction is for types of services not specified elsewhere.
    • VisionCare - The reason for the transaction is vision care services.
    • HomeHealthCare - The reason for the transaction is for home health care services.
    • HospitalCare - The reason for the transaction is for hospital care services.
    • IntermediateCareFacility - The reason for the transaction is for intermediate care facility services.
    • Long-TermCareFacility - The reason for the transaction is for long-term care facility services.
    • ConvalescentCareFacility - The reason for the transaction is for convalescent care facility services.
    • AnesthesiaService - The reason for the transaction is for health care anaesthesia services
    • DentalServices - The reason for the transaction is for dental services.
    • DurableMedicalEquipment - The reason for the transaction is the use of durable medical equipment.
    • BusinessExpenses - The reason for the transaction is business expenses.
    • AdvancePayment - The reason for payment is advance payment.
    • AgriculturalTransfer - Support payment to farmer.
    • Alimony - Payment on alimony.
    • ChildBenefit - Payment made to assist to parent/guardian to maintain child.
    • Unemployment-Disability-Benefit - Payment to person unemployed/disabled.
    • Bonus - The reason the transaction is bonus.
    • CashManagementTransfer - Reason for the transaction is cash management transfer.
    • CapitalBuildingFringeFortune - Capital building for retirement.
    • CommodityTransfer - Reason for payment is commodity.
    • CommercialCreditPayment - Reason for payment is commercial credit.
    • CommissionPayment - Payment of commission.
    • Costs - Reason for payments is costs.
    • CopyrightPayment - Reason for payment is copyright.
    • DividendPayment - Reason for payment is dividend.
    • ForeignExchange - Reason for transaction is foreign exchange.
    • PurchasingAndSellingOfGoods - Purchasing and selling of goods.
    • GovernmentPayment - Payment to or from a government department.
    • InstalmentOrHire-PurchaseAgreement - Reason for transaction is instalment or hire/purchase agreement.
    • InsurancePremium - Reason for transaction is insurance premium.
    • InterestPayment - Payment of interest.
    • LicenceFeesPayment - Payment of licence fees.
    • Loan - Transfer of loan to borrower.
    • LoanRepayment - Repayment of loan to lender.
    • Netting - Reason for transaction is netting.
    • PensionPayment - Payment of pension.
    • Refunding - Payment of refund.
    • Rent - Reason for transaction is rent.
    • RoyaltiesPayment - Payment of royalties.
    • SalaryPayment - Reason for payment is salary.
    • PurchasingAndSellingOfServices - Purchasing and selling of services.
    • Securities - Reason for transaction is securities.
    • SocialSecurityBenefit - Payment made by government to support individuals.
    • Subscription - Reason for transaction is subscription.
    • TaxPayment - Payment of tax.
    • ValueAddedTaxPayment - Payment of Value Added Tax (VAT).
    • VendorPayment

[^]Code Fragment

    <xsd:simpleType name="PaymentReasonCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="PaymentTerms">
        <xsd:enumeration value="MedicalServices">
        <xsd:enumeration value="MultipleTypesOfService">
        <xsd:enumeration value="NotOtherwiseSpecified">
        <xsd:enumeration value="VisionCare">
        <xsd:enumeration value="HomeHealthCare">
        <xsd:enumeration value="HospitalCare">
        <xsd:enumeration value="IntermediateCareFacility">
        <xsd:enumeration value="Long-TermCareFacility">
        <xsd:enumeration value="ConvalescentCareFacility">
        <xsd:enumeration value="AnesthesiaService">
        <xsd:enumeration value="DentalServices">
        <xsd:enumeration value="DurableMedicalEquipment">
        <xsd:enumeration value="BusinessExpenses">
        <xsd:enumeration value="AdvancePayment">
        <xsd:enumeration value="AgriculturalTransfer">
        <xsd:enumeration value="Alimony">
        <xsd:enumeration value="ChildBenefit">
        <xsd:enumeration value="Unemployment-Disability-Benefit">
        <xsd:enumeration value="Bonus">
        <xsd:enumeration value="CashManagementTransfer">
        <xsd:enumeration value="CapitalBuildingFringeFortune">
        <xsd:enumeration value="CommodityTransfer">
        <xsd:enumeration value="CommercialCreditPayment">
        <xsd:enumeration value="CommissionPayment">
        <xsd:enumeration value="Costs">
        <xsd:enumeration value="CopyrightPayment">
        <xsd:enumeration value="DividendPayment">
        <xsd:enumeration value="ForeignExchange">
        <xsd:enumeration value="PurchasingAndSellingOfGoods">
        <xsd:enumeration value="GovernmentPayment">
        <xsd:enumeration value="InstalmentOrHire-PurchaseAgreement">
        <xsd:enumeration value="InsurancePremium">
        <xsd:enumeration value="InterestPayment">
        <xsd:enumeration value="LicenceFeesPayment">
        <xsd:enumeration value="Loan">
        <xsd:enumeration value="LoanRepayment">
        <xsd:enumeration value="Netting">
        <xsd:enumeration value="PensionPayment">
        <xsd:enumeration value="Refunding">
        <xsd:enumeration value="Rent">
        <xsd:enumeration value="RoyaltiesPayment">
        <xsd:enumeration value="SalaryPayment">
        <xsd:enumeration value="PurchasingAndSellingOfServices">
        <xsd:enumeration value="Securities">
        <xsd:enumeration value="SocialSecurityBenefit">
        <xsd:enumeration value="Subscription">
        <xsd:enumeration value="TaxPayment">
        <xsd:enumeration value="ValueAddedTaxPayment">
        <xsd:enumeration value="VendorPayment">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: PaymentRequestAcknDetailType

PaymentRequestAcknDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ConfirmationID[xsd:string] , PaymentDocumentID[core:ReferenceType] , PaymentSequenceNo[xsd:int]? , SettlementAmount[core:MonetaryValueType]? , DebitAmount[core:MonetaryValueType]? , CreditAmount[core:MonetaryValueType]? , PaymentParty[PaymentPartyType]? , FinancialInstitutionDetail[core:FinancialInstitutionDetailType]? , ListOfRateOfExchangeDetail[core:ListOfRateOfExchangeDetailType]? , ExceptionNote[xsd:string]? , PaymentRequestNote[xsd:string]? , ListOfPaymentException[ListOfPaymentExceptionType]? , EncryptedInfo[EncryptedInfoType]? )

    Description: PaymentRequestAcknDetailType contains high level information for the PaymentRequest document.

    Elements:

    • ConfirmationID - contains the confirmation ID to acknowledge the receipt of the PaymentRequest document. This value is sent by the financial institution and should be used in the future to reference the payment.
    • PaymentDocumentID - contains a unique identifier for the payment document.
    • PaymentSequenceNo - contains a counter to track the payment document in the case where the PaymentRequest contains more than one payment document.
    • SettlementAmount - contains the monetary amount to be paid as specified in the PaymentRequest document. This is the requested payer amount specified by the Payer.
    • DebitAmount - specifies the amount banks actually debit from payer's account.
    • CreditAmount - specifies the amount banks actually credit to the payee's account.
    • PaymentParty - contains all parties relevant to the payment document. The required parties are the PayerParty and the PayeeParty. The PayerParty includes an optional CertificatAuthority field to specify a digital signature.
    • FinancialInstitutionDetail - contains specifications for the financial institution information which includes both account specific detail (i.e., account ID, account type, account holder) and financial institution specific detail (i.e., bank ID, branch ID). Financial institution information must be provided for the originating bank and associated account detail and the receiving bank and associated account detail.
    • ListOfRateOfExchangeDetail - contains one or more elements detailing information on the rate of exchange between currencies.
    • ExceptionNote -
    • PaymentRequestNote - contains any free form text pertinent to the PaymentRequest document. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfPaymentException -
    • EncryptedInfo - contains a placeholder to store customer or bank specific encrypted fields.

[^]Code Fragment

    <xsd:complexType name="PaymentRequestAcknDetailType">
    <xsd:sequence>
        <xsd:element name="ConfirmationID" type="xsd:string">
        <xsd:element name="PaymentDocumentID" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="PaymentSequenceNo" type="xsd:int">
        <xsd:element minOccurs="0" name="SettlementAmount" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="DebitAmount" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="CreditAmount" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="PaymentParty" type="PaymentPartyType">
        <xsd:element minOccurs="0" name="FinancialInstitutionDetail" type="core:FinancialInstitutionDetailType">
        <xsd:element minOccurs="0" name="ListOfRateOfExchangeDetail" type="core:ListOfRateOfExchangeDetailType">
        <xsd:element minOccurs="0" name="ExceptionNote" type="xsd:string">
        <xsd:element minOccurs="0" name="PaymentRequestNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfPaymentException" type="ListOfPaymentExceptionType">
        <xsd:element minOccurs="0" name="EncryptedInfo" type="EncryptedInfoType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PaymentRequestAcknHeaderType

PaymentRequestAcknHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PaymentRequestAcknID[xsd:string] , PaymentRequestAcknIssueDate[xsd:dateTime] , PaymentRequestIDReference[core:ReferenceType]? , PayerParty[PayerPartyType] , FinancialServicesParty[PayerPartyType] , PaymentRequestAcknPurpose[core:PurposeType]? , CertificateAuthority[xsd:string]? , SuccessfulReceiptIndicator[xsd:boolean] , GeneralNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? , Language[core:LanguageType] )

    Description: PaymentRequestAcknHeaderType contains information to acknowledge receipt of a PaymentRequest document.

    Elements:

    • PaymentRequestAcknID - indicates the unique number assigned to the PaymentRequestAckn typically according to the system that generated the document.
    • PaymentRequestAcknIssueDate - holds the time stamp provided by the application that created the PaymentRequestAcknowledgment document.
    • PaymentRequestIDReference - contains the payer's PaymentRequestID number from the PaymentRequest document.
    • PayerParty - describes the partner that is responsible for payment. This is assumed to also be the sender of the document. For PayerParty, the Party definition is extended to include CertificateAuthority.
    • FinancialServicesParty -
    • PaymentRequestAcknPurpose - indicates the intended function of the PaymentRequestAcknowledgment document.
    • CertificateAuthority - contains the payer's certificate of authority or digital signature which will be used by the financial institution to verify the origins of the document and validate the payment.
    • SuccessfulReceiptIndicator -
    • GeneralNote - contains any free-form text pertinent to the PaymentRequestAcknHeader. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfNameValueSet - is used to hold sets of name value pairs. The use of this element should be limited to the support of previous versions of xCBL.
    • Language - specifies the language used in the PaymentRequestAcknowledgment document. This is an ISO language code list.

[^]Code Fragment

    <xsd:complexType name="PaymentRequestAcknHeaderType">
    <xsd:sequence>
        <xsd:element name="PaymentRequestAcknID" type="xsd:string">
        <xsd:element name="PaymentRequestAcknIssueDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="PaymentRequestIDReference" type="core:ReferenceType">
        <xsd:element name="PayerParty" type="PayerPartyType">
        <xsd:element name="FinancialServicesParty" type="PayerPartyType">
        <xsd:element minOccurs="0" name="PaymentRequestAcknPurpose" type="core:PurposeType">
        <xsd:element minOccurs="0" name="CertificateAuthority" type="xsd:string">
        <xsd:element name="SuccessfulReceiptIndicator" type="xsd:boolean">
        <xsd:element minOccurs="0" name="GeneralNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
        <xsd:element name="Language" type="core:LanguageType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PaymentRequestAcknowledgmentType

PaymentRequestAcknowledgmentType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PaymentRequestAcknHeader[PaymentRequestAcknHeaderType] , ListOfPaymentRequestAcknDetail[ListOfPaymentRequestAcknDetailType] , PaymentRequestAcknSummary[PaymentRequestSummaryType]? )

    Description: PaymentRequestAcknowledgmentType acknowledges the receipt of the PaymentRequest.

    Elements:

    • PaymentRequestAcknHeader - contains information to acknowledge receipt of a PaymentRequest document.
    • ListOfPaymentRequestAcknDetail - contains a list of one or more payment document details for which the PaymentRequestAcknowledgement is referencing from the original PaymentRequest document.
    • PaymentRequestAcknSummary - contains summary information for the PaymentRequestAcknowledgment document.

[^]Code Fragment

    <xsd:complexType name="PaymentRequestAcknowledgmentType">
    <xsd:sequence>
        <xsd:element name="PaymentRequestAcknHeader" type="PaymentRequestAcknHeaderType">
        <xsd:element name="ListOfPaymentRequestAcknDetail" type="ListOfPaymentRequestAcknDetailType">
        <xsd:element minOccurs="0" name="PaymentRequestAcknSummary" type="PaymentRequestSummaryType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PaymentRequestDetailType

PaymentRequestDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PaymentDocumentID[core:ReferenceType] , PaymentSequenceNo[xsd:int]? , PaymentDates[PaymentDatesType]? , ( FinancialInstitutionDetail[core:FinancialInstitutionDetailType] | ( OriginatingFinancialInstitution[core:FIAccountType] , ReceivingFISpecificID[core:PartyType] ) | ( OriginatingFISpecificID[core:PartyType]? , ( ReceivingFinancialInstitution[core:FIAccountDetailType] | ReceivingFISpecificID[core:PartyType] ) ) | CardInfo[core:CardInfoType] ) , SettlementAmount[core:Decimal21_6Type] , SettlementCurrency[core:CurrencyType] , PaymentRequestParty[PaymentRequestPartyType] , LegalReportingInformation[LegalReportingInformationType]? , PaymentReasonCoded[PaymentReasonCodeType]? , PaymentReasonCodedOther[xsd:string]? , PaymentUrgencyCoded[PaymentUrgencyCodeType]? , PaymentUrgencyCodedOther[xsd:string]? , InternationalPaymentIndicator[xsd:boolean]? , IntraCompanyPaymentIndicator[xsd:boolean]? , PaymentMeanCoded[core:PaymentMeanCodeType] , PaymentMeanCodedOther[xsd:string]? , PaymentMeanReference[core:ReferenceType]? , PaymentSystemCoded[core:PaymentSystemCodeType]? , PaymentSystemCodedOther[xsd:string]? , PaymentReference[core:ListOfReferenceCodedType]? , AcceptFXMarketRate[xsd:boolean]? , ListOfRateOfExchangeDetail[core:ListOfRateOfExchangeDetailType]? , PaymentDetailAttachment[core:AttachmentType]? , PaymentInstructionNotes[xsd:string]? , IsCredit[xsd:boolean]? , RepetitiveCode[xsd:string]? , FinancialChargesAllocation[FinancialChargesAllocationType]? , ListOfPaymentDocumentDetail[ListOfPaymentDocumentDetailType]? )

    Description: PaymentRequestDetailType contains details and instructions for the PaymentRequest. This may include, for example, settlement amount, receiving financial institution detail, payment reason and payment mean codes, and payment dates.

    Elements:

    • PaymentDocumentID - contains a unique identifier for the payment document.
    • PaymentSequenceNo - contains a counter to track the payment document in the case where the PaymentRequest document contains more than one payment document.
    • PaymentDates - contains a list of dates that are pertinent to the payment document.
    • FinancialInstitutionDetail - contains specifications for the financial institution information which includes both account specific detail (i.e., account ID, account type, account holder) and financial institution specific detail (i.e., bank ID, branch ID).
    • OriginatingFinancialInstitution - contains the financial institution account information of the originating bank. The account detail and financial institution detail are required.
    • ReceivingFISpecificID - contains a bank specified ID to identify the payee information. This includes optional payee details such as address and contact. This can be an internal identifier assigned by the bank or possibly an MPID.contains a bank specified ID to identify the payee information. This includes optional payee details such as address and contact. This can be an internal identifier assigned by the bank or possibly an MPID.
    • OriginatingFISpecificID - contains a bank specified ID to identify the payer information. This includes optional payee details such as address and contact. This can be an internal identifier assigned by the bank or possibly an MPID.
    • ReceivingFinancialInstitution - contains the financial institution account information for the receiving bank. The account detail and financial institution detail is required.
    • ReceivingFISpecificID - contains a bank specified ID to identify the payee information. This includes optional payee details such as address and contact. This can be an internal identifier assigned by the bank or possibly an MPID.contains a bank specified ID to identify the payee information. This includes optional payee details such as address and contact. This can be an internal identifier assigned by the bank or possibly an MPID.
    • CardInfo - contains details of the credit or debit card that is being used for the payment. This includes credit card number, card type, card holder name, expiration date and other pertinent information.
    • SettlementAmount - specifies the monetary amount to be paid.
    • SettlementCurrency - specifies the currency for the PaymentRequest document. This is the currency in which the payment will be made. This is an ISO currency code list.
    • PaymentRequestParty - contains all parties relevant to the payment document. The PayerParty is optional in this structure.
    • LegalReportingInformation - contains legal reporting information associated with payments made to a foreign payee. This is used by central banks for processing cross border payments over a certain amount.
    • PaymentReasonCoded - specifies the business purpose of the payment.
    • PaymentReasonCodedOther - is used to provide a non-standard PaymentReasonCode. This element is mandatory if the value of PaymentReasonCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • PaymentUrgencyCoded - specifies the priority of the payment document.
    • PaymentUrgencyCodedOther - is used to provide a non-standard PaymentUrgencyCode. This element is mandatory if the value of PaymentUrgencyCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • InternationalPaymentIndicator - contains a boolean indicator to specify whether the payment is a cross border payment
    • IntraCompanyPaymentIndicator - contains a boolean indicator to specify if the payment is an intra-company transaction
    • PaymentMeanCoded - contains a valid means of extinguishing the debt to which it relates.
    • PaymentMeanCodedOther - is used to provide a non-standard PaymentMeanCode. This element is mandatory if the value of PaymentMeanCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • PaymentMeanReference - identifies specific information relating to the specified payment mean. For example, if the selected payment mean were check, then PaymentMeanReference would be used to communicate the check number.
    • PaymentSystemCoded - indicates the system through which the payment is processed using a standard codelist.
    • PaymentSystemCodedOther - is used to provide a non-standard PaymentSystemCode. This element is mandatory if the value of PaymentSystemCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • PaymentReference - contains a list of documents, business transactions, or identifiers that are relevant to the PaymentRequest.
    • AcceptFXMarketRate - specifies whether the payer is willing to accept an FI supplied market rate for payment.
    • ListOfRateOfExchangeDetail - contains one or more elements detailing information on the rate of exchange between currencies.
    • PaymentDetailAttachment - contains an attachment relevant to the payment request transaction.
    • PaymentInstructionNotes - contains any free-form text pertinent to the PaymentInstructionDetail. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • IsCredit - contains a boolean value to indicate whether the amount is a credit or debit.
    • RepetitiveCode - describes a company specific payment transaction code which a payer and the financial institution agree upon for fixed payments. The code is used to indicate the determined set of payer and payee accounts from which the funds will be transferred to or from. The financial institutions require this code to validate, transact, and bill properly.
    • FinancialChargesAllocation - contains information pertaining to how payment of fees will be allocated between partners.
    • ListOfPaymentDocumentDetail - contains the RemittanceAdvice details. Remittance detail is not required to process a payment. Thus, usage of this element is dependent on the established trading partner agreements between sender and receiver of this document.

[^]Code Fragment

    <xsd:complexType name="PaymentRequestDetailType">
    <xsd:sequence>
        <xsd:element name="PaymentDocumentID" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="PaymentSequenceNo" type="xsd:int">
        <xsd:element minOccurs="0" name="PaymentDates" type="PaymentDatesType">
        <xsd:choice>
            <xsd:element name="FinancialInstitutionDetail" type="core:FinancialInstitutionDetailType">
            <xsd:sequence>
                <xsd:element name="OriginatingFinancialInstitution" type="core:FIAccountType">
                <xsd:element name="ReceivingFISpecificID" type="core:PartyType">
            </xsd:sequence>
            <xsd:sequence>
                <xsd:element minOccurs="0" name="OriginatingFISpecificID" type="core:PartyType">
                <xsd:choice>
                    <xsd:element name="ReceivingFinancialInstitution" type="core:FIAccountDetailType">
                    <xsd:element name="ReceivingFISpecificID" type="core:PartyType">
                </xsd:choice>
            </xsd:sequence>
            <xsd:element name="CardInfo" type="core:CardInfoType">
        </xsd:choice>
        <xsd:element name="SettlementAmount" type="core:Decimal21_6Type">
        <xsd:element name="SettlementCurrency" type="core:CurrencyType">
        <xsd:element name="PaymentRequestParty" type="PaymentRequestPartyType">
        <xsd:element minOccurs="0" name="LegalReportingInformation" type="LegalReportingInformationType">
        <xsd:element minOccurs="0" name="PaymentReasonCoded" type="PaymentReasonCodeType">
        <xsd:element minOccurs="0" name="PaymentReasonCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="PaymentUrgencyCoded" type="PaymentUrgencyCodeType">
        <xsd:element minOccurs="0" name="PaymentUrgencyCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="InternationalPaymentIndicator" type="xsd:boolean">
        <xsd:element minOccurs="0" name="IntraCompanyPaymentIndicator" type="xsd:boolean">
        <xsd:element name="PaymentMeanCoded" type="core:PaymentMeanCodeType">
        <xsd:element minOccurs="0" name="PaymentMeanCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="PaymentMeanReference" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="PaymentSystemCoded" type="core:PaymentSystemCodeType">
        <xsd:element minOccurs="0" name="PaymentSystemCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="PaymentReference" type="core:ListOfReferenceCodedType">
        <xsd:element minOccurs="0" name="AcceptFXMarketRate" type="xsd:boolean">
        <xsd:element minOccurs="0" name="ListOfRateOfExchangeDetail" type="core:ListOfRateOfExchangeDetailType">
        <xsd:element minOccurs="0" name="PaymentDetailAttachment" type="core:AttachmentType">
        <xsd:element minOccurs="0" name="PaymentInstructionNotes" type="xsd:string">
        <xsd:element minOccurs="0" name="IsCredit" type="xsd:boolean">
        <xsd:element minOccurs="0" name="RepetitiveCode" type="xsd:string">
        <xsd:element minOccurs="0" name="FinancialChargesAllocation" type="FinancialChargesAllocationType">
        <xsd:element minOccurs="0" name="ListOfPaymentDocumentDetail" type="ListOfPaymentDocumentDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PaymentRequestHeaderType

PaymentRequestHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PaymentRequestID[xsd:string] , PaymentRequestIssueDate[xsd:dateTime] , PaymentRequestPurpose[core:PurposeType]? , PayerParty[PayerPartyType] , FinancialServicesParty[PayerPartyType] , Language[core:LanguageType] , GeneralNotes[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? , PaymentRequestAttachment[core:AttachmentType]? )

    Description: PaymentRequestHeaderType contains the header information of the PaymentRequest.

    Elements:

    • PaymentRequestID - specifies a unique identifier for the PaymentRequest document.
    • PaymentRequestIssueDate - holds the time stamp provided by the application that created the PaymentRequest document.
    • PaymentRequestPurpose - indicates the intended use of the PaymentRequest document.
    • PayerParty - describes the partner that is responsible for payment. This is assumed to also be the sender of the document. For PayerParty, the Party definition is extended to include CertificateAuthority.
    • FinancialServicesParty -
    • Language - identifies the language of the RemittanceAdvice.
    • GeneralNotes - contains any free-form text pertinent to the entire PaymentRequest. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfNameValueSet - is used to hold sets of name value pairs. The use of this element should be limited to the support of previous versions of xCBL.
    • PaymentRequestAttachment - holds an attachment applicable to the entire PaymentRequest,and is not specific to a particular item.

[^]Code Fragment

    <xsd:complexType name="PaymentRequestHeaderType">
    <xsd:sequence>
        <xsd:element name="PaymentRequestID" type="xsd:string">
        <xsd:element name="PaymentRequestIssueDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="PaymentRequestPurpose" type="core:PurposeType">
        <xsd:element name="PayerParty" type="PayerPartyType">
        <xsd:element name="FinancialServicesParty" type="PayerPartyType">
        <xsd:element name="Language" type="core:LanguageType">
        <xsd:element minOccurs="0" name="GeneralNotes" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
        <xsd:element minOccurs="0" name="PaymentRequestAttachment" type="core:AttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PaymentRequestPartyType

PaymentRequestPartyType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PayerParty[PayerPartyType]? , PayeeParty[core:PartyType] , BuyerParty[core:PartyType]? , SellerParty[core:PartyType]? , BillToParty[core:PartyType]? , ListOfPartyCoded[core:ListOfPartyCodedType]? )

    Description: PaymentRequestPartyType contains all parties relevant to the payment document. The PayerParty is optional in this structure.

    Elements:

    • PayerParty - describes the party responsible for payment. The PayerParty at the header level is the default payer. If this information is filled at the line level, then it overrides the header payer.
    • PayeeParty - describes the party to receive payment.
    • BuyerParty - describes the buyer of the goods or services.
    • SellerParty - describes the supplier of the goods or services.
    • BillToParty - describes the party to receive the invoice.
    • ListOfPartyCoded - contains information relevant to describing parties other than the source target parties which are relevant to the time series data.

[^]Code Fragment

    <xsd:complexType name="PaymentRequestPartyType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="PayerParty" type="PayerPartyType">
        <xsd:element name="PayeeParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="BuyerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="SellerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="BillToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ListOfPartyCoded" type="core:ListOfPartyCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PaymentRequestSummaryType

PaymentRequestSummaryType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( TotalPaymentDocuments[xsd:int]? , TotalLineItem[xsd:int]? , TotalSettlementAmount[core:MonetaryValueType]? , EncryptedInfo[EncryptedInfoType]? , ListOfSummaryItems[core:ListOfValuesType]? , SummaryNote[xsd:string]? )

    Description: PaymentRequestSummaryType contains the summary information of the PaymentRequest typically totals of numeric fields.

    Elements:

    • TotalPaymentDocuments - contains the total number of payment documents included in the payment request.
    • TotalLineItem - contains the total number of line item details given in the PaymentRequestDetails.
    • TotalSettlementAmount - contains the total amount of payment requested.
    • EncryptedInfo - contains a placeholder to store customer or bank specific encrypted fields.
    • ListOfSummaryItems - represent a payment run more completely. It is often the case that there will be check sums or summary values for certain items in a payment run and these items can vary from vendor to vendor. This element will allow this information to be communicated.
    • SummaryNote - contains any free-form text pertinent to the PaymentRequestSummary. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.

[^]Code Fragment

    <xsd:complexType name="PaymentRequestSummaryType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="TotalPaymentDocuments" type="xsd:int">
        <xsd:element minOccurs="0" name="TotalLineItem" type="xsd:int">
        <xsd:element minOccurs="0" name="TotalSettlementAmount" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="EncryptedInfo" type="EncryptedInfoType">
        <xsd:element minOccurs="0" name="ListOfSummaryItems" type="core:ListOfValuesType">
        <xsd:element minOccurs="0" name="SummaryNote" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PaymentRequestType

PaymentRequestType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PaymentRequestHeader[PaymentRequestHeaderType] , ListOfPaymentRequestDetail[ListOfPaymentRequestDetailType] , PaymentRequestSummary[PaymentRequestSummaryType]? , DigitalSignature[dgs:SignatureType]? )

    Description: PaymentRequestType consists of details for arranging for payment of a specified value amount to a beneficiary in settlement of a business transaction. The payer can initiate a PaymentRequest to instruct its financial institution to debit its account by the specified amount to be paid to the beneficiary for goods or services rendered. The PaymentRequest can reference multiple documents (i.e. PO, ASN, Invoice) but no reference is mandatory. The payment is expressed in a single language. Consolidated payment is supported. The Payer can send multiple payment requests in a single PaymentRequest document. Foreign exchange rates are supported. This is not an IFX compliant document; however IFX influenced the design of this document.

    Elements:

    • PaymentRequestHeader - contains the header information of the PaymentRequest.
    • ListOfPaymentRequestDetail - contains a list of payment documents which include details and instructions for payment. Each payment document can optionally have RemittanceAdviceDetail. This is a required element with at least one payment document.
    • PaymentRequestSummary - contains the summary information of the PaymentRequest typically totals of numeric fields.
    • DigitalSignature - contains a digital signature for the document.

[^]Code Fragment

    <xsd:complexType name="PaymentRequestType">
    <xsd:sequence>
        <xsd:element name="PaymentRequestHeader" type="PaymentRequestHeaderType">
        <xsd:element name="ListOfPaymentRequestDetail" type="ListOfPaymentRequestDetailType">
        <xsd:element minOccurs="0" name="PaymentRequestSummary" type="PaymentRequestSummaryType">
        <xsd:element minOccurs="0" name="DigitalSignature" type="dgs:SignatureType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: PaymentStatusEventCodeType

PaymentStatusEventCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:
    Reports status events related to Payment

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom code
    • NotApplicable
    • CreditReviewInProcess
    • CreditApproved
    • PrepaymentRequired
    • CardCharged
    • Invoiced
    • PaymentReceived
    • AutomatedPaymentInitiated
    • PaidInFull

[^]Code Fragment

    <xsd:simpleType name="PaymentStatusEventCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="NotApplicable">
        <xsd:enumeration value="CreditReviewInProcess">
        <xsd:enumeration value="CreditApproved">
        <xsd:enumeration value="PrepaymentRequired">
        <xsd:enumeration value="CardCharged">
        <xsd:enumeration value="Invoiced">
        <xsd:enumeration value="PaymentReceived">
        <xsd:enumeration value="AutomatedPaymentInitiated">
        <xsd:enumeration value="PaidInFull">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: PaymentStatusRequestDetailType

PaymentStatusRequestDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( SequenceNumber[xsd:int]? , ( PaymentRequestID[core:ReferenceType] | ConfirmationID[xsd:string] | PaymentDateRange[core:ValidityDatesType] | PaymentDates[PaymentDatesType] ) , SettlementAmount[core:MonetaryValueType]? , ListOfPaymentRequestReferences[core:ListOfReferenceType]? )

    Description: PaymentStatusRequestDetailType contains detailed information related to the payment status being requested.

    Elements:

    • SequenceNumber - contains a sequence number to be used if there are multiple payments per document.
    • PaymentRequestID - contains a unique identifier assigned by the payer for the original PaymentRequest transaction.
    • ConfirmationID - contains the confirmation identifier of the payment. This is the unique identifier assigned by the financial institution for the original PaymentRequest transaction.
    • PaymentDateRange - contains a date range for which the payment status is being requested. This element is composed of a StartDate and an EndDate.
    • PaymentDates - contains a list of dates that are pertinent to the payment. This structure is composed of optional PaymentDueDate, RequestedPaymentDate, PayBeforeDate and ListOfPaymentDates.
    • SettlementAmount - specifies the monetary amount paid.
    • ListOfPaymentRequestReferences - contains a list of references that are relevant to the PaymentRequest detail.

[^]Code Fragment

    <xsd:complexType name="PaymentStatusRequestDetailType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="SequenceNumber" type="xsd:int">
        <xsd:choice>
            <xsd:element name="PaymentRequestID" type="core:ReferenceType">
            <xsd:element name="ConfirmationID" type="xsd:string">
            <xsd:element name="PaymentDateRange" type="core:ValidityDatesType">
            <xsd:element name="PaymentDates" type="PaymentDatesType">
        </xsd:choice>
        <xsd:element minOccurs="0" name="SettlementAmount" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="ListOfPaymentRequestReferences" type="core:ListOfReferenceType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PaymentStatusRequestHeaderType

PaymentStatusRequestHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PaymentStatusRequestID[xsd:string] , PaymentStatusRequestIssueDate[xsd:dateTime] , PayerParty[PayerPartyType] , FinancialServicesParty[PayerPartyType] , Language[core:LanguageType] , GeneralNotes[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? )

    Description: PaymentStatusRequestHeaderType contains the header information of the PaymentStatusRequest.

    Elements:

    • PaymentStatusRequestID - is the unique number assigned to the PaymentStatusRequest.
    • PaymentStatusRequestIssueDate - holds a time stamp provided by the application that created the PaymentStatusRequest.
    • PayerParty - contains information for the party that is responsible for payment. This is assumed to also be the sender of the document. The PayerParty includes an optional CertificateAuthority field to hold the payer's digital signature or certificate of authority.
    • FinancialServicesParty -
    • Language - identifies the language of the PaymentStatusRequest.
    • GeneralNotes - contains any free form text pertinent to the entire PaymentStatusRequest or to the PaymentStatusRequest message itself. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.

[^]Code Fragment

    <xsd:complexType name="PaymentStatusRequestHeaderType">
    <xsd:sequence>
        <xsd:element name="PaymentStatusRequestID" type="xsd:string">
        <xsd:element name="PaymentStatusRequestIssueDate" type="xsd:dateTime">
        <xsd:element name="PayerParty" type="PayerPartyType">
        <xsd:element name="FinancialServicesParty" type="PayerPartyType">
        <xsd:element name="Language" type="core:LanguageType">
        <xsd:element minOccurs="0" name="GeneralNotes" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PaymentStatusRequestSummaryType

PaymentStatusRequestSummaryType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( TotalNumberPaymentRequests[xsd:int]? )

    Description: PaymentStatusRequestSummaryType contains the summary information of the PaymentRequestStatus.

    Elements:

    • TotalNumberPaymentRequests - contains the total number of PaymentRequest documents for which a status update is required.

[^]Code Fragment

    <xsd:complexType name="PaymentStatusRequestSummaryType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="TotalNumberPaymentRequests" type="xsd:int">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PaymentStatusRequestType

PaymentStatusRequestType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PaymentStatusRequestHeader[PaymentStatusRequestHeaderType] , ListOfPaymentStatusRequestDetail[ListOfPaymentStatusRequestDetailType] , PaymentStatusRequestSummary[PaymentStatusRequestSummaryType]? )

    Description: PaymentStatusRequestType enables payers to query the status of a previously submitted payment to/from a financial institution.

    Elements:

    • PaymentStatusRequestHeader - contains the header information of the PaymentStatusRequest.
    • ListOfPaymentStatusRequestDetail - contains a list of PaymentStatusRequest details.
    • PaymentStatusRequestSummary - contains the summary information of the PaymentRequestStatus.

[^]Code Fragment

    <xsd:complexType name="PaymentStatusRequestType">
    <xsd:sequence>
        <xsd:element name="PaymentStatusRequestHeader" type="PaymentStatusRequestHeaderType">
        <xsd:element name="ListOfPaymentStatusRequestDetail" type="ListOfPaymentStatusRequestDetailType">
        <xsd:element minOccurs="0" name="PaymentStatusRequestSummary" type="PaymentStatusRequestSummaryType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PaymentStatusResponseDetailType

PaymentStatusResponseDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( SequenceNumber[xsd:int]? , PaymentRequestID[core:ReferenceType] , ConfirmationID[xsd:string] , PaymentDates[PaymentDatesType]? , SettlementDate[xsd:dateTime]? , FXValueDate[xsd:dateTime]? , SettlementAmount[core:MonetaryValueType]? , DebitAmount[core:MonetaryValueType]? , CreditAmount[core:MonetaryValueType]? , OriginatingFinancialInstitution[core:FIAccountDetailType]? , ReceivingFinancialInstitution[core:FIAccountDetailType]? , CardInfo[core:CardInfoType]? , PaymentParty[PaymentPartyType]? , ParticipantUserID[core:IdentifierType]? , PaymentSystemCoded[core:PaymentSystemCodeType]? , PaymentSystemCodedOther[xsd:string]? , ListOfPaymentReferences[core:ListOfReferenceType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? , ListOfPaymentException[ListOfPaymentExceptionType] )

    Description: PaymentStatusResponseDetailType contains detailed information pertaining to the payment status. This includes payment document information containing payment related information at the line item level.

    Elements:

    • SequenceNumber - contains a sequence number to be used when there are multiple payments per document.
    • PaymentRequestID - contains the unique identifier assigned by the payer for the original PaymentRequest transaction.
    • ConfirmationID - contains the confirmation identifier of the payment. This is the unique identifier assigned by the financial institution for the original PaymentRequest transaction.
    • PaymentDates - contains a list of dates that are pertinent to the payment. This structure is composed of optional PaymentDueDate, RequestedPaymentDate, PayBeforeDate and ListOfPaymentDates.
    • SettlementDate - contains the actual date that the transaction is settled.
    • FXValueDate - contains the date that a foreign exchange transaction is expected to settle.
    • SettlementAmount - identifies the monetary amount paid.
    • DebitAmount - identifies the monetary amount debited from the originating account.
    • CreditAmount - identifies the monetary amount credited to the receiving account.
    • OriginatingFinancialInstitution - contains the financial institution account information for the "From" bank.
    • ReceivingFinancialInstitution - contains the financial institution information for the "To" bank.
    • CardInfo - contains details for payments made via credit card. This includes credit card number, card type, card holder name, expiration date, and other pertinent information.
    • PaymentParty - contains all parties relevant to the payment transaction. The required parties are the PayerParty and the PayeeParty. The PayerParty includes an optional CertificateAuthority field to specify a digital signature.
    • ParticipantUserID - contains the user identification of the participant.
    • PaymentSystemCoded - contains a code that indicates the system through which the payment was processed.
    • PaymentSystemCodedOther - is used to provide a non-standard PaymentSystemCode. This element is mandatory if the value of PaymentSystemCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • ListOfPaymentReferences - contains a list of payment related references such as invoice numbers, purchase order numbers, dates etc.
    • ListOfNameValueSet - contains a set of generic name and values pairs that can be used to describe payment details not explicitly specified in this document.
    • ListOfPaymentException - contains a list of response codes relating to the PaymentRequest document. This includes both positive status response codes as well as error response codes.

[^]Code Fragment

    <xsd:complexType name="PaymentStatusResponseDetailType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="SequenceNumber" type="xsd:int">
        <xsd:element name="PaymentRequestID" type="core:ReferenceType">
        <xsd:element name="ConfirmationID" type="xsd:string">
        <xsd:element minOccurs="0" name="PaymentDates" type="PaymentDatesType">
        <xsd:element minOccurs="0" name="SettlementDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="FXValueDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="SettlementAmount" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="DebitAmount" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="CreditAmount" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="OriginatingFinancialInstitution" type="core:FIAccountDetailType">
        <xsd:element minOccurs="0" name="ReceivingFinancialInstitution" type="core:FIAccountDetailType">
        <xsd:element minOccurs="0" name="CardInfo" type="core:CardInfoType">
        <xsd:element minOccurs="0" name="PaymentParty" type="PaymentPartyType">
        <xsd:element minOccurs="0" name="ParticipantUserID" type="core:IdentifierType">
        <xsd:element minOccurs="0" name="PaymentSystemCoded" type="core:PaymentSystemCodeType">
        <xsd:element minOccurs="0" name="PaymentSystemCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfPaymentReferences" type="core:ListOfReferenceType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
        <xsd:element name="ListOfPaymentException" type="ListOfPaymentExceptionType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PaymentStatusResponseHeaderType

PaymentStatusResponseHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PaymentStatusResponseID[xsd:string] , PaymentStatusResponseIssueDate[xsd:dateTime] , PaymentStatusRequestID[core:ReferenceType] , PayerParty[PayerPartyType] , FinancialServicesParty[PayerPartyType] , Language[core:LanguageType] , GeneralNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? )

    Description: PaymentStatusResponseHeaderType contains the header information of the PaymentStatusResponse.

    Elements:

    • PaymentStatusResponseID - is the unique number of the PaymentStatusResponse.
    • PaymentStatusResponseIssueDate - holds a time stamp provided by the application that created the PaymentStatusResponse.
    • PaymentStatusRequestID - is the unique number of the original PaymentStatusRequest.
    • PayerParty - contains information for the party that is responsible for payment. This is assumed to also be the sender of the document. The PayerParty includes an optional CertificateAuthority field to hold the payer's digital signature or certificate of authority.
    • FinancialServicesParty - contains details of the financial institution that is responsible for payment. This is assumed to also be the sender of the document. The PayerParty includes an optional CertificateAuthority field to hold the payer's digital signature or certificate of authority.
    • Language - identifies the language of the PaymentStatusResponse.
    • GeneralNote - contains any free form text pertinent to the entire PaymentStatusResponse or to the PaymentStatusResponse message itself. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.

[^]Code Fragment

    <xsd:complexType name="PaymentStatusResponseHeaderType">
    <xsd:sequence>
        <xsd:element name="PaymentStatusResponseID" type="xsd:string">
        <xsd:element name="PaymentStatusResponseIssueDate" type="xsd:dateTime">
        <xsd:element name="PaymentStatusRequestID" type="core:ReferenceType">
        <xsd:element name="PayerParty" type="PayerPartyType">
        <xsd:element name="FinancialServicesParty" type="PayerPartyType">
        <xsd:element name="Language" type="core:LanguageType">
        <xsd:element minOccurs="0" name="GeneralNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PaymentStatusResponseType

PaymentStatusResponseType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PaymentStatusResponseHeader[PaymentStatusResponseHeaderType] , ListOfPaymentStatusResponseDetail[ListOfPaymentStatusResponseDetailType] , PaymentStatusResponseSummary[PaymentStatusRequestSummaryType]? )

    Description: PaymentStatusResponseType . The payment status response document enables the financial institution to send the information on the status of a payment to the payer.

    Elements:

    • PaymentStatusResponseHeader - contains the header information of the PaymentStatusResponse.
    • ListOfPaymentStatusResponseDetail - contains a list of PaymentStatusResponse details.
    • PaymentStatusResponseSummary - contains the summary information of the PaymentStatusResponse document.

[^]Code Fragment

    <xsd:complexType name="PaymentStatusResponseType">
    <xsd:sequence>
        <xsd:element name="PaymentStatusResponseHeader" type="PaymentStatusResponseHeaderType">
        <xsd:element name="ListOfPaymentStatusResponseDetail" type="ListOfPaymentStatusResponseDetailType">
        <xsd:element minOccurs="0" name="PaymentStatusResponseSummary" type="PaymentStatusRequestSummaryType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: PaymentUrgencyCodeType

PaymentUrgencyCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:
    This code identifies whether the payment should be normal or express.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Normal - Normal payment processing
    • Express - Express payment processing
    • Other - Other

[^]Code Fragment

    <xsd:simpleType name="PaymentUrgencyCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Normal">
        <xsd:enumeration value="Express">
        <xsd:enumeration value="Other">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: RelatedInvoiceRefType

RelatedInvoiceRefType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( RelatedInvoiceType[InvoiceTypeType] , InvoiceNumber[core:ReferenceType] , InvoiceLineItemNumber[xsd:string]? )

    Description: RelatedInvoiceRefType holds a reference to another invoice.

    Elements:

    • RelatedInvoiceType - identifies the type of the invoice that is being referenced.
    • InvoiceNumber - holds the number of another invoice issued by the seller.
    • InvoiceLineItemNumber - holds a reference to the line item within the referenced invoice.

[^]Code Fragment

    <xsd:complexType name="RelatedInvoiceRefType">
    <xsd:sequence>
        <xsd:element name="RelatedInvoiceType" type="InvoiceTypeType">
        <xsd:element name="InvoiceNumber" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="InvoiceLineItemNumber" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: RemittanceAdviceDetailType

RemittanceAdviceDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ( ListOfSubsidiary[ListOfSubsidiaryType] | ListOfInvoicingDetail[ListOfInvoicingDetailType] | ListOfLineItemAdjustment[ListOfLineItemAdjustmentType] ) , GeneralNote[xsd:string]? )

    Description: RemittanceAdviceDetailType contains detail information pertaining to the RemittanceAdvice document. The structure is composed of Adjustments, Subsidiary and/or InvoicingDetail

    Elements:

    • ListOfSubsidiary - contains a set of subsidiary detail with associated invoicing and adjustment information. This structure is used in the case where the payment is made by a central party and invoice detail needs to be specified by subsidiary.
    • ListOfInvoicingDetail - contains a set of invoicing detail.
    • ListOfLineItemAdjustment - contains a set of adjustment detail.
    • GeneralNote - describes any free-form text pertinent to the detail item described by the RemittanceAdvice. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.

[^]Code Fragment

    <xsd:complexType name="RemittanceAdviceDetailType">
    <xsd:sequence>
        <xsd:choice>
            <xsd:element name="ListOfSubsidiary" type="ListOfSubsidiaryType">
            <xsd:element name="ListOfInvoicingDetail" type="ListOfInvoicingDetailType">
            <xsd:element name="ListOfLineItemAdjustment" type="ListOfLineItemAdjustmentType">
        </xsd:choice>
        <xsd:element minOccurs="0" name="GeneralNote" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: RemittanceAdviceHeaderType

RemittanceAdviceHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( RemittanceAdviceID[xsd:string] , RemittanceAdviceIssueDate[xsd:dateTime] , RemittanceAdvicePurpose[core:PurposeType]? , RemittanceAdviceStatusCoded[RemittanceAdviceStatusCodeType]? , RemittanceAdviceStatusCodedOther[xsd:string]? , PaymentSettlementDate[xsd:dateTime]? , TotalAmountDue[core:MonetaryValueType]? , TotalAmountPaid[core:MonetaryValueType] , PaymentCurrency[core:CurrencyType] , ListOfRateOfExchangeDetail[core:ListOfRateOfExchangeDetailType]? , ListOfPrice[core:ListOfPriceType]? , Language[core:LanguageType] , IsCredit[xsd:boolean]? , PaymentInstructions[core:PaymentInstructionsType]? , ListOfFinancialInstitutionCoded[ListOfFinancialInstitutionCodedType]? , PaymentParty[PaymentPartyType] , PaymentReasonCoded[PaymentReasonCodeType]? , PaymentReasonCodedOther[xsd:string]? , TransactionHandlingCoded[TransactionHandlingCodeType]? , TransactionHandlingCodedOther[xsd:string]? , TraceType[TraceTypeType]? , ListOfRemittanceAdviceReference[core:ListOfReferenceCodedType]? , RemittanceAdviceHeaderNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? , ListOfAttachment[core:ListOfAttachmentType]? )

    Description: RemittanceAdviceHeaderType contains the header information for the RemittanceAdvice.

    Elements:

    • RemittanceAdviceID - contains the unique number that identifies the RemittanceAdvice, typically according to the system that generated the RemittanceAdvice.
    • RemittanceAdviceIssueDate - holds a time stamp provided by the application that created the RemittanceAdvice document.
    • RemittanceAdvicePurpose - indicates the intended use of the RemittanceAdvice document.
    • RemittanceAdviceStatusCoded - provides the status of the RemittanceAdvice in terms of the payment stage.
    • RemittanceAdviceStatusCodedOther - is used to provide a non-standard RemittanceAdviceStatusCode. This element is only used if the value of RemittanceAdviceStatusCoded is 'Other' when it is mandatory.
    • PaymentSettlementDate - contains the date the originating company intends for the transaction to be settled.
    • TotalAmountDue - contains the total amount of payment due.
    • TotalAmountPaid - contains the total amount of payment being made.
    • PaymentCurrency - specifies the currency used in the payment transaction.
    • ListOfRateOfExchangeDetail - contains one or more elements detailing information on the rate of exchange between currencies.
    • ListOfPrice - is used to provide default pricing schemes for all items contained in the RemittanceAdvice.
    • Language - specifies the language used in the RemittanceAdvice. This is an ISO language code.
    • IsCredit - contains a boolean indicator to specify whether the amount is a credit or debit.
    • PaymentInstructions - contains the terms and the method of payment for goods or services received.
    • ListOfFinancialInstitutionCoded - identifies any other financial institutions other than the originating and recieving that are relavent to the remittance advice.
    • PaymentParty - contains information on all parties involved in the RemittanceAdvice.
    • PaymentReasonCoded - specifies the business purpose of the payment.
    • PaymentReasonCodedOther - is used to provide a non-standard PaymentReasonCode. This element is mandatory if the value of PaymentReasonCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • TransactionHandlingCoded - communicates the handling of transactions relating to the remittance advice document
    • TransactionHandlingCodedOther - is used to provide a non-standard TransactionHandlingCode. This element is only used if the value of TransactionHandlingCoded is 'Other' when it is mandatory.
    • TraceType - identifies a transaction being referenced.
    • ListOfRemittanceAdviceReference - contains a list of documents, business transactions, or identifiers that are relevant to the RemittanceAdvice document, i.e.: invoices, purchase order, ASN.
    • RemittanceAdviceHeaderNote - contains any free-form text pertinent to the entire RemittanceAdvice. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. Such notes may include the line item text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line, or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfNameValueSet - is used to holds a collection of values qualified by names. The values contianed in this element should be agreed upon by trading partners.
    • ListOfAttachment - holds a list of attachments applicable to the entire Invoice, or to a large part of the invoice it describes.

[^]Code Fragment

    <xsd:complexType name="RemittanceAdviceHeaderType">
    <xsd:sequence>
        <xsd:element name="RemittanceAdviceID" type="xsd:string">
        <xsd:element name="RemittanceAdviceIssueDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="RemittanceAdvicePurpose" type="core:PurposeType">
        <xsd:element minOccurs="0" name="RemittanceAdviceStatusCoded" type="RemittanceAdviceStatusCodeType">
        <xsd:element minOccurs="0" name="RemittanceAdviceStatusCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="PaymentSettlementDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="TotalAmountDue" type="core:MonetaryValueType">
        <xsd:element name="TotalAmountPaid" type="core:MonetaryValueType">
        <xsd:element name="PaymentCurrency" type="core:CurrencyType">
        <xsd:element minOccurs="0" name="ListOfRateOfExchangeDetail" type="core:ListOfRateOfExchangeDetailType">
        <xsd:element minOccurs="0" name="ListOfPrice" type="core:ListOfPriceType">
        <xsd:element name="Language" type="core:LanguageType">
        <xsd:element minOccurs="0" name="IsCredit" type="xsd:boolean">
        <xsd:element minOccurs="0" name="PaymentInstructions" type="core:PaymentInstructionsType">
        <xsd:element minOccurs="0" name="ListOfFinancialInstitutionCoded" type="ListOfFinancialInstitutionCodedType">
        <xsd:element name="PaymentParty" type="PaymentPartyType">
        <xsd:element minOccurs="0" name="PaymentReasonCoded" type="PaymentReasonCodeType">
        <xsd:element minOccurs="0" name="PaymentReasonCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="TransactionHandlingCoded" type="TransactionHandlingCodeType">
        <xsd:element minOccurs="0" name="TransactionHandlingCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="TraceType" type="TraceTypeType">
        <xsd:element minOccurs="0" name="ListOfRemittanceAdviceReference" type="core:ListOfReferenceCodedType">
        <xsd:element minOccurs="0" name="RemittanceAdviceHeaderNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
        <xsd:element minOccurs="0" name="ListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: RemittanceAdviceStatusCodeType

RemittanceAdviceStatusCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:
    Identifies the status of the remittance advice in terms of the payment stage.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • Approved - Payment approved
    • PaymentReleased - Payment released to Financial Institution
    • Paid - Payment confirmed by Financial Institution

[^]Code Fragment

    <xsd:simpleType name="RemittanceAdviceStatusCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Approved">
        <xsd:enumeration value="PaymentReleased">
        <xsd:enumeration value="Paid">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: RemittanceAdviceSummaryType

RemittanceAdviceSummaryType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( TotalPaymentDocuments[xsd:int]? , TotalLineItem[xsd:int]? , EncryptedInfo[EncryptedInfoType]? , ListOfSummaryItems[core:ListOfValuesType]? , SummaryNote[xsd:string]? )

    Description: RemittanceAdviceSummaryType contains the summary information of the PaymentRequest typically totals of numeric fields.

    Elements:

    • TotalPaymentDocuments - contains the total number of payment documents included in the payment request.
    • TotalLineItem - contains the total number of line item details given in the PaymentRequestDetails.
    • EncryptedInfo - contains a placeholder to store customer or bank specific encrypted fields.
    • ListOfSummaryItems - represent a payment run more completely. It is often the case that there will be check sums or summary values for certain items in a payment run and these items can vary from vendor to vendor. This element will allow this information to be communicated.
    • SummaryNote - contains any free-form text pertinent to the PaymentRequestSummary. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.

[^]Code Fragment

    <xsd:complexType name="RemittanceAdviceSummaryType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="TotalPaymentDocuments" type="xsd:int">
        <xsd:element minOccurs="0" name="TotalLineItem" type="xsd:int">
        <xsd:element minOccurs="0" name="EncryptedInfo" type="EncryptedInfoType">
        <xsd:element minOccurs="0" name="ListOfSummaryItems" type="core:ListOfValuesType">
        <xsd:element minOccurs="0" name="SummaryNote" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: RemittanceAdviceType

RemittanceAdviceType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( RemittanceAdviceHeader[RemittanceAdviceHeaderType] , RemittanceAdviceDetail[RemittanceAdviceDetailType] , RemittanceAdviceSummary[RemittanceAdviceSummaryType]? , DigitalSignature[dgs:SignatureType]? )

    Description: RemittanceAdviceType advises a trading partner of payment for specific goods and/or services being provided. Payers may initiate a RemittanceAdvice with a related payment request to specify the exact goods being paid. Payers may also initiate a RemittanceAdvice to inform payees of the intent to refund moneys for specific goods and/or services.

    Elements:

    • RemittanceAdviceHeader - contains the header information for the RemittanceAdvice.
    • RemittanceAdviceDetail - contains all line item information pertaining to the RemittanceAdvice.
    • RemittanceAdviceSummary - contains summary information for the RemittanceAdvice document.
    • DigitalSignature - contains a digital signature for the document.

[^]Code Fragment

    <xsd:complexType name="RemittanceAdviceType">
    <xsd:sequence>
        <xsd:element name="RemittanceAdviceHeader" type="RemittanceAdviceHeaderType">
        <xsd:element name="RemittanceAdviceDetail" type="RemittanceAdviceDetailType">
        <xsd:element minOccurs="0" name="RemittanceAdviceSummary" type="RemittanceAdviceSummaryType">
        <xsd:element minOccurs="0" name="DigitalSignature" type="dgs:SignatureType">
    </xsd:sequence>
</xsd:complexType>


Simple Types:

AdjustmentReasonCodeType
ChargeRegulationCodeType
ComputationalMethodCodeType
FXQuoteTypeCodeType
FXTransactionTypeCodeType
IndustrySectorCodeType
InvoiceMediumCodeType
InvoicePurposeCodeType
InvoiceTypeCodeType
PaymentExceptionCodeType
PaymentReasonCodeType
PaymentStatusEventCodeType
PaymentUrgencyCodeType
RemittanceAdviceStatusCodeType
TraceTypeCodeType
TransactionHandlingCodeType


complexType definition: SpecificRequirementType

SpecificRequirementType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( RequirementTypeCoded[core:ReferenceTypeCodeType] , RequirementTypeCodedOther[xsd:string]? , RequirementReference[core:ReferenceType]? , RequirementDetails[xsd:string]? )

    Description: SpecificRequirementType qualifies and provides detail about any information specifically required.

    Elements:

    • RequirementTypeCoded -
    • RequirementTypeCodedOther -
    • RequirementReference - provides any reference information specific to the requirement. Typically this would be used to reference another document.
    • RequirementDetails - provides any details about the specific requirement. If the requirement is for a free form text description, this field should be used.

[^]Code Fragment

    <xsd:complexType name="SpecificRequirementType">
    <xsd:sequence>
        <xsd:element name="RequirementTypeCoded" type="core:ReferenceTypeCodeType">
        <xsd:element minOccurs="0" name="RequirementTypeCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="RequirementReference" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="RequirementDetails" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: SpotRateDetailType

SpotRateDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( SpotRateID[core:ReferenceType] , ConfirmationID[xsd:string] , FXIdentificationData[FXIdentificationDataType]? , FXReferenceNumber[core:ReferenceType]? , FXAmounts[FXAmountsType]? , ListOfFee[ListOfFeeType]? , FXTransactionTypeCoded[FXTransactionTypeCodeType]? , FXTransactionTypeCodedOther[xsd:string]? , FXQuoteTypeCoded[FXQuoteTypeCodeType]? , FXQuoteTypeCodedOther[xsd:string]? , FXDates[FXDatesType]? )

    Description: SpotRateDetailType contains fields and elements specific to the spot rate quote. This structure is provided when the IndicativeIndicator is false.

    Elements:

    • SpotRateID - contains an identification relevant to the spot rate transaction.
    • ConfirmationID - contains free form text pertinent to the confirmation identification.
    • FXIdentificationData - contains data relevant to identifying the parties involved in the spot rate transaction.
    • FXReferenceNumber - contains a reference to the origins of the exchange rate quote. This contains the FX rate reference number.
    • FXAmounts - contains all amount data relevant to the spot rate quote.
    • ListOfFee - contains a list of fees and amounts pertinent to the spot FX rate quote.
    • FXTransactionTypeCoded - contains the specific type of FX transaction quoted.
    • FXTransactionTypeCodedOther - is used to provide a non-standard FXTransactionTypeCode. This element is mandatory if the value of FXTransactionTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • FXQuoteTypeCoded - contains the coded FXRate quote type.
    • FXQuoteTypeCodedOther - is used to provide a non-standard FXQuoteTypeCode. This element is mandatory if the value of FXQuoteTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • FXDates - contains dates relevant to the spot rate quote.

[^]Code Fragment

    <xsd:complexType name="SpotRateDetailType">
    <xsd:sequence>
        <xsd:element name="SpotRateID" type="core:ReferenceType">
        <xsd:element name="ConfirmationID" type="xsd:string">
        <xsd:element minOccurs="0" name="FXIdentificationData" type="FXIdentificationDataType">
        <xsd:element minOccurs="0" name="FXReferenceNumber" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="FXAmounts" type="FXAmountsType">
        <xsd:element minOccurs="0" name="ListOfFee" type="ListOfFeeType">
        <xsd:element minOccurs="0" name="FXTransactionTypeCoded" type="FXTransactionTypeCodeType">
        <xsd:element minOccurs="0" name="FXTransactionTypeCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="FXQuoteTypeCoded" type="FXQuoteTypeCodeType">
        <xsd:element minOccurs="0" name="FXQuoteTypeCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="FXDates" type="FXDatesType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: SubsidiaryType

SubsidiaryType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: Extends: core:PartyType

      Append:( ListOfInvoicingDetail[ListOfInvoicingDetailType] )

    Description: SubsidiaryType contains information relating to a third party or subsidiary associated with the payment document.

    Elements:

    • ListOfInvoicingDetail - contains invoicing document line item detail along with any relevant adjustment detail.

[^]Code Fragment

    <xsd:complexType name="SubsidiaryType">
    <xsd:complexContent>
        <xsd:extension base="core:PartyType">
            <xsd:sequence>
                <xsd:element name="ListOfInvoicingDetail" type="ListOfInvoicingDetailType">
            </xsd:sequence>
        </xsd:extension>
    </xsd:complexContent>
</xsd:complexType>


simpleType definition: TraceTypeCodeType

TraceTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other
    • CurrentTransactionTraceNumbers
    • ReferencedTransactionTraceNumbers
    • FinancialReassociationTraceNumber

[^]Code Fragment

    <xsd:simpleType name="TraceTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="CurrentTransactionTraceNumbers">
        <xsd:enumeration value="ReferencedTransactionTraceNumbers">
        <xsd:enumeration value="FinancialReassociationTraceNumber">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: TraceTypeType

TraceTypeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( TraceTypeCoded[TraceTypeCodeType] , TraceTypeCodedOther[xsd:string]? , TraceReference[core:ReferenceType]? )

    Description: TraceTypeType identifies a transaction being referenced.

    Elements:

    • TraceTypeCoded - specifies the trace type. Based on X12 481
    • TraceTypeCodedOther - is used to provide a non-standard TraceTypeCode. This element is only used if the value of TraceTypeCoded is 'Other' when it is mandatory.
    • TraceReference - provides further reference information for the transaction being referenced.

[^]Code Fragment

    <xsd:complexType name="TraceTypeType">
    <xsd:sequence>
        <xsd:element name="TraceTypeCoded" type="TraceTypeCodeType">
        <xsd:element minOccurs="0" name="TraceTypeCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="TraceReference" type="core:ReferenceType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: TransactionHandlingCodeType

TransactionHandlingCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/financial/v1_0/financial.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:
    This code the handling of the transaction for remittance advice. This code list is derived from X12 305 (Transaction Handling Code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom code
    • OffInvoiceDeductionFromOriginalInvoice - Off invoice (deduction from original invoice)
    • DebitCreditAdviceNoRemittanceDetail - Debit/credit advice no remittance detail
    • PaymentAccompaniesRemittanceAdvice - Payment accompanies remittance advice
    • MakePaymentOnly - Make payment only
    • DebitCreditAdviceWithRemittanceDetail - Debit/credit advice with remittance detail
    • PlanAndSubmitSuggestedPurchaseOrder - Plan and submit suggested purchase order(s)
    • PlanOrderAndShipProduct - Plan order(s) and ship product
    • NotificationOnly - Notification only
    • RemittanceInformationOnly - Remittance information only
    • PaymentRequestedAdjustmentToAccount - Payment requested (adjustment to account)
    • ReimbursementToFollow - Reimbursement to follow
    • ApplyOnAccount - Apply on account
    • MemoAdditionalRemittanceDetail - Memo/additional remittance detail
    • CheckIssuanceNotice - Check issuance notice
    • DeductFromNextRemittance - Deduct from next remittance
    • PrenotificationOfFutureTransfers - Prenotification of future transfers
    • PaymentBeingIssuedCreditDue - Credit due, payment being issued
    • RecurringDebitAuthorization - Recurring debit authorization
    • SingleDebitAuthorization - Single debit authorization
    • AdjustmentRequested - Adjustment requested
    • SplitPaymentAndRemittance - Split payment and remittance
    • HandlingPartysOptionToSplitPaymentAndRemittance - Handling party's option to split payment and remittance

[^]Code Fragment

    <xsd:simpleType name="TransactionHandlingCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="OffInvoiceDeductionFromOriginalInvoice">
        <xsd:enumeration value="DebitCreditAdviceNoRemittanceDetail">
        <xsd:enumeration value="PaymentAccompaniesRemittanceAdvice">
        <xsd:enumeration value="MakePaymentOnly">
        <xsd:enumeration value="DebitCreditAdviceWithRemittanceDetail">
        <xsd:enumeration value="PlanAndSubmitSuggestedPurchaseOrder">
        <xsd:enumeration value="PlanOrderAndShipProduct">
        <xsd:enumeration value="NotificationOnly">
        <xsd:enumeration value="RemittanceInformationOnly">
        <xsd:enumeration value="PaymentRequestedAdjustmentToAccount">
        <xsd:enumeration value="ReimbursementToFollow">
        <xsd:enumeration value="ApplyOnAccount">
        <xsd:enumeration value="MemoAdditionalRemittanceDetail">
        <xsd:enumeration value="CheckIssuanceNotice">
        <xsd:enumeration value="DeductFromNextRemittance">
        <xsd:enumeration value="PrenotificationOfFutureTransfers">
        <xsd:enumeration value="PaymentBeingIssuedCreditDue">
        <xsd:enumeration value="RecurringDebitAuthorization">
        <xsd:enumeration value="SingleDebitAuthorization">
        <xsd:enumeration value="AdjustmentRequested">
        <xsd:enumeration value="SplitPaymentAndRemittance">
        <xsd:enumeration value="HandlingPartysOptionToSplitPaymentAndRemittance">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: AdvanceShipmentNoticeType

AdvanceShipmentNoticeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ASNHeader[ASNHeaderType] , ASNDetail[ASNDetailType]? , ASNSummary[ASNSummaryType]? , DigitalSignature[dgs:SignatureType]? )

    Description: AdvanceShipmentNoticeType (ASN) comprises the notification by a supplier to the buyer of a shipment. The shipment can be for planning or serve as a notice of a shipment in progress. Therefore it is not necessary for a supplier to provide a preliminary notice of shipment, nor is it necessary for a supplier to send an actual note of shipment. Actual tracking of freight will initially be handled by the shipper directly and not via the ASN. Buyers can respond to the ASN with an ASN Error document that will be created at a later date.

    Elements:

    • ASNHeader - contains the header information of the ASN.
    • ASNDetail - contains line item and package details of the ASN.
    • ASNSummary - contains the summary information of the ASN, typically totals of numerical fields.
    • DigitalSignature - contains a digital signature for the document.

[^]Code Fragment

    <xsd:complexType name="AdvanceShipmentNoticeType">
    <xsd:sequence>
        <xsd:element name="ASNHeader" type="ASNHeaderType">
        <xsd:element minOccurs="0" name="ASNDetail" type="ASNDetailType">
        <xsd:element minOccurs="0" name="ASNSummary" type="ASNSummaryType">
        <xsd:element minOccurs="0" name="DigitalSignature" type="dgs:SignatureType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ASNBaseItemDetailType

ASNBaseItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( LineItemNum[core:LineItemNumType] , LineItemType[core:LineItemTypeType]? , ParentItemNumber[core:LineItemNumberReferenceType]? , ItemIdentifiers[core:ItemIdentifiersType]? , ListOfDimension[core:ListOfDimensionType]? , ASNQuantities[ASNQuantitiesType] , CountryOfOrigin[core:CountryType]? , CountryOfDestination[core:CountryType]? , ASNLineItemParty[ASNLineItemPartyType]? , HazardousMaterials[core:HazardousType]? , DetailResponseCoded[core:DetailResponseCodeType]? , DetailResponseCodedOther[xsd:string]? , ASNLineItemReferences[ASNLineItemReferencesType]? , ItemPackagingReference[core:ItemPackagingReferenceType]? , ListOfDestinationRef[core:ListOfDestinationRefType]? , ASNItemDates[ASNItemDatesType]? )

    Description: ASNBaseItemDetailType contains the identifying and descriptive information for the line items in the ASN. The TotalQuantity element from BaseItemDetail is used to hold the quantity of the item that is being shipped in this advance shipment notice.

    Elements:

    • LineItemNum - is a set of numbers uniquely identifying the line item for the number. In the case where the seller's system splits a line item number into 2 line items, the buyer item number will remain the same for both line items, but the seller item number will be different.
    • LineItemType - identifies whether the line item is a component group (consists of other line items), a typical line item, or a textual line item.
    • ParentItemNumber - identifies the line item that groups this and other line items. This is done using LineItemNumberReference, which specifies the number of the parent line item and whether this reference is the Buyer or Seller's number. LineItemNumberReference is a string content model of datatype integer that contains an attribute to specify whether the ParentItemNumber is a Seller or Buyer number, with the default being Buyer. This value references the parent item represented a group.
    • ItemIdentifiers - details all of the part numbers assigned to the item.
    • ListOfDimension - lists one or more quantitative measurements of the item.
    • ASNQuantities - specifies the quantities of the item pertaining to the ship notice.
    • CountryOfOrigin - specifies the country code for the country in which the line item was manufactured.
    • CountryOfDestination - specifies the country code for the country in which the delivery is finally received.
    • ASNLineItemParty - identifies the parties relevant to the item.
    • HazardousMaterials - contains the hazardous information for the line item.
    • DetailResponseCoded - specifies the response for the item in the advance shipment notice.
    • DetailResponseCodedOther - is used to provide a non-standard DetailResponseCode. This element is mandatory if the value of DetailResponseCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • ASNLineItemReferences - describes the references at the line item level if different than the header level.
    • ItemPackagingReference - identifies which package the line item is in.
    • ListOfDestinationRef - holds a list of all the destinations for the line item.
    • ASNItemDates - holds a collection of dates relative to this item.

[^]Code Fragment

    <xsd:complexType name="ASNBaseItemDetailType">
    <xsd:sequence>
        <xsd:element name="LineItemNum" type="core:LineItemNumType">
        <xsd:element minOccurs="0" name="LineItemType" type="core:LineItemTypeType">
        <xsd:element minOccurs="0" name="ParentItemNumber" type="core:LineItemNumberReferenceType">
        <xsd:element minOccurs="0" name="ItemIdentifiers" type="core:ItemIdentifiersType">
        <xsd:element minOccurs="0" name="ListOfDimension" type="core:ListOfDimensionType">
        <xsd:element name="ASNQuantities" type="ASNQuantitiesType">
        <xsd:element minOccurs="0" name="CountryOfOrigin" type="core:CountryType">
        <xsd:element minOccurs="0" name="CountryOfDestination" type="core:CountryType">
        <xsd:element minOccurs="0" name="ASNLineItemParty" type="ASNLineItemPartyType">
        <xsd:element minOccurs="0" name="HazardousMaterials" type="core:HazardousType">
        <xsd:element minOccurs="0" name="DetailResponseCoded" type="core:DetailResponseCodeType">
        <xsd:element minOccurs="0" name="DetailResponseCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="ASNLineItemReferences" type="ASNLineItemReferencesType">
        <xsd:element minOccurs="0" name="ItemPackagingReference" type="core:ItemPackagingReferenceType">
        <xsd:element minOccurs="0" name="ListOfDestinationRef" type="core:ListOfDestinationRefType">
        <xsd:element minOccurs="0" name="ASNItemDates" type="ASNItemDatesType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ASNDatesType

ASNDatesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( DeliveryDate[xsd:dateTime]? , ShipDate[xsd:dateTime]? , EarliestDeliveryDate[xsd:dateTime]? , LatestDeliveryDate[xsd:dateTime]? , CollectionDateOfCargo[xsd:dateTime]? , ScheduleDeliveryDateAfter[xsd:dateTime]? , ScheduleDeliveryDateBefore[xsd:dateTime]? , ListOfDateCoded[core:ListOfDateCodedType]? )

    Description: ASNDatesType indicates the pertinent dates for the ASN. These dates are global and apply to the entire ASN, except where overridden by dates provided at the line item or package level

    Elements:

    • DeliveryDate - indicates the date delivery is requested to arrive at the destination.
    • ShipDate - indicates the date items in the ASN must be shipped from the seller.
    • EarliestDeliveryDate - indicates the earliest delivery date.
    • LatestDeliveryDate - indicates the latest delivery date.
    • CollectionDateOfCargo - indicates the date the cargo is requested to be collected.
    • ScheduleDeliveryDateAfter - indicates the date that delivery is scheduled for on or after.
    • ScheduleDeliveryDateBefore - indicates the date that delivery is scheduled for on or before.
    • ListOfDateCoded - is used to communicate any other dates not explicitly stated by another element.

[^]Code Fragment

    <xsd:complexType name="ASNDatesType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="DeliveryDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ShipDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="EarliestDeliveryDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="LatestDeliveryDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="CollectionDateOfCargo" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ScheduleDeliveryDateAfter" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ScheduleDeliveryDateBefore" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ListOfDateCoded" type="core:ListOfDateCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ASNDetailType

ASNDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ListOfASNItemDetail[ListOfASNItemDetailType] , ListOfASNPackageDetail[ListOfASNPackageDetailType]? )

    Description: ASNDetailType contains line item and package details of the ASN.

    Elements:

    • ListOfASNItemDetail - contains a list of line items for the ASN.
    • ListOfASNPackageDetail - contains the details of the packaging of the goods in the ASN.

[^]Code Fragment

    <xsd:complexType name="ASNDetailType">
    <xsd:sequence>
        <xsd:element name="ListOfASNItemDetail" type="ListOfASNItemDetailType">
        <xsd:element minOccurs="0" name="ListOfASNPackageDetail" type="ListOfASNPackageDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ASNHeaderType

ASNHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ASNNumber[xsd:string] , ASNIssueDate[xsd:dateTime] , ASNOrderNumber[ASNOrderNumberType]+ , ShippingReferences[ShippingReferencesType]? , ASNPurpose[ASNPurposeType] , ASNType[ASNTypeType]? , ASNStatus[ASNStatusType]? , ASNCurrency[core:CurrencyType]? , ASNLanguage[core:LanguageType]? , ASNDates[ASNDatesType] , ASNParty[ASNPartyType] , ListOfTransportRouting[core:ListOfTransportRoutingType]? , ASNTermsOfDelivery[core:TermsOfDeliveryType]? , ASNPaymentInstructions[core:PaymentInstructionsType]? , ASNAllowancesOrCharges[core:ListOfAllowOrChargeType]? , ASNHeaderNote[xsd:string]? , SpecialHandling[core:SpecialHandlingType]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? , ASNHeaderAttachments[core:ListOfAttachmentType]? )

    Description: ASNHeaderType contains the header information of the ASN.

    Elements:

    • ASNNumber - is the unique number that uniquely identifies the ASN, typically according to the system that generated the ASN.
    • ASNIssueDate - holds a digital time stamp provided by the application that created the ASN document.
    • ASNOrderNumber - indicates the unique number assigned to identify a purchase order that the ASN is referencing.
    • ShippingReferences - defines the references for the shipment.
    • ASNPurpose - defines the purpose of the ASN. This element should be used to identify whether the ASN is a new ASN (Original), a replacement ASN (Replacement), or a cancellation of an existing ASN (Cancellation). In the case that the ASN is a replacement, the ASNNumber should not change.
    • ASNType - identifies the type of ASN being transmitted.
    • ASNStatus - identifies the status of the order/orders that the ASN is referencing and transmitting.
    • ASNCurrency - identifies the default currency of the ASN, which when used at the header level may be overwritten at a lower level within the structure (line item level).
    • ASNLanguage - identifies the language of the ASN.
    • ASNDates - indicates the pertinent dates for the ASN. These dates are global and apply to the entire ASN, except where overridden by dates provided at the line item or package level.
    • ASNParty - holds information on the parties to the ASN, including unique ID's and address information.
    • ListOfTransportRouting - defines the information on the movement of the goods, including the carrier, equipment, locations and dates contained in the ASN.
    • ASNTermsOfDelivery - describes the terms of delivery for the shipment described by the ASN.
    • ASNPaymentInstructions - describes the payment instructions for the ASN, this can include cost of the goods and the cost of transport.
    • ASNAllowancesOrCharges - defines the allowances or charges for the ASN, this can include cost of the goods and the cost of transport.
    • ASNHeaderNote - contains any free-form text pertinent to the entire shipment described by the ASN or to the ASN message itself. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • SpecialHandling - descibes any special handling conditions that apply to the enitre ship notice.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfNameValueSet - is used to hold a collection of values qualified by names. The values contianed in this element should be agreed upon by trading partners.
    • ASNHeaderAttachments - contains a list of attachments applicable to the entire ASN. The information is not specific to a particular line item or package, unless specifically noted.

[^]Code Fragment

    <xsd:complexType name="ASNHeaderType">
    <xsd:sequence>
        <xsd:element name="ASNNumber" type="xsd:string">
        <xsd:element name="ASNIssueDate" type="xsd:dateTime">
        <xsd:element maxOccurs="unbounded" name="ASNOrderNumber" type="ASNOrderNumberType">
        <xsd:element minOccurs="0" name="ShippingReferences" type="ShippingReferencesType">
        <xsd:element name="ASNPurpose" type="ASNPurposeType">
        <xsd:element minOccurs="0" name="ASNType" type="ASNTypeType">
        <xsd:element minOccurs="0" name="ASNStatus" type="ASNStatusType">
        <xsd:element minOccurs="0" name="ASNCurrency" type="core:CurrencyType">
        <xsd:element minOccurs="0" name="ASNLanguage" type="core:LanguageType">
        <xsd:element name="ASNDates" type="ASNDatesType">
        <xsd:element name="ASNParty" type="ASNPartyType">
        <xsd:element minOccurs="0" name="ListOfTransportRouting" type="core:ListOfTransportRoutingType">
        <xsd:element minOccurs="0" name="ASNTermsOfDelivery" type="core:TermsOfDeliveryType">
        <xsd:element minOccurs="0" name="ASNPaymentInstructions" type="core:PaymentInstructionsType">
        <xsd:element minOccurs="0" name="ASNAllowancesOrCharges" type="core:ListOfAllowOrChargeType">
        <xsd:element minOccurs="0" name="ASNHeaderNote" type="xsd:string">
        <xsd:element minOccurs="0" name="SpecialHandling" type="core:SpecialHandlingType">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
        <xsd:element minOccurs="0" name="ASNHeaderAttachments" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ASNItemDatesType

ASNItemDatesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( RequestedDeliveryDate[xsd:dateTime]? , ShipDate[xsd:dateTime]? , ListOfDateCoded[core:ListOfDateCodedType]? )

    Description: ASNItemDatesType holds dates relative to the line item.

    Elements:

    • RequestedDeliveryDate - indicates the date delivery is requested to arrive at the destination.
    • ShipDate - indicates the date items will be or have been shipped from the seller.
    • ListOfDateCoded - is used to communicate any other dates not explicitly stated by another element.

[^]Code Fragment

    <xsd:complexType name="ASNItemDatesType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="RequestedDeliveryDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ShipDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ListOfDateCoded" type="core:ListOfDateCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ASNItemDetailType

ASNItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ASNBaseItemDetail[ASNBaseItemDetailType] , ASNLineItemListOfAllowOrCharge[core:ListOfAllowOrChargeType]? , LineItemNote[xsd:string]? , SpecialHandling[core:SpecialHandlingType]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? , LineItemAttachment[core:ListOfAttachmentType]? )

    Description: ASNItemDetailType contains the item detail information for the ASN.

    Elements:

    • ASNBaseItemDetail - contains the identifying and descriptive information for the line items in the ASN.
    • ASNLineItemListOfAllowOrCharge - contains the line item allowance and charge information for the ASN.
    • LineItemNote - describes any free form text pertinent to the line item. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • SpecialHandling - descibes any special handling conditions that apply to the line item.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfNameValueSet - is used to holds a collection of values qualified by names. The values contianed in this element should be agreed upon by trading partners.
    • LineItemAttachment - contains a list of attachments applicable to the specified line item of the ASN. The information is not specific to a particular line item or package, unless specifically noted.

[^]Code Fragment

    <xsd:complexType name="ASNItemDetailType">
    <xsd:sequence>
        <xsd:element name="ASNBaseItemDetail" type="ASNBaseItemDetailType">
        <xsd:element minOccurs="0" name="ASNLineItemListOfAllowOrCharge" type="core:ListOfAllowOrChargeType">
        <xsd:element minOccurs="0" name="LineItemNote" type="xsd:string">
        <xsd:element minOccurs="0" name="SpecialHandling" type="core:SpecialHandlingType">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
        <xsd:element minOccurs="0" name="LineItemAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ASNLineItemPartyType

ASNLineItemPartyType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ShipToParty[core:PartyType]? , ShipFromParty[core:PartyType]? , FinalRecipient[core:PartyType]? , ListOfPartyCoded[core:ListOfPartyCodedType]? )

    Description: ASNLineItemPartyType holds all party information related to the line items.

    Elements:

    • ShipToParty - contains the information for the party which the items are to be shipped.
    • ShipFromParty - contains party information identifying the location from which the items are to be shipped.
    • FinalRecipient - identifies the person or organization who will ultimately receive the item or items.
    • ListOfPartyCoded - is a collection of all other party information not explicitly stated as the content of another element.

[^]Code Fragment

    <xsd:complexType name="ASNLineItemPartyType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ShipToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ShipFromParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="FinalRecipient" type="core:PartyType">
        <xsd:element minOccurs="0" name="ListOfPartyCoded" type="core:ListOfPartyCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ASNLineItemReferencesType

ASNLineItemReferencesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PurchaseOrderReference[core:PurchaseOrderReferenceType]? , ShippingReferences[ShippingReferencesType]? )

    Description: ASNLineItemReferencesType defines the references for the ASN.

    Elements:

    • PurchaseOrderReference - contains a reference to the specific order information for the item.
    • ShippingReferences - defines references to any other shipment documents relevant to the item.

[^]Code Fragment

    <xsd:complexType name="ASNLineItemReferencesType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="PurchaseOrderReference" type="core:PurchaseOrderReferenceType">
        <xsd:element minOccurs="0" name="ShippingReferences" type="ShippingReferencesType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ASNOrderNumberType

ASNOrderNumberType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: Extends: core:PurchaseOrderReferenceType

      Append:( OtherOrderShippingReferences[ShippingReferencesType]? )

    Description: ASNOrderNumberType indicates the unique number assigned to identify a purchase order.

    Elements:

    • OtherOrderShippingReferences - identifies any other documents association with the order being referenced.

[^]Code Fragment

    <xsd:complexType name="ASNOrderNumberType">
    <xsd:complexContent>
        <xsd:extension base="core:PurchaseOrderReferenceType">
            <xsd:sequence>
                <xsd:element minOccurs="0" name="OtherOrderShippingReferences" type="ShippingReferencesType">
            </xsd:sequence>
        </xsd:extension>
    </xsd:complexContent>
</xsd:complexType>


complexType definition: ASNPartyType

ASNPartyType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( BuyerParty[core:PartyType] , SellerParty[core:PartyType] , ShipToParty[core:PartyType]? , BillToParty[core:PartyType]? , RemitToParty[core:PartyType]? , ShipFromParty[core:PartyType]? , WarehouseParty[core:PartyType]? , SoldToParty[core:PartyType]? , ManufacturingParty[core:PartyType]? , MaterialIssuer[core:PartyType]? , Carrier[core:PartyType]? , ListOfPartyCoded[core:ListOfPartyCodedType]? )

    Description: ASNPartyType holds all party information related to the ship notice.

    Elements:

    • BuyerParty - contains the information for the party purchasing the goods.
    • SellerParty - identifies the party selling the goods.
    • ShipToParty - contains the information for the party which the items are to be shipped.
    • BillToParty - contains the information for the party that will receive the bill for the goods..
    • RemitToParty - contains the information for the party to be paid.
    • ShipFromParty - contains party information identifying the location from which the items are to be shipped.
    • WarehouseParty - contains party information identifying the warehouse from which the items are to be shipped.
    • SoldToParty - contains party information identifying the location where the items were sold.
    • ManufacturingParty - contains the party information identifying the location where the item is to be or is being manufactured.
    • MaterialIssuer - contains the information identifying the location that is issuing the request for the material.
    • Carrier - identifies the carrier for the ASN, in cases when only one carrier is used for the entire ship notice.
    • ListOfPartyCoded - is a collection of all other party information not explicitly stated as the content of another element.

[^]Code Fragment

    <xsd:complexType name="ASNPartyType">
    <xsd:sequence>
        <xsd:element name="BuyerParty" type="core:PartyType">
        <xsd:element name="SellerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ShipToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="BillToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="RemitToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ShipFromParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="WarehouseParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="SoldToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ManufacturingParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="MaterialIssuer" type="core:PartyType">
        <xsd:element minOccurs="0" name="Carrier" type="core:PartyType">
        <xsd:element minOccurs="0" name="ListOfPartyCoded" type="core:ListOfPartyCodedType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: ASNPurposeCodeType

ASNPurposeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:
    This code identifies the purpose of the ASN message. This is a subset codelist derived from EDIFACT 1225 (Message Function, Coded) and X12 353 (Transaction Set Purpose Code) and 587 (Acknowledgement Type Code)

    Content: Restriction of base type core:PurposeCodeType

    Enumerated List:

    • Other - Custom Code
    • Original
    • Confirmation
    • Duplicate
    • Replace
    • Cancellation

[^]Code Fragment

    <xsd:simpleType name="ASNPurposeCodeType">
    <xsd:restriction base="core:PurposeCodeType">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Original">
        <xsd:enumeration value="Confirmation">
        <xsd:enumeration value="Duplicate">
        <xsd:enumeration value="Replace">
        <xsd:enumeration value="Cancellation">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: ASNPurposeType

ASNPurposeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ASNPurposeCoded[ASNPurposeCodeType] , ASNPurposeCodedOther[xsd:string]? )

    Description: ASNPurposeType defines the purpose of the ASN.

    Elements:

    • ASNPurposeCoded - indicates the purpose of the document.
    • ASNPurposeCodedOther - is used to provide a non-standard ASNPurposeCode. This element is mandatory if the value of ASNPurposeCoded is'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="ASNPurposeType">
    <xsd:sequence>
        <xsd:element name="ASNPurposeCoded" type="ASNPurposeCodeType">
        <xsd:element minOccurs="0" name="ASNPurposeCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ASNQuantitiesType

ASNQuantitiesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ShippedQuantity[core:QuantityType] , OrderedQuantity[core:QuantityType]? , BackOrderedQuantity[core:QuantityType]? , MaxBackOrderQuantity[core:QuantityType]? , DamagedQuantity[core:QuantityType]? , UnusableQuantity[core:QuantityType]? , ReturnedQuantity[core:QuantityType]? , ShippedToDateQuantity[core:QuantityType]? , ListOfQuantityCoded[core:ListOfQuantityCodedType]? )

    Description: ASNQuantitiesType informs why the invoiced quantity is different to the ordered.

    Elements:

    • ShippedQuantity - Is the amount of the item that is being shipped.
    • OrderedQuantity - holds the quantity ordered.
    • BackOrderedQuantity - is the quantity of the item that has been back ordered.
    • MaxBackOrderQuantity - specifies the maximum quantity of an item that a customer will allow to be back ordered.
    • DamagedQuantity - holds the quantity received that was damaged.
    • UnusableQuantity - holds the quantity received that was unusable.
    • ReturnedQuantity - holds the quantity that has been returned.
    • ShippedToDateQuantity - holds the total quantity shipped for the line item (partial deliveries).
    • ListOfQuantityCoded - specifies any other quantities not explicitly stated.

[^]Code Fragment

    <xsd:complexType name="ASNQuantitiesType">
    <xsd:sequence>
        <xsd:element name="ShippedQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="OrderedQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="BackOrderedQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="MaxBackOrderQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="DamagedQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="UnusableQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="ReturnedQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="ShippedToDateQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="ListOfQuantityCoded" type="core:ListOfQuantityCodedType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: ASNStatusCodeType

ASNStatusCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:
    This code identifies the status of the orders covered by the ASN message.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • CompleteOrder - The ASN covers one complete order
    • PartialOrder - The ASN covers part of one order
    • ManyCompleteOrders - The ASN covers more than one complete order
    • ManyPartialOrders - The ASN covers more than one partial order
    • MixedOrder - The ASN covers a mixture of partial or complete orders

[^]Code Fragment

    <xsd:simpleType name="ASNStatusCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="CompleteOrder">
        <xsd:enumeration value="PartialOrder">
        <xsd:enumeration value="ManyCompleteOrders">
        <xsd:enumeration value="ManyPartialOrders">
        <xsd:enumeration value="MixedOrder">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: ASNStatusType

ASNStatusType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ASNStatusCoded[ASNStatusCodeType] , ASNStatusCodedOther[xsd:string]? )

    Description: ASNStatusType identifies the status of the Order/Orders that the ASN is referencing and transmitting.

    Elements:

    • ASNStatusCoded - indicates the status of the Order/Orders covered by the ASN.
    • ASNStatusCodedOther - is used to provide a non-standard ASNStatusCode. This element is mandatory if the value of ASNStatusCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="ASNStatusType">
    <xsd:sequence>
        <xsd:element name="ASNStatusCoded" type="ASNStatusCodeType">
        <xsd:element minOccurs="0" name="ASNStatusCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ASNSummaryType

ASNSummaryType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( NumberOfLines[xsd:int]? , TransportPackagingTotals[core:TransportPackagingTotalsType]? , SummaryNote[xsd:string]? )

    Description: ASNSummaryType contains the summary information of the ASN, typically totals of numerical fields.

    Elements:

    • NumberOfLines - identifies the number of line items.
    • TransportPackagingTotals - summarizes the transport and packaging information if included in the ASN.
    • SummaryNote - describes any free-form text pertinent to the summary described by the ASN. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.

[^]Code Fragment

    <xsd:complexType name="ASNSummaryType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="NumberOfLines" type="xsd:int">
        <xsd:element minOccurs="0" name="TransportPackagingTotals" type="core:TransportPackagingTotalsType">
        <xsd:element minOccurs="0" name="SummaryNote" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: ASNTypeCodeType

ASNTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • Planned - Planned
    • Actual - Actual

[^]Code Fragment

    <xsd:simpleType name="ASNTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Planned">
        <xsd:enumeration value="Actual">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: ASNTypeType

ASNTypeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ASNTypeCoded[ASNTypeCodeType] , ASNTypeCodedOther[xsd:string]? )

    Description: ASNTypeType identifies the type of ASN being transmitted.

    Elements:

    • ASNTypeCoded - indicates the type of the ASN.
    • ASNTypeCodedOther - is used to provide a non-standard ASNTypeCode. This element is mandatory if the value of ASNTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="ASNTypeType">
    <xsd:sequence>
        <xsd:element name="ASNTypeCoded" type="ASNTypeCodeType">
        <xsd:element minOccurs="0" name="ASNTypeCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: BaseShippingDetailType

BaseShippingDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: Extends: ScheduleBaseItemDetailType

      Append:( ItemPackagingReference[core:ItemPackagingReferenceType]* )

    Description: BaseShippingDetailType extends BaseItemDetail to include item schedule reference, release frequency and item quantities.

    Elements:

    • ItemPackagingReference - identifies which package the line item is in.

[^]Code Fragment

    <xsd:complexType name="BaseShippingDetailType">
    <xsd:complexContent>
        <xsd:extension base="ScheduleBaseItemDetailType">
            <xsd:sequence>
                <xsd:element minOccurs="0" maxOccurs="unbounded" name="ItemPackagingReference" type="core:ItemPackagingReferenceType">
            </xsd:sequence>
        </xsd:extension>
    </xsd:complexContent>
</xsd:complexType>


complexType definition: CarrierReferenceType

CarrierReferenceType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( CarrierReferenceNumber[core:ReferenceType] , TransportRouteID[xsd:int] )

    Description: CarrierReferenceType contains the carrier reference number.

    Elements:

    • CarrierReferenceNumber - contains the reference number issued by the carrier.
    • TransportRouteID - holds a unique identifier for this route of transport to be referenced. The TransportID is intended to be used as an internal reference for the document.

[^]Code Fragment

    <xsd:complexType name="CarrierReferenceType">
    <xsd:sequence>
        <xsd:element name="CarrierReferenceNumber" type="core:ReferenceType">
        <xsd:element name="TransportRouteID" type="xsd:int">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: CommitmentLevelCodeType

CommitmentLevelCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:
    This code identifies the commitment level for the forecast. This code list is derived from EDIFACT 4017 (Delivery plan commitment level code) and X12 680 (Forecast Qualifier)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • Immediate
    • Pilot-Prevolume
    • Firm
    • Planning
    • RoundedContainerQuantity
    • PotentialOrderIncrease
    • AveragePlantUsage
    • FirstTimeReportedFirm
    • FinalModelYearRequirementsOrOrders
    • EngineeringChangePending
    • MaximumToolingCapacity
    • NormalToolingCapacity
    • Prototype
    • OrderReleaseAuthorization
    • StrikeProtection
    • RequiredToolingCapacity
    • CooperativeLogisticsPlanning
    • CooperativeLogisticsFirm
    • Cancellation
    • Modification
    • CommitmentForManufacturingAndMaterial
    • CommitmentForMaterial
    • PlanningForecast
    • ShortDeliveredOnPreviousDelivery
    • CapacityAvailable
    • DeliverToSchedule
    • AwaitManualPull
    • ReferenceToCommercialAgreementBetweenPartners
    • Proposed

[^]Code Fragment

    <xsd:simpleType name="CommitmentLevelCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Immediate">
        <xsd:enumeration value="Pilot-Prevolume">
        <xsd:enumeration value="Firm">
        <xsd:enumeration value="Planning">
        <xsd:enumeration value="RoundedContainerQuantity">
        <xsd:enumeration value="PotentialOrderIncrease">
        <xsd:enumeration value="AveragePlantUsage">
        <xsd:enumeration value="FirstTimeReportedFirm">
        <xsd:enumeration value="FinalModelYearRequirementsOrOrders">
        <xsd:enumeration value="EngineeringChangePending">
        <xsd:enumeration value="MaximumToolingCapacity">
        <xsd:enumeration value="NormalToolingCapacity">
        <xsd:enumeration value="Prototype">
        <xsd:enumeration value="OrderReleaseAuthorization">
        <xsd:enumeration value="StrikeProtection">
        <xsd:enumeration value="RequiredToolingCapacity">
        <xsd:enumeration value="CooperativeLogisticsPlanning">
        <xsd:enumeration value="CooperativeLogisticsFirm">
        <xsd:enumeration value="Cancellation">
        <xsd:enumeration value="Modification">
        <xsd:enumeration value="CommitmentForManufacturingAndMaterial">
        <xsd:enumeration value="CommitmentForMaterial">
        <xsd:enumeration value="PlanningForecast">
        <xsd:enumeration value="ShortDeliveredOnPreviousDelivery">
        <xsd:enumeration value="CapacityAvailable">
        <xsd:enumeration value="DeliverToSchedule">
        <xsd:enumeration value="AwaitManualPull">
        <xsd:enumeration value="ReferenceToCommercialAgreementBetweenPartners">
        <xsd:enumeration value="Proposed">
    </xsd:restriction>
</xsd:simpleType>


Complex Types:

AdvanceShipmentNoticeType
ASNBaseItemDetailType
ASNDatesType
ASNDetailType
ListOfASNPackageDetailType
ASNHeaderType
ASNItemDatesType
ASNItemDetailType
ListOfASNItemDetailType
ASNLineItemPartyType
ASNLineItemReferencesType
ASNOrderNumberType
ASNPartyType
ASNPurposeType
ASNQuantitiesType
ASNStatusType
ASNSummaryType
ASNTypeType
BaseShippingDetailType
CarrierReferenceType
ListOfCarrierReferenceType
GoodsConditionType
ListOfGoodsConditionType
GoodsReceiptBaseItemDetailType
GoodsReceiptDatesType
GoodsReceiptDeliveryDetailType
GoodsReceiptDetailType
GoodsReceiptHeaderType
GoodsReceiptItemDetailType
ListOfGoodsReceiptItemDetailType
GoodsReceiptLineItemReferencesType
GoodsReceiptQuantitiesType
GoodsReceiptReferencesType
GoodsReceiptType
ItemResourceAuthorizationType
InventoryReportType
InventoryReportSummaryType
InventoryManagementDetailType
ListOfInventoryManagementDetailType
InventoryReportDetailType
ListOfInventoryReportDetailType
InventoryReportHeaderType
InventoryReportPartyType
InventoryReportDatesType
InventoryReportTypeType
InventoryItemIdentifiersType
IDNumberRangesType
ListOfIDNumberRangesType
IDNumbersType
ListOfIDNumbersType
LineItemGoodsConditionType
ListOfLineItemGoodsConditionType
LocationGroupedPlanningDetailType
ListOfLocationGroupedPlanningDetailType
LocationGroupedPlanningResponseType
ListOfLocationGroupedPlanningResponseType
LocationGroupedShippingDetailType
ListOfLocationGroupedShippingDetailType
LocationGroupedShippingResponseType
ListOfLocationGroupedShippingResponseType
LocationPlanningItemDetailType
ListOfLocationPlanningItemDetailType
LocationScheduleType
ListOfLocationScheduleType
LocationShippingItemDetailType
ListOfLocationShippingItemDetailType
LocationShipScheduleType
ListOfLocationShipScheduleType
MaterialGroupedPlanningDetailType
ListOfMaterialGroupedPlanningDetailType
MaterialGroupedPlanningResponseType
ListOfMaterialGroupedPlanningResponseType
MaterialGroupedShippingDetailType
ListOfMaterialGroupedShippingDetailType
MaterialGroupedShippingResponseType
ListOfMaterialGroupedShippingResponseType
PlanningScheduleHeaderType
PlanningScheduleResponseHeaderType
PlanningScheduleResponseType
PlanningScheduleSummaryType
PlanningScheduleType
ScheduleBaseItemDetailType
ScheduleDetailType
ListOfScheduleDetailType
SchedulePartyType
ScheduleReferencesType
ShippingDatesType
ShippingReferencesType
ShippingScheduleHeaderType
ShippingScheduleResponseHeaderType
ShippingScheduleResponseType
ShippingScheduleSummaryType
ShippingScheduleType
ShipScheduleDetailType
ListOfShipScheduleDetailType
TrackingInformationType


simpleType definition: DeliveryStageQualifierCodeType

DeliveryStageQualifierCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:
    provides a specific meaning to a physical or logical state.This code list is derived from EDIFACT 7001

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • UponReceipt - At the time of receipt.
    • UponDispatch - At the time of dispatch.
    • UponArrivalCondition - The arrival condition of an object.
    • LifeCycleStage - The state of an object in its life cycle.
    • Other - Custom code

[^]Code Fragment

    <xsd:simpleType name="DeliveryStageQualifierCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="UponReceipt">
        <xsd:enumeration value="UponDispatch">
        <xsd:enumeration value="UponArrivalCondition">
        <xsd:enumeration value="LifeCycleStage">
        <xsd:enumeration value="Other">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: DiscrepancyCodeType

DiscrepancyCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:
    Defines the disposition or physical condition of any difference between the quantityshipped/ordered/invoiced and the quantity received for a line item or transaction. Based on EDIFACT 4221, 7001 and X12 412

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Over-Shipped - Over-shipped
    • DeliveredButNotAdvised - Delivered but not advised
    • GoodsDeliveredDamaged - Goods delivered damaged
    • DeliveredTooLate - Delivered too late
    • NextHigherPackagingQuantity - Next higher packaging quantity
    • BackOrderedFromPreviousOrder - Back ordered from previous order
    • ShipmentPartial-BackOrderToFollow - Shipment partial - back order to follow
    • ShipmentIncludesExtraItemsToMeetPriceBreak - Shipment includes extra items to meet price break
    • CancelledFromPreviousOrder - Cancelled from previous order
    • ShipmentCompleteWithAdditionalQuantity - Shipment complete with additional quantity
    • NextCarrier - Next carrier PVE - (date)
    • ShipmentPartial-ConsideredComplete - Shipment partial - considered complete no backorder
    • ShipmentCompleteWithSubstitution - Shipment complete with substitution
    • ItemCancelled - Item cancelled
    • ItemRepresentsSubstitutionFromOriginalOrder - Item represents substitution from original order
    • LastShipment - Last shipment (date)
    • PurchaseOrderComplete - Purchase order complete
    • SplitShipment - Split shipment
    • MutuallyDefined - Mutually defined
    • ContainerDamaged - damaged container at receipt
    • QuantityShort - quantity short of orginally ordered or shipped quantity
    • QualityProblem - problem with the quality
    • IncorrectProduct - incorrect product
    • Non-standardContainer - non-standard container
    • WrongIdentification - The actual identification is different from the given identification.
    • Other - Custom Code

[^]Code Fragment

    <xsd:simpleType name="DiscrepancyCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Over-Shipped">
        <xsd:enumeration value="DeliveredButNotAdvised">
        <xsd:enumeration value="GoodsDeliveredDamaged">
        <xsd:enumeration value="DeliveredTooLate">
        <xsd:enumeration value="NextHigherPackagingQuantity">
        <xsd:enumeration value="BackOrderedFromPreviousOrder">
        <xsd:enumeration value="ShipmentPartial-BackOrderToFollow">
        <xsd:enumeration value="ShipmentIncludesExtraItemsToMeetPriceBreak">
        <xsd:enumeration value="CancelledFromPreviousOrder">
        <xsd:enumeration value="ShipmentCompleteWithAdditionalQuantity">
        <xsd:enumeration value="NextCarrier">
        <xsd:enumeration value="ShipmentPartial-ConsideredComplete">
        <xsd:enumeration value="ShipmentCompleteWithSubstitution">
        <xsd:enumeration value="ItemCancelled">
        <xsd:enumeration value="ItemRepresentsSubstitutionFromOriginalOrder">
        <xsd:enumeration value="LastShipment">
        <xsd:enumeration value="PurchaseOrderComplete">
        <xsd:enumeration value="SplitShipment">
        <xsd:enumeration value="MutuallyDefined">
        <xsd:enumeration value="ContainerDamaged">
        <xsd:enumeration value="QuantityShort">
        <xsd:enumeration value="QualityProblem">
        <xsd:enumeration value="IncorrectProduct">
        <xsd:enumeration value="Non-standardContainer">
        <xsd:enumeration value="WrongIdentification">
        <xsd:enumeration value="Other">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: ElementIdentifierCodeType

ElementIdentifierCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:
    In EDIFACT this is used at the segment level, where the CDI and INP are per segment. In X12 the default value for this is the GoodsReceiptDocument in the header. At the header the values pertain to the entire header document item level discrepancies are handled at the detail level.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • GoodsReceiptDocument - describes the entire goods receipt document.
    • TransportRouting - describes the discrepancy in the TransportRouting
    • Equipment - describes the discrepancy in the equipment
    • Packaging - describes the discrepancy in the packaging
    • SealNumber - describes the discrepancy in the SealNumber found in the TransportEquipment

[^]Code Fragment

    <xsd:simpleType name="ElementIdentifierCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="GoodsReceiptDocument">
        <xsd:enumeration value="TransportRouting">
        <xsd:enumeration value="Equipment">
        <xsd:enumeration value="Packaging">
        <xsd:enumeration value="SealNumber">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: ForecastFrequencyCodeType

ForecastFrequencyCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:
    This code identifies the release frequency of the line item. This code list is derived from X12 681 (Timing Qualifier)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Annually - Annually (Calendar Year)
    • Daily - Daily
    • Discrete - Discrete
    • FlexibleInterval - Flexible Interval (from Date X through Date Y)
    • MonthlyBucket - Monthly Bucket (Calendar Months)
    • Quarterly - Quarterly (Calendar Quarters)
    • Semi-Annually - Semi-Annually (Calendar Year)
    • FourWeekBucket - Four week bucket (13 buckets per year)
    • WeeklyBucket - Weekly Bucket (Monday through Sunday)
    • Just-In-Time - Just-in-time
    • Continuous - Continuous
    • Synchronous - Synchronous
    • Replenishment - Replenishment
    • Other - Custom Code

[^]Code Fragment

    <xsd:simpleType name="ForecastFrequencyCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Annually">
        <xsd:enumeration value="Daily">
        <xsd:enumeration value="Discrete">
        <xsd:enumeration value="FlexibleInterval">
        <xsd:enumeration value="MonthlyBucket">
        <xsd:enumeration value="Quarterly">
        <xsd:enumeration value="Semi-Annually">
        <xsd:enumeration value="FourWeekBucket">
        <xsd:enumeration value="WeeklyBucket">
        <xsd:enumeration value="Just-In-Time">
        <xsd:enumeration value="Continuous">
        <xsd:enumeration value="Synchronous">
        <xsd:enumeration value="Replenishment">
        <xsd:enumeration value="Other">
    </xsd:restriction>
</xsd:simpleType>


Global Elements (Document Roots):

AdvanceShipmentNotice
GoodsReceipt
InventoryReport
PlanningSchedule
PlanningScheduleResponse
ShippingSchedule
ShippingScheduleResponse


simpleType definition: GoodsConditionCodeType

GoodsConditionCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:
    this list describes the status of units in a specific shipment.This code list is derived from EDIFACT 7007 and X12 412.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • GoodCondition - in a state of good condition
    • Rejected - Rejected
    • Hold - on hold, waiting further information
    • MaterialScrapped - Material scrapped
    • AdjustSupplierShippedCumulativeQuantity - Adjust supplier shipped cumulative quantity
    • QuantityNotProcessed - Quantity received, but cannot process because no matching ship notice
    • NotReceived-ShipNoticeRequired - Not received - Ship Notice required
    • Split - Separated into multiple units.
    • Missing - Missing
    • Proposed - Proposed
    • Accepted - Accepted
    • Scheduled - Scheduled
    • Completed - Completed
    • Postponed - Postponed
    • Cancelled - Cancelled
    • QuantityProcessed - Quantity processed with no matching ship notice
    • Returned - Quantity returned. Can be used for returnable containers
    • Other - Non-standard GoodsConditionCode

[^]Code Fragment

    <xsd:simpleType name="GoodsConditionCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="GoodCondition">
        <xsd:enumeration value="Rejected">
        <xsd:enumeration value="Hold">
        <xsd:enumeration value="MaterialScrapped">
        <xsd:enumeration value="AdjustSupplierShippedCumulativeQuantity">
        <xsd:enumeration value="QuantityNotProcessed">
        <xsd:enumeration value="NotReceived-ShipNoticeRequired">
        <xsd:enumeration value="Split">
        <xsd:enumeration value="Missing">
        <xsd:enumeration value="Proposed">
        <xsd:enumeration value="Accepted">
        <xsd:enumeration value="Scheduled">
        <xsd:enumeration value="Completed">
        <xsd:enumeration value="Postponed">
        <xsd:enumeration value="Cancelled">
        <xsd:enumeration value="QuantityProcessed">
        <xsd:enumeration value="Returned">
        <xsd:enumeration value="Other">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: GoodsConditionType

GoodsConditionType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ElementIdentifierCoded[ElementIdentifierCodeType]? , ElementIdentifierCodedOther[xsd:string]? , IdentifyingReference[xsd:string]? , DeliveryStageQualifierCoded[DeliveryStageQualifierCodeType]? , DeliveryStageQualifierOther[xsd:string]? , GoodsConditionCoded[GoodsConditionCodeType] , GoodsConditionCodedOther[xsd:string]? )

    Description: GoodsConditionType is used to provide information on the data that is being contested/rejected/put on hold. This can be the entire document or an element such as the seal number on a piece of equipment. When the ElementIdentifierCoded is not used at the header level, the GoodsCondition applies as the default to the entire GoodsReceipt document.

    Elements:

    • ElementIdentifierCoded - is a code list describing what the discrepancy is in relation to. This is referenced to the item/document/etc being described through the IdentifyingReference.
    • ElementIdentifierCodedOther - is used to provide a non-standard ElementIdentifierCode. This element is mandatory if the value of ElementIdentifierCode is 'Other'. These codes should not contain white space unless absolutely necessary.
    • IdentifyingReference - allows for internal referencing to the element described in the ElementIdentifierCode. This should be used to represent a unique distinction between identified discrepancies. In the case when only one discrepancy is identified this element does not need to be used. (for example: in equipment this would equal the EquipmentID)
    • DeliveryStageQualifierCoded - is a code giving a specific meaning to a physical or logical state. This is often referred to as the stage in the delivery process.
    • DeliveryStageQualifierOther - is used to provide a non-standard DeliveryStageQualifierCode. This element is mandatory if the value of DeliveryStageQualifierCode is 'Other'. These codes should not contain white space unless absolutely necessary.
    • GoodsConditionCoded - is a code designating the physical condition or status of units in a specific shipment.
    • GoodsConditionCodedOther - is used to provide a non-standard GoodsConditionCode. This element is mandatory if the value of GoodsConditionCode is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="GoodsConditionType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ElementIdentifierCoded" type="ElementIdentifierCodeType">
        <xsd:element minOccurs="0" name="ElementIdentifierCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="IdentifyingReference" type="xsd:string">
        <xsd:element minOccurs="0" name="DeliveryStageQualifierCoded" type="DeliveryStageQualifierCodeType">
        <xsd:element minOccurs="0" name="DeliveryStageQualifierOther" type="xsd:string">
        <xsd:element name="GoodsConditionCoded" type="GoodsConditionCodeType">
        <xsd:element minOccurs="0" name="GoodsConditionCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: GoodsReceiptBaseItemDetailType

GoodsReceiptBaseItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( LineItemNum[core:LineItemNumType] , LineItemType[core:LineItemTypeType]? , ParentItemNumber[core:LineItemNumberReferenceType]? , ItemIdentifiers[core:ItemIdentifiersType]? , ListOfDimension[core:ListOfDimensionType]? , GoodsReceiptQuantities[GoodsReceiptQuantitiesType] , CountryOfOrigin[core:CountryType]? , CountryOfDestination[core:CountryType]? , GoodsReceiptLineItemParty[ASNLineItemPartyType]? , HazardousMaterials[core:HazardousType]? , GoodsReceiptLineItemReferences[GoodsReceiptLineItemReferencesType]? , ItemPackagingReference[core:ItemPackagingReferenceType]? , ListOfDestinationRef[core:ListOfDestinationRefType]? , GoodsReceiptItemDates[GoodsReceiptDatesType]? )

    Description: GoodsReceiptBaseItemDetailType contains the identifying and descriptive information for the line items in the goods receipt.

    Elements:

    • LineItemNum - is a set of numbers uniquely identifying the line item for the number. In the case where the seller's system splits a line item number into 2 line items, the buyer item number will remain the same for both line items, but the seller item number will be different.
    • LineItemType - identifies whether the line item is a component group (consists of other line items), a typical line item, or a textual line item.
    • ParentItemNumber - identifies the line item that groups this and other line items. This is done using LineItemNumberReference, which specifies the number of the parent line item and whether this reference is the Buyer or Seller's number. LineItemNumberReference is a string content model of datatype integer that contains an attribute to specify whether the ParentItemNumber is a Seller or Buyer number, with the default being Buyer. This value references the parent item represented a group.
    • ItemIdentifiers - details all of the part numbers assigned to the item.
    • ListOfDimension - lists one or more quantitative measurements of the item.
    • GoodsReceiptQuantities - specifies the quantities of the item pertaining to the ship notice.
    • CountryOfOrigin - specifies the country code for the country in which the line item was manufactured.
    • CountryOfDestination - specifies the country code for the country in which the delivery is finally received.
    • GoodsReceiptLineItemParty - identifies any references relevant to the line item.
    • HazardousMaterials - contains the hazardous information for the line item.
    • GoodsReceiptLineItemReferences - identifies the paties relevant to the item.
    • ItemPackagingReference - identifies which package the line item is in.
    • ListOfDestinationRef - holds a list of all the destinations for the line item.
    • GoodsReceiptItemDates - holds a collection of dates relative to this item.

[^]Code Fragment

    <xsd:complexType name="GoodsReceiptBaseItemDetailType">
    <xsd:sequence>
        <xsd:element name="LineItemNum" type="core:LineItemNumType">
        <xsd:element minOccurs="0" name="LineItemType" type="core:LineItemTypeType">
        <xsd:element minOccurs="0" name="ParentItemNumber" type="core:LineItemNumberReferenceType">
        <xsd:element minOccurs="0" name="ItemIdentifiers" type="core:ItemIdentifiersType">
        <xsd:element minOccurs="0" name="ListOfDimension" type="core:ListOfDimensionType">
        <xsd:element name="GoodsReceiptQuantities" type="GoodsReceiptQuantitiesType">
        <xsd:element minOccurs="0" name="CountryOfOrigin" type="core:CountryType">
        <xsd:element minOccurs="0" name="CountryOfDestination" type="core:CountryType">
        <xsd:element minOccurs="0" name="GoodsReceiptLineItemParty" type="ASNLineItemPartyType">
        <xsd:element minOccurs="0" name="HazardousMaterials" type="core:HazardousType">
        <xsd:element minOccurs="0" name="GoodsReceiptLineItemReferences" type="GoodsReceiptLineItemReferencesType">
        <xsd:element minOccurs="0" name="ItemPackagingReference" type="core:ItemPackagingReferenceType">
        <xsd:element minOccurs="0" name="ListOfDestinationRef" type="core:ListOfDestinationRefType">
        <xsd:element minOccurs="0" name="GoodsReceiptItemDates" type="GoodsReceiptDatesType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: GoodsReceiptDatesType

GoodsReceiptDatesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ReceivedDate[xsd:dateTime]? , RequestedDeliveryDate[xsd:dateTime]? , ShippedDate[xsd:dateTime]? , ListOfDateCoded[core:ListOfDateCodedType]? )

    Description: GoodsReceiptDatesType holds dates relative to an entire shipment or a single line item on a shipment.

    Elements:

    • ReceivedDate - indicates the date the delivery or item is received.
    • RequestedDeliveryDate - indicates the date the delivery or item is requested to arrive at the destination.
    • ShippedDate - indicates the date shipment or item was shipped from the seller.
    • ListOfDateCoded - is used to communicate any other dates not explicitly stated by another element.

[^]Code Fragment

    <xsd:complexType name="GoodsReceiptDatesType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ReceivedDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="RequestedDeliveryDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ShippedDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ListOfDateCoded" type="core:ListOfDateCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: GoodsReceiptDeliveryDetailType

GoodsReceiptDeliveryDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ItemPackagingReference[core:ItemPackagingReferenceType]? , ListOfDestinationRef[core:ListOfDestinationRefType]? , RequestedDeliveryDate[xsd:dateTime]? , ShipByDate[xsd:dateTime]? , OtherItemDates[core:ListOfDateCodedType]? , ItemShipToParty[core:PartyType]? , ItemShipFromParty[core:PartyType]? , TermsOfDelivery[core:TermsOfDeliveryType]? )

    Description: GoodsReceiptDeliveryDetailType contains the delivery information in the GoodsReceipt.

    Elements:

    • ItemPackagingReference - contains reference information when detailed packaging information contained in the list of package detail is to be associated with the line item.
    • ListOfDestinationRef - holds a list of all the destinations for the line item.
    • RequestedDeliveryDate - is the date items in the purchase order must be received by the buyer.
    • ShipByDate - is the date items in the purchase order must be shipped from the seller.
    • OtherItemDates - specifies other dates related to the item.
    • ItemShipToParty - contains the information for the party which the items were shipped to.
    • ItemShipFromParty - contains party information identifying the location from which the items were shipped.
    • TermsOfDelivery - includes the information related to delivery including shipment method of payment and transport.

[^]Code Fragment

    <xsd:complexType name="GoodsReceiptDeliveryDetailType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ItemPackagingReference" type="core:ItemPackagingReferenceType">
        <xsd:element minOccurs="0" name="ListOfDestinationRef" type="core:ListOfDestinationRefType">
        <xsd:element minOccurs="0" name="RequestedDeliveryDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ShipByDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="OtherItemDates" type="core:ListOfDateCodedType">
        <xsd:element minOccurs="0" name="ItemShipToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ItemShipFromParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="TermsOfDelivery" type="core:TermsOfDeliveryType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: GoodsReceiptDetailType

GoodsReceiptDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ListOfGoodsReceiptItemDetail[ListOfGoodsReceiptItemDetailType] , ListOfGoodsReceiptPackageDetail[core:ListOfPackageDetailType]? )

    Description: GoodsReceiptDetailType contains the detail level information for the GoodsReceipt.

    Elements:

    • ListOfGoodsReceiptItemDetail - provides a list of line item information for the GoodsReceipt.
    • ListOfGoodsReceiptPackageDetail - is a container to hold one or more PackageDetail elements.

[^]Code Fragment

    <xsd:complexType name="GoodsReceiptDetailType">
    <xsd:sequence>
        <xsd:element name="ListOfGoodsReceiptItemDetail" type="ListOfGoodsReceiptItemDetailType">
        <xsd:element minOccurs="0" name="ListOfGoodsReceiptPackageDetail" type="core:ListOfPackageDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: GoodsReceiptHeaderType

GoodsReceiptHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( GoodsReceiptID[xsd:string] , GoodsReceiptIssueDate[xsd:dateTime] , GoodsReceiptPurpose[core:PurposeType] , GoodsReceiptTypeCoded[GoodsReceiptTypeCodeType] , GoodsReceiptTypeCodedOther[xsd:string]? , ListOfGoodsCondition[ListOfGoodsConditionType]? , GoodsReceiptReferences[GoodsReceiptReferencesType]? , GoodsReceiptDates[GoodsReceiptDatesType]? , DeliveryComplete[xsd:boolean]? , GoodsReceiptLanguage[core:LanguageType] , GoodsReceiptParty[SchedulePartyType] , TermsOfDelivery[core:TermsOfDeliveryType]* , ListOfTransportRouting[core:ListOfTransportRoutingType]? , GoodsReceiptHeaderNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? , ListOfAttachment[core:ListOfAttachmentType]? )

    Description: GoodsReceiptHeaderType contains the header information of the GoodsReceipt.

    Elements:

    • GoodsReceiptID - is the number that uniquely identifies the GoodsReceipt, typically according to the system that generated the GoodsReceipt.
    • GoodsReceiptIssueDate - holds a time stamp provided by the application that created the GoodsReceipt document.
    • GoodsReceiptPurpose - indicates the purpose of the GoodsReceipt document.
    • GoodsReceiptTypeCoded - is a code that specifies the type of GoodsReceipt being sent.
    • GoodsReceiptTypeCodedOther - is used to provide a non-standard GoodsReceiptTypeCode. This element is mandatory if the value of GoodsReceiptTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary
    • ListOfGoodsCondition - is used to describe the elements around which discrepancies exist. This is used at the header level to report any conditions that don't relate to a specific goods item, i.e.this relates to the entire shipment or to all of the goods. Specific item discrepancies should be handled at the item level.
    • GoodsReceiptReferences - contains information on other documents and numbers referenced by the GoodsReceipt.
    • GoodsReceiptDates - holds a collection of dates relative to this goods receipt.
    • DeliveryComplete - signifies that the delivery has been completed and nothing is outstanding in the delivery.
    • GoodsReceiptLanguage - identifies the language of the GoodsReceipt
    • GoodsReceiptParty - contains all information on the parties for the GoodsReceipt, including unique ID's and address information.
    • TermsOfDelivery - includes the information related to delivery including shipment method of payment and transport.
    • ListOfTransportRouting - holds the definition of the transport routing. A single TransportRouting is defined by one carrier (that is, one organization arranging or undertaking the transport of goods) moving between two or more named locations with a single mode of transport. You may have more than one vehicle acting as part of the transport, but all must use the same route, be of the same mode, and be operated by the same carrier.
    • GoodsReceiptHeaderNote - contains any free-form text pertinent to the entire shipment described by the GoodsReceipt or to the GoodsReceipt message itself. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfNameValueSet - is used to hold sets of name value pairs. The use of this element should be limited to the support of previous versions of xCBL.
    • ListOfAttachment - is a container for specifying the attachments to the GoodsReceipt.

[^]Code Fragment

    <xsd:complexType name="GoodsReceiptHeaderType">
    <xsd:sequence>
        <xsd:element name="GoodsReceiptID" type="xsd:string">
        <xsd:element name="GoodsReceiptIssueDate" type="xsd:dateTime">
        <xsd:element name="GoodsReceiptPurpose" type="core:PurposeType">
        <xsd:element name="GoodsReceiptTypeCoded" type="GoodsReceiptTypeCodeType">
        <xsd:element minOccurs="0" name="GoodsReceiptTypeCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfGoodsCondition" type="ListOfGoodsConditionType">
        <xsd:element minOccurs="0" name="GoodsReceiptReferences" type="GoodsReceiptReferencesType">
        <xsd:element minOccurs="0" name="GoodsReceiptDates" type="GoodsReceiptDatesType">
        <xsd:element minOccurs="0" name="DeliveryComplete" type="xsd:boolean">
        <xsd:element name="GoodsReceiptLanguage" type="core:LanguageType">
        <xsd:element name="GoodsReceiptParty" type="SchedulePartyType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="TermsOfDelivery" type="core:TermsOfDeliveryType">
        <xsd:element minOccurs="0" name="ListOfTransportRouting" type="core:ListOfTransportRoutingType">
        <xsd:element minOccurs="0" name="GoodsReceiptHeaderNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
        <xsd:element minOccurs="0" name="ListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: GoodsReceiptItemDetailType

GoodsReceiptItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( GoodsReceiptBaseItemDetail[GoodsReceiptBaseItemDetailType] , ListOfLineItemGoodsCondition[ListOfLineItemGoodsConditionType]? , UnacceptablePackaging[xsd:boolean]? , GoodsReceiptDeliveryDetail[GoodsReceiptDeliveryDetailType]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? , ListOfAttachment[core:ListOfAttachmentType]? , GoodsReceiptDetailNote[xsd:string]? )

    Description: GoodsReceiptItemDetailType holds one or more items for the document.

    Elements:

    • GoodsReceiptBaseItemDetail - identifies the basic information for the line item.
    • ListOfLineItemGoodsCondition - is used to capture discrepancies specific to a line item or relating to a item such as the packaging.
    • UnacceptablePackaging - is a flag that describes whether the package for the line item is unacceptable. The packaging is unacceptable because it has been damaged in transit or is insuffiecient to protect or contain the goods. Details of the unacceptable packing are to be completed in the LineItemGoodsCondition where Packaging is the GoodsConditionCode.
    • GoodsReceiptDeliveryDetail - contains the delivery information in the GoodsReceipt.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. Such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfNameValueSet - is used to hold sets of name value pairs. The use of this element should be limited to the support of previous versions of xCBL.
    • ListOfAttachment - holds one or more Attachment elements.
    • GoodsReceiptDetailNote - conatains a detail level note for the GoodsReceipt.

[^]Code Fragment

    <xsd:complexType name="GoodsReceiptItemDetailType">
    <xsd:sequence>
        <xsd:element name="GoodsReceiptBaseItemDetail" type="GoodsReceiptBaseItemDetailType">
        <xsd:element minOccurs="0" name="ListOfLineItemGoodsCondition" type="ListOfLineItemGoodsConditionType">
        <xsd:element minOccurs="0" name="UnacceptablePackaging" type="xsd:boolean">
        <xsd:element minOccurs="0" name="GoodsReceiptDeliveryDetail" type="GoodsReceiptDeliveryDetailType">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
        <xsd:element minOccurs="0" name="ListOfAttachment" type="core:ListOfAttachmentType">
        <xsd:element minOccurs="0" name="GoodsReceiptDetailNote" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: GoodsReceiptLineItemReferencesType

GoodsReceiptLineItemReferencesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ASNReference[core:ReferenceType]? , ASNLineItemNumber[xsd:int]? , ShippingReferences[ShippingReferencesType]? , ListOfPurchaseOrderReference[core:ListOfPurchaseOrderReferenceType]? , PlanningScheduleReference[core:ReferenceType]* , ShippingScheduleReference[core:ReferenceType]* , ListOfReferenceCoded[core:ListOfReferenceCodedType]? )

    Description: GoodsReceiptLineItemReferencesType provides the line item reference information for the GoodsReceipt.

    Elements:

    • ASNReference - contains a reference to the ASN that this GoodsReceipt is in response to.
    • ASNLineItemNumber - contains a reference to the line item number in the ASN.
    • ShippingReferences - identifies any documents associated with the shipment.
    • ListOfPurchaseOrderReference - is a list of Order information referenced by the GoodsReceipt.
    • PlanningScheduleReference - contains a reference to a planning schedule.
    • ShippingScheduleReference - contains a reference to a shipping schedule.
    • ListOfReferenceCoded - identifies other references.

[^]Code Fragment

    <xsd:complexType name="GoodsReceiptLineItemReferencesType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ASNReference" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="ASNLineItemNumber" type="xsd:int">
        <xsd:element minOccurs="0" name="ShippingReferences" type="ShippingReferencesType">
        <xsd:element minOccurs="0" name="ListOfPurchaseOrderReference" type="core:ListOfPurchaseOrderReferenceType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="PlanningScheduleReference" type="core:ReferenceType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="ShippingScheduleReference" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="ListOfReferenceCoded" type="core:ListOfReferenceCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: GoodsReceiptQuantitiesType

GoodsReceiptQuantitiesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ReceivedQuantity[core:QuantityType] , ShippedQuantity[core:QuantityType]? , QuantityDifference[core:QuantityType]? , OrderedQuantity[core:QuantityType]? , BackOrderedQuantity[core:QuantityType]? , ShippedToDateQuantity[core:QuantityType]? , ListOfQuantityCoded[core:ListOfQuantityCodedType]? )

    Description: GoodsReceiptQuantitiesType identifies all quantities associated with the line item for the goods receipt.

    Elements:

    • ReceivedQuantity - is the amount of the item that was received.
    • ShippedQuantity - is the amount of the item that is being shipped.
    • QuantityDifference - is the difference between the quantity shipped and the quantity received, if applicable.
    • OrderedQuantity - holds the quantity ordered.
    • BackOrderedQuantity - is the quantity of the item that has been back ordered.
    • ShippedToDateQuantity - holds the total quantity shipped for the line item (partial deliveries).
    • ListOfQuantityCoded - specifies any other quantities not explicitly stated.

[^]Code Fragment

    <xsd:complexType name="GoodsReceiptQuantitiesType">
    <xsd:sequence>
        <xsd:element name="ReceivedQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="ShippedQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="QuantityDifference" type="core:QuantityType">
        <xsd:element minOccurs="0" name="OrderedQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="BackOrderedQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="ShippedToDateQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="ListOfQuantityCoded" type="core:ListOfQuantityCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: GoodsReceiptReferencesType

GoodsReceiptReferencesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ASNReference[core:ReferenceType]? , ShippingReferences[ShippingReferencesType]? , ListOfPurchaseOrderReference[core:ListOfPurchaseOrderReferenceType]? , PlanningScheduleReference[core:ReferenceType]* , ShippingScheduleReference[core:ReferenceType]* , ListOfReferenceCoded[core:ListOfReferenceCodedType]? )

    Description: GoodsReceiptReferencesType contains information on other documents and numbers referenced by the GoodsReceipt.

    Elements:

    • ASNReference - contains a reference to the ASN that this GoodsReceipt is in response to.
    • ShippingReferences - identifies any documents associated with the shipment.
    • ListOfPurchaseOrderReference - is a list of Order information referenced by the GoodsReceipt.
    • PlanningScheduleReference - contains a reference to a planning schedule.
    • ShippingScheduleReference - contains a reference to a shipping schedule.
    • ListOfReferenceCoded - allows for referencing other documents that can apply to the GoodsReceipt.

[^]Code Fragment

    <xsd:complexType name="GoodsReceiptReferencesType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ASNReference" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="ShippingReferences" type="ShippingReferencesType">
        <xsd:element minOccurs="0" name="ListOfPurchaseOrderReference" type="core:ListOfPurchaseOrderReferenceType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="PlanningScheduleReference" type="core:ReferenceType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="ShippingScheduleReference" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="ListOfReferenceCoded" type="core:ListOfReferenceCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: GoodsReceiptType

GoodsReceiptType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( GoodsReceiptHeader[GoodsReceiptHeaderType] , GoodsReceiptDetail[GoodsReceiptDetailType]? , DigitalSignature[dgs:SignatureType]? )

    Description: GoodsReceiptType A message initiated by the party, which received the goods. In most cases this is the buyer, but can also be a third party. The GoodsReceipt can be used to provide customary and established business and industry practice relative to the notification of receipt or formal acceptance of goods and services. The message is used to report the physical receipt of goods. It allows for the reporting of discrepancies in products, quantities, terms, packages, etc. It should not be used to convey inventory positions- this will be handled in a separate xCBL document. The GoodsReceipt is often sent when there is a discrepancy between the material being received and the information that was transmitted in the AdvanceShipmentNotice (ASN). The GoodsReceipt can also be used as a credit memo in a 'pay on ASN relationship.' In this scenario the GoodsReceipt is used as a reference for payment, as in an Evaluated Receipt Settlement (ERS).

    Elements:

    • GoodsReceiptHeader - contains the header information of the GoodsReceipt.
    • GoodsReceiptDetail - contains the detail level information for the GoodsReceipt.
    • DigitalSignature - contains a digital signature for the document.

[^]Code Fragment

    <xsd:complexType name="GoodsReceiptType">
    <xsd:sequence>
        <xsd:element name="GoodsReceiptHeader" type="GoodsReceiptHeaderType">
        <xsd:element minOccurs="0" name="GoodsReceiptDetail" type="GoodsReceiptDetailType">
        <xsd:element minOccurs="0" name="DigitalSignature" type="dgs:SignatureType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: GoodsReceiptTypeCodeType

GoodsReceiptTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - CustomCode
    • ReceivingDockAdvice - Receiving Dock Advice
    • PostReceiptAdvice - Post Receipt Advice
    • DispositionAdvice - indicates receipt at the final point where disposal will occur
    • MeteredGasVolumeAdvice - Metered Gas Volume Advice
    • FacilityOperatorsAllocationAdvice - Facility Operator's Allocation Advice
    • NaturalGasSellersAllocationAdvice - Natural Gas Seller's Allocation Advice
    • PipelineAllocationAdvice - Pipeline Allocation Advice
    • AcceptanceCertificate - Acceptance Certificate
    • AuthorizedRepresentativeInReceipt - Authorized Representative in Receipt of an Acceptance Alert
    • AuthorizedRepresentativeNotInReceipt - Authorized Representative Not in Receipt of an Acceptance Alert
    • IntermediatePointReceiptAdvice - Intermediate Point Receipt Advice
    • Acknowledgement - Acknowledgement to ASN

[^]Code Fragment

    <xsd:simpleType name="GoodsReceiptTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="ReceivingDockAdvice">
        <xsd:enumeration value="PostReceiptAdvice">
        <xsd:enumeration value="DispositionAdvice">
        <xsd:enumeration value="MeteredGasVolumeAdvice">
        <xsd:enumeration value="FacilityOperatorsAllocationAdvice">
        <xsd:enumeration value="NaturalGasSellersAllocationAdvice">
        <xsd:enumeration value="PipelineAllocationAdvice">
        <xsd:enumeration value="AcceptanceCertificate">
        <xsd:enumeration value="AuthorizedRepresentativeInReceipt">
        <xsd:enumeration value="AuthorizedRepresentativeNotInReceipt">
        <xsd:enumeration value="IntermediatePointReceiptAdvice">
        <xsd:enumeration value="Acknowledgement">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: IDNumberRangesType

IDNumberRangesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ProductIdentifierQualifierCoded[core:ProductIdentifierQualifierCodeType] , ProductIdentifierQualifierCodedOther[xsd:string]? , ListOfIDNumbers[ListOfIDNumbersType] )

    Description: IDNumberRangesType contains a qualifier that specifies the type of the ID numbers along with a set of number ranges.

    Elements:

    • ProductIdentifierQualifierCoded - qualifies the item identification using a standard codelist.
    • ProductIdentifierQualifierCodedOther - is used to provide a non-standard ProductIdentifierQualifierCode. This element is mandatory if the value of ProductIdentifierQualifierCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • ListOfIDNumbers - contains a set of numbers that can be specified as ranges or single ID values.

[^]Code Fragment

    <xsd:complexType name="IDNumberRangesType">
    <xsd:sequence>
        <xsd:element name="ProductIdentifierQualifierCoded" type="core:ProductIdentifierQualifierCodeType">
        <xsd:element minOccurs="0" name="ProductIdentifierQualifierCodedOther" type="xsd:string">
        <xsd:element name="ListOfIDNumbers" type="ListOfIDNumbersType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: IDNumbersType

IDNumbersType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( IDNumberMin[xsd:string] , IDNumberMax[xsd:string]? )

    Description: IDNumbersType contains a set of numbers that can be specified as ranges or single ID values.

    Elements:

    • IDNumberMin - contains an ID number that is a stand-alone value if the IDNumberMax value is not present. If the IDNumberMax value is present, then the IDNumberMin is the lower value of the specified ID range. This range value is inclusive.
    • IDNumberMax - contains the upper value of the specified ID range. This range value is inclusive.

[^]Code Fragment

    <xsd:complexType name="IDNumbersType">
    <xsd:sequence>
        <xsd:element name="IDNumberMin" type="xsd:string">
        <xsd:element minOccurs="0" name="IDNumberMax" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: InventoryItemIdentifiersType

InventoryItemIdentifiersType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: Extends: core:ItemIdentifiersType

      Append:( ListOfIDNumberRanges[IDNumberRangesType]? )

    Description: InventoryItemIdentifiersType extends the core ItemIdentifiers to include the ability to specify identification number ranges.

    Elements:

    • ListOfIDNumberRanges - contains a qualifier along with a a set of identifcation numbers which can be given as single numbers or a range or numbers.

[^]Code Fragment

    <xsd:complexType name="InventoryItemIdentifiersType">
    <xsd:complexContent>
        <xsd:extension base="core:ItemIdentifiersType">
            <xsd:sequence>
                <xsd:element minOccurs="0" name="ListOfIDNumberRanges" type="IDNumberRangesType">
            </xsd:sequence>
        </xsd:extension>
    </xsd:complexContent>
</xsd:complexType>


complexType definition: InventoryManagementDetailType

InventoryManagementDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( InventoryQuantity[core:QuantityCodedType] , InventoryReportDates[InventoryReportDatesType]? , InventoryDescription[xsd:string]? , GoodsMovementDescription[xsd:string]? , GoodsMovementReason[xsd:string]? , IsMovementIntoInventory[xsd:boolean]? )

    Description: InventoryManagementDetailType is used to specify further details pertaining to the goods movement, inventory classification, and and additional quantity information for the material.

    Elements:

    • InventoryQuantity - can be used to further break down the details of the TotalInventoryQuantity. For example, the TotalInventoryQuantity is 100 items. Users can further specify that 50 of the 100 items are restricted stock and 50 is open stock. The InventoryQuantity can also be used to specify goods movements details that resulted in the TotalInventoryQuantity value. For example,
    • InventoryReportDates - contains dates that are intended to be used to describe teh InventoryQuantity value. This may contain the date that the goodsmovement took place or the date that the inventory was actually counted.
    • InventoryDescription - contains a free-form text field to further describe the inventory. This may be used to specify the classification or type of the inventory (i.e., restricted stock, damaged stock).
    • GoodsMovementDescription - identifies the type of goods movement for the specified inventory.
    • GoodsMovementReason - contains a free-text format to specify a brief business reason for the goods movement.
    • IsMovementIntoInventory - contains a boolean flag to specify whether or not the goods movement direction is into the current inventory. If value is "True" then the goods movement direction is "IN". If value is "False", then the goods movement direction is "OUT"

[^]Code Fragment

    <xsd:complexType name="InventoryManagementDetailType">
    <xsd:sequence>
        <xsd:element name="InventoryQuantity" type="core:QuantityCodedType">
        <xsd:element minOccurs="0" name="InventoryReportDates" type="InventoryReportDatesType">
        <xsd:element minOccurs="0" name="InventoryDescription" type="xsd:string">
        <xsd:element minOccurs="0" name="GoodsMovementDescription" type="xsd:string">
        <xsd:element minOccurs="0" name="GoodsMovementReason" type="xsd:string">
        <xsd:element minOccurs="0" name="IsMovementIntoInventory" type="xsd:boolean">
    </xsd:sequence>
</xsd:complexType>


complexType definition: InventoryReportDatesType

InventoryReportDatesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( StartDate[xsd:dateTime]? , EndDate[xsd:dateTime]? , ListOfDateCoded[core:ListOfDateCodedType]? )

    Description: InventoryReportDatesType indicates the pertinent dates for the InventoryReport. These dates are global and apply to the entire inventory report, except where overridden by dates provided at the line item or package level

    Elements:

    • StartDate - indicates the date and time for which the inventory report information begins.
    • EndDate - indicates the date and time for which the inventory report information ends.
    • ListOfDateCoded - is used to communicate any other dates not explicitly stated by another element.

[^]Code Fragment

    <xsd:complexType name="InventoryReportDatesType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="StartDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="EndDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ListOfDateCoded" type="core:ListOfDateCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: InventoryReportDetailType

InventoryReportDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( LineItemNumber[xsd:string] , LineItemType[core:LineItemTypeType]? , ParentLineItemReference[xsd:string]? , InventoryItemIdentifiers[InventoryItemIdentifiersType] , ListOfDimension[core:ListOfDimensionType]? , TotalInventoryQuantity[core:QuantityType] , InventoryReportDates[InventoryReportDatesType]? , ListOfInventoryMangementDetail[ListOfInventoryManagementDetailType]? , InventoryReportDetailNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? , InventoryReportDetailAttachments[core:ListOfAttachmentType]? )

    Description: InventoryReportDetailType contains the identifying and descriptive information for the line items in the InventoryReport.

    Elements:

    • LineItemNumber - is a unique identifier for the the line item within the document.
    • LineItemType - identifies whether the line item is a component group (consists of other line items), a typical line item, or a textual line item.
    • ParentLineItemReference - identifies the line item that groups this and other line items. This specifies the number of the parent line item.
    • InventoryItemIdentifiers - details all of the part numbers assigned to the item.
    • ListOfDimension - lists one or more quantitative measurements of the item.
    • TotalInventoryQuantity - specifies the total quantity of the item in inventory.
    • InventoryReportDates - indicates date values for which the TotalInventoryQuantity is valid. This date may be the date when the inventory was counted.
    • ListOfInventoryMangementDetail - is used to specify further details pertaining to the goods movement, inventory classification, and and additional quantity information for the material.
    • InventoryReportDetailNote - contains any free-form text pertinent to the entire InventoryReport document. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfNameValueSet - is used to hold a collection of values qualified by names. The values contianed in this element should be agreed upon by trading partners.
    • InventoryReportDetailAttachments - contains a list of attachments applicable to the entire InventoryReport. The information is not specific to a particular line item or package, unless specifically noted.

[^]Code Fragment

    <xsd:complexType name="InventoryReportDetailType">
    <xsd:sequence>
        <xsd:element name="LineItemNumber" type="xsd:string">
        <xsd:element minOccurs="0" name="LineItemType" type="core:LineItemTypeType">
        <xsd:element minOccurs="0" name="ParentLineItemReference" type="xsd:string">
        <xsd:element name="InventoryItemIdentifiers" type="InventoryItemIdentifiersType">
        <xsd:element minOccurs="0" name="ListOfDimension" type="core:ListOfDimensionType">
        <xsd:element name="TotalInventoryQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="InventoryReportDates" type="InventoryReportDatesType">
        <xsd:element minOccurs="0" name="ListOfInventoryMangementDetail" type="ListOfInventoryManagementDetailType">
        <xsd:element minOccurs="0" name="InventoryReportDetailNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
        <xsd:element minOccurs="0" name="InventoryReportDetailAttachments" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: InventoryReportHeaderType

InventoryReportHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( InventoryReportID[xsd:string] , InventoryReportIssueDate[xsd:dateTime] , InventoryReportPurpose[core:PurposeType]? , InventoryReportType[InventoryReportTypeType] , InventoryReportLanguage[core:LanguageType]? , InventoryReportDates[InventoryReportDatesType]? , InventoryReportParty[InventoryReportPartyType] , InventoryReportHeaderNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? , InventoryReportHeaderAttachments[core:ListOfAttachmentType]? )

    Description: InventoryReportHeaderType contains the header information of the InventoryReport.

    Elements:

    • InventoryReportID - is the number that uniquely identifies the InventoryReport, typically according to the system that generated the document.
    • InventoryReportIssueDate - holds a digital time stamp provided by the application that created the InventoryReport document.
    • InventoryReportPurpose - defines the purpose of the InventoryReport document.
    • InventoryReportType - specifies the type of report the InventoryReport document.
    • InventoryReportLanguage - identifies the language of the InventoryReport.
    • InventoryReportDates - indicates the pertinent dates for the InventoryReport. These dates are global and apply to the entire document, except where overridden by dates provided at the line item level.
    • InventoryReportParty - holds information on the parties to the InventoryReport, including unique ID's and address information.
    • InventoryReportHeaderNote - contains any free-form text pertinent to the entire InventoryReport document. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfNameValueSet - is used to hold a collection of values qualified by names. The values contianed in this element should be agreed upon by trading partners.
    • InventoryReportHeaderAttachments - contains a list of attachments applicable to the entire InventoryReport. The information is not specific to a particular line item or package, unless specifically noted.

[^]Code Fragment

    <xsd:complexType name="InventoryReportHeaderType">
    <xsd:sequence>
        <xsd:element name="InventoryReportID" type="xsd:string">
        <xsd:element name="InventoryReportIssueDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="InventoryReportPurpose" type="core:PurposeType">
        <xsd:element name="InventoryReportType" type="InventoryReportTypeType">
        <xsd:element minOccurs="0" name="InventoryReportLanguage" type="core:LanguageType">
        <xsd:element minOccurs="0" name="InventoryReportDates" type="InventoryReportDatesType">
        <xsd:element name="InventoryReportParty" type="InventoryReportPartyType">
        <xsd:element minOccurs="0" name="InventoryReportHeaderNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
        <xsd:element minOccurs="0" name="InventoryReportHeaderAttachments" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: InventoryReportPartyType

InventoryReportPartyType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( SenderParty[core:PartyCodedType] , ReceiverParty[core:PartyCodedType] , ListOfPartyCoded[core:ListOfPartyCodedType]? )

    Description: InventoryReportPartyType holds all party information related to the inventory report.

    Elements:

    • SenderParty - contains information for the party originating the InventoryReport document. PartyRoleCoded is used to specify the relationship between the sender and receiver and identify the role that the sender plays with respect to the receiver. The PartyRoleCoded value can be any valid role code value. For example, values such as Seller, Buyer, ThirdParty, or Warehouse could be used here.
    • ReceiverParty - contains information for the party receving the InventoryReport document. PartyRoleCoded is used to specify the relationship between the sender and receiver and identify the role that the receiver plays with respect to the sender. The PartyRoleCoded value can be any valid role code value. For example, values such as Seller, Buyer, ThirdParty, or Warehouse could be used here.
    • ListOfPartyCoded - is used to identify any other relevant parties associated with the InvetoryReport.

[^]Code Fragment

    <xsd:complexType name="InventoryReportPartyType">
    <xsd:sequence>
        <xsd:element name="SenderParty" type="core:PartyCodedType">
        <xsd:element name="ReceiverParty" type="core:PartyCodedType">
        <xsd:element minOccurs="0" name="ListOfPartyCoded" type="core:ListOfPartyCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: InventoryReportSummaryType

InventoryReportSummaryType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( NumberOfLines[xsd:int]? , SummaryNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? )

    Description: InventoryReportSummaryType contains the summary information of the InventoryRep[ort, typically totals of numerical fields.

    Elements:

    • NumberOfLines - identifies the number of line items.
    • SummaryNote - describes any free-form text pertinent to the summary described by the InventoryReport. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfNameValueSet - is used to hold a collection of values qualified by names. The values contianed in this element should be agreed upon by trading partners.

[^]Code Fragment

    <xsd:complexType name="InventoryReportSummaryType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="NumberOfLines" type="xsd:int">
        <xsd:element minOccurs="0" name="SummaryNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: InventoryReportType

InventoryReportType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( InventoryReportHeader[InventoryReportHeaderType] , ListOfInventoryReportDetail[ListOfInventoryReportDetailType] , InventoryReportSummary[InventoryReportSummaryType]? , DigitalSignature[dgs:SignatureType]? )

    Description: InventoryReportType is used to communicate information regarding current inventory levels for raw materials, manaufactured goods, or any other type of stockable materials.

    Elements:

    • InventoryReportHeader - contains the header information of the InventoryReport.
    • ListOfInventoryReportDetail - contains line level details for the InventoryReport.
    • InventoryReportSummary - contains the summary information of the InventoryReport,typically totals of numerical fields.
    • DigitalSignature - contains a digital signature for the document.

[^]Code Fragment

    <xsd:complexType name="InventoryReportType">
    <xsd:sequence>
        <xsd:element name="InventoryReportHeader" type="InventoryReportHeaderType">
        <xsd:element name="ListOfInventoryReportDetail" type="ListOfInventoryReportDetailType">
        <xsd:element minOccurs="0" name="InventoryReportSummary" type="InventoryReportSummaryType">
        <xsd:element minOccurs="0" name="DigitalSignature" type="dgs:SignatureType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: InventoryReportTypeCodeType

InventoryReportTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • AgentInventoryReport
    • Agent-DistributorInventoryReport
    • Customer-DistributorInventoryReport
    • Customer-ManufacturerInventoryReport
    • Distributor-CustomerInventoryReport
    • DistributorInventoryReport
    • Distributor-ManufacturerInventoryReport
    • LocationInventoryReport
    • Manufacturer-AgentInventoryReport
    • Manufacturer-DistributorInventoryReport
    • Manufacturer-CustomerInventoryReport
    • ManufacturerInventoryReport
    • PipeLine-ShipperInventoryReport
    • InterPlantInventoryReport
    • SellerInventoryReport

[^]Code Fragment

    <xsd:simpleType name="InventoryReportTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="AgentInventoryReport">
        <xsd:enumeration value="Agent-DistributorInventoryReport">
        <xsd:enumeration value="Customer-DistributorInventoryReport">
        <xsd:enumeration value="Customer-ManufacturerInventoryReport">
        <xsd:enumeration value="Distributor-CustomerInventoryReport">
        <xsd:enumeration value="DistributorInventoryReport">
        <xsd:enumeration value="Distributor-ManufacturerInventoryReport">
        <xsd:enumeration value="LocationInventoryReport">
        <xsd:enumeration value="Manufacturer-AgentInventoryReport">
        <xsd:enumeration value="Manufacturer-DistributorInventoryReport">
        <xsd:enumeration value="Manufacturer-CustomerInventoryReport">
        <xsd:enumeration value="ManufacturerInventoryReport">
        <xsd:enumeration value="PipeLine-ShipperInventoryReport">
        <xsd:enumeration value="InterPlantInventoryReport">
        <xsd:enumeration value="SellerInventoryReport">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: InventoryReportTypeType

InventoryReportTypeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( InventoryReportTypeCoded[InventoryReportTypeCodeType] , InventoryReportTypeCodedOther[xsd:string]? )

    Description: InventoryReportTypeType is used to indicate the .

    Elements:

    • InventoryReportTypeCoded - specifies the function of the InventoryReport using a standard codelist.
    • InventoryReportTypeCodedOther - is used to provide a non-standard InventoryReportTypeCode. This element is mandatory if the value of InventoryReportTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="InventoryReportTypeType">
    <xsd:sequence>
        <xsd:element name="InventoryReportTypeCoded" type="InventoryReportTypeCodeType">
        <xsd:element minOccurs="0" name="InventoryReportTypeCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: ItemReleaseStatusCodeType

ItemReleaseStatusCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:
    This code identifies the status of the part being ordered or forecast with respect to the material release or planning document. This code list is derived from X12 682 (Part release status code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • FabricationAuthorizationQuantityIsFinalYearRequirement - Fabrication Authorization Quantity is Final Model Year Requirement; The Part is a Non carryover Item for the Subsequent Model Year from the Supplier
    • MaterialAuthorizationQuantityIsFinalYearRequirement - Material Authorization Quantity is Final Model Year Requirement; The Part is a Non carryover Item for the Subsequent Model Year from the Supplier
    • PartWillBeCanceledAtTheMaterialQuantity - Part will be Canceled at the Material Quantity
    • PartIsACarryoverItemFromSubsequentModelYearFromTheSupplier - Part is a Carryover Item from Subsequent Model Year from the Supplier
    • PartIsANewItemForTheSubsequentModelYear - Part is a New Item for the Subsequent Model Year
    • PartIsANewItemDueToAnInterimEngineeringRelease - Part is a New Item Due to an Interim Engineering Release
    • FinalReleaseForThisCancelledPart - Final Release for this Cancelled Part
    • PlanningQuantityIsFinalYearRequirement - Planning Quantity is Final Model Year Requirement The Part is a Non-Carryover Item for the Subsequent Model Year From the Supplier
    • FinalForecastForThisCancelledPart - Final Forecast for this Cancelled Part
    • AllTimeBuy - All Time Buy. Unless Specifically Stated, This Code is Not to be Interpreted as Authorization for Tool Scrap
    • Balance-OutPart - Balance-Out Part; Eng. Change Pending
    • TerminalBuy - Terminal Buy
    • SystemsAutomatedBuy - Systems Automated Buy
    • CorporationCampaignBuy - Corporation Campaign Buy
    • SourceSurplus - Source Surplus
    • Reschedule - Reschedule
    • MerchandizingActPromotionBuy - Merchandizing Act Promotion Buy
    • MinimumOrLotBuy - Minimum or Lot Buy
    • DieTie - Die Tie
    • LandauSpecification - Landau Specification
    • MillRunPurchase - Mill Run Purchase
    • Solicitation - Solicitation
    • PilotPreProduction - Pilot/Pre-production
    • SpecialLargeQuantityBuy - Special Large Quantity Buy
    • ReplacementOrders - Replacement Orders
    • InitialOrders - Initial Orders
    • TrimOrder - Trim Order
    • ConfirmingPhoneOrder - Confirming Phone Order
    • CoverOvershipment-DoNotReship - Cover Overshipment - Do Not Reship
    • EconomicOrderQuantity - Economic Order Quantity
    • ProductionYearEndSurplus - Production Year End Surplus

[^]Code Fragment

    <xsd:simpleType name="ItemReleaseStatusCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="FabricationAuthorizationQuantityIsFinalYearRequirement">
        <xsd:enumeration value="MaterialAuthorizationQuantityIsFinalYearRequirement">
        <xsd:enumeration value="PartWillBeCanceledAtTheMaterialQuantity">
        <xsd:enumeration value="PartIsACarryoverItemFromSubsequentModelYearFromTheSupplier">
        <xsd:enumeration value="PartIsANewItemForTheSubsequentModelYear">
        <xsd:enumeration value="PartIsANewItemDueToAnInterimEngineeringRelease">
        <xsd:enumeration value="FinalReleaseForThisCancelledPart">
        <xsd:enumeration value="PlanningQuantityIsFinalYearRequirement">
        <xsd:enumeration value="FinalForecastForThisCancelledPart">
        <xsd:enumeration value="AllTimeBuy">
        <xsd:enumeration value="Balance-OutPart">
        <xsd:enumeration value="TerminalBuy">
        <xsd:enumeration value="SystemsAutomatedBuy">
        <xsd:enumeration value="CorporationCampaignBuy">
        <xsd:enumeration value="SourceSurplus">
        <xsd:enumeration value="Reschedule">
        <xsd:enumeration value="MerchandizingActPromotionBuy">
        <xsd:enumeration value="MinimumOrLotBuy">
        <xsd:enumeration value="DieTie">
        <xsd:enumeration value="LandauSpecification">
        <xsd:enumeration value="MillRunPurchase">
        <xsd:enumeration value="Solicitation">
        <xsd:enumeration value="PilotPreProduction">
        <xsd:enumeration value="SpecialLargeQuantityBuy">
        <xsd:enumeration value="ReplacementOrders">
        <xsd:enumeration value="InitialOrders">
        <xsd:enumeration value="TrimOrder">
        <xsd:enumeration value="ConfirmingPhoneOrder">
        <xsd:enumeration value="CoverOvershipment-DoNotReship">
        <xsd:enumeration value="EconomicOrderQuantity">
        <xsd:enumeration value="ProductionYearEndSurplus">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: ItemResourceAuthorizationType

ItemResourceAuthorizationType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ResourceAuthorizationCoded[ResourceAuthorizationCodeType] , ResourceAuthorizationCodedOther[xsd:string]? , ValidityDates[core:ValidityDatesType]? )

    Description: ItemResourceAuthorizationType is used to specify resource authorization in the schedule.

    Elements:

    • ResourceAuthorizationCoded - is the code identifying the resource authorization for the schedule quantity. The quantity fields are cumulative when this segment is used.
    • ResourceAuthorizationCodedOther - is used to provide a non-standard ResourceAuthorizationCode. This element is mandatory if the value of ResourceAuthorizationCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • ValidityDates - is used to specify a start and end dates of a period which the ItemResourceAuthorization is valid.

[^]Code Fragment

    <xsd:complexType name="ItemResourceAuthorizationType">
    <xsd:sequence>
        <xsd:element name="ResourceAuthorizationCoded" type="ResourceAuthorizationCodeType">
        <xsd:element minOccurs="0" name="ResourceAuthorizationCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="ValidityDates" type="core:ValidityDatesType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: LineItemGoodsConditionType

LineItemGoodsConditionType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( Quantity[core:QuantityType] , GoodsCondition[GoodsConditionType] , DiscrepancyCoded[DiscrepancyCodeType]? , DiscrepancyCodedOther[xsd:string]? )

    Description: LineItemGoodsConditionType specifies a quantity and the condition or discrepancy associated with it.

    Elements:

    • Quantity - contains the numeric value that applies to the conditions and descrepancy codes.
    • GoodsCondition - is used to provide detail on the data that is being contested/rejected/put on hold. The GoodsCondition is assumed to relate to the specific line item, unless specified differently by the ElementIdentifierCoded.
    • DiscrepancyCoded - is a code identifying the difference between the quantity shipped/ordered/invoiced and the quantity received for a line item or transaction.
    • DiscrepancyCodedOther - is used to provide a non-standard DiscrepancyCode. This element is mandatory if the value of DiscrepancyCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="LineItemGoodsConditionType">
    <xsd:sequence>
        <xsd:element name="Quantity" type="core:QuantityType">
        <xsd:element name="GoodsCondition" type="GoodsConditionType">
        <xsd:element minOccurs="0" name="DiscrepancyCoded" type="DiscrepancyCodeType">
        <xsd:element minOccurs="0" name="DiscrepancyCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfASNItemDetailType

ListOfASNItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ASNItemDetail[ASNItemDetailType]+ )

    Description: ListOfASNItemDetailType contains a list of line items for the ASN.

    Elements:

    • ASNItemDetail - contains the item detail information for the ASN.

[^]Code Fragment

    <xsd:complexType name="ListOfASNItemDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="ASNItemDetail" type="ASNItemDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfASNPackageDetailType

ListOfASNPackageDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ASNPackageDetail[core:PackageDetailType]+ )

    Description: ListOfASNPackageDetailType

    Elements:

    • ASNPackageDetail

[^]Code Fragment

    <xsd:complexType name="ListOfASNPackageDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="ASNPackageDetail" type="core:PackageDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfCarrierReferenceType

ListOfCarrierReferenceType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( CarrierReference[CarrierReferenceType]+ )

    Description: ListOfCarrierReferenceType contains a list of references issued by the carrier.

    Elements:

    • CarrierReference - contains the carrier reference number.

[^]Code Fragment

    <xsd:complexType name="ListOfCarrierReferenceType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="CarrierReference" type="CarrierReferenceType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfGoodsConditionType

ListOfGoodsConditionType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( GoodsCondition[GoodsConditionType]+ )

    Description: ListOfGoodsConditionType is used to describe the elements around which discrepancies exist. This is used at the header level to report any conditions that don't relate to a specific goods item, i.e.this relates to the entire shipment or to all of the goods. Specific item discrepancies should be handled at the item level.

    Elements:

    • GoodsCondition - used to provide information on the data that is being contested/rejected/put on hold. This can be the entire document or an element such as the seal number on a piece of equipment. When the ElementIdentifierCoded is not used at the header level, the GoodsCondition applies as the default to the entire GoodsReceipt document.

[^]Code Fragment

    <xsd:complexType name="ListOfGoodsConditionType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="GoodsCondition" type="GoodsConditionType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfGoodsReceiptItemDetailType

ListOfGoodsReceiptItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( GoodsReceiptItemDetail[GoodsReceiptItemDetailType]+ )

    Description: ListOfGoodsReceiptItemDetailType provides a list of line item information for the GoodsReceipt.

    Elements:

    • GoodsReceiptItemDetail - holds one or more items for the document.

[^]Code Fragment

    <xsd:complexType name="ListOfGoodsReceiptItemDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="GoodsReceiptItemDetail" type="GoodsReceiptItemDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfIDNumberRangesType

ListOfIDNumberRangesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( IDNumberRanges[IDNumberRangesType]+ )

    Description: ListOfIDNumberRangesType

    Elements:

    • IDNumberRanges

[^]Code Fragment

    <xsd:complexType name="ListOfIDNumberRangesType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="IDNumberRanges" type="IDNumberRangesType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfIDNumbersType

ListOfIDNumbersType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( IDNumbers[IDNumbersType]+ )

    Description: ListOfIDNumbersType

    Elements:

    • IDNumbers

[^]Code Fragment

    <xsd:complexType name="ListOfIDNumbersType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="IDNumbers" type="IDNumbersType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfInventoryManagementDetailType

ListOfInventoryManagementDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( InventoryManagementDetail[InventoryManagementDetailType]+ )

    Description: ListOfInventoryManagementDetailType

    Elements:

    • InventoryManagementDetail

[^]Code Fragment

    <xsd:complexType name="ListOfInventoryManagementDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="InventoryManagementDetail" type="InventoryManagementDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfInventoryReportDetailType

ListOfInventoryReportDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( InventoryReportDetail[InventoryReportDetailType]+ )

    Description: ListOfInventoryReportDetailType

    Elements:

    • InventoryReportDetail

[^]Code Fragment

    <xsd:complexType name="ListOfInventoryReportDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="InventoryReportDetail" type="InventoryReportDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfLineItemGoodsConditionType

ListOfLineItemGoodsConditionType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( LineItemGoodsCondition[LineItemGoodsConditionType]+ )

    Description: ListOfLineItemGoodsConditionType is used to capture discrepancies specific to a line item or relating to a item such as the packaging.

    Elements:

    • LineItemGoodsCondition - specifies a quantity and the condition or discrepancy associated with it.

[^]Code Fragment

    <xsd:complexType name="ListOfLineItemGoodsConditionType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="LineItemGoodsCondition" type="LineItemGoodsConditionType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfLocationGroupedPlanningDetailType

ListOfLocationGroupedPlanningDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( LocationGroupedPlanningDetail[LocationGroupedPlanningDetailType]+ )

    Description: ListOfLocationGroupedPlanningDetailType contains the line level detail information for the PlanningSchedule. The detail is grouped by the delivery location. This is one of two options for grouping forecasting detail in the PlanningSchedule.

    Elements:

    • LocationGroupedPlanningDetail - contains all the schedule-line-level data grouped by the delivery location.

[^]Code Fragment

    <xsd:complexType name="ListOfLocationGroupedPlanningDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="LocationGroupedPlanningDetail" type="LocationGroupedPlanningDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfLocationGroupedPlanningResponseType

ListOfLocationGroupedPlanningResponseType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( LocationGroupedPlanningResponse[LocationGroupedPlanningResponseType]+ )

    Description: ListOfLocationGroupedPlanningResponseType contains the line level detail information for the planning schedule. The detail is grouped by the delivery location. This is one of two options for grouping forecasting detail in the PlanningScheduleResponse document.

    Elements:

    • LocationGroupedPlanningResponse - contains all the schedule-line-level data grouped by the delivery location.

[^]Code Fragment

    <xsd:complexType name="ListOfLocationGroupedPlanningResponseType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="LocationGroupedPlanningResponse" type="LocationGroupedPlanningResponseType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfLocationGroupedShippingDetailType

ListOfLocationGroupedShippingDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( LocationGroupedShippingDetail[LocationGroupedShippingDetailType]+ )

    Description: ListOfLocationGroupedShippingDetailType contains the line level detail information for the ShippingSchedule document. The detail is grouped by the delivery point. This is one of two options for grouping the shipping detail.

    Elements:

    • LocationGroupedShippingDetail - contains all the schedule-line-level data grouped by the delivery location.

[^]Code Fragment

    <xsd:complexType name="ListOfLocationGroupedShippingDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="LocationGroupedShippingDetail" type="LocationGroupedShippingDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfLocationGroupedShippingResponseType

ListOfLocationGroupedShippingResponseType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( LocationGroupedShippingResponse[LocationGroupedShippingResponseType]+ )

    Description: ListOfLocationGroupedShippingResponseType contains the line level detail information for the planningschedule. The detail is grouped by the delivery location. This is one of two options for grouping forecasting detail in the ShippingScheduleResponse.

    Elements:

    • LocationGroupedShippingResponse - contains all the schedule-line-level data grouped by the delivery location.

[^]Code Fragment

    <xsd:complexType name="ListOfLocationGroupedShippingResponseType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="LocationGroupedShippingResponse" type="LocationGroupedShippingResponseType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfLocationPlanningItemDetailType

ListOfLocationPlanningItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( LocationPlanningItemDetail[LocationPlanningItemDetailType]+ )

    Description: ListOfLocationPlanningItemDetailType is a list of item details organized by location.

    Elements:

    • LocationPlanningItemDetail - is a collection of items that are grouped by location for planning purposes.

[^]Code Fragment

    <xsd:complexType name="ListOfLocationPlanningItemDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="LocationPlanningItemDetail" type="LocationPlanningItemDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfLocationScheduleType

ListOfLocationScheduleType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( LocationSchedule[LocationScheduleType]+ )

    Description: ListOfLocationScheduleType is the scheduling information by location for the material identified by the line item.

    Elements:

    • LocationSchedule - is a schedule for the material based on location.

[^]Code Fragment

    <xsd:complexType name="ListOfLocationScheduleType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="LocationSchedule" type="LocationScheduleType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfLocationShippingItemDetailType

ListOfLocationShippingItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( LocationShippingItemDetail[LocationShippingItemDetailType]+ )

    Description: ListOfLocationShippingItemDetailType is a list of item details organized by location.

    Elements:

    • LocationShippingItemDetail - is a collection of items that are grouped by location for shipping purposes.

[^]Code Fragment

    <xsd:complexType name="ListOfLocationShippingItemDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="LocationShippingItemDetail" type="LocationShippingItemDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfLocationShipScheduleType

ListOfLocationShipScheduleType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( LocationShipSchedule[LocationShipScheduleType]+ )

    Description: ListOfLocationShipScheduleType is the scheduling information by location for the material identified by the line item.

    Elements:

    • LocationShipSchedule - is a schedule for the material based on location.

[^]Code Fragment

    <xsd:complexType name="ListOfLocationShipScheduleType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="LocationShipSchedule" type="LocationShipScheduleType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfMaterialGroupedPlanningDetailType

ListOfMaterialGroupedPlanningDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( MaterialGroupedPlanningDetail[MaterialGroupedPlanningDetailType]+ )

    Description: ListOfMaterialGroupedPlanningDetailType contains the line level detail information for the PlanningSchedule. The detail is grouped by the material. This is one of two options for grouping forecasting detail in the PlanningSchedule.

    Elements:

    • MaterialGroupedPlanningDetail - contains all the schedule-line-level data grouped by the material/product.

[^]Code Fragment

    <xsd:complexType name="ListOfMaterialGroupedPlanningDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="MaterialGroupedPlanningDetail" type="MaterialGroupedPlanningDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfMaterialGroupedPlanningResponseType

ListOfMaterialGroupedPlanningResponseType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( MaterialGroupedPlanningResponse[MaterialGroupedPlanningResponseType]+ )

    Description: ListOfMaterialGroupedPlanningResponseType contains the line level detail information for the Planning schedule. The detail is grouped by the material. This is one of two options for grouping forecasting detail in the PlanningScheduleResponse document.

    Elements:

    • MaterialGroupedPlanningResponse - contains all the schedule-line-level data grouped by the material/product for the PlanningSchedule and the PlanningScheduleResponse document.

[^]Code Fragment

    <xsd:complexType name="ListOfMaterialGroupedPlanningResponseType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="MaterialGroupedPlanningResponse" type="MaterialGroupedPlanningResponseType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfMaterialGroupedShippingDetailType

ListOfMaterialGroupedShippingDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( MaterialGroupedShippingDetail[MaterialGroupedShippingDetailType]+ )

    Description: ListOfMaterialGroupedShippingDetailType contains the line level detail information for the ShippingSchedule document. The detail is grouped by the material. This is one of two options for grouping shipping detail.

    Elements:

    • MaterialGroupedShippingDetail - contains all the schedule-line-level data grouped by the material/product.

[^]Code Fragment

    <xsd:complexType name="ListOfMaterialGroupedShippingDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="MaterialGroupedShippingDetail" type="MaterialGroupedShippingDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfMaterialGroupedShippingResponseType

ListOfMaterialGroupedShippingResponseType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( MaterialGroupedShippingResponse[MaterialGroupedShippingResponseType]+ )

    Description: ListOfMaterialGroupedShippingResponseType contains the line level detail information for the planning schedule. The detail is grouped by the material. This is one of two options for grouping forecasting detail in the ShippingScheduleResponse document.

    Elements:

    • MaterialGroupedShippingResponse - contains all the schedule-line-level data grouped by the material/product for the ShippingSchedule and the ShippingScheduleResponse document.

[^]Code Fragment

    <xsd:complexType name="ListOfMaterialGroupedShippingResponseType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="MaterialGroupedShippingResponse" type="MaterialGroupedShippingResponseType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfScheduleDetailType

ListOfScheduleDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ScheduleDetail[ScheduleDetailType]+ )

    Description: ListOfScheduleDetailType is the detailed schedule information for the materials. Includes dates and quantity.

    Elements:

    • ScheduleDetail - provides the commitment level, dates, and quantity for the shipment.

[^]Code Fragment

    <xsd:complexType name="ListOfScheduleDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="ScheduleDetail" type="ScheduleDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfShipScheduleDetailType

ListOfShipScheduleDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ShipScheduleDetail[ShipScheduleDetailType]+ )

    Description: ListOfShipScheduleDetailType is the detailed schedule information for the materials. Includes dates and quantity.

    Elements:

    • ShipScheduleDetail - provides the commitment level, dates, and quantity for the shipment.

[^]Code Fragment

    <xsd:complexType name="ListOfShipScheduleDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="ShipScheduleDetail" type="ShipScheduleDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: LocationGroupedPlanningDetailType

LocationGroupedPlanningDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( Location[core:LocationType] , ListOfContact[core:ListOfContactType]? , ListOfLocationPlanningItemDetail[ListOfLocationPlanningItemDetailType] )

    Description: LocationGroupedPlanningDetailType contains all the schedule-line-level data grouped by the delivery location.

    Elements:

    • Location - contains details relevant to describing the location. This includes name, address, and contact information. Note: each delivery point can have multiple materials planned for the location. In addition, each material at each location can contain multiple scheduled delivery dates and quantities.
    • ListOfContact - lists the information on one or more contacts by the parties involved.
    • ListOfLocationPlanningItemDetail - is a list of item details organized by location.

[^]Code Fragment

    <xsd:complexType name="LocationGroupedPlanningDetailType">
    <xsd:sequence>
        <xsd:element name="Location" type="core:LocationType">
        <xsd:element minOccurs="0" name="ListOfContact" type="core:ListOfContactType">
        <xsd:element name="ListOfLocationPlanningItemDetail" type="ListOfLocationPlanningItemDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: LocationGroupedPlanningResponseType

LocationGroupedPlanningResponseType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( DetailResponseCoded[core:DetailResponseCodeType] , DetailResponseCodedOther[xsd:string]? , LocationGroupedPlanningDetail[LocationGroupedPlanningDetailType] , LineItemNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfAttachment[core:ListOfAttachmentType]? )

    Description: LocationGroupedPlanningResponseType contains all the schedule-line-level data grouped by the delivery location.

    Elements:

    • DetailResponseCoded - is a code to identify the response for the line item detail.
    • DetailResponseCodedOther - is used to provide a non-standard DetailResponseCode. This element is mandatory if the value of DetailResponseCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • LocationGroupedPlanningDetail - is used to echo back the detail that is being responded to, with any changes made by the responding party.
    • LineItemNote - describes any free-form text pertinent to the line item described by the PlanningScheduleResponse. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfAttachment - holds a list of attachments to a document that contain information relating to the document.

[^]Code Fragment

    <xsd:complexType name="LocationGroupedPlanningResponseType">
    <xsd:sequence>
        <xsd:element name="DetailResponseCoded" type="core:DetailResponseCodeType">
        <xsd:element minOccurs="0" name="DetailResponseCodedOther" type="xsd:string">
        <xsd:element name="LocationGroupedPlanningDetail" type="LocationGroupedPlanningDetailType">
        <xsd:element minOccurs="0" name="LineItemNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: LocationGroupedShippingDetailType

LocationGroupedShippingDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( Location[core:LocationType] , ListOfContact[core:ListOfContactType]? , ListOfLocationShippingItemDetail[ListOfLocationShippingItemDetailType] )

    Description: LocationGroupedShippingDetailType contains all the schedule-line-level data grouped by the delivery location.

    Elements:

    • Location - contains details relevant to describing the location. This includes name, address, and contact information.
    • ListOfContact - lists the information on one or more contacts by the parties involved.
    • ListOfLocationShippingItemDetail - is a list of item details organized by location.

[^]Code Fragment

    <xsd:complexType name="LocationGroupedShippingDetailType">
    <xsd:sequence>
        <xsd:element name="Location" type="core:LocationType">
        <xsd:element minOccurs="0" name="ListOfContact" type="core:ListOfContactType">
        <xsd:element name="ListOfLocationShippingItemDetail" type="ListOfLocationShippingItemDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: LocationGroupedShippingResponseType

LocationGroupedShippingResponseType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( DetailResponseCoded[core:DetailResponseCodeType] , DetailResponseCodedOther[xsd:string]? , LocationGroupedShippingDetail[LocationGroupedShippingDetailType] , LineItemNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfAttachment[core:ListOfAttachmentType]? )

    Description: LocationGroupedShippingResponseType contains all the schedule-line-level data grouped by the delivery location.

    Elements:

    • DetailResponseCoded - is a code to identify the response for the line item detail.
    • DetailResponseCodedOther - is used to provide a non-standard DetailResponseCode. This element is mandatory if the value of DetailResponseCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • LocationGroupedShippingDetail - is used to echo back the detail that is being responded to, with any changes made by the responding party.
    • LineItemNote - is a note containing general information for the ShippingScheduleResponse line item.
    • ListOfStructuredNote - is a structured note which contains an identifier and URL.
    • ListOfAttachment - holds a list of attachments to a document that contain information relating to the document.

[^]Code Fragment

    <xsd:complexType name="LocationGroupedShippingResponseType">
    <xsd:sequence>
        <xsd:element name="DetailResponseCoded" type="core:DetailResponseCodeType">
        <xsd:element minOccurs="0" name="DetailResponseCodedOther" type="xsd:string">
        <xsd:element name="LocationGroupedShippingDetail" type="LocationGroupedShippingDetailType">
        <xsd:element minOccurs="0" name="LineItemNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: LocationPlanningItemDetailType

LocationPlanningItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( BasePlanningDetail[ScheduleBaseItemDetailType] , ListOfScheduleDetail[ListOfScheduleDetailType] , LineItemNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? )

    Description: LocationPlanningItemDetailType is a collection of items that are grouped by location for planning purposes.

    Elements:

    • BasePlanningDetail - extends BaseItemDetail to include item schedule reference, release frequency and item quantities.
    • ListOfScheduleDetail - is the detailed schedule information for the materials. Includes dates and quantity.
    • LineItemNote - describes any free-form text pertinent to the line item described by the PlanningSchedule. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.

[^]Code Fragment

    <xsd:complexType name="LocationPlanningItemDetailType">
    <xsd:sequence>
        <xsd:element name="BasePlanningDetail" type="ScheduleBaseItemDetailType">
        <xsd:element name="ListOfScheduleDetail" type="ListOfScheduleDetailType">
        <xsd:element minOccurs="0" name="LineItemNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: LocationScheduleType

LocationScheduleType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( Location[core:LocationType]? , ListOfContact[core:ListOfContactType]? , ListOfScheduleDetail[ListOfScheduleDetailType] )

    Description: LocationScheduleType is a schedule for the material based on location.

    Elements:

    • Location - contains details relevant to describing the location. This includes name, address, and contact information.
    • ListOfContact - lists the information on one or more contacts by the parties involved.
    • ListOfScheduleDetail - is the detailed schedule information for the materials. Includes dates and quantity.

[^]Code Fragment

    <xsd:complexType name="LocationScheduleType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="Location" type="core:LocationType">
        <xsd:element minOccurs="0" name="ListOfContact" type="core:ListOfContactType">
        <xsd:element name="ListOfScheduleDetail" type="ListOfScheduleDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: LocationShippingItemDetailType

LocationShippingItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( BaseShippingDetail[BaseShippingDetailType] , ListOfShipScheduleDetail[ListOfShipScheduleDetailType] , LineItemNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? )

    Description: LocationShippingItemDetailType is a collection of items that are grouped by location for shipping purposes.

    Elements:

    • BaseShippingDetail - extends BaseItemDetail to include item schedule reference, release frequency and item quantities.
    • ListOfShipScheduleDetail - is the detailed schedule information for the materials. Includes dates and quantity.
    • LineItemNote - contains any free-form text pertinent to the entire ShippingSchedule. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - is a structured note which contains an identifier and URL.

[^]Code Fragment

    <xsd:complexType name="LocationShippingItemDetailType">
    <xsd:sequence>
        <xsd:element name="BaseShippingDetail" type="BaseShippingDetailType">
        <xsd:element name="ListOfShipScheduleDetail" type="ListOfShipScheduleDetailType">
        <xsd:element minOccurs="0" name="LineItemNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: LocationShipScheduleType

LocationShipScheduleType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( Location[core:LocationType]? , ListOfContact[core:ListOfContactType]? , ListOfShipScheduleDetail[ListOfShipScheduleDetailType] )

    Description: LocationShipScheduleType is a schedule for the material based on location.

    Elements:

    • Location - contains details relevant to describing the location. This includes name, address, and contact information.
    • ListOfContact - lists the information on one or more contacts by the parties involved.
    • ListOfShipScheduleDetail - is the detailed schedule information for the materials. Includes dates and quantity.

[^]Code Fragment

    <xsd:complexType name="LocationShipScheduleType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="Location" type="core:LocationType">
        <xsd:element minOccurs="0" name="ListOfContact" type="core:ListOfContactType">
        <xsd:element name="ListOfShipScheduleDetail" type="ListOfShipScheduleDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: MaterialGroupedPlanningDetailType

MaterialGroupedPlanningDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( BasePlanningDetail[ScheduleBaseItemDetailType] , ListOfLocationSchedule[ListOfLocationScheduleType] , LineItemNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? )

    Description: MaterialGroupedPlanningDetailType contains all the schedule-line-level data grouped by the material/product.

    Elements:

    • BasePlanningDetail - extends BaseItemDetail to include item schedule reference, release frequency and item quantities.
    • ListOfLocationSchedule - is the scheduling information by location for the material identified by the line item.
    • LineItemNote - describes any free-form text pertinent to the line item described by the PlanningSchedule. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.

[^]Code Fragment

    <xsd:complexType name="MaterialGroupedPlanningDetailType">
    <xsd:sequence>
        <xsd:element name="BasePlanningDetail" type="ScheduleBaseItemDetailType">
        <xsd:element name="ListOfLocationSchedule" type="ListOfLocationScheduleType">
        <xsd:element minOccurs="0" name="LineItemNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: MaterialGroupedPlanningResponseType

MaterialGroupedPlanningResponseType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( DetailResponseCoded[core:DetailResponseCodeType] , DetailResponseCodedOther[xsd:string]? , MaterialGroupedPlanningDetail[MaterialGroupedPlanningDetailType] , LineItemNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfAttachment[core:ListOfAttachmentType]? )

    Description: MaterialGroupedPlanningResponseType contains all the schedule-line-level data grouped by the material/product for the PlanningSchedule and the PlanningScheduleResponse document.

    Elements:

    • DetailResponseCoded - is a code to identify the response for the line item detail.
    • DetailResponseCodedOther - is used to provide a non-standard DetailResponseCode. This element is mandatory if the value of DetailResponseCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • MaterialGroupedPlanningDetail - is used to echo back the detail that is being responded to, with any changes made by the responding party.
    • LineItemNote - describes any free-form text pertinent to the line item described by the PlanningScheduleResponse. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfAttachment - holds a list of attachments to a document that contain information relating to the document.

[^]Code Fragment

    <xsd:complexType name="MaterialGroupedPlanningResponseType">
    <xsd:sequence>
        <xsd:element name="DetailResponseCoded" type="core:DetailResponseCodeType">
        <xsd:element minOccurs="0" name="DetailResponseCodedOther" type="xsd:string">
        <xsd:element name="MaterialGroupedPlanningDetail" type="MaterialGroupedPlanningDetailType">
        <xsd:element minOccurs="0" name="LineItemNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: MaterialGroupedShippingDetailType

MaterialGroupedShippingDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( BaseShippingDetail[BaseShippingDetailType] , ListOfLocationShipSchedule[ListOfLocationShipScheduleType] , LineItemNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? )

    Description: MaterialGroupedShippingDetailType contains all the schedule-line-level data grouped by the material/product.

    Elements:

    • BaseShippingDetail - is the base item detail for the ShippingSchedule. It extends BaseItemDetail to include release frequency and packaging information.
    • ListOfLocationShipSchedule - is the scheduling information by location for the material identified by the line item.
    • LineItemNote - contains any free-form text pertinent to the entire ShippingSchedule. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information. .
    • ListOfStructuredNote - is a structured note which contains an identifier and URL.

[^]Code Fragment

    <xsd:complexType name="MaterialGroupedShippingDetailType">
    <xsd:sequence>
        <xsd:element name="BaseShippingDetail" type="BaseShippingDetailType">
        <xsd:element name="ListOfLocationShipSchedule" type="ListOfLocationShipScheduleType">
        <xsd:element minOccurs="0" name="LineItemNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: MaterialGroupedShippingResponseType

MaterialGroupedShippingResponseType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( DetailResponseCoded[core:DetailResponseCodeType] , DetailResponseCodedOther[xsd:string]? , MaterialGroupedShippingDetail[MaterialGroupedShippingDetailType] , LineItemNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfAttachment[core:ListOfAttachmentType]? )

    Description: MaterialGroupedShippingResponseType contains all the schedule-line-level data grouped by the material/product for the ShippingSchedule and the ShippingScheduleResponse document.

    Elements:

    • DetailResponseCoded - is a code to identify the response for the line item detail.
    • DetailResponseCodedOther - is used to provide a non-standard DetailResponseCode. This element is mandatory if the value of DetailResponseCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • MaterialGroupedShippingDetail - is used to echo back the detail that is being responded to, with any changes made by the responding party.
    • LineItemNote - is a note containing general information for the ShippingScheduleResponse line item.
    • ListOfStructuredNote - is a structured note which contains an identifier and URL.
    • ListOfAttachment - holds a list of attachments to a document that contain information relating to the document.

[^]Code Fragment

    <xsd:complexType name="MaterialGroupedShippingResponseType">
    <xsd:sequence>
        <xsd:element name="DetailResponseCoded" type="core:DetailResponseCodeType">
        <xsd:element minOccurs="0" name="DetailResponseCodedOther" type="xsd:string">
        <xsd:element name="MaterialGroupedShippingDetail" type="MaterialGroupedShippingDetailType">
        <xsd:element minOccurs="0" name="LineItemNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PlanningScheduleHeaderType

PlanningScheduleHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ScheduleID[xsd:string] , ScheduleIssueDate[xsd:dateTime] , ScheduleReferences[ScheduleReferencesType]? , ReleaseNumber[xsd:string]? , Purpose[core:PurposeType]? , RequestedResponse[core:RequestedResponseType]? , ScheduleTypeCoded[ScheduleTypeCodeType] , ScheduleTypeCodedOther[xsd:string]? , QuantityQualifierCoded[core:QuantityQualifierCodeType]? , QuantityQualifierCodedOther[xsd:string]? , ShippingDates[ShippingDatesType]? , ScheduleParty[SchedulePartyType] , Language[core:LanguageType] , PlanningScheduleHeaderNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfAttachment[core:ListOfAttachmentType]? )

    Description: PlanningScheduleHeaderType contains the header information of the Planning Schedule.

    Elements:

    • ScheduleID - is the unique number that uniquely identifies the PlanningSchedule, typically according to the system that generated the PlanningSchedule.
    • ScheduleIssueDate - is a digital time stamp by the application which created the PlanningSchedule document.
    • ScheduleReferences - is used to identify references to other documents and release information for the PlanningSchedule.
    • ReleaseNumber - identifies the specific iteration of the release against a given contract, purchase order, etc.
    • Purpose - indicates the purpose of the PlanningSchedule document.
    • RequestedResponse - specifies the type of acknowledgment requested by the buyer from the seller.
    • ScheduleTypeCoded - identifies the type of schedule when defining shipping or delivery time in a schedule or forecast.
    • ScheduleTypeCodedOther - is used to provide a non-standard ScheduleTypeCode. This element is mandatory if the value of ScheduleTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • QuantityQualifierCoded - is the purpose of a quantity using a standard codelist.
    • QuantityQualifierCodedOther - is used to provide a non-standard QuantityQualifierCode. This element is mandatory if the value of QuantityQualifierCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • ShippingDates -
    • ScheduleParty - contains information on the parties to the PlanningSchedule, including unique ID's and address information.
    • Language - identifies the language of the PlanningSchedule
    • PlanningScheduleHeaderNote - contains any free-form text pertinent to the entire PlanningSchedule. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - is a note that allows for an ID, URL, and a free-form note field.
    • ListOfAttachment - contains a list of attachments applicable to the entire PlanningSchedule. The information is not specific to a particular line item or package, unless specifically noted.

[^]Code Fragment

    <xsd:complexType name="PlanningScheduleHeaderType">
    <xsd:sequence>
        <xsd:element name="ScheduleID" type="xsd:string">
        <xsd:element name="ScheduleIssueDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ScheduleReferences" type="ScheduleReferencesType">
        <xsd:element minOccurs="0" name="ReleaseNumber" type="xsd:string">
        <xsd:element minOccurs="0" name="Purpose" type="core:PurposeType">
        <xsd:element minOccurs="0" name="RequestedResponse" type="core:RequestedResponseType">
        <xsd:element name="ScheduleTypeCoded" type="ScheduleTypeCodeType">
        <xsd:element minOccurs="0" name="ScheduleTypeCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="QuantityQualifierCoded" type="core:QuantityQualifierCodeType">
        <xsd:element minOccurs="0" name="QuantityQualifierCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="ShippingDates" type="ShippingDatesType">
        <xsd:element name="ScheduleParty" type="SchedulePartyType">
        <xsd:element name="Language" type="core:LanguageType">
        <xsd:element minOccurs="0" name="PlanningScheduleHeaderNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PlanningScheduleResponseHeaderType

PlanningScheduleResponseHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ScheduleResponseID[xsd:string] , ScheduleResponseIssueDate[xsd:dateTime] , PlanningScheduleReference[core:ReferenceType] , ListOfReferenceCoded[core:ListOfReferenceCodedType]? , BuyerParty[core:PartyType] , SellerParty[core:PartyType] , Purpose[core:PurposeType]? , ResponseType[core:ResponseTypeType] , Language[core:LanguageType] , PlanningScheduleHeader[PlanningScheduleHeaderType]? , PlanningScheduleResponseHeaderNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfAttachment[core:ListOfAttachmentType]? )

    Description: PlanningScheduleResponseHeaderType contains the header information of the PlanningScheduleResponse.

    Elements:

    • ScheduleResponseID - contains a reference number to uniquely identify the PlanningScheduleResponse, typically according to the system that generated the PlanningScheduleResponse.
    • ScheduleResponseIssueDate - holds a digital time stamp provided by the application that created the PlanningScheduleResponse document.
    • PlanningScheduleReference - is a reference to the original PlanningSchedule document.
    • ListOfReferenceCoded - contains one or more elements containing information that can be used to find further information elsewhere that are not explicitly stated in another element.
    • BuyerParty - is the buyer of the goods or services.
    • SellerParty - is the seller of the goods or services.
    • Purpose - is used to communicate the purpose of the document.
    • ResponseType - identifies the type or response intended by the PlanningScheduleResponse document.
    • Language - identifies the language of the PlanningScheduleResponse
    • PlanningScheduleHeader - holds the original PlanningScheduleHeader with any changes made by the responding party. Note: If there are changes to the header, the entire header section should be repeated with the changes.
    • PlanningScheduleResponseHeaderNote - contains any free-form text pertinent to the entire PlanningScheduleResponseHeader. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfAttachment - contains a list of attachments applicable to the document.

[^]Code Fragment

    <xsd:complexType name="PlanningScheduleResponseHeaderType">
    <xsd:sequence>
        <xsd:element name="ScheduleResponseID" type="xsd:string">
        <xsd:element name="ScheduleResponseIssueDate" type="xsd:dateTime">
        <xsd:element name="PlanningScheduleReference" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="ListOfReferenceCoded" type="core:ListOfReferenceCodedType">
        <xsd:element name="BuyerParty" type="core:PartyType">
        <xsd:element name="SellerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="Purpose" type="core:PurposeType">
        <xsd:element name="ResponseType" type="core:ResponseTypeType">
        <xsd:element name="Language" type="core:LanguageType">
        <xsd:element minOccurs="0" name="PlanningScheduleHeader" type="PlanningScheduleHeaderType">
        <xsd:element minOccurs="0" name="PlanningScheduleResponseHeaderNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PlanningScheduleResponseType

PlanningScheduleResponseType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PlanningScheduleResponseHeader[PlanningScheduleResponseHeaderType] , ( ListOfLocationGroupedPlanningResponse[ListOfLocationGroupedPlanningResponseType] | ListOfMaterialGroupedPlanningResponse[ListOfMaterialGroupedPlanningResponseType] ) , PlanningScheduleResponseSummary[PlanningScheduleSummaryType]? )

    Description: PlanningScheduleResponseType is the response to a previously sent PlanningSchedule. The intent of this document is for sellers to provide changes or corrections to the original documents. A seller can reply back with changes to a schedule due to factors such as backorder, insufficient parts, cannot meet demand, incorrect information, etc.

    Elements:

    • PlanningScheduleResponseHeader - contains all PlanningScheduleResponse header-level information. This element occurs once within the document.
    • ListOfLocationGroupedPlanningResponse - contains the line level detail information for the PlanningSchedule. The detail is grouped by the delivery location. This is one of two options for grouping forecasting detail in the PlanningScheduleResponse document.
    • ListOfMaterialGroupedPlanningResponse - contains the line level detail information for the planning schedule. The detail is grouped by the material. This is one of two options for grouping forecasting detail in the PlanningScheduleResponse document.
    • PlanningScheduleResponseSummary - contains the summary information of the PlanningScheduleResponse, typically totals of numerical fields.

[^]Code Fragment

    <xsd:complexType name="PlanningScheduleResponseType">
    <xsd:sequence>
        <xsd:element name="PlanningScheduleResponseHeader" type="PlanningScheduleResponseHeaderType">
        <xsd:choice>
            <xsd:element name="ListOfLocationGroupedPlanningResponse" type="ListOfLocationGroupedPlanningResponseType">
            <xsd:element name="ListOfMaterialGroupedPlanningResponse" type="ListOfMaterialGroupedPlanningResponseType">
        </xsd:choice>
        <xsd:element minOccurs="0" name="PlanningScheduleResponseSummary" type="PlanningScheduleSummaryType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PlanningScheduleSummaryType

PlanningScheduleSummaryType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( TotalNumberOfLineItems[xsd:int] )

    Description: PlanningScheduleSummaryType contains the summary information of the PlanningSchedule, typically totals of numerical fields.

    Elements:

    • TotalNumberOfLineItems - is the total number of line items in the PlanningSchedule.

[^]Code Fragment

    <xsd:complexType name="PlanningScheduleSummaryType">
    <xsd:sequence>
        <xsd:element name="TotalNumberOfLineItems" type="xsd:int">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PlanningScheduleType

PlanningScheduleType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PlanningScheduleHeader[PlanningScheduleHeaderType] , ( ListOfLocationGroupedPlanningDetail[ListOfLocationGroupedPlanningDetailType] | ListOfMaterialGroupedPlanningDetail[ListOfMaterialGroupedPlanningDetailType] ) , PlanningScheduleSummary[PlanningScheduleSummaryType]? , DigitalSignature[dgs:SignatureType]? )

    Description: PlanningScheduleType is sent from a party who is planning the use or consumption of products (buyer) to a party who has to plan for the supply of the products (seller). The document consists of the notification of a forecast to be sent from the buyer to the seller. The document outlines the requirements regarding the details for short term delivery and/or medium to long scheduling for products. The scheduling can be used to authorize manufacturing and/or the provision of materials. This is based on the terms and conditions defined in a purchasing agreement commonly outlined by a contract or order. The Planning Schedule defined here will not be designed to support release capability. This document will serve solely as a materials requirement schedule. All schedule requirements relating to shipping and release authorization will be handled by the ShippingSchedule document. A response to Planning Schedule can be made using the PlanningScheduleResponse document. Use of this document is determined by trading partners.

    Elements:

    • PlanningScheduleHeader - contains the header information of the Planning Schedule.
    • ListOfLocationGroupedPlanningDetail - contains the line level detail information for the PlanningSchedule. The detail is grouped by the delivery location. This is one of two options for grouping forecasting detail in the PlanningSchedule.
    • ListOfMaterialGroupedPlanningDetail - contains the line level detail information for the PlanningSchedule. The detail is grouped by the material. This is one of two options for grouping forecasting detail in the PlanningSchedule.
    • PlanningScheduleSummary - contains the summary information of the PlanningSchedule, typically totals of numerical fields.
    • DigitalSignature - contains a digital signature for the document.

[^]Code Fragment

    <xsd:complexType name="PlanningScheduleType">
    <xsd:sequence>
        <xsd:element name="PlanningScheduleHeader" type="PlanningScheduleHeaderType">
        <xsd:choice>
            <xsd:element name="ListOfLocationGroupedPlanningDetail" type="ListOfLocationGroupedPlanningDetailType">
            <xsd:element name="ListOfMaterialGroupedPlanningDetail" type="ListOfMaterialGroupedPlanningDetailType">
        </xsd:choice>
        <xsd:element minOccurs="0" name="PlanningScheduleSummary" type="PlanningScheduleSummaryType">
        <xsd:element minOccurs="0" name="DigitalSignature" type="dgs:SignatureType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: ResourceAuthorizationCodeType

ResourceAuthorizationCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:
    This code identifies the resource authorization for the schedule quantity. This code list is derived from X12 672 (Resource authorization code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • Finished
    • QuantityBasedPricingGroups
    • Labor
    • LaborAndMaterial
    • Material
    • CumulativeQuantityRequiredPriortoFirstSchedulePeriod
    • PreviouslyReleasedRequirements

[^]Code Fragment

    <xsd:simpleType name="ResourceAuthorizationCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Finished">
        <xsd:enumeration value="QuantityBasedPricingGroups">
        <xsd:enumeration value="Labor">
        <xsd:enumeration value="LaborAndMaterial">
        <xsd:enumeration value="Material">
        <xsd:enumeration value="CumulativeQuantityRequiredPriortoFirstSchedulePeriod">
        <xsd:enumeration value="PreviouslyReleasedRequirements">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: ScheduleBaseItemDetailType

ScheduleBaseItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( LineItemNum[core:LineItemNumType] , LineItemType[core:LineItemTypeType]? , ParentItemNumber[core:LineItemNumberReferenceType]? , ItemIdentifiers[core:ItemIdentifiersType]? , ListOfDimension[core:ListOfDimensionType]? , TotalQuantity[core:QuantityType] , ListOfQuantityCoded[core:ListOfQuantityCodedType]? , ItemScheduleReference[ScheduleReferencesType]? , RecordKeepingYear[xsd:string]? , ForecastFrequencyCoded[ForecastFrequencyCodeType] , ForecastFrequencyCodedOther[xsd:string]? , ItemReleaseStatusCoded[ItemReleaseStatusCodeType]? , ItemReleaseStatusCodedOther[xsd:string]? , CountryOfOrigin[core:CountryType]? , CountryOfDestination[core:CountryType]? , ListOfPartyCoded[core:ListOfPartyCodedType]? , HazardousMaterials[core:HazardousType]? )

    Description: ScheduleBaseItemDetailType extends BaseItemDetail to include item schedule reference, release frequency and item quantities.

    Elements:

    • LineItemNum - is a set of numbers uniquely identifying the line item for the number. In the case where the seller's system splits a line item number into 2 line items, the buyer item number will remain the same for both line items, but the seller item number will be different.
    • LineItemType - identifies whether the line item is a component group (consists of other line items), a typical line item, or a textual line item.
    • ParentItemNumber - identifies the line item that groups this and other line items. This is done using LineItemNumberReference, which specifies the number of the parent line item and whether this reference is the Buyer or Seller's number. LineItemNumberReference is a string content model of datatype integer that contains an attribute to specify whether the ParentItemNumber is a Seller or Buyer number, with the default being Buyer. This value references the parent item represented a group.
    • ItemIdentifiers - details all of the part numbers assigned to the item.
    • ListOfDimension - lists one or more quantitative measurements of the item.
    • TotalQuantity - contains the total amount of the line item pertaining to the document.
    • ListOfQuantityCoded - specifies any other quantities not explicitly stated.
    • ItemScheduleReference - identifies reference and possible release information for the planning schedule. The assumption is made that there will be only one reference document (i.e., contract, blanket order, etc) for the PlanningSchedule. If additional references exist, then these will be given here at the line item level. The reference value here will override the reference value given at the header level.
    • RecordKeepingYear - is the record keeping or model year for the buyer.
    • ForecastFrequencyCoded - identifies the release frequency of the line item.
    • ForecastFrequencyCodedOther - is used to provide a non-standard ForecastFrequencyCode. This element is mandatory if the value of ForecastFrequencyCode is 'Other'. These codes should not contain white space unless absolutely necessary.
    • ItemReleaseStatusCoded - indicates the status of the part being ordered or forecast with respect to this material release or planning document.
    • ItemReleaseStatusCodedOther - is used to provide a non-standard ItemReleaseStatusCode. This element is mandatory if the value of ItemReleaseStatusCode is 'Other'. These codes should not contain white space unless absolutely necessary.
    • CountryOfOrigin - specifies the country code for the country in which the line item was manufactured.
    • CountryOfDestination - specifies the country code for the country in which the delivery is finally received.
    • ListOfPartyCoded - specifies any other parties associated with the line item that are not already explicitly stated.
    • HazardousMaterials - contains the hazardous information for the line item.

[^]Code Fragment

    <xsd:complexType name="ScheduleBaseItemDetailType">
    <xsd:sequence>
        <xsd:element name="LineItemNum" type="core:LineItemNumType">
        <xsd:element minOccurs="0" name="LineItemType" type="core:LineItemTypeType">
        <xsd:element minOccurs="0" name="ParentItemNumber" type="core:LineItemNumberReferenceType">
        <xsd:element minOccurs="0" name="ItemIdentifiers" type="core:ItemIdentifiersType">
        <xsd:element minOccurs="0" name="ListOfDimension" type="core:ListOfDimensionType">
        <xsd:element name="TotalQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="ListOfQuantityCoded" type="core:ListOfQuantityCodedType">
        <xsd:element minOccurs="0" name="ItemScheduleReference" type="ScheduleReferencesType">
        <xsd:element minOccurs="0" name="RecordKeepingYear" type="xsd:string">
        <xsd:element name="ForecastFrequencyCoded" type="ForecastFrequencyCodeType">
        <xsd:element minOccurs="0" name="ForecastFrequencyCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="ItemReleaseStatusCoded" type="ItemReleaseStatusCodeType">
        <xsd:element minOccurs="0" name="ItemReleaseStatusCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="CountryOfOrigin" type="core:CountryType">
        <xsd:element minOccurs="0" name="CountryOfDestination" type="core:CountryType">
        <xsd:element minOccurs="0" name="ListOfPartyCoded" type="core:ListOfPartyCodedType">
        <xsd:element minOccurs="0" name="HazardousMaterials" type="core:HazardousType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ScheduleDetailType

ScheduleDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( CommitmentLevelCoded[CommitmentLevelCodeType] , CommitmentLevelCodedOther[xsd:string]? , ScheduleDates[core:ListOfDateCodedType] , ScheduleQuantities[core:ListOfQuantityCodedType] , ItemResourceAuthorization[ItemResourceAuthorizationType]? , ScheduleNote[xsd:string]? )

    Description: ScheduleDetailType provides the commitment level, dates, and quantity for the shipment.

    Elements:

    • CommitmentLevelCoded - identifies the commitment level for the forecast.
    • CommitmentLevelCodedOther - is used to provide a non-standard CommitmentLevelCode. This element is mandatory if the value of CommitmentLevelCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • ScheduleDates - is a list of forecasted dates and times corresponding to the commitment level for the given material and location.
    • ScheduleQuantities - is the quantity of the line item for the scheduled date.
    • ItemResourceAuthorization - is used to specify resource authorization in the schedule.
    • ScheduleNote - contains any free-form text pertinent to the PlanningSchedule. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.

[^]Code Fragment

    <xsd:complexType name="ScheduleDetailType">
    <xsd:sequence>
        <xsd:element name="CommitmentLevelCoded" type="CommitmentLevelCodeType">
        <xsd:element minOccurs="0" name="CommitmentLevelCodedOther" type="xsd:string">
        <xsd:element name="ScheduleDates" type="core:ListOfDateCodedType">
        <xsd:element name="ScheduleQuantities" type="core:ListOfQuantityCodedType">
        <xsd:element minOccurs="0" name="ItemResourceAuthorization" type="ItemResourceAuthorizationType">
        <xsd:element minOccurs="0" name="ScheduleNote" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: SchedulePartyType

SchedulePartyType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( BuyerParty[core:PartyType] , SellerParty[core:PartyType] , ShipFromParty[core:PartyType] , ShipToParty[core:PartyType] , BillToParty[core:PartyType]? , MaterialIssuerParty[core:PartyType]? , ListOfPartyCoded[core:ListOfPartyCodedType]? )

    Description: SchedulePartyType contains information on the parties to the PlanningSchedule, including unique ID's and address information.

    Elements:

    • BuyerParty - is the buyer of the goods or services.
    • SellerParty - is the seller of the goods or services.
    • ShipFromParty - is the party that is planning the good or services.
    • ShipToParty - is the party that is receiving the goods or services.
    • BillToParty - is the party that is responsible for payment of the goods or services.
    • MaterialIssuerParty - is the party issuing the material release on behalf of the ship-to destination.
    • ListOfPartyCoded - contains information relevant to describing parties other than the source target parties which are relevant to the time series data.

[^]Code Fragment

    <xsd:complexType name="SchedulePartyType">
    <xsd:sequence>
        <xsd:element name="BuyerParty" type="core:PartyType">
        <xsd:element name="SellerParty" type="core:PartyType">
        <xsd:element name="ShipFromParty" type="core:PartyType">
        <xsd:element name="ShipToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="BillToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="MaterialIssuerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ListOfPartyCoded" type="core:ListOfPartyCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ScheduleReferencesType

ScheduleReferencesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ContractReferences[core:ListOfContractType]? , PurchaseOrderReference[core:PurchaseOrderReferenceType]? , OtherScheduleReferences[core:ListOfReferenceCodedType]? )

    Description: ScheduleReferencesType is used to identify references to other documents and release information for the PlanningSchedule.

    Elements:

    • ContractReferences - is an element that holds the contract number and contract type for referencing a contract.
    • PurchaseOrderReference - references the Order that the PlanningSchedule references.
    • OtherScheduleReferences -

[^]Code Fragment

    <xsd:complexType name="ScheduleReferencesType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ContractReferences" type="core:ListOfContractType">
        <xsd:element minOccurs="0" name="PurchaseOrderReference" type="core:PurchaseOrderReferenceType">
        <xsd:element minOccurs="0" name="OtherScheduleReferences" type="core:ListOfReferenceCodedType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: ScheduleTypeCodeType

ScheduleTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • AuthorizedDeliveryBased
    • AuthorizedShipmentBased
    • CustomerProduction-Consumption-Based
    • DeliveryBased
    • BuyerProductionSequenceSchedule
    • KanbanSignal
    • PlannedDeliveryBased
    • PlannedRequirementBased
    • PlannedShipmentBased
    • ShipmentBased

[^]Code Fragment

    <xsd:simpleType name="ScheduleTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="AuthorizedDeliveryBased">
        <xsd:enumeration value="AuthorizedShipmentBased">
        <xsd:enumeration value="CustomerProduction-Consumption-Based">
        <xsd:enumeration value="DeliveryBased">
        <xsd:enumeration value="BuyerProductionSequenceSchedule">
        <xsd:enumeration value="KanbanSignal">
        <xsd:enumeration value="PlannedDeliveryBased">
        <xsd:enumeration value="PlannedRequirementBased">
        <xsd:enumeration value="PlannedShipmentBased">
        <xsd:enumeration value="ShipmentBased">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: ShippingDatesType

ShippingDatesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ManufacturingRequiredDate[xsd:dateTime]? , PORequiredDate[xsd:dateTime]? , VendorPromiseDate[xsd:dateTime]? , ValidityDates[core:ValidityDatesType]? , ListOfDateCoded[core:ListOfDateCodedType]? )

    Description: ShippingDatesType indicates the pertinent dates for the ASN. These dates are global and apply to the entire ASN, except where overridden by dates provided at the line item or package level

    Elements:

    • ManufacturingRequiredDate - .
    • PORequiredDate -
    • VendorPromiseDate -
    • ValidityDates - is used to specify a start and end date of a period which the element in which they are used is valid.
    • ListOfDateCoded - is used to communicate any other dates not explicitly stated by another element.

[^]Code Fragment

    <xsd:complexType name="ShippingDatesType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ManufacturingRequiredDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="PORequiredDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="VendorPromiseDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ValidityDates" type="core:ValidityDatesType">
        <xsd:element minOccurs="0" name="ListOfDateCoded" type="core:ListOfDateCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ShippingReferencesType

ShippingReferencesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ShipmentIdentifier[core:ReferenceType]? , PackingListNumber[core:ReferenceType]? , ContractNumber[core:ReferenceType]? , BillOfLadingNumber[core:ReferenceType]? , AirWaybillNumber[core:ReferenceType]? , ImportLicenceNumber[core:ReferenceType]? , ExportLicenceNumber[core:ReferenceType]? , LetterOfCreditNumber[core:ReferenceType]? , URL[xsd:anyURI]? , TrackingInformation[TrackingInformationType]? , ListOfCarrierReference[ListOfCarrierReferenceType]? , OtherShippingReferences[core:ListOfReferenceCodedType]? )

    Description: ShippingReferencesType defines the references for the ASN.

    Elements:

    • ShipmentIdentifier - contains the shipper's unique identification number for identifying the shipment.
    • PackingListNumber - contains the number of the packing list for this ASN.
    • ContractNumber - contains the number of the contract.
    • BillOfLadingNumber - holds the bill of lading number for the invoice.
    • AirWaybillNumber - contains the reference to the air waybill.
    • ImportLicenceNumber - contains the reference to the import license number.
    • ExportLicenceNumber - contains the reference to the export license number.
    • LetterOfCreditNumber - contains the reference to a Letter of Credit.
    • URL - contains the reference to a URL.
    • TrackingInformation - contains the information to allow tracking of the ASN.
    • ListOfCarrierReference - contains a list of references issued by the carrier.
    • OtherShippingReferences - contains all other references for the shipment not explicitly stated as the content of other elements.

[^]Code Fragment

    <xsd:complexType name="ShippingReferencesType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ShipmentIdentifier" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="PackingListNumber" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="ContractNumber" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="BillOfLadingNumber" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="AirWaybillNumber" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="ImportLicenceNumber" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="ExportLicenceNumber" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="LetterOfCreditNumber" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="URL" type="xsd:anyURI">
        <xsd:element minOccurs="0" name="TrackingInformation" type="TrackingInformationType">
        <xsd:element minOccurs="0" name="ListOfCarrierReference" type="ListOfCarrierReferenceType">
        <xsd:element minOccurs="0" name="OtherShippingReferences" type="core:ListOfReferenceCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ShippingScheduleHeaderType

ShippingScheduleHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ScheduleID[xsd:string] , ScheduleIssuedDate[xsd:dateTime] , ScheduleReferences[ScheduleReferencesType]? , ReleaseNumber[xsd:string]? , Purpose[core:PurposeType]? , RequestedResponse[core:RequestedResponseType]? , ScheduleTypeCoded[ScheduleTypeCodeType] , ScheduleTypeCodedOther[xsd:string]? , QuantityQualifierCoded[core:QuantityQualifierCodeType]? , QuantityQualifierCodedOther[xsd:string]? , ShippingDates[ShippingDatesType]? , ScheduleParty[SchedulePartyType] , ListOfTransportRouting[core:ListOfTransportRoutingType]? , TermsOfDelivery[core:TermsOfDeliveryType]? , Language[core:LanguageType] , ShippingScheduleHeaderNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfAttachment[core:ListOfAttachmentType]? )

    Description: ShippingScheduleHeaderType contains the header information of the ShippingSchedule.

    Elements:

    • ScheduleID - contains a reference number to uniquely identify the ShippingSchedule.
    • ScheduleIssuedDate - is a digital time stamp the time the application created the ShippingSchedule document.
    • ScheduleReferences - is used to identify references to other documents and release information for the ShippingSchedule.
    • ReleaseNumber - identifies the specific iteration of the release against a given contract, purchase order, etc.
    • Purpose - indicates the intended use of the ShippingSchedule document.
    • RequestedResponse - specifies the type of acknowledgment requested by the buyer from the seller.
    • ScheduleTypeCoded - identifies the type of schedule when defining shipping or delivery time in a schedule or forecast.
    • ScheduleTypeCodedOther - is used to provide a non-standard ScheduleTypeCode. This element is mandatory if the value of ScheduleTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • QuantityQualifierCoded - is the purpose of a quantity using a standard codelist.
    • QuantityQualifierCodedOther - is used to provide a non-standard QuantityQualifierCode. This element is mandatory if the value of QuantityQualifierCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • ShippingDates -
    • ScheduleParty - contains information on the parties to the ShippingSchedule, including unique ID's and address information.
    • ListOfTransportRouting - defines the information on the movement of the goods, including the carrier, equipment, locations and dates.
    • TermsOfDelivery - includes the information related to delivery including shipment method payment and transport.
    • Language - denotes the language the ShippingSchedule is written in.
    • ShippingScheduleHeaderNote - contains any free-form text pertinent to the entire ShippingSchedule. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - is a structured note which contains an identifier and URL.
    • ListOfAttachment - holds a list of attachments to a document that contain information relating to the document.

[^]Code Fragment

    <xsd:complexType name="ShippingScheduleHeaderType">
    <xsd:sequence>
        <xsd:element name="ScheduleID" type="xsd:string">
        <xsd:element name="ScheduleIssuedDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ScheduleReferences" type="ScheduleReferencesType">
        <xsd:element minOccurs="0" name="ReleaseNumber" type="xsd:string">
        <xsd:element minOccurs="0" name="Purpose" type="core:PurposeType">
        <xsd:element minOccurs="0" name="RequestedResponse" type="core:RequestedResponseType">
        <xsd:element name="ScheduleTypeCoded" type="ScheduleTypeCodeType">
        <xsd:element minOccurs="0" name="ScheduleTypeCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="QuantityQualifierCoded" type="core:QuantityQualifierCodeType">
        <xsd:element minOccurs="0" name="QuantityQualifierCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="ShippingDates" type="ShippingDatesType">
        <xsd:element name="ScheduleParty" type="SchedulePartyType">
        <xsd:element minOccurs="0" name="ListOfTransportRouting" type="core:ListOfTransportRoutingType">
        <xsd:element minOccurs="0" name="TermsOfDelivery" type="core:TermsOfDeliveryType">
        <xsd:element name="Language" type="core:LanguageType">
        <xsd:element minOccurs="0" name="ShippingScheduleHeaderNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ShippingScheduleResponseHeaderType

ShippingScheduleResponseHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ScheduleResponseID[xsd:string] , ScheduleResponseIssueDate[xsd:dateTime] , ShippingScheduleReference[core:ReferenceType] , ListOfReferenceCoded[core:ListOfReferenceCodedType]? , BuyerParty[core:PartyType] , SellerParty[core:PartyType] , Purpose[core:PurposeType] , ResponseType[core:ResponseTypeType] , Language[core:LanguageType] , ShippingScheduleHeader[ShippingScheduleHeaderType]? , ShippingScheduleResponseHeaderNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfAttachment[core:ListOfAttachmentType]? )

    Description: ShippingScheduleResponseHeaderType holds all ShippingScheduleResponse header-level information. This element occurs once within the document.

    Elements:

    • ScheduleResponseID - contains a reference number to uniquely identify the ShippingSchedule.
    • ScheduleResponseIssueDate - is a digital time stamp, that the application creating the ShippingScheduleDocument generated.
    • ShippingScheduleReference - is a reference to the original ShippingSchedule.
    • ListOfReferenceCoded - contains one or more elements containing information that can be used to find further information elsewhere that are not explicitly stated in another element.
    • BuyerParty - is the buyer of the goods or services.
    • SellerParty - is the seller of the goods or services.
    • Purpose - is used to communicate the intended purpose of the document.
    • ResponseType - identifies the type of response intended by the document.
    • Language - denotes the language of the document.
    • ShippingScheduleHeader - holds the original ShippingScheduleHeader with any changes made by the responding party. Note: If there are changes to the header, the entire header section should be repeated with the changes.
    • ShippingScheduleResponseHeaderNote - is a note containing general information for the ShippingScheduleResponse.
    • ListOfStructuredNote - is a structured note which contains an identifier and URL.
    • ListOfAttachment - holds a list of attachments to the document that contain information relating to the document.

[^]Code Fragment

    <xsd:complexType name="ShippingScheduleResponseHeaderType">
    <xsd:sequence>
        <xsd:element name="ScheduleResponseID" type="xsd:string">
        <xsd:element name="ScheduleResponseIssueDate" type="xsd:dateTime">
        <xsd:element name="ShippingScheduleReference" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="ListOfReferenceCoded" type="core:ListOfReferenceCodedType">
        <xsd:element name="BuyerParty" type="core:PartyType">
        <xsd:element name="SellerParty" type="core:PartyType">
        <xsd:element name="Purpose" type="core:PurposeType">
        <xsd:element name="ResponseType" type="core:ResponseTypeType">
        <xsd:element name="Language" type="core:LanguageType">
        <xsd:element minOccurs="0" name="ShippingScheduleHeader" type="ShippingScheduleHeaderType">
        <xsd:element minOccurs="0" name="ShippingScheduleResponseHeaderNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ShippingScheduleResponseType

ShippingScheduleResponseType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ShippingScheduleResponseHeader[ShippingScheduleResponseHeaderType] , ( ListOfLocationGroupedShippingResponse[ListOfLocationGroupedShippingResponseType] | ListOfMaterialGroupedShippingResponse[ListOfMaterialGroupedShippingResponseType] ) , ShippingScheduleResponseSummary[ShippingScheduleSummaryType]? )

    Description: ShippingScheduleResponseType is a response to a previously sent ShippingSchedule. The intent of these documents is for sellers to provide changes or corrections to the original documents. A seller can reply back with changes to a schedule due to factors such as backorder, insufficient parts, cannot meet demand, incorrect information, etc. The choice between ListOfLocationGroupedShippingResponse and ListOfMaterialGroupedShippingResponse allows you to determine how the detail section will be structured. ListOfLocationGroupedShippingResponse groups the shipping schedule line items according to location and ListOfMaterialGroupedShippingResponse allows you to group the planning schedule line items according to product.

    Elements:

    • ShippingScheduleResponseHeader - holds all ShippingScheduleResponse header-level information. This element occurs once within the document.
    • ListOfLocationGroupedShippingResponse - contains the line level detail information for the planning schedule. The detail is grouped by the delivery location. This is one of two options for grouping forecasting detail in the ShippingScheduleResponse document.
    • ListOfMaterialGroupedShippingResponse - contains the line level detail information for the planning schedule. The detail is grouped by the material. This is one of two options for grouping forecasting detail in the ShippingScheduleResponse document.
    • ShippingScheduleResponseSummary - provides summary information for the ShippingScheduleResponse document.

[^]Code Fragment

    <xsd:complexType name="ShippingScheduleResponseType">
    <xsd:sequence>
        <xsd:element name="ShippingScheduleResponseHeader" type="ShippingScheduleResponseHeaderType">
        <xsd:choice>
            <xsd:element name="ListOfLocationGroupedShippingResponse" type="ListOfLocationGroupedShippingResponseType">
            <xsd:element name="ListOfMaterialGroupedShippingResponse" type="ListOfMaterialGroupedShippingResponseType">
        </xsd:choice>
        <xsd:element minOccurs="0" name="ShippingScheduleResponseSummary" type="ShippingScheduleSummaryType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ShippingScheduleSummaryType

ShippingScheduleSummaryType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( TotalNumberOfLineItems[xsd:int] )

    Description: ShippingScheduleSummaryType is the summary section for the ShippingSchedule document which contains a total number of lines.

    Elements:

    • TotalNumberOfLineItems - is the total number of lines in the shipping schedule.

[^]Code Fragment

    <xsd:complexType name="ShippingScheduleSummaryType">
    <xsd:sequence>
        <xsd:element name="TotalNumberOfLineItems" type="xsd:int">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ShippingScheduleType

ShippingScheduleType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ShippingScheduleHeader[ShippingScheduleHeaderType] , ( ListOfLocationGroupedShippingDetail[ListOfLocationGroupedShippingDetailType] | ListOfMaterialGroupedShippingDetail[ListOfMaterialGroupedShippingDetailType] ) , ListOfPackageDetail[core:ListOfPackageDetailType]? , ShippingScheduleSummary[ShippingScheduleSummaryType]? , DigitalSignature[dgs:SignatureType]? )

    Description: ShippingScheduleType consists of notifications of short-term shipping requirements from a buyer to a supplier in reference to an existing planning schedule or purchasing agreement. The shipping schedule is not intended to be used for authorizing labor, materials, or other resources. The buyer will initially outline product requirements to the supplier in the form of a planning schedule or purchasing agreement. The Shipping Schedule will then be issued in reference to a planning schedule or purchasing agreement and provide specific details relating to the required products, quantities, delivery points and requested delivery dates. The Shipping Schedule document supersedes certain shipping and delivery information transmitted in a previous planning schedule, but does not replace it. Shipping schedules are usually stated in daily, weekly or monthly buckets (depending upon the industry) and are used to refine planning schedules in support of a just-in-time planning environment. This provides a mechanism to issue precise shipping schedule requirements on a more frequent basis than with the issuance of a planning schedule. The Shipping Schedule also provides the ability for a customer location to issue shipping requirements independent of other customer locations when planning schedules are issued by a consolidated scheduling organization.

    Elements:

    • ShippingScheduleHeader - contains the header information of the ShippingSchedule.
    • ListOfLocationGroupedShippingDetail - contains the line level detail information for the ShippingSchedule document. The detail is grouped by the delivery point. This is one of two options for grouping the shipping detail.
    • ListOfMaterialGroupedShippingDetail - contains the line level detail information for the ShippingSchedule document. The detail is grouped by the material. This is one of two options for grouping shipping detail.
    • ListOfPackageDetail - is a container to hold a number of package details.
    • ShippingScheduleSummary - is the summary section for the ShippingSchedule document which contains a total number of lines.
    • DigitalSignature - contains a digital signature for the document.

[^]Code Fragment

    <xsd:complexType name="ShippingScheduleType">
    <xsd:sequence>
        <xsd:element name="ShippingScheduleHeader" type="ShippingScheduleHeaderType">
        <xsd:choice>
            <xsd:element name="ListOfLocationGroupedShippingDetail" type="ListOfLocationGroupedShippingDetailType">
            <xsd:element name="ListOfMaterialGroupedShippingDetail" type="ListOfMaterialGroupedShippingDetailType">
        </xsd:choice>
        <xsd:element minOccurs="0" name="ListOfPackageDetail" type="core:ListOfPackageDetailType">
        <xsd:element minOccurs="0" name="ShippingScheduleSummary" type="ShippingScheduleSummaryType">
        <xsd:element minOccurs="0" name="DigitalSignature" type="dgs:SignatureType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ShipScheduleDetailType

ShipScheduleDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( CommitmentLevelCoded[CommitmentLevelCodeType] , CommitmentLevelCodedOther[xsd:string]? , ScheduleDates[core:ListOfDateCodedType] , ScheduleQuantities[core:ListOfQuantityCodedType] , ItemResourceAuthorization[ItemResourceAuthorizationType]? , ScheduleNote[xsd:string]? , RouteID[xsd:int]? )

    Description: ShipScheduleDetailType provides the commitment level, dates, and quantity for the shipment.

    Elements:

    • CommitmentLevelCoded - identifies the commitment level for the forecast.
    • CommitmentLevelCodedOther - is used to provide a non-standard CommitmentLevelCode. This element is mandatory if the value of CommitmentLevelCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • ScheduleDates - is a list of forecasted dates and times corresponding to the commitment level for the given material and location.
    • ScheduleQuantities - is the quantity of the line item for the scheduled date.
    • ItemResourceAuthorization - is used to specify resource authorization in the schedule.
    • ScheduleNote - contains any free-form text pertinent to the entire ShippingSchedule. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • RouteID - references the route ID in TransportRouting.

[^]Code Fragment

    <xsd:complexType name="ShipScheduleDetailType">
    <xsd:sequence>
        <xsd:element name="CommitmentLevelCoded" type="CommitmentLevelCodeType">
        <xsd:element minOccurs="0" name="CommitmentLevelCodedOther" type="xsd:string">
        <xsd:element name="ScheduleDates" type="core:ListOfDateCodedType">
        <xsd:element name="ScheduleQuantities" type="core:ListOfQuantityCodedType">
        <xsd:element minOccurs="0" name="ItemResourceAuthorization" type="ItemResourceAuthorizationType">
        <xsd:element minOccurs="0" name="ScheduleNote" type="xsd:string">
        <xsd:element minOccurs="0" name="RouteID" type="xsd:int">
    </xsd:sequence>
</xsd:complexType>


Simple Types:

ASNPurposeCodeType
ASNStatusCodeType
ASNTypeCodeType
CommitmentLevelCodeType
DeliveryStageQualifierCodeType
DiscrepancyCodeType
ElementIdentifierCodeType
ForecastFrequencyCodeType
GoodsConditionCodeType
GoodsReceiptTypeCodeType
ItemReleaseStatusCodeType
InventoryReportTypeCodeType
ResourceAuthorizationCodeType
ScheduleTypeCodeType


complexType definition: TrackingInformationType

TrackingInformationType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/materialsmanagement/v1_0/materialsmanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( TrackingNumber[core:ReferenceType] , TrackingCallURL[xsd:anyURI]? )

    Description: TrackingInformationType contains the information to allow tracking of the ASN.

    Elements:

    • TrackingNumber - contains the reference for tracking purposes.
    • TrackingCallURL - contains the tracking URL.

[^]Code Fragment

    <xsd:complexType name="TrackingInformationType">
    <xsd:sequence>
        <xsd:element name="TrackingNumber" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="TrackingCallURL" type="xsd:anyURI">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ApplicationIdentificationType

ApplicationIdentificationType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( ApplicationID[xsd:string] , ApplicationIDExtension[xsd:string]? , ApplicationInstance[xsd:string]? )

    Description: ApplicationIdentificationType contains reference information for the service or application.

    Elements:

    • ApplicationID - contains the Primary ID that trading partners use to reference each other's applications or services. Typically, this will be the same value as that used in a marketplace registry
    • ApplicationIDExtension - contains an additional identifying reference that trading partner's use to reference each other's applications or services. This may be used in cases where trading partners need additional information to describe their applications.
    • ApplicationInstance - can contain information such as the version, name or code which enables a trading partner to identify which instance of an application or service is being referenced. This may be used in cases where there is more than one instance of an application or service being run at a trading partner site .

[^]Code Fragment

    <xsd:complexType name="ApplicationIdentificationType">
    <xsd:sequence>
        <xsd:element name="ApplicationID" type="xsd:string">
        <xsd:element minOccurs="0" name="ApplicationIDExtension" type="xsd:string">
        <xsd:element minOccurs="0" name="ApplicationInstance" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ApplicationResponseDetailType

ApplicationResponseDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( ErrorTypeCoded[ErrorTypeCodeType] , ErrorTypeCodedOther[xsd:string]? , ItemReference[ItemReferenceType]? , ErrorInfo[core:ErrorInfoType] , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? )

    Description: ApplicationResponseDetailType provides details of an error in a document

    Elements:

    • ErrorTypeCoded - defines the type of error identified by the ApplicationResponse
    • ErrorTypeCodedOther - is used to provide a non-standard ErrorTypeCode. This element is mandatory if the value of ErrorTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • ItemReference - contains information to identify the line item and the schedule line information that contains an error. If an error does not occur in the line item it is not necessary to complete this
    • ErrorInfo - element is used by the receiving application to return complete information about errors encountered during processing of a message. The specific use of some of these elements is as follows:<ul><br>1. CompletionText- contains the error code produced by the recieving service/application. These codes are generally agreed upon by trading partners. Completion codes are not defined in enumerated lists and possible values are not listed in xCBL documentation because it is not reasonably possible to know every completion code for every business process or document.<br>2. CompletionMSG- contains the detailed description of the error code (ie the error message)<br>3. Severity- states the severity of the error encountered <br>4. ListOfParameter- can be used to provide any additional information needed to further identify the error. For instance this can be used to provide the complete schema path for a payload error.</ul>
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. Such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents. Can also be used to contain the document being responded to.
    • ListOfNameValueSet - is used to hold a collection of values qualified by names. The values contained in this element should be agreed upon by trading partners.

[^]Code Fragment

    <xsd:complexType name="ApplicationResponseDetailType">
    <xsd:sequence>
        <xsd:element name="ErrorTypeCoded" type="ErrorTypeCodeType">
        <xsd:element minOccurs="0" name="ErrorTypeCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="ItemReference" type="ItemReferenceType">
        <xsd:element name="ErrorInfo" type="core:ErrorInfoType">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ApplicationResponseHeaderType

ApplicationResponseHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( ApplicationResponseIssueDate[xsd:dateTime] , ApplicationResponseTypeCoded[ApplicationResponseTypeCodeType] , ApplicationResponseSender[core:PartyType] , SendingApplication[ApplicationIdentificationType]? , ApplicationResponseReceiver[core:PartyType] , RespondingApplication[ApplicationIdentificationType]? , BusinessDocumentTypeCoded[BusinessDocumentTypeCodeType] , BusinessDocumentTypeCodedOther[xsd:string]? , DocumentReference[core:ReferenceType] , DocumentStatusCoded[DocumentStatusCodeType] , DocumentStatusCodedOther[xsd:string]? , ApplicationResponseNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? )

    Description: ApplicationResponseHeaderType contains the ApplicationResponse header-level information. This element occurs once within the document.

    Elements:

    • ApplicationResponseIssueDate - holds a digital time stamp provided by the application that created the ApplicationResponse document.
    • ApplicationResponseTypeCoded - defines whether this ApplicationResponse is an acknowledgment of receipt or identifies an error.
    • ApplicationResponseSender - identifies the party that is sending the ApplicationResponse. This party was the receiver of the original document to which the ApplicationResponse is in response.
    • SendingApplication - is used to reference the service or application that sent the original document to which the ApplicationResponse is in response to.
    • ApplicationResponseReceiver - identifies the party who will receive the ApplicationReponse and who sent the original document to which the ApplicationResponse responds.
    • RespondingApplication - is used to reference the service or application that identified the error and is sending the ApplicationResponse.
    • BusinessDocumentTypeCoded - identifies the type of business document the ApplicationResponse is in reponse to.
    • BusinessDocumentTypeCodedOther - is used to provide a non-standard BusinessDocumentTypeCode. This element is mandatory if the value of BusinessDocumentTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • DocumentReference - identifies the original document that the ApplicationResponse is in response to
    • DocumentStatusCoded - describes the status of the document being responded to.
    • DocumentStatusCodedOther - is used to provide a non-standard DocumentStatusCode. This element is mandatory if the value of DocumentStatusCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • ApplicationResponseNote - contains any free form text pertinent to the entire header or to the ApplicationResponse message itself. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. Such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents. Can also be used to contain the document being responded to.
    • ListOfNameValueSet - is a set of collections of name value pairs.

[^]Code Fragment

    <xsd:complexType name="ApplicationResponseHeaderType">
    <xsd:sequence>
        <xsd:element name="ApplicationResponseIssueDate" type="xsd:dateTime">
        <xsd:element name="ApplicationResponseTypeCoded" type="ApplicationResponseTypeCodeType">
        <xsd:element name="ApplicationResponseSender" type="core:PartyType">
        <xsd:element minOccurs="0" name="SendingApplication" type="ApplicationIdentificationType">
        <xsd:element name="ApplicationResponseReceiver" type="core:PartyType">
        <xsd:element minOccurs="0" name="RespondingApplication" type="ApplicationIdentificationType">
        <xsd:element name="BusinessDocumentTypeCoded" type="BusinessDocumentTypeCodeType">
        <xsd:element minOccurs="0" name="BusinessDocumentTypeCodedOther" type="xsd:string">
        <xsd:element name="DocumentReference" type="core:ReferenceType">
        <xsd:element name="DocumentStatusCoded" type="DocumentStatusCodeType">
        <xsd:element minOccurs="0" name="DocumentStatusCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="ApplicationResponseNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ApplicationResponseType

ApplicationResponseType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( ApplicationResponseHeader[ApplicationResponseHeaderType] , ListOfApplicationResponseDetail[ListOfApplicationResponseDetailType]? )

    Description: ApplicationResponseType is a message used by one Application (the receiver of a Business Document) to indicate to another Application (the sender of the Business Document) a business response to the received document. The document can report content errors in a document, acknowledge the receipt or successful processing of a document or be used in those cases where a business response is needed. The ApplicationResponse document is only to be used when a specific response document does not exist for a Business Document.

    Elements:

    • ApplicationResponseHeader - element contains the ApplicationResponse header-level information. This element occurs once within the document.
    • ListOfApplicationResponseDetail - contains a list of ApplicationResponseDetails.

[^]Code Fragment

    <xsd:complexType name="ApplicationResponseType">
    <xsd:sequence>
        <xsd:element name="ApplicationResponseHeader" type="ApplicationResponseHeaderType">
        <xsd:element minOccurs="0" name="ListOfApplicationResponseDetail" type="ListOfApplicationResponseDetailType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: ApplicationResponseTypeCodeType

ApplicationResponseTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • AcknowledgeReceipt - acknowledges the receipt of the document by the application, but not processing
    • AcknowledgeProcess - acknowledges the receipt and processing of the document by the application
    • Error - Identifies that an error was identified in the document

[^]Code Fragment

    <xsd:simpleType name="ApplicationResponseTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="AcknowledgeReceipt">
        <xsd:enumeration value="AcknowledgeProcess">
        <xsd:enumeration value="Error">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: BusinessDocumentTypeCodeType

BusinessDocumentTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • AccountCheck - the AccountCheck document
    • AdvanceShipmentNotice - the AdvanceShipmentNotice document
    • AuctionCreate - The AuctionCreate document
    • AuctionCreateResponse - The AuctionCreateResponse document
    • AuctionEventCreate - The AuctionEventCreate document
    • AuctionEventCreateResponse - The AuctionEventCreateResponse document
    • AuctionEventResult - The AuctionEventResult document
    • AuctionEventResultResponse - The AuctionEventResultResponse document
    • AuctionResult - The AuctionResult document
    • AuctionResultResponse - The AuctionResultResponse document
    • AvailabilityCheckResult - The AvailabilityCheckResult document
    • AvailabilityToPromise - The AvailabilityToPromise document
    • AvailabilityToPromiseResponse - The AvailabilityToPromiseResponse document
    • BulletinBoardNoteChange - The BulletinBoardNoteChange document
    • BulletinBoardNoteCreate - The BulletinBoardNoteCreate document
    • BulletinBoardNoteDelete - The BulletinBoardNoteDelete document
    • BulletinBoardReceipt - The BulletinBoardReceipt document
    • ExternalRequirementFullfillment - The ExternalRequirementFullfillment document
    • FXRateRequest - The FXRateRequest document
    • FXRateResponse - The FXRateResponse document
    • GoodsReceipt - The GoodsReceipt document
    • InternalInvoice - The InternalInvoice document
    • InternalOrder - The InternalOrder document
    • InvoiceResponse - The InvoiceResponse document
    • MessageAcknowledgement - The MessageAcknowledgement document
    • Opportunity - The Opportunity document
    • OpportunityAcknowledgement - The OpportunityAcknowledgement document
    • OpportunityList - The OpportunityList document
    • OpportunityRequest - The OpportunityRequest document
    • OpportunityResponse - The OpportunityResponse document
    • OpportunityResult - The OpportunityResult document
    • OrderConfirmationResponse - The OrderConfirmationResponse document
    • OrderRequest - The OrderRequest document
    • OrderResponse - The OrderResponse document
    • OrderStatusResult - The OrderStatusResult document
    • PaymentRequest - The PaymentRequest document
    • PaymentRequestAcknowledgment - The PaymentRequestAcknowledgment document
    • PaymentStatusRequest - The PaymentStatusRequest document
    • PaymentStatusResponse - The PaymentStatusResponse document
    • PlanningSchedule - The PlanningSchedule document
    • PlanningScheduleResponse - The PlanningScheduleResponse document
    • PriceCheckResult - The PriceCheckResult document
    • ProductCatalog - The ProductCatalog document
    • Quote - The Quote document
    • RemittanceAdvice - The RemittanceAdvice document
    • RequestForQuotation - The RequestForQuotation document
    • Requisition - The Requisition document
    • ShippingSchedule - The ShippingSchedule document
    • ShippingScheduleResponse - The ShippingScheduleResponse document
    • SourcingCreate - The SourcingCreate document
    • SourcingCreateResponse - The SourcingCreateResponse document
    • SourcingResult - The SourcingResult document
    • SourcingResultResponse - The SourcingResultResponse document
    • TimeSeries - The TimeSeries document
    • TimeSeriesRequest - The TimeSeriesRequest document
    • TimeSeriesResponse - The TimeSeriesResponse document
    • TradingPartnerOrganizationDelete - The TradingPartnerOrganizationDelete document
    • TradingPartnerOrganizationInformation - The TradingPartnerOrganizationInformation document
    • TradingPartnerResponse - The TradingPartnerResponse document
    • TradingPartnerUserDelete - The TradingPartnerUserDelete document
    • TradingPartnerUserInformation - The TradingPartnerUserInformation document
    • TransportOrderInitialRequest - TransportOrderInitialRequest document
    • TransportOrderQuoteConfirm - TransportOrderQuoteConfirm document
    • TransportOrderFollowUpRequest - TransportOrderFollowUpRequest document
    • TransportOrderQuoteResponse - TransportOrderQuoteResponse document
    • TransportOrderResponse - TransportOrderResponse document
    • TransportOrderStatusRequest - TransportOrderStatusRequest document
    • TransportOrderStatusRequestResponse - TransportOrderStatusRequestResponse document
    • Other - Non-Standard BusinessTypeCode

[^]Code Fragment

    <xsd:simpleType name="BusinessDocumentTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="AccountCheck">
        <xsd:enumeration value="AdvanceShipmentNotice">
        <xsd:enumeration value="AuctionCreate">
        <xsd:enumeration value="AuctionCreateResponse">
        <xsd:enumeration value="AuctionEventCreate">
        <xsd:enumeration value="AuctionEventCreateResponse">
        <xsd:enumeration value="AuctionEventResult">
        <xsd:enumeration value="AuctionEventResultResponse">
        <xsd:enumeration value="AuctionResult">
        <xsd:enumeration value="AuctionResultResponse">
        <xsd:enumeration value="AvailabilityCheckResult">
        <xsd:enumeration value="AvailabilityToPromise">
        <xsd:enumeration value="AvailabilityToPromiseResponse">
        <xsd:enumeration value="BulletinBoardNoteChange">
        <xsd:enumeration value="BulletinBoardNoteCreate">
        <xsd:enumeration value="BulletinBoardNoteDelete">
        <xsd:enumeration value="BulletinBoardReceipt">
        <xsd:enumeration value="ExternalRequirementFullfillment">
        <xsd:enumeration value="FXRateRequest">
        <xsd:enumeration value="FXRateResponse">
        <xsd:enumeration value="GoodsReceipt">
        <xsd:enumeration value="InternalInvoice">
        <xsd:enumeration value="InternalOrder">
        <xsd:enumeration value="InvoiceResponse">
        <xsd:enumeration value="MessageAcknowledgement">
        <xsd:enumeration value="Opportunity">
        <xsd:enumeration value="OpportunityAcknowledgement">
        <xsd:enumeration value="OpportunityList">
        <xsd:enumeration value="OpportunityRequest">
        <xsd:enumeration value="OpportunityResponse">
        <xsd:enumeration value="OpportunityResult">
        <xsd:enumeration value="OrderConfirmationResponse">
        <xsd:enumeration value="OrderRequest">
        <xsd:enumeration value="OrderResponse">
        <xsd:enumeration value="OrderStatusResult">
        <xsd:enumeration value="PaymentRequest">
        <xsd:enumeration value="PaymentRequestAcknowledgment">
        <xsd:enumeration value="PaymentStatusRequest">
        <xsd:enumeration value="PaymentStatusResponse">
        <xsd:enumeration value="PlanningSchedule">
        <xsd:enumeration value="PlanningScheduleResponse">
        <xsd:enumeration value="PriceCheckResult">
        <xsd:enumeration value="ProductCatalog">
        <xsd:enumeration value="Quote">
        <xsd:enumeration value="RemittanceAdvice">
        <xsd:enumeration value="RequestForQuotation">
        <xsd:enumeration value="Requisition">
        <xsd:enumeration value="ShippingSchedule">
        <xsd:enumeration value="ShippingScheduleResponse">
        <xsd:enumeration value="SourcingCreate">
        <xsd:enumeration value="SourcingCreateResponse">
        <xsd:enumeration value="SourcingResult">
        <xsd:enumeration value="SourcingResultResponse">
        <xsd:enumeration value="TimeSeries">
        <xsd:enumeration value="TimeSeriesRequest">
        <xsd:enumeration value="TimeSeriesResponse">
        <xsd:enumeration value="TradingPartnerOrganizationDelete">
        <xsd:enumeration value="TradingPartnerOrganizationInformation">
        <xsd:enumeration value="TradingPartnerResponse">
        <xsd:enumeration value="TradingPartnerUserDelete">
        <xsd:enumeration value="TradingPartnerUserInformation">
        <xsd:enumeration value="TransportOrderInitialRequest">
        <xsd:enumeration value="TransportOrderQuoteConfirm">
        <xsd:enumeration value="TransportOrderFollowUpRequest">
        <xsd:enumeration value="TransportOrderQuoteResponse">
        <xsd:enumeration value="TransportOrderResponse">
        <xsd:enumeration value="TransportOrderStatusRequest">
        <xsd:enumeration value="TransportOrderStatusRequestResponse">
        <xsd:enumeration value="Other">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: CategoryCodeType

CategoryCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • TransportUnavailable
    • TransportFailure
    • AuthenticationFailure
    • AuthorizationFailure
    • SignatureFailure
    • EncryptionError
    • StructureError
    • ContentError
    • ProcessFailure
    • Unknown

[^]Code Fragment

    <xsd:simpleType name="CategoryCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="TransportUnavailable">
        <xsd:enumeration value="TransportFailure">
        <xsd:enumeration value="AuthenticationFailure">
        <xsd:enumeration value="AuthorizationFailure">
        <xsd:enumeration value="SignatureFailure">
        <xsd:enumeration value="EncryptionError">
        <xsd:enumeration value="StructureError">
        <xsd:enumeration value="ContentError">
        <xsd:enumeration value="ProcessFailure">
        <xsd:enumeration value="Unknown">
    </xsd:restriction>
</xsd:simpleType>


Complex Types:

ApplicationIdentificationType
ApplicationResponseDetailType
ListOfApplicationResponseDetailType
ApplicationResponseHeaderType
ApplicationResponseType
DetailedMessageType
ErrorResponseType
ItemReferenceType
MessageAcknowledgmentType
StringType


complexType definition: DetailedMessageType

DetailedMessageType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: Extension of type: xsd:string

    Attribute:Ref: xml:lang, Use: 'optional'

    Description: DetailedMessageType is a human readable field that provides detailed description of the cause of the error, for example message dump and stack trace

    Attributes:

    • xml:lang

[^]Code Fragment

    <xsd:complexType name="DetailedMessageType">
    <xsd:simpleContent>
        <xsd:extension base="xsd:string">
            <xsd:attribute ref="xml:lang">
        </xsd:extension>
    </xsd:simpleContent>
</xsd:complexType>


simpleType definition: DocumentStatusCodeType

DocumentStatusCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Received - The message has been received but not checked or processed it in any way
    • CheckedOK - The message has been received and checked for structure and content as well as consistency between inerdependent data within the document and with other sources such as earlier documents received and reference data. No problems were found
    • WarningError - The message has been received and checked and problems were found. However the message can still be processed successfuly
    • FatalError - The message has been received and checked but problems were found that prevent the message from being processed
    • ProcessingStarted - Processing of the message has started but not yet completed
    • ProcessedOK - Processing of the message has completed and no errors were found
    • ProcessFatalError - The message was processed but errors were found which prevented a successful conclusion of the process
    • ProcessWarningError - The message was processed and errors were found. However successful processing of the message occurred
    • Other - Other

[^]Code Fragment

    <xsd:simpleType name="DocumentStatusCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Received">
        <xsd:enumeration value="CheckedOK">
        <xsd:enumeration value="WarningError">
        <xsd:enumeration value="FatalError">
        <xsd:enumeration value="ProcessingStarted">
        <xsd:enumeration value="ProcessedOK">
        <xsd:enumeration value="ProcessFatalError">
        <xsd:enumeration value="ProcessWarningError">
        <xsd:enumeration value="Other">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: ErrorResponseType

ErrorResponseType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: ( Code[xsd:string]? , String[StringType] , Role[xsd:anyURI]? , Originator[xsd:anyURI]? , CategoryCoded[CategoryCodeType] , ScopeCoded[ScopeCodeType] , SeverityCoded[SeverityCodeType] , Pointer[xsd:string]? , DetailedMessage[DetailedMessageType]? )

    Description: ErrorResponseType Error information that is exposed to applications

    Elements:

    • Code - Error code for debugging purpose. Error codes can be hierarchical with each subcode separated by the "|" character, for example "abc|def|ghi"
    • String - This is a human readable field that provides a short description of the cause of the error. This is the same as the SOAP 1.2 SOAP Reason element
    • Role - This describes the type of processing that the "Originator" of the error was carrying out when the error was generated. This is the same as the SOAP 1.2 Role element
    • Originator - This contains the identifier of the connector or server that generated the error. This is the same as the SOAP 1.2 SOAP Node element
    • CategoryCoded - indicates what the problem is. Its purpose is to enable an application to use the information in this element to determine what alternative or compensating action to take.
    • ScopeCoded - indicates where in the message the error occurs, for example the envelope, the header or the body.
    • SeverityCoded - indicates the severity of the error. It is used to determine whether or not the message was processed by its recipient and whether a resend of the same message could succeed.
    • Pointer - contains a pointer to the exact part of the message, e.g. an element or attribute that caused the error. It contains an XPATH expression, content id, or a URL.
    • DetailedMessage - is a field that allows developers to put large detailed information (in human readable format) about the error, for instance stack trace and message dump.

[^]Code Fragment

    <xsd:complexType name="ErrorResponseType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="Code" type="xsd:string">
        <xsd:element name="String" type="StringType">
        <xsd:element minOccurs="0" name="Role" type="xsd:anyURI">
        <xsd:element minOccurs="0" name="Originator" type="xsd:anyURI">
        <xsd:element name="CategoryCoded" type="CategoryCodeType">
        <xsd:element name="ScopeCoded" type="ScopeCodeType">
        <xsd:element name="SeverityCoded" type="SeverityCodeType">
        <xsd:element minOccurs="0" name="Pointer" type="xsd:string">
        <xsd:element minOccurs="0" name="DetailedMessage" type="DetailedMessageType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: ErrorTypeCodeType

ErrorTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • CorrelationError - A correlation error is an error that prevents the document from being processed, related to the referencing of other business documents or the sequence of exchange of documents in a choreography.
    • BusinessError - These are commonly referred to as Context Errors. The payload has a valid structure and follows the basic consistency rules for the payload but the particular usage of a field or combination of fields is incorrect, and will stop processing, or make it prone to error.
    • PayloadError - An error in the payload which can be a structure error in the XML, an error in non-XML data, or an inconsistency in the data.
    • Informational - An error has not occured, but warning level information is communicated.
    • Other - Other

[^]Code Fragment

    <xsd:simpleType name="ErrorTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="CorrelationError">
        <xsd:enumeration value="BusinessError">
        <xsd:enumeration value="PayloadError">
        <xsd:enumeration value="Informational">
        <xsd:enumeration value="Other">
    </xsd:restriction>
</xsd:simpleType>


Global Elements (Document Roots):

ApplicationResponse
ErrorResponse
MessageAcknowledgment


complexType definition: ItemReferenceType

ItemReferenceType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( LineItemNumberReference[core:LineItemNumberReferenceType] , ScheduleLineID[xsd:int]? )

    Description: ItemReferenceType contains information to identify the line item and the schedule line information that contains an error. If an error does not occur in the line item it is not necessary to complete this

    Elements:

    • LineItemNumberReference - references the line item number that contains an error.
    • ScheduleLineID - references the schedule line which contains an error. Used when the error occurs at the schedule line level.

[^]Code Fragment

    <xsd:complexType name="ItemReferenceType">
    <xsd:sequence>
        <xsd:element name="LineItemNumberReference" type="core:LineItemNumberReferenceType">
        <xsd:element minOccurs="0" name="ScheduleLineID" type="xsd:int">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfApplicationResponseDetailType

ListOfApplicationResponseDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( ApplicationResponseDetail[ApplicationResponseDetailType]+ )

    Description: ListOfApplicationResponseDetailType contains a list of ApplicationResponseDetails.

    Elements:

    • ApplicationResponseDetail - Provides details of an error in a document

[^]Code Fragment

    <xsd:complexType name="ListOfApplicationResponseDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="ApplicationResponseDetail" type="ApplicationResponseDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: MessageAcknowledgmentType

MessageAcknowledgmentType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( AcknowledgmentLocation[xsd:string]? , AcknowledgmentReferenceNumber[xsd:string]? , AcknowledgmentNote[xsd:string]? )

    Description: MessageAcknowledgmentType is part of a larger business process defined by a document exchange. Message acknowledgments are used by e-business parties to notify the sender of a message/document that the message has been received. Message acknowledgments are not used to indicate a syntactical or content check of the received document.

    Elements:

    • AcknowledgmentLocation - references the location in the system in which the corresponding message is being acknowledged. For example, "MyCompany.XPC.MsgAckResponder" and "MyCompany.Translator"
    • AcknowledgmentReferenceNumber - is a reference number that can be used to associate the message acknowledgment with an originating message.
    • AcknowledgmentNote - is a note that can included with the message acknowledgment.

[^]Code Fragment

    <xsd:complexType name="MessageAcknowledgmentType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="AcknowledgmentLocation" type="xsd:string">
        <xsd:element minOccurs="0" name="AcknowledgmentReferenceNumber" type="xsd:string">
        <xsd:element minOccurs="0" name="AcknowledgmentNote" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: ScopeCodeType

ScopeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Envelope
    • Header
    • Payload
    • Attachment
    • NonMessageRelated
    • Unknown

[^]Code Fragment

    <xsd:simpleType name="ScopeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Envelope">
        <xsd:enumeration value="Header">
        <xsd:enumeration value="Payload">
        <xsd:enumeration value="Attachment">
        <xsd:enumeration value="NonMessageRelated">
        <xsd:enumeration value="Unknown">
    </xsd:restriction>
</xsd:simpleType>


simpleType definition: SeverityCodeType

SeverityCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Description:
    This code indicates the severity of an error.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Fatal
    • Warning - Non fatal error.
    • Transient - Errors are temporary in nature and request possibly can be resent in the future. The interval before resend can occurs can be specified as one of the parameters.

[^]Code Fragment

    <xsd:simpleType name="SeverityCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Fatal">
        <xsd:enumeration value="Warning">
        <xsd:enumeration value="Transient">
    </xsd:restriction>
</xsd:simpleType>


Simple Types:

ApplicationResponseTypeCodeType
BusinessDocumentTypeCodeType
DocumentStatusCodeType
CategoryCodeType
ScopeCodeType
ErrorTypeCodeType
SeverityCodeType


complexType definition: StringType

StringType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/messagemanagement/v1_0/messagemanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema

    Content: Extension of type: xsd:string

    Attribute:Ref: xml:lang, Use: 'optional'

    Description: StringType is a human readable field that provides a short description of the cause of the error. This is the same as the SOAP 1.2 SOAP Reason element

    Attributes:

    • xml:lang

[^]Code Fragment

    <xsd:complexType name="StringType">
    <xsd:simpleContent>
        <xsd:extension base="xsd:string">
            <xsd:attribute ref="xml:lang">
        </xsd:extension>
    </xsd:simpleContent>
</xsd:complexType>


TEST

TEST


complexType definition: AccountAssignmentType

AccountAssignmentType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( AccountAssignmentID[xsd:string] , DistributionPercentage[xsd:decimal] , GLAccount[xsd:string]? , CostCenter[xsd:string]? , AccountAssignmentOrderNumber[xsd:string]? , OperationNumber[xsd:string]? , SalesOrderReference[xsd:string]? , BusinessArea[xsd:string]? , ControllingArea[xsd:string]? , ProfitCenter[xsd:string]? , WorkBreakdownStructure[xsd:string]? , Network[xsd:string]? , FixedAsset[xsd:string]? , FixedAssetSub[xsd:string]? , FundsCenter[xsd:string]? , Fund[xsd:string]? , CommitmentItem[xsd:string]? , FunctionalArea[xsd:string]? , GenericAccounting[xsd:string]? , ListOfNameValueSet[core:ListOfNameValueSetType]? )

    Description: AccountAssignmentType provides detailed account assignment information referring to items of internal documents.

    Elements:

    • AccountAssignmentID - is the item number of account assignment information.
    • DistributionPercentage - is the distribution by percentage in the case of multiple account assignment. The total for all account assignment information for an item must always be 100%.
    • GLAccount - is the General Ledger Account to which the costs are posted.
    • CostCenter - is the assignment to a cost center as cost object.
    • AccountAssignmentOrderNumber -
    • OperationNumber - is the assignment to an activity within the order.
    • SalesOrderReference -
    • BusinessArea - is the assignment to a business area as cost object.
    • ControllingArea - is the assignment to a controlling area as cost object.
    • ProfitCenter - is the assignment to a profit center as cost object.
    • WorkBreakdownStructure - is the assignment to a work breakdown structure element as cost object.
    • Network - is the assignment to a network as cost object.
    • FixedAsset - is the assignment to an asset type (office inventory, for example) as cost object.
    • FixedAssetSub -
    • FundsCenter - is the assignment to a funds center as cost object (usual for public facilities).
    • Fund - is the assignment to a fund as cost object (usual for public facilities).
    • CommitmentItem - is the assignment to a commitment item as cost object (usual for public facilities).
    • FunctionalArea - is the assignment to a functional area as cost object (usual for public facilities).
    • GenericAccounting - is a user defined account assignment.
    • ListOfNameValueSet - contains a collection of name and value sets.

[^]Code Fragment

    <xsd:complexType name="AccountAssignmentType">
    <xsd:sequence>
        <xsd:element name="AccountAssignmentID" type="xsd:string">
        <xsd:element name="DistributionPercentage" type="xsd:decimal">
        <xsd:element minOccurs="0" name="GLAccount" type="xsd:string">
        <xsd:element minOccurs="0" name="CostCenter" type="xsd:string">
        <xsd:element minOccurs="0" name="AccountAssignmentOrderNumber" type="xsd:string">
        <xsd:element minOccurs="0" name="OperationNumber" type="xsd:string">
        <xsd:element minOccurs="0" name="SalesOrderReference" type="xsd:string">
        <xsd:element minOccurs="0" name="BusinessArea" type="xsd:string">
        <xsd:element minOccurs="0" name="ControllingArea" type="xsd:string">
        <xsd:element minOccurs="0" name="ProfitCenter" type="xsd:string">
        <xsd:element minOccurs="0" name="WorkBreakdownStructure" type="xsd:string">
        <xsd:element minOccurs="0" name="Network" type="xsd:string">
        <xsd:element minOccurs="0" name="FixedAsset" type="xsd:string">
        <xsd:element minOccurs="0" name="FixedAssetSub" type="xsd:string">
        <xsd:element minOccurs="0" name="FundsCenter" type="xsd:string">
        <xsd:element minOccurs="0" name="Fund" type="xsd:string">
        <xsd:element minOccurs="0" name="CommitmentItem" type="xsd:string">
        <xsd:element minOccurs="0" name="FunctionalArea" type="xsd:string">
        <xsd:element minOccurs="0" name="GenericAccounting" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: BaseItemDetailType

BaseItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( LineItemNum[core:LineItemNumType] , LineItemType[core:LineItemTypeType]? , ParentItemNumber[core:LineItemNumberReferenceType]? , ItemIdentifiers[core:ItemIdentifiersType]? , ListOfDimension[core:ListOfDimensionType]? , TotalQuantity[core:QuantityType] , MaxBackOrderQuantity[core:QuantityType]? , ListOfQuantityCoded[core:ListOfQuantityCodedType]? , BaseItemReferences[core:BaseItemReferencesType]? , CountryOfOrigin[core:CountryType]? , CountryOfDestination[core:CountryType]? , FinalRecipient[core:PartyType]? , ListOfPartyCoded[core:ListOfPartyCodedType]? , ConditionsOfSale[core:ConditionsOfSaleType]? , HazardousMaterials[core:HazardousType]? )

    Description: BaseItemDetailType identifies the line item for the document. This contains the description, specific identifiers, weights, measures and other information associated with the product.

    Elements:

    • LineItemNum - is a set of numbers uniquely identifying the line item for the number. In the case where the seller's system splits a line item number into 2 line items, the buyer item number will remain the same for both line items, but the seller item number will be different.
    • LineItemType - identifies whether the line item is a component group (consists of other line items), a typical line item, or a textual line item.
    • ParentItemNumber - identifies the line item that groups this and other line items. This is done using LineItemNumberReference, which specifies the number of the parent line item and whether this reference is the Buyer or Seller's number. LineItemNumberReference is a string content model of datatype integer that contains an attribute to specify whether the ParentItemNumber is a Seller or Buyer number, with the default being Buyer. This value references the parent item represented a group.
    • ItemIdentifiers - details all of the part numbers assigned to the item.
    • ListOfDimension - lists one or more quantitative measurements of the item.
    • TotalQuantity - contains the total amount of the line item pertaining to the document.
    • MaxBackOrderQuantity - specifies the maximum quantity of an item that a customer will allow to be back ordered.
    • ListOfQuantityCoded - specifies any other quantities not explicitly stated.
    • BaseItemReferences - contains all reference information for the item.
    • CountryOfOrigin - specifies the country code for the country in which the line item was manufactured.
    • CountryOfDestination - specifies the country code for the country in which the delivery is finally received.
    • FinalRecipient - identifies the person or organization who will ultimately receive the item or items.
    • ListOfPartyCoded - specifies any other parties associated with the line item that are not already explicitly stated.
    • ConditionsOfSale - details the conditions of sale for the item.
    • HazardousMaterials - contains the hazardous information for the line item.

[^]Code Fragment

    <xsd:complexType name="BaseItemDetailType">
    <xsd:sequence>
        <xsd:element name="LineItemNum" type="core:LineItemNumType">
        <xsd:element minOccurs="0" name="LineItemType" type="core:LineItemTypeType">
        <xsd:element minOccurs="0" name="ParentItemNumber" type="core:LineItemNumberReferenceType">
        <xsd:element minOccurs="0" name="ItemIdentifiers" type="core:ItemIdentifiersType">
        <xsd:element minOccurs="0" name="ListOfDimension" type="core:ListOfDimensionType">
        <xsd:element name="TotalQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="MaxBackOrderQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="ListOfQuantityCoded" type="core:ListOfQuantityCodedType">
        <xsd:element minOccurs="0" name="BaseItemReferences" type="core:BaseItemReferencesType">
        <xsd:element minOccurs="0" name="CountryOfOrigin" type="core:CountryType">
        <xsd:element minOccurs="0" name="CountryOfDestination" type="core:CountryType">
        <xsd:element minOccurs="0" name="FinalRecipient" type="core:PartyType">
        <xsd:element minOccurs="0" name="ListOfPartyCoded" type="core:ListOfPartyCodedType">
        <xsd:element minOccurs="0" name="ConditionsOfSale" type="core:ConditionsOfSaleType">
        <xsd:element minOccurs="0" name="HazardousMaterials" type="core:HazardousType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ChangeOrderDetailType

ChangeOrderDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ListOfChangeOrderItemDetail[ListOfChangeOrderItemDetailType]? , ListOfChangeOrderPackageDetail[ListOfChangeOrderPackageDetailType]? )

    Description: ChangeOrderDetailType is an optional section providing a list of line items. This list can only include those which were changed, the entire line item list, or no line items at all. This should be used in accordance with the OrderHeaderPurpose selected in the ChangeOrderHeader.

    Elements:

    • ListOfChangeOrderItemDetail - holds change information for the item detail information.
    • ListOfChangeOrderPackageDetail - holds change information for the package detail information.

[^]Code Fragment

    <xsd:complexType name="ChangeOrderDetailType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ListOfChangeOrderItemDetail" type="ListOfChangeOrderItemDetailType">
        <xsd:element minOccurs="0" name="ListOfChangeOrderPackageDetail" type="ListOfChangeOrderPackageDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ChangeOrderHeaderType

ChangeOrderHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ChangeOrderNumber[ChangeOrderNumberType] , ChangeOrderSequence[xsd:string] , ChangeOrderIssueDate[xsd:dateTime] , OrderReference[core:ReferenceType] , SellerParty[core:PartyType] , BuyerParty[core:PartyType] , ListOfReferenceCoded[core:ListOfReferenceCodedType]? , Purpose[core:PurposeType]? , RequestedResponse[core:RequestedResponseType]? , ChangeType[core:ChangeTypeType] , OrderType[core:OrderTypeType]? , OriginalOrderHeaderWithChanges[OrderHeaderType]? , ChangeOrderHeaderNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? )

    Description: ChangeOrderHeaderType contains the header information of the ChangeOrder.

    Elements:

    • ChangeOrderNumber - indicates the unique number assigned to the ChangeOrder, typically according to the system that generated the ChangeOrderNumber.
    • ChangeOrderSequence - is a number to identify the change or revision against an order. The first change submitted for an order would have a value of 1, the second 2, and so on.
    • ChangeOrderIssueDate - holds a time stamp provided by the application that created the ChangeOrder document.
    • OrderReference - holds the number and the issue date for the purchase order being changed.
    • SellerParty - identifies the party selling the goods.
    • BuyerParty - identifies the party buying the goods.
    • ListOfReferenceCoded - contains all other references for the ChangeOrder not explicitly stated as the contents of other elements.
    • Purpose - is used to communicate the purpose of the ChangeOrder document.
    • RequestedResponse - specifies the type of acknowledgment requested by the buyer from the seller.
    • ChangeType - identifies the type of change in the ChangeOrder.
    • OrderType - identifies the type of purchase order the ChangeOrder is referencing.
    • OriginalOrderHeaderWithChanges - contains the new order header. This should be the origiginal order header information with any changes that are being made..
    • ChangeOrderHeaderNote - contains any free-form text pertinent to the entire ChangeOrder. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information. This element can be used to explicitly state the changes that were made to the header section.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.

[^]Code Fragment

    <xsd:complexType name="ChangeOrderHeaderType">
    <xsd:sequence>
        <xsd:element name="ChangeOrderNumber" type="ChangeOrderNumberType">
        <xsd:element name="ChangeOrderSequence" type="xsd:string">
        <xsd:element name="ChangeOrderIssueDate" type="xsd:dateTime">
        <xsd:element name="OrderReference" type="core:ReferenceType">
        <xsd:element name="SellerParty" type="core:PartyType">
        <xsd:element name="BuyerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ListOfReferenceCoded" type="core:ListOfReferenceCodedType">
        <xsd:element minOccurs="0" name="Purpose" type="core:PurposeType">
        <xsd:element minOccurs="0" name="RequestedResponse" type="core:RequestedResponseType">
        <xsd:element name="ChangeType" type="core:ChangeTypeType">
        <xsd:element minOccurs="0" name="OrderType" type="core:OrderTypeType">
        <xsd:element minOccurs="0" name="OriginalOrderHeaderWithChanges" type="OrderHeaderType">
        <xsd:element minOccurs="0" name="ChangeOrderHeaderNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ChangeOrderItemDetailType

ChangeOrderItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ItemDetailChangeCoded[core:DetailChangeCodeType] , ItemDetailChangeCodedOther[xsd:string]? , ListOfReferenceCoded[core:ListOfReferenceCodedType]? , OriginalItemDetailWithChanges[ItemDetailType]? , LineItemNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? )

    Description: ChangeOrderItemDetailType contains a qualifier for the type of change made to the line item, the changes to the line item, and a note field for any additional information to be provided.

    Elements:

    • ItemDetailChangeCoded - identifies the type of change to the line item.
    • ItemDetailChangeCodedOther - is used to provide a non-standard ItemDetailChangeCode. This element is mandatory if the value of ItemDetailChangeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • ListOfReferenceCoded - contains all other references for the ChangeOrder, not explicitly stated as the content of other elements.
    • OriginalItemDetailWithChanges - is used to send the original information with any changes that may be made.
    • LineItemNote - describes any free form text pertinent to the line item. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.

[^]Code Fragment

    <xsd:complexType name="ChangeOrderItemDetailType">
    <xsd:sequence>
        <xsd:element name="ItemDetailChangeCoded" type="core:DetailChangeCodeType">
        <xsd:element minOccurs="0" name="ItemDetailChangeCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfReferenceCoded" type="core:ListOfReferenceCodedType">
        <xsd:element minOccurs="0" name="OriginalItemDetailWithChanges" type="ItemDetailType">
        <xsd:element minOccurs="0" name="LineItemNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ChangeOrderNumberType

ChangeOrderNumberType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( BuyerChangeOrderNumber[xsd:string] , SellerChangeOrderNumber[xsd:string]? )

    Description: ChangeOrderNumberType indicates the unique number assigned to the ChangeOrder, typically according to the system that generated the ChangeOrderNumber.

    Elements:

    • BuyerChangeOrderNumber - is the unique number assigned by the buyer to this ChangeOrder.
    • SellerChangeOrderNumber - is the unique number assigned by the seller to this ChangeOrder.

[^]Code Fragment

    <xsd:complexType name="ChangeOrderNumberType">
    <xsd:sequence>
        <xsd:element name="BuyerChangeOrderNumber" type="xsd:string">
        <xsd:element minOccurs="0" name="SellerChangeOrderNumber" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ChangeOrderPackageDetailType

ChangeOrderPackageDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PackageDetailChangeCoded[core:DetailChangeCodeType] , PackageDetailChangeCodedOther[xsd:string]? , OriginalPackageDetailWithChanges[core:PackageDetailType]? , PackageDetailNote[xsd:string]? )

    Description: ChangeOrderPackageDetailType holds a change information for the package detail.

    Elements:

    • PackageDetailChangeCoded - identifies the type of change to the PackageDetail.
    • PackageDetailChangeCodedOther - is used to provide a non-standard DetailChangeCode. This element is mandatory if the value of DetailChangeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • OriginalPackageDetailWithChanges - identifies the PackageDetail to be added/deleted or to identify the changes to an existing PackageDetail.
    • PackageDetailNote - describes any free-form text pertinent to the PackageDetail described by the ChangeOrder. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.This can be used to give any additional information concerning the changes made to the PackageDetail.

[^]Code Fragment

    <xsd:complexType name="ChangeOrderPackageDetailType">
    <xsd:sequence>
        <xsd:element name="PackageDetailChangeCoded" type="core:DetailChangeCodeType">
        <xsd:element minOccurs="0" name="PackageDetailChangeCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="OriginalPackageDetailWithChanges" type="core:PackageDetailType">
        <xsd:element minOccurs="0" name="PackageDetailNote" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ChangeOrderSummaryType

ChangeOrderSummaryType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OriginalOrderSummary[OrderSummaryType]? , RevisedOrderSummary[OrderSummaryType]? )

    Description: ChangeOrderSummaryType is the summary section for the ChangeOrder. This contains the same information as the OrderSummary.

    Elements:

    • OriginalOrderSummary - is used to show the old OrderSummary for comparison purposes, if needed.
    • RevisedOrderSummary - is the summary section that reflects any changes made to the Order.

[^]Code Fragment

    <xsd:complexType name="ChangeOrderSummaryType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="OriginalOrderSummary" type="OrderSummaryType">
        <xsd:element minOccurs="0" name="RevisedOrderSummary" type="OrderSummaryType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ChangeOrderType

ChangeOrderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ChangeOrderHeader[ChangeOrderHeaderType] , ChangeOrderDetail[ChangeOrderDetailType]? , ChangeOrderSummary[ChangeOrderSummaryType]? , DigitalSignature[dgs:SignatureType]? )

    Description: ChangeOrderType ChangeOrder allows a requisitioner or buyer to initiate a change to an already existing order. A seller uses the OrderResponse document to accept or reject an order or a changed order.

    Elements:

    • ChangeOrderHeader - contains the header information of the OrderChange.
    • ChangeOrderDetail - is an optional section providing a list of line items. This list can only include those which were changed, the entire line item list, or no line items at all. This should be used in accordance with the OrderHeaderPurpose selected in the ChangeOrderHeader.
    • ChangeOrderSummary - is the summary section for the ChangeOrder. This contains the same information as the OrderSummary.
    • DigitalSignature - contains a digital signature for the document.

[^]Code Fragment

    <xsd:complexType name="ChangeOrderType">
    <xsd:sequence>
        <xsd:element name="ChangeOrderHeader" type="ChangeOrderHeaderType">
        <xsd:element minOccurs="0" name="ChangeOrderDetail" type="ChangeOrderDetailType">
        <xsd:element minOccurs="0" name="ChangeOrderSummary" type="ChangeOrderSummaryType">
        <xsd:element minOccurs="0" name="DigitalSignature" type="dgs:SignatureType">
    </xsd:sequence>
</xsd:complexType>


Complex Types:

AccountAssignmentType
ListOfAccountAssignmentType
BaseItemDetailType
ChangeOrderDetailType
ChangeOrderHeaderType
ChangeOrderItemDetailType
ListOfChangeOrderItemDetailType
ChangeOrderNumberType
ChangeOrderPackageDetailType
ListOfChangeOrderPackageDetailType
ChangeOrderSummaryType
ChangeOrderType
ContractAndSystemReferenceType
ItemDetailType
ListOfItemDetailType
ItemStatusType
OrderConfirmationActionType
OrderConfirmationDetailReferencesType
OrderConfirmationDetailType
OrderConfirmationHeaderType
OrderConfirmationItemDetailType
ListOfOrderConfirmationItemDetailType
OrderConfirmationPartyType
OrderConfirmationResponseDetailType
ListOfOrderConfirmationResponseDetailType
OrderConfirmationResponseHeaderType
OrderConfirmationResponsePartyType
OrderConfirmationResponseType
OrderConfirmationType
OrderConfirmationTypeType
OrderDatesType
OrderDetailType
OrderHeaderType
OrderNumberType
OrderPartyType
OrderReferencesType
ListOfOrderReferencesType
OrderRequestHeaderType
OrderRequestNumberType
OrderRequestPartyType
OrderRequestType
OrderResponseDetailType
OrderResponseHeaderType
OrderResponseItemDetailType
ListOfOrderResponseItemDetailType
OrderResponseNumberType
OrderResponsePackageDetailType
ListOfOrderResponsePackageDetailType
OrderResponseSummaryType
OrderResponseType
OrderStatusItemType
ListOfOrderStatusItemType
OrderStatusReferenceType
OrderStatusRequestDetailType
ListOfOrderStatusRequestDetailType
OrderStatusRequestHeaderType
OrderStatusRequestType
OrderStatusResultDetailType
ListOfOrderStatusResultDetailType
OrderStatusResultHeaderType
OrderStatusResultItemType
ListOfOrderStatusResultItemType
OrderStatusResultReferenceType
OrderStatusResultType
OrderSummaryType
OrderType
OriginalItemDetailWithChangesType
ResponseBaseItemDetailType
ResponseDeliveryDetailType
SplitQuantityType
ListOfSplitQuantityType


complexType definition: ContractAndSystemReferenceType

ContractAndSystemReferenceType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ContractID[core:IdentifierType] , ContractItemID[xsd:string] , SystemID[xsd:string]? )

    Description: ContractAndSystemReferenceType is a reference including contract and system.

    Elements:

    • ContractID - is the ID of the contract.
    • ContractItemID - is the ID of the contract item.
    • SystemID - is the ID of the system in which the transaction takes place.

[^]Code Fragment

    <xsd:complexType name="ContractAndSystemReferenceType">
    <xsd:sequence>
        <xsd:element name="ContractID" type="core:IdentifierType">
        <xsd:element name="ContractItemID" type="xsd:string">
        <xsd:element minOccurs="0" name="SystemID" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


Global Elements (Document Roots):

ChangeOrder
Order
OrderRequest
OrderResponse
OrderConfirmation
OrderConfirmationResponse
OrderStatusRequest
OrderStatusResult


complexType definition: ItemDetailType

ItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( BaseItemDetail[BaseItemDetailType] , PricingDetail[core:PricingDetailType]? , DeliveryDetail[core:DeliveryDetailType]? , RoundTripInformation[core:RoundTripInformationType]? , LineItemNote[xsd:string]? , SpecialHandling[core:SpecialHandlingType]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? , LineItemAttachments[core:ListOfAttachmentType]? )

    Description: ItemDetailType contains information to describe and identify an item along with all pricing and delivery information for that item.

    Elements:

    • BaseItemDetail - identifies the line item for the document. This contains the description, specific identifiers, weights, measures and other information associated with the product.
    • PricingDetail - contains all pricing information, including taxes, allowances and charges, and total price for an item.
    • DeliveryDetail - is used to specify the scheduling information for a distinct set of ship from party, ship to party, and transport information for the line item.
    • RoundTripInformation - identifies information specific to the round trip order process for the item. This element should only be used if the ordering process for this item is round trip.
    • LineItemNote - describes any free form text pertinent to the line item. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • SpecialHandling - descibes any special handling conditions that apply to the item.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. Such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfNameValueSet - is used to hold sets of name value pairs. The use of this element should be limited to the support of previous versions of xCBL.
    • LineItemAttachments - contains attachments for the line item.

[^]Code Fragment

    <xsd:complexType name="ItemDetailType">
    <xsd:sequence>
        <xsd:element name="BaseItemDetail" type="BaseItemDetailType">
        <xsd:element minOccurs="0" name="PricingDetail" type="core:PricingDetailType">
        <xsd:element minOccurs="0" name="DeliveryDetail" type="core:DeliveryDetailType">
        <xsd:element minOccurs="0" name="RoundTripInformation" type="core:RoundTripInformationType">
        <xsd:element minOccurs="0" name="LineItemNote" type="xsd:string">
        <xsd:element minOccurs="0" name="SpecialHandling" type="core:SpecialHandlingType">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
        <xsd:element minOccurs="0" name="LineItemAttachments" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ItemStatusType

ItemStatusType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ItemStatusQuantity[core:QuantityType] , ItemStatusEvent[core:StatusType] , PaymentStatusEvent[core:StatusType]? , ShipmentStatusEvent[core:ShipmentStatusEventType]? )

    Description: ItemStatusType provides a status for the item.

    Elements:

    • ItemStatusQuantity - gives a quantity (less than the total item quantity) for which this combination of status events are applicable.
    • ItemStatusEvent - provides a general item status.
    • PaymentStatusEvent - provides a payment status.
    • ShipmentStatusEvent - provides a shipment status.

[^]Code Fragment

    <xsd:complexType name="ItemStatusType">
    <xsd:sequence>
        <xsd:element name="ItemStatusQuantity" type="core:QuantityType">
        <xsd:element name="ItemStatusEvent" type="core:StatusType">
        <xsd:element minOccurs="0" name="PaymentStatusEvent" type="core:StatusType">
        <xsd:element minOccurs="0" name="ShipmentStatusEvent" type="core:ShipmentStatusEventType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfAccountAssignmentType

ListOfAccountAssignmentType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( AccountAssignment[AccountAssignmentType]+ )

    Description: ListOfAccountAssignmentType is a list of account assignment information that references items in internal documents.

    Elements:

    • AccountAssignment - contains account assignment information

[^]Code Fragment

    <xsd:complexType name="ListOfAccountAssignmentType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="AccountAssignment" type="AccountAssignmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfChangeOrderItemDetailType

ListOfChangeOrderItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ChangeOrderItemDetail[ChangeOrderItemDetailType]+ )

    Description: ListOfChangeOrderItemDetailType holds change information for the item detail information.

    Elements:

    • ChangeOrderItemDetail - contains a qualifier for the type of change made to the line item, the line item itself, and note field for any additional information to be provided.

[^]Code Fragment

    <xsd:complexType name="ListOfChangeOrderItemDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="ChangeOrderItemDetail" type="ChangeOrderItemDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfChangeOrderPackageDetailType

ListOfChangeOrderPackageDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ChangeOrderPackageDetail[ChangeOrderPackageDetailType]+ )

    Description: ListOfChangeOrderPackageDetailType holds change information for the package detail information.

    Elements:

    • ChangeOrderPackageDetail - holds changeed information for the package detail.

[^]Code Fragment

    <xsd:complexType name="ListOfChangeOrderPackageDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="ChangeOrderPackageDetail" type="ChangeOrderPackageDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfItemDetailType

ListOfItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ItemDetail[ItemDetailType]+ )

    Description: ListOfItemDetailType holds one or more items for the document.

    Elements:

    • ItemDetail - contains the item detail information.

[^]Code Fragment

    <xsd:complexType name="ListOfItemDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="ItemDetail" type="ItemDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfOrderConfirmationItemDetailType

ListOfOrderConfirmationItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OrderConfirmationItemDetail[OrderConfirmationItemDetailType]+ )

    Description: ListOfOrderConfirmationItemDetailType contains a list of OrderConfirmationItemDetails.

    Elements:

    • OrderConfirmationItemDetail - contains details of the item used in the order confirmation.

[^]Code Fragment

    <xsd:complexType name="ListOfOrderConfirmationItemDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="OrderConfirmationItemDetail" type="OrderConfirmationItemDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfOrderConfirmationResponseDetailType

ListOfOrderConfirmationResponseDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OrderConfirmationResponseDetail[OrderConfirmationResponseDetailType]+ )

    Description: ListOfOrderConfirmationResponseDetailType contains a list of line items for order confirmation response.

    Elements:

    • OrderConfirmationResponseDetail - contains the item detail information for the OrderConfirmationResponse.

[^]Code Fragment

    <xsd:complexType name="ListOfOrderConfirmationResponseDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="OrderConfirmationResponseDetail" type="OrderConfirmationResponseDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfOrderReferencesType

ListOfOrderReferencesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OrderReferences[OrderReferencesType]+ )

    Description: ListOfOrderReferencesType is a list of order references

    Elements:

    • OrderReferences - defines the references for the Order.

[^]Code Fragment

    <xsd:complexType name="ListOfOrderReferencesType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="OrderReferences" type="OrderReferencesType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfOrderResponseItemDetailType

ListOfOrderResponseItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OrderResponseItemDetail[OrderResponseItemDetailType]+ )

    Description: ListOfOrderResponseItemDetailType contains response information for one or more item details.

    Elements:

    • OrderResponseItemDetail - holds response information for a line item, any references for that line item, and the relevant response to that line item. Applications will be expected to return any line items with any changes and generally all of the accepted line items as well. Any line item not present in this section that was found in the original order will be assumed to be accepted as is.

[^]Code Fragment

    <xsd:complexType name="ListOfOrderResponseItemDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="OrderResponseItemDetail" type="OrderResponseItemDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfOrderResponsePackageDetailType

ListOfOrderResponsePackageDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OrderResponsePackageDetail[OrderResponsePackageDetailType]+ )

    Description: ListOfOrderResponsePackageDetailType holds response information for the package detail information.

    Elements:

    • OrderResponsePackageDetail - contains response information for the package detail. This includes a response code for the package detail and elements to repeat the original package detail and to change the package detail.

[^]Code Fragment

    <xsd:complexType name="ListOfOrderResponsePackageDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="OrderResponsePackageDetail" type="OrderResponsePackageDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfOrderStatusItemType

ListOfOrderStatusItemType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OrderStatusItem[OrderStatusItemType]+ )

    Description: ListOfOrderStatusItemType is a container holding the line item information.

    Elements:

    • OrderStatusItem - contains item detail information for the OrderStatusRequest.

[^]Code Fragment

    <xsd:complexType name="ListOfOrderStatusItemType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="OrderStatusItem" type="OrderStatusItemType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfOrderStatusRequestDetailType

ListOfOrderStatusRequestDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OrderStatusRequestDetail[OrderStatusRequestDetailType]+ )

    Description: ListOfOrderStatusRequestDetailType contains the list of order status request details.

    Elements:

    • OrderStatusRequestDetail - contains the order status detail information.

[^]Code Fragment

    <xsd:complexType name="ListOfOrderStatusRequestDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="OrderStatusRequestDetail" type="OrderStatusRequestDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfOrderStatusResultDetailType

ListOfOrderStatusResultDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OrderStatusResultDetail[OrderStatusResultDetailType]+ )

    Description: ListOfOrderStatusResultDetailType contains a list of line items for the OrderStatusResult

    Elements:

    • OrderStatusResultDetail - contains the OrderStatus detail information.

[^]Code Fragment

    <xsd:complexType name="ListOfOrderStatusResultDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="OrderStatusResultDetail" type="OrderStatusResultDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfOrderStatusResultItemType

ListOfOrderStatusResultItemType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OrderStatusResultItem[OrderStatusResultItemType]+ )

    Description: ListOfOrderStatusResultItemType contains a list of line items for the OrderStatusResult.

    Elements:

    • OrderStatusResultItem - contains the identifying and descriptive information for the line items in OrderStatusResult.

[^]Code Fragment

    <xsd:complexType name="ListOfOrderStatusResultItemType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="OrderStatusResultItem" type="OrderStatusResultItemType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfSplitQuantityType

ListOfSplitQuantityType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( SplitQuantity[SplitQuantityType]+ )

    Description: ListOfSplitQuantityType contains all of the quantity splits based on shipment.

    Elements:

    • SplitQuantity - contains the break out of the response quantity. The sum of the quantities specified here should add up to the response quantity given. The split only occurs when the shipment of an item is broken into different dates.

[^]Code Fragment

    <xsd:complexType name="ListOfSplitQuantityType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="SplitQuantity" type="SplitQuantityType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: OrderConfirmationActionCodeType

OrderConfirmationActionCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:
    describes the action of the order confirmation to be performed.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Other action in the confirmation to be performed.
    • Create - is the action "Create" to be performed in the order confirmation.
    • Update - is the action "Update" to be performed in the order confirmation.
    • Delete - is the action "Delete" to be performed in the order confirmation.

[^]Code Fragment

    <xsd:simpleType name="OrderConfirmationActionCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Create">
        <xsd:enumeration value="Update">
        <xsd:enumeration value="Delete">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: OrderConfirmationActionType

OrderConfirmationActionType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OrderConfirmationActionCoded[OrderConfirmationActionCodeType] , OrderConfirmationActionCodedOther[xsd:string]? )

    Description: OrderConfirmationActionType defines the action to be performed in the order confirmation. It can be Create (default value), Update, Delete or Other.

    Elements:

    • OrderConfirmationActionCoded - defines the action of the OrderConfirmation to be performed.
    • OrderConfirmationActionCodedOther - is used to provide a non-standard OrderConfirmationActionCode. This element is mandatory if the value of OrderConfirmationActionCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="OrderConfirmationActionType">
    <xsd:sequence>
        <xsd:element name="OrderConfirmationActionCoded" type="OrderConfirmationActionCodeType">
        <xsd:element minOccurs="0" name="OrderConfirmationActionCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderConfirmationDetailReferencesType

OrderConfirmationDetailReferencesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PurchaseOrderReference[core:PurchaseOrderReferenceType] , Category[core:CategoryType]? , CatalogReference[core:CatalogReferenceType]? , ContractAndSystemReference[ContractAndSystemReferenceType]? , ListOfReferenceCoded[core:ListOfReferenceCodedType]? )

    Description: OrderConfirmationDetailReferencesType contains the references of the item details in the order confirmation.

    Elements:

    • PurchaseOrderReference - is the reference to the purchase order.
    • Category - is the product category identified by a standard ID like UNSPSC or an ID of any other procurement system.
    • CatalogReference - is the reference to a catalog.
    • ContractAndSystemReference - is a reference including contract and system.
    • ListOfReferenceCoded - contains all other references for the confirmation detail section.

[^]Code Fragment

    <xsd:complexType name="OrderConfirmationDetailReferencesType">
    <xsd:sequence>
        <xsd:element name="PurchaseOrderReference" type="core:PurchaseOrderReferenceType">
        <xsd:element minOccurs="0" name="Category" type="core:CategoryType">
        <xsd:element minOccurs="0" name="CatalogReference" type="core:CatalogReferenceType">
        <xsd:element minOccurs="0" name="ContractAndSystemReference" type="ContractAndSystemReferenceType">
        <xsd:element minOccurs="0" name="ListOfReferenceCoded" type="core:ListOfReferenceCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderConfirmationDetailType

OrderConfirmationDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ListOfOrderConfirmationItemDetail[ListOfOrderConfirmationItemDetailType] )

    Description: OrderConfirmationDetailType contains the line item details of the order confirmation.

    Elements:

    • ListOfOrderConfirmationItemDetail - contains a list of line items for the order confirmation.

[^]Code Fragment

    <xsd:complexType name="OrderConfirmationDetailType">
    <xsd:sequence>
        <xsd:element name="ListOfOrderConfirmationItemDetail" type="ListOfOrderConfirmationItemDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderConfirmationHeaderType

OrderConfirmationHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( SellerOrderConfirmationNumber[xsd:string] , SellerOrderNumber[xsd:string] , OrderConfirmationIssueDate[xsd:dateTime] , OrderConfirmationType[OrderConfirmationTypeType]? , Language[core:LanguageType]? , Currency[core:CurrencyType]? , OrderConfirmationParty[OrderConfirmationPartyType]? , OrderConfirmationAction[OrderConfirmationActionType]? , OrderConfirmationHeaderShortDescription[core:AlphaNum40Type]? , OrderConfirmationHeaderNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? , ListOfAttachment[core:ListOfAttachmentType]? )

    Description: OrderConfirmationHeaderType contains the header info of the OrderConfirmation.

    Elements:

    • SellerOrderConfirmationNumber - is the document number issued by the seller of the OrderConfirmation.
    • SellerOrderNumber - is the purchase order number of the seller system. The OrderConfirmation refers to a purchase order.
    • OrderConfirmationIssueDate - is the issue date of the order confirmation. It is the date when the goods or services were provided.
    • OrderConfirmationType - is the type of the OrderConfirmation (confirmation, return delivery).
    • Language - is the language of the OrderConfirmation.
    • Currency - is the currency of the OrderConfirmation.
    • OrderConfirmationParty - holds all party information related to the OrderConfirmationn.
    • OrderConfirmationAction -
    • OrderConfirmationHeaderShortDescription - is the short description of the OrderConfirmation.
    • OrderConfirmationHeaderNote - describes any free form text pertinent to the entire document described by the OrderConfirmation or to the OrderConfirmation message itself. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. Such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfNameValueSet -
    • ListOfAttachment - is a container that holds one or more Attachment elements.

[^]Code Fragment

    <xsd:complexType name="OrderConfirmationHeaderType">
    <xsd:sequence>
        <xsd:element name="SellerOrderConfirmationNumber" type="xsd:string">
        <xsd:element name="SellerOrderNumber" type="xsd:string">
        <xsd:element name="OrderConfirmationIssueDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="OrderConfirmationType" type="OrderConfirmationTypeType">
        <xsd:element minOccurs="0" name="Language" type="core:LanguageType">
        <xsd:element minOccurs="0" name="Currency" type="core:CurrencyType">
        <xsd:element minOccurs="0" name="OrderConfirmationParty" type="OrderConfirmationPartyType">
        <xsd:element minOccurs="0" name="OrderConfirmationAction" type="OrderConfirmationActionType">
        <xsd:element minOccurs="0" name="OrderConfirmationHeaderShortDescription" type="core:AlphaNum40Type">
        <xsd:element minOccurs="0" name="OrderConfirmationHeaderNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
        <xsd:element minOccurs="0" name="ListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderConfirmationItemDetailType

OrderConfirmationItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OrderConfirmationItemNum[xsd:string] , OrderConfirmationAction[OrderConfirmationActionType]? , OrderConfirmationDetailShortDescription[core:AlphaNum40Type]? , OrderConfirmationDetailReferences[OrderConfirmationDetailReferencesType] , DeliveryComplete[xsd:boolean]? , ItemDetail[ItemDetailType] , ListOfAccountAssignment[ListOfAccountAssignmentType]? )

    Description: OrderConfirmationItemDetailType contains details of the item for the order confirmation.

    Elements:

    • OrderConfirmationItemNum - uniquely identifies the item within the context of the order confirmation document.
    • OrderConfirmationAction -
    • OrderConfirmationDetailShortDescription - is the short description of the item detail of the order confirmation.
    • OrderConfirmationDetailReferences - contains the references of the item detail of the order confirmation.
    • DeliveryComplete -
    • ItemDetail - contains all or a subset of the details of the item, including any changes (such as the quantity) , from the order which is being referenced.
    • ListOfAccountAssignment - contains all account assignment information related to the item.

[^]Code Fragment

    <xsd:complexType name="OrderConfirmationItemDetailType">
    <xsd:sequence>
        <xsd:element name="OrderConfirmationItemNum" type="xsd:string">
        <xsd:element minOccurs="0" name="OrderConfirmationAction" type="OrderConfirmationActionType">
        <xsd:element minOccurs="0" name="OrderConfirmationDetailShortDescription" type="core:AlphaNum40Type">
        <xsd:element name="OrderConfirmationDetailReferences" type="OrderConfirmationDetailReferencesType">
        <xsd:element minOccurs="0" name="DeliveryComplete" type="xsd:boolean">
        <xsd:element name="ItemDetail" type="ItemDetailType">
        <xsd:element minOccurs="0" name="ListOfAccountAssignment" type="ListOfAccountAssignmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderConfirmationPartyType

OrderConfirmationPartyType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( BuyerParty[core:PartyType]? , SellerParty[core:PartyType]? , ShipToParty[core:PartyType]? , ListOfPartyCoded[core:ListOfPartyCodedType]? )

    Description: OrderConfirmationPartyType holds all party information related to the order confirmation.

    Elements:

    • BuyerParty - contains the information for the party purchasing goods or services.
    • SellerParty - identifies the party selling the goods or services.
    • ShipToParty - contains party information identifying the location where the items were sold.
    • ListOfPartyCoded - is a collection of all other party information not explicitly stated as the content of another element.

[^]Code Fragment

    <xsd:complexType name="OrderConfirmationPartyType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="BuyerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="SellerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ShipToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ListOfPartyCoded" type="core:ListOfPartyCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderConfirmationResponseDetailType

OrderConfirmationResponseDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OrderConfirmationItemNum[xsd:string] , BuyerOrderConfirmationItemNum[xsd:string] , OrderConfirmationResponseCode[core:BasicResponseCodeType]? , OrderConfirmationResponseCodedOther[xsd:string]? , ListOfAccountAssignment[ListOfAccountAssignmentType]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ErrorInfo[core:ErrorInfoType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? )

    Description: OrderConfirmationResponseDetailType contains the line item details of the OrderConfirmationResponse.

    Elements:

    • OrderConfirmationItemNum - is the ID of the order confirmation item in the seller system.
    • BuyerOrderConfirmationItemNum - is the ID of the order confirmation item in the buyer system.
    • OrderConfirmationResponseCode -
    • OrderConfirmationResponseCodedOther - is used to provide a non-standard OrderConfirmationResponseCode. This element is mandatory if the value of OrderConfirmationResponseCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • ListOfAccountAssignment - contains all account assignment information related to the item.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. Such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ErrorInfo - contains error information related to the processing of the item referenced.
    • ListOfNameValueSet - contains a collection of name and value sets, which can be freely defined by the user.

[^]Code Fragment

    <xsd:complexType name="OrderConfirmationResponseDetailType">
    <xsd:sequence>
        <xsd:element name="OrderConfirmationItemNum" type="xsd:string">
        <xsd:element name="BuyerOrderConfirmationItemNum" type="xsd:string">
        <xsd:element minOccurs="0" name="OrderConfirmationResponseCode" type="core:BasicResponseCodeType">
        <xsd:element minOccurs="0" name="OrderConfirmationResponseCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfAccountAssignment" type="ListOfAccountAssignmentType">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ErrorInfo" type="core:ErrorInfoType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderConfirmationResponseHeaderType

OrderConfirmationResponseHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( BuyerOrderConfirmationID[xsd:string] , SellerOrderConfirmationReference[core:ReferenceType] , OrderConfirmationResponseIssueDate[xsd:dateTime]? , OrderConfirmationType[OrderConfirmationTypeType]? , OrderConfirmationResponseCoded[core:BasicResponseCodeType] , OrderConfirmationResponseCodedOther[xsd:string]? , Language[core:LanguageType] , OrderConfirmationResponseParty[OrderConfirmationResponsePartyType] , OrderConfirmationResponseHeaderNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ErrorInfo[core:ErrorInfoType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? , ListOfAttachment[core:ListOfAttachmentType]? )

    Description: OrderConfirmationResponseHeaderType contains the header info of the OrderConfirmationResponse.

    Elements:

    • BuyerOrderConfirmationID - is the confirmation number of the order confirmation response in the buyer system.
    • SellerOrderConfirmationReference - contains the ID and issue date of a confirmation that for the OrderConfirmationResponse in the supplier system.
    • OrderConfirmationResponseIssueDate - is the date that the order confirmation response was created.
    • OrderConfirmationType - is the type of the order confirmation (confirmation, return delivery).
    • OrderConfirmationResponseCoded - is the response code. The confirmation can be rejected or accepted by the order confirmation response.
    • OrderConfirmationResponseCodedOther - is used to provide a non-standard OrderConfirmationResponseCode. This element is mandatory if the value of OrderConfirmationResponseCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • Language - is the language of the OrderConfirmationResponse.
    • OrderConfirmationResponseParty - holds all party information related to the OrderConfirmationResponse.
    • OrderConfirmationResponseHeaderNote - contains a note or description of the OrderConfirmationResponseHeader.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. Such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ErrorInfo - contains error information related to the processing of the header or the order confirmation.
    • ListOfNameValueSet - contains a collection of name and value sets, which can be freely defined by the user.
    • ListOfAttachment - is container that holds one or more Attachment elements.

[^]Code Fragment

    <xsd:complexType name="OrderConfirmationResponseHeaderType">
    <xsd:sequence>
        <xsd:element name="BuyerOrderConfirmationID" type="xsd:string">
        <xsd:element name="SellerOrderConfirmationReference" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="OrderConfirmationResponseIssueDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="OrderConfirmationType" type="OrderConfirmationTypeType">
        <xsd:element name="OrderConfirmationResponseCoded" type="core:BasicResponseCodeType">
        <xsd:element minOccurs="0" name="OrderConfirmationResponseCodedOther" type="xsd:string">
        <xsd:element name="Language" type="core:LanguageType">
        <xsd:element name="OrderConfirmationResponseParty" type="OrderConfirmationResponsePartyType">
        <xsd:element minOccurs="0" name="OrderConfirmationResponseHeaderNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ErrorInfo" type="core:ErrorInfoType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
        <xsd:element minOccurs="0" name="ListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderConfirmationResponsePartyType

OrderConfirmationResponsePartyType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( BuyerParty[core:PartyType] , SellerParty[core:PartyType] , ListOfPartyCoded[core:ListOfPartyCodedType]? )

    Description: OrderConfirmationResponsePartyType holds all party information related to the order confirmation response.

    Elements:

    • BuyerParty - contains the information for the party purchasing services.
    • SellerParty - identifies the party selling services.
    • ListOfPartyCoded - is a collection of all other party information not explicitly stated as the content of another element.

[^]Code Fragment

    <xsd:complexType name="OrderConfirmationResponsePartyType">
    <xsd:sequence>
        <xsd:element name="BuyerParty" type="core:PartyType">
        <xsd:element name="SellerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ListOfPartyCoded" type="core:ListOfPartyCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderConfirmationResponseType

OrderConfirmationResponseType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OrderConfirmationResponseHeader[OrderConfirmationResponseHeaderType] , ListOfOrderConfirmationResponseDetail[ListOfOrderConfirmationResponseDetailType]? )

    Description: OrderConfirmationResponseType is used to respond to an OrderConfirmation. This document details whether the OrderConfirmation was accepted or rejected.

    Elements:

    • OrderConfirmationResponseHeader -
    • ListOfOrderConfirmationResponseDetail -

[^]Code Fragment

    <xsd:complexType name="OrderConfirmationResponseType">
    <xsd:sequence>
        <xsd:element name="OrderConfirmationResponseHeader" type="OrderConfirmationResponseHeaderType">
        <xsd:element minOccurs="0" name="ListOfOrderConfirmationResponseDetail" type="ListOfOrderConfirmationResponseDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderConfirmationType

OrderConfirmationType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OrderConfirmationHeader[OrderConfirmationHeaderType] , OrderConfirmationDetail[OrderConfirmationDetailType] )

    Description: OrderConfirmationType describes the confirmation of the purchase of goods or services. A supplier system sends the confirmation to an e-procurement system as a confirmation for already provided services or delivered goods. The confirmation usually refers to a purchase order.

    Elements:

    • OrderConfirmationHeader - contains the header information of an OrderConfirmation.
    • OrderConfirmationDetail - contains the detail information of an OrderConfirmation.

[^]Code Fragment

    <xsd:complexType name="OrderConfirmationType">
    <xsd:sequence>
        <xsd:element name="OrderConfirmationHeader" type="OrderConfirmationHeaderType">
        <xsd:element name="OrderConfirmationDetail" type="OrderConfirmationDetailType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: OrderConfirmationTypeCodeType

OrderConfirmationTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Other type of confirmation
    • OrderConfirmation - is of type order confirmation
    • ReturnDelivery - is of type return delivery

[^]Code Fragment

    <xsd:simpleType name="OrderConfirmationTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="OrderConfirmation">
        <xsd:enumeration value="ReturnDelivery">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: OrderConfirmationTypeType

OrderConfirmationTypeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OrderConfirmationTypeCoded[OrderConfirmationTypeCodeType] , OrderConfirmationTypeCodedOther[xsd:string]? )

    Description: OrderConfirmationTypeType defines the type of order confirmation

    Elements:

    • OrderConfirmationTypeCoded - defines the type of confirmation to be performed.
    • OrderConfirmationTypeCodedOther - is used to provide a non-standard OrderConfirmationTypeCode. This element is mandatory if the value of OrderConfirmationTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="OrderConfirmationTypeType">
    <xsd:sequence>
        <xsd:element name="OrderConfirmationTypeCoded" type="OrderConfirmationTypeCodeType">
        <xsd:element minOccurs="0" name="OrderConfirmationTypeCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderDatesType

OrderDatesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( RequestedShipByDate[xsd:dateTime]? , RequestedDeliverByDate[xsd:dateTime]? , PromiseDate[xsd:dateTime]? , ValidityDates[core:ValidityDatesType]? , CancelByDate[xsd:dateTime]? , ListOfDateCoded[core:ListOfDateCodedType]? )

    Description: OrderDatesType is used to hold a list of the pertinent dates for the purchase order dates will include validity dates, RequestedShipDate, CancelByDates, among others. These dates act as defaults that may be overwritten at the item level or package level in the body of the message.

    Elements:

    • RequestedShipByDate - is the date items in the purchase order must be shipped from the seller.
    • RequestedDeliverByDate - is the date items in the purchase order must be received by the buyer.
    • PromiseDate - is used mainly for confirming orders when a date was promised by the supplier over the phone.
    • ValidityDates - contains the dates between which the Order is effective.
    • CancelByDate - is the date after which Order should be cancelled.
    • ListOfDateCoded - contains all other dates not for the Order not explicitly stated as the content of other elements.

[^]Code Fragment

    <xsd:complexType name="OrderDatesType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="RequestedShipByDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="RequestedDeliverByDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="PromiseDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ValidityDates" type="core:ValidityDatesType">
        <xsd:element minOccurs="0" name="CancelByDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ListOfDateCoded" type="core:ListOfDateCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderDetailType

OrderDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ListOfItemDetail[ListOfItemDetailType] , ListOfPackageDetail[core:ListOfPackageDetailType]? )

    Description: OrderDetailType contains the line item and package details of the Order.

    Elements:

    • ListOfItemDetail - contains a list of line items for the Order.
    • ListOfPackageDetail - contains a list of package details for the Order.

[^]Code Fragment

    <xsd:complexType name="OrderDetailType">
    <xsd:sequence>
        <xsd:element name="ListOfItemDetail" type="ListOfItemDetailType">
        <xsd:element minOccurs="0" name="ListOfPackageDetail" type="core:ListOfPackageDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderHeaderType

OrderHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OrderNumber[OrderNumberType] , OrderIssueDate[xsd:dateTime] , OrderReferences[OrderReferencesType]? , ReleaseNumber[xsd:string]? , Purpose[core:PurposeType]? , RequestedResponse[core:RequestedResponseType]? , OrderType[core:OrderTypeType]? , OrderCurrency[core:CurrencyType] , TaxAccountingCurrency[core:CurrencyType]? , OrderLanguage[core:LanguageType] , OrderTaxReference[core:TaxReferenceType]* , OrderInvoiceMediumTypeCoded[OrderInvoiceMediumTypeCodeType]? , OrderInvoiceMediumTypeCodedOther[xsd:string]? , OrderDates[OrderDatesType]? , PartialShipmentAllowed[xsd:boolean]? , OrderParty[OrderPartyType] , PartLocation[xsd:string]? , ListOfTransportRouting[core:ListOfTransportRoutingType]? , OrderTermsOfDelivery[core:TermsOfDeliveryType]* , OrderHeaderPrice[core:ListOfPriceType]? , OrderPaymentInstructions[core:PaymentInstructionsType]? , OrderAllowancesOrCharges[core:ListOfAllowOrChargeType]? , RoundTripInformation[core:RoundTripInformationType]? , OrderHeaderNote[xsd:string]? , SpecialHandling[core:SpecialHandlingType]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? , OrderHeaderAttachments[core:ListOfAttachmentType]? )

    Description: OrderHeaderType contains the header information of the order.

    Elements:

    • OrderNumber - is the unique number assigned to the Order, typically according to the system that generated the Order.
    • OrderIssueDate - holds a time stamp provided by the application that created the Order document.
    • OrderReferences - contains external references to the Order that are important to the processing and use of the Order.
    • ReleaseNumber - is the element used if the purchase order is a release against the document specified in the ContractReference under the order reference.
    • Purpose - is used to communicate the purpose of the Order.
    • RequestedResponse - specifies the type of acknowledgment requested by the buyer from the seller.
    • OrderType - identifies the type of Order being transmitted.
    • OrderCurrency - identifies the default currency of the Order, which when used at the header level may be overwritten at the lower level within the structure.
    • TaxAccountingCurrency - identifies the tax accounting currency for the Order if different than the OrderCurrency .
    • OrderLanguage - identifies the language of the Order.
    • OrderTaxReference - identifies the default tax information for the Order
    • OrderInvoiceMediumTypeCoded - is used to describe the type of invoice required for this Order.
    • OrderInvoiceMediumTypeCodedOther - is used to provide a non-standard OrderInvoiceMediumTypeCode. This element is mandatory if the value of OrderInvoiceMediumTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • OrderDates - is used to hold a list of the pertinent dates for the Order - dates include validity dates, RequestedShipDate, CancelByDates, among others. These dates apply to the entire order, acting as defaults and that may be overwritten at the item level or package level in the body of the message.
    • PartialShipmentAllowed - is a flag that indicates whether less than the entirety of the order can be shipped.
    • OrderParty - holds information on the parties for the Order, including unique ID's and address information.
    • PartLocation - is used when a supplier has multiple warehouses.
    • ListOfTransportRouting - provides information on the movement of the goods including carrier, equipment and service level instructions.
    • OrderTermsOfDelivery - defines the terms of delivery for the Order.
    • OrderHeaderPrice - is the pricing information for the Order. This is the default price and can be overwritten at the item level.
    • OrderPaymentInstructions - holds the payment instructions for the Order.
    • OrderAllowancesOrCharges - contains the allowances and/or charges for the whole Order. These may include goods and shipping charges. Additional allowance or charges may be present at lower levels of the Order.
    • RoundTripInformation - identifies information specific to the round trip order process for the entire order. This element should only be used if the ordering process for this entire order is round trip.
    • OrderHeaderNote - describes any free form text pertinent to the entire document described by the Order or to the Order message itself. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • SpecialHandling - descibes any special handling conditions that apply to the enitre order.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfNameValueSet - is used to hold sets of name value pairs. The use of this element should be limited to the support of previous versions of xCBL.
    • OrderHeaderAttachments - holds a list of attachments applicable to the entire Order, or a large part of the consignment it describes. This information is not specific to a particular line item or package unless specifically noted.

[^]Code Fragment

    <xsd:complexType name="OrderHeaderType">
    <xsd:sequence>
        <xsd:element name="OrderNumber" type="OrderNumberType">
        <xsd:element name="OrderIssueDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="OrderReferences" type="OrderReferencesType">
        <xsd:element minOccurs="0" name="ReleaseNumber" type="xsd:string">
        <xsd:element minOccurs="0" name="Purpose" type="core:PurposeType">
        <xsd:element minOccurs="0" name="RequestedResponse" type="core:RequestedResponseType">
        <xsd:element minOccurs="0" name="OrderType" type="core:OrderTypeType">
        <xsd:element name="OrderCurrency" type="core:CurrencyType">
        <xsd:element minOccurs="0" name="TaxAccountingCurrency" type="core:CurrencyType">
        <xsd:element name="OrderLanguage" type="core:LanguageType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="OrderTaxReference" type="core:TaxReferenceType">
        <xsd:element minOccurs="0" name="OrderInvoiceMediumTypeCoded" type="OrderInvoiceMediumTypeCodeType">
        <xsd:element minOccurs="0" name="OrderInvoiceMediumTypeCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="OrderDates" type="OrderDatesType">
        <xsd:element minOccurs="0" name="PartialShipmentAllowed" type="xsd:boolean">
        <xsd:element name="OrderParty" type="OrderPartyType">
        <xsd:element minOccurs="0" name="PartLocation" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfTransportRouting" type="core:ListOfTransportRoutingType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="OrderTermsOfDelivery" type="core:TermsOfDeliveryType">
        <xsd:element minOccurs="0" name="OrderHeaderPrice" type="core:ListOfPriceType">
        <xsd:element minOccurs="0" name="OrderPaymentInstructions" type="core:PaymentInstructionsType">
        <xsd:element minOccurs="0" name="OrderAllowancesOrCharges" type="core:ListOfAllowOrChargeType">
        <xsd:element minOccurs="0" name="RoundTripInformation" type="core:RoundTripInformationType">
        <xsd:element minOccurs="0" name="OrderHeaderNote" type="xsd:string">
        <xsd:element minOccurs="0" name="SpecialHandling" type="core:SpecialHandlingType">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
        <xsd:element minOccurs="0" name="OrderHeaderAttachments" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: OrderInvoiceMediumTypeCodeType

OrderInvoiceMediumTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • Circuitswitching - A process that, on demand, connects two or more data terminal equipment and permits the exclusive use of a data circuit between them until the connection is released (ISO).
    • SITA - Communications number assigned by Societe Internationale de Telecommunications Aeronautiques (SITA).
    • ARINC - Communications number assigned by Aeronautical Radio Inc.
    • Courier - A communication channel identifying a courier.
    • CableAddress
    • EDITransmission - Number identifying the service and service user.
    • ElectronicMail - Exchange of mail by electronic means.
    • Extension - Telephone extension.
    • FileTransferAccessMethod - According to ISO.
    • TeleFax - Device used for transmitting and reproducing fixed graphic material (as printing) by means of signals over telephone lines or other electronic transmission media.
    • GEISMailbox - General Electric Information Service
    • IBMInformationExchange
    • InternalMail - Internal mail address/number.
    • Mail - Postal service document delivery.
    • PostBoxNo
    • PacketSwitching - The process of routing and transferring data by means of addressed packets so that a channel is occupied only during the transmission; upon completion of the transmission the channel is made available for the transfer of other packets (ISO).
    • SWIFT - Communications address assigned by Society for Worldwide Interbank Financial Telecommunications s.c.
    • Telephone - Voice/data transmission by telephone.
    • Telegraph - Text transmission via telegraph.
    • Telex - Transmission of text/data via telex.
    • TeleMail - Transmission of text/data via telemail.
    • TeleText - Transmission of text/data via teletext.
    • TWX - Communication service involving Teletypewriter machines connected by wire or electronic transmission media. Teletypewriter machines are the devices used to send and receive signals and produce hardcopy from them.
    • X.400 - CCITT Message handling system.
    • NotRequired

[^]Code Fragment

    <xsd:simpleType name="OrderInvoiceMediumTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Circuitswitching">
        <xsd:enumeration value="SITA">
        <xsd:enumeration value="ARINC">
        <xsd:enumeration value="Courier">
        <xsd:enumeration value="CableAddress">
        <xsd:enumeration value="EDITransmission">
        <xsd:enumeration value="ElectronicMail">
        <xsd:enumeration value="Extension">
        <xsd:enumeration value="FileTransferAccessMethod">
        <xsd:enumeration value="TeleFax">
        <xsd:enumeration value="GEISMailbox">
        <xsd:enumeration value="IBMInformationExchange">
        <xsd:enumeration value="InternalMail">
        <xsd:enumeration value="Mail">
        <xsd:enumeration value="PostBoxNo">
        <xsd:enumeration value="PacketSwitching">
        <xsd:enumeration value="SWIFT">
        <xsd:enumeration value="Telephone">
        <xsd:enumeration value="Telegraph">
        <xsd:enumeration value="Telex">
        <xsd:enumeration value="TeleMail">
        <xsd:enumeration value="TeleText">
        <xsd:enumeration value="TWX">
        <xsd:enumeration value="X.400">
        <xsd:enumeration value="NotRequired">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: OrderNumberType

OrderNumberType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( BuyerOrderNumber[xsd:string] , SellerOrderNumber[xsd:string]? )

    Description: OrderNumberType is a unique number assigned to the Order in respect to the parties assigning the number.

    Elements:

    • BuyerOrderNumber - is the unique number assigned by the buyer to the Order.
    • SellerOrderNumber - is the unique number assigned by the seller to the Order.

[^]Code Fragment

    <xsd:complexType name="OrderNumberType">
    <xsd:sequence>
        <xsd:element name="BuyerOrderNumber" type="xsd:string">
        <xsd:element minOccurs="0" name="SellerOrderNumber" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderPartyType

OrderPartyType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( BuyerParty[core:PartyType] , SellerParty[core:PartyType] , ShipToParty[core:PartyType]? , BillToParty[core:PartyType]? , RemitToParty[core:PartyType]? , ShipFromParty[core:PartyType]? , WarehouseParty[core:PartyType]? , SoldToParty[core:PartyType]? , ManufacturingParty[core:PartyType]? , MaterialIssuer[core:PartyType]? , ListOfPartyCoded[core:ListOfPartyCodedType]? )

    Description: OrderPartyType holds all party information related to ordering goods.

    Elements:

    • BuyerParty - contains the information for the party purchasing the goods.
    • SellerParty - identifies the party selling the goods.
    • ShipToParty - contains the information for the party which the items are to be shipped.
    • BillToParty - contains the information for the party that will receive the bill for the goods..
    • RemitToParty - contains the information for the party to be paid.
    • ShipFromParty - contains party information identifying the location from which the items are to be shipped.
    • WarehouseParty - contains party information identifying the warehouse from which the items are to be shipped.
    • SoldToParty - contains party information identifying the location where the items were sold.
    • ManufacturingParty - contains the party information identifying the location where the item is to be or is being manufactured.
    • MaterialIssuer - contains the information identifying the location that is issuing the request for the material.
    • ListOfPartyCoded - is a collection of all other party information not explicitly stated as the content of another element.

[^]Code Fragment

    <xsd:complexType name="OrderPartyType">
    <xsd:sequence>
        <xsd:element name="BuyerParty" type="core:PartyType">
        <xsd:element name="SellerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ShipToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="BillToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="RemitToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ShipFromParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="WarehouseParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="SoldToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ManufacturingParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="MaterialIssuer" type="core:PartyType">
        <xsd:element minOccurs="0" name="ListOfPartyCoded" type="core:ListOfPartyCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderReferencesType

OrderReferencesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( AccountCode[core:ReferenceType]? , ContractReferences[core:ListOfContractType]? , QuoteReference[core:ReferenceType]? , RequisitionReference[core:ReferenceType]? , ListOfCostCenter[core:ListOfCostCenterType]? , OtherOrderReferences[core:ListOfReferenceCodedType]? )

    Description: OrderReferencesType defines the references for the Order.

    Elements:

    • AccountCode - is the unique identification assigned to the buyer by the seller. This is used for reference purposes in the transaction. For example, Buyer Company A has a standing account with Seller Company B, which is assigned the identification of A-127654, therefore A-127654 would be the AccountCode.
    • ContractReferences - is an element that holds the contract number and contract type for referencing a contract. This element can also be used to hold a reference to a standing order. In this case do not use the ContractType field.
    • QuoteReference - refers to a Quote ID or Shopping Cart ID.
    • RequisitionReference - references a requisition in an ERP system which created this order.
    • ListOfCostCenter - identifies all cost center information, and if applicable, the split to each different cost center for the entire order. If a quantity is used to show the split, it is assumed to be the default quantity for each item on the order, and can be overwritten. If a a percent or monetary amount is used, it is assumed to be in relation to the entire amount of the order, included any taxes, allowances, or charges.
    • OtherOrderReferences - is all other references to the Order not explicitly stated as the content of other elements.

[^]Code Fragment

    <xsd:complexType name="OrderReferencesType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="AccountCode" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="ContractReferences" type="core:ListOfContractType">
        <xsd:element minOccurs="0" name="QuoteReference" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="RequisitionReference" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="ListOfCostCenter" type="core:ListOfCostCenterType">
        <xsd:element minOccurs="0" name="OtherOrderReferences" type="core:ListOfReferenceCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderRequestHeaderType

OrderRequestHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OrderRequestNumber[OrderRequestNumberType]? , OrderRequestIssueDate[xsd:dateTime] , OrderRequestReferences[OrderReferencesType]? , Purpose[core:PurposeType]? , RequestedResponse[core:RequestedResponseType]? , OrderRequestCurrency[core:CurrencyType] , TaxAccountingCurrency[core:CurrencyType]? , OrderRequestLanguage[core:LanguageType] , OrderRequestTaxReference[core:TaxReferenceType]? , OrderInvoiceMediumTypeCoded[OrderInvoiceMediumTypeCodeType]? , OrderInvoiceMediumTypeCodedOther[xsd:string]? , OrderRequestDates[OrderDatesType]? , PartialShipmentAllowed[xsd:boolean]? , OrderRequestParty[OrderRequestPartyType] , PartLocation[xsd:string]? , ListOfTransportRouting[core:ListOfTransportRoutingType]? , OrderTermsOfDelivery[core:TermsOfDeliveryType]* , OrderHeaderPrice[core:ListOfPriceType]? , OrderPaymentInstructions[core:PaymentInstructionsType]? , OrderAllowancesOrCharges[core:ListOfAllowOrChargeType]? , RoundTripInformation[core:RoundTripInformationType]? , OrderHeaderNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? , OrderHeaderAttachments[core:ListOfAttachmentType]? )

    Description: OrderRequestHeaderType contains the header information of the OrderRequest.

    Elements:

    • OrderRequestNumber - is the unique number assigned to the OrderRequest in respect to the parties assigning the number.
    • OrderRequestIssueDate - holds a digital time stamp provided by the application that created the OrderRequest document.
    • OrderRequestReferences - is used to hold a list of all other documents pertinent to this OrderRequest.
    • Purpose - is used to communicate the purpose of the OrderRequest document.
    • RequestedResponse - specifies the type of acknowledgment requested by the buyer from the seller.
    • OrderRequestCurrency - identifies the default currency of the OrderRequest, which when used at the header level may be overwritten at a lower level within the structure at line item level.
    • TaxAccountingCurrency - identifies the currency to be used for tax accounting purposes. This element is mandatory when the tax accounting currency is not the same as the InvoiceCurrency.
    • OrderRequestLanguage - identifies the language of the document.
    • OrderRequestTaxReference - identifies the default tax information for the order.
    • OrderInvoiceMediumTypeCoded - is used to describe the type of invoice required for this purchase order.
    • OrderInvoiceMediumTypeCodedOther - is used to provide a non-standard OrderInvoiceMediumTypeCode. This element is mandatory if the value of OrderInvoiceMediumTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • OrderRequestDates - is used to hold a list of the pertinent dates for the purchase order. Dates include validity dates, RequestedShipDate, CancelByDates, among others. These dates are global and apply to the entire order.
    • PartialShipmentAllowed - is a flag that indicates whether the less than the entirety of the order can be shipped.
    • OrderRequestParty - holds information on the parties for the OrderRequest, including unique ID's and address information.
    • PartLocation - is used when a supplier has multiple warehouses.
    • ListOfTransportRouting - provides information on the movement of the goods including carrier, equipment and service level instructions.
    • OrderTermsOfDelivery - defines the terms of delivery for the Order.
    • OrderHeaderPrice - is the pricing information for the Order. This can be overwritten at the item level.
    • OrderPaymentInstructions - holds the payment instructions of the Order.
    • OrderAllowancesOrCharges - request or identifies a service, promotion, allowance, or charge; to specify the amount or percentage for the service, promotion, allowance, or charge.
    • RoundTripInformation - identifies information specific to the round trip order process for the entire order request. This element should only be used if the ordering process for this entire order request is round trip.
    • OrderHeaderNote - contains any free-form text pertinent to the entire Order. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfNameValueSet - is used to hold sets of name value pairs. The use of this element should be limited to the support of previous versions of xCBL.
    • OrderHeaderAttachments - contains a list of attachments applicable to the entire Order. The information is not specific to a particular line item or package, unless specifically noted.

[^]Code Fragment

    <xsd:complexType name="OrderRequestHeaderType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="OrderRequestNumber" type="OrderRequestNumberType">
        <xsd:element name="OrderRequestIssueDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="OrderRequestReferences" type="OrderReferencesType">
        <xsd:element minOccurs="0" name="Purpose" type="core:PurposeType">
        <xsd:element minOccurs="0" name="RequestedResponse" type="core:RequestedResponseType">
        <xsd:element name="OrderRequestCurrency" type="core:CurrencyType">
        <xsd:element minOccurs="0" name="TaxAccountingCurrency" type="core:CurrencyType">
        <xsd:element name="OrderRequestLanguage" type="core:LanguageType">
        <xsd:element minOccurs="0" name="OrderRequestTaxReference" type="core:TaxReferenceType">
        <xsd:element minOccurs="0" name="OrderInvoiceMediumTypeCoded" type="OrderInvoiceMediumTypeCodeType">
        <xsd:element minOccurs="0" name="OrderInvoiceMediumTypeCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="OrderRequestDates" type="OrderDatesType">
        <xsd:element minOccurs="0" name="PartialShipmentAllowed" type="xsd:boolean">
        <xsd:element name="OrderRequestParty" type="OrderRequestPartyType">
        <xsd:element minOccurs="0" name="PartLocation" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfTransportRouting" type="core:ListOfTransportRoutingType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="OrderTermsOfDelivery" type="core:TermsOfDeliveryType">
        <xsd:element minOccurs="0" name="OrderHeaderPrice" type="core:ListOfPriceType">
        <xsd:element minOccurs="0" name="OrderPaymentInstructions" type="core:PaymentInstructionsType">
        <xsd:element minOccurs="0" name="OrderAllowancesOrCharges" type="core:ListOfAllowOrChargeType">
        <xsd:element minOccurs="0" name="RoundTripInformation" type="core:RoundTripInformationType">
        <xsd:element minOccurs="0" name="OrderHeaderNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
        <xsd:element minOccurs="0" name="OrderHeaderAttachments" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderRequestNumberType

OrderRequestNumberType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( BuyerOrderRequestNumber[xsd:string] , SellerOrderRequestNumber[xsd:string]? )

    Description: OrderRequestNumberType is the unique number assigned to the PurchaseOrder in respect to the parties assigning the number.

    Elements:

    • BuyerOrderRequestNumber - is the unique number assigned by the buyer to this OrderRequest.
    • SellerOrderRequestNumber - is he unique number assigned by the seller to this OrderRequest.

[^]Code Fragment

    <xsd:complexType name="OrderRequestNumberType">
    <xsd:sequence>
        <xsd:element name="BuyerOrderRequestNumber" type="xsd:string">
        <xsd:element minOccurs="0" name="SellerOrderRequestNumber" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderRequestPartyType

OrderRequestPartyType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( BuyerParty[core:PartyType]? , SellerParty[core:PartyType] , ShipToParty[core:PartyType]? , BillToParty[core:PartyType]? , RemitToParty[core:PartyType]? , ShipFromParty[core:PartyType]? , ListOfPartyCoded[core:ListOfPartyCodedType]? )

    Description: OrderRequestPartyType holds information on the parties for the OrderRequest, including unique ID's and address information.

    Elements:

    • BuyerParty - contains the information for the entity purchasing the goods.
    • SellerParty - contains the information for the entity selling the goods.
    • ShipToParty - is the party that is receiving the goods or services.
    • BillToParty - describes the party to receive the invoice.
    • RemitToParty - contains the information for the party will be paid..
    • ShipFromParty - contains party information identifying the location from which the items are to be shipped.
    • ListOfPartyCoded - contains information relevant to describing parties other than the source target parties which are relevant to the time series data.

[^]Code Fragment

    <xsd:complexType name="OrderRequestPartyType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="BuyerParty" type="core:PartyType">
        <xsd:element name="SellerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ShipToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="BillToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="RemitToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ShipFromParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ListOfPartyCoded" type="core:ListOfPartyCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderRequestType

OrderRequestType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OrderRequestHeader[OrderRequestHeaderType] , OrderRequestDetail[OrderDetailType]? , OrderRequestSummary[OrderSummaryType]? )

    Description: OrderRequestType comprises ordering information that is a result of a buyer's inquiry to purchase. A supplier initiates an OrderRequest to a requisitioner that is a result of a buyer's inquiry into a purchase of the supplier's goods. The requisitioner's approval of this OrderRequest results in the creation of a purchase order. There is not a response to the OrderRequest. Any changes to the OrderRequest will be represented in the Order.

    Elements:

    • OrderRequestHeader - contains the header information of the OrderRequest.
    • OrderRequestDetail - is the container element to hold line item and package item details.
    • OrderRequestSummary - contains the summary information of the OrderRequest, typically totals of numerical fields.

[^]Code Fragment

    <xsd:complexType name="OrderRequestType">
    <xsd:sequence>
        <xsd:element name="OrderRequestHeader" type="OrderRequestHeaderType">
        <xsd:element minOccurs="0" name="OrderRequestDetail" type="OrderDetailType">
        <xsd:element minOccurs="0" name="OrderRequestSummary" type="OrderSummaryType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderResponseDetailType

OrderResponseDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ListOfOrderResponseItemDetail[ListOfOrderResponseItemDetailType]? , ListOfOrderResponsePackageDetail[ListOfOrderResponsePackageDetailType]? )

    Description: OrderResponseDetailType is an optional section used to repeat the detail section of the Order as it is, make changes to line item details or packaging details, or both. This should be used in accordance with the OrderHeaderResponseCode selected in the OrderResponseHeader.

    Elements:

    • ListOfOrderResponseItemDetail - contains a list of response information for one or more line item details.
    • ListOfOrderResponsePackageDetail - holds response information for the package detail information.

[^]Code Fragment

    <xsd:complexType name="OrderResponseDetailType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ListOfOrderResponseItemDetail" type="ListOfOrderResponseItemDetailType">
        <xsd:element minOccurs="0" name="ListOfOrderResponsePackageDetail" type="ListOfOrderResponsePackageDetailType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: OrderResponseDocTypeCodeType

OrderResponseDocTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other
    • OrderResponse
    • ChangeOrderResponse

[^]Code Fragment

    <xsd:simpleType name="OrderResponseDocTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="OrderResponse">
        <xsd:enumeration value="ChangeOrderResponse">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: OrderResponseHeaderType

OrderResponseHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OrderResponseNumber[OrderResponseNumberType] , OrderResponseIssueDate[xsd:dateTime] , OrderResponseDocTypeCoded[OrderResponseDocTypeCodeType] , OrderResponseDocTypeCodedOther[xsd:string]? , OrderReference[core:ReferenceType] , ChangeOrderReference[core:ReferenceType]? , SellerParty[core:PartyType] , BuyerParty[core:PartyType] , TrackingURL[xsd:anyURI]? , ListOfReferenceCoded[core:ListOfReferenceCodedType]? , Purpose[core:PurposeType]? , ResponseType[core:ResponseTypeType] , ShipmentStatusEvent[core:ShipmentStatusEventType]? , PaymentStatusEvent[core:StatusType]? , OriginalOrderHeaderWithChanges[OrderHeaderType]? , OrderResponseHeaderNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? )

    Description: OrderResponseHeaderType contains the header information of the OrderResponse.

    Elements:

    • OrderResponseNumber - is the unique number that identifies the OrderResponse, typically according to the system that generated the OrderResponse.
    • OrderResponseIssueDate - holds a time stamp provided by the application that created the OrderResponse.
    • OrderResponseDocTypeCoded - identifies the type of OrderResponse being sent.
    • OrderResponseDocTypeCodedOther - is used to provide a non-standard OrderResponseDocTypeCode. This element is mandatory if the value of OrderResponseDocTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • OrderReference - is the purchase order number that the OrderResponse document is referencing. This includes the number and the date of the purchase order.
    • ChangeOrderReference - is used for tracking purposes only. If the document is in response to a ChangeOrder, the ChangeOrderResponse document transmission can be identified here.
    • SellerParty - contains the information for the party selling the goods.
    • BuyerParty - contains the information for the entity purchasing the goods.
    • TrackingURL - provides a URL for tracking the shipment of the goods contained in an entire order.
    • ListOfReferenceCoded - contains all other references for the OrderResponse not explicitly stated as the content of other elements.
    • Purpose - is used to communicate the purpose of the document.
    • ResponseType - identifies the action the seller has taken on the buyer's order. This is used to communicate whether the seller has accepted or rejected the buyer's order. This is the only element that can be used to communicate this information, and only values that communicate such information should be used.
    • ShipmentStatusEvent - communicates any shipping status information pertaining to the entire order. This element is used for informational purposes only, and is used by the seller to communicate shipment specific status information to the buyer. For instance, the seller can use this element to inform the buyer that the order has already been shipped.
    • PaymentStatusEvent - communicates any payment status information pertaining to the entire order. This element is used for informational purposes only, and is used by the seller to communicate payment specific status information to the buyer. For instance, the seller can use this element to inform the buyer that an invoice has already been created for this order.
    • OriginalOrderHeaderWithChanges - is used to make any changes to the OrderHeader.
    • OrderResponseHeaderNote - contains any free form text pertinent to the entire OrderResponse. This element may contain notes or other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.

[^]Code Fragment

    <xsd:complexType name="OrderResponseHeaderType">
    <xsd:sequence>
        <xsd:element name="OrderResponseNumber" type="OrderResponseNumberType">
        <xsd:element name="OrderResponseIssueDate" type="xsd:dateTime">
        <xsd:element name="OrderResponseDocTypeCoded" type="OrderResponseDocTypeCodeType">
        <xsd:element minOccurs="0" name="OrderResponseDocTypeCodedOther" type="xsd:string">
        <xsd:element name="OrderReference" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="ChangeOrderReference" type="core:ReferenceType">
        <xsd:element name="SellerParty" type="core:PartyType">
        <xsd:element name="BuyerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="TrackingURL" type="xsd:anyURI">
        <xsd:element minOccurs="0" name="ListOfReferenceCoded" type="core:ListOfReferenceCodedType">
        <xsd:element minOccurs="0" name="Purpose" type="core:PurposeType">
        <xsd:element name="ResponseType" type="core:ResponseTypeType">
        <xsd:element minOccurs="0" name="ShipmentStatusEvent" type="core:ShipmentStatusEventType">
        <xsd:element minOccurs="0" name="PaymentStatusEvent" type="core:StatusType">
        <xsd:element minOccurs="0" name="OriginalOrderHeaderWithChanges" type="OrderHeaderType">
        <xsd:element minOccurs="0" name="OrderResponseHeaderNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderResponseItemDetailType

OrderResponseItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ItemDetailResponseCoded[core:DetailResponseCodeType] , ItemDetailResponseCodedOther[xsd:string]? , ShipmentStatusEvent[core:ShipmentStatusEventType]? , PaymentStatusEvent[core:StatusType]? , PriceErrorInfo[core:ErrorInfoType]? , AvailabilityErrorInfo[core:ErrorInfoType]? , ListOfErrorInfo[core:ListOfErrorInfoType]? , TrackingURL[xsd:anyURI]? , ListOfReferenceCoded[core:ListOfReferenceCodedType]? , OriginalItemDetailWithChanges[OriginalItemDetailWithChangesType] , LineItemNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? )

    Description: OrderResponseItemDetailType holds response information for a line item, any references for that line item, and the relevant response to that line item. Applications will be expected to return any line items with any changes and generally all of the accepted line items as well. Any line item not present in this section that was found in the original order will be assumed to be accepted as is.

    Elements:

    • ItemDetailResponseCoded - is used to communicate the action taken by the seller on the item. This is element is to be used by the seller to communicate if an item has been accepted or rejected. Values not relating specifically to the action taken on the item should not be used here. This is the only place that the seller's action on the item can be communicated.
    • ItemDetailResponseCodedOther - is used to provide a non-standard DetailResponseTypeCode. This element is mandatory if the value of DetailResponseTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • ShipmentStatusEvent - communicates any shipping status information pertaining to the entire item. Only values pertaining the shipment specific information should be used for the status code. Shipment status pertaining to only part of the item should be communicated in the ScheduleLine element. A seller can use this to inform the buyer that an item has been shipped.
    • PaymentStatusEvent - communicates any payment status information pertaining to the entire item. Only values pertaining the payment specific information should be used for the status code. Payment status pertaining to only part of the item should be communicated in the ScheduleLine element.
    • PriceErrorInfo - is optional error information related to price.
    • AvailabilityErrorInfo - is optional error information related to quantity.
    • ListOfErrorInfo - contains all other error information not explicitly stated as the content of other elements.
    • TrackingURL - provides a URL for tracking the shipment of an item.
    • ListOfReferenceCoded - contains one or more elements containing information that can be used to find further information elsewhere that are not explicitly stated in another element.
    • OriginalItemDetailWithChanges - is used to make changes to a line item detail. Note: If a change is made to a line item, the entire line item must be completely repeated again. if this is not used, then either OriginalItemDetail or ChangeOrderItemDetail must be used.
    • LineItemNote - describes any free-form text pertinent to the line item described by the OrderResponse. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.

[^]Code Fragment

    <xsd:complexType name="OrderResponseItemDetailType">
    <xsd:sequence>
        <xsd:element name="ItemDetailResponseCoded" type="core:DetailResponseCodeType">
        <xsd:element minOccurs="0" name="ItemDetailResponseCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="ShipmentStatusEvent" type="core:ShipmentStatusEventType">
        <xsd:element minOccurs="0" name="PaymentStatusEvent" type="core:StatusType">
        <xsd:element minOccurs="0" name="PriceErrorInfo" type="core:ErrorInfoType">
        <xsd:element minOccurs="0" name="AvailabilityErrorInfo" type="core:ErrorInfoType">
        <xsd:element minOccurs="0" name="ListOfErrorInfo" type="core:ListOfErrorInfoType">
        <xsd:element minOccurs="0" name="TrackingURL" type="xsd:anyURI">
        <xsd:element minOccurs="0" name="ListOfReferenceCoded" type="core:ListOfReferenceCodedType">
        <xsd:element name="OriginalItemDetailWithChanges" type="OriginalItemDetailWithChangesType">
        <xsd:element minOccurs="0" name="LineItemNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderResponseNumberType

OrderResponseNumberType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( BuyerOrderResponseNumber[xsd:string] , SellerOrderResponseNumber[xsd:string]? )

    Description: OrderResponseNumberType is the unique number that identifies the OrderResponse, typically according to the system that generated the OrderResponse.

    Elements:

    • BuyerOrderResponseNumber - is the unique number assigned by the buyer to this OrderResponse.
    • SellerOrderResponseNumber - is the unique number assigned by the seller to this OrderResponse.

[^]Code Fragment

    <xsd:complexType name="OrderResponseNumberType">
    <xsd:sequence>
        <xsd:element name="BuyerOrderResponseNumber" type="xsd:string">
        <xsd:element minOccurs="0" name="SellerOrderResponseNumber" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderResponsePackageDetailType

OrderResponsePackageDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PackageDetailResponseCoded[core:DetailResponseCodeType] , PackageDetailResponseCodedOther[xsd:string]? , OriginalPackageDetailWithChanges[core:PackageDetailType]? , PackageDetailNote[xsd:string]? )

    Description: OrderResponsePackageDetailType contains response information for the package detail. This includes a response code for the package detail and elements to repeat the original PackageDetail and to change the PackageDetail.

    Elements:

    • PackageDetailResponseCoded - contains the response for the PackageDetail.
    • PackageDetailResponseCodedOther - is used to provide a non-standard DetailResponseCode. This element is mandatory if the value of DetailResponseCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • OriginalPackageDetailWithChanges - is used to make changes to the PackageDetail. Note: If a change is made to a package detail line, the entire package detail line must be completed again to reflect the changes made.
    • PackageDetailNote - contains any free form text pertinent to the package. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.. This could be used to explicitly state the changes that were made to the PackageDetail.

[^]Code Fragment

    <xsd:complexType name="OrderResponsePackageDetailType">
    <xsd:sequence>
        <xsd:element name="PackageDetailResponseCoded" type="core:DetailResponseCodeType">
        <xsd:element minOccurs="0" name="PackageDetailResponseCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="OriginalPackageDetailWithChanges" type="core:PackageDetailType">
        <xsd:element minOccurs="0" name="PackageDetailNote" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderResponseSummaryType

OrderResponseSummaryType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ErrorInfo[core:ErrorInfoType]? , OriginalOrderSummary[OrderSummaryType]? , RevisedOrderSummary[OrderSummaryType]? )

    Description: OrderResponseSummaryType contains the summary information of the OrderResponse.

    Elements:

    • ErrorInfo - is a container for the error details.
    • OriginalOrderSummary - is used to show the old OrderSummary for comparison purposes, if needed.
    • RevisedOrderSummary - is the summary section that reflects any changes made to the order.

[^]Code Fragment

    <xsd:complexType name="OrderResponseSummaryType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ErrorInfo" type="core:ErrorInfoType">
        <xsd:element minOccurs="0" name="OriginalOrderSummary" type="OrderSummaryType">
        <xsd:element minOccurs="0" name="RevisedOrderSummary" type="OrderSummaryType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderResponseType

OrderResponseType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OrderResponseHeader[OrderResponseHeaderType] , OrderResponseDetail[OrderResponseDetailType]? , OrderResponseSummary[OrderResponseSummaryType]? , DigitalSignature[dgs:SignatureType]? )

    Description: OrderResponseType is used to respond at the application level to an order or change order that has been received.

    Elements:

    • OrderResponseHeader - contains the header information of the OrderResponse.
    • OrderResponseDetail - is an optional section used to repeat the detail section of the Order as it is, make changes to line item details or packaging details, or both. This should be used in accordance with the OrderHeaderResponseCode selected in the OrderResponseHeader.
    • OrderResponseSummary - contains the summary information of the OrderResponse.
    • DigitalSignature - contains a digital signature for the document.

[^]Code Fragment

    <xsd:complexType name="OrderResponseType">
    <xsd:sequence>
        <xsd:element name="OrderResponseHeader" type="OrderResponseHeaderType">
        <xsd:element minOccurs="0" name="OrderResponseDetail" type="OrderResponseDetailType">
        <xsd:element minOccurs="0" name="OrderResponseSummary" type="OrderResponseSummaryType">
        <xsd:element minOccurs="0" name="DigitalSignature" type="dgs:SignatureType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: OrderStatusEventCodeType

OrderStatusEventCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:
    This code identifies the status of the event.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom code
    • NoInfo
    • NewOrder
    • Accepted
    • NotAccepted
    • Processing
    • Completed
    • Cancelled
    • PrepaymentRequired

[^]Code Fragment

    <xsd:simpleType name="OrderStatusEventCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="NoInfo">
        <xsd:enumeration value="NewOrder">
        <xsd:enumeration value="Accepted">
        <xsd:enumeration value="NotAccepted">
        <xsd:enumeration value="Processing">
        <xsd:enumeration value="Completed">
        <xsd:enumeration value="Cancelled">
        <xsd:enumeration value="PrepaymentRequired">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: OrderStatusItemType

OrderStatusItemType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( LineItemNum[core:LineItemNumType] , LineItemType[core:LineItemTypeType]? , ParentItemNumber[core:LineItemNumberReferenceType]? , ItemIdentifiers[core:ItemIdentifiersType]? , QuantityLeftToRecieve[core:QuantityType] , OrderedQuantity[core:QuantityType]? , MaxBackOrderQuantity[core:QuantityType]? , BaseItemReferences[core:BaseItemReferencesType]? )

    Description: OrderStatusItemType contains item detail information for the OrderStatusRequest.

    Elements:

    • LineItemNum - is a set of numbers uniquely identifying the line item for the number. In the case where the seller's system splits a line item number into 2 line items, the buyer item number will remain the same for both line items, but the seller item number will be different.
    • LineItemType - identifies whether the line item is a component group (consists of other line items), a typical line item, or a textual line item.
    • ParentItemNumber - identifies the line item that groups this and other line items. This is done using LineItemNumberReference, which specifies the number of the parent line item and whether this reference is the Buyer or Seller's number. LineItemNumberReference is a string content model of datatype integer that contains an attribute to specify whether the ParentItemNumber is a Seller or Buyer number, with the default being Buyer. This value references the parent item represented a group.
    • ItemIdentifiers - details all of the part numbers assigned to the item.
    • QuantityLeftToRecieve - is the quantity of the item that is left to be recieved
    • OrderedQuantity - contains the quantity of the item originally ordered.
    • MaxBackOrderQuantity - specifies the maximum quantity of an item that a customer will allow to be back ordered.
    • BaseItemReferences - contains all reference information for the item.

[^]Code Fragment

    <xsd:complexType name="OrderStatusItemType">
    <xsd:sequence>
        <xsd:element name="LineItemNum" type="core:LineItemNumType">
        <xsd:element minOccurs="0" name="LineItemType" type="core:LineItemTypeType">
        <xsd:element minOccurs="0" name="ParentItemNumber" type="core:LineItemNumberReferenceType">
        <xsd:element minOccurs="0" name="ItemIdentifiers" type="core:ItemIdentifiersType">
        <xsd:element name="QuantityLeftToRecieve" type="core:QuantityType">
        <xsd:element minOccurs="0" name="OrderedQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="MaxBackOrderQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="BaseItemReferences" type="core:BaseItemReferencesType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderStatusReferenceType

OrderStatusReferenceType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( BuyerReferenceNumber[xsd:string] , SellerReferenceNumber[xsd:string] , AccountCode[core:ReferenceType]? , OtherReference[core:ListOfReferenceCodedType]? , OrderDate[xsd:dateTime] , ListOfOrderStatusItem[ListOfOrderStatusItemType]? )

    Description: OrderStatusReferenceType identifies the order the status is being requested for.

    Elements:

    • BuyerReferenceNumber - holds the purchase order number assigned by the buyer.
    • SellerReferenceNumber - holds the seller's order number.
    • AccountCode - holds the unique identification assigned to the buyer by the seller.
    • OtherReference - provides any other reference to the order.
    • OrderDate - provides the date of the order.
    • ListOfOrderStatusItem - is a container holding the line item information.

[^]Code Fragment

    <xsd:complexType name="OrderStatusReferenceType">
    <xsd:sequence>
        <xsd:element name="BuyerReferenceNumber" type="xsd:string">
        <xsd:element name="SellerReferenceNumber" type="xsd:string">
        <xsd:element minOccurs="0" name="AccountCode" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="OtherReference" type="core:ListOfReferenceCodedType">
        <xsd:element name="OrderDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ListOfOrderStatusItem" type="ListOfOrderStatusItemType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderStatusRequestDetailType

OrderStatusRequestDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OrderStatusReference[OrderStatusReferenceType] , GeneralLineItemNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , LineItemAttachment[core:ListOfAttachmentType]? )

    Description: OrderStatusRequestDetailType contains the line item and package detail for the OrderStatusRequest.

    Elements:

    • OrderStatusReference - identifies the order the status is being requested for.
    • GeneralLineItemNote - contains any free-form text pertinent to the line item in OrderStatusRequest. This element may contain notes or any other similar information that is not contained explicitly in another structure. It should not be assumed that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • LineItemAttachment - contains details of the attachments for the OrderStatusRequest item.

[^]Code Fragment

    <xsd:complexType name="OrderStatusRequestDetailType">
    <xsd:sequence>
        <xsd:element name="OrderStatusReference" type="OrderStatusReferenceType">
        <xsd:element minOccurs="0" name="GeneralLineItemNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="LineItemAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderStatusRequestHeaderType

OrderStatusRequestHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OrderStatusRequestID[xsd:string] , OrderStatusIssueDate[xsd:dateTime] , BuyerParty[core:PartyType] , SellerParty[core:PartyType] , OrderStatusLanguage[core:LanguageType]? , OrderStatusRequestNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , OrderStatusListOfAttachment[core:ListOfAttachmentType]? )

    Description: OrderStatusRequestHeaderType holds all OrderStatusRequest header-level information. This element occurs once within the document.

    Elements:

    • OrderStatusRequestID - contains a reference number to identify the OrderStatusRequest document. This value can be used for internal audit purposes. Possible values for the ID are GUIDs, internal tracking numbers, or system generated numbers. This reference number should not be needed for document correlation purposes since this is a synchronous transaction. It is valid for the OrderStatusRequestID and the OrderStatusID from the OrderStatusResult to be the same value. For applications that do not require this type of document identification, a dummy value can be used as a default for the OrderStatusRequestID.
    • OrderStatusIssueDate - indicates the date the OrderStatusRequest is transmitted.
    • BuyerParty - contains the information for the party purchasing the goods.
    • SellerParty - identifies the party selling the goods.
    • OrderStatusLanguage - identifies the language for OrderStatusRequest.
    • OrderStatusRequestNote - contains any free-form text pertinent to the entire OrderStatusRequest. This element may contain notes or any other similar information that is not contained explicitly in another structure. It should not be assumed that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • OrderStatusListOfAttachment - contains a list of attachments applicable to the entire OrderStatusRequest. The information is not specific to a particular line item or package, unless specifically noted.

[^]Code Fragment

    <xsd:complexType name="OrderStatusRequestHeaderType">
    <xsd:sequence>
        <xsd:element name="OrderStatusRequestID" type="xsd:string">
        <xsd:element name="OrderStatusIssueDate" type="xsd:dateTime">
        <xsd:element name="BuyerParty" type="core:PartyType">
        <xsd:element name="SellerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="OrderStatusLanguage" type="core:LanguageType">
        <xsd:element minOccurs="0" name="OrderStatusRequestNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="OrderStatusListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderStatusRequestType

OrderStatusRequestType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OrderStatusRequestHeader[OrderStatusRequestHeaderType] , ListOfOrderStatusRequestDetail[ListOfOrderStatusRequestDetailType] )

    Description: OrderStatusRequestType is the root element for requesting the status of an Order. OrderStatusRequest is sent from a buyer to a supplier. The request is only used to request the status of goods.

    Elements:

    • OrderStatusRequestHeader - holds all OrderStatusRequest header-level information. This element occurs once within the document.
    • ListOfOrderStatusRequestDetail - contains the list of order status request details.

[^]Code Fragment

    <xsd:complexType name="OrderStatusRequestType">
    <xsd:sequence>
        <xsd:element name="OrderStatusRequestHeader" type="OrderStatusRequestHeaderType">
        <xsd:element name="ListOfOrderStatusRequestDetail" type="ListOfOrderStatusRequestDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderStatusResultDetailType

OrderStatusResultDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OrderStatusResultReference[OrderStatusResultReferenceType] , GeneralLineItemNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , LineItemAttachment[core:ListOfAttachmentType]? )

    Description: OrderStatusResultDetailType contains the detail information for the OrderStatusResult.

    Elements:

    • OrderStatusResultReference - contains external references to the OrderStatusResult that are important to the processing and use of the OrderStatusResult
    • GeneralLineItemNote - contains any free-form text pertinent to the line item in OrderStatusResult. This element may contain notes or any other similar information that is not contained explicitly in another structure. it should not be assumed that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • LineItemAttachment - contains details of the attachments for the OrderStatusResult item.

[^]Code Fragment

    <xsd:complexType name="OrderStatusResultDetailType">
    <xsd:sequence>
        <xsd:element name="OrderStatusResultReference" type="OrderStatusResultReferenceType">
        <xsd:element minOccurs="0" name="GeneralLineItemNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="LineItemAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderStatusResultHeaderType

OrderStatusResultHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OrderStatusID[xsd:string] , OrderStatusIssueDate[xsd:dateTime] , BuyerParty[core:PartyType] , SellerParty[core:PartyType] , OrderStatusResultLanguage[core:LanguageType]? , OrderStatusResultNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ResultListOfAttachment[core:ListOfAttachmentType]? )

    Description: OrderStatusResultHeaderType holds all OrderStatusResult header-level information. This element occurs once within the document.

    Elements:

    • OrderStatusID - contains a reference number to identify the OrderStatusResult document. This value can be used for internal audit purposes. Possible values for the ID are GUIDs, internal tracking numbers, or system generated numbers. This reference number should not be needed for document correlation purposes since this is a synchronous transaction. It is valid for the OrderStatusID and the OrderStatusRequestID from the OrderStatusRequest to be the same value. For applications that do not require this type of document identification, a dummy value can be used as a default for the OrderStatusRequestID.
    • OrderStatusIssueDate - indicates the date for which status was requested.
    • BuyerParty - contains the information for the party purchasing the goods.
    • SellerParty - identifies the party selling the goods.
    • OrderStatusResultLanguage - identifies the language of the OrderStatusResult.
    • OrderStatusResultNote - contains any free-form text pertinent to the entire OrderStatusResult. This element may contain notes or any other similar information that is not contained explicitly in another structure. It should not be assumed that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ResultListOfAttachment - contains a list of attachments applicable to the entire OrderStatusResult. The information is not specific to a particular line item or package, unless specifically noted.

[^]Code Fragment

    <xsd:complexType name="OrderStatusResultHeaderType">
    <xsd:sequence>
        <xsd:element name="OrderStatusID" type="xsd:string">
        <xsd:element name="OrderStatusIssueDate" type="xsd:dateTime">
        <xsd:element name="BuyerParty" type="core:PartyType">
        <xsd:element name="SellerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="OrderStatusResultLanguage" type="core:LanguageType">
        <xsd:element minOccurs="0" name="OrderStatusResultNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ResultListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderStatusResultItemType

OrderStatusResultItemType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( LineItemNum[core:LineItemNumType] , LineItemType[core:LineItemTypeType]? , ParentItemNumber[core:LineItemNumberReferenceType]? , ItemIdentifiers[core:ItemIdentifiersType]? , QuantityLeftToRecieve[core:QuantityType] , OrderedQuantity[core:QuantityType]? , ItemStatus[ItemStatusType]+ , MaxBackOrderQuantity[core:QuantityType]? , BaseItemReferences[core:BaseItemReferencesType]? )

    Description: OrderStatusResultItemType contains the identifying and descriptive information for the line items in OrderStatusResult.

    Elements:

    • LineItemNum - is a set of numbers uniquely identifying the line item for the number. In the case where the seller's system splits a line item number into 2 line items, the buyer item number will remain the same for both line items, but the seller item number will be different.
    • LineItemType - identifies whether the line item is a component group (consists of other line items), a typical line item, or a textual line item.
    • ParentItemNumber - identifies the line item that groups this and other line items. This is done using LineItemNumberReference, which specifies the number of the parent line item and whether this reference is the Buyer or Seller's number. LineItemNumberReference is a string content model of datatype integer that contains an attribute to specify whether the ParentItemNumber is a Seller or Buyer number, with the default being Buyer. This value references the parent item represented a group.
    • ItemIdentifiers - details all of the part numbers assigned to the item.
    • QuantityLeftToRecieve - is the quantity of the item that is left to be recieved
    • OrderedQuantity - contains the quantity of the item originally ordered.
    • ItemStatus - provides information about the status of the line item.
    • MaxBackOrderQuantity - specifies the maximum quantity of an item that a customer will allow to be back ordered.
    • BaseItemReferences - contains all reference information for the item.

[^]Code Fragment

    <xsd:complexType name="OrderStatusResultItemType">
    <xsd:sequence>
        <xsd:element name="LineItemNum" type="core:LineItemNumType">
        <xsd:element minOccurs="0" name="LineItemType" type="core:LineItemTypeType">
        <xsd:element minOccurs="0" name="ParentItemNumber" type="core:LineItemNumberReferenceType">
        <xsd:element minOccurs="0" name="ItemIdentifiers" type="core:ItemIdentifiersType">
        <xsd:element name="QuantityLeftToRecieve" type="core:QuantityType">
        <xsd:element minOccurs="0" name="OrderedQuantity" type="core:QuantityType">
        <xsd:element maxOccurs="unbounded" name="ItemStatus" type="ItemStatusType">
        <xsd:element minOccurs="0" name="MaxBackOrderQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="BaseItemReferences" type="core:BaseItemReferencesType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderStatusResultReferenceType

OrderStatusResultReferenceType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( BuyerReferenceNumber[xsd:string] , SellerReferenceNumber[xsd:string] , AccountCode[core:ReferenceType]? , OtherReference[core:ListOfReferenceCodedType]? , OrderDate[xsd:dateTime] , OrderStatusDate[xsd:dateTime] , OrderStatus[core:StatusType] , PaymentStatusEvent[core:StatusType]? , ShipmentStatusEvent[core:ShipmentStatusEventType]? , ListOfOrderStatusResultItem[ListOfOrderStatusResultItemType]? )

    Description: OrderStatusResultReferenceType contains external references to the OrderStatusResult that are important to the processing and use of the OrderStatusResult

    Elements:

    • BuyerReferenceNumber - holds the purchase order number assigned by the buyer.
    • SellerReferenceNumber - holds the sellers order number.
    • AccountCode - holds the unique identification assigned to the buyer by the seller.
    • OtherReference - provides any other reference to the order.
    • OrderDate - holds the date of the order.
    • OrderStatusDate - holds the date of the result of the status request.
    • OrderStatus - provides the status details.
    • PaymentStatusEvent - provides payment status information relating to the entire order.
    • ShipmentStatusEvent - provides shipment status information relating to the entire order.
    • ListOfOrderStatusResultItem - contains a list of line items for the OrderStatusResult.

[^]Code Fragment

    <xsd:complexType name="OrderStatusResultReferenceType">
    <xsd:sequence>
        <xsd:element name="BuyerReferenceNumber" type="xsd:string">
        <xsd:element name="SellerReferenceNumber" type="xsd:string">
        <xsd:element minOccurs="0" name="AccountCode" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="OtherReference" type="core:ListOfReferenceCodedType">
        <xsd:element name="OrderDate" type="xsd:dateTime">
        <xsd:element name="OrderStatusDate" type="xsd:dateTime">
        <xsd:element name="OrderStatus" type="core:StatusType">
        <xsd:element minOccurs="0" name="PaymentStatusEvent" type="core:StatusType">
        <xsd:element minOccurs="0" name="ShipmentStatusEvent" type="core:ShipmentStatusEventType">
        <xsd:element minOccurs="0" name="ListOfOrderStatusResultItem" type="ListOfOrderStatusResultItemType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderStatusResultType

OrderStatusResultType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OrderStatusResultHeader[OrderStatusResultHeaderType] , ListOfOrderStatusResultDetail[ListOfOrderStatusResultDetailType] )

    Description: OrderStatusResultType is the root element that holds the OrderStatusResult response to an OrderStatusRequest. This element occurs once within the document.

    Elements:

    • OrderStatusResultHeader - holds all OrderStatusResult header-level information. This element occurs once within the document.
    • ListOfOrderStatusResultDetail - contains a list of line items for the OrderStatusResult

[^]Code Fragment

    <xsd:complexType name="OrderStatusResultType">
    <xsd:sequence>
        <xsd:element name="OrderStatusResultHeader" type="OrderStatusResultHeaderType">
        <xsd:element name="ListOfOrderStatusResultDetail" type="ListOfOrderStatusResultDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderSummaryType

OrderSummaryType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( NumberOfLines[xsd:int]? , ListOfTaxSummary[core:ListOfTaxSummaryType]? , AllowOrChargeSummary[core:AllowOrChargeSummaryType]? , OrderSubTotal[core:MonetaryValueType]? , OrderTotal[core:MonetaryValueType]? , TransportPackagingTotals[core:TransportPackagingTotalsType]? , SummaryNote[xsd:string]? )

    Description: OrderSummaryType contains the summary information of the Order, typically totals of numerical fields.

    Elements:

    • NumberOfLines - identifies the number of line items.
    • ListOfTaxSummary - contains the summary of the tax information specified within the Invoice. This element is mandatory if tax elements occur in either the invoice header or any invoice detail item line.
    • AllowOrChargeSummary - contains the summary amounts, for each category of the allowance or charge.
    • OrderSubTotal - contains the sub total for all items on the order. This should be the sum of the sub totals of all items, not including taxes, allowances, or charges.
    • OrderTotal - contains the total price for the entire order, including all taxes, allowances, and charges.
    • TransportPackagingTotals - is a summary of transport and packaging information if included in the Order.
    • SummaryNote - contains any free form text for the OrderSummary. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.

[^]Code Fragment

    <xsd:complexType name="OrderSummaryType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="NumberOfLines" type="xsd:int">
        <xsd:element minOccurs="0" name="ListOfTaxSummary" type="core:ListOfTaxSummaryType">
        <xsd:element minOccurs="0" name="AllowOrChargeSummary" type="core:AllowOrChargeSummaryType">
        <xsd:element minOccurs="0" name="OrderSubTotal" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="OrderTotal" type="core:MonetaryValueType">
        <xsd:element minOccurs="0" name="TransportPackagingTotals" type="core:TransportPackagingTotalsType">
        <xsd:element minOccurs="0" name="SummaryNote" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OrderType

OrderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( OrderHeader[OrderHeaderType] , OrderDetail[OrderDetailType]? , OrderSummary[OrderSummaryType]? , DigitalSignature[dgs:SignatureType]? )

    Description: OrderType comprises the creation of a purchase order that is sent for acceptance or rejection by a seller. A requisitioner, buyer, or buying organization can initiate an Order in response to a variety of factors in the electronic business arena, contracts, auctions, order requests, etc. A requisitioner, or buyer, can initiate a change to an already existing order. A seller uses the OrderResponse document to accept or reject an Order or a changed order.

    Elements:

    • OrderHeader - contains the header information of the Order.
    • OrderDetail - contains the line item and package details of the Order.
    • OrderSummary - contains the summary information of the Order, typically totals of numerical fields.
    • DigitalSignature - contains a digital signature for the document.

[^]Code Fragment

    <xsd:complexType name="OrderType">
    <xsd:sequence>
        <xsd:element name="OrderHeader" type="OrderHeaderType">
        <xsd:element minOccurs="0" name="OrderDetail" type="OrderDetailType">
        <xsd:element minOccurs="0" name="OrderSummary" type="OrderSummaryType">
        <xsd:element minOccurs="0" name="DigitalSignature" type="dgs:SignatureType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: OriginalItemDetailWithChangesType

OriginalItemDetailWithChangesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( BaseItemDetail[ResponseBaseItemDetailType] , PricingDetail[core:PricingDetailType]? , DeliveryDetail[ResponseDeliveryDetailType]? , RoundTripInformation[core:RoundTripInformationType]? , LineItemNote[xsd:string]? , SpecialHandling[core:SpecialHandlingType]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfNameValueSet[core:ListOfNameValueSetType]? , LineItemAttachments[core:ListOfAttachmentType]? )

    Description: OriginalItemDetailWithChangesType contains information to describe and identify an item along with all pricing and delivery information for that item.

    Elements:

    • BaseItemDetail - identifies the line item for the document. This contains the description, specific identifiers, weights, measures and other information associated with the product.
    • PricingDetail - contains all pricing information, including taxes, allowances and charges, and total price for an item.
    • DeliveryDetail - is used to specify the scheduling information for a distinct set of ship from party, ship to party, and transport information for the line item.
    • RoundTripInformation - identifies information specific to the round trip order process for the item. This element should only be used if the ordering process for this item is round trip.
    • LineItemNote - describes any free form text pertinent to the line item. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • SpecialHandling - descibes any special handling conditions that apply to the item.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. Such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfNameValueSet - is used to hold sets of name value pairs. The use of this element should be limited to the support of previous versions of xCBL.
    • LineItemAttachments - contains attachments for the line item.

[^]Code Fragment

    <xsd:complexType name="OriginalItemDetailWithChangesType">
    <xsd:sequence>
        <xsd:element name="BaseItemDetail" type="ResponseBaseItemDetailType">
        <xsd:element minOccurs="0" name="PricingDetail" type="core:PricingDetailType">
        <xsd:element minOccurs="0" name="DeliveryDetail" type="ResponseDeliveryDetailType">
        <xsd:element minOccurs="0" name="RoundTripInformation" type="core:RoundTripInformationType">
        <xsd:element minOccurs="0" name="LineItemNote" type="xsd:string">
        <xsd:element minOccurs="0" name="SpecialHandling" type="core:SpecialHandlingType">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfNameValueSet" type="core:ListOfNameValueSetType">
        <xsd:element minOccurs="0" name="LineItemAttachments" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ResponseBaseItemDetailType

ResponseBaseItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( LineItemNum[core:LineItemNumType] , LineItemType[core:LineItemTypeType]? , ParentItemNumber[core:LineItemNumberReferenceType]? , ItemIdentifiers[core:ItemIdentifiersType]? , ListOfDimension[core:ListOfDimensionType]? , ResponseQuantity[core:QuantityType] , OrderedQuantity[core:QuantityType]? , ListOfQuantityCoded[core:ListOfQuantityCodedType]? , BaseItemReferences[core:BaseItemReferencesType]? , CountryOfOrigin[core:CountryType]? , CountryOfDestination[core:CountryType]? , FinalRecipient[core:PartyType]? , ListOfPartyCoded[core:ListOfPartyCodedType]? , ConditionsOfSale[core:ConditionsOfSaleType]? , HazardousMaterials[core:HazardousType]? )

    Description: ResponseBaseItemDetailType holds the basic item identification and quantities for the item that is being responded to.

    Elements:

    • LineItemNum - is a set of numbers uniquely identifying the line item for the number. In the case where the seller's system splits a line item number into 2 line items, the buyer item number will remain the same for both line items, but the seller item number will be different.
    • LineItemType - identifies whether the line item is a component group (consists of other line items), a typical line item, or a textual line item.
    • ParentItemNumber - identifies the line item that groups this and other line items. This is done using LineItemNumberReference, which specifies the number of the parent line item and whether this reference is the Buyer or Seller's number. LineItemNumberReference is a string content model of datatype integer that contains an attribute to specify whether the ParentItemNumber is a Seller or Buyer number, with the default being Buyer. This value references the parent item represented a group.
    • ItemIdentifiers - details all of the part numbers assigned to the item.
    • ListOfDimension - lists one or more quantitative measurements of the item.
    • ResponseQuantity - contains the quantity which applies to the ItemDetailResponseCoded element. For instance, if the code is Accepted, then this quantity is the quantity that has been accepted.
    • OrderedQuantity - sepcifies the original quantity ordered by the buyer. This should be used if the response quantity is different from the amount actually ordered by the buyer..
    • ListOfQuantityCoded - specifies any other quantities not explicitly stated.
    • BaseItemReferences - contains all reference information for the item.
    • CountryOfOrigin - specifies the country code for the country in which the line item was manufactured.
    • CountryOfDestination - specifies the country code for the country in which the delivery is finally received.
    • FinalRecipient - identifies the person or organization who will ultimately receive the item or items.
    • ListOfPartyCoded - specifies any other parties associated with the line item that are not already explicitly stated.
    • ConditionsOfSale - details the conditions of sale for the item.
    • HazardousMaterials - contains the hazardous information for the line item.

[^]Code Fragment

    <xsd:complexType name="ResponseBaseItemDetailType">
    <xsd:sequence>
        <xsd:element name="LineItemNum" type="core:LineItemNumType">
        <xsd:element minOccurs="0" name="LineItemType" type="core:LineItemTypeType">
        <xsd:element minOccurs="0" name="ParentItemNumber" type="core:LineItemNumberReferenceType">
        <xsd:element minOccurs="0" name="ItemIdentifiers" type="core:ItemIdentifiersType">
        <xsd:element minOccurs="0" name="ListOfDimension" type="core:ListOfDimensionType">
        <xsd:element name="ResponseQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="OrderedQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="ListOfQuantityCoded" type="core:ListOfQuantityCodedType">
        <xsd:element minOccurs="0" name="BaseItemReferences" type="core:BaseItemReferencesType">
        <xsd:element minOccurs="0" name="CountryOfOrigin" type="core:CountryType">
        <xsd:element minOccurs="0" name="CountryOfDestination" type="core:CountryType">
        <xsd:element minOccurs="0" name="FinalRecipient" type="core:PartyType">
        <xsd:element minOccurs="0" name="ListOfPartyCoded" type="core:ListOfPartyCodedType">
        <xsd:element minOccurs="0" name="ConditionsOfSale" type="core:ConditionsOfSaleType">
        <xsd:element minOccurs="0" name="HazardousMaterials" type="core:HazardousType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ResponseDeliveryDetailType

ResponseDeliveryDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ShipToLocation[core:LocationType]? , ShipFromLocation[core:LocationType]? , ListOfSplitQuantity[ListOfSplitQuantityType]? , ItemPackagingReference[core:ItemPackagingReferenceType]? , SimplePackageNote[xsd:string]? , TermsOfDelivery[core:TermsOfDeliveryType]* , CargoClassification[core:CargoClassificationType]? )

    Description: ResponseDeliveryDetailType is used to specify the scheduling information for a distinct set of ship from party, ship to party, and transport information for the line item

    Elements:

    • ShipToLocation - is the location to which the shipments are to be delivered.
    • ShipFromLocation - identifies the party from which the item is to be shipped from. This is only used if the ShipFromParty differs from that identified in the header.
    • ListOfSplitQuantity - is all of the schedule information relevant to the line item for the shipping parties. This may indicate several shipments to the same location over a period of time.
    • ItemPackagingReference - contains reference information when detailed packaging information contained in list of package detail is to be associated with the line item.
    • SimplePackageNote - is free form text relating to the packaging.
    • TermsOfDelivery - includes the information related to delivery including shipment method payment and transport.
    • CargoClassification - contains different conventions for the classification and description of the goods being transported.

[^]Code Fragment

    <xsd:complexType name="ResponseDeliveryDetailType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ShipToLocation" type="core:LocationType">
        <xsd:element minOccurs="0" name="ShipFromLocation" type="core:LocationType">
        <xsd:element minOccurs="0" name="ListOfSplitQuantity" type="ListOfSplitQuantityType">
        <xsd:element minOccurs="0" name="ItemPackagingReference" type="core:ItemPackagingReferenceType">
        <xsd:element minOccurs="0" name="SimplePackageNote" type="xsd:string">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="TermsOfDelivery" type="core:TermsOfDeliveryType">
        <xsd:element minOccurs="0" name="CargoClassification" type="core:CargoClassificationType">
    </xsd:sequence>
</xsd:complexType>


Simple Types:

OrderConfirmationActionCodeType
OrderConfirmationTypeCodeType
OrderInvoiceMediumTypeCodeType
OrderResponseDocTypeCodeType
OrderStatusEventCodeType


complexType definition: SplitQuantityType

SplitQuantityType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/ordermanagement/v1_0/ordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ShipmentStatusEventCoded[core:ShipmentStatusEventCodeType] , ShipmentStatusEventCodedOther[xsd:string]? , ShipmentStatusReasons[core:ListOfStatusReasonType]? , SplitQuantity[core:QuantityType] , ActualShipDate[xsd:dateTime]? , EstimatedShipDate[xsd:dateTime]? , ActualDeliveryDate[xsd:dateTime]? , EstimatedDeliveryDate[xsd:dateTime]? , ListOfOtherDeliveryDate[core:ListOfDateCodedType]? , SplitQuantityNote[xsd:string]? )

    Description: SplitQuantityType contains the break out of the response quantity. The sum of the quantities specified here should add up to the response quantity given. The split only occurs when the shipment of an item is broken into different dates.

    Elements:

    • ShipmentStatusEventCoded - is used to provide status information pertaining to the shipment of a schedule line.
    • ShipmentStatusEventCodedOther - is used to provide a non-standard StatusEventCode. This element is mandatory if the value of StatusEventCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • ShipmentStatusReasons - is used to provide reasons for a shipment status. This should only be used if the ShipmentStatusEventCoded element is used.
    • SplitQuantity - contains the quantity of the item the pertains to the split.
    • ActualShipDate - is the date that the quantity specified was shipped.
    • EstimatedShipDate - is the date that the quantity specified is estimated to be shipped.
    • ActualDeliveryDate - is the date that the quantity specified was recieved by the buyer.
    • EstimatedDeliveryDate - is the date that the quantity specified is estimated to be recieved by the buyer.
    • ListOfOtherDeliveryDate - lists the dates revolving around delivery.This is used to express simple date information that is not tied to particular carriers, transport, etc.
    • SplitQuantityNote - is a free form text field that is used to provide any additional information relating to this schedule.

[^]Code Fragment

    <xsd:complexType name="SplitQuantityType">
    <xsd:sequence>
        <xsd:element name="ShipmentStatusEventCoded" type="core:ShipmentStatusEventCodeType">
        <xsd:element minOccurs="0" name="ShipmentStatusEventCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="ShipmentStatusReasons" type="core:ListOfStatusReasonType">
        <xsd:element name="SplitQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="ActualShipDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="EstimatedShipDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ActualDeliveryDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="EstimatedDeliveryDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ListOfOtherDeliveryDate" type="core:ListOfDateCodedType">
        <xsd:element minOccurs="0" name="SplitQuantityNote" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: ATPCheckTypeCodeType

ATPCheckTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • NotSpecified - The criteria for the check process is not given
    • ConfirmQuantityAndDate - Confirm both the quantity and requested date
    • ConfirmAvailableQuantityForRequestedDate - Confirm the quantity available on the requested date
    • ConfirmAvailableDateForRequestedQuantity - Confirm the availability date for the requested quantity

[^]Code Fragment

    <xsd:simpleType name="ATPCheckTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="NotSpecified">
        <xsd:enumeration value="ConfirmQuantityAndDate">
        <xsd:enumeration value="ConfirmAvailableQuantityForRequestedDate">
        <xsd:enumeration value="ConfirmAvailableDateForRequestedQuantity">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: ATPCheckTypeType

ATPCheckTypeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ATPCheckTypeCoded[ATPCheckTypeCodeType] , ATPCheckTypeCodedOther[xsd:string]? )

    Description: ATPCheckTypeType is a container for the AvailabilityToPromise check type.

    Elements:

    • ATPCheckTypeCoded - indicates the type of check to be performed for the AvailabilityToPromise document.
    • ATPCheckTypeCodedOther - is used to provide a non-standard ATPCheckTypeCode. This element is mandatory if the value of ATPCheckTypeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="ATPCheckTypeType">
    <xsd:sequence>
        <xsd:element name="ATPCheckTypeCoded" type="ATPCheckTypeCodeType">
        <xsd:element minOccurs="0" name="ATPCheckTypeCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ATPQuantitiesType

ATPQuantitiesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( TotalQuantity[core:QuantityType]? , MinimumQuantity[core:QuantityType]? , MaximumQuantity[core:QuantityType]? , ListOfQuantityCoded[core:ListOfQuantityCodedType]? )

    Description: ATPQuantitiesType identifies the line item for the document. This contains the description, specific identifiers, weights, measures and other information associated with the product.

    Elements:

    • TotalQuantity - is the total amount of the item being requested.
    • MinimumQuantity - is the minimum amount of the item that is being requested.
    • MaximumQuantity - is the maximum amount of the item that is being requested.
    • ListOfQuantityCoded - specifies any other quantities not explicitly stated.

[^]Code Fragment

    <xsd:complexType name="ATPQuantitiesType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="TotalQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="MinimumQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="MaximumQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="ListOfQuantityCoded" type="core:ListOfQuantityCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ATPResponseType

ATPResponseType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( AvailabilityToPromiseResponseCoded[AvailabilityToPromiseResponseCodeType] , AvailabilityToPromiseResponseCodedOther[xsd:string]? )

    Description: ATPResponseType provides either the response given or the status of the response.

    Elements:

    • AvailabilityToPromiseResponseCoded - specifies the response or the status of the response.
    • AvailabilityToPromiseResponseCodedOther - is used to provide a non-standard AvailabilityToPromiseResponseCode. This element is only used if the value of AvailabilityToPromiseResponseCoded is 'Other' when it is mandatory.

[^]Code Fragment

    <xsd:complexType name="ATPResponseType">
    <xsd:sequence>
        <xsd:element name="AvailabilityToPromiseResponseCoded" type="AvailabilityToPromiseResponseCodeType">
        <xsd:element minOccurs="0" name="AvailabilityToPromiseResponseCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: AvailabilityCheckRequestHeaderType

AvailabilityCheckRequestHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( AvailabilityCheckRequestID[xsd:string] , AvailabilityCheckRequestIssueDate[xsd:dateTime] , SellerParty[core:PartyType] , SellerIDReferenceDate[xsd:dateTime]? , BuyerParty[core:PartyType] , BuyerIDReferenceDate[xsd:dateTime]? , AccountCode[core:ReferenceType]? , ShipToParty[core:PartyType] , AvailabilityCheckRequestLanguage[core:LanguageType]? , AvailabilityCheckRequestNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfAttachment[core:ListOfAttachmentType]? )

    Description: AvailabilityCheckRequestHeaderType holds reference dates, supplier and buyer information, and any special notes associated with the AvailabilityCheckRequest. This element occurs once within the document.

    Elements:

    • AvailabilityCheckRequestID - contains a reference number to identify the AvailabilityCheckRequest document. This value can be used for internal audit purposes. Possible values for the ID are GUIDs, internal tracking numbers, or system generated document numbers. This reference value should not be needed for document correlation purposes since this is a synchronous transaction. It is valid for the AvailabilityCheckRequestID & the AvailabilityCheckResultID from the AvailabilityCheckResult document to be the same value. For applications that do not require this type of document identification, a dummy value can be used as a default.
    • AvailabilityCheckRequestIssueDate - indicates the date the AvailabilityCheckRequest is transmitted.
    • SellerParty - holds information relating to the supplier who is the receiver of the AvailabilityCheckRequest.
    • SellerIDReferenceDate - holds the date of the supplier ID reference.
    • BuyerParty - holds information relating to the buyer who is the initiator of the AvailabilityCheckRequest. This includes unique ID's and address information.
    • BuyerIDReferenceDate - holds the date of the buyer ID reference.
    • AccountCode - holds the account code for the buyer.
    • ShipToParty - holds the address details of the delivery party. If different delivery parties are involved in this request then they will be specified at the line item level within the detail section of the AvailabilityCheckRequest.
    • AvailabilityCheckRequestLanguage - identifies the language for the AvailabilityCheckRequest.
    • AvailabilityCheckRequestNote - contains any free-form text pertinent to the entire AvailabilityCheckRequest. This element may contain notes or any other similar information that is not contained explicitly in another structure. It should not be assumed that the receiving application is capable of doing more than storing and/or displaying this information
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfAttachment - contains a list of attachments applicable to the entire AvailabilityCheckRequest. The information is not specific to a particular line item unless specifically noted.

[^]Code Fragment

    <xsd:complexType name="AvailabilityCheckRequestHeaderType">
    <xsd:sequence>
        <xsd:element name="AvailabilityCheckRequestID" type="xsd:string">
        <xsd:element name="AvailabilityCheckRequestIssueDate" type="xsd:dateTime">
        <xsd:element name="SellerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="SellerIDReferenceDate" type="xsd:dateTime">
        <xsd:element name="BuyerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="BuyerIDReferenceDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="AccountCode" type="core:ReferenceType">
        <xsd:element name="ShipToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="AvailabilityCheckRequestLanguage" type="core:LanguageType">
        <xsd:element minOccurs="0" name="AvailabilityCheckRequestNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: AvailabilityCheckRequestItemDetailType

AvailabilityCheckRequestItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( LineItemNum[core:LineItemNumType] , LineItemType[core:LineItemTypeType]? , ParentItemNumber[core:LineItemNumberReferenceType]? , ItemIdentifiers[core:ItemIdentifiersType] , RequestedQuantity[core:QuantityType] , RequestedDeliveryDate[xsd:dateTime]? , MaxBackOrderQuantity[core:QuantityType]? , BaseItemReferences[core:BaseItemReferencesType]? , GeneralLineItemNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfAttachment[core:ListOfAttachmentType]? )

    Description: AvailabilityCheckRequestItemDetailType contains the item detail for the AvailabilityCheckRequest.

    Elements:

    • LineItemNum - is a set of numbers uniquely identifying the line item for the number. In the case where the seller's system splits a line item number into 2 line items, the buyer item number will remain the same for both line items, but the seller item number will be different.
    • LineItemType - identifies whether the line item is a component group (consists of other line items), a typical line item, or a textual line item.
    • ParentItemNumber - identifies the line item that groups this and other line items. This is done using LineItemNumberReference, which specifies the number of the parent line item and whether this reference is the Buyer or Seller's number. LineItemNumberReference is a string content model of datatype integer that contains an attribute to specify whether the ParentItemNumber is a Seller or Buyer number, with the default being Buyer. This value references the parent item represented a group.
    • ItemIdentifiers - details all of the part numbers assigned to the item.
    • RequestedQuantity - is the quantity of the item that is requested for availability.
    • RequestedDeliveryDate - is the date that the requested quantity is to be delivered on.
    • MaxBackOrderQuantity - specifies the maximum quantity of an item that a customer will allow to be back ordered.
    • BaseItemReferences - contains all reference information for the item.
    • GeneralLineItemNote - describes any free-form text pertinent to the line item described by the AvailabilityCheckRequest. This element may contain notes or any other information that is not contained explicitly in another structure. It should not be assumed that the receiving application is capable of doing any more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfAttachment - contains details of the attachments for the line item.

[^]Code Fragment

    <xsd:complexType name="AvailabilityCheckRequestItemDetailType">
    <xsd:sequence>
        <xsd:element name="LineItemNum" type="core:LineItemNumType">
        <xsd:element minOccurs="0" name="LineItemType" type="core:LineItemTypeType">
        <xsd:element minOccurs="0" name="ParentItemNumber" type="core:LineItemNumberReferenceType">
        <xsd:element name="ItemIdentifiers" type="core:ItemIdentifiersType">
        <xsd:element name="RequestedQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="RequestedDeliveryDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="MaxBackOrderQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="BaseItemReferences" type="core:BaseItemReferencesType">
        <xsd:element minOccurs="0" name="GeneralLineItemNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: AvailabilityCheckRequestType

AvailabilityCheckRequestType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( AvailabilityCheckRequestHeader[AvailabilityCheckRequestHeaderType] , ListOfAvailabilityCheckRequestItemDetail[ListOfAvailabilityCheckRequestItemDetailType] )

    Description: AvailabilityCheckRequestType contains a request to check the availability of a specified list of items. All items in the list are offered by a single supplier to a single buyer account.

    Elements:

    • AvailabilityCheckRequestHeader - holds reference dates, supplier and buyer information, and any special notes associated with the AvailabilityCheckRequest. This element occurs once within the document.
    • ListOfAvailabilityCheckRequestItemDetail - contains a list of the line items for the AvailalbilityCheckRequest.

[^]Code Fragment

    <xsd:complexType name="AvailabilityCheckRequestType">
    <xsd:sequence>
        <xsd:element name="AvailabilityCheckRequestHeader" type="AvailabilityCheckRequestHeaderType">
        <xsd:element name="ListOfAvailabilityCheckRequestItemDetail" type="ListOfAvailabilityCheckRequestItemDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: AvailabilityCheckResultHeaderType

AvailabilityCheckResultHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( AvailabilityCheckResultID[xsd:string] , AvailabilityCheckResultIssueDate[xsd:dateTime] , SellerParty[core:PartyType] , SellerIDReferenceDate[xsd:dateTime]? , BuyerParty[core:PartyType] , BuyerIDReferenceDate[xsd:dateTime]? , ShipToParty[core:PartyType] , AvailabilityCheckResultLanguage[core:LanguageType]? , AvailabilityCheckResultNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfAttachment[core:ListOfAttachmentType]? )

    Description: AvailabilityCheckResultHeaderType holds reference dates, supplier and buyer information, and any special notes associated with the AvailabilityCheckResult. This element occurs once within the document.

    Elements:

    • AvailabilityCheckResultID - contains a reference number to identify the AvailabilityCheckResult document. This value can be used for internal audit purposes. Possible values for the ID are GUIDs, internal tracking numbers, or system generated document numbers. This reference value should not be needed for document correlation purposes since this is a synchronous transaction. It is valid for the AvailabilityCheckResultID & the AvailabilityCheckRequestID from the AvailabilityCheckRequest document to be the same value. For applications that do not require this type of document identification, a dummy value can be used as a default.
    • AvailabilityCheckResultIssueDate - indicates the date the AvailabilityCheckResult is transmitted.
    • SellerParty - holds information relating to the supplier who is the initiator of the AvailabilityCheckResult. This includes unique ID's and address information.
    • SellerIDReferenceDate - holds the date of the supplier ID reference.
    • BuyerParty - holds information relating to the buyer who is the receiver of the AvailabilityCheckResult. This includes unique ID's and address information.
    • BuyerIDReferenceDate - holds the date of the buyer ID reference.
    • ShipToParty - holds the address details of the delivery party. If different delivery parties are involved in this request then they will be specified at the line item level.
    • AvailabilityCheckResultLanguage - identifies the language for the AvailabilityCheckResult.
    • AvailabilityCheckResultNote - contains any free-form text pertinent to the entire AvailabilityCheckResult. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfAttachment - contains details of the attachments for the AvailabilityCheckResult.

[^]Code Fragment

    <xsd:complexType name="AvailabilityCheckResultHeaderType">
    <xsd:sequence>
        <xsd:element name="AvailabilityCheckResultID" type="xsd:string">
        <xsd:element name="AvailabilityCheckResultIssueDate" type="xsd:dateTime">
        <xsd:element name="SellerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="SellerIDReferenceDate" type="xsd:dateTime">
        <xsd:element name="BuyerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="BuyerIDReferenceDate" type="xsd:dateTime">
        <xsd:element name="ShipToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="AvailabilityCheckResultLanguage" type="core:LanguageType">
        <xsd:element minOccurs="0" name="AvailabilityCheckResultNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: AvailabilityCheckResultItemDetailType

AvailabilityCheckResultItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( LineItemNum[core:LineItemNumType] , LineItemType[core:LineItemTypeType]? , ParentItemNumber[core:LineItemNumberReferenceType]? , ItemIdentifiers[core:ItemIdentifiersType]? , RequestedQuantity[core:QuantityType]? , RequestedDeliveryDate[xsd:dateTime]? , AvailableQuantity[core:QuantityType] , AvailableDeliveryDate[xsd:dateTime]? , MaxBackOrderQuantity[core:QuantityType]? , BaseItemReferences[core:BaseItemReferencesType]? , AvailabilityErrorInfo[core:ErrorInfoType]? , GeneralLineItemNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfAttachment[core:ListOfAttachmentType]? )

    Description: AvailabilityCheckResultItemDetailType contains the item detail information in response to the AvailabilityCheckRequest line item information.

    Elements:

    • LineItemNum - is a set of numbers uniquely identifying the line item for the number. In the case where the seller's system splits a line item number into 2 line items, the buyer item number will remain the same for both line items, but the seller item number will be different.
    • LineItemType - identifies whether the line item is a component group (consists of other line items), a typical line item, or a textual line item.
    • ParentItemNumber - identifies the line item that groups this and other line items. This is done using LineItemNumberReference, which specifies the number of the parent line item and whether this reference is the Buyer or Seller's number. LineItemNumberReference is a string content model of datatype integer that contains an attribute to specify whether the ParentItemNumber is a Seller or Buyer number, with the default being Buyer. This value references the parent item represented a group.
    • ItemIdentifiers - details all of the part numbers assigned to the item.
    • RequestedQuantity - is the quantity of the item that is requested for availability.
    • RequestedDeliveryDate - is the date that the requested quantity is to be delivered on.
    • AvailableQuantity - contains the available quantity of the item.
    • AvailableDeliveryDate - specifies the date which the available quantity can be deliverd on.
    • MaxBackOrderQuantity - specifies the maximum quantity of an item that a customer will allow to be back ordered.
    • BaseItemReferences - contains all reference information for the item.
    • AvailabilityErrorInfo - contains the completion codes and messages, severity codes, and other error information.
    • GeneralLineItemNote - describes any free-form text pertinent to the line item described by the AvailabilityCheckResult. This element may contain notes or any other similar information that is not contained explicitly in another structure. It should not be assumed that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfAttachment - contains details of the attachments for the line item.

[^]Code Fragment

    <xsd:complexType name="AvailabilityCheckResultItemDetailType">
    <xsd:sequence>
        <xsd:element name="LineItemNum" type="core:LineItemNumType">
        <xsd:element minOccurs="0" name="LineItemType" type="core:LineItemTypeType">
        <xsd:element minOccurs="0" name="ParentItemNumber" type="core:LineItemNumberReferenceType">
        <xsd:element minOccurs="0" name="ItemIdentifiers" type="core:ItemIdentifiersType">
        <xsd:element minOccurs="0" name="RequestedQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="RequestedDeliveryDate" type="xsd:dateTime">
        <xsd:element name="AvailableQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="AvailableDeliveryDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="MaxBackOrderQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="BaseItemReferences" type="core:BaseItemReferencesType">
        <xsd:element minOccurs="0" name="AvailabilityErrorInfo" type="core:ErrorInfoType">
        <xsd:element minOccurs="0" name="GeneralLineItemNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: AvailabilityCheckResultType

AvailabilityCheckResultType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( AvailabilityCheckResultHeader[AvailabilityCheckResultHeaderType] , ListOfAvailabilityCheckResultItemDetail[ListOfAvailabilityCheckResultItemDetailType] )

    Description: AvailabilityCheckResultType contains the resulting response to an AvailabilityCheckRequest for specific supplier items.

    Elements:

    • AvailabilityCheckResultHeader - holds reference dates, supplier and buyer information, and any special notes associated with the AvailabilityCheckResult. This element occurs once within the document.
    • ListOfAvailabilityCheckResultItemDetail - contains a list of line items for the AvailabilityCheckResult.

[^]Code Fragment

    <xsd:complexType name="AvailabilityCheckResultType">
    <xsd:sequence>
        <xsd:element name="AvailabilityCheckResultHeader" type="AvailabilityCheckResultHeaderType">
        <xsd:element name="ListOfAvailabilityCheckResultItemDetail" type="ListOfAvailabilityCheckResultItemDetailType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: AvailabilityDeliveryOptionCodeType

AvailabilityDeliveryOptionCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:
    This code identifies the type of delivery required for the AvailabilityToPromise.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom code
    • Complete - The delivery is required as a complete shipment.
    • Partial - The delivery will be accepted as a partial shipment
    • OneTime - the delivery is considered to be a single event.

[^]Code Fragment

    <xsd:simpleType name="AvailabilityDeliveryOptionCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Complete">
        <xsd:enumeration value="Partial">
        <xsd:enumeration value="OneTime">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: AvailabilityDeliveryOptionType

AvailabilityDeliveryOptionType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( AvailabilityDeliveryOptionCoded[AvailabilityDeliveryOptionCodeType] , AvailabilityDeliveryOptionCodedOther[xsd:string]? )

    Description: AvailabilityDeliveryOptionType contains the type of delivery for the AvailabilityToPromise document.

    Elements:

    • AvailabilityDeliveryOptionCoded - contains the type of delivery required for the document
    • AvailabilityDeliveryOptionCodedOther - is used to provide a non-standard AvailabilityDeliveryOptionCode. This element is mandatory if the value of AvailabilityDeliveryOptionCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="AvailabilityDeliveryOptionType">
    <xsd:sequence>
        <xsd:element name="AvailabilityDeliveryOptionCoded" type="AvailabilityDeliveryOptionCodeType">
        <xsd:element minOccurs="0" name="AvailabilityDeliveryOptionCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: AvailabilityToPromiseBaseItemDetailType

AvailabilityToPromiseBaseItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( LineItemNum[core:LineItemNumType] , LineItemType[core:LineItemTypeType]? , ParentItemNumber[core:LineItemNumberReferenceType]? , ItemIdentifiers[core:ItemIdentifiersType]? , ListOfDimension[core:ListOfDimensionType]? , ATPQuantities[ATPQuantitiesType] , BaseItemReferences[core:BaseItemReferencesType]? , FinalRecipient[core:PartyType]? , ListOfPartyCoded[core:ListOfPartyCodedType]? )

    Description: AvailabilityToPromiseBaseItemDetailType contains the line item information for the items being requested.

    Elements:

    • LineItemNum - is a set of numbers uniquely identifying the line item for the number. In the case where the seller's system splits a line item number into 2 line items, the buyer item number will remain the same for both line items, but the seller item number will be different.
    • LineItemType - identifies whether the line item is a component group (consists of other line items), a typical line item, or a textual line item.
    • ParentItemNumber - identifies the line item that groups this and other line items. This is done using LineItemNumberReference, which specifies the number of the parent line item and whether this reference is the Buyer or Seller's number. LineItemNumberReference is a string content model of datatype integer that contains an attribute to specify whether the ParentItemNumber is a Seller or Buyer number, with the default being Buyer. This value references the parent item represented a group.
    • ItemIdentifiers - details all of the part numbers assigned to the item.
    • ListOfDimension - lists one or more quantitative measurements of the item.
    • ATPQuantities - contains the quantity or quantity range of the item requested for availability.
    • BaseItemReferences - contains all reference information for the item.
    • FinalRecipient - identifies the person or organization who will ultimately receive the item or items.
    • ListOfPartyCoded - specifies any other parties associated with the line item that are not already explicitly stated.

[^]Code Fragment

    <xsd:complexType name="AvailabilityToPromiseBaseItemDetailType">
    <xsd:sequence>
        <xsd:element name="LineItemNum" type="core:LineItemNumType">
        <xsd:element minOccurs="0" name="LineItemType" type="core:LineItemTypeType">
        <xsd:element minOccurs="0" name="ParentItemNumber" type="core:LineItemNumberReferenceType">
        <xsd:element minOccurs="0" name="ItemIdentifiers" type="core:ItemIdentifiersType">
        <xsd:element minOccurs="0" name="ListOfDimension" type="core:ListOfDimensionType">
        <xsd:element name="ATPQuantities" type="ATPQuantitiesType">
        <xsd:element minOccurs="0" name="BaseItemReferences" type="core:BaseItemReferencesType">
        <xsd:element minOccurs="0" name="FinalRecipient" type="core:PartyType">
        <xsd:element minOccurs="0" name="ListOfPartyCoded" type="core:ListOfPartyCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: AvailabilityToPromiseDetailType

AvailabilityToPromiseDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ListOfAvailabilityToPromiseItemDetail[ListOfAvailabilityToPromiseItemDetailType]? )

    Description: AvailabilityToPromiseDetailType is the container for the AvailabilityToPromise information.

    Elements:

    • ListOfAvailabilityToPromiseItemDetail - is the container for the list of line items for the AvailabilityToPromise.

[^]Code Fragment

    <xsd:complexType name="AvailabilityToPromiseDetailType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ListOfAvailabilityToPromiseItemDetail" type="ListOfAvailabilityToPromiseItemDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: AvailabilityToPromiseHeaderType

AvailabilityToPromiseHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( AvailabilityID[xsd:string] , AvailabilityIssueDate[xsd:dateTime] , ListOfReferenceCoded[core:ListOfReferenceCodedType]? , AvailabilityToPromisePurpose[AvailabilityToPromisePurposeType] , AvailabilityDeliveryOption[AvailabilityDeliveryOptionType] , ATPCheckType[ATPCheckTypeType]? , ATPResponse[ATPResponseType]? , InitiatingParty[core:PartyType] , RespondingParty[core:PartyType]? , AvailabilityShipToParty[core:PartyType]? , AvailabilityToPromiseHeaderTransport[core:TransportRoutingType]? , AvailabilityToPromiseHeaderNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , AvailabilityToPromiseListOfAttachment[core:ListOfAttachmentType]? )

    Description: AvailabilityToPromiseHeaderType holds all AvailabilitytoPromise header-level information. This element occurs once within the document.

    Elements:

    • AvailabilityID - contains a reference number to identify the AvailabilityToPromise document.
    • AvailabilityIssueDate - indicates the date the AvailabilitytoPromise request is transmitted.
    • ListOfReferenceCoded - contains one or more elements containing information that can be used to find further information elsewhere that is not explicitly stated in another element.
    • AvailabilityToPromisePurpose - is a container for the AvailabilitytoPromise purpose details.
    • AvailabilityDeliveryOption - contains the type of delivery for the AvailabilityToPromise document.
    • ATPCheckType - specifies the requested criteria for checking the availability of the items specified by the AvailabilityToPromise document.
    • ATPResponse - is used to communicate the status of the response (if one exists) for the AvailabilityToPromise document. The initiating party can use this code to accept or reject an existing response from the responding party.
    • InitiatingParty - holds the information to identify the initiator of the AvailabilityToPromise document.
    • RespondingParty - holds information to identify the entity that is responding to the original AvailabilityToPromise document.
    • AvailabilityShipToParty - holds the address details of the delivery party. If different delivery parties are involved in this request then they will be specified at the line item level.
    • AvailabilityToPromiseHeaderTransport - identifies the transport details that apply to the entire AvailabilityToPromise document.
    • AvailabilityToPromiseHeaderNote - is used to provide a note in text form if desired.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • AvailabilityToPromiseListOfAttachment - contains attachments for the AvailabilityToPromise.

[^]Code Fragment

    <xsd:complexType name="AvailabilityToPromiseHeaderType">
    <xsd:sequence>
        <xsd:element name="AvailabilityID" type="xsd:string">
        <xsd:element name="AvailabilityIssueDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ListOfReferenceCoded" type="core:ListOfReferenceCodedType">
        <xsd:element name="AvailabilityToPromisePurpose" type="AvailabilityToPromisePurposeType">
        <xsd:element name="AvailabilityDeliveryOption" type="AvailabilityDeliveryOptionType">
        <xsd:element minOccurs="0" name="ATPCheckType" type="ATPCheckTypeType">
        <xsd:element minOccurs="0" name="ATPResponse" type="ATPResponseType">
        <xsd:element name="InitiatingParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="RespondingParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="AvailabilityShipToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="AvailabilityToPromiseHeaderTransport" type="core:TransportRoutingType">
        <xsd:element minOccurs="0" name="AvailabilityToPromiseHeaderNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="AvailabilityToPromiseListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: AvailabilityToPromiseItemDetailType

AvailabilityToPromiseItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( AvailabilityToPromiseBaseItemDetail[AvailabilityToPromiseBaseItemDetailType] , AvailabilityToPromiseDeliveryDetail[core:DeliveryDetailType]? , AvailabilityToPromiseTransportDetail[core:TransportRoutingType]? , AvailabilityToPromiseItemListOfAttachment[core:ListOfAttachmentType]? , LineItemNote[xsd:string]? )

    Description: AvailabilityToPromiseItemDetailType contains the line item detail information.

    Elements:

    • AvailabilityToPromiseBaseItemDetail - contains the identifying and descriptive information for the line item in the AvailabilityToPromise.
    • AvailabilityToPromiseDeliveryDetail - identifies the delivery details for the line item in the AvailabilityToPromise.
    • AvailabilityToPromiseTransportDetail - identifies the transport details for the line item in the AvailabilityToPromise.
    • AvailabilityToPromiseItemListOfAttachment - contains attachments for the line item.
    • LineItemNote - contains any free-form text pertinent to the line item in AvailabilityToPromise. This element may contain notes or any other similar information that is not contained explicitly in another structure. it should not be assumed that the receiving application is capable of doing more than storing and/or displaying this information.

[^]Code Fragment

    <xsd:complexType name="AvailabilityToPromiseItemDetailType">
    <xsd:sequence>
        <xsd:element name="AvailabilityToPromiseBaseItemDetail" type="AvailabilityToPromiseBaseItemDetailType">
        <xsd:element minOccurs="0" name="AvailabilityToPromiseDeliveryDetail" type="core:DeliveryDetailType">
        <xsd:element minOccurs="0" name="AvailabilityToPromiseTransportDetail" type="core:TransportRoutingType">
        <xsd:element minOccurs="0" name="AvailabilityToPromiseItemListOfAttachment" type="core:ListOfAttachmentType">
        <xsd:element minOccurs="0" name="LineItemNote" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: AvailabilityToPromisePurposeCodeType

AvailabilityToPromisePurposeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:
    This code identifies the purpose of the AvailabilityToPromise message. This is a subset codelist derived from EDIFACT 1225 (Message Function, Coded) and X12 353 (Transaction Set Purpose Code) and 587 (Acknowledgement Type Code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • Closed - The Availabiltiy To Promise process is closed
    • Open - The Availabiltiy To Promise process is open
    • Original - Refers to the initial transmission of the Availability To Promise message.
    • Cancellation - Indicates that a previous transmission of the Availabiltiy To Promise message is to be cancelled.
    • EndProcess - Specifies that the Availability To Promise process is to be terminated.

[^]Code Fragment

    <xsd:simpleType name="AvailabilityToPromisePurposeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="Closed">
        <xsd:enumeration value="Open">
        <xsd:enumeration value="Original">
        <xsd:enumeration value="Cancellation">
        <xsd:enumeration value="EndProcess">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: AvailabilityToPromisePurposeType

AvailabilityToPromisePurposeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( AvailabilityToPromisePurposeCoded[AvailabilityToPromisePurposeCodeType] , AvailabilityToPromisePurposeCodedOther[xsd:string]? )

    Description: AvailabilityToPromisePurposeType is a container for the AvailabilitytoPromise purpose details.

    Elements:

    • AvailabilityToPromisePurposeCoded - indicates the intended use of the AvailabilitytoPromise request.
    • AvailabilityToPromisePurposeCodedOther - used to provide a non-standard AvailabilityToPromisePurposeCode. This element is mandatory if the value of AvailabilityToPromisePurposeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="AvailabilityToPromisePurposeType">
    <xsd:sequence>
        <xsd:element name="AvailabilityToPromisePurposeCoded" type="AvailabilityToPromisePurposeCodeType">
        <xsd:element minOccurs="0" name="AvailabilityToPromisePurposeCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: AvailabilityToPromiseResponseBaseItemDetailType

AvailabilityToPromiseResponseBaseItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( LineItemNum[core:LineItemNumType] , LineItemType[core:LineItemTypeType]? , ParentItemNumber[core:LineItemNumberReferenceType]? , ItemIdentifiers[core:ItemIdentifiersType]? , ListOfDimension[core:ListOfDimensionType]? , BidQuantities[ATPQuantitiesType]? , ConfirmedQuantities[core:QuantityType]? , BaseItemReferences[core:BaseItemReferencesType]? , FinalRecipient[core:PartyType]? , ListOfPartyCoded[core:ListOfPartyCodedType]? )

    Description: AvailabilityToPromiseResponseBaseItemDetailType contains the line item information and response for the items being requested.

    Elements:

    • LineItemNum - is a set of numbers uniquely identifying the line item for the number. In the case where the seller's system splits a line item number into 2 line items, the buyer item number will remain the same for both line items, but the seller item number will be different.
    • LineItemType - identifies whether the line item is a component group (consists of other line items), a typical line item, or a textual line item.
    • ParentItemNumber - identifies the line item that groups this and other line items. This is done using LineItemNumberReference, which specifies the number of the parent line item and whether this reference is the Buyer or Seller's number. LineItemNumberReference is a string content model of datatype integer that contains an attribute to specify whether the ParentItemNumber is a Seller or Buyer number, with the default being Buyer. This value references the parent item represented a group.
    • ItemIdentifiers - details all of the part numbers assigned to the item.
    • ListOfDimension - lists one or more quantitative measurements of the item.
    • BidQuantities - contains the quantity or quantity range of the item requested for availability.
    • ConfirmedQuantities - specifies the amount of the item that is confirmed.
    • BaseItemReferences - contains all reference information for the item.
    • FinalRecipient - identifies the person or organization who will ultimately receive the item or items.
    • ListOfPartyCoded - specifies any other parties associated with the line item that are not already explicitly stated.

[^]Code Fragment

    <xsd:complexType name="AvailabilityToPromiseResponseBaseItemDetailType">
    <xsd:sequence>
        <xsd:element name="LineItemNum" type="core:LineItemNumType">
        <xsd:element minOccurs="0" name="LineItemType" type="core:LineItemTypeType">
        <xsd:element minOccurs="0" name="ParentItemNumber" type="core:LineItemNumberReferenceType">
        <xsd:element minOccurs="0" name="ItemIdentifiers" type="core:ItemIdentifiersType">
        <xsd:element minOccurs="0" name="ListOfDimension" type="core:ListOfDimensionType">
        <xsd:element minOccurs="0" name="BidQuantities" type="ATPQuantitiesType">
        <xsd:element minOccurs="0" name="ConfirmedQuantities" type="core:QuantityType">
        <xsd:element minOccurs="0" name="BaseItemReferences" type="core:BaseItemReferencesType">
        <xsd:element minOccurs="0" name="FinalRecipient" type="core:PartyType">
        <xsd:element minOccurs="0" name="ListOfPartyCoded" type="core:ListOfPartyCodedType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: AvailabilityToPromiseResponseCodeType

AvailabilityToPromiseResponseCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:
    This code identifies the response or the status of the response. This is a subset codelist derived from EDIFACT 1229 (Action request/notification description code) and X12 670 (Change or Response Type Code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Other - Custom Code
    • NotAccepted - Not Accepted
    • AcceptedWithoutAmendment - Accepted Without Amendment
    • AcceptedWithAmendment - Accepted With Amendment
    • ResponseOpen - No response has been given yet
    • ResponseExists - Response has been created
    • RequestRefused - No Availability To Promise commitment possible
    • ResponseAccepted - Response is given and accepted by the initiating party
    • ResponseRejected - Response is given and rejected by the initiating party
    • ResponseWithdrawn - Response has been given but it is now cancelled

[^]Code Fragment

    <xsd:simpleType name="AvailabilityToPromiseResponseCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Other">
        <xsd:enumeration value="NotAccepted">
        <xsd:enumeration value="AcceptedWithoutAmendment">
        <xsd:enumeration value="AcceptedWithAmendment">
        <xsd:enumeration value="ResponseOpen">
        <xsd:enumeration value="ResponseExists">
        <xsd:enumeration value="RequestRefused">
        <xsd:enumeration value="ResponseAccepted">
        <xsd:enumeration value="ResponseRejected">
        <xsd:enumeration value="ResponseWithdrawn">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: AvailabilityToPromiseResponseDetailType

AvailabilityToPromiseResponseDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ListOfAvailabilityToPromiseResponseItemDetail[ListOfAvailabilityToPromiseResponseItemDetailType]? )

    Description: AvailabilityToPromiseResponseDetailType is the container for the AvailabilityToPromiseResponse document.

    Elements:

    • ListOfAvailabilityToPromiseResponseItemDetail - is the container for the list of line items for AvailabilityToPromiseResponse document.

[^]Code Fragment

    <xsd:complexType name="AvailabilityToPromiseResponseDetailType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ListOfAvailabilityToPromiseResponseItemDetail" type="ListOfAvailabilityToPromiseResponseItemDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: AvailabilityToPromiseResponseHeaderType

AvailabilityToPromiseResponseHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( AvailabilityResponseID[xsd:string] , AvailabilityResponseIssueDate[xsd:dateTime] , AvailabilityToPromiseRefernece[core:ReferenceType] , ATPResponse[ATPResponseType] , ListOfReferenceCoded[core:ListOfReferenceCodedType]? , AvailabilityResponseDeliveryOption[AvailabilityDeliveryOptionType] , ATPCheckType[ATPCheckTypeType]? , InitiatingParty[core:PartyType] , RespondingParty[core:PartyType]? , AvailabilityShipToParty[core:PartyType]? , AvailabilityResponseHeaderTransport[core:TransportRoutingType]? , AvailabilityResponseHeaderNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , AvailabilityResponseListOfAttachment[core:ListOfAttachmentType]? )

    Description: AvailabilityToPromiseResponseHeaderType holds all AvailabilityToPromiseResponse header-level information. This element occurs once within the document.

    Elements:

    • AvailabilityResponseID - contains a reference number to identify the Availability Request Response document.
    • AvailabilityResponseIssueDate - indicates the date the AvailabilityToPromiseResponse is transmitted.
    • AvailabilityToPromiseRefernece - contains the reference to the original AvailabilityToPromise request.
    • ATPResponse - is a container for the AvailabilityToPromiseResponse type.
    • ListOfReferenceCoded - contains one or more elements containing information that can be used to find further information elsewhere that is not explicitly stated in another element.
    • AvailabilityResponseDeliveryOption - indicates the type of delivery for the AvailabilityToPromiseResponse document.
    • ATPCheckType - specifies the criteria used for checking the availability of the items specified by the AvailabilityToPromise document.
    • InitiatingParty - holds the information to identify the initiator of the AvailabilityToPromise document.
    • RespondingParty - holds information to identify the entity that is responding to the original AvailabilityToPromise document.
    • AvailabilityShipToParty - holds the address details of the delivery party. If different delivery parties are involved in this request then they will be specified at the line item level.
    • AvailabilityResponseHeaderTransport - identifies the transport details that apply to the entire AvailabilityToPromiseResponse document.
    • AvailabilityResponseHeaderNote - contains any free-form text pertinent to the entire AvailabilityToPromiseResponse. This element may contain notes or any other similar information that is not contained explicitly in another structure. It should not be assumed that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • AvailabilityResponseListOfAttachment - contains attachments for the AvailabilityToPromiseResponse document.

[^]Code Fragment

    <xsd:complexType name="AvailabilityToPromiseResponseHeaderType">
    <xsd:sequence>
        <xsd:element name="AvailabilityResponseID" type="xsd:string">
        <xsd:element name="AvailabilityResponseIssueDate" type="xsd:dateTime">
        <xsd:element name="AvailabilityToPromiseRefernece" type="core:ReferenceType">
        <xsd:element name="ATPResponse" type="ATPResponseType">
        <xsd:element minOccurs="0" name="ListOfReferenceCoded" type="core:ListOfReferenceCodedType">
        <xsd:element name="AvailabilityResponseDeliveryOption" type="AvailabilityDeliveryOptionType">
        <xsd:element minOccurs="0" name="ATPCheckType" type="ATPCheckTypeType">
        <xsd:element name="InitiatingParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="RespondingParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="AvailabilityShipToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="AvailabilityResponseHeaderTransport" type="core:TransportRoutingType">
        <xsd:element minOccurs="0" name="AvailabilityResponseHeaderNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="AvailabilityResponseListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: AvailabilityToPromiseResponseItemDetailType

AvailabilityToPromiseResponseItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( AvailabilityToPromiseItemResponse[AvailabilityToPromisePurposeType]? , AvailabilityToPromiseResponseBaseItemDetail[AvailabilityToPromiseResponseBaseItemDetailType] , AvailabilityToPromiseResponseDeliveryDetail[core:DeliveryDetailType]? , AvailabilityToPromiseResponseTransportDetail[core:TransportRoutingType]? , AvailabilityToPromiseResponseItemListOfAttachment[core:ListOfAttachmentType]? , LineItemNote[xsd:string]? )

    Description: AvailabilityToPromiseResponseItemDetailType is the container for the list of line items.

    Elements:

    • AvailabilityToPromiseItemResponse - indicates the intended use of the AvailabilityToPromiseItemResponse
    • AvailabilityToPromiseResponseBaseItemDetail - contains the identifying and descriptive information for the item detail
    • AvailabilityToPromiseResponseDeliveryDetail - identifies the delivery details for the line item in the AvailabilityToPromiseResponse document.
    • AvailabilityToPromiseResponseTransportDetail - identifies the transport details for the line item in the AvailabilityToPromiseResponse document.
    • AvailabilityToPromiseResponseItemListOfAttachment - contains attachments for the line item.
    • LineItemNote - contains any free-form text pertinent to the line item in AvailabilityToPromiseResponse. This element may contain notes or any other similar information that is not contained explicitly in another structure. it should not be assumed that the receiving application is capable of doing more than storing and/or displaying this information.

[^]Code Fragment

    <xsd:complexType name="AvailabilityToPromiseResponseItemDetailType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="AvailabilityToPromiseItemResponse" type="AvailabilityToPromisePurposeType">
        <xsd:element name="AvailabilityToPromiseResponseBaseItemDetail" type="AvailabilityToPromiseResponseBaseItemDetailType">
        <xsd:element minOccurs="0" name="AvailabilityToPromiseResponseDeliveryDetail" type="core:DeliveryDetailType">
        <xsd:element minOccurs="0" name="AvailabilityToPromiseResponseTransportDetail" type="core:TransportRoutingType">
        <xsd:element minOccurs="0" name="AvailabilityToPromiseResponseItemListOfAttachment" type="core:ListOfAttachmentType">
        <xsd:element minOccurs="0" name="LineItemNote" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: AvailabilityToPromiseResponseType

AvailabilityToPromiseResponseType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( AvailabilityToPromiseResponseHeader[AvailabilityToPromiseResponseHeaderType] , AvailabilityToPromiseResponseDetail[AvailabilityToPromiseResponseDetailType]? , DigitalSignature[dgs:SignatureType]? )

    Description: AvailabilityToPromiseResponseType is used to respond to an AvailabilityToPromise document. This element occurs once within the document.

    Elements:

    • AvailabilityToPromiseResponseHeader - holds all AvailabilityToPromiseResponse header-level information. This element occurs once within the document.
    • AvailabilityToPromiseResponseDetail - contains the line item and package details for AvailabilityToPromiseResponse
    • DigitalSignature - contains a digital signature for the document.

[^]Code Fragment

    <xsd:complexType name="AvailabilityToPromiseResponseType">
    <xsd:sequence>
        <xsd:element name="AvailabilityToPromiseResponseHeader" type="AvailabilityToPromiseResponseHeaderType">
        <xsd:element minOccurs="0" name="AvailabilityToPromiseResponseDetail" type="AvailabilityToPromiseResponseDetailType">
        <xsd:element minOccurs="0" name="DigitalSignature" type="dgs:SignatureType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: AvailabilityToPromiseType

AvailabilityToPromiseType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( AvailabilityToPromiseHeader[AvailabilityToPromiseHeaderType] , AvailabilityToPromiseDetail[AvailabilityToPromiseDetailType]? , DigitalSignature[dgs:SignatureType]? )

    Description: AvailabilityToPromiseType consists of the request for availability to be sent from a buyer to a supplier or a number of suppliers. The request for availability can also be received from an outside source by a supplier. The request is used to determine when, where and how many of the requested goods the supplier(s) can supply, in many cases the request will be sent to existing suppliers only.

    Elements:

    • AvailabilityToPromiseHeader - holds all AvailabilitytoPromise header-level information. This element occurs once within the document.
    • AvailabilityToPromiseDetail - contains line item details of the AvaiabilityToPromise
    • DigitalSignature - contains a digital signature for the document.

[^]Code Fragment

    <xsd:complexType name="AvailabilityToPromiseType">
    <xsd:sequence>
        <xsd:element name="AvailabilityToPromiseHeader" type="AvailabilityToPromiseHeaderType">
        <xsd:element minOccurs="0" name="AvailabilityToPromiseDetail" type="AvailabilityToPromiseDetailType">
        <xsd:element minOccurs="0" name="DigitalSignature" type="dgs:SignatureType">
    </xsd:sequence>
</xsd:complexType>


Complex Types:

ATPCheckTypeType
ATPQuantitiesType
ATPResponseType
AvailabilityCheckRequestHeaderType
AvailabilityCheckRequestItemDetailType
ListOfAvailabilityCheckRequestItemDetailType
AvailabilityCheckRequestType
AvailabilityCheckResultHeaderType
AvailabilityCheckResultItemDetailType
ListOfAvailabilityCheckResultItemDetailType
AvailabilityCheckResultType
AvailabilityDeliveryOptionType
AvailabilityToPromiseBaseItemDetailType
AvailabilityToPromiseDetailType
AvailabilityToPromiseHeaderType
AvailabilityToPromiseItemDetailType
ListOfAvailabilityToPromiseItemDetailType
AvailabilityToPromisePurposeType
AvailabilityToPromiseResponseBaseItemDetailType
AvailabilityToPromiseResponseDetailType
AvailabilityToPromiseResponseHeaderType
AvailabilityToPromiseResponseItemDetailType
ListOfAvailabilityToPromiseResponseItemDetailType
AvailabilityToPromiseResponseType
AvailabilityToPromiseType
PriceCheckRequestHeaderType
PriceCheckRequestItemDetailType
ListOfPriceCheckRequestItemDetailType
PriceCheckRequestType
PriceCheckResultHeaderType
PriceCheckResultItemDetailType
ListOfPriceCheckResultItemDetailType
PriceCheckResultType
QuotationRequestReferenceType
QuoteBaseItemDetailType
QuoteDetailType
QuoteHeaderType
QuoteItemDetailType
ListOfQuoteItemDetailType
QuotePartyType
QuoteType
QuoteTypeType
RequestForQuotationType
RequestQuoteBaseItemDetailType
RequestQuoteDateType
RequestQuoteDetailType
RequestQuoteHeaderType
RequestQuoteItemDetailType
ListOfRequestQuoteItemDetailType
RequestQuotePurposeType
RequestQuoteReferenceType


Global Elements (Document Roots):

AvailabilityCheckRequest
AvailabilityCheckResult
AvailabilityToPromise
AvailabilityToPromiseResponse
PriceCheckRequest
PriceCheckResult
Quote
RequestForQuotation


complexType definition: ListOfAvailabilityCheckRequestItemDetailType

ListOfAvailabilityCheckRequestItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( AvailabilityCheckRequestItemDetail[AvailabilityCheckRequestItemDetailType]+ )

    Description: ListOfAvailabilityCheckRequestItemDetailType contains a list of the line items for the AvailalbilityCheckRequest.

    Elements:

    • AvailabilityCheckRequestItemDetail - contains the item detail for the AvailabilityCheckRequest.

[^]Code Fragment

    <xsd:complexType name="ListOfAvailabilityCheckRequestItemDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="AvailabilityCheckRequestItemDetail" type="AvailabilityCheckRequestItemDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfAvailabilityCheckResultItemDetailType

ListOfAvailabilityCheckResultItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( AvailabilityCheckResultItemDetail[AvailabilityCheckResultItemDetailType]+ )

    Description: ListOfAvailabilityCheckResultItemDetailType contains a list of line items for the AvailabilityCheckResult.

    Elements:

    • AvailabilityCheckResultItemDetail - contains the item detail information in response to the AvailabilityCheckRequest line item information.

[^]Code Fragment

    <xsd:complexType name="ListOfAvailabilityCheckResultItemDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="AvailabilityCheckResultItemDetail" type="AvailabilityCheckResultItemDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfAvailabilityToPromiseItemDetailType

ListOfAvailabilityToPromiseItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( AvailabilityToPromiseItemDetail[AvailabilityToPromiseItemDetailType]+ )

    Description: ListOfAvailabilityToPromiseItemDetailType is the container for the list of line items.

    Elements:

    • AvailabilityToPromiseItemDetail - contains the line item detail information for AvailabilityToPromise.

[^]Code Fragment

    <xsd:complexType name="ListOfAvailabilityToPromiseItemDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="AvailabilityToPromiseItemDetail" type="AvailabilityToPromiseItemDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfAvailabilityToPromiseResponseItemDetailType

ListOfAvailabilityToPromiseResponseItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( AvailabilityToPromiseResponseItemDetail[AvailabilityToPromiseResponseItemDetailType]+ )

    Description: ListOfAvailabilityToPromiseResponseItemDetailType is the container for the list of line items.

    Elements:

    • AvailabilityToPromiseResponseItemDetail - contains the item detail information for AvaialabilityToPromiseResponse.

[^]Code Fragment

    <xsd:complexType name="ListOfAvailabilityToPromiseResponseItemDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="AvailabilityToPromiseResponseItemDetail" type="AvailabilityToPromiseResponseItemDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfPriceCheckRequestItemDetailType

ListOfPriceCheckRequestItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PriceCheckRequestItemDetail[PriceCheckRequestItemDetailType]+ )

    Description: ListOfPriceCheckRequestItemDetailType contains a list of line items for PriceCheckRequest.

    Elements:

    • PriceCheckRequestItemDetail - contains item detail for the PriceCheckRequest

[^]Code Fragment

    <xsd:complexType name="ListOfPriceCheckRequestItemDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="PriceCheckRequestItemDetail" type="PriceCheckRequestItemDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfPriceCheckResultItemDetailType

ListOfPriceCheckResultItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PriceCheckResultItemDetail[PriceCheckResultItemDetailType]+ )

    Description: ListOfPriceCheckResultItemDetailType contains a list of line items for the PriceCheckResult.

    Elements:

    • PriceCheckResultItemDetail - contains the item detail information for the PriceCheckResult

[^]Code Fragment

    <xsd:complexType name="ListOfPriceCheckResultItemDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="PriceCheckResultItemDetail" type="PriceCheckResultItemDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfQuoteItemDetailType

ListOfQuoteItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( QuoteItemDetail[QuoteItemDetailType]+ )

    Description: ListOfQuoteItemDetailType contains detailed information concerning the quote.

    Elements:

    • QuoteItemDetail - contains the line item and package details of the Quote

[^]Code Fragment

    <xsd:complexType name="ListOfQuoteItemDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="QuoteItemDetail" type="QuoteItemDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfRequestQuoteItemDetailType

ListOfRequestQuoteItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( RequestQuoteItemDetail[RequestQuoteItemDetailType]+ )

    Description: ListOfRequestQuoteItemDetailType contains the line item level information for the RequestForQuotation.

    Elements:

    • RequestQuoteItemDetail - contains the line item level information for the RequestForQuotation.

[^]Code Fragment

    <xsd:complexType name="ListOfRequestQuoteItemDetailType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="RequestQuoteItemDetail" type="RequestQuoteItemDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PriceCheckRequestHeaderType

PriceCheckRequestHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PriceCheckRequestID[xsd:string] , PriceCheckRequestIssueDate[xsd:dateTime] , SellerParty[core:PartyType] , SellerIDReferenceDate[xsd:dateTime]? , BuyerParty[core:PartyType] , BuyerIDReferenceDate[xsd:dateTime]? , AccountCode[core:ReferenceType]? , ShipToParty[core:PartyType] , PriceCurrency[core:CurrencyType]? , QuoteDate[xsd:dateTime]? , PriceCheckRequestLanguage[core:LanguageType]? , PriceCheckRequestNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfAttachment[core:ListOfAttachmentType]? )

    Description: PriceCheckRequestHeaderType holds all PriceCheck header-level information. This element occurs once within the document and contains reference date along with buyer and supplier information.

    Elements:

    • PriceCheckRequestID - contains a reference number to identify the PriceCheckRequest document. This value can be used for internal audit purposes. Possible values for the ID are GUIDs, internal tracking numbers, or system generated document numbers. This reference value should not be needed for document correlation purposes since this is a synchronous transaction. It is valid for the PriceCheckRequestID & the PriceCheckResultID from the PriceCheckResult document to be the same value. For applications that do not require this type of document identification, a dummy value can be used as a default.
    • PriceCheckRequestIssueDate - indicates the date the PriceCheckRequest is transmitted.
    • SellerParty - holds information relating to the supplier who is the receiver of the PriceCheckRequest. This includes unique ID's and address information.
    • SellerIDReferenceDate - holds the date of the supplier ID reference.
    • BuyerParty - holds information relating to the Buyer who is the initiator of the PriceCheckRequest.This includes unique ID's and address information.
    • BuyerIDReferenceDate - holds the date of the buyer ID reference.
    • AccountCode - holds the account code for the buyer.
    • ShipToParty - holds the address details of the delivery party. If different delivery parties are involved in this request then they will be specified at the line item level.
    • PriceCurrency - identifies the default currency of the PriceCheckRequest, which when used at the header level may be overwritten at a lower level within the structure (line item level).
    • QuoteDate - is the date for which prices are being quoted.
    • PriceCheckRequestLanguage - identifies the language for the PriceCheckRequest.
    • PriceCheckRequestNote - contains any free-form text pertinent to the entire PriceCheckRequest. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfAttachment - contains a list of attachments applicable to the entire PriceCheckRequest. The information is not specific to a particular line item unless specifically noted.

[^]Code Fragment

    <xsd:complexType name="PriceCheckRequestHeaderType">
    <xsd:sequence>
        <xsd:element name="PriceCheckRequestID" type="xsd:string">
        <xsd:element name="PriceCheckRequestIssueDate" type="xsd:dateTime">
        <xsd:element name="SellerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="SellerIDReferenceDate" type="xsd:dateTime">
        <xsd:element name="BuyerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="BuyerIDReferenceDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="AccountCode" type="core:ReferenceType">
        <xsd:element name="ShipToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="PriceCurrency" type="core:CurrencyType">
        <xsd:element minOccurs="0" name="QuoteDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="PriceCheckRequestLanguage" type="core:LanguageType">
        <xsd:element minOccurs="0" name="PriceCheckRequestNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PriceCheckRequestItemDetailType

PriceCheckRequestItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( LineItemNum[core:LineItemNumType] , LineItemType[core:LineItemTypeType]? , ParentItemNumber[core:LineItemNumberReferenceType]? , ItemIdentifiers[core:ItemIdentifiersType] , RequestedQuantity[core:QuantityType]? , RequestedDeliveryDate[xsd:dateTime]? , MaxBackOrderQuantity[core:QuantityType]? , PriceCurrency[core:CurrencyType]? , BaseItemReferences[core:BaseItemReferencesType]? , GeneralLineItemNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfAttachment[core:ListOfAttachmentType]? )

    Description: PriceCheckRequestItemDetailType contains the item detail information for the PriceCheckRequest

    Elements:

    • LineItemNum - is a set of numbers uniquely identifying the line item for the number. In the case where the seller's system splits a line item number into 2 line items, the buyer item number will remain the same for both line items, but the seller item number will be different.
    • LineItemType - identifies whether the line item is a component group (consists of other line items), a typical line item, or a textual line item.
    • ParentItemNumber - identifies the line item that groups this and other line items. This is done using LineItemNumberReference, which specifies the number of the parent line item and whether this reference is the Buyer or Seller's number. LineItemNumberReference is a string content model of datatype integer that contains an attribute to specify whether the ParentItemNumber is a Seller or Buyer number, with the default being Buyer. This value references the parent item represented a group.
    • ItemIdentifiers - details all of the part numbers assigned to the item.
    • RequestedQuantity - is the quantity of the item that is requested for availability.
    • RequestedDeliveryDate - is the date that the requested quantity is to be delivered on.
    • MaxBackOrderQuantity - specifies the maximum quantity of an item that a customer will allow to be back ordered.
    • PriceCurrency - identifies currency which the price for the item should be specified in for the PriceCheckResult.
    • BaseItemReferences - contains all reference information for the item.
    • GeneralLineItemNote - describes any free-form text pertinent to the line item described by the PriceCheckRequestDetail. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfAttachment - contains details of the attachments for the line item.

[^]Code Fragment

    <xsd:complexType name="PriceCheckRequestItemDetailType">
    <xsd:sequence>
        <xsd:element name="LineItemNum" type="core:LineItemNumType">
        <xsd:element minOccurs="0" name="LineItemType" type="core:LineItemTypeType">
        <xsd:element minOccurs="0" name="ParentItemNumber" type="core:LineItemNumberReferenceType">
        <xsd:element name="ItemIdentifiers" type="core:ItemIdentifiersType">
        <xsd:element minOccurs="0" name="RequestedQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="RequestedDeliveryDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="MaxBackOrderQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="PriceCurrency" type="core:CurrencyType">
        <xsd:element minOccurs="0" name="BaseItemReferences" type="core:BaseItemReferencesType">
        <xsd:element minOccurs="0" name="GeneralLineItemNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PriceCheckRequestType

PriceCheckRequestType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PriceCheckRequestHeader[PriceCheckRequestHeaderType] , ListOfPriceCheckRequestItemDetail[ListOfPriceCheckRequestItemDetailType] )

    Description: PriceCheckRequestType consists of the request for a price to be sent from a buyer to a supplier. The request is only used to request the price of the goods.

    Elements:

    • PriceCheckRequestHeader - holds all PriceCheckRequest header-level information. This element occurs once within the document and contains reference date along with buyer and supplier information.
    • ListOfPriceCheckRequestItemDetail - contains a list of line items for PriceCheckRequest.

[^]Code Fragment

    <xsd:complexType name="PriceCheckRequestType">
    <xsd:sequence>
        <xsd:element name="PriceCheckRequestHeader" type="PriceCheckRequestHeaderType">
        <xsd:element name="ListOfPriceCheckRequestItemDetail" type="ListOfPriceCheckRequestItemDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PriceCheckResultHeaderType

PriceCheckResultHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PriceCheckResultID[xsd:string] , PriceCheckResultIssueDate[xsd:dateTime] , SellerParty[core:PartyType] , SellerIDReferenceDate[xsd:dateTime]? , BuyerParty[core:PartyType] , BuyerIDReferenceDate[xsd:dateTime]? , ShipToParty[core:PartyType] , PriceCheckCurrency[core:CurrencyType]? , QuoteDate[xsd:dateTime]? , PriceCheckResultLanguage[core:LanguageType]? , PriceCheckResultNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfAttachment[core:ListOfAttachmentType]? )

    Description: PriceCheckResultHeaderType holds all price check header-level information. This element occurs once within the document.

    Elements:

    • PriceCheckResultID - contains a reference number to identify the PriceCheckResult document. This value can be used for internal audit purposes. Possible values for the ID are GUIDs, internal tracking numbers, or system generated document numbers. This reference value should not be needed for document correlation purposes since this is a synchronous transaction. It is valid for the PriceCheckResultID & the PriceCheckRequestID from the PriceCheckRequest document to be the same value. For applications that do not require this type of document identification, a dummy value can be used as a default.
    • PriceCheckResultIssueDate - indicates the date the PriceCheckResult is transmitted.
    • SellerParty - holds information from the supplier as a response to the PriceCheckRequest.
    • SellerIDReferenceDate - holds the date of the supplier ID reference.
    • BuyerParty - holds information relating to the buyer who is the receiver of the PriceCheckResult.
    • BuyerIDReferenceDate - holds the date of the buyer ID reference.
    • ShipToParty - holds the address details of the delivery party. If different delivery parties are involved in this request then they will be specified at the line item level.
    • PriceCheckCurrency - identifies the default currency of the PriceCheckResult which when used at the header level may be overwritten at a lower level within the structure (line item level).
    • QuoteDate - is the date for which prices are being quoted.
    • PriceCheckResultLanguage - contains the language for the PriceCheckResult.
    • PriceCheckResultNote - contains additional information in, free form text, pertinent to the PriceCheckResult
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfAttachment - contains details of the attachments for the PriceCheckResult.

[^]Code Fragment

    <xsd:complexType name="PriceCheckResultHeaderType">
    <xsd:sequence>
        <xsd:element name="PriceCheckResultID" type="xsd:string">
        <xsd:element name="PriceCheckResultIssueDate" type="xsd:dateTime">
        <xsd:element name="SellerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="SellerIDReferenceDate" type="xsd:dateTime">
        <xsd:element name="BuyerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="BuyerIDReferenceDate" type="xsd:dateTime">
        <xsd:element name="ShipToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="PriceCheckCurrency" type="core:CurrencyType">
        <xsd:element minOccurs="0" name="QuoteDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="PriceCheckResultLanguage" type="core:LanguageType">
        <xsd:element minOccurs="0" name="PriceCheckResultNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PriceCheckResultItemDetailType

PriceCheckResultItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( LineItemNum[core:LineItemNumType] , LineItemType[core:LineItemTypeType]? , ParentItemNumber[core:LineItemNumberReferenceType]? , ItemIdentifiers[core:ItemIdentifiersType]? , RequestedQuantity[core:QuantityType]? , RequestedDeliveryDate[xsd:dateTime]? , MaxBackOrderQuantity[core:QuantityType]? , BaseItemReferences[core:BaseItemReferencesType]? , ResultPrice[core:PriceType] , PriceErrorInfo[core:ErrorInfoType]? , GeneralLineItemNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfAttachment[core:ListOfAttachmentType]? )

    Description: PriceCheckResultItemDetailType contains the item detail information for the PriceCheckResult

    Elements:

    • LineItemNum - is a set of numbers uniquely identifying the line item for the number. In the case where the seller's system splits a line item number into 2 line items, the buyer item number will remain the same for both line items, but the seller item number will be different.
    • LineItemType - identifies whether the line item is a component group (consists of other line items), a typical line item, or a textual line item.
    • ParentItemNumber - identifies the line item that groups this and other line items. This is done using LineItemNumberReference, which specifies the number of the parent line item and whether this reference is the Buyer or Seller's number. LineItemNumberReference is a string content model of datatype integer that contains an attribute to specify whether the ParentItemNumber is a Seller or Buyer number, with the default being Buyer. This value references the parent item represented a group.
    • ItemIdentifiers - details all of the part numbers assigned to the item.
    • RequestedQuantity - is the quantity of the item that is requested for availability.
    • RequestedDeliveryDate - is the date that the requested quantity is to be delivered on.
    • MaxBackOrderQuantity - specifies the maximum quantity of an item that a customer will allow to be back ordered.
    • BaseItemReferences - contains all reference information for the item.
    • ResultPrice - is the unit price for the product when purchased in a particular quantity during a particular time period.
    • PriceErrorInfo - is optional error info related to price.
    • GeneralLineItemNote - describes any free-form text pertinent to the line item described by the PriceCheckResultDetail. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfAttachment - contains details of the attachments for the line item.

[^]Code Fragment

    <xsd:complexType name="PriceCheckResultItemDetailType">
    <xsd:sequence>
        <xsd:element name="LineItemNum" type="core:LineItemNumType">
        <xsd:element minOccurs="0" name="LineItemType" type="core:LineItemTypeType">
        <xsd:element minOccurs="0" name="ParentItemNumber" type="core:LineItemNumberReferenceType">
        <xsd:element minOccurs="0" name="ItemIdentifiers" type="core:ItemIdentifiersType">
        <xsd:element minOccurs="0" name="RequestedQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="RequestedDeliveryDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="MaxBackOrderQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="BaseItemReferences" type="core:BaseItemReferencesType">
        <xsd:element name="ResultPrice" type="core:PriceType">
        <xsd:element minOccurs="0" name="PriceErrorInfo" type="core:ErrorInfoType">
        <xsd:element minOccurs="0" name="GeneralLineItemNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: PriceCheckResultType

PriceCheckResultType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( PriceCheckResultHeader[PriceCheckResultHeaderType] , ListOfPriceCheckResultItemDetail[ListOfPriceCheckResultItemDetailType] )

    Description: PriceCheckResultType consists of the response from a supplier to a PriceCheckRequest sent by a buyer. The PriceCheckResult contains specific price information for items in the PriceCheckRequest

    Elements:

    • PriceCheckResultHeader - holds all of the PriceCheckResult header-level information. This element occurs once within the document.
    • ListOfPriceCheckResultItemDetail - contains a list of line items for the PriceCheckResult.

[^]Code Fragment

    <xsd:complexType name="PriceCheckResultType">
    <xsd:sequence>
        <xsd:element name="PriceCheckResultHeader" type="PriceCheckResultHeaderType">
        <xsd:element name="ListOfPriceCheckResultItemDetail" type="ListOfPriceCheckResultItemDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: QuotationRequestReferenceType

QuotationRequestReferenceType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( QuotationReqReference[core:ReferenceType] , ReferenceReleaseNumber[xsd:string]? )

    Description: QuotationRequestReferenceType identifies the RequestReference.

    Elements:

    • QuotationReqReference - contains the reference for the Request for which the Quote is placed against.
    • ReferenceReleaseNumber - identifies the specific iteration of the quotation (if applicable).

[^]Code Fragment

    <xsd:complexType name="QuotationRequestReferenceType">
    <xsd:sequence>
        <xsd:element name="QuotationReqReference" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="ReferenceReleaseNumber" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: QuoteBaseItemDetailType

QuoteBaseItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: Extends: RequestQuoteBaseItemDetailType

      Append:( QuoteItemReferences[RequestQuoteReferenceType]? , QuoteParty[QuotePartyType]? )

    Description: QuoteBaseItemDetailType identifies the material relevant information associated with the quote.

    Elements:

    • QuoteItemReferences - identifies the references at line item level.
    • QuoteParty - identifies the parties at line item level.

[^]Code Fragment

    <xsd:complexType name="QuoteBaseItemDetailType">
    <xsd:complexContent>
        <xsd:extension base="RequestQuoteBaseItemDetailType">
            <xsd:sequence>
                <xsd:element minOccurs="0" name="QuoteItemReferences" type="RequestQuoteReferenceType">
                <xsd:element minOccurs="0" name="QuoteParty" type="QuotePartyType">
            </xsd:sequence>
        </xsd:extension>
    </xsd:complexContent>
</xsd:complexType>


complexType definition: QuoteDetailType

QuoteDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ListOfQuoteItemDetail[ListOfQuoteItemDetailType]? , ListOfPackageDetail[core:ListOfPackageDetailType]? )

    Description: QuoteDetailType contains detail information for the quote.

    Elements:

    • ListOfQuoteItemDetail - contains the line level detail information for the Quote.
    • ListOfPackageDetail - lists the packaging information for the Quote.

[^]Code Fragment

    <xsd:complexType name="QuoteDetailType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ListOfQuoteItemDetail" type="ListOfQuoteItemDetailType">
        <xsd:element minOccurs="0" name="ListOfPackageDetail" type="core:ListOfPackageDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: QuoteHeaderType

QuoteHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( QuoteID[xsd:string] , QuoteIssueDate[xsd:dateTime] , RequestQuoteReference[QuotationRequestReferenceType]? , QuoteType[QuoteTypeType]? , QuoteExpirationDate[xsd:dateTime]? , Purpose[core:PurposeType]? , QuoteParty[QuotePartyType] , ListOfTransportRouting[core:ListOfTransportRoutingType]? , QuoteCurrency[core:CurrencyType]? , AllowancesOrCharges[core:ListOfAllowOrChargeType]? , PaymentInstructions[core:PaymentInstructionsType]? , TermsOfDelivery[core:TermsOfDeliveryType]? , TaxReference[core:TaxReferenceType]* , Language[core:LanguageType]? , QuoteHeaderNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfAttachment[core:ListOfAttachmentType]? )

    Description: QuoteHeaderType holds all RequestforQuotation header-level information. This element occurs once within the document.

    Elements:

    • QuoteID - is the unique number assigned to the Quote, typically according to the system that generated the Quote.
    • QuoteIssueDate - holds a time stamp provided by the application that created the Quote document.
    • RequestQuoteReference - identifies the RequestReference sent in the RequestForQuotation.
    • QuoteType - specifies the type of Quote generated in response to the request.
    • QuoteExpirationDate - contains the date on which the quote expires.
    • Purpose - identifies the purpose of the quote. Typical values are New, Copy, and Replacement.
    • QuoteParty - specifies the parties involved in the Quote.
    • ListOfTransportRouting - specifies the transport for the Quote.
    • QuoteCurrency - specifies the currency used for the Quote.
    • AllowancesOrCharges - lists the allowance and or charges for the Quote.
    • PaymentInstructions - describes the terms of payment for the Quote.
    • TermsOfDelivery - defines the terms of delivery for the Quote.
    • TaxReference - provides the tax information for the Quote.
    • Language - identifies the language used on the Quote.
    • QuoteHeaderNote - contains any free-form text pertinent to the entire consignment described by the Quote or to This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information. This can be used to nominate another supplier if applicable.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfAttachment - lists the attachments for the quote.

[^]Code Fragment

    <xsd:complexType name="QuoteHeaderType">
    <xsd:sequence>
        <xsd:element name="QuoteID" type="xsd:string">
        <xsd:element name="QuoteIssueDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="RequestQuoteReference" type="QuotationRequestReferenceType">
        <xsd:element minOccurs="0" name="QuoteType" type="QuoteTypeType">
        <xsd:element minOccurs="0" name="QuoteExpirationDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="Purpose" type="core:PurposeType">
        <xsd:element name="QuoteParty" type="QuotePartyType">
        <xsd:element minOccurs="0" name="ListOfTransportRouting" type="core:ListOfTransportRoutingType">
        <xsd:element minOccurs="0" name="QuoteCurrency" type="core:CurrencyType">
        <xsd:element minOccurs="0" name="AllowancesOrCharges" type="core:ListOfAllowOrChargeType">
        <xsd:element minOccurs="0" name="PaymentInstructions" type="core:PaymentInstructionsType">
        <xsd:element minOccurs="0" name="TermsOfDelivery" type="core:TermsOfDeliveryType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="TaxReference" type="core:TaxReferenceType">
        <xsd:element minOccurs="0" name="Language" type="core:LanguageType">
        <xsd:element minOccurs="0" name="QuoteHeaderNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: QuoteItemDetailType

QuoteItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( QuoteItemType[QuoteTypeType] , QuoteBaseItemDetail[QuoteBaseItemDetailType] , PricingDetail[core:PricingDetailType]? , DeliveryDetail[core:DeliveryDetailType]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfAttachment[core:ListOfAttachmentType]? )

    Description: QuoteItemDetailType identifies the material relevant information associated with the quote.

    Elements:

    • QuoteItemType - specifies the type of quote at item level.
    • QuoteBaseItemDetail - identifies the material relevant information associated with the quote.
    • PricingDetail - holds the pricing information for the line item.
    • DeliveryDetail - holds the delivery information for the line item- includes scheduling, transport, delivery terms and basic packaging information for the line item.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfAttachment - contains the attachments for the line item.

[^]Code Fragment

    <xsd:complexType name="QuoteItemDetailType">
    <xsd:sequence>
        <xsd:element name="QuoteItemType" type="QuoteTypeType">
        <xsd:element name="QuoteBaseItemDetail" type="QuoteBaseItemDetailType">
        <xsd:element minOccurs="0" name="PricingDetail" type="core:PricingDetailType">
        <xsd:element minOccurs="0" name="DeliveryDetail" type="core:DeliveryDetailType">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: QuotePartyType

QuotePartyType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( BuyerParty[core:PartyType] , SellerParty[core:PartyType] , ShipToParty[core:PartyType]? , BillToParty[core:PartyType]? , RemitToParty[core:PartyType]? , ShipFromParty[core:PartyType]? , WarehouseParty[core:PartyType]? , SoldToParty[core:PartyType]? , ManufacturingParty[core:PartyType]? , MaterialIssuer[core:PartyType]? , ListOfPartyCoded[core:ListOfPartyCodedType]? )

    Description: QuotePartyType holds all party information related to ordering goods.

    Elements:

    • BuyerParty - contains the information for the party purchasing the goods.
    • SellerParty - identifies the party selling the goods.
    • ShipToParty - contains the information for the party which the items are to be shipped.
    • BillToParty - contains the information for the party that will receive the bill for the goods..
    • RemitToParty - contains the information for the party to be paid.
    • ShipFromParty - contains party information identifying the location from which the items are to be shipped.
    • WarehouseParty - contains party information identifying the warehouse from which the items are to be shipped.
    • SoldToParty - contains party information identifying the location where the items were sold.
    • ManufacturingParty - contains the party information identifying the location where the item is to be or is being manufactured.
    • MaterialIssuer - contains the information identifying the location that is issuing the request for the material.
    • ListOfPartyCoded - is a collection of all other party information not explicitly stated as the content of another element.

[^]Code Fragment

    <xsd:complexType name="QuotePartyType">
    <xsd:sequence>
        <xsd:element name="BuyerParty" type="core:PartyType">
        <xsd:element name="SellerParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ShipToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="BillToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="RemitToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ShipFromParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="WarehouseParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="SoldToParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ManufacturingParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="MaterialIssuer" type="core:PartyType">
        <xsd:element minOccurs="0" name="ListOfPartyCoded" type="core:ListOfPartyCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: QuoteType

QuoteType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( QuoteHeader[QuoteHeaderType] , QuoteDetail[QuoteDetailType]? , DigitalSignature[dgs:SignatureType]? )

    Description: QuoteType contains information in response to a RequestForQuotation. This will contain details on the availability of the goods and prices if applicable.

    Elements:

    • QuoteHeader - holds the header-level information for the Quote.
    • QuoteDetail - contains the line item and packaging information for the quote.
    • DigitalSignature - contains a digital signature for the document.

[^]Code Fragment

    <xsd:complexType name="QuoteType">
    <xsd:sequence>
        <xsd:element name="QuoteHeader" type="QuoteHeaderType">
        <xsd:element minOccurs="0" name="QuoteDetail" type="QuoteDetailType">
        <xsd:element minOccurs="0" name="DigitalSignature" type="dgs:SignatureType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: QuoteTypeCodeType

QuoteTypeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Accept - Accept
    • Decline - Decline
    • AlternateBid - AlternateBid
    • BestAndFinal - BestAndFinal
    • BidWithoutException - BidWithoutException
    • BidWithoutExceptionRequestForInformation - Bid Without Exception and Request For Information
    • RequestForTimeExtension - RequestForTimeExtension
    • DeclinedToQuote - DeclinedToQuote
    • OneOfMultiple - One of Multiple
    • Replacement - Replacement
    • UnableToQuote - UnableToQuote
    • AcceptWithChanges - AcceptWithChanges
    • Other - CustomCode

[^]Code Fragment

    <xsd:simpleType name="QuoteTypeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Accept">
        <xsd:enumeration value="Decline">
        <xsd:enumeration value="AlternateBid">
        <xsd:enumeration value="BestAndFinal">
        <xsd:enumeration value="BidWithoutException">
        <xsd:enumeration value="BidWithoutExceptionRequestForInformation">
        <xsd:enumeration value="RequestForTimeExtension">
        <xsd:enumeration value="DeclinedToQuote">
        <xsd:enumeration value="OneOfMultiple">
        <xsd:enumeration value="Replacement">
        <xsd:enumeration value="UnableToQuote">
        <xsd:enumeration value="AcceptWithChanges">
        <xsd:enumeration value="Other">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: QuoteTypeType

QuoteTypeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( QuoteTypeCoded[QuoteTypeCodeType] , QuoteTypeCodedOther[xsd:string]? )

    Description: QuoteTypeType specifies the type of quote generated in response to the request.

    Elements:

    • QuoteTypeCoded - lists the code values for the type of the Quote.
    • QuoteTypeCodedOther - is used to specify a non-standard QuoteTypeCode. The element is mandatory if the value of QuoteTypeCoded is "Other". These codes should not contain white spaces unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="QuoteTypeType">
    <xsd:sequence>
        <xsd:element name="QuoteTypeCoded" type="QuoteTypeCodeType">
        <xsd:element minOccurs="0" name="QuoteTypeCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: RequestForQuotationType

RequestForQuotationType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( RequestQuoteHeader[RequestQuoteHeaderType] , RequestQuoteDetail[RequestQuoteDetailType]? , DigitalSignature[dgs:SignatureType]? )

    Description: RequestForQuotationType consists of the request for a quotation to be sent from the buyer to the supplier. The document outlines the requirements regarding the details for a request for quotation sent directly between the two parties. The request can be used to request goods or services. The requests are based on the terms and conditions defined either in a previous purchasing agreement or in the request itself. The request can be used to determine the availability of goods from existing suppliers where price will not be a deciding factor. The RequestForQuotation defined here allows for delivery information to be built into the request. All schedule requirements relating to shipping and release authorization will be handled by the ShippingSchedule document. The response to the request (a quote) can be used as the basis for a purchase order by the buyer if appropriate.

    Elements:

    • RequestQuoteHeader - holds all RequestForQuotation header-level information.
    • RequestQuoteDetail - contains the line level and packaging detail information for the RequestForQuotation.
    • DigitalSignature - contains a digital signature for the document.

[^]Code Fragment

    <xsd:complexType name="RequestForQuotationType">
    <xsd:sequence>
        <xsd:element name="RequestQuoteHeader" type="RequestQuoteHeaderType">
        <xsd:element minOccurs="0" name="RequestQuoteDetail" type="RequestQuoteDetailType">
        <xsd:element minOccurs="0" name="DigitalSignature" type="dgs:SignatureType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: RequestQuoteBaseItemDetailType

RequestQuoteBaseItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( LineItemNum[core:LineItemNumType] , LineItemType[core:LineItemTypeType]? , ParentItemNumber[core:LineItemNumberReferenceType]? , ItemIdentifiers[core:ItemIdentifiersType]? , LeadTime[core:MeasurementType]? , ListOfDimension[core:ListOfDimensionType]? , TotalQuantity[core:QuantityType] , MaxBackOrderQuantity[core:QuantityType]? , ListOfQuantityCoded[core:ListOfQuantityCodedType]? , BaseItemReferences[core:BaseItemReferencesType]? )

    Description: RequestQuoteBaseItemDetailType identifies the line item for the item being requested for quotation.

    Elements:

    • LineItemNum - is a set of numbers uniquely identifying the line item for the number. In the case where the seller's system splits a line item number into 2 line items, the buyer item number will remain the same for both line items, but the seller item number will be different.
    • LineItemType - identifies whether the line item is a component group (consists of other line items), a typical line item, or a textual line item.
    • ParentItemNumber - identifies the line item that groups this and other line items. This is done using LineItemNumberReference, which specifies the number of the parent line item and whether this reference is the Buyer or Seller's number. LineItemNumberReference is a string content model of datatype integer that contains an attribute to specify whether the ParentItemNumber is a Seller or Buyer number, with the default being Buyer. This value references the parent item represented a group.
    • ItemIdentifiers - details all of the part numbers assigned to the item.
    • LeadTime - specifies the lead time for the item.
    • ListOfDimension - lists one or more quantitative measurements of the item.
    • TotalQuantity - contains the total amount of the line item pertaining to the document.
    • MaxBackOrderQuantity - specifies the maximum quantity of an item that a customer will allow to be back ordered.
    • ListOfQuantityCoded - specifies any other quantities not explicitly stated.
    • BaseItemReferences - contains all reference information for the item.

[^]Code Fragment

    <xsd:complexType name="RequestQuoteBaseItemDetailType">
    <xsd:sequence>
        <xsd:element name="LineItemNum" type="core:LineItemNumType">
        <xsd:element minOccurs="0" name="LineItemType" type="core:LineItemTypeType">
        <xsd:element minOccurs="0" name="ParentItemNumber" type="core:LineItemNumberReferenceType">
        <xsd:element minOccurs="0" name="ItemIdentifiers" type="core:ItemIdentifiersType">
        <xsd:element minOccurs="0" name="LeadTime" type="core:MeasurementType">
        <xsd:element minOccurs="0" name="ListOfDimension" type="core:ListOfDimensionType">
        <xsd:element name="TotalQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="MaxBackOrderQuantity" type="core:QuantityType">
        <xsd:element minOccurs="0" name="ListOfQuantityCoded" type="core:ListOfQuantityCodedType">
        <xsd:element minOccurs="0" name="BaseItemReferences" type="core:BaseItemReferencesType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: RequestQuoteDateType

RequestQuoteDateType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( RequestQuoteValidityDate[core:ValidityDatesType] , DecisionDate[xsd:dateTime]? , DeliveryDate[xsd:dateTime]? , DeliveryDateEarliest[xsd:dateTime]? , DeliveryDateLatest[xsd:dateTime]? , AdviseBefore[xsd:dateTime]? , CancelIfNotDelivered[xsd:dateTime]? , ListOfDateCoded[core:ListOfDateCodedType]? )

    Description: RequestQuoteDateType holds the dates for the RequestforQuotation.

    Elements:

    • RequestQuoteValidityDate - holds horizon start and end dates to indicate the validity period of the Request.
    • DecisionDate - indicates the date by when a decision will be made. This is always later than the end date.
    • DeliveryDate - specifies the delivery date for the goods.
    • DeliveryDateEarliest - specifies the earliest delivery date.
    • DeliveryDateLatest - specifies the latest delivery date.
    • AdviseBefore - specifies the date that you must advise before.
    • CancelIfNotDelivered - specifies the date that the goods must be delivered by or the order will be cancelled.
    • ListOfDateCoded - contains all other dates not explicitly stated as the content of other elements.

[^]Code Fragment

    <xsd:complexType name="RequestQuoteDateType">
    <xsd:sequence>
        <xsd:element name="RequestQuoteValidityDate" type="core:ValidityDatesType">
        <xsd:element minOccurs="0" name="DecisionDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="DeliveryDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="DeliveryDateEarliest" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="DeliveryDateLatest" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="AdviseBefore" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="CancelIfNotDelivered" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="ListOfDateCoded" type="core:ListOfDateCodedType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: RequestQuoteDetailType

RequestQuoteDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ListOfRequestQuoteItemDetail[ListOfRequestQuoteItemDetailType]? , ListOfPackageDetail[core:ListOfPackageDetailType]? )

    Description: RequestQuoteDetailType contains the line item and packaging information for the quotation request.

    Elements:

    • ListOfRequestQuoteItemDetail - contains the line level detail information for the RequestForQuotation.
    • ListOfPackageDetail - lists the packaging information.

[^]Code Fragment

    <xsd:complexType name="RequestQuoteDetailType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ListOfRequestQuoteItemDetail" type="ListOfRequestQuoteItemDetailType">
        <xsd:element minOccurs="0" name="ListOfPackageDetail" type="core:ListOfPackageDetailType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: RequestQuoteHeaderType

RequestQuoteHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( RequestQuoteID[xsd:string] , RequestQuoteIssueDate[xsd:dateTime] , RequestForQuotationReferences[RequestQuoteReferenceType]? , Purpose[RequestQuotePurposeType]? , RequestQuoteDates[RequestQuoteDateType]? , QuoteParty[QuotePartyType] , ResultingOrderType[core:OrderTypeType]? , QuoteCurrency[core:CurrencyType]? , AllowancesOrCharges[core:ListOfAllowOrChargeType]? , PaymentInstructions[core:PaymentInstructionsType]? , TermsOfDelivery[core:TermsOfDeliveryType]? , TaxReference[core:TaxReferenceType]? , ListOfTransportRounting[core:ListOfTransportRoutingType]? , Language[core:LanguageType]? , RequestQuoteHeaderNotes[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfAttachment[core:ListOfAttachmentType]? )

    Description: RequestQuoteHeaderType holds all RequestForQuotation header-level information.

    Elements:

    • RequestQuoteID - contains a reference number to identify the request document.
    • RequestQuoteIssueDate - indicates the date the request is created in the application.
    • RequestForQuotationReferences - contains a list of references for the request.
    • Purpose - indicates the use of the document.
    • RequestQuoteDates - holds the dates for the RequestforQuotation.
    • QuoteParty - identifies the parties involved in the quotation.
    • ResultingOrderType - identifies the type of the resulting order.
    • QuoteCurrency - identifies the currency to quote in.
    • AllowancesOrCharges - lists the allowances and or charges for the request.
    • PaymentInstructions - describes the terms of payment relevant to the request.
    • TermsOfDelivery - defines the terms of delivery for the request.
    • TaxReference - identifies the relevant tax information.
    • ListOfTransportRounting - describes the transport information for the message.
    • Language - describes the language used on the RequestForQuotation.
    • RequestQuoteHeaderNotes - contains general instructions for the RequestForQuotation. This can be used to nominate another supplier if applicable.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfAttachment - holds the list of attachments for the request.

[^]Code Fragment

    <xsd:complexType name="RequestQuoteHeaderType">
    <xsd:sequence>
        <xsd:element name="RequestQuoteID" type="xsd:string">
        <xsd:element name="RequestQuoteIssueDate" type="xsd:dateTime">
        <xsd:element minOccurs="0" name="RequestForQuotationReferences" type="RequestQuoteReferenceType">
        <xsd:element minOccurs="0" name="Purpose" type="RequestQuotePurposeType">
        <xsd:element minOccurs="0" name="RequestQuoteDates" type="RequestQuoteDateType">
        <xsd:element name="QuoteParty" type="QuotePartyType">
        <xsd:element minOccurs="0" name="ResultingOrderType" type="core:OrderTypeType">
        <xsd:element minOccurs="0" name="QuoteCurrency" type="core:CurrencyType">
        <xsd:element minOccurs="0" name="AllowancesOrCharges" type="core:ListOfAllowOrChargeType">
        <xsd:element minOccurs="0" name="PaymentInstructions" type="core:PaymentInstructionsType">
        <xsd:element minOccurs="0" name="TermsOfDelivery" type="core:TermsOfDeliveryType">
        <xsd:element minOccurs="0" name="TaxReference" type="core:TaxReferenceType">
        <xsd:element minOccurs="0" name="ListOfTransportRounting" type="core:ListOfTransportRoutingType">
        <xsd:element minOccurs="0" name="Language" type="core:LanguageType">
        <xsd:element minOccurs="0" name="RequestQuoteHeaderNotes" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: RequestQuoteItemDetailType

RequestQuoteItemDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( RequestQuoteBaseItemDetail[RequestQuoteBaseItemDetailType] , PricingDetail[core:PricingDetailType]? , DeliveryDetail[core:DeliveryDetailType]? , LineItemNote[xsd:string]? , ListOfStructuredNote[core:ListOfStructuredNoteType]? , ListOfAttachment[core:ListOfAttachmentType]? )

    Description: RequestQuoteItemDetailType contains the line item level information for the RequestForQuotation.

    Elements:

    • RequestQuoteBaseItemDetail - identifies the material relevant information associated with the RequestForQuotation.
    • PricingDetail - identifies details of the pricing associated with the line item.
    • DeliveryDetail - specifies delivery information for the line item including scheduling, transport, delivery terms and basic packaging information for the line item.
    • LineItemNote - describes any free form text pertinent to the line item. This element may contain notes or any other similar information that is not contained explicitly in another structure. You should not assume that the receiving application is capable of doing more than storing and/or displaying this information.
    • ListOfStructuredNote - contains one or more structured notes that allow you to provide notes that are more than a simple free-text field. such notes may include the message text, or this text may be referenced with an external identifier or a URL. An agency may be specified, and is needed in the case where an ID has been provided for a note that is either included in-line or referenced. This field is often used to include references to centrally stored clauses in contracts that are required to appear within business documents.
    • ListOfAttachment - contains attachments for the line item.

[^]Code Fragment

    <xsd:complexType name="RequestQuoteItemDetailType">
    <xsd:sequence>
        <xsd:element name="RequestQuoteBaseItemDetail" type="RequestQuoteBaseItemDetailType">
        <xsd:element minOccurs="0" name="PricingDetail" type="core:PricingDetailType">
        <xsd:element minOccurs="0" name="DeliveryDetail" type="core:DeliveryDetailType">
        <xsd:element minOccurs="0" name="LineItemNote" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfStructuredNote" type="core:ListOfStructuredNoteType">
        <xsd:element minOccurs="0" name="ListOfAttachment" type="core:ListOfAttachmentType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: RequestQuotePurposeCodeType

RequestQuotePurposeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Description:
    This code identifies the purpose of the RequestforQuotation message. This is a subset code list derived from EDIFACT 1225 (Message function, coded) and X12 353 (Transaction set purpose code) and 587 (Acknowledgement type code)

    Content: Restriction of base type core:PurposeCodeType

    Enumerated List:

    • Original - Refers to the initial transmission of the message.
    • Cancellation - Indicates that a previous transmission of the message is to be cancelled.
    • Replace - Indicates that this transmission is to replace a previous message.
    • Confirmation - Indicates that this transmission is to confirm details of a previous message.
    • Duplicate - Indicates that this transmission is a duplicate of a previously generated message.
    • Other - Custom code

[^]Code Fragment

    <xsd:simpleType name="RequestQuotePurposeCodeType">
    <xsd:restriction base="core:PurposeCodeType">
        <xsd:enumeration value="Original">
        <xsd:enumeration value="Cancellation">
        <xsd:enumeration value="Replace">
        <xsd:enumeration value="Confirmation">
        <xsd:enumeration value="Duplicate">
        <xsd:enumeration value="Other">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: RequestQuotePurposeType

RequestQuotePurposeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( RequestQuotePurposeCoded[RequestQuotePurposeCodeType] , RequestQuotePurposeCodedOther[xsd:string]? )

    Description: RequestQuotePurposeType indicates the use of the document.

    Elements:

    • RequestQuotePurposeCoded - indicates the intended use of the RequestforQuotation.
    • RequestQuotePurposeCodedOther - is used to provide a non-standard RequestQuotePurposeCode. This element is mandatory if the value of RequestQuotePurposeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.

[^]Code Fragment

    <xsd:complexType name="RequestQuotePurposeType">
    <xsd:sequence>
        <xsd:element name="RequestQuotePurposeCoded" type="RequestQuotePurposeCodeType">
        <xsd:element minOccurs="0" name="RequestQuotePurposeCodedOther" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: RequestQuoteReferenceType

RequestQuoteReferenceType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/preordermanagement/v1_0/preordermanagement.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd
      • [dgs] - http://www.w3.org/2000/09/xmldsig#

    Content: ( ContractReference[core:ContractType]? , AccountNumber[core:ReferenceType]? , PriceListNumber[core:ReferenceType]? , PriceListVersionNumber[core:ReferenceType]? , BuyersCatalogNumber[core:ReferenceType]? , OtherRequestQuoteReferences[core:ListOfReferenceCodedType]? )

    Description: RequestQuoteReferenceType contains a list of references for the request.

    Elements:

    • ContractReference - identifies the contract number which the request is referencing.
    • AccountNumber - contains the buyers account code with the supplier.
    • PriceListNumber - identifies the reference number of the price list.
    • PriceListVersionNumber - identifies the version number of the price list.
    • BuyersCatalogNumber - identifies the catalog number of the buyer.
    • OtherRequestQuoteReferences - lists any other references to the Request not documented by the ContractReference.

[^]Code Fragment

    <xsd:complexType name="RequestQuoteReferenceType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ContractReference" type="core:ContractType">
        <xsd:element minOccurs="0" name="AccountNumber" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="PriceListNumber" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="PriceListVersionNumber" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="BuyersCatalogNumber" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="OtherRequestQuoteReferences" type="core:ListOfReferenceCodedType">
    </xsd:sequence>
</xsd:complexType>


Simple Types:

ATPCheckTypeCodeType
AvailabilityDeliveryOptionCodeType
AvailabilityToPromisePurposeCodeType
AvailabilityToPromiseResponseCodeType
QuoteTypeCodeType
RequestQuotePurposeCodeType


complexType definition: BaseCharacteristicLocationType

BaseCharacteristicLocationType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( LocationAttributeID[xsd:string] , LocationAttributeName[core:IdentifierType]* , LocationAttributeDescription[xsd:string]? , Location[core:LocationType]? , LocationNotes[xsd:string]? , OtherLocationAttribute[CharacteristicAttributeType]? )

    Description: BaseCharacteristicLocationType contains the details describing a location. It also includes a generic characteristic field to allow for user specific location related data.

    Elements:

    • LocationAttributeID - contains a unique identifier which serves as the technical description or primary key of the location with respect to the originating system.
    • LocationAttributeName - contains the human readable value to identify the location. The LocationAttributeName will contain the attributes Agency and AgencyCoded which can be used to qualify the value of the LocationName.
    • LocationAttributeDescription - is used to describe the location. This is a language dependent text field.
    • Location - contains details relevant to describing the location. This includes name, address, and contact information.
    • LocationNotes - gives specifications relating to the location description.
    • OtherLocationAttribute - is additional user-specific characteristics related to the location.

[^]Code Fragment

    <xsd:complexType name="BaseCharacteristicLocationType">
    <xsd:sequence>
        <xsd:element name="LocationAttributeID" type="xsd:string">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="LocationAttributeName" type="core:IdentifierType">
        <xsd:element minOccurs="0" name="LocationAttributeDescription" type="xsd:string">
        <xsd:element minOccurs="0" name="Location" type="core:LocationType">
        <xsd:element minOccurs="0" name="LocationNotes" type="xsd:string">
        <xsd:element minOccurs="0" name="OtherLocationAttribute" type="CharacteristicAttributeType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: BaseCharacteristicProductType

BaseCharacteristicProductType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( ProductAttributeID[xsd:string] , ProductAttributeName[core:IdentifierType]* , ProductAttributeDescription[xsd:string]? , ListOfDimension[core:ListOfDimensionType]? , ProductNotes[xsd:string]? , OtherProductAttribute[CharacteristicAttributeType]? )

    Description: BaseCharacteristicProductType contains the details describing a characteristic product. It also includes a generic characteristic field to allow for user-specific product related data.

    Elements:

    • ProductAttributeID - contains a unique identifier which serves as the technical description or primary key of the product with respect to the originating system.
    • ProductAttributeName - contains the human readable value to identify the product.
    • ProductAttributeDescription - is used to describe the product. This is a language dependent text field.
    • ListOfDimension - element is a container for a list of one or more dimension elements.
    • ProductNotes - gives specifications relating to the product.
    • OtherProductAttribute - is additional user-specific characteristics related to the product.

[^]Code Fragment

    <xsd:complexType name="BaseCharacteristicProductType">
    <xsd:sequence>
        <xsd:element name="ProductAttributeID" type="xsd:string">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="ProductAttributeName" type="core:IdentifierType">
        <xsd:element minOccurs="0" name="ProductAttributeDescription" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfDimension" type="core:ListOfDimensionType">
        <xsd:element minOccurs="0" name="ProductNotes" type="xsd:string">
        <xsd:element minOccurs="0" name="OtherProductAttribute" type="CharacteristicAttributeType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: CharacteristicAttributeType

CharacteristicAttributeType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( CharacteristicName[xsd:string] , CharacteristicAttributeID[xsd:string] , CharacteristicAttributeName[core:IdentifierType]* , CharacteristicAttributeDescription[xsd:string]? , ListOfDimension[core:ListOfDimensionType]? , CharacteristicAttributeNote[xsd:string]? , OtherCharacteristicAttribute[CharacteristicAttributeType]* )

    Description: CharacteristicAttributeType contains the details relevant to describing a characteristic. It also includes a generic characteristic field to allow for user-defined data.

    Elements:

    • CharacteristicName - identifies the characteristic being described. Examples of CharacteristicName are product and location.
    • CharacteristicAttributeID - identifies the ID for the characteristic being described.
    • CharacteristicAttributeName - contains the human readable value to identify the characteristic. The identifier element consists of an agency and a string value. The string will hold the CharacteristicAttributeName value. The agency will be used to identify the origins of the CharacteristicAttributeName value.
    • CharacteristicAttributeDescription - provides a description of the characteristic
    • ListOfDimension - is used to further describe the CharacteristicAttribute.
    • CharacteristicAttributeNote - provides additional information about the characteristic
    • OtherCharacteristicAttribute - is additional user-specific characteristics related to the CharacteristicAttribute.

[^]Code Fragment

    <xsd:complexType name="CharacteristicAttributeType">
    <xsd:sequence>
        <xsd:element name="CharacteristicName" type="xsd:string">
        <xsd:element name="CharacteristicAttributeID" type="xsd:string">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="CharacteristicAttributeName" type="core:IdentifierType">
        <xsd:element minOccurs="0" name="CharacteristicAttributeDescription" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfDimension" type="core:ListOfDimensionType">
        <xsd:element minOccurs="0" name="CharacteristicAttributeNote" type="xsd:string">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="OtherCharacteristicAttribute" type="CharacteristicAttributeType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: CharacteristicCombinationType

CharacteristicCombinationType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( CharacteristicCombinationPurposeCoded[TimeSeriesPurposeCodeType]? , CharacteristicCombinationPurposeCodedOther[xsd:string]? , CharacteristicCombinationResponseCoded[TimeSeriesErrorCodeType]? , CharacteristicCombinationResponseCodedOther[xsd:string]? , CharacteristicCombinationID[xsd:string] , CharacteristicProduct[CharacteristicProductType]? , CharacteristicLocation[CharacteristicLocationType]? , CharacteristicProductGroup[CharacteristicProductGroupType]? , CharacteristicOther[CharacteristicOtherType]* )

    Description: CharacteristicCombinationType defines a single characteristic combination for the time series.

    Elements:

    • CharacteristicCombinationPurposeCoded - is used to indicate the function of the characteristic combination in the transmission of this document. The application can use this code to process the characteristic combinations appropriately.
    • CharacteristicCombinationPurposeCodedOther - is used to provide a non-standard CharacteristicCombinationPurposeCode. This element is mandatory if the value of CharacteristicCombinationPurposeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • CharacteristicCombinationResponseCoded - indicates whether there is an error in the characteristic combination data. This code is sent in response to a TimeSeriesRequest.
    • CharacteristicCombinationResponseCodedOther - is used to provide a non-standard CharacteristicCombinationResponseCode. This element is mandatory if the value of CharacteristicCombinationResponseCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • CharacteristicCombinationID - is the key to uniquely identify a characteristic combination.
    • CharacteristicProduct - contains the basic elements used to describe a characteristic product with respect to the source and target systems.
    • CharacteristicLocation - contains the basic elements used to describe a characteristic location with respect to the source and target systems.
    • CharacteristicProductGroup - contains the basic elements used to describe a characteristic product group with respect to the source and target systems.
    • CharacteristicOther - is a generic configurable characteristic element that can be used to describe various characteristics of a time series. This element is given with respect to the source and target systems.

[^]Code Fragment

    <xsd:complexType name="CharacteristicCombinationType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="CharacteristicCombinationPurposeCoded" type="TimeSeriesPurposeCodeType">
        <xsd:element minOccurs="0" name="CharacteristicCombinationPurposeCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="CharacteristicCombinationResponseCoded" type="TimeSeriesErrorCodeType">
        <xsd:element minOccurs="0" name="CharacteristicCombinationResponseCodedOther" type="xsd:string">
        <xsd:element name="CharacteristicCombinationID" type="xsd:string">
        <xsd:element minOccurs="0" name="CharacteristicProduct" type="CharacteristicProductType">
        <xsd:element minOccurs="0" name="CharacteristicLocation" type="CharacteristicLocationType">
        <xsd:element minOccurs="0" name="CharacteristicProductGroup" type="CharacteristicProductGroupType">
        <xsd:element minOccurs="0" maxOccurs="unbounded" name="CharacteristicOther" type="CharacteristicOtherType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: CharacteristicLocationType

CharacteristicLocationType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( SourceLocation[BaseCharacteristicLocationType]? , TargetLocation[BaseCharacteristicLocationType]? )

    Description: CharacteristicLocationType contains the basic elements used to describe a characteristic location with respect to the source and target systems.

    Elements:

    • SourceLocation - is the location description with respect to the source system.
    • TargetLocation - is the location description with respect to the target system.

[^]Code Fragment

    <xsd:complexType name="CharacteristicLocationType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="SourceLocation" type="BaseCharacteristicLocationType">
        <xsd:element minOccurs="0" name="TargetLocation" type="BaseCharacteristicLocationType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: CharacteristicOtherType

CharacteristicOtherType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( SourceCharacteristicsOther[CharacteristicAttributeType]? , TargetCharacteristicsOther[CharacteristicAttributeType]? )

    Description: CharacteristicOtherType is a generic configurable characteristic element that can be used to describe various characteristics of a time series. This element is given with respect to the source and target systems.

    Elements:

    • SourceCharacteristicsOther - is other characteristics described with respect to the source system.
    • TargetCharacteristicsOther - is other characteristics described with respect to the target system.

[^]Code Fragment

    <xsd:complexType name="CharacteristicOtherType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="SourceCharacteristicsOther" type="CharacteristicAttributeType">
        <xsd:element minOccurs="0" name="TargetCharacteristicsOther" type="CharacteristicAttributeType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: CharacteristicProductGroupType

CharacteristicProductGroupType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( SourceProductGroup[BaseCharacteristicProductType]? , TargetProductGroup[BaseCharacteristicProductType]? )

    Description: CharacteristicProductGroupType contains the basic elements used to describe a characteristic product group with respect to the source and target systems.

    Elements:

    • SourceProductGroup - is the product group description with respect to the source system.
    • TargetProductGroup - is the product group description with respect to the target system.

[^]Code Fragment

    <xsd:complexType name="CharacteristicProductGroupType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="SourceProductGroup" type="BaseCharacteristicProductType">
        <xsd:element minOccurs="0" name="TargetProductGroup" type="BaseCharacteristicProductType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: CharacteristicProductType

CharacteristicProductType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( SourceProduct[BaseCharacteristicProductType]? , TargetProduct[BaseCharacteristicProductType]? )

    Description: CharacteristicProductType contains the basic elements used to describe a characteristic product with respect to the source and target systems.

    Elements:

    • SourceProduct - is the product description with respect to the source system.
    • TargetProduct - is the product description with respect to the target system.

[^]Code Fragment

    <xsd:complexType name="CharacteristicProductType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="SourceProduct" type="BaseCharacteristicProductType">
        <xsd:element minOccurs="0" name="TargetProduct" type="BaseCharacteristicProductType">
    </xsd:sequence>
</xsd:complexType>


Complex Types:

BaseCharacteristicLocationType
BaseCharacteristicProductType
CharacteristicAttributeType
CharacteristicCombinationType
ListOfCharacteristicCombinationType
CharacteristicLocationType
CharacteristicOtherType
CharacteristicProductGroupType
CharacteristicProductType
KeyFigureDataType
ListOfKeyFigureDataType
KeyFigureInformationType
KeyFigureType
SourceTargetIDType
TimeSeriesDataType
TimeSeriesDetailType
TimeSeriesHeaderType
TimeSeriesKeyFigureDataType
ListOfTimeSeriesKeyFigureDataType
TimeSeriesPartyType
TimeSeriesRequestDetailType
TimeSeriesRequestType
TimeSeriesResponseDetailType
TimeSeriesResponseHeaderType
TimeSeriesResponseType
TimeSeriesSummaryType
TimeSeriesType


Global Elements (Document Roots):

TimeSeriesResponse
TimeSeriesRequest
TimeSeries


complexType definition: KeyFigureDataType

KeyFigureDataType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( KeyFigurePurposeCoded[TimeSeriesPurposeCodeType]? , KeyFigurePurposeCodedOther[xsd:string]? , CharacteristicCombinationID[xsd:string]? , KeyFigureInformation[KeyFigureInformationType] , UnitOfMeasurement[core:UnitOfMeasurementType] , KeyFigureNotes[xsd:string]? )

    Description: KeyFigureDataType defines the key figure and includes all of the time series data values.

    Elements:

    • KeyFigurePurposeCoded - is the detail level response code to indicate whether there was an error in the key figure or time series data. This code is sent in response to a TimeSeriesRequest.
    • KeyFigurePurposeCodedOther - is used to provide a non-standard KeyFigurePurposeCode. This element is mandatory if the value of KeyFigurePurposeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • CharacteristicCombinationID - is the key to uniquely identify the characteristic combination. The CharacteristicCombinationID for the TimeSeriesRequest document is optional.
    • KeyFigureInformation - is used to identify the name, type, and value of a key figure used in a time series with respect to the source or target systems.
    • UnitOfMeasurement - specifies the unit of measure of rate.
    • KeyFigureNotes - is used to provide additional key figure information

[^]Code Fragment

    <xsd:complexType name="KeyFigureDataType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="KeyFigurePurposeCoded" type="TimeSeriesPurposeCodeType">
        <xsd:element minOccurs="0" name="KeyFigurePurposeCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="CharacteristicCombinationID" type="xsd:string">
        <xsd:element name="KeyFigureInformation" type="KeyFigureInformationType">
        <xsd:element name="UnitOfMeasurement" type="core:UnitOfMeasurementType">
        <xsd:element minOccurs="0" name="KeyFigureNotes" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: KeyFigureInformationType

KeyFigureInformationType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( SourceKeyFigure[KeyFigureType]? , TargetKeyFigure[KeyFigureType]? )

    Description: KeyFigureInformationType is used to identify the name, type, and value of a key figure used in a time series with respect to the source or target systems.

    Elements:

    • SourceKeyFigure - is the key figure data with respect to the source system.
    • TargetKeyFigure - is the key figure data with respect to the target system.

[^]Code Fragment

    <xsd:complexType name="KeyFigureInformationType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="SourceKeyFigure" type="KeyFigureType">
        <xsd:element minOccurs="0" name="TargetKeyFigure" type="KeyFigureType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: KeyFigureType

KeyFigureType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( KeyFigureID[xsd:string] , KeyFigureName[xsd:string]? , KeyFigureDescription[xsd:string]? )

    Description: KeyFigureType is the key figure data used to identify the name, type, and value of a key figure used in a time series.

    Elements:

    • KeyFigureID - is the key that uniquely identifies a key figure via its technical name with respect to the TimeSeriesSystemType given at the header. Eg: APO_FORECAST
    • KeyFigureName - contains the predefined name used for the key figure. Eg: sales forecast
    • KeyFigureDescription - contains the alternate name used to rename the given key figure. Eg: my sales forecast

[^]Code Fragment

    <xsd:complexType name="KeyFigureType">
    <xsd:sequence>
        <xsd:element name="KeyFigureID" type="xsd:string">
        <xsd:element minOccurs="0" name="KeyFigureName" type="xsd:string">
        <xsd:element minOccurs="0" name="KeyFigureDescription" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfCharacteristicCombinationsType

ListOfCharacteristicCombinationsType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Imported Namespaces:
    • rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( CharacteristicCombination[CharacteristicCombinationType]+ )

    Description: ListOfCharacteristicCombinationsType

    Elements:

    • CharacteristicCombination

[^]Code Fragment

    <xsd:complexType name="ListOfCharacteristicCombinationsType">
    <xsd:sequence>
        <xsd:element name="CharacteristicCombination" type="CharacteristicCombinationType" maxOccurs="unbounded">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfCharacteristicCombinationType

ListOfCharacteristicCombinationType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( CharacteristicCombination[CharacteristicCombinationType]+ )

    Description: ListOfCharacteristicCombinationType

    Elements:

    • CharacteristicCombination

[^]Code Fragment

    <xsd:complexType name="ListOfCharacteristicCombinationType">
    <xsd:sequence>
        <xsd:element name="CharacteristicCombination" type="CharacteristicCombinationType" maxOccurs="unbounded">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfKeyFigureDataType

ListOfKeyFigureDataType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( KeyFigureData[KeyFigureDataType]+ )

    Description: ListOfKeyFigureDataType contains a list of all the key figure and time series data related information.

    Elements:

    • KeyFigureData - defines the key figure and includes all of the time series data values.

[^]Code Fragment

    <xsd:complexType name="ListOfKeyFigureDataType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="KeyFigureData" type="KeyFigureDataType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: ListOfTimeSeriesKeyFigureDataType

ListOfTimeSeriesKeyFigureDataType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( TimeSeriesKeyFigureData[TimeSeriesKeyFigureDataType]+ )

    Description: ListOfTimeSeriesKeyFigureDataType contains a list of all the key figure and time series data related information.

    Elements:

    • TimeSeriesKeyFigureData - defines the key figure and includes all of the time series data values.

[^]Code Fragment

    <xsd:complexType name="ListOfTimeSeriesKeyFigureDataType">
    <xsd:sequence>
        <xsd:element maxOccurs="unbounded" name="TimeSeriesKeyFigureData" type="TimeSeriesKeyFigureDataType">
    </xsd:sequence>
</xsd:complexType>


Simple Types:

TimeSeriesActionCodeType
TimeSeriesErrorCodeType
TimeSeriesPurposeCodeType
TimeSeriesResponseCodeType


complexType definition: SourceTargetIDType

SourceTargetIDType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( SourceID[xsd:string]? , TargetID[xsd:string]? )

    Description: SourceTargetIDType provides containers to identify source and target values.

    Elements:

    • SourceID - contains information describing the data originating from the source system.
    • TargetID - contains information describing the data originating from the target system.

[^]Code Fragment

    <xsd:complexType name="SourceTargetIDType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="SourceID" type="xsd:string">
        <xsd:element minOccurs="0" name="TargetID" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: TimeSeriesActionCodeType

TimeSeriesActionCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Description:
    This code identifies the status of the TimeSeries message at line level.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Delete
    • Change
    • Error
    • Accepted
    • Rejected
    • Other

[^]Code Fragment

    <xsd:simpleType name="TimeSeriesActionCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Delete">
        <xsd:enumeration value="Change">
        <xsd:enumeration value="Error">
        <xsd:enumeration value="Accepted">
        <xsd:enumeration value="Rejected">
        <xsd:enumeration value="Other">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: TimeSeriesDataType

TimeSeriesDataType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( TimeSeriesBucket[core:ValidityDatesType] , TimeSeriesValue[xsd:float] , TimeSeriesDataNote[xsd:string]? )

    Description: TimeSeriesDataType contains the time series data which is composed of time buckets and a value. This element can occur a multiple of times.

    Elements:

    • TimeSeriesBucket - describes the date range of the time series value by specifying the start and end dates. The element is composed of a StartDate and an EndDate which are both of type datetime.
    • TimeSeriesValue - is the value of the time series data to be analyzed
    • TimeSeriesDataNote - is associated with the time series data.

[^]Code Fragment

    <xsd:complexType name="TimeSeriesDataType">
    <xsd:sequence>
        <xsd:element name="TimeSeriesBucket" type="core:ValidityDatesType">
        <xsd:element name="TimeSeriesValue" type="xsd:float">
        <xsd:element minOccurs="0" name="TimeSeriesDataNote" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: TimeSeriesDetailType

TimeSeriesDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( ListOfCharacteristicCombinations[ListOfCharacteristicCombinationType]? , ListOfTimeSeriesKeyFigureData[ListOfTimeSeriesKeyFigureDataType]? )

    Description: TimeSeriesDetailType contains detail information for the time series document. The TimeSeriesDetail defines the characteristic combination, key figure, unit of measure, and time series values of a given planning data. This element is broken down into two structures: ListOfTimeSeriesKeyFigures and ListOfCharacteristicCombinations. Both lists can occur independently of the other. If necessary, you can send only one of the data elements.

    Elements:

    • ListOfCharacteristicCombinations - contains a list of all the characteristic combinations for the time series. This element can be sent in a separate transmission from the time series document (without the key figure and time series value information) to serve as an initial setup/configuration process.
    • ListOfTimeSeriesKeyFigureData - contains a list of all the key figure and time series data related information.

[^]Code Fragment

    <xsd:complexType name="TimeSeriesDetailType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ListOfCharacteristicCombinations" type="ListOfCharacteristicCombinationType">
        <xsd:element minOccurs="0" name="ListOfTimeSeriesKeyFigureData" type="ListOfTimeSeriesKeyFigureDataType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: TimeSeriesErrorCodeType

TimeSeriesErrorCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Description:
    This code identifies any errors in the data of the response to the TimeSeriesRequest message.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • BasicError
    • Accepted
    • Rejected
    • Other

[^]Code Fragment

    <xsd:simpleType name="TimeSeriesErrorCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="BasicError">
        <xsd:enumeration value="Accepted">
        <xsd:enumeration value="Rejected">
        <xsd:enumeration value="Other">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: TimeSeriesHeaderType

TimeSeriesHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( TimeSeriesIssueDate[xsd:dateTime] , TimeSeriesID[xsd:string] , TimeSeriesPurposeCoded[TimeSeriesPurposeCodeType] , TimeSeriesPurposeCodedOther[xsd:string]? , TimeSeriesTimePeriod[core:ValidityDatesType]? , TimeSeriesSystemType[SourceTargetIDType]? , TimeSeriesPlanningData[SourceTargetIDType] , TimeSeriesSelection[SourceTargetIDType]? , TimeSeriesPlanningStep[SourceTargetIDType]? , TimeSeriesParty[TimeSeriesPartyType] , Language[core:LanguageType] , TimeSeriesHeaderNote[xsd:string]? )

    Description: TimeSeriesHeaderType contains all time series header relevant information. The header data will include information such as source target ID, issue date, time series ID, reference information, purpose code, etc.

    Elements:

    • TimeSeriesIssueDate - indicates the date and time that the time series document is transmitted.
    • TimeSeriesID - contains a reference number to uniquely identify the time series document. The reference data type also contains an optional reference date. (This is assumed to be with respect to the source system.)
    • TimeSeriesPurposeCoded - is used to indicate the function of the time series document. The application can use this code to process the document appropriately.
    • TimeSeriesPurposeCodedOther - is used to provide a non-standard TimeSeriesPurposeCode. This element is mandatory if the value of TimeSeriesPurposeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • TimeSeriesTimePeriod - indicates the overall time period for which the time series data represents. The TimeSeriesTimePeriod consists of a start and end date.
    • TimeSeriesSystemType - identifies the application system type from which the data is originating with respect to the source and target systems. This is used to interpret the technical names being sent in the document.
    • TimeSeriesPlanningData - identifies the time series planning data with respect to the source or target system. This contains the name or ID of the planning data for a given planning system.
    • TimeSeriesSelection - identifies the technical name of the time series selection with respect to the source or target system. This is used to describe the primary keys of the database table at a technical level. On a higher level, this contains the name or ID given to describe the set of dimensions or parameters of the given planning data structure.
    • TimeSeriesPlanningStep - identifies the work flow planning step associated with the instance of the time series with respect to the source and target systems.
    • TimeSeriesParty - contains information describing all parties associated with the time series document. Data such as the identifier, name, address, and contact information is provided.
    • Language - denotes the language the TimeSeries is written in.
    • TimeSeriesHeaderNote - contains information or instructions pertinent to the analysis of the time series data.

[^]Code Fragment

    <xsd:complexType name="TimeSeriesHeaderType">
    <xsd:sequence>
        <xsd:element name="TimeSeriesIssueDate" type="xsd:dateTime">
        <xsd:element name="TimeSeriesID" type="xsd:string">
        <xsd:element name="TimeSeriesPurposeCoded" type="TimeSeriesPurposeCodeType">
        <xsd:element minOccurs="0" name="TimeSeriesPurposeCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="TimeSeriesTimePeriod" type="core:ValidityDatesType">
        <xsd:element minOccurs="0" name="TimeSeriesSystemType" type="SourceTargetIDType">
        <xsd:element name="TimeSeriesPlanningData" type="SourceTargetIDType">
        <xsd:element minOccurs="0" name="TimeSeriesSelection" type="SourceTargetIDType">
        <xsd:element minOccurs="0" name="TimeSeriesPlanningStep" type="SourceTargetIDType">
        <xsd:element name="TimeSeriesParty" type="TimeSeriesPartyType">
        <xsd:element name="Language" type="core:LanguageType">
        <xsd:element minOccurs="0" name="TimeSeriesHeaderNote" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: TimeSeriesKeyFigureDataType

TimeSeriesKeyFigureDataType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( TimeSeriesKeyFigurePurposeCoded[TimeSeriesPurposeCodeType]? , TimeSeriesKeyFigurePurposeCodedOther[xsd:string]? , TimeSeriesKeyFigureResponseCoded[TimeSeriesErrorCodeType]? , TimeSeriesKeyFigureResponseCodedOther[xsd:string]? , CharacteristicCombinationID[xsd:string] , KeyFigureInformation[KeyFigureInformationType] , UnitOfMeasurement[core:UnitOfMeasurementType] , TimeSeriesData[TimeSeriesDataType]+ )

    Description: TimeSeriesKeyFigureDataType defines the key figure and includes all of the time series data values.

    Elements:

    • TimeSeriesKeyFigurePurposeCoded - is used to indicate the function of the key figure and time series data in the transmission of this document. The application can use this code to process the key figure and time series data appropriately.
    • TimeSeriesKeyFigurePurposeCodedOther - is used to provide a non-standard TimeSeriesKeyFigurePurposeCode. This element is mandatory if the value of TimeSeriesKeyFigurePurposeCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • TimeSeriesKeyFigureResponseCoded - indicates whether there was an error in the key figure. This code is sent in response to a TimeSeriesRequest.
    • TimeSeriesKeyFigureResponseCodedOther - is used to provide a non-standard TimeSeriesKeyFigureResponseCode. This element is mandatory if the value of TimeSeriesKeyFigureResponseCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • CharacteristicCombinationID - is the key to uniquely identify the characteristic combination.
    • KeyFigureInformation - is used to identify the name, type, and value of a key figure used in a time series with respect to the source or target systems.
    • UnitOfMeasurement - specifies the unit of measure of rate.
    • TimeSeriesData - contains the time series data which is composed of time buckets and a value. This element can occur a multiple of times.

[^]Code Fragment

    <xsd:complexType name="TimeSeriesKeyFigureDataType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="TimeSeriesKeyFigurePurposeCoded" type="TimeSeriesPurposeCodeType">
        <xsd:element minOccurs="0" name="TimeSeriesKeyFigurePurposeCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="TimeSeriesKeyFigureResponseCoded" type="TimeSeriesErrorCodeType">
        <xsd:element minOccurs="0" name="TimeSeriesKeyFigureResponseCodedOther" type="xsd:string">
        <xsd:element name="CharacteristicCombinationID" type="xsd:string">
        <xsd:element name="KeyFigureInformation" type="KeyFigureInformationType">
        <xsd:element name="UnitOfMeasurement" type="core:UnitOfMeasurementType">
        <xsd:element maxOccurs="unbounded" name="TimeSeriesData" type="TimeSeriesDataType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: TimeSeriesPartyType

TimeSeriesPartyType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( SourceParty[core:PartyType]? , ReceiverParty[core:PartyType]? , ListOfPartyCoded[core:ListOfPartyCodedType]? )

    Description: TimeSeriesPartyType contains information describing all parties associated with the time series document. Data such as the identifier, name, address, and contact information is provided.

    Elements:

    • SourceParty - contains information relevant to describing the party of the source system.
    • ReceiverParty - contains information relevant to describing the party of the target system.
    • ListOfPartyCoded - contains information relevant to describing parties other than the source target parties which are relevant to the time series data.

[^]Code Fragment

    <xsd:complexType name="TimeSeriesPartyType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="SourceParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ReceiverParty" type="core:PartyType">
        <xsd:element minOccurs="0" name="ListOfPartyCoded" type="core:ListOfPartyCodedType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: TimeSeriesPurposeCodeType

TimeSeriesPurposeCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Description:
    This code identifies the purpose of the TimeSeries message.This is a subset code list derived from EDIFACT 1225 (Message Function, Coded) and X12 353 (Transaction Set Purpose Code) and 587 (Acknowledgement Type Code)

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Original
    • Delete
    • Change
    • Response
    • Other

[^]Code Fragment

    <xsd:simpleType name="TimeSeriesPurposeCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Original">
        <xsd:enumeration value="Delete">
        <xsd:enumeration value="Change">
        <xsd:enumeration value="Response">
        <xsd:enumeration value="Other">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: TimeSeriesRequestDetailType

TimeSeriesRequestDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( ListOfCharacteristicCombinations[ListOfCharacteristicCombinationType]? , ListOfKeyFigureData[ListOfKeyFigureDataType]? )

    Description: TimeSeriesRequestDetailType is similar to TimeSeriesDetail with a few minor changes. The ListOfCharacteristicCombinations is the same but the ListOfTimeSeriesKeyFigures contains only information for the key figure and no time series data.

    Elements:

    • ListOfCharacteristicCombinations - contains a list of all the characteristic combinations for the time series.
    • ListOfKeyFigureData - contains a list of all the key figure and time series data related information.

[^]Code Fragment

    <xsd:complexType name="TimeSeriesRequestDetailType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="ListOfCharacteristicCombinations" type="ListOfCharacteristicCombinationType">
        <xsd:element minOccurs="0" name="ListOfKeyFigureData" type="ListOfKeyFigureDataType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: TimeSeriesRequestType

TimeSeriesRequestType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( TimeSeriesRequestHeader[TimeSeriesHeaderType] , TimeSeriesRequestDetail[TimeSeriesRequestDetailType] , TimeSeriesRequestSummary[TimeSeriesSummaryType] )

    Description: TimeSeriesRequestType contains the TimeSeriesRequestHeader, Detail and Summary information relating to the request of a time series document. TimeSeries is a forecasting document that can be used to process data based on variable characteristics. Data is collected over a period of time, and time slices can be presented as a historical account or a planned forecast.

    Elements:

    • TimeSeriesRequestHeader - includes information such as sender receiver ID, issue date, time series ID, reference information, purpose code, etc. The TimeSeriesRequestHeader is identical to the TimeSeriesHeader.
    • TimeSeriesRequestDetail - is similar to TimeSeriesDetail with a few minor changes. The ListOfCharacteristicCombinations is the same but the ListOfTimeSeriesKeyFigures contains only information for the key figure and no time series data.
    • TimeSeriesRequestSummary - contains all information relevant to the summary of the time series document.

[^]Code Fragment

    <xsd:complexType name="TimeSeriesRequestType">
    <xsd:sequence>
        <xsd:element name="TimeSeriesRequestHeader" type="TimeSeriesHeaderType">
        <xsd:element name="TimeSeriesRequestDetail" type="TimeSeriesRequestDetailType">
        <xsd:element name="TimeSeriesRequestSummary" type="TimeSeriesSummaryType">
    </xsd:sequence>
</xsd:complexType>


simpleType definition: TimeSeriesResponseCodeType

TimeSeriesResponseCodeType (simpleType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Description:
    This code identifies the acknowledgement of the TimeSeriesRequest document.

    Content: Restriction of base type xsd:NMTOKEN

    Enumerated List:

    • Accept
    • Reject
    • BasicError
    • PlanningDataError
    • SeriesSelectionError
    • KeyFigureError
    • TimePeriodError
    • Other

[^]Code Fragment

    <xsd:simpleType name="TimeSeriesResponseCodeType">
    <xsd:restriction base="xsd:NMTOKEN">
        <xsd:enumeration value="Accept">
        <xsd:enumeration value="Reject">
        <xsd:enumeration value="BasicError">
        <xsd:enumeration value="PlanningDataError">
        <xsd:enumeration value="SeriesSelectionError">
        <xsd:enumeration value="KeyFigureError">
        <xsd:enumeration value="TimePeriodError">
        <xsd:enumeration value="Other">
    </xsd:restriction>
</xsd:simpleType>


complexType definition: TimeSeriesResponseDetailType

TimeSeriesResponseDetailType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( TimeSeriesDetailResponseCoded[TimeSeriesActionCodeType] , TimeSeriesDetailResponseCodedOther[xsd:string] , ListOfChangedCharacteristicCombinations[ListOfCharacteristicCombinationType]? , ListOfChangedTimeSeriesKeyFigureData[ListOfTimeSeriesKeyFigureDataType]? )

    Description: TimeSeriesResponseDetailType contains the detail level information relating to the time series response.

    Elements:

    • TimeSeriesDetailResponseCoded - is the overall line level response code for the entire time series detail section. This is a subset of the ActionCode list.
    • TimeSeriesDetailResponseCodedOther - is used to provide a non-standard TimeSeriesDetailResponseCode. This element is mandatory if the value of TimeSeriesDetailResponseCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • ListOfChangedCharacteristicCombinations - contains a list of all the characteristic combinations for the time series that need to be changed. The ListOfChangedCharacteristicCombinations is identical to the ListOfCharacteristicCombinations with the exception that the response code is required.
    • ListOfChangedTimeSeriesKeyFigureData - contains a list of all the key figure and time series data related information that will need to be changed. The ListOfChangeTimeSeriesKeyFigureData is identical to the ListOfTimeSeriesKeyFigureData with the exception that the response code is required.

[^]Code Fragment

    <xsd:complexType name="TimeSeriesResponseDetailType">
    <xsd:sequence>
        <xsd:element name="TimeSeriesDetailResponseCoded" type="TimeSeriesActionCodeType">
        <xsd:element name="TimeSeriesDetailResponseCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="ListOfChangedCharacteristicCombinations" type="ListOfCharacteristicCombinationType">
        <xsd:element minOccurs="0" name="ListOfChangedTimeSeriesKeyFigureData" type="ListOfTimeSeriesKeyFigureDataType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: TimeSeriesResponseHeaderType

TimeSeriesResponseHeaderType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( TimeSeriesResponseIssueDate[xsd:dateTime] , TimeSeriesResponseID[xsd:string] , TimeSeriesReference[core:ReferenceType] , TimeSeriesPlanningData[SourceTargetIDType]? , TimeSeriesResponseParty[TimeSeriesPartyType] , TimeSeriesHeaderResponseCoded[TimeSeriesResponseCodeType] , TimeSeriesHeaderResponseCodedOther[xsd:string]? , ChangedTimeSeriesHeader[TimeSeriesHeaderType]? , Language[core:LanguageType] , TimeSeriesResponseNote[xsd:string]? )

    Description: TimeSeriesResponseHeaderType contains all time series response header relevant information. The header data includes information such as sender receiver ID, issue date, time series ID and reference information, response code, etc.

    Elements:

    • TimeSeriesResponseIssueDate - indicates the date and time that the TimeSeriesResponse document is transmitted.
    • TimeSeriesResponseID - contains a reference number to uniquely identify the TimeSeriesResponse document. The reference data type also contains an optional reference date.
    • TimeSeriesReference - is the original time series document for which this response document refers to. The reference also includes an optional date field which can be used to indicate original create date.
    • TimeSeriesPlanningData - identifies the time series planning data with respect to the relevant source or target system. This contains the name or ID of the planning instance for a given planning system. For SAP users, this would be the planning book ID.
    • TimeSeriesResponseParty - contains information describing all parties associated with the time series response document. Data such as the name, address, and contact information is provided.
    • TimeSeriesHeaderResponseCoded - indicates the type of acknowledgement with respect to the time series document.
    • TimeSeriesHeaderResponseCodedOther - is used to provide a non-standard TimeSeriesHeaderResponseCode. This element is mandatory if the value of TimeSeriesHeaderResponseCoded is 'Other'. These codes should not contain white space unless absolutely necessary.
    • ChangedTimeSeriesHeader - is the entire TimeSeriesHeader document as provided here. The purpose of this is to allow the user to make the appropriate changes to the time series header. You have the option of sending corrections to the time series header or just simply sending the response code.
    • Language - denotes the language the attachment is written in.
    • TimeSeriesResponseNote - contains information or instructions pertinent to the analysis of the time series response data.

[^]Code Fragment

    <xsd:complexType name="TimeSeriesResponseHeaderType">
    <xsd:sequence>
        <xsd:element name="TimeSeriesResponseIssueDate" type="xsd:dateTime">
        <xsd:element name="TimeSeriesResponseID" type="xsd:string">
        <xsd:element name="TimeSeriesReference" type="core:ReferenceType">
        <xsd:element minOccurs="0" name="TimeSeriesPlanningData" type="SourceTargetIDType">
        <xsd:element name="TimeSeriesResponseParty" type="TimeSeriesPartyType">
        <xsd:element name="TimeSeriesHeaderResponseCoded" type="TimeSeriesResponseCodeType">
        <xsd:element minOccurs="0" name="TimeSeriesHeaderResponseCodedOther" type="xsd:string">
        <xsd:element minOccurs="0" name="ChangedTimeSeriesHeader" type="TimeSeriesHeaderType">
        <xsd:element name="Language" type="core:LanguageType">
        <xsd:element minOccurs="0" name="TimeSeriesResponseNote" type="xsd:string">
    </xsd:sequence>
</xsd:complexType>


complexType definition: TimeSeriesResponseType

TimeSeriesResponseType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( TimeSeriesResponseHeader[TimeSeriesResponseHeaderType] , TimeSeriesResponseDetail[TimeSeriesResponseDetailType] , TimeSeriesResponseSummary[TimeSeriesSummaryType] )

    Description: TimeSeriesResponseType contains all time series response header, detail and summary information relating to the response to a time series document. TimeSeries is a forecasting document that can be used to process data based on variable characteristics. Data is collected over a period of time, and time slices can be presented as a historical account or a planned forecast.

    Elements:

    • TimeSeriesResponseHeader - contains all time series response header relevant information. The header data includes information such as sender receiver ID, issue date, time series ID and reference information, response code, etc.
    • TimeSeriesResponseDetail - contains the detail level information relating to the time series response.
    • TimeSeriesResponseSummary - contains all information relevant to the summary of the time series document.

[^]Code Fragment

    <xsd:complexType name="TimeSeriesResponseType">
    <xsd:sequence>
        <xsd:element name="TimeSeriesResponseHeader" type="TimeSeriesResponseHeaderType">
        <xsd:element name="TimeSeriesResponseDetail" type="TimeSeriesResponseDetailType">
        <xsd:element name="TimeSeriesResponseSummary" type="TimeSeriesSummaryType">
    </xsd:sequence>
</xsd:complexType>


complexType definition: TimeSeriesSummaryType

TimeSeriesSummaryType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( TotalTimeSeriesData[xsd:int]? , TotalCharacteristicCombinations[xsd:int]? , TotalKeyFigures[xsd:int]? )

    Description: TimeSeriesSummaryType contains all information relevant to the summary of the time series document.

    Elements:

    • TotalTimeSeriesData - is the total number of time series items given in the document.
    • TotalCharacteristicCombinations - is the total number of characteristic combinations given in the document.
    • TotalKeyFigures - is the total number of key figures.

[^]Code Fragment

    <xsd:complexType name="TimeSeriesSummaryType">
    <xsd:sequence>
        <xsd:element minOccurs="0" name="TotalTimeSeriesData" type="xsd:int">
        <xsd:element minOccurs="0" name="TotalCharacteristicCombinations" type="xsd:int">
        <xsd:element minOccurs="0" name="TotalKeyFigures" type="xsd:int">
    </xsd:sequence>
</xsd:complexType>


complexType definition: TimeSeriesType

TimeSeriesType (complexType)

    Schema

    Namespaces:
    • Default - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • targetNamespace - rrn:org.xcbl:schemas/xcbl/v4_0/statisticsandforecasting/v1_0/statisticsandforecasting.xsd
    • Others -
      • [xml] - http://www.w3.org/XML/1998/namespace
      • [xsd] - http://www.w3.org/2001/XMLSchema
      • [core] - rrn:org.xcbl:schemas/xcbl/v4_0/core/core.xsd

    Content: ( TimeSeriesHeader[TimeSeriesHeaderType] , TimeSeriesDetail[TimeSeriesDetailType] , TimeSeriesSummary[TimeSeriesSummaryType] )

    Description: TimeSeriesType is a forecasting document that can be used to process data based on variable characteristics. Data is collected over a period of time, and time slices can be presented as a historical account or a planned forecast.

    Elements:

    • TimeSeriesHeader - contains all time series header relevant information. The header data will include information such as source target ID, issue date, time series ID, reference information, purpose code, etc.
    • TimeSeriesDetail - contains detail information for the time series document. The TimeSeriesDetail defines the characteristic combination, key figure, unit of measure, and time series values of a given planning data. This element is broken down into two structures: ListOfTimeSeriesKeyFigures and ListOfCharacteristicCombinations. Both lists can occur independently of the other. If necessary, you can send only one of the data elements.
    • TimeSeriesSummary - contains all information relevant to the summary of the time series document.

[^]Code Fragment

    <xsd:complexType name="TimeSeriesType">
    <xsd:sequence>
        <xsd:element name="TimeSeriesHeader" type="TimeSeriesHeaderType">
        <xsd:element name="TimeSeriesDetail" type="TimeSeriesDetailType">
        <xsd:element name="TimeSeriesSummary" type="TimeSeriesSummaryType">
    </xsd:sequence>
</xsd:complexType>